卸载或重新安装 Macromedia Studio 8 产品时发生 MSI 错误
日本語 | 繁體中文 | 한국어 | Deutsch | English | Español | Français | Italiano
问题
尝试卸载或安装 Macromedia Studio 8 产品时, 可能会收到以下错误信息:
“不能访问 Windows Installer 服务。可能是你在安全模式下运行 Windows, 或者 Windows Installer 没有正确地安装。请和你的支持人员联系以获得帮助。”

原因
如果以下两个条件均成立, 则会发生此错误:
- 硬盘上的 Windows Installer 文件损坏或丢失。
- 所安装或删除的程序需要使用 Windows Installer Microsoft 软件安装 (MSI)。
参考文章 (133823)
解决方法
安装过程
如果您在尝试安装任何 Studio 8 产品时遇到此错误, 请尝试以下一种或两种方法:
- 重新启动计算机, 然后再次执行安装过程。
- 运行引导文件 (XX_Client_Installer.exe);其中 XX 是产品名称缩写。例如, Dreamweaver 8 的引导文件为“DW_Client_Installer.exe”。
卸载过程
如果在尝试卸载任何 Studio 8 产品时遇到此错误, 请尝试以下操作:
- 在安装 CD 上找到 WindowsInstaller-KB884106-v2-x86.exe。
- 双击以运行 WindowsInstaller-KB884106-v2-x86.exe。
- 卸载该产品。
更多信息
- 如果计算机上安装的 MSI 早于版本 3: 引导文件 XX_Client_Installer.exe 将运行 WindowsInstaller-KB884016-v2-x86.exe 来升级 MSI。
- 有关 Windows Installer 技术的更多信息, 请访问 Windows Installer 概述 MSDN 网站。
| 上次更新时间: | 2005 年 9 月 14 日 |
|---|