
 

A Quick Tour of Adobe GoLive

 

This interactive tour introduces you to 

key features of Adobe GoLive. During the 

tour, you’ll create a Web site that includes 

a home page and two linked pages. The 

pages incorporate formatted text, GIF 

images, rollovers, JavaScript, and even 

animation.
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For detailed instructions on how to use the features introduced in this tour, see the

 

 

Adobe GoLive 4.0 User Guide

 

. For further lessons on using Adobe GoLive, continue this 

tour and see the rest of this book.

 

Important: 

 

Before starting Adobe GoLive, make sure that you have installed a copy of the 

QuickTime 3 plug-in into Adobe GoLive’s Plugins (Windows) or Plug-ins (Mac OS) folder. 

Without this plug-in, you cannot preview QuickTime movies in Adobe GoLive.

 

The tour takes about an hour to complete. If needed, copy the Tour folder onto your hard 

drive, so that you can save files in the folder.

 

Getting started

 

You’ll begin this tour by using your Web browser to view a copy of the finished Web site.

 

1

 

Start a Web browser, such as Netscape® Communicator

 

TM

 

 or Microsoft Internet 

Explorer

 

TM

 

 4.0.

 

Note: 

 

Some features of the Web pages you’ll view require browsers that support JavaScript 

and Dynamic Hypertext Markup Language (DHTML). If you don’t have an appropriate 

Web browser, you can use Adobe GoLive to preview some elements of the site. For more infor-

mation, see “Previewing Web pages with Adobe GoLive” on page 23.

 

2

 

Open index.html, the home page of the site:

 

•

 

In Windows, the path is Tour/TEnd/Matchbox Folder/Matchbox/index.html.

 

Important: 

 

In Windows, your preferences may be set to hide file extensions for known file 

types. In this case, the files cat.gif, cat.jpg, and cat.html would all display as cat when using 

the Explorer. In addition, you may have preferences set to hide certain files, such as plug-ins 

and modules, which are used by Adobe GoLive. See the documentation that came with your 

system for information on how to display file extensions and show all files. Otherwise, 

filenames referred to in some steps may be difficult to follow.

 

•

 

In Mac OS, the path is Tour/TEnd/Matchbox

 

 f 

 

/Matchbox/index.html.

 

3

 

Click the links in the index.html Web page, and explore the site.

 

4

 

When you have finished viewing the Web site, quit the browser.
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Creating a new site

 

Now you’ll begin creating your own Web site.

 

1

 

Start Adobe GoLive.

One or more palettes and a context-sensitive toolbar appear, and (depending on how 

your preferences are set) an empty document named Untitled.html opens in the 

document window. The document window can display the document in different views, 

from raw HTML code to browser-specific previews. Currently, the document is in Layout 

view. This is the view you will use to edit your pages.

 

2

 

If you are using Windows, dock the toolbar to the menu bar in the application window. 

Because Adobe GoLive provides a blank home page as part of the site you’ll create, you 

don’t need this empty, untitled page for the tour.

 

3

 

If it’s currently open, close the page Untitled.html. You are now ready to create a new, 

empty Web site. 

 

4

 

Choose File > New Site > Blank.

 

5

 

Locate and select the Tour folder you copied to your desktop. (In Windows, click the 

Browse button and use the pop-up dialog box to do this.)
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Type 

 

Matchbox 

 

in the New Site text box. This will be the name of the folder that 

contains the site. Then select Create Folder. This creates a grouping folder (in this case, 

called Matchbox Folder in Windows and Matchbox 

 

f

 

 in Mac OS) that contains the 

Matchbox site folder plus a special data folder and site document used by Adobe GoLive 

to manage the site.

 

Note:

 

 If you are using a system earlier than Mac OS 8.5, press the tab key three times so that 

the New Site Name text box is highlighted and retype the name. You can also click Cancel to 

close the dialog box, choose Edit > Preferences > General > Display, deselect Use Navigation 

Services, click OK, and redo steps 4 through 6.
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Click OK (Windows) or Save or Choose (Mac OS) to create the new Web site.
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Adobe GoLive displays a site window, with a home page file, called index.html, already in 

place. The site window lets you manage Web pages and resources in your Web site. The 

Files tab of the site window shows the file structure of the site.

 

8

 

Use the Windows Explorer (Windows) or Finder (Mac OS) to open the newly 

created grouping folder inside the Tour folder, Matchbox Folder (Windows) or 

Matchbox ƒ (Mac OS), and examine its contents.
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Matchbox Folder (Windows) or Matchbox ƒ (Mac OS) contains the following folders 

and files:

 

•

 

The Matchbox folder stores the Web pages and media that make up your Web site. To 

upload the site, you upload this folder. Its contents appear in the Files tab of the site 

window. When you create a new site it already contains a blank home page, whose 

filename is index.html. 

By convention, the home page of a Web site is named index.html. This is the page 

displayed when a visitor views the site but does not enter the filename of a specific page 

in the site. For example, if you upload the Matchbox folder to the Web location 

www.FirstStrikeMatches.com, a visitor who uses a browser to go to http://www.First-

StrikeMatches.com/Matchbox would see the file index.html contained in Matchbox.

 

•

 

The Matchbox.data folder stores stationery and other items Adobe GoLive uses to help 

you build and maintain your site, but that don’t need to be uploaded as part of the site.

 

•

 

The Matchbox.site (Windows) or Matchbox.

 

π

 

 (Mac OS) document is used by 

Adobe GoLive to record the structure of your Web site so that you can manage the 

contents of the site in the Files tab of the site window. Opening the 

Matchbox.site/Matchbox.

 

π

 

 document by double-clicking it or using the Open command 

displays the site window in Adobe GoLive. The document is not uploaded as part of the 

Web site. 
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Dragging and dropping to add files to a Web site

 

You are now ready to add some structure and elements to your Web site by dragging and 

dropping files. First, you’ll add a folder of images and other media files. This will be the 

source of the images and media you’ll add to your Web pages.

 

1

 

Using Windows Explorer (Windows) or the Finder (Mac OS), select the 

Tour/TStart/Media folder, and drag it from the desktop into the Files tab of the 

site window.

 

 

 

Although you can work from your system’s desktop, the site window lets you manage the 

files from within Adobe GoLive.

 

2

 

Open the Media folder in the site window to display the folder’s contents:

 

•

 

In Windows, double-click the Media folder in the site window.
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•

 

In Mac OS, click the arrow next to the Media folder icon in the site window.

Next, you’ll add a new folder to the site. This folder will hold the Web pages you’ll create.

 

3

 

Create a new folder:

 

•

 

In Windows, click to select Matchbox in the left pane of the site window. Then choose 

Site > New > Group to create the folder.

 

•

 

In Mac OS, choose Site > New > Group to create the folder.

 

4

 

Select the new untitled folder in the site window and rename it 

 

Pages

 

.

 

Most Web servers are case-sensitive and restrict the characters you can use in filenames 

and folder names. Don’t use a forward slash (/), empty space, or ampersand (

 

&

 

). Don’t use 

a period (.) except as part of an extension (for example, index.html), and don’t use the 

hyphen (-) as the first character in a filename or folder name. Your Web server may have 

additional requirements.

 

Your Web site now consists of a file named index.html (the home page of your Web site) 

as well as two folders: the Media folder you dragged over containing several image files 

and the Pages folder you created which is currently empty.

 

Designing a Web page

 

You’ll begin designing your first Web page by opening the home page index.html, listed 

in the site window.

 

1

 

Open the Web page index.html:

 

•

 

In Windows, select the folder Matchbox in the site window. Then double-click 

index.html.

 

•

 

In Mac OS, double-click index.html in the site window.
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For easy access to the various windows and palettes in Adobe GoLive, you can set up the 

document window above the site window, and place the palettes to the side. In Mac OS, you 

can minimize a palette to an icon by control-clicking the title bar of the palette or dragging it 

to the right edge of the desktop. To reopen a minimized palette in Mac OS, click the icon. In 

Windows, you can dock a palette by dragging or double-clicking its title bar and undock it by 

double-clicking the double lines at the top of the palette. In addition, you can place the 

document window over the site window and click the Toggle Between Windows button ( ) 

in the toolbar to switch between the windows.

 

First, you’ll change the title of the Web page. This is the text that appears in the title bar 

of a Web browser when your page is viewed.

 

2

 

Select the text “Welcome to Adobe GoLive 4” located next to the Page icon ( ) at the 

top of the document window. Replace this text with the new title 

 

First Strike Matches

 

.

 

Laying out pages and adding text

 

One of the objects you’ll use often is the 

 

layout grid

 

. By putting a layout grid on a Web 

page, you can place objects on the page with one-pixel accuracy. You don’t have to use a 

layout grid that runs the entire length of the page. In fact, using layout grids is optional 

on a page-by-page basis, but it is often much more convenient to do so.

The grid automatically lengthens to accommodate the objects you place on it. You can 

also resize the grid by selecting it and dragging a handle or specifying a precise size. The 

layout grid is one of the many objects available in the palette that you can use to add 

elements to Web pages.

 

1

 

If necessary, Choose View > Palette (Windows) or Window > Palette (Mac OS) to 

display the Palette. Make sure the Basic tab ( ) is selected in the Palette.
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Drag the Layout Grid icon from the Palette to your Web page. 

 

To display the name of any item in the toolbar or in the Palette, hold the mouse pointer 

over the item. The name of a button in the toolbar or a tab in the Palette appears next to the 

pointer. The name of an icon within the Palette appears at the bottom of the Palette.

 

You can type directly onto a Web page you are creating in Adobe GoLive without using a 

layout grid. However, in this tour you’ll place a container called a layout text box onto the 

layout grid. You can then enter text into the layout text box, resize the box, and move it 

around the grid to easily format the look and placement of the text on your page.

 

3

 

Drag the Layout Text Box icon from the Palette to the left side of the layout grid on the 

Web page.

 

4

 

To reposition the layout text box (or any object), deselect it and move the mouse 

pointer to any of its edges. When the pointer turns into a hand, drag the layout text box 

to where you want it.

 

Note: 

 

You can also select an object and move it one pixel at a time by holding down Ctrl+Alt 

(Windows) or Option (Mac OS) and pressing an arrow key.

 

5

 

Click inside the layout text box and type 

 

Welcome to First Strike Matches

 

.

 

6

 

Press Enter to create a second paragraph and type: 

 

For answers to your burning 

questions about our matches, use the links below.

 

 

As in a word processor, you can edit and format the text.

 

7

 

Select the text “Welcome to First Strike Matches” in the layout text box.
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8

 

In the toolbar, click the Align Center ( ) and Bold ( ) buttons and choose 6 from 

the Font Size menu ( ).

 

9

 

To resize the layout text box (or any object), move the pointer to one of its handles. 

When the pointer turns into a hollow (not black) arrow, drag the handle until the box is 

the size you want.

 

When designing Web pages, you’ll usually want to make them no wider than your visitor’s 

screen. You can choose 580 from the menu at the bottom right of the document window to 

display the current page at 580 pixels wide, the standard default width for 14-inch monitors. 

This helps prevent you from adding objects that are too wide to display on a standard page, 

such as large graphic banners.

 

Note:

 

 In Windows, Adobe GoLive creates new pages 520 pixels wide by default. Change the 

width of these pages to 580 pixels.

 

It is good practice to save your project regularly as you work. 

 

10

 

Choose File > Save.
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Adding color

 

Now you’ll add color to the text you entered and to the background of the page.

 

1

 

Drag to select the text “Welcome to First Strike Matches” you entered in the Web page.

 

2

 

If necessary, choose View > Color Palette (Windows) or Window > Color Palette 

(Mac OS) to display the Color Palette.

The Color Palette has several tabs representing different color spaces. The tab most often 

used is for the Web-safe (also called “browser-safe”) colors. It’s a good idea to use Web-

safe colors, because they keep your colors from dithering (shifting) when viewed on 

platforms that can’t display those colors. 

 

3

 

Click the Web-safe tab ( ) in the Color Palette.

 

4

 

Select a color using the grid of sample swatches, the list, or by entering a value in the 

Value text box. (We chose the color labeled #FF6633.)

 

A.

 

 Preview pane

 

B.

 

 Color space tabs

 

C.

 

 Swatches

 

5

 

Drag the color from the preview pane at the top of the Color Palette to the selected text 

in the Web page. Then click away from the text on the Web page to see the result.

Now you’ll change the background color of your page.

 

6

 

Select a color on the Color Palette for the background. (We chose the color labeled 

#66CCCC.)

B

A

C



 

17

 

ADOBE GOLIVE 4.0

 

Classroom in a Book

 

7

 

Drag the color from the preview pane at the top of the Color Palette to the Page icon 

( ) near the top left corner of the document window.

 

8

 

Choose File > Save.

 

Adding images

 

To make your Web page more visually appealing, you can use images in your design. In 

this part of the tour, you’ll add three images to the page. You’ll add each image by putting 

an image placeholder on the page and then linking the placeholder to an image file.

The standard image formats for the Web are Graphical Interchange Format (GIF) and 

Joint Photographic Experts Group (JPEG). GIF images are typically used for line art and 

JPEGs are typically used for photographs and other images with more than 256 colors. In 

this tour, you’ll use GIF images.

You’ll begin by putting an image placeholder on the page.
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1

 

Drag the Image icon from the Palette and place it on the layout grid to the right of the 

layout text box on your Web page. (If there isn’t enough room, select the layout grid and 

drag one of its handles to enlarge it.)

Adobe GoLive provides a context-sensitive palette called the Inspector. This palette lets 

you quickly customize objects without using commands in the menu bar. You’ll use it now 

to work with the image placeholder.

 

2

 

If necessary, choose View > Inspector (Windows) or Window > Inspector (Mac OS) to 

display the Inspector.

Because an image placeholder is selected, the Inspector appears as the Image Inspector. 

The Source text box in the Image Inspector states “Empty Reference!” because the image 

placeholder in your Web page does not refer to an image yet.

Now you’ll “point and shoot” to connect the placeholder on the Web page with an image 

file in the site window.
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3

 

Drag from the Point and Shoot button ( ) in the Image Inspector to the file 

Matchbox.gif in the Media folder in the site window. 

You can tell you’ve made the connection when the line from the Point and Shoot button 

connects with and highlights the filename in the site window.

The GIF image now appears on the Web page, and the Source text box in the Image 

Inspector shows the relative path of the image.

 

4

 

To lengthen the layout grid to place more images, click the grid so that the Inspector 

changes to the Layout Grid Inspector. Enter 

 

360

 

 for Height and click the Enter button ( ) 

on the Layout Grid Inspector or press Enter on your keyboard.
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Drag two more Image icons from the Palette and place them next to each other near 

the bottom of the layout grid on the page. You can move other objects on the page if they 

are in the way.

 

6

 

Select the empty image placeholder on the left and use the Image Inspector to link it to 

the file Features.gif in the site window.

 

You can also hold down Ctrl+Alt (Windows) or Command (Mac OS) and drag from the 

image placeholder on a Web page to a file in the site window. This has the same effect as using 

the Point and Shoot button in the Inspector.

 

7

 

Select the remaining image placeholder and link it to the file Questions.gif.

Now you’ll align the two images.

 

8

 

Shift-click to select both of the images. 

The Inspector changes to the Multiselection Inspector.
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Click the Align Top button in the Multiselection Inspector to align the tops of both 

images. (This button is dimmed if the images are already aligned.)

 

10

 

Click the Special tab in the Multiselection Inspector. In the Horizontal section, select 

Offset, enter a distance in pixels (we chose 60), and click the Equidistant Edges button.

 

11

 

Click the Align Center button ( ) in the toolbar to center the buttons.

 

12

 

Choose File > Save.
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Adding keywords
Adobe GoLive lets you add keywords to a Web page. This nondisplaying text is used by 

search engines to identify the topics on your page. You’ll add keywords to your home 

page next.

1 Click the triangle next to the Page icon ( ) in the document window to display the 

head section pane.

2 Click the Head tab ( ) in the Palette (the third tab from the left).

3 Drag the Keywords icon from the Palette to the head section pane of the document 

window.

The Inspector changes to the Keywords Inspector.

4 Enter a word or phrase you want to use as a keyword in the text box at the bottom of 

the Keywords Inspector. (We used the phrase “First Strike Matches.”)

5 Click Add, click the Enter button ( ) in the Keywords Inspector, or press Enter on the 

keyboard.

6 Enter more words and phrases if you want.

7 When you are done, click the triangle next to the Page icon to close the head 

section pane.

8 Choose File > Save.
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Previewing Web pages with Adobe GoLive
You have just completed your first Web page design with Adobe GoLive. You can preview 

your page within Adobe GoLive or by using your browser. Here, you’ll use Adobe GoLive 

to preview the page.

Not all objects on a Web page can be previewed in Adobe GoLive. For example, 

Adobe GoLive cannot show certain JavaScript actions, anchors, and animations. For this 

reason, it is always a good idea to preview pages using a Web browser as well.

1 In the document window, click the Layout Preview tab ( ) (the tab labeled Preview).

The Inspector changes to the Document Layout Controller. You can use this palette to 

define which browser and which platform you want to emulate in the preview. Defining 

a different platform is especially useful, because fonts on Web pages usually display larger 

in Windows than in Mac OS.

2 Choose a browser option from the Root menu in the Document Layout Controller—

for example, “Explorer 4 (Windows)” to preview how your page would look in Internet 

Explorer 4 on a Windows platform. Switch between the different Root menu options and 

notice how your page changes in Preview view.

3 When you’re through previewing the page, click the Layout Preview tab ( ) in the 

document window to return to Layout view.

Now you’ll set up a Web browser for viewing pages.

4 Choose Edit > Preferences. Then select Browsers from the list in the left pane of the 

Preferences dialog box to display preferences for browsers.
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5 Click Find All to search for Web browsers on your system.

6 Select the browsers you want from the list in the right pane of the dialog box and 

click OK.

7 Choose a browser by clicking the small triangle that indicates the Browser menu ( ) 

in the toolbar. The browser displays the current page, index.html.

8 Close the page index.html in Adobe GoLive.

Creating a second Web page
You’re now ready to create a second Web page for the site. When you are finished, this page 

will contain formatted text, an example of JavaScript, and a QuickTime movie.

1 Choose File > New to create a new, empty Web page.

2 Select the text “Welcome to Adobe GoLive 4” located next to the Page icon ( ) at the 

top of the document window. Replace this with the new title Burning Questions.

Now you’ll change the background color of the page.

3 Select a color on the Color Palette for the background. (We chose the color labeled 

#66CCCC.)

4 Drag the color from the preview pane in the Color Palette to the Page icon.

5 Choose File > Save to save the page. Name the document Questions.html and save the 

page inside the Pages folder you created for your site (Tour/Matchbox Folder/ 

Matchbox/Pages in Windows or Tour/Matchbox ƒ /Matchbox/Pages in Mac OS).
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Copying design elements from one page to another
To help you design this page, you’ll copy the elements from another page as a model.

1 Choose File > Open.

2 Locate and open the file Sample.html located in the Tour/TStart/Pages folder.

3 Choose Edit > Select All. Then choose Edit > Copy to copy all of its contents.

4 Close the page Sample.html.

5 Select the page Questions.html and choose Edit > Paste to paste the contents into 

that page.

The images in Questions.html are still linked back to image files in the 

Tour/TStart/Pages/SampleMedia folder. Now, you’ll link them to images in your 

Matchbox/Media folder.

6 Select the Masthead image in Questions.html.
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7 Hold down Ctrl+Alt (Windows) or Command (Mac OS) and drag from the Masthead 

image placeholder to Burning.gif in the site window. (Remember, this is a shortcut for 

using the Point and Shoot button in the Image Inspector.) The temporary artwork is 

replaced with the specific artwork for your Matchbox site.

8 Select the Logo image in the Web page.

The Inspector changes to the Button Inspector.

9 Click the Main icon in the Button Inspector and drag from the Point and Shoot button 

( ) to Box.gif in the site window.

10 Scroll down if necessary to display the images at the bottom of Questions.html.

11 Link the Button 1 image to Features.gif in the site window.

12 Link the Button 2 image to Questions.gif in the site window.

13 Link the Button 3 image to Main.gif in the site window.

You now have linked the images for your page.

14 Choose File > Save.

15 Select the site window.

16 Click the Update button ( ) in the toolbar to establish the new links and update 

your site with this page.
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Adding a table and importing text
Instead of using a layout text box, you’ll use a table to format text on this page. This will 

give you more control over the spacing between paragraphs. And rather than type in all 

the text, you’ll import it.

1 Click the Basic tab of the Palette.

2 Drag the Table icon from the Palette below the text “Burning questions for” on 

the page.

The Inspector changes to the Table Inspector.

3 With the table still selected, enter 450 for Width in the Table Inspector to make the 

table wider.

4 Click Browse in the Table Inspector to locate the text file you want to import.

5 Select the file Table.txt located in the Tour/TStart folder.

6 For Col. (Column) Separator, choose Tab. Then click Open to import the file into 

the table.
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Notice that the text is separated into multiple rows in the leftmost column. You’ll delete 

the extra columns now and format the table.

7 In the Table tab of the Table Inspector, enter 1 for Columns. 

8 Enter 0 for Border to remove the table border so you display just the text.

9 Enter 5 for Cell Pad to add 5 pixels of extra space around text in the table cells.

10 Select the text “What is a match?” in the first row of the table. Then choose 5 from the 

Font Size menu ( ) in the toolbar so that the text looks like a heading.

11 Select the text “What is Fire?” and “Why won’t my First Strike match light?” in turn 

and change their font size to 5 as well.

12 Choose File > Save.
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Adding JavaScript
Now you’ll add a simple JavaScript to the page. Adobe GoLive includes a full JavaScript 

editor. For this tour, you’ll add a JavaScript file that shows the date and time.

1 Click to insert the cursor after “Burning questions for.”

2 Drag the JavaScript icon from the Palette into the layout text box. The JavaScript place-

holder now appears at the end of the phrase.

The Inspector changes to the Body Script Inspector.

3 Click the button next to the Source text box to display the Point and Shoot button ( ).

4 Drag from the Point and Shoot button to the JavaScript file Date.scpt in the Media 

folder in the site window.

Adding a QuickTime movie
You can place any multimedia element that Netscape Navigator or Microsoft Internet 

Explorer supports into a Web page you are creating with Adobe GoLive. Here, you’ll add 

a QuickTime movie to the page.

1 If necessary, scroll to display the area below the table and above the match images on 

the Web page. Then drag the Plug-in icon from the Palette to this area.

The Inspector changes to the Plug-in Inspector. Now you’ll connect the Plug-in place-

holder on the Web page to a QuickTime file in the site window.

Note: The QuickTime 3 plug-in must be installed in Adobe GoLive’s Plugins (Windows) or 

Plug-ins (Mac OS) folder for the QuickTime preview to work.
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2 With the placeholder selected on the Web page, drag from the Point and Shoot button 

in the Plug-in Inspector to the QuickTime file Strike.mov in the Media folder in the 

site window.

The title Strike now appears in the placeholder on the Web page and the Inspector 

changes to the Folder Inspector.

3 Reselect the Plug-in placeholder to change the Inspector to the Plug-in Inspector.

4 Click the QuickTime tab of the Plug-in Inspector.

5 Select Show Controller to display a movie control bar when visitors play the movie.

6 Deselect Autoplay so the movie doesn’t start until a visitor chooses to play it.

7 With the Plug-in placeholder still selected, click the Align Center button ( ) in the 

toolbar to center align the movie to the layout grid. (This button is dimmed if the movie 

is already aligned to the center.)

8 Choose File > Save.

9 Do one of the following:

• Choose a browser from the Browser menu ( ) in the toolbar. The browser displays 

Questions.html and you can view the JavaScript date and time and play the movie.

• Click the Preview tab in the document window to play the movie (although you cannot 

view the JavaScript date and time).

10 In Adobe GoLive, close the page Questions.html.

Adding a predesigned Web page and animating it
In this section of the tour, you’ll add an existing Web page to your site and make the page’s 

content more dynamic by adding rollovers and animation. 

1 Move the predesigned page:

• In Windows, use Windows Explorer to drag the Web page Features.html from the 

Tour/TStart/Pages folder into the Tour/Matchbox Folder/Matchbox/Pages folder. (Do 

not drag it to the site window.)
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• In Mac OS, use the Finder to drag the Web page Features.html from the 

Tour/TStart/Pages folder into the Tour/Matchbox f /Matchbox/Pages folder. (Do not drag 

it to the site window.)

When you dragged the page Sample.html into the site window earlier in the tour, 

Adobe GoLive updated the links so that they still referred to the original images in the 

Tour/TStart/Pages/SampleMedia folder. That is why you needed to relink the images to 

files in the Tour/Matchbox Folder/Media folder (Windows) or Tour/Matchbox f /Media 

folder (Mac OS). 

This time, by moving the page Features.html from one folder to another without 

dragging it into the site window, the links are not updated. Instead, the page is looking for 

images in a Media folder one level above its current location. Because Tour/Matchbox 

Folder/Matchbox/Media (Windows) or Tour/Matchbox f /Matchbox/Media (Mac OS) 

contains the appropriate images, once you update the site, the correct images will appear 

in the page Features.html without any relinking.

2 Open the Pages folder in the site window.

3 Click the Update button ( ) in the toolbar to update the site window with the new 

page. The new page Features.html now appears in the site window.

4 Double-click Features.html in the site window to open the page.
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Creating rollovers in Adobe GoLive
Here you will make a rollover on the page. Rollovers are objects that change their look as 

you move the mouse pointer over or click them.

To save time, a button image placeholder has already been added to the page from the 

Palette and a GIF image of a closed matchbox has been linked to the placeholder.

1 Click to select the image of the matchbox.

Notice that the Inspector changes to the Button Inspector. Notice, too, that the Main icon 

is selected in the Button Inspector. This indicates the button image placeholder is linked 

to the file Box.gif, the image you want to display when the mouse pointer is away from 

the button.

Now you’ll select the image that will appear when a visitor’s pointer is over the button on 

the Web page.

2 Click the Over icon in the Button Inspector. Then click the button next to the text box 

to activate the Point and Shoot button ( ).
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3 Drag from the Point and Shoot button to Boxopen.gif in Media folder in the 

site window.

Because you are in Layout view, the button on the Web page still shows the Main image 

for the rollover. However, the appropriate image is shown in the Over icon in the Button 

Inspector.

4 Choose File > Save.

5 Choose a browser from the Browser menu ( ) in the toolbar. The browser displays 

Features.html and you can move the mouse pointer over the button to preview your 

rollover.

6 When you are through, select the Features.html document window in Adobe GoLive.

Animating a page
HTML 4.0 adds Dynamic Hypertext Markup Language (DHTML) to the options you can 

use in creating a Web page. With DHTML, you can add movable, stackable layers called 

floating boxes that can move across a Web page, animating your site. These floating boxes 

can contain text, images, and even JavaScript. In this part of the tour, you’ll animate the 

page with a graphic in a floating box. 

Note: Only HTML 4.0-compatible browsers such as Microsoft Internet Explorer 4.0 and 

Netscape Communicator can display DHTML animations.

To save you time, the floating box placeholder has already been added to the page from 

the Palette, an image placeholder has been put inside it, and a GIF image of a match has 

been connected to the image placeholder.

You can now give motion to the floating box so it moves from item to item in the list when 

a visitor views the page.
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1 Click an edge of the floating box to select it. Make sure the floating box is selected and 

not just the image within it. The floating box is selected when the pointer changes to a 

hand pointed to the left. (If the hand is pointed up, the image is selected and not the 

floating box.)

The Inspector changes to the Floating Box Inspector.

2 Click the Record button ( ) in the Floating Box Inspector to begin recording.

3 Move the pointer over the floating box so that the hand points to the left, then drag the 

floating box around the Web page. (We moved the box so the match pointed from feature 

to feature in the list.) Then release the mouse button to stop the recording.
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4 Choose File > Save.

5 Click the Preview tab ( ) in the document window to view the finished motion. 

6 Click the Layout tab ( ) in the document window to return to Layout view when you 

are done.

7 Close the page.

Creating links
You now have three pages with varying amounts of content. But as yet, there’s no way 

visitors to your site can get from one page to the other. The next thing to do is to add links 

that connect the pages.

First, you will link the text in the index.html page so that visitors can click there to go to 

the other two pages.

1 Double-click index.html in the site window to open that page for editing.

2 In index.html, select the text “burning questions.”

The Inspector changes to the Text Inspector.

3 Click the New Link button ( ) in the toolbar.

4 Drag from the Point and Shoot button ( ) in the Text Inspector to the Web page 

Questions.html in the Pages folder in the site window. Then click away from the text to 

deselect it.

The text in index.html is now blue and underlined to indicate it is a link. You have just 

created your first link in Adobe GoLive.

5 Choose File > Save.

6 Click the Preview tab ( ) in the document window to view the page. 

7 Click the “burning questions” text to try out the new link.

In Windows, Questions.html replaces index.html in the document window. In Mac OS, 

Questions.html opens in a new document window on top of index.html.

8 Do one of the following:

• In Windows, where Questions.html replaced index.html in the document window, click 

the Layout tab ( ) in the document window to return to index.html in Layout view.

• In Mac OS, where Questions.html opened as a separate page, close it so that only 

index.html is open. 
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Linking from images
In addition to linking from text, you can also link from a graphic. Here you will 

link the buttons you created in the index.html page to the Features.html and 

Questions.html pages.

1 Click the Layout tab ( ) in the document window, if necessary, to return the 

index.html to Layout view.

2 Select the Features image on index.html.

The Inspector changes to the Image Inspector.

3 Click the Link tab in the Image Inspector.

4 Click the New Link button ( ) on the Image Inspector. This is the same as clicking 

the New Link button in the toolbar.

5 Drag from the Point and Shoot button ( ) in the Image Inspector to the Web page 

Features.html in the site window.

The image has a bright blue border around it indicating that it’s a link. You’ll remove this 

border because it’s already clear the button is a link. In addition, the Inspector changes to 

the Folder Inspector.

6 Reselect the image to change the Inspector to the Image Inspector.

7 Click the Spec. (Special) tab in the Image Inspector. Then select Border to give the 

image a border of 0 width.

8 Select the Questions image on the Web page. Then create a link for it and remove its 

blue border using the same steps you used for the Features image, but this time link 

Questions to the Web page Questions.html in the site window.

9 Choose File > Save.

10 Click the Preview tab ( ) in the document window to view the page. 

11 Click the Features link to open the page Features.html.

12 Do one of the following:

• In Windows, click the Layout tab ( ) in the document window to return to index.html 

in Layout view. Then click the Questions link to open the page Questions.html.

• In Mac OS, click the Questions link to open the page Questions.html.

13 Close all open pages.
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Creating e-mail links
Now you’ll add a link to the Questions.html page that brings up an e-mail window with 

an e-mail address in it.

1 Double-click Questions.html in the site window to open the page.

2 Click the External tab ( ) in the site window. 

The External tab lets you store nonfile objects, such as URLs and e-mail addresses. Here, 

you’ll use the External tab to store an e-mail address.

3 Click the Site tab ( ) (the fifth tab from the left) in the Palette. This tab contains 

elements for sites, such as pages, URLs, and e-mail addresses.

4 Drag the Address icon from the Palette to the site window.

5 Double-click the Address icon in the site window to change the Inspector to the 

Reference Inspector.

6 In the Name text box of the Reference Inspector, enter a name for the address. For 

example, change “untitled address” to “Anne’s Address.” Although it’s not required, 

entering names helps you manage addresses in a site.

7 In the URL text box, enter an e-mail address after “mailto:”. For example, change 

“mailto:untitled@1/” to “mailto:AnneSmith@mycompany.com”. Make sure that you 

leave “mailto:” in the text box and that there are no spaces between it and the e-mail 

address.

8 Select the text “E-mail us” at the bottom of the list of questions in the 

Questions.html page.

9 Click the New Link button ( ) in the toolbar.

The link is highlighted and underlined. Now you can attach the text as a link to the e-mail 

address you just created.
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10 Drag from the Point and Shoot button ( ) in the Text Inspector to the Address icon 

in the site window.

11 Choose File > Save.

12 Choose a Web browser from the Browser menu ( ) in the toolbar. Then use the 

Questions.html page displayed in the browser to click the e-mail link and display an e-

mail editor.

13 Close the page Questions.html in Adobe GoLive.

To save you time in the tour, the remaining links have already been provided.

Managing sites
Now you’ll change the name of a file and update the links to it, so you can learn how to 

manage a site in Adobe GoLive.

1 Click the Files tab of the site window.

2 Select the filename Questions.html in the site window and change it to Answers.html.

Because changing the name of a file would normally break the links from any pages that 

were connected to it under its old name, Adobe GoLive displays a dialog box that lets you 

update all the links affected by the name change.

3 Click OK.

The Link Inspector lets you review all incoming and outgoing links and embedded items, 

such as images, assigned to a Web page.

4 Select the Web page Answers.html in the site window.
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5 Click the Link Inspector button ( ) in the toolbar to display all of the links and 

embedded images assigned to that page.

6 Close the Link Inspector.

Adobe GoLive also provides a visual snapshot of your Web site, so you can view how your 

three pages are related.

7 Click the Site tab in your site window.
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Your Web pages appear with a graphical representation of the link hierarchy of your site—

beginning with your home page, index.html. Notice that the Site tab does not show 

a folder hierarchy as in the Files Tab or in Windows Explorer (Windows) or the 

Finder (Mac OS). There you would see that Answers.html and Features.html are in the 

Pages folder. 

Previewing and testing files
You have now finished creating a site in Adobe GoLive. Go ahead and preview it using 

your Web browser.

1 Do one of the following:

• Click the Files tab in the site window. Double-click the page index.html in the site 

window. Then choose a Web browser from the Browser menu ( ) in the toolbar.

• If necessary, start a Web browser. (If you do not have enough memory to run the 

browser and Adobe GoLive, quit Adobe GoLive.) Then use the Open or equivalent 

command in the browser to locate and open the file Tour/Matchbox 

Folder/Matchbox/index.html in Windows or Tour/Matchbox f /Matchbox/index.html in 

Mac OS.

• Click the links in the Web page and explore the site you just created.
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