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Director-TechNote

Fehlermeldung fordert nach Shockwave-Installation zum Neustart des Computers auf

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Problem

Benutzer, die den Shockwave Player installieren möchten, erhalten am Ende der Installation die folgende Fehlermeldung:

Der Computer muss neu gestartet werden, um die Installation von
Shockwave Player abzuschließen. Möchten Sie den Computer jetzt neu starten?

Für die Installation des Shockwave Players ist kein Neustart des Computers erforderlich. Der Benutzer gerät in eine Endlosschleife; ein Neustart hilft nicht. Die Fehlermeldung wird jedes Mal angezeigt, wenn der Browser den Shockwave Player aufruft. Der Shockwave Player kann nicht verwendet werden, es werden keine Inhalte angezeigt.

Ursache

Dieses Problem tritt auf, wenn alte oder doppelte DLLs auf dem System des Benutzers installiert sind. Die folgenden DLLs können im Ordner "system32" gefunden werden:

  • dirapi.dll
  • iml32.dll

Die Dateien dirapi.dll und iml32.dll sollten nur im Shockwave-Ordner vorhanden sein (Beispiel: C:\Windows\system32\macromed\Shockwave [Versionsnummer]). Director-Entwickler finden diese Dateien auch in den Anwendungsordnern der Director-Anwendung (Beispiel: C:\Programme\Macromedia\Director [Versionsnummer oder -name]).

Diese Dateien könnten sich auch in temporären Ordnern befinden, zum Beispiel: C:\Dokumente und Einstellungen\Benutzername\Lokale Einstellungen\Temp\TempFolder.aaa

Hinweis: Dieses Problem tritt nur unter Microsoft Windows 2000 und Microsoft Windows XP auf.

Lösung

Entfernen Sie alle Dateien mit dem Namen dirapi.dll oder iml32.dll, die sich nicht im macromed-Ordner oder in den Director-Anwendungsordnern befinden. Die folgenden Pfade sind Beispiele für korrekte Speicherorte dieser Dateien:

  • C:\WINDOWS\system32\Macromed\Shockwave 10
  • C:\WINDOWS\system32\Macromed\Shockwave 8
  • C:\Programme\Macromedia\Director [Versionsnummer oder -name]

Überzählige DLLs suchen und entfernen

  1. Suchen Sie auf der Festplatte nach Dirapi.dll und iml32.dll (Director-Laufzeitdateien). Notieren Sie sich die Speicherorte der Dateien außerhalb dieser Speicherorte:
    • C:\WINDOWS\system32\Macromed\Shockwave 10
    • C:\WINDOWS\system32\Macromed\Shockwave 8
    • C:\Programme\Macromedia\Director [Versionsnummer oder -name]
  2. Notieren Sie sich die Speicherorte und verschieben Sie die Dateien in den Papierkorb. Falls erforderlich, lassen sich die Dateien wiederherstellen.
  3. Testen Sie den Shockwave Player

Shockwave Player neu installieren

In einigen Fällen kann es erforderlich sein, den Shockwave Player zu deinstallieren und erneut zu installieren. Falls der normale Download nicht möglich ist, führen Sie die folgenden Schritte aus:

  1. Deinstallieren Sie den Shockwave Player. Verwenden Sie dazu je nach Version das Deinstallationsprogramm oder "Software" in der Systemsteuerung.
    • Das Deinstallationsprogramm für Shockwave 8.5 finden Sie auf der Seite Macromedia Web Players.
    • Das Deinstallationsprogramm für Shockwave 10 finden Sie unter C:\WINDOWS\system32\Macromed\Shockwave 10 als UNWISE.exe. Alternativ dazu können Sie auch die Funktion "Software" in der Systemsteuerung verwenden.
  2. Löschen Sie alle Ordner im Macromed-Ordner mit Ausnahme der AUTHORWA-Ordner oder Flash-Ordner.
  3. Installieren Sie den Shockwave Player mithilfe des Standalone-Installers erneut. Links zum Standalone-Installer finden Sie unter Standalone-Installer für Shockwave Player* (TechNote 15895) oder über den Standard-Download des Shockwave Players.
  4. Testen Sie den Shockwave Player

Letzte Aktualisierung: 3. Mai 2004
Erstellt: 3. Mai 2004

ID: 19303
Produkt: Director
Versionen: MX, MX 2004
OS: Windows XP, Windows 2000
Browser: Alle
Server: Keine
Datenbank: Keine
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