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 Tutorial

 

Adobe Encore DVD

 

Make animated DVD menus with After 

 

Effects and Photoshop

 

Pair Adobe® Encore™ DVD with Adobe After Effects® 
6 to leverage the features of both applications. You can 
import AVI files that you create in After Effects into 
Adobe Encore DVD, and return to After Effects to edit 
them at any time. 

In this lesson, you’ll use an After Effects movie as a 
background for a menu in Adobe Encore DVD, and pair 
it with an Adobe Photoshop menu to provide subpic-
tures. 

 

Importing a Photoshop menu 

 

First, import the Photoshop menu into your project. 

 

1

 

Choose File > New Project. Click OK to accept NTSC 
as the television standard. 
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Choose File > Import as Menu. Navigate to the 
layered Photoshop file that you want to use as your 
menu (in this example, we're using a file called 
Zephyr.psd). The menu appears in Adobe Encore DVD. 

 

3

 

Click on the menu in the Menu Editor window, and 
then open the Layers palette. The menu includes a layer 
set for the title text; a background layer; and two 
additional layer sets, which Adobe Encore DVD recog-
nizes as buttons. 

http://www.adobe.com/products/encore/
http://www.adobe.com/products/aftereffects/
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Click the Show Selected Subpicture Highlight button 
at the bottom of the Menu Editor window to see the 
subpictures for the buttons. The subpictures were 
dened in Photoshop. Adobe Encore DVD recognizes the 
layers as subpictures because their names begin with 
(=1). 
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Make the Character palette active by clicking the 
Character tab. Then choose OCR A Std for the font, 
Medium for the font style, and 36 for the type size. Click 
the Align Center option. 

 

6

 

With the text tool, click an insertion point in the 
Menu Editor window, and type 2004. Press Enter, and 
type Season. 

 

7

 

With the selection tool, move the text block you just 
created to the bottom-left area of the menu. 
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With the text block still selected, choose Object > 
Drop Shadow. Accept the defaults in the Drop Shadow 
dialog box, and click OK. 
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Save the project as Lesson_09.ncor. 

 

Modifying a Photoshop file in After 
Effects 

 

Now you’ll import the same Photoshop file into After 
Effects, and save it with a 10-second duration. 

 

1

 

Open After Effects. 

 

2

 

After Effects opens with a new, untitled project. 

 

3

 

Choose File > Save As, and save the project as 
Lesson_09.aep. 

 

4

 

Choose Composition > New Composition. The 
Composition Settings dialog box opens. 
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Set the duration to 00:00:04:00 (4 seconds). Leave the 
other settings as they are, and click OK. 

Comp 1 appears in the Project window. You won’t use 
this composition, but when you import the Photoshop 
file into After Effects, the duration of the new compo-
sition and each of its layers will be eight seconds. 

 

6

 

Select Comp 1 in the Project window and choose 
Edit > Clear. The Project window is now empty. 
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Choose File > Import > File. 

 

8

 

Select your Photoshop file (again, ours is 
Zephyr.psd), and choose Composition from the Import 
As pop-up menu. Then click Open. 

The Project window contains a folder and a comp, both 
named Zephyr Comp 1. The folder contains the 
individual layers. The composition is made up of the 
assembled layers. 
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Note: If there’s only one file in the Project window, you 
didn’t import the layered Photoshop file as a composition 
(step 7). Delete the file and re-import it as a composition. 
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In the Project window, double-click the composition 
icon (not the folder) for Zephyr Comp 1. The Timeline 
and Composition window open. Each Photoshop layer 
or layer set is on a separate line in the timeline. 
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Choose Composition > Composition Settings. 

 

11

 

Make sure the Preset is NTSC 720 x 480, and the 
duration is 00:00:04:00 (4 seconds). Then click OK. 
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Save the After Effects project. 

 

Animating a menu file in After 
Effects 

 

You imported a static Photoshop menu file. Now you’ll 
animate the file so that the buttons and title move 
during the four seconds that the menu plays. 

 

1

 

In the Timeline window, move the current-time 
indicator to 01:00 (1 second). 

 

2

 

Select the first three layers in the timeline. (Hold 
down the Ctrl key to select multiple layers.) 

 

3

 

Press the P key on your keyboard to display the 
Position property for each of the selected layers. 

 

4

 

Click the stopwatches next to each of the Position 
properties to create a keyframe for the position of each 
layer. 

 

5

 

Return the current-time indicator to 00:00. 
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Select the Title layer, and change its position to 930, 
240. 

You can change the position manually by selecting and 
dragging the title in the Comp window. Or you can click 
the numbers in the timeline and type new values.
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Move both the Kiteboard layer set and the Sailboard 
layer set to 710,240.
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Choose Composition > Preview > RAM Preview. 
The title and buttons enter the screen from the right 
and then stop in their final positions. 
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Save the project.  

 

Adding more animation 

 

You have animated the layers so that they are off the 
screen at 0 seconds and enter from the right. Now you 
will add keyframes to move them off the screen again. 

 

1

 

In the Timeline window, move the current-time 
indicator to 03:00 (3 seconds). 

 

2

 

Press the Ctrl key as you click the word Position 
underneath the layer name for the top three layers. 
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Choose Animation > Add Keyframe. A new 
keyframe is added to each layer; it has the same value as 
the keyframes in the 01:00 frame. You want the layers to 
stay in the same position from 01:00 to 03:00. 

 

4

 

Click an empty area on the timeline to deselect the 
keyframes at 03:00. Then press the Shift key as you 
select the three position keyframes at the 01:00 frame. 
Choose Animation > Toggle Hold Keyframe. You’ve 
ensured that the three layers won’t change position until 
the next keyframe. 
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Click an empty area on the timeline to deselect the 
keyframes. Then move the current-time indicator to the 
last frame of the composition (03:29). 
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Move the Title layer’s position to the left (-40, 240). 
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Move both the Kiteboard layer set’s and the Sailboard 
layer set’s position to -280, 240. 
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Choose Composition > Preview > RAM Preview.  
The layers move onto the screen from the right, pause 
for two seconds, and then continue to move to the left 
until they’re off screen. 
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Save the project. 

 

Adjusting keyframes to add interest 

 

To make the animation more interesting, change the 
keyframes so that the title and buttons move at different 
times. Times are suggested in these instructions, but the 
exact times of the keyframes isn’t critical. You can 
experiment with different times, using the RAM 
Preview command to view the results. 

 

1

 

For the Title layer, drag the second keyframe 
(currently at 1 second) to 8 frames (00:08). 

 

2

 

For the Kiteboard layer set, move the rst keyframe 
(currently at 0 seconds) to 9 frames (00:09), and the 
second keyframe (currently at 1 second) to 18 frames 
(00:18). 

 

3

 

For the Sailboard layer set, move the rst keyframe 
(currently at 0 seconds) to 19 frames (00:19), and leave 
the second keyframe at 1 second (01:00). 

 

4

 

Move the last two keyframes for each layer to create 
more interesting exits and entries. 

 

Note: Make sure you don’t change the order of the 
keyframes in a layer. 
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Choose Composition > Preview > RAM Preview. 
The title and buttons move into the screen from the 
right at intervals, and exit the screen according to the 
keyframes you’ve created. 

 

6

 

Save the project.
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Rendering a movie in After Effects 

 

You’re ready to create the movie in After Effects. 

 

1

 

Choose Composition > Make Movie. If prompted, 
name the movie file (we named ours 
Zephyr_background.avi) and specify a folder for it. The 
Render Queue dialog box opens. Your project appears 
in the queue. 

 

2

 

Click the value next to Render Settings for your 
project. 

 

3

 

Choose Best from the Quality pop-up menu and Full 
from the Resolution pop-up menu. Then click OK. 
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Click the value next to Output Module in the Render 
Queue dialog box. 

 

5

 

In the Output Module Settings dialog box, choose 
Project Link from the Embed popup menu. Embedding 
a project link ensures that you can return to the After 
Effects file to edit it from Adobe Encore DVD, even 
though you’ll place a rendered movie file—not the After 
Effects file itself—into your Adobe Encore DVD 
project. 

 

6

 

Click Format Options in the Video Output section of 
the Output Module Settings dialog box. 
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Choose No Compression from the Compressor pop-
up menu, and click OK. Click OK to close the Output 
Module Settings dialog box. 
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Click the name next to Output To in the Render 
Queue dialog box. If you haven’t already named the file, 
do so and specify a folder for it. 
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Click Render. If you’re prompted to save the After 
Effects project, click OK. After Effects renders the 
movie. Depending on your system, this may take a few 
minutes. 

 

10

 

Leave the Render Queue open, and don’t change the 
settings. 
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Save the After Effects project and close it. 

 

Note: It’s important to close the project. 

 

Importing an After Effects movie 
into Adobe Encore DVD 

 

You’ll import the movie into Adobe Encore DVD as an 
asset. Though you’ll use the movie in the menu, it’s only 
a component of the menu. The Photoshop file you 
imported will provide the framework for the menu, so 
the subpictures will be intact. 

 

1

 

In Adobe Encore DVD, click the Project window to 
make it active, and then choose File > Import as Asset. 

 

2

 

Select the AVI file you just rendered in After Effects 
(Zephyr_background.avi), and click Open. 

 

3

 

In the Project window, double-click the Zephyr 
menu to open the Menu Editor window, and then click 
the Layers tab or choose Window > Layers to open the 
Layers palette. 

 

4

 

In the Layers palette, select the Title layer set and 
choose Edit > Clear. The title disappears from the menu 
in the Menu Editor window. 
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Click the arrow next to the Kiteboard layer set to 
expand it. Then delete the text layer in it (named 
“Kiteboard”). The “kiteboard” text disappears from the 
Menu Editor window, but the Kiteboard layer set and 
the subpicture layer remain in the Layers palette. 
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Delete the text layer from the Sailboard layer set in 
the same way. The layer sets themselves, and the subpic-
tures within them, should remain in the Layers palette. 

 

7

 

Click the Show Selected Subpicture Highlight button 
at the bottom of the Menu Editor window to see the 
subpictures. 

 

8

 

Press the Alt key while you drag the 
Zephyr_background.avi file from the Project window 
into the Menu Editor window.  
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There’s no apparent change in the Menu Editor 
window, because the text is off-screen at 0 seconds. 
However, the background has been replaced by the 
video asset you created in After Effects. The beginning 
frame of the movie should match the menu background 
perfectly. 

 

Note: If a button appears, delete it and the new timeline it 
created in the Project window, and then be sure to press 
the Alt key while you drag the file into the Menu Editor 
window. 
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Select the Zephyr menu in the Project window, and 
open the Properties palette. The 
Zephyr_background.avi file should be listed in the 
Video eld in the Properties palette. If it isn’t, press the 
Alt key as you drag the Zephyr_background.avi file into 
the Menu Editor window again. 
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Choose File > Render Motion Menus. To display a 
menu in motion, Adobe Encore DVD must first render 
it. If you don’t render the motion menu, Adobe Encore 
DVD will display it as a still menu. 

 

11

 

Choose File > Preview. The video plays once, and 
then a black screen appears. 

 

12

 

Close the Project Preview window, and save the 
Adobe Encore DVD project.

 

Activating a motion menu 

 

You animated the menu in After Effects. Now you’ll 
specify how the motion menu should behave in Adobe 
Encore DVD. 

 

1

 

Select the Zephyr menu in the Project window. 

 

2

 

In the Properties palette, leave the Duration at 4 
seconds (04:00), and choose Forever  from the Loop # 
pop-up menu. The video will play until it reaches the 
end, and then loop until you make a selection. 

 

3

 

Choose File > Render Motion Menus. If File > 
Render Motion Menus is dimmed, go to step 4. 

 

4

 

Choose File > Preview. 

 

5

 

Close the Project Preview window, and save the 
project.

Excerpted from “Adobe Encore DVD Classroom in a 
Book,” Copyright ©2004 by Adobe Systems Inc., 
published by Peachpit Press. Used with the permission 
of Pearson Education and Peachpit Press. To buy this 
book, visit www.peachpit.com.
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