
In this overview of using text in GoLive CS2, you’ll learn how to do 
the following:

•	 Import and enter text into your document.

•	 Change the color of text.

•	 Format and stylize text.

•	 Create numbered and unnumbered lists.

•	 Style text using CSS.

•	 Create an Internal Style Sheet.

•	 Convert an Internal Style Sheet to an External Style Sheet.

•	 Use spell checking.

•	 Configure language and font preferences.

Getting started
In this lesson, you will be working on a single HTML file which has 
already been created for you, and learn how to use the various tools, 
palettes and windows.

1	 To ensure that the tools and palettes function as described in 
this lesson, delete or deactivate the Adobe GoLive CS2 preferences 
file.

2	 Launch Adobe GoLive CS2. Close the Welcome Screen if it 
appears.

3	 Choose File > Open. Navigate to the Lesson_05 folder inside 
the GOL_CIB\Lesson05 folder on your hard drive, and open the file 
named Lesson05.site. Click Open and the site window appears. 
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4	 In the site window, double-click on the file named lesson05_end.html. The 
document window containing the HTML file “lesson05_end.html” opens on your 
screen. This document represents the final version of your file; you may keep it open for 
reference during this lesson, or choose File > Close.

5	 In the site window, double-click on the file named lesson05_start.html to open the 
file.

6	 With the lesson05_start.html page forward, choose File > Save As and name the file 
faculty.html. Click on the Site Folder button ( ) at the bottom of the Save As window 
and select Root (Windows) or Root folder (Mac OS). This directs you to the Lesson_05 
web-content folder. Click Save.

Importing and working with text
You can type text directly into a text box in GoLive CS2 or you can import a .txt file 
from a word processor, and copy and paste the text. Once the text is in your document, 
GoLive provides several ways to format it.

1	 Choose File > Open and navigate to the Lesson_05 folder. Select the file faculty.txt 
and click Open.

2	 Choose Edit > Select All to select the text. Then choose Edit > Copy. You could 
have also used the keyboard shortcuts Ctrl+A (Windows) or Command+A (Mac OS) to 
select the text and Ctrl+C (Windows) or Command+C (Mac OS) to copy it. Choose  
File > Close to close the faculty.txt file.
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3	 Choose the Standard Editing tool ( ), and click once in the currently empty center 
layout text box. Choose Edit > Paste or use the keyboard shortcut Ctrl+V (Windows) or 
Command+V (Mac OS) to paste the text. 

Basic formatting in HTML
In this exercise you will learn the fundamentals of formatting your text in HTML. 
Basics, such as justifying and bolding text, are often easily accomplished in GoLive CS2. 
Controlling paragraph attributes, such as alignment, are often referred to as paragraph 
styles, whereas controlling text attributes, such as color or bolding, are referred to as 
physical styles.

1	 Place your cursor anywhere in the first paragraph, Faculty & Staff, and then click on 
the Align center button ( ) in the Main toolbar. This centers the text within the layout 
text box. Click on the Align right button ( ) to align it to the far right of the text box. 
Finally, click on the Align left button ( ) to align the paragraph to its original location.

Alignment Controls: 
A. Align left. B. Align Center. C. Align Right.

2	 Click and drag over the Faculty & Staff paragraph to highlight the text. Then click 
on the Set Font Size drop-down menu, which is located to the right of the alignment 
controls. Choose the number 6 from the list and the selected text gets bigger. Font size 
works on relative scale; a font size of 3 is the default font size. Choosing numbers larger 
than 3 results in a larger font size, and choosing numbers smaller than 3 results in a 
smaller font size.

3	 Click on the Set Font Size drop-down menu again and choose None from the list to 
remove the size.
Immediately to the right of the Set Font Size drop-down menu are the Strong, 
Emphasize, and Teletype buttons.

4	 Click on the Strong button ( ) in the Main toolbar; this renders your text in a 
bolder style. Click on the Strong button again to remove the formatting.
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5	 Click on the Emphasis button ( ) in the Main toolbar; this is the equivalent of 
italicizing your text. Click on the Emphasis button again to remove the formatting.

6	 Choose Type > Style to view the other style options available to you. Experiment 
with the other styles if you wish, make sure you select the style again to deselect it.

Creating lists from text
GoLive CS2 allows you to create bulleted and numbered lists, which can be useful when 
you need to visually organize information.

1	 Scroll to the bottom of your document and locate the four names at the bottom. 
Each name is in its own paragraph. Select the four names by clicking and dragging over 
the names.

2	 In the Main toolbar, click the Numbered List button ( ) to format the selected 
names as a numbered list.

3	 Click the Unnumbered List button ( ) to convert the names to an unnumbered 
or bulleted list.

4	 Click once after the second name in the list and then click on the Increase List Level 
button ( ) to increase the indentation of the bullet and the name.

5	 Select the entire list and click on the Unnumbered List button again to remove the 
list formatting.
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Setting text color
Easily change your text color in GoLive CS2.

1	 Select the headline Adjunct Faculty by clicking and dragging over the text.

2	 In the Main toolbar, double-click the Set text color button to open the Color Picker.

3	 Click on a red shade, click the Tab key and then OK to apply the color.

4	 Click and hold on the black triangle in the lower right corner of the Set text color 
button to access the color menu. Choose the first option, Remove Color, to remove the 
color formatting.

Note: You will be working more with color and the color controls in Chapter 6, “Working 
with Color.”
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Using the CSS palette and editor
The paragraph formatting in the last section is useful for quickly styling your text, but 
there are disadvantages as well. Each time you add a style, such as coloring your text or 
bolding a word, you are adding tags around the elements that you manually add to each 
selection. For example, if you wanted to bold a product name on every page in your 
Web site, you would have to locate it and apply the strong formatting. However, if at 
some point you choose to remove the bolding, you would have to locate every instance 
of the formatting and manually remove it, a process which could be quite cumbersome 
on a large site.

A useful alternative to this process is to use GoLive CS2’s CSS Editor to stylize your text. 
Cascading Style Sheets (CSS) make it easy to update text properties and other attributes 
throughout a Web site. If a CSS style needs to be updated, you simply edit the style, and 
all content that uses the style automatically reflects the new properties. With style sheets, 
you can set text size to display more consistently across different platforms, and control 
the position of content on a page with pixel-level precision. An External Style Sheet can 
be shared by an entire site, giving your pages a consistent presence, and enabling you to 
update the site’s styles with a single file.

The GoLive CSS Editor allows you to create CSS styles, edit style properties, and 
reference or create External Style Sheets. It can also preview how many of the style 
properties will appear. Sample style sheets are available in the New dialog box.

The CSS palette displays the existing CSS attributes in your document. You will now 
make sure you can adequately view your CSS palette for this exercise.

Paragraph formatting
You can use CSS to redefine existing HTML tags. In this exercise you will change the 
Head tags of your paragraphs in order to prepare them for formatting with the CSS 
Editor.

1	 Choose Window > Workspace > Default Workspace to restore your workspace to 
GoLive’s original settings.
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2	 Click on the arrow to the left of the Color tab to collapse the Color palette. Then 
click on the arrow to the left of the CSS tab to expand the CSS palette. The Style Apply 
tab is in the forefront. The Style name lists New Generic. As you add more styles, this 
window will list the various styles.

Click on the arrows to collapse  
and expand the palettes.

3	 Select the Standard Editing tool and click once at the end of the first line, Faculty 
& Staff. You will now change the formatting of this paragraph to a Header using the 
paragraph format menu. Headers are used in HTML to define the level of importance in 
a heading hierarchy. Browsers display the header text in bold formatting with a default 
point size. Header 1 is the largest size, and Header 6 is the smallest.

4	 In the Main toolbar, click on the Set paragraph format drop-down menu on the far 
left and choose Heading 1 from the list. Because the Faculty & Staff text is in its own 
paragraph, it increases to the default Heading 1 format and size.

5	 Click once after the word History and change the paragraph format to Heading 2. 
This makes the paragraph formatting of the second line bold but slightly smaller than 
the Heading 1.

6	 For the paragraph “Jeremy Osbourne—Director,” repeat the last step, formatting the 
paragraph as Heading 3. In the next exercise you will apply CSS styles to the headings.
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Using the CSS Editor to redefine markup elements
Markup Elements can be thought of as the tags used in HTML. For example, formatting 
the first paragraph as a Heading 1 assigned the <h1> tag to the paragraph. The actual 
source code looks like this: <h1> Faculty & Staff </h1>, where everything inside the 
opening and closing <h1> tags are assigned this attribute. However, these Heading 
tags are given default properties when rendered in a browser. CSS allows you to assign 
different properties to the tags, such as font family, color, point size, line height, and 
more. This provides designers with more control and flexibility over the appearance of 
text in their documents.

1	 Click once on the CSS Editor button ( ), located in the bottom left corner of the 
CSS palette. The CSS Editor window opens.

2	 If necessary, reposition your CSS Editor window so that the Faculty and Staff 
heading in your document window is visible. Changes you make in the CSS Editor will 
be automatically applied to your document. In the CSS Editor, click and hold the button 
marked Create a Style That Applies to Markup Elements ( ) to open a list of tags.



ADOBE GOLIVE CS2 207
Classroom in a Book

3	 Select the h1 tag, and the h1 tag appears in the CSS Definitions tab. If the Font 
Properties tab ( ) is not visible, select it now.

A B C D

A. h1 style. B. Font Properties. C. Create New Font Family. D. Create New Font.

You will now assign a font family to your Heading 1 tag.

4	 At the bottom right of the Font Properties tab, click on the Create new font family 
button ( ) to access a list of various font sets. A font set is a list of fonts that the browser 
will use to display your Heading 1 text.

5	 Choose the Trebuchet set from the menu and a list of fonts appears in the Font 
Family window. Click on your document window and, if necessary, scroll through your 
page to see the heading with the Trebuchet style applied to it.

Heading 1 with no CSS styling.	 Heading 1 with CSS styling.

Note: The list of fonts in a font set refers to the font order to be used when a user opens the 
HTML page in their Web browser. In this example, Trebuchet will be used first to display 
the Heading 1; if the user does not have Trebuchet on their machine, then the next font on 
the list (Geneva) will be used, then Arial, Helvetica, etc.
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6	 Click on the Preview tab to view your page in your default browser. The heading 
Faculty & Staff is now being rendered in the Trebuchet MS font in your Web browser. 
Click back on the Layout tab to enter the Layout Editor.

Formatting the body text of your page
Headings are used to emphasize a hierarchy in your documents. However, all of your 
visible text is also contained within the <body> tag of the html page. You will now 
format the properties of your body text.

1	 If the faculty.html CSS Editor window is no longer open, click on the Open CSS 
Editor button ( ) in the upper right of the document window. In the upper left corner 
of the CSS Editor, click and hold the small page icon ( ) located directly below the 
CSS Definitions tab to open a menu. This menu offers an alternative way to redefine a 
markup element, as you did in the last exercise.

2	 Choose New Style from the menu and select the first option: body. 

3	 Click on the Create new font family button ( ) at the bottom of the CSS Editor and 
choose Verdana Set.

4	 In the Font Properties tab ( ) in the CSS Editor window, click on the arrow to the 
right of the Size property. In the menu that appears, choose pixel from the list. 
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The Size property allows you to define what unit of measurement you would like to use 
for your fonts.

5	 In the size field, type 12. Press the Tab key to enter the Line Height field; type 16. 
Press the Tab key. Line height is defined as the amount of spacing between the baselines 
of your text; greater values result in more space between lines. This is similar to leading 
if you are familiar with typesetting terms.

Using CSS styles to format your text
In addition to changing the font style and line height of your text, CSS allows you to 
do much more. Color, margins, and background are all properties of text that can be 
modified. In this exercise you will first modify the h1 style that you created in a previous 
exercise, then you will create new styles on the remaining headers.

1	 Make sure that the faculty.html: CSS Editor is forward. If it is not, click on the CSS 
Editor button in the bottom left corner of the CSS palette or in the upper right of your 
document window. Once open, position the CSS Editor window toward the bottom of 
the screen; you want to be able to see your Heading 1 and the CSS Editor at the same 
time. Click on the h1 name in your CSS Editor.

2	 Double-click the color swatch in the Font Properties window to open the color 
picker. By default, there is no color associated with text. The color picker allows you to 
choose your own colors by locating a range in the color spectrum or by entering specific 
numbers in the fields.
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3	 In the Color Picker, locate the field next to the # sign and type 944A25. This is a 
hexadecimal number and corresponds to a dark brown color. Press Tab, then click OK 
to commit the change. The Heading 1 is now dark brown.

Note: Hexadecimal numbers are commonly used in HTML pages to designate colors. 

4	 Click on the Text Properties tab ( ) located immediately to the right of the Font 
Properties tab in the CSS Editor. Each tab allows you access to different CSS Properties.

A. Selector and Properties. B. Font Properties.  
C. Text Properties. D. Block Properties.  
E. Margin and Padding Properties. F. Border and Outline Properties.  
G. List Item and Other Properties. H. Background Properties.

5	 In the Text Alignment menu, choose Center. Although alignment can also be 
done in the Layout view, formatting alignment in CSS can often be more efficient. For 
example, changing alignment in the Layout view must be done on an individual basis. If 
you have six headings, each one would have to be reformatted in the Layout view. CSS 
allows you to apply global changes with a single command.

6	 In your GoLive document window, locate the second paragraph, History, and click 
once at the end of the paragraph. Click on your CSS Editor window to bring it into the 
forefront. If your CSS Editor is obscured by your document window, you could also 
choose the Window menu and select the CSS Editor option at the bottom.

7	 In the upper left-hand corner of the CSS Editor, click and hold the small page  
icon ( ) located directly below the CSS Definitions tab to open the menu. Choose New 
Style from the menu and then choose h2 from the submenu that opens.

8	 Make sure you are still in the Font Properties tab ( ). Click the Create new font 
family button ( ) and choose Trebuchet Set from the list.

9	 Repeat steps 7 and 8, but modify the h3 tag, selecting the same Trebuchet Set, but 
also double-click on the box to the right of “Color” and assign the color 944A25 to the 
h3 tag. Don’t forget to press the Tab key after typing a hexadecimal value in the Color 
Picker, before pressing OK.

10	 Close the CSS Editor when done.
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Applying CSS to the body of your text
After you have defined the CSS properties, you can apply them easily to your text by 
simply changing the formatting of your text. In this exercise, you will apply your CSS 
styles to the second section of your document.

1	 Scroll down your document and locate the second heading ENGLISH and click 
once anywhere inside the paragraph.

2	 In the Main toolbar, click on the Set paragraph format drop-down menu and 
choose Heading 2 from the list. Because that heading has a CSS style associated with it, 
it automatically assumes those properties.

3	 Click once inside the paragraph Jennifer Smyth—Director, and choose Heading 3 
from the Set paragraph format drop-down menu. The heading automatically updates to 
the style you set in the earlier exercise.
Now you will change the color and adjust the margins between your Heading 2 and 
Heading 3 paragraphs using the Margins and Padding Properties.

4	 Click on the CSS Editor button in the bottom left corner of your CSS palette to 
open the CSS Editor.

5	 Click on the h3 element in the CSS Editor and then double-click on the color 
swatch to open the Color Picker. In the hexadecimal field, type in 666666, press the Tab 
key and then click OK to update the color of your h3 headings to dark grey. Notice that 
both of your Headings were instantly updated. The ability to make global changes across 
a page (and even a whole site) allows you to experiment creatively with colors and styles.
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6	 With the h3 element still selected, click on the Margin and Padding Properties 
tab ( ) in the CSS Editor.

7	 In the Top field of the Margin section, type -0.2em and then press the Tab key, and 
the change will be applied. CSS allows you to modify the top, bottom, right, and left 
margins of any given element.

8	 Choose File > Save to save the changes made to your document.

Adding a CSS class style
Adobe GoLive CS2 lets you create and apply class styles to text in your documents. A 
class is not specific to a given tag, so you have more formatting flexibility than with 
tags alone. For example, if you wanted the first word of each paragraph to be a different 
color, you could create a class for that color; but, the style for the entire paragraph would 
remain the same. In this exercise you will create and then apply a class style to the 
school address information in the right-hand sidebar.

1	 With the faculty.html page forward, select the Standard Editing tool ( )—if not 
already selected—and highlight the address information in the sidebar on the lower 
right or your page.

 If you click inside a paragraph four times rapidly, you can select the entire paragraph.
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2	 If your CSS window is not currently open, open it by choosing Window > CSS. 
In the Style Apply tab you will see four checkboxes: Inline Style, Block Style, <p>, and 
<div>. These represent the CSS formatting options currently available to you.

Class style format options
You can choose from the following formatting options in the CSS palette or the inline CSS Style 
preview:

Inline Style formats an item inline.

Block Style creates a division that is disconnected from the normal flow of HTML.

<p> formats an entire paragraph with a style. You don’t need to select the entire paragraph; either place 
an insertion point in the paragraph or select a portion of it.

<body> applies a style to the entire body of a page. If this option isn’t listed, select the <body> tag in 
the markup tree at the bottom of the page, or place an insertion point anywhere in the Layout Editor, 
except inside a table or layer.

Specific HTML tags apply the style to a selected object, such as a table cell, image, or layer. For 
example, the <td> tag for a table cell, the <img> tag for an image object, and the <div> tag for a layer.

—From GoLive Help

3	 Click on the checkbox below the <p> and the New CSS Style window appears. Type 
address and click OK.

The CSS Editor window will appear and the .address class appears in the CSS palette. 
You will now format the address text.
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4	 In the CSS Editor, be sure you are in the Font Properties tab ( ). Click on the 
Create new font button ( ) on the bottom right side of the CSS Editor window. From 
the menu that appears, choose arial.

5	 Click in the box to the right of Size and type 11px, then press Enter. If necessary, 
reposition the CSS Editor window to see the text change in your sidebar.

6	 Double-click the Color swatch to open the Color Picker. In the hexadecimal field, 
type B90000 to select a dark red color. Press Tab and then click OK to apply the change. 

7	 Click on the arrow next to the Weight field and choose 700 (Bold) from the list.

8	 Click on the Text Properties tab ( ), click on the Text Alignment menu, and 
choose the Center option. Close the CSS Editor window.

Applying a CSS class style to a div
Understanding the difference between a paragraph and a div can be tricky if you’re not 
accustomed to tags. In the last exercise you selected a paragraph and applied a class style 
named “.address” to the selection. However, the paragraph is also contained within the 
entire sidebar. In the source code this sidebar begins with an opening <div> tag and 
ends with a closing div tag, </div>. Class styles can be applied to an entire div if needed.

1	 In the CSS palette, place your cursor over the checkbox for the <p> tag (in the 
address style), but do not click it. A preview window will appear to the left of the CSS 
palette. Although this window can be helpful when previewing changes, you will disable 
it in order to see your document window more clearly.
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2	 Click on the arrow located on the top right of the CSS palette to open the menu. 
Deselect the option Show Apply Information. Repeat this step twice to deselect the 
Show Cascaded Preview and Show Cascaded Properties.

Deselect these three options.

3	 In the CSS palette, click on the checkbox for the <p> tag to deselect it. The style is 
removed from the paragraph.

4	 In the CSS palette, click on the checkbox for the <div> tag. All text in the sidebar is 
formatted with the .address style.

5	 Click the checkbox for the <p> tag to select it. This centers the paragraph. 

Div with .address class applied.
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Exporting an Internal Style Sheet
The code that GoLive has been generating for the styles you have created in the last few 
exercises has been written into the document itself and is referred to as an Internal Style 
Sheet. In fact, the code for cascading style sheets can be placed in different locations. 
One of the most useful techniques is to create an External Style Sheet, which is a 
separate document with the extension .css. This document can be linked to multiple 
Web pages or an entire Web site. The benefits of this are that it becomes a simple matter 
to make one change to the External Style Sheet and automatically have the changes 
reflected in the linked pages.

You can create an External Style Sheet from scratch, but you can also take a page with 
existing CSS and convert the CSS to an External Style Sheet.

You will quickly identify the CSS code in your current document to help you 
understand the structure of CSS in relation to HTML documents.

1	 Click on the Source tab at the top of your document window to view your page 
as source code. Scroll to the top of your document and locate lines 9-15. These lines 
represent the CSS code you created using the CSS Editor.

2	 Click on the Layout tab to return to the Layout view. Open the CSS Editor by 
clicking the CSS Editor button. You could also choose Special > CSS > Open Editor.

3	 In the CSS Editor window, click on the button on the top right corner to open the 
menu. Choose the Export Internal CSS option.

4	 You will be prompted to name and save the file. If necessary, browse to your 
Lesson_05 folder to ensure that your CSS file is saved there. Name the file virtechu_
styles.css and click the Save button. This creates the standalone CSS file to which you 
can link other documents in your site.

5	 Chose File > Close to close the virtechu_styles.css file. 
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Importing an External Style Sheet
Now that you have created an External Style Sheet, you need to link it to another page 
in your site.

1	 Choose File > Open and select the file our_history.html located in your Lesson_05 
folder. This file has a similar layout and the paragraphs have already been formatted 
with their respective headings.

2	 Open the CSS Editor by clicking on the CSS Editor button ( ). Click on the 
arrow in the top right corner to open the menu, and choose the Import External CSS 
command.

3	 Locate the virtechu_styles.css file in your Lesson_05 folder and select it. Click the 
Open button to apply it. The changes are updated automatically.

 You can also apply an external style by selecting the virtechu_styles.css file from the 
Files tab of the site window and dragging it on top of the Show page properties button on 
the our_history.html page.

Congratulations! You have finished the lesson.

Exploring on your own
1	 Apply the Heading 2 and Heading 3 paragraph formatting to the second half of 
your document and then experiment with changing the colors, font family, and font size 
in the CSS Editor. 

2	 Add a bottom margin to the h1 heading to add more space between the Faculty & 
Staff paragraph and the History paragraph.

3	 Create a new class style for the text Home > About Us > Faculty & Staff located 
above the search box.



Review
Review questions
1	 Name two ways of adding text to a document.

2	 What are paragraph and physical styles and how are they applied to text?

3	 When using CSS, what is the difference between changing markup elements 
and creating a class style?

Review answers
1	 You can type text directly into a text layout box, or you can open a file created 
in a word processing program and copy and paste the text directly into GoLive.

2	 Paragraph and physical styles are formatting that you apply to text using the 
controls in the Main toolbar or in the Type menu. An example of a paragraph 
style would be applying a header; an example of a physical style would be bolding 
text using the strong control.

3	 When using CSS, a user can redefine the markup elements, such as a 
paragraph or heading tag, in order to change the default appearance based on the 
CSS properties. Additionally, users can create a class style which is a CSS styling 
that can be applied to a single word, a single tag, or a div.






