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In this lesson, you’ll learn how to do the following:

•	 Differentiate between vector and bitmap graphics. 

•	 Place embedded Adobe Photoshop graphics in an Adobe Illustrator file. 

•	 Create a clipping mask from compound paths.

•	 Make an opacity mask to display part of the image.

•	 Sample color in a placed image.

•	 Replace a placed image with another, and update the document.

•	 Export a layered file to Adobe Photoshop and edit the type.

Combining artwork
You can combine Illustrator artwork with images from other graphics 
applications in a variety of ways for a wide range of creative results. Sharing 
artwork between applications lets you combine continuous-tone paintings 
and photographs with line art. Even though Illustrator lets you create certain 
types of raster images, Photoshop excels at many image-editing tasks; once 
done, the images can then be placed in Illustrator.

To illustrate how you can combine bitmap images with vector art, and work 
between applications, this lesson steps you through the process of creating a 
composite image. In this lesson, you will add photographic images created 
in Adobe Photoshop to a postcard created in Adobe Illustrator. Then you’ll 
adjust the color in the photo, mask the photo, and sample color from the 
photo to use in the Illustrator artwork. You’ll update a placed image and then 
export your postcard to Photoshop to complete the type treatment.

Combining Illustrator CS2 
Graphics with the Creative 
Suite



376
Combining Illustrator CS2 Graphics with the Creative Suite
LESSON 13

Vector versus bitmap graphics
Adobe Illustrator creates vector graphics, also called draw graphics, which are made up 
of shapes based on mathematical expressions. These graphics consist of clear, smooth 
lines that retain their crispness when scaled. They are appropriate for illustrations, type, 
and graphics, such as logos, that may be scaled to different sizes. 

Bitmap images, also called raster images, are based on a grid of pixels and are created by 
image-editing applications such as Adobe Photoshop. In working with bitmap images, 
you edit groups of pixels rather than objects or shapes. Because bitmap graphics can 
represent subtle gradations of shade and color, they are appropriate for continuous-tone 
images such as photographs or artwork created in painting programs. A disadvantage of 
bitmap graphics is that they lose definition and appear jagged when scaled up. 
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Logo drawn as vector art.

Fl
ow

er
Tou

r 2005

Logo rasterized as bitmap art.
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In deciding whether to use Illustrator or a bitmap image program such as Photoshop 
for creating and combining graphics, consider both the elements of the image and how 
the image will be used. In general, use Illustrator if you need to create art or type with 
clean lines that will look good at any magnification. In most cases, you will also want 
to use Illustrator for laying out a design, because Illustrator offers more flexibility in 
working with type and with reselecting, moving, and altering images. You can create 
raster images in Illustrator but its pixel-editing tools are limited. Use Photoshop for 
images that need pixel-editing, color correcting, painting, and other special effects. Use 
InDesign for laying out anything from a postcard to a multiple chapter book such as this 
Classroom in a Book.

Getting started
Before you begin, you’ll need to restore the default preferences for Adobe Illustrator. 
Then you’ll open the finished art file for this lesson to see what you’ll create. 

1	 To ensure that the tools and palettes function exactly as described in this lesson, 
delete or deactivate (by renaming) the Adobe Illustrator CS2 preferences file. 

Note: To delete the preferences file, exit from Illustrator, and then delete the AIPrefs file 
(Windows) or Adobe Illustrator Prefs file (Mac OS) from the Adobe Illustrator CS2 Settings 
folder.

2	 Start Adobe Illustrator.

3	 Choose File > Open, and open the L13end.ai file in the ILL_CIB\Lesson13 folder 
on your hard drive.

4	 Choose View > Zoom Out to make the finished artwork smaller, adjust the window 
size, and leave it on-screen as you work. (Use the Hand tool ( ) to move the artwork 
where you want it in the window.) If you don’t want to leave the image open, choose  
File > Close.
Now you’ll open the start file to begin the lesson.
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5	 Choose File > Browse to open the Adobe Bridge, and Navigate to the L13strt.ai file 
(in the ILL_CIB\Lesson13 folder on your hard drive), and choose Open.

The file has been prepared with three layers: the Text layer, and two additional layers, 
Flowers and Layer 1, on which you’ll place images. Flowers also contains objects that 
you’ll make into a mask.
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6	 Choose File > Save As, name the file Postcard.ai, and select the Lesson13 folder. 
Leave the type of format set to Adobe Illustrator CS2 Document, and click Save. In the 
Illustrator Options dialog box leave at the default settings and click OK.

Placing an Adobe Photoshop file
You’ll begin by placing a Photoshop file that contains two layer comps in the Illustrator 
document as an embedded file. Placed files can be embedded or linked. Embedded 
files are added to the Illustrator file, and the Illustrator file size increases to reflect the 
addition of the placed file. Linked files remain separate, external files, with a link to the 
placed file in the Illustrator file. (The linked file must always accompany the Illustrator 
file, or the link will break and the placed file will not appear in the Illustrator artwork.)

About layer comps
Designers often create multiple compositions, or comps, of a page layout to show clients. 
Using layer comps, you can create, manage, and view multiple versions of a layout in a 
single Photoshop or ImageReady file. Layer comps are fully interchangeable between 
Photoshop and ImageReady if the image color mode is RGB.

A layer comp is a snapshot of a state of the Layers palette. Layer comps record three 
types of layer options:

•	 Layer visibility—whether a layer is showing or hidden.

•	 Layer position in the document.

•	 Layer appearance—whether a layer style is applied to the layer and the layer’s 
blending mode.

You create a comp by making changes to the layers in your document and updating the 
comp in the Layer Comps palette. You view comps by applying them in the document. 
You can export layer comps to separate files, to a single PDF, or to a web photo gallery.

1	 Resize the Layers palette so you can see all the layers.

2	 In the Layers palette, select the Flowers layer. 
When you place an image, it is added to the selected layer. You’ll use the Flowers layer 
for the placed image. The layer includes artwork for a mask for the image that you’ll 
create later in the lesson.
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3	 Choose File > Place.

4	 Navigate to the Flower1.psd file (in the ILL_CIB\Lesson13 folder on your hard 
drive), and select it. Do not double-click the file or click Place yet.

5	 If Link is checked, uncheck the Link option.

6	 Click Place.

7	 In the Photoshop Import dialog box, select Background 2 in the Layer Comp drop-
down menu, then check the Show Preview option to view the comps.

8	 Select the Convert Photoshop layers to objects option. Click OK.

Rather than flatten the file, you want to convert the Photoshop layers to objects. This is 
because the Flower1.psd file contains two layers and one layer mask. You will use them 
later in the lesson.

Now you’ll move the placed image, using the guides in the artwork to place the image 
precisely.

9	 Choose the Selection tool ( ) in the toolbox. Click on the edge of the placed image 
(don’t select a bounding box handle as it will resize the image), and drag the image onto 
the guides provided in the artwork. Release the mouse button when you have aligned 
the image with the guides.
By pressing the arrow keys you can nudge the selection into place.
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The placed image covers up the black flowers in the Flowers layer. The placed image 
was added as a sublayer to the Flowers layer because it was selected when you chose the 
Place command. 

10	 Choose File > Save
Now you will move the image below the black flowers and duplicate it.

Duplicating a placed image
You can duplicate placed images just as you do other objects in an Illustrator file. The 
copy of the image can then be modified independently of the original.

Now you’ll reposition and duplicate the Flower1.psd image in the Layers palette.

1	 Click the Expand triangle ( ) to the left of the Flowers layer to expand it. Enlarge 
the Layers palette so that you can see all the contents of the Flowers layer.

2	 Drag the Flower1.psd layer down the list until it is at the bottom of the Flowers 
layer. Release the mouse button when the indicator bar appears between the last <Path> 
layer and Layer 1.

Indicator bar.	 Flower1.psd layer moved.
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3	 Click the triangle to the left of the Flower1.psd layer to expand it. Notice that the 
Flower1.psd layer has two sublayers, Masked Flower and Background. You will now 
duplicate the Background layer.

4	 To duplicate the Background layer, click on the named layer and drag its thumbnail 
onto the New Layer button at the bottom of the Layers palette. Another layer called 
Background is created.

5	 Double-click the lower Background layer and rename it Pink Flower. Click OK. 
You will change the color of this image later in the lesson.

Duplicate Background layer.	 Rename layer. 

6	 Choose File > Save.
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Adjusting color in a placed image
Use filters to modify colors in placed images in a variety of ways. You can use filters 
to convert to a different color mode (such as RGB, CMYK, or grayscale) or to adjust 
individual color values. You can also use filters to saturate or desaturate (darken or 
lighten) colors, or invert colors (create a color negative). 

 For information on color modes and modifying colors with filters, see “About Color 
models and color modes” and “Applying filters and effects” in Illustrator Help.

In this section, you’ll adjust colors in the Background layer. Later in the lesson, you’ll 
apply a mask to this image and then adjust colors in the Pink Flower layer so that the 
two layers appear in contrasting colors through the mask.

1	 In the Layers palette, select the Background sublayer.

2	 Click the eye icon ( ) to the far left of the Masked Flower layer to hide it.
When you hide a layer, all objects on that layer are deselected, hidden, and locked.

3	 In the Layers palette, click the selection column to the far right of the Background 
layer to select its contents quickly.

Masked Flower layer hidden and contents of Background layer selected.

4	 Choose Filter > Colors > Adjust Colors.
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5	 In the Adjust Colors dialog box, select Preview so that you can see the color 
changes. Drag the sliders or enter values for the CMYK percentages to change the colors 
in the image. You can press Tab to move between the text fields. (We used the following 
values to create a blue/purple cast: C=54, M=20, Y=–59, and K=0.) 

6	 When you are satisfied with the color in the image, click OK.

7	 Click outside the artwork to deselect the Background image, and then choose File > 
Save.

 You can also use filters to apply special effects to images, distort images, produce 
a hand-drawn appearance, and create other interesting effects. See “Changing the 
appearance of bitmap images with filters and effects” in Illustrator Help.
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Masking an image
Masks crop part of an image so that only a portion of the image appears through the 
shape of the mask. You can make a mask from a single path or a compound path. You 
can also import masks made in Photoshop files.

Creating compound paths and opacity masks
In this section, you’ll create a compound path from the flower pattern on the Flower 
layer and create an opacity mask from the compound path, so that the Background layer 
appears through the mask. Then you’ll adjust the colors in Pink Flower to contrast with 
the Background layer. You’ll also use an opacity mask that was created in Photoshop and 
saved as a layer mask.

1	 Select the Magic Wand tool ( ) in the toolbox.

2	 Using the Magic Wand tool, click the upper left black flower in the flower pattern to 
select all the black flowers. This action selects the flowers and deselects the background.

 You can use the Magic Wand tool to select all objects in a document with the same 
or similar fill color, stroke weight, stroke color, opacity, or blending mode. See “Using 
the Magic Wand tool and palette” in Illustrator Help.

3	 Choose Object > Compound Path > Make.
Notice how all the flowers have been placed onto one layer, called <Compound Path>, 
in the Layers palette. 

The Compound Path command creates a single compound object from two or more 
objects. Compound paths act as grouped objects. The Compound Path command 
lets you create complex objects more easily than if you used the drawing tools or the 
Pathfinder commands.
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4	 With the compound path selected, in the Layers palette Shift+click the selection 
column to the far right of the Background layer. This selects it and adds it to the 
<Compound Path> selection. (The Selection indicator ( ) appears and the Background 
layer is added to the selection.)

Note: Both the masking object and the object to be masked must be selected in order to 
create a mask.

Background and  
<Compound Path> selected.

5	 Click the Transparency palette tab to bring it to the front of its group. (If the 
Transparency palette isn’t visible on-screen, choose Window > Transparency.)

6	 From the Transparency palette menu, choose Show Options.
Now you’ll mask the Background layer with an opacity mask. This allows you to use the 
change in luminosity in the overlying flower pattern to affect the background. Similar 
to a clipping mask, an opacity mask lets you make color and other fine adjustments that 
you can’t make with a clipping mask.

7	 From the Transparency palette menu, choose Make Opacity Mask. Select both the 
Clip and Invert Mask options to see the effect.

Dotted line indicates mask.		 Preview includes opacity mask.
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The Background layer is now masked with the flower pattern, as indicated by the dotted 
underline beneath the layer name. The Pink Flower layer appears through the masked 
sections of the Background layer.

Now you’ll apply the Adjust Colors filter to the Pink Flower layer to create a stronger 
contrast between the two images.

8	 In the Layers palette, click to the right of the target indicator ( ) of the Pink Flower 
layer to turn on the selection indicator ( ). This selects only the Pink Flower layer’s 
contents.

9	 Choose Filter > Colors > Adjust Colors.
The most recently used filter (in this case, Adjust Colors) appears at the top of the Filter 
menu, letting you easily reapply the filter. (Choosing Filter > Apply Adjust Colors would 
apply the filter with the same settings used on the Background layer.) 

10	 Click Preview to preview changes in the artwork.

11	 Drag the sliders for the CMYK values to change the colors in the image. (We used 
the following values to create a blue cast: C=–10, M=–17, Y=–91, and K=0.) Note that 
some of these numbers are negative. You can compare the color in Pink Flower to that 
in the Background layer to choose a color that contrasts effectively.

12	 When you are satisfied with the color, click OK. With the Selection tool ( ), click 
outside the artwork to deselect the Pink Flower image. 
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Editing an imported mask
You’ve made an opacity mask from artwork created in Illustrator. Now you’ll use a 
mask that was created in Photoshop and imported when you placed the Flower1.psd 
file. You’ll experiment with changing the color of the image and then adjusting the 
transparency of the opacity mask to tone down the effect.

1	 In the Layers palette, click the eye column to show the Masked Flower layer.

2	 Click the selection indicator ( ) for the Masked Flower layer to select its contents. 
(The dotted line under its layer name indicates that the Masked Flower layer has an 
opacity mask applied to it.)

3	 Choose Filter > Colors > Adjust Colors.

4	 In the Adjust Colors dialog box, click Preview to preview changes in the artwork. 
Drag the sliders for the CMYK values to change the colors in the image. (We used the 
following values to create a yellow cast: C=–79, M=–35, Y=–22, and K=0.) Note that 
some of these numbers are negative. Click OK.

5	 In the Transparency palette, change the opacity setting, enter 85 for the Masked 
Flower layer and press Enter.
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Mask opacity set to 85%.	 Result.

6	 Choose File > Save.
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Sampling colors in placed images
You can sample, or copy, the colors in placed images, to apply the colors to other objects 
in the artwork. Sampling colors enables you to easily make colors consistent in a file 
combining Photoshop images and Illustrator artwork.

In this section, you’ll use the Eyedropper tool to sample colors from the placed image, 
and apply the colors to selected type on the Text layer.

1	 Use the Selection tool ( ) to click in the text at the bottom of the artwork to select 
the entire text block.

2	 Click on Fill in the toolbox and use the Swatches palette change the Fill to None.

3	 Select the Eyedropper tool ( ), and Shift+click in the image to sample a color to be 
applied to the selected text. (We chose a yellow color from the petals of the flower in the 
middle.)
The color you sample is applied to the selected text.
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4	 Choose File > Save.
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To copy appearance attributes using the Eyedropper tool
You can use the Eyedropper tool to copy appearance attributes from one object to another, including 
character, paragraph, fill, and stroke attributes between type objects. By default, the Eyedropper tool 
affects all attributes of a selection. To customize the attributes affected by this tool, use the Eyedropper 
dialog box.

1. Select the object, type object, or characters whose attributes you want to change.

2. Select the Eyedropper tool ( ).

3. Move the Eyedropper tool onto the object whose attributes you want to sample. (When you’re correctly 
positioned over type, the pointer displays a small T.)

4. Do one of the following:

•	Click the Eyedropper tool to sample all appearance attributes and apply them to the selected object.

•	Shift‑click to sample only the color from a portion of a gradient, pattern, mesh object, or placed 
image and apply the color to the selected fill or stroke.

•	Hold down the Shift key and then the Alt (Windows) or Option (Mac OS) key while clicking to add 
the appearance attributes of an object to the selected object’s appearance attributes. Alternatively, click 
first, and then hold down Shift and then Alt or Option.

Note: You can also click an unselected object to sample its attributes, and Alt‑click (Windows) or 
Option‑click (Mac OS) an unselected object to which you want to apply the attributes. 

—From Illustrator Help

Replacing a placed image
You can easily replace a placed image with another image to update a document. The 
replacement image is positioned exactly where the original image was, so you don’t 
have to align the replacement image. (If you scaled the original images, you may have to 
resize the replacement image to match the original image.)

Now you’ll replace the Pink Flower image with the Flower1.psd image using Layer comp 
Background 1 to create a new version of the postcard.
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1	 Choose File > Save As, enter Postcard2.ai for the file name, and select the Lesson13 
folder in the Save In menu. Leave the type of format set to Adobe Illustrator (.AI), and 
click Save. In the Illustrator options dialog box, leave at the default settings and click 
OK.

2	 Click the Links tab to bring the Links palette to the front of its group. (If the Links 
palette isn’t visible on-screen, choose Window > Links.)

3	 Click the last link in the Links palette to select it. (These links don’t have names 
because we embedded them instead of linking them.)

4	 Click the Relink button ( ) at the bottom of the Links palette.

5	 In the Place dialog box, navigate to the Flower1.psd image in the Lesson13 folder 
and select it. Make sure that the Link option is deselected. Click Place and select 
Background 1 in the Layer comp drop-down menu to replace the Pink Flower image 
with the new one.
The replacement image appears in the Flowers layer as a Flowers1.psd sublayer with no 
color adjustments applied. When you replace an image, color adjustments you made to 
the original image are not applied to the replacement. However, masks applied to the 
original image are preserved. Any layer modes and transparency adjustments you’ve 
made to other layers also may affect the image’s appearance. 

Select image in Links palette.	 Click Replace Link button to  
	 replace with new image. 

6	 Choose File > Save.
You have completed the lesson. If you want to learn how to open and manipulate a 
layered Illustrator file in Photoshop, continue. If not, skip to “Exploring on your own”.
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Exporting a layered file to Photoshop
Not only can you open layered Photoshop files in Illustrator, but you can also save 
layered Illustrator files and then open them in Photoshop. Working with layered files 
between Illustrator and Photoshop is very helpful when creating and editing Web 
graphics. You can preserve the hierarchical relationship of the layers by selecting the 
Write Layers option when saving your file. You can also open and edit type objects.

1	 Choose File > Export.

2	 Navigate to the folder where you’ll save the file, and name the file Postcard2.psd. 
Changing the file name preserves your original Illustrator file.

3	 Choose Photoshop (PSD) from the Save as Type (Windows) or Format (Mac OS) 
drop-down menu, and click Save (Windows) or Export (Mac OS).

4	 In the Photoshop Export Options dialog box, choose CMYK as the Color Model, 
select Screen (72 ppi) for Resolution, and check Write Layers. Leave Preserve Text 
Editability and Maximum Editability checked. Check Anti-alias. Click OK. 
The Anti-alias option removes jagged edges in the artwork. The Write Layers option lets 
you export each Illustrator top-level layer as a separate Photoshop layer. 

5	 Start Adobe Photoshop CS2.

6	 Open the Postcard2.psd file that you exported in step 4.

7	 If prompted to update text layers, click Update.

8	 Select the Type tool ( ) in the toolbox. 

9	 Click the Type tool within the text on the path, and choose Select > All to select all 
the text.

10	 In the control bar, change the text attributes by changing the font and size.

11	 Choose File > Save. Choose File > Close to close the file.
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Importing Adobe Illustrator graphics in InDesign CS2
How you save and import Illustrator graphics depends on how you want to edit the art once you place 
it in InDesign.

If you plan to edit a graphic only in Illustrator...

Save the graphic in native Illustrator format (.ai). Some graphics require the extensive drawing tools 
available in Illustrator or are in their final form and shouldn’t be edited. In InDesign, you can place a 
native Illustrator graphic and transform it as a single object (you can resize or rotate it, for example). 
Use the Edit > Edit Original command to open the graphic in Illustrator and edit it there.

If you want to adjust layer visibility in InDesign...

Save the Illustrator CS2 file in layered PDF format. For some documents, you want to control the 
visibility of the layers of a graphic depending on the context. For example, for a multilanguage 
publication, you can create a single illustration that includes one text layer for each language. Using the 
layered PDF format, you can transform the illustration as a single object in InDesign but you cannot 
edit the paths, objects, or text within the illustration.

If you want to edit objects and paths in InDesign...

Copy the art from Illustrator and paste it into an InDesign document. For some graphics, you might 
want to edit them after they’re placed in the InDesign document. For example, in a magazine, you 
might use the same design element in each issue, but want to change its color every month. If you paste 
a graphic into InDesign and edit it there, you cannot set layer transparency or edit the text.

Exploring on your own
Now that you know how to place and mask an image in an Illustrator file, you can 
place other images and apply a variety of modifications to the images. You can also 
create masks for images from objects you create in Illustrator. For more practice, try the 
following:

•	 In addition to adjusting color in images, apply transformation effects (such as 
shearing or rotating) or filters or effects (such as one of the Artistic or Distort filters/
effects), to create contrast between the two images in the flower pattern.

•	 Use the basic shapes tools or the drawing tools to draw objects to create a compound 
path to use as a mask. Then place the Flower1.psd image into the file with the 
compound path, and apply the compound path as a mask.

•	 Create large type and use the type as a mask to mask a placed object.



Review
Review questions
1	 Describe the difference between linking and embedding a placed file in 
Illustrator.

2	 How do you create an opacity mask for a placed image? 

3	 What kinds of objects can be used as masks?

4	 What color modifications can you apply to a selected object using filters?

5	 Describe how to replace a placed image with another image in a document.

Review answers
1	 A linked file is a separate, external file connected to the Illustrator file by an 
electronic link. A linked file does not add significantly to the size of the Illustrator 
file. The linked file must accompany the Illustrator file to preserve the link and 
ensure that the placed file appears in the Illustrator file. An embedded file is 
included in the Illustrator file. The Illustrator file size reflects the addition of the 
embedded file. Because the embedded file is part of the Illustrator file, no link 
can be broken. Both linked and embedded files can be updated using the Replace 
Link button in the Links palette.

2	 You create an opacity mask by placing the object to be used as a mask on 
top of the object to be masked. Then you select the mask and the objects to be 
masked, and choose Make Opacity Mask from the Transparency palette menu. 

3	 A mask can be a simple or compound path. You can use type as a mask. You 
can import opacity masks with placed Photoshop files. You can also create layer 
clipping masks with any shape that is the topmost object of a group or layer.

4	 You can use filters to change the color mode (RGB, CMYK, or grayscale) or 
adjust individual colors in a selected object. You can also saturate or desaturate 
colors or invert colors in a selected object. You can apply color modifications to 
placed images, as well as to artwork created in Illustrator.



5	 To replace a placed image, select the placed image in the Links palette. Then 
click the Replace Link button, and locate and select the image to be used as the 
replacement. Then click Place. The replacement image appears in the artwork in 
place of the original image.




