
TECHNICAL paper

Migrating from  
FreeHand to Illustrator
A Technical Resource
Switching tools in a work environment is not a trivial task even when the overall goal 
is a more efficient and beneficial workflow. But there are many benefits in moving from 
Macromedia® FreeHand® to Adobe Illustrator® CS2, including better integration with 
Adobe Creative Suite components like Adobe Photoshop®, Adobe InDesign®, Adobe 
GoLive®, and Adobe Acrobat®. In addition, support for open standards like OpenType®, 
PDF/X, SVGt, CSS, and XMP help ensure that Illustrator is a perfect fit in any workflow.

When migrating from FreeHand to Illustrator, one of the main concerns is converting  
an existing library containing years of legacy FreeHand files so that you may use them 
in an Illustrator workflow. This document is a technical resource for using legacy 
FreeHand content in Illustrator. For detailed information on feature comparisons 
between FreeHand and Illustrator, see the FreeHand to Illustrator Migration Guide on 
the Adobe website at www.adobe.com/products/illustrator/pdfs/illcs2ip_fhillmigr.pdf.

Importing FreeHand files, and saving and exporting Illustrator files
When moving files from FreeHand to Illustrator, the file format affects how your files 
appear in Illustrator. In this section, we will explore several file formats that you can use 
when moving files from FreeHand to Illustrator, and the benefits of each. Once you’ve 
opened your files in Illustrator, you can save and export them in a variety of formats.

What is the best way to import my legacy FreeHand files into Illustrator?
There are several ways to get FreeHand files into Illustrator CS2. Determining the best 
way depends on the type of illustration and whether you plan to edit the text in the file. 
Each method has its pros and cons, especially in the way text and multiple pages are 
affected. For a side-by-side comparison of formats, see the table on page 2.

•	 FreeHand 9  Illustrator can open native FreeHand 9 files directly. If you use FreeHand 10 
or FreeHand MX, you must first export your files in FreeHand 9 format. To export a 
FreeHand 10 or later file in FreeHand 9 format, choose File > Export and then choose 
FreeHand 9 from the Format pop-up menu. Click Export.

• 	Encapsulated PostScript  Illustrator can open Encapsulated PostScript (EPS) files 
created in FreeHand.

	 To export a FreeHand file as an EPS file:

1.  �Open the file in FreeHand and do one of the following:

	 • �Choose File > Save As and choose Editable EPS from the Format pop-up menu.

	 • �Choose File > Export and choose Generic EPS from the Format pop-up menu.

	 • �Choose File > Export and choose Macintosh EPS from the Format pop-up menu.

2.  Click Save or Export.

• 	PDF  To save a FreeHand file as an Adobe PDF file, choose File > Export and choose 
PDF from the Format pop-up menu. Click Export.

• 	Illustrator 7.x  FreeHand can export a native Illustrator 7 file, which you can open 
in Illustrator CS2. With your file open in FreeHand, choose File > Export and choose 
Illustrator 7.x from the Format pop-up menu. Click Export.
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File  
Attri bute

File exported as  
FreeHand 9 (.fh9)

File saved or  
exported as EPS (.eps)

File exported as  
PDF (.pdf)

File exported AS  
Illustrator 7.x (.ai)

Text Text remains unbroken and editable, but 
kerning information is not retained and 
text may reflow.

Text appearance is maintained, but text 
is broken up into separate text strings 
and is less editable.

Text appearance is maintained, but text 
is broken up into separate text strings 
and is less editable.

Text remains unbroken and editable, but 
kerning information is not retained and 
text may reflow.

Multiple Pages The first page appears centered on the  
Illustrator artboard. All other pages appear 
off the page in the Pasteboard area.

Each page is exported as a separate EPS 
file, which can be opened as individual 
documents in Illustrator.

Illustrator presents you with a dialog box 
with previews so that you may choose 
which page you want to open.

Each page is exported as a separate .ai 
file, which can be opened as individual 
documents in Illustrator.

Gradients Linear and logarithmic gradients are 
converted to Illustrator linear gradients, 
but the appearance of the gradient may 
change drastically. All other gradient 
types are expanded and maintain their 
appearance.

All gradient types are expanded and 
maintain their appearance. The number 
of steps in the expanded gradient may 
not be enough for quality reproduction.

Linear and logarithmic gradients are con-
verted to nonnative Illustrator objects. 
All other gradient types are expanded 
and maintain their appearance.

All gradient types are expanded and 
maintain their appearance. The number 
of steps in the expanded gradient may 
not be enough for quality reproduction.

Blends Blends are maintained and converted to 
Illustrator Live Blends.

Blends maintain their appearance but 
are expanded into individual objects for 
each step in the blend.

Blends maintain their appearance but 
are expanded into individual objects for 
each step in the blend.

Blends maintain their appearance but 
are expanded into individual objects for 
each step in the blend.

Colors All process colors that are used in the 
file are imported and defined as global 
process color swatches. Spot colors are 
imported and preserved.

All swatches and spot colors are  
imported and preserved.

No swatches are imported, and spot 
colors are converted to process.

Process color swatches are imported. 
Spot colors are imported and preserved.

When converting files from FreeHand to Illustrator, the attributes that are most important to you will determine 
which file format will work best.

When I open a file from FreeHand, I am sometimes presented with a Convert Color Mode dialog box. 
What does this mean?
Similar to the artboard in Photoshop, Illustrator’s artboard uses a single color mode. If you open 
a document that contains both CMYK and RGB data, Illustrator asks you what color mode you 
want to work in, and converts all colors to match the chosen color space. To manually change a 
document’s color space in Illustrator, choose File > Document Color Space.

When you open a document that contains both CMYK and RGB elements, Illustrator asks you to choose a  
single color mode.

Does Illustrator have a Collect for Output feature like FreeHand?
While Illustrator doesn’t have a built-in feature that automatically collects all linked images 
used in a document, it does include a script that performs this function. In Mac OS, this script 
is in the Adobe Illustrator CS2/Scripting/Sample Scripts/AppleScript/Collect for Output folder. 
In Windows, the script is in the Adobe Illustrator CS2/Scripting/Sample Scripts/Visual Basic/
Collect for Output folder. To make the script available in the Scripts menu, copy it into the 
Adobe Illustrator CS2/Presets/Scripts folder and then restart Illustrator.

In addition, you can see a list of all placed images in a document by looking at the Links palette, 
(Window > Links), and you can see all of the fonts used in a document by looking at the Find 
Font dialog box (Type > Find Font).

In FreeHand, I am able to export a document as a layered Photoshop file. How can I do the same 
from Illustrator?
You can export Photoshop files from Illustrator in PSD format. To do so, choose File > Export 
and choose Photoshop (.psd) from the Format pop-up menu. When exporting a .psd file from 
Illustrator, you can preserve layer structure, editable text, editable transparency, clipping masks, 
vector compound shapes, web slices, and image maps.
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In FreeHand, I am able to export a document as PDF. How do I create a PDF from Illustrator?
Since Adobe PDF is a file format that can be round-trip edited in Illustrator, you save PDF files 
from Illustrator rather than export them as you would from FreeHand. To create a PDF file from 
Illustrator, choose File > Save As and choose Adobe PDF from the Format pop-up menu, and 
then click Save. In the Save Adobe PDF dialog box, specify options for the resulting PDF file. For 
more information, see the PDF file creation section of the Print Resource Center on the Adobe 
website at www.adobe.com/studio/print/designer.html#pdfcreation.

How do I create a multipage PDF file from Illustrator?
Unlike FreeHand, Illustrator follows a single-page-per-document model. However, you can 
use Illustrator’s Page Tiling feature to simulate multiple pages in a single document (refer to 
Illustrator’s Help for information on how to set up page tiles). After applying tiling to a page, 
select Create Multi-Page PDF From Page Tiles in the Save Adobe PDF dialog box to automati-
cally convert all page tiles to individual pages in the resulting PDF file.

How do I export a GIF or a JPEG file from Illustrator?
To export GIF or JPEG images for use on the web, choose File > Save For Web. In the Save For 
Web dialog box, you can preview your art in a multitude of web file formats including GIF, JPEG, 
PNG, WBMP, SWF, and SVG.

How do I create Flash (SWF) files from Illustrator?
There are two ways to export Illustrator files to SWF files: Choose File > Export and then choose 
Macromedia Flash (.SWF) from the Format pop-up menu, or use the Save For Web feature.

Does Illustrator support duotone images?
Yes, you can place duotone images saved from Photoshop, and link or embed them.

Does Illustrator support DCS 2.0 files?
Illustrator supports DCS 2.0 files only in a nontransparency workflow. If a DCS image interacts 
with transparency, the image won’t print as expected when output. To see if a placed DCS image 
interacts with transparency, choose Palette Options from the Links palette menu and select 
Show DCS Transparency Interactions. With this setting turned on, yellow icons in the Links 
palette identify images that interact with transparency. For more reliable results, save spot color 
files from Photoshop as native PSD or Photoshop PDF files.

The Show DCS Transparency Interactions option helps you locate DCS images that interact with transparency.

Working with text
Illustrator contains a Unicode-compliant next-generation text engine that provides full support 
for OpenType fonts as well as optical kerning, optical margin alignment, every-line composing, 
and multilingual hyphenation and spell checking. The following section covers issues that you 
might encounter when importing and working with text.

How does Illustrator handle legacy text?
When you open a FreeHand file saved in Illustrator 7.x format, Illustrator CS2 displays a 
dialog box informing you that there is legacy text in the file. Illustrator CS2 has a newer text 
engine than the one in Illustrator 7, and must convert text when opening documents created in 
Illustrator CS or earlier.

http://www.adobe.com/studio/print/designer.html#pdfcreation
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When opening a file, Illustrator alerts you if the document contains legacy text.

When you open a file containing legacy text, Illustrator gives you options to update the text, or 
to open the file without updating the text. Click Update if you plan on editing the text in the 
file (the text may reflow). Click OK if you won’t be editing the text; the text’s appearance will be 
preserved. For more information on updating legacy text, see “Working with Type in Illustrator 
CS2” on the Adobe website at www.adobe.com/products/illustrator/pdfs/Text_in_AICS2.pdf.

If you try to edit legacy text, Illustrator returns a dialog box so that you can update the text first.

Does Illustrator maintain kerning or text styling when importing files from FreeHand?
Editable kerning values are not retained when you open FreeHand files in Illustrator. However, 
you can maintain the appearance of kerned text (but will lose the ability to edit the text) by 
exporting files from FreeHand as EPS or PDF files. For more information, see the table on page 2 
of this document.

How do I place text along the top and bottom of a path in Illustrator?
In Illustrator, you use the Type On A Path tool to type text along any opened or closed path. 
Unlike FreeHand, Illustrator can only place text along one side of a path. To simulate text 
appearing along the top and bottom halves of a circle, you must create two distinct shapes and 
then overlay them on top of each other.

To create text that flows on both the top and bottom of a circle, first draw a circle and place text along the top por-
tion of the path (left). Then, duplicate the circle and position the text along the bottom portion of the path (center). 
Finally, align the circles on top of each other (right).

Does Illustrator support Unicode text?
Yes, the text engine in Illustrator is Unicode-compliant. For more information on the Unicode 
standard, see www.unicode.org.

Does Illustrator support OpenType fonts?
Yes, Illustrator has full support for OpenType fonts. OpenType is an open standard font format 
that is Unicode-based and that supports advanced features like automatic glyph replacement.  
For more information on OpenType fonts, visit the Adobe website at http://studio.adobe.com/us/
type/main.jsp?xhtml=opentype/main.

http://www.adobe.com/products/illustrator/pdfs/Text_in_AICS2.pdf
http://www.unicode.org
http://studio.adobe.com/us/type/main.jsp?xhtml=opentype/main
http://studio.adobe.com/us/type/main.jsp?xhtml=opentype/main
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When I open a PDF or EPS file that wasn’t created in Illustrator, text is broken into individual text 
blocks. Is there any way to avoid this?
No. In order to preserve kerning and the appearance of text objects, text in imported generic EPS 
or PDF files (that is, an EPS or a PDF created with an application other than Illustrator) is not 
imported as a single string of editable text.

To combine multiple text objects into a single text string, you can use the Selection tool to select 
the different type objects, switch to the Type tool and create a new area text object, and then 
choose Edit > Paste.

How do I set a text frame to auto-expand in Illustrator?
Illustrator doesn’t have auto-expanding text frames as FreeHand does. Besides Type on a Path 
(see previous page), there are two kinds of type objects in Illustrator: point type objects and area 
type objects. A point type object has no boundaries and doesn’t wrap automatically to fit within 
a set width. An area type object is most similar to a FreeHand text object, and its width deter-
mines how the text wraps and flows. If there is overset text in an area type object, a red plus sign 
appears at the lower right corner of the object. You can resize an area type object so that more 
text will fit in it.

Working with objects and colors
There are some differences in how FreeHand and Illustrator work with objects and colors. This 
section discusses how to work around these differences.

Can you set an Illustrator window to multiple views?
Illustrator allows you to view the same file in different windows with different zoom levels and 
preview settings. To open your artwork in another window, choose Window > New Window.

Where is the paste inside function in Illustrator?
Illustrator uses a variety of mask functions to clip objects, unlike FreeHand, which has a paste 
inside function. The ability to define layer masks in Illustrator makes it possible to have multiple 
objects clipped by a single object while still maintaining layer structure.

•	To apply a clipping mask on an object-by-object basis, first draw a shape that you want to use 
as a mask. Place this shape above your artwork in the object stacking order. Select both the 
artwork and the mask shape and choose Object > Clipping Mask > Make. Illustrator groups 
the artwork with the mask. You can use the Direct Selection tool to move the artwork and the 
mask independently.

•	For more complex objects, and to maintain layer structure, first draw a shape that you want to 
use as a mask. Bring the object to the top level of the layer. In the Layers palette, highlight the 
layer that contains the shape and click the Create/Release Clipping Mask button at the bottom 
of the palette. The path is listed with an underline in the palette and clips all objects within 
that layer.

For more detailed information about masking in Illustrator, see the FreeHand to Illustrator Migration 
Guide on the Adobe website at www.adobe.com/products/illustrator/pdfs/illcs2ip_fhillmigr.pdf.

How can I combine multiple shapes using path operations?
Illustrator contains a collection of path-combining functions in the Pathfinder palette. Functions 
like Add To Shape Area and Subtract From Shape Area are similar to the Union and Punch com-
mands in FreeHand.

The Pathfinder palette contains many functions for combining paths, making it easy to combine primitive vector 
shapes into more complex ones.
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How do I select through objects in Illustrator?
In Illustrator, you can select objects that are beneath other objects by choosing Select > Next 
Object Below. You can also access this command by right-clicking (Windows) or Ctrl-clicking 
(Mac OS).

You might find it easier to select objects when the Object Selection By Path Only setting in the 
General preferences panel is selected. With this setting turned on, you can select objects only by 
clicking on their path.

Does Illustrator have a clone command, like FreeHand does?
Yes. To clone a selection in Illustrator:

1.	 Choose Edit > Copy (Command-C in Mac OS, or Ctrl-C in Windows).

2.	 �Choose Edit > Paste In Front (Command-F in Mac OS, or Ctrl-F in Windows), or Edit > Paste 
In Back (Command-B in Mac OS, or Ctrl-B in Windows).

You can also hold the Option key (Mac OS) or Alt key (Windows) when you move or transform 
an object to leave a copy behind.

Does Illustrator contain the newer Pantone color libraries?
Yes, Illustrator contains the updated Pantone libraries that were created in 20000. Choose 
Window > Swatch Libraries to access any of the 10 Pantone libraries included with Illustrator: 
Metallic Coated, Pastel Coated, Pastel Uncoated, Process Coated, Process Uncoated, Solid 
Coated, Solid Matte, Solid Uncoated, Solid to Process Coated, and Solid to Process Uncoated.

How do I define a logarithmic gradient in Illustrator?
Illustrator only supports linear and radial gradients.

Does Illustrator have a search and replace feature, like FreeHand?
Illustrator contains a text-based search-and-replace feature (Edit > Find), but does not have a 
graphic search-and-replace function like FreeHand.

How do I select multiple objects with the same attributes in Illustrator?
Illustrator contains a Select menu that allows you to select a single object and then select all other 
objects that either contain a similar fill or stroke color, stroke weight, or other similar attributes. 
In addition, Illustrator contains a Magic Wand tool that allows you to select objects that have a 
similar fill color, stroke color, stroke weight, opacity, and blending mode with a single click.

By setting a tolerance level for the Magic Wand tool, you can select multiple objects that fall into a general  
range of colors.

How do I align or distribute objects in Illustrator?
Illustrator has an Align palette that contains functions for aligning objects to each other or to 
the artboard, and for distributing objects evenly. Select the objects you want to align, and then 
select one of the icons in the Align palette. These icons also appear in the Control palette when 
multiple objects are selected.

Choosing the Align To Artboard setting allows you align objects to the page.
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Does Illustrator have a Release To Layers feature?
Yes. In Illustrator, you can easily distribute text objects and the individual steps in a blend 
among individual layers. To do so, select a layer and choose Release To Layers from the Layers 
palette menu. The Release To Layers command also works on text objects.

General document settings
Both Illustrator and FreeHand support a wide range of features that can be used to be more  
productive, to express your creativity, and to push the boundaries of design. This section 
explores general application use and offers guidance on how to get the most out of Illustrator.

How do I create guides in Illustrator?
To create guides in Illustrator, drag them out from the horizontal or vertical rulers (choose View > 
Show Rulers to turn on the rulers). Alternatively, you can convert any vector object into a guide 
by choosing View > Guides > Convert To Guide. In Illustrator, there is no dedicated layer for 
guides. Guides are added to the layers that they are drawn on.

Does Illustrator have an AutoTrace tool to convert bitmap images to vectors?
Illustrator CS2 has a powerful new feature called Live Trace, which enables you to convert 
bitmapped images into vector paths. For detailed information on the Live Trace feature, see 
“Creating Vector Content Using Live Trace” on the Adobe website at www.adobe.com/products/
illustrator/pdfs/creating_vector_content.pdf.

Transparency effects don’t always print reliably from FreeHand. Do these similar effects print 
reliably from Illustrator?
For transparency effects (like blend modes or soft drop shadows) to print to a PostScript device, 
the transparency must be flattened. This process happens automatically when you print your 
file, save it in the EPS format, or export it to any format that doesn’t support transparency. For 
information on how transparency flattening works, see “The Designer’s Guide to Transparency” 
on the Adobe website at www.adobe.com/products/creativesuite/pdfs/dgt.pdf.

I have heard that Illustrator supports metadata. What does that mean?
Metadata is information that describes the content of a document, which can then be used in 
searches. Illustrator has full support for the Extensible Metadata Platform (XMP) standard for 
storing metadata, and such information can be added to a file either using the File Info dialog 
box or Adobe Bridge. For more information on the XMP Metadata standards, please visit the 
Adobe website at www.adobe.com/products/xmp/main.html.

What measurement systems does Illustrator support?
Illustrator supports points, picas, inches, millimeters, centimeters, and pixels.

Terminology differences
Illustrator and FreeHand share many similar functions, but the terminology used for tools, menu 
commands, or functions differs in some cases.

FreeHand Illustrator

Pasteboard Scratch Area

Pages Artboard

Panels Palettes

Object Properties panel Appearance palette

Import Place

Transform handles Bounding box

Keyline view Outline

Extrude tool 3D effects

Live vector effects Effects

Graphic Hose tool Symbol Sprayer tool

Edit text in external editor Edit Original command

Output Area tool Crop Area

Styles Graphic styles

Mixer Color palette

Paste inside Mask

Composite paths Compound paths

http://www.adobe.com/products/illustrator/pdfs/creating_vector_content.pdf
http://www.adobe.com/products/illustrator/pdfs/creating_vector_content.pdf
http://www.adobe.com/products/creativesuite/pdfs/dgt.pdf
http://www.adobe.com/products/xmp/main.html


FOR MORE INFORMATION
For a comprehensive overview of  
Adobe Illustrator CS2, visit the Adobe  
website at www.adobe.com/products/ 
illustrator/main.html.
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Additional resources
For additional information on the topics discussed in this document, see the  
following documents or websites referenced earlier in this article:

FreeHand to Illustrator Migration Guide

Adobe Print Resource Center

Working with Type in Illustrator CS2

Unicode standard

Support for OpenType fonts

Creating Vector Content Using Live Trace

The Designer’s Guide to Transparency

XMP metadata standards

http://www.adobe.com/products/illustrator/main.html
http://www.adobe.com/products/illustrator/main.html
http://www.adobe.com/products/illustrator/pdfs/illcs2ip_fhillmigr.pdf
http://www.adobe.com/studio/print/designer.html#pdfcreation
http://www.adobe.com/products/illustrator/pdfs/Text_in_AICS2.pdf
http://www.unicode.org
http://studio.adobe.com/us/type/main.jsp?xhtml=opentype/main
http://www.adobe.com/products/illustrator/pdfs/creating_vector_content.pdf
http://www.adobe.com/products/creativesuite/pdfs/dgt.pdf
http://www.adobe.com/products/xmp/main.html
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