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Adobe Reader 9.0 
Compatibility Overview 
Updated for Adobe Reader 9.2 

Introduction

There are numerous features in Adobe Reader 9.0 that may be of 
interest to you as you engage in efforts to install and use 
Adobe Reader in the enterprise. These features include 
improvements in the experiences of installing, document viewing, 
performance, security, accessibility, and real-time collaboration. 
There are also changes in Adobe Reader 9.0 of which you should be 
aware. These changes, which occurred since Adobe Reader 8.0, may 
affect workflows used in your company.

Installing Adobe Reader

There are new installation options for Adobe Reader 9.0.

Product Improvement Program

When enabled, the Product Improvement Program will track and 
return data to Adobe. This data is used to help improve the product. 
Please consider enabling this feature for your organization. You can 
control whether this feature is enabled by clicking Help > 
Improvement Program Options.

Customize installer behavior

You can customize the behavior of the installer. 

You can specify whether silent installation takes place, set up pre-
serialization, and specify other custom setup choices. 

You can also customize key application preferences, determine 
whether to enable automatic updates, add and set default job 
options, customize collaboration settings, enable or disable 
advanced security settings, and customize security settings. 

You can prevent the user from modifying certain preferences. You 
can restrict installation to only using an Adobe PDF printer, suppress 
the End User License Agreement and registration, embed license 
management information, opt out of the Product Improvement 
Program, specify shared review settings, and customize the toolbar 
appearance. 

You can also pre-populate PDF Portfolio templates, turn off Hosted or 
Shared workflow settings, specify redaction settings, suppress PDF 
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online creation, and choose supported CAD formats. While AIR and Shared workflow are included in 
the Adobe Reader installation, you will need to determine whether to deploy those components in 
the enterprise. In case you do not want to deploy those components, a version of Adobe Reader that 
excludes them is available for download.

Viewing documents

There are several changes to the user interface for Adobe Reader 9.0.

Next and previous document commands removed

The Next Document and Previous Document commands have been removed from the View > Go To 
menu.

PDF/A, PDF/E, and PDF/X files

When you open a file that is compliant with the PDF/A, PDF/E, or PDF/X standard, a Standards pane 
will opens and provides file details and options.

How To command removed

The Help > How To command, which had provided brief explanations of the usage of tools or how to 
perform specific tasks, has been removed. Use the Adobe Reader Help instead.

Performance improvements

There have been numerous improvements to Adobe Reader performance, including support for 
multi-threading, thereby allowing Adobe Reader to take advantage of environments that have 
multiple processors. Launch times for Adobe Acrobat Professional and Acrobat Standard, 
Adobe Reader, and Adobe LiveCycle LiveCycle Designer ES have been reduced, as have rendering 
times for certain forms.

Plug-ins are now loaded on demand

The launch time for Acrobat and Adobe Reader has been significantly reduced because Adobe plug-
ins are now loaded on demand. However, non-Adobe plug-ins are still loaded as they have been 
before. Note that your plug-in’s handshake and initialization callback procedures can significantly 
affect the product launch time.

Form performance

There have been numerous improvements to the product performance with respect to forms, 
including support for form workflows. 

LiveCycle Designer ES

The launch time of LiveCycle Designer ES from Acrobat has significantly improved.
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Barcoded forms

There have been rendering enhancements in barcoded forms. See Page rendering performance for 
more information.

Adobe Reader Extensions Server

Forms processed with the Adobe Document Server 5.0 for Reader Extensions Server will no longer 
open with Adobe Reader 9.0 and later. Please see your Adobe representative for more information. 
There is also a technical article on this topic in the Adobe developer forum.

Page rendering performance

GPU support for Macintosh is provided in Acrobat and Adobe Reader 9.0 and later. Select 2D 
graphics by clicking Edit > Preferences under the Page Display category.

In Adobe Reader, when viewing documents that are not rights-enabled, if the Paper Metadata 2D 
Barcode-related field changes, the barcode appears dimmed. 

In all cases, barcoded forms now honor language pack checking.

IPv6 support added

Internet Protocol version 6 is now supported in Adobe Reader and Acrobat. Both Adobe Reader and 
Acrobat can run in IPv6 mode, IPv4 mode, or mixed mode networks.

Security enhancements

There are several security-related enhancements to Adobe Reader and Acrobat.

AES 256-bit encryption is supported

Through the File > Properties option, it is now possible to specify an Encryption Level of 256-bit AES 
for both password and certificate security.

Passwords can contain Unicode

Passwords used for document protection can contain Unicode characters.

Importing and exporting security settings

You can now import and export security settings, save them on a server, and load them by 
specifying the URL for the server. You can also use the exported settings to back up and restore your 
settings as needed. An early version of an enhanced security feature has been added to 
Adobe Reader and Acrobat. Although this feature may not be ready for use in all network situations, 
you may want to enable it to improve security in your network. Please report any problems found 
with this feature to Adobe. See Enhanced Security in Adobe Acrobat 9 and Adobe Reader 9 for more 
details.
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Using digital signatures

There have been significant changes to the ways in which the status of digital signatures is displayed 
and verified. See Adobe Acrobat 9 Digital Signatures, Changes and Improvements for more details.

Using forms

Adobe Reader 9.0 - Public keys cannot be embedded in forms for Adobe Reader 9.0, and those 
forms cannot be encrypted. Adobe Acrobat 9.0 removed the ability to embed public keys in PDF 
documents. Adobe Reader 9.0 cannot process forms with embedded public keys that were created 
by earlier versions of Adobe Acrobat.

Adobe Reader 9.1 - Reader 9.1 will now correctly handle and encrypt forms created with embedded 
public keys.

Authentication using proxy servers

Adobe Reader 9.0 and later has improved authentication capabilities when using proxy servers. The 
following tables summarize the differences between Adobe Reader 9.0 with earlier versions.

TABLE 1 Adobe Reader 8.x and earlier

Proxy server In browser Standalone

Non-authenticating proxy Adobe Reader uses the 
operating system’s TCP stack to 
locate the proxy server. The 
proxy server passes the request 
to the intended HTTP address.

Adobe Reader uses the 
operating system’s TCP stack to 
locate the proxy server. The 
proxy server passes the request 
to the intended HTTP address.

Authenticating proxy Adobe Reader uses the 
operating system’s TCP stack to 
locate the proxy server. The 
proxy server requests 
authentication but 
Adobe Reader does not have a 
mechanism to request 
authentication, so the request 
fails.

Adobe Reader uses the 
operating system’s TCP stack to 
locate the proxy server. The 
proxy server requests 
authentication but 
Adobe Reader does not have a 
mechanism to request 
authentication, so the request 
fails.
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TABLE 2 Adobe Reader 9.0 and later

Accessibility support

Data accessibility for forms created in LiveCycle Designer ES is now supported through the Adobe 
Accessibility API.

Real-time collaboration

You can share PDF files on your computer screen and collaborate in a live session with other users. 
You can see who else is working on the document, chat with them, and sync up mouse pointer, 
screen views, page flipping, zoom, 3D views, layers, and other actions within the PDF file in real time. 
All changes are reflected in every participant’s view in real time.

Proxy server In browser Standalone

Non-authenticating proxy Adobe Reader uses the 
browser’s TCP stack to locate 
the proxy server. The proxy 
server passes the request to the 
intended HTTP address.

Adobe Reader uses the 
operating system’s TCP stack to 
locate the proxy server. The 
proxy server passes the request 
to the intended HTTP address.

Authenticating proxy Adobe Reader uses the 
browser’s TCP stack to locate 
the proxy server. 

The browser’s existing 
credentials (basic, digest, or 
certificate) are used to 
authenticate with the proxy 
server for all HTTP requests from 
XFA scripts/actions and for 
JavaScript for Acrobat SOAP 
requests where the 
UsePlatformAuth 
authentication parameter is set 
to true. 

If the browser does not have the 
credentials stored, it will display 
a dialog requesting the 
credentials.

Adobe Reader uses the 
operating system’s TCP stack to 
locate the proxy server. 
Adobe Reader prompts the user 
for a username and password 
for HTTP basic or digest 
authentication. It may prompt 
the user for certificate selection, 
depending on the host 
operating system settings.
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Additional addressed issues 

Forms

xfa.host.getFocus() returns an incorrect SOM expression 

The returned value an incorrect SOM expression. For example, for the form structure: 

form1

  -> sfMain

    -> TextField1

The SOM expression of the object returned from xfa.host.getFocus(), results in:

Page1[0].#contentArea[1].form1[0].sfMain[0].TextField1[0]

The proper SOM expression is:

xfa[0].form[0].form1[0].sfMain[0].TextField1[0]

Recommended action: Form scripts that examine the SOM expression for the object returned by 
getFocus() need examination for possible changed.

Events are missing after double-clicking on an image field 

Double-clicking on an image field does not generate the MouseUp or Click events.  These events are 
now being generated.

Recommended action: Image fields containing scripts on the MouseUp or Click events need 
examination to ensure expected behavior. 

Event ordering between Exit and PrePrint is inconsistent 

The order of the field Exit and Preprint events are different for printing between the Reader menu 
(File->print) and the icon bar.  The order is now consistent in that the exit event always fires before 
the preprint event.

Recommended action: Forms with PrePrint actions need examination for possible conflicts of event 
ordering with Exit scripts.  In general, any side effects of this change are expected to be benign.

SOM expressions accessing the form incorrectly now failing in Acrobat/Reader 9.0 

A SOM expression such as "xfa.form1.nodes.length" which worked in previous versions of Reader 
now fails in Reader 9.0.  This is an invalid SOM expression. The correct SOM expression is 
"xfa.form.form1.nodes.length". 

Recommended action: Forms that contain SOM expressions of this type need correction.

Change in behavior (output) of saveXML function 

In Reader 9.0 and 9.1 the SaveXML function on a template node no longer returns the results as it 
should.  The SaveXML function on data nodes is not affected by this problem.

Recommended action: This is an issue with the XFA forms processing it should not affect most 
forms.
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setItemState method does not work as expected a multi select list box within a table, 
and with direct rendering OFF. 

When using the setItemState method on a multi-select list box inside a table, the items are not 
selected.  This worked in Reader 8 but does not work in Reader 9.

Recommended action: For this functionality, enable direct rendering.

Forms containing the new USPS barcode crash Reader 9.0 on Mac only 

LiveCycle ES 2 implements a new barcode type for the US Postal Service.   Forms containing this 
barcode will fail in Reader 9.0 on Macintosh.  The forms do not fail in Reader 8.1.3 or 9.1.  The forms 
work as expected all Reader versions on all other platforms.

Recommended action: Upgrade to Reader 9.1.

XFA Forms containing empty values for numeric fields, signed in Acrobat/Reader 6 
and viewed in Acrobat/Reader 8 or later may show "miscellaneous change" 
when no change has occurred.

The processing of empty fields changed between Reader 6 and Reader 8.  This results in a form with 
signature status as "valid" in Reader 6 while the result in when viewed in Reader 9 shows a "changed" 
state with a "miscellaneous change".

Recommended action: If a form that has not changed shows a "miscellaneous change" in a later 
version of Reader, review the form in Reader 6 to ensure the Signature is correct.

Opening a form designed for Reader 9.1 in Reader 9.0 results in an error message

A form designed for use in Reader 9.1 has XFA version 3.0. Opening this form in Reader 9.0 results in 
a “Unrecognized namespace XFA 3.0, defaulting to XFA 2.8” message.

Recommended action: Upgrade to Reader 9.1.

Printing

Color Postscript printing from Reader has a slightly different color map in Reader 9 
compared to Reader 8 

In Reader 9, the color mapping from RGB to CMYK has changed to produce better results.  For some 
printers the results are not as expected.

Recommended action: Select a non-Postscript printer or change to color space of the original 
document to CMYK.

PDF/A

PDF/A conversion using Acrobat does not work as expected.

Converting a PDF file to a PDF/A using Acrobat may work as expected. You may also have questions 
regarding PDF/A compliance checking. 

Recommended action:

• Refer to the "PDF/A in Acrobat and LiveCycle" document for a details on this topic.
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• Generate PDF/A directly instead of generating a PDF and then convert it to PDF/A.
• Use the latest version of Acrobat for PDF/A conversion or validation.  Acrobat 9.1 contains many 

improvements in this area.
• The PDF/A standard requires that PDF/A files be viewed with a compliant Reader. The first 

Reader to be compliant is Reader 9.0. Therefore, always use Reader version 9.0 or later for 
viewing PDF/A.

Installing

Installing the Reader Language Pack into Reader 9.1 takes longer than expected.

The language pack installs quickly in Reader 9.0. Installing the language pack in Reader 9.1 takes 
significantly more time. This is caused by a design limitation in the updater. Once the language pack 
is installed, there is no performance impact.

Recommended action: Enterprises who wish to avoid this problem should install the Language 
Pack on Reader 9.0 before updating to Reader 9.1.

Rights Management

Unable to open existing protected document after an upgrade of Acrobat to 9.1 
using Kerberos SSO or anonymous authentications

Customers who upgrade their version of Acrobat to 9.1 using Kerberos SSO or anonymous 
authentication, on any release of LiveCycle Rights Management or Adobe Policy Server with no 
explicit URL port set, will not be able to open existing protected documents.

This problem affects any server that was configured without explicitly setting the HTTP port number 
in the baseURL. Adobe documentation suggests the system administrator specify the port number. 
Since customers enter HTTPS as the URL prefix, Acrobat defaults to 443 if the URL is not explicitly 
specified. Adding the baseURL port will work for any new documents, but existing documents will 
still have problems as the baseURL and port is included in the document at the time it was 
protected.

This issue does not affect Reader, only Acrobat 9.1

Recommended action: This issue has been addressed in the 9.1.1 patch for Acrobat. Users can work 
around the problem by opening the document in Reader 9.1 or by upgrading their Acrobat 9.1 
installation.

Users cannot add comments to a Rights Managed documents that are Reader 
Extended

Starting with Reader 9.1, users are unable to add comments to PDF files that are both policy-
protected and Reader Extended. This inadvertent change was introduced as a result of some security 
fixes.

Recommended action: Adobe intends to fix this issue in a later update to Reader 9.
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Users may be unable to access the rights Management server through a firewall or 
proxy server

Reader (and Acrobat) 9.1 implemented some new capabilities in preparation for an upcoming 
LiveCycle product release. A number of new URLs on the RM server may be accessed by Reader. If 
the proxy or firewall blocks access to these URLs in such a way as an HTTP error code other than 
"404" is returned, Reader may fail to access the server.

Recommended action: Firewalls or proxy servers should be configured in such a way as to return 
error 404 for the list of URL's below. An alternative is to open the Firewall or proxy server to pass 
these URLs to the Rights Management server and allow it to return the 404 error code.

List of URL extensions to be also opened.

/rmws/rest/secure/server/info
/rmws/rest/secure/authentication/login
/rmws/rest/secure/authentication/user
/rmws/rest/secure/authentication/sso
/rmws/rest/secure/license/consume
/rmws/rest/secure/license/batch
/rmws/rest/secure/events/audit
/rmws/rest/secure/license/iterate
/rmws/rest/secure/license/publishAs
/rmws/rest/secure/offline/synchronize

This issue exists in Reader 9.1 and 9.1.1 only. It is fixed in Reader 9.1.2.

AIR

AIR applications are unable to load a PDF using Reader 9.2

AIR applications that load a PDF in the broswer will no longer work with Adobe Reader 9.2.

Recommended action: This issue will be addressed in an upcoming patch release to Reader. For 
enterprises which can control the deployment of Reader, a hotfix is available from Adobe Support. 

Copyright 2009 Adobe Systems, Incorporated. All rights reserved.
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