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Using the Pattern Stamp tool 

With the Pattern Stamp tool, you can paint patterns onto an image, choosing from a variety of patterns. 

To use the Pattern Stamp tool: 

1. Click the Clone Stamp tool and hold down the mouse 
button to open the Pattern Stamp tool (Figure 10). 

 Observe that the options bar appears slightly different 
than it does for the Brush tool (Figure 11).  

 To the right of the Flow field is the Pattern picker.  

2. Select a pattern from the Pattern picker. 

3. Select the Aligned option to keep the pattern aligned 
with your original starting point. 

 Otherwise, the pattern starts anew each time you lift the 
pointer. 

4. Leave the Impressionist option deselected. 

 With this option on, the pattern appears in blocks of 
color. 

5. Drag on the image to draw with the Pattern Stamp tool 
(Figure 12) 

 
Figure 10 Pattern Stamp tool 

 

Figure 11 Pattern Stamp tool options 

 

 
Figure 12 Painting with the Pattern Stamp tool 
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How to draw shapes 
In addition to its photo-editing features, Adobe Photoshop CS3 has a full suite of drawing tools. This guide teaches 
you to draw shapes in Photoshop. If you’ve used other drawing tools, such as Adobe Illustrator, you will see that 
Photoshop’s approach to drawing is slightly different. Everything in Photoshop is based on the idea of film 
exposure, of letting light show through rather than placing things onto a canvas. 

Photoshop uses both bitmapped and vector images. Bitmapped images are made up of individual pixels and do not 
scale well; vector images are constructed from mathematical formulas and scale very well. 

Types of shapes 
This guide addresses adding shapes as shape layers, which gives you the most flexibility in determining how your 
shapes appear. However, adding shapes as separate layers adds to your image’s file size and may eventually affect 
Photoshop’s speed. Shape layers are added as vector masks—that is, they are vector shapes through which only part 
of the background shows. 

If you’re creating very simple shapes that do not need to be scaled, you can create bitmaps by using the Fill Pixels 
option. This option creates shapes that are rasterized or created from individual pixels. Because Fill Pixels shapes 
don’t require additional layers, they can improve performance. 

You set shape options in the Shape options bar (Figure 1). 
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shape (polygon)

Color for shape 
layer background

Style for shape 
layer background Shape layer  

 
 

 

 

Figure 1 Shape options bar 

Drawing shape layers 
Shape layers are essentially vector masks that hide a background. They consist of two parts: a mask and a 
background color. 

Shape layers offer the most flexibility in determining a shape’s appearance, position, and visibility. Because the 
shape masks are vector shapes, you can transform these shapes without loss of clarity. 

To draw a shape in a shape layer: 

1. Start Photoshop and create a new file. 

2. Click one of the shape tools in the Tools palette, such as 
the Polygon tool. 

 Shape tools are located between the Notes tool and the 
Path selection tool. By default, the Tools palette shows 
the Rectangle tool. To access other shapes, click and 
hold on the Rectangle tool (Figure 2). 

 

 
Figure 2 Shape tools in the Tools palette 
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3. In the options bar (Figure 1), make sure Shape Layers 
and Create New Shape Layer are selected. 

4. In the color picker, choose a color for the layer 
background. 

5. From the Custom Shape Tool pop-up menu, select 
options for the shape you chose. 

 In Figure 3, the polygon is set to Star, leaving the 
Indent Sides By setting at its default of 50%. 

5. Draw the shape by dragging the pointer across the 
canvas (Figure 4). 

6. If  the Layers palette is not already visible, choose 
Window > Layers. 

 Observe that the shape is on a separate layer with the 
default name of Shape 1 (Figure 5). The link icon 
between the shape and fill indicates the two are linked. 

7. Double-click the fill thumbnail. 

 The color picker appears (Figure 6). 

8. Pick a new color for the shape’s fill. 

9. Click OK to apply the color and close the color picker. 

 
Figure 3 Polygon options pop-up menu 

 

 
Figure 4 Shape appearance as you draw it 

 

 
 

Figure 5 Shape layer in Layers palette 

 

Figure 6 Color picker 
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Adjusting a shape’s path 

A path is the edge of a vector shape. By changing the path, you change the appearance of the vector mask and thus 
the appearance of the shape. One way to change the shape’s path is by moving one of its anchor points. Anchor 
points appear at the shape’s corners. 

To adjust a shape’s path: 

1. Click and hold on the Path Selection tool and select the 
Direct Selection tool (Figure 7). 

2. Click the edge of the shape to select its path. 

 Anchor points—small hollow squares—appear at the 
corners of the shape (Figure 7). 

3. Move the pointer over an anchor point. 

4. Click to select the anchor point. 

 Observe that the anchor point changes from a hollow 
square to a solid square when you select it. 

5. Drag to change the shape (Figure 8). 

 In Figure 8, the left corner of the square has been 
moved up by dragging its anchor point. 

 

 
 

Figure 7 Moving a point with the Direct Selection 
tool 

 

 
Figure 8 Path change completed 

Adding to and subtracting from shape areas 

You can add to and subtract from a shape layer to show more or less of the background. You set add and subtract 
options in the Shape options bar. 

 
 

 

 

Figure 9 Shape options bar 

Create new shape area: Create a new shape layer. 

Add to shape area: Add to the existing shape. 

Subtract from shape area: Subtract from the existing shape. You will only observe the effect of subtracting if you 
draw over an existing shape. 

Intersect shape areas: Show only those areas where the last two shapes drawn intersect. 

Exclude intersecting shape areas: Show all parts of a shape except where the last two drawn shapes intersect. 
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To add to a shape layer: 

1. Click the shape thumbnail to select the shape. 

2. Select a shape tool, such as the Ellipse tool. 

3. Click the Add To Shape Area icon in the Shape options 
bar (Figure 9). 

4. Draw a shape that adds to the image (Figure 10). 

 Observe that the new shape appears in the shape layer 
(Figure 10). 

Figure 10 Adding to a shape layer 

To subtract from a shape layer: 

1. Click the mask thumbnail to select the shape. 

2. Select a shape tool, such as the Ellipse tool. 

3. Click the Subtract From Shape Area icon in the Shape 
options bar (Figure 9). 

4. Draw a shape that overlaps the image (Figure 11). 

 Observe that the shape has been modified in the shape 
layer (Figure 11). 

Figure 11 Subtracting from a shape layer 

Controlling shape appearance with layer styles 
Because shapes are on a layer, you can change their appearance by using layer styles. You can add a drop shadow to 
the shape, make the shape appear embossed or beveled, or outline the shape with a stroke. 

To modify a shape by using layer styles: 

1. If it is not already visible, choose Window > Layers to 
open the Layers palette. 

2. Double-click the shape’s layer to open the Layer Style 
dialog box (Figure 12). 

3. One of the simplest things you can do is apply a stroke 
or outline to the shape. Select the Stroke option to apply 
a stroke. Make sure the Preview option is selected so 
you can observe the effects of applying the stroke. 

4. Now, set options for the stroke by clicking the word 
itself. You can set the size, position, blend mode, 
opacity, fill type, and color of the stroke. 

 

Figure 12 Layer Style dialog box 
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5. Click OK to apply the stroke (Figure 13). 

6. Apply one or more additional layer styles to the shape. 

 Figure 14 shows the shape with the Bevel style, to give 
the shape a slightly raised appearance, and the Drop 
Shadow style, to make the shape appear slightly above 
the page. 

 Note: You can apply layer styles to rasterized shapes as 
well. However, the advantage with shapes on shape 
layers is that you can resize them without loss of 
resolution. 

 
Figure 13 Stroke applied 

 

 
Figure 14 Bevel and Drop Shadow applied 
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Bitmap and vector images 
Adobe Photoshop CS3 uses two different types of images, bitmap and vector. 

Bitmap images (also called raster images) combine different-colored pixels to make the image. When you create 
bitmaps, you (using your graphics program) essentially decide the color for each pixel. Graphics and photographs 
saved as GIFs or JPEGs are bitmapped formats. Because bitmaps assign colors pixel by pixel, they are very good at 
representing gradations of shade and color. If you import a GIF or JPEG, it will remain bitmapped in Adobe 
Photoshop CS3. 

Bitmap images are resolution-dependent. This means the size and quality of the image depends on the number of 
pixels per inch in the image. Images saved for on-screen display have a resolution of 72 pixels per inch because 
that’s all most monitors can handle. Images saved for print should have at least 300 pixels per inch. 

In contrast to bitmaps, vector images are not created pixel by pixel. Instead, vector graphics make use of 
mathematical equations to calculate a line’s shape. These equations are stored in the image and determine the 
image’s dimensions, color, shape, and thickness. The actual shape is rendered (or drawn) on the screen at view time. 

Because they use equations and not pixels, vector images are not resolution-dependent. As a result, vector images 
are great for illustrations and logos that need to be scaled to different sizes. When you import images from Adobe 
Illustrator, these are generally vector images. You also create vector images in Photoshop when you draw shapes on 
shape layers. 

Scaled bitmap and vector images 
Because bitmaps are composed of individual pixels, they tend to scale poorly. That is, when you try to increase their 
size, their edges become blurry, as is evident in Figure 1. 

 
Figure 1 Bitmapped image scaled 

 

Vector images, on the other hand, scale well, because they rely on mathematical equations to determine their 
appearance (Figure 2). 

 
Figure 2 Vector image scaled 
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How to add text to images 
In Adobe Photoshop CS3 Extended, you add text directly to an image. As with shapes, you add text in its own layer, 
which is named after the first few words of your text. Once you add text, you can modify it by using the Character 
and Paragraph palettes, by transforming the text box, and by applying layer styles to the text’s layer. 

 

 

 

  

 

Figure 1 Text options bar 

Adding text to an image 

1. Start Photoshop and open an image. 

2. Select the Text tool. 

3. In the Text options bar, set a font family, font style, size, 
alignment, and color for the text (Figure 1). 

 Note: When you’re working with a font on-screen, you 
may observe that it seems smaller or larger than its point 
size. This is because the on-screen appearance of fonts 
depends on the document size and magnification. To see 
the font sized as it will appear when printed, choose 
View > Print Size. 

4. Select an anti-aliasing mode from the Anti-aliasing pop-
up menu. 

5. Drag on the image to draw a text box (Figure 2). When 
you are satisfied with the size of the box, release the 
mouse. 

6. Click in the text box you’ve created and type to add text 
(Figure 3). 

 
Figure 2 Drawing a text box 

 

 
Figure 3 Text box with text added 
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Modifying text by using the Character and Paragraph palettes 
You can change textual characteristics through the Character and Paragraph palettes. These options are similar to 
those found in many word-processing and layout applications. 

Modifying text by using the Character palette 

To set an option in the Character palette, you first open the palette and select the text you want to change. For each 
option in the palette, choose a value from the pop-up menu (Figure 4) or type a value. When you type a value 
directly, press Enter (Windows) or Return (Mac OS) to apply it. 

 

 

Leading 
 

 
Horizontal scale 

 Font color 
Vertical scale 
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Font size 

g Tracking 

All caps 

Small caps 
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Figure 4 Character palette options 

The options in the Character palette include the following: 

Font size: Depends on document size. You set this in points. 

Leading: Space between lines. You set leading in points. 

Tracking: Space between characters. You set tracking in points. You can also fine-tune the space between any two 
characters by selecting them and adjusting kerning. Usually you only need to adjust kerning for large font sizes—at 
least 16 points. 

Horizontal scale: Height of the letters. You set this as a percentage. 

Vertical scale: Width of the letters. You set this as a percentage. 
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Anti-aliasing 

Anti-aliasing produces smooth-edged type by partially filling the edge pixels so the edges of the type blend into the 
background. For print jobs, you will generally want to apply anti-aliasing to your text, especially for larger text. For 
smaller text or for web images, you may want to leave anti-aliasing turned off. 

Note: When you use anti-aliasing, type may be rendered inconsistently at small sizes and low resolutions (such as 
the resolution used for web graphics). To reduce this inconsistency, deselect the Fractional Width option in the 
Character palette menu. 

• None: Applies no anti-aliasing. 

• Sharp: Type appears at its sharpest. (This option is set by default.) 

• Crisp: Type appears somewhat sharp. 

• Strong: Type appears heavier. 

• Smooth: Type appears smoother. 

To modify text by using the Character palette: 

1. Choose Window > Character. If this option is not 
available, first choose Window >Show All Menu Items.

 The Character palette appears (Figure 5). 

2. Apply changes to the text. 

 In Figure 5, for example, the following changes have 
been applied: 

• Font size set to 14 pt. 

• Leading set to 20 pt. 

• Font color set to dark red. 

• Horizontal scale set to 80%. 

Figure 5 Character palette 

Modifying text by using the Paragraph palette 

You can make further changes to the text in the Paragraph palette. Most importantly, you can change the text’s 
alignment—whether the text lines up with the right, left, or center of the text box. You can also justify the text. 
Justification means spacing the text so it meets both margins. 

To modify text by using the Paragraph palette: 

1. Choose Window > Paragraph. If this option is not 
available, first choose Window >Show All Menu Items.

 The Paragraph palette appears (Figure 6). 

2. Apply changes to the text. 

 In Figure 6, for example, the text has been aligned with 
the right side of the text box. Figure 6 Paragraph palette 
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Transforming a text box 
As with most objects in Photoshop, you can transform text boxes. After you apply transformations, the text remains 
editable. 

To transform a text box: 

1. Choose Edit > Free Transform. 

2. Drag a transform control to change the shape of the text 
box. 

3. Move the pointer over the corner of the text box until the 
pointer changes into a rotation tool (Figure 7). 

4. Drag the rotation tool to rotate the text box (Figure 7). 

5. Choose the Text tool in the Tools palette. 

6. A message appears asking if you want to apply the 
transformation. Click Yes. 

7. Click in the text box. 

 Observe that the text remains editable even while 
rotated. If you resize the text box vertically, the font size 
changes accordingly. 

 
 

Figure 7 Transforming a text box 

Rotation pointer 

Warping text 
You can also curve, or warp, text by using the Create Warped Text option. 

1. Select the text you wish to warp. 

2. Click the Create Warped Text option in the Text options 
bar. 

 The Warp Text dialog box appears (Figure 8). 

3. Select a style, such as Arch. 

4. Choose Horizontal or Vertical to determine a direction 
for the warp. 

5. Select a degree of bend for the warp. 

6. Leave Horizontal Distortion and Vertical Distortion at 0.

 These settings let you create asymmetrical warps in 
either a horizontal or vertical direction. You can 
experiment with these settings later, but for now, keep 
the warp straightforward. 

7. Click OK to apply the warp (Figure 9). 

 
Figure 8 Warp Text dialog box 

 

 
Figure 9 Text with Arch warp applied 
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Modifying text by using layer styles 
Because text is added to its own layer, you can also change the appearance of text by using layer styles. You can add 
a drop shadow to the text, make the text appear embossed or beveled, or outline each letter with a stroke. 

To modify text by using layer styles: 

1. If  the Layers palette is not already visible, choose 
Window > Layers. 

2. Double-click the text layer to open the Layer Style 
dialog box (Figure 10). 

 Layer styles appear in a column to the left. To apply a 
style, check its box. You can also modify a style by 
clicking its name. 

3. Apply one or more layer styles to the text. Bevel style 
and Drop Shadow style have been applied to the text in 
Figure 11. 

 Bevel style gives the text a slightly raised appearance, 
and Drop Shadow style makes the text appear to float 
slightly above the page.  

Figure 10 Layer Style dialog box 

 

 
Figure 11 Layer effects applied to text 

Click a style’s name to 
modify options for it 

Check boxes 
to apply styles

 

© 2007 Adobe Systems Incorporated How to add text to images 5 



Adobe Photoshop CS3 Extended Project 1 guide 

How to generate different file formats 
Different mediums—print and web—require different file formats. This guide describes how to generate appropriate 
file formats for both the web and print by using Adobe Photoshop CS3. 

When generating any image in Photoshop, it’s important to remember that when you save an image, Photoshop 
saves the image as it appears onscreen. That is, if you have hidden some layers, they will not appear in the saved 
image. 

Saving files for the web 
For web pages, you will generally want to save photos in JPEG format. JPEG is used more than any other format for 
photos on web pages. (Other web formats include GIF—usually used for images with limited colors—and PNG—a 
less often used, but flexible format.) 

JPEG is popular because it compresses well—that is, you can make files smaller without sacrificing quality. 
However, if you compress too much, file quality will suffer; the trick is to find the right balance between image 
quality and compression. 

Photoshop makes this process easier through a command called Save For Web & Devices. You can use Save For 
Web & Devices to preview JPEGs with different compression settings before you save them. 

Note: When you save a file for the web, it appears at its full pixel size. The document size does not affect how the 
image appears in a browser. For example, an image whose pixel size is 640 x 480 displays at that size in a browser. 
The document size affects only how the image prints. 

To save a file as a JPEG: 

1. Start Photoshop and open an image. 

2. Choose File > Save For Web & Devices. 

 The Save For Web & Devices dialog box appears 
(Figure 1). 

3. Click the 2-Up tab to display both the original and a 
preview of the file to be saved. 

Figure 1 Save For Web & Devices dialog box 
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4. In the Optimized File Format pop-up menu, choose 
JPEG (Figure 2). 

5. Adjust quality by using either the Compression Quality 
pop-up menu or the Quality slider (Figure 2). 

 As you change settings, observe how the photo to the 
right appears. 

6. When you are satisfied, click Save. 

 Clicking Save automatically saves a copy of the image 
as a JPEG with the settings you indicated. The original 
image is left unchanged. For working purposes, you may 
want to incorporate some of the settings into the 
filename, such as “banner_high.jpg” for an image saved 
as a high-quality JPEG. 

 After you save, the original file stays open in Photoshop.

Note: If the original image is also a JPEG (many digital 
cameras use JPEG as a format), you need to save the 
copy in a different location from the original (or give it a 
different name) to avoid confusion. 

 
 Optimized File 
 

Figure 2 Save for web settings 

Quality 
slider

Compression 
Quality pop-up 
menu

pop-up menu

Generating files for print 
Generating files for print use is different from saving images for the web: you use an uncompressed file format and 
you must be sure the file is at a high enough resolution (preferably 300 ppi) before you save it. It is always good to 
import the image into Photoshop at the highest possible resolution to give more flexibility in the kinds of images you 
can generate. 

Note: You can print to a printer directly from any computer running Photoshop. The options described here are for 
sending an image to a printer, to another computer to be printed, or to another application. 

Generating files for print involves three steps: 

1. Setting the image resolution to 300 ppi. 

2. Converting the image to CMYK (if the image is going to an offset print vendor). 

3. Generating a print-friendly (compression-free or lossless) format, such as TIFF. 
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Setting resolution to 300 ppi 

1. Open an image in Photoshop. 

2. Choose Image > Image Size. 

 The Image Size dialog box appears (Figure 3). 

3. Make sure the Resample Image option is not selected. 

 When you leave this option unselected, you ensure that 
you’re only changing the image’s resolution, not 
removing or adding pixels. 

4. Enter 300 in the Resolution text box. 

 Make sure pixels/inch is selected as the units for 
Resolution. 

5. Click OK. 

Figure 3 Image Size dialog box 

To preview an image at the size it will appear when printed, choose View > Print Size (you may need to first select 
View > Show All Menu Items). 

Converting images to CMYK 

Computers use combinations of red, green, and blue (RGB) to display photos. Offset printing presses print full-color 
photos, using cyan (blue), magenta (red), yellow, and black. This is known as CMYK printing. If you are printing to 
an inkjet printer, you can leave the image in RGB mode, but if you are sending the image to an offset print vendor, 
you need to convert the image to CMYK. 

To view how the image will appear in CMYK, choose View > Proof Setup > Working CMYK. (For some images, 
you may not observe any difference at all.) This preview is called a soft proof. 

Note: Soft proofs are approximations. What you see onscreen depends on the quality and settings of your monitor as 
well as the lighting conditions of your work environment. You may observe different results when you actually 
print. Nevertheless, soft proofs can be useful. 

Photoshop also lets you preview how the image will appear on a range of different printers, including most Epson 
models and offset printing. To view these, choose View > Proof Setup > Custom. 

To convert the image to CMYK: 

1. Save a copy of the image. 

2. Choose Image > Mode > CMYK Color. 

3. If the image has layers, Photoshop asks whether you 
wish to flatten these. Click Yes. 

 (Because you saved a copy of the file, you can open the 
saved copy to recover the layers.) 
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Generating TIFFs 

After you convert the image to CMYK and make sure it is at the correct resolution, you can save it in a print-
friendly format (a format with no compression, known as a lossless format). In this exercise, you will choose the 
TIFF format. 

Note: Although TIFF is the most common lossless image format, you can also use EPS or an Adobe PDF. 

1. Choose File > Save As. 

 The Save As dialog box appears (Figure 4). 

2. In the Format box, choose TIFF (*.TIF, *.TIFF). 

3. Click Save.  

 The TIFF Options dialog box appears (Figure 5). 

4. Because the image is going to a printer, you do not need 
to compress it. Leave Compression set to None. Leave 
Pixel Order set to Interleaved. 

 Note: In practice, TIFF files are seldom compressed. 

5. Set Byte Order to your operating system (Windows or 
Mac OS).  

6. Because the image is going to a printer, you also don’t 
need to save the layers. Make sure Discard Layers And 
Save A Copy is selected. This option flattens the layers 
in the image. 

7. Click OK.  

Figure 4 Save As dialog box (Windows) 

 

 
Figure 5 TIFF Options dialog box 

Format pop-up menu
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