Accessibility
Adobe
Identification Politique de confidentialité Mon Adobe

Compatibilité J2EE 1.3

Java Compatible Enterprise Edition

Macromedia JRun 4 est pleinement compatible avec J2EE 1.3. Exploitez les spécifications des API Java les plus récentes – telles que JSP 1.2, Servlet 2.3, EJB 2.0, etc. – pour créer et exécuter vos applications. Cette nouvelle version supporte les spécifications de services web les plus récentes – SOAP 1.1, UDDI 1.0, production WSDL automatique et JAX-RPC.


Support

Macromedia JRun supporte les API J2EE 1.3 les plus récentes :

  • JSP 1.2
  • JDBC 2.0
  • JNDI 1.2
  • JAAS 1.0
  • JAXP 1.1
  • Servlet 2.3
  • JTA 1.0.1
  • Java RMI 1.0
  • JavaMail 1.1
  • EJB 2.0
  • JMS 1.0.2
  • RMI/IIOP 1.0
  • JMX 1.0

Puissant

  • Gestion de clustering JINI pour les connecteurs web, et mécanismes d’équilibrage de charge et de reprise sur incident des composants
  • Support des services web avec SOAP 1.1, production WSDL automatique, UDDI 1.0 et JAX-RPC
  • Interopérabilité avec Macromedia Flash MX pour la connectivité avec les interfaces utilisateur des applications dynamiques
  • Nouvelle architecture avec des services modulaires pour une meilleure souplesse et une plus grande facilité de personnalisation

Productif

  • Nouvelles fonctions de publication par glisser-déposer et équilibrage dynamique de la charge
  • Intégration XDoclet facilitant le développement de servlets et beans EJB
  • Meilleure administration et gestion basée sur JMX, simplifiant les tâches les plus communes
  • Nouveau système d’aide en ligne intégré