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Photoshop

Windows only: Can I install my new Adobe Photoshop 5.5 

upgrade into the same folder as 5.0.2? I have tons of third-

party plug-ins that I don’t want to reinstall. 

Not a good idea, at least for an upgrade like the Photo-

shop 5.5 release. If you were installing an update, it would 

be okay. A Photoshop upgrade (a full release of the applica-

tion) includes signifi cant new features, is self-contained, and 

should always be installed to a fresh folder on your hard disk. 

Updates (such as Photoshop version 5.0.2) are a different 

story—they enhance the current program or make minor 

fi xes by overwriting a few existing fi les. (An update may 

come to you in the form of a “patch”—an executable fi le or 

installer that updates your current version, say, from 5.0 to 

5.0.2. If you install an update, you’ll be prompted to specify 

the folder in which Photoshop currently resides; the installer 

overwrites only the fi les it needs to, and leaves others alone.)

If you install the Photoshop 5.5 upgrade into the same 

folder as a previous version of the program, you may not im-

mediately experience problems. However, some customers 

have reported errors after this type of installation, such as 

“Could not initialize Photoshop because of a disk error” 

when launching. So even if you experience no problems at 

fi rst, note that overwriting older fi les with those from an up-

grade may lead to problems down the road.

If you’ve already installed Photoshop 5.5 on top of your 

previous version, we recommend using the Add/Remove Pro-

grams Control Panel to remove Photoshop 5.5 and then rein-

stalling it to a unique folder. In the process of reinstalling, if 

you’re using an upgrade CD, you may encounter a “proof of 

ownership” dialog box asking you to verify your original pro-

gram. If the installer can’t fi nd an earlier version of Photo-

shop, you can verify it off the media of your original program 

(the installer will guide you through this easy process). After 

your new installation is successfully completed, you can unin-

stall your previous version to free up disk space.

And yes, even if you installed to a separate folder, you’ll 

still need to do a bit of work with your plug-ins in order to 

access them from Photoshop 5.5. (In other words, don’t just 

copy the entire Plug-ins folder from the previous version of 

Photoshop to your new Photoshop 5.5 folder or retarget the 

Photoshop plug-ins preferences to the old folder—that may 

result in various errors, double listings, or limited access to 

plug-ins.) All plug-ins included with Photoshop (or whatever 

plug-ins you opt to install in a custom installation) will be au-

tomatically installed in the right location for Photoshop 5.5, 

and you’ll need to copy or reinstall your third-party plug-ins 

to Photoshop 5.5’s Plug-ins folder. Before doing so, contact 

the plug-in developers to make sure the versions you own 

are compatible with Photoshop 5.5.

Can I scan a color negative straight into Photoshop and then convert 

the image to a color positive on screen? When I use Photoshop’s Invert 

command, it just doesn’t seem to do the color any justice. Is there a 

better way to do it? 

We’ve consulted our experts, and the general consensus is that you 

should, if possible, let your scanner do the color inversion for you. We 

know that’s not always possible, and that there are other ways to in-

vert the colors; everyone has a favorite. The best we can do is to pro-

vide you with some background information on inversions, tell you a bit 

about the techniques, and encourage you to make educated decisions or at 

least experiment with the different methods.

You’re correct in realizing that a simple inversion of the negative doesn’t 

give you accurate color. The problem is caused by the orange mask on the 

negative fi lm. In the traditional photographic process, color negative fi lm is 

for making color prints. The mask is necessary in the printing process, both 

to compensate for impure dyes in the cyan and magenta layers of the nega-

tive and to assist in properly exposing the three layers of emulsion (cyan, 

yellow, and magenta). Without the mask, colors can bleed in the print.

When scanning negatives for digital retouching, you’ve got to remove 

the orange mask before going to positive; otherwise you can get incorrect 

color and tones in the resulting image when you invert it. If you apply Photo-

shop’s Invert command on a co lor negative without any correction, it will 

invert the orange, thereby creating a bluish cast on the positive image. You 

can compensate for this to some degree by using Photoshop’s tonal and 

color-cor  rec tion tools, but 

this tech nique isn’t 100 per-

cent accurate, because the 

orange mask isn’t consistent 

across the negative.

Ideally, you want your 

scanner’s software to perform the inversion. Good fi lm-

scanning soft  ware contains algorithms for removing the or-

ange mask and converting the image to a positive. The hue 

and density of the orange mask can vary among fi lms; some 

scanning software gives you the option to target specifi c 

brands of fi lm for more accurate scans. 

In case you’re not aware of this, in order to scan fi lm (as 

opposed to refl ective art like prints or drawings) on a fl atbed 

scanner, you must have a transparency adapter—an over-

head light source that projects light through the fi lm from 

above rather than refl ecting it from below. The software for 

a scanner with this adapter will let you choose between scan-

ning transmissive and refl ective images. It should also have a 

separate setting for color negative fi lm and for color trans-

parency fi lm. Older scanners may not have these abilities.

If your scanner cannot correctly invert a color negative, 

you may want to consider other ways to get satisfactory in-

versions, such as a third-party plug-in like Cytopia’s Negative 

Filter, which will help properly compensate for the orange 

mask. This fi lter is part of the Cytopia PhotoOptics set avail-

able at www.cytopia.com. Or get your negatives developed 

at a lab that will scan your images onto a Kodak PhotoCD. 

Select the type of image that you’re 

scanning, not the type you want it 

to become. In most scanning soft-

ware, the preview will refl ect the 

change it’s going to make.
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One of my customers sent me a grayscale image that he 

wants made into a duotone. He also sent me “Duo” and 

“Trans” fi les (that’s what their icons say). What’s the differ-

ence, and which one should I use?

Your customer is playing it safe by including the two fi les, 

but you really need just the “Duo” fi le. The Trans fi le is the 

transfer curve saved for an individual duotone ink. (To create 

such a fi le, choose Image > Mode > Duotone to open the Du-

otone Options dialog box, click on any of the curves that ap-

pear to the left of their corresponding inks, and then click 

Save in the Duotone Curves dialog box). The Duo fi le is the 

combination of all information (such as specifi c ink colors, ink 

curves, and overprint colors) for the entire image—you can 

create this fi le by clicking Save in the Duotone Options dialog 

box. The Duo fi le includes all necessary data for your image; 

the Trans fi le in this case would be redundant.

By the way, in Windows, you’d recognize duotone and 

transfer fi les by their .ado and .atf extensions respectively. 

To apply a saved duotone fi le to another grayscale image, 

take the following steps:

1. With the original grayscale image open, choose Image > 

Mode > Duotone.

2. Click Load, and then locate and load the Duo (.ado) fi le.

3. Click OK.

Macintosh only: None of my thumbnail previews appear in 

Photoshop’s Open dialog box anymore. I’m having a devil of 

a time distinguishing among the thousands of fi les I’ve ac-

cumulated. What happened?

There are a few things that could have changed on your 

system to cause this. 

First, you may have installed QuickTime 4 using the mini-

mum installation, which doesn’t add the necessary fi les for 

displaying previews—including the QuickTime Authoring ex-

tension. Use a full or custom installation of QuickTime 4 to 

regain this functionality. Further, note that QuickTime 4 was 

originally released as a public beta. While that is not neces-

sarily the cause of your problem, it’s a good idea to get the 

latest release, now that it’s available. If you think you may be 

using a beta, download the full, up-to-date QuickTime in-

staller from www.apple.com/quicktime. Remove your exist-

ing QuickTime (performing a custom install gives you the 

“uninstall” option), and then install the latest version using 

the full install option.

Second, Photoshop’s Image 

Pre view option may have been 

disabled. Check this by doing 

the following: 

1. Choose File > Preferences > 

Saving Files.

2. From the Image Previews 

pop-up menu, choose 

Always Save.

3. Click OK.

Third, if you see just a few thumbnails missing, you may have 

changed your Saving Files Preferences from Always Save to 

Ask When Saving. If you want to be able to select, on the fl y, 

whether each image gets a preview, leave this option as is. If 

you do so, be sure to select the Macintosh Thumbnail option 

under Image Previews in the Save As dialog box every time 

you want a preview.

Finally, extension confl icts or damaged application or sys-

tem software may also prevent Photoshop from displaying 

thumbnail previews in the Open dialog box. For more infor-

mation on troubleshooting your system software, please see 

“How to Troubleshoot System Errors or Freezes in Photoshop 

for Mac OS,” which is document 313189 on Adobe’s Web site 

at www.adobe.com/support/techdocs/6db2.htm.

ImageR eady

What is the “lossy” option that you guys have added for GIFs 

in Image Ready 2.0? I thought GIF was a lossless fi le format.

You thought right—traditionally, GIF has been a lossless 

fi le format—that is, one in which the compression algorithm 

loses no pixel data. Lossy fi le formats such as JPEG, however, 

use compression algorithms that eliminate pixel data in order 

to give you a smaller fi le size. Generally, any time you choose 

between lossy and lossless, you’re making some trade-off 

between fi le size and image quality (lossy gives you smaller 

fi le sizes and lower quality; lossless gives you higher quality 

but larger fi les). What works best depends on the image and 

how you’re using it. 

To give you the best of both worlds and the most fl ex-

ibility in making the fi le size versus quality tradeoff, Adobe 

ImageReady 2.0 (and Photoshop 5.5’s Save For The Web dia-

log box) include the new GIF lossy slider. This feature allows 

lossiness to be introduced into the compression process (sim-

ilar to the one used in JPEG’s compression algorithm). Trans-

lated, this means you can squeeze out a smaller GIF fi le with 

a sometimes negligible loss in quality. Even though you will 

lose some data (it is, after all, lossy), the compression bene fi t 

can be tremendous. Depending on the fi le, we’ve seen Lossy 

settings as low as 5–10 percent reduce the fi le size by 5–40 

percent—without serious degradation in the fi le quality.

However, because this lossy compression throws away 

data, you may see artifacts and pixelated areas—especially at 

very high levels of compression. If you want to play it safe 

and stick with the original GIF LZW compression algorithm, 

just keep the lossy slider set to zero (the default). This will 

always produce a traditional lossless GIF. Later, if you like, you 

can try adding compression through the Lossy slider.

The new rollovers in ImageReady 2.0 are awesome. 
But how do I create a rollover that’s activated by an-
other part of the image? 

You’re thinking of remote, or secondary, rollovers, and 

they are fairly easy to create.  To create a remote rollover, you 

edit and activate the content of a layer that appears outside 

of the slice containing the rollover state—that is, you edit the 

content of slices other than the rollover slice. 

Here’s an example of how to create a remote rollover. In 

our instructions, note that the “trigger” is the slice (and roll-

over state) that activates the remote rollover when the user 

moves the mouse over that area of the image in their brow-

ser. The slice containing the visual changes (the one in which 

the image is swapped) is referred to as the “remote” slice. 

Remote rollovers, like all rollovers, require Image slices. 

To quickly switch 

among layers in 

Photoshop, Ctrl + 

right-click (Win-

dows) or Com-

mand + Control-

click (Mac) to see 

the name of all 

layers containing 

pixels under that 

point. Choose 

any layer from 

the list to make 

it active.
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Having determined the remote roll-

over area and created a selection 

from it (a), you should specify the 

appearance to change on a new layer. 

Then turn off the “non-rolled-over” 

layer, select the trigger slice, and set 

up your new rollover (b). Here’s how 

the preview looks in the browser (c).

a

b 

c

Before you proceed, make sure 

that neither your trigger slice 

nor your remote slice is a No-

Image slice.

1. Open your image in Image-

Ready and select the Slice 

tool. Create all of your 

slices. A common and easy 

workfl ow would be to drag 

the Slice tool around the 

perimeter of your button 

or whatever object you’ve 

chosen as the trigger slice. 

(This will create auto slices 

throughout the rest of 

your image.)

2. Determine which slice will 

contain the trigger and 

which will be the remote slice—or, in technical terms, 

the slice that will contain an image swap. The trigger 

must be a user slice—one that you created with the slice 

tool, or by choosing Slices > Promote To User-Slice. The 

other slice can be either a user- or an auto-slice. For 

help with user-slices, see About Slices on page 132 of 

the Adobe Photoshop 5.5 User Guide Supplement.

3. With the remote slice selected, choose Select > Create 

Selection From Slice.

4. Choose Layer > New > Layer Via Copy to create a new 

layer for the rollover. Make any edits you like on this 

new layer—apply a fi lter, change the colors, and so on. 

(Since you’re working in a new layer at this point, any 

changes you make will affect only that layer.)

5. Hide the new layer by clicking the eye icon to the left 

of the layer. This is important, because any layer that’s 

turned on will be a part of the currently selected state.

6. Select the trigger slice. Select the Rollover palette tab, 

and click the New Rollover button at the bottom. 

Choose any rollover state (such as Over, Down, or Out) 

in the palette. 

7. Turn on the eye icon next to the new layer to apply the 

changed appearance (that is, the image swap) to the 

remote slice in the rollover state you just created, and 

turn off the eye icon for any layer it may be replacing. 

8. Choose File > Preview In, and select your browser to 

survey your handiwork.

9. To save your JavaScript rollover, export HTML from 

ImageReady. Choose File > Save Optimized, and choose 

the HTML and Images options.

Repeat steps 3–7 for any additional rollover states in which 

you want to swap an image (don’t forget to deselect the eye 

icon for any layers unnecessary for each new state).

Keep in mind that rollovers, like animations, are layer-

based. That means that any pixel editing of a layer’s content 

will affect all rollover states. However, you can move, hide or 

show layers, or add layer effects without a worry: just like 

animations, these options affect only the current state. For 

more information on creating rollovers in Image Ready 2.0, 

see the section “Working With Rollovers” on pages 146– 150 

of the Adobe Photoshop 5.5 User Guide Supplement. 

ImageSt yler

I used ImageStyler to create rollover buttons, exported the 

fi le in HTML, opened it in PageMill, and copied the buttons 

to all my pages. Now when I view my site in a browser, I get 

a Java Script error message and broken rollovers! It worked 

when I previewed it from ImageStyler; what did I do wrong?

You copied only the rollover objects to your Web pages. 

However, JavaScript rollovers consist not only of the original 

object that you copied (the noAction object), but also the in-

dividual images corresponding with each assigned rollover 

state as well as the JavaScript code linking these images to-

gether. Simply copying and pasting what you see on the page 

leaves behind the other half of the equation: the code link-

ing it to the rollover state images. That’s why you’re getting 

broken rollovers and JavaScript error messages when viewing 

the new fi le in your browser. 

Fortunately, a few simple revisions will do the trick. All of 

the JavaScript code still exists on your original Image Styler-

generated HTML page. Just copy and paste the code using 

Adobe PageMill’s Source Mode on to each page that contains 

your buttons. For information on how to identify and trans-

fer the JavaScript for various Web editors, see document 

322464, “Importing ImageStyler Objects with JavaScripts Into 

PageMill.” (There’s a comparable document 322448, for sim-

ilar problems in Microsoft FrontPage. Both are available at 

www.adobe.com/support/database.html.) 

By the way, your current routine of copying ImageStyler 

objects to different pages in your Web site is usually accept-

able for noAction objects (that is, those without any rollover 

states). Most WYSIWYG editors can paste the object and up-

date it with the proper backup HTML code at the same time 

(including any URL links). ◗


