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Micro Tip

Can’t see extensions

on your Windows

files? In Explorer,

choose Options from

the View menu, click

View, and uncheck

Hide MS-DOS File

Extensions For File

Types That Are Reg-

istered. (In Windows

NT, uncheck Hide

File Extensions For

Known File Types.)
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Windows NT (5.0 only): I can’t seem to find that new Adobe

Gamma thingamabob, even though I just installed the whole

program. Where is it?

The new Adobe Gamma Control Panel—a utility that gener-

ates ICC monitor profiles and can adjust monitor display under

certain conditions—cannot be automatically installed in the

Control Panels folder under Windows NT due to limitations of that

system. Under NT, if you want Adobe Gamma to appear in the

Control Panel folder, copy the Adobe Gamma.cpl file from the Pro-

gram Files\Common Files\Adobe\Calibration folder into the

WINNT\System32 folder.  Because Windows NT doesn’t allow di-

rect control of hardware by any application, Adobe Gamma can’t

affect the display on your monitor in NT. But you should still use

Adobe Gamma to generate a monitor profile based on the set-

tings (x and y values) given to you by your monitor manufacturer

for white point and phosphors. These values will then be given to

Adobe Photoshop 5.0 via the ICC profile you’ve generated with

Adobe Gamma and will be used to calculate proper display of

your images.  For more information about this process, see the

Technical Guides on Adobe’s Web site.

Windows (3.0x and 4.0x): I’m having trouble pasting screen

shots into Photoshop. The program doesn’t always seem to

remember what I last copied. Is there a way to fix this?

Many users have told us that from time to time they can’t paste

a screen shot (taken by using the F13 or Print Screen key) into

Photoshop for Windows; either nothing happens, or you keep

getting the first thing you copied to the Clipboard. But you can

make it work every time by adding lines to Photoshop’s .INI file as

described in the following procedure. (If you have a specific need

for 96-ppi screen shots, see the second-to-last paragraph of this

answer for a different method to obtain them.)

Exit Photoshop. Locate and double-click on the Photos40.ini

(or Photos30.ini) file in the Prefs subfolder of the Photoshop

folder. On a new line at the bottom of the file, type the following:

AlwaysImportClip=1
 color con-

ns such as

e pictured

 are useful

ting topo-

al features

plex maps.
This line forces Photoshop to always (or always try to) import im-

ages from the Clipboard, regardless of their formats.

If you work with large screen shots (especially if your monitor

is set to a high resolution, such as 1,024 by 1,280 pixels at 24-bit

color), you can also force Photoshop to allow more data to be im-

ported via the Clipboard. By default, Photoshop’s Clipboard is lim-

ited to 4,096 K of data, but you can increase this limit by adding

the following line to the Photos30.ini or Photos40.ini file:

MaxClip=xxxx

For xxxx, type a multiple of 1,024 that’s larger than 4,096 (for ex-

ample, MaxClip=5120, or MaxClip=8192). Then restart Photoshop

after you’ve added the line(s) above.

You may find that colors shift in Windows screen shots when

they’re pasted into Photoshop. You should be able to avoid this if

you change your Monitor Gamma to 2.2 (by default it’s set to 1.8

in Photoshop 4.0). To do this, choose Monitor Setup from the

Color Settings submenu of the File menu (in Photoshop 4.0) or

from the Preferences submenu (in Photoshop 3.x), and type 2.2 in

the Gamma field. This is the Gamma of Windows. If you’re using

Photoshop primarily for screen graphics, you may want to keep

your Gamma at 2.2 to see your graphics as they’ll display in other

applications. If you’re working primarily with natural images for

print, you may want to change the Gamma back to 1.8. See “The

Full Gamut” on page 51 for more information on Gamma settings.

You may also have noticed that screen shots get pasted in at a

resolution of 72 ppi, even though Windows monitors typically

have a screen resolution of 96 ppi. If you happen to need 96-ppi

screen shots in Photoshop, you can get them by first pasting from

the Clipboard into Windows Paint (from the Start menu, choose

Paint from the Accessories submenu of the Programs menu).

Once your data is in Paint, save it, select all, copy again, switch to

Photoshop, and paste one last time. Incidentally, this technique

would solve your initial problem with pasting screen shots—with

the added benefit of not having to edit your .INI file.

For lots more information about capturing screen shots, see

“Hot Shots” by Olav Martin Kvern on page 61.

Windows/Mac: I have a grayscale image that I’d like to con-

vert to a false-color image for a scientific application. Is

there any way to do this without painting every last pixel?

You bet. This is one of the things that indexed color does best.

In fact, in the old days before the Web became so prevalent, this

was a typical use for indexed color. Here’s what you need to do.

Convert your grayscale image to indexed color by choosing In-

dexed Color from the Mode submenu of the Image menu. Then

choose Color Table from the Mode submenu of the Image menu.

In the Color Table dialog box, you can choose from among the

built-in color tables that are supplied with Photoshop—Black

Body, Grayscale, Mac OS System, Spectrum, or Windows System—

or you can choose Custom and create a color table to meet your

specific needs. In either case, the gray levels in your image will be

remapped to the new color table.

Depending on the effect you’re trying to achieve, it may take

some editing and massaging to get the custom color table just

right, but once you do, you’ll want to save it. That way, any time

you want to convert a grayscale image to your particular flavor of

false color, you can just switch to indexed-color mode and load

your custom table.
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Toggle Preserve

Transparency

on or off for any

nonbackground

layer using the

Forward Slash

(/) key.
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Windows/Mac (5.0 only): I’m running an older system and

I’m afraid that the new multiple-undo feature will really

slow down my computer. Is there anything I can do about

that, besides buying a new, faster computer?

Although we’re always tempted to suggest that you exploit ev-

ery excuse to run out and buy a faster computer, in this case that’s

really not necessary. The addition of Photoshop’s History palette/

multiple-undo feature really shouldn’t slow things down very

much at all. Try it out for a while and see if you think, as we do,

that this new feature hardly affects performance. If you find that

you would rather not have all those undos available, you can limit

Photoshop to a single undo, or just a few. (You set the Maximum

History States option from the History Options menu in the His-

tory palette.) You can also use the Purge command from Photo-

shop’s Edit menu to clear out the steps in your History palette.

Windows/Mac (5.0 only): Whenever I open a file in Photo-

shop 5.0, it says “converting colors.“ How can I stop it from

changing my files?

By changing your defaults. Photoshop uses the program’s de-

fault color settings and may convert files as you open them into

its current working color space (which it reads from the ICC profile

information specified in the RGB and CMYK Setup dialog boxes

from the Color Settings submenu of the File menu). Of course, this

will occur only when the file is from an earlier version of Photo-

shop or was defined with a different color space than the current

one. For best results you should calibrate your system, select an

appropriate working color space, and set your Assumed Profiles

preferences correctly. It’s when your Profile Setup isn’t accurate
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ace: the sky’s (almost) the limit
s versions of Photoshop, if you worked on very large

might have occasionally exceeded the limits of Pho-

vailable scratch-disk space (which was limited to a

 of two scratch-disk files, each of which were limited

imum of 2 GB). Now the limits on the amount of

e scratch-disk space have been raised dramatically.

shop 5.0 supports up to four scratch-disk volumes

see this by choosing Scratch Disks from the Prefer-

menu of the File menu). Photoshop will write

isk files to the first designated drives, beginning a

fter the first one reaches a size of 2 GB (which is the

e size that Photoshop can handle) and creating

l scratch-disk files on the same volume until the

xhausted. If necessary, Photoshop will write addi-

atch-disk files to your next designated scratch-disk

nd the process will continue from there.

shop 5.0 supports a maximum of 100 scratch-disk

 of which can be a maximum of 2 GB, for a total

00 GB (this is not a typo) of space—assuming, of

at you can afford that much disk space. We hope

r have to work on a file that big!
that you may see shifting colors in your files as you open them.

For the most part, you do want Photoshop to convert your files

into the (appropriate) current working color space. (If you don’t,

they will still be in the other space, and they won’t display accu-

rately.) But in some cases—most notably, for Web images—you

should probably turn off Photoshop’s color management and not

convert your files when you open them.

To control how files open in Photoshop, choose Profile Setup

from the Color Settings submenu of the File menu. In the Profile

Setup dialog box, choose None for all the options under Assumed

Profile and Ask When Opening for all the options under Profile

Mismatch Handling. Now you can control each image individually

and avoid unwanted changes.

For more information, you can obtain two detailed Technical

Guides on color management in Photoshop on our Web site at

www.adobe.com/supportservice/custsupport/TECHGUIDE/PSHOP/

html. Also, make sure you check out “The Full Gamut” by Bruce

Fraser on page 51 of this issue.

Windows/Mac (5.0 only): When I have Black Ink selected for

my grayscale setup in Photoshop 5.0, I see a different pre-

view than I did in Photoshop 4.0.  What has changed?

What’s changed is the approach. Adobe received feedback

from prepress professionals who thought that the dot-gain val-

ues that had been used in Photoshop 4.0 (and earlier) produced

results that were too dark. So in Photoshop 5.0 the algorithm’s

been changed, and this should result in better (but lighter) re-

sults. There is no simple conversion for going between new dot-

gain numbers and old numbers, but if you would prefer to use the

old dot-gain numbers from Photoshop 4.0, you can bring those

into Photoshop 5.0. Here’s how.

1. In Photoshop 4.0, choose Printing Inks Setup from the Color

Settings submenu of the File menu. In the Printing Inks Setup

dialog box, make sure your preferred standard is selected, and

then click Save.

2. Store the resulting printing-inks file in a logical place where

you’ll be able to find it, preferably in a place where it will be

backed up (in Windows, this custom file will be saved with the

extension .API). Click Save again and then click OK.

3. Switch to Photoshop 5.0 and load the custom dot-gain set-

tings in the CMYK Setup dialog box (choose CMYK Setup from

the Color Settings submenu of the File menu).

4. In CMYK Setup, make sure that the Built-in option is selected

for CMYK Model type, click Load to load your custom API file,

and then click OK.

Windows/Mac (5.0 only): I wanted to throw away my Photo-

shop 5.0 Prefs file, but it’s not there anymore. What did you

guys do with it?

The Photoshop 5.0 preferences have been moved and subdi-

vided: one overall file has been made into three separate files

for your benefit. The three files are named Adobe Photoshop 5

Prefs.psp, Color Settings.psp, and Actions Palette.psp (Windows)

and Adobe Photoshop 5 Prefs, Color Settings, and Actions Palette

(Mac). You can find them in the Adobe Photoshop Settings sub-

folder of your Photoshop 5.0 folder.

Why are three Preferences files better than one? If, heaven for-

bid, one of Photoshop’s Preferences files were to become corrupt

and you decided to throw it away, it wouldn’t take all the other



Tip: Windows/Mac (5.0 only)

Trouble with your upgrade serial number?
If you have purchased Photoshop 5.0 as an upgrade (that is, you

owned and used an earlier version of the product), be aware that

it requires the serial number from your previous version of Photo-

shop—upgrade versions don’t have their own serial number. The

seven-digit number on the Photoshop 5.0 upgrade registration card

(for example, PWW501V) may look like a serial number, but it’s just a

tracking code that Adobe uses internally for processing registrations.

If you’ve removed Photoshop 4.0, please be aware that you must

retain your original Photoshop media—the diskette or CD from the

version that has the serial number—as well as the previous serial

number itself. You’ll need these items to install the upgrade and for

any future reinstallations.

If you have any trouble with your serial number, call Adobe

Customer Services at (800) 492-3623.

It looks like Photoshop, but the

Layers palette above belongs to

ImageReady, which will take

your Photoshop layers and

create an animated GIF.
preferences down with it. For example, if you’ve created some

elaborate Actions that you haven’t saved to a separate file (shame

on you!), and you had to delete the general or the color Prefer-

ences file, you wouldn’t lose your Actions settings.

Windows/Mac (5.0 only): I’m having trouble cropping im-

ages. When I drag the crop boundary near the edge of the

image window, it snaps to the edge of the window and

seems to hug that edge no matter what I do. Sometimes it’s

helpful, but other times it’s really annoying. Isn’t there some

way to get it to stop being so clingy when I don’t want it to?

Yes, don’t fret; you can tame the crop rather than having the

crop tame you. When you drag to define an area with the crop

tool in Photoshop 5.0, you can resize that area before you actually

crop it. You can even drag the crop border out beyond the edge of

the canvas, which actually provides a sneaky way to enlarge the

canvas (we like to call this “reverse cropping”). Because you may

not always want to drag your cropping bounding box beyond the

edge of the canvas, the crop border is set up by default to snap to

the document edge when you get near it, as a safeguard. That’s

what is bothering you now.

To temporarily disable this “sticky” behavior, first make an ini-

tial selection with the crop tool and then hold down Ctrl (Win-

dows) or Command (Mac)  as you drag to refine the selection area.

Ctrl or Command prevents the cropping boundary from snapping

to the edges as you cross them.

Windows/Mac: Can Photoshop

create animated GIFs?

Sorry, Photoshop itself doesn’t

do animation, but if you’re looking

for an easy way to animate images

that were created in Photoshop,

check out Adobe ImageReady, a

new optimization program for Web

graphics. One good timesaving

idea is to create your animation

using Photoshop layers and then

open the Photoshop file in Image-

Ready—ImageReady and Photo-

shop can exchange files seamlessly

with all layers and layer effects intact. Once the file is opened

in ImageReady, choose Make Frames From Layers from Image-

Ready’s Layers palette; ImageReady will automatically generate

an animated sequence from your layers.

If you’re not already familiar with the program, see “Take It

Online” in the Adobe Announces section of Adobe Magazine,

Summer 1998, page 16, or go to www.adobe.com/prodindex/

imageready/main.html for more information about ImageReady.

Windows/Mac: When I added some new plug-in filters, some

of my old ones disappeared. What happened?

Adding the new filters probably put you over the limit of what

the basic Filter menu can show. Look on the Other submenu of

the Filter menu; all of your “missing” filters should show up there.

Beyond the standard, automatically installed filters that always

appear on the Filter menu, Photoshop can handle 13 more cat-

egories below the line near the bottom of the menu. All addi-

tional ones will appear under the Other submenu. ◆
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