
Disappearing Act. Making and faking
transparent backgrounds in Photoshop

How-to
B Y  L I N N E A  D A Y T O N  A N D  J A C K  D A V I S
Your client wants to show off some cars in her next brochure, fo-

cusing attention on the autos and eliminating the distracting surroundings
in which they were originally photographed. So you open the two photos in
Photoshop and painstakingly select each car. You invert the selection, and
you press Delete. Voilà! The oil-stained curbside and nondescript bushes
are replaced with plain white nothing, and you’ve got a silhouette, right?

Maybe—or maybe not. If your page is white and the cars are far apart in
the layout, you may be home free. But if they’re placed close together, they
start acting like a couple of trading cards: whichever car you put “on top” in
the layout, the white background of that car covers up part of the other car.
You redesign the layout to cope . . . hmmm, looks good!
Adobe
But now the client wants a full-
bleed blue background. While you
dump buckets of blue paint into the
white areas, you’re thinking, “There
has got to be a better way!”

There is. Or rather, there are—
several methods let you make those
pixels outside the silhouette dis-
appear. The one you choose will de-
pend on whether your image is
headed for print or the Web, what
the background of your final layout
is, and whether you want to add drop shadows. Too
many choices? Don’t worry, this article will give you
techniques for all of these options. (We’ll show them in
Photoshop 4.0, but you can also use them in Photoshop
3.x, although the processes and shortcuts will vary.)

Focusing on the subject
There are at least three ways to create a silhouette by
making a background “disappear.”
• For a print image, you can use a clipping path—a se-

lection stored within the image file that, in a page-lay-
out or illustration program, isolates the subject and
makes the rest of the image transparent.

• For a Web image, you can use an alpha channel.
Wherever the alpha channel is light, the image will
show up; wherever it’s dark, the image will disappear.

• For either print or the Web, you can simply retain
whatever part of the image you want, and fill the rest
with the background color of the final page. This will
make the background around your silhouette blend
seamlessly into the page.

Note: We recommend working on a duplicate image in
case you need the original again later. Also, for simplic-
ity, we’ve assumed that you’re starting with a flattened
file—that is, one composed of only a Background layer
in Photoshop.

Start by selecting the subject you want to silhouette.
If your subject contrasts with the background of the
photo, you may be able to put that color difference to
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work in the selection process (for tips, see “Beyond the
Magic Wand: Making selections by color in Photoshop”
in the Autumn 1997 issue of Adobe Magazine). Other-
wise you can place points and shape curves with the pen
tool to make a path around the subject, or maybe “draw”
the silhouette selection with the lasso tool.

Preparing silhouetted images for print. Once your
path or selection is made, you’ll save it as a clipping path
so that you can import both the image and its path into
a page-layout or illustration program. Here’s how.
1. Make sure you have a work path: If you used the pen

tool to outline your subject, the work path will already
be in the Paths palette. If you selected your subject by
some other method, turn the active selection into a
path by clicking the Make Work Path button. (You
may need to fine-tune the path with the pen’s modifier
tools from the fly-out palette in the tool box.)

2. Create the clipping path: Double-click the work path,
and then name and save it as a path. Choose Clipping
Path from the Paths palette pop-up menu and select
your newly named path.

3. Save the file as a TIFF or Photoshop EPS image. (See
“To TIFF or not to TIFF?” on page 52 to learn more
about the pros and cons of these formats.)

Preparing silhouetted images for the Web. Photo-
shop gives you two formats for silhouetted Web graph-
ics—GIF and PNG. GIF is well-established and sup-
ported by virtually all Web browsers—any visitor who
lands at your site can see your GIF image. PNG is fairly
new, and not all browsers fully support it yet. But PNG
offers a few benefits that GIF doesn’t. GIF images can
contain no more than 256 colors; PNG files can contain
millions. Pixels in a GIF are either totally transparent or
totally opaque; PNG uses a grayscale mask to cut out
your silhouette, which means you can have varying lev-
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els of opacity for smooth, anti-aliased edges. In this ar-
ticle, we’ll stick to the “here-and-now” technology of the
GIF format. (To learn more about PNG, see “Look Out,
GIF and JPEG” by Glenn Fleishman on page 23.)

The way you produce a GIF for a silhouetted image
will depend on what kind of background it will appear
over, and whether your subject also has the background
color inside it. If the background for the Web page is a
known solid color, the following approach will allow the
pixels at the edges of the silhouette to pick up tints of
the page’s background color, resulting in limited anti-
aliasing so the silhouette edge will look smooth instead
of stairstepped. Here’s how you set it up.
1. Select the background area: Working in RGB mode,

make an anti-aliased selection of the subject you
want to silhouette (anti-aliasing is the default for
most selection tools). Store the selection as an alpha
channel. With the selection still active, choose In-
verse from the Select menu.

2. Match the Web page’s background color and fill the
selection: Set Photoshop’s Foreground color to that of
the Web page and press Alt + Backspace (Windows)
or Option + Delete (Mac) to fill the selection.

3. Make an RGB “backup” of your image by choosing
Duplicate from the Image menu. (This just ensures
that you can start over if the rest of the procedure
doesn’t give you the results you want.)

4. Make an Indexed Color version of the file: Choose In-
dexed Color from the Mode submenu of the Image
menu. In the Indexed Color dialog box, select Web (if
you expect a significant portion of your viewing audi-
ence to be using 256-color display systems) or Adap-
tive (if you expect the vast majority of your audience
to have display systems that can display thousands of
colors) from the Palette pop-up menu. Click OK.

5. Export in GIF and make the background pixels trans-
parent: Choose GIF89a Export from the Export sub-
menu of the File menu, and then click the dialog box’s
eyedropper tool on the background color, outside of
the subject but still within the preview box. This
makes the background color transparent but leaves
the “anti-aliasing” pixels in place. (If there are pixels
of the background color within the silhouette sub-
jects, those pixels will also become transparent, al-
lowing the background color to show through the
holes. But that shouldn’t be a problem if the color that
you’ve chosen for transparency really is the same as
your Web page’s background color.)

If you don’t know the background color of
the Web page, or if the silhouette will need
to appear over more than one background
color, then you should create your GIF im-
age using an alpha channel, as described
on the next page. Be forewarned, however,
that the pixels in a GIF transparency cre-
ated in this manner are “all or nothing”—

there will be no anti-aliasing at the edges (even though
the alpha channel as it appears in Photoshop will have a
smooth, anti-aliased edge).



How-to

1. Make an alpha channel of the selection: Working in

RGB mode, select the subject and shrink the selection
by one pixel all around (choose Contract from the
Modify submenu of the Select menu). Open the Chan-
nels palette (from the Window menu) and click the
Save Selection button. The new channel will show up
in the Channels palette.

2. Convert to Indexed Color using the procedure in step
4 in the previous column.

3. Export in GIF format: Choose GIF89a Export from
the Export submenu of the File menu. In the GIF89a
Export dialog box, choose the alpha channel’s name
in the Transparency From pop-up menu, and then
click OK. You’ll see that wherever the alpha channel
is black, the GIF file will be transparent, and wherever
the channel is white, the GIF’s pixels will be opaque,
creating a silhouetted subject when you place the im-
age on a Web page.
Regardless of what
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Stepping into the shadows
The technique you’d use for creating a soft, semitrans-
parent shadow is the same for both print and the Web,
but you have to process the shadow appropriately for its
final medium. First, we’ll create the shadow effect.

Making the shadow. There are many ways to make a
realistic drop shadow. Here’s our favorite “manual” tech-
nique, but you can automate the process with a Photo-
shop Action or use a plug-in such as PhotoCastShadow
(in Extensis PhotoTools 2.0, reviewed on page 25).
1. Make a shadow layer: Select your subject from the

Background layer using the stored selection you
made for safekeeping when you were producing the
silhouette. Copy the subject to a new layer (Ctrl + J in
Windows or Command + J on a Macintosh), and then
duplicate the new layer by dragging its thumbnail in
the Layers palette to the New Layer button at the bot-
tom of the palette, so you have two isolated subject
layers stacked above the background.

2. Create the shadow: Set the foreground color to black.
Make the lower subject layer active, and then press
Shift + Alt + Backspace (Windows) or Shift + Option +
Delete (Macintosh). This fills the subject in the lower
layer with black without spilling the fill into the layer’s
transparency. (The Shift key acts as a temporary Pre-
serve Transparency function.)

3. Add a white-filled layer beneath the shadow: Activate
the Background layer, click the New Layer button, se-
lect all, and fill with white. This layer will help give you
a good view of your developing shadow, and may
serve other purposes later depending on the back-
ground you’ll be using.

4. Reactivate the shadow layer and soften the edges of
the shadow with the Gaussian Blur filter (from the
Blur submenu of the Filter menu).

5. Adjust both the shadow’s density (with the opacity
slider in the Layers palette) and position (with the
move tool) to suit you. No matter how you’ve made
the shadow, as long as it’s on its own layer, you can
continue to tweak it.

Processing the shadow. How you will work with the
shadow from this point forward depends on whether it’s
going to print or to the Web, and what kind of back-
ground will be behind it.

If your silhouette and shadow are going to appear
over a portion of a page that has no other printed ele-
ments, just flatten the file (choose Flatten Image from
the Layer menu) and then turn off the clipping path (if
you made one earlier) by choosing Clipping Path from
the Paths palette pop-up menu and choosing None for
the Path option in the Clipping Path dialog box. Save the
file as a TIFF or EPS.

If your silhouette and shadow will
appear over a solid-color printed
background on a paper page, fill the
white layer below the shadow with
the color of the page (set the fore-
ground color to match the page’s
background color and press Alt +
Backspace in Windows or Option +
Delete on a Macintosh). Then flat-
ten the file, turn off the clipping
path, and save the file.

If you plan to put your shadowed
subject over printed matter other
than a solid-color background, you
can turn your shadow into a sepa-
rate transparent image using Bit-
map mode. The following technique
will turn your shadow into a high-
resolution, transparent, one-bit im-
age that can “fake” the soft grays of the shadow by using
tiny black dots in varying densities—more dots per inch
for the dark center of the shadow, and fewer dots per
inch for the edges. The spaces between the dots are
transparent, so whatever is underneath shows through
the shadow. You then combine this shadow image with
the opaque, colored subject image.
1. Make sure the file is at its final printed dimensions: If

necessary, use Image Size from the Image menu to
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adjust the final printed width and height of the file.
(Once you make the 1-bit shadow file as described in
steps 3 and 4 below, you won’t be able to resize it with-
out degrading its appearance.)

2. Make the separate shadow file: With
your shadow layer active, turn off vis-
ibility for the silhouette layer above
it, select all, and copy merged (Ctrl +
Shift + C in Windows or Command +
Shift + C on the Mac). Then start a
new file, choosing Grayscale from
the Mode pop-up menu. Paste the
shadow into the new file.

3. Convert to Bitmap mode: Select Bit-
map from the Mode submenu of the
Image menu. Click OK to flatten the
layers. In the Bitmap dialog box,
choose the Diffusion Dither option
and enter an output resolution—try
300 to 600 dpi for laser printing, 600
dpi for offset printing. (To be successful with
this method, you may have to experiment to
get the right output settings for the conver-
sion to Bitmap mode. Higher settings can
make the shadow “go solid” because of dot
gain on the press or desktop printer. Lower
settings can show the dotted nature of the
image. For offset printing, you should consult with
your commercial printer about what you plan to do.)

4. Save and place the file: Save the shadow file as a TIFF
and then place the TIFF into your layout program. In
most applications (including Adobe applications),
the noncolored areas of the 1-bit image will automati-
cally behave as if they’re transparent. In some appli-
cations, however, you might need to select an option
to ensure that your shadow behaves this way (check
your application’s manual if you’re not sure how it
handles 1-bit TIFFs). You can position your silhouette
file on top of the shadow on the page.
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To process a transparent shadow or halo for a GIF, use
an alpha channel that combines the shapes of the sil-
houette and shadow. It takes several steps to get the de-
sired result, so suspend your disbelief and follow the in-
structions carefully. We’ll assume you’ve made an alpha
channel and shadow using the procedures for a complex
or unknown background, and your image is 72 dpi.
1. Create a separate bitmap shadow file as described in

steps 1–3 in the previous procedure, but this time set
the file’s resolution to 72 dpi.

2. Convert the bitmap shadow file back to grayscale and
select all the black pixels: Set the Tolerance option for
the Magic Wand at 0 (zero), click on a black pixel, and
then choose Similar from the Select menu.

3. Use a selection tool—not the move tool—to drag and
drop only the selection border (“marching ants”), not
the contents, back into the silhouette file. Offset the
marching ants where you want the shadow to be. (In
Photoshop 3.x, paste the selection border into a new
alpha channel in the original file.)

4. Add the silhouette selection to the shadow selection:
Ctrl-Shift-click (Windows) or Command-Shift-click
(Mac) the thumbnail for the silhouette’s alpha chan-

Fadeout
It may take some experimentation with drawing clip-
ping paths or adjusting bitmap output resolution to pull
off this “disappearing act” and get the silhouettes, soft
edges, or partial transparency that you want. But the
time and effort will pay off with pages that stand out
clearly among everyone else’s. ◆

Linnea Dayton and Jack Davis are the authors of The
Photoshop 4 Wow! Book and accompanying CD-ROM
with more than 60 Wow! tutorial special-effects actions,
published by Peachpit Press.

To give your shadow a glow or “halo,”

assign it a light color; to give it a color

cast, make it a dark version of the Web

page’s background color.

5. In the original shadow layer,
select all and fill with the sha-
dow color. The entire layer will
now be filled with color.

6. Convert the image to Indexed
Color (duplicating it first for
later projects) and delete the
silhouette-only alpha channel.
Export as a GIF, choosing your
combined alpha channel from
the dialog box’s Transparency
From pop-up menu.

nel in the Channels palette, and then click
the Save Selection button. You’ve now cre-
ated a combined alpha channel. (In 3.x,
use Load Selection to add the first alpha
channel to the second, and press Delete to
get your combined channel.)
To TIFF or not to TIFF?
Photoshop can save clipping paths in both EPS and TIFF files, so

which format should you use? Each has distinct advantages.

EPS files with clipping paths are widely accepted by page-layout

and illustration programs (including PageMaker, Illustrator, and

FrameMaker). But PageMaker 6.x can also recognize a clipping path

in a TIFF image. While EPS is the more universally readable format,

TIFF’s big advantages are that it can produce a smaller file size (since

it supports LZW compression) and can print reliably to non-Post-

Script printers.

TIFF files can also provide better on-screen previews than EPS

files. In some cases—particularly with EPS files created in Win-

dows—your clipping path may not display properly (the area out-

side the clipping path may not look transparent on screen). Regard-

less of how the EPS displays, it’ll print properly on any PostScript

device. But if you’re printing to a non-PostScript printer (which can

print only the screen preview, not the actual EPS), what you see on

screen is what you’ll get on output.


