Desktop Science

BY OLAV MARTIN KVERN < ILLUSTRATIONS BY JOHN UELAND

Linking 101. Managing imported
graphic files in FrameMaker, lllustrator,
and PageMaker

Ahem. Good morning. Please be seated.

In previous classes, we have discussed
the ethical, moral, philosophical, and
sociological implications of design de-
cisions made in the course of creating
todays graphics software applications.
In your most recent assignment, I asked
the class to split into teams to consider a
particular problem inherent in publishing
programs—namely, what to do with files
imported from other applications.

I'would like to commend the work done by
the team made up of Mr. PageMaker, Ms.
Hlustrator, and The Entity Known As Frame-
Maker. I believe that they have stated the problem clearly, have drawn the
correct conclusions, and have developed good—if not always perfect—solu-
tions. It is particularly interesting to note that, while each member of this
team has come up with an individual approach that varies slightly from
those of the other team members, the approaches are all remarkably similar.

Please stop fidgeting. Mr. PageMaker, you may remove your hat.

Problem? What problem?

What's going on in the imaginary
classroom scene described here? The
students—all desktop-publishing ap-
plications—are confronting questions
each of them must face: What should
happen when you import a file from
another application? Should the pro-
gram create a copy of the file and store
it inside the document? (This is usu-
ally called embedding.) Or should the
file be stored outside the document,
with the application referring to the
file on disk for information when
printing or drawing the imported file
on your screen? (This method is often
called linking, although this term is
somewhat misleading, as we'll see
later.) This area is one of the most
misunderstood parts of PageMaker,
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[llustrator, and FrameMaker.

What's the practical outcome of choosing one way
of dealing with imported files over another? If you opt
to embed the imported graphic, your document file
increases in size by the size of each file you import.
Store the graphic file outside the document, and you
save disk space and keep your document file trim—
but you’ll have to keep track of the graphic file for
printing (and, in some cases, for display).

In my opinion, the choice should be easy for a soft-
ware developer to make: provide both methods, and
let users choose to use one method, or the other, or
both. That’s what PageMaker, Illustrator, and Frame-
Maker have done.

With this flexibility, however, comes responsibility.
You, the user, have to know which method you're us-
ing, and what advantages and disadvantages come
with it (especially when it comes to printing the doc-
ument file or moving it to another computer).

Thinking about linking

FrameMaker and Illustrator use different terminology,

but they work the same way. In both applications, you

can store a graphic either inside or outside the docu-
ment file. In FrameMaker, a graphic you've imported
using the Copy Into Document option is embedded

in your document file; one you've imported using the

Import by Reference option is stored outside the doc-

ument file. In Illustrator, linked graphics are stored

outside the document file; embedded graphics are
stored inside. You can’t maintain a link to an external
file while embedding a copy of the file in your docu-
ment, as you can in PageMaker.

In PageMaker, linking is really about two separate
but related things.

+ Afile’s storage location. PageMaker tracks whether
a copy of the imported file has been stored (embed-
ded) inside the document file or if it’s been stored
outside the document.

¢ Afile’s creation and modification status. PageMaker
can track where an imported file came from and
what’s happened to it—whether or not the file is em-

bedded in the document.

Of the three programs,
PageMaker has the
most flexible—and

therefore potentially
confusing—system
for managing imported
files. In PageMaker, you can
create a link to a file even if
you've embedded the file in
a document, and you can tell
PageMaker to forget about a link
to an embedded file.
Both options are
very useful.
But this capabil-
ity causes prob-
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lems when you talk about your PageMaker publica-
tions with users of other publishing programs. To
them, “linked” files are always stored externally. They
assume that you'll need to have a copy of each linked
file to print the document. And they keep on making
this assumption—even if the files are embedded in the
document (and therefore aren’t needed for printing).
To PageMaker, the link is simply a way of keeping track
of the original file—and can be maintained for embed-
ded graphics, as well as for those stored outside a doc-
ument. I've seen many a PageMaker job mistakenly
delayed at an imagesetting service bureau because of
“missing” linked files—files that were, in fact, embed-
ded in the document.

When you change an externally stored (that is, not
embedded) file, all three programs update any instan-
ces of that file in your document file. When you update
the source file of a graphic you've embedded in an II-
lustrator or FrameMaker document, nothing happens
to the version of the graphic in your document file.
This may or may not be what you want to have hap-
pen. In PageMaker, the graphic updates—or does not
update—based on the state of the options in the Link
Options dialog box (more on this later).

Where are your files?

Here's an overview of the methods used by each pro-
gram to define the storage location of placed graphics.
Iustrator. To find out whether a graphic is stored
inside or outside an Illustrator 7 document, select the
graphic and choose Selection Info from the File menu.

Ilustrator displays the Selection Info dialog box.
Choose Linked Images from the Info pop-up menu.
If the selected graphic is stored externally, Illustrator
displays information about the graphic in the Selec-
tion Info dialog box. If it’s not, choose Embedded Im-
ages from the Info pop-up menu to see information
about the embedded image. To see the storage options
for all of the imported graphics in a document, press
Ctrl + Shift + A (Windows) or Command + Shift + A
(Mac) to deselect all objects, and then choose Docu-
ment Info from the File menu. Choose Linked Images
or Embedded Images from the Info pop-up menu

to display a listing of linked or embedded graphics.

In Illustrator, you control a graphic’s storage loca-
tion when you place the file. To store the graphic out-
side the document, turn on the Link option in the
Place dialog box (this is Illustrator’s default). Turn
this option off when you want to embed a copy of
the graphic inside your document file.

To embed all of the graphics in a file, turn on the
Include Placed Files option as you save the file in Illus-
trator 7 format. (Note: The Include Placed Files option
does not work correctly with linked EPS files. If you
use it, lllustrator will write all the code from the EPS
into the illustration file, and it will print correctly if
the illustration file is itself an EPS and placed into an-
other application. But if you open the file in Illustrator
again, you'll need to re-place your EPS.)



To embed a bitmap image, I use a sneaky trick—I
rasterize it. Select the graphic and look at its specifi-
cations in the Selection Info dialog box (choose Linked
Images to view the information if it’s not already vis-
ible). Close the Selection Info dialog box and choose
Rasterize from the Object menu. lllustrator displays
the Rasterize dialog box. Make the settings in this dia-
log box match the specifications of the original image
(make sure you leave the Anti-Alias and Create Mask
options off), and click OK to rasterize the image. Illus-
trator duplicates the image and stores the copy inside
your document. On a related note, running any of the
bitmap (Photoshop) filters on linked graphics will also
automatically embed them.

FrameMaker. When you import a graphic into a
FrameMaker document, the Import File dialog box
gives you two options: Import by Reference and Copy
Into Document. Select Import by Reference to store
the file outside the document, or select Copy Into
Document to embed the file in the document.

To change the storage location for a graphic, re-
place it: Select the graphic, and choose File from the
Import submenu of the File menu. In the Import File
dialog box, select the filename of the graphic, and then
select the storage option you want to use. Click Im-
port, and FrameMaker replaces the graphic with itself,
changing the storage method as it does so.

PageMaker. To set or view the options for a placed
graphic in PageMaker, select the graphic with the
pointer tool and choose Link Options from the Ele-
ment menu. In the Link Options dialog box, turn on
the Store Copy in Publication option to embed a copy
of the graphic inside your document file. To store the
graphic outside the document, turn this option off.

When you turn on the Store Copy in Publication
option, you can also choose to have PageMaker auto-
matically update the placed graphic if the original
graphic has been changed since you were last inside
the document. You may or may not want to use this
feature (I never do), but if you do, please, please also
turn on the Alert Before Updating option. I know too
many people who have lost their sanity because Page-
Maker updated images while they weren’t paying
attention (even though it was only doing what it had
been told to do). If you turn off the Store Copy in
Publication option, PageMaker always automatically
updates the placed graphic if the original file has
changed since you last worked in the PageMaker file.

PageMaker makes it easy to take the third route—
you can set a threshold at which it will ask if you want
to store a copy of a graphic inside the document. By
default, this threshold is 256 k—PageMaker automati-
cally stores files smaller than that inside the document
(this default works pretty well and is what I use). Place
a file larger than 256 k, however, and PageMaker will
ask how you want it stored. You can change the thres-
hold using the Alert When Storing Graphics Over op-
tion in the More Preferences dialog box (to get there,
choose Preferences from the File menu, and then click

More in the
Preferences dialog
box). Changing the
threshold has no effect on files
you've already placed.

PageMaker’s Links Manager (Page-
Maker 6.5) or Links (previous versions)
dialog box gives you a central place to
view and edit the storage and link sta-
tus of all the files you've placed in a document.

To display it, choose Links from the File menu.

You can also use this dialog box to tell PageMaker
to unlink a given file—that is, to forget completely
about its link status so that PageMaker won’t have to
keep track of the file anymore. Choose the filename
from the list, and then click Unlink. If the file isn't al-
ready stored inside the document, PageMaker copies
it, stores it inside the document, and then removes the
filename from the list of linked files.

PageMaker includes the Global Link Options plug-
in, which gives you a way of changing the storage set-
tings for all the files linked to your document. This
means that you can quickly change linking strategies.
To display the plug-in, choose Global Link Options
from the Plug-ins submenu of the Utilities menu.

A few tricks
Here are a few of my favorite linking-related tips.

Updating shortcuts. In Windows and Macintosh
versions of PageMaker and Illustrator, and the Mac-
intosh version of FrameMaker, you can use a shortcut
to open and edit an externally stored graphic in its
originating application—hold down Alt in Windows
(in PageMaker and Illustrator) or Option on the Mac-
intosh and double-click the graphic on your document
page. This switches to the application you used to cre-
ate the graphic (Photoshop, for example), and opens
the graphic in that application. When you save the
graphic and return to your document, your publishing
application updates the imported graphic. However,
we do not recommend that you use this technique
in Illustrator 7.x with a non-EPS linked image from
Photoshop—doing so can change the arbitrary origin
point to the center of the object when you try to use a
transformation tool, or it can cause the watch cursor
or the Place progress bar to appear unexpectedly.

In PageMaker, you can choose the program you
want to use to edit the graphic by holding down Alt
+ Shift (Windows) or Option + Shift (Macintosh) as
you double-click the graphic. PageMaker displays the
Choose Editor dialog box. Choose the program you
want to use to edit the graphic, and click OK.

In PageMaker, you can also use this shortcut on
graphics you've embedded in your document—just
make sure you turn on the Update Automatically op-
tion for that graphic before you switch to the applica-
tion you'll be using to edit it—if you don’t do this, the
graphic won't update when you return to PageMaker.

Save linked files to your document’s folder. If
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you've ever moved or renamed a folder full of files
you've placed in a document, you've probably experi-
enced the horror of having to relink to those files one
at a time. How can you keep from repeating this? The
simplest way (and what I do most of the time) is to
store linked files in the same folder as the document
file—PageMaker, Illustrator, and FrameMaker can
always find linked files there. If you're using Frame-
Maker, you can store the files in folders inside the
document file’s folder.

Let your program do some of the hunting. When
FrameMaker discovers it can’t find linked files, you’ll
see the Missing File dialog box. Locate the first missing
graphic, turn on the Update Document to Use This
Path option, and click OK. FrameMaker updates the
linked graphic. The next time FrameMaker encounters
a graphic you've “imported by reference” (i.e., stored
outside the document), it’ll check this folder before
asking you to locate the lost file.

When PageMaker discovers that it can’t find a
linked graphic as it opens a document, you'll see the
Cannot Find [filename] dialog box. Just as in Frame-
Maker, you locate the first missing graphic and update
the link to it; PageMaker adds the folder containing
the graphic to the list of folders it searches automati-
cally. To keep PageMaker from searching this folder,
hold down Alt (Windows) or Option (Macintosh) as
you click the Link button.

File-management strategies
What's the best way to work with imported files? That
depends on who you are and what sort of document
you're working on. Here are three main approaches.
Store all your graphics outside your document.
When you do this, your document file size
stays small—at least compared to an
identical document using embed-
ded graphics. Here are some of the
other advantages and disadvantages
of this approach.
* You can’t move, rename, or other-
wise change the location of the
graphics you've placed in your
document file (this in-
cludes renaming or mov-
ing any of the folders or
drives containing the
graphics)—unless
you're prepared to
relink to all of the
graphics (or move them
to your document’s folder).
* You can update a graphic and
expect to see the changes

{fl'm

from the update appear
in your document.
* You have to remember
to take the files with
you when you bring

your publication file to another computer, such as

when you take your document to an imagesetting

service bureau.

Store all your graphics inside your document. When

you do this, your document file size increases by the

size of each graphic file you import, or more. Unless
you delete the original file (usually a bad idea), you'll
be taking up at least twice as much disk space, per
graphic, as you would have if you had stored the
graphic externally. On the other hand, here are some
advantages of this approach.

+ You can move, rename, or even delete the original
graphics files without fear of changing their appear-
ance in your document. If you want to do this, and
you're using PageMaker, you'll have to make sure
that the Update Automatically option in the Link
Options dialog box has been turned off.

* You have only one file to worry about—your docu-
ment file—and it contains all of the information you
need to print or display it.

Store small graphics inside the document and large

graphics outside the document. This approach gives

you the best (or worst) of both worlds. Your document
size isn't as large as if youd stored all the graphics in-
side the file, but you've still got to keep track of the
graphics you've stored externally.

In PageMaker, you've got help. When you choose
Save As from the File menu, you'll see two options in
the Save Publication As dialog box: Files for Remote
Printing and All Linked Files. Both options copy a
document’s linked files to the same location you
choose for the document, but they work a little differ-
ently. Select the Files for Remote Printing option when
you want to copy only those files you've stored outside
the document. Select the All Linked Files option to
copy (as youd expect) all the graphics files you've
placed in your document and haven’t unlinked, re-
gardless of their storage status.

You can also use PageMaker’s Save for Service Pro-
vider plug-in to create a package of files to hand off
to your imagesetting service bureau.

Class dismissed
Thats all the time we have today. Mr. PageMaker, Ms.
Illustrator, and The Entity Known As FrameMaker may
take the remainder of the week off. The rest of you would
all do well to study their example. Empower your users
by giving them a choice, provide tools to support their
decisions, and you really can’t go wrong.

Ms. Illustrator, you are forgetting your clamshell.

Please feel free to drop me a line care of the maga-
zine or at okvern@ix.netcom.com. I'd love to hear from
you, and your comments help me make this column
better—and they're a lot of fun! I can’t always reply,
but I read and consider every message. Thanks! []

Olav Martin Kvern is a software developer, writer, de-
signer, and illustrator, and is the author of Real World
FreeHand and Real World PageMaker.



