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Getting Started

The following few pages contain important information on how to 
handle the downloaded files so you can use them with FrameMaker 
on your computer.

Requirements

To use these templates, you should have the following:

N FrameMaker or FrameMaker+SGML

All the templates work equally in either FrameMaker product. 
If you’re using FrameMaker+SGML, you can use these tem-
plates for unstructured documents; none of the templates pro-
vide element definitions.

N Version 5.5 or later

If you only have an earlier version of FrameMaker and still want 
to use one of the templates, ask a friend to save the template in 
MIF and then open and resave the file in the earlier version. 
(Any 5.5-specific formatting will be lost in the conversion.)

Installation

The most convenient place to install the template files is in the 
folder that contains the standard FrameMaker templates. By plac-
ing them in this location, they will be available whenever you create 
a new document by choosing File > New. If you prefer to place 
them in a different folder, you may have to navigate to that folder to 
find them when you create a new document.
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Windows

The six template groups are compressed in .exe format. 

To install the template files in Windows:

1 Copy any or all of the .exe files (tempac1.exe, tempac2.exe, and 
so on) to the Templates folder, which is in the folder you 
installed FrameMaker in. The default location is:

\Program Files\Adobe\FrameMaker5.5\Templates

2 After downloading an .exe file in Windows, double-click on the 
.exe file to access the file’s contents.

3 Delete the .exe files once all the files have been uncompressed.

Macintosh

The six template groups are coded as BinHex files (.hqx) and com-
pressed in StuffIt format (.sit format).

To install the template files on the Macintosh:

1 Copy any or all of the .hqx files (tempac1.sit.hqx, 
tempac2.sit.hqx, and so on) to the Templates folder, which is in 
the folder in which you installed FrameMaker. 

2 Drag the .hqx files onto StuffIt Expander to uncompress the 
.hqx files. 

StuffIt Expander is a free utility from Aladdin Systems (408-
761-6200). For more information about StuffIt Expander, see 
http://www.aladdinsys.com.

3 Delete the .hqx and .sit files once all the files have been uncom-
pressed.

UNIX

The template files in each group are collected in .tar format and 
then compressed into a .Z file. 

To install the template files in UNIX:

1 Copy any or all of the tmpltar files (tmpl1.tar.Z, tmpl2.tar.Z, 
and so on) to the following directory:

$FMHOME/fminit/<language>/Templates
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where <language> is the language version of FrameMaker 
you’re using (such as usenglish or ukenglish).

2 Extract the contents of this tmpl.tar file by entering the follow-
ing command:

uncompress -c tmpl1.tar.Z|tar xvf  - 

(If you’re extracting a different file—tmpl2.tar.Z, tmpl3.tar.Z, 
etc.—be sure to substitute that name in this command.)

3 Delete the tmpl.tar file by entering this command:

rm tmpl1.tar.Z

(If you’re deleting a different file—tmpl2.tar.Z, tmpl3.tar.Z, 
etc.—be sure to substitute that name in this command.)

That’s it. Now when you choose File > Open, you’ll have the addi-
tional template directories available in the New dialog box. 

Most of the templates contain sample text and instructions. These 
instructions are helpful when you’re using the templates for the 
first time. After a while, however, you’ll probably want to clear out 
the sample text from the templates you use regularly. If you do this, 
be sure to keep a copy of the filled-in template in case you need to 
be reminded of how it’s supposed to look or work.

Typographical conventions

The Adobe Acrobat PDF documents that make up this primer and 
the instructions for each template package make use of a number of 
typographical conventions you should be aware of:

t This format indicates an important note or warning.

M This format indicates a tip or technique that can make you more productive.

Text formatted like this, The Adobe Web site, indicates a Web link 
you can click in the PDF document to open your default browser to 
that site.

Each template instruction file (a separate PDF file) lists and 
describes the templates in that package, giving each template’s full 
name with the filename or folder name (if several templates make 
up the document) in parentheses; for example:
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Press Release (Press.fm)

is the heading for the Press Release template entry (Press.fm is the 
name of the template file). Similarly,

Dissertation (Thesis)

is the heading for the dissertation template entry (Thesis is the 
folder name).

In a few cases you might see an entry such as this,

Legal (Collect.fm, Complain.fm, Plead.fm, Will.fm)

This indicates the heading for the legal templates entry (Legal is the 
name of the subfolder which contains the files Collect.fm, Com-
plain.fm, Plead.fm, and Will.fm).
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Introduction

Template.

The origin of the word itself hints suggestively at templates and 
their value for whatever field in which they’re used. In ancient 
Rome, augurs traced out a rectangular open area of the sky—a tem-
plum—within whose confines alone could valid signs and meaning 
be sought. In Homeric Greece, a temenos (derived from the word 
temno, which means to cut, cut out, mark off) was a space set off as 
special or sacred to a ruler or god, within which only specified peo-
ple, actions, and rites were deemed appropriate or permitted.

In keeping with these distant linguistic roots, templates generate 
almost a kind of religious fanaticism or devotion among Framers. 
Like the Roman templum or Homeric temenos, a FrameMaker tem-
plate involves formats, ritualistic forms as it were, that force the 
writer to follow a certain structure or approved set of rules in order 
to create a finished, valid document of significance. Why are tem-
plates so important to this program and its users when the tem-
plates shipped with other programs generally remain untouched, 
tucked away in forgotten directories, or deleted from hard disks 
altogether? Most early FrameMaker adopters, already devotees of 
UNIX arcana, produced highly technical, complex material that 
required a highly structured presentation to be effective and com-
prehensible. In addition, most of these documents were extremely 
long—500 pages or more. The writer didn’t have the leisure to 
check and format every page (often the case with smaller docu-
ments and traditional DTP programs), but had to be able to entrust 
formatting to the program itself. FrameMaker handles that chore 
admirably with templates. It brings order to the unwieldy chaos.

The love affair between Framers and templates that developed nat-
urally in this environment has never lost its intensity even as the 
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program has become increasing popular among Windows and 
Macintosh users.

Over 150 templates

About 20 templates grace FrameMaker. You can preview them from within the 
program.

Given the importance of templates to the FrameMaker way of 
working, we’ve always thought it strange that the software shipped 
with relatively few templates—just a handful compared to the doz-
ens that accompany the leading word processors. And that feeling 
gave birth to this series.

The Adobe FrameMaker Template Series brings over 150 profession-
ally designed templates to FrameMaker users. The templates range 
from technical manuals to cookbooks, personal letterhead, and 
even Web sites you can create entirely in FrameMaker. We’ve also 
thrown in over 30 custom table formats; borders (created entirely 
with FrameMaker tools) you can use for certificates, menus, and 
invitations; and special features, such as guidelines (for layout 
work), pre-built fractions (handy for recipes), quickly customizable 
variables, and easy-to-use tables of contents that can be updated 
with just a click or two.
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Why we chose the templates we did

FrameMaker traditionally finds itself at work in corporate or tech-
nological settings. Framers have tended to be part of publications 
departments producing highly technical material or manuals for 
their companies. We’ve included a wealth of templates and other 
material of interest to this important segment of the FrameMaker 
userbase. But there’s no reason why the program should be limited 
to this niche. Accordingly, we’ve tried to include templates for a 
broader spectrum of users: pubsters, of course, but also marketing/
PR writers, administrative assistants, home office workers, and 
even casual users. We’ve tried to make templates aimed at these less 
technical users less intimidating and more intuitive to use. In some 
instances, we’ve even intentionally avoided employing some of 
FrameMaker’s more advanced features where a seasoned, savvy 
Framer would have used them automatically. 

What’s in the series

This series is not just another rehash of the documentation. It does 
not teach you how to use FrameMaker or go through a stale listing 
of every menu item. We’ve tried to put fresh food on the table. The 
Adobe FrameMaker Template Series will help you put FrameMaker 
to better use by helping you fully understand the power of tem-
plates, by supplying you with an abundant store of customizable 
templates, and by informing you of template-related resources you 
can tap. The series’ organization closely reflects these intentions:

A FrameMakerTemplate Primer

This primer covers original template creation in FrameMaker, lead-
ing you step-by-step through the process with a checklist of things 
to do or consider as you create your template’s structure and for-
mats. We take a look at template dos and don’ts to keep you from 
making some common mistakes. We also pay special attention to 
optimizing templates for on-line use as HTML or PDF files on the 
World Wide Web or on intranets. The primer also examines in 
great detail how to customize templates, covering issues of typogra-
phy and font use, graphics, and the use of variables.
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A FrameMaker Template Collection

The template collection itself is available in six template packs 
downloadable from the Adobe Web site. A PDF file accompanying 
each pack describes each template briefly, provides a screen dump 
of a representative page, describes how the template works (“Nuts 
and bolts”), and finally suggests some specific ways you might want 
to use or customize the template (“Making it your own”). In the 
case of borders, tables, letters, and some other common document 
types, we cover all the variations in one entry rather than examin-
ing each template separately.

Because we could not reliably know which fonts users have 
installed on their computers, we reluctantly restricted ourselves to 
an excruciatingly basic set of Type 1 PostScript typefaces and their 
variants: Times, Helvetica, Courier, and Symbol. Again and again, 
we found ourselves at painful odds with this self-imposed embargo 
every time we caught a tantalizing glimpse of Galliard, Stempel 
Garamond, or even Zapf Dingbats (our kingdom for a non-round 
bullet!) in the Paragraph Designer. It wasn’t fun. We encourage you 
to let your natural fontasy run free. The “FrameMaker Template 
Primer” includes some suggestions on suitable font substitutes.

FrameMaker as a Layout Program

This section describes in detail some of the innovative techniques 
we used to handle the sort of design-intensive doucments (newslet-
ters, ads, etc.) that FrameMaker normally does not handle as well as 
DTP programs such as Adobe PageMaker. In short, this section tells 
you how to break all of FrameMaker’s rules.

Essential Keyboard Shortcuts

This section lists and describes some keyboard shortcuts that tem-
plate designers can use to increase their productivity.

Localizing Templates

This section outlines the simple steps you would take if you wanted 
to localize one of our templates (most are designed with U.S. paper 
sizes in mind) for another country or language.
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FrameMaker Resources

The “FrameMaker Resources” section lists various other on-line 
and off-line sources of tools, templates, instruction, and other 
items of interest to Framers.

A “Getting Started” section following the Introduction tells you 
how to install any template packs you download. Separate instruc-
tions cover Macintosh, Windows, and UNIX installations. We’ve 
also peppered the lot with handy tips, undocumented features, and 
special techniques, all denoted with special icons, throughout the 
book. Be sure to read them. They’ll teach you some things about 
conditional text, text strings, and other FrameMaker features you 
never knew. They include the techniques and workarounds we used 
again and again in our templates.

We hope the Adobe FrameMaker Template Series makes a positive 
difference in your work. FrameMaker users have long hungered for 
more pre-made templates and a greater variety of template types 
than come with the software itself. This template series will take the 
edge off that appetite.

Bon appetit!

Dave Valiulis wrote his first long document (a 300-page doctoral 
dissertation) on a cutting-edge electric typewriter (an IBM Selec-
tric). Since then, he’s been a library assistant, a science writer, a 
production manager, and most lately a technical writer for Adobe. 
He has been a primary writer on the FrameMaker documentation 
for the last several versions.

Gregory Wasson is a long-time contributing editor to the now 
defunct MacUser and one of the founding sysops of the ZiffNet/
Mac online service (now absorbed into Computing Pro on Com-
puServe). He’s done online work for both CompuServe (now part 
of America Online) and America Online and was the Webmaster 
for NetCarta Corporation (before Microsoft gobbled it up). Per-
haps events are trying to tell him something. He has produced soft-
ware manuals and marketing material for a variety of clients, 
including Apple, Claris, Frame Technology, Live Picture, and oth-
ers. His motto: Template fugit!
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A FrameMaker Template Primer

Templates are the heart and soul of FrameMaker—brevity to 
FrameMaker’s wit. These powerful stylesheets or collections of for-
mats, page size, background elements, and master pages control a 
document’s look and feel from the get-go. In FrameMaker, tem-
plates automate and simplify document creation by combining 
composition and formatting in one efficient process. In fact, tem-
plates are so integral to the way FrameMaker functions that you 
cannot work in the program without using a template, even if the 
template provides only the most generic of formats and structure. 
It shouldn’t come as a surprise, then, that knowing your way 
around templates is the key to FrameMaker success.

You can harness the power of FrameMaker by customizing the tem-
plates provided with the software to better conform to your needs 
or the conventions of you or your company. The templates in this 
seriesor available through third parties provide another source. In 
fact, any file, even a finished document, can serve as the start of a 
template. But before you can effectively use templates obtained in 
any of these ways, you need to understand how they work. In the 
next section we’ll take a brief tour of a template in the process of 
being created from scratch so you can see how the parts fit and 
work together as a whole. If you feel comfortable with the template 
creation process already, feel free to skip this section and move on 
to the next section, “Having it your way,” on page 42.

Creating your own template

Starting
from scratch

The File > New command lets you create a template based on 
default settings for standard or custom pages in Portrait or Land-
scape orientation or use one of the standard templates that ship 
with FrameMaker. For all your effort in the New dialog box, you 
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generally walk away with a bare-bones page with one column, a 
master page with a footer and header, and a collection of boiler-
plate formats such as Body, Bullet, Numbered, Heading1, and so 
on. For most purposes, the default templates simply won’t cut the 
mustard and you’ll find yourself tailoring the template or better yet, 
simply striking out solo on that lone template trail. Starting from 
scratch really isn’t the long march you might imagine. Designing a 
template does, indeed, take some careful planning, but it can also 
be enormously satisfying and fun as you successfully gather 
together the supplies needed for the journey to a finished docu-
ment.

Page layout, columns, and master pages

Every journey begins with the first step and to start a template from 
scratch means choosing New from the File menu. Clicking Custom 
in the New dialog box displays the Custom Blank Paper dialog box 
where you define the first elements of any template: page size, num-
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ber of columns, margins, whether the document is single- or dou-
ble-sided, and the units of measurement—in other words, the 
basics. You can change any of these elements later, but it’s a lot eas-
ier to do it right now, so give this dialog box more than just a cur-
sory once over. Give it careful thought and build the template on a 
firm foundation.

Creating a consistent look and feel with master pages

Once you sign off on the initial New dialog box, the nascent tem-
plate appears, squealing and kicking, fresh with a single text flow 
and a basic set of paragraph and character formats, but not quite 
equipped for its adult responsibilities. First stop in the education of 
any template: master pages.

Every template has at least one master page. This page contains all 
the items you want to appear on every page based on the master 
page: footers, headers, background text or graphics. In most page 
layout or desktop publishing (DTP) programs, master pages are a 
traditional way to maintain a consistent look and feel across pages 
without manually mucking around on each and every page to make 
sure page numbers fall in the same location or that graphic ele-
ments are properly aligned. In FrameMaker, you access the master 
page area by choosing View > Master pages. You scroll through the 
pages, if more than one exists.
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M While in the Master Pages area, switch the viewing size to 25% to see all the master pages dis-
played as thumbnails. You can easily click a master page you want to edit and then switch back 
to a more practical viewing size.

Some templates may have more than one master page. For exam-
ple, a template for chapters in a book or manual may have three 
master pages: first, right, and left. The first master page might have 
a special layout and graphics for the title page at the start of a chap-
ter. Right and left master pages would incorporate the look and ele-
ments you want to appear on the rectos and versos that make up 
the rest of the chapter. You might have other master pages (as many 
as a hundred) for other special-purpose sections of a document, 
such as fold-out or rotated pages.

A newly created, custom template will have at most two master 
pages, depending on whether the document is single- or double-
sided. One text flow named “A” graces the master page(s). Each 
automatically generated master page will also have a header and a 
footer. You can change any of this (remove the header or footer, 
change its location, resize the text flow). We’ll talk more about that 
later. You can add background text to a master page, but text placed 
or typed in a master page text flow will not appear on body pages 
when you switch back to normal viewing via View > Body Pages. 
Headers and footers buck that limitation. You can enter text, sys-
tem or user-defined variables (such as page number or count, date, 
or running headers/footers), and graphics in the header/footer text 
frames. Anything placed there will appear in Body pages view.
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Controlling text with paragraph and character formats

The use of text on master pages brings us to the issue of controlling 
how text looks (its font, point size, color, etc.) throughout a docu-
ment. Just as master pages control the general page layout, para-
graph and character formats control how text looks at the 
paragraph level or even letter by letter. FrameMaker’s Paragraph 
and Character catalogs correspond to the stylesheets found in some 
word processors or DTP application software. Creating the individ-
ual formats of these catalogs is the next step in transforming a 
fledgling template into a powerful, independent tool.

M FrameMaker provides two paragraph formats for creating numbered steps: Numbered1 and 
Numbered. Numbered1 starts numbering at 1 (the autonumber format is defined as: <n=1>.\t) 
and then hands off to the Numbered format for the rest of the steps. Unfortunately, if you need to 
add a step before it, you can’t just place the insertion point at the beginning of step one and 
press Return. If you do, you end up with two step ones. A better way to handle numbered steps is 
to adopt the convention that the paragraph before the numbered steps always resets the num-
bered step autonumber series. Rename Body to “NumberedIntro” and save it to the catalog as a 
separate format when prompted. Enter the following as the autonumber format: S:< =0> where 
S is the label for your steps autonumber format. Another option is to let Body itself reset the 
autonumbering series.

Each template comes with a set of basic formats for paragraphs and 
characters, ranging from text for body material, heads, bulleted or 
numbered lists, and table cells to character formats to make single 
words within a paragraph bold or italic. Why not just apply font, 
size, and style selections from a menu? Because formats make 
quick, painless changes on a document-wide scale possible. You 
have to reformat text formatted on the fly paragraph by paragraph, 
word by word. Text controlled by FrameMaker formats, on the 
other hand, changes instantly throughout a file if you change the 
corresponding formats.
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Formats are forged, blow by blow, within two mighty dialog boxes:

N The Paragraph Designer (Format > Paragraphs > Designer)

N The Character Designer (Format > Characters > Designer) 

The Paragraph Designer is a dialog box with a series of tabbed 
sheets where you have total control over a paragraph’s look. 
FrameMaker lets you muck around with the basics, such as font, 
point size, and alignment, but the true test of its mettle comes in 
the details: pair kerning, autonumbering, default text strings, 
stretching text (FrameMaker 5.5 or later only), hyphenation and 
word spacing, widow/orphan control, space above/below, leading, 
change bars, and next paragraph links. While designing a template, 
you’ll spend so much time in the Designer, that the keyboard short-
cut to display it will become a personal mantra: Control+M (Win-
dows), Command+M (Macintosh), Esc o p d (UNIX). Some 
Framers find it more efficient to dispense with the keystroke alto-
gether and simply leave the Paragraph Designer open all the time. If 
you have enough available screen real estate, it makes sense to let 
Paragraph Designer and other frequently used non-modal dialog 
boxes move in.
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The Character Designer in FrameMaker.

The Character Designer basically serves as a way to selectively over-
ride the type-related aspects of a paragraph format, including font, 
point size, weight, and so on. Instead of formatting an entire para-
graph, character formats let you format single words, phrases, or 
even just characters. Like paragraph formats, character formats let 
you quickly change the look of text by simply changing the defini-
tion of the character format itself. Any words or characters con-
trolled by that format instantly change to reflect the new definition. 
For example, you might need to emphasize a word in a paragraph 
occasionally. You create a character format called Emphasis that 
makes selected text bold. Later you decide italics makes more sense 
as a way to draw attention to emphasized words. Instead of search-
ing for all bold words in a document, you can simply change the 
definition of the Emphasis character format from bold to italics 
and presto! Previously bold words bow humbly.

M The Numbering property of a paragraph format creates autonumber schemes, such as numbered 
steps. You can also use it to insert default text at the beginning of a paragraph, such as “Note:” 
or “Warning” by entering the text in the Numbering property area of the Paragraph Designer. You 
can use this ability to prompt a typist for specific information in a form letter or invoice. For exam-
ple, the Customer format might insert the label “Customer” and then seemingly pause for the 
typist to enter a name and press Return. Customer might link to Street which automatically 
inserts the label “Street” and then waits for the typist to enter the street address. It’s an easy way 
to automate data entry in certain kinds of business documents and thus make an employee more 
productive. The template invoice.fm makes use of this technique, as do many others.
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Paragraph and character formats in FrameMaker, when thought-
fully designed and not merely cranked out with indifference, can 
do more than just distinguish an otherwise dull document with a 
distinctive look and feel. Properly equipped, a paragraph format 
can insert default text automatically, or pass the controlling torch 
onto another format (from Heading1 to Body, for example) when 
it has run its course (and you’ve pressed Return), thus saving you 
or the user of your template time and keystrokes. 

Setting up reference pages

Not content with mere body and master pages, FrameMaker relies 
on another page type called the reference page (View > Reference 
Pages). A template can have as many as 100 reference pages. 
Together they form a kind of document warehouse stocked to the 
ceiling with boilerplate graphics, lines (rules), entries that control 
HTML output, heading levels, formatting for generated files, and 
special macros or mappings. When a document needs a special 
item that is stored in the reference pages, such as a single horizontal 
line to place below a heading, the document can simply grab it off 
the shelves, so to speak.

Reference pages offer several advantages. They help keep 
FrameMaker documents smaller by storing frequently used mate-
rial, such as graphics or boilerplate text in one place. This lets you 
display, for example, a special graphic icon or rule above or below a 
paragraph several times in a document without copying the 
graphic multiple times into the file, inflating its size with each addi-
tional instance. The graphic exists only once—on the reference 
page in a named frame. Reference pages also help maintain consis-
tency in graphic placement throughout a document, since reference 
page graphics retain the alignment, spacing, and other attributes of 
their frames when brought into a body page. Even the most generic 
template has, at a minimum, about six reference pages, one with 
predefined lines (for use above or below paragraphs) and several 
pages of special mappings that control HTML conversions. We’ll 
get back to some reference page chicanery you can profit from later.

Aren’t we special!

FrameMaker teems with a variety of special text items ideal for 
working in long documents, documents destined for online use, or 
dynamic documents. They even reside in their own menu with the 
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highly appropriate name Special. You’ll find some of them indis-
pensable as you create your own templates or customize the ones in 
this series.

Cross references send readers off to related passages. 

M You usually use cross-references and Special > Cross-Reference to direct readers to another loca-
tion in a document, but a writer can also exploit them as navigation tools while working within a 
long document to jump to distant passages or sections in a flash. Simply open the Cross-Refer-
ence dialog box with Special > Cross-Reference. Select a paragraph tag, such as Heading1 or 
Heading2, that denotes a major section in your document. A list of paragraphs formatted with 
the chosen tag appears. Highlight one and click the Go to Source button to warp off to that sec-
tion of the document through your cross-reference wormhole. Using cross-references this way 
wasn’t the intention of the Great Framer; but, as the Klingons say, “Hoch nuH yIqel!” Consider 
every weapon!

The Cross-Reference dialog box can help you naviagte around a long document.

Variables serve as placeholders, displaying their definition. Change 
the definition, and what the variable displays changes instantly, no 
matter how many times you’ve inserted the variable in your tem-
plate or document. Special system variables store handy bits of 
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information such as the time and date, page number, number of 
pages, filename, and other data. Other variables, such as those for 
running headers or footers, steal their definitions from headings or 
other paragraphs, displaying that text wherever you’ve placed run-
ning headers or footers.

M User-defined variables tend to be a single word: a role in a play, a product name that may change 
as documentation is prepared—in short, a single line or less. In fact, the definition cannot exceed 
255 characters. But you can create multi-line variables by typing \r in the definition wherever you 
want to insert a line break. This technique is handy for storing an address that might change fre-
quently or any other information that might take up several lines.

Creating a variable with multiple lines.

Other special text items you’ll probably use at some point are index 
markers, footnotes, conditional text (text sections of a document 
that can be turned on or off), hypertext markers for creating jumps 
within a FrameMaker document or to prepare a document for use 
as PDF or HTML. You can read a lot more about online documents 
and FrameMaker’s features for creating them in “Optimizing a 
template for online use as HTML,” on page 22.

Templates for generated files

Templates for generated files such as TOCs or indexes are also spe-
cial, unique creatures unto themselves. Here’s a case in 
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FrameMaker, moreover, where you generally start with a file and 
create the template for it afterwards, placing the cart before the 
horse, as it were. Most often, you open a document and generate its 
TOC or index. You then open the generated files and turn them 
into a template by creating master pages, formats, and other ele-
ments; and save them under the default name for a TOC or index. 
For example, if the main file is book.fm, the TOC will be automati-
cally named bookTOC.fm and the index will be bookIX.fm. You 
must retain these names for your templates or any subsequent TOC 
or index generated from the main file, as updates to previous gen-
erated files will not reflect your carefully designed formatting and 
page layout. The default for generated files is the underlying page 
layout of the source document with all TOC and index entries 
appearing the same.

M Documented, but seldom remembered, is the technique you use to generate pagination such as 
2-3 (Chapter 2, page 3) in a table of contents or index. You can fiddle with a paragraph’s Num-
bering property until you scream, but the answer lies elsewhere in a mysterious place called the 
book file. To accomplish this sort of numbering, all files must be part of a book file. Open the 
book file and choose File > Set Up File. The Set Up File dialog box appears. Enter 1- (or whatever 
chapter number is appropriate) in the prefix area. Do this for each document in the book file.

You can enter prefixes to page numbers (such as 1-, 2-, etc.) in the Set Up File 
dialog box for book files.

Some aspects of formatting generated files, however, are anything 
but straightforward and require some explanation. Each generated 
file has a special text flow located on a reference page with place-
holders representing the actual text that appears on the body pages. 
It’s here and not on the main body page, however, where you do 
most of your formatting. The entries are tagged with paragraph 
formats, with names derived from the paragraph formats the 
entries had in the source document. For example, a Heading1 entry 
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adopts a Heading1TOC tag in a TOC. You must change these gen-
erated formats to reflect the way you want the TOC or index to 
look. To insert tabs (between a TOC entry and its page number), 
you do this on the appropriate reference page, placing the tab 
between the default placeholders as shown in the illustration.

It can be a complex process, but is fully explained in the 
FrameMaker User Guide. We’re providing only the most basic over-
view so you can understand the role of generated files in the tem-
plate creation process.

t Some Framers prefer to create a template for the generated file 
before the file is generated, thus placing the template horse sensibly 
back in front of the generated file cart. To do this, simply create a blank 
document based on the template for your main file (this helps keep 
footers, headers, page numbers, and so on consistent and aligned 
properly). Give the template file the same name that FrameMaker 
would automatically create when generating a TOC or index, as 
already explained. Likewise, design formats with the names 
FrameMaker would auto-generate: Heading1TOC, Heading2TOC, and 
so on. Place this template in the same directory as the source file. 
When you generate the TOC or index, FrameMaker will use your tem-
plate.

Optimizing a template for online use as HTML

FrameMaker (version 5.1 or later) has climbed aboard the Internet 
bandwagon by incorporating a number of features designed to turn 
it into a Web and PDF publishing powerhouse—or at least nudge it 
along in that direction. There’s always room for improvement, but 
starting with version 5.1 (with a special plug-in available at the 
Adobe Web site), FrameMaker makes single sourcing for print, 
HTML, and PDF output more and more practical. Here are some 
guidelines that should help you avoid mistakes and make the most 
of FrameMaker as a cybertool as you develop your own templates 
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or customize existing ones for online use. This section assumes you 
are using at least FrameMaker 5.5.

t FrameMaker tables translate over to standard HTML tables, but 
there are some limitations and caveats. Cell color, cell border widths, 
rotated text, and table size do not carry over, but perish in the transla-
tion process. The documentation tells you that you can control whether 
the table has borders or not. But it doesn’t make it clear that you must 
specify the table’s borders in the Table Designer. Any setting you make 
with Table > Custom Ruling & Shading (even to turn borders on or 
totally off) FrameMaker ignores during the conversion to HTML.

Spinning a Web with FrameMaker’s HTML capabilities can be fun, 
challenging, frustrating, and exhilarating all at once. On the plus 
side, you can produce attractive HTML pages and incorporate 
them in an existing Web site without extensive knowledge of 
HTML and without leaving the familiar WYSIWYG environment 
of FrameMaker—at least if you stick to relatively basic, no-non-
sense page layouts. On the negative side, FrameMaker’s HTML 
capabilities seem largely aimed at producing plain, corporate-ori-
ented pages totally lacking in the multimedia pizazz and wired 
design of many Web sites. In other words, we’re talking technical 
manuals, press releases, product data sheets, company directories, 
and white papers where one text flow, a body format, and perhaps a 
couple of heading levels suffice. Sideheads, runaround graphics, 
and other advanced design elements just don’t fly. FrameMaker, in 
short, is not Adobe PageMill. That said, this book has the audacity 
to include two templates for creating full-fledged, if rather simple 
Web sites: one for personal use, the other for creating a corporate 
presence on the Web. It can be done. If you do want your 
FrameMaker document to appear on the Web exactly as it appears 
within FrameMaker, Adobe’s PDF format is a practical alternative 
we’ll discuss later. It requires that visitors to your site install a free 
browser plug-in, but you may find the results merit this inconve-
nience.

M You might expect FrameMaker to append the .htm or .html extension automatically when you 
save a file as HTML. Oops! It doesn’t. You can bypass this sign of sloth by appending it yourself in 
the Save dialog box. Once you do, FrameMaker, shamed to the task, will add the extension to any 
other HTML files generated.

When you save a FrameMaker document as HTML, the program 
saves everything in the main text flow, text and anchored frames, to 
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the generated HTML file(s). Text or graphics from the master pages 
disappear. FrameMaker uses settings on the HTML reference pages 
(View > Reference Pages) to determine which HTML tags corre-
spond to the paragraph formats you used in your FrameMaker 
document and formats the HTML page accordingly. You can set the 
mapping before the conversion by choosing File > Utilities > 
HTML Setup (see following illustration). If you don’t do it, 
FrameMaker will, and you may not be happy with the results.

Normally, the entire FrameMaker file gets pumped into one HTML 
file (and hence one scrolling page), but you can designate any head-
ing in the source file to force FrameMaker to generate a separate 
HTML file/page whenever it encounters that heading. The first 
HTML file contains links to the secondary pages. The result is a 
fairly pedestrian, but useful series of linked HTML pages or even a 
complete Web site. We’ve used a sneaky variation of this technique 
in the Personal Web Site Template that awards you with much more 
flexibility in designing an attractive home page. Check out that 
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template and the Corporate Web Site for some ideas and examples 
of how to get the most out of FrameMaker’s HTML prowess.

M FrameMaker provides a palette imbued with all the colors that nature and Pantone provide. 
Unfortunately, only 216 of them work across platforms on all browsers. Browsers dither other col-
ors and the results aren’t always very pretty. You can avoid the problem by restricting yourself to 
the 216 Web-safe browser colors. FrameMaker 5.5.3 and later have a built-in Web safe color pal-
ette called Online that version 5.5 lacked.

Table 1: FrameMaker to HTML Reminders

Remember Comments

1 Avoid format overrides Overrides are the Devil’s snares; a professional shouldn’t be 
using them. Create new formats or expect a sloppy conver-
sion to HTML that can’t be blamed on the software.

2 Avoid complex page design HTML was never intended for complex page layouts and 
can’t handle side heads, complicated hanging indents, drop 
caps, and irregular runaround graphics. Keep documents 
intended for online use simple and elegant.

3 Use File > Utilities > HTML Setup 
to map formats to HTML tags

FrameMaker’s default mapping is seldom 100% on the mark. 
Always do this step manually or be prepared for some amus-
ing and confusing HTML formatting faux pas.

4 Set table borders in Table Designer, 
not with the Table > Custom Ruling 
& Shading command

Borders are an all-or-nothing affair in the great FrameMaker 
to HTML chase. Custom settings are ignored.

5 Map special characters to HTML 
substitutions on the HTML refer-
ence pages (Character macros 
table).

Smart quotes, copyright symbols, angle brackets, em dashes, 
and more are simply not in the parlance of HTML. Instead of 
dumbing down your source document, map these typo-
graphical niceties to straight quotes, (c), double hyphens, 
and so on. Some are already mapped for you.

6 Open all documents in a book file 
before converting

Error messages can disrupt the conversion process.

7 Resolve all cross-references before 
converting

Broken links await the disobedient.

8 Make sure Copy Files Imported by 
Reference is enabled in File > 
Utilities > HTML Setup

Broken graphic links will mar the HTML page without this 
setting.

9 Tag the .html or .htm extension on 
to the file name when you save to 
HTML

There’s just no Web connection without that three- or four-
letter extension!
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Finally, the HTML reference pages (see following illustration). 
We’ve mentioned them once before as a source of settings 
FrameMaker relies on to parse a document into HTML. They also 
store snippets of HTML code the documentation calls HTML mac-
ros. For example, you can create horizontal rules in FrameMaker by 
placing lines in anchored frames. They become GIFs during the 
conversion. But you can minimize your page’s graphic load by 
defining a “macro” with a single line of HTML code to draw a hor-
izontal rule and then inserting a marker (Special > Marker) on the 
body page that calls this macro. Unlike the GIF line, the macro-cre-
ated line will expand as needed to fit the browser window. The 
FrameMaker User Guide contains full details on how to do this.

M FrameMaker doesn’t let you print reference pages, but here’s a workaround in case you need hard 
copy of the HTML reference pages for reference. Open a blank new document. Choose File > 
Import > File, select the file with the reference pages you want to print, and click Import by Copy 
or Import by Reference. The Import dialog box appears and lets you elect to import the Reference 
Page Flow. Choose HTML from the popup menu and click the Import button to flow the HTML ref-
erence pages onto the body pages of the new document. Now you can print the pages without so 
much as a murmur from FrameMaker.
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PDF PDQ!

t This section, as did the previous one, assumes you use at least 
FrameMaker 5.5. If you aren’t using the most recent release, you will 
not be able to take advantage of the product’s growing Internet capa-
bilities.

The Adobe PDF format offers far more flexibility in presenting 
your documents online than does HTML—and it’s far easier deal-
ing with PDF than with the various HTML variables you have to 
consider when saving out to HTML. Starting with version 5.5, 
Adobe Acrobat technology is increasingly integrated within 
FrameMaker. In fact, if you installed the Acrobat software when 
you installed FrameMaker (it’s an option during the FrameMaker 
installation), you simply choose File >Save As and select PDF from 
the dialog box popup to save the current document as a PDF Acro-
bat file. FrameMaker generates some PostScript, launches Acrobat 
Distiller, and feeds Distiller the PostScript. A few moments later, 
out comes a spanking fresh PDF version of your document. The 
process takes place transparently. You might not even notice it’s 
happening. No alerts pop up, no progress indicators fill. It’s almost 
a no-brainer.
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Although the procedure soars along on autopilot, you can exert 
some control over the process before it starts and you can take 
some steps to prep your document for optimal use online.

Just after you click the Save button to generate the PDF file, the 
Acrobat Setup dialog box (see illustration above) offers you control 
over which paragraph tags will be used to create Acrobat book-
marks (for navigation within the Acrobat PDF file) and how to 
thread articles: by text frame (single column documents) or by col-
umn (the best choice for multicolumn layouts). The default choices 
for the tag/bookmark mapping are seldom satisfactory, so make 
sure you pay attention to this dialog box or you’ll regret it later.

After the file is converted to PDF, any cross-references or hyperlinks 
in the file become links in the PDF version. You can also explicitly 
set up URLs in the FrameMaker document. They transform into 
active Web links in the PDF file that open in your default browser 
when clicked. Take the time to enhance any document destined for 
online use with online features. FrameMaker makes it easy to turn 
any text or graphic into an active URL link. You simply select the 
text or draw out a text box on top of an area of a graphic in an 
anchored frame and set a hypertext URL message command 
(Special > Hypertext). It’s easier than entering HTML code.
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The Hypertext dialog box lets you enter links to URLs in FrameMaker documents.

You might consider using conditional text to include additional 
online material or variants of existing paragraphs edited for online 
use in a document also used in print form. A simple flick of a con-
ditional text switch could flip you between the online and print 
forms of the same file, thus controlling the content of the HTML or 
PDF versions of the same FrameMaker source document.

M Problems converting a file to PDF? Cherchez la printer driver. Faulty,out-of-date, inferior printer 
drivers are the most common culprits in PDF file conversion mishaps. ALWAYS install an Adobe 
printer driver (included on the FrameMaker install disc) for the best results.

In addition to single documents, you can convert multiple linked 
files or book files. All links remain intact after the conversion pro-
cess. Refer to the FrameMaker User Guide for details.

The downside to all this, of course, is that end-users have to config-
ure their browsers and install a free plug-in or the Acrobat Reader 
in order to benefit fully from PDF. Some people would rather eat 
ground glass than do so. Therein lies the rub.

M When you save as PDF or HTML, you may notice a puzzling phenomenon—when you open the 
PDF file or view the HTML page in a browser, everything might seem smaller than it did in 
FrameMaker. What causes this? Alien probes? Occult interference? A shadowy and nefarious con-
spiracy? Nope, but the truth is out there, and you can find it by choosing File > Preferences. The 
Monitor Size setting (present in the Windows version only) in the Preferences dialog box (see 
illustration following this tip) lets you control how FrameMaker displays your document based on 
your monitor size. Why is this important? In Windows, monitors come in many physical sizes and 
can have many resolutions (dots per inch), which has the effect of defining a logical size. Given 
all the possibilities, should FrameMaker display a document so that, at 100% zoom, it is dis-
played at the same size as it will print, or should it display a document based on the current reso-
lution? If the former, 1 inch on the FrameMaker ruler will be the same as 1 inch on paper. If the 
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latter, 1 inch on the FrameMaker ruler may not match a real inch at all (if, for example, you’ve 
upped the dpi of your monitor to squeeze more info on a screen). Most Windows users don’t 
notice that their onscreen ruler doesn’t match a real-world ruler in their applications (hold a ruler 
up to the screen in Word, for example), but FrameMaker takes WYSIWYG more literally than most 
applications. FrameMaker lets you resolve this issue by offering a Monitor Size setting that recal-
ibrates what 100% zoom looks like to compensate for your physical and logical monitor size. You 
can choose Default to let FrameMaker work as other Windows applications, or you can enter an 
explicit monitor size to recalibrate (you may or may not have to enter your actual monitor dimen-
sion, depending on the current dpi setting of your monitor). You can enter monitor sizes from 
0.05" to an amazing 455".

The Monitor Size setting in the Preferences dialog box (Windows only) affects the 
apparent size of your pages on the screen.

Designing sensibly

Designing for online use is part of a more general issue that needs 
to be kept in mind as you bring your template up from its infancy 
to maturity: designing appropriately for the template’s intended 
users. Don’t use inappropriate features for the users of your tem-
plate. Neither an administrative assistant nor marketing staff need 
a template based on the complexities of a FrameMaker book file. 
KISS, if the user’s needs warrant it.
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M Framers usually keep TOCs as separate files, including them with a project’s other documents in a 
book file. That can be overkill on a grand scale if the base project is a simple pamphlet or booklet 
best handled in a single document. In this sort of smaller document, generate and format the TOC 
as usual (see “Templates for generated files,” on page 20 and the FrameMaker User Guide), but 
don’t create a book file to combine it with the source document. Instead, create a page for the 
TOC in the source document and choose File > Import > File to copy the generated TOC into the 
page by reference as a text inset. Then if the source document changes, generate the TOC again, 
double-click the TOC text inset in the source document, and click the Update button.

In general, don’t let the template get away from you. Template fugit. 
It’s easy to become so distracted by the creation of elaborate for-
mats, autonumbering schemes, and other FrameMaker arcana that 
you lose sight of the goal: good, elegant design that makes informa-
tion a breeze to enter, interesting to look at, and easy to understand.

The following few pages contain an extensive checklist you might 
want to go through each time you design a template. The table out-
lines the things to do when creating a template, roughly in the 
order in which they should be done. Such a checklist is not defini-
tive—many of these steps have no correct order, but all of them 
should be considered at some point or another during the creation 
process. That’s the important thing.

Table 2: What to do when creating a template  (sheet 1 of 11)

Task Comment How to

1 Open a standard template 
that’s similar to your goal, 
and save it under a new 
name.

This will save you a lot time 
defining formats. Think 
about what the name should 
be: BookTemplate.fm, 
Generic.fm, StartHere.fm, etc.

Open one of the formats from this 
series of template packs, or use the 
formats that come with 
FrameMaker. Choose File > Save As.

2 Decide if you want to 
enter values in inches, 
points, centimeters, etc.

Values will be more under-
standable to you if you use a 
unit of measurement you’re 
familiar with.

Choose View > Options > Display 
Units.

3 If want to use color, 
decide on a color model 
and define the colors 
you’ll be using.

Color can be expensive to 
print. Consider defining grays 
or a range of tints from one 
color. If you’re writing for the 
Web, use the Online color 
library provided in version 
5.5.1 and later.

Choose View > Color > Definitions.
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Decide on page layout...

4 Set up page size (trim 
size) and double-sided-
ness.

Not needed if the original 
already is the size you need.

Choose Format > Page Layout > 
Page Size.

5 Decide on overall page 
layout (margins, side-
head area, number of col-
umns, etc.)

If you’re unsure, look at some 
examples or ask for advice.

Choose Format > Page Layout > 
Column Layout.

6 Decide on special master 
pages that might be 
needed.

Do you need a special master 
page for the first page of the 
chapter, or for a landscape 
table? Avoid too many custom 
master pages because they are 
hard to maintain later on.

1. Choose View > Master Pages.
2. Choose Special > Add Master 

Page.

7 Set up master pages with 
all the needed back-
ground text frames.

Text or objects in these frames 
will appear on each page that 
uses that master page.

Choose View > Master Pages and 
then use the Text Frame tool to add 
background frames.

8 Turn on Smart Quotes 
and Smart Spaces.

Both are recommended in 
most templates.

Choose Format > Document > Text 
Options.

9 Will the document use 
footnotes?

You may need a special for-
mat for footnotes. (And be 
sure to set the maximum 
height of a footnote to some-
thing large to prevent foot-
notes from falling onto the 
next page.)

Click in body text (not in a table) 
and then choose Format > 
Document > Footnote Properties. 

10 Examine catalogs for for-
mats you can remove, 
then delete them.

The fewer formats the easier 
your template will be to use. 
The standard FrameMaker 
templates continue to ship 
with a character format called 
EquationVariables—you can 
get rid of this one for sure.

Click the Delete button at the bot-
tom of the catalogs. Click Delete as 
often as needed, and then click 
Done.

11 Decide on your overall 
font families and point 
sizes. Decide which font 
will be used the most 
(usually the body font).

Font decisions dictate many 
decisions later. Font sizes 
affect tab stop positions.

Consult a designer if needed. In a 
workgroup, you may be restricted to 
a standard set of fonts.

Table 2: What to do when creating a template  (sheet 2 of 11)

Task Comment How to
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Create character formats...

12 Apply the font family 
(and other universal font 
settings such as Pair 
Kern) to all character for-
mats.

This will save you having to 
set these options over and 
over later.

1. Open Character Designer.
2. Choose Set Window to As Is from 

the Commands pop-up menu.
3. Choose the font family you want 

(and other universally needed 
properties).

4. Choose Global Update Options 
from the Commands pop-up 
menu.

5. Click Characters and Catalog 
Entries and click Update.

13 Add formats as needed. Do you need an underlined 
format? a small caps format? 
You probably will need a for-
mat for bulleted or num-
bered lists.

Choose Set Window to As Is from 
the designer’s Commands pop-up 
menu. Type a name in the designer’s 
Tag text box, click Apply, and then 
click Create.

14 Go though the character 
formats, one by one, 
checking that the proper-
ties are As Is except for 
the ones you want to be 
applied.

Most of the properties in 
most character formats 
should be set to As Is.

Control-click (Mac: Command-
click) a format name in the catalog 
to “stuff” it into the Designer, edit 
properties, and then click Update 
All.

Create paragraph formats...

15 Rename formats to group 
them as needed and to 
optimize them for use 
with other, related tem-
plates.

For example, consider start-
ing all table-cell formats with 
Tbl and all headings with 
Head.
If your workgroup uses a set 
of related templates, keep the 
naming conventions the 
same.

Click in text formatted in the format 
you want to rename, change the 
name in the Paragraph Designer’s 
Tag text box, and click Update All.

Table 2: What to do when creating a template  (sheet 3 of 11)

Task Comment How to
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16 Apply the body font (and 
other universal font set-
ting such as Pair Kern) to 
all paragraph formats.

This will save you having to 
set these options over and 
over later.

1. Open Paragraph Designer and 
display Default Font properties.

2. Choose Set Window to As Is from 
the Commands pop-up menu.

3. Choose the font you want (and 
other universally needed proper-
ties).

4. Choose Global Update Options 
from the Commands pop-up 
menu.

5. Click Default Font Properties 
Only and then click All Paragraph 
and Catalog Entries.

6. Click Update.

17 Go though the paragraph 
formats, one by one, 
applying and checking 
font properties.

Headings are often in a differ-
ent size and font than body 
formats, and sometimes in a 
different color.

Control-click (Mac: Command-
click) a format name in the para-
graph catalog to “stuff” it into the 
Designer, edit properties, and then 
click Update All.

18 Check the Language 
property of each format.

A language such as US 
English will do for most, but 
formats you don’t want spell-
checked or hyphenated (such 
as Code) should be set to 
None.

Choose None from the Language 
pop-up menu in the Designer and 
then click Update All.

19 Check the Keep With 
property of each format.

Headings should be kept with 
Next. Bullets should be kept 
with Previous.

Click Next ¶ or Previous ¶ in the 
Keep With area of the Pagination 
properties. Click Update All.

20 Adjust spacing between 
paragraphs.

This can be tricky; should you 
use Space Above or Space 
Below? Headings should have 
a large space above and a little 
or no space below. Use a con-
sistent amount of space below 
(or above) in all body for-
mats.

Enter values in the Space Above and 
Space Below text boxes and then 
click Update All.

Table 2: What to do when creating a template  (sheet 4 of 11)

Task Comment How to
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21 Adjust indents and tab 
stops.

Check the indents of bulleted 
and numbered lists. If they 
use tabs, the Left indent 
should match the first tab 
stop. 
Most formats don’t need 
many tab stops, but some may 
need a lot (such as Code).

In the Basic properties, enter values 
in the First and Left text boxes, and 
create tabs as needed. Click Update 
All.

22 Decide on your autonum-
bering strategy.

Do you need a Numbered1 
format? How many numbered 
series will you have? (Tables, 
lists, and headings?)

Implement series counters in the 
Autonumber Format text box. Be 
sure to specify a character format for 
numbered lists and bulleted lists.

23 Decide on the Next ¶ Tag 
format.

Leave this blank if you want 
the same format to repeat 
when users press Return. 
Headings usually automati-
cally go to Body or the like.

Select a format from the Next ¶ Tag 
text box and then click Update All.

24 Do you need ruling lines 
with headings?

If so, you need to name and 
draw them on the reference 
page before creating the for-
mat.

In the Advanced properties of the 
paragraph Designer, choose from the 
Frame Above ¶ pop-up menu or the 
Frame Below ¶ pop-up menu. Then 
click Update All.

25 Do you want hyphen-
ation globally on or off?

Casual works seldom hyphen-
ate nowadays; more formal 
works do.
You can also turn it on or off 
for specific formats.

1. Open Paragraph Designer and 
display Advanced properties.

2. Choose Set Window to As Is from 
the Commands pop-up menu.

3. Set hyphenation as wanted.
4. Choose Global Update Options 

from the Commands pop-up 
menu.

5. Click Advanced Properties Only 
and then click All Paragraph and 
Catalog Entries.

6. Click Update.

Table 2: What to do when creating a template  (sheet 5 of 11)

Task Comment How to
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Set up headers and footers...

26 Define the headers and 
footers on the master 
pages.

Will they pick up the text of 
the current chapter or head-
ing? Will they be different on 
a recto and a verso?

1. Insert the Running H/F 1 variable 
or the Running H/F 2 variable on 
a master page background text 
frame.

2. Double-click it and redefine to 
use the text of the format(s) you 
want.

3. Format the text and variable.

27 Will page numbers pick 
up chapter numbers?

Some industries prefer the 
2-3, 2-4, 2-5 type of page 
numbers, but such number-
ing can make indexes clut-
tered and hard to read.

Use a Running H/F variable in con-
junction with the Current Page # 
variable.

Decide on graphics issues...

28 Will you need a standard 
size graphic frame?

If so, create it and store it on 
the reference page so users 
can copy it.

1. Use Special > Anchored Frame to 
create a frame.

2. Cut the frame to the Clipboard.
3. Go to the reference page and drag 

out a text frame there and paste 
the anchored frame.

29 Do you need a paragraph 
format just for anchored 
frames?

It’s more convenient to 
anchor a frame to the end of a 
body paragraph, but you have 
more control over spacing if 
you create a special paragraph 
format just for anchoring.

30 Do you need a standard 
piece of artwork?

For example, a small “tip” 
icon is more convenient when 
placed on the reference page 
of the template rather than 
having to import it. But don’t 
overdo it; graphics added to 
templates add to file size.

Copy the graphic and paste it on the 
reference page.

Table 2: What to do when creating a template  (sheet 6 of 11)

Task Comment How to
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Create table formats...

31 Remove Format A and 
Format B, if present, or 
give them more descrip-
tive names.

Much better names might be 
2col, 3col, PriceList, etc.

To delete a table format, open the 
Table Designer and choose Delete 
Format from the Commands pop-
up menu.
To rename a format, insert a table 
with the format you want to rename, 
change its name in the Table Tag text 
box, click Update All.

32 Set up the number of col-
umns and rows.

This will be the default, but 
users can override this when 
they insert a table.

Insert a table and change it to the 
number of rows and columns you 
want. Then click Update All in the 
Table Designer.

33 Double-check that you 
have the paragraph for-
mats you’ll need.

You may want a special table 
cell format for table titles, 
headings, body cells, body 
cells with numbers, etc.

If you need to create some paragraph 
formats for tables, go back to 
Step 15.

34 Set up the paragraph for-
mats you want used in the 
table.

Again, this will be the default, 
but users can override this 
when they insert a table.

Apply a format to the headers and 
body rows. Then click Update All in 
the Table Designer.

35 Set the basic properties 
for the table.

Will the table have a title? Will 
the title be autonumbered?
Adjust margins, indents, and 
space above/below so that the 
table fits in with the look of 
the rest of the template 
design.

Set the Basic properties in the Table 
Designer and click Update All.

36 Will the table be allowed 
to break across pages?

Tables meant for fewer than 8 
rows should probably not 
break.

To prevent breaking, set the Orphan 
Rows property to 255 in the Table 
Designer and click Update All.

37 Will the table use foot-
notes?

You may need a special for-
mat for table footnotes.

Click in any table and then choose 
Format > Document > Footnote 
Properties.
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38 Set up regular ruling, if 
needed.

“Ruling” just means the lines 
used to separate rows or col-
umns. You may need special 
types of lines defined (such as 
the white line used in this 
table).

1. Define a special rule if needed by 
choosing Table > Custom Ruling 
& Shading and then clicking Edit 
Ruling Style.

2. Set up the Ruling properties of the 
Table Designer and click Update 
All.

39 Set up regular shading, if 
needed.

You may need special colors 
for the table.

1. Define a special color if needed 
(see Step 3).

2. Set up the Shading properties of 
the Table Designer and click 
Update All.

40 Adjust any paragraph for-
mat that might be used in 
a table cell that no longer 
indents correctly.

For example, a Code format 
that starts with an indent will 
be too indented when placed 
in a cell.

Adjust the Table Cell properties in 
the paragraph Designer for that for-
mat.

41 Will you need a table for-
mat strictly for position-
ing purposes?

You could use an “invisible” 
table to simulate a 3-column 
bulleted list.

Assign no heading rows, no ruling, 
no shading, and no title. Assign body 
formats to the cells.

Create cross-reference formats...

42 Remove formats you 
won’t need.

The fewer formats, the easier 
they will be to use.

Choose Special > Cross-Reference, 
click Edit Format, and then click 
Delete.

43 Add formats you’ll need. Will you need to refer to 
chapter names (and num-
bers), table numbers, num-
bered steps, headings, etc.?
Will the document use end-
notes? (Endnotes are a special 
case of cross-references.)

Choose Special > Cross-Reference, 
click Edit Format, and then click 
Add.
Refer to online Help for help with 
building blocks.

44 Are spaces and special 
characters working in the 
formats?

Entering special spaces and 
characters in a dialog box can 
be tricky. You’ll want a non-
breaking space to precede a 
page number; you’ll want 
curved quote marks around 
references to headings.

See online Help for a list of codes 
you may have to use to enter special 
characters in a dialog box.
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Define user variables...

45 Remove user variables 
you won’t need.

You may not need any. Choose Special  > Variable, click Edit 
Definition, and click Delete.

46 Add user variables you 
will need.

You may want to insert a 
Draft# variable in a footer.

Choose Special  > Variable, click Edit 
Definition, and click Add.

Set up conditional text...

47 Add conditions you’ll 
need.

Will you be creating multi-
versioned manuals for differ-
ent platforms or audiences 
(an OEM manual and an end-
user one)? You may not need 
any conditions.

Choose Special  > Conditional Text 
and click Edit Condition tag.

48 Adjust the condition indi-
cators.

Use a color or effect that keeps 
the text readable both 
onscreen and when printed.

Choose Special  > Conditional Text 
and click Edit Condition tag.

Set up HTML mappings...

49 Optimize for use on the 
Web—if appropriate.

You may want to split up the 
file into several HTML files. 
You may need conversion 
macros for cross-reference 
formats.

Choose File > Utilities > HTML 
Setup.
Choose View > Reference Pages and 
edit the tables on the HTML refer-
ence page.

Set up Acrobat settings...

50 Optimize for conversion 
to PDF—if appropriate.

The defaults for bookmarks 
are usually way off.

1. Choose Format > Document > 
Acrobat Setup.

2. Shift-click the –> arrow and then 
add just the formats you want 
included as bookmarks.

Consider Japanese settings...

51 Set up some special Japa-
nese settings, if needed.

This applies to FrameMaker 
5.5 only. These settings are 
best done by a native speaker 
working on a Japanese system.

Choose Format > Document > Rubi 
Properties.
Choose Japanese in the Paragraph 
Designer.
Consider the Tsume font property in 
the designers.
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52 Do you need to specify 
special Kumihan rules?

A corporate standard may 
dictate very precise typo-
graphical rules. This is for 
advanced users only.

To customize the Kumihan tables for 
the template, you export the tem-
plate to MIF and edit the tables 
there. See the online manual MIF 
Reference.

Don’t forget templates for generated files...

53 Create a template for each 
generated file you might 
need.

These would include TOCs, 
indexes, and possibly tables of 
figures, and the like.

1. Create a book file from the tem-
plate sample you create in Step 56.

2. Rename the book file to some-
thing generic.

3. Add the generated files.
4. Choose File > Generate/Update 

from the book file.
5. Use these generated files as the 

start of your templates for gener-
ated files.

54 Remove formats and 
objects that won’t be 
needed in these files.

The generated files inherit lots 
of useless baggage from the 
sample file the book file was 
created from.

1. Remove any format that doesn’t 
end with TOC, IX, or the like.

2. Remove all unused variable defi-
nitions, master pages, reference 
pages, conditions, table formats, 
and color definitions.

Document and test...

55 Document how the tem-
plate should be used.

Too many template creators 
fail to perform this vital step.

You can enter the explanation in the 
template itself.

56 Create a sample docu-
ment trying to use every 
format and master page.

Try every combination of for-
mats you can think of. If you 
find the need to apply a for-
mat override, you may need 
to create a new format.

Test, test, test.

Last steps and save...

57 Set the template’s View 
settings and its zoom and 
save.

Users won’t usually need to 
see rulers, but borders and 
text symbols are usually help-
ful.

Choose View > Borders.
Choose View > Text Symbols.
Choose View > Rulers.
Choose View > Grid Lines.
Use the Zoom pop-up menu.
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M Did you notice that Table 2 on page 31 has three independently numbered series? (The table title 
is numbered, every row in the lead-off cell is numbered, and in each row there can be a group of 
numbered steps.) To see how this nimble numbering was handled in a single “series,” open the 
template that was used for this primer (it’s the Bk8.fm book template) and check out the sample 
table there. Look at the Autonumbering Format for the TableTitle, CellBodyNum, and CellNum-
bered formats.

58 Set up the template’s 
Print dialog box settings.

You’ll probably want to set the 
template to print with no 
crop marks, just 1 copy, and 
all pages.

Choose File > Print.

59 Set up color separations. Specify colors you’ve defined 
in Step 39+ to print as spot 
colors.

Choose File > Print and then click 
Separations Setup.

60 Look for items you can 
remove to reduce file size 
and improve usability.

Be careful that users won’t 
import unwanted items when 
they use File > Import > For-
mats.

Scan for unneeded formats, refer-
ence pages, master pages, table for-
mats, color definitions, etc.
Delete extra body pages too.

61 Celebrate!
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Having it your way

The fine art
of tweaking

templates

Taking an existing template, such as the ones accompanying this 
PDF file as separate downloads, and bending it to your will, is an 
art in itself. It requires craft and occasionally cunning. The follow-
ing sections discuss some of the ways you can customize pre-made 
templates so they better serve you. And there’s a final sidebar dis-
cussion on using FrameMaker for design-intensive documents such 
as newsletters in ways that will, without doubt, send seasoned 
Framers screaming from your side. Fasten your seatbelts.

Fonts—when Times and Helvetica just won’t do

Changing the fonts used in a template is inevitably one of the first 
acts of template customization. One person’s selection of perfect 
fonts presents a vision of typographic hell to another. Or, the 
change may simply be predicated by the conventions of corporate 
font use: your company’s pubs or marketing department must use 
specific fonts in its printed material to preserve the corporate iden-
tity. Whatever the case, it’s likely you’ll want to abandon the Times/
Helvetica combo used in all of the templates included here. We 
used Times for body text and related formats, Helvetica for head-
ings, tips, notes, TOCs, and so on. Chances are you’ll want to stick 
to this kind of dichotomy (one serif font family for body-type text, 
a sans serif family for everything else), simply replacing Times and 
Helvetica with something more au courant.

FrameMaker makes global font updates like this quite painless. The 
strategy is to change all formats to font X (leaving all other proper-
ties As Is) and then, one by one, change specific formats to font Y:

1 Choose Format > Paragraphs > Designer and click the Default 
Font property.

2 Select the Body format.

3 Select a new font from the Family popup that you want body 
text and most other most text elements to have.

4 Choose Commands > Global Update Options. Make sure 
Default Font Property Only and All Paragraphs and Catalog 
Entries are selected.

5 Click the Update button.
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Now go back to the Default Font property in the Paragraph 
Designer and, one by one, select the heading-type formats that 
should not be in the main font just defined above and change them 
to the desired font. The reason we take this approach to changing 
the fonts is that most text in many documents uses the same font 
family as the Body format. Changing all formats to this font and 
then changing the few headings and related formats to another font 
family will save a lot of time for most users.

t If the template you’re customizing with font changes is part of a 
book, load the book file first. Select one of the book parts and make all 
the font changes as outlined above. Then use File > Import > Formats 
to import the Paragraph Formats from that file into the other files of 
the book. See the FrameMaker User Guide for details on how to do 
this.

The following chart shows some appropriate font substitutions for 
Times and Helvetica that, because of their characters per pica 
(cpp), will work in all the templates in this series without forcing 
you to fiddle much with changing indents, table cell sizes, and so 
on.

t If you still prefer to use some other font families, you might con-
sider using the Spread and Stretch settings in the Paragraph Designer’s 
Default Font property to create condensed or expanded versions of the 
desired fonts on the fly so they fit properly with a given template’s lay-
out and elements. This feature is available only with FrameMaker 5.5 
or later. Simply decreasing a font’s point size can also make it a candi-
date as a replacement for another font, so don’t rule out that low-tech 
solution.

Table 3: Substituting for Times and Helvetica

Times
(2.85 cpp at 10 pt.)

Helvetica
(2.68 cpp at 10 pt.)

Many common serif font families can sub for 
Times in most documents, but several that 
match the high space-saving cpp property of 
Times include:

ITC Berkeley Oldstyle, ITC Galliard, Adobe 
Garamond, and Minion

We find the following font families generally make 
suitable substitutes in our templates:

ITC Eras, Eurostyle, Franklin Gothic, Frutiger (Light), 
Futura, Helvetica Inserat, News Gothic, ITC Novarese, 
Optima, and Univers
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Importing and updating formats

Importing paragraph formats to update font use globally is only 
one aspect of customizing a template. Here are several scenarios 
you’ll eventually encounter as you customize a template:

M Many may come away from their first experience with FrameMaker thinking that named text 
flows must have truncated labels such as A. You should keep labels short (there’s only so much 
room in the status bar inn!), but you can use more descriptive tags such as Story1, Main, or Side, 
if you have more than one flow. Control-click the flow’s text frame on the master page, choose 
Graphics > Object Properties, and enter a new Tag name.

Clip art and color

You can use clip art and color to spruce up even the drabbest docu-
ment. FrameMaker includes a relatively large and wholly underap-
preciated or unnoticed treasury of clip art we used in several of our 
templates. Even electronics symbols, which many might consider 
useful only in that industry, became a rich source of elements we 
could use as graphic accents or geometric borders. The built-in clip 
art is as close as FrameMaker’s Help menu and should be explored. 
Also use scanned artwork, company logos, and other corporate 

Table 4: Import and update scenarios

Scenario Comments How to

Import all formats You want to change a document’s 
formats to those found in another 
document or template.

Make sure both files are open, then 
choose File > Import > Formats. Select 
the formats and other elements you want 
imported, and click the Import button.

Import just one for-

mata

You find a format in one docu-
ment or template that you want 
to use in another.

Copy and paste the paragraph containing 
the format from one document into the 
other. Choose File > Utilities > Create 
and Apply Formats and click the Con-
tinue button.

Global updates You need to change a format 
name or apply other changes to 
many files or formats at the same 
time.

Apply changes made in Paragraph 
Designer to several paragraphs or files at 
once by choosing Commands > Global 
Update Options in the designer dialog 
box.

a.If the format has a “frame before” or “frame after,” you also need to include the frame on the
reference page. If the format has a numbering format that includes a character format, you must
also bring in that character format.
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symbols to make the template better reflect you or your company’s 
identity. Many templates use FrameMaker clip art as placeholders 
waiting to be replaced by a company logo or personal piece of art-
work.

t If the document is to be used online in HTML format, be sure that 
any graphics you want to appear in the online version are in anchored 
frames attached to the main text flow. Otherwise they will not be con-
verted to GIF or JPEG files when you save to HTML. Background graph-
ics placed on master pages, positioned unanchored in sideheads, or left 
floating on a page will all vamoose from the HTML output.

M If you define colors, name them to reflect their function (e.g., WarningColor), not their hue. This 
lets you change a color’s definition later without also changing its name.

Most corporate print material, from press releases to manuals, 
tends to be monochrome. Put bluntly, black and white is cheaper. 
But it doesn’t have to be boring. Most of the templates included in 
this book are likewise monochrome. Several of our templates (for 
example, Personal Web Site) make effective use of gray tones to add 
“color” to the page. And if color is not a financial issue, you can 
modify virtually any element in the templates (rules, page num-
bers, headings, etc.) by applying any color on your palette.

M One innovative use of color in FrameMaker lets you create non-printing guide lines (a feature 
common to design-oriented DTP software, but which we’ve sometimes missed in FrameMaker). 
Simply use a single color for all guides and other non-printing elements; see any of the Grid tem-
plates for examples. Choose View > Color > Views and include that color in View 1, but make it 
invisible in View 6. To see the guidelines, press Esc v 1. To make them invisible (and so non-print-
ing), press Esc v 6.

As mentioned earlier, if the document may be used online in 
HTML format, you should, in most cases, restrict yourself to one of 
the 216 browser- or Web-safe colors. We’ve created a special color 
palette file you can install in FrameMaker. Windows users: Copy 
the file websafe.acf included with this PDF file to the fminit > color 
subdirectory inside the main FrameMaker directory on your hard 
disk. Macintosh users: Copy the file websafe.acf to the Color folder 
within the Modules folder. UNIX users: Copy the file websafe.acf to 
$FMHOME/fminit/color.

M FrameMaker doesn’t restrict text to flows and frames. The underused Text Line tool offers a way 
to place single lines of text on a body or master page. You can stretch a text line. This lets you 
stretch a line of text to fit a defined area—a way cool Protean trick for creating logos and head-
line text art in some kinds of layouts. We used this technique a lot in the certificate templates.
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The templates we created as part of this project are available as sep-
arate downloads, “template packs,” at the Adobe Web site. A PDF 
template guide is available for each template pack as a separate 
download. Each entry in the PDF guide covers one template or 
family of templates, providing a screen shot, details on how the 
template works, distinguishing features, and some hints on how to 
customize and use the template effectively.

Check the “Getting Started” section near the front of this primer 
for details on installing the templates on your computer.
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FrameMaker as a Layout Program

A layout grid in FrameMaker.

Turning
FrameMaker

on its
head

FrameMaker excels at huge documents where most pages resemble 
each other in terms of structure. That doesn’t mean it can’t produce 
letters, memos, fax cover sheets, and all the other paper jetsam and 
flotsam of the work-a-day world—this template series attests to 
that.

FrameMaker can also handle some design-intensive documents 
such as newsletters, where each page’s layout tends to differ from its 
siblings in the same document. FrameMaker comes with a newslet-
ter template, but it assumes the usual FrameMaker modus operandi 
and expects each page to resemble the others. That’s just not the 
way newsletters work and we wanted to try a more radical 
approach that turns FrameMaker on its head.
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M We’ve mentioned several times that the contents of an anchored frame in the main text flow 
become a single GIF (or JPEG) file when you save the document as HTML. And that means every-
thing, including text. This lets you easily use any fonts you want for creating logos, establishing 
company identity, artful heading graphics, etc., and see the fonts appear normally even on the 
Web, whether or not the site’s visitors have the fonts installed. Just make sure to place the text 
string or frame within an anchored frame. See the book style #7 for an example.

First, start with one of our Grid templates. The 5- and 7-column 
grid templates provide the most flexibility. Add the exact number 
of pages the final newsletter should have, make sure Snap is on, and 
save the file under a new name. Don’t worry. We’ve set the template 
to preserve blank pages; they will not be automatically deleted 
when you save. Now you’re ready to begin.

Use the Text Frame tool to draw out the frames or “columns” that 
will contain your first story. You can always resize them later if the 
story does not fit. Rely on the background grid to form the text 
frames into columns. You can place columns for the same story on 
different pages. Now go back and select the second frame. Choose 
Format > Customize Layout > Connect Text Frames. The first two 
frames become one text flow. Note how the insertion point disap-
pears in the second frame (if you have View >Text Symbols turned 
on). Now Control-click the third frame and choose Format > Cus-
tomize Layout > Connect Text Frames to add it to the text flow. 
Continue doing this until all the story’s columns/frames are one 
flow. Control-click the first frame and choose Graphics > Object 
Properties. In the Customize Text Frame dialog box enter a name 
for the flow’s Tag. Although these Tag names are usually one-letter 
affairs, you might want to give the flow a more descriptive name 
(keep it short), such as Story1, Story2, etc.
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You can give meaningful tag names to stories in a newsletter.

Now type the story in the text flow or choose File > Import > File 
to copy the story in from an external word processing or 
FrameMaker document. Follow the same procedure for the rest of 
your stories.

You can create “continued on” jumps using cross-references. There 
are several approaches to this. The one we find works best in most 
cases is to insert a cross-ref marker near the end or middle of the 
text frame where the story resumes. Then insert a cross-reference at 
the end of the column: “Continued on page x.” Create jumps only 
after you have finished all editing on the story or your cross-refer-
ence jump lines and cross-ref markers may move into the wrong 
columns as text is added or deleted.

M Whenever creating a template for a document with a set number of pages, such as a 4- or 8-page 
newsletter, add the number of pages, and then choose Format > Document > Numbering. In the 
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Numbering Properties dialog box change Before Saving & Printing to Don’t Change Page Count. 
If you don’t, FrameMaker deletes any empty pages when you save the template.

Add masthead material, graphics, rules, and other traditional 
newsletter material as background elements on the body pages 
where they belong.

It feels decidedly bizarre to work in FrameMaker like this, but we 
do find it a better approach to doing design intensive work in 
FrameMaker than the method adopted for the newsletter template 
supplied with the product. 
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Essential Keyboard Shortcuts

Template designers and creators will find that learning the follow-
ing keyboard shortcuts will increase their productivity. 

Some of the shortcuts use Escape shortcuts, which are unique to 
FrameMaker. Unlike other shortcuts, you must press Esc and then 
release it before pressing the keys that go with it. Once you get the 
hang of it, you’ll really enjoy the power that these Esc shortcuts give 
because they work identically on all platforms.

Table 5: Shortcuts every template creator should knowa

Windows Macintosh UNIX

View Body Pages
View Master Pages
View Reference Pages

Esc v b
Esc v m
Esc v r

Com-
mand+Option+b
Com-
mand+Option+m
Command+Option+r

Esc v b
Esc v m
Esc v r

Paragraph Designer
Character Designer
Table Designer

Ctrl+m
Ctrl+d
Ctrl+t

Command+m
Command+d
Command+Option+t

Prop key or Esc o p d
Esc o c d
Esc t f

Open format in Designer Ctrl-click name in 
Catalog

Command-click 
name in Catalog

Ctrl-click name in 
Catalog

Show/Hide Rulers
Show/Hide Borders
Show/Hide Text Symbols

Esc v r
Esc v b
Esc v t

Com-
mand+Option+u
Com-
mand+Option+h
Command+y

Esc v r
Esc v b
Esc v t

100% Zoom
Zoom In
Zoom Out

Esc z z
Esc z i
Esc z o

Esc z z
Esc z i
Esc z o

Esc z z
Esc z i
Esc z o

a.The Esc sequences will work on all three platforms.
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Localizing Templates

The templates included here have an admitted North American 
bias. For example,

N Some of them use an 8.5-by-11-inch paper size.

N Their Language property is set to US English.

N Many of the dimensions are entered in inches.

This appendix outlines some of the steps you would take if you 
wanted to localize a template for another country or language.

Localization in 20 easy steps

Change the
paper size

Localization isn’t difficult, but you do need to be methodical, 
checking every format and every margin. Use the following steps as 
a checklist.

1 Choose Format > Page Layout > Page Size.

2 Choose a new paper size (A4 Letter, for example) from the Page 
Size pop-up menu and click Set.

Now you’ll want to set the measurement units...

Set display
units

3 Choose View > Options.

4 Choose cm (or mm, if you prefer) from the Display Units pop-
up menu.

5 Choose one of the cm settings from the Rulers and Grid Lines 
pop-up menus as well.

6 Click Set.
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Round off
values

Next, you’ll want to adjust the format settings in the properties to 
be round numbers. You want to do this because round numbers in 
one unit are unwieldy in another. For example, 1.0 inch converts to 
2.54 cm, which would be more elegant to change to 2.5 cm. 
(Granted, this isn’t absolutely necessary, but it’s one of those nice-
ties that differentiates a well-localized template from a quick-and-
dirty job.)

7 Open the Paragraph Designer and choose each format in turn 
from the Paragraph Tag pop-up menu. Examine the settings 
and adjust them as needed, clicking Update All for each one.

8 If you’ve adjusted tab settings, make sure they still look OK and 
work as expected.

9 Choose Format > Page Layout > Column Layout and round off 
the values for margins and side heads.

10 You may want to adjust the text frame measurements on the 
master pages to be round numbers as well.

Change the
color library

If your template uses color and is destined to be printed profession-
ally, you should make sure the color library is appropriate. For 
example. Asian markets prefer using Toyo color definitions. In 
Europe, you may want to use the Pantone ProSim Euro library. Ask 
a commercial printer for guidance if you’re unsure what library 
would be most suitable for the locale.

11 Choose View > Color > Definitions and redefine colors using 
the appropriate color library.

Change the
Language

property

You’ll want to change the Language property in the Default Font of 
both paragraph formats and character formats. This makes sure 
FrameMaker uses the proper dictionary when spell-checking and 
hyphenating.

12 In the Paragraph Designer, choose Set Window to As Is from 
the Commands pop-up menu, and then choose the language 
you want (UK English, for example) from the Language pop-up 
menu.

13 Choose Global Update Options form the Commands pop-up 
menu and apply Default Font Properties to “All Paragraphs and 
Catalog Entries.” This will change the Language property—and 
only the Language property—for all paragraph formats.
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14 Do the equivalent procedure in the Character Designer.

Localize
format
names

You might also want to localize the format names to conform to 
UK English spelling or to translate them into a different language.

15 Open the Paragraph and Character Designers and choose each 
format in turn from the Paragraph Tag pop-up menu. 

16 Edit the name as needed in the Tag text box and then click 
Update All. Click OK to rename the format throughout the 
template.

Localize
auto-

generated
text

It’s common for some formats to insert text automatically. You 
should check to see if this text needs translating or adjusting. For 
example, a bullet format inserts a bullet character, which won’t 
need localizing, but a table-title format may insert the word 
“Table,” which will.

17 In the Paragraph Designer, look at the text entered in the Auto-
number Format text box for each format. 

18 If you need to change the text, click Update All before continu-
ing to the next format.

Localize
other names
and formats

Depending on the complexity of a template, there may be other 
formats that need changing. Some of these are rarely used (custom 
marker names, for example), but others are not infrequent (table 
formats, for example).

19 Consider renaming the following formats:

N Table formats

N Custom color names

N Conditional text settings

N Cross-reference formats

N Names of user variables

N Names of custom master pages and reference pages

N User-defined marker names

20 Test the template and tweak as needed.
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FrameMaker Resources

This section contains a listing of resources that FrameMaker tem-
plate designers and users will want to explore. You can click blue 
underlined text to open your browser to the relevant Web site.

Online resources

The Adobe Web site (www.adobe.com)

Information about FrameMaker, updates, special events and pro-
motions, tips, and techniques—straight from the horse’s mouth.

Adobe Magazine (www.adobe.com/publications/adobemag)

A free bimonthly magazine featuring tips and articles on many of 
Adobe’s products, including FrameMaker. You can apply for a free 
subscription online.

The FrameUsers.com site (www.frameusers.com)

This Web site is a cornucopia of all things FrameMaker. Up-to-date 
links to FrameMaker-related companies, newsgroups, free utilities, 
templates, Framer pages, and more. It provides one-stop conve-
nience for all your FrameMaker needs.

Charles Poynton FrameMaker page
(www.inforamp.net/~poynton/Poynton-frame.html)

This FrameMaker expert’s page contains a wealth of information 
about FrameMaker, much of it in the form of tips and techniques.
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FrameMaker newsgroup (comp.text.frame)

Need help from real-world FrameMaker experts? This newsgroup is 
the place to go. Share problems and solutions with other Framers 
from around the world.

Books

Classroom in a Book: Adobe FrameMaker Version 5.5, 1997, Mac-
millan Computer Publishing, 351 pp. ISBN: 1568303998. Read
more about it at Amazon.com.

FrameMaker to HTML, Ken Jackson and Sonya Keene, Addison-
Wesley, 1997, 327 pp. ISBN 0-201-31204-2. Not updated for ve
sion 5.5, but still contains useful information, Check out the boo
online at the Harlequin Group Web site.

Learning Adobe FrameMaker: The Official Guide to Adobe 
FrameMaker, 1996, Macmillan Computer Publishing, 420 pp. 
ISBN: 1568302908. Applies to version 5.0 only. Read more abo
it at Amazon.com.
58 FrameMaker Resources

http://www.harlequin.com/education/books/frametohtml/fl_1.htm
news:comp.text.frame
http://www.amazon.com/exec/obidos/ISBN=1568302908/3124-9226719-970273
http://www.amazon.com/exec/obidos/ISBN=1568303998/r/3124-9226719-970273

	Getting Started
	Requirements
	Installation
	Typographical conventions
	Over 150 templates
	Why we chose the templates we did
	What’s in the series

	A FrameMaker Template Primer
	Creating your own template
	Having it your way

	FrameMaker as a Layout Program
	Essential Keyboard Shortcuts
	Localizing Templates
	Localization in 20 easy steps

	FrameMaker Resources
	Online resources
	Books


