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Overview

 

his overview introduces you to the key features in Adobe Illustrator, the industry-standard vector 

graphics software for designers and Web developers. Illustrator provides easy-to-use tools, editable 

effects, and powerful productivity features to help you create professional-quality graphics for Web, 

print, and emerging media such as wireless devices. And when you use Illustrator in tandem with other 

Adobe software, you can take advantage of superior Adobe technologies such as cross-product color 

management tools, Smart Object technology, and transparency.

 

Produce superb Web graphics

 

Illustrator delivers robust tools to lay out Web pages, create high-quality vector or raster graphics, optimize 

file size, and automate repetitive tasks. With Illustrator, it’s easier than ever to produce high-quality, low-

maintenance Web pages.

 

Balance image quality and file size

 

Illustrator provides Web-savvy tools to help you minimize file size without sacrificing the quality of your 

artwork—and unlike their raster-based counterparts, the vector elements you create in Illustrator remain 

completely editable.

 

Symbols

 

To manage repeating graphics efficiently, create a symbol and then use as many instances of it as 

you need. File size stays small because the symbol is defined only once, and the instances reference the 

symbol. In addition, the instances update automatically when you edit the symbol.

 

Slicing

 

Create vector- or raster-based slices from objects, groups, or layers. The slices update automatically 

when elements are repositioned or edited, and you can export individual slices in Macromedia Flash 

(SWF), SVG, GIF, JPEG, PNG, or HTML format, all within the same HTML table.

 

SVG effects

 

Apply drop shadows and other effects as editable SVG effects. These low-memory vector effects 

are rasterized only when viewed in an SVG viewer, so they look crisp at any size.

T
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Selective anti-aliasing

 

Apply type anti-aliasing selectively to keep small text easy to read.

 

Optimization controls

 

The Save For Web dialog box displays side-by-side previews of your artwork to let 

you compare different compression options and select settings that keep the image quality high and the file 

size low. 

 

Automate complex tasks

 

Stay focused on the creative side of your Web work by using the powerful productivity tools in Illustrator 

to handle repetitive work automatically.

 

Dynamic data-driven graphics

 

Design a template in Illustrator, and define elements within the template as 

variables. Then generate an unlimited number of unique variations quickly by using scripts to replace the 

variables.

 

Instant layer generation

 

Use the Release To Layers command to shuffle objects from one layer onto 

individual layers. Then export the layers in Photoshop format or as a Macromedia Flash (SWF) file for 

animation in another Adobe application.

 

Image map generation

 

Use the Image Map pop-up menu in the Attributes palette to define an image map. 

Enter a URL, and Illustrator automatically generates a linked image map when you export the file in Web 

format.

 

Get an accurate on-screen view

 

The best way to ensure that your Web graphics look the way you want them to look is by getting an accurate 

view as you create them.Illustrator lets you see your artwork exactly as your viewers will.

 

Pixel Review

 

Choose View > Pixel Preview to see how your vector objects will appear when they are 

rasterized for the Web.

 

Web-safe color support

 

You can set the Color palette to display only Web-safe colors, or use the Only Web 

Colors option in the Color Picker. In addition, you can convert an existing print file to RGB by choosing 

File > Document Color Mode > RGB.
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Experience extraordinary creative freedom

 

Whether you’re creating graphics for the Web or high-resolution images for print, Illustrator delivers easy-

to-use tools and editable effects to let you experiment at will—or revise as needed—and still meet your 

deadlines.

 

Create complex graphics easily

 

In addition to tools that let you reshape or refine a path with ease, Illustrator provides advanced features 

for more complex processes.

 

Live distortion

 

Bend, stretch, and twist your text and graphics in any way imaginable with live enveloping, 

warping, and liquify tools. The distorted objects—even text—remain editable, no matter how much they 

have been manipulated.

 

Symbolism

 

Use symbols to create natural-looking masses of repeating elements such as foliage or crowds. 

Define a symbol, use the symbol sprayer tool to create duplicates, and then manipulate them interactively 

with one of the specialized symbolism tools.

 

Compound shapes

 

Create complex shapes quickly by combining simple shapes into compounds. Then 

edit the compounds if you need to without redrawing the original shapes.

 

Transformation tools

 

Resize, rotate, reflect, or shear objects with the Illustrator transformation tools. You 

can apply the changes interactively, or enter specific settings to control the results precisely.

 

Blending

 

Select two or more objects, and use the Illustrator blend tool and Make Blend command to 

create a set of objects that transition—in shape and color—between your selections. Edit one of your 

original objects, and the blend updates automatically.

 

Appearance attributes

 

Change the appearance of any object, group, or layer by using the Effects menu or 

the Appearance and Styles palettes. These adjustments do not affect the underlying objects, so the 

attributes can be modified or removed instantly.

 

Apply sophisticated color effects

 

Illustrator offers advanced fill and stroke options such as patterns, gradients, and the ability to add multiple 

fills and strokes to a single object. In addition, you can apply transparency and masks to produce painterly, 

see-through effects. 

 

Transparency 

 

The Illustrator Transparency palette lets you apply transparency to vector objects, bitmap 

images, or type. You have the option of limiting transparency to a layer, a group, or an object’s fill or stroke, 

and transparent objects and type remain fully editable.
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Blending modes

 

Apply blending modes to blend the colors of graphics and type with the colors on under-

lying layers. By experimenting with different mode settings in the Transparency palette, you can create a 

wide range of effects.

 

Masks

 

Use clipping masks to cut an object away from its background, or create opacity masks to let 

elements on an underlying layer show through an object.

 

Fills

 

Paint objects by filling them with solid colors or patterns. Or use gradients to produce painterly fills 

that flow between multiple colors, similar to watercolors.

 

Multiple strokes and fills

 

Select Add New Fill or Add New Stroke from the Appearance palette to apply 

multiple strokes and fills to a single object.

 

Draw the way you want to

 

From the industry-standard pen tool to the versatile art brushes, Illustrator supplies tools that support 

your illustration style.

 

Pen and pencil

 

Use the pen tool for precise paths—smooth, flowing curves or straight lines—or use the 

dynamic pencil to draw on-screen as easily as you do on paper.

 

Brushes 

 

With the Brushes palette and paintbrush tool, you can create hand-drawn effects such as calli-

graphic strokes, or paint patterns that flow along a path. Customize the brushes or edit the strokes at any 

time to fine-tune the image.

 

Automatic shapes

 

Specialized tools let you draw shapes—lines, arcs, two types of grids, spirals, stars, and 

more—with click-and-drag ease.

 

Enjoy professional-level type control

 

Illustrator provides powerful, flexible features for creating and modifying type. Format type, place it on a 

path, and wrap it around a shape with complete typographic control. You can also apply transformations 

and other graphic enhancements to turn your text into an artistic element.

 

Utilize powerful production tools

 

Illustrator streamlines the way designers and developers work together by delivering groundbreaking tools 

to help them work faster and smarter. From robust scripting support to flexible selection tools, Illustrator 

makes it easier to meet your deadlines.
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Automate time-consuming processes

 

Tight deadlines require efficient workflow, especially for designers and developers working in high-volume 

publishing environments. Illustrator lets you automate some of the most repetitive tasks, such as batch 

processing and creating variations of similar designs.

 

Dynamic data-driven graphics

 

Build a basic template in Illustrator and define objects in the design as 

variables. Then use an automated script or an image server to produce unique variations, using data stored 

in any ODBC-compliant source. 

 

Scripting support

 

Automate repetitive tasks using the rich scripting support, which allows access to almost 

every function in Illustrator. Write scripts using JavaScript, AppleScript, or Microsoft Visual Basic.

 

Asset management 

 

Use the Illustrator asset management tools to make collaboration easier. Check files 

in and out of WebDAV servers to eliminate the risk of overwriting files or losing updates.

 

Metadata support

 

Embed metadata tags in Illustrator files to make your artwork easier to catalog, 

organize, and retrieve.

 

Actions palette

 

Use the Illustrator Actions palette to group a series of commands into a single action. Then 

play back the action to repeat the entire set of steps automatically. You can even use the Batch command 

to apply an action to a folder of files and subfolders.

 

Speed up everyday tasks

 

Saving a few seconds here and there can shave hours off a complex project, and Illustrator is packed with 

features to handle common tasks quickly and efficiently.

 

Selection tools

 

Specify a tolerance range for the magic wand tool to select a range of objects with similar 

attributes—every object with a stroke weight between 1 and 3 points, for example. Save and load selections 

easily using the Select menu.

 

Appearance attributes

 

Use the commands in the Effects menu and options in the Appearance and Style 

palettes to add nondestructive effects to vector objects. Because the original objects remain intact, you can 

edit the effects at any time.

 

Graphic styles

 

Save a set of appearance attributes as a style so that you can apply the same set of attributes 

instantly to other objects. 

 

Layers palette

 

Manage complex artwork efficiently by using the Layers palette to organize the file into 

distinct layers and sublayers. You can also use the Layers palette to apply appearance attributes to layers, 

groups, and objects.

 

Precision layout tools

 

Position objects quickly using the precision layout tools in Illustrator, including 

snap-to grids, Smart Guides, and the Align palette. For Web work, you can set objects to snap to the nearest 

pixel edge by specifying pixels as the measurement unit in the Units & Undo preferences panel and then 

choosing View > Pixel Preview.

 

Eyedropper tool

 

Sample text and color attributes with the eyedropper tool and apply the attributes to 

other objects.

 

Swatches palette

 

Use the Swatches palette to store color and pattern swatches in a custom swatch set. 

When you copy an object from one file to another, any swatches associated with the object are added to the 

Swatches palette in the destination document.

 

Export in a wide range of formats

 

Illustrator supports PDF, EPS, Photoshop, TIFF, GIF, JPEG, WMF, EMS, SVG, Macromedia Flash (SWF), 

CGM, DXF, DWG, BMP, ASCII, and RTF formats. Additionally, you can monitor linked files in the Links 

palette.
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Improve your workflow

 

Work more efficiently, thanks to tight integration between Illustrator and the latest releases in Adobe’s 

family of professional graphics software, including Adobe Photoshop®, Adobe InDesign®, Adobe GoLive®, 

Adobe LiveMotion™, Adobe After Effects®, Adobe Premiere®, and Adobe AlterCast™.

 

Photoshop

 

Preserve layers, masks, transparency, compound shapes, and editable type when passing files 

between Illustrator and Adobe Photoshop. Retain rollover and animation information in linked 

Photoshop files when exporting from Illustrator as CSS layers.

 

InDesign

 

Edit native Illustrator files directly in InDesign.

 

GoLive 

 

Drop Illustrator files inside GoLive and then double-click the files to launch Illustrator and make 

edits. The changes appear automatically in the GoLive file. Export sliced AISVG files from Illustrator, and 

fine-tune the optimization settings directly in GoLive. Import data-driven graphics templates into GoLive 

for automated network publishing.

 

LiveMotion

 

Export EPS and Macromedia Flash (SWF) files for use in LiveMotion. Export Illustrator 

blends as SWF sequences that can be animated in LiveMotion. Double-click a placed Illustrator file to 

launch Illustrator; any edits update automatically in the LiveMotion file.

 

After Effects and Premiere

 

Import layered Illustrator artwork into After Effects, and integrate easy-to-edit 

Illustrator graphics into your Premiere video productions.

 

AlterCast

 

Create templates in Illustrator and define variable elements. Then use Adobe AlterCast image 

server software to replace the variable text and graphics automatically and generate an unlimited number 

of unique iterations of the design.


