
TECHNICAL paper

Migrating from Legacy Versions 
of Illustrator to Illustrator CS2
A Technical Resource
Upgrading tools in a work environment is not a trivial task even when the overall goal  
is a more efficient and beneficial workflow. But there are many benefits in upgrading 
from previous versions of Adobe® Illustrator® to Adobe Illustrator CS2, including better  
integration with Adobe Creative Suite components like Adobe Photoshop®, Adobe 
InDesign®, Adobe GoLive®, and Adobe Acrobat®. In addition, support for open standards 
like OpenType®, PDF/X, SVG-t, CSS, and XMP help ensure that Illustrator CS2 is a 
perfect fit in any workflow.

When upgrading to Illustrator CS2, one of the main concerns is converting an exist-
ing library containing years of legacy Illustrator files. A legacy Illustrator file is any 
document created in a version of Illustrator older than CS2 (version 12). Another valid 
concern is learning to adapt to all that’s new in Illustrator, as many features have been 
modified, updated, or even changed completely. This document is a technical resource 
for bringing legacy Illustrator content into Illustrator CS2; it also includes information 
on some of the major differences in key features. For details about the new features  
in Illustrator CS2, see the Discover Illustrator CS2 guide on the Adobe website at  
www.adobe.com/products/illustrator/pdfs/AI_DiscoveryGuide_for_Web.pdf.

Importing, saving, and exporting Illustrator files
While Illustrator CS2 can open legacy files directly, some files may be changed. This is 
mainly due to the new technologies in Illustrator CS2. In this section, we will explore 
how best to open, save, and export files from Illustrator CS2. 

What is the best way to import my legacy Illustrator files into Illustrator CS2?
The easiest and best way to bring legacy content into Illustrator CS2 is simply to open it 
in Illustrator CS2. Depending on which version of Illustrator the file was saved in, you 
may see differences in how these files look when opened:

•	 Illustrator 10 and older legacy files: Illustrator CS2 opens the document and adds 
the name “converted” to the file name. Text has to be updated to be edited.

• Illustrator CS legacy files: Illustrator CS2 opens the document as normal. Text does 
not have to be updated.

For more information on why the text in certain legacy files must be updated, and the 
benefits of doing so, see Working with text on page 2.
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When I open a legacy Illustrator file, I am sometimes presented with a Convert Color Mode dialog 
box. What does this mean?
Prior to Illustrator 9, documents could contain both RGB and CMYK data. In Illustrator CS2, 
documents are restricted to use a single color mode, similar to Photoshop. If you open a docu-
ment that contains both CMYK and RGB data, Illustrator asks you what color mode you want to 
work in, and converts all colors to match the chosen color space. To manually change a document’s 
color space in Illustrator, choose File > Document Color Space.

When you open a document that contains both CMYK and RGB elements, Illustrator asks you to choose a single  
color mode.

How can I save my file back to use in a legacy version of Illustrator?
To save an Illustrator CS2 file so that it can be opened in a legacy version of Illustrator, choose 
File > Save As and then choose Adobe Illustrator Document from the Format pop-up menu in 
the Save As dialog box. Click Save to open the Illustrator Options dialog box and choose the 
desired compatibility setting from the Version pop-up menu. Be aware that saving files from 
Illustrator CS2 back to a legacy version can cause all text to be converted to outlines. See  
Working with text for more details.

When saving a native Illustrator file, you can choose which version of Illustrator you want the file to be compatible with.

When a file contains transparency, saving back to version 8 or earlier results in the flattening of 
any transparency in the file. Illustrator allows you to choose to Preserve Paths, which discards 
the transparent effects and keeps the editability of the paths intact, or you can choose Preserve 
Appearance And Overprints to retain the overall appearance of the file, but sacrifice editability.
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 How do I create a PDF from Illustrator CS2?
To create an Adobe PDF file from Illustrator, choose File > Save As. Then, choose Adobe PDF 
from the Format pop-up menu, and click Save. In the Save Adobe PDF dialog box, specify 
options for the resulting PDF file (these options can also be saved as PDF Presets, which can be 
shared across Adobe Creative Suite applications). For more information, see the PDF file creation 
section of the Print Resource Center on the Adobe website at www.adobe.com/studio/print/
designer.html#pdfcreation.

How do I export a GIF or a JPEG file from Illustrator CS2?
To export GIF or JPEG images for use on the web, choose File > Save For Web. In the Save For 
Web dialog box, you can preview and export your art in many web file formats including GIF, 
JPEG, PNG, WBMP, SWF, and SVG.

How do I create Flash® (SWF) files from Illustrator CS2?
There are two ways to export Illustrator files to SWF files: Choose File > Export and then choose 
Macromedia Flash (.SWF) from the Format pop-up menu, or use the Save For Web feature.

Can I place duotone images into Illustrator CS2?
Yes, you can place duotone images saved from Photoshop, and link or embed them.

Does Illustrator CS2 support DCS 2.0 files?
Illustrator CS2 supports DCS 2.0 files only in a nontransparency workflow. If a DCS image inter-
acts with transparency, the image won’t print as expected. To see if a placed DCS image interacts 
with transparency, choose Palette Options from the Links palette menu and select Show DCS 
Transparency Interactions. With this setting turned on, yellow icons in the Links palette identify 
images that interact with transparency. For more reliable results, save spot-color files from  
Photoshop as native PSD or Photoshop PDF files. Refer to the Designer’s Guide to Transparency 
for information about how transparency is introduced in a document.

The Show DCS Transparency Interactions option helps you locate DCS images that interact with transparency.

Working with text
Illustrator contains a next-generation Unicode-compliant text engine that provides full support 
for OpenType® fonts as well as optical kerning, optical margin alignment, every-line composing, 
and multilingual hyphenation and spell checking. The following section covers issues that you 
might encounter when importing and working with text.

When I open a legacy Illustrator file, a dialog box tells me that I must update the text in the file. 
What is the reason for this, and what happens to my text when it is updated?
Because of the new text engine introduced in Illustrator CS and its advanced technology, text 
isn’t directly compatible with legacy versions of Illustrator. You can think of this as a line 
drawn in the sand, with Illustrator CS2 and CS on one side, and all older versions on the other. 
Therefore, when opening legacy files in Illustrator CS2, any text has to be updated before you can 
edit it. There are several different options for updating text, as during the update process, some 
text reflow may occur.

Note: Text reflow here refers to adjustments in kerning and line breaks that may result in updated 
text having a different appearance than the text in the legacy file.

http://www.adobe.com/studio/print/designer.html#pdfcreation
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Opening Legacy Illustrator Files in Illustrator CS2
When you open a legacy file in Illustrator CS2, you’re presented with a warning dialog that states 
the following: “This file contains text that was created in a previous version of Illustrator. This 
Legacy text must be updated before you can edit it.” The dialog presents you with three options:

When opening a file, Illustrator alerts you if the document contains legacy text.

•	 Update  converts all of the legacy text so it is compatible with the text engine in Illustrator CS2. 
This process may result in some of your text reflowing and having different line breaks and 
kerning. However, sometimes no reflow occurs. 

•	 Cancel  doesn’t open the legacy document.

•	 OK  opens the document without updating the text—the file opens just as it did in Illustrator 
10 or earlier. However, legacy text, which appears in the document much like a placed file—in 
a box with an “X” through it—cannot be edited. You can print the file and make edits to other 
objects in the file, but Illustrator treats the text as a foreign object.

When opening a legacy file where you know you will be changing or deleting the text, choosing 
Update is the best method, as text will reflow anyway. If, however, you want to open a file so that 
you can quickly print it, or if text placement is important (which it usually is), choosing OK is the 
better choice.

Updating legacy text in an open document
If you open a legacy file without updating the text, you can still update the text on an object-by- 
object basis by selecting the Type tool and clicking a legacy text object. Illustrator presents a 
dialog box with three options:

If you try to edit legacy text, Illustrator returns a dialog box so that you can update the text first.

•	 Copy Text Object  updates the legacy text and makes it editable. Some reflow may occur in  
the conversion, but Illustrator creates a copy of the legacy text on a locked and dimmed layer 
beneath the converted text. If the new text does reflow, you will see the difference between 
it and the old text. You can then adjust the new text to match the legacy text. To delete the 
dimmed copy, choose Type > Legacy Text > Delete Copies.

•	 Cancel  leaves the legacy text as a foreign object—it can be printed, but not edited.

•	 Update  updates the text so that you can edit it. However, a copy of the legacy text is not  
created, so if the text does reflow, you may not be able to tell.

You may find that when you’re updating text, no significant reflow occurs. If, after updating 
several text objects, you decide to convert all of the legacy text at once, you can choose Type > 
Legacy Text > Update All Legacy Text. 

For more information on updating legacy text, see Working with Type in Illustrator CS2 on the 
Adobe website at www.adobe.com/products/illustrator/pdfs/Text_in_AICS2.pdf.

http://www.adobe.com/products/illustrator/pdfs/Text_in_AICS2.pdf
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Does Illustrator CS2 maintain kerning or text styling when importing files?
Where possible, editable kerning values are retained when you open legacy files in Illustrator CS2. 
However, the new text engine introduced in Illustrator CS uses a more advanced kerning method 
and may cause some reflow within your text.

Does Illustrator CS2 support Unicode text?
Yes, the text engine in Illustrator CS2 is Unicode-compliant. For more information on the  
Unicode standard, see www.unicode.org.

Does Illustrator CS2 support OpenType fonts?
Yes, Illustrator has full support for OpenType fonts. OpenType is an open standard font format 
that is Unicode-based and that supports advanced features like automatic glyph replacement.  
For more information on OpenType fonts, visit the Adobe website at http://studio.adobe.com/us/
type/main.jsp?xhtml=opentype/main.

The OpenType palette in Illustrator enables you to easily access the added functionality built into OpenType fonts.

When I open a PDF or EPS file that wasn’t created in Illustrator, text is broken into individual text 
blocks. Is there any way to avoid this?
No. In order to preserve kerning and the appearance of text objects, text in imported generic EPS 
or PDF files (that is, EPS or PDF files created with an application other than Illustrator) is not 
imported as a single string of editable text.

To combine multiple text objects into a single text string, you can use the Selection tool to select 
the different type objects, switch to the Type tool and create a new area text object, and then 
choose Edit > Paste.

Working with objects and colors
There are some differences in how Illustrator CS2 works with objects and colors. This section dis-
cusses how to understand these differences and how to take advantage of the newer technology.

Why does the appearance of my objects sometimes change when I ungroup them?
With Illustrator CS2, groups can contain attributes like strokes and fills, and effects like drop 
shadows. Since these effects can be applied at the group level, ungrouping removes the effects. 
Shaded circles in the Layers palette help identify groups that have effects or appearances applied 
to them.

The shaded circle to the right of the Group entry in the Layers palette indicates that an appearance has been  
applied to that group. Ungrouping such a group will result in a loss of the effect and a chance in the appearance  
of the grouped objects.

In Illustrator 8 and 9, there was a Unite function in the Pathfinder palette. Where is the Unite 
feature now?
In Illustrator 10, the Pathfinder palette was updated to better match some of the functionality 
found in Photoshop. The Unite filter was replaced with the Add To Shape Area function that also 
appears in the Pathfinder palette.

You can still achieve the same functionality of the old Unite function by holding the Option key 
(Mac) or Alt key (Windows) while clicking the Add To Shape Area icon.

http://www.unicode.org
http://studio.adobe.com/us/type/main.jsp?xhtml=opentype/main
http://studio.adobe.com/us/type/main.jsp?xhtml=opentype/main
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Why do I sometimes see a gray box around my selected objects?
In Illustrator CS2, double-clicking on a group activates Group Isolation Mode. This allows you 
to draw new objects directly in the isolated group. The exit Group Isolation Mode, double-click 
outside the gray box. The gray box does not print.

When you double-click a group, Illustrator indicates Group Isolation Mode by displaying a gray box around the 
perimeter of the grouped objects.

I thought that Illustrator had 3D tools, but I can’t find them. Where are they?
3D in Illustrator is applied to existing graphics as a live effect through the Effect menu. Choose 
Effect > 3D and then choose Extrude & Bevel, Revolve, or Rotate to apply a variety of 3D effects 
to your artwork or text objects.

Why is there both a Filter menu and an Effect menu in Illustrator CS2? It appears that both of 
these menus contain the same features. Is there a difference between them?
At first glance, it appears that many of the features listed in the Filter menu are duplicated in 
the Effect menu. The Effect menu, which contains editable effects, was added in Illustrator 9. As 
effects are applied to objects, the effects are listed in the Appearance palette. At any time, you can 
double-click the effects to edit them or you can remove them entirely, as they are nondestructive. 
In contrast, any feature applied from the Filter menu is destructive and cannot be edited after it 
has been applied.

Illustrator 10 contained filters called Ink Pen and Photo Crosshatch. Do these still exist in  
Illustrator CS2?
The Ink Pen filter (also known as hatch effects) and the Photos Crosshatch features aren’t  
available in Illustrator CS2. To achieve results similar to what those filters could create, choose 
Effect > Stylize > Scribble.

When I create a mask in Illustrator CS2, all of my selected objects are moved into the topmost 
layer. Why does this happen and how can I avoid this?
When Illustrator CS2 creates a mask, it also groups the mask with the artwork that is being 
masked. Because all objects within a group must reside in the same layer, creating a mask forces 
Illustrator to move all masked items into the same layer as the mask itself.

To maintain layer structure, use a Layer Clipping mask by first drawing a shape that you want 
to use as a mask. Bring the object to the top level of the layer. In the Layers palette, highlight the 
layer that contains the shape and click the Create/Release Clipping Mask button at the bottom 
of the palette. The top-most path is listed with an underline in the palette and clips all objects 
within that layer.

With a layer highlighted in the Layers palette, clicking on the Make/Release Clipping Mask icon makes the top-most 
object in that layer a mask for all contents in that layer.

Does Illustrator CS2 contain the newer Pantone color libraries?
Yes, Illustrator CS2 contains the updated Pantone libraries that were created in 2000. Choose 
Window > Swatch Libraries to access any of the 10 Pantone libraries included with Illustrator: 
Metallic Coated, Pastel Coated, Pastel Uncoated, Process Coated, Process Uncoated, Solid 
Coated, Solid Matte, Solid Uncoated, Solid to Process Coated, and Solid to Process Uncoated.
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General document settings
Illustrator CS2 contains a wide range of features that can be used to be more productive, to 
express your creativity, and to push the boundaries of design. This section explores general  
application use and offers guidance on how to get the most out the latest version of Illustrator.

How do I specify page tiling in Illustrator CS2?
In Illustrator CS2, many of the functions that were once found in the Page Setup dialog box have 
been consolidated and moved into the Print dialog box. To set up page tiling in Illustrator CS2, 
choose File > Print and navigate to the Setup panel. Here you can specify Tiling options and also 
specify an Overlap value. When you’ve completed the changes, click Done in the Print dialog box.

Options for specifying page tiling can be found in the Setup panel of the Print dialog box.

The Paintbucket tool in Illustrator CS2 seems to act differently than in previous versions.  
What has changed?
The Paintbucket tool has been replaced with the Live Paintbucket tool in Illustrator CS2.  
This new tool is used to create and edit Live Paint Groups, which allow you to paint vector 
graphics more easily. For more information on how Live Paint Groups work, see the Discover 
Illustrator CS2 guide on the Adobe website at www.adobe.com/products/illustrator/pdfs/ 
AI_DiscoveryGuide_for_Web.pdf.

Illustrator used to have an Autotrace tool that could be used to convert bitmap images to vectors. 
Is that tool still available?
Illustrator CS2 has a powerful new feature called Live Trace, which enables you to convert  
bitmapped images into vector paths. This feature replaces the Autotrace tool. For detailed  
information on the Live Trace feature, see Creating Vector Content Using Live Trace on the  
Adobe website at www.adobe.com/products/illustrator/pdfs/creating_vector_content.pdf.

I have heard that transparency effects don’t always print reliably from Illustrator. Is this true?
Most printers today can handle artwork with transparency with no adverse effects. For transparency 
effects (like blend modes or soft drop shadows) to print to a PostScript device, the transparency 
must be flattened. This process happens automatically when you print your file, save it in EPS 
format, or export it to any format that doesn’t support transparency. For information on how 
transparency flattening works, see The Designer’s Guide to Transparency on the Adobe website 
at www.adobe.com/products/creativesuite/pdfs/dgt.pdf.

I have heard that Illustrator supports metadata. What does that mean?
Metadata is information that describes the content of a document, which can then be used in 
searches. Illustrator has full support for the Extensible Metadata Platform (XMP) standard for 
storing metadata, and such information can be added to a file either using the File Info dialog 
box or Adobe Bridge. For more information on the XMP Metadata standards, please visit the 
Adobe website at www.adobe.com/products/xmp/main.html.

http://www.adobe.com/products/illustrator/pdfs/AI_DiscoveryGuide_for_Web.pdf
http://www.adobe.com/products/illustrator/pdfs/AI_DiscoveryGuide_for_Web.pdf
http://www.adobe.com/products/illustrator/pdfs/creating_vector_content.pdf
http://www.adobe.com/products/creativesuite/pdfs/dgt.pdf
http://www.adobe.com/products/xmp/main.html
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Major features added
Each version of Illustrator introduces new features and functionality. Below is a list of 
added features beginning with the release of Illustrator 9.

Illustrator 9 Illustrator 10 Illustrator CS Illustrator CS2

Flash and SVG export Symbols New text engine Live Trace

Save For Web Symbolism tools Paragraph and character styles Live Paint

Pixel Preview mode Web slicing WYSIWYG font menu Control palette

Web-safe RGB colors Variables palette 3D effects Saved workspaces

Release to Layers Enhanced SWF export Scribble effect Colorize grayscale images

Transparency SVG import Enhanced PDF support and presets Spot color support for drop shadow

Live effects SVG effects Acrobat layer support Align Stroke

Appearance palette Envelopes Save for Microsoft Office Enhanced SWF export

Opacity masks Warp effect Startup (Welcome) screen Adobe Swatch Exchange support

Layer clipping masks New drawing tools New Print dialog box SVG-Tiny support

Graphic styles Compound shapes New print engine SVG-Basic support

Nested layers Flare tool Fit To Page command PDF/X support

Integrated PDF support Magic Wand tool New template (.ait) format

Simplify path Select menu Version Cue support

Lasso tools Native Mac OS X support Enhanced Photoshop export

Customizable keyboard shortcuts XMP support Scripting support

Transparency flattener presets

Visit the Adobe Design Center (www.adobe.com/designcenter) for helpful tips and tutorials on how to get 
the most out of the features in Illustrator.

Resources
For additional information on the topics discussed in this document, see the  
following documents:

Creating vector content using Live Trace  
www.adobe.com/products/illustrator/pdfs/creating_vector_content.pdf

Working with type in Adobe Illustrator CS2  
www.adobe.com/products/illustrator/pdfs/Text_in_AICS2.pdf

Extensible Metadata Platform (XMP)  
www.adobe.com/products/xmp/main.html

Support for OpenType fonts  
http://studio.adobe.com/us/type/main.jsp?xhtml=opentype/main

The Designer’s Guide to Transparency  
www.adobe.com/products/creativesuite/pdfs/dgt.pdf

www.adobe.com
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http://www.adobe.com/products/illustrator/pdfs/Text_in_AICS2.pdf
http://www.adobe.com/products/xmp/main.html
http://studio.adobe.com/us/type/main.jsp?xhtml=opentype/main
http://www.adobe.com/products/creativesuite/pdfs/dgt.pdf
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