Accessibility
Home > Products > Director > Support > Release Notes
Macromedia Director Support Center - Release Notes
Director MX-Versionshinweise

Einführung
Neue Funktionen
Wichtige Informationen
Zusätze und Korrekturen zur Dokumentation - Tipps, Tricks, Komplexitäten und anderes Wissenswerte zu Director MX.
Bekannte Probleme - Informationen zu bekannten Problemen in der vorliegenden Version von Director.
 


Einführung
Die vorliegenden Versionshinweise enthalten die neuesten Informationen zu Director MX, die in der Dokumentation noch nicht zu finden sind.

Bitte lesen Sie dieses Dokument aufmerksam durch. Gehen Sie darüber hinaus bitte auch zum Director Support Center; dort finden Sie die neuesten TechNotes und Hinweise zur Fehlerbehebung in Director sowie Artikel mit Tipps zur Verwendung von Director, ausdruckbare Dokumentation und vieles mehr.

Neue Funktionen

Verfassen und Bereitstellen von Inhalten unter Mac OS X
Auch unter Mac OS X, dem modernen Betriebssystem von Apple, lassen sich Director MX-Inhalte erstellen. Sie können außerdem ausführbare Dateien für OS X-Systeme generieren.

Neue produktivitätssteigernde Benutzeroberfläche
Dank eines extrem flexiblen Arbeitsbereichs, der anwendungsübergreifend auch in Dreamweaver MX, Fireworks MX und Macromedia Flash MX verwendet wird, können Sie schneller arbeiten. Die vertraute, individuell anpassbare Umgebung ist übersichtlich aufgebaut und steigert die Produktivität.

Umschreiben vorhandener Anwendungen entsprechend der Richtlinien zur Barrierefreiheit
Mithilfe der Drag & Drop-Verhalten in Director MX können Sie die Sprechfunktion und Tabulatorreihenfolge steuern und Text mit gesprochenen Wörtern synchronisieren, um vorhandene Director-Anwendungen zu aktualisieren.

Enge Integration mit Macromedia Flash MX.
Neue Funktionen in Director MX, wie das Aufrufen und Bearbeiten von Macromedia Flash MX-Dateien, Steuerung von Macromedia Flash MX-Objekten per Lingo und die Fähigkeit zum Erstellen neuer Macromedia Flash MX-Objekte direkt in Director MX, machen die Arbeit mit Macromedia Flash MX effizienter denn je. Der Import von Macromedia Flash MX-Dateien ist problemlos möglich.

Bessere Kommunikation mit Macromedia-Servertechnologien
Durch die gemeinsame Verwendung von Macromedia Flash Communication Server MX und Director MX lassen sich im Handumdrehen Multiuser-Spiele, Distanzlernanwendungen und Echtzeit-Kollaborationsanwendungen erstellen. Der Macromedia Flash Remoting-Dienst sorgt für eine sichere, hochperformante Verbindung zwischen Macromedia ColdFusion MX und dem Shockwave Player. Bei Verwendung mit Director MX ermöglicht Macromedia Flash Remoting MX den einfachen Austausch von Daten mit ColdFusion MX.

Unterstützung für QuickTime 6
Sie können die Leistungsmerkmale von QuickTime 6 nutzen, darunter Unterstützung für streamendes MPEG4-Video.

Unterstützung für das Euro-Währungssymbol
Director unterstützt jetzt auf allen Plattformen das Euro-Währungssymbol in Text- und Felddarstellern.

Andere wichtige Informationen
Die RealMedia-Xtras für OS X werden nur zum Testen von Inhalten unter OS X zur Verfügung gestellt. Diese Xtras sind nicht als endgültig zu betrachten und wurden nicht umfassend getestet. Aus diesem Grund können wir für diese Xtras keine Unterstützung bieten. Weitere Informationen zur Verwendung der RealMedia-Xtras für OS X enthält diese TechNote.

Weitere Informationen zu den auf OS X portierten Xtras und andere Updates zu den verfügbaren Xtras von Drittanbietern enthält die Xtra-Liste unter http://www.macromedia.com/software/xtras/director.

Der Shockwave Multiuser Server wird nicht mehr weiterentwickelt (siehe TechNote 16688). Macromedia stellt diese nicht unterstützte Software zwar auch weiterhin zur Verfügung, empfiehlt jedoch, zur Entwicklung neuer Inhalte den Flash Communication Server anstelle des Shockwave Multiuser Servers zu verwenden. Die Personal Edition des Flash Communication Servers ist auf der CD im Ordner "Flash Communication Server MX" zu finden. Der Shockwave Multiuser Server befindet sich auf der CD im Ordner "goodies".

Unter Mac OS X wird Internet Explorer 5.1 oder höher unterstützt. Unter 10.1.5 wird jedoch von der Wiedergabe in Internet Explorer 5.2 abgeraten.

Bei Filmen, die die Flash-, Sprach- oder QuickTime-Xtras erfordern und für die Shockwave-Wiedergabe in einem Browser oder in einem Shockwave-Projektor vorgesehen sind, müssen diese Xtras in den Film aufgenommen und als "Bei Bedarf herunterladen" markiert werden, damit auch auf Systemen, auf denen die Director MX-Version des Shockwave Players noch nicht installiert ist, eine Wiedergabe möglich ist.

Zusätze und Korrekturen zur Dokumentation

Besetzungen
Benutzerdefinierte Besetzungsanordnungen werden nicht zusammen mit dem Film gespeichert. Um diese beizubehalten, müssen Sie ein Bedienfeldlayout speichern. Der entsprechende Befehl – Bedienfeldlayout speichern ist im Menü Fenster zu finden.

Um einen Film mit mehreren Besetzungen so zu öffnen, dass nur die interne Besetzung eingeblendet wird, halten Sie beim Öffnen die Umschalttaste gedrückt. Andernfalls erscheinen alle Besetzungen als Registerkarten im Bedienfeld Besetzung, das zusammen mit dem Film geöffnet wird.

Für die zweite Instanz eines Besetzungsfensters kann erst dann eine neue Besetzung erstellt werden, wenn Sie eine weitere Besetzungsregisterkarte hinzufügen (im Pulldownmenü bzw. im Menü zum Befehl gruppieren mit eine vorhandene Besetzung auswählen).

Die Besetzungsregisterkarten können mit <Befehl>+<Nach oben/Nach unten> (Mac) bzw. <Strg>+<Nach oben/Nach unten> (Windows) in Indexreihenfolge durchlaufen werden.

Die Besetzungsregisterkarten können mit <Befehl>+<Wahl>+<Nach links/Nach rechts> (Mac) bzw. <Strg>+<Alt>+<Nach links/Nach rechts> (Windows) in Tabulatorreihenfolge durchlaufen werden.

Offene Dokumentfenster können mit <Wahl>+<Tab> (Mac) bzw. <Strg>+<Tab> (Windows) vorwärts durchlaufen werden.

Um einen Film so zu öffnen, dass nur die interne Besetzung in der Bedienfeldgruppe Besetzung zu sehen ist, halten Sie bei Auswahl von Datei > Öffnen die Umschalttaste gedrückt..

Allgemeine Informationen
Auf Windows NT- und Windows 95/98-Systemen müssen SAPI4 und SAPI5 separat installiert sein, damit Text in Sprache umgewandelt werden kann. Weitere Informationen finden Sie im Artikel Director MX Text-To-Speech solution. Macintosh-Systeme sind von Haus aus sprachfähig.

Der 8-Bit-Farbmodus (256 Farben) wird bei der Erstellung von Inhalten nicht mehr unterstützt und führt mit großer Wahrscheinlichkeit zu nicht akzeptablen Ergebnissen.

Im Objektinspektor wird bei der Bearbeitung nur die Punktsyntax unterstützt. Die ausführliche Syntax wird zwar richtig angezeigt, doch die zugehörigen Unterkomponenten werden nicht korrekt eingeblendet, sodass die Unterwerte u. U. nicht geändert werden können.

Nur Erstellung: Wenn der Abspielkopf im selben Sprite-Kanal einen anderen Medientyp erreicht, wird im Objektinspektor die Strukturansicht für den entsprechenden Sprite-Bezug minimiert, was dazu führen kann, dass bei der Wiedergabe die Ansicht für andere Sprite-Bezüge nicht aktualisiert wird. Dieses Problem lässt sich oft umgehen, indem Sie die Sprite-Bezüge im Objektinspektor anders anordnen.

Benutzeroberfläche
Mit der Bedienfeldlayout-Funktion lassen sich Layouts auf Filmbasis speichern. Entwickler können also nicht nur angepasste Anordnungen des Bedienfelds Besetzung speichern, sondern auch gruppierte Skriptfenster und angepasste Gruppierungen von Medieneditoren.

Der Bedienfeldsatz Director 8 ist für Benutzer gedacht, die auch weiterhin mit dem vertrauten Director-Layout arbeiten möchten. Dieses Layout kann beliebig modifiziert und dann über Fenster > Bedienfeldsätze > Bedienfeldlayout speichern gespeichert werden.

Bekannte Probleme

Benutzeroberfläche
Registerkartennamen für Skriptfenster: Beim Öffnen eines neuen Skriptfensters wird ein leerer Skriptdarsteller erstellt. Der Darstellername "Skript" erscheint in der Registerkarte für gruppierte Skripts. Wenn das Skriptfenster geschlossen wird, ohne den Skriptdarsteller zu ändern, wird dieser genau wie bei allen anderen Medientypen gelöscht. Wenn es mehrere Skriptfenster gibt, die auf leere, nicht modifizierte Skripts verweisen, können die Registerkartennamen verwirrend sein.

Aufgrund der unter Windows verwendeten kleinen Schriftart ist Text bei einer Bildschirmauflösung von 1280 x 1024 oder höher u. U. schwer zu lesen.

Gespeicherte Bedienfeldsätze können nicht direkt umbenannt werden. Stattdessen müssen Sie den umzubenennenden Bedienfeldsatz auswählen und dann Fenster > Bedienfeldsätze > Bedienfeldlayout speichern verwenden, um einen neuen Namen festzulegen.

Wenn Sie doppelte Fenster für eine nicht verknüpfte externe Besetzung öffnen und dann einen Darsteller aus der externen Besetzung in den Film kopieren, erscheinen mehrere Instanzen von Besetzungsregisterkarten in der Besetzungsbedienfeldgruppe, zu der die externe Besetzung hinzugefügt wurde.

Das Ziehen mehrerer ausgewählter Darsteller mithilfe der Schaltfläche Darsteller ziehen funktioniert nicht. Stattdessen können Sie auf allen Plattformen die ausgewählten Darsteller direkt aus der Besetzung ziehen.

Wenn Sie in einem Film mit mehreren Besetzungen den Bedienfeldsatz Director 8 auswählen, erscheint ein Besetzungsfenster mit mehreren Registerkarten anstatt eines Einzelfensters, das nur die interne Besetzung enthält.

OS X
Der Vorwärtsschrägstrich (/) ist bei der Generierung von Dateien unter Mac OS X in Pfadangaben nicht zulässig. Weitere Informationen finden Sie in dieser TechNote.

Auf Macintosh-Computern, die die Mindestsystemvoraussetzungen nicht erfüllen, kann es in den folgenden Fällen zu einer beträchtlichen Verlangsamung kommen:
-- beim Speichern nach Erstellung von mehr als drei Bedienfeldsätzen;
-- beim Öffnen von Filmen mit mehr als sechs Besetzungen;
-- beim Öffnen nicht verknüpfter externer Besetzungen.
Damit Director MX optimal läuft, ist mindestens 256 MB RAM sowie ein G4 oder höher erforderlich.

Unter OS X wird OpenGL nach CloneModel() in einem Sprite, das in Bild 1 beginnt, nicht ordnungsgemäß initialisiert. Um dieses Problem zu umgehen, sorgen Sie dafür, dass das betreffende Sprite in Bild 2 beginnt, oder verwenden Sie den Software-Renderer.

Unter OS X sind nicht verknüpfte externe Besetzungen von verknüpften internen Besetzungen nur schwer zu unterscheiden. Externe Besetzungen sind daran zu erkennen, dass sie nicht mit anderen Besetzungen gruppiert (d. h. als Registerkarten angezeigt) werden können, nicht zusammen mit Bedienfeldlayouts gespeichert werden und bei Auswahl eines vorhandenen Bedienfeldlayouts geschlossen werden.

Die Tastenkombination <Befehl>+<M> funktioniert auf dem Macintosh nicht, wenn ein MIAW vom Typ 49 (schwebendes Fenster) geöffnet ist.

Allgemeine Informationen
Nur Erstellung: Wenn ein Film über längere Zeit hinweg läuft und im Besetzungsfenster Textdarsteller als Piktogramme dargestellt werden, kann es zu einem Absturz wegen Speichermangel kommen. Um dies zu verhindern, sollten Sie das Besetzungsfenster schließen bzw. die Listenansicht verwenden. (Dies trifft auch auf D8 und D8.5 zu.)

Nachdem Sie den Internet Explorer über den Eigenschafteninspektor gezogen haben, können Sie in den Feldern im Eigenschafteninspektor keine Eingabe mehr vornehmen. Um dieses Problem zu lösen, schließen Sie das Eigenschafteninspektorfenster und öffnen Sie es erneut. Weitere Informationen finden Sie in dieser TechNote. (Dies trifft auch auf D8 und D8.5 zu.)

Die Bearbeitung von Aktionen im Verhaltensinspektor kann zu einem Absturz führen, wenn in der Prozedur getPropDescriptionList Fehler enthalten sind. Dieses Problem war auch in Director 8.5 vorhanden. Weitere Informationen finden Sie in dieser TechNote.

Wenn Sie in einem verknüpften Director-Film (Linked Director Movie, LDM) auf ein nicht vorhandenes Sprite Bezug nehmen, stürzt Director ab. Wenn es beispielsweise einen LDM mit einem einzigen Sprite gibt und der LDM im Hostfilm unter Bezugnahme auf Sprite 2 aufgerufen wird, kommt es zu einem Absturz. Dieses Problem war auch in Director 8.5 vorhanden.

Wenn Sie ein Skript in einem verknüpften Director-Film im Debugmodus bearbeiten, stürzt die Anwendung u. U. ab (auch in D8.5 ein Problem).

Die Verwendung des OBJ-Konverters unter Windows NT 4 führt zum Absturz. Windows NT 4 wird von Director MX nicht unterstützt.

Wenn sich das Skriptfenster bei einem Doppelmonitorsystem auf beide Monitore erstreckt, erscheinen bei Auswahl von Text u. U. Linien auf der rechten Seite des Fensters.

Unter Windows erscheint beim Drucken die Standardanzahl der zu druckenden Seiten als 9999 Seiten. Der Benutzer darf nicht vergessen, die Seitenzahl zu ändern.

Geparster HTML-Code in Textdarstellern kann in bestimmten Fällen leicht abweichend interpretiert werden. Der zurückgegebene HTML-Code ist mit dem eingegebenen HTML-Code nicht identisch. In manchen Fällen werden Zeilenumbrüche oder Leerzeichen hinzugefügt.

Bei Auswahl eines Farbeffekts in einem von mehreren angedockten Malfenstern wird er in allen Fenstern geändert.

Bei Deaktivierung eines Films in einem Fenster (MIAW), wenn sich auf der Bühne kein bearbeitbares Sprites befindet, verhält sich Director so, als sei mit sprite(1) ein Cursor verknüpft. Um dieses Problem zu umgehen, fügen Sie eine on deactivateWindow-Prozedur mit der Lingo-Anweisung sprite(1).cursor = 0 hinzu. Dieses Problem war auch in Director 8.5 vorhanden.

Bei Verwendung von rateShift für Sounds mit Aufrufpunkten, ist keine Synchronisation mehr gegeben, und die Aufrufpunkte werden nach und nach verfehlt, bis überhaupt keine Aufrufpunkte mehr entdeckt werden. Dieses Problem war auch in Director 8.5 vorhanden.

Bei Verwendung des Befehls setPref kann es zu einem kleinen Speicherleck kommen. Von der Größe her entspricht der nicht mehr freigegebene Speicher dem String, der in die Einstellungsdatei geschrieben wird. Dieses Problem war auch in Director 8 und 8.5 vorhanden. Weitere Informationen finden Sie in dieser TechNote.

Der Debugger funktioniert beim Durchlaufen einer tell-Anweisung nicht richtig. Wenn in dem auf der Bühne ablaufenden Film ein Breakpoint erreicht wird und das Ereignis aus einem MIAW stammt (oder umgekehrt), erscheinen im Debugger beim Durchlaufen des Call Stacks VOID-Werte für Variablen, die eigentlich nicht VOID sind. Die richtigen Variablenwerte erscheinen nur für den Filmkontext, in dem sich der Breakpoint bzw. der Lingo-Fehler befindet.

Debuggerleistung: Bei Filmen, die Variablen mit außergewöhnlich langen Strings oder Listen enthalten, kann es lange dauern, bis das Skriptfenster in den Debuggermodus schaltet. Um dieses Problem zu umgehen, sollten Sie die Debugger-Trennleiste vor dem Debugging von Lingo-Code minimieren, der Variablen mit Bezüge auf lange Strings oder Listen enthält. Durch Minimieren der Trennleiste werden die Debugger-Fenster ausgeblendet, und ihr Inhalt wird nicht mehr aktualisiert. Weitere Informationen finden Sie im Director Support Center.

Flash
Flash Communication Server: Japanischer Text wird während der Eingabe bestätigt. NetDebug muss bei japanischem Text vor dem Import in Director aus der Flash-Datei entfernt werden. Bei Filmen mit NetDebug wird die Leistung beeinträchtigt und IME für Japanisch deaktiviert.

Bei Verwendung des Flash Communication Servers ist das Ausschneiden und Einfügen von bearbeitbarem Text nicht möglich. Wie Sie dieses Problem umgehen können, geht aus dieser TechNote hervor.

Die Flash Remoting-Funktion setCallBack darf nicht von einem verknüpften Film aus verwendet werden. Sie funktioniert zwar bei der Inhaltserstellung, führt aber in Shockwave und Projektoren zum Absturz. Weitere Informationen finden Sie in dieser TechNote.

Aus Sicherheitsgründen können nur Flash-Sprites, für die die Option Direkt auf Bühne aktiviert ist, auf das Flash-Einstellungsbedienfeld zugreifen.

Flash-Ganzzahlen werden bei der Übergabe an Lingo in Fließkommazahlen konvertiert. Der Grund: Bei der Umwandlung von Flash-Zahlen in Strings fallen das Dezimalzeichen und nachgestellte Nullen weg, damit Zahlen in Flash als Ganzzahlen dargestellt werden können. Intern werden in Flash jedoch alle Zahlen als Fließkommawerte gespeichert. Aus Lingo stammende numerische Werte sind deshalb Fließkommawerte.

3D
Bei mehrfachem Zugriff auf die Eigenschaft image eines Shockwave-W3D-Darstellers kommt es zum Absturz. Weitere Informationen finden Sie in dieser TechNote.

Auf dem Macintosh kann 3D-Text nicht bearbeitet werden, wenn die Option Direkt auf Bühne aktiviert ist. Weitere Informationen finden Sie in dieser TechNote.

Wenn Sie ein Verhalten an einem 3D-Sprite mit einer mouseUpOutside-Prozedur anbringen, wird diese Prozedur beim Auftreten eines mouseUpOutside-Ereignisses nicht ausgelöst. Dies ist auch bei D8.5 der Fall.

Im Objektinspektor erscheinen einige 3D-Lingo-Eigenschaften, die nicht unterstützt werden, darunter ShaderReference.nextShader und CameraReference.targetModel. Diese Eigenschaften werden von der Lingo-Engine verwendet und können nicht in Lingo-Skripts eingesetzt werden.

Text-to-Speech-Engine
Anders als bei Windows, wo Stimmen von Drittanbietern entwickelt werden, ist auf dem Macintosh die Text-to-Speech-Engine Teil des Betriebssystems. Apple bietet gegenwärtig nur Stimmen für amerikanisches Englisch und mexikanisches Spanisch:

http://www.apple.com/lae/education/disability/easyaccess.html

Große Umlaute im Verhalten "Eingabezeichen filtern" nicht zulässig (OS X)
Geben Sie zur Umgehung dieses Problems sowohl groß als auch klein geschriebene erweiterte ASCII-Zeichen in das Feld Zulässige Zeichen ein.

Fontmap.txt
Wenn die Datei "fontmap.txt" statt Windows- oder Macintosh- (OS 9-) Zeilenendungen Unix-Zeilenendungen aufweist, wie sie unter OS X verwendet werden, werden erweiterte ASCII-Zeichen nicht ordnungsgemäß zugeordnet. Stellen Sie aus diesem Grund sicher, dass die Datei "fontmap.txt" entweder Windows- oder OS 9-Zeilenendungen (CR) enthält.