辅助功能*

面向 Adobe AIR 用户的发行说明

发行日期:2010 年 6 月 9 日

入门

Adobe® AIR® 运行时支持许多常见的桌面应用程序,包括视频播放器、企业应用程序、游戏和效率工具。在运行这些应用程序之前,用户必须安装 Adobe AIR。

本文档包含系统要求、安装说明、已知问题以及有关使用 AIR 2 运行时的其它信息。

系统要求

   Windows® Macintosh® Linux
最低处理器配置 最低配置:Intel® Pentium® III 1GHz 或更快的处理器;建议配置:Pentium 4 2GHz 或更快的处理器 Intel Core™ Duo 1.83GHz 或更快的处理器。 最低配置:Intel® Pentium® III 1GHz 或更快的处理器;建议配置:Pentium 4 2GHz 或更快的处理器
操作系统 Windows Vista® Home Premium、Business、Ultimate 或 Enterprise 版(包括 64 位版本);Windows Vista SP1;Windows XP Tablet PC Edition SP2 和 SP3;Windows XP SP2 和 SP3;Windows 2003/2008 Server;Windows 7 Mac OS 10.4、10.5 或 Mac OS 10.6 Fedora Core 12、Ubuntu 9.10 和 openSUSE 11.2。
内存 最低配置:512MB RAM;建议配置:1GB RAM 最低配置:512MB RAM;建议配置:1GB RAM 1GB RAM

注意:Windows 2000 和 Mac PowerPC 不支持 AIR 2。用户可以安装和运行 AIR 1.5 应用程序,但无法安装或更新到 AIR 2。Intel 处理器上的 Mac OS 10.4 支持 AIR 2,但不能作为使用 AIR 2 SDK 的开发环境。

Linux 发行版的其它要求:

支持的桌面环境 GNOME 和 KDE
软件包管理系统 RPM 和 Debian
最低 GTK+ 版本 2.6
窗口管理器 Metacity(GNOME 的默认值) 和 KWin(KDE 的默认值)
透明度 若要在 AIR 应用程序中支持透明度,需要使用复合窗口管理器和其他 X 服务器扩展。支持的复合窗口管理器:Beryl、Compiz、Compiz-fusion;支持的 X 服务器扩展:Composite、Render、Shape
Flash Player 从 Web 进行无缝安装(标志安装)需要 Flash Player 10.0.15.3 或更高版本。

支持的语言

Adobe AIR 2 安装和运行时用户体验支持下列语言:

  • 简体中文
  • 繁体中文
  • 捷克语
  • 荷兰语
  • 英语
  • 法语
  • 德语
  • 意大利语
  • 日语
  • 韩语
  • 波兰语
  • 巴西葡萄牙语
  • 俄语
  • 西班牙语
  • 瑞典语
  • 土耳其语

AIR 2 中的新增功能

  • 不再支持 Windows 2000 和 Mac PowerPC — 使用这些操作系统的用户仍然可以安装和运行 AIR 1.5 应用程序,但不能安装或更新到 AIR 2。
  • 本机进程 API
  • 海量存储设备检测
  • 可打开文档的本机文档处理程序
  • 本地麦克风 API
  • 支持屏幕阅读器(仅限 Windows)
  • 拖放支持增强
  • IME API 和 IME 文本输入增强
  • 具有 CSS3 功能和某些 HTML5 功能支持的新 WebKit
  • JavaScript 引擎加快
  • 套接字服务器和对等技术
  • TLS/SSL 套接字
  • UDP 网络支持
  • 多点触控和手势
  • 性能改进
  • 跨平台 (Mac/Windows) 矢量输出
  • 打印机交互增强
  • 全局错误处理程序
  • IPv6 网络支持
  • 运行时安装程序用作 Linux 的 .deb 和 .rpm 软件包
  • 安全性提高
  • 最大窗口尺寸增大

安装 Adobe AIR

安装 AIR 2 和 AIR 应用程序时,要求您在计算机上具有管理员权限。

在 Windows 计算机上安装 AIR 2

  1. http://get.adobe.com/cn/air 下载 AIR 2 安装文件。
  2. 双击 AIR 2 安装文件,按照屏幕提示完成安装。

在 Mac OS 计算机上安装 AIR 2

  1. http://get.adobe.com/cn/air 下载 AIR 2 安装文件。
  2. 双击 AIR 2 安装文件,按照屏幕提示完成安装。
  3. 如果安装程序显示"身份验证"窗口,请输入管理员用户名和密码。

在 Linux 计算机上安装 AIR 2

使用二进制安装程序

  1. http://get.adobe.com/cn/air 下载 AIR 2 二进制安装文件。
  2. 双击 AIR 2 安装文件 AdobeAIRInstaller.bin,按照屏幕提示完成安装。
  3. 如果您不是以管理员身份登录,则调用安装程序时,会提示您输入管理员密码(Debian 系统为 sudo 用户密码,其它系统为 root 用户密码)。另外请注意以下事项:
    • 您需要授予对 bin 文件的执行权限
      chmod +x [AdobeAIRInstaller].bin
    • Adobe AIR 以本机软件包形式进行安装,即,在基于 rpm 的发行版中以 rpm 的形式安装,在 Debian 发行版中以 deb 的形式安装。AIR 当前不支持任何其它软件包格式,因此无法在 Slackware 等发行版上进行安装。
    • Adobe AIR 将安装到以下位置:/opt/Adobe AIR/Versions/1.0
    • AIR 注册 mime 类型"application/vnd.adobe.air-application-installer-package+zip",这表示 .air 文件属于此 mime 类型,因此向 AIR 运行时注册。

使用软件包安装程序

  1. http://get.adobe.com/cn/air< 下载 AIR 2 软件包文件。根据您的系统,可以选择 rpm 或 Debian 软件包。
  2. 双击 AIR 2 软件包文件安装软件包。
  3. 还可以使用命令行安装。

如果您使用的是基于 Debian 的系统,则使用以下命令:

sudo dpkg -i <path to the package>/adobeair-2.0.0.xxxxx.deb

如果您使用的是基于 rpm 的系统,则首次安装 AIR 时使用以下命令:

sudo rpm -i <path to the package>/adobeair-2.0.0-xxxxx.i386.rpm

或者,使用以下命令更新现有 AIR 安装:

sudo rpm -U <path to the package>/adobeair-2.0.0-xxxxx.i386.rpm

注意:只有已安装的 AIR 为 1.5.3 或更高版本时,才支持使用软件包安装程序升级 Adobe AIR。

卸载 Adobe AIR

安装完 Adobe AIR 后,可以按照以下过程卸载该程序。

在 Windows 计算机上卸载 Adobe AIR

  1. 在 Windows"开始"菜单中,选择“设置” > “控制面板”。
  2. 选择“添加/删除程序”控制面板。
  3. 选择“Adobe AIR”以卸载运行时。
  4. 单击“更改/删除”按钮。

在 Mac 计算机上卸载 Adobe AIR

1. 双击位于 /Applications/Utilities 文件夹中的“Adobe AIR Uninstaller”。

在 Linux 计算机上卸载 Adobe AIR

1. 使用系统的软件包管理器卸载 adobeair 软件包。

安装 AIR 应用程序

安装用于 Mac、Windows 和 Linux 的 AIR 应用程序

Web 浏览器中进行标志安装
您可以利用无缝安装功能(标志安装)安装 AIR 应用程序,该功能将根据需要安装或更新 AIR 运行时。安装 AIR 运行时后,单击 Web 页面上的链接/标志将启动应用程序安装。系统将提示您输入安装位置和管理员密码(如果需要)。

从本地 .air 文件安装
安装 AIR 运行时后,您可以双击 .air 文件调用应用程序安装程序。安装程序会首先显示安全对话框,说明发行商身份。系统将提示您输入安装位置和本机用户密码(如果需要)。

Linux 的其它详细信息

  1. AIR 应用程序以 Linux 软件包(rpm 或 deb)形式安装。
  2. 软件包名称是应用程序的 applicationID 和 publisherID 的组合。

提示和技巧

AIR 安装程序疑难解答

有关安装程序疑难解答,请参阅以下技术说明:

http://kb2.adobe.com/cps/403/kb403150.html*

AIR 2 应用程序和运行时安装的安装程序日志

在 AIR 2 中,默认情况下在日志文件中创建安装日志。该文件在 Linux 和 Windows 上名为“Install.log”。在 Mac OS 上名为“system.log”。此日志文件是累积式的,即,只要尝试安装或更新 AIR 运行时或 AIR 应用程序,无论成功与否,都将在现有日志文件的末尾追加新日志。日志文件的大小限于 0.5MB,超出此大小时将被截断。

此文件的位置根据平台而有所不同:

*在 Windows XP 上:C:\Documents and Settings\<用户名>\Local Settings\Application Data\Adobe\AIR\logs\Install.log
*在 Windows Vista/ Windows 7 上:C:\Users\<用户名>\Appdata\Local\Adobe\AIR\logs\Install.log
*在 Mac OS X 上:/private/var/log/system.log(控制台应用程序)
*在 Linux 上:/home/<用户名>/.appdata/Adobe/AIR/Logs/Install.log

已知问题和限制

屏幕阅读器支持

目前只在 Windows 操作系统上提供屏幕阅读器支持。与 AIR 兼容的屏幕阅读软件包括 NonVisual Desktop Access (NVDA) 和 JAWS 版本 11。在某些情况下,屏幕内容的顶级激活和自动通知可能不会完全起作用。例如,光标的焦点在文本字段上时,JAWS 11 可能在必要时进入“虚拟光标”模式,而不切换到“窗体”模式,不允许键入文本字段。解决方法是先使焦点离开文本字段,然后再进入文本字段,以便输入文本。

非 ASCII URL

如果 URL 字符串包含非 ASCII 字符,则可能在 Windows XP 上无效,因为系统上可能不存在 AIR 所依赖的 Windows 代码模块。解决办法是安装 Internet Explorer 7,这样将安装必要的代码模块。Windows Vista 和更高版本不存在此问题。

Linux 本机软件包安装的标志安装问题

使用本机软件包安装程序安装 Adobe AIR 后,标志安装可能无效,您可能看到以下错误:“对不起,出现了错误。无法安装应用程序。请尝试重新安装。如果问题仍然存在,请与应用程序作者联系。错误 #1”。此问题在 Flash Player 10.1 中已解决。

早期版本的 Flash Player 的解决方法是下载 .air 文件并在本地保存,然后尝试使用“Adobe AIR 应用程序安装程序”进行安装。完成此过程后,以后的标志安装就可以正常使用了。

AIR HTML 中的泰文输入问题

在 HTML 内容中键入某些泰文字符时,光标可能移到错误的位置。目前不支持除上述"支持的语言"部分列出的语言以外的语言的文本输入。

没有 Adobe Reader 就无法显示 PDF 内容

若要在 AIR 2 中显示 PDF 内容,请确保安装 Adobe Reader 8.2/9.3 或更高版本。

嵌入的 Flash 内容出现显示问题

如果应用程序使用透明窗口,HTML 页或 HTML 应用程序中嵌入的 Flash 内容不显示。

启用 SELinux 的 Fedora Core 上的安装问题

在 Fedora Core 计算机上启用 SELinux 时,使用二进制安装程序的运行时安装和 AIR 应用程序的标志安装无效。

在 64 位 Linux 发行版上安装 AIR2

有关在 64 位 Linux 计算机上安装 AIR 2 或对 AIR 1.5.3 进行后台更新时出现的问题,请参阅以下技术说明:http://kb2.adobe.com/cps/521/cpsid_52132.html*

AIR 知识库

有关已知问题的其它信息,请访问 Adobe AIR 支持网站 http://www.adobe.com/support/air/*