Accessibility
 
Home > Products > Dreamweaver > Support > Working with Studio MX
Dreamweaver Icon Macromedia Dreamweaver Support Center - Working with Studio MX
Set HTML preferences

HTML, or HyperText Markup Language, is the primary method used on the Internet to create and display web pages. You don't need to understand HTML to use Fireworks, but it helps to keep in mind that Fireworks slices become cells in an HTML table when exported.

Before you export the document for the first time, you need to set HTML export preferences.

1 Select File > HTML Setup.
The HTML Setup dialog box appears.

The options you set in this dialog box will affect all future Fireworks documents you create, except the options on the Document Specific tab.
2 On the General tab, select an HTML style.
If you use an HTML editor such as Macromedia Dreamweaver MX or Microsoft FrontPage, select it from this pop-up menu. Doing so allows you to easily open and edit the exported file in that HTML editor. If you don't use an HTML editor or you use one that's not in this list, select Generic HTML.
3 Select .htm as the file extension.
4 Click the Table tab.
The Table tab allows you to change HTML table properties.
5 In the Space with pop-up menu, select 1-Pixel Transparent Spacer.

When this option is selected, Fireworks exports a graphic file called spacer.gif, which is a 1-pixel transparent image. Spacers are used by web designers to aid in page layout. They hold empty HTML table cells open. Without them, empty HTML table cells collapse, altering your intended page layout. You'll see the spacer.gif file later when you view your exported files.
6 Click the Document Specific tab.

The Document Specific tab allows you to choose a variety of document-specific preferences, including a customized naming convention for your exported files. Remember that the options you set here apply only to the current Fireworks document.
Note: You can apply the settings on the Document Specific tab to all new documents by clicking the Set Defaults button.
7 Click OK to accept the settings on the Document Specific tab and close the HTML Setup dialog box.
For more information about setting HTML preferences, see Fireworks Help (Help > Using Fireworks > Optimizing and Exporting > Exporting from Fireworks > Exporting HTML).

To Table of Contents Back to Previous document Forward to next document