Accessibility
 
Home / Products / Fireworks / Support / Release Notes  
Fireworks Icon Macromedia Fireworks Support Center - Release Notes

Fireworks 4 and 4.0.2
Notas de versão

Fireworks 4.0.2 updater
Fireworks 4

Fireworks 4.0.2 updater
O atualizador para o Fireworks 4.0.2 corrige vários problemas encontrados após o lançamento do Fireworks 4.

Para usar o atualizador, é necessário primeiro adquirir e instalar a versão completa do Fireworks 4. Esta transferência contém o atualizador para o Fireworks 4.0.2 e o arquivo LeiaMe.

Principais Correções
Problemas identificados em ambas as plataformas
Problemas identificados - Macintosh
Arquivos substituídos
Requisitos do sistema

Principais Correções
Veja a seguir uma lista dos problemas corrigidos pelo atualizador:

> Processo em lote: Escalonar para dimensionar
Durante o processo em lote, Escalonar para dimensionar funcionará como esperado quando "Variável" for selecionada como Largura ou Altura.
> Processo em lote: Escalonar para porcentagem ou Tamanho do pixel (somente no Windows)
O Fireworks não mais exibirá uma mensagem de "erro interno" quando os arquivos forem processados em lote com as configurações Escalonar para porcentagem ou Tamanho do pixel.
> Iniciar e editar do Director
Ao iniciar e editar no Fireworks a partir do Director, o Fireworks não mais pedirá que você localize um arquivo de origem.
> Comprimento do URL no menu pop-up (somente no Windows)
O campo Vínculo da caixa de diálogo Menu pop-up agora rolará à medida em que você digitar o texto, permitindo que você digite URLs mais longos. Além disso, os menus pop-up que contêm múltiplos itens não mais produzirão erros.
> Ponto ativo do Menu pop-up
Os menus pop-up agora funcionam como esperado quando visualizados no Internet Explorer 4.0 - 4.5 no Windows.
> Importação do FreeHand
A opção "Converter camadas em molduras" funcionará como esperado ao importar arquivos do FreeHand.
> Problema no menu Ajuda do Alien Skin Eye Candy (somente no Macintosh)
Usar um plug-in Alien Skin Eye Candy não faz mais com que os itens do menu Ajuda desapareçam.
> Efeitos múltiplos de terceiros
Efeitos múltiplos de terceiros aplicados a um objeto agora serão renderizados corretamente.
> Suporte de HTML do Netscape Navigator 6
Os modelos de HTML para o Fireworks foram atualizados para fins de compatibilidade com o Netscape Navigator 6.
> Visualização no Netscape Navigator 6 (somente no Windows)
O Netscape Navigator 6 pode ser configurado como o navegador ao utilizar Arquivo > Visualizar no navegador, no Fireworks 4.

Problemas Detectados
Se você já tiver o Fireworks 3 e o Director 8 instalados, iniciar e editar podem parar de funcionar quando você instalar o Fireworks 4.

Para corrigir o problema, faça o seguinte:

1 Abra o Director 8.
2 Selecione Arquivo > Preferências > Editores.
3 Selecione um formato de imagem que você deseja editar com o Fireworks (geralmente PNG, JPEG, e GIF).
4 Clique no botão Editar e navegue até a aplicação do Fireworks 4 no disco rígido.

O Director pode indicar que o Fireworks já está configurado como o seu editor externo, mas o iniciar e editar não funcionará até que você especifique novamente o Fireworks como editor
externo.


Problemas identificados - específicos do Macintosh
Se você usar o Otimizar do Fireworks em uma imagem GIF ou PNG que foi importada para o Director, a caixa de diálogo Otimização do Fireworks exibirá inicialmente PNG como formato. Será necessário
selecionar JPEG no menu pop-up Formato na caixa de diálogo Otimização do Fireworks.

Arquivos substituídos
Os seguintes arquivos são substituídos quando o atualizador para o Fireworks 4.0.2 é executado:

> Fireworks.exe (Windows) ou Fireworks 4 (Macintosh)
> Configuration \ Batch Code \ BatchTemplate.jst
> Configuration \ HTML Code \ Generic \ slices.htt
> Configuration \ HTML Code \ Dreamweaver \ slices.htt
> Configuration \ HTML Code \ fw_menu.js

Fireworks 4
Este documento trata de problemas não discutidos na documentação do Fireworks e pode ser atualizado quando houver mais informações disponíveis.

Requisitos do sistema
Problemas detectados em ambas as plataformas
Problemas detectados - específicos do Macintosh
Problemas detectados - específicos do Windows
Como fazer o relatório de depuração de erros

Requisitos do sistema

Windows Macintosh
Processador Intel Pentium (Pentium II, recomendado) Processador Power Macintosh (G3 ou posterior, recomendado)
Windows 95, 98, NT (com service Pack 3), ME ou 2000 Mac OS 8.6 ou 9.x
64 MB de RAM disponível 64 MB de RAM disponível
Tela com 800 x 600, 256 cores
(1024 x 768, milhões de cores, recomendado)
Tela com 800 x 600, 256 cores
(1024 x 768, milhões de cores, recomendado)
100 MB de disco rígido disponível 100 MB de disco rígido disponível
Adobe Type Manager Versão 4 ou posterior com fontes do Tipo 1

Problemas detectados em ambas as plataformas

> No processo em lote, a utilização de Escalonar para dimensionar com os campos de largura ou altura definidos como Variável, fará com que o processo dos arquivos falhe.

Para resolver esse problema, faça o seguinte:

1 Localize o arquivo BatchTemplate.jst atualizado no CD do Dreamweaver-Fireworks Studio em Fireworks 4/Goodies/Batch Code Backup.
  Ou faça o download do arquivo BatchTemplate.jst atualizado a partir do Fireworks Support Center.
2 Substitua o arquivo antigo pelo arquivo BatchTemplate.jst localizado em Fireworks 4/Configuration/Batch Code.

Nota: Esse problema afeta apenas a versão em inglês do Fireworks. Os outros idiomas são instalados com o arquivo atualizado.

> Originalmente, o Dreamweaver não suporta o JavaScript usado para os menus pop-up do Fireworks, portanto, seu funcionamento não será confiável se você usar Copiar HTML, ou exportar e copiar o HTML para a área de transferência

Para exportar menus pop-up para o Dreamweaver Ultradev faça o seguinte:

1 Use Atualizar HTML a partir do Fireworks ou escolha Inserir > Imagens interativas > HTML do Fireworks a partir do Dreamweaver.
> Os plug-ins de filtro do Photoshop 6 não funcionam no Fireworks 4, devido a alterações não documentadas na API de plug-in do Photoshop.
> O texto importado do Photoshop 6 é convertido em bitmaps no Fireworks, da mesma maneira que o Photoshop 5.5 converte texto de arquivos do Photoshop 6 em bitmaps.
> O algoritmo de conversão de cores do Fireworks é diferente do algoritmo do Photoshop. Por isso, pequenas variações de cores podem ocorrer quando abrir arquivos EPS ou exportar do Fireworks como um arquivo PSD e, em seguida, abri-lo no Photoshop
> Se o nome do seu disco rígido contiver um caractere não permitido em um caminho de arquivo HTML, como uma barra (/), Vizualizar no navegador não funcionará.
> O mecanismo de pesquisa na Utilização da Ajuda do Fireworks não funcionará se o Java estiver desativado no seu navegador.
> Se você quiser exportar objetos de fatia e botões ao exportar para o Director, escolha Arquivo > Configuração do HTML e, em seguida, desmarque "Incluir áreas sem fatias" na guia Específico do documento.
> Ao exportar para o Director, exporte imagens para a mesma pasta do seu arquivo HTML ou para uma subpasta contendo seu arquivo HTML.
> O Fireworks não pode abrir arquivos do Adobe Illustrator 9.

Para trazer informações vetoriais para o Fireworks, faça o seguinte:

1 Exporte do Illustrator 9 como um arquivo do Illustrator 8 e, em seguida, abra-o no Fireworks.
2 Ou, Exporte um arquivo EPS API do Illustrator 9 e o Fireworks o rastreará ao importá-lo.
> A exportação de arquivos ou pastas que contenham caracteres ASCII ampliados pode fazer com que as imagens não sejam exibidas quando visualizadas em um navegador. O Netscape não suporta nomes de arquivo ou de pasta que contenham caracteres ASCII ampliados. Ao dar nomes a documentos, fatias ou molduras, evite usar caracteres inválidos para nomes de arquivo HTML.

Problemas conhecidos - específicos do Macintosh

> Quando importar arquivos EPS, as fontes podem ser renderizadas como Courier, a menos que tenham sido incluídas no arquivo EPS quando esse foi criado.
> Se você estiver usando uma versão antiga do Macintosh Runtime para Java, o Internet Explorer pode exibir um erro de JavaScript quando você fechar a janela do navegador durante a visualização da Ajuda do Fireworks. Se isso acontecer, verifique se está usando a última versão do Apple Macintosh Runtime para Java, disponível em http://www.apple.com.
> O software Kensington Mouseworks faz com que alguns comandos do teclado não funcionem de forma adequada. Se tiver problemas com os atalhos, tente desativar a extensão do Mouseworks.
> Se a memória virtual estiver desativada, o Fireworks não será iniciado a partir de alguns discos rígidos internos ATA de outros fabricantes. Se tiver problemas ao iniciar o Fireworks a partir de uma unidade de outro fabricante, tente ativar a memória virtual. Se o problema persistir, mova o Fireworks para um disco rígido diferente ou entre em contato com o fabricante do disco rígido para obter os drivers atualizados do dispositivo.

Problemas conhecidos - específicos do Windows

> Se tiver o Dreamweaver 3 e o Fireworks 3 instalados em seu computador, e desinstalar o Fireworks 4, o início e a edição não funcionarão mais da forma adequada entre o Dreamweaver 3 e o Fireworks 3.
> Em computadores com WIndows 2000 ou NT4, é necessário efetuar o login como administrador para instalar o Fireworks. Você não precisa efetuar o login como administrador para executar o Fireworks se esse já tiver sido instalado.

> É possível mover painéis totalmente para fora da tela. Se isso acontecer, escolha Comandos > Definições de layout de painel e selecione a definição que corresponder à resolução do seu monitor. Esse procedimento restaurará a posição e aparência padrão de seus painéis.

Como fazer relatórios de depuração de erros
Encontrou um erro? Envie um e-mail para a equipe do Fireworks com as seguintes informações:

=======================
Seu nome:
Seu e-mail:
Seu telefone:
=======================
Descrição do erro
=======================
Resumo:
Etapas a reproduzir:
1.
2.
3.
Resultados esperados:

Resultados reais:
=======================
Plataforma:
=======================
Power Macintosh________
Windows 95/98________
Windows NT________
Windows 2000________
Windows ME________
=======================
Informações do sistema:
=======================
Hardware:
Versão do Sistema operacional:
RAM:
=======================

Inclua Relatório de depuração de erros: [resumo breve do problema] na linha Assunto, para que possamos separar os relatórios de depuração de erros das solicitações de recursos. Por exemplo, "Relatório de depuração de erros: Não consigo exportar JPEGs".