Accessibility
 
Home / Products / Fireworks / Support / Release Notes  
Fireworks Icon Macromedia Fireworks Support Center - Release Notes

Fireworks 4 and 4.0.2
versionshinweise

Fireworks 4.0.2 updater

Fireworks 4

Fireworks 4.0.2 updater
Der Fireworks 4.0.2 Updater behebt mehrere Fehler, die in Fireworks Release 4 aufgetreten sind.

Um den Updater benutzen zu können, müssen Sie zuerst eine Vollversion von Fireworks 4 erwerben und installieren.Dieses Download enthält den Fireworks 4.0.2 Updater und eine Readme-Datei.

Die wichtigsten Korrekturen im Überblick
Bekannte Probleme auf beiden Plattformen
Bekannte Probleme - Macintosh
Ersetzte Dateien
Systemanforderungen

Die wichtigsten Korrekturen im Überblick
Der Updater behebt die folgenden Fehler:

> Stapelverarbeitung: Option "Scale to Size"
Bei der Stapelverarbeitung wird die Option "Scale to Size" nun korrekt ausgeführt, wenn für die Breite oder Höhe die Option "Variable" gewählt wird.
> Stapelverarbeitung: "Scale Percentage" oder "Pixel Size" (nur Windows)
Wenn bei der Stapelverarbeitung von Dateien die Einstellung "Scale Percentage" oder "Pixel Size" aktiviert ist, zeigt Fireworks keine Meldungen des Typs "Internal Error" mehr an.
> Starten und Editieren über Director
Beim Starten und Editieren in Fireworks über Director fordert Fireworks den Benutzer nicht mehr zur Angabe einer Quellendatei auf.
> Popup-Menü "URL length" (nur Windows)
Das Feld "Link" im Dialogfeld des Popup-Menüs läuft bei der Texteingabe mit und ermöglicht die Eingabe längerer URLs. Weiterhin werden bei Popup-Menüs mit mehreren Einträgen keine Fehler mehr verursacht.
> Hot Spot im Popup-Menü
Popup-Menüs werden bei der Ansicht im Internet Explorer 4.0 - 4.5 unter Windows korrekt angezeigt.
> Importieren von FreeHand-Dateien
Die Option "Convert Layers to Frames" wird jetzt beim Importieren von FreeHand-Dateien korrekt ausgeführt.
> Problem mit dem Hilfemenü in Eye Candy von Alien Skin (nur Macintosh)
Bei der Verwendung des Plug-In Eye Candy von Alien Skin verschwinden im Hilfemenü keine Einträge mehr.
> Effekte aus Fremdprodukten
Auf ein Objekt angewandte Effekte aus Fremdprodukten werden jetzt korrekt wiedergegeben.
> HTML-Unterstützung für Netscape Navigator 6
Die Fireworks HTML-Vorlagen wurden aktualisiert und sind jetzt mit Netscape Navigator 6 kompatibel.
> Vorschau mit Netscape Navigator 6 (nur Windows)
Netscape Navigator 6 kann jetzt in Fireworks 4 über die Optionen File > Preview als Browser eingestellt werden.

Bekannte Probleme
Wenn Sie Fireworks 3 und Director 8 bereits installiert haben und Fireworks 4 installieren, funktioniert "Starten und bearbeiten" möglicherweise nicht mehr.

Zur Behebung dieses Problems gehen Sie wie folgt vor:

1 Öffnen Sie Director 8.
2 Wählen Sie Datei> Voreinstellungen > Editoren.
3 Wählen Sie ein Bildformat, das Fireworks bearbeiten soll (typischerweise PNG, JPEG und GIF).
4 Klicken Sie auf die Schaltfläche "Bearbeiten", und wählen Sie das Programm Fireworks 4 auf der Festplatte.

Director zeigt Fireworks zwar möglicherweise bereits als externen Editor an, doch funktioniert "Starten und bearbeiten" erst dann, wenn Sie Fireworks erneut als externen Editor einstellen.

Bekannte Probleme - Macintosh-spezifisch
Wenn Sie in Fireworks die Funktion "Optimieren" auf eine GIF-oder PNG-Datei anwenden, die in Director importiert wurde, wird im Optimierungsdialogfeld von Fireworks zunächst PNG als Format angezeigt.Sie müssen im Popup-Menü "Format" im Optimierungsdialogfeld von Fireworks den Eintrag JPEG wählen.

Ersetzte Dateien
Die folgenden Dateien werden während der Ausführung des Fireworks 4.0.2 Updaters ersetzt:

> Fireworks.exe (Windows) oder Fireworks 4 (Macintosh)
> Configuration \ Batch Code \ BatchTemplate.jst
> Configuration \ HTML Code \ Generic \ slices.htt
> Configuration \ HTML Code \ Dreamweaver \ slices.htt
> Configuration \ HTML Code \ fw_menu.js

Fireworks 4
Dieses Dokument enthält Informationen, die in der Dokumentation zu Fireworks nicht enthalten sind und gegebenenfalls aktualisiert werden, sobald neue Erkenntnisse vorliegen.

Systemanforderungen
Bekannte Probleme (betriebssystemunabhängig)
Bekannte Probleme (nur Macintosh-Version)
Bekannte Probleme (nur Windows-Version)
Vorgehensweise bei der Fehlerbenachrichtigung

Systemanforderungen

Windows Macintosh
Intel Pentium-Prozessor (Empfehlung: Pentium II) Power Macintosh-Prozessor (Empfehlung: G3 oder höher)
Windows 95, 98, NT (mit Service Pack 3), ME oder 2000 Mac OS 8.6 oder 9.x
64 MB verfügbarer RAM-Speicher 64 MB verfügbarer RAM-Speicher
Grafikanzeige mit 800 x 600 Bildpunkten und 256 Farben (Empfehlung: 1024 x 768 Bildpunkte, Millionen von Farben) Grafikanzeige mit 800 x 600 Bildpunkten und 256 Farben (Empfehlung: 1024 x 768 Bildpunkte, Millionen von Farben)
100 MB freier Speicherplatz auf der Festplatte 100 MB freier Speicherplatz auf der Festplatte
Adobe Type Manager 4 oder neuer zum Verwenden von Type-1-Schriftarten

Bekannte Probleme (betriebssystemunabhängig)

> Bei der Batch-Verarbeitung werden Dateien, in denen die Option "Auf Größe skalieren" mit der Option "Variabel" für Breiten- oder Höhenangabe verwendet wird, ignoriert.

Gehen Sie wie folgt vor, um dieses Problem zu beheben:

1 Suchen Sie die Datei "BatchTemplate.jst" auf der Dreamweaver-Fireworks Studio-CD im Verzeichnis Fireworks 4 > Goodies > Batch Code Backup.
  Laden Sie sich die aktualisierte Version der Datei "BatchTemplate.jst" aus dem Fireworks Support Center herunter.
2 Ersetzen Sie die alte Dateiversion von "BatchTemplate.jst" im Verzeichnis Fireworks 4 > Configuration > Batch Code durch die neue Version.

Hinweis: Dieses Problem betrifft nur die englischsprachige Fireworks-Version. In den anderen Sprachen wird automatisch die aktualisierte Datei installiert.

> Da Dreamweaver den von Fireworks zur Erstellung von Popupmenüs verwendeten JavaScript-Code von Haus aus nicht unterstützt, funktionieren die Menüs nicht zuverlässig, wenn der Code mit der Option "HTML-Code kopieren" bzw. über Exportfunktion und Zwischenablage in Dreamweaver importiert wird.

Um Popupmenüs nach Dreamweaver oder Dreamweaver UltraDev zu exportieren, gehen Sie wie folgt vor:

1 Verwenden Sie entweder den Befehl "HTML aktualisieren" in Fireworks oder den Befehl "Einfügen > Interaktive Bilder > Fireworks-HTML" in Dreamweaver.
> Filter-Plug-Ins für Photoshop 6 können aufgrund nicht dokumentierter Änderungen in der Plug-In-API von Photoshop nicht mit Fireworks 4 eingesetzt werden.
> Aus Photoshop 6 importierter Text wird in Fireworks - ebenso wie in Photoshop 5.5 - in ins Bitmap-Grafikformat umgewandelt.
> Fireworks verwendet einen anderen Farbkonvertierungs-Algorithmus als Photoshop. Daher können leichte Farbabweichungen auftreten, wenn EPS-Dateien geöffnet werden oder wenn aus Fireworks exportierte PSD-Dateien in Photoshop verwendet werden.
> Wenn der Name Ihrer Festplatte ein Zeichen enthält, das in einem HTML-Dateipfad nicht zulässig ist - z.B. einen Schrägstrich (/) - kann die Funktion "Vorschau in Browser" nicht verwendet werden.
> Wenn Java in Ihrem Browser deaktiviert ist, funktioniert die Suchmaschine der Online-Hilfe "Fireworks verwenden" nicht.
> Um beim Export nach Director nur Segmentobjekte und Schaltflächen zu berücksichtigen, wählen Sie den Menübefehl "Datei > HTML-Einrichtung" und deaktivieren Sie im Register "Dokumentspezifisch" die Option "Bereiche ohne Segmente einschließen".
> Beim Export nach Director sollten Grafiken in denselben Ordner wie die HTML-Datei oder in einen Unterordner dieser Datei exportiert werden.
> Ändern zu: Das Dateiformat von Adobe Illustrator 9 kann in Fireworks nicht geöffnet werden.

Um Vektordaten nach Fireworks zu importieren, gehen Sie wie folgt vor:

1 Speichern Sie die Datei in Illustrator 9 im Dateiformat von Illustrator 8 ab und öffnen Sie sie anschließend in Fireworks.
2 Sie können die Datei stattdessen auch im AI EPS-Format aus Illustrator 9 exportieren. In diesem Fall wird sie beim Import in Fireworks automatisch gerastert.
> Wenn beim Export Datei- oder Ordnernamen verwendet werden, die Zeichen aus dem oberen ASCII-Bereich enthalten, kann dies dazu führen, dass die Grafiken in einem Browser nicht korrekt angezeigt werden. Datei- oder Ordnernamen, die Zeichen aus dem oberen ASCII-Bereich enthalten, werden von Netscape nicht unterstützt. Vermeiden Sie beim Benennen von Dokumenten, Segmenten oder Frames Zeichen, die in HTML-Dateinamen nicht zulässig sind.

Bekannte Probleme (nur Macintosh-Version)

> Beim Import von EPS-Dateien werden Schriftarten, die beim Erstellen nicht in die Datei eingeschlossen wurden, unter Umständen als Courier-Schrift wiedergegeben.
> Wenn Sie eine ältere Java-Runtime-Version für Macintosh verwenden, zeigt Internet Explorer unter Umständen eine JavaScript-Fehlermeldung an, wenn Sie das Browserfenster schließen, während die Fireworks-Hilfe angezeigt wird. Installieren Sie in diesem Fall die aktuelle Java-Runtime-Version für Apple Macintosh, die unter der Webadresse http:/www.apple.com erhältlich ist.
> Die Software "Kensington Mouseworks" bewirkt, dass einige Tastaturbefehle nicht korrekt funktionieren. Falls Sie Probleme mit Tastenkombinationen haben, deaktivieren Sie Mouseworks.
> Wenn der virtuelle Speicher deaktiviert wurde, kann Fireworks von einigen internen Festplatten, die von Drittherstellern stammen, nicht gestartet werden. Falls Sie Probleme damit haben, Fireworks vom Laufwerk eines Drittherstellers zu starten, aktivieren Sie versuchsweise den virtuellen Speicher. Falls das Problem dann weiterhin besteht, installieren Sie Fireworks auf einem anderen Laufwerk oder erkundigen Sie sich beim Hersteller des Laufwerks nach einem aktualisierten Gerätetreiber.

Bekannte Probleme (nur Windows-Version)

> Wenn auf Ihrem Computer Dreamweaver 3 und Fireworks 3 installiert sind, funktioniert nach dem Deinstallieren von Fireworks 4 die Option "Starten und Bearbeiten" zwischen Dreamweaver 3 und Fireworks 3 nicht mehr korrekt. Um die Funktion wiederherzustellen, müssen Sie Fireworks 3 erneut installieren.
> Unter Windows 2000 und Windows NT müssen Sie als Administrator angemeldet sein, um Fireworks installieren zu können. Um Fireworks nach der Installation ausführen zu können, ist die Anmeldung als Administrator jedoch nicht erforderlich.

> Bedienfelder können unter Umständen durch Verschieben völlig vom Bildschirm verschwinden. Wählen Sie in diesem Fall "Befehle > Panel Layout Sets" und wählen Sie die Einstellung, die der Auflösung Ihres Monitors entspricht. Daraufhin werden die Bedienfelder wieder an ihrer Standardposition und mit ihrem Standard-Erscheinungsbild angezeigt.

Vorgehensweise bei der Fehlerbenachrichtigung
Haben Sie einen Programmfehler gefunden? In diesem Fall schicken Sie bitte eine E-Mail an das Fireworks-Team. Sie sollte die folgenden Informationen enthalten:

=======================
Ihr Name:
Ihre E-Mail-Adresse:
Ihre Telefonnummer:
=======================
Beschreibung des Fehlers
=======================
Zusammenfassung:
Zur Reproduktion benötigte Schritte:
1.
2.
3.
Erwartetes Ergebnis:

Tatsächliches Ergebnis:
=======================
Systemplattform:
=======================
Power Macintosh________
Windows 95/98________
Windows NT________
Windows 2000________
Windows ME________
=======================
Systeminformation:
=======================
Hardware:
Version des Betriebssystems:
RAM:
=======================

Geben Sie als Betreff Ihrer E-Mail bitte "Bug Report: [sehr kurze Problembeschreibung]" an, damit wir Fehlerbenachrichtigungen von Funktionsanfragen unterscheiden können. Beispiel: "Bug Report: Kein JPEG-Export möglich".