Creating rich interactive documents with Adobe® InDesign® CS5

The definition of a "document" has become less straightforward as more information destinations emerge. Documents today can incorporate blended experiences that combine the look and feel of a traditional print document with websites that include rich media. The means by which people access and consume that information—in print, on desktops, and on mobile devices—also continue to change. Keeping pace with these changes and trends, Adobe InDesign CS5 software offers a new feature set that allows rich interactive document content to be created and directly published as a desktop/browser experience apart from, or in addition to, a printed piece.

This white paper explores the expanded InDesign CS5 rich media and interactivity features; new, nontraditional publishing options for interactive documents created in InDesign; and the way that InDesign works with Adobe Flash® Professional CS5 software. You’ll learn how to create screen-based interactive documents and presentations and become familiar with the animation and interactivity toolsets in InDesign CS5. With these tools and techniques, you can expand your visual storytelling or maximize the impact of your sales message by offering readers content that keeps them engaged on a deeper level.

The following software is required for the tasks described in this paper:

- **InDesign CS5**—Previous versions of InDesign do not support the features described in this paper. Download a 30-day trial version at www.adobe.com/cfusion/tdrc/index.cfm?product=indesign&promoid=GXRKJ.

- **A modern web browser with the Adobe Flash Player 10.1 plug-in installed**—Safari 3.0 or Mozilla Firefox 2.0 on Mac OS X v10.4; Microsoft Internet Explorer 6.0, Firefox 2.0, Google Chrome 2.0, Safari 3.0, or Opera 9.5 on Microsoft® Windows® XP, Windows Vista®, or Windows 7.

- **Flash Player 10.1 software**—Required to view SWF content without a web browser. Flash Player 10.1 ships and installs with Flash Professional CS5.

- **Flash Professional CS5**—Required if you want to open and modify FLA files exported from InDesign, but not required for SWF-only export.

Why InDesign for interactive documents

Print continues to have a significant place in the information landscape, but it’s sharing that space with an ever-increasing number of platforms (the web, mobile phones, tablets, e-readers, and so on). As a result, creative professionals must adapt to a dramatic shift in the preferences and expectations of their audiences. Some stories are better told with video than with lengthy text explanations, and the fixed nature of a print page can limit the use of images to a mere few, while an interactive document can include a slide show in which many photos share the same space.

As the most robust professional document-creation tool on the market, InDesign CS5 is an ideal platform for creating rich interactive documents. These documents can be navigable, enhanced versions of existing collateral materials (catalogs, brochures, promotions, and so on), or they can be created from the outset as original interactive pieces that are never destined for print. Creating interactive documents, presentations, and prototypes in InDesign gives designers the control over format and typography they demand, in the application with which they’re most familiar, but with enhancements like slide shows, button navigation, video, live hyperlinks, and more.
InDesign CS5 interactive features overview

From an InDesign CS5 document, you can:

- Animate objects using built-in animation presets and your own customized settings
- Modify or create motion paths
- Trigger animations when a page is loaded, when the animated object is clicked or rolled over, or when a button is clicked
- Build slide shows or change a frame’s content using multistate objects
- Create buttons with normal, rollover, and click appearances
- Import and preview rich media files including FLV video and MP3 audio, among other formats
- Assign actions to buttons that provide document navigation; play/pause/stop an animation, sound, or video; launch an external web page in the user’s browser; and more
- Establish page transitions when the user proceeds from spread to spread
- Preview all interactivity and rich media before exporting or publishing
- Export directly to SWF for desktop viewing in Flash Player 10.1 or on the web using a browser with the Flash Player 10.1 plug-in
- Export in native FLA format to add more advanced functionality in Flash Professional CS5 (such as custom ActionScript® code, enhanced animation and transitions, links to dynamic data sources, and so on)

Creating web-intended documents

When starting a new interactive project, set your document’s intent to Web in the New Document dialog box. This changes the measurement system to pixels and the page orientation to landscape and creates a document with a Document RGB Transparency Blend Space and RGB default swatches. Any existing print layout can also have interactivity added and be exported to SWF or FLA. In that case, InDesign automatically converts colors to RGB during the export process.

The interactive workspace

InDesign CS5 installs with an existing workspace for interactivity that displays the relevant new panels—Animation, Timing, Preview, Media, and Object States—and already existing panels—Buttons, Hyperlinks, and Bookmarks—that will be most frequently used in an interactive project. Switch to this workspace from the
Control panel or by choosing Window > Workspace > [Interactive]. In this workspace, most of the design-related panels (type, effects, tables, styles, and so on) are closed, and an InDesign Object Library of sample buttons is opened and docked with the other panels.

The InDesign Interactive workspace

Project scenario: Interactive travel brochure

The design of an interactive document must include navigational controls that don’t exist in print layouts. These mechanisms should be consistent and unambiguous. When planning to use interactive features such as videos or looping animations, keep the user experience in mind to help you create a manageable document that’s both a satisfying user experience and can be produced and modified quickly and easily. In this paper, the travel brochure shown here is used as an example to illustrate the interactive features in InDesign CS5. You can view the finished interactive document at www.adobe.com/go/ridbrochure.

Getting started with an existing layout

This four-page layout is the starting-off point for a rich interactive document project. Ultimately, it will include document-wide page-to-page navigation, page transitions, animated text and objects moving into or appearing on each page, sound, video, and buttons to control all interactive features. The last page of the document is a duplicate of the first, but without any animation, so users don’t have to wait for the first page’s animation to replay each time they navigate back to the “home” page.
Button-based document navigation

Since there are no physical pages to turn in an interactive document, it’s up to you to provide the user with mechanisms for moving from page to page. Your project might have document-wide navigation that jumps from section to section and a secondary navigation scheme within each section to navigate its specific content. For each, you’d use buttons to allow the reader to navigate your document.

The Buttons panel

Button creation was made much simpler in InDesign CS4, and buttons are fully integrated into the expanded interactive features in InDesign CS5. In addition to enabling the user to navigate through a document with Previous Page/Next Page options, buttons also recognize all the states in a multistate object and all of the navigation points in a placed video file.

Every button is made up of several components: its appearance (based on user interaction), the event that triggers its functionality, and the action(s) carried out by the button itself. In a typical interaction with a button, users receive visual feedback (appearance) when they roll over it with the cursor, they click on it (event), and something happens (action).

Appearance. To create a button, simply select any existing object on the page, or create a new object, and then click the Convert Object To A Button icon in the bottom of the Buttons panel. The current appearance of the object is established as its “Normal” appearance—how it will look when not in use. Each button can have up to three states: Normal, Rollover (displayed when the user’s cursor hovers over it), and Click (displayed when the user clicks the button).

Event. Once a button’s appearance is established, you must define an Event—an action performed by the user—that “triggers” the button’s functionality. Such events include On Release (when the user clicks, and then releases, the mouse), On Click, and On Rollover. When the specified event occurs, the button carries out the action assigned to it.

Actions. Actions are specific functions like navigating to a page or playing a video. Each button can have several actions assigned to it.

Creating page-specific navigation buttons

In simple navigation schemes, you can successfully move the viewer through an entire document using only two buttons—one set to Go To Next Page and one set to Go To Previous Page. For more targeted navigation, you can create buttons that go to specific pages by using the Go To Page action and entering a specific page number. The travel brochure example shown here uses the latter, more targeted method, as each page within the document has additional navigable content.
Use object styles for button appearances
To speed up both the creation of your button appearances and any later changes you may want to make to them, define and apply Object Styles for the Normal, Click, and Rollover appearances. By using object styles, you can more quickly and consistently set up additional buttons throughout your document. Also, you can make document-wide changes to the appearance of all buttons simply by modifying the object style attributes. Without object styles, you would need to go into each occurrence of every button and make changes manually.

Setting button appearances and actions
This navigation button jumps to a specific page in this document using the Go To Page action (shown in the Buttons panel at right). The button is made up of a graphic frame containing the image and a text frame (left). The two frames were grouped and then converted to a button with a rollover appearance (center).

Animation and timing
One solution for unobtrusive, document-wide navigation is to create a "pop-up" navigation panel that appears on the page only when the user rolls the mouse over an icon or a specific area of the page. By grouping all the navigation buttons with another object, the entire group can be animated to appear when triggered, and all button functionality (including rollover behavior) is preserved. In the travel brochure, a semitransparent panel is moved off the right edge of the page with only a small "tab" visible. Hovering over that tab slides the entire panel into view—a behavior established in the Animation panel.

Place navigation elements on master pages
Many of the document efficiency principles you use for print documents can also benefit interactive documents. For a consistent navigation scheme that will appear on all pages, place your navigation on a master page, so that navigation changes need only be made in one place if changes occur in the document. Animation and interactivity on a master page appear and function on every document page that uses that master.

Anatomy of a slide-out navigation panel
On this document’s master page, four buttons (a home icon and three photo/text frame groups) are all grouped with a gray panel. Only the very left edge of the gray panel (with the arrow graphic) appears on the page at all times. The rest is revealed only when the user’s mouse rolls over that visible portion, at which point it moves left onto the page as far as the motion path extends. Note that buttons and animations have unique semitransparent icons on them, indicating that they’re interactive objects.
The Animation panel

Objects in InDesign are animated from the Animation panel using the same motion presets available in Flash Professional CS5. However, the animation process is not timeline based as it is in Flash, nor does the panel function like the one in Adobe Photoshop® software. Instead, animation in InDesign is object based. Animation settings are applied to an object (or a group containing several objects) using the various options and settings in the Animation panel.

Simulating multiple animations per object

A single object can have only one animation applied to it. But try this: You can animate a single object and then group it with an “invisible” object, such as an empty frame with no fill or stroke. The animation is preserved for the original object, but the group is considered a new and unique object, which you can also animate.

By repeating this grouping trick, you can apply multiple animations and control the order of their playback in the Timing panel. The result is a lot more like timeline-based animation.

Using and customizing animation presets

The Animation panel in InDesign CS5 has 47 preconfigured animation presets—from basics like Fade In or Zoom Out to more complex animations like Gallop, Swoosh, and Wave—that can be assigned to any selected object. These presets are the same as those used in Flash Professional CS5 and should be more than sufficient to handle the vast majority of your animation needs. When a preset is used as-is, a butterfly image at the top of the panel provides a preview of how an object animates using that preset.

The Animation Encyclopedia

InDesign CS5 installs with a script called AnimationEncyclopedia. When you run that script from the Scripts panel (Window > Utilities > Scripts), it creates a new document containing six pages of examples of InDesign animations and animation-triggering events. All examples can be viewed in the Preview panel. Re-create this document at any time by running the script again.
You can also modify existing presets—adjusting their duration, speed, and other properties—to meet your specific animation needs. Changing any of a preset’s attributes transforms the preset into a custom one (just as modifying the parameter of a print preset or new document preset does). You can save your customized setting as a new preset from the Animation panel menu. Once a preset is customized, however, the butterfly preview functionality is disabled. Note that any presets you create in InDesign can be also be shared with and used by Flash Professional CS5.

All animations are set by default to play “on page load,” meaning as soon as the page is displayed to the viewer. This can be changed so that the animation starts when the page is clicked, when the animated object is clicked, or when the user rolls the cursor over the object. An animation can also be set to start when a completely different object—a button—is clicked.

You can set an object to animate either to or from its current appearance. Animating to the current appearance means it will start at the opposite end of its motion path and finish where the object currently exists on the layout. Animating from the current appearance means it will start where it is in the layout and end at the opposite end of its motion path. To better visualize an animation’s start and end points, click the Show Animation Proxy button at the bottom of the Animation panel, which displays a ghosted version of the object’s position when the animation finishes.

Slide-out navigation panel settings
In the Animation panel (right), the Event that triggers the “pop-up” navigation panel’s move onto the page is On Roll Over (Self). The animation occurs only when the user hovers the cursor over the animated object. The Reverse On Roll Off option becomes active when this event is chosen. Selecting it will reverse the animation, effectively “sliding” the navigation panel back off the page when the user’s mouse moves off it. The object is set to animate “From Current Appearance,” meaning both its current position and visual appearance. The animation proxy provides a quick preview of the animation’s ending position.

Timing multiple animations
The Timing panel is where all animations on a spread are sequenced. Interactivity in InDesign is spread specific, so the Timing panel will display only the animations on the current spread. By default, animations play, one after another, in the order they were created on the spread (which displays top-to-bottom in the panel). That sequence can be changed by dragging an animation name up (to play earlier) or down (to play later).

To make some or all of your animations play simultaneously, select all animations in the list, Shift-select a continuous range of animations, or Command-click (Mac OS)/Ctrl-click (Windows) individual animations for a discontiguous selection. Then click the Play Together button at the bottom of the panel. The panel’s
appearance changes, displaying connecting lines next to any animations that will play together. When animations are linked to play together, you can establish a fixed number of repetitions for them or have them all play continuously in a loop.

Delaying animations
You can set a delay in the Timing panel’s Delay field for one or all animations, independent of the speed and duration specified in the Animations panel. If, for example, your animation is set to play when the page loads, but you want it to play two seconds after the page is loaded, set a two-second delay for all animations in the Timing panel.

Timing a sequence of animations
On the first page of this document, there are four animations. First, the background photo fades in via the “Cover Castle Photo” animation, which uses the Fade In preset. The “Discovering” animation plays at the same time—because the first two animations are linked via the Play All Together function—and moves the text frame with the word Discovering onto the page from a starting point on the pasteboard (indicated by the gray animation proxy box). This is done with a customized version of the Fly In From Left preset. Next, the word Ireland (converted to outlines and split into two parts so that some of it is beneath the word Discovering, and some is above it) appears using the Fade In preset. The two halves of the word are linked to play together so the whole word appears at once.

Multistate objects
One of the key new interactive features in InDesign CS5 is the multistate object—a new kind of object that can be made up of several different object types (graphic frames, text frames, shapes, and lines), each with different content and different appearances. When controlled by InDesign buttons, multistate objects enable interactive features as simple as image slide shows or as complex as interactive maps.
You set up and manage multistate objects from the Object States panel (Window > Interactive > Object States). There, you name both the multistate object and its individual states. When you start setting up buttons to control a multistate object, clearly named objects and states will help speed up that process.

The Object States panel (and its panel menu options) showing a graphic frame with three named states

To create a multistate object for something simple like an image slide show, select several graphic frames that contain images, align them so they exist in a stack, one on top of the other, and then click the Convert Selection To Multi-state Object button at the bottom of the Object States panel. The separate objects become a single object, each of them constituting one state of that object. Clicking any state name in the Object Styles panel makes that state’s content visible. While a state is active, it can be modified, reformatted, or have its content replaced.

Controlling multistate objects with buttons
Multistate objects are controlled by buttons. In a simple image slide show, one “previous” button with the Go To Previous State action assigned to it and one “next” button using Go To Next State can move the user through each state of the multistate object. By adding a second action to a button that controls another multistate object, you can control multiple multistate objects at the same time, allowing you to switch states for each with one button click.

To set a button to control a multistate object, choose one of the state-related actions (Go To State, Go To Next State, or Go To Previous State) from the Button panel’s Actions menu. This activates a menu in the panel, listing all multistate objects on the current spread, from which you can choose the multistate object you want to target. If you choose Go To State, a second menu appears, listing all the states in the targeted multistate object. From there, you can pick a specific state. To control more than one multistate object, add another state-related action to the button and repeat these steps.

Button options for controlling a single multistate object (left) and for controlling two multistate objects (right)

In this example interactive document, multistate objects are used to change the appearance of each of the three document pages following the cover without adding pages to the document, and buttons are used to navigate through the object states.
Using object states to change a page’s appearance

The page 2 layout (top) contains two multistate objects—the background photo and the body copy text frame. Each of these multistate objects has three states, allowing three different "views" to exist on one page of the InDesign document (bottom row). The two small buttons below the text frame control both multistate objects, changing the background photo and body copy simultaneously when clicked.

Adding and controlling audio and video

InDesign CS5 supports a number of media formats, including MP3 audio and FLV video. Media files can be placed in an InDesign document by choosing File > Place, just like text and graphics files. Although they don’t play on the InDesign page, these rich media files can be previewed, and their basic playback options established, in the new Preview panel.

Audio files appear in the document as a small frame with diagonal lines and an audio icon. The Preview panel limits control over the audio to Play On Page Load, Stop On Page Turn, and Loop, but additional control over placed audio files—including Play, Stop, Pause, Resume, and Stop All—is available when you use buttons to control audio.
In this layout, the audio file is placed on the pasteboard, rather than on the document page itself, to avoid cluttering the page with an element that doesn’t need to be seen. Despite this placement, the audio is still included in the SWF file when the interactive document is exported. In this layout, the audio is controlled entirely from the Preview panel and is set to both Play On Page Load and Loop.

Video placed in InDesign CS5 can be in any of the file formats supported by previous versions, plus FLV, F4V, SWF, and MP4. Using these formats lets you take full advantage of the rich media support offered in Adobe Acrobat® 9 Professional, Adobe Reader® 9, and Adobe Flash Player 10 software.

The Media panel
The Media panel (Window > Interactive > Media) allows you to preview any external rich media assets (video, audio, or SWF files) placed in your InDesign document without having to first export the file to SWF or FLA. It’s also where you define whether the media plays automatically (Play On Page Load), loops, or has a visible controller overlay. From the Media panel, you can add navigation points—time-coded points along the playback timeline—to a video. With navigation points established, you can then create buttons that “jump” to specific points in a video, just as a DVD menu jumps to individual scenes in a movie.
Poster strategies
By selecting an external, high-resolution file as a video’s poster, you get a better-looking placeholder for the video, plus the added benefit of using the same document for both print and interactive use.

By choosing None (and applying no fill or stroke to the frame), there will be no indication of the presence of your video on the page. This can be useful if you want your video to appear only if triggered by a button elsewhere on the spread but don’t want it to occupy page space unless it’s played.

The InDesign Media panel showing a video file with navigation points established and a Controller option selected

When placed, videos are given a default poster—an image that acts as a placeholder until the media file is played—from a frame within the first few seconds of the video. In the Preview panel, you can choose any other frame from the video as its poster by dragging the playback head along the timeline to the desired frame, or choose a static, high-resolution image to act as the poster. You can also opt to have no poster at all.

Controlling video files
You can establish whether or not a video plays when the page loads, loops, or has a controller. You can also set navigation points in the video that can be called upon by buttons you create to jump to specific places in the video timeline.

To set a button that controls a video’s playback, choose Video from the Actions menu in the Buttons panel and assign the appropriate playback function—Play, Stop, Pause, Resume, Stop All, or Play From Navigation Point—for the video. Crafting a customized video controller using buttons requires creating individual buttons for play, stop, pause, and resume. Making a menu-style controller that jumps the viewer to different navigation points in a movie requires creating a button for each navigation point. These options can help you produce a specific, customized video playback experience in the interactive document.

The default controller overlay options available from the Preview panel’s Controller menu—which are the same “skins” you see in Flash Professional CS5—do not have Navigation Point options, but they include functionality that’s not available with buttons you create yourself. These options include a full-screen view mode, volume control, and a scrubbable playback head. Controller overlays can also appear and disappear when the user’s mouse moves over or off the video, respectively.
Launching a "hidden" video

In the InDesign layout (top), a video is placed over the bridge photo with no poster and no fill or stroke on its frame. This makes the video invisible in the interactive document; it appears only when played. Since no one can see it, initially there is a simple button with "Cross the Bridge" and a filmstrip icon at the top left of the page. When the file is exported to SWF and plays in the browser (bottom), clicking that button plays the video, revealing it for the first time. When playback is complete, however, the video does not disappear—it's final frame remains on the page. It will return to its hidden state only when the user navigates away from, and then back to, this page.

Establishing page transitions

The transition from page to page in an interactive document is, by default, a "quick cut," where one page is instantly replaced with the next. You can, however, establish more visual transitions between pages such as Fade, Dissolve, Wipe, and a SWF-specific Interactive Page Curl that simulates the turn of a page as the user clicks and drags any corner of the page.

Unique page transitions can be assigned to each spread by choosing Page Transitions > Choose from the Pages panel menu or from the Page Transitions panel (Window > Interactive > Page Transitions). With either method, small proxy animations provide a preview of the transition, and several selections include options for the speed and direction of the transition. You can also assign the transition to all spreads, overriding any individual transitions previously set.
The InDesign CS5 Page Transitions dialog box including working proxy previews for each transition, which play when you mouse over them.

When you export your interactive document to SWF, you can either honor the settings in the document by choosing From Document from the Page Transitions menu or override the document’s transitions and assign a different transition altogether. If you haven’t set any transitions in the document, you can do so upon export without affecting the document itself. The transitions set at export are not saved with the document.

### Previewing your interactive document

All animation and interactivity created in InDesign can be previewed and tested directly in the application using the Preview panel (Window > Interactive > Preview). The Animation, Timing, and Buttons panels each have a preview button that brings the Preview panel to the foreground and runs the selected animation, timing sequence, or button behavior. The keyboard shortcut for opening the panel and playing a preview is Shift+Command+Return (Mac OS) or Shift+Ctrl+Enter (Windows). You can preview the entire document, the current spread, or any selected object(s).

The finished document playing in the Preview panel. In preview mode, you can navigate to specific pages using the forward and back arrows at the bottom of the panel, or you can click on any of the interactive elements in the preview window, all of which are fully functional.
InDesign builds a temporary SWF file to play in the Preview panel the same way the Test Movie feature does in Flash. This eliminates the need to first export a SWF file (along with an HTML file and any supporting assets) and then preview that SWF file in a browser, speeding up workflow and enabling immediate feedback about whether your animation looks the way you want or your interactivity functions as you intended.

Video and sound can also play in the Preview panel, but only if they’re set to play on page load, or if some other mechanism (such as a button or a controller) exists to trigger them from the Preview panel. Otherwise, those rich media files must be previewed in the Media panel.

### Publishing to SWF and FLA

Once an interactive InDesign document is designed and its functionality tested in the Preview panel, the next step is to either publish the project for a browser or Flash Player (SWF) or to export it as a Flash Professional CS5 (FLA) file for additional development. If the interactive document is 100% ready to publish, with no additional work required, export as SWF. If, however, there’s more advanced interactivity to be added that is beyond the capabilities of InDesign, then export to FLA. Such additional functionality might include linking the document to dynamic online content and adding complex ActionScript code.

Any interactivity that you create in InDesign will appear and work in the SWF file just as you saw it in the Preview panel. When exported to FLA, however, animation and timing need to be re-established using ActionScript. The table indicates which InDesign settings are preserved in the SWF and FLA workflows.

<table>
<thead>
<tr>
<th>Interactive Feature</th>
<th>SWF</th>
<th>FLA</th>
</tr>
</thead>
<tbody>
<tr>
<td>Animation, motion paths, and motion presets</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Timing panel settings</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Multistate objects</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Page transitions</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Interactive page curl</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Button appearances</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Button names</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Button actions</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>SWF</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>FLV video</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>MP3 audio</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>TLF text engine</td>
<td>✓</td>
<td>✓</td>
</tr>
</tbody>
</table>
Exporting for a browser or Flash Player (SWF)

To publish an interactive InDesign document for a browser or Flash Player, choose File > Export, and then choose Flash Player (SWF) from the Format pull-down menu.

The options in the Export SWF dialog box

The General options in the Export SWF dialog box allow you to export a page, a range of pages, the entire document, or just the current selection. InDesign will also generate the HTML for displaying the file in a browser. Selecting View SWF After Exporting launches your default browser once the export is complete and loads the HTML file. If the document includes video, sound files, or placed SWF files, all of the rich media assets will be gathered into a folder named <yourfilename>_Resources in the same directory as the exported SWF and HTML files.

SWF files can be exported at the same size as the document, set to fit to a standard display resolution like 800x600, or customized to output at a specific size. Note that InDesign exports SWF files with an embedded "no scale" value, so the resulting file will not scale up or down to adapt to the size of the browser window.

The Background Color option refers to the color that appears behind nonrectangular objects on the page, not to the background color in the HTML file generated by InDesign. Choosing Paper Color lets you add page transitions, whether or not you’ve set individual transitions on pages in the document itself. Any transition chosen from this dialog box is document-wide and overrides any settings established in the Page Transitions dialog box. You can also select the Interactive Page Curl feature, which creates an animated, draggable page-turning effect. This effect is applied in addition to your selection in the Page Transitions menu, so you can have a Fade transition whenever navigation buttons are clicked to move from page to page, as well as the page-turning effect if the user hovers the mouse over and clicks a page corner. The transition options are disabled if Transparent is chosen.

The options in the Advanced tab offer specific control over how text and images are converted. Here, you establish whether the layout’s text is converted to Flash Classic Text (meaning crisp vector text with little or no impact on file size), to outlines (also crisp and vector, but with more file overhead, as every letter is a separate vector shape), or to pixels (neither scalable nor crisp, and adding much more pixel-based information to the exported SWF file, significantly increasing its size).

In the Advanced tab, you also establish how InDesign converts and compresses images. As a rule, the higher the quality settings and resolution, the larger the resulting SWF file will be. For browser-based viewing, 72 dpi is a sufficient resolution. Since InDesign SWF files can’t scale up as the browser window size increases, there’s no benefit to going higher than 72 dpi.
Of the three compression options available, PNG compression makes files smaller with no quality loss, making it an ideal choice for SWF files containing many images and where quality is a primary concern. JPEG compression is "lossy" and will compress with some degree of quality loss, depending on your choice from the JPEG Quality menu. However, if image quality is less important than file size, you may want to experiment with the different quality settings for JPEG file conversion to see if you can get acceptable results at a smaller file size. The Automatic option leaves all conversion decisions up to InDesign. The application evaluates the images in the file and assigns a compression method accordingly.

Advanced SWF export options

Exporting to Flash Professional CSS (FLA)

Most of the options in the Export Flash CSS Professional (FLA) dialog box are the same as those in the Export SWF dialog box, but with some significant exceptions. When exporting to FLA, you can opt to rasterize your pages (converting all text and images to pixels), but doing so will severely limit the file's editability in Flash. You can also flatten any transparency in the InDesign document to reduce file size or improve compatibility with Flash, but this could limit your ability to manipulate those flattened objects when you open the file in Flash.

When the file is exported to FLA, all InDesign images and text are converted to movie clips and placed on the Flash stage. The Interactivity And Media options determine whether the actual media (video, audio, SWF) and interactivity (button behaviors, animations, and so on) in the InDesign document get built into the exported FLA file, or if only their appearance—a placeholder image with no rich media attributes—is passed on to Flash.
You might choose the Appearance Only option if you used InDesign to create a working mock-up to present to a client but wanted to pass the file along to a Flash developer as a template to follow, since most of the ActionScript coding required for that interactivity and media will have to be reestablished in Flash Professional CS5 using ActionScript and code snippets.

There’s an additional text export option set by default for FLA export: Flash TLF Text, the new text engine built into Flash Professional CS5. TLF supports advanced typographic composition features previously unavailable in Flash, such as superscript and subscript, ligatures, multicolumn text frames, and threaded text frames that reflow just like InDesign text frames. In Flash, columns can be controlled by ActionScript, allowing the user to change the text layout from one column to two or three columns, and the text will reflow accordingly. TLF also makes content resizing relative to stage width possible, allowing text to adapt dynamically if displayed on a mobile device. Text orientation can be changed to flow right to left or top to bottom—ideal for working with Asian languages.

Conclusion

With its robust new interactive toolset, InDesign CS5 expands the capabilities of designers beyond print to immersive, screen-based experiences with rich media, web banner ad creation, site prototyping, and more. Documents can be published directly for the browser and Flash Player or handed off to a Flash developer to add dynamic, web-based content. And it can all be done with the same precision, control, and confidence afforded by the application with which designers have the most experience and expertise—InDesign CS5.