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1. Deployment overview
This document describes the options for configuring and silently installing and unin-
stalling Adobe Creative Suite 3 edition and component volume licenses in an enterprise 
environment. Retail licensed software cannot be configured or installed silently. The 
workflow described in this document is identical on Mac OS X, Microsoft Windows 
XP, and Windows Vista 32-bit editions. 

Deployment and installation options are configured by modifying or creating XML 
files that control the setup process. Installation can then be run directly from a client 
computer, or from a network volume or server using scripted automation. Alternatively, 
a deployment tool, such as Microsoft Systems Management Server (SMS) on Windows 
or Apple Remote Desktop (ARD) on Mac OS, can be used. Both tools have been tested 
in deployment scenarios. 

The following Adobe Creative Suite 3 (CS3) editions and components are supported by  
this workflow: 

Adobe Creative Suite 3 Design Premium	 •	 Adobe Flash CS3 Professional

Adobe Creative Suite 3 Design Standard	 •	 Adobe Illustrator CS3

Adobe Creative Suite 3 Web Premium	 •	 Adobe InCopy CS3

Adobe Creative Suite 3 Web Standard	 • Adobe InDesign CS3

Adobe After Effects CS3	 •	 Adobe Photoshop CS3

Adobe Contribute CS3	 •	 Adobe Photoshop CS3 Extended

Adobe Dreamweaver CS3	 •	 Adobe Premiere Pro CS3

Adobe Fireworks CS3 	 •	 Adobe Soundbooth CS3

2. Configure enterprise deployment settings 
Most users install Adobe software from media, such as DVDs, directly onto their 
computers. This method works well for installing software on a handful of comput-
ers. However, in an enterprise scenario in which asset management is employed, and 
software must be installed and maintained on dozens or hundreds of computers, IT 
managers typically use enterprise deployment tools. This method involves obtaining 
a volume license and performing multiple installations over a network from a central 
location, using silent install. Silent installations run unattended and require no interac-
tion with the installer.
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A silent installation of Adobe Creative Suite 3 editions and components can be performed by 
simply sending a command from a command-line tool in Windows or Mac OS. However, many 
enterprises use more advanced content management tools, such as SMS and ARD. These content 
management tools provide more control over client computers and the installation process. For 
example, an installation can be scheduled to run automatically overnight.

Another way to control deployment is to use the following Adobe enterprise deployment options: 

1	 Preserialization: Add a volume serial number automatically during the installation process.  
By default, installation does not include preserialization.

2	 Suppress user interface (UI) settings: Disable one or more of the following items to prevent 
the user interface from displaying or running after installation: End-User License Agreement 
(EULA), registration, and automatic updates (Adobe Update Manager). By default, these items 
will run or appear.

3	 Edition selection: Configure deployment files to install only specific Adobe Creative Suite 3 
components. By default, the complete suite is installed. This option applies only to Adobe 
Creative Suite 3 editions.

4	 Silent install and uninstall: Configure the deployment files for silent install or uninstall.

After configuring deployment options, perform a silent install or uninstall using a command 
prompt (see section 3), or by using a content management tool, such as ARD (see section 4)  
or SMS (see section 5).

2.1. Preserialization and suppression settings 
Adobe Creative Suite 3 editions and components can be deployed with preserialization and  
suppressed UI settings by first creating an application override file (application.xml.override) 
that contains the appropriate XML script, and then placing the file in the driver payload folder.  
A driver payload folder contains a set of files used by the installation program for customizing  
an installation. 

Before creating the application override file, identify the driver payload folder by opening the 
Setup.xml file and locating the element that contains the folder name. 

❖ To identify a driver payload folder

1	 Open the installation folder to apply preserialization and suppression settings. An installa-
tion folder contains the setup programs (Setup.exe and Setup.app) and all of the other files for 
installing or uninstalling.

2	 Open the Payloads folder. 

3	 To identify which of the folders in the Payloads folder is the driver payload folder, open the 
Setup.xml file with a text editor, such as Notepad.

4	 Locate the following line:

<Driver folder=”driver payload folder”/>

Make a note of the driver payload folder name. 

❖ To create an application.xml.override file

1	  Open a text editor, such as Notepad.

2	  Copy and paste, or type the following XML script:

<?xml version=”1.0” encoding=”utf-8”?> 

<Configuration> 

<Payload>

   <Data key=”Serial” protected=”0”>10611049374654XXXXXXX</Data>

   <Data key=”Registration”>Suppress</Data>

   <Data key=”EULA”>Suppress</Data>

   <Data key=”Updates”>Suppress</Data> 
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</Payload> 

</Configuration> 

3	 Between <Payload> and </Payload>, choose any or all of the following data keys:

To add pre-serialization, include:

<Data key=”Serial” protected=”0”>Edition serial number(No  

Hyphens)</Data>

To suppress the UI registration prompts, include:

<Data key=”Registration”>Suppress</Data>

To suppress the UI EULA, include:

<Data key=”EULA”>Suppress</Data>

To suppress automatic updates, include:

<Data key=”Updates”>Suppress/Data>

Notes: 

•	�Automatic updates are typically suppressed for administrator testing. More information regard-
ing enterprise updates can be found at www.adobe.com/support. 

•	�When automatic updates are suppressed, the Updates command in the Help menu is disabled on 
client computers. 

•	Automatic updates cannot be suppressed for Acrobat 8.

4	 Choose File > Save, and navigate to the driver payload folder.

5	 In the File name text box, type application.xml.override.

6	 Click Save.

7	 In the driver payload folder window, verify that the file has the correct filename and extension. 

2.2. Choose the Adobe components to deploy (applies only to Adobe Creative Suite 3 editions)
By default, all Adobe Creative Suite 3 components are installed. However, by modifying the 
Deployment.xml and Uninstall.xml files, one or more components can be removed from the 
install and uninstall manifests. 

The file containing the install manifest, Deployment.xml, is located in the installation folder, 
which also contains the suite setup programs (Setup.exe and Setup.app). An annotated 
AdobeCode identifier is associated with each Adobe Creative Suite 3 edition and component. 
To prevent a component from being installed, delete the associated AdobeCode from the 
Deployment.xml file, and then save the file. Only Adobe Creative Suite 3 components listed in 
section 1 can be removed. Removal of other AdobeCodes will cause install errors. 

The manifest of the uninstall file, Uninstall.xml, which is located in the Adobe CS3 folder, must 
be identical to that of Deployment.xml. After modifying Deployment.xml, make the same 
changes in Uninstall.xml.

❖ To remove a component from Deployment.xml

1	  In the installation folder, open the Deployment.xml file with a text editor, such as Notepad.

2	  Locate and delete the Payload element containing the AdobeCode script of the component 
you want to remove. For example, to remove Adobe Illustrator CS3, delete the following script:

<Payload adobecode=”{4156A6D2-cF59-4F88-8488-ABD98E4XXXXX}”> 

<Action>install</Action></Payload><!--Adobe Illustrator cs3-->

3	 Choose File > Save.

❖ To remove a component from Uninstall.xml

1	  In the Adobe CS3 folder, open the Uninstall.xml file with a text editor, such as Notepad.

2	  Locate and delete the Payload element containing the AdobeCode script of the component 
you want to remove. For example, to remove Adobe Illustrator CS3, delete the following script:
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<Payload adobecode=”{4156A6D2-cF59-4F88-8488-ABD98E4XXXXX}”> 

<Action>remove</Action></Payload><!--Adobe Illustrator cs3-->

3	  Choose File > Save.

3. Perform a silent install or uninstall
This section describes how to perform a silent install or uninstall from the Command Prompt 
in Windows and the Terminal in Mac OS. The Adobe commands are identical in all operating 
systems.

If the Adobe CS3 folder contains both Deployment.xml and Uninstall.xml, a silent install or 
uninstall can be performed by running Setup.exe (Windows) or Setup.app (Mac OS) from a com-
mand prompt.

Mac:

<Path to setup.app>/Contents/MacOS/Setup --mode=silent --

deploymentFile=<Path to deployment.xml or uninstall.xml>

Win:

<Path to setup.exe> --mode=Silent -–deploymentFile =  

<Path _ to _ deployment.xml or uninstall.xml>

To specify whether setup installs or uninstalls the components, enter the path to either 
Deployment.xml or Uninstall.xml. The command can also be executed from both ARD  
and SMS. 

Before beginning, perform the following preinstallation tasks to ensure a successful deployment:

•	 Check system requirements: Adobe Setup checks system requirements to validate the client 
operating system, processor speed, system memory, and disk space. Make sure that all clients 
meet the system requirements to avoid a failed installation. See the Adobe Creative Suite sys-
tem requirements at www.adobe.com/products/creativesuite/systemreqs.html.

•	 Remove previously installed duplicate versions of Adobe Creative Suite 3 editions and compo-
nents. Alternatively, omit duplicate components from the deployment file (see section 2.2). If 
Acrobat 8 was installed as part of Adobe Creative Suite 2.3, use the Acrobat uninstaller. Trial 
versions of Adobe Creative Suite 3 components must also be removed. Restart client comput-
ers after uninstalling components.

•	 Close client applications: To avoid a failed installation, make sure that all web browser win-
dows and any Adobe, Microsoft, or instant-messaging applications are closed on all clients.

3.1 To perform a silent install or uninstall in Windows XP using the Command Prompt
1	  In Windows, choose Start > Run. Type cmd, and click OK.

2	 At the command prompt, type the following command:

<Path to setup.exe> --mode=Silent -–deploymentFile = <Path _ to _

deployment.xml or uninstall.xml>

Replace Path to installation folder with the correct path, and enter the path to either  
Deployment.xml or Uninstall.xml.

3	 Press Enter. 

Adobe setup begins. The command line displays the UI mode (Silent). 

3.2 To perform a silent install or uninstall in Mac OS X using the Terminal
1	 In the Finder, navigate to Applications/Utilities, and open a terminal window.

2	 At the command prompt, type the following command:

<Path to setup.app>/Contents/MacOS/Setup --mode=silent --

deploymentFile=<Path to deployment.xml or uninstall.xml>
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Replace Path to installation folder with the correct path, and enter the path to either  
Deployment.xml or Uninstall.xml.

3	 Press Enter. 

Adobe setup begins. The command line displays the UI mode (Silent). 

3.3. To validate a silent install or uninstall
Adobe Setup provides two ways to validate a deployment procedure: exit codes and log files.

When setup finishes, the command line displays End Adobe Setup, followed by an exit code.  
The following list describes the most common exit codes:

•	 Exit code: 0 No errors encountered

•	 Exit code: 1 Unable to parse command line

•	 Exit code: 2 Unknown UI mode specified

•	 Exit code: 6 Silent workflow completed with errors

•	 Exit code: 7 Unable to complete the silent workflow 

•	 Exit code: 8 Exit with restart needed

•	 Exit code: 9 Unsupported OS

•	 Exit code: 10 Unsupported file system

•	 Exit code: 11 Another instance of Setup is running

For a more complete picture, refer to the installation log files, which are created on each client 
computer during installation. These files can be helpful in troubleshooting any failure.

•	 In Windows, the log files are located in the [system drive]/Program Files/Common Files/ 
Adobe/Installers folder.

•	 In Mac OS X, the log files are located in the /Library/Logs/Adobe/Installers folder.

4. Install Adobe Creative Suite 3 editions and components with Apple 
Remote Desktop (ARD)
Before beginning, make sure that ARD is enabled on all client systems. Use the Upgrade Client 
software feature to upgrade all targeted clients. For scheduled deployments, clients must be 
logged on in order to receive the install or uninstall command. 

Also create or modify installation XML files as needed (see section 2), and note the path to the 
installation folder (Adobe CS3). 

After completing these tasks, follow the procedures in sections 4.1 and 4.2 to deploy with ARD. 
The following steps summarize the procedures:

1	 Use ARD to copy the install files to each client machine and access the installation files locally, 
or create a network volume. The installer may be run from a mounted network volume with 
these restrictions:

The permissions on the volume must allow a root process on the client to read.

The volume must be mounted using the Apple Filing Protocol (AFP). Server Message 
Block protocol (SMB) or Network File System protocol (NFS) will not work.

Alternatively, if the product installer is available as a disk image (DMG), the client can mount the 
disk image from any local or network source and run the installer from the mounted image. This 
is a more flexible solution, but requires an extra step of mounting the DMGs by using ARD.

If a product has multiple disk images, all disk images need to be mounted before running the 
install because silent mode cannot prompt for disk swaps. Please visit www.apple.com for more 
information.

2	 Send the install or uninstall command. Clients begin the setup process when the command  
is received.

•

•
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4.1. To copy the install files using ARD
Use the Copy Items task pane in ARD to copy all of the necessary install files from the source 
computer to the target client systems. 

1	 Open ARD.

2	 Select a Computer list and verify the target clients in the Detailed view. 

3	 Click Copy. The Copy Items task pane opens.

4	 In the Items To Copy list, navigate to and open the Adobe CS3 folder. 

5	 Click Save.

The install and deployment files in the Adobe CS3 folder are copied to the target clients.

4.2. To send the install or uninstall command
Installation is run on the target clients from the executable program that is located in the  
Setup.app application package.

1	 In ARD, click the UNIX icon.

2	 Enter the following UNIX command:

<Path to installation folder>/Setup.app/Contents/MacOS/Setup  

--mode=silent --deploymentFiles=<Path to deployment.xml or  

uninstall.xml>

Replace Path to installation folder with the correct path, and enter the path to either  
Deployment.xml or Uninstall.xml.

3	 In the Run Command As area, select User, and type root.

4	 To schedule the task to be completed at another time, click Schedule Task, and enter a time 
and date. Click OK.

5	 Click Send.

The dialog box closes and the command is sent immediately or at the time you scheduled in  
step 4. The Send UNIX Command dialog box opens and displays the status of the installation. 
When installation finishes, the End Adobe Setup message appears with an exit code.

5. Install Adobe Creative Suite 3 editions and components with Microsoft 
Systems Management Server (SMS)
Before beginning, ensure that administrative permissions are obtained on all the target client 
computers, and that SMS is properly configured. For more information, see Adobe Acrobat 8 for 
Microsoft Systems Management Server at partners.adobe.com/public/developer/en/acrobat/SMS.pdf 
and the SMS home page at www.microsoft.com/smserver.

After completing these tasks, follow the procedures in sections 5.1 through 5.1 to deploy with 
SMS. The following steps summarize the procedures: 

1	 Create a new SMS package. The package contains the deployment files and information.

2	 Configure a new distribution point (the point from which clients access the installation files).

3	 Create install and uninstall programs. SMS runs these programs on the client.

4	 Advertise the program to make clients aware of the deployment.

After SMS is configured, the Adobe Creative Suite 3 installation can be pushed to client comput-
ers without requiring user interaction.

5.1. To create a new SMS package 
The SMS package will contain the installation files, distribution point, programs used to install 
and uninstall the Adobe Creative Suite 3 editions and components, and instructions that SMS 
uses to advertise the installation.

1	 Open the SMS console.

2	 In the console tree, right-click Packages, click New, and then click Package.

partners.adobe.com/public/developer/en/acrobat/SMS.pdf


Enterprise Deployment Options �

3	 In the Package Properties dialog box, click the Data Source tab, and select This Package  
Contains Source Files.

4	 In the Source directory, click Set.

5	 In the Set Source Directory dialog box, in Source directory, enter the path to the installation 
folder, such as \\servername\sharename\path\Adobe CS3. Click OK.

6	 In the Package Properties dialog box, click the Data Access tab and make sure that Access 
Distribution Folder Through Common SMS Package Share is selected. Click OK.

5.2. To create a new distribution point 
SMS will copy the package to the new distribution point.

1	 In the SMS console, expand Packages in the console tree, and then expand the new Adobe 
package.

2	 Right-click Distribution Points, click New, and then click Distribution Points.

3	 In the New Distribution Points Wizard, assign the package to the desired distribution points.

4	 Click Finish.

5.3. To create install and uninstall programs 
Create install and uninstall programs that link to Deployment.xml and Uninstall.xml. For more 
information about enterprise deployment options, see section 2.

1	 In the SMS console, expand Packages, and then expand the new Adobe package.

2	 Right-click Programs, click New, and then click Program.

3	 On the General tab, in Command line, enter the following command:

setup.exe -mode=silent -deploymentFile=<deployment.xml or  

uninstall.xml> 

Replace Deployment.xml or Uninstall.xml with the correct path to either file.

4	 On the Environment tab, in Program can run, choose Only When No User Is Logged In from 
the menu. Click OK. The new program appears in the Details pane.

5	 Repeat steps 1-4 to add the second program.

5.4. To advertise the program 
This procedure steps through the Distribute Package Wizard, which provides a number of 
options for advertising a program to clients, including mandatory install, scheduling, and 
expiration. There are also advanced settings for distribution points that allow client-controlled 
installation. For more information about these options, see SMS Help. 

1	 In the SMS console, expand Packages. 

2	 Right-click the Adobe package, click All Tasks, and then click Distribute Software. The  
Distribute Package Wizard opens.

3	 On the Distribution Points page, verify the distribution point, and click Next.

4	 On the Advertise A Program page, make sure Yes is selected, and then click Next.

5	 On the Select A Program To Advertise page, make sure Install is selected, and then click Next.

6	 On the Advertisement Target page, click Browse.

7	 In Browse Collection, locate the client collection to advertise, for example, All Windows XP 
Systems, and click OK.

8	 Click Next.

9	 On the Advertisement Name page, type a name for the advertisement and any desired com-
ments.

10	 �Choose options on subsequent pages: Specify whether the advertisement should apply to sub-
collections, specify when the program will be advertised, and specify whether to assign the 
program. 



11	 On the last page of the wizard, click Finish.

When the package is advertised, a notification appears in the client’s Windows toolbar 
indicating that a program is about to run. If the installation was not mandatory, clients 
can choose to install the package on the Add New Programs tab of the Add Or Remove 
Programs dialog box.

 
6. References
The following links have been provided for further assistance. For additional  
assistance with enterprise deployments, please consider an Adobe Creative Suite 3  
Gold Support Plan.

•	 Adobe Creative Suite information 
www.adobe.com/creativesuite/

•	 Adobe Creative Suite system requirements 
www.adobe.com/products/creativesuite/systemreqs.html

•	 Additional documentation  
www.adobe.com/support
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