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Chapter 1: Getting Started Guide

About this document
This guide describes new features and enhancements in this release and 
helps you install and quickly set up and started with the latest version of 
Adobe® RoboHelp® 6. You can also find information about installing Adobe 
Acrobat® Elements 7 and Adobe RoboSource Control 3 simultaneously. 
Adobe Acrobat Elements 7 enables you to create PDF documents from 
your topics, using the improved PDF generation feature. Adobe 
RoboSource Control is a document- and version-control system you can 
use for your source files. You can use RoboSource Control to manage 
project versions in a multi-authoring environment. You can also use a 
third-party version control provider that supports the Microsoft® SCC API, 
such as Microsoft® Visual SourceSafe.
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What’s new
The latest version of Adobe RoboHelp includes new and powerful features 
for both technical writers and software developers. 

Conditional table of contents (TOC) You can apply Conditional Build 
tags to a book, or to a specific chapter in the TOC. You can do this by using 
the Format menu or the right-click menu for a TOC item. From the TOC 
view, you can also apply build tags on associated topics. After a tag is 
applied, the TOC appears hatched with the same color as the tag color. 
Additionally, you can apply more than one tag to the TOC. When you do 
this, the color of the hatch turns gray.

Conditional index You can apply Conditional Build tags to a keyword or 
sub-keyword in the index. You can do this by using the Format menu or the 
right-click menu in the index. After the tag is applied, the index appears 
hatched with the same color as that of the tag. You can also apply more 
than one tag to the index. When you do this, the color of the hatch turns 
gray.

The following lists the major improvements in the existing conditional 
build tag functionality:

• The visual indication of the application of build tags is displayed on the 
topics, topic content and topic lists to which it is applied.

• You can apply build tags on folders. After you apply a build tag on a 
folder, build tags are applied on all topics within the folder. The visual 
indication on the application of build tags is displayed on all the topics 
under the folder.

• You can apply build tags on rows and columns within a table. If you 
exclude this tag from the output, the corresponding row or column is 
excluded from the help output.

• You can drag and drop conditional tags on a topic or folder from the 
Conditional Build Tags folder in the Project view. You can also right-click 
a folder or topic, and apply build tags.

User-defined variables You can see User Defined Variable folder in 
project view. From User Defined Variable folder, you can create Variable 
and drag them to WYSIWYG in order to add them to the content. Once you 
drag them to WYSIWYG, you can enter a for the variable. 
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You can also create user-defined variables for text items by using the Insert 
menu. You can assign global values for the variables. 

You can also specify values for these variables for a selected single source 
layout. Values specified in this layout override the global value set earlier, 
and scope of this value is limited to this layout only.

The new Fields and Variables dialog box helps you manage fields and user 
defined variables and inserts the value of a selected field or variable in your 
topic.

Easier WinHelp migration WinHelp users can now move their projects to 
WebHelp and HTML Help to use other enhanced help formats. WinHelp 
users can note the following changes in WebHelp and HTML Help systems:

• You can now resize the Edit Map ID dialog box.

• You can sort on columns in the Edit Map ID dialog box and easily locate 
duplicate Map IDs.

• The enhanced import feature enables you to import the following 
components from MS Word documents, without loss of format: bulleted 
and numbered lists; styles used within table cells; TOC elements; headers 
and footers

Streamlined reports RoboHelp 6 comprises the following reports which 
streamline the process of obtaining data pertaining to Build Tags usage, 
user-defined variables usage and missing Topic references:

• Report on Build Tags: You can generate reports to track usage of Build 
Tags in your project. You can see their usage at Topic level, Content level, 
TOC level, and Index level.

• Report on User-defined variables: You can generate reports to track 
usage of user-defined variables, not fields, in your project. You can see 
the variables, the values assigned to the variables, and the topics where 
the variables are referenced.

• Report on Missing Topic References: You can generate a report to track 
missing references for topics within your project. It includes links to the 
topic from other topics, books and pages in the table of contents that 
use the topic, keywords, and keyword phrases in the index that use the 
topic.



4
Getting Started Guide

Command-line compilation You can generate help output from the 
command line without opening the RoboHelp application. You can 
generate a single source layout, perform batch generation, and publish to 
Adobe RoboHelp Server by running commands at the command prompt. 
This is particularly useful when you want to set your nightly builds and 
need batch processing of files. Go to Start > Programs > Adobe RoboHelp 
6.0 > RoboHelp HTML Command prompt to generate the output. 

Mark of the web RoboHelp 6 enables you to use the Mark of the Web in 
Single Source Layouts for WebHelp, WebHelp Pro, FlashHelp®, and 
FlashHelp Pro. As a result, the output in these layouts is not blocked in 
Internet Explorer® on Windows® XP SP2.

Seamless integration and collaboration with other 
tools
Using RoboHelp 6, you can now work with RoboScreen Capture and Adobe 
Captivate 2.

RoboScreenCapture and Image Editing RoboHelp 6 ships with a screen 
capture and image-editing tool. This tool is available in the Tools view. 

The following are the key features of RoboScreenCapture:

• Ability to capture the screen in 10 efficient modes, including Free Hand, 
Virtual Screen, and Multi-Region.

• Ability to save images in over 20 image formats.

• Ability to add identifying stamps to every screen capture, such as the 
company name or logo.

• Ability to easily edit images from RoboHelp for HTML. You can add image 
stamps, frames, drop shadows, change image colors, flip or rotate 
images, and crop images to a smaller size, and call-out specific areas of 
the capture with shapes, and shadow effects.

Adobe PDF generation RoboHelp 6 ships with Acrobat Elements 7 used 
to generate Adobe PDF files. This integration offers the following features:

• Single-click PDF generation

• Ability to retain hyperlinks

• Creation of accessible PDF files
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• Conversion of headings to bookmarks in PDF

• Ability to apply security to PDF files

• Installation of Adobe PDF printer, which empowers you to convert 
documents created using various applications, to PDF files

• Integration of the PDFMaker toolbar and icons in Microsoft Word, Excel, 
and PowerPoint applications

Retain hyperlinks RoboHelp 6 retains hyperlinks in printed documen-
tation.

Integration with Adobe Captivate 2 RoboHelp 6 allows you to use 
Adobe Captivate 2.0 from within RoboHelp HTML and RoboHelp for Word, 
if Captivate is installed on your computer.

Simplified multi-authoring and version control 
management
The task of managing version control using RoboSource Control and 
working in a multi – authoring environment is simplified in RoboHelp 6 
with the following new features and enhancements:

Improved RoboSource control
Significant improvements in the RoboSource Control mechanism include:

Speed and bandwidth efficiency RoboSource Control can now work 
flawlessly even over dial-up connections.

Enhanced performance, scalability, and ease of backup The SQL 
Server / MSDE database architecture has been implemented in 
RoboSource Control.

Simple integration with your current working practices New commu-
nications and extensibility options have been made available in this 
release of RoboSource Control.

Robust integration with MS Windows Explorer This feature eliminates 
the need to use the RoboSource Control Explorer interface to perform 
elementary tasks such as checking in and checking out documents.

Better offline support Improved offline and integrated working and 
optimized secure and transparent operation over the Internet
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Support for multiple languages Now Intelligent code parsers under-
stand many languages, enabling automatic documentation and more 
sophisticated merging of files containing differences

New multi-file History Explorer It provides greater flexibility when 
attempting to view or recover historical versions of files, folders, or entire 
projects.

Tip: For more information about using the features listed in this document, see 
the online Help in RoboHelp HTML (using the Help menu, select Contents and 
Index.)

Uninstalling RoboHelp Office X5
Before installing your new version of Adobe RoboHelp, uninstall earlier 
versions or evaluation versions of the program. 

Important: Running multiple versions of RoboHelp applications on the 
same computer is not recommended.

Use the following information to protect existing information you may 
have on your system.

Saving existing RoboHelp projects
Uninstalling RoboHelp will remove program files only Project files 
you created or modified in RoboHelp Office X5 will remain untouched on 
your computer. However, we recommend that you copy and move any 
projects you have saved in the RoboHelp folder, to another location on 
your hard drive before uninstalling RoboHelp Office X5.

Saving existing RoboHelp templates
If you modify existing RoboHelp templates, and want to preserve the 
styles, you must save a copy of the template in another location on your 
hard drive (such as the My Documents folder,) before uninstalling 
RoboHelp Office X5. 

The existing Robohelp.dot template is saved (copied and renamed as Copy 
of Robohelp.dot) during installation. (Locate the file where your other 
templates are stored by opening Microsoft Word, and selecting Tools > 
Options. Click File Locations. Under File types, refer to the folder listed for 
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User templates.) To use the styles from Copy of Robohelp.dot, merge the 
styles into the new RoboHelp.dot template using the Microsoft Word 
Organizer. For more information about merging styles, refer to the 
Microsoft Word Online Help.

Note: Earlier versions of Robohelp.dot cannot be used in RoboHelp 6. You can 
use the MS Word Organizer to copy styles to the newly installed RoboHelp.dot.

Moving customized lists
If you have customized a Phrase List, Stop List, “Always Ignore” Words List, 
or a .LNG file in a version of RoboHelp prior to version 9.1, then those lists 
will not be included in RoboHelp 6. This is because this release uses a 
different file structure and extensions to save those lists. However 
customized lists created in version RoboHelp X5 will work as it is.

If you want to move your customized list to lists in this version, you can 
open Notepad, view the changes, and type them in the RoboHelp user 
interface. Your original files are located at the root of your project folder 
with the extensions .PHR, .STP, .WLF, and .LNG. When you upgrade to this 
version, the files will remain in these folders.

The new files can be viewed in the Advanced Setting for Localization 
dialog box in RoboHelp. See RoboHelp Help for more information.

To uninstall RoboHelp Office X5
1 From the Start menu, select Settings > Control Panel.

2 Double-click Add/Remove Programs.

3 Click Change/Remove.

4 Click Yes to confirm that you want to remove the RoboHelp Office X5 
program.

The uninstall program removes RoboHelp Office X5. When the files are 
removed, the uninstall program indicates that the process is complete.

5 Click OK.

Note: You should not uninstall RoboSource Control version 1 at this stage. 
There is an option available where you can do migration of your data from 
RoboSource Control version 1 to RoboSource Control 3.
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System requirements
When you install RoboHelp 6, you can choose to install Adobe RoboHelp 
and/or Acrobat Elements 7, and/or RoboSource Control. Ensure that your 
system meets all the software and hardware requirements, before 
installing each program.

Software requirements
• Windows 2000 SP4 or later

• Internet Explorer 6.0 or later

• Microsoft Word XP SP2, Microsoft Word 2000, and Microsoft Word 20031

Hardware requirements
• Pentium III 300MHz or later

• 256 MB RAM

• 400 MB available disk space

Acrobat Elements If Acrobat Elements 7 or Acrobat Standard 7 or Profes-
sional 7 or Acrobat 7 3D is not available on your computer, Adobe 
RoboHelp installer gives you the option to install Acrobat Elements 7. You 
must install it to generate Adobe PDF output for your help systems.

RoboSource Control 3 While installing RoboHelp 6, you can choose to 
install RoboSource Control server, RoboSource Control Client, or both. If 
you have an earlier version of RoboSource Control, you must not uninstall 
it now. 

Installing Adobe RoboHelp 6
While installing RoboHelp 6, you can choose to install Adobe RoboHelp 6 
and/or Acrobat Elements 7, and/or RoboSource Control 3. The installation 
program prompts you to provide the RoboHelp product key. The product 
key is included in your CD holder.

1. Microsoft Word is required for the RoboHelp for Word component. Mi-
crosoft Word 2000 or later is required for the enhanced printed documenta-
tion feature in RoboHelp for HTML.
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Note: If you are already using another version control provider that supports 
the Microsoft SCC API, you need not install RoboSource Control 3. It is recom-
mended that you install the RoboSource Control 3 server on a dedicated server 
computer, which has network tape backup and will always be available to 
users. (You can install the RoboSource Control client on your computer 
regardless of where the server is located.) To install the RoboSource Control 
server on a dedicated server computer, give the installation CD to your systems 
or network administrator.

To install Adobe RoboHelp 6
1 Close all programs currently running on the system.

2 Insert the Adobe RoboHelp 6.0 CD into your CD-ROM drive. 

If Autorun is enabled on your system, the installation process starts 
automatically, and you can skip Steps 3 and 4.

3 From the Start menu, select Run.

4 At the command prompt, type D:\setup (substitute the appropriate 
letter of your CD-ROM drive for D).

5 If you are installing Adobe Acrobat Elements 7, an installation wizard 
appears. Follow the instructions on the screen to complete the installation.

6 If you are installing Adobe RoboSource Control 3, an installation wizard 
appears. You can choose the option to install the Client, Server, or both. 
Follow the instructions on the screen to complete the installation. You can 
then configure RoboSource Control and the Database.

7 Click Yes if you are prompted to restart your computer.

By default, the programs are installed in the following locations: 

• Adobe RoboHelp 6 C:\Program Files\Adobe\RoboHelp 6.0 (each 
authoring tool is installed in a folder under RoboHelp 6.0)

• Acrobat Elements 7 C:\Program Files\Adobe\Acrobat 7.0\Acrobat 
Elements

• RoboSource Control 3 C:\Program Files\Adobe\RoboSource Control 3
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Installing Adobe RoboSource Control 3

Migrating a database to Adobe RoboSource Control 3
If you have an earlier version of RoboSource Control, and you have 
installed RoboSource Control 3, then execute RoboSource Convert Wizard 
(C:\Program Files\Adobe\RoboSource Control 3\ RSO3ConvertWizard.exe) 
to migrate your data into the latest source control system. 

Configuring RoboSource Control
Execute RSO3ConvertWizard.EXE from C:\Program Files\ Adobe\ 
RoboSource Control 3. When the configurator is opened, a list of all 
existing RoboSource Control databases is displayed along with the 
following options:

• Create a database

• View Properties of a database connection string

• Delete a database from the list or permanently remove the database

Creating a database
Step 1 When you click Create, a new dialog box appears. The following 
four key pieces of information are required to create a RoboSource Control 
3 database:

• The name of the connection you are creating.

• The server name and instance name of the SQL Server or MSDE instance. 
Typically '(local)' OR '(local)\SQLExpress.'

• The name of the database. By default, this is the name given to the 
connection.

• and either: Verify the option to embed files within the database
OR: The local path(s) on the server, files, and file histories must be stored.

For RoboSource Control 3 users who do not have access to an instance of 
SQL Server, an MSDE database instance can be used, although it is highly 
recommended that files are not embedded within the database, due to the 
2GB file size restriction on an MSDE database instance. An installer for 



MSDE is available from http://msdn.microsoft.com/vstudio/express/sql/. 
However, an existing MSDE instance may be used by specifying its name in 
place of 'SQLExpress.”

Step 2 When you click Create in the second dialog box, another dialog 
box appears, allowing you to determine if the Database Server needs to be 
accessible.

You are prompted to select a local folder (on the Server) to hold the 
contents of the database. If this folder exists already, existing contents will 
be overwritten. RoboSource Control stores the source files, histories, and 
other data in this path. You must take a back-up of this path and its sub-
folders, on a regular basis.

You are also prompted to provide the Admin user name and password for 
the new database. The default login is 'Admin' with a blank password. This 
is the only user account created by default. The Admin / User Library can 
be used to set up and configure other users. If the Admin and blank 
password account are retained, all users will be able to log in with full 
security rights without being prompted.

Tip: You may place the Adobe RoboHelp folder on a local drive or a network 
drive. If you place the folder on a network drive, you must have write privileges. 
If you are not sure about any option, contact your system administrator for 
help with installing Adobe RoboHelp 6.

Troubleshooting
Occasionally, users encounter problems during installation. Here are some 
troubleshooting tips you can use to resolve problems. If you have further 
questions, please contact Adobe Technical Support (see “Contacting 
Adobe” at the end of this guide).

1 Ensure that there is enough free disk space on your hard drive to meet 
the system requirements listed at the beginning of this guide. (The setup 
process must notify you if there is not enough free disk space prior to 
installation.)

2 Before installation, close all running programs, including virus-checking 
programs. (Usually, virus-checking software has little or no impact on the 
installation process. However, if you are running such software and 



encounter difficulties with your Adobe RoboHelp installation, turning off 
the virus-checking programs and then re-installing RoboHelp, often 
resolves the problem.)

3 Delete any files in your temporary folder. (This folder is determined by 
the TEMP environment variable and is usually located in C:\TEMP or 
C:\WINDOWS\TEMP.)

4 Run a disk-scanning utility. Hard drive errors can cause problems with 
the installation process. (Some Microsoft Windows systems contain a 
utility called Scandisk. If you have questions about disk-scanning utilities, 
talk to your system administrator.)

5 Copy the Adobe RoboHelp setup CD to your hard drive, then run 
setup.exe from your hard drive.

6 If you are using Windows® 2000 or Windows® XP, ensure that you are 
logged in to your computer as the local administrator, or as a user in the 
local administrator group.

Opening and closing Adobe RoboHelp
After you install the program, Adobe RoboHelp 6 for Word and Adobe 
RoboHelp 6 HTML are displayed on your desktop. (If you choose to install 
RoboSource Control 3 from the installer, you will get RoboSource Control 3 
Explorer icon on the desktop as well.) You can choose the environment in 
which you want to work. Adobe RoboHelp 6 for Word uses Microsoft Word 
as the editor, and Adobe RoboHelp 6 HTML uses the HTML editor. 

To access Adobe RoboHelp Starter
❖ Click Start and select Programs > Adobe RoboHelp 6.0 > RoboHelp Starter.

You can use RoboHelp Starter to create a new project, open an existing 
project, import files or projects, or open productivity tools that ship with 
Adobe RoboHelp. You can use the Starter to open the RoboHelp HTML and 
RoboHelp for Word authoring tools shipped with Adobe RoboHelp.

To open a RoboHelp authoring tool
Click on RoboHelp HTML or RoboHelp for Word icon on the desktop.

OR



Open the RoboHelp Starter. In the toolbar, click Application. Select RoboHelp HTML 
or RoboHelp for Word.

OR

Click on Start – Run. Type robohtml to start RoboHelp HTML. Type robohelp to start 
RoboHelp for Word.

To close a RoboHelp authoring tool
Click X in the program window.

Opening and closing RoboSource Control 3
While you use RoboSource Control 3 from within RoboHelp HTML most of 
the time, you can access the standalone application, if desired.

To open RoboSource Control 3
In RoboHelp HTML, click .exe in the Version Control toolbar.

OR

In RoboHelp HTML, switch to the Tools view, and then double-click the RoboSource 
Control icon.

OR

From the File menu, select Version Control > RoboSource Control 3.

If a login dialog box appears, enter the relevant information. The 
RoboSource Control 3 application is opened. For more information, see the 
RoboSource Control 3 documentation.

To close RoboSource Control 3
Click X in the program window.

Note: For more information about setting up user accounts, refer to 
RoboSource Control 3 Help.



Activating Adobe RoboHelp 6
After installing Adobe RoboHelp 6, you must launch the application, and 
activate the product. If you do not activate the product within 30 days, the 
pre-activation period comes to an end, and you must activate your 
product key to continue using the software. You only need to activate 
RoboHelp once. 

Why is activation important?

Product activation validates that a particular product key has not been 
installed on more computers than is allowed by the end-user license 
agreement (EULA). Activation is simple and takes only a moment. 

How is activation different from registration?

Activation allows you to use RoboHelp fully and legally. During the 
activation process, you are not required to provide any personal infor-
mation – only a product key. 

You can register after the activation process. Registration allows you to 
create a relationship with Adobe and entitles you to receive special 
benefits including news, tips, and updates for your software. Registration 
is optional, but highly recommended.

When do you activate RoboHelp?

The Activation screen automatically appears the first time you open 
RoboHelp, and we recommend activating the product immediately. 
However, you have the option of skipping the activation process for 30 
days.

Note: You must activate RoboHelp within 30 days of downloading / installing 
the product. After 30 days, the Activate Later button is no longer available on 
the Activation Wizard, and you need to activate your product key to continue 
using the software.

Follow the steps listed in this section to activate your copy of RoboHelp (if 
needed, see the previous section for instructions on opening RoboHelp.)

To activate RoboHelp in the first 30 days
When you open RoboHelp, you are prompted to activate the application. Follow the 

instructions provided in the Activation Wizard. 
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While RoboHelp is open, select Help > Activate. Follow the instructions provided in the 
Activation Wizard.

To activate RoboHelp after 30 days
1 Start RoboHelp.

2 At the prompt, select Activate Now.

3 Follow the instructions provided in the Activation Wizard.

Deactivating Adobe RoboHelp 6
1 You can deactivate from product itself. Go to Help – Transfer Activation. 
Click on Transfer Button. Product will show that transfer activation is done 
successfully.

2 You can also deactivate while un-installation is going on. While you are 
un-installing RoboHelp 6, you will get a screen which says “Deactivate 
Adobe RoboHelp 6”. Click on button “Deactivate now” to deactivate 
product. It will deactivate product on current machine and then you can 
install and activate product on any other machine.

3 In Step 2, click on button “Skip Deactivation” to skip deactivation of the 
product at this point of time. 

Note: You do not need to deactivate or transfer activation if you are not 
planning to install RoboHelp 6 on separate machine.

Redistributables
Some of the tools in Adobe RoboHelp provide additional functionality for 
your Help systems through the use of Dynamic Link Libraries (DLLs) and 
ActiveX controls (OCXs). These DLLs must be distributed along with your 
Help system and installed on your end user computers. All redistributables 
are listed in the redistrb.txt file, located in the Redist folder of your Adobe 
RoboHelp 6 Program Files folder.



Contacting Adobe

Technical support
Adobe is committed to providing you with the best overall product 
experience. This includes intuitive technical products and flexible options 
to fit your support needs. 

• For current hours of operation and details about all support offerings, 
please visit the Adobe RoboHelp Web site: 
www.adobe.com/support/robohelp 

• For 24-hour support resources that include a knowledge base and 
forums, please visit the User to User forums: 
www.adobe.com/support/forums

• To contact Technical Support (Complementary/Paid) via E-mail, please 
go to the following link: 
www.adobe.com/support/programs/robohelp/index.html

Customer care
Adobe strives to continuously provide our customers with the best 
possible service. Our Customer Care Web site 
(www.adobe.com/support/programs/robohelp/index.html) offers a list of 
the most frequently asked questions and the ability to search our site. 
Results are provided in an easy-to-view format.

Address Adobe Systems 
Incorporated
345 Park Avenue
San Jose, CA 95110-2704
U.S.A

Telephone 1-408-536-6000
Fax 1-408-537-6000
World Wide Web www.adobe.com
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