Accessibility

Support Knowledgebase

Optimizing Performance (Illustrator 10 on Mac OS 9.x and earlier)

What's covered

Optimizing the Mac OS configuration

Optimizing your hardware configuration

Using Illustrator features effectively

Mac OS resources

The performance of Adobe Illustrator depends on several factors, including the options you select, your workflow, and the operating system and hardware configuration. The performance improvements listed below are most noticeable when you work with larger files. Optimizing the operating system and hardware configuration improves performance in other applications as well.

Before performing the steps below, make sure you have updated Illustrator to the most current version. Illustrator updates often include performance-related fixes or enhancements. Current version information and updates are available on the Adobe website at www.adobe.com .

Optimizing the Mac OS configuration

By configuring your system to run efficiently, you increase the amount of memory available to applications and ensure that they run smoothly. By increasing the amount of memory available to Illustrator, quitting applications you are not using, or disabling nonessential extensions or fonts, you can improve the performance of Illustrator.

Restarting the system to defragment memory

Starting and quitting applications repeatedly can fragment the system's memory. When memory is fragmented, or is unavailable in a single, contiguous block, applications may be unable to access all their available memory. This can decrease their performance or may prevent them from starting. Restarting your system defragments memory.

Allocating more memory to Illustrator

Illustrator uses random-access memory (RAM) to process file information. The more RAM allocated to Illustrator, the faster Illustrator can process file information. If other applications are open, less memory may be available to Illustrator. Quitting applications you are not using makes more memory available to Illustrator.

To allocate more RAM to Illustrator:

1. Quit Illustrator.

2. Start any applications you want to run simultaneously with Illustrator.

3. In the Finder, choose About This Computer from the Apple menu.

4. Note the Largest Unused Block value, which is the total amount of available memory.

5. In the Finder, select the Adobe Illustrator application icon, then choose File > Get Info.

6. In the Adobe Illustrator Info window, enter a value for Preferred Size that is less than 90% of the Largest Unused Block value you noted in step 4.

7. Close the Adobe Illustrator Info window.

Optimizing memory settings

When virtual memory is enabled, your system uses hard disk space to store information normally stored in memory (RAM). Because accessing information on a hard disk is slower than accessing it in memory, using virtual memory can decrease performance. In addition, the hard disk space used for virtual memory cannot be used for the Illustrator scratch disk, which Illustrator uses to store image information as you work. If you need more memory when working in Illustrator, Adobe recommends installing more RAM.

To optimize memory settings for Illustrator:

1. Choose Control Panels > Memory from the Apple menu.

2. In the Disk Cache section, select Default Setting.

3. In the RAM Disk section, select Off.

4. If you have more than one hard disk, select one in the Virtual Memory section, and use the default Virtual Memory setting.

5. Restart the Macintosh.

Fonts

Installing only the fonts you need improves system performance and the performance of application features that access fonts. Each installed font increases the amount of memory used by the system, which decreases the amount of RAM available to open applications, and increases the amount of time it takes applications to display font menus. Using a font management utility, such as Adobe Type Manager or Extensis Suitcase, can help you manage a large number of fonts.

Printer drivers

Because non-PostScript printer drivers can conflict with Illustrator, Adobe recommends that you set a PostScript printer driver as the default in Mac OS:

1. Open the Chooser and select a PostScript printer driver (for example, AdobePS, LaserWriter 8). If a PostScript printer driver isn't installed, install Adobe PS 8.7.2 from the Illustrator 10 CD.

3. Close the Chooser.

System extensions

System extensions and control panels use memory that could be made available to other applications, including Illustrator. If your Macintosh has a limited amount of memory, use the Apple Extensions Manager to disable nonessential extensions and control panels. Disabling nonessential extensions can also prevent extension conflicts. For more information about disabling extensions, see document 311687 , "Disabling Extensions and Isolating Extension Conflicts in Mac OS 9.x and 8.x."

Optimizing your hardware configuration

The hardware you use affects the performance of Illustrator: The faster the processor or hard drive, the faster Illustrator can process information. Other hardware enhancements, such as installing additional RAM, using a multiprocessor system, or optimizing and defragmenting drives, can also improve performance.

Processor speed

The speed at which Illustrator performs is limited by the speed of the computer processor: The faster the processor, the faster Illustrator performs.

Installed RAM

If Illustrator has insufficient memory (RAM), it uses hard disk space (that is, a scratch disk) to process information. Illustrator is fastest when it can process file information in memory, without having to use the scratch disk.

Hard disks

As you add, delete, and move files on a hard disk, its available space is no longer a single, contiguous block. If the system does not have enough contiguous space, it saves fragments of a file to different locations on the hard disk. It takes an application longer to read a fragmented file than one saved to a contiguous location. You can defragment files and optimize available hard disk space by using a disk utility such as Speed Disk included with Symantec Norton Disk Utilities for Macintosh.

Since Illustrator reads and writes information while working on a file, the faster the access speed of the disk containing the file or the Illustrator scratch disk, the faster Illustrator can process file information. To improve the performance of Illustrator, work on files saved on drives with fast access speeds, such as an internal hard drive, rather than those with slow access speeds, such as a network server (a network drive) or removable media (for example, Zip or Jaz drive, or floppy disk). Removable media often have slower access times and are more easily damaged than internal hard drives.

When you want to save an Illustrator file to a network or removable drive, Adobe recommends you first save the file to an internal hard disk, then close the file and use the Finder to copy the closed file to the external or network drive.

Using Illustrator features effectively

The way you work in Illustrator, and especially the way you view artwork, can effect the performance of Illustrator. Modifying the Illustrator view options, linking images rather than embedding them, and optimizing scratch disk and startup options can all affect the speed and memory usage of Illustrator.

Outline view

Outline view hides paint attributes, displaying the artwork as unfilled paths. Working in Outline view can speed the display of complex artwork, such as objects containing gradients or patterns. Outline view can also make it easier to edit objects hidden behind other filled objects. Choose View > Outline to display a document in outline mode.

For more information on viewing artwork in Illustrator, see Illustrator Help.

Custom views

You can create custom views of your document, allowing you to quickly change the view mode, magnification, scroll position, and layer options by choosing a custom view from the View menu. To create a custom view, set the view attributes you want to save, then choose View > New View and enter a name in the New View dialog box. The custom view will appear in the View menu.

Raster effect resolution

You can change the resolution of raster effects to optimize the performance of Illustrator. To change the resolution of raster effects, choose Effect > Document Raster Effects Settings, do one of the following, and then click OK:

-- If you are editing files, click Screen. Illustrator uses a resolution of 72 ppi for raster effects, increasing display speed.

-- If you are printing files, click High. Illustrator uses a resolution of 300 ppi for raster effects, decreasing printing speed, but increasing print quality.

Layers palette

The Layers palette lets you easily organize and modify artwork. When you hide layers that contain complex artwork or high resolution bitmap images, Illustrator redraws the screen faster. To hide a layer, click the eye icon to the left of the layer's name, or choose Options from the Layers palette menu, deselect Show Layer, and then click OK . To hide all but the selected layer, Option-click the eye icon, or choose Hide Others from the Layers palette menu.

Note: The Layers palette can display thumbnails for top-level layers, nested layers, groups, and objects. You can reduce the number of thumbnails so that Illustrator redraws the screen faster:

1. Choose Palette Options from the Layers palette menu.

2. Reduce the number of thumbnails:

-- To remove all thumbnails from the Layers palette, select Small in the Row Size section, and then click OK.

-- To remove thumbnails for specific elements in the Layers palette, deselect Layers, Groups, or Objects in the Thumbnails section, and then click OK.

Scratch disk

When you are working with an embedded bitmap image and your system does not have enough RAM to perform an operation, Illustrator uses hard disk space as a scratch disk. Because it takes longer to access information on a hard disk than it does to access information in memory, using a portion of the hard disk as virtual memory can decrease performance. If you need more memory to work in Illustrator, Adobe Systems recommends installing more RAM.

By default, Illustrator uses the system drive as its primary scratch disk. You should change the Illustrator primary scratch disk setting to your fastest hard drive.

To change the scratch disk preference in Illustrator:

1. Choose Edit > Preferences > Plug-ins & Scratch Disk.

2. Choose a hard disk from the Primary pop-up menu. If you will be working with large images and have more than one hard disk, choose another disk from the Secondary pop-up menu.

3. Click OK and restart Illustrator.

Note: Adobe recommends that you use a disk utility such as Norton Utilities or TechTool Pro to optimize and defragment your hard disk on a regular basis. For more information, see your Mac OS documentation.

Adobe Illustrator startup files

Adobe Illustrator startup files contain the default patterns, gradients, graph designs, colors, and color libraries that will appear in new Illustrator documents. These files also determine zoom level, window size, viewing preferences, and scroll position for new documents. You can minimize the file size of new documents by removing unnecessary swatches and brushes from Adobe Illustrator startup files.

For instructions on creating custom startup files, see Illustrator Help.

Linked files

Embedded bitmap images (such as TIFF, BMP, or Photoshop EPS) can dramatically increase the size of an Illustrator document, causing slower performance. To improve performance, select Link in the Place dialog box when you place a bitmap image. The Link option creates a reference to the placed image on your hard disk.

If you use any of the Illustrator filters on a linked bitmap image, Illustrator must embed the image. Selecting Include Placed Images in the Illustrator Save As dialog box will also embed the image file. If you must include the image in the Illustrator document for transfer to a service bureau, replace the image without the Link option or save a copy of the file with Include Placed Images selected as a last step before final output.

EPS previews

If a document contains linked EPS images with high-resolution previews, Illustrator may redraw the screen slowly as you edit artwork. To enable Illustrator to redraw the screen more quickly, use low-resolution EPS previews: Choose Edit > Preferences > Files & Clipboard, select Use Low Resolution Proxy for Linked EPS, and then click OK.

Show Transparency Interactions option

In Illustrator 10, the Links Palette Options dialog box includes a Show Transparency Interactions option. When this option is selected, the Links palette displays a yellow icon to identify linked EPS graphics that are transparent or overlap transparent objects. Because this option forces Illustrator to regularly determine if linked EPS files interact with transparency, it can reduce performance.

To disable the Show Transparency Interactions option:

1. Choose Palette Options from the Links palette menu.

2. Deselect Show Transparency Interactions, and then click OK.

Navigator palette

In Illustrator, the Navigator palette displays a thumbnail view of your current artwork for easy navigation. Depending on the complexity of your artwork, a substantial amount of processing time may be required to update the thumbnail each time you make a change. To improve screen redraw speed and performance in a complex Illustrator document, hide the Navigator palette by choosing Window > Hide Navigator.

You can set up custom views to more efficiently zoom to particular areas of your document. See the "Custom Views" section above for more information.

Anti-Alias Artwork option

The Anti-Alias Artwork option smoothes text and graphics by blending the color of an object's edge pixels with that of adjacent pixels. However, this process can cause slow screen redraw. To disable this option, choose Edit > Preferences > General, deselect Anti-aliased Artwork, and then click OK.

Simplify command

The Simplify command reduces the amount of anchor points in paths and path shapes, reducing file size and increasing performance. To apply the Simplify command, select the desired path or object, and then choose Object > Path > Simplify.

Smart Guides

Smart Guides allow you to create, align, edit, and transform Illustrator objects relative to other objects. If there are a large number of objects in your artwork, Illustrator will require more time to display Smart Guides. To disable Smart Guides, choose View > Smart Guides. A check mark appears next to the command when Smart Guides are enabled.

For more information on Smart Guides, see Illustrator Help.

Mac OS resources

These websites provide troubleshooting tips and further information about Mac OS:

Apple Support: www.apple.com/support

MacCentral Online: www.maccentral.com

MacFixIt: www.macfixit.com

MacDirectory: www.macdirectory.com

VersionTracker: www.versiontracker.com


Related Documents

311742: Creating efficient files and improving print performance (Illustrator 10 and CS)

317280: Optimize performance in Photoshop (Mac OS)

Document 320771
Last edited - 01/25/2005

 

Got Some Time to Take a Survey?

Tell us what you think about this support site.