Accessibility

Support Knowledgebase

Optimize performance in Illustrator (CS-CS2 on Windows)

What's covered

Optimizing Windows

Optimizing your hardware configuration

Using Illustrator features effectively

Windows resources

The performance of Adobe Illustrator depends on several factors, including the options you select, your workflow, and the operating system and hardware configuration. The performance improvements listed below are most noticeable when you work with larger files. Optimizing the operating system and hardware configuration improves performance in other applications as well.

Before you perform the steps below, make sure to install the latest version of Illustrator or any Illustrator updates to the version you are using. Illustrator updates often include performance-related fixes or enhancements. Current version information and updates are available on the Adobe website at www.adobe.com .

Note: The Windows XP procedures in this document are based on the default interface of Windows XP. If the interface is customized, some procedures may vary. For example, a commonly encountered difference is the navigation to Control Panel from the Start menu: You may navigate Start > Settings > Control Panel instead of Start > Control Panel.

Optimizing Windows

By configuring your system to run efficiently, you increase the amount of memory available to applications and ensure that they run smoothly. Increase the amount of memory available to Illustrator, quit applications you are not using, or disable nonessential startup applications or fonts to improve the performance of Illustrator.

Virtual memory

Virtual memory allows the system to use hard disk space to store information normally stored in RAM. Because it takes longer to access information on a hard disk than it does to access information in memory, using a portion of the hard disk as virtual memory can decrease performance.

Windows XP and 2000 manage virtual memory using a paging file; you define the minimum and maximum size of this file. Illustrator performs best when the paging file's maximum size is at least twice the amount of installed RAM.

To create a paging file with a maximum size of twice your amount of installed RAM:

Note: You need Administrator rights to change the size of your computer's paging file.

1. Quit all applications.

2. Choose Start > Control Panel (Windows XP), or choose Start > Settings > Control Panel (Windows 2000), and then double-click System.

3. Access the Performance Options dialog box:

-- In Windows XP, click the Advanced tab, click Settings in the Performance section, and then click the Advanced tab.

-- In Windows 2000, click the Advanced tab, and then click Performance Options.

4. In the Virtual Memory section, click Change.

5. From the Drive list, select a hard drive that has at least twice the amount of your computer's installed RAM. For example, if your computer has 64 MB of RAM, select a hard drive that has at least 128 MB of free space. For best performance, choose a hard drive not used for the Illustrator scratch disk.

Note: To determine the amount of space available on a drive, click the drive letter; the amount of space available appears in the Paging File Size for Selected Drive section.

6. In the Initial Size box in the Paging File Size for Selected Drive section, enter a value equal to the amount of your computer's installed RAM plus 12 MB.

7. In the Maximum Size box, enter a value equal to twice the amount of your computer's installed RAM.

8. Close the System Properties dialog box:

-- In Windows XP:

a. Click Set, and then click OK.

b. Click OK in the Performance Options dialog box

c. Click OK in the System Properties dialog box.

-- In Windows 2000:

a. Click Set, and then click OK.

b. Click OK in the System Control Panel Applet dialog box.

c. Click OK in the Performance Options dialog box, and then click OK.

9. Click Yes in the System Settings Change dialog box to restart Windows.

Printer drivers

Because non PostScript printer drivers can conflict with Illustrator, Adobe recommends that you set a PostScript printer driver as the default printer in Windows.

To determine if a printer is using a PostScript driver:

1. Choose Start > Printers and Faxes (Windows XP), or Start > Settings > Printers (Windows 2000).

2. Right-click the printer icon and choose Properties from the pop-up menu.

3. Click the Device Settings tab.

4. Right-click the printer at the top of the list, and choose About from the pop-up menu:

-- If "PostScript" appears in the About dialog box (for example, "Adobe PostScript Printer Driver"), the printer uses a PostScript driver.

-- If a PostScript printer driver isn't installed, use the Add Printer Wizard to install a PostScript printer. See the Windows documentation for more information about installing a PostScript printer.

To set a default printer driver in Windows:

1. Choose Start > Printers and Faxes (Windows XP) or Start > Settings > Printers (Windows 2000).

2. Right-click the desired printer and choose Set as Default from the pop-up menu.

Note: Do not specify a nonprinting output device, such as a fax or modem.

After you complete the steps above, you may wish to configure Illustrator to print to a nondefault printer.

To configure Illustrator to print to a nondefault printer:

1. In Illustrator, choose File > Print.

2. Choose the printer from the Printer menu.

3. Click Done to close the Print dialog box, or Print to print the file.

Display drivers

Some display drivers offer advanced settings for accelerating or modifying graphics display. Sometimes these settings can adversely affect screen redraw performance in Illustrator. Try disabling driver-specific features to determine the best settings for use with Illustrator. For more information, see the documentation for your display card.

Fonts

If you install only the fonts you need, then you will improve system performance and the performance of applications that access fonts. Each installed font increases the amount of RAM used by the system, which decreases the amount of RAM available to open applications, and increases the amount of time applications take to display font menus. Use a font management utility (for example, Adobe Type Manager) to help you manage many fonts.

Startup applications

Applications that start automatically with Windows compete with Illustrator for available RAM. You can prevent programs from starting automatically with Windows by doing the following:

To remove programs from the StartUp folder:

1. Quit all applications.

2. Start Windows Explorer.

3. Disable startup applications that are specific to the current user:

-- In Windows 2000 and XP, move all icons and shortcuts from the Documents and Settings\ [current user] \Start Menu\Programs\Startup folder to another folder.

4. Disable startup applications that are common to all users:

-- In Windows 2000 and XP, move all icons and shortcuts from the Documents and Settings\All Users\Start Menu\Programs\Startup folder to another folder:

5. Restart Windows:

-- If the performance of Illustrator does not improve, move the icons and shortcuts back.

-- If the performance of Illustrator improves, isolate the performance problem to one or more programs by moving one back and restarting Windows. Repeat this process until the performance of Illustrator degrades. When you have isolated the icon or shortcut that is causing the performance problem, remove it again and contact the program's manufacturer to see if an update is available.

To close applications that are specified to start automatically in the registry:

1. Restart Windows.

2. Press Ctrl+Shift+Esc.

3. Click the Applications tab.

4. Select an application name, and then click End Task.

5. Restart Illustrator. If performance for Illustrator improves, contact the application's manufacturer for help in permanently disabling it from starting automatically. Repeat steps 2-5 for each remaining startup application.

Optimizing your hardware configuration

The hardware you use affects the performance of Illustrator: the faster the processor or hard drive, the faster Illustrator can process information. Other hardware enhancements, such as installing additional RAM, using a multiprocessor system, or optimizing and defragmenting drives, can also improve performance.

Processor speed

The speed of Illustrator is limited by the speed of your computer's Central Processing Unit (CPU). Since Illustrator manipulates large quantities of data and performs many calculations, its speed is greatly dependent on the processor's speed. Using a computer with a faster processor will increase Illustrator's speed.

Installed RAM

If Illustrator has insufficient RAM, it uses hard disk space (that is, virtual memory, scratch disk, or both) to process information. Illustrator is fastest when it can process information in memory, without having to use a hard disk.

Hard disks

As you add, delete, and move files on a hard disk, available space is no longer a single, contiguous block. If the system does not have enough contiguous space, it saves fragments of a file to different locations on the hard disk. An application requires more time to read a fragmented file than one saved to a contiguous location. You can defragment files and optimize available hard disk space by using ScanDisk and Disk Defragmenter. For more information on Scandisk and Disk Defragmenter, see your Windows documentation.

Since Illustrator reads and writes information while working on a file, the faster the access speed of the disk containing the file or the Illustrator scratch disk, the faster Illustrator can process file information. To improve the performance of Illustrator, work on files saved on drives with fast access speeds, such as an internal hard drive, rather than those with slow access speeds, such as a network server (a network drive) or removable media (for example, Zip drive, or floppy disk). Removable media often have slower access times and are more easily damaged than internal hard drives.

When you want to save an Illustrator file to a network or removable drive, Adobe recommends you first save the file to an internal hard disk, and then close the file and use Windows Explorer to copy the closed file to the external or network drive, or save the file to the network using Adobe Version Cue.

Printer language

For best results when printing from Illustrator, use a PostScript printer. Most non PostScript printers rely on display information, host computer resources, and proprietary printer drivers to relay print information to the printer, so they may take much longer to print than a PostScript printer.

Using Illustrator features effectively

The way you work in Illustrator, and especially the way you view artwork, can effect the performance of Illustrator. Modifying view options, linking images rather than embedding them, and optimizing scratch disk and startup options can all affect the speed of Illustrator and its memory usage.

Outline View

Outline view hides paint attributes, displaying the artwork as unfilled paths. Working in Outline view can speed the display of complex artwork, such as objects containing gradients or patterns. Outline view can also make it easier to edit objects hidden behind other filled objects. In Illustrator, choose View > Outline to display a document in outline mode.

For more information on viewing artwork in Illustrator, see Illustrator Help.

Custom Views

You can create custom views of your document, allowing you to quickly change the view mode, magnification, scroll position, and layer options by choosing a custom view from the View menu. To create a custom view, set the view attributes you want to save, and then choose View > New View and type a name in the New View dialog box. The custom view appears in the View menu.

Display performance

You can specify the quality and speed of the display when you use the Hand tool to move the artboard. To specify the display quality, choose Edit > Preferences > Units & Display Performance. Drag the Hand Tool slider to the left to improve the display quality when you use the Hand tool, or move it to the right to improve speed.

Raster effect resolution

You can change the resolution of raster effects to optimize the performance of Illustrator. To change the resolution of raster effects, choose Effect > Document Raster Effects Settings, do one of the following, and then click OK:

-- If you are editing files, click Screen. Illustrator uses a resolution of 72 ppi for raster effects, increasing display speed.

-- If you are printing files, click High. Illustrator uses a resolution of 300 ppi for raster effects, decreasing printing speed, but increasing print quality.

Layers palette

The Layers palette lets you easily organize and modify artwork. When you hide layers that contain complex artwork or high resolution bitmap images, Illustrator redraws the screen faster. To hide a layer, click the eye icon to the left of the layer name, deselect Show Layer, and then click OK. To hide all but the selected layer, Alt-click the eye icon.

Note: The Layers palette can display thumbnails for top-level layers, nested layers, groups, and objects. You can reduce the number of thumbnails so Illustrator redraws the screen faster:

1. Choose Palette Options from the Layers palette menu.

2. Reduce the number of thumbnails:

-- To remove all thumbnails from the Layers palette, select Small in the Row Size section, and then click OK.

-- To remove thumbnails for specific elements in the Layers palette, deselect Layers, Groups, or Objects in the Thumbnails section, and then click OK.

Scratch disk

When you work with an embedded bitmap image and your system does not have enough RAM to perform an operation, Illustrator uses hard disk space as a scratch disk. Because it takes longer to access information on a hard disk than it does to access information in memory, using a portion of the hard disk as virtual memory can decrease performance. If you need more memory to work in Illustrator, Adobe Systems recommends installing more RAM.

By default, Illustrator uses the system drive as its primary scratch disk. You should change the Illustrator primary scratch disk setting to your fastest hard drive.

To change the scratch disk preference:

1. Choose Edit > Preferences > Plug-ins & Scratch Disk.

2. Choose a hard disk from the Primary pop-up menu. If you work with large images and have more than one hard disk, choose another disk from the Secondary pop-up menu.

3. Click OK and restart Illustrator.

Note: Adobe recommends that you use a disk utility, such as Disk Defragmenter, to optimize and defragment your hard disk on a regular basis. For more information, see your Windows documentation.

Illustrator startup files

Illustrator startup files contain the default patterns, gradients, graph designs, colors, and color libraries that appear in new Illustrator documents. These files also determine zoom level, window size, viewing preferences, and scroll position for new documents. You can minimize the file size of new documents by removing unnecessary swatches and brushes from Illustrator startup files.

For instructions on creating custom startup files, see Illustrator Help.

Templates

Templates let you create new documents that share common settings and design elements. For example, to design a series of business cards with a similar look and feel, create a template with the desired artboard size, view settings (such as guides), and print options. You can minimize the file size of new documents by removing unnecessary swatches, symbols, graphic styles, and brushes from templates.

Templates offer a powerful alternative to creating custom startup files. While you can create only two custom startup files (one for CMYK mode and one for RGB mode), you can create an unlimited number of templates. In addition, you can store and access templates anywhere, as opposed to startup files, which must have a specific name and location.

For instructions on creating template files, see Illustrator Help.

Linked files

Embedded bitmap images (for example, TIFF, BMP, or Photoshop EPS) can dramatically increase the size of an Illustrator document, causing slower performance. To improve performance, select Link in the Place dialog box when you place a bitmap image. The Link option creates a reference to the placed image on your hard disk.

If you use any of the Illustrator filters on a linked bitmap image in Illustrator CS, Illustrator must embed the image. Illustrator CS2 does not allow you to apply any filters on linked bitmap images. Selecting Include Placed Images in the Illustrator Save As dialog box also embeds the image file. If you must include the image in the Illustrator document for transfer to a service bureau, replace the image without the Link option or save a copy of the file with Include Placed Images selected as a last step before final output.

EPS previews

If a document contains linked EPS images that have high-resolution previews, Illustrator may redraw the screen slowly as you edit artwork. To enable Illustrator to redraw the screen more quickly, use low-resolution EPS previews: Choose Edit > Preferences > File Handling & Clipboard, select Use Low Resolution Proxy For Linked EPS, and then click OK.

Show DCS Transparency Interactions option

The Links Palette Options dialog box includes a Show DCS Transparency Interactions option for Illustrator CS2 and a Show Transparency Interactions option for Illustrator CS. If this option is selected, the Links palette displays a yellow icon to identify linked DCS EPS graphics that are transparent or overlap transparent objects. Because this option forces Illustrator to regularly determine if linked EPS files interact with transparency, it can reduce performance.

To disable the Show Transparency Interactions option:

1. Choose Palette Options from the Links palette menu.

2. Deselect Show DCS Transparency Interactions (Illustrator CS2) or Show Transparency Interactions (Illustrator CS), and then click OK.

Navigator palette

The Navigator palette displays a thumbnail view of your current artwork for easy navigation. Depending on the complexity of your artwork, a substantial amount of processing time may be required to update the thumbnail each time you make a change. To improve screen redraw speed and performance in a complex Illustrator document, hide the Navigator palette by choosing Window > Hide Navigator.

You can set up custom views to more efficiently zoom to particular areas of your document. See the Custom Views section of this document for more information.

Anti-Alias Artwork option

The Anti-Alias Artwork option smooths text and graphics by blending the color of an object's edge pixels with that of adjacent pixels. However, this process can cause slow screen redraw. To disable this option, choose Edit > Preferences > General; then deselect Anti-aliased Artwork and click OK.

Simplify command

The Simplify command reduces the amount of anchor points in paths and path shapes, reducing file size and increasing performance. To apply the Simplify command, select the desired path or object, and then choose Object > Path > Simplify.

For more information on the Simplify command, see Illustrator Help.

Smart Guides

Smart Guides allow you to create, align, edit, and transform Illustrator objects relative to other objects. If you have a large number of objects in your artwork, Illustrator will require more time to display Smart Guides. To disable Smart Guides, choose View > Smart Guides. A check mark appears next to the command when Smart Guides are enabled.

For more information on Smart Guides, see Illustrator Help.

Windows resources

The following websites provide troubleshooting tips and general information about Windows.

Adobe Customer Support: www.adobe.com/support/

Microsoft Knowledgebase: http://support.microsoft.com

Download.com: www.download.com


Related Documents

311742: Creating efficient files and improving print performance (Illustrator 10 and CS)

310237: Editing the Win.ini File General Information

Document 320782
Last edited - 07/01/2005

 

Got Some Time to Take a Survey?

Tell us what you think about this support site.