Accessibility

Support Knowledgebase

Error "...printing libraries are out of date..." occurs with LaserWriter 8.x (AdobePS 8.5-8.6 on Mac OS)

Issue

When you select LaserWriter 8 in the Chooser, the system returns the error "This printer driver can not be used because the printing libraries are out of date. . . . "

Detail

You recently installed the AdobePS printer driver 8.6 or earlier in Mac OS 9.x, or you recently installed AdobePS 8.5.x in Mac OS 8.6.x or earlier.

Solutions

Do either of the following solutions:

Solution 1

Move the PrintingLib file from the System Folder:Extensions folder to the desktop, and then do one of the following:

-- In Mac OS 9.x, install LaserWriter 8.7 from the Mac OS 9 installation CD.

-- In Mac OS 8.6.x or earlier, install LaserWriter 8.5.1 or later, which is available from the Apple website at www.apple.com .

Solution 2

Print using the following version of AdobePS, available from the Adobe website at www.adobe.com/support/downloads/ :

-- Use AdobePS 8.6 or later in Mac OS 8.6.x or earlier.

-- Use AdobePS 8.7 or later in Mac OS 9.

Background information

Mac OS uses the PrintingLib file to enable desktop printing. Both AdobePS and LaserWriter require the PrintingLib file to be installed. When you install AdobePS 8.5.x in Mac OS 8.6.x or earlier, or when you install Adobe PS 8.6 or earlier in Mac OS 9, its installer replaces the existing PrintingLib file with a version that is incompatible with LaserWriter.


Related Documents

Document 328553
Last edited - 02/14/2005

 

Got Some Time to Take a Survey?

Tell us what you think about this support site.