Accessibility

Support Knowledgebase

Troubleshoot system errors or freezes in Photoshop (CS2 on Mac OS X)

What's covered

Beginning troubleshooting

Intermediate troubleshooting

Advanced troubleshooting

This document can help you resolve system errors that occur while you use Adobe Photoshop CS2 in Mac OS X. System errors can manifest themselves in many different ways, including (but not limited to) the following:

-- A blank or flickering dialog box

-- A frozen cursor or screen

-- An error such as "The application 'unknown' has unexpectedly quit. The system and other applications have not been affected."

Different factors can cause system errors, including conflicts among device drivers, software, and hardware, and corrupt elements in specific files. Although a system error may occur only when you work with Photoshop, Photoshop may not necessarily be the cause--it may be the only application that uses enough memory or processor cycles to expose the problem.

To benefit most from this document, perform the tasks in order. Keep track of the tasks you perform and the results of each task, including errors or problematic behavior. Adobe Technical Support can use this information to better assist you, if you need to call.

Beginning troubleshooting

The tasks in this section can help you resolve the most common system errors. Before performing any of these tasks, back up all personal files (for example, Photoshop CS2 PSD files you created). Always restart the computer after a system error occurs to refresh its memory. Continuing to work without restarting the computer may compound the problem.

1. Make sure that the system meets the minimum requirements for Photoshop.

Photoshop may not run correctly on a system that doesn't meet the following requirements:

Photoshop CS2 (purchased as a stand-alone product)

-- PowerPC G3, G4, or G5 processor

-- Mac OS X v10.2.8-10.3.8 (10.3.4-10.3.8 recommended)

-- 320 MB of RAM* (384 MB recommended)

-- 750 MB of available hard-disk space

-- 1024 x 768 monitor resolution with 16-bit video card

-- CD-ROM drive

-- Internet or phone connection required for product activation

Photoshop CS2 (purchased as part of the Adobe Creative Suite 2.0)

-- PowerPC G4 or G5

-- Mac OS X v10.2.8-10.3.8 (10.3.4-10.3.8 recommended; G5 requires 10.3 or later), Java Runtime Environment 1.4.1

-- 384 MB of RAM* to run any one creative application with Adobe Bridge and Version Cue Workspace

-- Additional RAM required to run multiple applications simultaneously (512 MB to 1 GB recommended)

-- QuickTime 6.5 required for multimedia features

-- 4 GB of available hard-disk space to install all applications in Adobe Creative Suite 2.0 Premium (3 GB required for Adobe Creative Suite 2.0 Standard)

-- 1024 x 768 monitor resolution with 16-bit or greater video card (24-bit screen display recommended)

-- CD-ROM drive

-- For PostScript printing: Adobe PostScript Language Level 2 or PostScript 3 printer

-- Internet or phone connection required for product activation

-- Broadband internet connection required for Adobe Stock Photos and additional service

*To check how much RAM is installed, choose About This Mac from the Apple menu. The Memory value indicates the amount of installed RAM.

2. Install the latest version of Photoshop.

Your operating system and hardware drivers may be more compatible with the latest version of Photoshop than with an earlier version. Before you install an update or upgrade, make sure that your system meets the requirements.

-- To locate an Authorized Reseller, visit the Adobe website at http://partners.adobe.com/resellerfinder/na/findreseller.jsp or call Customer Services at 800- 833-6687 .

-- To purchase an upgrade from Adobe, visit the Adobe Store at http://store.adobe.com/store or call Customer Services at 800- 833-6687 .

3. Install current Mac OS X updates.

Updates to the Mac OS X operating system improve its performance and compatibility with applications. You can obtain Mac OS X updates from the Apple website at www.apple.com/downloads/macosx , or choose Software Update from the Apple menu. For assistance installing updates, contact Apple technical support.

4. Re-create the Photoshop preferences files.

You can re-create the Photoshop preferences file to eliminate problems caused by a damaged preferences file.

Note: Re-creating the Photoshop preferences files restores settings to their defaults.

To re-create the Photoshop preferences files:

1. Quit Photoshop.

2. Drag the Adobe Photoshop CS2 Settings folder from the Users/ [username] /Library/Preferences folder to the Trash.

3. Restart Photoshop.

If the problem recurs after you re-create the Photoshop preferences files, the problem isn't related to preference files. To restore custom settings, drag the file you moved in step 2 back to its original location, and then click Replace to the alert "An item named 'Adobe Photoshop CS2 Settings folder' already exists in this location. Do you want to replace it with the one you're moving?"

5. Run Photoshop while no other applications are running.

To maximize available RAM and reduce the chance that another application may conflict with Photoshop, quit open applications, and then restart Photoshop. If applications don't quit as expected, force quit them.

To force quit open applications:

1. Choose Force Quit from the Apple menu.

2. In the Force Quit Applications dialog box, select an application, and then click Force Quit.

Note: Don't select the Finder, which is the core Mac OS X component.

3. Click Force Quit again when Mac OS X returns the alert "Do you want to force [application] to quit?"

4. Restart Photoshop, try to re-create the error, and continue as follows:

-- If the error doesn't occur, the application you selected in step 2 conflicts with Photoshop.

-- If the error occurs, repeat steps 3-4; or, if you've quit all open applications, proceed to the next task.

6. Use the Console utility to identify software conflicts.

If the problem causes Photoshop to freeze, the Console utility can identify software that causes the conflict.

To use the Console utility to identify software conflicts in Mac OS X v10.3.x:

1. Choose Go > Applications, open the Utilities folder, and then double-click Console.

2. Choose View > Show Log List.

3. Open ~/Library/Logs by clicking the triangle to the left of the line.

4. Open CrashReporter by clicking the triangle to the left of the line.

5. Choose [ Adobe application ].crash.log.

6. Restart Photoshop, and try to re-create the problem. If the problem recurs, reinstall or update the software identified in the crash log.

To use the Console utility to identify software conflicts in Mac OS X v10.2.8:

1. Choose Go > Applications, open the Utilities folder, and then double-click Console.

2. Choose Console > Preferences, and then click the Crashes tab.

3. Select Log Crash Information in ~/Library/Logs/, and then select Automatically Display Crash Logs.

4. Restart Photoshop, and try to re-create the problem. If the problem recurs, reinstall or update the software identified in the crash log.

7. Verify that you are using the latest driver and PPD file for the printer.

If the problem occurs when printing, verify that you are using the latest driver and PPD file for the printer: Download and install the latest driver and PPD file from the printer manufacturer's website.

Intermediate troubleshooting

If the tasks in the previous section don't solve the problem, then try the following intermediate troubleshooting tasks.

8. Reinstall Photoshop.

An incorrect installation can cause errors when you work in Photoshop. Reinstalling Photoshop can eliminate these errors.

To reinstall Photoshop:

1. Move any personal files from the Photoshop CS2 folder on the hard disk to another location.

2. Delete the Photoshop CS2 folder on the hard disk.

3. Quit all applications. Force quit applications, if necessary.

4. Double-click the installer file in the Photoshop CS2 folder on the application CD.

5. Follow the on-screen instructions to complete the installation.

Note: If you previously installed an update to Photoshop, reinstall the update after you reinstall Photoshop.

9. Log in as a user with administrator access privileges.

If you lack administrator access privileges, Photoshop may be unable to access necessary files. To determine if limited privileges cause the problem, log in as a user with access privileges, and try to re-create the problem. If the problem doesn't recur, the account you were previously using lacks access privileges. Contact your system administrator to grant you access privileges.

To log in as a user with administrator access privileges:

1. From the Apple menu, choose Log Out.

2. Click Log Out when the system returns the message "Are you sure you want to quit all applications and log out now?"

3. When the log in screen appears, select a user with access privileges, type the appropriate password, and then press Return.

10. Repair disk permissions by running Disk Utility.

If you log in to an account with administrator privileges, but are still unable to install or run Photoshop, your disk permissions may be damaged.

To repair your permissions using the Disk Utility:

1. Choose Go > Applications, open the Utilities folder, and then double-click Disk Utility.

2. Select the First Aid tab.

3. Select the volume on which you want to install Photoshop, and then click Repair Disk Permissions.

11. Remove third-party plug-ins from the Photoshop plug-ins folder.

Remove third-party plug-ins from the Photoshop plug-ins folder, and then restart Photoshop. If the problem doesn't occur after removing third-party plug-ins, one or more of them conflicts with Photoshop. Contact the manufacturer of the plug-ins for information about updates.

12. Run the Adobe application from within a new user account.

Occasionally, a user account can become corrupted and prevent the installer from accessing or creating the necessary files and folders. Create a new account, log in to the new account, and then try to install or run the Adobe application.

To create a new user account in Mac OS X v10.3.x:

1. From the Apple menu, choose System Preferences.

2. Click Accounts.

3. Click the plus sign toward the bottom of the window on the left.

4. Type a user name and a password that you'll remember, such as test .

5. Click the Security tab, and then select Allow User To Administer This Computer. This makes the test user an administrator.

6. Close the Accounts window.

7. Choose Log Out from the Apple menu.

8. When the log in screen displays, choose the test user.

To create a new user account in Mac OS X v10.2.8:

1. From the Apple menu, choose System Preferences.

2. From the View menu, choose Users, and then click New User.

3. Type the user name (for example, test ).

4. Click the Password tab, and then enter a password that you'll remember, such as test .

5. Select Allow User To Administer This Computer. This makes the test user an administrator.

5. Click OK and close the Accounts window.

6. Choose Log Out from the Apple menu.

7. When the log in screen displays, choose the test user.

13. Troubleshoot fonts.

A system error can occur if Photoshop accesses a damaged font. You can troubleshoot fonts to determine if they cause the problem:

1. Drag the contents of the Library/Fonts folder to a new folder on the desktop. (If you manually added fonts to the Library/ Application Support/ Adobe/ Fonts folder, also drag those fonts to the new folder.)

2. At the Finder, choose File > Find.

3. Type AdobeFnt , select the system drive, and then press Return.

4. Delete all AdobeFnt.lst files found (for example, AdobeFnt06.list).

5. Restart the computer.

6. Restart Photoshop. Photoshop creates new AdobeFnt.lst files.

7. Try to re-create the problem, and continue as follows:

-- If the problem doesn't recur, move one font back to the Library: Fonts folder, and then repeat steps 5-7 until you identify the problematic font.

-- If the problem recurs, move the contents of the new folder on the desktop back to the Library/ Fonts folder.

14. Optimize scratch disks.

If the Adobe product uses scratch disks, include information about optimizing them, such as the following:

Photoshop uses a scratch disk file (that is, temporary disk space for storing data and performing computations) when insufficient RAM is available for image editing. The hard disk partition you specify as the primary scratch disk should have free space equal to three to five times the size of the average image file; specify a secondary scratch disk if you have an additional hard disk partition. If disk space is insufficient, remove unnecessary files from the hard disk.

To specify a scratch disk in Photoshop, choose Photoshop > Preferences > Plug-ins & Scratch Disks.

15. Defragment and check hard disks for damage.

A fragmented or damaged hard disk can cause Photoshop and other applications to freeze or return an error. Defragment and check hard disks by using a disk utility, such as Apple Disk Utility, Symantec Norton Utilities, or Micromat Drive 10.

Disclaimer: Adobe doesn't support third-party disk utilities but provides the following instructions as a courtesy. For support, contact the developer of the disk utility.

To check for damage by using Apple Disk Utility (included on the system CD):

1. Start the computer from the system CD.

2. Choose Installer > Open Disk Utility.

3. Select the disks to be checked, and then click the First Aid tab.

4. Click Repair to check and, if necessary, repair selected disks.

Advanced troubleshooting

If the tasks in the previous section don't resolve the problem, you may be able to resolve the problem by reformatting your hard disk or by determining if hardware is conflicting with Photoshop.

Disclaimer: Adobe doesn't support hardware and provides these tasks as a courtesy only. For further assistance, contact the hardware manufacturer or an authorized reseller. If you troubleshoot hardware problems yourself, you may void the computer's warranty.

Note: Before you remove or rearrange hardware, turn off and disconnect the power to the computer and any peripheral devices.

16. Reformat the hard disk using HFS+ formatting, and install only Mac OS X and Photoshop.

Reformat the hard disk using HFS+ formatting, and then install only Mac OS X and Photoshop from the original installation media. Reformatting a disk erases all files it contains, so be sure to back up all personal files first. Also make sure that you have all application and system disks.

Note: Don't install additional software or hardware until you're sure that the problem is resolved. Don't back up the hard disk and restore Mac OS X and Photoshop instead of reinstalling them; if the problem is caused by an application or Mac OS X, and either one is restored instead of reinstalled, the problem may recur.

After you reformat the hard disk and install only Mac OS X and Photoshop, try to re-create the problem:

-- If the problem no longer occurs, install other applications one at a time, and try to re-create the problem after each installation. If the problem occurs after an installation, the recently installed application may be the cause. Contact the developer of the application for information about an update.

-- If the problem recurs, the cause is hardware-related, and you should contact the hardware manufacturer or an authorized reseller for assistance. Before contacting the manufacturer or reseller, however, you may want to try one or more tasks in the following section.

17. Check for SCSI problems.

If you have a SCSI card for internal or external SCSI devices, verify that the settings for the card are correct, ensure that the SCSI chain is properly connected and terminated, update SCSI drivers, and check for hardware or cable damage. For instructions, contact the SCSI card manufacturer.

18. Check for damaged expansion cards.

Damaged or incompatible expansion cards can cause system errors. To check expansion cards, turn off the computer, remove any processor accelerator, cache, or other installed expansion cards, and then restart the computer.

19. Check for problems with RAM modules.

Ensure that the RAM modules are installed properly and aren't the cause by doing one or more of the following:

-- Change the order of the installed RAM modules.

-- Remove all but the minimum number of RAM modules needed to run Mac OS X and Photoshop, and test to see if the problem persists. If it does, replace the RAM modules you removed and remove the others, testing again to see if the problem persists. If the problem doesn't recur, one or more of the removed RAM modules are the cause. For assistance, contact the RAM manufacturer.

20. Use a different hard disk or computer.

Install and run Photoshop from a different hard disk on the same computer (not a different partition on the same disk) or the same hard drive installed in a different computer. If the problem doesn't recur, the hard disk or the motherboard you were using previously may be the cause. For assistance, contact the manufacturer.


Related Documents

Document 331307
Last edited - 09/19/2006

 

Got Some Time to Take a Survey?

Tell us what you think about this support site.