Accessibility

Support Knowledgebase

Configure 3D applications for Acrobat 3D Capture (on Windows or Unix)

What's covered

Supported application settings in Acrobat 3D

Unsupported application settings in Acrobat 3D

Third-party application settings for use with Acrobat 3D

Acrobat 3D Capture supports capturing objects in OpenGL mode only and does not support DirectX. If your specific application is not listed here, you may need to experiment with the setting in both the 3D application and Acrobat 3D Capture.

Supported application settings in Acrobat 3D

Application
Frame Buffer Mode
View Transform Mode
4DNAV
Swap Buffer Event
No Matrix
CATIA V4
Swap Buffer Event
Last Matrix
CATIA V5
Swap Buffer Event
First Matrix
DeepExploration
Swap Buffer Event
Last Matrix
DMU
Swap Buffer Event
First Matrix
I-DEAS
Swap Buffer Event
Last Matrix
Inventor
Clear Event
Last Matrix
NX 3.0
Clear Event
Last Matrix
Rhino 3D
Clear Event
Last Matrix
Solid Edge
Flush Event
Last Matrix
SolidWorks
Clear Event
Last Matrix
VisView / VisMockup
Swap Buffer Event
First Matrix

Unsupported application settings in Acrobat 3D

Application
Frame Buffer Mode
View Transform Mode
3D Studio Max/VIZ
Clear Event
No Matrix
ABAQUS/CAE
Swap Buffer Event
Last Matrix
AutoCAD and AutoCAD Mechanical
Swap Buffer Event
Last Matrix
AutoStudio
Swap Buffer Event
Last Matrix
eDrawings
Clear Event
No Matrix
Gocad
Swap Buffer Event
First Matrix
ICEM Surf
Swap Buffer Event
No Matrix
Maya
Clear Event
No Matrix
Mechanical Desktop
Swap Buffer Event
Last Matrix
MicroStation
Flush Event
No Matrix
Multiphysics
Swap Buffer Event
Last Matrix
PAM-CRASH
Swap Buffer Event
Last Matrix
Pro/Desktop
Clear Event
First Matrix
Pro/ENGINEER
Clear Event
Last Matrix
Revit
Swap Buffer Event
No Matrix
RobCAD
Swap Buffer Event
No Matrix
Unigraphics
Swap Buffer Event
Last Matrix
PowerSHAPE

Flush no Matrix

Third-party application settings for use with Acrobat 3D

Note: Adobe provides this third-party information as a courtesy only. Adobe Technical Support supports the Acrobat 3D Toolkit but cannot help you configure a third-party application. For more information on how to set up your third-party application, please consult the user manual for that application.

3D Studio Max/VIZ

Verify that the following setting is correct in Autodesk 3D Studio Max:

1. Choose Customize > Preferences.

2. Click the Viewports tab.

3. Under Display Drivers, click Choose Driver.

4. Select OpenGL, and then click OK.

Capture limitations: Original orientation, origin, and scale are not preserved. Measurements may be incorrect.

4DNAV

No special 4DNAV settings are required.

ABAQUS/CAE

No special ABAQUS/CAE settings are required.

AutoCAD / AutoCAD Mechanical

Verify that the following settings are correct in AutoCAD or AutoCAD Mechanical:

1. Choose Tools > Options.

2. Select the System tab.

3. Under Current 3D Graphics Display, select Properties.

4. Under Acceleration, select Hardware Acceleration.

5. Under Select Driver, choose wopengl8.hdi.

6. Click Apply & Close, and then click OK.

Note: Acrobat 3D Capture can capture DWG and DXF files, however you must render the DWG or DXF file in AutoCAD before it can be captured. The Acrobat 3D Capture utility cannot capture unrendered models (wireframes).

AutoStudio

No special AutoStudio settings are required.

When capturing Alias AutoStudio models in Windows, Acrobat 3D creates a preset with the correct settings. To capture on a UNIX platform, you may need to change settings in the OpenGL panel of the 3D Capture Settings dialog box. For Frame Buffer Mode, select Swap Buffer Event. For View Transform Mode, select Last Matrix.

CATIA V4

No special CATIA 4 settings are required.

CATIA V5

Verify that the following settings are correct in CATIA 5:

1. Choose Tools > Options > General > Display.

2. Under Performances, confirm the following settings:

-- Occlusion Culling Enabled: Off

-- Transparency Quality: High

-- Enable Back Face Culling For Faces And Surfaces Only: Off

-- Enable OpenGL Local Viewer Lighting: On

3. Under Visualization, deselect the option to display all elements using Z-buffer depth.

Deep Exploration

For Right Hemisphere Deep Exploration versions earlier than 4.0, the graphic mode must be set to OpenGL Hardware T&L. Choose Display > Graphics Mode > OpenGL Hardware T&L.

Gocad

No special Gocad settings are required.

I-DEAS

Verify that the following settings are correct in I-DEAS:

1. Choose Option > Preferences > Display.

2. Deselect Viewport Triad, Viewport Outline, Viewport Label, Origin display.

3. Deselect Enable Display Reduction.

4. Deselect Save Graphic Levels Of Detail Per Entity.

5. Select Display Off Screen Entities.

ICEM Surf

No special ICEM settings are required.

Limitations: Original orientation, origin, and scale are not preserved. Measurements may be incorrect. You may experience color problems in the most advanced ICEM Surf graphics. The original orientation, origin, and scale can be preserved by selecting First Matrix instead of Ignore Matrix for View Transform Signal in the Acrobat 3D Capture Settings dialog box. However, changing this setting may generate errors in the 3D model's geometry.

Inventor

Verify that the following settings are correct in Autodesk Inventor:

1. Choose Tools > Application Options.

2. Click the General tab, and deselect Show 3D Indicator.

3. Click the Display tab. Under Shaded Display Modes, deselect Active-Edge Display.

4. Under Display Quality, select Smooth.

Maya

No special Maya settings are required.

Limitations: Original orientation, origin, and scale are not preserved. Measurements may be incorrect.

Mechanical Desktop

Autodesk Mechanical Desktop must be configured to use OpenGL.

MicroStation

Verify that the following settings are correct in MicroStation:

1. Choose Settings > Rendering > View Attributes.

2. Select Graphics Acceleration.

3. Under Display, select Phong.

4. Select All.

Limitations : Original orientation, origin, and scale are not preserved. Measurements may be incorrect.

Multiphysics

No specific Multiphysics settings are required.

Nx3

No specific Nx3 settings are required.

PAM-CRASH

No specific PAM-CRASH settings are required.

Pro/Desktop

No specific PTC Pro/Desktop settings are required.

Pro/ENGINEER

Verify that the following settings are correct in Pro/ENGINEER:

1. Choose View > Model Tree to deselect it so that the Model Tree isn't captured.

2. Choose View > Display Settings > Datum Display, and deselect all settings.

3. Choose View > Display Settings > System Colors, and deselect Blended Background.

Limitations: Original orientation, origin, and scale are not preserved. Measurements may be incorrect.

Revit 5.1

No specific Autodesk Revit settings are required.

Rhino3D

Verify that the following settings are correct in Rhino 3D:

1. Choose Tools > Options.

2. Choose Rhino Options > Display.

3. Under Wireframe Viewport Options, set Display Wireframe Viewport to OpenGL.

4. Under Rendered Viewport Options, deselect all options.

5. Choose Document Properties > Grid to select Grid.

6. Under Grid Properties, deselect all options.

Limitations for all Rhino Display Modes :

-- DOT Entity is not captured.

-- Text Entity is not captured (the Rhino TextObject entity is captured).

-- Bump mapping information is not captured.

-- Environment mapping is captured as a static texture map.

-- Wireframe lines and edges are captured, but they are not oriented correctly.

-- For Analysis Modes, Rhino analysis results displayed as interpolated color across surfaces are not captured correctly (colors are all set to the first color in the gradient).

RobCAD

Verify that the following setting is correct in eM-Workplace (formerly Robcad):

1. Select Display.

2. Select Viewing.

3. Click Open Graphics Window.

4. Click Default.

Limitations : Original orientation, origin, and scale are not preserved. Measurements may be incorrect.

Solid Edge

Verify that the following settings are correct in UGS Solid Edge:

1. Choose Tools > Options.

2. Click the View tab.

3. From the Application Display list, select Graphics Card Driven or Backing Store.

4. Deselect Culling.

5. Click OK.

SolidWorks

No specific SolidWorks settings are required.

Unigraphics

Verify that the following settings are correct in Unigraphics:

1. Choose Preferences > Visualization.

2. Click Edit Background.

3. Select Plain for all settings.

4. Click Apply, and then click OK.

VisView / VisMockup

Verify that the following setting is correct in VisView VisMockup:

1. Choose Display > Preferences.

2. In the General panel, deselect Backface Culling.

3. Click Apply, and then click OK.

PowerSHAPE

Verify that the following setting is correct in PowerSHAPE:

1. Choose View > Single > Top.

2. Choose View > Appearance > Solid, and click OK to use a solid shaded background (instead of a graduated background).

3. Choose View > Shading > Shaded to display models in shaded mode.

Note: During capture in Acrobat 3D, use the Flush No Matrix option.


Related Documents

Document 332661
Last edited - 09/21/2006

 

Got Some Time to Take a Survey?

Tell us what you think about this support site.