Structuring and designing content
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How can you improve your content? \‘7
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Adobe tips Kl

Back to school: tips and tricks for authors!

Bernard Aschwanden shares tips when using Adobe
FrameMaker and RoboHelp 2019 to make the best use of
metadata possible and prepare your content for the future.

1 AEM. Adobe Experience
Manager. www.adobe.com/uk/
marketing/experience-manager.
html (accessed July 2019)

It’s autumn. Children have returned to classes
(or are about to). Today they’ll learn skills
and apply ideas that will improve their future.
Let’s do the same with our tools. Let’s set up
content today to take advantage of it when we
repurpose and publish it in the future!

Two of the most common tools in technical
communications are Adobe FrameMaker and
Adobe RoboHelp. In the past year, both tools have
had a 2019 release. This article explores features
you may not know about (or may not remember
having used) to make what content does in the
present, and what it can do in the future, much
better.

For a full overview of what is new, and what
is enhanced, make sure you visit the Adobe site
where you can read more, as well as watch video
highlights:
= www.adobe.com/products/

robohelp/features.html
= www.adobe.com/products/

framemaker/features.html

Metadata today helps you (and your readers) tomorrow
In both FrameMaker and RoboHelp there are a
few simple things to do early-on to make your
content more potent in the future. Many people
either never set up content with metadata (think
of it as information about your information), or
don’t do so regularly.

With today’s focus on findability, search
engine optimisation, and taxonomies it’s
a great idea to perform a few basic steps
when you create any content. Assigning
metadata means tools like component content
management systems (including Adobe’s own
AEM! tool!) can take advantage of you doing
it right the first time. We’ll look at what you
can do with structured standards (like DITA)
and unstructured FrameMaker, and explore
considerations when creating projects or topics
in RoboHelp.

Structured FrameMaker (with DITA)

DITA has a lot of metadata information that can

be stored in the XML document. Ensure you are

using Structured FrameMaker before proceeding
with this next sample.

1. Select File>New>DITA>topic. Update the
content to appear similar to what is seen here
with an author, copyright information, and
metadata including any keywords, product
info, or other DITA elements, attributes, and
values as needed.

v [opic >
tile
shortdesc
' prolog =
author Bernard Aschwanden
copyright
copyryear
year 2019
copyrholder |» www.publishingsmarter.com
metadata
keywords
keyword | » automation
keyword widgets
v prodinfo
prodname » Widget-o-matic 10K
¥ vmmlist »
vim >

version v
release r2
modification m3

DITA topic with <prolog> and metadata

2. Continue to create content and, when ready,
save the document as XML. All the information
can be retrieved. It can even be used when
publishing. Consider the sample above
converted to HTML5 using File>Publishing
as a starting point and how the output is
converted to meta tags.

>
0 automation, widgets" /
snt="automation, widgets” (>

t="Bernard Aschwanden™ />
t="www. publishingsmarter.com 2819" />

cont

DITA content as meta tags

Unstructured FrameMaker

Document properties in an unstructured file

transfer into a PDF. It’s important to ensure the

content is correct, and unique to what you are
writing about.

1. Select File>New>Document. In the Custom
Blank Page dialog select a page layout that
relates to the content type you plan to create
(for example, A4 Letter). Modify columns,
margins, and pagination. Click Create.
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2.

3.

Select File>File Info. In the dialog complete
as much (or as little) of the information as
you need.

| File Info x
Author [Bemard Aschwanden
Title: |Getting started with Adobe FrameMaker
|2019
Subiject: |Overview and introduction to the newest

|version of Adobe FramaMaker including
tips and tricks for new users.

Keywords: |framemaker, new users, lips and tricks,
|getting started

Copyright: 'wm.publishingsmarter com

Web Statement:

Job Reference:

Marked: Unknown »
Create Date:  July 8, 2019 10.04:26 PM
Maodify Date: July 8, 2019 10:12:32 PM

Metadata Date: July 8, 2019 10:12:32 PM

‘ (No Unda)

Cancel

File info as seen in FrameMaker

Continue to create content in the document
and, when ready, save it as a PDF. Then open
the PDF and select File>Properties and review
the dialog!

Domert Fropenies
| wcipnin Secssty Fores il View Cutomn Adwarced
Duasiption

T Figdage

Dt [t Veed wits A Faerabdihee 2079

PPN =y re—

S o e o i o R e ki o Vel o L

Erpwcodic [Tuumermdke, ew coar, bgm ard ik, goting staked

POF Prosducee. b POF Ubsary 150

POF Yersion 14 [Acrobet 5. |

Document properties in PDF

Taking the time to correctly set up your file
information in the source ensures the resulting
PDF is easier to find, use, and manage as it

contains information inherited from the source.

W RoboHelp projects

2. Review all the settings and develop the General,
Topic Status, Colors, and Tag Groups settings.

You may decide, for example, to add and update
the Topic Status to support translation.

Project Settings

STATUS

General

Add a ney +
Topic Status

Draft ]
Colors

In Progress ]
Tag Groups B

Ready for Review ]

Sent for Review o

Reviewed ]

Complete o

Project Settings — Default Topic Status

Project Settings

General SIS
Add a new status +
Topic Status
Draft | |
Colors
In Progress |
Tag Groups g
Ready for Review | |
Sent for Review |
Reviewed L
Ready to Translate |
Sent to Translate L |
Translated |
Complete o

D €

Project Settings — Updated Topic Status with
Translation Information

W RoboHelp topics

Information about a topic can be stored

within the topic for use when published. This

can be displayed and edited in several ways.

One method that I like to use is to show the

Properties panel at all times.

1. Open any topic and select View>Properties
Panel. Then select the Topic tab.

A project can have many properties, but most

people don’t set them up. These settings help

control content across the entire project.

1. Create or open a project and select
File>Project Settings.

Communicator Autumn 2019



General  Styles  Tople

Topic Status, after updates to the Project Settings

2. Assign the status as required.

W RoboHelp Topic List

The Topic List allows you to see all of the topics

and, by clicking on the header of any column,

sort them.

1. After defining the Status for your topics,
select View>Topic List. Review the panel and
sort topics.

Alt properties for images

Graphics require properties to define the height,
width, and placement, but the use of alternate
text prepares your content for the future. It
adds information that can be used by search
engines and other tools.

Structured FrameMaker (with DITA)

There are elements such as <fig> and <image>

in DITA that are used to insert a figure, title,

and picture. However, they also support

metadata in several unique ways.

1. Insert a <fig> element in a DITA topic, then
insert nested <title> and <desc> elements.

2. Populate the <desc> with more information
about the image. This could, for example, be
a sentence to describe its appearance.

3. Once the <image> is added, the attribute
for longdescref can be populated. This may
contain a link to a DITA topic that provides a
much richer background about the image.

<fig frame="all"»
<titlesLogo¢/titles
<desc>The company logo displays the Publishing Smarter
logo including the company name and a stylised
feather icon in blue on a white background.</desc>
<image href="logo.png” longdescref="HistoryofOurLogo.dita™ />
¢/figy

<fig> with <desc> and <image> witha
longdescref

Unstructured FrameMaker
If you plan to export your document to a tagged
PDF or to XML, you can include object attribute
information for your anchored frames.

When you provide alternate text attribute on
an anchored frame, the corresponding figure
elements in PDF and graphic elements in XML

get an ‘alt text’ attribute. Actual Text attribute

is processed only for tagged PDF. XML export

ignores this attribute.

1. Select an anchored frame and select
Insert>Anchored Frame.

Anchored Frame

[

Object Style: |As Is v
Element Tag: <Unstructured> ~
Anchoring Position: |Below Current Line ~

Alignment: Left i

Cropped |:| Floating
Size:

Width: .1_244" Height: |0.83"

Object Attributes Edit Frame

2. Click the Object Attributes button.

Object Attributes X
Text Altibutes:

Alternate [

Actual
New or Changed Attribute.

Name

Definition

Defined Attributes

Add
Change
Delete

[[se ] Gancel

{No Undo)

3. Populate the Object Attributes as required.

Alternate text is different from graphics or
standard text. Alt text is typically used for
describing an image so that screen readers can
read it aloud. Actual text is for reading aloud
the actual text, as in the case of a drop cap. For
example, if the author is using a drop cap for
the letter A in the word ‘Adobe’ but still wants
the screen readers to read the word as ‘Adobe’
and not as ‘dobe’, this can be done by filling in
actual text. The attribute will be saved to alt text
and actual text in tagged PDF and XML.
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Eﬂ RoboHelp

Images benefit from the use of the Alt text in

many ways. Alt content can be used by screen

readers and can make content more ‘find
friendly’ when SEO comes into play.

1. Select an image in a topic. Ensure you have
already activated View>Properties Panel and
that the General tab is selected.

2. Modify the Alternate Text as required.

This content is typically used for describing an

image so that screen readers can read it aloud.

The value entered will be stored and converted

to online formats such as HTML5.

General Styles Topic

TYPE —
img ~ T
Source

assets/images/logo.png i'c't

Alternate Text

The Publishing Smarter company logo ...

Generate DITA-OT Qutput X

Choose output type:
schtml
himihelp

pdi2
custom

Output Type:

Optlions:
[[] view Log File
[] ©pen Output Folder
[:| Keep this dialog open after build

DitaVal File:

Generate DITA-OT Output dialog

2. Select an output format and click Build. If

required, the Customize button can be used to
create a custom publishing environment with
the toolkit. The DitaVal option allows you to
set up conditional publishing.

Structured or unstructured frameMaker
(using the Publish dialog)
1. Open FrameMaker content to publish and

Image Title
Title
Width Height
100 & 50 (o

Alternate Text in the General properties

Publishing content

Configuring a file with metadata and other
properties as outlined in this article means that
published content includes greater functional

support for readers, and for automated systems.

Content is not intelligent, but the people who
create it are. Once you create FrameMaker or
RoboHelp content using these tips, the publish
process adds features for you.

Structured FrameMaker (using the DITA Open Toolkit)
1. Open DITA content to publish and select

Structure>DITA>Generate DITA-OT Output.

select File>Publish.

\

Publish

Source Document:  Current L o I &

(A PoF

a Responsive HTMLS

[ Motite App

& ePus

@ Kindle

B Microsoft HTML Help

Adobe Experience Manager Mobile
<[> Basic HTML

Settings Fils: |Defaultsts -

Output Folder: |E-\AdobeliSTCO] .

Publish dialog

. Select a source document and generate the

selected output. All output formats can be
further customised by developing a Settings
File. Depending on the output type, any
metadata will be published to the PDF, HTML5,
or other online outputs and automatically
converted for you.
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If you plan to export your document to a tagged

PDF or to XML, you can include object attribute

information for your anchored frames.

1. Switch to the Output Presets and configure
options if required.

File Edit View Collaborate Help

Author  Output H jo
E Output Presets QUTPUT PRESETS
Skins Responsive HTMLS

© Microsoft HTML Help

;.' Labels
3 WebHel
{} Variable Sets S :
[] Mobile App
A/B Condition Expressions
& EPUB
Y Dynamic Content Filters B o

25 Map Files ﬁ XML Output

Output presets

2. Select an output preset, click the ellipsis icon
(three dots) and choose Edit.

3. Configure the output as required. For
example, for Responsive HTML5 ensure you
change the Layout and select a Skin.

4. Once configured, click Generate Preset.

Reviewing output

Once content is published the rewards can

be seen. Just like a report card shows us the
results of the efforts of children in school, the
code or properties of files shows the results of
the work we put in.

Open the HTMLS5, or the PDF output, hover
over images, test the content with screen
readers, or otherwise review content (including,
if required, the actual source code) and review
the results.

Now you can see that the information we
created early in our projects and files is
converted to the output that we generated. This
can be used by tools and readers to improve the
experience of finding and using content.

The patterns become repeatable as well. Once
established, the workflows can be formalised,
shared, or even modified as needed to create
consistent content.

The initial effort pays off as you now are
publishing better, faster, and smarter. E

Further reading

Adobe RoboHelp (2019 release)
www.adobe.com/products/robohelp/features.html
(accessed July 2019)

Adobe FrameMaker (2019 release)
www.adobe.com/products/framemaker/features.
html (accessed July 2019)

. _________________________________________________________________________|
Bernard Aschwanden is an Adobe

~ Certified Expert in FrameMaker. His

| business, Publishing Smarter, excels at

template creation, legacy content
migration, DITA and content

management implementation, content strategy, and

all things related to professional business

communications.

E: bernard@publishingsmarter.com

W: www.publishingsmarter.com

T: @publishsmarter or @aschwanden4stc

community
InfoPlus

The monthly newsletter from
the ISTC featuring:

Information
News
Advertisements
Events

Training Courses

Please note that the deadline
for contributions is 24th of the
month preceding publication.

It's free to subscribe
InfoPlus is available to everybody, so if you'd like to receive notification as soon
as it's published, send your details to istc@istc.org.uk.

Want to contribute to the newsletter?
If you have news or information that's relevant to scientific and technical
communicators, contact the editor at newsletter.editor@istc.org.uk.

Are you an ISTC Business Affiliate?
We’'d love to include your news or press releases. Email details to
newsletter.editor@istc.org.uk.

Are you organising an event?
Send your event details and dates to events@istc.org.uk.

Advertising

Advertising in InfoPlus can help you achieve greater brand awareness and
exposure with target readers. If you're interested in advertising in the newsletter,
contact Felicity Davie at felicity@tou-can.co.uk.
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