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BENEFIT: RTL support for Arabic
in FrameMaker 2015 is one more
way you can "future-proof” you
content. Deliver your content to
any device, and also in nearly any
language to increase your global
reach.

Author and Publish in Arabic, Farsi and Hebrew
with FrameMaker

The growing importance of Arabic language projects

Taking into account different dialects, if
Arabic is considered a single language,
there 420 million native speakers, making
Arabic the sixth most common language
in the world. Several Arabic speaking
nations are in the midst of accelerated
construction for additional airports,

hospitals, large scale infrastructure

projects. In previous decades, S~—
documentation for projects such as these

was in English only. This is no longer the

case.

In Saudi Arabia and Dubai, many projects are now requiring large scale, technical documentation to
be provided in both English and Arabic. This has been spurred partly by government initiatives to
increase employment within the large, youthful segment of the workforce.

Many military and aerospace projects require documentation to be provided in XML format. This has
previously been a challenge due to the complexity of “XML-only" authoring solutions. The advent of
Right-to-Left (RTL) Arabic support in FrameMaker is a very significant development because it makes
XML authoring and publishing broadly available to a workforce with minimal knowledge of XML and
DITA.

Due to the dynamics of high-end hospitality properties in Dubai, Arabic/Chinese/English are
becoming one of the most common language combinations. The increased presence of Chinese
contractors in the Arab Gulfregion is another reason that it is important to have an authoring tool
that can easily handle mixed content with western languages, Arabic and CJK (Chinese, Japanese and
Korean.) Once again, FrameMaker 2015 can easily handle this language combination.

For anyone who bids for contracts with large, multi-national corporations doing significant business
in key portions of the Arab Gulf Region, it essential to be able to deliver content in both XML and
Arabic. Mixed content (western and RTL languages) is increasingly becoming a "deal-breaker” in
terms of qualifying for 7-figure projects in this region. As you read on through this white paper, you
will discover the many ways that FrameMaker 2015 can help ensure your success in these endeavors.



What has changed with FrameMaker in regards to RTL?

FrameMaker (2015 Release) has been dramatically improved to extend its authoring and
publishing capabilities to include Right-to-Left (RTL) languages, Arabic and Hebrew. You can create

regular or structured documents that are entirely Arabic or Hebrew, or with mixed content using
western Left-to-Right (LTR) and RTL languages

For example, in an LTR document, you can include selected paragraphs or tables that are authored
in an RTL document.

You can also author a document containing both RTL and LTR content, as shown in the example
below:

fThis document in authored predominantly in an LTR script. However, some parts of the document :
are authored in an RTL script. :
For example, the following paragraph is authored in Hebrew: :
: N2V TN TR0nN YW 1t poy:
The contents of the following table is authored in Arabic: :
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FrameMaker (2015 Release) is the first highly accessible product designed specifically for high-
volume technical content that handles RTL authoring and publishing in an easy to use fashion.
FrameMaker is unique in that authors can create content for RTL languages in a familiar,
unstructured document model, or in pure XML or DITA.

The advent of RTL support in FrameMaker will prove to be a huge gain for the translation industry
for several reasons:

- A lower skill level is required to accomplish many layout and formatting actions w/in
FrameMaker

- FrameMaker is capable of handling XML and DITA in RTL languages with a very visual interface.
Translation agencies can dramatically reduce training costs for their staff when they embark on
large-scale, XML projects

- Many tools within FrameMaker make collaborative review through PDF much simpler than with

other authoring solutions

Read further on to determine how RTL authoring and publishing in FrameMaker can benefit you.
You will notice many benefit comments shown as marginal quotes.



Common workflows working with bi-directional content

The illustration below summarizes the two common workflows in FrameMaker when working with
RTL content.

In the first model, text is probably authored in a western LTR language. Once translated into Arabic

Author the Translate into Do DTP work to Publish to desired
content in the desired languages  get the translated formats and devices
source e.g. Arabic, Hebrew documents ready
language using any for publishing

translation tool

Publish

Author the content Publish to desired
in Arabic/Hebrew formats and devices

or Hebrew, post-translation DTP work is done to achieve correct layout and appearance. With
FrameMaker this can be easily done by importing RTL and font values from a separate template. As

explained below, FrameMaker's model of inheritance makes this third step easier than with many
other publishing tools.

In the second model, templates are set up ahead of time that already have RTL text direction
appropriate fonts, and specific layout features appropriate to Arabic or Hebrew. The cursor
movement direction can be designated to move in the appropriate direction with RTL text. Then,
authors simply author with blank copies of this template (or an appropriate XML or DITA
application with RTL attribute settings.) When the project is complete, authors simply publish to
FrameMaker's many output targets, like HTMLS responsive, ePub or traditional PDF or print.

For projects that require mixed languages, LTR in one column and RTL in another column,
maintaining separate pagination flows, see the section "Creating master pages with 2-column,
parallel pagination for RTL and LTR content” to understand the simple steps for setting up page
layout in @ mixed content template.



BENEFIT: FrameMaker's
inheritance model allows
template creation that only
requires a document
direction specification in one
place. Everything in the
document (including page
layout) is instantly
transformed to RTL.

Language Direction and Inheritance

Document

Paragraph]

Table

Text Flow

Graphic

Heads

EtC. ]

Side I

The inheritance model in FrameMaker has been designed to support a new
document direction property. For example, if a Document'’s Direction
attribute has been set to RTL, and the Direction attribute of a paragraph
within the Document has been set to inherit, then the paragraph’s direction
will also be set to RTL.

You will discover that you may change document direction from LTR to RTL
on many levels, for instance in paragraphs, for some graphic objects and
tables. If you leave all of these document objects with a direction value of
“inherit,” they will inherit their direction from the setting at the highest
level: the document (in unstructured documents) or at the highest
containing element level in structured documents.

You may set the direction for the document with the menu Format >
Document > Right-to-Left (or Left-to-Right). Or, you may use the first two
icons in the Direction toolbar. Sections further into this white paper will
reveal how to change direction on the paragraph or table levels.

Direction toolbar

For your convenience, the direction toolbar (View > Toolbars > Direction Toolbar), provides

options for the most commonly used direction commands.

E.

Set the document direction to LTR in one click

Set the document direction to RTL in one click
lcons "A" and "B" also darken to show current document direction

. Change the selected digits from Indic to Roman.

NOTE: This does not change the direction of the selected digits.

Change the selected digits from Roman to Indic.
NOTE: This does not change the direction of the selected digits.

List of available direction markers.

Videos to review for an overview of Bidirectional support:

- FrameMaker 2015: Bidirectional language support = http://adobe.ly/1FDSAo0i

- FrameMaker 2015: Bidirectional language publishing = http://adobe.ly/1FDTcua
- FrameMaker 2015: Bidirectional content flipping = htip://adobe.ly/1lalbUv




Translation Workflow

In a typical translation workflow, the original source document would be authored in the usual
manner. A template would be created with RTL direction specified on the document level.

When the author of the source document is aware that certain document objects are to remain in a
western language, a specific style would be applied to give a fixed value of LTR, so that the content
orientation for such instances would be correct after translation.

The translation agency would import an Arabic or Hebrew template into the translated documents;
the template would contain the following ingredients:

- Document direction set to RTL

- Arabic or Hebrew fonts applied to all appropriate styles

- If necessary, numbered paragraph prefixes, footnotes, etc. would be specified as Indic instead of
western numbers

- Individual adjustments would be made as necessary to rare instances of mixed content that may
require an override (e.g. special markers to ensure correct use of slash or punctuation in URLs
and CODE)

You will find specific directions for implementing the steps in this list in the sections that follow.

Authoring RTL source documents

You can author an entire document in an LTR or RTL language. By default, all FrameMaker
documents are enabled for LTR languages.

Some users may wish to author content in RTL format, for instance, with Arabic as the source
language rather than English or German.

To set up a document for RTL language support:
1. Choose Format > Document > Direction.
2. In the Direction sub-menu, choose Left-to-Right or Right-to-Left.

If you choose Right-to-Left, the cursor shifts to the right edge of the document view. Alternatively, if
you choose Left-to-Right, the cursor shifts back to the left edge of the document view.

If you have changed the direction of the document to RTL, by default, the cursor moves from
Right-to-Left of the document view as you type. This means that the cursor at any point is to the left
of the last character entered. However, you can change the Cursor location and movement in any
document (RTL/LTR).

jlg.'llagl ORYNTG Al Sl e saakaay o) A 585N ey Lu._,




Authoring documents with mixed RTL and LTR content

Besides, creating documents that are RTL or LTR enabled, you can also create documents that have a
combination of these language directions. For example, in an LTR enabled document, you can
include a paragraph or table containing text that is RTL enabled.

Add RTL paragraphsin an LTR document

If the document is currently LTR-enabled, to add a paragraph that is RTL-enabled, you will need to
apply a paragraph format with text direction of the paragraph set to RTL.

1. To apply a paragraph format to a paragraph, open the Paragraph Designer (Format > Paragraphs >
Designer).

2. In the Paragraph Designer, go to the new Direction tab.

3. By default, the paragraph formats in a document inherit the direction of the document. To change
the direction, choose RTL.

Paragraph Designer

W A &5 & B B E

Paragraph Tag: Bodjr

Direction: lm - I
As Iz
Leftto-Right
Right4o-Left

Whenever the direction (LTR-RTL) is changed for a paragraph, the following associated properties
are switched:

+ Alignment

+ Indentation

+ Left and right tabs

+ Left and right cell margins
- Cell margins flags

- Alignment of child anchored frames

4. You can choose to either apply the direction to the current paragraph, all the paragraphs of the
selected format, or you can create a new paragraph format.



Add RTL-enabled tables in an LTR-enabled document

If the document is currently LTR-enabled, to add a table that is RTL-enabled, you will need to apply a
table format with direction of the table set to RTL.

1. To apply a table format to a table, open the Table Designer (Table > Format > Table Designer).
2. In the Table Designer, go to the new Direction tab.

3. By default, the table formats in a document inherit the direction of the document. To change the
direction, choose RTL.

Whenever the direction (LTR-RTL) is changed for a table, the following associated properties are
switched:

-+ Alignment

+ Indentation

+ Ruling

+ Left and right cell margins

4. You can choose to either apply the direction to the current table, all the tables of the selected
format, or you can create a new table format.

The illustration below shows a table before and after its Direction property was changed to Right-to-
Left. Notice that columns have reversed order and that text alignment is reversed.

Table 2: Varieties of Vacations e L YVarieties of Vacations :Table 2!




RTL support for graphic objects

If you place anchored frames or graphical objects on your documents and set the direction of the
document to RTL, the objects are adjusted (flipped) to the new direction.

Flipping graphical objects:
If you place an anchored frames, graphical frame, or text frame on a document and change the
direction of the document, the object is horizontally flipped on the document. This implies that if an

object is placed 10 px from the left margin, changing the direction will cause the object to be placed
10 px from the right margin. However, the orientation of the object remains the same.

l. LTR Anchored Frame RTL Anchored Frame _

Figure 1: A sign§ . §Figure 1: A sign

You can use the following maker.ini flag to switch off this behavior:
TranslateObjectOnDirectionChange=0n

By default, this flag is set to ON. If you do not want the graphical objects on your documents to be
flipped, set this flag to OFF.

Also, you can choose to mirror the orientation of a graphical object that is flipped:

To flip and change the orientation of a graphical object, ensure that the following maker.ini flags are
switched ON:

TranslateObjectOnDirectionChange=0n
FlipObjectOnDirectionChange=0n

Flipping text in graphics and in selected text frames

Although you may have many projects in which all document content is LTR or RTL, there will be
instances with mixed content wherein you need to define specific document objects, like paragraphs
or text frames (text flows) to have a specific direction.

The following sections summarize where to find the commands mentioned above to flip certain
objects in FrameMaker.

To flip text lines and text flows

1. Select the text line or text flow.

2. From the Graphic menu, choose Object Properties.

3. In the Object Properties dialog box, choose Text Line or Text Frame.

4. In the Direction drop-down list, choose Right-to-Left or Left-to-Right.



Creating master pages with 2-column, parallel pagination for RTL
and LTR content

IEERNTRNRE

In order to create a template which has parallel columns on the master page, with
separate flows (for connected pagination) and different direction (e.g. one LTR and
one RTL), follow these simple steps:

- Create a new, blank document, View -> Master Pages, Control-Click the text
column, and 2

- resize the single column to a narrow width placed towards the left side of the
page. By default, this column will have “Flow A" as a property and “LTR" for
direction.

- Using FrameMaker's Graphic Toolbar from View->Toolbars -> Graphic Tool, draw
a second Text Frame from the tool indicated to the right

When you finishing drawing a column on the right side of the master page you will

be prompted to fill in values in the "add new text frame" alert that will appear. Add
the values shown below.

e

Add New Text Frame

To Master Page: Right
Text Frame Type:

| Backaground Text ffor headers, footers, and so on)
'@ Template for Body Page Text Frame:
Flow Tag: B -

Columns:

MNumber: 1 Gap: 0.25"

Add Cancel

« Click on Add. Then, with the text frame still selected as an object, choose Graphics -> Object

Properties ... then choose Text Frame as a category, and fill in the values in the lower third of the
menu as indicated below and Apply.

Flow

Taa: B

V| Autoconnect

PostScript Code

Room for Side Heads

Width: 1.5" Gap: 0.25"
Side: Right -
Direction: Rightto-Left -




- View -> Body Pages ... and you will observe a 2-column page. If you insert text into the left column
and type a few paragraphs, then repeat the process with the column on the right side, you will
achieve results like the illustration below.
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- With this brief experiment, you have successfully created a mixed content document that allows
LTR English text in left column to paginate parallel to the RTL Arabic text in the right column. If you
continue to type enough text, or hit return numerous times in either column, it will create a new

page with the 2 parallel columns.

Numbering properties W A B O

FrameMaker now supports the following auto number Paragraph Tag: Heading 3

|

building blocks (Paragraph Designer) and numbering formats

V| Autonumber Format:
<&chapnums>.<n>.<n>.<n+>\t

(Numbering Properties dialog) based on RTL language

properties:
- Indic numeric Building Blocks: Ct
. Farsi numeric {FE“E! n+2 - D
<Farsiaz 2
- Farsi alpha <Farsi a=1> 2
. Hebrew numeric <Farsi a+>
: . <Hebrew n> Er
- Abjad numeric Sicbrew n=1> B o
. Alif Ba Ta numeric <Hebrew n+> Pe
<Hebrew a> y E
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NOTE: In this case, the
numbers displayed in your
document are based on the
Windows settings. This
indicates that if you change
your settings or send this
document to another user,
the numbers will display
accordingly

You may also use the third and fourth icon from the Direction Toolbar to convert selected numerals
from English to Indic (Arabic) and vice versa. This is highly useful when western telephone numbers

need to be converted to Arabic.
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For native authoring in RTL script, you can also use the Windows numbering settings to display

numbers in Arabic, Farsi or Hebrew.

¥ Region and Language

Fommast

|English (United States)

Date and time formats

Shor date: | My -
Long date: [adda, MMMM dd, yyyy v
Shont time [MM " -
Lang time: | hermeness tt v

-

| Sunday

Sher date 6/14/2015

Long date: Sunday, June 14, 2015
Shen time 1259 PM

Long time: 12:56:45 PM

| Additional settings..

[0 onkne b0 lesm sbout changng linguages snd regionasl formaks

Lok ][ Coce |

Spo

Mumbers | Currency | Tme | Date |

Erarnple
Pesitive:  123.456.789.00

Decumal symbol:

Ho. of diges after decimal:
Dygtt groupsng symbek:
gt groupang:

Nggatret sign symibal:
Neqgatree number format-
Drsgiley leading reros:

List separator

Lleasurement system:

|US.

Sandard dupts
Use natrve dhgs

[.\mﬂm

Dlationsl _________| ~|

numbers, currency, time, and date.

Click Reset to restore the system default settings for

[ Bee ]

Lo J[ conced || oot |

Arabic language support

For Arabic language, FrameMaker supports diacritics and standard ligature characters as shown in the

following figure:

Il
-
+
gy

I
s
+
Vv
i
R

7
w -

1’ &
Ou\.JJ

~
- &

s O

I
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|
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BENEFIT: FrameMaker has a
logical model for inheriting
language direction and

binding direction from specific,

non-generated documents.
This makes it easy for authors
to create books with mixed
content.

Book support

The direction of a book is based on the first non-generated chapter in the book. For example, if a
book contains some RTL chapters (documents) and some LTR chapters, the direction of the book is
based on the direction of the first chapter in the book.

If you create a book that contains chapters, FrameMaker defines the direction (RTL or LTR) for the
book. FrameMaker uses this direction information to define the direction of the lists and indexes
generated in the book.

Direction in generated book components

The direction of generated components such as indexes in a

FrammeMaker book is based on the direction of the book. See
Book support.

Schapter 1 title T
Tthis is heading 1 T
ihis 15 headi m

The direction of the mini-TOC of a document is based on the

Tihis 15 heading | - second instance 3
L | | B - e LRI TR o '\-.\.'.I:.' 1I -'.|.\_'.'1

direction the document. If all the content in a document is based
on an RTL language (using the paragraph designer), but the

direction of the document is LTR (Format > Document > L ":ffn_:’fj
Direction), the generated component will be Left-to-Right. 1 _~f;'J_f‘1

Ty .,,';1_'1
The illustration below shows an example of a Table of Contents €5 s )

generated from a book in which the first component determined
that the layout and direction should be RTL. Notice that the TOC o
works quite well displaying headlines of mixed content. PP B W

€Chapter 3 title &
YHeading 1 from chatper 3 §
SHeading 2 § _ e

Mixed TOC can be set up using references pages by following ways:
Usage of Tab Stops in the Generated Components
- By changing the direction of document from LTR to RTL, tab stops are automatically right aligned

Usage of Directional Markers in the definition of TOC Formats on the Reference Pages
+ Go to Reference Page of Respected TOC
+ Add LRM/RLM Directional Markers to tweak the direction of the Toc content

Swapping of Building blocks
- Go to Reference Page of Respected TOC
- Swap the building blocks to tweak the TOC content to flow as per RTL direction

Indexes

In the event of mixed content containing Arabic/Hebrew/English, index headers will automatically
will get configured, if user will adjust the language specific locale.

For Example:

- If Documents contain mixed content of English and Arabic, then user has to switch to Arabic locale
to get the index headers generated automatically.

- Ifuser is already working in Arabic locale, then no need to switch, and Index Headers will generated

correctly.
4 12



BENEFIT: FrameMaker allows
you to set cursor direction to
match the preference of the
user. This helps make
western, non-native Arabic
linguists more proficient
when doing post-translation
LQA (Linguistic Quality
Assurance) in RTL documents

BENEFIT: FrameMaker's easy,
one-step publishing to HTML5
and other online formats
empowers you to swiftly share
your translated Arabic and
Hebrew content with
consumers who have a variety
of mobile devices.

Editing: Cursor location and movement

By default, the cursor in an RTL enabled document moves Right-to-Left as your type. FrameMaker
now has system of a strong (primary) cursor and a weak (secondary) cursor. The strong cursor
indicates where an inserted character will be displayed when that character’s direction is the same as
the base direction of the text. The weak cursor shows where an inserted character will be displayed
when the character’s direction is the opposite of the base direction.

To change the movement behavior of the cursor:
1. Open the Preferences dialog (Choose Edit > Preferences).

2. In the Cursor Movement group, choose Logical to ensure that the key movement remains the
same as the logical order of inserted characters.

3. Choose Visual to ensure that the cursor movement is in the direction of the keys. For example, the
left key moves the cursor in the left direction.

For example, the left key moves the cursor in the left direction.

Publishing RTL content from FrameMaker

It is remarkably easy to publish RTL content from FrameMaker to the variety of on-line and print
formats that FrameMaker supports. The only additional steps required are slight adjustments in the
Publish layout editor to accommodate RTL direction and to specify an Arabic or Hebrew font.
Incidentally, Arabic and Hebrews fonts are included with the FrameMaker software installation.

You may wish to view a brief, instructive video on publishing Bi-directional content at:
http://adobe.ly/IHFgmmP

The image below shows a FrameMaker Arabic project published to HTMLS, resized in a browser to

emulate how it will look when displayed on a tablet. Note the "filter” icon in the right-hand pane,
which enables users to choose categories to customized the content which is displayed.
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Direction markers

The Insert Symbols button on the Quick Access toolbar now includes a set of new Directional
markers for use in mixed content:

[ =————

Bullet Character

Plus/Minus
Double Dagger

Ellipsis
En Dash
Em Dash

Register

Copyright
Trademark
Cent
Pound

Yen

Left-to-Right Mark
Right-to-Left Mark
Left-te-Right Embedding
Left-to-Right Overnide

Right-to-Left Embedding
Right-to-Left Override
Pop Directicnal Foermatting

For example, if your English language document contains the following URL:

http://www.adobe.com/

If you set the direction of the document to RTL, the URL displays as:

/http://www.adobe.com

NOTE: The trailing slash is now incorrectly placed at the start of the URL.
To place the slash again at the end of the URL:

1. Place the insertion point at the start of the URL.

2. In the Quick Access Toolbar, choose Symbols > Left-to-Right Mark.

14



Import and Export of mixed language content

The new FrameMaker Word import feature supports the import of documents (.doc, .docx. or .rtf)
containing RTL text.

You can also copy and paste RTL text to and from FrameMaker documents.

NOTE: When you import or copy RTL text into a FrameMaker document, you need to ensure the text
direction of the destination location (document, table, or paragraph) is set to RTL.

Dictionary support

The FrameMaker Spelling checker and hyphenation features also work for RTL content as they do for
LTR documents.

Arabic and Hebrew spelling preferences are now available in the Preferences dialog.

Preferences
El Ezlcrbal Dictionary Provider Settings
General Spelling Hunspell a
s Hyphenation Hunspell
Alerts 5 EAMpvies
- Pods Speliing Hunspel
- Launch Hyphenation Hunspell
- =~ Dropbox = GearapcKkm
- CMS Speliing Hunspel
- Spelling Hyphenation Hunspell
.. Spelling Options Speling Hunspell
. Simplified XML Hyphenation | Hunspel
- MathML = M
Spelling Hunspell
Hyphenation WinSoft
= A mll
Spelling Hunspell ‘_‘

15



BENEFIT: Chinese and Arabic
are increasingly becoming a
critical target language pair
in translation. This is
common in multi-national
construction and aerospace
projects in the Gulf Region.

Asian language support

FrameMaker now provides the option to choose Layout Engine at paragraph level by specifying
paragraph property Asian Composer.

While authoring, whenever you select a font that has double byte encoding or is a CJK (Chinese,
Japanese, Korean) language font in paragraph designer, the value of the ‘Use Asian composer’ flag

will be switched on.

Paragraph Designer

W A E Y
Paragraph Tag: Body _ 3 -
Westem/Asian Spacing (% of Fort Size):
Minimum: 0.0% Optimum: 25.0%
Madmum: 50.0%

Agian Character Spacing (% of Font Size):

Minimum: ©0.0% Optimum: 0.0%
Maximum: 10.0%
Asian Punctuation: | Squeeze as Necessary -

|Update All | | Reset || Apply |

An alert is displayed to the user with the following warning:
M

AsianComposer has been turned on for this paragraph (or paragraph
format) because the selection has double byte encoding.

I OK I

Do not show again

Notice that this alert has the "Do not show again” option in the lower left corner.

When a legacy document is opened, this property is switched on for all paragraphs containing double
byte font or Rubi text, so that the Asian layout engine will be used for those paragraphs.

Since the two layout engines have different capabilities, scenarios may arise wherein neither engine
can handle the text correctly. For example, if a paragraph contains both Rubi and Arabic text, neither
engine can handle both of these correctly.

You can also set FrameMaker to automatically switch to Asian language support when double byte
content is detected.
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Edit->Preferences, select the Alerts category and tick the box next to "Automatically Switch to Asian
Composer” as indicated in the screen capture below.

ﬁ".'.'r-"!"'*“'““"; — e — — — - e —— - — "-III
= Glohal ¥ Show wamings while cleaning history
. Genernl ) Once for every history cleaning command
Inleilace @ Mways
- Pods ' File contains unresolved cross{eterences
. i-Launch || Opening an old relcoac document
P = 7 File contains unavalable forts
- CMS File cortains una
- Spelling || Dicdivnsany provides misnalud
Simplified XML |/ | File 1= pportad in moda
. XML
L MathML [/ File unsupported in view
(V| Atomatically awitch to Asian Compoacr
|/ Show alerts on session restore
[ Show Contextual Tips [ Reset Conteaxdua Tps |
OK | [ Cancel

RTL support in structured documents

BENEFIT: FrameMaker You can now author your FrameMaker XML or structured FrameMaker documents in RTL languages.

FERNICES IS DESCmmGiecey There are multiple ways to use the direction property in XML/Structured docs:

access' XML Authoring

solution for authoring in or 1. Map the property to attribute

translating to Arabic and 2. EDD - Specify direction in pgf style which is applied on an element.
Hebrew. This is a major 3. EDD - Directly specify the direction property in an Element. This can be found under paragraph
advance for tech dociin properties.

these languages. o _ S _
If you change the direction attribute of an element, the direction is propagated to all child elements

whose direction is set to default or inherit.

To change the direction of a structured element, open the Attributes editor (Element > Edit
Attributes) and choose the appropriate direction attribute as indicated in the screen capture below.

I avoote |

Element: shortdesc

Attribute Name Value
audience <no value:
base <no value:
class <no value:
conaction <no value>
conkeyref <no value:
conref <no value>
conrefend <no value:

id

importance

otherprops

outputclass dita-use-conref{arget
platform <no value:>

product
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BENEFIT: FrameMaker's
support for RTL within XML
is a major benefit for large
projects with high-volume,
technical content that must
be translated into Arabic.
FrameMaker's unique,
simplified XML Authoring
tools and automated
formatting potentially
provided by an EDD can
shave hundreds of hours
from translation projects.

Once you have set an elements dir attribute to ltr, you will see the XML code for that attribute if you
view your content with FrameMaker's XML Code View. In this case, it displays on line 7.

6 Vew INT OF Wi ey - =~

e L R _*I'l

GRAX (0" RPEI L
l =l<topic id = "1d1557L50K0AU" dir = "rtl"
8 xmlns:ditaarch = "http://dita.oasis-open.org/a
9 <title>title</title>

10 <shortdesc></shortdesc>

S <prolog>

12 <author></author>

13 </prolog>

= <body>

1S <p>first para</p>

16 <P >yunoiioyiodio.< /P>

3 ) </body>

If you enable element boundaries in the WYSIWYG view, the tags will display in the RTL direction, as
shown below.

--------------------------------------------------------------------------------------------------------------------------------------------

tide /) Aady )y titel=] { topic =

|ﬂ'|mdm / :’iig_,gq;-wim{: ﬂlﬂﬂ.dﬁﬂ:lzﬂ

\prolog /) [author /) :i:; . Autiior {_author =] {_prolog =}:

topic 1) [body 1) (D10 x4 o) ses (P (TBOdy =]

Notice that the start tag is to the right of the text, and the end tag is to the left of the element.

Define direction in structured applications

FrameMaker provides out-of-the-box direction support for DITA structured applications. However,
you can create your own structured application with direction support in your EDD (Element
Definition Document.)

FrameMaker now includes a new direction property, which you can use in your structured
application.

For example, you can create a read-write rule such as the following to specify that the FrameMaker
direction property maps to the structured document dir attribute.

attribute “dir"{ is fm attribute; is fm property direction;}

When you author in a topic based on the structured application, to change the direction of an
element, you can set the following values for the dir attribute:

- rtl

- ltr

- inherit
When a new element is added to the topic, its default direction will be Inherit.

If you change the direction attribute of a element in a non-DITA XML file, the direction of the contents
does not immediately change. You will need to close and open the XML file to reflect the changes.

The direction from EDD will map to the direction property of paragraph format or table format and

not the Element. This will supersede the direction specified in the attribute. o



The direction property is supported for the following elements:

- Paragraph

- Table

- Footnotes

- Graphic

FrameMaker now includes an Asian Composer construct in the EDD for paragraph properties. The

property defines the layout engine the element will pick. For more details, see Asian language
support.

If you save the topic as a MIF file, the direction attribute is written to the <pgfdir> and <elemdir> tags.

RTL support in FDK / ExtendScript

RTL documents or contents (paragraphs and tables) support all the available programming (FDK) and
scripting (ESTK) features as they are supported in LTR documents.

- The direction property for different objects (Document, Paragraph, Flow, Table, and Text line) is
available in latest FDK.

« There is FDK/ Extendscript support for RTL features as they are supported in LTR.

- The direction property for different objects (Document, Paragraph, Flow, Table, and Text line) is
available in latest FDK and Extendscript

« Numbering building block for RTL scripts such as Indic, Farsi and Hebrew has been added.

Further resources to explore RTL publishing in FrameMaker

The following are some online documentation resources you will find helpful.

- FrameMaker 2015 User Guide
http://www.adobe.com/go/learn_fm_ug_en

- FrameMaker 2015 Getting Started Guide
www.adobe.com/go/learn fm 2015 rev guide en
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Key benefits from Arabic/Hebrew publishing in FrameMaker

FrameMaker's powerful, yet highly accessible authoring tools, with or without XML, are a major

advance in RTL publishing in Arabic and Hebrew. Previously, most projects translated into Arabic

were finalized in the post-translation DTP phase with highly manual processes.

The few tools that have previously been used for publishing in Arabic and Hebrew were either highly

complex, inaccessible XML-only based solutions, or design tools that were never intended for

high-volume, demanding technical content.

FrameMaker's support of RTL languages offers the following key benefits:

You may specify language direction at the document level, letting all other objects (paragraph,
tables, etc.) inherit their direction from one source. This makes template (and XML application)
formatting extremely easy to maintain.

Since tables will reverse order automatically, no special steps are necessary to prepare for
translation.

The tools needed to specify a "fixed language direction” for paragraphs, tables and text flows are
logical and easy to find.

When FrameMaker documents, books or DITAmaps are saved to PDF, the binding property is
automatically set to "Right Edge" if a RTL document is involved.

All key ingredients for Arabic support are built-in to FrameMaker, from diacritics and ligatures to
alternate forms of numbering. Language and numbering may be easily specified in the template

FrameMaker makes XML and DITA truly accessible to a broad audience publishing for Arabic and
Hebrew consumers. No other product has simplified XML authoring as dramatically as
FrameMaker.

FrameMaker is widely used in the translation industry and there is a large pool of talent who can
master these new LTR capabilities with a minimal investment of time.

The one-step process for reformatting translated Arabic content into the right layout and format
eliminates endless hours of billable time from localization projects.

The ability to publish western LTR languages, along with Hebrew or Arabic RTL content, mixed
with Asian CJK content is a major achievement. Due to the extensive commerce between China
and some Arabic speaking nations, Asian language support within RTL FrameMaker files is of great
strategic value.

When you author your content in FrameMaker 2015, you are “future-proofing” your content in two

essential ways:

A. your content can be easily transformed to appropriate formatting for Arabic after translation and

B. regular, unstructured documents in FrameMaker can be easily converted to XML to ensure that

your content is always up-to-date.

Adobe, the Adobe logo, and FrameMaker are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States
and/or other countries. All other trademarks are the property of their respective owners.
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