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In a 2020 Adobe survey, we found that 56% of content professionals have used 
Microsoft© Word for authoring at some point in time. While Word is widely used 
globally, its capability is limited as compared to a specialized authoring tool like 
Adobe RoboHelp, when used for technical documentation. While there are some 
similarities between RoboHelp and Word (like word processing features, ability 
to generate a text or PDF output, add graphics, and create templates and styles), 
the commonalities end at the basics. One might think of Word as a launchpad for 
RoboHelp. Word is helpful for everyday content and a tool for content contributors. 
As a Help Authoring Tool (HAT), RoboHelp is designed to deliver help, procedures, 
and knowledge base content on many platforms and outlets. Over the years, as 
technology has advanced and the end user’s need for instant information has 
accelerated, unique needs such as publishing to self-service content platforms, are 
currently being addressed by RoboHelp. 

Understanding the core differences between RoboHelp and Word helps identify the 
use cases for both.
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The beginning
Microsoft© released Word as a word processor in 1983. It is primarily used for 
everyday content and documents. It is a good application to quickly and easily create 
letters, short documents, proposals, small guides, and similar content, which can then 
be exported as PDF files for publishing.

Adobe RoboHelp enables authors to create advanced end-user documentation and 
help content, which can be published across channels, formats, and languages to 
address global customers. We will explore what RoboHelp can do, in detail, in the 
upcoming sections. Here are some of the core strengths of Adobe RoboHelp:

End-users can consume the published content on multiple devices and		
screen sizes

Allow users to curate content for their particular needs

Empower users to interact with the content through an easy-to-use and 	
branded web-based layout
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Deliver bite-sized answers to questions in the form of Microcontent and chatbots 
integrated directly into the help system 

Ensure content consistency using variables, snippets, glossary, and topic reuse

Provide unique features such as drop-downs and expandable text, bookmarks 	
for favorite topics, topic navigation, and browse sequences

Facilitate role-based content personalization via Dynamic Content Filters;
Enable superior navigation through predictive search and a customized index

Accommodate large libraries by publishing to RoboHelp Server or a merged 	 	
output

What can you create with Adobe RoboHelp?
Suppose you create enterprise policies and procedures, user guides, software manuals, 
or help systems for large or complex audiences. In that case, RoboHelp has the 
features and functionalities to curate content based on your end user’s unique needs. 
Here are some examples of use cases where Adobe RoboHelp is well suited:

Call center / Customer service help
For call centers, customer service departments, or other high-volume groups, 
help must be highly consumable to be valuable. Correct information must be 
available to the agent quickly, the search must provide relevant results, and 
callers must receive correct answers fast. Agents are evaluated by call times 
(TAT – Turn Around Time), providing accurate information, and customer service. 
Quick access to correct answers improves the agent’s performance and increases 
customer satisfaction.

Advanced search, Microcontent, virtual assistance (chatbots), indexes, 
glossaries, topic navigation, and modern layouts are features available in 
RoboHelp that support this use case.
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Regulatory manuals
Highly regulated industries like government, finance, healthcare, and aerospace 
and defense may consider the integrity of the documentation to be its most 
important value. Are policies and procedures relating to regulations consistent 
and current? Are agency audits satisfactory after reviewing procedures? Can the 
content be delivered as a PDF to external regulators and in a web-based,
user-friendly format to internal employees?

Customer-facing content
Help systems that are public-facing need to be visually appealing, well-branded, 
searchable, organized, and viewable on various devices.

Master Pages and Style Sheets for consistency, a well-defined glossary, a 
collaborative review and approval process, and omnichannel publishing are 
important ways RoboHelp can meet these end-user needs.

Language translation, variables, reusable content (snippets), and dynamic 
content filters are examples of RoboHelp features valuable to this type of 
deliverable.

Customized skins, Frameless layouts, standardized formatting through 
master pages and style sheets are essential RoboHelp elements.

User guides
User guides created to accompany software releases over a wide distribution 
channel might require variations for different users. Does the content need to be 
translated into multiple languages? Are there geographic, legal, or other factors 
that require multiple versions of the help system to be delivered?



Transitioning from Word to RoboHelp

Signs that it might be time to change
If you are currently authoring large manuals in Word, here are some signs that may 
prompt you to consider changing software platforms:
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Your documents have many pages making updates cumbersome

You need to generate numerous variants of your documents to accommodate 
multiple audiences and multiple purposes

Tracking comments and approvals of multiple reviewers have become a challenge

Content is viewed on multiple devices but is not responding appropriately to 
‘automagically’ adjust to the different screen sizes

End-user navigation is limited

Search is not delivering the best results

Customers are requesting features that are not available in Word

Internal employee manuals
Internal-facing content like policy and procedure manuals often serves the 
dual purpose of employee communications and training. Multiple authors 
often support content creation. The content is enriched with flowcharts and 
illustrations and reaches large audiences. Understanding how a large,
multi-faceted audience uses the content is essential.

Giving readers the ability to view or hide ancillary information with drop-downs 
and expanding text is crucial. Adobe RoboHelp Server provides the authoring 
team with analytics, usage statistics, project merging, and the ability to define 
access groups. Utilizing the collaborative review feature enables updates to be 
made more quickly and edits centralized.



Migrating Word documents to RoboHelp
Adobe RoboHelp makes it easy to migrate even long and complex Word documents. 
You can fine-tune the import process, map styles, create new topics based on 
headings, and more. Once the content is in RoboHelp, improve the user experience 
by organizing smaller topics and adding content navigation. Easily customize the web 
layout to match your corporate design with an intuitive WYSIWYG skin designer.
And, if needed, output the refined content from RoboHelp back into a Word 
document. RoboHelp guides you through the process of converting legacy content 
through easy-to-follow import settings.
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Feature comparison

Authoring experience
The following are overall features that distinguish RoboHelp and Word from an 
authoring perspective. We will dive deeper into editing and publishing functions in 
subsequent comparisons.

Feature RoboHelp Word

User 
Interface

Work intuitively with a modern,
task-oriented user interface that gives 
contextual access to features via three 
panels — Authoring, Review and 
Output.

Features related to a specific task, such 
as topic authoring, graphic editing, or 
spell check, appear as needed, reducing 
clutter.

Functions are accessible 
via a traditional ribbon 
interface that has some 
level of customizability.

Workflow Author with an easy workflow
designed to follow a natural left-to-right 
progression for all tasks.

Authoring in Word is more 
free form, with features 
made accessible either
via the top ribbon or by
right-clicking.

Reporting Track all aspects of a project with over 
20 reports, publishable to Excel and PDF.

Track all aspects of a 
project with over 20 
reports, publishable to 
Excel and PDF.

Collaboration 
between 
authors

Enable seamless collaboration and 
version control for teams through built-
in connectors for SharePoint Online, 
Azure DevOps, and Git.

Authors can share 
documents through the 
cloud, but version control 
is not available.
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Feature RoboHelp Word

Migration of 
existing Word 
documents

Import Word documents into RoboHelp 
and retain existing formatting by 
mapping styles using an easy-to-use 
conversion tool.

Not applicable.

Importing 
other files

Add files created in other applications, 
such as Adobe FrameMaker, Microsoft© 
PowerPoint, Excel, and PDF to a 
RoboHelp project.

Some files can be utilized 
within Word, such as 
images or online videos, 
but functionality is 
limited.

Linking to 
and from 
Word or 
FrameMaker 
files

Link Word or FrameMaker documents to 
a RoboHelp project for seamless syncing 
when changes are made to them. Use it 
in situations where content is managed 
by another entity, but relevant to the 
RoboHelp project.

No comparable feature

Collaborative 
Review

Use the Review feature to generate 
an online link of the document to be 
reviewed and share them with team 
members for collaborative feedback.

Word documents can be 
shared, and reviewers 
can use track changes to 
red-line and comment on 
documents.

Layout 
customization

Customize layouts as per the needs of 
the brand with a powerful Skin Editor 
that provides hundreds of options to 
achieve the expected result.

Customization is limited 
to fonts, colors, and 
themes under the Design 
tab.



Topic editing

The author’s experience when editing content is similar in Word and RoboHelp. 
However, there are also some unique differences as described in this section.
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Feature RoboHelp Word

Topic 
authoring

Access all functions related to topic 
authoring in a single area.

Tasks for page authoring 
are in various places in 
the top toolbar, including 
Home, Insert, Layout, and 
others.

Topic 
information

See all information regarding a topic 
(general information, topic information, 
metadata, styles) in an embedded panel 
as you edit.

Information is available 
at the document level 
through File>Info, or from 
the Home tab for styles, or 
other tabs for layout and 
design.

Styles Define styles with industry-standard 
Cascading Style Sheets (CSS), including 
headings, table styles, lists, hyperlinks, 
and other styles related to RoboHelp 
authoring (glossary text, drop-downs, 
expanding text, breadcrumbs, topic 
TOCs). Add embellishments such as 
pseudo styles and twisties to enhance 
the user’s interaction and understanding 
of the content.

Styles are available from 
the Home tab and focus 
primarily on paragraph, 
heading, lists, and table 
styles. Templates can be 
created based on styles 
and saved in a .dot file 
to be used for other 
documents.

Inline styles See inline style options in the General 
tab. Add attributes and apply styling to 
a specific element (image, text, video, 
table, header, link) by simply selecting it 
to see the options available.

Styles such as bold, italic, 
underline, shading, colors, 
fonts can be applied from 
the Home tab from the 
top ribbon.



10

Feature RoboHelp Word

Inline styling is applied in 
general to an item that is 
selected (primarily text 
styling). Table design and 
styling is done through 
the Table Tools tab. Other 
styles can be applied 
through a right-click.

Topic status Customize and apply status labels to 
topics (draft, in review, approved). 
Generate topic status reports to facilitate 
reviews and manage content.

No comparable 
functionality.

Table styles Define table styles in the style sheet. 
Create table templates for consistent 
use. Define table formatting for the 
entire table, heading row, and odd/even 
rows and columns. Apply specific styles 
to cells, fonts, alignment, shading, and 
other features. Customize cell padding, 
alignment, borders, layout, positioning, 
and more.

Table styles can be 
created through the Styles 
tab. Table properties, 
shading, font, paragraph 
styles, etc. can be applied 
in general.

Inline table 
styles

Apply inline styles to tables from the 
General tab after selecting it. Modify the 
table width, columns, rows, captions, 
and apply templates as desired.

Word provides table 
formatting through the 
Table Tools tab (design 
and layout). Templates 
are provided, and 
customization in terms 
of borders, shading, and 
fonts can be applied from 
the toolbar.

Drop-down
and 
expanding 
text

Place ancillary information as
drop-down text or expandable text that 
can be collapsed and expanded by the 
user (as an alternative to footnotes). 

No comparable 
functionality.
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Feature RoboHelp Word

Snippets Create content as a snippet (reusable 
text) and place it in multiple topics, 
eliminating the need to retype the 
same content. Automatically update 
all instances where the snippet is used 
when the source snippet is edited.

No comparable feature – 
content would need to be 
replicated in all instances. 

Variables Curate content for different audiences 
and uses using variables. Use variables 
to interchange terminology for unique 
outputs. For example, use a variable 
to create state-specific versions of 
your content to swap the state name 
depending on the audience. Instead of 
creating duplicate content for a specific 
audience, repurpose the same content 
using variables.

No comparable
feature – duplicate sets of 
content would need to be 
created or Find / Replace-
generated.

Feature RoboHelp Word

Spell check 
and find and 
replace

Apply spell check and find and replace 
to the current topic, all topics, or all 
project files. This includes master pages 
and other files.

Spell check is limited to 
the open document.

Drag and 
drop

Utilize the drag and drop method for 
hyperlinks, reusable text, glossary terms, 
condition tags, TOC, index and See Also 
links, thus reducing authoring time.

Links are manually 
added. Drag and drop 
functionality is not 
applicable to Word 
authoring.

Content reuse

RoboHelp allows you to reuse topics or parts of a topic. Authors do not need to create 
reusable content from scratch thereby save authoring time and translation costs; 
something that Word cannot offer.
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Feature RoboHelp Word

Glossary Use glossaries to define terms and 
acronyms, and their definitions can 
be expanded within the topic content. 
Publish a global glossary with the 
output. The glossary keeps terminology 
consistent and definitions available 
when needed. 

Glossaries are often built 
as separate stand-alone 
documents or as an 
appendix to a document. 
The glossary is referred 
to, but not integrated into, 
the output.

Topic reuse Single-source and reuse topics instead of 
duplicating, in more than one instance. 
For example, using the same topic by 
linking it in multiple places for reuse.

No comparable feature. 
Information can be 
duplicated through
copy / paste, but not 
duplicated single-sourced.

Condition 
expressions

Tag content within a topic or at the topic 
or chapter/folder level. E.g., Authors 
can create a conditional expression to 
exclude content from publishing (Do 
Not Publish) or make content
interest-based filterable for the end-user.

No comparable feature.

Information would need 
to be customized in 
different documents.

Multiple 
TOCs and 
glossaries

Add multiple TOCs and glossaries to a 
project in RoboHelp. E.g., deliver a policy 
and procedure manual as a training 
workbook with exercises by using a 
separate and unique TOC. Once the TOC 
is created, the shared topics are in sync 
and can be organized accordingly. The 
author can simply select the applicable 
TOC when generating the output. The 
same workflow applies to glossaries.

No comparable feature. 

The information would 
need to be rebuild in 
different documents.

Microcontent Create Microcontent to deliver small 
information units to end-users. Deliver 
Microcontent in a frameless layout. e.g., 
in the form of FAQs and MicroHelp. The 
author creates an intent (a question) and 
a corresponding response to the intent, 
which is added by selecting relevant text 
within a topic. 

No comparable feature. 
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Navigation

End-users prefer Help content to be precise, easily searchable, and quickly findable 
during the need of the hour. RoboHelp offers easy options to navigate across your 
help content, unlike Word.

Feature RoboHelp Word

Table of 
Contents

Create unique tables of contents for their 
output. TOC pages do not have to be 
the same as the topic names, and they 
are not generated at the style level (see 
Topic TOC).  Add bookmarked content 
within a topic, URLs, and other files to a 
TOC, making it a rich navigational tool.

TOCs can be auto-
generated from the 
References tab. TOC 
incorporates heading 
references from the 
document as established 
by the author. TOCs 
cannot include external 
references.  

Topic TOC Authors can add and stylize a Topic 
TOC (also known as mini-TOC) into 
master pages or topics to assist a user 
in navigating through topics with 
several sections. The heading styles 
are automatically added to the Topic 
TOC. The TOC automatically updates if 
headings change.

This feature is part and 
parcel of the overall TOC 
in Word. Headings are 
added to the document 
TOC at the level defined 
by the author. Manual 
hyperlinks can be added 
to the beginning of a 
Word document.

Index Develop author-defined indexes by 
creating keywords and associating topics 
with the keywords. Create
cross-references in the same manner. 
Review keywords through a report or 
the topic properties. The index is used 
globally in the help system in the same 
manner as the TOC and glossary.

Indexes can be created 
from the References tab 
by marking entries in text 
and then inserting an 
index. The index is specific 
to the document.
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Feature RoboHelp Word

Search Enhance the user’s ability to obtain 
relevant results with Frameless 
and Responsive outputs that utilize 
predictive search. Add search keywords 
and search synonyms to help the user 
even when the exact search term they 
enter is not in the help system. Add stop 
words to remove irrelevant results.

A Word document can 
be searched through 
the “Find” function or, 
if published as a PDF, 
through the Find Text tool.

Browse 
sequences

Add a browse sequence to a collective 
group of topics that the end-user should 
navigate in a certain order or workflow. 
A browse sequence provides an extra 
navigational utility in the web-based 
output.

No comparable feature.

Favorites Generate a Frameless or Responsive 
layout so the end-user can add topics 
to their Favorites tab, thus helping 
them quickly refer to frequently visited 
content.

Bookmarks can be added 
in PDF outputs which can 
assist the user in tagging 
content they would like 
to revisit, but it is more 
limited than adding 
favorites to a favorites 
drop-down.

Content 
filters

Develop content filters using condition 
tags to isolate content for different 
users or purposes (geographic region, 
position, product, department). In the 
published output, the end-user can filter 
the content for relevant information 
using Dynamic Content Filters.

No comparable feature.

Landing / 
Home Pages

Create portal-like, customizable Home 
Pages with Frameless and Responsive 
skins. Home pages act as the “entry 
point” for the help system. End-users 
access MicroHelp and search through 
the help portal from the Home Page.

Word documents may 
have title or introductory 
pages to help a user 
understand the larger 
document, with manual 
links to specific pages.
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Feature RoboHelp Word

Style sheets Use Cascading Style Sheets (CSS) to 
maintain the format of the content 
in RoboHelp. Available in an easily 
identifiable Assets folder, adapt the style 
sheets to your company’s brand. Use the 
built-in UI editor for style sheets to easily 
incorporate changes or design new ones 
without needing to know how to declare 
CSS syntaxes. Choose colors that match 
an organization’s website using the 
color pick utility. Create unique topics by 
making multiple style sheets in a single 
project.

Styles are created from 
the Home tab. Custom 
colors can be created 
using RGB or HSL 
color models numbers. 
Additional styling can be 
made through the Format 
menu for the selected 
style.

Master pages Use master pages to act as templates 
for content, with headers and footers 
that include the company’s logo and 
other important information (such as a 
confidentiality clause). Also use master 
pages as style guides for authors to 
develop topic content with consistent 
heading labels and wording.

Word has themes that can 
be applied and modified 
under the Design tab. 
Watermarks, page colors 
and backgrounds can 
also be applied under this 
menu. Templates in Word 
are focused on styles.

Skins Customize Frameless skins to reflect a 
brand’s colors, logos, images, fonts, and 
other elements. Attain a comprehensive 
web-based layout by using customized 
labels, layouts, background images, 
themes, and other output settings.

Word design elements are 
based on themes applied 
from the Design tab which 
can be customized. Cover 
pages can be added for 
additional information.

Branded layouts

Documentation and help systems should reflect the organization’s corporate design 
in terms of fonts, colors, logo usage, and general look and feel. This section describes 
the features available to enhance the branding of your help content.
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Feature RoboHelp Word

Available 
outputs

Publish content as Content Only 
(XML), eBook (Kindle), Frameless and 
Responsive HTML5 (web), Mobile 
App (phone), Microcontent, Chatbot, 
Microsoft© HTML help (.chm), 
SalesForce, ZenDesk, Zoho, ServiceNow, 
PDF and Word. 

Provides the ability to 
generate .pdf, .rtf, .txt, 
.mhtml outputs.

Publishing Leverage direct, single-click publishing 
of output to RoboHelp Server, 
SharePoint Online, SalesForce, ZenDesk, 
Zoho, ServiceNow, FTP / SFTP and / or 
file system.

Word, PDF, or single 
HTML file outputs can be 
published to shared drive, 
SharePoint, FTP / SFTP, or 
other specified location.  

Merging 
projects

Merge multiple projects into a 
single master project, delivering a 
unified knowledge management 
experience. Merging projects allows 
you to effortlessly maintain smaller, 
manageable projects based on product 
family, categories, or modules. Table of 
contents, indexes, glossaries, dynamic 
content filters, and condition settings are 
all identified during output generation 
ensuring the delivery of a perfectly 
stable help system.

Multiple Word documents 
can be merged, but 
the process can be 
cumbersome, and errors 
can easily occur. Large, 
merged documents can 
be unstable.

Publishing, Translation, Hosting and Analytics

All content teams need to publish content irrespective of the tool they use to author. 
And they want to understand how their content is performing. You can publish to a 
range of publishing formats including Responsive HTML, PDF, Knowledge bases and 
more, with RoboHelp. Omnichannel publishing is something where Word takes a step 
back, especially when it comes to technical documentation.
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Feature RoboHelp Word

RoboHelp 
Server

RoboHelp Server is a companion 
product of RoboHelp for hosting 
Responsive HTML5 and Frameless 
outputs. You can define user groups 
with varying degrees of access levels 
and merge content from several projects 
instantaneously without performing a 
project merge in RoboHelp. Analytics 
based on user consumption patterns, 
keywords, or mode ensures that you 
keep a pulse on your end-users. You 
are also guaranteed a quick turnaround 
time for amendments or modifications 
required.

No comparable feature

Translation RoboHelp provides you with a handy 
dashboard to manage translated 
projects. Export content to XLIFF for 
manual translation. Once translated, 
import it into RoboHelp to create a 
translated version of the original project.
For automated translation, translation 
service providers integrate with 
RoboHelp to translate content via APIs. 
When complete, automatically import 
back the translated content.

No comparable feature.



© 2022 Adobe. All rights reserved.

Adobe, the Adobe logo, RoboHelp, and RoboHelp Server are either registered trademarks or 
trademarks of Adobe in the United States and/or other countries. 

Adobe Systems Incorporated
345 Park Avenue
San Jose, CA 95110-2704
USA
www.adobe.com

About Adobe RoboHelp

Try nowVisit website

techcomm@adobe.comFor any queries, write to us at

Create and deliver exceptional Help, policy and procedure, and knowledge base 
content with Adobe RoboHelp, now also on Mac. Author Microcontent to fuel 
chatbots, featured snippets in search results, and more. Create media-rich experiences 
using HTML5 and CSS3. Make collaboration seamless using web-based review 
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