
Acrobat XI Pro PDF Accessibility Repair Workflow
Analyze PDF files and add enhancements to make  
documents accessible to all users
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This document describes the process for making PDF documents accessible. Whenever 
possible, accessibility should be incorporated directly into the document using the 
application that created it. When accessibility is incorporated directly into the source 
document, less repair work will be required in Adobe Acrobat. This is very important when 
the PDF must be regenerated based on changes in the source file. If changes are only made 
in the PDF and not in the source file, accessibility work will need to be done each time the 
document is updated.

Adobe Acrobat XI Pro contains a Make Accessible Wizard that guides the user through the 
basic steps found in this document. This tutorial can be used with or without the wizard.

The process of making existing PDF files accessible consists of a few basic steps:

1.	 Examine the PDF document (See “Step 1: Examine the PDF File” on 
page 2).

2.	 Add document properties and interactive features to the PDF such 
as links and bookmarks and set the document open settings and 
security so that it does not interfere with assistive technology (See 
“Step 2: Add Document Properties and Interactive Features” on page 
2).

3.	 Determine if the PDF originated from a scan. If so, perform Optical 
Character Recognition (OCR) using the OCR Text Recognition 
command in Adobe Acrobat XI (See “Step 3: Perform OCR on Scanned 
Document” on page 8) .

4.	 If the PDF is intended to be an interactive document, add fillable 
form fields and buttons with labels and accessible names. Set the 
tab order for the form fields, provide instructions, ensure proper 
keyboard focus, and ensure any error handling is accessible (See 
“Step 4: Add Form Fields and Set the Tab Order” on page 12) . If the 
PDF document does not have interactive form fields and buttons, 
then skip to Step 5.

5.	 Set the document’s language.

6.	 Add tags to the PDF file if it has not been tagged. Tagging should be 
performed at this step in the workflow to ensure that any elements 
that were added during steps 1 through 4 are included in the 
document’s structure. (See “Step 6: Add Tags to the Document” on 
page 13).

7.	 Determine if the PDF file has been properly tagged. Verify tagged 
elements are properly sequenced and applied. For example, is a first-
level heading tagged as an H1 and not an H3? (See “Step 7: Examine 
and Repair the Tag Structure” on page 23). 

8.	 Add Alternative Text. Add informative and concise alternative text 
and descriptions for all non-text elements. 
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9.	 Check the document with the Acrobat Accessibility Checker. Refer 
to the results of the Accessibility Checker and Report and use the 
recommendations to make any necessary changes. Repeat this process 
until the checker indicates no problems are found in the document (See 
“Step 9: Use the Accessibility Checker to Evaluate the PDF File” on page 
49).

Note: 	 These steps are presented in an order that suits most needs most of the time. It may 
be necessary to perform them in a different order for a particular workflow. You may 
need to repeat some steps to achieve the desired result. In all cases, examine the 
document first, determine its intended purpose, and use that analysis to guide the 
workflow.

Step 1: Examine the PDF File
When a PDF file is opened in Adobe Acrobat XI Pro, briefly analyze the document and note its 
characteristics. Does the document have:

•	 a small number of pages or many pages

•	 scanned pages

•	 text, links, graphics or a mixture of elements

•	 headings and/or lists

•	 data tables

•	 mathematical formulas, subscripts, superscripts, or other font attributes

•	 form fields

•	 annotations such as comments, revision marks, etc.

•	 multiple columns of information

•	 complex layouts and articles that span different pages

•	 multimedia

•	 multiple languages

The greater number of document features and complex layouts, the more time it may require to 
make the document accessible.

Step 2: Add Document Properties and Interactive Features
There are several document properties that must be set to ensure the document is accessible. In 
addition, interactive features such as links and bookmarks can be added at this step. Properties 
to set include

•	 document title

•	 document subject

•	 document author

•	 document keywords

•	 security settings that are compatible with assistive technology
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Document Title, Subject, Author, and Keywords

Specifying the document title ensures there is a programmatic method to identify the document 
and may help provide metadata to searches performed by users of assistive technology. 
A document subject and author provide additional description about the document. The 
document keywords field allows metadata to be provided about the document, which makes it 
easier to find.

To set the document properties:

•	 Open the Document Properties dialog: Choose File > Properties

•	 Activate the Make Accessible Wizard—the Add Document Description 
command is the first item to run

Set the following properties:

1.	 Enter a title in Document Title area of the Description tab. 

2.	 Enter a subject

3.	 Enter an author

4.	 Enter keywords that may be used to improve the document’s searchability

5.	 Select the OK button
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Figure 1.  The Description Dialog Generated by the Make Accessible Wizard

Set Security That Permits Accessibility

It is important to ensure the Acrobat XI security settings permit access to the document by 
assistive technology. Verify that the Acrobat XI or Adobe Reader XI security settings do not 
prohibit access by assistive technology by checking the Security tab of the Document Properties 
dialog.

1.	 Open the Document Properties dialog: Select File > Properties

2.	 Select the Security tab of the Document Properties dialog (See “Figure 2. 
Security Tab Location in Document Properties Dialog” on page 5)
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Figure 2.  Security Tab Location in Document Properties Dialog

3.	 Determine the security level needed. If security is not required, security 
need not be set—by default this will allow assistive technologies to access 
the document content.

4.	 Set security. When security is required, select “Password Security” as the 
security method from the drop-down list. In the Permissions section of 
the Password Security Settings dialog, verify that the box labeled “Enable 
text access for screen reader devices for the visually impaired” is checked. 
This is the default setting for Adobe Acrobat XI and Adobe Reader XI (See 
“Figure 3. Password Security Settings” on page 6).
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Figure 3.  Password Security Settings

Create Accessible Links

Links allow users to quickly move to another part of a document, to related information in a 
different document, or to a desired website.

For URLs to be accessible to users of screen readers, they must be converted to active links and 
be correctly tagged in the PDF file. 

Note: 	 If the document was tagged during conversion from an authoring application to 
Adobe PDF, the links and URLs in the document are most likely already active 
and included in the tag tree and thus accessible to users of assistive technology. 
The links should be verified and any additional links added to the document must 
follow this process to ensure access. 

Acrobat provides several ways to create active links for text, objects, and URLs in a PDF 
document: 

•	 Link tool

•	 Create from URLs in document

•	 Create Link Command

These methods differ in how they affect the tag tree. The best way to create accessible links 
is with the Create Link command. This command adds the proper tags, including a special 
LINK OBJR tag which can not directly be entered into the tag tree. Without this link object tag, 
keyboard-only users and users of screen readers will not have access to the link. Although it is 
necessary to create active links one by one, using the Create Link command provides the fastest 
results and the least amount of follow-up work to make the links accessible to screen readers 
and keyboard-only users. Intra-document links in Acrobat only move and scroll to a particular 
area of a page and thus cannot be used to move to a specific line, word, or paragraph on a page. 
Bookmarks, however, can set focus on a specific tag, allowing assistive technology to move to a 
particular word, line, or paragraph within a page. You may also edit the tag tree to add additional 
actual text to the new links to ensure they are unique and descriptive.
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Note: 	 Automatically detected URLs in PDF documents are not accessible. Avoid using 
the Create Links from URLs command (Tools> Document Processing > Create 
Links from URLs.

Note: 	 The General Preference option, “Basic tools: Create Links from URLs” also does 
not allow users of the keyboard-only or screen readers to access a link. This 
option must not be relied upon for ensuring access to links.

Note: 	 Creating links with Acrobat XI Standard does not generate any tags for the 
links.

Perform the following steps to make links active and add them to the tag tree:

1.	 Activate the Selection tool for text and images

2.	 Select the text or object you want to link. 

3.	 Right-click or press the applications key (Windows) on the selection, and 
choose Create Link from the context menu. 

4.	 In the Create Link dialog box, select the appropriate options, and then 
follow the on-screen instructions to specify a URL, page view, or file as the 
link target. 

By default, the selected text for each link becomes the link text. If the document is tagged, the 
proper link tags will be added in the appropriate place in the structure tree. If the document is 
not yet tagged, the appropriate link tags will be generated when the document is tagged.

After all the links are added, the tag tree can be edited (refer to step 6 on page 23) to add 
additional text descriptions to the links via the “actual text” property. Adding actual text can help 
clarify the link’s purpose and make the link text unique.

Add Bookmarks

A bookmark is a type of link with representative text in the Bookmarks panel in the navigation 
pane. Each bookmark goes to a different view, page, or structural element in the document. 
Bookmarks can be generated automatically during PDF creation from the table-of-contents 
entries of documents created by most desktop publishing programs. These bookmarks are often 
tagged and can be used to navigate within the PDF. Bookmarks can also provide a visual outline 
of the logical structure of the document.

Initially, a bookmark displays the page that was in view when the bookmark was created. 
In Acrobat, bookmark destinations can be set as each bookmark is created. However, it is 
sometimes easier to create a group of bookmarks, and then set the destinations later. 

In Acrobat, bookmarks can be used to mark your place in the PDF, or to jump to a destination or 
structural element in the PDF, another document, or a web page. Bookmarks can also perform 
actions, such as executing a menu item or submitting a form. For bookmarks to move focus 
by keyboard or assistive technology to a certain word, line, link, or paragraph, use the “create 
bookmark from structure” option in the Options menu of the Bookmarks panel. 
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Figure 4.  The New Bookmark from Structure option in the Bookmark options 
context menu

Note: 	 An Acrobat user can add bookmarks to a document only if the security settings 
allow it. If this security setting must be disabled, ensure bookmarks are added to 
the document before publishing.

Set Initial View/Open Options

There are several options that can be set to assist users with disabilities when the document 
loads. When the Make Accessible Wizard Set Open Option is run, the document metadata is set 
to the document title. In addition to the wizard, options can be set this way:

1.	 Open the Document Properties Dialog

2.	 Activate the Initial View page tab

3.	 Set Page Layout to “single” or “single page continuous”

4.	 Set Window Options: Show to “Window Title”

5.	 Set the Navigation Tab dropdown to “Bookmarks Panel and Page”

6.	 Activate the OK button

Step 3: Perform OCR on Scanned Document
A common method for making PDF documents is to place a paper copy of a document into a 
scanner and view the newly-scanned document as a PDF with Adobe Acrobat. Unfortunately, 
scanners only create an image of text, not the actual text itself. This means the content is not 
accessible to users who rely on assistive technology. Additional modifications must be made to 
make the document accessible.

Note: 	 If the PDF document is not a scanned document or it has previously undergone 
optical character recognition (OCR), skip this discussion and proceed to “Step 4: 
Add Form Fields and Set the Tab Order” on page 12.

How to Determine if a PDF File is a Scanned Document

There are many ways to determine if a PDF file originated from a scanned page:
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The Page Appears to be Skewed 

Sometimes sheets are not properly fed into the scanner. The result is the page appears to be 
crooked, or skewed on the screen . Lines of text will not be straight but will appear to slant up or 
down. 

Figure 5.  Skewed Text Indicates a Scanned PDF

Search for Characters that Appear on the Page

Use the find command in Acrobat to search for text that appears on the page. Select Edit > Find 
and type a term that appears on the page in the search field.

If the document was scanned, Acrobat will not find the search item but will display the message: 
“Acrobat has finished searching the document. No matches were found.”

Zoom in and Check for Jagged Edges on Smooth Characters

Scanned images are bitmaps (See “Figure 6. Bitmapped Text Appearance” on page 10). 
The edges of curves on bitmapped images will not appear to be smooth or rounded but will be 
jagged, as shown in the sample illustrating the word “Writing” in Figure 6 on page 10. Use 
the Marquee Zoom tool in Acrobat to define the area and magnify the edges of curved letters 
such as “c”, “s”, and “o”. Text that has undergone the OCR process using the ClearScan option will 
display edges that are smoother but still uneven or lumpy where there should be smooth curves, 
as shown in the illustration of the of the words “Quality” and “region” in Figure 7 on page 10. 
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Figure 6.  Bitmapped Text Appearance

Figure 7.  ClearScan Text Appearance

Use Assistive Technology or the Read Out Loud Feature

Acrobat XI Pro can detect the presence of assistive technology, and if it encounters a scanned 
document, Acrobat will announce an audible empty page warning and display the Scanned Page 
Alert dialog (See “Figure 8. Scanned Page Alert Dialog” on page 11). 
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Figure 8.  Scanned Page Alert Dialog

Perform OCR on a Scanned Document

Perform Optical Character Recognition (OCR) to convert the bitmap image of text to actual 
characters. In Acrobat XI Pro, this can be performed three ways:

•	 Make Accessible Wizard: Recognize Text� using OCR command

•	 With assistive technology running, open the document. When the 
Scanned Page Alert dialog appears, select “OK” from the Scanned Page 
Alert dialog (See “Figure 8. Scanned Page Alert Dialog” on page 11). 

•	 The Recognize Text pane can also be used in the Acrobat XI Pro Tools 
pane. 

•	 Activate View > Tools > Text Recognition > Choose In This File/In 
Multiple Files (See “Figure 9. Recognize Text Dialog and Recognize 
Text Settings” on page 12). 

The non-wizard methods will display the Recognize Text panel when activated. There is an 
option of recognizing the entire document, the current page, or a range of pages within the 
document. Use the Edit button in the scanned page dialog to set the desired characteristics for 
the resulting file. This “Recognize Text—General Settings” dialog appears also when the Make 
Accessible Wizard is run. The options to choose are:

•	 Primary OCR Language. Acrobat does not recognize a document’s 
language itself—a user must indicate which language is used.

•	 PDF Output Style. This option should be set to ClearScan. ClearScan will 
allow the resulting PDF to “reflow”. Reflow allows the text on the page 
to be enlarged without displaying horizontal scroll bars. As the text size 
increases, the text wraps so content is not lost in the margins. The other 
two options, “Searchable Image” and “Searchable Image Exact”, will also 
work with assistive technology but will result in a PDF file that does not 
reflow.

•	 Downsample to. Downsampling should be set to the highest resolution as 
measured in dots per inch (dpi). This should be 600 dpi.
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Figure 9.  Recognize Text Dialog and Recognize Text Settings

For additional information on performing optical character recognition using Adobe Acrobat, 
refer to the Acrobat XI Pro Help.

Step 4: Add Form Fields and Set the Tab Order
To determine if a PDF file is meant to be an interactive form, examine the file for the presence of 
form fields, or areas in the document that ask for information such as name, address, preference, 
etc. Boxes or fields drawn on the page can also indicate that the document is meant to function 
as a form. If the form is to be completed online, rather than on paper, then the form is meant 
to be an interactive form, and the form elements must be made accessible. Even when a form 
is meant to be filled out on paper, it can be very beneficial to users with disabilities to provide 
the form in electronic format with accessible forms. For example, this will allow users who are 
blind or visually impaired to fill out the form electronic privately, even if it is not submitted 
electronically.

The Make Accessible Wizard contains a command to Detect Form Fields and Set Tab Order to 
follow the document structure. The wizard will ask if the document is meant to be a fillable form, 
and then it will automatically detect form fields.

Please refer to the document Acrobat XI Accessible Forms for instructions on how to make 
electronic forms accessible to people with disabilities. This document provides instructions for 
creating form fields manually or making form fields accessible after automatic detection.

Step 5: Set the Document Language
Setting the document language in a PDF enables some screen readers to switch to the 
appropriate language. The document language can be set for an entire document with Acrobat 
Pro or Acrobat Standard. The document language for specific portions of a multi-language 
document can be set only with Acrobat Pro (See “Figure 10. Setting the document language” 
on page 13).

 Set the Language for an Entire Document

1.	 Open the Document Properties dialog: Choose File > Properties

2.	 Select a language from the Language menu in the Reading Options area of 
the Advanced tab. 

3.	 Activate the OK button.

Set the Language for an Entire Document to a Language not in the Language Menu

1.	 Open the Document Properties dialog: Choose File > Properties 
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2.	 Enter the ISO 639 code for the language in the Language field in the 
Reading Options area of the Advanced tab. For more information, refer to 
the ISO Language Codes on http://www.loc.gov/standards. 

3.	 Activate the OK button

Set the Language for Individual Sections or Words

Please refer to Section 6 on page 23 for information on setting the language of specific text 
using the Tags panels.

Figure 10.  Setting the document language

Step 6: Add Tags to the Document
Tagging is essential for PDF accessibility. Tags establish logical reading order and to provide 
a means for indicating structure and type, adding alternative text descriptions to non-text 
elements and substitute text (referred to as actual text) for elements in the PDF document.

If you’ve followed each step so far, your PDF document is searchable either from optical 
character recognition or through the native document conversion. Any desired interactivity has 
been added in the form of navigational controls or interactive form fields. The next step is to 
add tags to the document if it has not been tagged. This section addresses the addition of tags, 
while “Step 7: Examine and Repair the Tag Structure” on page 23 explains how to fix tags and 
properly tag complex layouts and elements.

Note: 	 If the PDF document has been tagged, skip this discussion and proceed to “Step 
7: Examine and Repair the Tag Structure” on page 23.

Determine if the Document has been Tagged

There are several ways to determine if a PDF file has been tagged:
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View Document Properties 

1.	 Open the Document Properties dialog: File > Properties.

2.	 Look for the “Tagged PDF” label n the lower left hand corner of the 
Description tab.

Figure 11.  Tagged PDF File Property

Reveal the Tags Panel 

1.	 Open the Tags panel. 

Select View > Show/Hide > Navigation Panes >Tags.

2.	 Examine the Tags panel. 

A tagged document will show tags and a structure tree descending from 
the root node. To fully expand the entire tree, Control + click on the root 
node labelled “Tags”.

An untagged document will display the words “No Tags Available” as its 
root and no structure tree will appear.
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Figure 12.  No Tags Available in Structure Panel

Figure 13.  Structure Panel Showing Tags Tree

In some cases, a document may not be considered tagged by Acrobat even though a structure is 
visible in the Tags panel. To indicate the document is tagged:

1.	 Select the Options icon from the Tags panel.

2.	 Ensure the “Document is Tagged PDF” option is checked.
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Figure 14.  “Document is Tagged PDF” Indicator in a Structured Document

Run the Accessibility Checker

The Accessibility Checker can perform a thorough check for many common accessible issues 
found in PDF documents, including missing tags. For a complete guide on using the Accessibility 
Checker in Acrobat please refer to the document “Acrobat XI Access Checker”. The section below 
will only specifically address using the checker to determine if tags are missing.

To run the Accessibility Checker to determine if the document is tagged, perform the following: 

1.	 Display the Accessibility Pane

In Adobe Acrobat XI Pro, the Accessibility tool pane is not shown by 
default. Select View > Tools > Accessibility from the Adobe Acrobat XI Pro 
menu to show the pane.

2.	 Select the Full Check command from the Accessibility pane (See “Figure 
15. Acrobat XI Pro Accessibility Pane with Full Check Command” on 
page 17).

Selecting the Full Check command opens the Accessibility Full Check 
dialog (See “Figure 16. Acrobat XI Pro Accessibility Checker Dialog” on 
page 17). 

3.	 Choose how you would like the results displayed.

The results can be saved as an HTML file, or as comments placed where 
the accessibility problems are detected. 

4.	 Select a page range if a check is needed for individual sections of a 
document. 

5.	 Choose the items you want to test from the four categories in the drop-
down menu (Document; Page Content; Forms, Tables and Lists; and 
Alternate Text and Headings).

6.	 Select the Start Checking button. 
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Figure 15.   Acrobat XI Pro Accessibility Pane with Full Check Command

Figure 16.   Acrobat XI Pro Accessibility Checker Dialog

The results are displayed in the Accessibility Checker panel in a tree format, which allows the 
user to navigate through each error the Checker encountered. (See “Figure 17. Acrobat XI Pro 
Accessibility Checker Panel” on page 18). Note the areas under Document, Page Content, 
and Forms, Tables and Lists that are related to tags. (See “Step 9: Use the Accessibility Checker to 
Evaluate the PDF File” on page 49).
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Figure 17.   Acrobat XI Pro Accessibility Checker Panel

Use the Touch Up Reading Order Tool (TURO)

Another way to check for the presence of tags is to display the Touch Up Reading Order tool or 
TURO. To display the Touch Up Reading Order tool, if the Accessibility panel is not already on 
display, select View > Tools > Accessibility from the Adobe Acrobat XI Pro menu. Then select the 
Touch Up Reading Order command under the Accessibility panel (See “Figure 18. Displaying 
the Touch Up Reading Order Tool” on page 19).

A tagged document will display shaded areas on the page that are numbered (See “Figure 19. 
Viewing a Tagged Document with the Touch Up Reading Order Tool” on page 19). An 
untagged document will not display these numbered rectangles (See “Figure 20. Viewing an 
Untagged Document with the Touch Up Reading Order Tool” on page 20).
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Figure 18.  Displaying the Touch Up Reading Order Tool

Figure 19.  Viewing a Tagged Document with the Touch Up Reading Order Tool
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Figure 20.  Viewing an Untagged Document with the Touch Up Reading Order Tool

Add Tags to an Untagged Document

Tags can be added to untagged documents using Adobe Acrobat XI Pro. There are several ways 
to do this:

•	 Add Tags from the Accessibility tool pane

•	 Add Tags from the Accessibility Check

•	 Add Tags from the Tags panel

Add Tags from the Make Accessible Actions Wizard

1.	 Open the Make Accessible Wizard

2.	 Activate the “Add Tags to Document” command to add tags to the document 
and generate a Recognition Results report for adding tags.

3.	 Verify the tags. Refer to the section “The Recognition Results Report for 
Adding Tags” on page 23
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Figure 21.  The Make Accessible Wizard with Add Tags to Document Command

Add Tags with the Accessibility Checker

When the document is not tagged at all, “Tagged PDF” will be listed as “failed” under the 
Document tree item. To add tags to the document: Refer to “Figure 17. Acrobat XI Pro 
Accessibility Checker Panel” on page 18

1.	 Right click or press the applications key (Windows) on the “Tagged PDF—
Failed” tree item

2.	 Choose Fix

3.	 Verify tags have now been added to the document

A Recognition Report for adding tags has been generated. Refer to the section “The Recognition 
Results Report for Adding Tags” on page 23.

When the document was tagged but specific content is still missing tags:

1.	 Select the untagged content in the tree.

2.	 Select the Move or Make Changes to Object tool in the Quick Tools 
toolbar.

21Adobe Acrobat XI  Accessibility Accessibility Repair Workflow



3.	 Select the highlighted object in the document pane.

4.	 Activate the Tags panel.

5.	 Select the desired location to insert the tag in the tree structure.

6.	 If a new element is needed, select Options and choose New Element 
followed by the desired element (the new tag will appear below the 
selection).

7.	 Right-click the desired element.

8.	 Choose Create Tag from Selection

Figure 22.  Create Tag from Selection Context Menu Item

Note: 	 It is useful to check the “highlight content” context menu item shown in Figure 
17 Create Tag from Selection Context Menu Item above. This option will highlight 
the corresponding item from the tag tree in the document pane with a blue 
rectangle.

Add Tags Manually via the Tags Panel

With the Tags panel open, select “Add Tags to Document from the Options button, or with the 
Accessibility panel open in the Tools pane, select the “Add Tags to Document” command (See 
“Figure 23. Adding Tags to an Untagged PDF File” on page 23).

A Recognition Report for adding tags has been generated. Refer to the section “The Recognition 
Results Report for Adding Tags” on page 23 for more details.
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Figure 23.  Adding Tags to an Untagged PDF File

The Recognition Results Report for Adding Tags

If Acrobat encounters potential problems while adding tags to the document, the Add Tags 
Report opens in the navigation pane. The report lists potential problems by page, provides a 
navigational link to each problem, and offers suggestions for fixing them. This is similar to the 
Accessibility Checker Report that is produced when an accessibility full check is run as described 
in “Step 9: Use the Accessibility Checker to Evaluate the PDF File” on page 49.

Remember that the automatically generated Recognition Results report requires human 
intervention to determine the best solution. For example, the report might state that an element 
has been tagged as a figure and requires alternate text to make it accessible. However, that figure 
may be a background design element that doesn’t convey any meaning to the user. 

Note: 	 The Add Tags Report highlights tagging-related problems only, and it is a 
temporary file that cannot be saved. Other accessibility issues, including reading 
order, can be assessed by using the Accessibility Checker.

Adding tags to a PDF may result in a tag structure that is overly complicated or problematic to fix 
manually. Specific tags can be removed directly via the Tags panel or via the Touch Up Reading 
Order tool. When a layout table is used, for example, the tagged table structure should be 
removed to create a cleaner, simpler tagging structure.

Step 7: Examine and Repair the Tag Structure
There are several tools available within Adobe Acrobat XI to repair and set the logical tag 
structure of the document. These include the Touch Up Reading Reader Order tool, the Order 
panel, the Tags panel, and the Content panel. The Touch Up Reading Order tool provides the 
easiest visual tool for tagging and setting order. However, it is limited in the types of structural 
elements that can be set. The Read Out Loud tool, which provides basic text-to-speech access 
for PDF files, uses the content order found in the Order panel. Assistive technologies such as 
screen readers, on the other hand, follow the order found in the Tags panel.

When order changes are made in the Touch Up Reading Order tool or the Order panel, 
order changes are made in both the Tags panel and the Contents panel automatically. Thus 
the Tags panel and Order panel generally should be synchronized—although they can get 
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unsynchronized. The Touch Up Reading Order tool (See “Figure 25. Touch Up Reading Order 
Tool” on page 25) can be used to quickly determine whether basic structural tags and reading 
order have been applied to a document. 

The Touch Up Reading Order tool displays tagged page content in shaded rectangles. Each 
rectangle is numbered and indicates the reading order or tag type of the item on the page. The 
reading order of items can also be verified by displaying the Order navigation panel.

Figure 24.  The Order Navigation Panel

Note: 	 When the PDF document is properly tagged, proceed to “Step 9: Use the 
Accessibility Checker to Evaluate the PDF File” on page 49.

The Tags panel is the most advanced panel for tagging PDF files and provides the most 
flexibility. Advanced users may primarily use the Tags panel for tagging documents in 
combination with several toolbar items such as the Move or Make Changes to Object tool and 
the Selection tool for text and images. Advanced users will find the Touch Up Reading Order 
tool useful for working with complex data tables and for selecting and tagging text that spans 
multiple objects.

Touch Up Reading Order Tool (TURO)

The Touch Up Reading Order tool provides the easiest way to fix basic reading order and tagging 
issues. When the Touch Up Reading Order tool is activated, a dialog displays an overlay of 
highlighted rectangles showing the reading order and tag type of page content. Each tagged 
region is numbered and highlighted with gray or colored blocks (the color is adjustable from the 
TURO dialog); the lower the number, the higher the content appears in the page’s reading order. 
The reading order of page content should be addressed first, followed by other semantic tasks.

Use the Touch Up Reading Order tool to perform the following accessibility tasks:

•	 Visually check, and then repair, the reading order of page content

•	 Display the tag type of page content

•	 Tag fillable form fields and their labels

•	 Assign accessible labels for form fields and alternative text for images
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•	 Specify heading structure

•	 Create formula, figure and caption tags 

•	 View table structure including table headers and data cells

•	 Fix the tagging of simple tables, and prepare complex tables for more 
advanced manipulation in the logical structure tree

•	 Remove decorative content, such as ornamental page borders, from the 
logical structure tree

Figure 25.  Touch Up Reading Order Tool

Selecting the Touch Up Reading Order Tool

To display the Touch Up Reading Order tool, if the Accessibility panel is not already displayed, 
select View > Tools > Accessibility from the Adobe Acrobat XI Pro menu. Then select the Touch 
Up Reading Order command under the Accessibility pane (See “Figure 18. Displaying the Touch 
Up Reading Order Tool” on page 19).

When the Touch Up Reading Order command is selected, a dialog box opens that displays 
the overlay highlighted rectangles that show the order of page content (See “Figure 26. Page 
Content Display with the Touch Up Reading Order Tool” on page 26).
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Figure 26.  Page Content Display with the Touch Up Reading Order Tool

Each highlighted region is numbered and highlighted with gray or colored blocks (colors can be 
customized from the dialog); the numbers indicate each region’s position in the page’s reading 
order. To display the contents corresponding tag type rather than reading order, check the 
“Structure Types” radio button.

Touch Up Reading Order Tool Options

Select Touch Up Reading Order options from the dialog box, from the pop-up menu that appears 
when the right mouse button is pressed in a highlighted region, or from the Options menu in the 
Order tab. The Touch Up Reading Order tool includes the following options:

•	 Text . Tags the selection as text.

•	 Background. Tags the selection as a background element, or artifact, 
removing the item from the tag tree so that it doesn’t appear in the reflowed 
document and isn’t read by screen readers.

•	 Figure. Tags the selection as a figure. Text contained within a figure tag is 
defined as part of the image and is not read by screen readers. 

•	 Figure/Caption. Tags a selected figure and caption as a single tag. Any 
text contained in the tag is defined as a caption. Useful for tagging photos 
and captions and preventing caption text from being incorrectly added to 
adjacent text blocks. Figures may require alternate text. 

•	 Table. Tags the selection as a table after the selection is analyzed to 
determine the location of headings, columns, and rows. 

•	 Cell. Tags the selection as a table or header cell. Use this option to merge 
cells that are incorrectly split.

•	 Form Field. Tags the selection as a form field.

•	 Formula. Tags the selection as a formula. Because speech software may 
handle formula tags differently from normal text, it may be necessary to add 
a description using alternate text. 

•	 Heading 1, Heading 2, Heading 3, Heading 4, Heading 5, Heading 6. Tags 
the selection as a first, second, third, fourth, fifth or sixth level heading tag. 
Heading elements can be converted to bookmarks to help users navigate 
the document. 
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•	 Show Page Content Groups. Outlines each content group, and allows the 
user to select between Page content order, which displays content based 
on it’s numerical order value, and Structure types, which displays content 
type, for example Paragraph or Figure, in place of numerical values.

•	 Show Page Content Order. Shows content elements as highlighted areas 
that contain numbers to indicate the reading order. The rectangle next to 
this entry is a color swatch. Specify the desired highlight color for page 
content order by clicking the color swatch. 

•	 Show Table Cells. Highlights the content of individual table cells. The 
rectangle next to this entry is a color swatch. Specify the highlight color for 
Table Cells by clicking the color swatch. 

•	 Show Tables And Figures. Outlines each table and figure with a crossed-out 
box. The box also indicates whether the element includes alternate text. The 
rectangle next to this entry is a color swatch. Specify the highlight color for 
Tables and Figures by clicking the color swatch. 

•	 Delete Selected Item Structure. Removes the structure from the selected 
item.

•	 Clear Page Structure. Removes the tagging structure from the page. Use 
this option to start over and create a new structure if the existing structure 
contains too many problems. 

•	 Show Reading Order Panel. Opens the Order tab to allow reordering of the 
highlighted content. 

The following items are only displayed when right-clicking a corresponding item in the 
document pane while the Touch Up Reading Order tool is activated:

•	 Table Editor. Automatically analyzes the selected table into cells and 
applies the appropriate tags. Table Editor is only available for content that is 
tagged as a table. 

•	 Edit Table Summary. Available via context menu on a highlighted table. 
Allows the user to add or edit a text description of the table that is read by a 
screen reader or other assistive technology.

•	 Edit Alternate Text. Available via context menu on a highlighted figure. 
Allows the user to add or edit a text description about the figure properties 
that is read by a screen reader or other assistive technology. 

•	 Edit Form Field Text. Available via context menu a form field. Allows the 
user to add or edit a form field text description that is read by a screen 
reader or other assistive technology. 

Tips for using the Touch Up Reading Order Tool

When using the Touch Up Reading Order tool, consider the following:

•	 Save the document (or a copy of it) before using the Touch Up Reading 
Order tool. Undo can not be used to reverse changes made with this tool 
or the Tags panel. Reverting to a saved document is the only way to undo 
such a change. 

•	 Choose View > Page Display > Single Page, when using the Touch Up 
Reading Order tool. When the Clear Structure button is activated, Acrobat 
clears tags from all visible pages—even pages that are only partially visible. 
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Checking Read Order with the Touch Up Read Order Tool

The reading order can quickly be checked by using the Touch Up Reading Order tool. It is 
possible to use this tool to add alternate text to images and correct many types of tagging 
problems that are outlined in the report that Acrobat generates when adding tags to a PDF. 

Reading order issues are readily apparent when using the Touch Up Reading Order tool. Each 
section of contiguous page content appears as a separate highlighted region and is numbered 
according to its placement in the reading order. It may be helpful to turn off the option “Display 
Like Elements in a Single Box” to change the order of similar elements that appear to be grouped 
with one number in the Order. This option can be set using the “Options” menu in the Order 
panel.

Within each region, text is ordered left to right and top to bottom. (This order can be changed 
in the Touch Up preferences.) If a single highlighted region contains two columns of text or 
text that will not flow normally, divide the region into parts that can be reordered. Because 
highlighted regions are rectangular, they may overlap somewhat, especially if their page content 
is irregularly shaped. Unless page content overlaps or is contained within two highlighted 
regions, no reading order problem is indicated. Page content should belong to no more than one 
highlighted region. 

The reading order of the highlighted regions can be changed by moving an item in the Order 
panel or by dragging the numbers on the page in the document pane. By reordering highlighted 
regions on the page, it is possible to make a figure and caption appear in the reading order at the 
specific point that they are referenced in the text. By changing the order of a highlighted region, 
the reading order can effectively be changed for an item without changing the actual appearance 
of the PDF.

To check the reading order with the Touch Up Reading Order tool:

•	 Select the Touch Up Reading Order tool.

•	 In the Touch Up Reading Order dialog box, select Show Page Content Order.

Note: 	 If highlighted regions do not appear in the document pane, the document does 
not contain tags. Tags will need to be added to the document (See “Step 6: Add 
Tags to the Document” on page 13).

The page view may be modified by doing any of the following: 

•	 To specify a highlight color, click on one of the color swatches, the small 
squares to the right of the check boxes for “Show page content groups”, 
“Show table cells” and “Show tables and figures.” Select the desired color 
from the swatch that pops up in the Touch Up Reading Order dialog.

•	 To highlight tables and figures, and to view alternate text for figures, select 
Show Tables And Figures checkbox.

•	 Check the reading order of text within each highlighted region. Zooming in 
can make this step easier. 

•	 It may be necessary to uncheck the display like elements in a single 
block checkbox to verify that elements within a single block are 
ordered correctly.

•	 Check the numbered order of all highlighted regions. If consecutive, 
numbered regions don’t follow one another, reorder them in the Order 
panel. 
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•	 Click Show Order Panel, and then select each content entry (in square 
brackets [ ]) in the Order panel to highlight that content region in the 
document pane. Use this method to find numbered regions that cannot be 
seen or located on the page.

Change the Reading Order by Dragging on the Page

•	 Select the Touch Up Reading Order tool.

•	 In the Touch Up Reading Order dialog box, select Show Page Content 
Groups: Page Content Order. 

•	 In the document pane, place the pointer over the number for the highlighted 
region to move, and drag it to where it to be read. The text-insertion pointer 
shows target locations within the text. 

Change the Reading Order using the Order Panel

In the Order panel, highlight an item in the list that corresponds to a numbered item in the 
document view. Push the item up or pull it down until it falls into the proper sequence.

•	 Select the Touch Up Reading Order tool. 

•	 In the Touch Up Reading Order dialog box, click Show Order Panel. 

•	 The Order panel shows a list of highlighted regions that appear in the 
document pane. 

•	 Push items up or drag them down to rearrange their order. (Note copy and 
paste keyboard commands can also be used).

Note: 	 Another way to display the Order panel is from the Acrobat X Pro menu. Select View > 
Show/Hide > Navigation Panes > Order.
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Figure 27.  Acrobat XI Pro Order Panel

Edit Tags with the Touch Up Reading Order Tool

Use the Touch Up Reading Order tool to create tags in untagged PDFs, or to add new tags 
to an existing structure. This manual tagging does not provide the same level of detail to the 
tagging structure as the Add Tags To Document command. For example, tags such as individual 
paragraphs, bulleted and numbered lists, line breaks, and hyphens. Sometimes it may be 
necessary to activate the “clear page structure” feature of the Touch Up Reading Order tool. 
Make sure that manual tagging is the only option before clearing the structure.

Tag a Region

With the Touch Up Reading Order tool active:

1.	 Drag within the document pane to select a region of the page that contains 
one type of content (for example, a text block).

•	 To add more page content to the current selection, Shift-drag.

•	 To remove page content from the current selection, Control-drag/
Command-drag.

2.	 Activate the appropriate button in the Touch Up Reading Order dialog box 
to specify the tag type.

Change the Tag for a Region

If a page element is not tagged incorrectly, change the tag type for the highlighted region.

1.	 Select the Touch Up Reading Order tool.

2.	 To select a highlighted region, click the number of a highlighted region.

3.	 Click the button for the tag type the highlighted region should be.

Add or Remove Content from a Tagged Region

The Touch Up Reading Order tool always displays as few highlighted regions as possible. If 
content within a highlighted region does not flow properly, it may be necessary to split a region 
to reorder it. Highlighted regions may also contain adjacent page content that is unrelated 
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or requires a different tag type. Page content may become orphaned from related elements, 
particularly if the content doesn’t fit within a rectangular shape. Use the Touch Up Reading Order 
tool to add or remove content from a region, or to split a region to reorder the content.

•	 Select the Touch Up Reading Order tool. 

•	 In the Touch Up Reading Order dialog box, unselect “Display like elements 
in a single box”

•	 In the document pane, select a highlighted region. 

Do one of the following: 

•	 To add content to the current selection, Shift-click the content to add. The 
pointer changes to include a plus sign (+).

•	 To remove content from the current selection, Control-click/Command-click 
the content to be removed. The pointer changes to include a minus sign (-).

•	 Click the button for the tag type to be highlighted.

Split a Region into two Regions

1.	 Select the Touch Up Reading Order tool. 

2.	 In the Touch Up Reading Order dialog box, unselect Display like elements in 
a single box. 

3.	 In the document pane, drag to select the content to create as the new 
region. 

4.	 Activate the desired tag button (such as text) in the dialog box. The 
highlighted region splits into two regions, numbered from left to right. 

5.	 To correct the reading order, click Show Order Panel, and drag the split 
region to the correct location in the Order panel. 

Note: 	 Regions can be combined by selecting each item in the Order panel (Shift+click) and 
then choosing the desired tag button in the Touch Up Reading Order dialog box or by 
choosing the tag type from the context menu.

Apply a Heading Tag

To help readers navigate a document and understand the logical structure of document content, 
tag content that represents a heading with the appropriate heading level to indicate its position 
in the document hierarchy. 

•	 Select the Touch Up Reading Order tool, and then select the heading text 
in the PDF. 

•	 In the Touch Up Reading Order dialog box, activate the button 
corresponding to the appropriate heading tag (for example, Heading 1, 
Heading 2). 

Remove Page Elements from the Tag Structure

Automatic tagging cannot always distinguish between instructive figures and decorative 
page elements. Items that visually enhance page layout, such as decorative borders, lines, or 
background elements, can add clutter to the structure layout and should be removed. Decorative 
elements may be tagged as figure tags instead of artifact elements that are not presented to 
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users of assistive technology. You can remove decorative and irrelevant page elements from the 
tag structure by redefining them with the Background (artifact) tag. Simply deleting these tags 
from the structure will prevent them be being seen by assistive technology but these untagged 
elements will then be flagged by the Accessibility Checker. Therefore it is best to tag these 
elements as artifacts by choosing the Background button of the Touch Up Reading Order tool..

1.	 Select the Touch Up Reading Order tool. 

2.	 In the Touch Up Reading Order dialog box, select Show Page Content Order 
and Show Tables And Figures. 

3.	 In the document pane, select the page element, and then click 
Background in the dialog box.

Apply a Figure Tag

Non-decorative figures must provide alternative text to users who cannot see them. Select an 
element and define it as a figure by using the Touch Up Reading Order tool. Once it is defined as 
a figure, add alternate text to describe it.

1.	 Activate the Touch Up Reading Order tool.

2.	 Select the figure by drawing a rectangle around it.

3.	 In the Touch Up Reading Order dialog box, activate the Figure button. 

4.	 In the document pane, right-click the region and choose Edit Alternate Text 
(See “Figure 28. Add / Edit Alternate Text with Touch Up Reading Order” 
on page 33). 

5.	 Enter the desired alternate text in the Alternate Text dialog (See “Figure 29. 
Touch Up Reading Order Alternate Text Dialog” on page 33), 

6.	 Select the OK button. 

Use the Touch Up Reading Order to tag figures with captions

Use the Touch Up Reading Order tool to correct tag figures with on-screen captions. Determine 
whether figures include caption. Typically this occurs when an image such as a graph or 
illustrative photograph is provided with text below or above it that describes or labels the figure. 
Background elements that should not be announced should be tagged as background elements.

Select the Touch Up Reading Order tool, and activate Show Tables And Figures in the dialog box. 

It may be necessary to do the following:

•	 If a figure with caption is not tagged as a figure/caption, select the desired 
image and text caption content, and then activate the Figure/Caption 
button in the dialog box.

•	 To remove text that was incorrectly combined with a figure, drag to select 
the text, and click the Text button in the dialog box.

•	 To include a caption that is visually grouped with the figure, select the figure 
and caption, and click the Figure/Caption button in the dialog box.

Add Alternate Text with the Touch Up Reading Order Tool

Screen reading software used by people who are blind or visually impaired cannot describe 
graphical elements that illustrate important concepts in a document. Thus, the document author 
must provide the description using alternate text. Figures are not recognized or announced by a 
screen reader unless alternate text is added to the tag properties. Alternate text that is applied to 
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text elements is not generally announced by screen readers. The actual text property must be set 
to change what is announced by screen readers for non-figure elements. To set alternative text 
for a figure:

1.	 Select the Touch Up Reading Order tool. 

2.	 Select Show Tables And Figures in the dialog box. Figures that are missing 
Alternate Text will have a flag indicating “Figure—No alternate text exists” 
(See “Figure 28. Add / Edit Alternate Text with Touch Up Reading Order” 
on page 33).

3.	 Right-click the figure, and choose Edit Alternate Text from the pop-up 
menu. (See “Figure 28. Add / Edit Alternate Text with Touch Up Reading 
Order” on page 33).

4.	 In the Edit Alternate Text dialog box, type a new (or edit an existing) 
description for the figure. (See “Figure 29. Touch Up Reading Order 
Alternate Text Dialog” on page 33).

5.	 Select the OK button.

Figure 28.  Add / Edit Alternate Text with Touch Up Reading Order

Figure 29.  Touch Up Reading Order Alternate Text Dialog

Using the Touch Up Reading Order Tool Table Editor

Tables pose a special challenge for screen readers because they present textual or numerical 
data to be easily referenced visually. Content within table cells can be complex and might 
contain lists, paragraphs, form fields, or another table.

33Adobe Acrobat XI  Accessibility Accessibility Repair Workflow



The Touch Up Reading Order Table Editor displays the selected table into cells and allows the 
user to apply additional table markup. The table must be tagged as a table before using TURO’s 
Table Editor command.

For best results when tagging tables, use the application that created the document to add tags 
when the PDF is created. If a PDF is not tagged and the source document is not available, add 
tags by using the Add Tags To Document command in the Accessibility pane. Most tables are 
properly recognized using this command; however, the command may not recognize a table 
that lacks clear borders, headings, columns, and rows. Use the Touch Up Reading Order tool to 
determine if the table has been properly recognized and to correct recognition problems such as 
missing cells. The Tags panel can also be used to manually tag data table elements.

Use the Table Editor to check and correct table tags. By viewing table tags, determine whether 
columns, rows, and cells have been correctly identified. Tables that lack well-defined borders 
and rules are often tagged incorrectly or contain adjacent page elements. It is possible to correct 
poorly tagged tables by selecting and redefining them; it is possible to split combined cells by 
creating a tag for each cell. 

1.	 Select the Touch Up Reading Order tool. 

2.	 Select the Show Tables And Figures button. 

3.	 If the table is not clearly labeled in the document pane, drag to select the 
entire table, and then click Table in the dialog box. 

4.	 Click Show Table Cells to make sure that all cells in the table are defined as 
individual elements.

If cells do not appear as separate elements: 

1.	 Use the Touch Up Reading Order tool to select a single cell from within a 
merged cell.

2.	 Select the Cell button in the dialog box. Repeat for each split merged cell.

Note: 	 If cells are not highlighted, the table might not use standard table formatting. Re-
create the table in the authoring application.

Add a Table Summary

With the cursor over the table, right click to add a Table Summary. The Edit Table Summary 
option is available in the menu that appears when a right-click is performed on a highlighted 
table. This allows the user to add or edit a text description about the table properties that may be 
read by a screen reader or other assistive technology.

Editng Table Tags

Place the Table in Editing Mode

There are two ways to place Tables in Table Editing Mode with the Touch Up Reading Order tool:

•	 With the cursor over the table, right click to select Table Editor from the 
context menu to place the table in Table Editing mode.

•	 Use the Order panel.

1.	 Activate the Show Order Panel button in the Touch Up Reading Order 
dialog. 
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2.	 Highlight a cell from the table in the Order panel. 

3.	 The Table Editor button in the Touch Up Reading Order tool becomes 
active. 

4.	 Select the Table Editor button on the Touch Up Reading Order dialog 
to place the table in Table Editing Mode (See “Figure 30. Using the 
Order Panel to Activate the Table Editor” on page 35).

Figure 30.  Using the Order Panel to Activate the Table Editor

Table Editor Options

In Table Editing mode, the borders of the table cells are highlighted. It is possible to change the 
color of the border (See “Figure 31. Table Editing Mode” on page 35). 

Figure 31.  Table Editing Mode

Right click on the table and choose “Table Editor Options” to display the options dialog. The 
Table Editor Options dialog allows users to control how table cells and table headers are 
displayed by Acrobat when using the Touch Up Reading Order Table Editor (See “Figure 32. 
Table Editor Options” on page 36).
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Figure 32.  Table Editor Options

Selecting Table Cells

Select individual cells by clicking within the borders with the mouse. Select multiple table cells 
by holding down Shift and clicking. (This is an efficient method for selecting the first row of data 
cells in a table which need to be changed to header cells.) Some properties for multiple cells can 
be set at once thus saving time tagging large and complex tables.

Edit Cell Properties

Once in Table Editing mode, right click to display the Table Cell Properties dialog. 

The Table Cell Properties dialog (See “Figure 33. Table Cell Properties” on page 37) can be 
used to: 

•	 Specify the type of a table cell (Header cell or Data cell)

•	 Set cell attributes that span more than one row or column

•	 Assign a scope of row, column, both, or none to header cells

•	 Assign a unique header ID for Table Headers

•	 Associate Data cells with Header IDs that have been created for the table
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Figure 33.  Table Cell Properties

To correct complex tagging issues in data tables, it may be necessary to use the Tags panel and 
the Table Editor in combination. For simple tables with only one row or column of header cells, 
the easiest approach is to set each cell in the header row or column to type “header cell”. Then 
set the scope on each cell to the appropriate item “row” for row headers on the left side of the 
table or “column” for column headers that appear across the top of a table. Data tables should 
always have headers tagged this way, or with IDs and headers.

For complex tables, those with more than one row or column of header cells IDs and headers 
must be used. IDs and headers refers to the method to associate data and header cells in data 
tables. This process is very similar to that of HTML data tables. When IDs and headers are used, 
the type of cells (header or data) should still be set but the scope option should not. Assign an 
ID property to each header cell. Then add mappings to the ID or IDs that label the cell in the 
Headers list. Headers are announced by screen readers in reverse order in the headers list.

Remove or Replace Document Structure Tags using the Touch Up Reading 
Order Tool

If the tags in a PDF file in Acrobat appear to be overly complicated and cannot be managed, it 
is possible to re-tag an already tagged document. To do this, first remove all existing tags from 
the tree. Use the Touch Up Reading Order tool to remove or replace the current structure. If 
the document contains mostly text, select a page and then remove headings, tables, and other 
elements to create a cleaner, simpler tagging structure. 

Remove All Tags from a PDF Document

The Touch Up Reading Order tool is very useful to create tags in untagged PDFs or to add new 
tags to an existing tagged structure, but the Add Tags to Document command provides more 
detail. For example, tags such as paragraphs, bulleted and numbered lists, line breaks, and 
hyphens are available from Add Tags to Document. Before clearing the existing structure, make 
sure that manual tagging is the only recourse.

To remove the tags from the entire PDF document, do the following:
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•	 Open the Tags tab (View > Navigation Panels > Tags) and select the root 
(topmost) tag, Tags. 

•	 In the Tags tab, choose Options > Delete Tag. 

Note: 	 The Clear Page Structure command in the Touch Up Reading Order dialog box 
removes all tags from the currently visible pages and not from any pages that are 
not visible.

Replace the Existing Tag Structure on a Page

This process works best in pages that contain a single column of text. If the page contains 
multiple columns, each column must be selected and tagged individually.

1.	 Select the Touch Up Reading Order tool. 

2.	 In the document pane, drag to select the entire page. The selection includes 
both text and non-text elements. 

3.	 Control-drag/Command-drag around non-text page elements—such as 
figures and captions—to deselect them, until only text is selected on the 
page. Click Text in the Touch Up Reading Order dialog box. 

4.	 In the document pane, select a non-text page element, such as a figure and 
caption, and click the appropriate button in the dialog box to tag it. Repeat 
until all page content is tagged. 

Complex Structures

To perform more advanced reading order and tagging tasks—such as tags table of contents, 
adding replacement (actual) text for blocks of text, removing obsolete tags, and adding 
replacement (actual) text to links—it may be necessary to use the Content panel and the Tags 
panel, which provide an advanced set of tools and features for manipulating PDF tags. The Touch 
Up Reading Order tool generally changes and synchronizes both of these panels, but the two 
can become out of sync. 

Content Panel

Use the Content panel to correct reflow problems in a PDF that cannot be corrected by using 
the Touch Up Reading Order tool. Take note that it is easy to damage a PDF by editing content 
objects as removing a content object will remove the object from the visual page. Be familiar 
with the PDF structure before changing anything. For comprehensive information about PDF 
structure, refer to the PDF Reference First Edition: Adobe Portable Document Format Version 
1.7, on the PDF reference page (English only) of the Adobe website.

The Content panel provides a hierarchical view of the objects that make up a PDF, including 
the PDF object itself. Each document includes one or more pages, a set of annotations (such as 
comments and links), and the content objects for the page, consisting of containers, text, paths, 
and images. Objects are listed in the order in which they appear on the page, similar to tags in 
the logical structure tree. However, objects in the Content panel do not require tags to view or 
change the object structure. 

To display the Content panel, choose View > Show/Hide > Navigation Panes > Content from the 
Acrobat XI menu.



Click the plus sign (+) (Windows) or the triangle (Mac OS) next to the document name to view 
each page content entry. Control + click expands the entire content tree. The Content panel 
provides an option to show the corresponding tag in the Tags panel by activating the context 
menu and choosing “Show in Tags Panel”.

Note: 	 It is helpful to have Acrobat highlight items in the document view when the 
associated item in the Content panel is selected. By default, Acrobat will 
highlight content in the tag and content panel trees. To toggle the highlight 
feature on and off, from the Options Menu, select “Highlight Content” 
(See “Figure 34. Set Highlighting On for the Content Panel” on page 
39). 

Containers or objects can be moved by selecting them and doing one of the following: 

•	 Drag it to the desired location. 

•	 Choose Cut from the Options menu, select the tag above the location, 
and choose Paste from the Options menu (Standard Windows and Mac 
keystrokes also work).

Figure 34.  Set Highlighting On for the Content Panel

Note: 	 Container elements can’t be pasted directly to page elements. To move a 
container to another page, cut the container to move, select a container on 
the page to move the container to, and choose Paste from the Options menu. 
Then, drag the container out one level to the desired location.

Content Panel Options

In the Content panel, use the Options menu or right-click an object to choose from the 
following options:

•	 New Container. Adds a new container object at the end of the selected 
page or container. 
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•	 Edit Container Dictionary . Specifies the dictionary for the container. Errors 
in this dialog box may damage the PDF. This option is only available only for 
containers that include dictionaries. 

•	 Cut. Cuts and copies the selected object (not the related page content).

•	 Paste. Pastes content directly below the selected object at the same 
hierarchical level.

•	 Paste Child. Pastes content into the selected object as a child content item.

•	 Delete. Removes the object (not the related page content) from the 
document.

•	 Find Content From Selection. Searches for the object in the Content tab 
that contains the object selected in the document pane.

•	 Find. Searches for unmarked (untagged) artifacts, content, comments, and 
links. Options allow page search or document, and to add tags to found 
items.

•	 Create Artifact. Defines selected objects as artifacts. Artifacts are not read 
by a screen reader or by the Read Out Loud feature. Page numbers, headers, 
and footers are often best tagged as artifacts.

•	 Remove Artifact. Removes the artifact definition from the selected object.

•	 Highlight Content. When selected, highlights appear in the document pane 
around content that relates to a selected object in the Content tab.

•	 Show Metadata . Allows viewing and editing of image or object metadata.

•	 Properties. Opens the Object Up Properties dialog box.

Tags Panel

The Tags panel allows the viewing and editing of tags in the logical structure tree, or tags tree, of 
a PDF file. Tags in panel appear in a hierarchical tree order that indicates the reading sequence 
of the document by assistive technologies such as screen readers. The first item in this structure 
is the Tags root. All other items are tags representing standard PDF structure elements and are 
children of the Tags root. Tags use coded element types that appear in angle brackets (< >). 
Each element, including structural elements such as sections and articles, appear in the logical 
structure order by type, followed by a title and the element’s content or a description of the 
content. Structural elements are typically listed as container—or parent—tags and include 
several smaller elements—or child tags—within them. The tag description is not seen by users 
of assistive technology and can be used by the author to provide comments during the tagging 
process. 

Note: 	 It is possible to directly change tag types by pressing F2 or double clicking the tag 
name in the tree. Tag names are case-sensitive, and care must be taken to properly 
enter the angle bracket if this method is used to change the type of a tag.

Many tagging issues can be corrected by using the Touch Up Reading Order tool, but it is 
necessary to use the Tags panel to address detailed tagging of tables and substructure items—
such as paragraphs, lists, and sections that require multiple languages. First consider using the 
Add Tags To Document feature and the Touch Up Reading Order tool and then use the Tags 
panel to modify the tags.
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Note: 	 Important! Operations performed in the Tags panel cannot be undone with the 
Undo command. Save a backup copy of each document before beginning work 
on it in the Tags panel.

•	 To display the Tags Panel Choose View > Show/Hide > Navigation Panes > 
Tags.

•	 Expand or collapse the tag for an individual element or section by clicking 
on it.

•	 Expand or collapse the entire tree or a node on the tree that has children 
with Control-click the plus sign (Windows) or Option-click the triangle (Mac 
OS) next to the Tags root to show all tags in the logical structure tree or 
press Shift+8 to expand all tags.

Note: 	 You may find it helpful to toggle whether Acrobat highlights items in the 
document view when the associated item in the Tags panel is selected. From the 
Tags panel options menu, “Highlight Content” can be turned on or off—it is on 
by default in Acrobat XI. (See “Figure 34. Set Highlighting On for the Content 
Panel” on page 39). It is also possible to show the corresponding content tag 
in the Content panel from the Tags panel by activating the context menu and 
choosing “Show in Content Panel”.

Figure 35.  Toggle Content Highlighting On/Off for the Tags Panel

Edit tags in the Tags Panel

There are many actions that can be taken on a tag within the Tags panel. These include but are 
not limited to:

•	 Adding a tag

•	 Creating a tag from the document selection

•	 Editing a tag title

•	 Changing a tag location

•	 Changing the tag type for an element
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•	 Deleting a tag

To reveal the Object Properties (See “Figure 36. The Object Properties Dialog: Tag Tab” 
on page 42) for any tag, select the desired tag in the Tags panel and perform one of the 
following:

•	 Right click (or activate the context menu) and select Properties from the 
context menu.

•	 Select Properties from the Tags Panel Option Menu.

Figure 36.  The Object Properties Dialog: Tag Tab 

Edit a Tag Title

From the Tags panel:

1.	 Expand the section of the desired logical structure to edit.

2.	 Select the desired tag to edit.

3.	 Choose Properties from the Options menu.

4.	 Enter text in the Title box.

5.	 Select the Close button.

Note: 	 The F2 command can also be used within the tags tree to edit the tag type and title. 
Make sure that the tag type does not get overridden.

Move a Tag

From the Tags panel:
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1.	 Expand the Tags root to view all tags.

2.	 Select the Tag icon of the element to move.

3.	 Then do one of the following:

•	 Drag the tag to the desired location. When dragging, a line appears at 
available locations to place the tag.

•	 Choose Cut from the Options menu, and select the tag that appears 
above the desired location to paste the cut tag. From the Options menu, 
choose Paste to move the tag to the same level as the selected tag, or 
choose Paste Child to move the tag within the selected tag.

Change the Element Type

From the Tags panel:

1.	 Expand the section of the logical structure that to change.

2.	 Select an element.

3.	 Choose Properties from the Options menu or from the context menu.

4.	 Choose a new element type from the Type menu.

5.	 Select the Close button.

Tags Panel Options

In the Tags panel, use the Options menu or right-click a tag in the logical structure tree to choose 
from the following options:

•	 New Tag. Creates a new tag in the logical structure tree after the currently 
selected item. Specify type and title of the new tag. 

•	 Cut . Removes the selected tag from its current location and puts it on the 
clipboard. 

•	 Paste. Places the tag on the clipboard into the location specified, replacing 
the selected tag.

•	 Paste Child. Places the tag on the clipboard into the location specified, as a 
child of the selected tag. 

•	 Delete Tag. Removes the selected tag. 

•	 Find Tag From Selection. Searches for the tag in the Tags tab that contains 
the text or object selected in the document pane. 

•	 Create Tag From Selection. Creates a new tag in the logical structure tree 
after the item selected in the document pane. Specify the type and title of 
the new tag. 

•	 Find. Searches for artifacts, OCR suspects, and unmarked (untagged) 
content, comments, links, and annotations. Options allow searching the 
page or document and adding tags to found items. 

•	 Change Tag To Artifact. Changes selected tags to artifacts and removes the 
tagged content from the structure tree. 

•	 Copy Contents To Clipboard. Copies all content contained within the 
selected tags. 
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•	 Edit Class Map. Allows the addition, modification, and deletion of the class 
map, or style dictionary, for the document. Class maps store attributes that 
are associated with each element.

•	 Edit Role Map. Allows the addition, changing, and deletion role maps 
for the document. Role maps allow each document to contain a uniquely 
defined tag set. By mapping these custom tags to predefined tags in 
Acrobat, custom tags are easier to identify and edit.

•	 Tag Annotations. When selected, all new comments and form fields are 
added to the tag tree; existing comments and form fields aren’t added 
to the tag tree. Highlight and Underline comments are automatically 
associated and tagged with the text that they annotate and don’t require 
this option.

•	 Document Is Tagged PDF. Flags the PDF as a tagged document. Deselect to 
remove the flag.

•	 Highlight Content. When selected, causes highlights to appear around 
content in the document pane when selecting the related tag in the Tags 
tab. The default option is on.

•	 Show in Content Panel. Shows the Selected tag’s contents in the Content 
panel.

•	 Show Metadata. Opens a read-only dialog box that contains reference 
information about the selected tag.

•	 Properties. Opens the Object Properties dialog box.

Create a New Child Tag

From the Tags panel:

1.	 Select the node the tag should appear inside.

2.	 Choose New Tag from the Options menu.

3.	 Select the appropriate tag type from the Type pop-up menu, or type a 
custom tag type, title the tag (optional).

4.	 Select the OK button . 

Add Tags to Comments

When tags are added to a PDF that includes comments, the comments are tagged as well. 
However, if comments are added to a PDF that’s already tagged, comments are untagged unless 
comment tagging is enabled first. 

Note: 	 To Enable comment tagging in a PDF, in the Tags panel, choose Tag Annotations 
from the Options menu. Comments or markups that are added to the PDF are 
tagged automatically. 

If a document contains untagged comments, they can be located in the logical structure tree and 
tag them by using the Find command in the Tags panel.

1.	 In the Tags panel, choose Find from the Options menu. 

2.	 In the Find Element dialog box, choose Unmarked Comments from the Find 
pop-up menu, and click Find. 
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3.	 When the comment type appears in the Type field (for example, Text), 
activate Tag Element, choose Annotation from the Type pop-up menu in 
the New Tag dialog box, and then activate the OK button. 

4.	 In the Find Element dialog box, activate the Find Next button to locate and 
tag all comments, and then activate the Close button. 

Add Links or Form Fields

Links and form fields should have already been added to the document with the appropriate 
tags if the previous steps in this document were followed. However, if the form fields or links 
were already present and tags already existed in the document, use the following steps to 
make the form field or link accessible. It is NOT enough to simply place the content under a 
link or form tag in the tags tree -- an appropriate object tag must also be present as a child of 
the parent link or form tag in the tree along with the corresponding text node.

From the Tags panel:

1.	 Locate the parent element in the tree to insert the desired link or form 
field (if the appropriate node does not exist create it first).

2.	 Choose Find from the Options menu.

3.	 In the Find Element dialog box, choose “Unmarked links” to find and tag 
links or “Unmarked annotations” to find and tag form fields from the Find 
pop-up menu.

4.	 Select the Find button.

5.	 If the item is located, activate the Tag Element button.

6.	 In the Find Element dialog box, select the Find Next button to locate and 
tag all comments.

7.	 Select the Close button.

Correct Table Tags with the Tags Panel

Use the Touch Up Reading Order tool to make sure that tables are tagged correctly. If it is 
necessary to structure figures and text within the cells of the table, it may be preferable to re-
create the table in the authoring application before converting it as an accessible PDF. Adding 
tags on a cell level in Acrobat is a labor-intensive process.

Before making any changes to table elements, use the Touch Up Reading Order tool to 
determine that the table is tagged correctly.

Check and Edit Table Elements

1.	 In the Tags panel, expand the tags root to view a table tag. 

2.	 Select the table tag <Table> and verify that it contains one of the following 
elements: 

•	 Table Rows <TR>, each of which contains Table Header <TH> or Table 
Data <TD> cells

•	 <THead>, <TBody>, or <TFoot> section, each of which contains Table 
Rows (The Table Rows contain <TH> cells, <TD> cells, or both). 

Do one or more of the following: 
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•	 If the tag for the table doesn’t contain these elements, but rows, columns, 
and cells appear in the table in the document pane, use the Touch Up 
Reading Order tool to select and define the table or individual cells.

•	 If the table contains cells that span two or more columns or rows, set 
ColSpan or RowSpan attributes as appropriate for these cells in the Table 
Editor of the Touch Up Reading Order tool.

•	 Re-create the table in the authoring application, and then convert it to a 
tagged PDF.

Set ColSpan and RowSpan Attributes

ColSpan, RowSpan, Scope, and Table IDs and Headers should be set using the Touch Up Reading 
Order tool. These properties can also be set in the Object Properties dialog of a tag. To set the 
RowSpan or ColSpan properties:

1.	 In the Tags panel, select a <TD> or <TH> element. 

2.	 Choose Properties from the Options menu. 

3.	 In the Object Properties dialog box, click the Tag tab, and then activate Edit 
Attribute Objects. 

4.	 Select Attribute Objects, and then click New Item to create a new Attribute 
Object Dictionary. 

5.	 Expand the new dictionary.

6.	 Select the Layout attribute.

7.	 Activate the Change Item button. 

8.	 Change the Layout value to Table. 

9.	 Select the Attribute Object Dictionary.

10.	 Activate the New Item button.

11.	 In the Add Key And Value dialog box, type ColSpan if the cell spans multiple 
columns or RowSpan if the cell spans multiple rows.

12.	 Enter the number of columns or rows spanned in key field.

13.	 In the Value field, choose Integer from the Value Type pop-up menu.

14.	 Activate the OK button. 

Set the Language for Specific Text

When a language is set for an element in the tag tree that language applies to all content under 
the tag. If the different language is part of the same tag it must first be split out into a separate 
tag. An easy way to do this is to create a new Span tag below the current element and then 
arrange the text content under the current tag in the appropriate location.

1.	 Select the text node that must be split.

2.	 Activate the context menu and choose New Tag.

3.	 Choose Span and Activate the OK button.

4.	 Select the new span tag.
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5.	 Activate the “Selection tool for text and image” on the Acrobat toolbar.

6.	 Select the text in a different language in the document pane.

7.	 Right click or activate the context menu on the new span element.

8.	 Choose “Create Tag from Selection”.

9.	 Reorder any text that appears after the span element so it appears after 
the span element (the text should appear as two separate text nodes 
under the parent element as siblings of the span element).

To set the language:

1.	 Select the tag in the Tags tree that contains the content in a different 
language.

2.	 Right click to activate the context menu.

3.	 Choose Properties from the Options menu.

4.	 Select the Tag tab of the Object Properties dialog.

5.	 Select a language from the Language drop-down.

6.	 Activate the Close button.

Note: 	 The language that is specified for an element also applies to all elements nested 
under it in the logical structure tree.

Step 8: Add Alternative Text

Add Alternate Text and Supplementary Information to Tags

Some tagged PDFs might not contain all the information necessary to make the document 
contents fully accessible. For example, to make a non-text document content available to a 
screen reader, the PDF should contain alternate text for figures and replacement (actual) text for 
some links, formulas and abbreviations.

There are several ways to add alternative text to images and figures:

•	 The “Set Alternative Text” command in the Accessibility tool

•	 The “Set Alternative Text” command in the Make Accessible Actions 
wizard

•	 The Touch Up Reading Order tool (refer to “Add Alternate Text with the 
Touch Up Reading Order Tool” on page 32).

•	 The alternative text field of the Object Properties dialog in the Tags panel

Note: 	 Alternate/Actual text should be short and concise. The Alternative Text field 
should be used to set alternative text for figure elements. The Alternative Text 
field is not announced by screen readers for non-image element. The Actual Text 
field is announced instead when it is present on a text element.
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Add Alternate Text to a Figure

To add alternative text to a figure using the Set Alternative Text command:

1.	 Activate the “Set Alternative Text” command from the Accessibility tool 
pane or from the Make Accessible wizard.

2.	 Enter short but descriptive alternative text for each image.

•	 Decorative images can be marked as decorative in this wizard, which 
will make the image an artifact.	

Note: 	 The “Set Alternative Text” command in the Accessibility tools will display the 
alternative text, if any, for all images. The same command in the Make Accessible 
Actions wizard will also allow the entry of alternative text for images that are missing 
alternative text.

To add alternative text to a figure using the Tags panel:

1.	 Choose View > Show/Hide > Navigation Panels > Tags. 

2.	 Expand the logical structure tree to find and select the desired <Figure> tag 
element for the image. 

3.	 Choose Properties from the Options menu in the Tags panel.

4.	 In the Object Properties dialog box, click the Tag panel.

5.	 Type text in the alternative text field that describes the figure. 

Add Actual/Alternate Text to Links

When a link contains a URL, screen reader will announce the URLs of web links. However, 
meaningful alternate text for links can be much more useful. Alternative text is also useful 
for links that have the same link text and or link text that is not descriptive when taken out 
of context. For example, a link with text of “http://www.adobe.com/accessibility/products/
acrobat/” could be presented using an Actual Text property of “Acrobat accessibility page at 
adobe.com”.

Note: 	 Actual text must be added only to tags that do not have child tags. Adding actual text 
to text links or alternate text to an image link’s parent tag prevents a screen reader 
from reading any of that tag’s child tags. 

Add alternate/actual text to the <Link> tag of a link.

1.	 In the Tag panel, select the <Link> (<Figure> for image link) tag for the 
link to add actual text to and choose Options > Properties.

2.	 In the Object Properties dialog box, activate the Tag tab.

3.	 Type the text in the “actual text” field for the text links, or type text in the 
“alerntaive text” field for image links.

4.	 Activate the Close button.
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Add Actual Text for an Abbreviated Term, Forumla, or Non-Unicode Symbol

It may be useful to provide expansion text for some abbreviations, particularly when assistive 
technologies may mispronounce an abbreviation, or where formulas or non-Unicode symbols 
are used.

In the Tags panel:

1.	 Locate the term to provide actual text for by performing one of the 
following:

•	 Expand the tag tree as needed to see the elements that contain the 
abbreviation.

•	 Use the Touch Up Text tool or the Move to or Make Changes to 
Object tool to select the item in the document.

2.	 Choose Find Tag From Selection from the Options menu to locate the text 
in the tag tree.

3.	 If the abbreviation includes additional text, cut the additional text and 
place it in a new <Span> child tag within the same <Span> parent tag.

4.	 Choose Properties from the Options menu of the Tag tab.

5.	 Type the actual text for the item in the Actual Text field.

6.	 Activate the Close button.

Step 9: Use the Accessibility Checker to Evaluate the PDF File
After all the previous steps have been performed, the PDF file must be checked using the Adobe 
Acrobat XI Pro Accessibility Checker. See the document “Adobe Acrobat XI Pro Accessibility 
Guide: Using the Accessibility Checker” for instructions on how to use the Accessibility Checker.

The Accessibility Checker tool can help to identify areas of a document that may be in conflict with 
Adobe’s interpretations of the accessibility guidelines referenced in the application and its 
documentation. However, these tools do not check documents against all accessibility criteria, 
including those in such referenced guidelines, and Adobe does not warrant that documents comply 
with any specific guidelines or regulations.

Additional Functional Validation Techniques

The Accessibility Checker can evaluate many of the technical requirements for accessibility. 
The best way to test the functional accessibility of a document is to use the document with 
the same tools that readers will use. It is recommended to review the document with assistive 
technologies including a screen reader. Even when a screen reader is not available, the following 
methods provided by Acrobat should be used to check the accessibility of a PDF file:

Use Reflow view to quickly check reading order:

1.	 Activate the View > Zoom > Zoom Text menu.

2.	 Enter 200 in the Zoom field.

3.	 Activate the View > Zoom.

4.	 Activate the Reflow option.

5.	 Verify that all content appears in the correct order.

6.	 Verify that all content is readable while zoomed.
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Use the Read Out Loud to experience the document as it will be heard by readers who use this 
text-to-speech tool:

1.	 Activate > View > Read Out Loud > Activate Read Out Loud

2.	 Activate > View > Read Out Loud > Read this page only

3.	 Verify that all page content is announced in the correct order.

4.	 Repeat for each page.

Save the document as accessible text and then read the saved text file in a word-processing 
application to experience the document as it will be experienced by readers who may emboss 
the document in Braille.

1.	 Activate File > Save as > Text Plain (.txt).

2.	 Select the desired location.

3.	 Activate the Save button.
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