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Introduction
These days more and more photographers have gone digital. Shooting digital is 
extremely liberating and gives photographers immediate and total control over their 
photographs.

In the past, the photographer and the client mulled over Polaroids. Then the photog-
rapher took over and exposed film that nobody could see until it was processed. The 
photographer wrote the work orders for the film and dropped it off at the lab. The next 
day, the photographer received rolls or sheets of film that he or she could drop on a light 
box to loupe and inspect—generally in privacy. Although mistakes at the photo lab 
rarely happened, the photographer sometimes blamed the lab for unfavorable results 
instead of admitting to the client that he or she had a problem on the shoot.

Very few photographers still shoot a large volume of film for delivery. Now it’s shoot 
digital, check the camera display, download the files, edit on the monitor, correct color 
and tone, do web photo galleries or other proofs, collect all the files for delivery and 
burn to CD, and more. The client, the talent, and even the assistants can all look at the 
monitor and see what the photographer shot. Everybody has an opinion, and opinions 
often conflict. 

Although digital photography avoids the time of film processing, using Adobe® Photoshop® 
software correctly to prepare a finished product can still take a lot of time. However, 
there are some ways to work more efficiently. I have the rare benefit of being a Photoshop 
alpha tester. Much of what I’ve learned, I’ve learned directly from product engineers or 
by finagling certain features to be the way I want them.

This paper is all about fast and easy methods, but not at the expense of quality. There are 
four sections to this paper: The File Browser, Photoshop Camera Raw, White Balance, 
and Simple Batching. You can read selected sections, but unless you read and under-
stand the entire process, you’ll have holes in your understanding that can cost you time 
and effort. So, I recommend that you read all four sections.
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The File Browser
I believe that the photographers who don’t like the File Browser really don’t know how to use it. I 
use the File Browser for a lot of things. I use it instead of choosing File > Open or double-clicking 
to open a file. I use it for editing a shoot, batch renaming, calling up batch operations, doing a 
contact sheet or web photo gallery, and storing and organizing final folders. The File Browser is 
not designed to replace a full-fledged asset management system, but it is a good image organiza-
tion system.

For the purpose of this paper, I’m going to walk you through how I edited several days of digital 
shooting in southern Utah in fall of 2003. I travel to the Southwest every year to teach at the 
Santa Fe Workshops and I always ride my motorcycle. The camera goes in the tank bag and the 
computer goes in the right saddle bag. I carry only two lenses, a 16-35mm and a 24-70mm. The 
camera on this trip was a Canon 10D. 

Photo of my motorcycle in Utah

All told, I shot just over 4.2 gigabytes (GB) of raw captures that weighed in at about 5.6 mega-
bytes (MB) before processing and produced a 36.1-MB, 16-bit final file. That’s 3072 x 2048 pixels 
(6 megapixels) before sampling up. A straight print would be about 12.75 inches x 8.5 inches at 
240 pixels per inch (ppi). However, I’ve successfully sampled images up to 24 inches x 30 inches 
at 240 ppi with stunning results.

Structure of image files

Just to show you the original file breakdown and how I deal with downloading while on the 
road, here’s a small screen shot of the drive holding the images. I shot with a single 1-GB card 
and a couple of 512-MB cards, with a few 256-MB cards as backups. At the end of each day, I 
used a FireWire card reader and copied the day’s files to two 20-GB external FireWire drives 
(one of which is a backup). I named an enclosing folder with the location, and then I copied the 
DCIM folder into the folder or into subfolders named disk one, disk two, and so on. I set up my 
folder structure this way for several reasons. I didn’t want to ever risk copying over a previous 
file folder and therefore lose images, and this structure helped keep the day’s shoot organized 
in the field until I could get back to the studio and organize it correctly. I had the camera set to 
auto-increase the capture number so that I wouldn’t risk ever getting two files to overwrite, but 
those DCIM folders posed a potential risk. I burned a DVD to archive the folders when the totals 
reached over 4 GB.
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The File Browser is accurate and allows for very fast browsing. When you first start the File 
Browser, it may look something like the following.

File Browser with default arrangement of tabs

The Folders tab in the upper left pane, the Preview tab in the middle pane, and the Metadata and 
Keywords tabs in the lower left pane are defaults. On the right side are the sorted thumbnails you 
can select to see as a preview. 

File menu

Build Cache for Subfolders command

In the upper left corner, there are menus that offer a lot of control over how the browser performs 
and that provide various commands. The most important commands in the File menu relate to 
the cache. The ability to cache subfolders is new in Photoshop CS and can save you a lot of time. 
By pointing to a folder or an entire hard drive and instructing Photoshop to cache it, you allow 
Photoshop to spend all its resources doing that one thing. Unlike normal browsing, where the File 
Browser caches in the background (a time-consuming process), the Build Cache For Subfolders 
command allows Photoshop to modally take over control and spend all its efforts just caching. 
You will be locked out of Photoshop while it is doing so, but this is the fastest way to have the File 
Browser cache a lot of files. The Utah 2003 folder, containing over 4 GB of raw captures, cached 
in just over 12 minutes on my studio system. My system is fast, but in general, Photoshop caches 
much faster when you do not try to use the File Browser during the caching process.



A Digital Workflow for Raw Processing 
Part One: The File Browser

4

Export Cache command

Searching in a folder

Another important cache command is Export Cache, which you can use to avoid re-caching a 
folder every time you move it. If you burn to a CD or DVD, you need to export the cache so that 
browsing isn’t painfully slow. If you need to copy folders between hard drives—for example, 
copying an external FireWire drive to an internal drive—Photoshop software will need to rebuild 
it unless you export the cache. 

There are two other important cache commands, but you should use them only if your File 
Browser cache somehow becomes corrupted. You use Purge Cache when the cache for a single 
folder or a single volume is corrupted; for example, when dates and times or thumbnails are 
displayed incorrectly. Purging that folder’s cache forces a clean regeneration of the database, 
although you must delete exported cache manually. Note that Purge Entire Cache loses every 
folder or volume you’ve cached, so if you use that command, you’ll have to cache those items 
again. The other useful new command is Search. It allows for a fairly advanced multi-criteria 
search function from within the File Browser—useful for searching on all the volumes or folders 
you’ve accumulated.

Edit menu
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Preferences dialog box

The Edit menu gives you control over certain editing functions, such as rotate, flag, rank, and 
append or replace metadata, and also your preferences and options in the File Browser. Some 
of these same commands are available in the context menu (right-click), but it’s important to 
understand the Preferences command in the File Browser as well as the way you wish to view 
metadata.

Preferences dialog box with useful options selected

When you choose the Preferences command in the File Browser, you access some important 
options. Be sure you understand the impact of what you set. For example, if you don’t want the 
File Browser to become bogged down on large images, you can set it to not show a preview if 
the image is over whatever size you enter. On slower machines, you may wish to deselect Allow 
Background Processing and High Quality Previews. This can help overcome the slow perfor-
mance some people object to. Another important preference is to make sure you keep metadata 
sidecar files with the master file. In addition, you shouldn’t choose to separate your metadata 
Extensible Metadata Platform (XMP) files from your images unless have a specific reason.
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Choosing which metadata fields to show in the File Browser

Another important item in the Edit menu is controlling how and which metadata fields you wish 
to view in the File Browser. You may never wish to see some metadata. Categories such as GPS or 
Edit History just may not be important to you. Within each category, you can choose the individual 
metadata fields you wish to see. You can also have the display collapse and hide any empty fields. 
I highly recommend this. Even in other categories, you may not be concerned over specific fields. 
You can decide which to see and which to hide. 

The importance of the File Browser preferences and the metadata viewing will become apparent 
later, when I explain how to customize the panel tabs for the optimum presentation, depending 
on your particular needs at the moment.

Automate menu

The Automate menu is critical for a fast and efficient workflow while you work in the File Browser. 
Using Batch and Batch Rename, while requiring a certain level of concentration, allows for 
rapid processing of images. Batch Rename won’t do everything you may need to do with naming 
conventions and organization; for some purposes, third-party finder utilities may be far more 
powerful. But, the intent is to offer a wide range of functionality while you work in Photoshop. 
Note that you can now directly access other Automate functions in the File Browser. This access 
enables you to use ranking and flagging to create selections of images for processing.
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Sort menu

The Sort menu allows for control over the sort order of multiple files. While you can now manu-
ally sort images in the File Browser, it’s really useful to re-sort by using various criteria when 
putting an edit together. In some cases, I use elaborate ranking systems to be able to rapidly 
create an extensive sort order. On the other hand, it’s simpler to merely use the Flag method of 
temporarily tagging an image for later viewing. As you’ll see later on, the Flag method allows for 
rapid edits, and the ability to show or hide is editorially useful.

View menu

The final menu in the File Browser is the View menu. This is where you control how and what 
you see in the browser’s thumbnail pane. I often use the various flagged files commands to show 
or hide various files and simplify the range of images I’m editing.

While you may not use the File Browser the way I do, what is important is to understand the way 
in which you can customize it and reconfigure it for a wide variety of different needs. Some of 
the available third-party browsing utilities are quite good. However, none of them have the one 
huge advantage that the File Browser in Photoshop has: It integrates with Photoshop to provide a 
powerful workflow potential. 
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Earlier, I showed what the default browser looks like. I had a hard time doing so because, quite 
honestly, I never use it in its default configuration. I always reposition and resize the panes and 
move the tabs based on what I’m tasked with doing at the moment. Below are a few configura-
tions that I use. Note that these are not the actual sizes of my File Browser screens. I generally 
work with the File Browser open full screen on my main monitor, which has a resolution of 
1920 x 1200 on a 23-inch Cinema Display.

Customized File Browser with the Preview and Folders tabs placed in one pane

This is my basic configuration. I place the Preview and Folders tabs in the same pane. If I’m pre-
viewing an image, I won’t be navigating to other folders. I also keep the Metadata and Keywords 
tabs together, and I have a wide area for the thumbnails. If necessary, I can also change the 
thumbnail view to Medium to show more images or Custom to show larger thumbnails.

Detail view for thumbnails

I’ll often change the thumbnails to Detail view if I need more information on an image-by-image 
basis. However, when I’m editing metadata, I use the next configuration.
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File Browser configuration that lists large amounts of metadata and shows enlarged thumbnails

With this configuration, it’s easy to see a lot of metadata and edit it from within the File Browser. 
This configuration also shows the use of custom thumbnails—256 pixels in this case—that allow 
a large view of images. On a large screen, you normally can view a couple of these large thumb-
nails at a time.

File Browser configuration that shows a huge image area in the preview

Perhaps my favorite File Browser configuration is a really huge preview with a single row of 
thumbnails. I can see a lot of image area in this preview. I wish I could zoom in, but for looking 
at images in a critical manner without actually opening them, this configuration is useful. 
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Location of the Save Workspace command

I always save my workspaces so that I don’t have to repeatedly move the panes in the File Browser. 
A lot of people don’t realize that the saved workspaces capture not only the position of the place-
ment and size of your palettes, but also the exact configuration of the File Browser. All of the File 
Browser setups shown in this screen shot are available at the click of the mouse. And, because 
they’re saved and visible in the Workspace menu, you can also record an action and then choose 
Insert Menu Item so that you can press an assigned F key to quickly and easily change your 
workspace for task-based editing. 

Flag command on the context menu

Selecting the option to show flagged files
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If you customize your File Browser setups and do the things that make working in the File 
Browser faster and easier, you will soon find that it’s a virtual replacement for the Finder. And 
that’s exactly how I like to use it: to move and copy files. I use the Flag command to preselect 
a variety of images. I use the context (right-click) menu or Command + apostrophe (Control 
+ apostrophe on Windows®). You can easily move through a variety of images to quickly edit 
them. Then, by selecting the option to show flagged files, you can view only those images.

Copying files to a new folder during the editing process

In this screen shot, I’ve selected a variety of images from within that particular location’s folder. 
I’ve flagged the images I like and hidden the others. Now I can either move or copy the files to a 
new folder. Generally, because I prefer to keep the original file structure intact within the folder, 
I copy images to a new folder. By holding the Option key (or the Control key on Windows) 
while dragging the images, I can tell Photoshop to copy the files to a new folder. Without hold-
ing down the Option key (or Control key on Windows), the images would simply be moved.

Edited collection of images from various camera disks

This is the resulting collection of selected images from all the various individual camera disks. 
This grouping of 42 images is only the first serious edit. I will pare the numbers down a bit 
more, but to do so I’ll need to open the images in Camera Raw to get a better sense of both the 
aesthetics and the technical merits of each image.



Before moving on to Camera Raw, I want to mention some other issues. Some people 
(like me) liked the ability to dock the File Browser in the palette well in Photoshop 
7.0. Because of the architectural changes in the File Browser in Photoshop CS, such as 
adding the menus, the File Browser can no longer be treated as a hybrid palette/docu-
ment window as it was in Photoshop 7.0. However, if you hold down the Option key (or 
the Alt key on Windows) while double-clicking an image in the File Browser, the File 
Browser will close after opening the file (not quite like having it collapse to the well, but 
functionally similar).

A few additional tips:

• If you are naming files, you can press the Tab key or Shift + Tab to automatically make 
the next or previous image’s name field active. 

• You can maximize space in the File Browser by pressing the Tab key (without an 
image’s text field highlighted) to hide or show all the other palettes.

• Command (or Control on Windows)-clicking the File Browser icon also opens the 
File Browser with the other palettes hidden; Command-click to hide the File Browser 
while revealing the palettes. 

• If you want to use the File Browser most efficiently, use a mouse with a scroll wheel. It 
allows for very fast scrolling without needing to move the mouse around.
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