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ABOUT ROBOHELP CLASSIC (2019 RELEASE)
CHAPTER 1 GETTING STARTED

Getting started

About RoboHelp Classic (2019 release)

Adobe RoboHelp Classic (2019 release) is the renamed version of the RoboHelp application you have 
used in the past and it is optimized for desktop-focused workflows. The user interface and feature set are 
much the same as before. The new RoboHelp (2019 release) installer will install both RoboHelp (2019 
release) - an all new application and RoboHelp Classic (2019 release).

You can easily migrate all your old RoboHelp projects into RoboHelp (2019 release). However, once you 
have migrated and updated your project to RoboHelp (2019 release), you cannot import it back into older 
version of RoboHelp Classic (2019 release).

For more information about the new RoboHelp release, see RoboHelp (2019 release) User Guide. You can 
also take an online course on Introduction to RoboHelp (2019 release).

Basic workflow

Indicative infographic: RoboHelp input and output formats

Create a project

Every Help system has at least one project. The basic element of the project is the topic.

https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fcourses.techcommtools.com%2Fp%2Frh2019intro%2F&data=02%7C01%7Csaibal%40adobe.com%7Cf9c0513dd8e84db73a0a08d5f27a7e72%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636681530283172256&sdata=XGj6Le5Flh8NuM5lD0xb19U5ug%2BYmNB9Dzcd15YRrHw%3D&reserved=0
http://www.adobe.com/go/learn_rh_ug_2019_en
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Author the content.

Create topics. You can add multimedia now, or later when you customize the output. Work with the 
application developer to start planning which topics to also use for context-sensitive Help. Context-sensi-
tive topics appear when the user clicks a Help button in the user interface or presses F1.

Import files.

You can import HTML files, Microsoft Word files (.doc, .docx, .docm, .rtf), FrameMaker books and docu-
ments (.book, .bk, .fm, .frm, .mif), XML files (.xml), and Adobe PDF files (.pdf).

Develop the navigation.

Based on the hierarchy, or organization scheme, of the content, create links among topics and to external 
content if necessary. You can also link text or images to other content. Create a table of contents that 
reflects the content hierarchy, and include an index that users can browse. You can also create browse 
sequences, paths a user can follow through Help topics. For example, if a user must read several related 
topics to understand a feature completely, you can link them in a browse sequence.

Customize the output.

You can apply layouts (which determine behavior and appearance) and formatting. You can also use 
conditional text to show or hide content, depending on user interest, application being used, skill level, 
and other factors. Add multimedia to make your Help more compelling and richer.

Generate, test, and distribute the Help package.

Generate the output so you can view the Help and check links, formatting, and so on. Test every output 
you intend to distribute, including printed documentation.

Activation and registration

To review complete system requirements and recommendations for your Adobe RoboHelp software, see 
RoboHelp Learn & Support page.

If your computer is not connected to the Internet, you can check the ReadMe file on the installation disc.

Install RoboHelp Classic

RoboHelp Classis is bundeled within the new RoboHelp (2019 release) installer. Once you install Robo-
Help (2019 release), you also get RoboHelp Classic. You can install RoboHelp in following ways:
• Technical Communication Suite DVDs: insert the first TCS installer DVD, run the TCS installer, and 

choose RoboHelp (2019 release) from the product list.

https://helpx.adobe.com/support/robohelp.html


3

ACTIVATION AND REGISTRATION
CHAPTER 1 GETTING STARTED

• RoboHelp (2019 release) downloadable link: run the .exe file and follow the on-screen instruc-
tions to install RoboHelp.

In both the cases, RoboHelp Classis is installed in the backend. The install location is within the main 
RoboHelp folder:

\Program Files\Adobe\Adobe RoboHelp 2019\RoboHTML

Help with installation

For Help with installation issues, see the Up and running section on the RoboHelp Learn & Support page.

License activation

During the installation process, your Adobe software contacts an Adobe server to complete the license 
activation process. No personal data is transmitted. For more information on product activation, visit the 
ActivateanddeactivateAdobe products page.

Adobe Product Improvement Program

After you have used your Adobe software a certain number of times, a dialog box appears, asking 
whether you want to participate in Adobe Product Improvement Program.

If you choose to participate, data about your use of Adobe software is sent to Adobe. No personal infor-
mation is recorded or sent. The Adobe Product Improvement Program only collects information about 
the features and tools that you use in the software and how often you use them.

You can opt in to or opt out of the program at any time:
• To participate, choose File > Help > Adobe Product Improvement Program and click Yes, Participate.
• To stop participating, choose File > Help > Adobe Product Improvement Program and click No, 

Thank You.

Adobe provides more information about the Adobe Product Improvement Program in a frequently asked 
questions (FAQ) list on the AdobeProductImprovementProgram site.

Register

Register your product to receive complimentary installation support, notifications of updates, and other 
services. To register, follow the on-screen instructions in the Registration dialog box, which appears after 
you install the software.

NOTE: Register only once for RoboHelp.

http://www.adobe.com/misc/apipfaq.html
http://www.adobe.com/go/activation
https://helpx.adobe.com/support/robohelp.html
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Help and support

Adobe Community Help

Adobe Community Help is an integrated environment on Adobe.com that gives you access to commu-
nity-generated content moderated by Adobe and industry experts. Think of Community Help as collec-
tions of related items rather than books. Adobe continually curates and adds to these collections.

Bookmark the RoboHelp Help hub page to find the best content on the web about RoboHelp, including 
these resources:
• Videos, tutorials, tips and techniques, blogs, articles, and examples for designers and developers.
• Complete online Help, which is updated regularly.
• All other content on Adobe.com, including knowledgebase articles, downloads and updates, Adobe 

Developer Connection, and more.

Accessing RoboHelp help

RoboHelp Classic help is available in the PDF and Microsoft Help (CHM) formats only. When you are 
working in RoboHelp Classic, press F1 to launch the help in a context-sensitive Help viewer. This Help 
viewer loads the CHM version of the Help. If you want to access the PDF version of the Help, visit Robo-
Help Help resource page.

Services, downloads, and extras

You can enhance your product by integrating various services, plug-ins, and extensions in your product. 
You can also download samples and other assets and see various resources to get your work done.

Adobe Exchange

Visit the Adobe Exchange at www.adobe.com/go/exchange to download samples as well as plug-ins and 
extensions from Adobe and third-party developers. The plug-ins and extensions can help you automate 
tasks, customize workflows, create specialized professional effects, and more.

Adobe downloads

Visit www.adobe.com/go/downloads to find free updates, trials, and other useful software.

Adobe Labs

Adobe Labs at www.adobe.com/go/labs gives you the opportunity to experience and evaluate new and 
emerging technologies and products from Adobe. At Adobe Labs, you have access to resources such as 
these:
• Prerelease software and technologies
• Code samples and best practices to accelerate your learning
• Early versions of product and technical documentation

http://www.adobe.com/go/learn_rh_help_res
http://www.adobe.com/go/learn_rh_help_res
http://www.adobe.com/go/exchange
http://www.adobe.com/go/labs
http://www.adobe.com/go/downloads
https://helpx.adobe.com/support/robohelp.html
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• Forums, wiki-based content, and other collaborative resources to help you interact with 
like-minded users

Adobe Labs fosters a collaborative software development process. In this environment, customers 
quickly become productive with new products and technologies. Adobe Labs is also a forum for early 
feedback. The Adobe development teams use this feedback to create software that meets the needs and 
expectations of the community.

Adobe forums

To reach out to experts in the Adobe RoboHelp community, visit Adobe RoboHelp Forum. If you 
comment on a Help page, the comment is automatically posted on the forum. The experts and other 
users can respond to your comment.

Adobe TV

Visit AdobeTV to view instructional and inspirational videos. The TechnicalCommunications channel 
features videos relevant for technical communicators. The videos on the RoboHelp channel help you get 
started.

If you are a beginner, then watch the RoboHelp for Beginners video. If you are an advanced user, then 
you should watch the RoboHelp for Advanced Users video.

RoboHelp sample projects and output

Visit the RoboHelp resources page and download sample projects created with RoboHelp and other 
resources, such as workspaces and applications configured for implementing context-sensitive Help.

RoboHelp Developer Center

Visit RoboHelp Developer Center for articles written by internal and external RoboHelp users on various 
user-requested topics.

Previous RoboHelp Help

Download the documentation of older versions of RoboHelp from the RoboHelpHelphub page.

RoboHelp Classic feature summary

Produce stunning interactive content with next- generation HTML5 publishing

Next generation Responsive HTML5 layouts
Present a visually rich content to your audience by using the chrome-less HTML5 layouts. The inter-
face features a cleaner look and feel, which makes it easy to jump to the most useful information 
quickly. These professionally designed layouts offer a superior search and intuitive navigation expe-
rience.

https://my.adobeconnect.com/rhforbeginnersv2/
http://www.adobe.com/go/learn_rh_devnet_en
http://tv.adobe.com/show/learn-robohelp-9/#/show/learn-robohelp-9
http://tv.adobe.com
https://my.adobeconnect.com/rhforadvanceusersv2/
http://www.adobe.com/go/learn_robohelp_forum_en
http://tv.adobe.com/channel/technical-communication/
http://www.adobe.com/go/learn_rh_devnet_resources_en
http://helpx.adobe.com/robohelp.html
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The layouts are preloaded with an assortment of useful features, like in-page topic slider, show or 
hide widgets such as glossary and TOC, add topics as favorites and more. It offers a responsive 
design that makes the website perform equally well on screens and devices of different sizes. The 
content adjusts dynamically as per the screen size of your device.

For more information, see Customizable HTML5 Indigo layout

Search faster with auto-complete
The search field in the responsive HTML5 output displays predictive search results based on a few 
characters that you type.

When you type the first few letters of any topic, subject or keywords into the search box, the rele-
vant suggestions start appearing in the drop down. The search results appear instantaneously and 
you don’t have to enter the full search string or click on search button every single time. Your users 
get better results that are more contextual and relevant in lesser time and in lesser number of 
clicks.

The powerful algorithm working at the background narrows down the search results for higher 
working efficiency. This greatly simplifies the search task and generates accurate results. The 
search results are intelligently ranked based on the frequency of the search term's occurrence 
within the content.

For more information, see Search auto-complete.

Thumbnail support for images
With the thumbnail support for images, you can publish and show images as thumbnails. This 
reduces your page load time, potentially saving bandwidth, making it easier to render and view 
content on mobile devices.

The thumbnail images are clickable, causing the larger image to load at user’s discretion. This 
makes the content user-friendly, saving the user from having to download large image files that 
they don’t need to see. With the image thumbnails in place, users can click on only those images 
that are of their interest. The users would have greater flexibility in setting a standard thumbnail 
size which will provide consistent look-and-feel of thumbnails across published output.

For more information, see Image thumbnails.

Greater content accessibility
The output that you generate using the Indigo themed Responsive HTML5 layout is 508 compliant. 
With the improved usability and accessibility of your website, you can increase the reach of your 
online content. You can benefit all of your customers, regardless of their special needs, by 
complying with web accessibility standards. A potentially greater benefit of an accessible content 
is better visibility to search engines.

Add favorites in Responsive HTML5 layouts
With the Indigo themed Responsive HTML5 layout, you can mark topics as favorites and add 
custom links thereby saving time and effort while accessing the content again.
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Do more in less time

Folder import for baggage files
Save time and work efficiently with the ability to import folders to baggage files. If you have 
multiple baggage files stored in a folder, you can add all of those files in a single click by adding that 
folder to the project. This makes importing relevant folders containing support information a lot 
easier. The hierarchal structure of the added folder is maintained in your project’s baggage file 
folder.

For more information, see Add files and folders to the Baggage folder.

Toggle variable views
Get greater content accessibility and save time by easily toggling between the variable name and 
the value it represents in multiple ways - using keyboard shortcut or the context menu. This helps 
you to view content as the end users would see it. You have the option to either toggle a single vari-
able or all the variables used in your project with a single click.

When you toggle all fields, by default the current state of the selected variable or the first variable 
of the topic is replicated across all the variables in the currently active document.

For more information, see Toggle variable views.

About RoboHelp Server

Adobe RoboHelp Server is a server-based Help solution that provides real-time end-user feedback on 
your Help and knowledgebase. RoboHelp Server gathers and logs data about what questions users ask 
while searching content and how users navigate through topics. Results are displayed in an easy-to-view 
graphical format for quick interpretation. Your Help system resides on a server (for example, Adobe Help 
Resource Center), and you can make instant updates to your Help system content.

RoboHelp Server contains the back-end processes, database functionality, and JDBC connections neces-
sary to integrate it. RoboHelp Server works with the authoring tool, so authors can edit content, set 
master project options, maintain windows, and view reports.
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RoboHelp Server interaction with different components

NOTE: With RoboHelp Server, you can install your database server on a separate machine or use any of 
the existing database servers.

Tracking and reporting

Adobe RoboHelp Server provides end users with the ability to find information when they have ques-
tions. Users can view content using any standard browser and operating system. Any number of users 
can access the published documents.
NOTE: You can define the maximum number of database connections for Oracle and Microsoft SQL Server 
database management systems through the maxload property in the robohelp_server.properties file.

RoboHelp Server tracks the following types of data:
• Where users request assistance: Identifies the location where users make repeated requests for 

specific information.
• How users search: Searches that users perform repeatedly. This data can be mined to move 

frequently searched information to a more prominent position in the content for easier access. You 
can also use this information to find information gaps and to improve heading titles for more intu-
itive navigation.

• How users navigate online content: Tracks how users seek information in online content and how 
frequently they access particular information such as headings and articles. This information is 
available at a topic level.
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• RoboHelp Server tracks the entire operating system and browser details. You can use this informa-
tion to improve the content quality for browsers preferred by users.

Automatic project merging

Concurrently work on multiple projects and merge them into a single project at run time.

While building an online information system, authors can develop and publish their content according to 
their own schedules. RoboHelp Server provides automatic project merging, so authors can work on 
different parts of a project at the same time, and publish them to the same server. When end users view 
the content, they see one seamless online information system. Do not worry about sharing source or 
depending on a single author or project—all separate projects are merged when users access the 
content. Users can navigate across all the projects using the Index, Contents, and Search buttons.

By default, projects are added to the Table of Contents in the order they are published to the server. You 
can customize this order in the Projects page of the Web Admin interface. When you merge projects, 
each project file in the authoring tool remains intact, but the keywords from the indexes and glossary 
terms are combined at run time, or when end users access the system from the server.

Support for languages other than English

The runtime interface (including Table of Contents, index, glossary, and search) can be automatically 
localized, and authors can publish projects written in various languages to the same server. RoboHelp 
Server supports localization for French, German and Japanese languages. You can change the display text 
on the user interface of the online system to another language, including text on the Contents, Index, 
and Search buttons.

In addition, end users can perform a full-text search of online content in their native language. This flex-
ibility allows authors to develop content in languages other than English and take advantage of 
server-based online information systems.

Integration with SharePoint

RoboHelp versions 10 and above provide native integration with Microsoft SharePoint. This integration 
allows for an end-to-end workflow using SharePoint as the content repository. It also allows for the 
sharing RoboHelp assets across projects and users. You can then use the SharePoint workspace as a 
repository for your RoboHelp generated PDF reviews and finally publish the RoboHelp content to the 
SharePoint server.

Use SharePoint as content repository for RoboHelp content:
RoboHelp supports version control with Microsoft SharePoint 2010 and above natively. This means 
that you do not need to install any third-party plugins. Add your RoboHelp projects to SharePoint 
repository. You can then check-in and check-out files, and perform other version control operations 
from within RoboHelp. For details, see Version control with Microsoft SharePoint.



10

INTEGRATION WITH SHAREPOINT
CHAPTER 1 GETTING STARTED

Publish Multiscreen and Responsive HTML5 content to SharePoint natively for both desktop and 
mobile access:

Publish RoboHelp content directly to a SharePoint site from within RoboHelp and in accordance 
with Microsoft security and compatibility recommendations. RoboHelp supports publishing the 
Multiscreen HTML5 and Responsive HTML5 output to SharePoint in its native format (ASPX), 
ensuring a problem-free display of output in SharePoint. When you view the published output, the 
topics appear in the SharePoint chrome as a single continuous HTML page. For details on publishing 
to SharePoint, see the details on the SharePoint tabs in the respective dialog documentation for:

• Generate Multiscreen HTML5 output
• Generate Responsive HTML5 output

Link SharePoint assets across RoboHelp projects and users:
You can link SharePoint assets (such as images, multimedia files, captivate videos, CSS files etc.) 
across multiple RoboHelp projects and authors. Live linking in RoboHelp Resource Manager is inte-
grated with SharePoint. This implies that when an asset is modified by one author, the change is 
reflected in all the topics and in all the RoboHelp projects that use (link) that asset. For details on 
how to add a SharePoint location, see Add a shared location.

Host RoboHelp content on SharePoint workspace for PDF review:
Select the RoboHelp topics that you want to send for review. Host this PDF for review in the Share-
Point workspace, and send the link to reviewers. Your reviewers can provide review comments 
using the free PDF reader, without having to install or learn any additional software products. You 
can then import all the comments from stored on the SharePoint workspace to the RoboHelp 
project in one click. For details, see PDF review.

SharePoint version matrix

The following matrix details the RoboHelp - SharePoint version support.

RoboHel
p 

Version Version control Publish Resource sharing Review

11 SharePoint 2010 
+

Native support: 
SharePoint 2010 +
Via SharePoint mapped 
drive: SharePoint 2007

SharePoint 2007, 
2010 +

SharePoint 2007, 
2010 +
Adobe Acrobat X +

10 SharePoint 2010 Native support: 
SharePoint 2010
Via SharePoint mapped 
drive: SharePoint 2007

SharePoint 2007, 
2010

SharePoint 2007, 
2010
Adobe Acrobat X +
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Exploring the workspace

Workspace overview

You work in RoboHelp using various elements, such as pods, panes, bars, and windows. Any arrangement 
of these elements is called a workspace. The RoboHelp workspace includes pods, panes, and customiz-
able tabs. Customize the Quick Access Toolbar to include your most frequently used commands. You can 
also customize keyboard shortcuts.

RoboHelp workspace

A.
Quick Access Toolbar

B.
Tabs

C.
Tabbed Document pane

D.
Design and HTML view panes

E.
Document area selectors F.Workspace switcher
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G, H, I.
Clubbed pods

Quick Access Toolbar

The Quick Access Toolbar in the upper right corner contains the most frequently used commands.

The right-most drop-down contains the following options:

More Commands
In the Customize dialog:

Customize the RoboHelp keyboard shortcuts

Change the RoboHelp theme: light or dark; colored or grayscale icons

Add or remove commands to the Quick Access Toolbar.

Show Below the Ribbon
Display the Quick Access Toolbar above (default) or below the ribbons.

Minimize the Ribbon
Show (default) or hide the RoboHelp ribbon.

RoboHelp Tabs

The RoboHelp tabs, such as Project, Edit, Output, and Review, provide you quick access to all the avail-
able RoboHelp commands. For more details, see Working with the RoboHelp tabs.

Tabbed document pane

The topic window or the Tabbed Document pane displays the topic(s) that you are editing currently. 
Select File > Options > Allow Editing Of Multiple Topics to edit multiple topics concurrently. You can paste 
objects and selections across multiple topics. You can select horizontal or vertical tiling of topics.

The Design and HTML buttons in the topic window let you switch between Design Editor and HTML 
Editor.

When multiple topics are open, click the down arrow button in the upper-right corner of the Tabbed 
Document pane to display the list of open topics and navigate to any topic.

Take advantage of fixed buttons in the Tabbed document pane to open and close topics quickly.

Right-click a tab to find options to save the active topic, close the active topic, close all topics, close all 
but the active topic, and create horizontal or vertical tab groups.
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Pods

Various pods, such as Project Manager, Output Setup, Resource Manager, and Single Source Layouts, 
help you complete the different steps to create the project and generate the required output. Select 
Project > Open > Pods to show or hide pods that you require.
NOTE: You can also access the list of pods in the Edit tabs.

From the context-sensitive menu of the title bar of a pod, access options such as Dockable, Floating, and 
Tabbed Document to arrange pods in various ways. The menu also includes options to hide and close the 
pod.

Working with the RoboHelp tabs

The RoboHelp commands included in logical groups and put together in the various tabs. Each tab 
contains commands of related functionality. Also, the tabs are groups based on the tasks performed by 
a user at any point of time. For example, the Edit tab includes commands specific to editing RoboHelp 
content. The Output tab includes command related to generating output.

Some common commands are included in different tabs. For example, the Pods drop-down list is avail-
able in the Project and Edit tabs. Also, some tabs are contextual only appear in the related context. For 
example the Table tab only appears when you are working in a table.

The RoboHelp interface includes the following tabs:

Tab Description

File Contains options such as open, close, rename and list recent projects. This tab also 
provides links to several help and community resources and options to customize 
RoboHelp preferences.

Project Includes commands associated with a project. You manage, create, import, edit, 
and delete project level components such as topics, snippets, tags, and variables. 
You can save the currently unsaved changes across the project.

Edit Allows you to perform authoring tasks such as creating and editing stylesheets. 
While authoring the contents of a topic, snippet, or master page, you can choose 
the commands in this tab such as Bold, Italic, font, and align. You can also apply 
tags to content.

Insert You use the commands to insert various types of objects at various points in your 
project. These objects include tables, images, Captivate content, and snippets.

Review When setting up or importing the comments from a PDF shared review, you can 
use the commands in this tab. This tab also includes commands that allow you to 
track changes, accept and reject changes in a document review.

Collaborate Includes commands that allows you to share project resources across users. You 
can also set up and use version control.
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Working with pods

Pods are workflow panes that you can float or dock anywhere in the application window. They provide 
quick access to logically grouped features from one location. For example, you can select and generate 
various layouts from the Single Source Layouts pod.

RoboHelp provides access to your most frequently used pods and projects, with flexible options. You can 
move a pod anywhere on the screen or to a different monitor. Use the auto-hide feature of pods to show 
or hide them on the desktop.

View a pod

1) Do one of the following:
– Select Project > Open > Pods > [pod name].
– Select Project > Open > Pods > [pod name].

Arrange pods

• Click the title bar of a pod and drag-and-drop it on the required part of the screen.
• Change the display of the pod.

a) Do one of the following:
• Click the down arrow button in the upper-right corner of a pod.
• Right-click in the titlebar of the pod.

b) Select one of the following options:

Output The options in this tab allow you to create, setup, generate, and view RoboHelp 
outputs.

Tools You can create and view reports. RoboHelp ships with a number of scripts that you 
can use to perform certain commands. Select and execute scripts from the Scripts 
list in this tab.

Table Provides access to table specific commands such as merge, split, borders and 
shading.
Note: This tab is context sensitive and only displays when the insertion point is 
within in table.

Positioning Allows you to position and size a Positioned text box.
Note: This tab is context-sensitive and only displays when a positioned text box is 
selected. To insert a positioned text box, go to the Insert tab and choose Positioned 
text box.

Tab Description
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Dockable
Docks the pod if it’s in the Tabbed Document state or in the Floating state

Close
Closes the pod

Floating
Floats the pod if it’s in the Tabbed Document state or in the docked state

Auto Hide
Pins or unpins the pod if it’s not in the Tabbed Document state.

Tabbed Document
Opens the pod in a new tab in the topic window.

Types of pods

Starter pod

The Starter pod provides links to common commands and product information.

Recent Projects
Open recently used projects (up to ten recent projects are listed) and other projects.

Create New
Select the Help type you want to generate.

Import
Import a Help project, such as an HTML Help project, Word document, and all other available types.

Resources
Access forums, developer centers, knowledgebase articles, complete online Help, videos, and other 
online content.

Access a stream of latest learning resources featured in the Starter pod. If you find the stream distracting, 
you can hide it by deselecting the Show Learning Resources On Starter Page option in general settings.

Project Manager pod

The Project Manager pod contains various folders where you create and delete project files, or edit their 
properties. It also has folders for various key project components, such as the table of contents, the 
index, and the glossary.
TIP: If the project has many topics, collapse the Project Files folder first to view the other folders.

RELATED LINKS:
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Project Manager folders

Output Setup pod

The Output Setup pod contains the following folders:

Windows
Containers for output. Custom windows for projects are stored in this folder. Modify window prop-
erties by double-clicking a window icon.

Master Pages
Use master pages to reuse information and create a standard appearance across topics.

Skins
Use skins with WebHelp or FlashHelp projects to change the appearance of the Help system. You 
can match the appearance of a company website or add interest and style to the output. Use skins 
to customize colors, buttons, text, fonts, icons, backgrounds, multimedia (FlashHelp projects), 
images for TOC icons and navigation buttons, and more.

Screen Profiles
Container for screen profiles used in Multiscreen HTML5 output.

Screen Layouts
Container for screen layouts used in Multiscreen HTML5 output.

Context-Sensitive Help
Container for the Map Files folder and the What’s This Help Files folder.

• Use the Map Files folder to access map files and perform most window-level context-sensitive Help 
tasks.

• Use the What's This Help Files folder for field-level context-sensitive Help in HTML Help projects.

RELATED LINKS:
Windows

Master pages

Skins

Screen profiles

Screen layouts

About context-sensitive Help

Map files and map IDs

Snippets pod

Add custom HTML code snippets to a project for insertion later into desired topics. When you modify a 
code snippet shared by different topics, the changes are reflected in all the associated topics.
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Snippets are stored in a Snippet library as separate files with the .hts extension. In the Snippets pod, you 
can organize them in categories, expanding or collapsing the categories for easy viewing. The category 
names appear in a sorted order in the Snippets pod and in the Insert dialog box. You can drag snippets 
to desired locations in a topic. You can also select snippets and then copy, duplicate, or delete them. 
Select the Preview option from the context menu to preview a snippet.

RELATED LINKS:
Single-source with snippets

Styles And Formatting pod

Use the Styles And Formatting pod to apply styles quickly. Select a style in the pod and apply it to the 
selected text in the topic. You can create and edit a style directly from the pod. Right-click the name of a 
style to rename, delete, or preview that style.
NOTE: Select Project > Open > Pods > Style and Formatting, to view the Styles And Formatting pod. You 
must open a topic to view the Styles And Formatting pod.

RELATED LINKS:
Create a style using the Styles And Formatting pod

User Defined Variables pod

From the User Defined Variables pod, you can accomplish these tasks:
• Create, edit, or delete variables.
• Create, edit, or delete variable sets.
• Provide and modify runtime values uniquely for different variable sets while generating the output.
• Format variable values.

RELATED LINKS:
User-defined variables

Error List pod

The Error List pod shows buttons for errors, warnings, and messages that are displayed when you try to 
validate a topic or a master page. You can click these buttons to display the relevant information in the 
Error list. The caption of buttons shows the number of errors, warnings, and messages. You can click all 
of these buttons to display the relevant information.

Output View pod

The Output View pod displays important errors, warnings, and messages that RoboHelp captures while 
importing content or generating project output. You can use the Quick Access Toolbar and the right-click 
options to save, copy, select, or clear the log.

Toolbox pod

The Toolbox pod provides shortcut icons to access various tools that come with RoboHelp. You can also 
add tools.

Graphics Locator, HTML Help Studio, and Resize are some of the default tools.
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Resource Manager pod

Resource Manager stores all the common resources to use across projects and allows for quick access 
and management of common resource files.

Shared Locations
Specify the various shared folders that store resource files to use across projects. While a shared 
location can contain files of any type, Resource Manager displays only those that match defined file 
types (Add/Edit Categories).

Categories
Specify categories to organize resources according to file types. For example, you can add a cate-
gory called Video and associate .flv, .swf, and .avi file types with it.

File Types
List the extensions associated with a category. For example, for the Images category, list all the file 
types that you want Resource Manager to consider as images.

Linked Resources
Manage linked resources (resources used in the project with links to the original versions in the 
shared locations). Synchronize the original version and the copy, remove links to stop automatic 
tracking of updates, or replace links to point to another resource of the same file type.

RELATED LINKS:
Managing Shared resources

External content search pod

The External Content Search pod lets you specify URLs for content available outside the Help system (for 
example, in blogs) and map them to terms that users are likely to search for. By curating relevant content 
in this way, you can optimize the search experience for users and provide easy access to user-generated 
content.

RELATED LINKS:
External content search

RoboHelp Server pod

The RoboHelp Server pod enables you to connect to RoboHelp Server. You can configure the setup for 
the server by selecting Responsive HTML5, WebHelp Pro, or FlashHelp Pro as the primary layout.

You can enter http://<server-name>:<port-number>/<context-name>/server and connect 
to it to publish your projects.
NOTE: By default, RoboHelp Server uses the http protocol. To specify that the https protocol should be 
used, enter https://<servername>:<port-number>/<context-name>/server.
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Environments

A RoboHelp environment refers to the arrangement of various workspace components, such as pods, in 
the main application window. By saving the current workspace as a named environment, you can restore 
that workspace even if you move or close a pod. The names of saved environments appear in the Work-
space menu on the right of the menu bar.

Create and save an environment

You can create multiple environments for a project. Only one environment is loaded at a time.
1) Arrange pods.
2) Click the down arrow button in the workspace switcher and select Save Environment.
3) Type a filename, including the .rhs extension.
4) Specify a location for the environment. The default location is C:\Documents and Settings\[user 

name]\My Documents\My RoboHelp Projects.

NOTE: You can exchange an RHS file with other authors.

Load an environment

1) Click the down arrow button in the workspace switcher and select Load Environment.
2) Browse to an RHS file and select it.
3) Click Open.

NOTE: The last environment you used before closing RoboHelp is used the next time you open RoboHelp.

Restore the default environment

1) Click the down arrow button in the workspace switcher and select Default Environment.

Delete an environment

1) Do one of the following:
– Delete the RHS file from the location where it was stored.
– Click Start > Run. In the Open box, type regedit and click OK. Locate the MRUENVFile[n] vari-

able in HKEY_CURRENT_USER > Software > Adobe > RoboHelp > [version] > Common and 
delete the string assigned to the variable.
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Create or remove keyboard shortcuts

Create keyboard shortcuts

1) Click the drop-down arrow on the right of the Quick Access Toolbar and choose More Commands.
2) In the General tab of the Customize dialog, check Show Keyboard Tips to display the keyboard 

shortcut if you press the Alt key, hold it down for a couple of seconds and then release the key.
3) Click Customize Keyboard Shortcuts.
4) In the Category drop-down, choose a tab category.
5) Choose a command from the Commands list and then place the insertion point inside the Press 

new shortcut key box.
6) Use the keyboard to choose a shortcut key combination and click Assign.

Remove or reset keyboard shortcuts

1) Click the drop-down arrow on the right of the Quick Access Toolbar and choose More Commands.
2) Click Customize Keyboard Shortcuts.
3) Do one of the following:

– To remove a keyboard shortcut, select the category and command for the shortcut to remove. 
Select the shortcut in Key Assignments, and click Remove.

– To restore all shortcuts to their default settings, click Reset All.

4) Click Export to export you Keyboard shortcuts to a .csv format.
You can then share shortcuts file.

Configure general settings

1) Select File > Options. Click General and set the following options to configure options for using the 
program and working with project files.

Set the default language and other preferences

Default Language for New Projects
Allows you to change the default language for every project that is created using the RoboHelp 
application.

Use Underscores In File Names
Saves topic filenames with underscores between words (for example, My_Help_Topic.htm). For 
HTML Help projects, topic filenames require underscores rather than spaces. This convention 
enables the book or page to synchronize with the topic content displayed at the right side of the 
viewer.
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Automatically Check For Updates
The program checks for updates when you quit the program. You can also enable this option by 
selecting File > Help > Check For Updates.

Allow Editing Of Multiple Topics
Opens topics in different tabs in Design Editor and allows editing. Deselect this option to work in 
single-topic mode.

Clear Project Cache (.cpd File) Before Opening Any Project
Controls whether the old <ProjectName>.cpd file will be deleted each time while opening a 
project and a new <ProjectName>.cpd will be created from the project files.

Remember Project State
Check this option to ensure that RoboHelp remembers the location of the opened files and pods. 
The next time you open RoboHelp, the project will open in the same state. Uncheck this option to 
prevent RoboHelp from remembering the current state.

Auto-Compile Outdated Files
When you view or publish your project, the program automatically generates your primary layout 
when the output files are out of date. If this option is disabled, the program prompts you to 
generate the primary layout if the output files are out of date.

Auto-display Output View
Shows the Output View at the bottom of the program window when a project is generating.

Convert RoboHelp-edited Topics To HTML
Converts XHTML topics created or edited in RoboHelp into HTML in the output. Topics created or 
edited with third-party editors are not converted.

Show Learning Resources On Starter Page
Show or hide the area in which a stream of learning resources, such as webinars, video tutorials, 
and whitepapers, is displayed on the Starter page.

Enable or disable confirmation

Prompt when a file is saved
The A File Is Saved option is disabled by default. Changes to the current topic are saved when you 
open another topic or close the project without saving. You can disable this setting here if neces-
sary. For example, if you change a topic and want to restore the content, you can temporarily 
disable the automatic save.

Prompt when auto-generated topics from linked documents are modified
Allows you to enable or disable the message displayed when you modify a topic generated from the 
contents of a linked Word or FrameMaker document.
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Enable, disable, or reset notifications

By default, notifications are enabled. Some notifications include an option (Don’t Ask Me Again) to 
suppress their display.
• To enable or disable all notifications, deselect or select File > Options > General > Do Not Show Noti-

fications.
• To restore all notifications to their default settings, click Reset All.



23

PROJECT BASICS
CHAPTER 3 PROJECTS

Projects

Project basics

About projects

Projects contain the source files that become the final Help system. Help authors work with the project 
files, and Help users view the output. For CHM output, the project contains the content you create and 
the properties you set up, such as what the output window looks like. The developer determines the 
window for WebHelp and FlashHelp output formats, or leaves them to run in your browser window. 
Create folders in the Project Manager to organize topics and structure the Help system.

Projects are collections of files. The project file (XPJ file) contains information about the content and 
properties of the project. Whenever you change the project, this file (and any other affected file) is 
updated automatically. Project files consist of the following:

Content
Project files contain topics with content and information about the location of topics, images, 
index, TOC, and other files.

Properties
Projects contain setting information, such as project title, language, and windows. When you first 
create a project, the basic (default) settings are used. Modify these settings according to your 
design needs.

Navigation
Projects include a table of contents, index, and full-text search.

You can view the elements that make up a project in several places, including the Project Manager, 
Single-Source Layouts pod, and Project Settings dialog box. You can also generate various reports 
(Tools > Reports) that identify project status, duplicate topics, files distributed with Help, and so on.

Help project components

Help systems are made up of different components that vary according to the Help format you deliver.

Projects
RoboHelp HTML creates a main project file (with the extension .xpj) that contains the information 
about your topics, images, and other files. (Open this file to open a project.) Project files also 
contain the settings that affect the appearance and functionality of a Help system.
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Topics
The basic unit of a Help system is the topic. Topics communicate the message of the Help system, 
mainly through text and images. You decide the content, format, and organization of your topics.

Table of contents
If a table of contents is included, users see a Contents tab or button when they open the Help 
system. The table of contents presents a hierarchical outline of what the Help project contains. 
Users can browse and select topics to view from the Contents tab.

Indexes
If an index is included, users see an Index tab or button when they open the Help system. The index 
displays a multilevel list of topics and keywords or phrases that you’ve specified.

Full-text search
Full-text search allows users to find specific words and phrases that occur in the content.

Links and navigation
Users navigate a Help system by clicking links. You design the strategy that connects your topics 
together. The most common links are from one topic to another. Links can also go to topics in 
different Help systems, different output formats, and even to a website or an application.

Styles
You format topics using styles. Styles are named formats that you design and apply to control the 
layout and appearance of text.

Image and multimedia files
Images and multimedia files enhance Help by adding graphics, sound, video, animation, and more.

Windows
Windows are the frames that display topics. In certain output formats, you can customize the 
appearance and attributes of windows. You can also design new windows to suit your content. You 
can open multiple windows and from the Windows dialog box, select a window and click Activate 
to bring it to focus. Click Save to save the displayed window in focus. Using the Windows feature, 
you can rename the project title to display in the output.

Compilers
The Help compiler isn’t part of the final Help file, but you sometimes need a compiler to create the 
Help file. For example, in Microsoft HTML Help projects, the compiler aggregates the source files 
and other project components. The compiler then creates one Help system file that you distribute 
to end users. (WebHelp and FlashHelp projects are not compiled.)

Viewers and browsers
Users access the Help system from within a viewer or browser.
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Files in a project

Main project file (XPJ)

The project file (.xpj) is XML-based. You can open project files with the .mpj extension, the format for 
older versions of RoboHelp, but they convert to XPJ files.

Folder files (FPJ)

Each project folder has an FPJ file that lists the folder contents. RoboHelp displays only those subfolders 
and topics that are listed in the FPJ file of a folder.

All the subfolders have their respective FPJ files. The name of an FPJ file except the FPJ file for the project 
folder is same as that of the folder.

The name of the FPJ file for the project folder is root.fpj. The root.fpj file is modified if you add, delete, 
or rename a topic or subfolder inside the respective folder. The root.fpj file is also modified if the order 
of topics or subfolders is changed in Project Manager.

Single-source layout files (SSL)

A single-source layout file (SSL) is used for each single-source layout. An SSL file stores the properties of 
the respective single-source layout and is modified when you edit the properties. An SSL file does not get 
modified on generating, viewing, or publishing a single-source layout.

Auxiliary project files (APJ)

The following components have corresponding APJ files, which get modified when you edit the compo-
nents:
• Baggage files
• Colors
• Conditional build tags
• Font sets
• Information types
• Map files
• Pop-up note topics
• See Also keywords
• Skins (when adding or removing skins only)
• Single-source layouts (when adding or removing single-source layouts only)
• Topic keywords
• Topic templates (when adding or removing single-source layouts only)
• Windows

Other types of files

When you modify the following components, the respective file gets modified:
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• Browse sequences (BRS)
• Topics (HTM)
• TOC (HHC)
• Index (HHK)
• Glossary (GLO)
• Image and multimedia files (filename extension varies)
• Style sheets (CSS)

About output types

RoboHelp can generate the following output types. These types have common basic characteristics but 
different features and viewing and platform requirements.

WebHelp
Adobe WebHelp format works with virtually any combination of browser and platform for 
web-based or desktop applications, online Help, and online books. WebHelp also provides custom-
izable navigation panes and quick downloads.

WebHelp Pro
WebHelp Pro is used for web-based applications, with features available only in server-based Help. 
WebHelp Pro provides feedback on the use of your Help system. Authors can work on separate 
projects and publish anytime, and projects are merged on the server at run time. RoboHelp Server 
is required to generate WebHelp Pro.

FlashHelp

Adobe FlashHelp® uses Adobe Flash® to provide an interactive navigation pane, customizable navi-
gation controls, Flash animation, streaming video, audio, and graphics. Users need Flash Player.

FlashHelp Pro
FlashHelp Pro is used for web-based applications, with features available only in server-based Help. 
Authors can work on separate projects and publish anytime, and projects are merged on the server 
at run time. RoboHelp Server is required to generate FlashHelp Pro.

Multiscreen HTML5
Multiscreen HTML5 output lets you deliver a reading experience that is optimized for specific types 
of devices. You can add and configure different screen profiles for different sets of devices and 
generate Multiscreen HTML5 output for these screen profiles. When users visit the landing page 
for the Multiscreen HTML5 output on their devices, they are automatically redirected to content 
optimized for their device.
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Responsive HTML5
Using Responsive HTML5, you can create a single output that is optimized for all your screens. 
Responsive HTML5 automatically adjusts to the screen a user is accessing it from and also adjusts 
to dynamic screen size changes, such as a flip of orientation or resizing of the browser.

 You can also publish Responsive HTML5 output to RoboHelp Server 10.

eBook
The eBook layout helps you generate output in EPUB 3 and Kindle Book (MOBI) formats.

Microsoft HTML Help
Microsoft HTML Help is used as application and stand-alone Help for Windows 98 and later, using 
Internet Explorer 4.x or later, and provides unique features. NOTE: Due to Microsoft security 
changes, Microsoft HTML Help is now used where the Help has to be run on the users' PC; it cannot 
be installed on a server without registry changes. WebHelp and FlashHelp are used where the Help 
is to be run from a server. WebHelp and FlashHelp can be run locally, but it is not recommended.

XML
XML output exports to Extensible Markup Language (XML) format, used to structure, store, and 
send information. XML files use style sheets, as well as handler files. Handler files determine how 
RoboHelp imports or generates the XML files, associated style sheets, and related components.

JavaHelp
JavaHelp, from Sun Microsystems™, works with Java applications and is a delivery system, not an 
authoring tool. JavaHelp features (TOC, index, searches, controls, global search and replace, 
pop-ups) are created automatically, along with HTML features (links, Related Topics buttons, and 
image files).

Oracle Help
Oracle Help for Java™ is used with applications written in any language. Oracle Help and the ICE 5 
browser provide TOC, index, full-text searches, pop-ups, context sensitivity, and customizable 
windows, through the Oracle Help viewer.

Printed documentation
RoboHelp enhanced printed documentation provides control over structure, content, and appear-
ance of printed documents. You can organize the content as needed, format using CSS or Word 
template styles, and produce formatted and structured Word documents or PDF files.

Adobe AIR
The Adobe AIR output type allows you to generate Help in Adobe AIR format. Generate your 
content in the cross-platform Adobe AIR Help format that brings a host of enhancements, such as 
these:

• Easy navigability through breadcrumbs, and more
• New templates and skins
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• A rich branding experience, and the ability to insert corporate logos and an About box in Help
• Rich commenting and auto-updates
• Browser-based Help, with both offline and online content.
• Ability to add and access RSS feeds
• Enhanced search

End-user viewer requirements

End-user 
system

Responsive 
HTML5

Mobile 
App

WebHelp/Pr
o

Microsoft 
HTML Help EPUB PDF

Windows® 
XP SP4 or 
later, 
Windows 
Vista, 
Windows 7

Web 
browser

N/A Web 
browser

Built-in 
viewer

eBook 
viewer

PDF viewer.
Example: 
Adobe 
Acrobat, 
Adobe 
Acrobat 
Reader

Mac OS, 
Linux®

Web 
browser

N/A Web 
browser

Not available eBook 
viewer

PDF viewer.
Example: 
Adobe 
Acrobat, 
Adobe 
Acrobat 
Reader

iOS, Android 
(devices)

Web 
browser

Native 
mobile 
app

N/A N/A eBook 
viewer

PDF viewer.
Example: 
Adobe 
Acrobat, 
Adobe 
Acrobat 
Reader

End-user system Multiscreen HTML5 JavaHelp* Oracle Help AIR Help

Windows® XP SP4 or 
later, Windows Vista, 
Windows 7

Web browser JavaHelp 
viewer

Oracle Help 
viewer

AIR Help 
Runtime

Mac OS, Linux® Web browser JavaHelp 
viewer

Not available AIR Help 
Runtime

iOS, Android (devices) Web browser N/A N/A N/A
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Create and manage projects

Create a project

1) Do one of the following: 
– Select File > New Project.
– In the Starter pod, click More under Create New.

2) On the New pane in the New Project dialog box, double-click a project type. You can change the 
project type after your project is created.

Blank Project
Customize and publish a project in any output. You can modify the window settings for WebHelp, 
FlashHelp, and HTML Help outputs.

Application Help
Create a Help system that you can install locally. The Application Help project has sample topics 
with notes on how you can customize and modify the information. For example, you can create a 
Help system to document information about a company product. NOTE: By default, the Application 
Help does not use master pages or snippets but you can always add them.

e-Handbook
Create a project for an electronic handbook, such as an employee handbook for a company. The 
e-Handbook project template provides the relevant folders and topics for you to place 
company-specific information.

e-Learning
Integrate and organize Captivate demos into a project. Using the layout and recommendations 
provided, you can create computer-based and web-based training.

Knowledge Base
Create a knowledgebase that has an interface similar to a wiki page. The knowledgebase project 
template contains master pages that you can customize. You can also create self-updating pages.

Web Application Help
Create a Help system that you can publish on a server. The Web Application Help project has 
sample topics with notes on creating online Help for a software application.

Department Guidelines
Create a Help system to outline guidelines for a department in a company. For example, you can 
create Help for a human resources department, outlining guidelines on recruitment and selection, 
flexible working hours, and so on.
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Disaster Recovery Plan
Create a Help system with samples on how to write a disaster recovery plan.

Online Manual
Create an online manual for a company product or software application.

Policies And Procedures
Create a handbook or a document listing policies and procedures specific to an organization.

Custom
Customize a Help project template.

3) Specify options in the New Project Wizard dialog box:
– RoboHelp stores the project title in a field called Project Title. You can insert the field in topic 

contents, snippets, master pages, and screen layouts.
– Leave Language as English or select another language to localize the project. Spell checking, 

indexing with the Smart Index Wizard, and parts of the user interface are localized.
– If you select Save As Default, the selected language is used for all new projects.

4) Click Finish.

The first topic opens in the Design Editor on the right. On the left, the Project Manager opens. The first 
topic is selected in the HTML Files (Topics) folder.

Create a project by importing documents

1) Do one of the following:
– From the Starter pod, select a new project type from the Import list.
– Select File > New Project. Click the Import tab and select a new project type.

2) Follow the prompts. The new project opens in RoboHelp.

Create a project using FrameMaker or Word documents

You can create new projects by importing FrameMaker or Word documents. While importing, you can 
map the styles of these documents to styles in RoboHelp.
1) Select File > New Project and click Import.
2) Select FrameMaker or Word documents and click OK.
3) Select from .book, .mif, .fm, .bk, and .frm files for FrameMaker and .doc, .docx, .rtf, and .docm files 

for Word. You can import multiple FrameMaker or Word documents at the same time. You can 
import .book and .bk files one at a time.
NOTE: For any FrameMaker format other than MIF, FrameMaker 8 or later is required. If the correct 
version is not installed, you cannot import the file.

4) Enter the project title, filename, and location of the project.
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5) Click Finish.
A new project wizard prompts you to select options to map the TOC, index, or glossary.

6) Select the required options, and click Next.
7) Click Edit.
8) Select styles to map to the RoboHelp styles.

For information about different conversion options for FrameMaker documents, see Conversion ba-
sics.
For information about different conversion options for Word documents, see Converting Word 
styles to RoboHelp styles.

9) Click OK.
NOTE: If you click Cancel in the wizard, no files are imported and the empty project remains open.

10) Click Finish.

Create a project using a DITA map file

 IMPORTANT: For expert users only.

Before you import a DITA map file, Java JDK and the DITA Open Toolkit must be installed and running 
properly. Experience with DITA and the DITA Open Toolkit is also required.
1) Select File > New Project.
2) Click the Import tab.
3) Select DITA Map File.
4) Click OK.
5) Enter the following information in the New Project wizard:

DITA Map File To Import
Specify path to a valid DITA map file that you want to import and create a project. Click the Browse 
button  to select the file.

Location Of The Project
Specify path to the location of the new project.

6) Click Next.
7) Specify the input required on the Open DITA Toolkit Processing Options dialog box.
8) Click Finish.

RELATED LINKS:
Converting Word styles to RoboHelp styles

Add a RoboHelp project to version control

Save projects

Save frequently while you work.
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• To save individual files, click Save in the Quick Access Toolbar.
• To save all files, click Save in the Quick Access Toolbar.

Disable auto-save

By default, RoboHelp saves changes when you close the project. If you prefer, you can disable the 
auto-save feature.
1) From the Tools menu, select Options.
2) Click the General tab.
3) Under Options, deselect Save Without Prompt.

Opening a project

Open a project when starting RoboHelp

1) From the Starter pod listing recently opened projects, click the project name. If you don’t see the 
project you want, click Open.
You can use the following controls to locate the project you want to open:

My Places bar
Find documents by using the shortcuts to the left of the Folder and Files list.

Desktop
The Desktop folder lists all folders on your desktop.

My Computer
The My Computer folder lists the hard drives configured on your computer.

My RoboHelp Projects
The My RoboHelp Projects folder is the default working folder where RoboHelp stores all projects. 
This folder is placed in the My Documents folder when Adobe RoboHelp is installed. When you start 
Adobe RoboHelp, projects stored in the My RoboHelp Projects folder are automatically listed in the 
Starter pod under the Recent Projects list. All RoboHelp projects use the .xpj filename extension.

Look in list
By default, this list displays the My RoboHelp Projects folder. Alternatively, if you have accessed 
other folders, the last folder you accessed, is selected in this list. This list includes the My Computer, 
My Network Places, and My Documents folders under the Desktop folder.

Go To Last Folder Visited icon
Displays the last folder you accessed. Click the arrowhead to view a list of the most recent folders 
you visited. This icon is disabled if you do not access a folder in the dialog box.
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Up one level icon
Enables you to move to the parent folder of the current folder displayed in the Look in list.

Delete icon
Enables you to delete a selected folder or file. The deleted folder or file is sent to the Recycle Bin.

Create New Folder icon
Enables you to create a folder under the parent folder selected in the Look in list.

View Menu icon
The arrowhead enables you to choose the view in which the folder and file list must be displayed. 
You can view the folders and files as thumbnails, tiles, icons, a simple list, or a list with details of the 
folders or files.

Tools icon
Enables you to delete or rename a folder or file, add a folder or file to the My Places bar, or map a 
hard drive to a computer or folder on your network. You can also view properties of a folder or file.

File Name box Enables you to specify the name of the file to access (to open, to import, and so 
on.)

Files Of Type menu
Enables you to select the type of files to list in the folder and file list.

Open a project after starting RoboHelp

1) Select File > Open Project > Local or Network Path.
The Open Project dialog box appears.
NOTE: You can also select the last ten projects opened from the bottom of the File menu.

2) Select RoboHelp HTML Help Project (.xpj) from the Files Of Type menu.
3) Locate the project file, and double-click it.

Upgrading a project

If you open a project created in a previous version of RoboHelp, you are asked whether to convert it 
before opening it.
IMPORTANT: Make a copy of your project before converting it into the new format.

RELATED LINKS:
RoboHelp output search

Pin a project to the list of recently opened projects

By default, the list of recent projects that appears in the Starter pod and in the File menu displays up to 
the last ten projects opened. Pin a recently opened project so that it always appears in the recent proj-
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ects’ list. The list displays the pinned projects and recently used projects up to the number of projects set 
in the Max Projects field.
1) Select File > Options.
2) On the Recent Projects tab, select a project from the Recently Opened Projects list.
3) Click Pin. Click OK.

NOTE: Click Unpin to remove a pinned project from the recent projects’ list.

Change project settings

1) Choose Project > File > Project Settings.
2) On the general tab, change settings as needed:

Project Title
Enter a project title. This title appears in the window bar of the output.

Primary Output/Layout
Select a primary layout.

Language
Select the default project language.

Advanced
Click to create or edit lists for localization. Set options in each pane.

To Do List
Click Manage to manage the To Do list for your project. For more information, see Using the To Do 
list.

Index
Select an option for saving keywords: 

– Index File (HHK) saves new index keywords in the project index file (HHK).
– Topics saves new index keywords in individual topic files (HTM).
– Binary Index uses a binary index in Microsoft HTML Help projects.

Set options on the Stop List pane

Use the Stop List tab to modify words contained in the Stop List file ProjectName.stp. A Stop List contains 
common words (for example, “a” or “the”) that the search ignores for an accurate result.

Edit
Select a word, click Edit. Type the new name. Press Enter. Right-click the word to display a 
drop-down box with the Undo, Cut, Copy, Paste, Delete, and Select All options.



35

CREATE AND MANAGE PROJECTS
CHAPTER 3 PROJECTS

Reset To Default
Removes the new entries and restores the default list.

New
Adds a word. Click New. Type the word. Press Enter.

Delete
Deletes a selected word.

NOTE: In Microsoft HTML Help projects, the stop list file can’t be larger than 512 K. If the file is larger, 
words at the end of the file are not included in the CHM file.

Set options on the Phrases pane

Modify words in the Phrases file ProjectName.phr. This tab contains a phrase list the Smart Index Wizard 
includes in keyword searches. For example, make project settings one phrase, not two words. You can 
add, rename, and delete words.

Edit
Select a word, click Edit. Type the new name. Press Enter. Right-click the word to display a 
drop-down box with the Undo, Cut, Copy, Paste, Delete, and Select All options.

Reset To Default
Removes the new entries and restores the default list.

New
Click New. Type the new word. Press Enter.

Set options on the “Always Ignore” Words pane

Modify words in the Always Ignore Words file ProjectName.ign. This list contains “noise” words such 
“as,” “the,” or “a.” The Smart Index wizard uses the list to keep the noise words out of the index.

Edit
Select a word, click Edit. Type the new name. Press Enter. Right-click the word to display a 
drop-down box with the Undo, Cut, Copy, Paste, Delete, and Select All options.

Reset To Default
Removes the new entries and restores the default list.

New
Click New. Type the new word. Press Enter.
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Set options on the LNG File pane

Change text elements in the user interface for Multiscreen HTML5, WebHelp, WebHelp Pro, FlashHelp, 
FlashHelp Pro, AIR Help, printed documentation, or HTML Help output.

See the complete list of available changes you can make in the LNG file tab.

When you edit the LNG file, your changes supersede settings made in Project Settings in other locations.
1) Select an element, and click either of the following:

Edit
Modify LNG file text for each user interface element listed. In Edit mode, you can also right-click on 
the edited line to undo the edits, cut, copy, paste, delete, or select all. NOTE: You can change the 
string to show expanding or collapsing topic TOCs in settings for master pages. For more informa-
tion, see Master pages.

Reset To Default
Erases the new entries and restores the default list.

NOTE: For quick access to these options, you can select Edit > LNG File.

Set options on the Synonyms pane

Define words as synonyms. For example, you can define “find” and “locate” as synonyms for “search.” In 
the generated output, when a user searches for “search,” results for “find” and “locate” are also 
displayed.

Reset To Default
Removes the new entries and restores the default list.

Edit
Select a word, click Edit. Type the new name. Press Enter. Right-click the word to display a 
drop-down box with the Undo, Cut, Copy, Paste, Delete, and Select All options.

New
Click to add a new word in the Synonym table and specify a synonym for it.

Delete
Click to delete the Word and its synonyms.

RELATED LINKS:
Upgrade localized projects

View output
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Rename a project

When you rename a project, the main project file (.xpj) and all other project files are renamed. NOTE: The 
TOC, index, and glossary files are not renamed.

When you rename a project, the project closes and reopens. Any changes made since last saving are 
saved. NOTE: You cannot rename projects under version control.
1) Open the project.
2) Select File > Rename Project.
3) In the Project Name box, enter the new project name (do not enter a filename extension).
4) Click OK. To make the changes take effect, the program closes and then reopens the project.

NOTE: If you are creating Microsoft HTML Help, the name of the compiled HTML Help file (CHM file) is 
based on the project filename. If you change the project name, the name of the CHM file changes as well. 
You can rename the CHM file to restore the old name.

Viewing projects

Help systems are displayed in a browser or viewer, depending on the output type, the application plat-
form, and the platforms of your end users. Help systems are displayed in a main window. Users can view 
topics in the right pane and navigate with tabs, buttons, and ribbons in the left pane and along the top.

View your project often to test links and make sure that styles appear properly. View each single-source 
in the viewer required for the specified output type.

RELATED LINKS:
Create TOCs

Define chapter layout

You can define a chapter layout for a project to order topics and folders logically in the Project Manager 
pod. RoboHelp uses this chapter layout to auto-create a TOC.

Notes:

• If you rename a folder or a topic, the topics and folders retain their order.
• If you delete a topic or a folder, the remaining topics retain their order.
• If you add a new topic or a folder, it is added at the top inside the parent folder.
• If you drop a topic or a folder on a non-topic/folder item (such as CSS, image, or baggage), it moves 

to the last position inside the parent folder of the target.
• When you upgrade a project from an older version of RoboHelp, all the topics appear randomly. 

You can customize the order of topics later.
• You can right-click a folder or topic in the Project Manager pod and select Explore to open the topic 

or the folder in Windows Explorer.
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Drag folders

• Drag a topic or a folder above or below another topic or folder. For linked documents, you can drag 
only above the linked documents.

RELATED LINKS:
Pin a project to the list of recently opened projects

Manage files

List topics by title or filename

1) In the Project Manager pod, open the Project Files folder.
2) Select Project > View > Display Topics > By Topic Title or By File Name.

Using the To Do list

The To Do list helps you track project tasks. You can customize the list by adding, deleting, or modifying 
the existing To Do tasks. NOTE: To Do settings are retained when you upgrade a project from an older 
version of RoboHelp to a newer version.

You can generate a report on the customized To Do list.

Edit items on the To Do list

1) Select Project > File > Project Settings.
2) Click the General tab.
3) Click Manage.
4) Do either of the following:

– To add a task to the list, click Add. Type the name of the task item.
– To edit or remove a task, select the task and click Edit or Delete.

NOTE: From the Project Settings dialog box, you cannot see the Ran Smart Index item in the default To Do 
list. This precaution ensures that you do not delete this item by mistake. By default, RoboHelp sets the 
option Ran Smart Index for all the topics on which you run the Smart Index wizard.

Update the To Do list for a topic

1) Right-click a topic in the Project Manager pod and select Properties. Click the Status tab.
2) Select or deselect items on the To Do list.
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Generate a status report

You can generate a Project Status report to view the number of topics using the To Do list.
1) Select Tools > Reports > Project Status.

Edit the list of recently opened projects

Recently opened projects are listed in the RoboHelp Starter pod.
1) Select File > Options.
2) Click the Recent Projects tab.

– To change the number of files listed, specify a number in the Max Projects box.
– To remove a file from the list, select it and click Remove.

RELATED LINKS:
Broken links report

Add files and folders to the Baggage folder

RoboHelp sometimes doesn’t automatically add references to external elements to the Baggage Files 
folder. If needed, add files to the Baggage Files folder so the external elements appear correctly in the 
output. Save time by importing the complete folder to the baggage files without having to add files indi-
vidually. It not only adds all contents from the chosen folder, but also maintains the same folder structure 
within the project. Follow the steps below to add baggage file or folder to the project:
1) Select Project > Open > Pods > Project Manager.

The Pods drop-down list is also available in the Edit and Review ribbons.
2) Right-click on Project Files, select Import Baggage > select File or Folder.

NOTE: You can also access this option by Right-click the Baggage Files folder > New > select File or 
Folder. If the Baggage Files folder isn’t listed, click the Toggle Project Manager View button .

3) To add a file, double-click the source file for any of the following:
– Bitmaps and icons used with HTML Help controls
– Image files used in style sheets, topic backgrounds, and scripts
– The JavaScript file that supports Dynamic HTML effects, such as pop-ups and drop-down 

hotspots

4) To add a folder, browse and select the folder containing the baggage files.
5) Click Open.

NOTE: You can create a link to a baggage file by pressing the Shift key while dragging and dropping 
it into a topic.

Additional features with Baggage folder

The Baggage Files feature allows you to perform the following additional tasks:
1) Drag-and-drop content from one location to another to organize content within the Baggage Files 

folders.
2) Delete the unwanted files.
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3) Rename files and folders.
4) Create a link to a baggage file by pressing the Shift key while dragging and dropping it into a topic.
5) Insert image from the Baggage Files by dragging and dropping it to the topic you are working on.

Remove files from the Baggage folder

To remove a file from the Baggage folder, select the file and click Delete.

Map file types

Map file types to associate them with the applications used for editing them.

Associate a file extension with an application

1) Select File > Options.
2) Click File Association tab.
3) For associated programs, click Add.
4) Enter a filename extension.
5) Select an editor to edit documents with the specified filename extension.

When you select a program, its location appears in the Edit With box. The programs appear 
alphabetically. NOTE: Only those programs appear in the list whose registry entry is set to “NoOpen-
With.”

6) Select a program to view the file.
You can also browse to a program not listed in the program list.

Add an HTML editor mapping

1) Select File > Options.
2) Click File Association tab.
3) For HTML editors, click Add.
4) Select from the recommended or other programs registered to edit or view .html or .htm 

files. NOTE: When you select a program, its name and location appear in the Name and Location box. 
You can also browse for a program that does not appear in the program list.

5) Click OK. The selected program appears in the list of HTML editors. NOTE: To change the HTML 
editor, browse and select a new program.

Remove topics from projects

Before you remove files, back up all project files and view and print reports if your project is not under 
version control. To avoid broken links, don’t remove files in Windows Explorer or version control soft-
ware. 
1) Select one or more files:

– To remove a topic, use the Project Manager pod.
– To remove multiple topics, use the Topic List pod.
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2) Press Delete. If prompted, do NOT remove references to removed topics.
NOTE: You can choose to remove the references, but if you do that, you do not get to review the effect 
of the removal in other topics. Electing NOT to remove the references, forces the links to display in 
Broken Links, from which you can review each topic to see if any editing is required.

RELATED LINKS:
Unused files report

Define chapter layout

Manage folders

Create folders

The Project Manager contains default folders for project organization. You can create folders and 
subfolders only in these folders: HTML Files (Topics), Images, Multimedia, Style Sheets, and Baggage 
Files.
NOTE: Do not use Windows Explorer to create subfolders to add, move, or rename files. RoboHelp does 
not recognize these changes.
1) Select the Project Files folder in the Project Manager pod. NOTE: If the Project Files folder isn’t listed, 

click the Toggle Project Manager View button .
2) Right-click the folder, and select New > Folder.
3) Enter a name for the folder. Avoid special characters and spaces.
4) Press Enter.

Tips:

• Move files and folders in Project Manager by dragging.
• You can drag topics from the Topic List into multiple folders in the Project Manager.

Project Manager folders

In the Project Manager pod, you edit, delete, and create project files. Two views are available in Project 
Manager. Both views include a set of commonly used options for authoring. One view displays all the 
project files gathered together in a single folder called Project Files; the other view groups the project 
files into various virtual folders based on file type. Click the Toggle Project Manager View button  or , 
to change views.

The Project Manager view that displays project files in various virtual folders contains the following 
folders:

HTML Files (Topics)
Stores the topics of a project. Files are sorted alpha numerically (A-Z, 0-9). You can add folders 
within this folder. You can use the structure to generate a TOC automatically and create browse 
sequences.
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Images
Images used in your project are stored in this folder. Image maps and their associated links 
(hotspots) are also listed. You can drag an image from this folder into the Design Editor to add 
images to topics. You can also rename images in this folder by selecting the image and pressing F2.

Multimedia
All sound and video files used in your project are saved in this folder. Adobe Captivate demos (SWF 
files) are also stored here. You can drag sound or video files into the Design Editor to add multi-
media to topics. You can also find out where the files are referenced in your project.

Style sheets
Style sheets control the formatting of topics. When you change a style sheet, all topics associated 
with it are updated. The RoboHelp default style sheets (CSS files) and any others you add to your 
project are stored in this folder. Edit a style sheet by double-clicking its icon.

Baggage Files
RoboHelp provides a mechanism to include content that isn't directly linked to your project by 
uploading it as a baggage file. When you click a link to a content in the baggage file, it opens the file 
in the associated application. You can add files like PDFs, Word docs, Excel spreadsheets, Power-
Points, and more. Certain files are automatically added to the Baggage Files folder in the Project 
Manager to display the following correctly in the generated project:

• Bitmap and icon files used with HTML Help controls
• Image files used in topic backgrounds and scripts
• The JavaScript file (ehlpdhtm.js) that supports Dynamic HTML effects such as related topics 

pop-ups, smart pop-ups, and drop-down hotspots.
• The support file for skins and the navigation pane in browser-based outputs (TOC, index, glossary, 

and full-text search.

You can drag files from the Baggage Files folder into topics to create links to the files.

Broken Links
Stores links to files that are not present in the project. To restore or remove a broken link, 
double-click it.

URLs
Stores links to web addresses, FTP sites, newsgroups, e-mail addresses, and HTML topics in external 
CHM files. From this folder, you can add a URL to an index. You can drag a URL into the Design 
Editor.

Table Of Contents
Stores the default TOC and all other TOCs created in the project.

Index
Stores the default index and all other indexes created in the project.
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Glossary
Stores the default glossary and all other glossaries created in the project.

See Also
Double-click the See Also folder to display the See Also pod. You can add the See Also keywords in 
the See Also pod.

Rename folders

Use the Project Manager to rename folders.
1) Select the Project Files folder in the Project Manager pod.
2) Right-click the folder. Select Rename.
3) Type the new name. Don’t include special characters, and avoid spaces, especially for WebHelp and 

FlashHelp.
4) Press Enter.

Move folders

Use the Project Manager pod to move folders.
1) Select Project Files in the Project Manager pod.
2) Drag the subfolder to its new location.

Remove custom folders

Before you remove the folder, move any items in it that you want to keep.
1) Select the custom folder in the Project Manager pod.
2) Choose Project > Delete.

File and folder icons

The Project Manager icons indicate the components and files included in your project.
NOTE: Icons with a red check mark indicate that the file is checked out (applicable only to topics under 
version control).

Icon Description

Closed folders. Closed folders that contain files display a plus sign. Click the plus sign 
to show the folder contents. Right-click for more options.

Open folders. Open folders display a minus sign with the contents shown below. 
Click the minus sign to collapse the folder.

, Toggle view. Click to switch between a simplified view with fewer folders or one 
showing all folders.

Show/hide files. Click to select the files you want to show in the Project Manager.
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Empty folders. Empty folders display no signs.

HTML files (Topics). Double-click page icons to open a Design editor. Right-click for 
more options.

HTML topics with bookmarks. Topics with bookmarks have a plus sign. Click the plus 
sign to show all bookmarks.

Missing files. A red X indicates files that the program cannot locate. These files are 
not in the project path. Either they have been deleted, or they are saved in a 
different folder of the project.

Bookmarks. Bookmarks appear alphabetically below their respective topics. 
Double-click to open a topic. Drag bookmarks into topics in Design Editor to create 
links.

Framesets. Double-click to open a dialog box for changing frame attributes.

URLs, web addresses, FTP sites, newsgroups, e-mail addresses, or HTML topics in 
external CHM files. Double-click to open a dialog box for adding keywords to a link. 
Drag URLs into topics open in Design Editor to create links.

Images (GIF, JPEG, and JPG formats). Double-click to preview the image, identify 
topics that use it, and view file information. Drag images into topics in Design Editor 
to add them.

Image maps. Images with clickable links or hotspots. Click the plus sign to display 
links. Double-click to preview the image, identify topics that use it, and view file 
information. Drag the image maps into topics in Design editor to add them.

Image map links (hotspots). Double-click to identify topics that use image maps.

Sound files (AU, MID, RMI, and WAV formats). Double-click to identify topics that 
use them and view file information. Drag sound files into topics in Design Editor to 
add them.

Video files (AVI and MOV formats). Double-click to identify topics that use them and 
view file information. Drag video files into topics in Design Editor to add them.

Adobe Captivate files (SWF files). Double-click to identify topics that use them and 
view file information. Drag Adobe Captivate files into topics in Design Editor to add 
them.

Custom windows. Double-click to modify window properties.

Style sheets (CSS). Double-click to modify styles.

Text-only files For What's This? Help (.TXT format). Double-click to create or modify 
text-only topics files.

Icon Description
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TIP: You can map filename extensions to applications. For example, map GIF files to Adobe Photoshop®. 
When you right-click a GIF file from the Images folder and select Edit, the file opens in Photoshop.

RELATED LINKS:
Define a language for a paragraph

Authoring content in multiple languages

You can change the language of an existing project or a new project. The language affects the window 
text, as well as the dictionary for the spell checker and the automatic indexing (Smart Index Wizard) 
customized settings.

You can also customize the display text, such as the text in browse sequence buttons, previous and next 
buttons, show/hide buttons, some messages, and more. The text can be anything you specify. For 
example, the default text “Search” on the Search tab can be changed to “Find” in the language of your 
choice.

Map Files For Context-Sensitive Help (.HH) Includes imported map files or 
automatically generated files.

All map IDs. Links map IDs to HTML topics for context-sensitive Help. Double-click to 
work with map IDs and map files.

Table of contents folder. Shows the default and other table of contents in the 
project.

Table of contents folder. Expand to view the table of contents listed.

Table of contents. Double-click to open the selected table of contents pane.

Index folder. Shows the default and other indexes (if any) listed.

Index folder. Expand to view the indexes listed.

Index. Double-click to open the selected index pane.

Glossary folder. Shows the default and other glossaries (if any) listed.

Glossary folder. Expand to view the glossaries listed.

Glossary. Double-click to open the selected glossary pane.

See also. Double-click to open the See Also pane and add to See also keywords.

Baggage files (BMP, ICO, XML, JS, other image files). Files such as bitmaps and icons 
used with HTML Help controls, including custom buttons for link controls and 
startup screens. If your project includes Dynamic HTML, the file EHLPDHTMJS is 
included in your Baggage Files folder. Other image files are included as well, such as 
topic backgrounds and scripts.

Icon Description
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When delivering the project to translators, always provide the source files and not the output files.
NOTE: In HTML Help systems, the end user’s operating system must be in the same language as the one 
used in your project. Otherwise, the end user’s operating system overrides the language specified in your 
project. The dictionary and index sorting are not affected in the end user’s system.

Support for multiple languages

RoboHelp provides multiple language support at the paragraph, topic, and project level. You can set the 
language at the paragraph level and topic level through the RoboHelp user interface. Language defined 
at the paragraph level takes precedence over language defined at a topic level. Language set at the topic 
level takes precedence over language defined at a project level. Language defined at the project level can 
never take precedence over language defined at paragraph level. You can think of the prioritized 
language as the effective language. Effective language is used in spelling checks, in a dictionary or a 
thesaurus, in generating a smart index, and in preparing a full-text search.

The project language is defined at the project level. You can apply different language settings using 
Project > Project Settings.

You define the topic language using the Topic Properties dialog box.

You define the paragraph language using the Paragraph dialog box. Select any paragraph in the Design 
view and choose Paragraph from the context menu.

RoboHelp supports the following languages:

Languages Spell Check User Dictionary Thesaurus Auto correct

Arabic Yes Yes Yes Yes

Danish (Denmark) Yes Yes Yes Yes

German (Germany) Yes Yes Yes Yes

English (US) Yes Yes Yes Yes

English (UK) Yes Yes Yes Yes

Spanish (Spain) Yes Yes Yes Yes

French (France) Yes Yes Yes Yes

Hebrew Yes Yes Yes Yes

Italian (Italy) Yes Yes Yes Yes

Dutch (The Netherlands) Yes Yes Yes Yes

Norwegian Bokmâl 
(Norway)

Yes Yes Yes Yes

Norwegian Nynorsk 
(Norway)

Yes Yes No Yes
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RELATED LINKS:

Portuguese (Brazil) Yes Yes No Yes

Swedish (Sweden) Yes Yes Yes Yes

Croatian (Croatia) Yes Yes No Yes

Portuguese (Portugal) Yes Yes No Yes

French (Canada) Yes Yes Yes Yes

Finnish (Finland) Yes Yes No Yes

Catalan (Spain) Yes Yes No Yes

Russian (Russia) Yes Yes No Yes

Bulgarian (Bulgaria) Yes Yes No Yes

Czech (Czech Republic) Yes Yes No Yes

Polish (Poland) Yes Yes No Yes

Romanian (Romania) Yes Yes No Yes

Hungarian (Hungary) Yes Yes No Yes

Greek (Greece) Yes Yes No Yes

Turkish (Turkey) Yes Yes No Yes

Estonian (Estonia) Yes Yes No Yes

Latvian (Latvia) Yes Yes No Yes

Lithuanian (Lithuania) Yes Yes No Yes

Slovenian (Slovenia) Yes Yes No Yes

German (Switzerland) Yes Yes Yes Yes

Japanese (Japan) No No No No

Korean (Korea) No No No No

Traditional Chinese 
(Taiwan)

No No No No

Simplified Chinese (China) No No No No

Thai (Thailand) No No No No

Vietnamese (Vietnam) No No No No

Languages Spell Check User Dictionary Thesaurus Auto correct
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Create a topic

Create and edit single-source layouts

Translation workflows

You can create content for multiple languages in a single RoboHelp HTML project by translating the 
English content in the same project. You can then create tables of contents, indexes, glossaries, and 
conditional build tags in the project for the desired languages. Finally, you can apply conditional build 
tags to content authored in the various languages, and generate conditional output.

Follow the steps in this workflow, which uses translation from English to French and Japanese as an 
example:
1) Apply French language project settings by selecting French Language.
2) Open an English topic, create a topic for the French language, and translate the content, including 

the topic title from English to French. (Do not translate topic filenames.)
3) Create French tables of contents, indexes, and glossaries.
4) Create a conditional build tag, such as FrenchContent.
5) Apply the FrenchContent conditional build tag to French content and topics.
6) Generate output for the French language.
7) Apply Japanese language project settings by selecting the Japanese Language.
8) Open an English topic, create a topic for the Japanese language, and translate the content from 

English to Japanese.
9) Create Japanese tables of contents, indexes, and glossaries.
10) Create a conditional build tag called JapaneseContent.
11) Apply the JapaneseContent conditional build tag to the Japanese content.
12) Generate output for the Japanese language. NOTE: To view the Japanese output, you must change 

your PC’s language to Japanese. NOTE: To translate a WebHelp project, first make a copy of the 
project, open that copy in RoboHelp and author in your desired language.

Compare content in different languages

1) Open topics created in different languages.
2) In Design Editor, position the topics side by side: Drag a topic tab slightly down or to the right, and 

release the mouse when the page icon  appears. Choose New Horizontal Tab Group or New 
Vertical Tab Group.

Select a different language for translating a project file

1) Select Output > Stop Words.
2) In the Advanced Settings for Localization dialog box, use the following tabs:

Stop List
Click New to add words that must be ignored during a text search.
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Phrases
Click New to add a phrase for the Smart Index Wizard to include when searching topic content for 
keywords.

Labels
Click Edit to modify the text for each user interface element listed.

"Always Ignore" Words
Click New to add a word or phrase that the Smart Index Wizard ignores when generating the index.

Synonyms
Click New to add a synonym for a word. This option enables you to search for words and their 
synonyms. The results are always returned for the searched words.

Create a project with a different language

1) Select File > New Project.
2) In the New tab, double-click Project Type. The New Project Wizard appears.

NOTE: To create a JavaHelp or Oracle Help project, first create a Microsoft HTML Help project, and 
then add a new layout to that project.

3) Enter project information.
4) From the Language menu, select the language. Click Save As Default to keep the language as the 

default.
5) Click Finish.

The first topic opens in the Design Editor. Generate and view your project to view the results.

RELATED LINKS:
Importing and linking Microsoft Word documents

Customizing text for localization

You can customize certain text in the user interface for WebHelp, WebHelp Pro, FlashHelp, FlashHelp 
Pro, and HTML Help outputs. Here is what you can change for each format:

WebHelp, WebHelp Pro, FlashHelp and FlashHelp Pro

• With a skin Customize text in the Skin Editor. If you do not change the default text (such as 
“Contents” for the Contents button), the text is automatically translated using the project language 
setting.). If you customize text in a skin, the skin text overrides any customizations you make in the 
LNG file. For FlashHelp, the Flash developer uses the Skin Development Kit to customize the text.
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WebHelp only

• Without a skin Edit the language file. You can localize browse sequence button text; text on the 
Glossary tab, Previous button, and Next button; certain messages; and the Contents, Index, and 
Search tabs. For example, you can change the text on the Search tab from “Search” to “Find.”

HTML Help

You can customize browse sequence button text and all text on the Glossary tab. Change window titles 
in the Windows Properties dialog box.

Edit the Labels file

1) Create or open a project.
2) Select Output > Labels.
3) Select the interface text. Click Edit.
4) Type the edits. Press Enter.

Notes:

• If RoboHHRE.LNG is already in your user's Windows folder, it overrides the file in the Baggage Files 
folder.

• If you do not include the RoboHHRE.LNG file, or omit some values, your project defaults to the 
English values shown in the example.

• If you are using a skin, the default text is translated to the default language. If you customized the 
text in a skin, the skin text overrides customizations in the LNG file.

Change the default project language

1) Open the project.
2) Select Project > Project Settings.
3) Click the General tab and select the language.
4) Click OK.
5) Generate and view your project.

Notes:

• If you use a skin, the default text uses the language setting of the project. Customized skin text over-
rides text settings in the LNG file.

• Localize window captions in the Windows Properties dialog (not applicable to WebHelp projects).

Language support for associated dictionaries

If your project contains content authored for multiple languages, define RoboHelp language settings in 
the project, topic, and paragraph separately. The effective language is used for dictionary or thesaurus 
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association and for spell checking. For example, suppose you set the project language to UK English and 
the paragraph language to French for several paragraphs. The French spelling checker is activated for 
French paragraphs while the UK English spelling checker is used for the rest of the content.
NOTE: Updated language settings for each language are stored at a common location in the project folder. 
You can access the language settings information in the Projects\ !Language! folder.

Index localized text

Use the Smart Index wizard to index your localized project. You can assign keywords for each topic based 
on the topic content. The index is generated based on language and search criteria you define in the 
Smart Index wizard. The Smart Index Wizard suggests keywords based on topic content.
1) Select a language for a new or existing project.
2) Follow the steps for automatically creating your index.

Universal character sets

RoboHelp enables you to create content in multiple languages. However, authoring content in a multi-
lingual environment can be challenging when the languages span multiple Microsoft Windows code 
pages. Support for the Unicode character encoding standard in RoboHelp overcomes many of these chal-
lenges.

Without Unicode, operating systems use a code-page-based environment, in which each language script 
has its own table of characters. Content based on the code page of one operating system seldom trans-
lates correctly on an operating system that uses another code page. For example, suppose you are 
running the English version of the Microsoft Windows® XP/Vista operating system with the German code 
page. Then suppose you open a plain text file created in the Japanese version of Windows XP/Vista. In 
this case, the code points of the Japanese code page are mapped to unexpected or nonexistent charac-
ters in the Western script. The resulting text is unintelligible.

Support for Unicode text encoding standards

RoboHelp HTML supports Unicode text encoding. You can create a topic in multiple languages, regardless 
of the language used by the operating system running RoboHelp.

You can perform the following tasks related to Unicode:
• Author documents containing multilingual paragraphs and words. For example, you can have a set 

of Greek characters followed by Russian characters, and then by French text in the same paragraph.
• Use the relevant language spelling checker to check Unicode content.
• Create, open, or edit Unicode-encoded HTML and text files (UTF-8 and UTF-16 encoded files).
• Enter Unicode characters in input forms and dialog boxes.
• Generate TOC, index, and glossary by using Unicode strings.
• Convert and import text of non-Unicode encoded file types (HTML, XML, MIGF, and so on).
• Publish content to a non-English server by adding multibyte characters in the complete path name.
• Create, open, or edit Unicode-encoded HTM files (UTF-8 and UTF-16 encoded files).
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• Provide Unicode-encoded input and view Unicode content in fields, dialog boxes, wizards, and 
forms.

Set up input languages on Windows

Before you start typing non-English text or Unicode characters in the HTML files, ensure that RoboHelp 
HTML 8 is running on a UTF-8 locale. Configure the regional language or locale settings on your computer 
to add additional languages for keyboard input, across operating systems.

Use the Windows® XP regional and language settings to add additional languages for keyboard input. 
These languages and speech settings appear in the Language bar on the desktop. After you select a 
language from the bar and a localized keyboard, you can start typing the required text in the document. 
Microsoft® defines the keyboard layouts.
1) Open the Control Panel and double-click the Regional And Language Options icon. The Regional 

And Language Options dialog box appears.
2) Click the Languages tab.
3) Click the Details button. The Text Services And Input Languages dialog box appears.
4) In the Settings tab, click the Add button.
5) Select a language from the Input Language list.
6) Click OK. The selected language is included in the Installed Services list.
7) Select the desired language in the Default Input Language list.
8) Click Apply and click OK to save the settings and close the Text Services And Input Languages dialog 

box.
9) Click the Regional Options tab, and choose the language you selected in the Default Input Language 

list.
10) Click Apply and click OK to save the settings and close the Regional And Language Options dialog 

box. The Language bar appears on the desktop of your computer.
11) Open RoboHelp, and type the content. The text appears in the selected language.

You can change the language in the Default Input Language list and the Regional Options tab. The 
language selected in the Language bar is updated automatically to reflect your new choice.

Upgrade localized projects

Product-level customization is moved to [install_folder]\Language in RoboHelp. For example, 
English is renamed as en_US and en_UK, and French is renamed as fr_FR.

The project-level customization is moved to[project folder]\!Language!\[language folder].

Minor customizations

1) Open Notepad.
2) Open the file to modify. These files reside in C:\Program Files\Adobe\Adobe RoboHelp 

[version]\RoboHTML\!Language!\en_US.
3) Open the project. Do the following:
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– Edit the LNG file.
– Edit the custom word lists.

Major customizations

1) Open Notepad.
2) Open the old file in C:\Program Files\Adobe\Adobe RoboHelp [version]\RoboHTML\Language.
3) Open the new file in a separate window in Project folder\Language.
4) Copy the customizations from the old file to the new file. See the table for filenames.

NOTE: The above procedure is NOT the recommended way. The recommended way is described in 
Change project settings

Import PDF files

You can convert an Adobe PDF file (version 1.4 or later) into a single topic or multiple topics for a new or 
existing project.
• You cannot import SWFs, PDF portfolios, and encrypted PDF files (files that require a password).
• If the PDF contains 3D images, save the PDF in version 5 to import the images.
• TOCs or index field codes convert to PDF.

• Adobe Reader® or Adobe Acrobat® is not required to import PDF files.
• Sometimes fonts in PDF files do not convert correctly when imported into HTML.

Create a project by importing a PDF file

NOTE: You cannot import encrypted PDF files (files that require a password).
1) Select File > New Project.
2) Click the Import tab. Select PDF Document and click OK.
3) Click the browse button to select one or more PDF files from a single folder. Click Open, and then 

click Next.
4) Enter the project information. Click Next.
5) Select options in the Conversion Options dialog box.

File description Pre-7 filenames 7 Filenames

Phrase list Phrases.wlf ProjectName.phr

Always Ignore list AlwaysIgn.wlf ProjectName.ign

Stop list *.stp ProjectName.stp

Language file *.lng ProjectName.lng
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Topic
Select how to split the PDF into topics.

Create New Topic(s) Based On Style(s)
Activates the Next button. Click to select styles.

Create A Single Topic
Creates one topic from the entire PDF.

Create A Topic For Each PDF Page
Choose additional options.

Convert As HTML
Creates a topic for each PDF page.

Convert As Image
Renders each PDF page as a separate image.

Convert As Absolutely Positioned HTML (Advanced)
Creates a topic for each PDF page. Positioning the content can require advanced HTML and subse-
quent editing can be difficult. Use this option if the other options don’t produce the results you 
want. This option is not recommended for printed documentation.

Image (JPG/GIF/PNG)
Select the format for images converted from the PDF. To exclude images, select None.

Page Range
By default, all PDF pages are converted. Alternatively, enter the page numbers on which to start 
and end.

Create new topics based on styles

Styles are converted based on the following:
• The most common style becomes the Normal style, which cannot be used to split topics.
• The remaining styles are ranked from largest point size to smallest. Style ranking also considers 

boldness (highest precedence), italics, and normal (lowest precedence).
• Styles are ordered and numbered using “Heading 1” for the dominant heading style and “PdfPara-

Style01” through “PdfParaStyleX” for all other styles. Rename these styles using this dialog.

Create New Topics Based On
Lists the styles used in the PDF document.

NOTE: RoboHelp splits the documents into topics using the specified styles. The style text is included by 
default in the filename of the topic file created. Any non-ASCII characters in the topic file names are auto-
matically converted to ASCII characters.
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Description
Displays a description of the selected style.

Paragraph Preview
Displays a preview of the selected style.

Rename Style
Renames the selected style in your project.

Finish
Completes the import process.

Back
Returns to the Conversion Options dialog box.

Import PDF files into a project

1) In the Project Manager pod, right-click Project Files.
2) Select the file to import into.
3) Select Project > Import > PDF Document.
4) Select one or more PDF files. Click Open.
5) Select options in the Conversion Options dialog box.
6) If Create New Topic(s) Based On Style(s) was selected, click Next to select styles.
7) Click Finish.

Importing and linking Word and FrameMaker documents

You can import Microsoft Word and Adobe FrameMaker documents to your RoboHelp projects.

RELATED LINKS:
Importing FrameMaker documents

Custom HTML tags

Importing and linking Microsoft Word documents

In RoboHelp, you can import or link Microsoft Word documents (files with .docx, .docm, .doc, or .rtf 
extensions after the filename). You can create new projects by importing or linking Word documents. Or, 
you can use the Word documents as source files for an existing RoboHelp project. You can use this work-
flow to integrate content created by different authors in Word.

The settings for importing and linking Word documents are applied at the project level. For this reason, 
you have consistent settings for all documents that you import or link to RoboHelp projects. You can also 
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export the conversion settings that you define and reuse them across multiple projects. Defining a set of 
standard settings for conversion ensures consistency across projects. See Word conversion settings.

Steps to import a Word document into RoboHelp

1) Locate your Word document.
2) Optimize the Word document for import. See Optimizing Word documents for online output.
3) Read through the differences between linking and importing the Word document. See Linking 

versus importing Word documents.
4) Open RoboHelp, and either create a project or use an existing project to import the Word docu-

ment.
5) Import the Word document. See Import a Word document into a RoboHelp project.
6) Export your conversion settings and reuse it when you import another Word document. See Export 

conversion settings.

Steps to link a Word document from RoboHelp

1) Locate your Word document.
2) Optimize the Word document for linking. See Optimizing Word documents for online output.
3) Read through the differences between linking and importing the Word document. See Linking 

versus importing Word documents.
4) Read through the options for linking Word documents. See Linking options for Word documents.
5) Open RoboHelp, and either create a project or use an existing project to link the Word document.
6) Link the Word document. See Link a Word document to a RoboHelp project.
7) Synchronize your linked Word document with RoboHelp when you edit your Word document. See 

Synchronizing linked Word documents with RoboHelp projects.
8) Export your conversion settings and reuse it when you link another Word document. See Export 

conversion settings.

Linking versus importing Word documents

You have two options for integrating content from Word documents into RoboHelp projects: linking and 
importing. The following table lists the differences between the two methods:
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Option Linking Importing Remarks

Ability to update 
generated topics

Yes. You can update the 
generated topics 
whenever the source 
document or your 
RoboHelp project 
settings change.

No. When you import a 
Word document into a 
RoboHelp project, 
RoboHelp copies the 
contents of the Word 
document into 
RoboHelp project. 
RoboHelp generates 
topics based on 
conversion settings. If 
the source document 
changes, delete the 
generated topics and 
reimport the Word 
document.

Use the link option 
when the source Word 
document can change. 
Typically, if multiple 
projects share the 
Word document, you 
link the Word 
document.
If, however, you are 
bringing in content as a 
one-time activity, you 
can use the import 
option.

Ability to automatically 
update TOC, index, and 
glossary changes from 
the source document

Yes. When you link a 
document, separate 
TOC, index, and 
glossary files are 
created and associated 
with the linked Word 
document. When the 
linked Word document 
is updated, the linked 
TOC, index, and 
glossary files are also 
updated.

No. When you import a 
Word document, the 
generated TOC is 
appended and index 
and glossary are 
merged into the 
selected TOC, index, 
and glossary file.

Use the link option if 
you want to 
automatically update 
the TOC, index, and 
glossary whenever 
these components are 
updated in the Word 
document.

Ability to regenerate 
deleted topics

Yes. You can delete a 
topic that is generated 
from an imported 
Word document, and 
then regenerate the 
same topic when you 
update the Word 
document.

No. Import the source 
document again to 
generate the deleted 
topic.

Use the linking option 
when you share the 
source document 
across multiple 
projects.
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Optimizing Word documents for online output

If you are importing Word documents that have been published in printed or online format, consider the 
following before linking or importing them into RoboHelp projects.

Heading hierarchies
Determine the best mapping of Word heading styles to RoboHelp styles so that you can achieve 
automatic pagination (splitting the document into topics) based on heading styles. If your docu-
ment does not employ hierarchical heading styles, apply them before conversion. For example, you 
can apply Heading 1 style to standalone articles in your Word document. Then map this style to a 
similar RoboHelp style and define pagination to create an HTML topic for each Heading 1 style. See 
Pagination and topic naming in converted Word files.

Inline styles and style overrides
You can convert inline styles to CSS styles in RoboHelp. However, converting inline styles to CSS 
styles can lead to numerous styles that share the same formatting. See Converting Word styles to 
RoboHelp styles.

Header and footer information
RoboHelp can convert headers and footers. However, to ensure consistency across your topics, you 
can define a master page that contains the required header and footer information. By using 
master pages, you can also suppress page numbers in headers and footers. Convert headers and 
footers in Word documents.

Ability to preserve 
changes in generated 
topics

Yes. You can mark 
topics generated from 
a linked Word 
document to ensure 
that the marked topics 
are not updated when 
the linked document is 
updated. In this way, 
you can preserve any 
changes you made in 
RoboHelp.

No. When you 
re-import a Word 
document, all topics 
previously generated 
from the imported 
document are 
recreated, overwriting 
any changes you made 
in RoboHelp.

Use the link option if 
you need to retain 
updates made to both 
the linked Word 
document and the 
generated topics.

Ability to change the 
filenames and topic 
titles of generated files 
from Project Manager

No. When you link a 
Word document, you 
cannot change the 
filenames or topic titles 
of generated files from 
Project Manager.

Yes. When you import 
a Word document, you 
can change the 
filenames or topic titles 
of generated files.

Use the import option 
if you want to 
customize the 
filenames and topic 
titles from Project 
Manager.

Option Linking Importing Remarks
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Chapter versus topic
In printed documentation, the chapter is the logical and physical unit for grouping content. In 
online Help, the organizational unit is the topic, and users see topics one at a time. Although you 
can group the content into folders that expand when the user navigates the table of contents, only 
one topic appears on the screen at a time. Try to provide comprehensive information without 
adding redundancy by grouping related topics. See Pagination and topic naming in converted Word 
files.

TOCs
As you import Word documents, you can also import the Word TOC into the RoboHelp TOC. You 
can define the topic hierarchy and represent that hierarchy in the RoboHelp TOC. See Importing a 
Word TOC, index, and glossary.

Context sensitivity
In online Help formats, you can link specific topics to dialog boxes and other elements that users 
encounter in the application workflow. You can assign map IDs to topics in RoboHelp. However, you 
can also assign context-sensitive Help markers in Word documents using custom footnote entries. 
RoboHelp reads these footnote entries and assigns the map IDs to the generated topics. Ensure 
that topics in the source Word document are not overly fragmented. A topic must contain sufficient 
information to make sense as a standalone unit.

For example, if a short task doesn’t make sense without some introductory conceptual information, 
don’t display that task as a standalone topic. To avoid overly fragmented content, assign 
context-sensitive Help markers to topics at a higher level. In this way, the generated Help topic can 
contain the concept, the task, and any relevant graphics. See Convert context-sensitive Help 
markers in Word to map IDs.

Linking options for Word documents

For linking Word documents to a RoboHelp project, you can specify one of the following options in the 
Import tab of project settings (Project > Project Settings):

Create A Reference
You create a reference to an external Word document. In this case, the source Word document is 
not copied into the RoboHelp project folder. It remains outside the project. You can edit and update 
the Word document independently in Word. Later, in RoboHelp, you can update the topics gener-
ated from the linked document.

Use the linking by reference option to bring in content that is shared across multiple projects. 
Because only a single copy of the document exists, any change in the source document is reflected 
in all projects to which this document is linked.

Create A Copy And Link
You create a copy of the source document and link to the RoboHelp project. In this case, a copy of 
the source document is copied into the RoboHelp project and is visible in the Project Manager pod. 
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You can edit and update the Word copy without affecting the source document. You update the 
topics generated from the copied Word document whenever you edit the document.

Use the Create A Copy And Link option to maintain the Word document in RoboHelp, and restrict 
access to the source document and allow editing only in the copy available in the RoboHelp project. 
For example, if you want to bring in content from a static Word document, link the document by 
copying it to the RoboHelp project. NOTE: This option is available only when you link Word docu-
ments. When you import a Word document, RoboHelp does not keep any link to the source Word 
document.

Link and import Word documents

• Create a RoboHelp project by linking to or importing a Word document. You can import DOCX, DOC, 
DOCM, or RTF files.

• Link or import Word documents into a RoboHelp project.
• (For linked documents)Update the generated topics whenever any of the conversion settings or the 

source documents changes.

HTML files are not created until you define the conversion settings and generate the Help topics. The 
source Word documents are unaffected by linking and subsequent editing. RoboHelp creates a copy of 
the linked or imported Word documents before applying the conversion settings.

Create a project by importing a Word document

You can create a RoboHelp project by importing a Word document. To import Word files, you must have 
Microsoft Word installed on your computer. NOTE: DOCX and DOCM formats are not supported by 
versions earlier than Microsoft Word 2007. See Microsoft Word Help for more information.
1) In the Starter pod, click Word Document under Import.
2) Select Word Documents from the Files Of Type pop-up menu, select the Word document, and click 

Open.
3) Enter relevant details in the New Project wizard and click Finish.

Link a Word document to a RoboHelp project

1) Create a project in RoboHelp.
2) Select Project > Link > Word File.
3) Click Browse to select one or more Word documents and click Open.

NOTE: To import multiple documents with separate TOCs, select them in the order they should 
appear in the master TOC.

4) Right-click the linked file in Project Manager, and select Properties.
5) In the Word Document Settings dialog box, do the following:

– To generate a TOC from the source document, select the Convert Table of Contents option, 
and specify a filename.

– To generate an index from the source document, select the Convert Index option, and specify 
a filename.
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– To generate a glossary from the source document, select the Convert Glossary option, and 
specify a filename.
NOTE: You can define the paragraph styles for a glossary term and definition in the project 
settings. See Convert Word paragraph styles to RoboHelp styles.

NOTE: RoboHelp associates the generated TOC, index, and glossary files with the source Word docu-
ment. So when the source document is updated, the TOC, index, and glossary files are also updated.

6) Click OK.

Import a Word document into a RoboHelp project

1) Create a project in RoboHelp.
2) Select Project > Import  > Word Document.
3) Click Browse to select one or more Word documents and click Open.

NOTE: To import multiple documents with separate TOCs, select them in the order they should 
appear in the master TOC.

4) In the dialog box, set conversion options for the TOC, index, and glossary, and click Next.
For information about various conversion options, see Importing a Word TOC, index, and glossary.

5) (Optional) To edit the conversion settings, click Edit.
6) Check the Import Max checkbox and specify the number of different headers footers to be 

imported from the MS Word document.
NOTE: New master pages will be created with the headers and footers from the imported MS Word 
document.

7) Modify conversion settings according to your requirements, and click OK.
For information about converting headers and footers, see Convert headers and footers in Word 
documents
For information about converting paragraph, character, and other styles, see Converting Word 
styles to RoboHelp styles.

8) Click Finish.

Importing a Word TOC, index, and glossary

When you import a Word document into a RoboHelp project, you can also import the table of contents 
(TOC). Import the TOC into the RoboHelp project to retain, in Help, the navigation structure you defined 
in your Word document. If you import a Word-generated TOC, the first heading becomes a book. 
Lower-level headings become pages (unless a book exists at a lower level).

To import multiple documents with separate TOCs, select the Word documents in the Open dialog box 
in the order that they should appear in the master TOC. The converted TOC is based on the {TOC} field 
codes of the Word document. Ensure that: 
• Headings for main books have lower-level headings.
• Headings for sub-books appear under main headings and have lower-level headings.
• Headings for pages do not have lower-level headings.
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For example, suppose you import a document with more styles than the TOC contains: The document 
contains heading levels 1 through 3, but the TOC contains only heading 1 and 2 entries. To ensure that 
heading 3 styles appear in the TOC, either include heading 3 in the Word TOC or auto-create the TOC in 
RoboHelp.

Import a Word TOC

1) Select Project > Import > Word Document.
2) In the Content Settings dialog box, select Convert Table Of Contents.
3) Select one of the following options:

Add To Existing TOC
Appends the TOC entries to any existing RoboHelp TOC present in the project. Select an existing 
RoboHelp TOC from the list.

Create New Associated TOC
Enter a name for a new associated TOC that is added to the RoboHelp project.

Import Word index entries

RoboHelp creates an index based on the index markers in the document you are importing.
1) Select Project > Import > Word Document.
2) Select Convert Index in the Content Settings dialog box, and select one of the following options:

Add To Existing Index
Add the Word index entries to the existing RoboHelp index of the project.

Create New Associated Index
Enter a name for a new associated index that is added to the RoboHelp project.

Add To Topic
Add the Word index entries to individual topics in which they appear.

Import Word glossary entries

RoboHelp creates a glossary from the Word document you are importing, based on the paragraph styles 
defined for the glossary terms and definitions in project settings.
NOTE: RoboHelp creates a glossary entry by finding a term and a definition in the specified styles in the 
Word document. Consecutive instances of term styles or definition styles are rejected.
1) Select Project > Import > Word Document.
2) Select Convert Glossary in the Content Settings dialog box, and select one of the following options:

Add To Existing Glossary
Add the Word glossary entries to the existing RoboHelp glossary of the project.
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Create New Associated Glossary
Enter a name for a new associated glossary that is added to the RoboHelp project.

Convert headers and footers in Word documents

You can convert the header and footer text in your Word documents to headers and footers in the gener-
ated HTML topics. NOTE: Don’t use this procedure if your projects have topics natively created in Robo-
Help and imported or linked from other sources as well. Instead, use the master page feature in RoboHelp. 
Using master pages, you can define consistent layouts and consistent headers and footers.
1) Select Project > Project Settings .
2) In the Import tab of the Project Settings dialog box, click Edit under Word Document.
3) In the Conversion Settings dialog box, select Other Settings and then do the following:

– To convert the header and footer in Word documents, select Convert Header and Footer.

Converting Word styles to RoboHelp styles

You can select the cascading style sheet (CSS) that RoboHelp uses to map Word styles to RoboHelp styles. 
RoboHelp saves all the style conversion settings in this CSS file. By default, RoboHelp uses the RHStyle-
Mapping.css file for your project.

You can also use a custom CSS for your project. You can later edit the styles either in RoboHelp or in an 
external CSS editing application, such as Adobe Dreamweaver®. You can define how the Word styles 
convert to RoboHelp styles at the project level. All Word style definitions in the Word document appear 
in the mapping dialog box, irrespective of whether they are used in the document.

Select CSS for style mapping

1) Do one of the following:
– Select Project > Import > Word Document.
– Select Project > Link > Word File.
– Select Project > Project Settings.

2) In the Import tab of the Project Settings dialog box, do one of the following:
– Select the CSS file from the CSS For Style Mapping menu. RoboHelp lists CSS files in the root 

folder of your project, from which you can select a CSS file.
– Select Browse CSS from the CSS For Style Mapping menu, and select the CSS file that you want 

to use. Use this option to specify a custom CSS for your project. When you select this option, 
RoboHelp copies the selected CSS file into the root folder of your project, and uses the 
selected CSS for style mapping.

NOTE: You can edit the CSS file you want to use for style mapping. The Edit With option lets you select an 
editor from a predefined list, which includes RoboHelp CSS Editor and other registered CSS editors.



64

IMPORTING AND LINKING MICROSOFT WORD DOCUMENTS
CHAPTER 3 PROJECTS

Automap styles

RoboHelp provides a quick option to map paragraph, character, and table styles in the Word files to the 
corresponding styles in the CSS selected for style mapping. The style names in the Word files and the CSS 
should be same for automap to work.
1) Select Project > Project Settings.
2) Click the Import tab of the Project Settings dialog box.

Do one of the following:
– Select the CSS file from the CSS For Style Mapping menu.
– Click Add next to the CSS for Style Mapping pop-up menu, and select a CSS file.

Use this option to specify a custom CSS for the project. When you select this option, RoboHelp 
copies the selected CSS file into the root folder of the project, and uses the selected CSS for 
style mapping.

3) To edit conversion settings for Word documents, click Edit.
4) In the Paragraph tab, select Automap Paragraph Styles.
5) In the Character tab, select Automap Character Styles.
6) In the Table tab, select Automap Table Styles.

Convert Word paragraph styles to RoboHelp styles

By default, RoboHelp converts all Word styles to CSS, thus retaining the appearance and behavior of the 
Word styles in the RoboHelp project. If you want to ensure consistency of your online Help projects, you 
can map the Word styles to RoboHelp styles and edit them.

If the style names in the style sheet selected for style mapping match RoboHelp style names, follow the 
steps described in Automap styles.

To manually map the styles, follow these steps:
1) Do one of the following:

– Select Project > Import > Word Document.
– Select Project > Link > Word File .
– Select Project > Project Settings .

2) In the Import tab of the Project Settings dialog box, click Edit under Word Document.
3) In the Conversion Settings dialog box, select the Word style from the Paragraph group.
4) From the RoboHelp Style pop-up menu, select the RoboHelp style that you want to map to the 

Word style. To retain the appearance of Word text in your online Help format, select [Source].
5) Select the properties for the selected Word style. To edit the selected RoboHelp style, click Edit 

Style.
To mark a style for glossary
– Select Glossary Definition Style to mark the style to consider for the glossary definition.
– Select Glossary Term to mark the style to consider for the glossary term.
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NOTE: Follow Glossary Definition Style with Glossary Term Style for a complete a Glossary 
Term Definition pair. RoboHelp uses the terms marked with the selected styles, to create a 
Glossary.

– To set up pagination: Select Pagination (Split into topics based on this style) to create a Help 
topic at each occurrence of the selected Word paragraph style. For example, if you select 
Heading 1 and Pagination (Split into topics based on this style), RoboHelp starts a new topic 
at every instance of Heading 1. For more information on Pagination, see Set pagination for 
online Help topics

– Using a user-defined HTML tag: Select or enter a user-defined HTML tag for the selected 
paragraph style.
For example:
A paragraph with styleParaStyleOne is imported in RoboHelp as <p 
class=ParaStyleOne> Paragraph Text </p>.
Specifying this string as Pre for the style ParaStyleOne causes RoboHelp to import the para-
graphs with the style ParaStyleOne as <pre> Paragraph Text </pre>.

Convert Word character styles to RoboHelp styles

You can map the Word character formats to character styles in RoboHelp. You can also edit the styles in 
RoboHelp.

If the style names in the style sheet selected for style mapping match RoboHelp style names, follow the 
steps described in Automap styles.

To manually map the styles, follow these steps:
1) Do one of the following:

– Select Project > Import > Word Document.
– Select Project > Link > Word File .
– Select Project > Project Settings .

2) In the Import tab of the Project Settings dialog box, click Edit under Word Document.
3) In the Conversion Settings dialog box, select the Character group.
4) Select the Word character style from the left pane of the Conversion Settings dialog box.
5) Select the RoboHelp character style from the pop-up menu. Optionally, you can do the following:

– To import the Word character style, select [Source] from the pop-up menu.
– To edit the character style in RoboHelp, click Edit Style.

List mapping

You can map Word lists to RoboHelp lists (multilevel lists) or HTML lists (basic ordered and unordered 
lists) in RoboHelp. If you have defined lists as paragraph styles in RoboHelp, you can map these list styles 
in RoboHelp. If you do not select a style mapping option for a list, it is converted to text without list prop-
erties.
1) Do one of the following:

– Select Project > Import > Word Document.
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– Select Project > Link > Word File .
– Select Project > Project Settings .

2) In the Import tab, click Edit under Word Document.
3) In the Conversion Settings dialog box, select the Other Settings group.
4) Do one of the following:

– To convert the Word list styles to RoboHelp lists, select RoboHelp List from the Convert Word 
List To pop-up menu.

– To convert the Word list styles to HTML lists, select HTML List from the Convert Word List To 
pop-up menu.

Create custom HTML tags

You can define or apply a custom HTML tag instead of the standard <p> tag for paragraph styles in the 
HTML output for the formats that you import from a Word document. You can define separate HTML 
tags for each format in the Word document.
1) Do one of the following:

– Select Project > Import > Word Document.
– Select Project > Link > Word File .
– Select Project > Project Settings .

2) In the Import tab, click Edit under Word Document.
3) In the Conversion Settings dialog box, select a Word paragraph style, and then select User Defined 

HTML Tag option.
4) Type the name of the custom HTML tag or select an existing tag to use instead of the default HTML 

tag.

Convert Word table styles to RoboHelp table styles

You can map Word table styles to RoboHelp table styles. Alternatively, you can import the table styles as 
inline formatting from the Word document. Optionally, you can edit the converted table styles in Robo-
Help.

If the style names in the style sheet selected for style mapping match RoboHelp style names, follow the 
steps described in Automap styles.

To manually map the styles, follow these steps:
1) Do one of the following:

– Select Project > Import > Word Document.
– Select Project > Link > Word File .
– Select Project > Project Settings .

2) In the Import tab, click Edit under Word Document.
3) Select the Word table style from the left pane of the Conversion Settings dialog box.
4) Select the RoboHelp table style from the pop-up menu. Optionally, to edit the table style in Robo-

Help, click Edit Style.
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Convert Word references to hyperlinks

RoboHelp can convert the cross-references in the Word documents. These references appear as hyper-
links in the generated Help topics.
1) Do one of the following:

– Select Project > Import > Word Document.
– Select Project > Link > Word File .
– Select Project > Project Settings .

2) In the Import tab, click Edit under Word Document.
3) In the Conversion Settings group, select Other Settings, and then select Convert References To 

Hyperlinks.

Create RoboHelp styles from inline formatting

Even though it’s best to avoid inline formatting in your Word documents, and apply defined paragraph 
and character styles, you can link and import Word documents to RoboHelp. You can also create Robo-
Help styles from inline formatting in your Word documents. Such styles are added to the project CSS.
1) Select Project > Project Settings .
2) In the Import tab, click Edit under Word Document.
3) In the Conversion Settings dialog box, select Other Settings and then select Auto-Create CSS Styles 

From Inline Formatting.

Pagination and topic naming in converted Word files

In addition to splitting the document into topics and defining topic naming settings, you can do the 
following: 

Convert header and footer
Header and footer text in your word documents is converted and used in the Help topics. See 
Convert headers and footers in Word documents.

Convert TOC and index entries
TOC and index entries in the Word document are converted in your RoboHelp project. See 
Importing a Word TOC, index, and glossary.

Map Word list styles to RoboHelp styles
You can convert the list styles in Word to either RoboHelp list styles or HTML list styles. See List 
mapping.

Automatically create CSS styles from inline formatting
See Create RoboHelp styles from inline formatting.
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Set pagination for online Help topics

When you import a Word document, you define how the contents of the Word file appear as topics in 
RoboHelp. For example, suppose your Word file contains ten topics. If each topic contains subtopics, 
definition lists, tasks, and tables, you can have each topic appear as a separate HTML file. If each of these 
topic headings is in Heading 1 style, you can have each Heading 1 topic created as a separate HTML topic. 
If, however, you set the pagination at Heading 2, separate HTML files are created for each Heading 2 
topic.

You can select multiple paragraph styles for pagination. For example, selecting Heading 1 and Heading 2 
for pagination, causes RoboHelp to start a new topic at every instance of Heading 1 as well as Heading 2.

NOTE: Pagination is based on the Word paragraph styles and not on RoboHelp styles. The text of the Word 
paragraph style is included by default in the filename of the HTML topic file created. Any non-ASCII char-
acters in the topic file name are automatically converted to ASCII characters.

Even though you can set pagination for any Word paragraph style, the topic generated must contain rele-
vant, complete information for the reader. For example, if you set pagination for Heading 3, you run the 
risk of creating topics with only task-level instructions. In this case, the required contextual information 
required to complete the task is isolated in another Heading 3 level topic. To avoid such disjointed, 
incomplete topics, set the pagination at a higher level.
1) Do one of the following:

– Select Project > Import > Word Document.
– Select Project > Link > Word File .
– Select Project > Project Settings .

2) Click Edit under Word Document.
3) In the Conversion Settings dialog box, in the Paragraph group, select the paragraph style on which 

to base pagination.
4) Select the option marked Pagination (Split into topics based on this style) and click OK.

RoboHelp splits the documents into topics using the specified pagination styles.

Convert context-sensitive Help markers in Word to map IDs

You can convert the context-sensitive Help markers that you insert in your Microsoft Word documents 
and reuse them as map IDs. You insert the context-sensitive markers using the Custom Footnote option 
in Word. You insert context-sensitive Help markers using the Insert Footnotes And Endnotes dialog box 
in Word. To insert context-sensitive Help markers, enter a custom string such as TopicAlias and then 
insert the map ID as the marker text. The custom string must not contain spaces or any other invalid char-
acters. See Microsoft Word Help for more information about inserting custom footnote markers.

Sometimes Word documents that you are linking to or importing have context-sensitive Help markers. If 
so, you can incorporate them in the map ID header file that you generate. In the project header file, add 
the map IDs that you assigned to topics in your Word documents. The context-sensitive marker string is 
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a project-wide parameter. Ensure that all Word documents that you link to or import contain the same 
string as the context-sensitive marker text.
1) Do one of the following:

– Select Project > Import > Word Document.
– Select Project > Link > Word File .
– Select Project > Project Settings .

2) Click Edit under Word Document.
3) In the Conversion Settings dialog box, in the Other Settings group, enter the context-sensitive Help 

marker string and click OK.

Define the topic name pattern for generated topics

When you set heading styles for pagination, the heading text is included by default in the filename of the 
topic file created in RoboHelp. For example, suppose you define Heading 2 for pagination. If the Word 
document has two Heading 2 topics, “Introduction” and “Beyond basics,” the topics are created as files 
named introduction.htm and beyond_basics.htm. The result is intuitively named HTML files that indicate 
the topic title. In addition to this default scheme, you can define more naming conventions. If, however, 
the Help system uses sequentially numbered files, such as helptopic001.html, helptopic002.html, and so 
on, you can define the pattern to support that convention.
1) Do one of the following:

– Select Project > Import > Word Document.
– Select Project > Link > Word File .
– Select Project > Project Settings .

2) In the Conversion Settings dialog box, select Other Settings.
3) In the Other Settings tab, set the topic name pattern.

Topics are named according to the selected pattern. You can select one of the following or create a 
topic name pattern.

Default Uses the topic title text as the topic filename.

<$filename_no_ext>-<$par
atext>

The name of the converted HTML topic contains the following:
• The name of the Word source file without its extension

Hyphen as the separator
Paragraph text used to demarcate HTML topics

For example, a Word file named “Chapter.doc” with “1-Introduction” as 
paragraph text is converted to an HTML topic named 
“Chapter-1-Introduction.”
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Synchronizing linked Word documents with RoboHelp projects

After you import or link Word documents to your RoboHelp project, you generate Help topics based on 
the project settings. When you import a Word document into a RoboHelp project, the topics are gener-
ated immediately and appear in the Project Manager pod. However, when you link a Word document to 
a RoboHelp project, the topics are not generated until you explicitly generate them. Because RoboHelp 
maintains a live link with the linked Word document, you can update a linked Word document if the 
source document or conversion settings in the RoboHelp project change. Icons of the project files in the 
Project Manager pod indicate whether the documents are in sync with the RoboHelp topics.

Update the topics generated from linked Word documents in the following scenarios:
• Source Word documents changed after you added or linked them to the RoboHelp project.
• You changed the pagination settings in the RoboHelp project.
• You changed the styles in the RoboHelp project and want to revert them to as in the FrameMaker 

document.
• You updated the CSS in the RoboHelp project.

If you imported documents into the project, the Project Manager pod does not indicate the synchroniza-
tion status. If either the Word documents or the conversion settings change, reimport the Word docu-
ments and overwrite the RoboHelp topics already generated. When you update the documents, 
RoboHelp updates the converted HTML topics, TOC, index, and glossary.

Word document synchronization status indicators

The following table shows the different status indicators that appear on the Project Manager pod in 
RoboHelp for all linked Word documents.

<$filename_no_ext>-<n> The name of the converted HTML topic contains the following:
• The name of the Word source file without its extension

Hyphen as the separator
A sequential number

For example, “Chapter.doc” is converted to an HTML topic named 
“Chapter-1.”

<$paratext_no_num> The name of the converted HTML topic contains the paragraph text 
used to demarcate the HTML topic, without numbering. For example, 
paragraph text “1.Introduction” is converted to an HTML topic named 
“Introduction.”.

<$paratext> The name of the converted HTML topic contains the paragraph text 
used to demarcate the HTML topic. For example, paragraph text 
“Introduction” is converted into an HTML topic named “Introduction.”

Default Uses the topic title text as the topic filename.
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Generate topics from linked Word documents

Generating Help topics from linked Word documents is a one-time activity. After you generate Help 
topics, you can update them whenever the source document or conversion settings change.
1) Right-click the linked Word document in the Project Manager pod, and select Update > Generate.

Update topics generated from linked Word documents

RoboHelp does not update linked documents automatically when you link Word documents to a Robo-
Help project. You define the conversion settings, including style mapping and pagination, and then 
generate the topics. Select options to update a linked document manually.
1) From the Project Manager pod, right-click a Word document, select Update, and select one of the 

following:

Generate
Generates HTML topics from the linked Word document for the first time. After the topics are 
generated, the option changes to Update.

Update
Updates topics generated from the selected Word document. Only the topics that have changed 
are updated.

Icon Description

Source Word document that was linked by reference missing. The source document 
that you have linked to the RoboHelp project is moved to another folder, renamed, or 
deleted. Locate the source document and link to the new location.

Source Word document that was linked by copy into the project is missing, renamed, 
or moved to another folder. Locate the source document and link to the new location.

Source Word document that was linked by reference is out of sync because of changes 
in the source document. Update the document.

Source Word document that was linked by copy into the project is out of sync because 
of changes in the source document. Update the document.

Source Word document linked by reference is out of sync because of changes in the 
RoboHelp conversion settings. Update the document.

Source Word document linked by copy into the project is out of sync because of 
changes in the RoboHelp conversion settings. Update the document.

Source Word document linked by reference and generated topics are in sync.

Source Word document linked by copy into the project and generated topics are in 
sync.



72

IMPORTING AND LINKING MICROSOFT WORD DOCUMENTS
CHAPTER 3 PROJECTS

Update All
Updates all topics generated from all linked documents including all Word and FrameMaker docu-
ments. Because all documents are updated, including those that you edited in RoboHelp, exercise 
caution when you use the Update All option.

Force Update
Overwrites the current set of topics generated from the selected Word document. Use this option 
to force an update of the topics generated from the linked Word document after you edit the 
source in Microsoft Word. This option updates all topics including those that haven’t changed.

Force Update All
Updates all linked documents, including Word and FrameMaker documents, and overwrites all 
generated topics.

Preserve changes to a topic during an update

Normally, when you update a linked document, all topics generated from it are updated, overwriting any 
other changes you made in the generated topics. However, you can selectively preserve changes in 
generated topics and retain your edits.
1) Right-click the linked document in the Project Manager pod and select Properties.
2) In the Word Document Settings dialog box, select File Update Settings tab.
3) On the left column, select the files in which you want to preserve changes during update and click 

OK.

Set alert when editing generated topics

You can set RoboHelp to alert you when you make changes to topics generated from linked documents. 
When you save the changes to such topics, RoboHelp alerts you that the changes would be lost when the 
linked documents are updated. 
1) Select File > Options.
2) In the General tab, select Show Alert On Modification Of Auto Generated Topics From Linked Docu-

ments and click OK.

Mark topic edits for preservation

If you enabled the alerts when saving changes to generated topics, you can mark the topic edits for pres-
ervation during an update. Topics marked for preservation during updates are automatically added to 
the list of preserved topics in the File Update Settings dialog box.
1) Edit a generated topic and save the changes.
2) In the alert message that appears, select Preserve Modifications To This File and click OK.
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Delete a generated topic

When you delete a generated topic, you have two options. You can regenerate the deleted topic when 
you update the linked Word document or completely remove the deleted topic from your project. By 
default, RoboHelp regenerates the deleted topic when you update the Word document.
1) In the Project Manager pod, expand the linked Word document to display the topics generated 

from it.
2) Right-click the topic that you want to delete, and select Delete.
3) Do one of the following:

– Click OK to delete the topic from the project permanently. The deleted topic is not regener-
ated when you update the Word document.

– Select Generate This File On Next Update and click OK to delete the topic. When you update 
the Word document, the deleted topic is generated again.

Regenerate a deleted topic

If you delete a topic generated from a linked Word document, the topic is removed from the project. 
However, you can regenerate topics deleted from a linked document.
1) Right-click the linked Word document in the Project Manager pod and select Properties.
2) In the Word Document Settings dialog box, select File Update Settings tab.
3) On the right column, select the deleted files that you want to retrieve and click OK.
4) Update the Word document.

Edit a linked Word document

You can edit linked Word documents directly in Microsoft Word.
1) Right-click a document and select Edit.
2) Edit the Word document in Microsoft Word.
3) Click Save. The modified Word document now appears in the Project Manager pod with a different 

icon. This icon indicates that the source content is now out of sync with the topics generated from 
the linked Word document. NOTE: Force an update of the document after you edit the source in 
Microsoft Word.

Delete a linked Word document

You can directly delete documents linked by copy from the Project Files folder, and you can delete the 
references of the documents linked by reference.
1) Right-click a document and select Delete.

When you delete a linked file, all its associated documents, such as CSS, images, baggage files, and multi-
media files, are also deleted.

Notes:

• If a referenced file is moved to a different location, its icon changes. You can restore the link to the 
Word document by pointing to its new location.
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• Do not rename files generated after linking a Word document.
• You cannot drag the generated topics outside the parent Microsoft Word document folder to some 

other location in the Project Manager pod.

Restore a link to a missing or renamed Word document

If any of the linked Word documents are moved or renamed, RoboHelp displays a missing link icon for 
the linked document in the Project Manager pod. You can restore the link to a moved or renamed file 
and have all the topics already generated from the document retained in the project.
1) In the Project Manager pod, right-click the Word document that has the missing link icon.
2) Select Restore Link To Word File, and browse to select the new location of the missing file.

Word conversion settings

You can create a standard set of conversion settings for importing Word content into RoboHelp projects 
and then use these settings consistently across multiple projects.

You define these settings once. For subsequent projects, import these settings to the project. In this way, 
you can quickly set up the project environment and publish Word content in several online formats.

These settings include:
• Cascading style sheets (CSS) for RoboHelp projects
• Style mapping between Word styles and RoboHelp styles
• Style conversion and other settings

Export conversion settings

1) Select Project > Project Settings.
2) On the Import tab of the Project Settings dialog box, click Export.
3) Specify a name for the RoboHelp Import Settings file (ISF) and click Save.

Import conversion settings to a project

1) Select Project > Project Settings.
2) On the Import tab of the Project Settings dialog box, click Browse.
3) Select a RoboHelp Import Settings File (ISF). Click Open.

Word document components converted to RoboHelp

RoboHelp converts most of the Word components when you link or import Word documents. The 
following tables list the major Word document components and show how they are converted in Robo-
Help.

Word document 
component
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TOC Converted, if selected. See Importing a Word TOC, index, and glossary.

Index Converted, if selected. See Importing a Word TOC, index, and glossary.

Glossary You can create a Glossary in RoboHelp from selected paragraph styles in 
Word. See Importing a Word TOC, index, and glossary.

Equations

Equations Ignored when importing the document into RoboHelp.

Markers

Cross-references, 
hypertext, URLs

Cross-references are converted to hypertext links if the Convert References 
to hyperlinks option is enabled in RoboHelp when importing a Word 
document. Else, the cross-references are imported as plain text. Unresolved 
cross-references and hypertext entries appear as text in online Help.
URLs become live hypertext links in the online Help output. See Convert 
Word references to hyperlinks.

Context-sensitive Help 
markers

Converted into map IDs in RoboHelp. See Convert context-sensitive Help 
markers in Word to map IDs.

Formats

Paragraph formats Converted. You can map Microsoft Word paragraph formats to RoboHelp 
styles or import the source formatting. See Convert Word paragraph styles to 
RoboHelp styles.

Character formats Converted. You can map Microsoft Word character formats to RoboHelp 
styles or import the source formatting. See Convert Word character styles to 
RoboHelp styles.

Table formats Converted. You can map Microsoft Word table formats to RoboHelp styles or 
import the source formatting. See Convert Word table styles to RoboHelp 
table styles.

Lists Converted according to the settings you define. See List mapping.

Page layouts

Page layout, size, and 
Word pagination

Ignored. These elements are not applicable to online Help.

Headers/footers Converted. See Convert headers and footers in Word documents.
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Importing FrameMaker documents

You can import FrameMaker book, XML files that are part of the book, FM files, or MIF files authored in 
FrameMaker into your Robohelp project. This chapter explains the conversion tips and settings that 
should be considered while importing Framemaker documents into Robohelp.

Optimizing for online output before conversion

If your authoring process in FrameMaker is optimized for print output, consider the following before 
linking or importing FrameMaker documents into RoboHelp projects.

Heading formats
Determine the best mapping of FrameMaker heading formats to RoboHelp styles. FrameMaker 
documents define various heading formats specifically for print documentation. Among these 
formats are side heads and heading styles that start on a new page. These formats don’t apply to 
online formats. You generally map these heading styles to a few standard styles in the RoboHelp 
project.

Page layout settings
Often FrameMaker chapter templates specify an even number of pages so that new chapters begin 
on a recto (right) page. For online Help, ignore these pagination considerations.

Headers and footers
RoboHelp ignores headers and footers during conversion, including legal text such as “Confiden-
tial” and copyright lines. Include such text in the headers and footers in a separate step, after 
conversion. Similarly, in RoboHelp, re-create watermark text or images that you used in the printed 
documentation. Use the master page feature in RoboHelp to make these changes.

Navigation
In print, cross-references specify page numbers which are irrelevant in Help. You can map 
cross-reference formats in FrameMaker to a format without the chapter and page number. 
Converting to online Help removes chapter and section titles in headers and footers. You can 
enhance navigability by using breadcrumbs, back and next buttons, and a defined browse sequence 
instead.

Images

Images Converted. PNG images are imported as is if the Allow PNG as a graphics 
format option is selected in Microsoft Word Web Options. All other images 
are converted to gif or jpg.

Drawings Converted to images.
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Redundant content
To provide context in different sections of a printed document, writers generally add redundant 
information such as brief summaries of concepts covered previously. Because online Help is a 
random-access, nonlinear medium, it requires less redundant content. Use cross-references and 
conditional text options to minimize redundant content in your outputs.

Chapter versus topic
Printed documentation requires you to segregate content into self-contained chapters, which 
allow readers to logically and physically separate content. Online Help segregates content at topic 
level, accessed one topic at a time. Although you can group the content within chapters into folders 
that expand when a user navigates the table of contents, only one topic appears at a time. In this 
case, try to provide comprehensive information without adding redundancy by chunking related 
topics together.

Context sensitivity
Online Help formats allow you to link specific topics to related content within the application work-
flow. Although you can assign map IDs to topics in RoboHelp, you can also assign context-sensitive 
Help markers in FrameMaker documents. RoboHelp reads these markers and assigns the map IDs 
to the generated topics. Ensure that sufficient information is contained in the topics that are 
created from FrameMaker.

For example, a short procedure as a stand-alone topic does not provide the conceptual information 
for the reader. To avoid creating topics with incomplete information, assign context-sensitive Help 
markers to topics at a higher level, so that the generated Help topic contains the concept, proce-
dure, and any relevant graphics.

Preparing FrameMaker documents for conversion to Help

If the FrameMaker document that you are importing is an unstructured FrameMaker book, you can 
define a single FrameMaker template for the conversion. You can then specify this template as the 
project template that overrides the formats of individual documents at the RoboHelp project level. You 
can also reuse the conversion settings across other projects by exporting the conversion settings.

Carefully examine the FrameMaker templates before importing the documents into RoboHelp, such as 
when you use a general-purpose FrameMaker template. If this template contains formats that aren’t 
used in the book, omit those formats in the template you use for the conversion.
1) Create a FrameMaker template that contains the formats you need in Help. Alternatively, 

customize the FrameMaker template. You don’t have to apply the template manually. You can set 
RoboHelp to apply a selected template to FrameMaker files before they are linked or imported to 
RoboHelp.
In Structured FrameMaker, the element definition document (EDD) or the DTD used in the struc-
tured FrameMaker template automatically controls formatting. Because structured FrameMaker 
enforces a valid structure and format, structured documents do not contain format overrides.

2) Apply context-sensitive Help markers to the required topics. See Convert context-sensitive Help 
markers from FrameMaker documents.
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3) Enclose graphics, callouts, and graphic or text frames you created with FrameMaker graphic tools 
into anchored frames. RoboHelp imports only those FrameMaker graphics that are enclosed in 
anchored frames. By default, when you import graphics and multimedia files into a FrameMaker 
document, these are placed in anchored frames. On the other hand, if your FrameMaker document 
contains graphics that are placed in graphic frames, you should place these into anchored frames 
before linking or importing the FrameMaker files into RoboHelp.
NOTE: If the offset for an image in the FrameMaker file is set to a negative value, the image can be 
partly hidden in the HTML. Change the value before importing.

4) To maintain the original quality of images, insert them in FrameMaker documents by reference. 
RoboHelp copies the referenced images directly from the source if the complete image is visible 
inside the anchored frame. Similarly, if the images are large, insert them in the source document 
by reference.

5) Fix any issues in the document such as unresolved cross-references, missing fonts, and irregular 
numbering issues. See FrameMaker Help for more information.

6) Set up alternate text or captions for the images and graphics to create accessible online content. 
See Create alternate text for images.

7) Apply conditional text settings in FrameMaker documents. See FrameMaker Help.
8) Edit the FrameMaker TOC reference pages to have indented hierarchical headings with different 

styles. See Convert a FrameMaker TOC.

Importing FrameMaker documents

The RoboHelp workflow for linking or importing FrameMaker documents allows you to do the following:
• Create a RoboHelp project by importing a FrameMaker book. You can import BOOK or BK files.
• Import FrameMaker documents into a RoboHelp project. You can import FM files, or MIF files that 

are authored in FrameMaker. XML files that are part of a FrameMaker book can be imported.

Before you import FrameMaker documents, check them in FrameMaker for errors such as unresolved 
cross-references and format overrides. See Preparing FrameMaker documents for conversion to Help.

Create a RoboHelp project by importing FrameMaker books or documents

You can create a RoboHelp project by importing FrameMaker books or documents. Importing these files 
requires that FrameMaker 8 or later installed is in your computer. 
1) On the RoboHelp Starter page, click More under Import or select File > New Project.
2) On the Import tab of the New Project dialog box, select FrameMaker Document and click OK.
3) Select the FrameMaker book or document (BOOK, BK, FM, MIF, FRM) from the Files Of Type pop-up 

menu, browse to select the FrameMaker book, and click Open.

NOTE: Use the above procedure to create a new project from scratch and import FrameMaker content in 
the new project. However, linking of FrameMaker documents is not allowed in this case.
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Import a FrameMaker book into a new RoboHelp project

1) Create a project in RoboHelp.
2) Select Project > Import > Document > FrameMaker Document.
3) Select FrameMaker book (BOOK) from the Files Of Type pop-up menu.
4) Browse to select the FrameMaker book file and click Open.

If you are importing a FrameMaker document, you can select the components that you want to import 
from the Import Wizard that appears. You can select the TOC, index, and glossary, and specify the conver-
sion settings.
NOTE: Use the above procedure if you already have a project with some content, and wish to import 
FrameMaker content. Linking of FrameMaker document is allowed in this case.

Import FrameMaker documents into an existing RoboHelp project

1) Select Project > Import > Document > FrameMaker document.
2) Select the FrameMaker document type that you want to import.
3) Select the documents and click Open.

FrameMaker document components converted to RoboHelp

RoboHelp converts most of the FrameMaker components when you link or import FrameMaker docu-
ments. The following tables list the major FrameMaker document components and show how they are 
converted in RoboHelp.

FrameMaker files

Book files Documents contained within the book are converted (FM, XML, MIF, HTM, 
and HTML files). XHTML files that are included in the FrameMaker book must 
be valid XHTML. Validate the XHTML in FrameMaker itself. All other files in 
the FrameMaker book are ignored. Child books, folders, and groups in 
FrameMaker 9 books are converted and appear as folders in the RoboHelp 
projects. See Hierarchical structure in a FrameMaker 9 book.

TOC Converted, if selected. See Convert a FrameMaker TOC.

Text insets Text insets in the FrameMaker documents are considered part of the 
FrameMaker document itself and are inserted as text in the RoboHelp topic. 
Once inserted, the content cannot be edited as a text inset in FrameMaker 
but can only be edited as text within RoboHelp.

Index and glossary Index and glossary files generated in the FrameMaker book are not 
converted. Instead, the index markers and glossary markers in the imported 
FrameMaker documents are converted if selected. See Import FrameMaker 
index entries and Import glossary definitions.
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Variables and 
conditional text

Variables Converted. User-defined variables in FrameMaker are converted as such in 
RoboHelp and can be redefined. Apply relevant conditional text tags to 
suppress variables that shouldn’t appear in online format. For example, you 
can suppress the Table Continuation variable in table headers for tables that 
break across pages in the FrameMaker documents.

Conditional tags Converted as RoboHelp conditional build tags.

Equations Convert equations to images and insert them in the RoboHelp topics after 
conversion.

Markers

Cross-references, 
hypertext, URLs

Converted to hypertext links. You can map the cross-reference formats in 
RoboHelp so that you can remove the volume, chapter, and page references 
that are not relevant in online format. Unresolved cross-references and 
hypertext entries appear as text in online Help. URLs become live hypertext 
links in the online Help output. See Convert FrameMaker cross-reference 
formats to RoboHelp styles.

Index and glossary 
markers

Converted to an index and glossary when creating project. See Import 
FrameMaker index entries and Import glossary definitions.

Topic name markers Converted if you select this option in the project conversion settings. Use 
topic name markers to create topic titles and topic filenames from the 
marker text. See Setting pagination and topic names.

Context-sensitive Help 
markers

Converted if you select this option in the project conversion settings. Use 
Context Sensitive Help Makers in FrameMaker to specify text in FrameMaker 
document for generating Context Sensitive Help. See Setting pagination and 
topic names.

Custom markers Converted. You can use these markers for delineating topics from 
FrameMaker source, or to pass processing instructions to RoboHelp for 
images and tables.

Formats

Paragraph formats Converted. You can map FrameMaker paragraph formats to RoboHelp styles 
or import the source formatting. See Convert FrameMaker paragraph 
formats to RoboHelp styles

Character formats Converted. You can map FrameMaker character formats to RoboHelp styles 
or import the source formatting. See Convert FrameMaker character formats 
to RoboHelp styles.
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Table formats Converted. You can map FrameMaker table formats to RoboHelp styles or 
import the source formatting. See Convert FrameMaker table formats to 
RoboHelp table styles.

Footnote properties 
and table footnotes

Converted. Because table title and table footnotes are paragraph formats in 
FrameMaker, you specify conversion settings for these paragraph formats 
separately.

Lists Converted according to the settings you define. See List-mapping scenarios

Page layouts

Master pages FrameMaker master pages are ignored. Master pages are used for layout, 
borders, and page numbers in FrameMaker, so they are not applicable to 
online Help. RoboHelp provides master page support for breadcrumbs, topic 
TOCs, and headers and footers that can be selected when you publish a 
single source layout.

Reference pages Ignored. However, you can use the advanced scripting support in RoboHelp 
to convert images and graphics placed in the reference pages that are 
associated with paragraph formats.

Page layout, size, and 
pagination

Ignored. These elements are not applicable to online Help. See Setting 
pagination and topic names.

Headers/footers Ignored. Headers and footers in FrameMaker usually contain chapter names, 
chapter numbers, and page numbers, which are not applicable in online 
formats. After you generate topics in RoboHelp, you can create headers and 
footers in RoboHelp that allow you to place information at the top and 
bottom of topics.

Rotated text Converted to text, such as in table cells. (Rotated text is not supported in 
HTML).

Images and anchored 
frames

Images Only converted if they are inside anchored frames. If the images are not in 
anchored frames, reinsert them after you have imported the FrameMaker 
files. By default, FrameMaker places the imported and linked images in 
anchored frames, so they are converted. However, images placed in graphic 
frames are not converted. If images contained in anchored frames are 
missing, RoboHelp creates blank images with the filename in a sequential 
manner. See Image conversion settings.

Drawings Drawings created within anchored frames are converted to images. You can 
define the image conversion settings. See Image conversion settings.
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Conversion basics

Convert a FrameMaker TOC

When you import a FrameMaker book to a RoboHelp project, you can also import the table of contents 
(TOC). Import the TOC into the RoboHelp project to retain the navigation structure you defined in the 
FrameMaker book.
1) Select Project > Import > FrameMaker Document. Select the FrameMaker file.
2) In the Content Settings dialog box, select Convert FrameMaker Table Of Contents, and browse to 

select the FrameMaker TOC file.
NOTE: If you are importing a FrameMaker DITA map, RoboHelp uses the TOC that FrameMaker 
creates based on the settings in the ditafm_output.ini file. For details about the ditafm_output.ini 
file, see FrameMaker Help.

3) Select one of the following options:

Add To Existing TOC
Appends the TOC entries to any existing RoboHelp TOC in the project. Select an existing RoboHelp 
TOC from the list.

Anchored frames Converted to images. See Image conversion settings.

ALT text on images 
and anchored frames

Converted. If no ALT text is provided in the FrameMaker document for 
images RoboHelp applies the filename of the converted images as the ALT 
text. See Create alternate text for images.

Hotspots Converted to image maps.

Text frames, graphic 
frames, and images 
inside anchored 
frames

Anchored frames and their content convert to images. All content within an 
anchored frame, including text frames, multiple images, and callouts convert 
to a single image. RoboHelp inserts the filename of the created image as the 
ALT text if no ALT text is defined for the anchored frame.

Equations Enclose equations in anchored frames so that they are converted to images 
when RoboHelp converts them. See FrameMaker Help.

Structured 
FrameMaker 
components

XML files in book Converted like FrameMaker documents.

XHTML files in book Converted like FrameMaker documents.

Content references Text or files inserted into FrameMaker documents as content references 
appear as part of the topics where they appear. They do not appear as 
references in the online Help outputs. See Content reference.
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Create New Associated TOC
Enter a name for a new associated TOC that is added to the RoboHelp project.

Styles in the FrameMaker TOC determine which TOC items become books, sub-books, or pages. The most 
important element in determining the level is the leftmost indent, followed by the font size and font 
weight. TOC entries that have indented items under them become books in the RoboHelp TOC. If all the 
TOC entries have the same indention, font size, and weight, the TOC in RoboHelp appears flat.
• To make a heading a main book, include indented heading levels beneath that heading, or use 

smaller fonts or no bold for the subsumed headings.
• To make a heading a sub-book, place the heading under a main heading. Then include indented 

heading levels beneath the sub-book heading, or use smaller fonts or no bold for the subsumed 
headings.

• To make a heading a page, don’t include any heading levels beneath that heading. Indent the page 
heading, or use smaller fonts or no bold.

Differences between FrameMaker and RoboHelp TOCs

You can either import the FrameMaker TOC or automatically create a TOC in RoboHelp from generated 
topics.
• In FrameMaker, the TOC is generated according to the heading styles that you include in the TOC. 

In RoboHelp, the TOC is generated according to the topic titles. If you use topic name markers in 
FrameMaker to name the topics when you import FrameMaker documents, filenames in RoboHelp 
differ from the topic titles.

• Autocreating a TOC for a FrameMaker 9 (or later) book can create multiple layers of content 
because of the folder structure in a FrameMaker 9 (or later) book.

• In RoboHelp, you can place a TOC placeholder in another TOC, thus allowing you to create nested 
TOCs.

Import FrameMaker index entries

RoboHelp creates an index based on the index markers in the document you are importing. However, the 
index file generated in the FrameMaker book is not imported into the RoboHelp project.
1) Select Project > Import > FrameMaker Document and select the FrameMaker book or document.
2) Select Convert Index in the Content Settings dialog box, and select one of the following options:

Add To Existing Index
Add the FrameMaker index entries to the existing RoboHelp index of the project.

Create New Associated Index
Enter a name for a new associated index that is added to the RoboHelp project.

Add To Topic
Add the FrameMaker index entries to individual topics in which they appear. NOTE: RoboHelp does 
not have any project-level setting related to index type. Index entries can be present in a project 
Index or topic. FrameMaker linking allows you to select the index type from the various possible 
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options related to indexing. When output is generated from RoboHelp, the index entries present in 
the topic and the index entries present in the selected (in SSL layout) index are placed in the output.

Import glossary definitions

RoboHelp creates a glossary based on glossary markers in the document you are importing. The text 
inside the glossary marker is the glossary term, and the paragraph text that contains the marker is the 
definition.
1) Select Project > Import > FrameMaker Document and select the FrameMaker book or document.
2) Select Convert Glossary in the Content Settings dialog box, and select one of the following options:

Add To Existing Glossary
Add the FrameMaker glossary to the RoboHelp glossary of the project. You can select the glossary 
from the list.

Create New Associated Glossary
Enter a name for a new associated glossary in the RoboHelp project.

Apply conditions from a Ditaval file

While importing a FrameMaker DITA map, you can apply a Ditaval file. RoboHelp processes the condi-
tions specified in the Ditaval file to filter content for import.
1) Select Project > Import > FrameMaker Document and select the FrameMaker DITA map.
2) Select the .ditaval file to apply and click Open.

Converting FrameMaker formats to RoboHelp styles

You can define how the FrameMaker formats are converted to RoboHelp styles at the project level. All 
FrameMaker format definitions in the FrameMaker document appear in the Conversion Settings dialog 
box, even if they aren’t used. You specify the following:
• FrameMaker template used for conversion. This step is optional.
• RoboHelp style sheet for style mapping.

Select a FrameMaker template for conversion

You can then specify this template as the project template, which overrides the formats of individual 
documents at the RoboHelp project level. You can also reuse the conversion settings across other proj-
ects by exporting the conversion settings.
1) Select Project > Project Settings.
2) Click the Import tab of the Project Settings dialog box. Select Apply FrameMaker Template.
3) Click Browse to select the FrameMaker template you want to use for the project.

NOTE: While importing, RoboHelp first copies the template into the project and then applies the 
template to the documents being imported. Any changes made to the template in the original loca-
tion.
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Select the CSS for style mapping

You can select the cascading style sheet (CSS) that RoboHelp uses to map the FrameMaker formats to 
RoboHelp styles. By default, RoboHelp uses the RHStyleMapping.css file for the project. You can also use 
a custom CSS. You can later edit the styles either in RoboHelp or in an external CSS editing application 
such as Adobe® Dreamweaver®.
1) Select Project > Project Settings.
2) Click the Import tab of the Project Settings dialog box. Do one of the following:

– Select the CSS file from the CSS For Style Mapping menu.
– Click Add next to the CSS for Style Mapping pop-up menu, and select a CSS file.

Use this option to specify a custom CSS for the project. When you select this option, RoboHelp 
copies the selected CSS file into the root folder of the project, and uses the selected CSS for 
style mapping.

Upgrading from RoboHelp 7 to RoboHelp 11

RoboHelp 7 allowed document-level conversion settings for the FrameMaker documents that you added 
to a RoboHelp project. With RoboHelp 8, the conversion settings are applied project-wide, allowing you 
to have a consistent set of conversion parameters. If you are opening a RoboHelp 7 project that had 
FrameMaker documents added by reference or by copy, you can retain the document-specific settings 
defined in the RoboHelp 7 project.

You can add or remove documents to an upgraded project with the document-level conversion settings. 
You can define document-level conversion settings for the newly added FrameMaker documents also. 
This option allows you to retain the RoboHelp 7 behavior for your upgraded project. However, to take 
advantage of the enhanced features of RoboHelp 9 and its integration with FrameMaker, you should 
upgrade the project completely. For example, RoboHelp 7 provided limited mapping options for auto-
numbering and list styles. On the other hand, RoboHelp 8 allows you to map complex autonumber 
formats and multilevel list styles to RoboHelp styles or HTML lists. In RoboHelp 9, list and table import is 
further enhanced.

NOTE: You can discard the document-level settings any time, even if you choose to retain them at the time 
of upgrading. However, discarding the document-level settings is irreversible.

Retain or discard RoboHelp 7 settings when upgrading

To retain the document-level settings for converting FrameMaker content into your RoboHelp project, 
you override the project-level settings of the converted project with the document-level settings inher-
ited from the RoboHelp 7 project. By default, RoboHelp allows you to retain the document-level settings 
by overriding the project-level settings.
1) Open the RoboHelp 7 project in RoboHelp 9.
2) Select Project > Project Settings.
3) In the Import tab of the Project Settings dialog box, do one of the following:

– To retain the document-level settings in the upgraded project, select the Override Project 
Settings At Document Level option. This is the default behavior.



86

IMPORTING FRAMEMAKER DOCUMENTS
CHAPTER 3 PROJECTS

– To discard the document-level settings and use project-level settings, deselect the Override 
Project Settings At Document Level option.

Edit document-level conversion settings

If you retain the document-level settings that override the project-level settings for a project converted 
from an earlier version of RoboHelp, you can edit these settings. 
1) In the Project Manager pod, right-click the added FrameMaker document and select Properties.
2) In the FrameMaker Document Settings dialog box, select the Conversion Settings tab, and set the 

following. 

Apply FrameMaker Conditional Text Build Expression
Select to apply conditional text settings before converting the added FrameMaker document.

Convert AutoNumber To HTML List
Select to convert the FrameMaker autonumbering to HTML lists in the converted HTML topics.

Context-Sensitive Help Marker
Specify the context-sensitive Help marker that RoboHelp should use for generating context-sensi-
tive Help.

User-Defined HTML Tag
Select the user-defined HTML tag that you want to use instead of the standard <p> tags in the 
generated topics. NOTE: To select FrameMaker formats on which the user-defined tag must be 
applied, select the FrameMaker formats from the Project Settings dialog box.

Topic Name Pattern
Specify the topic name pattern for topics generated from the added FrameMaker document.

FrameMaker Styles For Pagination
Specify the list of FrameMaker paragraph formats on which pagination for online Help topics should 
be done. You specify the FrameMaker paragraph formats separated by commas.

3) NOTE: Pagination is based on FrameMaker paragraph formats.

Hierarchical structure in a FrameMaker 9 book

With FrameMaker 9 or later, you can enforce a hierarchical structure and grouping within the book. You 
can also include child books within a book, and create folders and groups within a book.

When you link or import a structured FrameMaker book, the Project Manager pod in RoboHelp shows 
the FrameMaker book’s hierarchy. When linked or imported into RoboHelp, child books inherit the TOC, 
index, and glossary from the parent book. See FrameMaker Help for more information.
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Hierarchy of FrameMaker book reflected in the Project Manager pod when you link a FrameMaker book into RoboHelp

Convert FrameMaker cross-reference formats to RoboHelp styles

1) Select Project > Project Settings.
2) In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.
3) Select a cross-reference format from the Cross Reference group in the Conversion Settings dialog 

box.
4) Select a RoboHelp style to map to it, or type the RoboHelp style field to redefine the cross-refer-

ences in the FrameMaker document.
5) Double-click a building block to append it to the RoboHelp cross-reference definition.

Content reference

Text or files that you have inserted into the FrameMaker documents as content references appear as part 
of the topics where they are referenced. They do not appear as references in the online Help outputs. 
SeeFrameMaker Help for more information.

Conversion settings

RoboHelp allows you to define project-wide settings for each source type. For all FrameMaker docu-
ments, you define the conversion settings only once. Similarly, the conversion settings of Microsoft Word 
documents remain the same for imported Word documents.

Project-wide conversion settings promote consistency not just in your project but across multiple proj-
ects. You can quickly set up a RoboHelp project without having to define individual conversion settings 
for paragraphs, tables, images, and so on.

These settings include:
• Defining a FrameMaker template
• Cascading style sheets (CSS) for RoboHelp projects
• Style mapping between FrameMaker formats and RoboHelp styles
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• Format conversion settings, image conversion settings, and other settings

Export conversion settings

1) Select Project > Project Settings.
2) On the Import tab, click Export.
3) Specify a name for the RoboHelp Import Settings file (ISF file) and click Save.

Import conversion settings to a project

1) Select Project > Project Settings.
2) On the Import tab, click Browse.
3) Select a RoboHelp Import Settings File (ISF file) and click Open.

Setting pagination and topic names

Pagination basics

When you link or import a FrameMaker document, you define how the contents of the FrameMaker file 
are paginated or split into topics in RoboHelp. To paginate a FrameMaker document, you can select one 
or more paragraph styles (for example, Heading 1) and/or a marker type (for example, PageBreak) used 
in the document.
NOTE: PageBreak is the default marker type RoboHelp provides in the Split Topics Using Marker setting. 
You can specify any marker type used in the FrameMaker document for pagination.

Consider an example. If a FrameMaker document contains ten topics, with each topic containing 
subtopics, tasks, and tables, you can set each topic to appear as a separate HTML file. If each of these 
topic headings is at Heading 1 format, you can set each Heading 1 topic to be created as a separate HTML 
topic. On the other hand, if you set the pagination at Heading 2, separate HTML files are created for each 
Heading 2 topic. If you select both Heading 1 and Heading 2 for pagination, the contents between two 
consecutive headings of these paragraph styles are used to create a topic.
NOTE: RoboHelp splits the FrameMaker documents into topics using the specified paragraph styles and/or 
marker type. The paragraph style text/marker text is included by default in the filename of the topic file 
created. Any non-ASCII characters in the topic file name are automatically converted to ASCII characters.

To paginate a document using markers, apply markers to paragraphs where you want to create topics 
and select the marker type in RoboHelp. For example, you can apply PageBreak markers to all Heading 1 
paragraphs in the FrameMaker document.

In some cases, you can use a combination of paragraph styles and a marker type to paginate. For 
example, you want to paginate at all Heading 1 paragraphs and at some Heading 2 paragraphs. In this 
case, apply PageBreak markers to the respective Heading 2 paragraphs in the FrameMaker document 
and then select Heading 1 as the paragraph style for pagination and the PageBreak marker type in Robo-
Help.

You can even stop paginating a document on a particular paragraph style by applying a PageBreak marker 
type with the <NoSplit> marker text.
NOTE: The <NoSplit> marker text is not case-senstive.
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If RoboHelp finds no content between two consecutive paragraphs, it does not paginate or split the para-
graphs into topics based on the paragraph style setting for pagination. You can apply a PageBreak marker 
to the second paragraph to explicitly indicate that different topics should be created.
NOTE: PageBreak is an example. You can apply any marker consistently for pagination and specify it in the 
Split Topics Using Marker setting.

Follow these guidelines for paginating a document:

Completeness of content in the topic
Ensure that the topic generated contains relevant and complete information for the reader. For 
example, if you set pagination for Heading 3 level paragraph, it is possible that the topic contains 
only the task information, without the required contextual information that is covered in another 
Heading 3 level topic. To avoid such disconnected topics, set the pagination at a higher level so that 
complete information is available in a single Help topic.

Drop-down text
Ensure that the paragraph format for the drop-down text body is not set for pagination. The para-
graphs applied with this format must accompany the drop-down text caption paragraph format. 
See Optimizing for online output before conversion.

Topic name basics

When you set heading styles for pagination, the heading text becomes the default filename for the topic 
file created in RoboHelp. For example, suppose you define Heading 2 for pagination, and the 
FrameMaker document has two Heading 2 topics, “Introduction” and “Beyond basics.” In this case, 
RoboHelp creates the topics Introduction and Beyond basics with filenames introduction.htm and 
beyond_basics.htm. Thus, you get intuitively named HTML files that indicate the topic title.

RoboHelp supports various ways to customize topic names in the following scenarios:

Style-based pagination
Topics are named according to the pattern you select in the Other Settings tab of the Conversion 
Settings dialog box. You can select one of the following or create a topic name pattern using the 
Topic Name Pattern building blocks provided by RoboHelp. In addition, you can add static text, such 
as “HelpTopic,” followed by <n> to create topics such as HelpTopic 1, HelpTopic 2, and so on.

Topic name pattern Description

default HTML topic generated has the paragraph text as the topic title 
and the filename.
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Marker-based pagination
To name topics based on the marker used for pagination, configure each marker in the 
FrameMaker document and specify the filename and title as marker text in the filename | title 
format.

NOTE: Both filename and title are optional. If you do not specify a filename (for example, you specify | 
<title>), RoboHelp creates a valid filename from the title. If you do not specify a title (for example, you 
specify <filename>), RoboHelp creates the title from the topic name pattern. If marker text is empty, 
RoboHelp uses the topic name pattern to create the topic title and a valid filename.

Set pagination and topic names

1) Select Project > Project Settings.
2) In the Import tab of the Project Settings dialog box, click Edit under FrameMaker document.
3) To split the document into topics, do either or both of the following steps:

– In the Paragraph Styles tab, select a paragraph style to split the document on that paragraph 
style.

<$filename_no_ext>-<$parate
xt>

HTML topic generated has the filename consisting of the 
filename of the FrameMaker document without the .fm 
extension and the paragraph text, separated by a hyphen. For 
example, the FrameMaker document named “Chapter.fm” 
with "1-Introduction" as paragraph text is converted to an 
HTML topic with the title "Chapter-1-Introduction” and the 
filename "Chapter-1-Introduction.htm”

<$filename_no_ext>-<n> HTML topic generated has the filename consisting of the 
filename of the FrameMaker document without the .fm 
extension and the paragraph number separated by a hyphen. 
For example, the FrameMaker document "Chapter.fm" is 
converted to an HTML topic with the title “Chapter-1” and the 
filename "Chapter-1.htm"

<$paratext_no_num> HTML topic generated has the filename consisting of the 
paragraph text of the paragraph format at which pagination is 
set, without the paragraph number. For example, a heading 1 
paragraph "1. Introduction" is converted to an HTML topic 
with the title “Introduction” and the filename 
"Introduction.htm"

<$paratext> HTML topic generated has the filename consisting of the 
paragraph text of the paragraph format on which pagination is 
set. For example, a heading 1 paragraph "Introduction" is 
converted to an HTML topic with the same title and the 
filename "Introduction.htm"

Topic name pattern Description
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– In the Other Settings tab, select Split Topics Using Marker and specify a marker that is used in 
the FrameMaker document for pagination.

4) By default, RoboHelp names topics based on the paragraph text of styles that are used to paginate 
the FrameMaker document. To specify a different naming convention for topics that are created 
based on paragraph styles, select a topic name pattern from the Topic Name Pattern list or specify 
a custom pattern.

5) Click OK.

Convert context-sensitive Help markers from FrameMaker documents

You can convert the context-sensitive Help markers that you insert in your FrameMaker documents and 
reuse them as map IDs. You specify the context-sensitive Help marker in the Project Settings dialog box 
before linking FrameMaker documents. You can also specify this setting when you import FrameMaker 
documents. You can work with context-sensitive Help markers in FrameMaker documents in two ways:

Automatic conversion of map IDs from FrameMaker documents
You apply context-sensitive Help markers in your FrameMaker documents, and specify the marker 
type in the conversion settings. RoboHelp imports the markers from FrameMaker documents and 
adds the map IDs from the strings contained in the context-sensitive Help markers.

Manually adding a map ID file
If you received map IDs from your development team, you use these map IDs as the context-sensi-
tive Help marker text strings for the marker to be used as context-sensitive Help marker in your 
FrameMaker documents. Later, you create a map ID file by associating the map IDs from the devel-
opment team and the context-sensitive Help marker text you inserted in the FrameMaker docu-
ments. You then add this file to the project. When you link or import the FrameMaker documents, 
you specify the context-sensitive Help marker in the conversion settings.

1) Select Project > Project Settings.
2) In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.
3) In the Other Settings group of the Conversion Settings dialog box, enter the Context-Sensitive Help 

Marker.

Apply FrameMaker conditional text build expressions

You can apply the Show/Hide settings of the conditional text build expressions to the content in your 
FrameMaker documents imported into RoboHelp projects. RoboHelp imports the content after applying 
the Show/Hide settings to the FrameMaker content. Any text that is hidden is not brought into RoboHelp 
project.
1) Select Project > Project Settings.
2) In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.
3) In the Other Settings group of the Conversion Settings dialog box, select Apply FrameMaker Condi-

tional Text Build Expression.
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Converting FrameMaker content

Convert FrameMaker paragraph formats to RoboHelp styles

By default, RoboHelp converts all paragraph formats from FrameMaker to RoboHelp CSS styles, thus 
retaining the appearance and behavior of the FrameMaker formats in the RoboHelp project. To ensure 
consistency of the online Help projects, map the FrameMaker formats to RoboHelp styles and edit them.
1) Select Project > Project Settings.
2) In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.
3) On the Conversion Settings panel, select the FrameMaker format from the Paragraph group.
4) From the RoboHelp Style menu, select the RoboHelp style that you want to map to the FrameMaker 

format. To retain the appearance of FrameMaker text in the online Help format, select [Source].
To edit the selected RoboHelp style, click Edit Style.

5) Select the properties for the mapped RoboHelp style:

Exclude From Output
Select to discard the content in FrameMaker document that is applied with the selected 
FrameMaker paragraph format.

Pagination (Split into topics based on this style)
Select to create a Help topic at each occurrence for the selected FrameMaker paragraph format. 
For example, if you select Heading 1 and Pagination (Split into topics based on this style), RoboHelp 
starts a new topic at every instance of Heading 1.

User Defined HTML Tag
Select or enter a user-defined HTML tag for the selected paragraph format.

If the selected FrameMaker format has auto numbering properties defined, specify how auto num-
bering is converted.

RELATED LINKS:
Autonumber style mapping

Create a project

Convert FrameMaker character formats to RoboHelp styles

You can map the FrameMaker character formats to character styles in RoboHelp.

You can also edit the styles in RoboHelp.
1) Select Project > Project Settings.
2) In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.
3) Select the FrameMaker character format from the left pane of the Conversion Settings dialog box.
4) Select the RoboHelp character style from the pop-up menu. Optionally, you can do the following:

– To import the FrameMaker character format, select [Source] from the pop-up menu.
– To edit the selected RoboHelp style, click Edit Style.
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– To exclude the text in the FrameMaker document applied with the selected character format, 
select Exclude From Output.

– To apply a user-defined HTML tag to the imported text in HTML output, select User Defined 
HTML Tag, and select the tag from the pop-up menu. You can also enter a new HTML tag. The 
custom HTML tag for the character format replaces the <span> tag in the generated HTML 
file.

Exclude a FrameMaker paragraph format from Help topics

You can exclude the content in FrameMaker documents that has a specified paragraph format from the 
converted output. Use this option to remove content such as special notices that are not required in 
online output.
1) Select Project > Project Settings.
2) In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.
3) In the project settings, select a FrameMaker paragraph format in the left pane.
4) Click Exclude From Output.

Custom HTML tags

You can define or apply a custom HTML tag instead of the standard <p> tag for paragraph styles and 
<span> tag for character styles in the HTML output for the formats that you import from FrameMaker. 
You can define separate HTML tags for each format in the FrameMaker document.
1) Select Project > Project Settings.
2) In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.
3) In the Conversion Settings dialog box, select the user-defined HTML tag option.
4) Type the name of the custom HTML tag or select an existing tag to use instead of the default HTML 

tag.

Autonumber style mapping

Choose the conversion setting for converting autonumber formats in the FrameMaker document to the 
Help format. If the FrameMaker document contains hierarchical numbered lists, you can choose one of 
the following:

Ignore Autonumber
Choose this option if the autonumber text is relevant only in print format. The converted paragraph 
does not contain autonumbering. For example, suppose you ignore autonumbering for the 
FrameMaker paragraph format "Section2 Level." In this case, "Section 1.1: System Requirements" 
in the source appears as "System Requirements" in the RoboHelp topic generated.

Convert Autonumber To Text
Choose this option to retain the appearance of the FrameMaker numbered lists. The autonumber 
part loses its sequencing properties and appears as part of the paragraph text in RoboHelp topic.
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Convert Autonumber To HTML List
Choose this option to convert the autonumber to HTML lists using HTML tags such as <ol>, <ul>, 
and <li>.

Convert Autonumber To RoboHelp List
Choose this option if you want to edit the generated HTML topics in RoboHelp or use the RoboHelp 
styles to control the numbering properties.

List-mapping scenarios

RoboHelp allows you to convert list properties of FrameMaker paragraph formats in several ways. 
Consider the following scenarios:

FrameMaker numbered list mapped to [Source]

The FrameMaker paragraph format autonumber property converts to a list according the autonumber 
conversion settings you define for that FrameMaker paragraph format.

Ignore Autonumber
The autonumber part of the FrameMaker paragraph format is ignored. The converted paragraph 
style in the RoboHelp topic doesn't contain the list part.

Convert Autonumber To Text
The autonumber part of the FrameMaker paragraph converts to text and appears as paragraph text 
in the RoboHelp topic.

Convert Autonumber To HTML List
Autonumber format converts to list items using HTML tags such as <ol>, <ul>, and <li>.

Converted Autonumber To RoboHelp List
Autonumber properties of the paragraph style convert to a RoboHelp list.

Example:
• Create a paragraph style "FM_Para1" in FrameMaker with autonumbering defined as <a+> and 

apply it to paragraphs. The resulting paragraphs are ordered as "a, b, c, ...."
• Map the FrameMaker paragraph format "FM_Para1" to [Source].

Generated paragraphs in RoboHelp topics have the list style applied to them, where the list has proper-
ties similar to those in the source document.

FrameMaker numbered list mapped to RoboHelp unnumbered style

You can map a FrameMaker paragraph format with autonumbering properties to a RoboHelp paragraph 
style that is not linked to any list style. In this case, the autonumber is converted to a list according to the 
autonumber conversion settings you define for the paragraph format.
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Ignore Autonumber
The FrameMaker paragraph autonumber is ignored and doesn't appear in the RoboHelp topic. 
However, the paragraph style is mapped.

Convert Autonumber To Text
The FrameMaker autonumber part is converted to text and appears as a part of paragraph text in 
RoboHelp topic. The paragraph style is mapped.

Convert Autonumber To HTML List
The FrameMaker paragraph format is converted to HTML list items using HTML tags such as <ol>, 
<ul>, and <li>.

Convert Autonumber To RoboHelp List
The autonumber properties of the FrameMaker paragraph format are ignored. The paragraph style 
is mapped.

FrameMaker unnumbered format mapped to RoboHelp numbered style

In this case, the converted paragraph has the RoboHelp paragraph style and inherits the RoboHelp list 
style. The Autonumber conversion options do not affect the paragraph behavior in the RoboHelp topic.

For example:
• In the FrameMaker document, create a paragraph format "FM_Para 1" without autonumber prop-

erties.
• Define a RoboHelp list style "RH_List1" in the RH style mapping CSS.
• Create a paragraph style "RH_Para1" and link the first level of list style "RH_List1" to the paragraph 

style "RH_Para1".
• Map the FrameMaker paragraph style "FM_Para1" to RoboHelp paragraph style "RH_Para1".

The generated paragraph in the RoboHelp topic inherits the properties of the list style "RH_List1".

FrameMaker numbered list mapped to RoboHelp numbered list

The converted paragraph style has the RoboHelp paragraph style and inherits the RoboHelp list style. The 
Autonumber conversion options do not affect the paragraph behavior in the RoboHelp topic.

For example:
• In FrameMaker, create a paragraph format "FM_Para1" with autonumbering defined as <a+> and 

apply it to a paragraph so that the paragraph has an ordered list such as "a, b, c, …."
• Define a numeric list style "RH_List1" in the RoboHelp style mapping CSS with the first level defini-

tion as <x>.
• In RoboHelp, define a paragraph style "RH_Para1" and link the first level of list style "RH_List1" to 

the paragraph style "RH_Para1".
• Map the FrameMaker paragraph format "FM_Para1" to the RoboHelp paragraph style "RH_Para1".

The generated paragraph in the RoboHelp topic inherits the properties of list style "RH_List1" and 
displays a list of type "1, 2, 3, ...."
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Convert FrameMaker table formats to RoboHelp table styles

You can map FrameMaker table formats to RoboHelp table styles. Alternatively, you can import the table 
formats from the FrameMaker document. You can also edit the table formats in RoboHelp. Cells in the 
FrameMaker document that are merged (straddled) cannot be unmerged (unstraddled); however, the 
straddled cells appear merged in the RoboHelp topic.

If the FrameMaker table formats contained table titles and table footnotes, convert these paragraph 
formats in FrameMaker to RoboHelp paragraph styles separately. Decide whether you want to retain 
automatic numbering in the table title styles and specify the autonumbering properties for the mapped 
RoboHelp paragraph style. For example, if the table title formats in the FrameMaker documents included 
the chapter number, such as “Table 2-3: Quarterly Results”, you can choose to ignore the autonumbering 
part and have only “Quarterly Results” appear as the table title. See List-mapping scenarios.
1) Select Project > Project Settings.
2) In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.
3) Select the FrameMaker table format from the left pane of the Conversion Settings dialog box.

Image conversion settings

Some FrameMaker documents, especially those optimized for high-quality printing through PDF, contain 
images in EPS format. Convert EPS images to web-supported image formats such as JPEG, GIF, or PNG for 
online Help.

You specify the following image conversion settings in the Conversion Settings dialog box:

Use Distiller To Generate Image
Select this option to generate web-friendly image formats from graphics linked and inserted in 
FrameMaker documents. You should use this option especially if you have vector graphics formats, 
such as EPS or AI, or graphics with text content in them.

Do Not Regenerate Images
Select this option to save time if you are re-importing FrameMaker documents and don’t need to 
update the images in the imported content.

Preserve 3D Images
Select this option to convert the 3D graphics as a PDF file, with the 3D rendering intact within the 
PDF file. To ensure that the 3D image retains its rendering, enable embedding in FrameMaker.

Preferred Dimensions
Specify the dimensions for the images. Select one of the following:

Scale
Scale images as a percentage of the existing size. The aspect ratio of the images is maintained.
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Width and Height
Specify the absolute image size as Height and Width, in points. Select Maintain Aspect Ratio to 
ensure that the images are not skewed.

NOTE: To convert the images in FrameMaker documents to the actual dimensions of the images, specify 
the height and width as 0pt. The <img> tag for such images in the generated HTML does not have the 
height and width values. This conversion is irrespective of the dimensions of the anchored frames that 
contained the images.

Maximum Dimensions
Set the maximum dimensions for images in online format. Images that exceed the maximum 
dimensions you specify are automatically scaled down to fit the maximum size you specify. If you 
scale the images and specify an aspect ratio, RoboHelp scales the images within the maximum 
dimensions specified and maintains the aspect ratio.

Use this option to avoid large images causing the browser window to scroll horizontally or verti-
cally. For example, if you specify the window size to be 800 x 600 pixels, you can specify the 
maximum dimensions to be 640 x 480, so that the images do not exceed the window size.

Margins
Set the margins for the images:

• Set equal margins on all sides by setting the margin in All Sides.
• To set margins on individual sides, set the margins on each side.

Borders
Set a border for the images:

• To set a uniform border on all sides, select All from the Border pop-up menu. Alternatively, you can 
specify the side on which you want the border to appear from the pop-up menu.

• To set the border style, select the style from the Style pop-up menu.
• To set the border color, select the color from the Color pop-up menu.
• To set the border width, select it in, in points, from the Width menu.

Format
Define the image format, color depth, and quality settings for the web-supported images that are 
converted from the images in the FrameMaker document:

As Is
Select this option for retaining the images in the current web-supported format.

JPG
Select this option for multicolor images such as screenshots or photographs. JPG format with a high 
color depth provides the best online quality, but increases the file size. Select this option for photo-
graphs.
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GIF
Select this option if the FrameMaker document contains only line art, such as schematic diagrams.

BMP
Select this option only for small images such as icons and logos. BMP format images are large in size 
and uncompressed but rich in color and quality. Also, these images do not scale or compress well. 
Hence, this format is not suitable for web.

PNG
Select this option for screenshots.

JPEG Quality
Set the quality percentage for JPG images.

Color Bit Depth
Set the color bit depth for bitmap images. JPG and PNG formats can have either 8- or 24-bit color 
depth, while BMP images can have color bit depths of 1, 4, 8, 16, 24, or 32. GIF images can have 
only 8-bit color depth.

Grayscale
Select this option if you want monochrome images.

Preserve converted images

RoboHelp converts the images and anchored frames in the FrameMaker documents each time the topics 
are updated or generated. You can skip updating the images if the corresponding images or SWF files 
from the corresponding anchored frames are already present in the RoboHelp project. Use this option in 
the following cases:
• You want to avoid regenerating the images each time the FrameMaker document is updated
• You have edited the images in the RoboHelp project using another image-editing tool, and want to 

prevent overwriting of the edited images
• You want to preserve the earlier generated image in the RoboHelp project even though the image 

in the FrameMaker document has changed

If the order in which the images appear in the document or the image name has changed, you should 
clear this option and allow RoboHelp to update the images.
1) In the Image tab of the Conversion Settings dialog box, select Do Not Re-Generate Images.

Create alternate text for images

To create accessible content, create alternate text (ALT text) for images so that visually impaired users 
can access the content through screen readers. If you link or import completed FrameMaker books into 
RoboHelp for publication, add alternate text to graphics used in the FrameMaker documents. These 
entries are not visible in PDF files, but they appear in online content when the mouse hovers over the 
images. See FrameMaker Help to learn about setting alternate text for graphics and images.
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Import a DITA map file

A DITA map is like a table of contents listing and linking the topics for a specific output. DITA maps 
assemble topics into sequence and hierarchy tailored to specific delivery requirements. You can have 
multiple maps, each one arranging the topics for different requirements, such as a reference manual, a 
tutorial, or online Help. A DITA map file has the extension .ditamap.

You can import DITA map files in RoboHelp to generate XHTML output. The DITA Open Toolkit processes 
the information in the DITA map file and provides the XHTML output. RoboHelp reads the XHTML output 
to generate the XHTML topics, TOC, and index. RoboHelp shows processing information of the DITA Open 
Toolkit in the Output View pod.

NOTE: RoboHelp depends on the DITA Open Toolkit to process the DITA map content. RoboHelp does not 
correct any errors generated by the DITA Open Toolkit. For example, if the DITA Open Toolkit does not 
generate XHTML 1.0 transitional compliant files, RoboHelp does not generate errors. Therefore, the 
XHTML topics generated from the import of DITA map file do not contain the meta tag <meta 
name="generator" content="Adobe RoboHelp - www.adobe.com" /> NOTE: The XHTML 
file must have well-formed XML.
1) Do one of the following:

– Select Project > Import > DITA Map.
– Right-click the Project Files folder in the Project Manager pod. Select Import, and then select 

DITA Map as the file type.

2) Select a DITA map file. Click Open.
3) In the DITA Open Tool Kit Processing Options dialog box, specify the following options:

Replace Default XSLT File For Conversion
Select an XSL file to use for transforming the DITA files to XHTML instead of the default XSL file used 
by the DITA Open Toolkit. The equivalent parameter for the Ant processing of the DITA Open 
Toolkit file is args.xsl.

Use DITA Val For Conditional Processing
Specify a DITA Val file to use for conditional processing of the DITA files. The XHTML is generated 
based on the Val file. A DITA Val file contains filter, flagging, and revision information. The equiva-
lent parameter for the Ant processing of the DITA Open Toolkit file is args.filter.

Show Index Entries In The Topics
Select to show index entries (marked by <indexterm> in DITA topics) in RoboHelp topics. The equiv-
alent parameter for the Ant processing of the DITA Open Toolkit file is args.indexshow.

Show Image Filename In Annotation
Select to add annotations to images showing the filename of the image or the full path to include 
in the topics. The equivalent parameter for the Ant processing of the DITA Open Toolkit file is 
args.artlbl.
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Include Draft And Cleanup Content
Select to include draft and required cleanup content (items identified as left to do before 
publishing). The equivalent parameter for the Ant processing of the DITA Open Toolkit file is 
args.draft.

Select XHTML File To Be Placed In The Header Area (hdf)
Select the location of the file containing XHTML to place in the header area of the output file. The 
equivalent parameter for the Ant processing of DITA Open Toolkit file is args.hdf.

Select XHTML File To Be Placed In The Body Running-header Area (hdr)
Select the location of the file containing the XHTML to place in the body running-header area of the 
output file. The equivalent parameter for the Ant processing of the DITA Open Toolkit file is 
args.hdr.

Select XHTML File To Be Placed In The Body Running-footer Area (ftr)
Select the location of the file containing XHTML to place in the body running-footer area of the 
output file. The equivalent parameter for the Ant processing of the DITA Open Toolkit file is args.ftr.

DITA Open Tool Kit Home Directory
Select the absolute location of the home folder of the DITA Open Toolkit. Specify the valid DITA 
Open Toolkit home folder. You specify this location only once. It is stored in the registry. You can 
change the location.

4) Click Finish.

NOTE: RoboHelp verifies the location of the selected files but does not validate the files as the DITA Open 
Toolkit processes all the information.

Import XML files

When you import an XML file into an existing project, RoboHelp creates a topic for the XML file.
1) In the Project Manager pod, select the file to import into.
2) Select Project > Import > XML File.
3) Select one or more XML files. Click Open.
4) Select options in the Select XML Import Handler dialog box.
5) (Optional) To set advanced options, select Import XML (CSS/XSL).
6) Click Advanced.
7) Select an option:

Treat As Text Flow
Import the XML file as HTML text without formatting.
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Treat As XML Tree View
Import the XML file in HTML tree view. HTML imports as code.

Use Customized CSS/XSL File
Select a file from the pop-up menu.

8) Click OK.

NOTE: If multiple imported topics have the same topic name, this error is due to the XSL file used during 
the import process. The XSL file used to transform the XML to HTML contains the <title> specified field. 
Edit the XSL file and reimport the XML file.

Select XML Import Handler

Handler Name
The following are predefined handlers:

Import DocBook As Topics
A DocBook file is imported as an HTML topic.

Import XML (CSS/XSL)
If the XML file has an associated style sheet (CSS or XSL file), the file is imported as an HTML topic. 
Otherwise, the file is imported as an HTML file without any display control.

Advanced
Active if you select Import XML (CSS/XSL). Click for more import options.

Automatically Replace Topic(s) Imported From Previous Session
Overwrites old data.

Validate XML Before Import
RoboHelp validates the XML file before importing it.

Advanced XML Import Options dialog box

These options are available for importing XML with this handler only if no associated XML style sheet 
exists.

Treat As Text Flow
Imports the XML file as HTML text without formatting.

Treat As XML Tree View
Imports the XML file in HTML tree view. HTML imports as code.
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Use Customized CSS/XSL File
Select the customized file.

NOTE: You can create and edit customized handler files using the XML Handler Manager and the Handler 
Description File (HDF) Editor.

About the XML Handler Manager

Handlers determine how XML is imported. Select one of the predefined handlers or create a custom 
handler to meet your requirements. You can select a handler when you import an XML file into a project 
or when you generate XML output.

The XML Handler Manager lists all Handler Description files (HDF files) that have been exported from the 
HDF Editor.

Handler Description files (HDF files)
Contain individual handlers and the files necessary to perform the XML transformation. The 
predefined HDF files are organized by type (XHMTL, for example) and contain all related handlers:

DocBook
This handler type includes: Import DocBook As Topics, Export Project To DocBook, Export Topics To 
DocBook.

XHTML
This handler type includes: Import XHMTL (XML), Import XHTML (XHTML), Export Topics To XHTML, 
Export Project To XHMTL.

XML/CSS
This handler type includes: Import XML (CSS/XSL).

TIP: To open an HDF file and view the handlers in it, click the plus box to the left of an HDF file.

Edit
After selecting an HDF file (XHTML, for example) or a specific handler, click to open the HDF Editor 
and edit a handler.

Delete
After selecting an HDF file (XHTML, for example), click to delete all handlers in it.

Import
Import an existing handler.

NOTE: Initially a handler is an HDF file with a subfolder of support files. To bring a handler file from the 
HDF Editor into this program, export the HDF file as a ZDF file. Use the HDF Editor for this task.



103

IMPORT MICROSOFT HTML HELP PROJECTS
CHAPTER 3 PROJECTS

Import Microsoft HTML Help projects

When you import an HHP file, a new RoboHelp project file (XPJ) is created.
1) Select File > Open Project > Local or Network Path.
2) Select HTML Help Project (*HHP) from the Files Of Type menu.
3) Navigate to the HHP file and open it.

TIP: You can also import FrameMaker (.fm, .book, and .mif) files, Word files (.doc, .docx), PDF files, and 
XML files.
NOTE: If you use an HTML editor other than Design Editor to author your content, you can still use Robo-
Help for the project.

RELATED LINKS:
Third-party HTML editors

Third-party HTML editors

Import WinHelp projects

You can import compiled WinHelp 4.0 (HLP) or the WinHelp project file (HPJ) into a project.

The HPJ file is the main organizational file, containing all the source files. When generating WinHelp, 
RoboHelp creates an HLP file and a CNT file. The HLP file doesn’t contain topics excluded by a conditional 
build expression, so the new project might not mirror the original.

You can import HLP files to HTML-based projects, but the process is easier if you have the HPJ file.

You can’t output a WinHelp file from RoboHelp HTML.

Import WinHelp Project settings

Pop-ups

Smart Popups
Create links that display pop-ups that resize to accommodate content. All HTML formatting is 
supported.

Regular Hyperlinks
Create links that open in the window in which the link appears.

What’s This Help

Text-Only Topic Files
Create and save topics in text-only format (TXT). Use this option for What's This? Help topics.
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Individual HTML Files
Create and save topics as regular HTML topics for window-level context-sensitive Help.

External topics

Links To External HTML Help Topic
Convert external WinHelp topic links to HTML topic links in external CHM files.

Retain Keep External WinHelp Topic Links
HTML topics include WinHelp Topic controls. Use this option when linking HTML topics to WinHelp 
topics.

Images

Converts BMP images into GIFs or JPEGs.

Bullets/Numbering

HHTML Bullets And Numbering
(Recommended setting) Convert numbered lists and bulleted lists into their HTML equivalents 
using Pure HTML tags (<ol>, <ul>, <li>). These lists are auto-numbered or bulleted. Special para-
graph formatting used in RTF files is not carried over.

Formatted Text
Retain indents, line spacing, and other paragraph formats from RTF files. Convert numbered lists 
into hard-coded numbered lists. Convert bulleted-list items into hard-coded symbol characters.

Tips:

• Remove hard-coded numbers and bullets and replace with auto-numbered lists and bulleted lists 
in the Design Editor.

• Create special bulleted and numbered list styles and apply them to paragraphs after they are 
converted.

WinHelp folder import options

Folder for HTML files

Do Not Create Subfolder
Save all HTML topics at the root of the project folder.

Create Subfolder
Save all HTML topics in a subfolder.
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Create Folders Based On Source Document Names
Create and save HTML topics in subfolders based on the DOC files.

Create Subfolders Based On TOC Structure
Create and save HTML topics in subfolders, based on the WinHelp table of contents. Books within 
books are created as subfolders within folders. All topics not used in the WinHelp table of contents 
are saved at the root of the project folder.

Folders for images

Do Not Create Subfolder
Save all image files at the root of the project folder

Create Subfolder
Save all image files in a subfolder

File options

HTML File Extension
Save all HTML topics using the extension selected.

Always Use Lowercase

Save filename extensions in lowercase letters. Select this option for UNIX® servers.

WinHelp formatting import options

Work with or without style sheets. Without style sheets, topics format using inline styles. For external 
style sheets, create new style sheets based on the formatting in WinHelp documents or select a style 
sheet already in use.

Inline Styles (No External Style Sheets)
Convert all formatting into HTML inline styles. This option does not create or apply styles or style 
sheets to the topics. Formatting is handled on a paragraph-by-paragraph and character-by-char-
acter basis. Apply styles after importing the project. Manually apply character and paragraph attri-
butes to new topics.

External Style Sheets (One For Each Source Document)
Create one style sheet for each DOC file imported.

External Style Sheet Based On One Source Document
Create a single external style sheet based on one DOC file. The style sheet uses the same names and 
formatting as the styles in the WinHelp documents. The HTML topic text is formatted using these 
styles.
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External Style Sheet Based On Existing Style Sheet
Link an existing style sheet to all topics. Styles in the DOC files must have a one-to-one relationship 
to styles in the style sheet, including style names. Apply styles to the paragraphs and characters 
that use them. With a one-to-one style relationship, styles in HTML topics use the same names and 
formatting as the styles in WinHelp documents.

WinHelp general import options

Navigation pane

TOC
Contents displays books and pages in the table of contents. The index displays keywords.

Glossary
Provide definitions for the Help system.

Favorites
Create a personalized list of favorite topics.

History
See topics viewed previously. Sets options for the navigation pane.

Search:

No Search
Select this feature to disable full-text searching.

Regular
View a list of topics by title.

Advanced
Provide advanced full-text search capabilities including Boolean, wildcard, and nested expressions. 
Limit the search to previous results, match similar words, or search topic titles only.

Tab Position
Select Top, Left, or Bottom.

Default pane

Set options for Help projects.

Websearch
Quickly find topics on the web. A WebSearch button is added to the Help viewer.
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Create Browse Sequences
Transfer WinHelp browse sequences into HTML-based Help.

Ignore Secondary windows
Format jumps to display the HTML topics in the viewer.

NOTE: Display pages from the WinHelp CNT in custom windows. HTML supports jumps from TOC pages to 
custom windows.

Add Keywords To
Selects the location for saving keywords:

Index File (HHK)
Save all keywords in a single index file.

Each Topic
Save all keywords in the HTML topic files referencing them.

NOTE: The project compiles a binary index when keywords are added to HTML topics. Topic keywords are 
automatically sorted in the index and cannot be cross-referenced. They can link only to local HTML 
topics. The destination topics can be displayed only in the default Help window.

Advanced

Open the HTML Help Advanced Settings dialog to further customize the viewer.

HLP and HPJ files

When you import compiled WinHelp 4.0 files, RoboHelp does the following:
• Creates an HTML-based project. Information in the HLP or HPJ file is used to create the project file 

(HHP) and a RoboHelp project file (XPJ).
• Creates HTML topics. Information in the HPJ file is used to create an HTML Help file and a RoboHelp 

project file (XPJ). Open the project to open the XPJ file. A separate HTML topic is created for each 
WinHelp topic. These files are saved in the HTML Files (Topics) folder.

• Converts WinHelp graphics to HTML images. WinHelp bitmap files (BMP, MRB) and metafiles 
(WMF) convert into Graphic Interchange Format files (GIF). Images that are right-aligned are 
left-aligned in the HTML topics. Modify the size and placement of these images in the Design Editor.

• Converts hotspot images into image maps. WinHelp hotspot images (SHG files) convert to HTML 
image maps (GIF).

• Maintains authorable buttons. Authorable text buttons, mini buttons, and graphic buttons all 
convert and work in the HTML topics. Modify authorable buttons in the Design Editor. Authorable 
buttons are known as Link Controls and HTML Help controls.

• Creates an HTML table of contents. An HTML Help table of contents (HHC file) is created from the 
WinHelp contents file (CNT). Modify the table of contents in the TOC Composer.
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• Creates an HTML index. An HTML Help index (HHK file) is created that includes the same keywords 
as in WinHelp. A new index includes keywords that match jumps in the topic.

The RTF files are used to create an HTML index that includes the same keywords. Modify keywords in the 
Index Designer and use the Smart Index wizard to automate indexing tasks.
NOTE: This information doesn’t apply to every HLP or HPJ project.

HTML projects from WinHelp: Frequently asked questions

Will WinHelp macros work in the HTML project?

All WinHelp macros with HTML counterparts are converted and included in the HTML project. Non-stan-
dard WinHelp macros with no HTML equivalent are not converted.

Can HTML topics open in custom windows as in WinHelp?

You can format books and pages in the TOC to display destination topics in custom windows or frames. 
Microsoft HTML Help does not support links to custom windows, though you can format these links to 
use pop-up note windows and frames.

Can I use tabs in HTML topics?

HTML does not support tabs and converts them to spaces. Use tables instead to position text in HTML.

How can I add spaces to position text in HTML topics?

You can edit topics in the RoboHelp HTML Editor and add non-breaking spaces to position text. However, 
display issues can occur if the Help window is resized. Consider using tables instead to position text in 
HTML.

Tables convert into HTML topics, but the columns do not resize properly and a horizontal scroll bar 
appears.

Use the Design Editor to resize cells and tables.

How can I fix incorrectly formatted bullet lists?

You can remove broken bitmap references from topics and use HTML bulleted styles, and adjust hanging 
indents. You can also use the Formatted Text option to import paragraph formatting from Word docu-
ments.

My WinHelp topics use manually numbered lists with {SEQ} fields. What happens to these fields?

HTML does not support {SEQ} fields, but recognizes number sequences and converts the lists into 
numbered paragraphs. You can delete these numbers and apply an HTML numbered style to the list.

What happens to nonscrolling regions?

HTML projects do not support nonscrolling regions, and the tri-pane output window does not need them.

The background in the Design Editor is gray, but in the preview window is white. How can I make the 
background always white?

The style sheets use a gray background (the HTML default), while the preview window uses a background 
specified by your browser. To change the style sheet background, see Use color and images.
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When I click a hyperlink, an error says the system cannot open the site or find the path. What does this 
mean?

The link is to a non-existent file or a topic in a DOC or WinHelp Help file not included in the project.

After I create the HTML project, is it ready to distribute?

Open the HTML project in RoboHelp, review the topics, TOC, index, and so forth. Preview the topics and 
test the links.

Will context-sensitive topics transfer into an HTML project?

What's This? topics in RoboHelp for Word can convert into text-only topics. Dialog box level topics can 
convert into individual HTML topics for use as window-level Help in RoboHelp.

Import a WinHelp HLP file into an HTML project

1) In the Starter pod, click More under Import.
2) Select WinHelp (*.hlp) and click OK.
3) Click Browse, navigate to the HLP file, and open it.
4) Click Next. Set up File options:

Desired Result Actions

Specify a hard drive and folder for saving the 
HTML project and image (GIF) files (use the 
same folder for both).

Click Browse  and navigate to the 
drive/folder to select it. Or enter the name of 
the folder in the text box.

Limit the length of the HTML files to eight 
characters.

Select Short Filenames. (Enter the first three 
characters in Prefix if you want the filenames 
to use similar naming conventions.)

Distribute the HTML project as uncompiled 
HTML Help (not using Adobe WebHelp)

Enter the name of the start page in Start Page 
Name.

Distribute the project as compiled Microsoft 
HTML Help or cross-platform Help using 
Adobe WebHelp, JavaHelp, or Oracle Help 
output.

Do not enter information in Start Page Name.

Desired Result Actions

Format HTML topics without attaching style 
sheets to them.

Select <No Stylesheet>. All topics use default 
HTML styles, gray background, black serif font.
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5) Click Next. Set up HTML Help options:

6) Click Finish.

Version-control projects may have more options.

Tips:

• If you link a style sheet to your HTML topics, a generic style sheet file called StylesCSS is created and 
added into your project folder. You can modify the styles in this style sheet at any time.

• If you select Convert Numbered lists, all WinHelp topics that use numbered lists retain the 
numbered list formatting in the HTML topics.

HTML limitations with HLP files

Bullets
Make sure that the WinHelp topics do not use bitmap references as bullets. You can select an 
option to keep bulleted lists. This option applies only to topics that use bullet characters and not 
images. If you use images, the HTML output might not include hanging indents.

HTML jumps
Jumps to HTML pages are not converted. You can easily re-create the links in the Design Editor after 
the HTML topics are created.

Format HTML topics to look exactly like the 
WinHelp topics.

Select <Embedded>. Style sheets are not 
attached to topics. All formatting is embedded in 
individual topics. The topic title is Heading 1 
style. All other text (regardless of the styles used 
in WinHelp) is in Normal style.

Attach a custom style sheet to all HTML topics. Click Browse and navigate to the drive/folder 
where the style sheet file (CSS) is located to 
select it.

Desired results Actions

Specify where the Contents, Index, and Search 
tabs are displayed in the viewer.

Select Top, Side, or Bottom.

Convert your WinHelp pop-up windows into 
standard HTML links.

Deselect Display Popups In An Active pop-up 
window.

Desired Result Actions
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Jumps to external WinHelp topics
Jumps to external WinHelp topics are stripped out of the HTML topics. If you are using WinHelp 
projects (especially master projects) that include external jumps, use the HPJ file instead of the HLP 
file.

Macros, buttons, and shortcuts
These macros convert: Jump Context, JumpId, and PopupId. Other macros are not converted. Jump 
Context macros that send output to a window do not convert because links that send output to 
custom windows are not supported. Only buttons convert for Popup Context macros. Graphic 
buttons retain their images, but the button is not included.

Microsoft Word HTML styles
Microsoft Word HTML styles are not used to format the HTML topics.

Microsoft Word templates
Word templates that are used to format RTF files in WinHelp are not converted to HTML style 
sheets.

Mid-Topic jumps
Mid-topic jumps are converted to bookmarks. The bookmark name does not use the mid-topic 
jump topic ID that was created in WinHelp. Instead, it is assigned a sequence of numbers so that it 
can be read in the HLP file.

Multimedia files (AVI and WAV)
These files cannot be converted with HLP files. You can add sound and video to HTML topics in the 
Design Editor. HTML topics can use AVI, AU, MID, RMI, WAV, and other files.

Non-scrolling regions
HTML-based output does not support non-scrolling regions.

Numbered lists
Numbered lists use a 12-point serif font by default. You can create a numbered list style and use it 
to reformat numbered lists.

Related Topics buttons
Related Topics keywords are translated into Related Topics terms. You see customizable buttons 
when you view the topics.

Secondary windows
WinHelp secondary windows are not translated. Unlike WinHelp topics, HTML topics do not 
support links that display information in secondary windows. You can design custom windows in 
RoboHelp and use them to display topics selected from Related Topics buttons, Keyword Link 
controls, See Also controls, the table of contents, and the index.
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Table of contents
The HTML TOC file (HHC) does not support WinHelp pages that link to external WinHelp topics or 
reference macros or that contain link statements. You can link HTML TOC items to HTML topics, 
web and e-mail addresses, FTP sites, newsgroups, and multimedia.

What's This? Help
Context-sensitive Help is not converted. What's This? Help-style topics or dialog topics are 
converted into regular HTML Help topics. You can import map files and assign map IDs for the 
window-level Help topics. For What's This? Help, you can re-enter the text from these HTML Help 
topics into a text-only dialog box and create text-only topics. You can also import context-sensitive 
Help created with the What's This? Help Composer into your HTML Help projects. If you use the HPJ 
file, you can transfer the context-sensitive Help topics into HTML Help.

Microsoft Word formatting
Formatting that is not converted in the HTML topics includes underlining, paragraph spacing, 
indents, alignments, table borders, spreadsheets, background colors, and watermarks.

Tips for creating HTML projects with HLP files

• HTML topics cannot use styles and formatting from the WinHelp project. All topic titles are 
formatted to the Heading 1 style and the rest of the topic is formatted to the Normal style.

• Embed the formatting when selecting style options. Instead of attaching a style sheet, the HTML 
topics are formatted to closely resemble the formatting used in the WinHelp topics.

• A style sheet is not required. It can be created after generation.
• If the entire WinHelp project is available, create the HTML project using the HPJ file rather than the 

HLP file.

Import a WinHelp HPJ file into an HTML project

1) Select File > New Project.
2) Click the Import tab.
3) Select WinHelp Project. Click OK.
4) Click the browse button, and select the HPJ file to import. Click Next.
5) Specify the output folder and filename.
6) Under Choose Source Document(s), select the Word documents you want to import.
7) Click Finish or click Next to step through the remaining steps in the wizard.

Tips for creating HTML projects with HPJ files

• To ensure that the HTML project suits your preferences, review the steps before you start.
• All files referenced by the WinHelp project (HPJ) must be in the locations you specify before you 

generate the project files.
• You can create a single style sheet and apply it to all topics or use different style sheets for different 

topics.
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• WinHelp topics can use a combination of defined styles and manual character and paragraph 
formatting. If so, create style sheets that use the same styles from the WinHelp topics to retain the 
special formats.

• You can select an existing style sheet that you use with other HTML projects. Make the style names 
in the WinHelp topics identical to the style names in the style sheet. Also, format the paragraphs in 
the WinHelp topics to use these styles. Otherwise, you'll have to apply styles from the style sheet 
to paragraphs in the HTML topics after the project is generated.

• You do not have to use a style sheet at all. The HTML topics include the formatting from the DOC 
files (as inline styles which are individually formatted paragraphs and characters). You can always 
create styles and apply them to topics after the HTML project is created. (If your project is large, do 
use style sheets to create the HTML topics. When you revise the styles, the topics are automatically 
updated.)

• Run a small test project to become familiar with the options. Experiment with different options 
until you get the HTML output you want.

• If you are generating a large project, decide how you want to organize it beforehand. In HTML, you 
have one HTML topic file for each WinHelp topic. You have several options for organizing these 
files. You can save them at the root of the project folder or in a subfolder. You can create subfolders 
based on the DOC filenames and save the corresponding topics in them. Finally, you can save topics 
based on their use as pages in the table of contents. (Folders are created for each book and 
subfolders are created for sub-books in your CNT file.)

• Often a project is used in combination with several other WinHelp projects (for example, as a 
master project). If so, create HTML projects with each HPJ file separately so that all the links work.

• After the project is generated, you often want to make a few changes to the style sheet. By default, 
it uses a gray background. You can change it to white by changing the document properties for the 
style sheet.

Adding projects to version control

NOTE: Authors must use the "Add to Version Control" command from within the RoboHelp authoring client 
app itself when adding a new project to version control. Do not add the folders and files within the Robo-
Source Control Explorer interface, as this might cause file corruption.

About version control

RoboHelp works with version control software to check out files automatically (if already not in use) 
when you begin editing and tracks their use. You can also view files by opening them from version control 
without checking them out.

To work with RoboHelp, your version control software must support the Microsoft SCC API. You can use 
Adobe RoboSource Control (installed with RoboHelp), Microsoft SharePoint (integrated natively with 
RoboHelp), or a different third-party package. Either way, you perform version control tasks from within 
RoboHelp.
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Read the following articles if you plan to integrate RoboHelp projects with Microsoft Team Foundation 
Server or Subversion:
• Integrating RoboHelp projects with Team FoundationServer
• Integrating RoboHelp projects with Subversion

When you finish with a file, you can check it into version control, or let the program check in all files when 
you close the project. Once your changes are checked in, other authors can access them. You can also set 
RoboHelp to automatically check in files when you close the project. NOTE: If you cannot check out a file, 
check if one or more files is checked out by another user. Or, check if the file is not in version control.

Many topics are linked to other topics, or part of the TOC, index, and browse sequences. When you 
modify a file or change the project structure, RoboHelp automatically checks out all affected, dependent 
files (if available). When you move a file, the author is prompted to check out the source and destination 
folders.

To turn off prompts when performing version control tasks manually, deselect the option on the Version 
Control tab (Select File > Options). Files are then checked out automatically. Files not selected in the list 
cannot be checked out. RoboHelp shows which files you must check out and whether they are already 
checked out. NOTE: RoboHelp checks out all the dependent files automatically.

To undo any changes in the checked out copy of a version-controlled file, undo the checkout of the file 
listed. Then return to the latest copy from version control. This Undo Check Out command discards 
changes to the local file copy.

Version control safeguards files as you work, provides revision tracking, makes backups, and can provide 
file sharing and organization. All files added to a project under version control are automatically added 
to version control and checked out. All files removed from a project are automatically removed from 
version control, though file history is retained.

You can perform version control tasks from project panes: Right-click the file, select a command, select 
the file, and click Add to Version Control in the Collaborate ribbon. Or, select the file and then select an 
option in the Collaborate ribbon.

Apply version control

1) Install version control software that supports the Microsoft SCC API.
2) Work with your network administrator to address user access. See your version control software 

documentation.
3) Add the project to version control.

Access version control options in pods

File status pod
Select Project > Open > Pods > File Status. Shows the list of files for file status and version control 
tasks. The Version Control toolbar provides access to version control tasks.

Topic list pod
Select Project > Open > Pods > Topic List. Use to open, view, and sort topics.

http://www.adobe.com/go/learn_rh_devnet_team_foundation_en
http://www.adobe.com/go/learn_rh_devnet_subversion_en
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Project Manager pod
Select Project > Open > Pods > Project Manager. Displays file icons. A red check mark indicates that 
a file is checked out.

NOTE: The RoboHelp user interface is optimized for RoboSource Control, Microsoft Team Foundation 
Server 2005, and Microsoft Visual SourceSafe.

Version control FAQs

How does version control work?

A Help project includes topics, graphics, style sheets, TOC, windows, and other components, each with 
its own file so authors can work on components independently.

How can multiple authors use version control?

• Edit project components while authors edit other components.
• View project components even while they are being worked on.
• Get the latest changes (after authors check in files).
• Configure and use version control from RoboHelp. (Using version control on your project outside 

RoboHelp is not recommended.)

Can single-user projects use version control?

Yes, to use revision tracking, and to centralize projects onto a network for backup.

Are multiuser checkouts OK?

Multiuser checkouts are not recommended.

Where can I set version control options for RoboHelp?

Click File > Options > Version Control.

Will I need my version control program outside RoboHelp?

When removing files or folders from your project, remove them from version control also. Also use your 
version control software to create user accounts or set program properties. You can open version control 
from RoboHelp.

Should I check out the project file (XPJ) to edit the project?

You don’t have to check out the XPJ file when editing. You check out the XPJ file only if you edit project 
settings.
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Are items added to the project also added to version control?

Yes. New topics are added immediately; new folders are added when you save the project. When you 
rename a file or folder, it is not renamed in version control. The new item is added, but the original item 
remains with its old name. Remove the item by going into version control.

Save your project whenever you add files, but be sure to check files back in to add changes to version 
control. Changes saved to your local hard drive aren’t added.

Are items removed from the project removed from version control?

Files are removed from version control as you delete them. Renamed items are added under their new 
name, but the old version remains under its old name.

Where are the latest changes made by the team?

You can get the latest file versions (checked in by other users) when you open the project, or manually.

How can I add output files to version control?

If others need access to your output files, add them to version control.

Add a RoboHelp project to version control

NOTE: This topic focuses on adding a RoboHelp project to RoboSource Control. If you want to use Share-
Point as your version control system, refer to Version control with Microsoft SharePoint.

When you add a RoboHelp project to version control, create a database connection when you first 
connect to RoboSource Control. RoboHelp uses this connection to access the database. See Adobe Robo-
Source Control Help for more information.
1) Open the project in RoboHelp HTML.
2) Choose Collaborate > Add To Version Control.
3) Select RoboSource Control and click OK.
4) If you are connecting to the RoboSource Control database for the first time from your computer, 

go to step 5 to create a connection. If you have connected previously, verify that the correct 
connection is selected in the Connection list. Then skip to step 9.

5) From the Connection list, select Create.
6) Do one of the following:

– If the RoboSource Control Server software is on your computer, select the database connec-
tion from the list on the left

– If the RoboSource Control Server is on a server, complete the following fields:

Connection Name
Enter any name to identify the database from RoboSource Control Client. If you want, you can use 
the database name.
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Server
Enter either the IP address or the unique name of the server on your local network.

Database
Enter the name of the database exactly as you entered it in the Create Database dialog box.

7) Click Create And Connect.
8) Connect to RoboSource Control.
9) In the Configure Source Control dialog box, click the Browse button next to the Root Path field.
10) If prompted, enter the same password that you entered to log in.
11) NOTE: When the Login dialog box is hidden behind the RoboHelp window, your screen appears to 

be frozen. Use Alt+Tab to view the Login dialog box.
12) Click the root node $ to select it, click OK, and then click Yes in the displayed message.

All your RoboHelp project files are now copied to the server-based database, and all the files are flagged 
as checked out to you. When you close the project, you are prompted to check the files into the database. 
If you answer Yes, all the files are checked in.
NOTE: An additional File Status pod is displayed in the RoboHelp user interface. This pod lists all the 
project files that are under version control and the status of each (checked in or out). Further documen-
tation is installed with RoboSource Control. This help file is accessed from within the RoboSource Control 
Explorer application.

File checkin/checkout

When you begin to modify a project file in RoboHelp, the topic file is checked out from version control (if 
not in use).

Many topics are linked to other topics, or part of the TOC, index, and browse sequences. When you 
modify a file or change the project structure, RoboHelp automatically checks out all affected, dependent 
files (if available).

If a project has dependent files, RoboHelp asks to check them out. If some are already checked out, ask 
users to check them in.
NOTE: Once you’ve added a project to the version control system, you can view file versioning history and 
properties, as well as differences between the local copy of the file and its checked in version.

Version control with Microsoft SharePoint

RoboHelp supports version control with Microsoft SharePoint 2010 and above natively, which means you 
do not need to install any third-party plugins.

The RoboHelp installer automatically installs all needed components, including the following prerequi-
sites for the version control feature to work smoothly:
• .NET framework 4.0
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• SQL Server Compact 3.5 SP2

Configure RoboHelp settings for SharePoint

1) In RoboHelp, click File > Options > Version Control to display the version control settings.
2) In the SharePoint Settings area, enter the path of a file comparison program that is installed on the 

system and the arguments (parameters) for it. RoboHelp uses it in file comparison operations. You 
can download the free comparison program WinMerge from http://winmerge.org/
NOTE: If you use WinMerge, enter the path to WinMerge that is installed on your system, in the Path 
parameter, and %1 %2 as the Arguments. %1 and %2 denote the two files to be compared.

3) Configure the following options:

Notify Before Overwriting Writable Files
Notifies the user before overwriting any writable files that are not checked out.

Replace Local File Even If Server Version Is Same
Forces RoboHelp to fetch the latest files from the server, even if local file version and server version 
is the same.

Default Checkin Option
Select whether to check in the files as a major version or as a minor version. The default is to check 
in as a major version.

NOTE: The Default Checkin Option comes into effect while checking in files, the check in dialog is 
suppressed.

RoboHelp does not display notifications for version control operations by default. To display notifica-
tions, enable the relevant options in the Display Confirmation Dialog When area in the Version Control 
page of the Options dialog box (File > Options).

Configure SharePoint settings

To add a RoboHelp project to a document library in SharePoint, configure the document library settings:

NOTE: This section lists the broader steps that you need to configure your SharePoint Server. Refer to your 
product’s documentation for more details.
1) Log on to SharePoint.
2) Create a Site.

To create a site, you need to provide details like site title, web site address, template, and site ad-
ministrator.

3) Create a document library for the site you created in Step 2.
4) Enable versioning settings for the library:

a) Click the document library to be edited from the list of document libraries that are displayed.
b) Access Library Settings.

http://winmerge.org/
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c) Open Version Settings and then configure the following:

Require content approval for submitted items
Select No.

Create a version each time you edit a file in this document library?
Select Create major and minor (draft) versions.

NOTE: The Create major versions option is also supported. In this case, files cannot be checked in as minor 
versions.

Keep the following number of major versions
Deselect this option.

Keep drafts for the following number of major versions
Deselect this option.

Who should see draft items in this document library?
Users with read access.

Require documents to be checked out before they can be edited? (Force Checkout)
Select Yes.

NOTE: To provide users with read / write access to the RoboHelp files on your SharePoint server, ensure 
that the appropriate SharePoint user permissions are provided to the users.

Add a project to a SharePoint document library

1) Click Collaborate > Add to Version Control icon.
2) Select RoboHelp SharePoint Connector and click OK.
3) Specify the SharePoint site that contains the Document Library, and the username and password 

to log on to SharePoint. Click OK to log on to SharePoint.
NOTE: You can use LDAP authentication if it is configured on the SharePoint server, by selecting the 
option Use Windows Authentication.
When you connect to the SharePoint site, all the document libraries in that site are displayed.

4) Create a folder inside a document library or use an existing empty folder to upload the RoboHelp 
files and click OK.
RoboHelp adds the project files to SharePoint.
NOTE: You can add the project to any folder inside the document library. The folder must be empty. 
You cannot add the project directly to a document library.
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Merging Help projects

About merged Help projects

Using RoboHelp, you can create projects in an enterprise or distributed setup where different documen-
tation projects feed into a common project. You can achieve multi-authoring without using 
source-control software because multiple writers can work on their individual projects and you merge 
them to create the common project. By using skins and templates in the common project, you can 
achieve a unified appearance in the merged projects.

The merging takes place at run time, after the projects are generated. Before merging the projects, you 
simply place references to other projects inside a master project (the master project does not actually 
contain the child projects). You insert each reference in the master project's table of contents, placing it 
where you want the TOC of the child project to appear. This step gives you control over where end users 
access the child project and gives the appearance of a single, unified Help system. End users see a single 
online system complete with a table of contents, an index, full-text search, a glossary (in WebHelp proj-
ects), and link controls.
IMPORTANT: The child projects must not have content categories.

Merging multiple projects involves these steps:
• Create a master project with references to child projects in the TOC. See Create a master project.
• Publish the child projects. See Publish child projects.

NOTE: For master projects having the Adobe AIR Application output type, publish the child projects 
as browser-based Adobe AIR Help.
Browser based Help output type selection
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• (Adobe AIR Application output type only) Regenerate the output of the master project. See 
Configure the Adobe AIR layout.

NOTE: Responsive HTML5, WebHelp Pro, and FlashHelp Pro projects are automatically published by Robo-
Help Server.

Create a master project

This procedure applies to HTML Help, WebHelp, FlashHelp, Adobe AIR Application, and browser-based 
Adobe AIR projects.
1) Create the master project and the projects that you want to merge.

TIP: For ease of maintenance, the master project should ideally be an empty container or only have 
a default topic. The child projects should store all the content. For more information, see Which 
project works best as the master project? in FAQs about merging projects.

2) Open the master project. In the default topic, add the content that you want to display on the home 
page of the merged Help.

3) Select a skin. The skin of the master project is used as the skin of the merged Help.
4) Do one of the following:

– Select the default TOC of the master project from the Project Manager pod.
– Create a TOC for the master project.

5) To insert child projects, place your cursor in the TOC.
6) On the TOC pod, click the New Merged Project icon.
7) Do one of the following:

– For HTML Help projects, click the HTML Help tab in the Merged project dialog box.
– For WebHelp/FlashHelp/Adobe AIR projects, click the WebHelp/FlashHelp/Adobe AIR tab.

8) Do one of the following:
– For HTML Help projects, select a CHM file that is already in the current project folder or 

browse to the location of the CHM file.
An icon with the filename is displayed in the TOC pod where you inserted the child projects. 
The filename is in the format <CHM file> .chm::/<CHM file>.hhc. The HHC file represents the 
TOC of the merged CHM file. This icon appears where the TOCs of the child projects occur in 
the merged project. If needed, you can drag the icon to another location in the TOC and drop 
it into place.

– For WebHelp/FlashHelp/Adobe AIR projects, enter the name of a RoboHelp project (XPJ) or 
click Open to browse to the project file.
In case of WebHelp/FlashHelp/Adobe AIR projects, the placeholder appears as the name of the 
project.

9) Generate the master project.
When a project having merged project references in its TOC is generated, a folder "mergedProjects" 
appears in the SSL output folder. The mergedProjects folder contains a folder for each referenced 



122

MERGING HELP PROJECTS
CHAPTER 3 PROJECTS

child project. In the case of WebHelp/FlashHelp/Adobe AIR, the corresponding child project has to 
be generated in its own folder.
NOTE: The name mergedProjects is reserved. Do not give any folder in the project folder the name 
mergedProjects.

10) In the Result dialog, click View to see the results and test the merged project.

Notes:

• Merged HTML Help projects use non-binary contents files (HHC). The names of the compiled output 
file (CHM) and contents file (HHC) cannot include spaces. (To find out if they have spaces, look at 
them in your project folder in Windows Explorer. Do not rename the files in Windows Explorer, 
however.) If either of the filenames has spaces, open the project and rename the project file. Then, 
generate the project and change the name of the output file (CHM file). The HHC filename is 
updated automatically when you change the project name.

• Do not assign the Binary TOC feature to your project. If you do, the external TOCs are not displayed 
in the Contents tab in the HTML Help viewer.

• If you generate a WebHelp/FlashHelp/Adobe AIR output using a skin, the skin from the master 
project overrides the skin of the child project in the merged project. If you access the projects indi-
vidually outside the merged project, the project-specific skin is used.

• If you need to add cross-project links, make sure you set up the folder structure for source projects 
in the same way as the folder structure of the generated and published files.
Otherwise, while hyperlinking, you need to manually construct the URL based on the folder structure 
of the generated and published files and specify in the Link To text box. For detailed steps, see this 
article.

Publish child projects

This procedure applies to Microsoft HTML Help, WebHelp, FlashHelp, Adobe AIR Application, and 
browser-based Adobe AIR projects.

After you create the master project, publish the child projects to place them in the correct location. 
Publishing the projects enables you to view them together at run time. You can maintain child projects 
at different locations and merge them at a different location. You can publish the merged project to a 
corporate intranet, an Internet site, a local hard disk, or a network or FTP server. The output files of the 
merged project are stored only at the published site and not at individual child project locations.
1) Open a child project.
2) Right-click the layout in the Single Source Layouts pod and select Generate.

NOTE: In the case of master projects having the Adobe AIR Application output type, select the output 
type Browser Based Help for each child project.

3) For master projects having the Adobe AIR Application output type, select the output type Browser 
Based Help for the child project.

4) Display Publish settings.
– (Adobe AIR/WebHelp) Click the Publish tab in the layout properties dialog box.
– (FlashHelp/Microsoft HTML Help) Click Next until the Publish dialog box is displayed.

http://grainge.org/pages/authoring/merging_webhelp/merging_method_rh8.htm
http://grainge.org/pages/authoring/merging_webhelp/merging_method_rh8.htm


123

MERGING HELP PROJECTS
CHAPTER 3 PROJECTS

5) Specify a destination. For example, [master_project_folder]/SSL!/[layout_name]/mergedProj-
ects/[child_project_name] or //servername/mergedProjects/[child_project_name].

6) Click Save And Generate. The layout is generated.
7) On the Result dialog box, click Publish.

When the process is complete, a dialog box displays statistics about the publishing process and a list 
of files published.

8) Click Close.

View merged Help projects

1) To view the merged Help system from the local copy of the master project (instead of the published 
location), copy WebHelp files of child projects to the master project's mergedProject\<Project-
Name> folder. NOTE: To run browser-based Help from a local drive, the installation folder must be 
added in the list of trusted folders defined in the RoboHelp.cfg file of in the FlashPlayerTrust folder. 
See Distribute Adobe AIR output.

2) Right-click the layout in the Single Source Layouts folder and select View. If you use this method, be 
sure not to use the Republish All option in the master project, which could potentially overwrite 
newer child project files on the network or server.

Remove merged child projects

1) To remove a merged Help project, click Delete in the TOC pod. The child project icon is removed. 
Regenerate (and publish if applicable) the master project to remove the child project from the 
output. For WebHelp projects, publish the child projects for the change to take effect.

Customize merged Responsive HTML5, WebHelp Pro, or FlashHelp Pro projects

RoboHelp Server automatically merges multiple Responsive HTML5, WebHelp Pro or FlashHelp Pro proj-
ects. The projects appear in the table of contents in alphabetical order. To nest a project TOC within the 
TOC of another project, you can rearrange the projects in the table of contents. You can ask your server 
administrator to change the order of the projects for you in RoboHelp Server, or you can customize the 
projects yourself.
1) Ask your server administrator to deselect the Automatically Merge All Projects option in the Proj-

ects tab of the RoboHelp Server (Web Admin interface).
2) Open the master project. Select any project as the master or select a blank project as a master 

project.
3) In the TOC pod, click the New Merged Project icon. The Merged Project dialog opens.
4) In Project Name, type a Responsive HTML5, WebHelp Pro or FlashHelp Pro project (XPJ) name. Or, 

click Open to browse to the project file. A reference to this project is inserted in the TOC of the 
current project where you clicked.

5) Click OK. An icon with the project name is displayed in the TOC where you inserted the child project. 
The icon is a placeholder indicating where the TOC of the child project appears in the merged 
project. If needed, you can drag the icon to another location in the TOC and drop it into place.
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6) Generate all the projects to update any changes.
7) Publish the master project.

NOTE: (For HTML5 output only) If due to some technical issue the child project does not appear 
correctly in the published output, then regenerate the child project locally and replace the child 
project on the server (in the same area) with the newly generated (local) output.

8) View the merged project from the server.
NOTE: (For HTML5 output only) In the Admin Console you will only see the parent project. A separate 
entity of the child project is not shown. When you open the parent project, the child project's 
content are displayed in the parent project.

FAQs about merging projects

This information applies to Adobe AIR, WebHelp, and Microsoft HTML Help projects.

Master projects

Which project works best as the master project?

A blank project with no topics as a container for the child projects works best as the master project. If 
you need to include content in the master project, avoid creating cross-project links.

The TOC of the master project can consist of references to child projects only. The TOCs of the child proj-
ects appear in the output.

Can the master project include content categories?

How many child projects can the master project reference?

There is no limit to the number of child projects that you can reference in the master project.

Can a master project be a child project of another master project?

Yes. For example, Project A can be a master project referencing Project B, and it can also be added as a 
child project of Project C. Here are examples for each output type:

For WebHelp projects: To use Project A as a child project, publish it to the \mergedProjects\ folder of 
Project C.

For HTML Help projects: To use Project A as a child project, add the CHM file to Project C and generate 
the merged projects.

Where do I place the child project in the TOC?

You can place the child project anywhere in the TOC of the master project (as a subbook or a top-level 
book). After inserting the child projects into the TOC, you can drag them to the selected location in the 
TOC. However, you cannot separate or divide the child project TOC in the master TOC. The TOC of the 
child project appears in its entirety where you place it.

Does generating or publishing the master project update the child projects?

No. To update a child project in the merged Help system, generate the child project. In WebHelp projects, 
also publish the child projects to the correct folder.
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Features

Do I need to merge the index separately?

No. The updated merging function of RoboHelp merges the index automatically.

What happens if the merged projects have identical index keywords, glossary terms, or link controls?
– Index keywords

Identical index keywords are combined at run time. For example, if project A and project B 
both have the index keyword "Installation," this keyword contains all the topics and subkey-
words for both projects.

– Glossary terms
In WebHelp projects, if the same term is used in the master project and the child projects, the 
definitions are combined at run time (if different, the definitions are placed on separate lines 
in the "Definition for" pane).
In HTML Help projects, if the same term is used in the master project and the child projects, 
the definition in the master project replaces the child project definition.

– See Also keywords
• In WebHelp, identical See Also keywords are not combined at run time. Each project 

uses its own See Also keywords. For example, even if Project A and Project B both use 
the keyword "Setup," topics displayed are for the individual projects only.

• In HTML Help, identical See Also keywords are combined at run time.

Can you merge browse sequences?

No, browse sequences are not merged. However, all the browse sequences defined in each merged 
project are available in the merged Help.

How is conditional text handled?

Child projects generated with a conditional build expression are supported in the master project. For 
example, if a child project defines a conditional build expression to exclude Tag A, all topics and topic 
content with Tag A applied are excluded from the child project and the master project.

For HTML Help projects, are links to external topics retained?

For merged HTML Help projects, index keywords, TOC books and pages, and HTML topics can all link to 
external topics in any of the CHM files that are included in the master project. (Remote topics are not 
supported in WebHelp.)

WebHelp projects

How do I distribute merged WebHelp projects?

Publish merged WebHelp projects to an intranet or a web address, a local or network drive, or an FTP 
server.

Where do I publish the projects?

Although you publish the master project where you normally would, the child projects are published to 
a special location.
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What happens to references to child projects that are not published?

If you add a child project to the master project but do not publish it, the child project is not displayed 
when the master project is published.

HTML Help projects

What type of index should I use?

The master project must have an index or the merged index is empty. To merge CHM files, your master 
project needs to have a binary index when it is generated. With a binary index, all the keywords from the 
child projects are merged, alphabetically sorted, and saved in the index file (HHK) of the master project. 
Binary format is ideal because it is highly compressed, takes up less space, and is faster to load. Index files 
in the child projects do not have to be in the binary format.

Set the Binary index option to the master project before merging the projects.

How do I distribute merged HTML Help projects?

Distribute the CHM files for all the projects, and save them in the same folder as the master project. 
When you merge projects, the CHM file of the child project is copied to the folder of the master project. 
Whenever you update and generate the child project, copy the updated CHM file to the master project 
folder.(You can do this using Windows Explorer.) Distribute the most current versions of all CHM files.

Adobe AIR projects

How do I distribute merged Adobe AIR Application projects?

An Adobe AIR Application project is a single .air file. To distribute this .air file, copy the file from the 
output location to the required shared location.

How do I run merged browser-based Adobe AIR Help from a local folder?

Add the output folder in the list of trusted folders defined in the RoboHelp.cfg file in the FlashPlayerTrust 
folder. See Distribute Adobe AIR output.

Reports

Export project reports

1) Click Tools. Select report type.
2) Customize the report.
3) Click Save As.
4) Browse to the location where you want to save the file.
5) Enter a name for the file.
6) From the Save As Type list, select RTF or TXT.
7) Click Save.
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Print reports

1) Select Tools.
2) Select the report type.
3) Customize report options.
4) Click Print.

TIP: Print the table of contents or index from the TOC pod or Index pod. Select File > Print.

Send reports

You can share reports with others by sending the content as an e-mail message.
1) Select Tools.
2) Select the report type. The Reports dialog box appears.
3) Use the options available to customize the report. (Not all reports are customizable.)
4) Click Mail To.

Your e-mail program creates a message and the report information is added as the content of the 
message. Edit this text and add information as you would any other e-mail message.

5) Address and send your e-mail.

NOTE: If you need assistance using the Mail To feature (for example, your system prompts you to set up 
a profile), contact your e-mail administrator.

Generate and customize reports

All reports are available from Tools menu.

Broken links report

This report (available from Tools > Map ID > Broken Links) finds files that contain broken links. This report 
is not customizable.

Notes:

• In a multi-author, version-controlled environment, ensure that you don’t link to topics that have 
been moved, renamed, or removed. These links will be broken.

• For a version control project, have one person test the latest version for broken links before 
releasing the final output.

Conditional Build Tag report

This report provides information about usage of topic-level, content-level, and TOC-level build tags in the 
entire project.
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It displays a summary of the project. It identifies the conditional build tags used in the project. For each 
tag, it shows the detailed path of all topics in which the tag is used.
1) Select Tools > Topic Properties > Tags. The Reports dialog box appears, with the Build Tags tab 

selected, displaying the Conditional Build Tag report.
By default, the report sorts the tags by Build Tag Name.

2) (Optional) To change the sort order, select Options. The Build Tag Report Option dialog box 
appears.

3) Select Topic, TOC, And Index Name.
4) Click OK. You can view the tags usage report sorted by Topic, TOC, and Index Name.

See Also report

1) Select Tools > TOC > See Also. The See Also report appears.
2) Customize these options as needed:

Keywords
Includes all keywords from the index.

Keywords And Topics
Contains a list of keywords. Each keyword lists the topics that use it. You can discover if keywords 
are not linked to any topics and identify topics to remove from keywords.

Topics And Keywords
Contains a list of topics. Each topic list the keywords associated with the topic. You can discover if 
topics are missing keywords, inconsistent phrasing, and identify keywords to remove from topics.

Index report

1) Select Tools > TOC > Index.
2) To customize, select from the following options:

Keywords
Includes all keywords from the index.

Keywords And Topics
Contains a list of keywords. Each keyword lists the topics that use it. You can discover if keywords 
are not linked to any topics and identify topics to remove from keywords.

Topics And Keywords
Contains a list of topics. Each topic lists the keywords associated with the topic. You can identify 
missing keywords, inconsistent phrasing, and keywords to remove from topics.

Select Index
Select an Index from the list to generate a report for the index selected.
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Duplicate Map IDs report

Each map number in your project must be unique. Use this dialog to remove duplicate map IDs.

If your project includes context-sensitive Help, make all map numbers in your map files unique. If some 
map files use the same map numbers, the Duplicate Map IDs tab identifies them for you.
NOTE: If duplicate map IDs exist in your project, some of your context-sensitive Help topics might not work 
properly.
1) Select Tools > Map ID > Duplicate Map IDs.

TIP: Use this report to test your help project. With the RoboHelp BugHunter tool, you can test map 
numbers and topics.

External Topics report

The External Topics report (Tools > Map ID > External Topics) includes data on these topics:
• URLs
• Links to HTML topics in other CHM files
• FTP addresses
• Newsgroup addresses
• E-mail addresses

Tips:

• Use this report to test your links.
• Share this report with authors who use these URLs.

Glossary report

1) Select Tools > TOC > Glossary.
2) Select one of these options from the Reports menu:

Detailed Lists
Terms and definitions

Overview Lists
Terms without definitions

The glossary report is shown for the glossary selected.

Images report

1) Select Tools > Topic Properties > Images. The Image report appears.

View An Alphabetized List Of Images
Grouped under each image is a list of all topics that use it.
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View An Alphabetized List Of Topics
Grouped under each topic is a list of all images they include.

Map IDs report

Use this report (Tools > Map ID > Map IDs) to generate a project summary. It includes the number of map 
IDs, topic ID and location, map number, and map filename.

The Map IDs report provides information about all the context-sensitive Help topics that are used in your 
project, including map IDs and text-only topics (for What's This? Help).

First, the report displays a summary of the entire project. It identifies the number of map IDs and then 
gives more specific information. Each topic in the project that has a map ID assigned is listed with topic 
ID, map number, map filename, and topic location.
TIP: Use this report as a reference for testing Help.

Project Status report

Generate information for a group of topics (Tools > Project Status) by selecting a specific folder from the 
Folder list.
• Total number of topics completed, in progress, and ready for review
• Total number of topics in a project
• Estimated development time to author all topics
• Information on To Do items

Snippets report

Select Tools > Topic Properties > Snippets. The Snippets report appears showing the snippets defined in 
the project. The Snippets report also shows the topics in which a particular snippet has been used.

Style Sheets report

Use this report (Tools > Topic Properties > Style Sheets) to view an alphabetized list of style sheets or 
topics. The list of style sheets shows which topics use each style sheet. The list of topics identifies which 
style sheet each topic is attached to. To sort, choose an option from the Sort By menu.

Table Of Contents report

Use this report (Tools > TOC > Table Of Contents) to view information about TOCs. Specify the level of 
detail you want to see:

Detailed
Includes titles of books and pages, names of linked topics, and location of files.

Overview
Includes titles of books and pages and the names of linked topics.

The Table of Contents report is shown for the TOC selected.
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TIP: You can change your table of contents whenever you change topic titles or filenames.

Topic Properties report

Use this report (Tools > Topic Properties > Topic Properties) to filter reports according to various proper-
ties. To customize the report, click Options, and select details to add:

General
Folder and bookmark names and locations.

Topic Status
Status, priority, time, completed To Do items, and comments.

References
Links to the topic, links from the topic, map IDs, table of contents, See Also keywords, and 
keywords.

Advanced
Information types, conditional build tags, search keywords, and style sheet, and exclude from 
search.

You can filter the list of topics included in the report by selecting a specific folder from the Folder list.

Topic References report

Use this report (Tools > Topic Properties > Topic References) to track topic references. References 
include:
• Topic links
• TOC books and pages that use the topic
• Keywords and phrases that use the topic

Select the Folder list to generate information for a topic group.

Tips:

• Use this report to find references to remove when updating your topics.
• Before you remove a topic, you can remove all references to it. Use this report to identify the refer-

ences and relink them to different topics.
• If you don't remove references when you remove a topic, this report identifies the breakable refer-

ences.

Topics By Priority report

The Topics By Priority report (Tools > Topic Properties > Topics By Priority) provides a summary of your 
project. It lists topics sorted by the priority assigned by the author. This information is gathered from the 
topic properties. Therefore, the key to making this report work for you is to change topic properties as 
you author.
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To customize the information in this report, click Options and select the information you want to include 
in it. You can select a range of priorities or view all priorities. You can also filter the list of topics included 
in the report by selecting a folder from the Folder list.

Unreferenced Topics report

This customizable report (Tools > Topic Properties > Unreferenced Topics) tracks unreferenced topics in 
the TOC, index, browse sequences, or in other topics. Use it to identify:
• Inaccessible topics (To fix, create links from other topics.)
• Topics excluded from the TOC
• Topics without index or See Also keywords (To fix, add keywords, or add the topic to a See Also 

keyword.)

NOTE: Some topics do not use references. For example, if you create window-level context-sensitive Help, 
topics are only accessible when end-users press F1 or click Help. They don't need references. You can iden-
tify unreferenced topics that you are using as context-sensitive Help topics.

Unused files report

Use this report (Tools > Topic Properties > Unused Files) to view unused files in one place. You can sort 
by filename or file type by selecting from the Sort By menu.

You cannot remove these files from within your project. Make a list of the unused files and their paths 
and then use Windows Explorer to delete the files. IMPORTANT: Before you delete files, make a backup 
copy of the project in case you need to revert changes.
NOTE: Indiscriminate deletion of files other than what is listed by the unused files report, results in broken 
links, missing files and other undesirable consequences.

Unused index keywords report

Use this report (Tools > Map ID > Unused Index Keywords) to track all index keywords that are not asso-
ciated with topics. Use it to:
• Identify index keywords that you can remove from your project.
• Find index keywords that must be associated with topics.
• Review cross-references included in your index.

Used Files report

Use this report (Tools > Topic Properties > Used Files) for an inventory of all files in the project.

Missing topics report

Use this report (Tools > Topic Properties > Missing Topics) to track missing topics and several associated 
elements:
• TOCs, books, and pages that reference missing topics
• Index keywords and phrases that reference missing topics

Select a folder from the Folder list to generate topic group information.
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Tips:

• Before you remove a topic, remove all references to it.
• If you do not remove references when you remove a topic, this report identifies the breakable 

references.

Variables report

Use this report (Tools > Topic Properties > Variables) to list variables in the order they were created along 
with their values and information about their usage.

If you view all variables in the project, the report indicates the variables defined in Variable sets and the 
files in which they are used. You can also find variables that have not been used.

This report is useful when you want to remove variables. Locate all topics in which the variables are used 
and delete references to the variables before deleting the variables.

Reference

URL Properties dialog box

Use this dialog box to link index keywords to URLs in your project.

Keywords
Enter the word or phrase that end users must enter in the index to access the URL.

Delete Old Project dialog box

Delete the old WebHelp Pro project from the RoboHelp Server before publishing the renamed project.

Move File Into Project dialog box

Restore a broken topic link by finding a file or creating a link.

Try To Find
Browse for the linked file.

Create New
Create a topic and save it in your project folder to repair the broken link.

Help to HTML style options

Select The Style Sheet To Use
Specifies the style sheet name to attach to all created HTML topics.
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No Stylesheet
Does not attach a style sheet. All topics use default formatting.

Embedded Styles
Does not attach a style sheet to the topics. All HTML topics use WinHelp formatting. Formatting is 
embedded into each HTML element.

Convert Bulleted Lists
Uses bulleted list items from WinHelp topics in topics (retains bulleted lists).

Convert Numbered Lists
Uses numbered list items from WinHelp topics in topics (retains numbered lists).

Tips:

• You can modify any style sheet after you convert the project.
• Create new style sheets after converting and attach them to topics.
• Projects can include multiple style sheets.

HTML Help Advanced Settings tri-pane

Buttons

Defines the buttons/controls to include in the toolbar. Options:

Hide/Show
Hides the left-tab components in the tri-pane.

Options
Displays a menu of options.

Locate
Synchronizes the left and right panes (when Auto Synchronize TOC is not selected).

Navigation pane

Defines how content appears in the viewer. Options:

Auto Show/Hide Nav Pane
Hides the left navigation pane when end users switch from a compiled help file to a program. The 
content remains visible in the right pane. The left tabs can't be viewed until the user selects the 
window.

Auto Synchronize TOC
Formats the left and right panes to synchronize as users navigate content.
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NOTE: Project filenames cannot include spaces. You can automatically replace spaces with underscores 
after you create the project.

Width
Defines the navigation pane width in pixels.

NOTE: Project filenames cannot include spaces. You can automatically replace spaces with underscores 
after you create the project.

Width
Defines the width of the navigation pane, in pixels.

Font

Selects a font for displaying titles on the Contents tab.

Select
Opens the Font dialog box.

Default
Sets the font to use your default system setting.

HTML Help Advanced Settings TOC tab

Border
Add a border around the Contents pane.

Dialog Frame
Add a frame around Contents pane.

Lines From Root
Display lines connecting books and pages starting at the root.

Plus/Minus Squares
Display plus and minus squares that open and close books.

Folders Instead Of Books
For table of contents book items, display a folder icon in place of a book icon.

Single-Click To Open Book
Formats book items to open with a single click. When this feature is not selected, books open with 
a double-click.

Lines Between Items
Add lines between books and pages.
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Raised Edge
Format the table of contents so it looks raised from the tri-pane.

Sunken Edge
Format the table of contents so it looks sunken into the tri-pane.
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Working with topics

Create, save, and open topics

Create a topic

1) In the Project Manager pod, open the XHTML Files (Topics) folder.
2) To store the topic in a specific custom folder, select the folder.
3) Do either of the following:

– Click the New Topic icon .
– To create the topic with a different HTML editor, right-click and select New > Topic With. Then 

select the editor.
NOTE: You can also right-click in the Topic List and select New Topic With > [editor].

4) Specify a topic title.
5) Select a UDV from the Variables list to insert in the topic title and click Insert. Click OK. For example, 

instead of embedding a product name in the title, use a UDV for the product name. UDVs help you 
manage changes and ensure consistency.

6) If required, modify the file name that RoboHelp creates from the topic title.
For best results, use underscores instead of spaces in file names, and follow the HTML file naming 
protocol. Avoid using these characters in file names: \ / : * ? < > | # ", $, &, [ ]
(Apply these same conventions to folder names.)

7) (Optional) Select a master page.
8) Specify a language for the new topic.

NOTE: If you do not specify a language for the topic you are creating, RoboHelp uses the language 
setting for the project. RoboHelp uses the language setting for a topic for the spelling checker, the 
thesaurus, smart indexing, and full-text search indexing. The output UI is controlled by the project 
language setting. For more information about language support, see Authoring content in multiple 
languages

9) Add keywords to help users find the contents of this topic. To separate the keywords, you can use 
commonly used characters, such as comma, semicolon, and space. Space works in most languages.
NOTE: The keywords you specify are added to the index. For more information, see Topic keywords.

10) Select Exclude This Topic From Search only if you do not want to display this topic in the search 
results.
NOTE: Exclude From Search is not available for Microsoft HTML Help (CHM) search.

TIP: To open a topic in a third-party editor, right-click the topic in the Project Manager or the Topic List 
and select Edit With. The topic opens in the editor you specified (the Editor box still displays the editor 
set for the project).

RELATED LINKS:
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Add underscores to file names

Save topics

Save a topic

• Press Ctrl+S.
• In the toolbar, click Save.

Enable or disable Save

If you deselect Save Without Prompt, you are prompted to save topics.
1) Select File > Options.
2) Click the General tab.
3) Under Options, select or deselect Save Without Prompt.
4) Click OK.

Rename topic files

NOTE: Avoid using Windows Explorer or your version control application to rename files. The Project 
Manager cannot update file references.
1) Do either of the following:

– In the Project Manager pod, expand the appropriate folder. Select Project > View > Display 
Topics > By File Name. Right-click the file, and select Rename.

– In the Topic List pod, right-click the file. Select Properties.

2) Type the new name.
For best results, use underscores instead of spaces, and follow the HTML file naming protocol. Avoid 
using these characters in file names: \ / : * ? < > | # ", $, &, [ ]
If the file name has multiple words, use underscores instead of spaces.

Open topics

You can open topics in Design Editor or another editor while still using RoboHelp to add online Help 
features.
1) In the Project Manager or Topic List pod, do one of the following:

– To open the topic in Design Editor (or a third-party editor you’ve set as the default editor), 
double-click the topic.

– To open the topic in an editor, right-click the topic and select Edit With > [editor].
If you are prompted whether to continue with possible HTML code changes, click Yes. Howev-
er, to avoid code changes from one editor to the next, edit topics in the same editor and click 
No.

RELATED LINKS:
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RoboHelp Design Editor

Third-party HTML editors

Support for multiple document interfaces

You can open multiple topics in Design Editor. You can edit topics simultaneously, compare topics, and 
copy content from one topic to another.

Each open topic has a corresponding tab in the Design Editor pod. Click a tab to make its topic window 
active. Click the scroll arrows to scroll through tabs and reveal hidden tabs. Drag the tabs to position topic 
windows horizontally or vertically within Design Editor.

Author in XHTML

You can use RoboHelp to create topic files in XHTML and project-specific files in XML. Structured 
authoring in XHTML ensures well-written code, closed tags, no overlapping of tags, properly quoted attri-
butes with explicit values, and no proprietary attributes. RoboHelp upgrades all the old RoboHelp for 
HTML topics to XHTML when it imports them.
NOTE: For upgraded projects, the formatting of bulleted lists might not be correct in the output. After 
upgrading a project, make sure that the bulleted list style in the CSS specifies zero or a positive value for 
the left margin.

The RoboHelp editor creates all the topics in XHTML. All topic files are compliant with XHTML 1.0 Transi-
tional. XHTML generated from RoboHelp conforms to the XHTML 1.0 Transitional specification from the 
World Wide Web Consortium (W3C). All topics have the XHTML 1.0 Transitional doc type:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

Every XHTML topic contains an HTML tag and an xmlns attribute value of 
http://www.w3.org/1999/xhtml.

NOTE: To view the XHTML source of a topic, open the topic in the Design Editor and select the HTML view.

You can use third-party editors such as Notepad, Microsoft Word, or Adobe Dreamweaver to edit your 
files and retain these files in their existing format. You can edit topics using a third-party XHTML editor. 
RoboHelp retains its processing instructions (PI) as comments to avoid any data loss. You can use Robo-
Help to edit the third-party HTML or XHTML topics and generate XHTML output.

NOTE: Snippets, master pages, and framesets are created in XHTML format only.

When creating a project, RoboHelp creates several project-specific files, such as APJ, CSS, and BRS files, 
in XML format. For example, the TOC, index, glossary, and the following project file name extensions are 
generated in well-formed XML:

.ali, .brs, .phr, .stp, .ign, .lng, .ssl, .xpj, .apj, .syn, .glo, .hhk, .hhc, .ppf, .fpj

These files are in the root of the RoboHelp project folder. You can open these XML files and read the data 
using XML processors.

http://www.w3.org/1999/xhtml
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Convert XHTML to HTML

1) Select File > Options > General.
2) Select Convert RoboHelp Edited Topics To HTML.

Selecting this option converts all the topics to HTML in the SSL output. You can generate the SSL to check 
whether the output files are in HTML or XHTML. XHTML pages support all the DHTML effects that can be 
applied using RoboHelp HTML. HTML pages do handle DHTML effectively. Within a topic, right-click and 
select View or Preview Topic. View the source of the output file or preview the topic to verify whether it 
is XHTML or HTML.

RELATED LINKS:
RoboHelp editors

Validate XHTML

You can validate the RoboHelp generated XHTML code against W3C specifications for compliance with 
XHTML Transitional 1.0. Right-click a topic in the Project Manager and choose Validate W3C Compliance 
to validate the topic. You can select Validate All to validate all the topics.

The following features are not supported in XHTML:
• Marquees in topics
• Border color in framesets
• Background sound in topic properties

Use of these features results in invalid XHTML code. Remove these features to generate valid XHTML 
code.

RELATED LINKS:
W3C compliance

Import and copy topics

Import topics

1) Select Project > Open > Pods > Project Manager. The Project Manager pod appears.
2) Open the HTML Files (Topics) folder.
3) To save the file in a subfolder, select the folder.
4) Select Project > Import > HTML File.
5) Navigate to the HTML/XHTML file.
6) Select the file. Press Ctrl to select multiple files.
7) Click Open.
8) Click Yes to copy the file into the project folder. Click Yes To All to copy the file and all its 

components. NOTE: You can similarly import FrameMaker documents (*.mif, *.fm, *.book, *.bk), 
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PDF documents (*.pdf), Word documents (*.docx, *.docm, *.doc, *.rtf), XML files (*.xml), DITA maps 
(*.ditamap), and DITA topics (*.xml, *.dita).

Copy topics into a project

1) Do one of the following:
– Select Project > Open > Pods > Project Manager. The Project Manager pod appears.
– Select Project > Open > Pods > Topic List. The Topic List pod appears.

2) Select a topic.
3) Right-click and select Duplicate Topic.
4) In the Topic Title box, type the title.
5) If the topic is associated with a master page, it appears in the Master Page pop-up menu. If None 

appears, the topic uses the default style sheet.
6) Click the View icon  to view the master page. Or, browse to a new master page.
7) Click the Appearance tab to change the style sheet.
8) Click OK.

The new topic is appended to the project. It appears in the Project Manager.

View topics and design elements

Preview topics

Preview topics instead of generating an entire project. Click links and Related Topics buttons, see 
Dynamic HTML effects, access frames and forms, and view features.

IMPORTANT: If the topics contain links to PDFs, make sure that Adobe® Acrobat® 10 is installed on your 
computer. Previewing any PDF in Acrobat 9 or earlier versions might not work correctly.

If you have multiple browsers installed on your computer, you can select a browser from the View With 
list from the preview window. RoboHelp displays the topic in the selected browser.
1) Do one of the following:

– Open the topic in the Design view and click the View icon  on the toolbar.
– Right-click the topic in the Topic List pod or the Project Manager pod and select View.

2) (Optional) To preview conditional text areas, choose a conditional build tag expression from the 
menu.
NOTE: To change the CBT while previewing in the browser, change the CBT in the preview dialog and 
click Refresh in the browser.

3) Click View With and select the browser from the list of the browsers installed on your computer.
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Notes

• Certain features, such as See Also controls and Keyword Link controls, do not work in preview mode 
- both in the Preview dialog box and the browser.

• Text-only popups cannot be viewed in Firefox, Chrome, and Safari.
• If you close the Preview dialog box, the topic displayed in the browser appears until you refresh the 

browser.
• (Preview dialog box) The Back and Forward options in the context-sensitive menu help you navigate 

between topics that you open by clicking links in the topic you are previewing. You can also press 
the Backspace key.

• (Preview dialog box) If you change the topic in Design Editor and drag the Preview dialog box, Robo-
Help updates the content to display the new changes.

Define a conditional build expression

1) In the preview window, click Define.
2) Specify tags to exclude from the output:

– To move one tag, select it and click the single arrow button.
– To move all tags, click the double arrow button.

3) (Optional) Click Advanced. Select a conditional build tag from the menu. Click Add Tag. Click the 
AND, OR, or NOT operators to define an expression. Click Clear to remove the expression.

NOT
Excludes topics that use a named conditional build tag. NOT has the highest priority of all the build 
expressions.

AND
Includes or excludes topics that use specified conditional build tags. AND has the second-highest 
priority of all the build expressions.

OR
Includes or excludes topics that use specified conditional build tags.

4) Click OK to return to the preview window.
5) To remove the condition from the preview, select None from the menu.

View design elements

1) Select Edit > View > Show/Hide > [design element].

Design element Appearance in the Design Editor

Bookmarks
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Master pages

NOTE: Master pages replace templates in RoboHelp HTML 7 and earlier.

An HTML page is made up of three elements: content, layout, and styling. For single sourcing, the best 
practice is to separate content from styling and layout. Although CSS files help to separate styling from 
the content, layout remains embedded in the HTML code. By using master pages, you can separate 
layout and styling from the content. A master page contains the layout information and is associated with 
a CSS file.

A master page is a template for HTML topics. You define the placement of headers, footers, and place-
holders for the body, breadcrumbs, and topic TOC. Master pages can include snippets and user-defined 
variables. You can create a topic using a master page or associate an existing topic with a master page. 
When you create a topic using a master page, the body content is placed in the resulting topic. If you 
apply a master page to an existing topic, the body content is ignored.

The layout information defined in the master pages is not visible in Design view. However, you do see the 
CSS of the master page in Design view. You can see the layout when you generate output or a preview. 
The topic content is placed in the body placeholder, and the layout is inherited from the master page. All 
placeholders defined in the master page are also populated with relevant information when you 
generate output.

You can use tables to create a precise layout where each placeholder is placed in a table cell.

Paragraph markers

Table gridlines

Glyphs

Fields

Unknown tags

Conditional areas

Comments

Design element Appearance in the Design Editor
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Body placeholder
When you create a topic from a master page, the topic includes content from the master page. 
Copyright information is an example. When you apply a master page to a topic, actual content of 
the topic replaces the body placeholder at the time of preview and generation.

NOTE: When you apply a master page to a topic, the header and footer of the topic are overridden by 
those of master pages.

Topic TOC placeholder
Shows the automatically generated topic TOC at the time of generation or preview of Help topic. 
Define the exact location and format of the topic TOC by designing the layout of the master page. 
By default, the levels allowed for a TOC layout are heading 2 to heading 6.

Breadcrumbs placeholder
Shows the automatically generated breadcrumbs at the time of generation of Help topic. The 
breadcrumbs are generated based on the TOC. When you preview a topic, actual breadcrumbs links 
are not generated and only the layout of breadcrumbs is visible.

You can apply conditional build tags to the topic TOC and breadcrumbs placeholders but not to the body 
placeholder. However, you can apply a conditional build tag to the content inside or outside the body 
placeholder.

Create a master page

1) Select Output > Master Page > New Master Page.
2) Enter a name for the new master page in the General tab.

NOTE: Master pages have the file name extension .htt.
3) Click the Appearance tab.
4) Select a style sheet to apply to the master page.
5) (Optional) Select the Background Sound options.
6) Click OK.

A new master page shows the body placeholder by default. You can insert topic TOCs by clicking the Topic 
TOC icon  and breadcrumb placeholders by clicking the Breadcrumbs icon  from the toolbar in the 
Design editor of master pages. But this toolbar does not appear for normal pages. You can insert any 
number of topic TOCs or breadcrumbs at any location in the master page.

Create a master page from a topic

1) Open a topic.
2) Do one of the following:

– Right-click in the Design Editor and select Add To > Master Pages.
– Select Output > Master Page > Add Selected Topic To Master Pages
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All the content in the topic is wrapped in the body placeholder. After you add a topic to a master page, 
any new topic created from this master page includes its body placeholder content.

When topics are associated with a master page, the style sheet, header, and footer of the master page 
override style properties of the topic. You can edit or change the CSS of a topic later.
NOTE: Use the Topic Properties option to change the master page associated with a topic.

RELATED LINKS:
Headers, footers, and page breaks

Formatting master pages

When you generate or preview a layout, border and shading properties of the master pages override 
border and shading properties of topics. If the properties do not conflict, they are applied independently. 
For example, if you set border properties for a master page, and background color for a topic, the final 
output topic has both applied to it.

Edit a master page

1) Do one of the following:
– Right-click a master page in the Output Setup pod and select Edit.
– Double click a Master Page in the Output Setup pod.

2) Make the desired changes.

Change the CSS associated with a master page

1) Right-click in a master page and select Properties.
2) Click the Appearance tab.
3) Select a style sheet from the list of style sheets available in a project.
4) Click OK.

NOTE: Select the Used In tab in the Master Page Properties dialog box to see a report of the topics asso-
ciated with the master page.

Insert a placeholder

You can insert placeholders for topic TOCs, breadcrumbs, and topics in master pages. By default, a body 
placeholder is inserted in a new master page.
1) Place the cursor below or after the body placeholder.
2) Select Insert > Page Design > Topic TOC or Breadcrumbs.

NOTE: You cannot insert a placeholder inside a paragraph as inline text or in headers or footers.

RELATED LINKS:
Headers, footers, and page breaks
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Format and edit placeholders

You can format styles in placeholders using the Format Placeholders option from the context menu. 
Open a master page in Design view and do one of the following:
• Right-click a placeholder. Select Format Placeholder.
• Select a placeholder and click the Format Placeholder button  in the Design Editor toolbar.
• Double-click in the placeholder.

Notes:

• If a body placeholder is deleted from the master page or does not appear, the resultant topic has 
its headers appear first (if at all), followed by the HTML content of the master page, the topic 
content, and the footer (if present).

• You cannot apply DHTML effects on the placeholders. The content inside the body placeholder is 
normal HTML content, so you can apply DHTML effects to it.

• You can preview the master pages to see how the placeholder content is displayed in the final 
output. If the associated master page has topic TOC and breadcrumbs placeholders, the topic TOC 
and breadcrumbs are generated at the time of preview or layout generation.

RELATED LINKS:
Add breadcrumbs to topics

Importing master pages

You can import master pages from other projects and apply them to topics in your current project. When 
you upgrade from RoboHelp 7 or earlier, topic templates convert to master pages when you import 
them. Except for the header and footer, all the content in the topic template is wrapped in the body 
placeholder.

Applying master pages

You can apply or change the master page to one or multiple topics at a time. Use this option to change 
the master page of one or more, but not all topics in your project. You can apply the master page to all 
topics when you generate the Help output.

Apply a master page to a topic

1) From the Topic List, right-click the topic, and select Properties.
2) In the Topic Properties dialog box, select the General tab.
3) All the master pages in a project are listed in the Master Page menu. Select a master page and click 

OK. Optionally, you can do the following:
– To preview the selected master page, click the Preview icon.
– To select a master page that is not in the current project, click the Browse button.
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Apply a master page to multiple topics

1) In the topic list, sort the topics by the master page associated with them.
NOTE: If the Master Page column is not visible, right-click a column header, and select Master Page 
from the menu.

2) Select the topics that are associated with the master page that you want to substitute. If you are 
applying master pages for the first time, select the topics that are not associated with a master 
page. You can also select multiple sets of topics with different master pages applied to them.

3) Right-click, and select Properties.
4) In the Topic Properties dialog box, select General tab.
5) Select the master page from the Master Page menu, and click OK.

Applying a master page or CSS at the time of generation

Single-source layouts let you override the master page or the CSS when you generate output. For 
different output results, apply different master pages or a different CSS.

Each single-source layout except the Printed Documentation layout provides an option to apply master 
pages or CSS. You can choose to apply a master page or a CSS across all the topics in a project. NOTE: For 
the Printed Documentation layout, you can apply only a different CSS.
• If you do not select the Apply To All Topics option, the master pages associated with individual 

topics take effect. If no master pages are associated with individual topics, RoboHelp applies no 
master pages when it generates output.

• If you choose to apply a master page, master pages associated with individual topics are over-
ridden. The CSS associated with the master page becomes effective and overrides the CSS associ-
ated with all other individual topics.

• If you choose to apply a CSS, master pages associated with individual topics take effect. The 
selected CSS is applied to all the topics whether any master page is associated with them or not.

Adding headers and footers for printed documentation

You can add headers and footers to the master pages for printed documentation. When you add a 
header and / or a footer, you can added static information. For example, you can add the name of the 
document author to the footer. However, in addition to static information, you can also add information 
specific to the document itself.

To add headers and footers for printed documentation:
1) Go to the Output Setup pod.
2) Expand the Master Pages folder and double-click to open a master page.

Alternatively, to create a new master page, right-click on the Master Pages folder icon and choose 
New Master Page.

3) To add or edit a header to the master page, click the Edit Header icon in the upper-right corner of 
the Master Page pane.
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Similarly, to add or edit a footer to the master page, click the Edit Footer icon in the upper-right cor-
ner of the Master Page pane.

4) In the header or footer, add static content as needed.
5) Besides the static content, you can also add the following variables:

Page Number:
To add a page number to the header or footer, click the Insert Page Number icon in the upper-right 
corner of the Master Page pane.

Chapter Name
To add a chapter to the header or footer, click the Insert Chapter Name icon in the upper-right 
corner of the Master Page pane.

While the static content in the headers and footers of a document display as they are, the page numbers 
and chapter names display dynamically.

Manage topics

Rename a topic

When you rename a topic, the title is updated in the topic properties. Links to the topic still work. Other 
references are not automatically updated. For example, you may need to edit the TOC page title in the 
TOC Editor.

If you create new topics using a master page, topic titles are automatically updated when you change a 
topic title in Topic Properties.
1) Do one of the following:

– Select Project > Open > Pods > Project Manager.
– Select Prjoect > Pods > Topic List.

2) Select a topic.
3) In the toolbar, click the Properties icon . Click the General tab.
4) In the Topic Title box, type the new title.
5) Click OK. The topic title is updated.
6) To change the topic heading, open the topic in the Design Editor. Edit the heading text.

NOTE: To match the file name to the updated topic title, change the file name when you change a topic 
title.

RELATED LINKS:
Rename topic files

Manage files
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Update topic references

If you rename a topic title, make sure that you update the following items as indicated.

Text links
The path of the link is updated, but the link text that is visible to a user is not. If link text in any topics 
includes the topic title, update each topic.

Topic heading
If you want to change the topic heading to match the topic title, change it in the Design Editor.

Table of contents
Update a book or page with the new title. In the Table Of Contents pod, right-click the book or page 
and select Rename. Enter the new title.

Index
If the topic title is an index keyword, update the keyword in the Index pod. Right-click the keyword 
in the upper pane and select Rename. Type the new title.

Add underscores to file names

If topic file names have multiple words, you can set RoboHelp HTML to replace underscores with spaces. 
This convention enables TOC books and pages to synchronize with topic content displayed in the viewer.

Existing file names aren’t affected unless you edit them.
1) Select File > Options.
2) Click the General tab.
3) Select Use Underscores In file names.

Change topic properties

Topics have properties that define their appearance and index keywords. You can change properties for 
a single topic or a group of topics.
1) Do one of the following:

– Right-click one or more topics in the Topic List pod. Select Properties.
– Right-click a topic in the Project Manager pod. Select Properties.
– Right-click a topic in the Design Editor and select Topic Properties.

2) Click a tab and make changes.
3) Click OK.

TIP: Use options on the Status tab to track topic development and manage the project. (To access the 
Status tab, right-click a topic and select properties. On the Topic Properties dialog box, select the Status 
tab.) You can also generate project reports based on properties you set.
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Change topic properties on the Index tab (WebHelp Pro)

Work with keywords referenced by the topic.

Select Index
Select an index to add keywords or view the related referenced keywords.

Index Keywords
Create and edit keywords.

Add
Add a keyword from the Index Keywords text box.

Add Existing
Copy a keyword from other topics.

Delete
Remove a keyword.

Replace
Replace a keyword with text from the text box.

Smart Index
Open the Smart Index wizard.

Properties
Open the General tab. Save the keyword in either the index file or in the current topic.

Changing master pages

To change which master page is applied to a topic, select a master page from the Master Pages menu. 
The default is the last master page applied to the topic. You can view the master page by clicking the View 
button  or browse to a new master page by clicking the Browse button.

RELATED LINKS:
Update the To Do list for a topic

Link a style sheet to topics or master pages

Apply conditional build tags to multiple topics

Identify the browse sequences a topic is assigned to

Fix broken links

Find a topic

Find topics within your project from the Table Of Contents, Index, and Project Manager pods.
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You can search on all or part of a topic title or on topic properties.
1) Click the pod to search:

– To find out which folder a topic is in, click the Project Manager pod.
– To find out where a topic is in the table of contents, click the Table Of Contents pod.
– To find out where a topic is referenced in the index, click the Index pod.
– To find out if a topic is in your project, click the Topic List pod.

2) Select Project > View > Locate Item.
3) To conduct a simple search, click the Search tab and type all or part of the topic title next to Topic 

Title Includes.
4) To conduct an advanced search, click the Advanced tab. You can search according to the following 

options:

Topic Title Includes
Enter text to help you find the topic by title.

File Name Includes
Enter text to help you find the topic by file name.

You can search for the following topic properties:

Status
Click to ignore status in the search or search for topics that are assigned to a specific status.

File Modified
Click to ignore file modification dates or search for files modified before or after specific dates. You 
can enter a date at the right of this option.

Priority
Click to ignore topic priorities in the search or to search for topics based on a specific priority assign-
ment. You can enter a number at the right of this option.

NOTE: Searching by author is not supported.

The Found Topics area has these features:

Found Topics
Displays the topics that match the search criteria. Select a topic from this list to preview it or modify 
its properties.

View button
Displays the selected topic in the Preview window.



152

MANAGE TOPICS
CHAPTER 4 WORKING WITH TOPICS

By Title
Click to search for text in topic titles instead of in file names.

Topics Containing <item>
Displays the topics that match the search criteria. Select a topic from this list to preview it or modify 
its properties.

Locate topics or images in Project manager

If you are currently working on a topic or a snippet, you can locate where the topic or snippet exists in 
the RoboHelp project. Or where the selected image exists within the topic. You can also locate a selected 
image in the Project manager.
1) In the Project ribbon, click on Locate Item .

The topic, snippet, or image displays selected in the Project manager pod.

Assign a default topic

The default topic appears in the Topic panel when the Help system is opened.
1) In the Single Source Layouts pod, right-click the layout. Select Properties.
2) Next to the Default Topic box, click Select.
3) Select a topic. Click OK.
4) Click Save.
5) Generate and view the layout.

Track topic status

The status of new topics is In Progress by default. You can change this status as you work.

Status information is used in the Project Status report.
1) In the Topic List pod, select topics.
2) Click the Properties button .
3) Click the Status tab.
4) Set options as needed:

Status
Click the triangle  to select a development stage.

Priority
Enter a number.

Hours
Enter a number to assign estimated or actual hours of topic development.
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To Do list
Select items as you complete them.

Comments
Enter text.

RELATED LINKS:
Generate and customize reports

View and manage topic details in the Topics List pod

1) In the Topic List pod, do any of the following:
– To view details about topics, choose Project > View Item.
– To sort topics, click the column header.
– To select details to appear in the Topic List pod, right-click a column header, select More, and 

select the details.
– To view or update topic properties, select one or more topics and click the Properties 

button .
– To create topic references, drag topics from the list to create a table of contents, index, and 

See Also keywords.

RELATED LINKS:
Reports

Work with the Tag list

The Tag list in Design view shows the hierarchical structure of the HTML page. The top of the hierarchy 
is on the left (always the document). The currently selected item is on the right.
• To display the Tag list, select Edit > View > Show/Hide > Tag list.
• To select an item in Design Editor, click the item in the Tag list.
• To edit the properties of an item in the Tag list, double-click the item. Set options.

Specify formatting attributes to remove:

Tag
HTML tag that creates the specified format type.

Text
Text to which the formatting is applied.

Class
Class (style specified in the style sheet) used in the HTML tag. Not all tags have classes assigned.
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Id
ID (tag for JavaScript or Dynamic HTML) used in the HTML tag. Not all tags have IDs assigned.

Check spelling and find and replace

NOTE: If your project is localized, the spelling checker uses a dictionary in the selected language.

Check spelling in the TOC, index, see also list, or glossary

When the spelling checker finds an error, you can ignore the word, change it, or add it to the dictionary.
1) Open the component you want to check.
2) Select Tools, and then select Spell Check TOC, Index, See Also, or Glossary.
3) Select a suggested word or type a replacement in Not In Dictionary.
4) Select options.
5) To add a word to the custom dictionary, click Add.

NOTE: Online glossaries are available with WebHelp and Microsoft HTML Help.

Specify spelling options

1) Select Review > Spelling Options and select from the following sets of options:

Main Options

Check Spelling As You Type
Checks for misspelled words as you type.

Auto-Correct When Possible
Corrects misspelled words as you type. To view a list of typically misspelled words, open the Dictio-
nary Editor dialog box.

Match Case
Searches for uppercase or lowercase as indicated.

NOTE: The Auto-Correct When Possible and Match Case options do not work if you do not select the Check 
Spelling As You Type option.

Special Options

Ignore All Uppercased Words
Ignores all uppercase words.
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Ignore Mixed Letters/Digits
Ignores strings containing both letters and digits.

Ignore Doubles
Ignores repeated words.

User Dictionary
Lets you modify the existing dictionary.

Auto-correct spelling options

Auto-correction is possible only if you select the Auto-Correct When Possible option and the Check 
Spelling As You Type option in the Spelling Options dialog box. (Select Review > Spelling Options). You 
can define misspellings along with the correct version. For example, you can add ”r;adn” as a misspelling 
and define the correct spelling as ”random.”
NOTE: Misspellings are not predefined; be sure to add them explicitly. This feature is Unicode-compliant. 
You can add words in any language, including Russian and Japanese, in the same project, a topic, or a 
paragraph.

Replace
Specify a misspelling in the Replace box.

With
Specify the correct word in the With box.

Add
Click to add the word to the Auto-Correct list.

Delete
Click to delete the misspelled entries.

Cancel
Cancels any changes made in the dialog box fields.

OK
Click to save the changes made in the dialog box fields.

View Ignore Words list

1) Select the Ignored Words tab. Use this dialog box to view the list of words ignored during spelling 
checks.

Ignored Words
Lists words ignored during the spelling check.
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Delete All
Click to delete all words from the Ignored Words list.

Delete
Click to delete the selected words from the Ignored Words list.

Check spelling in topics or projects

1) Open a topic in the Design Editor. Do one of the following:
– Select Review > Spell Check.
– Select Review > Spell Check All Topics. (Optional) Click Skip Topic.
– Select Review > Spell Check Project. (Optional) Click Skip.

2) Select a suggested word or type a replacement in Not In Dictionary.
3) Select options as needed.
4) To add the word to the custom dictionary, click Add.

Spelling check options for topics

Not In Dictionary
Display the questionable word.

Suggestions
Display a list of suggested spellings for the word.

TIP: If a word is not listed, enter the correct spelling in Not In Dictionary.

Add
Add the word to the dictionary.

Ignore
Skip the word and continue the spelling check.

Ignore All
Add the word to the Ignore Word list.

Change
Replace the word displayed in Not In Dictionary with the word selected in Suggestions.

Change All
Replace all occurrences of the word displayed in Not in Dictionary with the word selected in Sugges-
tions.
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Close
End the spelling check and close the dialog box.

NOTE: The Spell Check tool works for the language selected. If the selected language does not support the 
Spell Check tool, the tool is disabled in the Tools menu.

Spelling check options for projects

Currently Checking
Display the topic currently being checked.

Skip
Skip the current topic.

Not In Dictionary
Display the word not found in the dictionary.

Add
Add the word to the dictionary.

Suggestions
Show a list of words similar to the word not in the dictionary.

Ignore
Ignore the word not found in the dictionary.

Ignore All
Ignore all the suggestions for the selected word.

Change
Replace the word under Not In Dictionary with the one in the Suggestions list.

Change All
Change all the instances of the word.

NOTE: Words are added to the custom dictionary of the language the project is using.

RELATED LINKS:
Authoring content in multiple languages

Customize a dictionary

Use the Dictionary Editor to add words, for example, “RoboHelp,” to your dictionary. The dictionary is 
specific to the language and the user. Every language has its own dictionary, and every user can save 
changes to the dictionary.
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NOTE: The Dictionary Editor is case sensitive.
1) Select Review > Spelling Options.
2) Click the Options tab.
3) Click Modify.
4) In the Dictionary Editor, under Word, type a new entry and click Add. To delete an entry, select it 

and click Delete.
NOTE: You cannot cancel additions or deletions made in the Dictionary Editor, so the Cancel button 
is disabled.

Use the thesaurus

1) In the Design Editor, open a topic.
2) Select a word.
3) Select Review > Thesaurus.
4) Select a synonym or antonym and click Replace.

Looked Up
Display the word selected in the topic or type a word to look up.

Replace With
Display a suggested replacement for the word.

Category
Display the meaning of the word and its part of speech. If more than one category appears, select 
one to see different synonyms.

Synonym
Display words that are equivalent alternatives to the selected word. Select a word to replace the 
word you looked up.

Replace
Replace the current word with the new one.

Look Up
Adds words in the Look Up pop-up menu.

Close
Close the dialog box.

Find and replace

The Find and Replace feature in RoboHelp allows you to search for (and optionally replace) text, HTML 
tags, and attributes in the current topic, the current project or across files and folders in a specified path. 
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You can search for text in the HTML editor, indexes, and TOCs in a project. This means that you can search 
for text in the Index and Table of Contents pods. In addition, the replace functionality allows you to 
replace the text in these pod.

In the Find and Replace pod, you set the search options. RoboHelp then displays the results in the Find 
Results pod and also lets you open each modified file in the Find Results Editor pod (HTML view). Also, 
when you perform the replace operation, RoboHelp provides the option to back up the files in which text 
replace occurred.
NOTE: The tool works best with text files.

Set Find and Replace options

1) Press Ctrl+Shift+F or do one of the following:
– In the Project ribbon, click Find and Replace.
– In the Pods drop-down list of the Project, Edit, or Review ribbons, choose Find and Replace

2) Specify what to find in one of the following ways:
– (Basic mode) Type the text, tag, or attribute that you want to search in the Find What 

box. NOTE: To find text such as Windows Desktop across multiple lines, type 
Windows(.|\n)*Desktop and make sure that you select Use Regular Expression.

– (Advanced mode) Click the Advanced Mode icon. Select the filters and specify the text, tag, or 
attribute for RoboHelp to build a regular expression.

Begins With
Specify phrases, words, or characters that should occur in the beginning of found instances.

Ends With
Specify phrases, words, or characters that should occur in the end of found instances.

Contains
Specify phrases, words, or characters that found instances should contain.

Does Not Contain
Specify phrases, words, or characters that found instances should not contain.

NOTE: In Advanced mode, the Multifile Find and Replace tool performs multiline search.

3) Type the text, tag, or attribute that you want to replace in the Replace With box.
If you want to search without replacing, leave the Replace With box empty.

4) Use the Look In option to search in the following:

Current Project
(Default) Search within the current project.

Current Window
Search in the current topic
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Opened Files
Search all files currently opened in RoboHelp.

Path
Search all files in the selected folder path.

NOTE: When searching in a selected path, RoboHelp only searches for files that appear in the File 
Status pod (Project > Open > Pods > File Status).

5) To confine your search to specific file types within the current project, or the files or folders you 
have selected in the previous step, use the Files Of Type option.
NOTE: The Find and Replace features works best with text files.

6) (Optional) Use the following options to limit or filter your search:

Match Case
Searches text that exactly matches the case of the text that you want to find. For example, if you 
want to search for the quick fox, you will not find the The Quick Fox.

Use Regular Expression
Lets you use MS Word-style or UNIX-style expressions to be interpreted as regular expression oper-
ators. For more information, see Use Microsoft-style regular expressions.

Use WildCards
Lets you use wildcard characters (such as *,?) to represent one or more characters when you are 
searching. For example, index* locates all instances of the word index as well as all files that 
begin with index, like index.doc and index.txt. NOTE: When you use wildcards or regular 
expressions, the Match Whole Word and Ignore HTML tags options are unavailable to indicate that 
these options are automatically turned off. You can’t turn on these options.

Match Whole Word
Searches for text that matches one or more complete words. For example, if you enter nation as 
the search term, you will not find explanation.

Exclude HTML Tags
Searches for a specific text string only in the content, ignoring any occurrence in HTML tags. For 
example, a search for the string title will only find occurrences of the string in the content and 
not in HTML tags, such as <title>.

NOTE: If you want to search for attributes, deselect the Exclude HTML Tags option.

7) (Optional) Use the following options while replacing text in files.

Backup Modified Files
Backs up the original files before replacing text
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Overwrite Backups
Lets you overwrite existing backups when you select Make Backups

Open Modified Files After Replace All
Opens each modified file in HTML Editor after replacing the text. You can review the changes, undo 
the changes if required, and save the file.

NOTE: If this option is not selected, RoboHelp saves each modified file after replacing all instances.

8) To search without replacing, click Find All or Find Next. 

Find Next
Searches iteratively across files. This implies that if your search found occurrences in multiple files, 
the first file is opened with the first occurrence of the result selected. If you use Find Next, Robo-
Help first navigates over the occurrences within the current file. After all the occurrences in the file 
are navigated, RoboHelp opens the next file. RoboHelp continues this way across all files that 
contain occurrences of the search. You can specify the direction of the search as forward or back-
ward.

Find All
Displays all occurrences of the search text or tags in the Find Results pod.

The results of the search are displayed in the Find Results pod. For more information, see Viewing 
Find results.

9) To replace found text or tags, click Replace All or Replace.

Use Microsoft-style regular expressions

RoboHelp supports various Microsoft-style regular expressions like the following:

?
c?rd finds card and cord

*
r*m finds ram and random

[ ]
[cg]lass finds class and glass

[-]
[c-g]lip finds clip and flip

@
ste@p finds step and steep
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For more information, see Microsoft-style regular expressions and these examples available on Peter 
Grainge'ssite.

Viewing Find results

The Multifile Find and Replace tool displays the results in the Find Results pod.

To view the Find Results pod, do the following:
1) Select Project > Open > Pods > Find Results.

The Find Results pod displays the files in which the search text appears. The line number and column 
number help you locate the searched or replaced text in a topic.
Use the following options to navigate and replace quickly:

Search box
Allows you to specify a criterion for searching through the results. The search functionality allows 
you to search by any field in the result list. This means that you can search by file name, file name, 
line number, or file path.

View
Displays the contents of the selected file in the browser.

Edit
Opens the selected file in the Find And Replace Editor. If no result is selected, the first match will 
be highlighted. Otherwise, the selected result is highlighted.

Cancel
Cancels search.

Toggle Scrolling
Toggles between autoscrolling to display the last found match and stopping at the last displayed 
match.

Replace All
Replaces all instances of the match.

W3C compliance

You can validate XHTML or HTML topics for World Wide Web Consortium (W3C) compliance and view 
error messages, informative messages, or warnings. You can validate the following for W3C compliance:

Topics
Right-click a topic in the Project Manager pod and select Validate W3C Compliance.

http://msdn.microsoft.com/en-us/library/bb982727.aspx
http://grainge.org/pages/authoring/regex/regular_expressions.htm
http://grainge.org/pages/authoring/regex/regular_expressions.htm
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Project
Right-click Project Files in the Project Manager pod and select Validate W3C Compliance.

RoboHelp validates all the HTML/XHTML topics and shows warnings or error messages for any 
non-compliance in the Output View pod and Error List pod. RoboHelp displays errors, warnings, and 
information in different situations:
• Errors appear if you have added an incorrect tag or if you have not closed a tag.
• Warnings appear if a tag is not valid for XHTML.
• Information appears when all topics are validated.

NOTE: You can double-click an error or a warning message in the Error List pod to open it. When you place 
the cursor on an error in the Error List pod, it shows the line of the topic where the error occurred.

Reference

General pane for Oracle projects

The General pane applies to the Topic Properties and New Topic dialog boxes in Oracle Help projects.

Use the General pane to create topic titles and file names.

Topic Title
Displays in the viewer, or when viewing topics by titles in the Project Manager.

File Name
Name of the topic file (default is based on the title). Displays when viewing topics by file names in 
the Project Manager.

TIP: You can automatically save file names using underscores, letting you synchronize the TOC book and 
pages in the Contents tab with content in the viewing pane.

Template
Displays or selects a template for a topic. Select None to use formatting from the default style 
sheet. To view the displayed template, click the View button.

Editor (For Topic Properties)
Shows the HTML editor for the project. Change this setting to use one other than the RoboHelp 
Design Editor.

NOTE: Oracle Help uses topic IDs (in a map file) to make context-sensitive Help calls. You can change the 
ID by editing the topic META tag.

RELATED LINKS:
Add underscores to file names
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Editing and formatting

RoboHelp editors

RoboHelp provides two editors by default: Design Editor and HTML Editor. You can also use third-party 
editors to edit their respective documents. For example, you can use Microsoft Word to edit a Word 
document linked to a project.

RoboHelp Design Editor

When you select a topic file from the Project Manager pod, the topic opens in Design Editor. Use the 
RoboHelp Design Editor to perform word-processing tasks and to insert online elements, such as links, 
multimedia, Dynamic HTML, and See Also/Related Topics buttons. You can also add index keywords to 
topics, apply conditional text, create browse sequences, map IDs, and edit master pages.

You can edit any standard XHTML or HTML file in Design Editor. (You can import stand-alone HTML files 
into a project and edit them). NOTE: To switch to HTML Editor from Design Editor, click the HTML tab.

RoboHelp HTML Editor

You can author topics in RoboHelp by writing XHTML code in the RoboHelp HTML Editor. RoboHelp HTML 
Editor is a text editor for XHTML and HTML tags and text.

Open RoboHelp HTML Editor

1) Select a topic file from the Project Manager pod. The topic opens in Design Editor.
2) Click the HTML tab to view the HTML code for the topic.

Undo a change

1) Click the Undo The Last Action button.
NOTE: If you switch views after making a change, you can’t undo the change.

View line numbers

1) Right-click the body of the topic and select Line Numbers.
All code lines are numbered in the HTML Editor.

Add keyword expansions

Keyword expansions allow matching keywords to appear for text you type in the editor. The closest 
match is highlighted. Click an entry in the list to insert it.

For example, suppose you add "RoboHelp" as an expansion. When you type "R", a list of keywords that 
begin with "R" appears. When you type the next letter "o," the keyword "RoboHelp" is highlighted. Click 
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it to insert it in the HTML Editor. Text assigned to this keyword (for example, Adobe RoboHelp) appears 
in the HTML Editor.
NOTE: If the characters you enter do not have a matching keyword, the pop-up window disappears.

You can add keyword expansions in the HTML Editor.
1) In the HTML Editor, right-click and select Edit Expansions.
2) Click New.
3) (Optional) Enter a new keyword in the Keyword box.
4) Enter a caption for the keyword in the Caption box.
5) Enter some text in the Text To Insert text area. This text appears when you select a keyword from 

the list in the HTML Editor.
6) Click OK.

Change code color

You can change the color of code in the RoboHelp HTML Editor. However, the content text is always 
black.
1) In HTML view, right-click and select Colors.
2) In the Color Table dialog box, select an item and specify a color for the text, highlight, or both.
3) Click OK.

RELATED LINKS:
Modify colors

Third-party HTML editors

Using RoboHelp with other HTML editors

When using RoboHelp with a third-party HTML editor, note the following details:
• You can edit HTML in another editor while RoboHelp is open. When you open a topic in a 

third-party HTML editor, RoboHelp functionality is not available. You can insert HTML code and 
elements, but you can’t insert or edit RoboHelp features, such as text-only pop-ups or link controls.

• Close files in the third-party editor before opening them in RoboHelp.
• If you insert an image using a third-party editor, add the image to the project Baggage Files folder. 

The same is true for JavaScript-based special effects with images, including accompanying .js files.

Add an HTML editor

For a list of detected HTML editors, select File > Options > Associations.
1) Select File > Options.
2) Click the Associations tab. Click Add in the HTML Editors area.
3) Do either of the following: Type the name of the HTML editor. Press Enter.

– Select an editor from the Recommended Programs or Other Programs folder. The Name and 
Location boxes display the information for the selected program.
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– Click the browse button  . Select the EXE file for the HTML editor and click Open. Type a 
name for the editor.

NOTE: If you install a new HTML editor, you can’t add it until you restart RoboHelp.

Remove or rename an HTML editor

1) Select File > Options.
2) Click the Associations tab.
3) Select an editor. Click Edit.

– To rename the editor, click Edit and type a name in the Name box.
– To remove the editor, click Remove.

NOTE: RoboHelp Design Editor, RoboHelp HTML Editor, and Windows Notepad cannot be 
changed or removed from the list.

Auto-select an HTML editor or set a default

RoboHelp can automatically open a third-party HTML editor for you. RoboHelp detects the editor to open 
based on the HTML file itself. The Auto Select option also lets you associate an editor with its own 
Meta/Generator tag to automatically open topics with the editor that created them. NOTE: To find out the 
editor associated with an installation of RoboHelp, select File > Options and check the default editor 
setting on the Associations tab.

You can set a default HTML editor. The default editor is used for creating new topics, even if the 
auto-select feature is enabled.
1) Select File > Options.
2) Click the Associations tab. Do one or more of the following.

– Select Use Default Editor. Click Set As Default.
– Select Auto Select Editor.

3) To change the associations between editor and tag, select Auto Select. You can change the HTML 
editor but not the Generator tag. You cannot remove the tags either. Choose from these Generator 
tags:

<None>
The editor associated with this tag is used for files with no Meta/Generator tag.

<Unknown>
The editor associated with this tag is used for files with Meta/Generator tags not in the Associations 
HTML Editors list.

<Robohelp>
The editor associated with this tag is used for files created with all versions of RoboHelp.

Change the associations between editor and tag using the following options:
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Add
Associate an editor and a Meta/Generator tag.

Remove
Remove an association between an editor and a Meta/Generator tag.

Set Editor
Display the editors in the Associations tab. Change associations between editors and Meta/Gener-
ator tags.

Set Tag
Modify associations between Meta/Generator tags and editors by typing a Meta/Generator tag in 
the field or browsing to an HTML file that contains the Meta/Generator tag.

4) Click OK when you finish.

Notes:

• You can also use third-party HTML editors on a topic-by-topic basis, even if you set a default editor. 
Right-click the topic in the Project Manager pod or the Topic List pod and select Edit With.

• All editors must be associated with a Meta/Generator tag.

Specify an editor for new topics

Specify the default editor for new topics.
1) In the Project Manager pod, right-click a topic. Select New > Topic With.
2) Select an editor. Click OK. Click the General tab, and specify options.
3) Select File > Options. Click the Associations tab. Select Use Default Editor.

Character formatting and fonts

If you format characters using the Edit toolbar or the Edit > Character Formatting > Font option, you 
create inline styles. Inline styles override style sheets. For repeated use, create or modify a character 
style in a style sheet.

Apply or remove character formatting

1) Select the text to format. Do one of the following:
– In the toolbar, click the tool for the formatting option.
– Choose Edit > Character > Character Formatting > Font.
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Apply color to text

1) Select text.
2) In the Edit toolbar, click the arrow on the Change Font Color button .
3) Click a color swatch, or click More Colors to select from additional swatches or to apply a custom 

color.

RELATED LINKS:
Create styles for style sheets

Define advanced font options

1) Select Edit > Character > Character Formatting > Font.
2) Click Advanced.

You can define the following advanced options for fonts:

Style
Specifies that the font is displayed in either normal, italic, or oblique

Weight
Defines the font weight property (to make it appear lighter or darker). The bolder and lighter values 
are relative to the inherited font weight, while the other values are absolute font weights. Not all 
fonts have all the possible display weights.

Overline
Inserts a line above the selected text.

Preview
Shows a Design Editor representation of how your text looks with the selected font options. The 
view updates as you apply different settings at the tab.

Change character spacing

1) Select Edit > Character > Character Formatting > Font.
2) Click the Spacing tab.
3) Select Normal, Expand, or Compress. Set options:

By
(For Expand or Compress) Specify the amount of space between characters.

Position
Specify a location for the text.
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4) Click OK.

Change font size

1) Select the text.
2) In the toolbar, select a font size.

TIP: You can also change font sizes in navigation panes using the WebHelp Skin Editor.

Create a font set

A font set is a collection of fonts to apply in style sheets or character and paragraph formatting. For 
example, you can create a font set with Verdana as the first font, and then (in order) Arial® and Sans Serif 
as substitute fonts. If users do not have Verdana installed, the viewer uses Arial and then Sans Serif.
1) Select Edit > Character > Character Formatting > Font Sets.
2) Click New, type a name, and click Modify. Select the first font, and click Add.

NOTE: Font sets are saved with projects.

Apply a font set to text

1) Open a topic in the Design view. Select the text to format.
2) Select a font.

Change font sets

1) Select Edit > Character > Character Formatting > Font Sets.
2) Select a font.
3) Click Modify.
4) Add fonts from Available Typefaces or delete them from Font Set Selections.
5) Click OK.

Remove font sets

NOTE: Before removing a font set, reformat all text that uses that font set. If you don't, the font set you 
remove is re-created.
1) Select Edit > Character > Character Formatting > Font Sets.
2) Select the font to remove.
3) Click Delete.
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Insert symbols and special characters

1) Open a topic in the Design Editor. Select a location for the character.
2) Select Insert > Media > Symbol.
3) Double-click the symbol.

Insert a non-breaking space

1) Place the insertion point where you want the non-breaking space. Press Ctrl+Alt+spacebar.

Format paragraphs

If you format a paragraph using the Edit toolbar or the Edit > Paragraph > Paragraph Formatting > Para-
graph option, you create inline styles. Inline styles override style sheets. For repeated use, create or 
modify a paragraph style in a style sheet.

Align paragraphs

1) Open a topic in the Design view. Select the paragraph to align.
2) From the toolbar, click an alignment button.

Indent paragraphs

1) Click in the paragraph.
2) Do one of the following:

– In the toolbar, click the Decrease Indent  or the Increase Indent button  in the toolbar.
– Select Edit > Paragraph > Paragraph Formatting > Paragraph. Set indents:

• For a left or right margin indent, click Up or Down and select a number from the list.
• For a first line indent, click the triangle under Special and select First Line. Under By, click 

Up or Down and select a number from the list.
• For a hanging indent, click the triangle under Special and select Hanging. Under By, click 

Up or Down and select a number from the list.

Indent text lines

1) Select Edit > View > Show/Hide > Ruler.
2) In the Design Editor, insert your cursor where you want to create the indent or select the text you 

want to change.
3) On the ruler, do one of the following:

– To create a hanging indent, drag the lower marker where you want the indent to start.
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Marker position for a hanging indent

– To create a first-line indent, drag the upper marker to the position where you want the text 
to start.

Marker position for a first-line indent

Change margins

Follow this procedure if you want to change a single topic. Otherwise, use a style sheet.
1) Select Edit > View > Show/Hide > Ruler.
2) In the Design Editor, insert your cursor where you want to change the margins or select the text to 

change.
3) Drag the margin markers on the ruler.

Tips:

• In tables, apply margin settings to each cell as you move your cursor through the table.
• To specify exact margin measurements, select Edit > Paragraph > Paragraph Formatting > Para-

graph.
• To specify a margin setting that affects a certain style, modify your style sheet.
• Right-click the ruler to access the Snap To Tick Marks option. Select it and drag the markers on the 

ruler so they align with the tick marks on the ruler. To move the markers in smaller increments, 
deselect Snap To Tick Marks.

RELATED LINKS:
Create styles for style sheets

Change the unit of measure for the ruler

1) Select Edit > View > Show/Hide > Ruler.
2) Right-click the ruler.
3) Select a unit of measure.

Define a language for a paragraph

Select a language for the paragraph. If no language is selected, the project language applies to the para-
graph.
1) Right-click and select Paragraph. Select a language from the Language menu.

RELATED LINKS:
Support for multiple languages
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Apply text wrapping

1) In the Design Editor, double-click an object.
2) Under Text Wrapping, select an option.

NOTE: To use Around (For Tables), the table must be left- or right-aligned.
3) (Optional) To set spacing between the object and surrounding text, click Margins.

– Enter values for the amount of space between the selected object and the surrounding text.
– Set the spacing between text and object or by entering an amount in inches. Depending on 

whether you select left or right text wrapping, you can enter the spacing for All Sides or 
Left/Right and Top/Bottom.

4) Click OK.

Notes:

• Tables must be left- or right-aligned to use text wrapping, and they must be less than 100% in size.
• If text wrapping is applied around an image, the image cannot be aligned.

Adjust line spacing

1) Select Edit > Paragraph > Paragraph Formatting > Paragraph.
2) Set Spacing options:

Before
Specify the amount of space above each paragraph.

After
Specify the amount of space after each paragraph.

At
(for Multiple and Exactly) Enter the spacing (in points) between selected lines.

3) Click OK.

Add line breaks to paragraphs

A manual line break ends the current line and aligns the text on the next line.
1) Open the topic in the Design Editor. Click where you want the line break.
2) Select Insert > Page Design > Line Break. Alternatively, press Shift + Enter.

Borders, backgrounds, color, and sound

Applying formatting without styles creates inline styles. Inline styles override style sheets.
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Add or edit borders and backgrounds in topics

1) Open a topic. Select the topic or topic elements, such as paragraphs or table cells.
2) Select Edit > Paragraph > Paragraph Formatting > Borders And Shading.
3) Click the Borders or Shading tab.
4) Specify border or shading options. Click OK.
5) Click the Save All button .

RELATED LINKS:
Add or edit borders or backgrounds in style sheets

Add borders to images

1) In the Design Editor, double-click the image.
2) Click the Image tab. Click Borders.
3) Set border options.
4) Click OK.

RELATED LINKS:
Add or edit borders or backgrounds in style sheets

Remove borders or backgrounds

1) Open a topic.
2) Select the item with the border or shading.
3) Do one or more of the following:

– In the toolbar, click the Border Type button  and select the option for no border.
– In the toolbar, click the Fill Color button  and select None.
– Select Edit > Paragraph > Paragraph Formatting > Borders And Shading. Click the Borders or 

Shading tab. Set the border to None or the fill color to Transparent. To remove a background 
image, remove the image name from the Image box in the Pattern area.

Add or delete horizontal lines

Add a horizontal line

You can insert a GIF image of a horizontal line or use the following procedures to add and change lines.
1) Open the topic in the Design view, and click where you want to add the line.
2) Select Insert > HTML > Text Box > Horizontal Line.
3) Select line options.

– To change line length, enter a value in Width.
– To change line thickness, enter a value in Height. (The lower the number, the narrower the 

line.)



174

BORDERS, BACKGROUNDS, COLOR, AND SOUND
CHAPTER 5 EDITING AND FORMATTING

– To specify alignment, select a line position.
– To change line color, click Custom and select a color.
– To add margins, click Margins and choose options.
– To add a border, click Border and choose options.

Delete a horizontal line

Select the line and click the Delete button .

Modify colors

1) Select Edit > Character > Character Formatting > Colors.
2) Click New. Type a name for the color.
3) Click Modify. Do one or more of the following:

– Click a basic color swatch.
– Click the color spectrum box and the vertical color bar to adjust the amount of black and white 

in the color.
– Specify values for Hue, Saturation, and Luminosity. Enter values from 0 to 255.
– Specify values for Red, Green, and Blue. Enter values from 0 to 255.
– Drag the slider to adjust the luminosity.
– Select Snap To Safe to change the selected color to the closest web-safe color.

Remove colors

NOTE: Before you remove a color, reformat any text using it.
1) Select Edit > Character > Character Formatting > Colors.
2) Select the color to remove.
3) Click Delete.

Add sound to topics

1) From the Topic List pod, select one or more topics.
2) Click the Properties button.
3) Click the Appearance tab.
4) In the Background Sound box, enter the name of the sound file. The following formats are 

supported:

.au
Used on UNIX systems. Supported by Microsoft Windows and HTML Help.
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.mid, .rmi
Musical Instrument Digital Interface. Standard for synthesized sound from electronic instruments.

.wav
The native sound format for Windows.

5) In the Sound Loop Count box, enter the number of times to play the sound file.

Tables

About tables

In RoboHelp for HTML, you can create tables to organize complex data in a simplified format. You can 
organize various elements in a table, segregate them using different colors, or draw patterns for easy 
identification of different elements in a group.

Table styles allow you to choose different formats for tables. Styles can define header rows and columns, 
first or last rows, repeatable groups of rows or columns, margins within cells, and so on. Using Table 
properties, you can set margins in a table, define width and height of various cells and select different 
table styles. In addition to using the predefined table styles in RoboHelp for HTML, you can create your 
own table styles to display for different kinds of data. For example, you can have simple tables showing 
salary components or tables displaying the sum of salary components, tax deductions including tax 
saving investments. You can have some global table styles, which can be used across multiple topics.

You can import tables from FrameMaker and Word documents and map their table styles to RoboHelp 
table styles or retain the original styles from other formats.

You can add text in tables. You can add cross-references, images, hypertext links to the content in a table. 
You can apply conditional build tags to rows or columns to hide or show them in certain outputs. For 
example, you can have a table describing features for each of the RoboHelp outputs. You can apply a 
conditional build tag on each column listing the features for the specific output and display only if you 
generate that output.

Support for topic TOCs and breadcrumbs in Tables make them more useful for displaying content in an 
organized and user-friendly fashion.

Workflow for creating a table

1) Insert a table using the toolbar or the Table menu. Then select the number of rows and columns in 
the table grid.
See Insert tables.

2) Select a global style to apply on the table. You can also create your own table styles using the Edit 
> Styles tab.
NOTE: If you do not select a table style, a default table style is applied to the table.
See Table styles.
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3) Change the table properties in the Table properties dialog box. You can set the margins, align cells 
in the table, and apply shading and borders to the table.
See Edit tables.

Insert tables

You can insert a table anywhere in a topic or a master page, including headers and footers. You can also 
insert a table within a table. You can apply different table properties to the inserted table to display 
complex data.

Insert a basic table

1) Click where you want the table.
2) Choose Insert > Table.
3) On the table grid, drag to determine the columns and rows to add.
4) Click to insert the table.

Insert a custom table

1) Click where you want to add the table.
2) Select Insert > Table.
3) Specify the number of rows and columns.
4) Select a table template, or select a custom style from CSS Styles.
5) Click OK.

TIP: To add a line below a table, click inside the lower-right cell of the table. When the cursor is blinking, 
press the Right or Down Arrow. Press Enter to begin a new line.

Inserting tables within tables

When you insert a table within a table, the second table resides in a single cell within the first table. You 
can change the table properties individually to differentiate the information.

The second table is 100% of the width of the cell in which you insert it. You can change this setting after 
you insert it.

Copy and paste tables

You can cut, copy, and paste tables.
1) Select the dotted outline around the table. Boxes around the table indicate that it is selected.
2) Right-click. Select Copy, or select Cut to move the table.
3) Right-click the destination. Select Paste.

TIP: To add a line below a table, click inside the lower-right cell of the table. When the cursor is blinking, 
press the Right or Down Arrow. Press Enter to begin a new line.
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Edit tables

For a demonstration of table editing, see the Table manipulation section of the Easy ways to create and 
manage tables and tablestyling video.

Insert table rows or columns

• Click in a table. Select Format Row or Column.
• To insert multiple rows or columns, select multiple cells in the table. Select Format > Insert > Row 

or Column.
• Select rows or columns. Copy or cut the selection, and paste it at the new location.
• Remove tables or parts of a table. To remove a table, row, a column or a cell, select and right-click. 

Select Delete [object].

NOTE: You can also cut, copy, and paste rows, columns, and cells within the same table or other tables.

Edit table properties

1) Click a table.
2) Select Format > Table > Properties.
3) Set options.

Set autofit table properties

1) Click a table.
2) Select Format > Size > AutoFit Contents.

Sets the column width to the width of the column contents.
3) OR

Select Format > Size > AutoFit Window.
Sets the column width to a fixed size.

Edit cell properties

To edit cell properties, you can place your cursor inside the table and click Format > Table > Properties > 
Cell tab.
• You can enter the amount of space between cells. If a CSS table style has the cell spacing set or row 

or column formatting done, this option is not enabled in Table Properties > Cell.
• Select the vertical alignment of the text within an individual cell.

NOTE: Setting the alignment and cell spacing using the Cell tab applies to all cells in the table.

http://www.adobe.com/designcenter/robohelp/videos/
http://www.adobe.com/designcenter/robohelp/videos/
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Edit spacing within cells

Define the amount of space between the cell contents and its inside edges. Add extra padding to prevent 
your tables from looking crowded.
1) Select one or more cells to modify.
2) Click Edit > Paragraph > Paragraph Formatting > Borders and Shading.
3) Click Borders tab. Click Padding.
4) In the Top, Bottom, Left, and Right boxes, enter a value.
5) Click OK twice to apply changes.

NOTE: The Margins option sets the spacing around the table.

Merge or split table cells

1) Select the cells to merge or split.
2) Select Format > Merge > Merge or Format > Split Cells.

TIP: You can split a cell into numerous rows and columns to create a table.

RELATED LINKS:
Table styles

Lists

Indent lists

1) Select the list items to indent. Do one of the following:
– Click Decrease Indent and Increase Indent in the toolbar.

NOTE: You can also press Shift+Tab and Tab to decrease and increase indent.
– From the Format menu, select Paragraph. Type a number in Left or Right.
– (Multilevel list) On the ruler, drag the markers to set the spacing between the number or 

letter and the list item.

Apply bullet styles

NOTE: When you format lists using the toolbar or Format menu, inline styles are created. Style sheets 
aren’t affected.

Specify an inline bullet style

1) Open the topic in the Design Editor.
2) Select text.
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3) Right-click on the list and choose Bullets And Numbering.
4) Do one of the following:

– Select a bullet style.
– To create a custom bullet, click Browse. Select a GIF file. Click OK. The file is added to Baggage 

Files.

Create a bullet style for a style sheet

1) Open the topic to customize a bullet style.
2) From the Format menu, select Styles.
3) In List, select All Styles.
4) From Available In, select an external or embedded style sheet.
5) From the Styles list, select a style and click the Create New Style button .
6) Under Style Type, select Paragraph Style.
7) Type a name for the new style. The name can contain letters and numbers only and cannot begin 

with a number.
8) Under Style For Following Paragraph, select (No Change).
9) Click Format and specify settings.

Match bullet color to text

Match color using an inline style

1) Select the bulleted list and choose Edit > Character > Character Formatting > Font.
The bullet and text color become inline instead of being associated with a style.

Match color using a style sheet

1) Place your cursor in the Design Editor, and select Edit > Styles > Style Pod.
2) From the Style list, select the style, and click the Create New Style button .
3) Under Style Type, select Paragraph Style.
4) Type a name for the new style. The name can contain letters and numbers only and cannot begin 

with a number.
5) Under Style For Following Paragraph, select a style.

Paragraph styles apply to entire paragraphs and affect the font, spacing between lines, numbering, 
borders and shading, and DHTML effects.

6) Select Format > Font.
7) Select a color.
8) Click OK twice.
9) Select the text that you want to format. Click Bulleted List.
10) From the Styles list, select the style you created.
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Remove bullets and numbering

1) Select the bulleted or numbered list items.
2) In the Edit menu, click the Create Numbered List or Create Bulleted List toggle button.

Apply a numbering format

NOTE: When you format lists using the toolbar or the Format menu, inline styles are created. Style sheets 
aren’t affected.
1) Open the topic in the Design Editor.
2) Select the numbered list.
3) Right-click on the list and choose Bullets And Numbering.
4) Click the Numbered tab. Select a numbering format.

Add a paragraph within a list

Use this procedure to insert paragraphs between numbered or bulleted items in a list.
1) Click at the end of the line to insert a paragraph over it.
2) Press Shift + Enter.
3) To end the line break and restart the numbering or bullets, press Enter.
4) (Optional) Drag the ruler at the top of the Design Editor to indent the paragraph.

TIP: Stop and start lists by clicking the Numbered List button in the toolbar.

Restart or continue numbering or lettering

After you insert a nested list, you can adjust numbering or lettering of the container list.
1) Click in the line where the new numbering or lettering sequence begins.
2) Right-click on the list and choose Bullets And Numbering.
3) Select the Numbered tab.
4) In Restart Numbering At, enter the start number.

For an alphabetical list, type the numeric equivalent for the start letter. For example, type 4 for the 
letter D.

5) Click OK.

Headers, footers, and page breaks

Headers and footers

You can create headers or footers in topics or master pages.
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If you edit or remove headers/footers, topics and master pages are affected as follows:

In a topic
The changes apply to the topic.

In a master page
The changes apply to all topics associated with the template.

In a topic associated with a master page
You can choose whether to apply the changes to the current topic or to the master page and all 
associated topics.

Create or edit headers and footers

1) Open the topic or master page.
2) Select Insert > Page Design > Topic TOC > Header or Footer.
3) Type the content for the header or footer. Text-only pop-ups are not supported.
4) (Optional) To add or edit margins, borders, color, or an image, right-click in the header or footer, 

and select Header Properties or Footer Properties.
NOTE: Any image file you select is added to the Baggage Files folder and is included in the project 
when you generate it.

5) Click outside the header or footer.
6) Click the Save All button.

Remove headers and footers

1) Open the topic or master page containing the header or footer.
2) Click the Header button or the Footer button.
3) Right-click in the header or footer, and select Remove Header or Remove Footer.
4) Click the Save All button.

Insert page breaks

Insert page breaks in topics to start new pages in the Printed Documentation output.
1) Open the topic in the Design Editor. Click where you want the page break.
2) Select Insert > Page Design > Page Break. Alternatively, press Ctrl + Enter.
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Text boxes

Insert text boxes in topics

Notes:

• Select Positioning from the View menu.
• Text can flow around a text box.
• If users have Internet Explorer 4.0 or later, you can apply Dynamic HTML effects to a paragraph by 

placing the paragraph in a text box.

Insert a text box

1) Click where you want to insert the text box.
2) Select Insert > HTML > Text Box.
3) (Optional) Right-click the text box and click Text Box Properties. Modify the properties.
4) Click in the text box to enter text or insert an image or other element.

Insert a positioned text box

Precisely position information on the page, allowing other elements to flow behind the text box.
1) Select Insert > HTML > Text Box > Positioned Text Box.
2) Select the positioned text box and drag it where you want it.
3) Right-click the positioned text box and select Positioned Text Box Properties. Adjust the properties.

Layer positioned text boxes

Layer positioned text boxes and specify their display order by applying Dynamic HTML (DHTML) effects.
1) Select the text box for the bottom layer.
2) In the Positioning toolbar, from the Z menu, select 1.
3) Repeat for additional text boxes.
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Layered text boxes

Change text box properties

1) Right-click the text box. Select Text Box Properties or Positioned Text Box Properties.
2) Change the properties.

Remove text boxes from a topic

1) Select the text box.
2) In the Edit toolbar, click the Delete button.

User-defined variables

User-defined variables store static global information that can be used repeatedly in your project, 
making information portable and simple to update. When you modify a variable or value, every occur-
rence of that variable or value is updated across the project. The User Defined Variables pod (available 
from Project > Open > Pods) lists all the user-defined variables in a project.
TIP: You can import documents with variables into a project.
NOTE: When you upgrade from previous versions of RoboHelp, variable values are converted to HTML 
text, and these variable values appear in the Default Variable Set.
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Create a user-defined variable

For global variables, ensure that all required variables exist.
1) Do one of the following:

– Select Project > Open > Pods > User Defined Variables.
– Right-click a word in the topic. Select Add To > User Defined Variable.

2) Enter a variable name and value.
Variable names can contain only alphanumeric characters, underscores, and hyphens, and can't ex-
ceed 255 characters. A variable value can be blank.

3) Click OK. The variable is inserted.

TIP: Press Ctrl+F9, and then specify the variable name within the curly brackets that appear in the topic. 
Double-click the variable to specify its value in the Variable dialog box. NOTE: You can create variables only 
in Default Variable Set, but you can modify the variable value in other variable sets.

Create a variable set

Variable sets enable you to modify values of various user-defined variables and use them in different 
outputs.

Default Variable Set is the master variable set. When you insert a variable, the variable is taken from 
Default Variable Set.

You can create different variable sets in the User Defined Variables pod to override the values of vari-
ables in Default Variable Set and use them in different outputs. To use a variable set other than Default 
Variable Set, select the variable set in the Content pane of layout properties.
1) Click the Add/Edit Variable Set icon.
2) Click Add and specify a name for the new variable set.
3) Click OK.

NOTE: You can edit and delete a variable set in the Variable Set dialog box by clicking the respective 
buttons.

Edit a user-defined variable

1) In the User Defined Variables pod, select a user-defined variable from the Default Variable Set.
2) Do one of the following:

– Right-click and select Edit.
– Select and edit its value in the User Defined Variables editor.
– From the Edit menu, select Edit [variable name].

3) (Optional) Select a different variable set.
4) Modify the value.
5) Click OK.
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NOTE: You can format a user-defined variable in the User Defined Variables editor. The Design and HTML 
buttons in the editor allow you to toggle between Design Editor and HTML Editor.

Format a user-defined variable

You can format variable values in the User Defined Variables editor. You can also achieve the following 
using Design Editor:
• Insert images, hypertext links, and multimedia files in the variable values.
• Apply conditional build tags to the values.
• Perform a spell-check on the variable values.

Insert a user-defined variable

You can drag a user-defined variable from the User Defined Variables pod to the desired location in a 
topic open in Design Editor. If the list of variables is long, specify the variable name or value to search the 
variable. You can also insert variables using the follow steps:
1) Place the insertion point at the desired location in a topic.
2) Select Insert > Variables > Variable.
3) Select a variable and click OK.

TIP: Specify the variable name or value to search the variable. As you type your search string, RoboHelp 
narrows down the variable list.

View properties of a user-defined variable

1) In the User Defined Variables pod, select Default Variable Set.
2) Select a variable.
3) Do one of the following:

– Right-click and select Properties.
– Select Edit > Properties.

4) View details (Variable Name, Variable Set, Variable Value, Description, and Used In Topics).
5) Click OK.

Toggle variable views

Use the toggle variable fields feature to toggle between the name and the value of the selected variable. 
When you toggle all fields, by default the current state of the selected variable or the first variable of the 
topic is replicated across all the variables in the currently active document.
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You can now easily toggle between the variable name and the value it represents through the following 
ways:
1) Using key combination: Click on the variable in the topic and use the key combination Shift+F9 to 

toggle single field or use the key combination Shift+F11 to toggle all fields.
2) Using the context menu: Right click the variable, choose Field > Toggle field to toggle a single vari-

able or select Toggle All Fields to toggle all variables.
You can also hover the mouse over the variable to view the variable name.

NOTE: The toggle variable view and the context menu option is visible only when you select the variable 
name.

Delete a user-defined variable

1) In the User Defined Variables pod, select Default Variable Set.
2) Right-click a user-defined variable, and select Delete.
3) Select one of the following options:

Delete Variable And Its References
Delete the variable and its references across the topics, TOC, index, SSL, and templates. No warning 
is shown before the deletion.

NOTE: Use the Variables report to locate the variables you want to remove.

Delete Only The Variable
Delete the value of a variable locally. Deleting a user-defined variable in the TOC does not remove 
it from the index.

NOTE: If the variable value is overridden in the Single Source layouts file, it is removed from the variable 
list in the Single Source layouts dialog box.

Delete Variable And Replace With Actual Content
Delete the variable across the topics, TOC, index, SSL, and templates. The formatting rules for the 
variable remain the same.

Rename a user-defined variable

NOTE: You can’t modify saved variable names.
1) Select Project > Open > Pods > User Defined Variables. The User Defined Variables pod appears.
2) Right-click a variable and select Rename.
3) In the Variable Name field, enter a name.
4) In the Variable Value field, modify the value.
5) Click OK.
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Single-source with snippets

A snippet is an element that you can single-source and reuse in various locations. It can be a paragraph 
of text, a code listing, an object such as an image, or an entire topic unto itself. When you create a 
snippet, RoboHelp adds it to the Snippet pod as a file with the .hts extension. If you change a snippet, it 
is automatically updated in all topics that share it. Snippets can contain images, variables, and conditional 
text tags. When shared in a topic, they retain inline text formatting. CSS formatting changes according to 
the CSS applied in the topic containing snippet.

The Snippet pod shows a preview of all the snippets on their individual selection. Right-click in the 
Snippet pod to enable and disable Preview mode. Drag snippets from the pod to a topic or from Windows 
Explorer to the Snippet pod. You can also select one or multiple snippets and then copy, duplicate, or 
delete them. NOTE: You can generate reports on unused snippets and delete the snippets not in use.

You can drag and drop snippets from the Snippet pod to the Resource Manager to export them to the 
target folder. The exported snippet exists at a global level and is visible to every user. Drag a snippet from 
the Resource Manager pod to the Snippet pod and RoboHelp imports the selected snippet file and its 
associated files to the project. NOTE: You can drag and drop a snippet in the Design Editor to edit its 
contents.

RELATED LINKS:
Managing Shared resources

Create and manage snippets

• To create a snippet from scratch, select Insert > Variables > Snippet. Specify a category name (if you 
don’t specify a category name, RoboHelp adds the snippet to the Default category).

• To create a snippet from existing content, select text. Right-click and select Add To > Snippets. 
Specify a category name (if you don’t specify a category name, RoboHelp adds the snippet to the 
Default category).

• To view snippet properties, right-click the snippet in the Snippets pod and select Properties. In the 
Used In tab, you can see the names of topics in which the snippet is used.

• To attach a style sheet to a snippet, right-click the snippet in the Snippets pod and select Properties. 
Click the Appearance tab and select a style sheet.

• To copy a snippet, right-click the snippet in the Snippets pod and select Copy from the context 
menu.

• To import a snippet, select Project > Import > Snippet and navigate to the source folder.
• To export a snippet, select it in the Snippets pod, click  in the toolbar, and navigate to the desti-

nation folder.
• To create a PDF for review with the snippet contents, right-click the snippet in the Snippets pod and 

select Create PDF For Review. Customize the settings and click OK.
• To insert a variable in a snippet, insert the pointer and drag a variable from the User Defined Vari-

ables pod.
• To preview a snippet, right-click a snippet in the Snippets pod and select Show Preview.
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Insert a snippet in a topic

1) Open a topic.
2) Do one of the following:

– From the Object toolbar, click Insert Snippet .
– From the Snippet pod, select a snippet and drag and drop it into the topic.
– Select Insert > Variables > Snippet. Select a snippet from the list in the dialog box and click OK.

3) NOTE: Right-click a snippet in the Resource Manager and select Add to Project to add the snippet to 
the project.

Insert a snippet in a drop-down text editor

1) Open a topic.
2) Select some text to expand.
3) Select Insert > DHTML > DropDown Text.
4) Drag a snippet from the Snippet pod and drop it in the Drop-down Text editor. NOTE: You can 

preview the topic and click the DHTML applied text. The snippet appears in the drop-down text.

Applying conditional build tags to a snippet

Use the Conditional Build Tags pod or right-click to apply conditional text on an entire snippet or a part 
of it. The preview option also lets you apply a conditional tag on selected text, code, or an image. You can 
exclude or include a conditional build tag from the output.

Inserting variables in snippets

Choose a variable from the User Defined Variables pod or right-click in a topic and choose Insert User 
Defined Variable. The snippet shows the variable value at the insertion point.

Convert a snippet to text

Convert an inserted snippet to embedded text. RoboHelp does not update the embedded text if the 
snippet is updated.
1) Click the snippet in the topic.
2) Right-click and select Convert To HTML Text.

Delete a snippet

1) In the Snippets pod, select the snippet you want to delete and click Delete Selected Item.
2) Select one of the following options:
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Delete The Snippet And Its References
Delete the snippet and its references across the topics, TOC, index, SSL, and templates. No warning 
is shown before the deletion.

NOTE: Use the Snippets report to locate the variables you want to remove.

Delete Only The Snippet
Delete the contents of the snippet locally. For example, selecting a snippet in a TOC and deleting it 
with this option selected does not remove the contents of the snippet from the index.

Delete Snippet And Replace References With Actual Content
Delete the snippet and replace the references in the project with the contents.

Reference

META tags default editor

Click Yes to make RoboHelp Design Editor the default editor for topics without META tags. Click No to 
retain the current editor. The topic then opens in the selected editor.
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Styles and style sheets

Style types

You can manage style sheets at the project level and apply styles at the topic level. Master pages provide 
the layout of a topic and help control the styling. These types of styles are available:

Inline styles
A block of text and its formatting within an HTML file (topic) formatted directly in Design Editor. If 
you link the file to a style sheet, inline styles override styles in the style sheet and embedded styles. 
See Inline styles.

Embedded styles
Style definitions saved in an HTML file (topic). If you link the file to a style sheet, embedded styles 
override the styles in the style sheet. You can create a character style or a paragraph style.

Styles in cascading style sheets (CSS)
Style definitions stored in a CSS file. You can create a character style, a paragraph style, a list style, 
a multilevel list style, and a table style.

After you convert a WinHelp project to an HTML-based project, styles are available as follows:

Project created from an HPJ file
You can create styles that use the same formatting as styles in Word templates. These styles are 
saved in style sheets that are attached to the HTML topics. If you do not want style sheets, translate 
the Word formatting into inline styles in the HTML topics.

Project created from an HLP file
Preformatted style sheets are available to apply to HTML topics. Topics are formatted to use the 
default HTML styles.

RELATED LINKS:
Master pages

Media rules and attributes in styles

Media rules and attributes help you control the appearance of your project output on different media, 
such as traditional desktop screens, printers, or popular devices such as iPad or iPhone. In RoboHelp, you 
can modify style definitions to add media rules and attributes.
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Define media-specific styles in a style sheet

In the Project Manager pod, right-click the style sheet and click Edit.
1) In the Styles dialog box, select a style to modify for a specific media.
2) Select the media type from the Media list.

None
Used to define generic styles

Print
Used for printers

<screen profile name>
Each screen profile in the project

3) Modify the style as required. For example, select a smaller font size.
4) Click OK.

Add a media rule in topic styles

Follow this procedure when you want to define different media rules for a style in the style sheet that is 
currently linked to a topic:
1) Choose Project > Open > Pods > Style and Formatting.
2) In the Styles and Formatting pod, select a style to modify for a specific media. Right-click and choose 

Edit.
3) Select the media or screen profile name from the Media list.
4) Modify the style as required. For example, select a smaller font size.
5) Click OK.

Apply the style and view the output.

Link media-specific CSSs to a topic and add media attributes in HTML

Create different CSSs, link to a topic, and edit the HTML code to add a media attribute in the link tag.

Syntax of the link tag

<link rel="StyleSheet" href="<stylesheet_filename>" type="text/css" 
media="<media_type>"/>

Examples

<link rel="StyleSheet" href="screen.css" type="text/css" media="screen"/> 
<link rel="StyleSheet" href="print.css" type="text/css" media="print"/>
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NOTE: The above examples specify that screen.css and print.css are used for output for display computer 
screens and printers, respectively. The media attribute requires predefined values, such as screen, print, 
projection, and handheld.

Map styles in Word/FrameMaker content to media-specific styles

While importing or linking Microsoft Word or FrameMaker content, you can map existing styles to 
different media. Select Project > Import.

View content in media-specific styles in Design view

After applying media-specific styles to a topic, snippet, or master page, you can check the appearance of 
the content in a specific media and modify the styles if required. The Design view displays the content 
with styles for the selected media.

The styles associated with the media are displayed in the Styles and Formatting pod and the Formatting 
toolbar.
1) Select the media from the Media list in the Format toolbar.

Delete a media-specific style

When you create a media-specific style, RoboHelp creates it from a generic style. When you delete the 
media-specific style, only that media-specific style is deleted; the generic style is not deleted.

Do one of the following:
• Right-click the style sheet in Project Manager and choose Edit. In the Styles dialog box, select the 

media-specific style you want to delete and click Delete.
• Select the media in the Format toolbar. Choose Project > Open > Pods > Style and Formatting. In 

the Styles and formatting pod, select the media-specific style you want to delete. Right-click and 
select Delete.

Media queries

Media queries help you gain finer control over media-specific styles by combining media types with 
media features, such as the width of a device. For example, the following code helps you define a style 
attribute for devices with a minimum screen width of 980 px:

@media screen and (min-width:980px) 
{ p { color: blue; } }

If your style sheet includes style definitions that use media queries, the minimum and maximum width 
values are reflected in the output generated from RoboHelp.
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Manage media queries for screen profiles

If you change the width of a screen profile, the media query for that screen profile defined in the style 
sheet becomes undefined. RoboHelp does not automatically update the media query.

To map the styles of an undefined media query to a media, follow these steps:
1) Right-click the CSS file and select Edit.
2) In the Styles dialog box, select Manage Media Queries from the Media list.
3) Select the undefined media query with the width you specified and click Map.
4) Select the screen profile.
5) Click OK.

To delete the styles of a media query, select the media query in the Manage Media Queries dialog box, 
and click Delete.

Manage style sheets

Link a style sheet to topics or master pages

You can associate one style sheet with any number of HTML topics, including a topic in Design view, 
multiple topics, or a new topic.

If you create a style sheet in a project and apply it to a new topic, all topics you create later use the new 
style sheet. Link a topic to another one, if necessary.
1) From the Topic List, select one or more topics.
2) Click the Properties icon  in the toolbar. Click the Appearance tab.
3) Select a style sheet. If needed, click the Browse button  to navigate to a style sheet, or click New 

to create a style sheet.
4) (Optional) Edit the style sheet:

Edit
Add, modify, or remove styles in the style sheet.

Background Sound
Add a sound clip that plays when the topic opens in the viewer or browser.

Sound Loop Count
Define the number of times the sound clip plays when the topic is opened. Select Infinite to play 
the sound continuously while the topic is open.

5) Click OK.
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NOTE: Use this same procedure to link a style sheet to a topic in Design Editor.

RELATED LINKS:
Applying a master page or CSS at the time of generation

Unlink a style sheet from topics or master pages

After you unlink a style sheet from a topic, the style sheet formatting is removed from the topic.
1) From the Topic List, select one or more topics.
2) Click the Properties icon  in the toolbar. Click the Appearance tab.
3) Select None in the list of style sheets, or click the browse button  to select a different style sheet 

to apply.
4) Click OK.

Create a style sheet

The new style sheet (default.css) is the default until you create a style sheet or link another style sheet 
to a new topic.
1) Edit > CSS > New Stylesheet.
2) Select New.
3) In Name, type a filename and include the .css extension.
4) In Folder, select a location.
5) (Optional) To base your new style sheet on an existing one, select Copy Styles From. Select a style 

sheet.
6) Click Create, create new styles, and click OK.

Create a style sheet and topic simultaneously

1) Select Project > New > Topic. Click the Appearance tab.
2) Click New.
3) Enter a filename and include the .css extension.
4) Create or edit predefined styles in the Styles dialog box.
5) Click OK.

Export a style sheet

1) Select the Design Editor.
2) Select Format > Export Styles.
3) Browse to where you want to export the style sheet.

If necessary, rename the style sheet, keeping the .css filename extension. NOTE: This feature is appli-
cable only for styles applied in a topic and not at a project level.
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4) Click Save.

NOTE: You can export topic-specific embedded styles only.

Create styles for style sheets

Create a style in the Styles dialog box

1) In the Project Manager pod, right-click the style sheet where you want to create the style, and click 
Edit.

2) Click New and select a style type, for example, Paragraph style. By default, the new style is created 
with a default name such as Style1.

3) In the Styles box, change the default name of the style. Do not use special characters or spaces in 
the name.
NOTE: If you use special characters, RoboHelp prompts you to fix the name. Some browsers cannot 
read styles with names containing special characters.

4) Select options in the Formatting section of the Styles dialog box. Changes appear in the Paragraph 
Preview section.

5) (Optional) To set additional values, click Format, and select an option:

Font
Select font families, size, and attributes, such as bold or italics.

Paragraph
Set up indents, line spacing, and alignment.

Borders And Shading
Use the Borders tab to set border types, color, line thickness, and spacing. Use the Shading tab to 
set background color and image options.

DHTML Effects
Select which dynamic HTML effect to include and when to include it.

NOTE: If you modify a style to include a Dynamic HTML effect, resave topics attached to the style 
sheet. Select Tools > Scripts > Update DHTML. When you resave the files linked to the style sheet, 
topics authored in third-party editors are converted to RoboHelp HTML. Special HTML tags are 
added to support specific Help features in the program.
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Create a style using the Styles And Formatting pod

1) To open the Styles And Formatting pod, open a topic and select Project Open > Pods> Style And 
Formatting.

2) Click the Create New Style button  in the Styles And Formatting toolbar, and select a style type, 
such as List Style.

3) Type the style name and click OK.
4) Select font and formatting options, and click OK.

RELATED LINKS:
Styles And Formatting pod

Create a style using the Design Editor

1) In the Design Editor, select some text in the topic.
2) Apply a format, such as bold.
3) With the text still highlighted, type a style name in the Style list in the toolbar and press Enter.
4) Click Create.

Table styles

With Style Editor, you can create and customize table styles according to your requirements. Applying a 
table style instead of inline formatting helps you add standard and easy-to-maintain tables. If you modify 
a table style, all tables using that style also change.

You can modify the appearance of existing tables by applying a style. RoboHelp asks you if you want to 
remove inline formatting also.

For tips and workarounds related to customizing tables, see the Table section in Peter Grainge’s Robo-
Help tour.

Global table styles

You can select predefined styles for a table. These styles are available globally and can be used across 
projects to define different tables. Global table styles are present at C:\Documents and Settings\[user 
name]\Application Data\Adobe\RoboHTML\[version]\Templates\Tables. For Windows Vista®, 
global table styles are present at C:\users\[user 
name]\AppData\Roaming\Adobe\RoboHTML\[version]\Templates\Tables. NOTE: If you delete the 
Tables folder from the suggested location, the global table styles are still visible in the Global Styles list. 
You can always recover the styles from C:\Program Files\Adobe\Adobe RoboHelp 
[version]\RoboHTML\Gallery\Tables.

In addition to the predefined global styles, you can copy table styles from a project folder and paste at 
C:\Documents and Settings\[user name]\Application 
Data\Adobe\RoboHTML\[version]\Templates\Tables. These table styles are available globally for all 

http://www.grainge.org/pages/authoring/rh_tour/index.htm
http://www.grainge.org/pages/authoring/rh_tour/index.htm
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the projects. TIP: Click the Apply Global Table Style  icon on the Tables And Borders toolbar to apply a 
style on the table.

Apply table styles

To apply a table style on an existing table, do the following:
1) Select an existing table in a topic.
2) Click the Apply Global Table Style icon  on the Tables And Borders toolbar to apply a style on the 

table.
3) In the Select Table Style dialog box, select Clean Table Inline Formatting. Selecting Clean Table 

Inline Formatting removes any inline styles used in the table.
4) Select a style from the Available Styles list or select a global table style (table template).
5) Click OK. NOTE: You can double-click a style in the Table Style dialog box to apply it to a table.

Create and manage table styles

Besides using global table styles (table templates) and predefined table styles in the CSS, you can create 
custom table styles to ensure consistent table layouts, borders, alignment, shading, and fonts. You can 
vary characteristics such as the colors, fonts, bold, italics, and alignments applied to rows and columns.

John Daigle demonstrates some easy ways to create and manage tables and tablestyling.

Create table styles

1) Select Project > Open > Pods> Style And Formatting.
2) Click Create New Style and select Table Style.
3) Name the new table style and click OK.
4) Apply formatting to the whole table, first or last column or row, or a group of rows or columns. 

From the Apply Formatting To list, select the columns or rows to format. For example, you can 
make the background of the first row blue and the background of first column yellow.

5) Select font, size, and color.
6) Select border and border color.
7) Click Apply. The new style appears in the CSS Styles list of the Table Styles dialog box. Select this 

style to create tables with the same style later.

Notes:

• Click the Apply Global Table Style icon  on the Tables And Borders toolbar to apply a style to the 
table.

• Based on the sequence of changes, in the first and last cell of a row, the row color overrides the 
column color.

The appearance of a table is the result of several classes, such as Table, TR, and TD. RoboHelp applies 
these subclasses to the respective table item when you apply a table class. Therefore, if you want to 

http://www.adobe.com/designcenter/robohelp/videos/


198

LIST STYLES
CHAPTER 6 STYLES AND STYLE SHEETS

change a table style through code or script, write a class attribute (class=”myTableClass”) in the table tag. 
RoboHelp applies all the table patterns for the remaining items of the table in Design Editor.

Apply conditional build tags to tables

Conditional build tags let you exclude content from output.
1) Select a row, column, table, or text in a table.
2) Select Edit > Tags > Apply > New/Multiple.
3) Select tags. Click OK.

List styles

About list styles

RoboHelp provides three types of lists: HTML lists, advanced lists, and autonumbered lists. Advanced lists 
can be either single level or multilevel lists. You can define HTML list styling under List Styles and 
Advanced lists under Multilevel List Styles. Define autonumbered lists under Paragraph Styles.

HTML lists
All the ordered <ol> and unordered <ul> lists come under HTML lists.

Advanced lists
Creates a hierarchical or outline list, such as numbered heading styles, with numbering such as 1, 
1.1, 1.1.1, and so on. Like simple numbered lists, hierarchical numbered lists and the accompanying 
paragraph styles share the same formatting. The multilevel lists set up complex nested steps, such 
as steps, step results, substeps, and so on. Multilevel lists define only the numbering properties. 
Multilevel lists do not have their formatting until they are linked to paragraph styles.

For an example of how to create a multilevel list based on a supplied style (list template), see the 
Outline Numbering section in Peter Grainge's RoboHelp tour.

Autonumbered lists
Autonumbered lists are linked to paragraph styles. To autonumber a paragraph, you can apply 
autonumbering to it. To number figures or tables sequentially, define a simple numbered list 
format, such as Figure Number or Table Number. In simple numbered lists, the paragraph style and 
numbering styles share the same font, font size, font weight, and font color.

For a video introduction by John Daigle, see Easy ways to create lists and autonumbering on the Adobe 
RoboHelp video tutorials page.

Create HTML lists

1) Right-click List Style in the Styles dialog box.
2) Click New.

http://www.grainge.org/pages/authoring/rh_tour/index.htm
http://www.adobe.com/designcenter/robohelp/videos/
http://www.adobe.com/designcenter/robohelp/videos/
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3) Name the new list.
4) Select a font, font size, or a color for the new list style.
5) Click the Create A Numbered List button to create a numbered list or the Create A Bulleted List 

button to create a bulleted list.
6) (Optional) Select other formatting options in the Formatting section of the Style editor.

NOTE: To edit a list style, select different formatting options in the Formatting section of the Style editor 
and preview them in the Preview section.

Create multilevel lists

1) Do one of the following:
– On the Style And Formatting pod, click Create New Style, and select Multilevel List Style. Then 

type a name for the new multilevel list, and click OK.
– Right-click a multilevel list style in the Style And Formatting pod, and select Edit.

2) Select a list level from the Apply Formatting To menu. List Preview displays the hierarchical order 
of the selected level.

3) (For multilevel lists only) Select the paragraph style to apply to the current list level.
4) Select a predefined list style from the List Style pop-up menu, or click New to create a list style. For 

example, you can have a sequenced list style such as Months, and you can have a sequence of all 
12 months added to this sequence.

5) You can prefix a sequence or a multilevel list. To prefix a list style, enter text or numbers to prefix 
in the Edit Style box. To specify the level to prefix, select the level from the Insert Level menu. You 
can add a prefix to the level in the Edit Style box by separating the level and prefix with a separator 
such as a dot (.) or an angle bracket (>).

6) Apply formatting to the list style:
– Font, font size, color, highlight color, bold, italic, and underline
– List indention, space between list prefix, and accompanying paragraph text

For more information about the numbering behavior, indentation and margin control, or prefix formats, 
see www.adobe.com/go/learn_rh_blog_multilist_en.

Create an autonumbering style

Autonumbering is linked to Paragraph styles. You can autonumber a paragraph style and apply it as a 
numbered list style.
1) Do one of the following:

– Select a paragraph style in the Styles dialog box.
– Create a paragraph style.

2) Click the Autonumber button .

http://www.adobe.com/go/learn_rh_blog_multilist_en
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3) (Optional) Select Inherit Numbering Property From Multilevel List to inherit the multilevel list style 
to apply autonumbering. Select the multilevel list style from the List Class pop-up menu and select 
the level to apply autonumbering. Click OK.

4) Enter a prefix for the new autonumbering style in the Format text box.
5) Select a predefined numbering option from the Numbering pop-up menu or select New to create 

a sequenced autonumbering style.

For more detailed information, see www.adobe.com/go/learn_rh_blog_autonumber_en.

Create a sequencing prefix

You can create custom sequencing prefixes to assign to Advanced lists.
1) In the Styles dialog box, click New.
2) In the Create/Edit Custom Sequence dialog box, click the plus sign to create a sequence.
3) Enter a unique sequence name such as Months and click OK.
4) Select the font for the sequence from the Sequence Font pop-up menu and click Add.
5) Click the Edit Sequence box and type the sequence that you want. For example, January, February, 

and so on. After you enter January, click Add to add February, and so on.

For more information about custom sequencing, see www.adobe.com/go/learn_rh_blog_multilist_en.

Edit a sequencing prefix

1) In the Styles dialog box, click New.
2) Select the sequence from the Sequence pop-up menu, and do one of the following:

– To edit a sequence entry, select the entry in the Edit Sequence list, and click Edit. Make your 
edits in the Edit Sequence box.

– To delete a sequence entry, select the entry in the Edit Sequence list, and click Delete.
– To reorder the sequence, delete entries and reenter them in the desired order.

Delete a custom sequence

1) In the Styles dialog box, click New.
2) Select the sequence. Click the plus sign.
3) Click Yes to confirm. Then click OK.

HTML styles

You can edit the Div, Hyperlink, and Image styles using the Styles editor or from the Styles and Formatting 
pod. The Div style can be used for text boxes and positioned text boxes. The Hyperlink style can be used 
for hyperlinks, drop-down hotspot, expanding hotspot, and glossary terms. The Image style can be used 
to place an image.

http://www.adobe.com/go/learn_rh_blog_autonumber_en
http://www.adobe.com/go/learn_rh_blog_multilist_en
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Create styles based on Div, Hyperlink, and Image styles

You can create styles based on available styles or edit properties of existing styles.
1) Double-click a CSS file in the Project Manager pod to open the Styles editor.
2) Select the style category from the Styles list. For example, select HyperLink.
3) Right-click and select New. Name the style and set the properties as desired.

Edit Div styles

You can edit the properties of Div styles from the Styles editor or the Styles and Formatting pod. You can 
edit the Size, Margin, Float, and Border attributes of a division or a section of text. Use the Float attribute 
to position text to the left or to the right of a division. For example, if you set the Float attribute to Left, 
the text is placed to the right.

Use the Overflow property to specify what happens if text overflows in a division. For example, if you 
specify Overflow as Scroll, a scroll bar is added to display the content that overflows.

Edit Hyperlink styles

You can edit the properties of Hyperlink styles from the Styles editor or the Styles and Formatting pod.

Use Pseudo classes

In CSS, pseudo classes are used to add different effects to a hyperlink. You can have the appearance of a 
hyperlink change according to its status. For example, you can define a specific CSS properties for a 
hyperlink that is not clicked, and a different set of CSS properties for a hyperlink that is clicked.

Examples of using pesudo classes:
• You can have one color for a Visited pseudo class in one style (for example, Expanding Hotspot) and 

have another color for a Visited pseudo class in another style (for example, Glossary Term).
• You can have multiple objects with multiple Hyperlink and Div styles in the same topic. Two hyper-

links in the same topic can be styled differently.

For more information about pseudo classes, see www.w3schools.com/css/css_pseudo_classes.asp.

Use Twisty images

You can add a twisty image to a Hyperlink style and apply the style to expanding hotspots, drop-down 
hotspots, and glossary terms. To set a twisty image, click Set Twisties, and select the image properties.

Use Block-style hyperlinks

You can add a Block attribute to a Hyperlink style. Block-style hyperlinks are helpful for output displayed 
on devices such as iPad or iPhone.
1) In the Styles editor, select the Hyperlink style to modify.
2) Select Block from the Display list.
3) Specify the height and width of the block.

http://www.w3schools.com/css/css_pseudo_classes.asp
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Edit Image styles

You can edit the properties of Image styles from the Styles editor or the Styles and Formatting pod.

You can edit the Size, Margin, Float, and Border attributes of the image.

Use the Float attribute to position an image to the left or to the right, while having the text of a paragraph 
wrap around it. For example, if you set the Float attribute to Left, the image is positioned to the right and 
text is wrapped to the left.

Apply styles

After you link a CSS file, an external style sheet, or embedded styles to a topic, you can apply styles.
1) In the Design view, do one of the following:

– Select the text to format.
– Click inside the paragraph to format. For multiple paragraphs, select the paragraphs.

2) In the Styles And Formatting pod, double-click a style.
– Character styles apply to selected blocks of text and impact fonts and DHTML effects.
– Paragraph styles apply to entire paragraphs and impact fonts, spacing between lines, 

numbering, borders and shading, and DHTML effects.
– Table styles apply to the content in the tables.
– List styles apply to all numbering and bullet styles.
– Multilevel list styles apply to hierarchical lists.

TIP: To remove a character style, select the text and select a different style from the Style list. To remove 
a paragraph style, select the style None.

Edit styles in CSS files

When you edit styles in a CSS file, all topics that are linked to the file are updated. IMPORTANT: You cannot 
use the Undo command to undo changes to a CSS file. Edit the CSS file to revert to a previous style.

Edit a style using the Styles dialog box

1) In the Project Manager pod, right-click the CSS file. Click Edit.
2) Deselect Hide Inherited Styles.
3) From Available In, select a style sheet.
4) In the Styles box, select a style.
5) Click Format, and select the attributes.
6) (Optional) Select formatting options from the Formatting section.
7) Click OK.
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Edit a style using the Styles And Formatting pod

1) Select a style in the Styles And Formatting pod.
2) Click Edit Selected Item.
3) In the Styles dialog box, select formatting options.
4) Click OK.

TIP: To prevent a user-defined color from displaying in the browser background, set the Background Text 
style to a white background. This style is for normal topic text, such as headings and paragraphs. It 
controls the default settings for background images, background colors, and borders.

Edit styles in an HTML Editor

1) In the Project Manager pod, right-click the CSS file. Click Edit With.
2) Select HTML Editor.

RoboHelp opens the style sheet in a new topic window.
3) Edit the styles according to your requirements.

Delete styles from style sheets

1) In the Project Manager pod, right-click the style sheet containing the style to remove, and click Edit.
2) If Hide Inherited Styles is selected, deselect it to see available styles.
3) From the Available In menu, select the style sheet name. For embedded styles, select the topic 

name.
4) From the Style menu, select the style to remove.

To delete custom formatting from a default style, select the style.
5) Click Delete.
6) Click Yes at the prompt. NOTE: To remove a style from the style sheet or the Formatting toolbar, 

select None from the Styles menu.

Use color and images

Change text and link colors in a style sheet

RoboHelp incorporates changes you make to a CSS file into every topic the CSS file is linked to. You cannot 
undo changes to a CSS file.

Using the WebHelp Skin Editor, you can change the color of text in the TOC, index, and Search panels for 
WebHelp and WebHelp Pro.
1) In the Project Manager pod, right-click the CSS file. Select Edit.
2) Deselect Hide Inherited Styles.
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3) From Available In, select a CSS file.
4) In the Styles box, select Character.
5) Expand Character Style, and select a link or text style from these options, among others:

Background + Text (Body)
In the default style sheet, body text (normal text). This style is for text, tables, and headings in 
topics. This style also controls the default settings for background images, background colors, and 
borders.

Hyperlink (Unvisited)
An unvisited hypertext link.

Hyperlink (Visited)
A visited hypertext link.

Hyperlink (Active)
The selected hypertext link.

6) Select Edit > Character > Character Formating > Font.
7) Under Font Color, select a color. Click OK.

RELATED LINKS:
Create styles for style sheets

Skins

Add or edit borders or backgrounds in style sheets

1) In the Project Manager pod, right-click the style sheet where you want to edit borders or back-
grounds, and click Edit.

2) Deselect Hide Inherited Styles.
3) From Available In, select a CSS file.
4) Under Other in the Styles box, select Background + Text (Body).
5) Select Format, and then select Borders And Shading.
6) Click the Border or Shading tab, define the borders or backgrounds, and click OK.

NOTE: Any image file used for borders or backgrounds is added to the project Baggage Files folder and is 
included in the output you generate.

RELATED LINKS:
Add or edit borders and backgrounds in topics
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Inline styles

Apply or edit inline styles

1) In the Design Editor, select the block of text to format.
2) Do one of the following:

– Select a formatting option from the toolbar.
– In the Edit ribbon, select the desired formatting from the Font, Paragraph, Bullets And 

Numbering, Borders And Shading, or Topic Borders And Shading options.

Update inline styles

You can edit the formatting of a character or paragraph style and then update all characters or paragraph 
across your project to which the same style is applied.
1) Select a piece of text or paragraph of the style that you want to update.
2) In the Edit ribbon, use the various character or paragraph formatting to edit the style.
3) Choose Edit > Styles > Update Style .

The formatting of content for the selected style is updated across all topics in the project.

Remove inline styles from text

1) In the Design Editor, select the block of text with the inline style.
2) In the toolbar, click the options menu  next to the Styles box.

Options menu

3) Select Default Paragraph Font.

Reset styles

Each style category in the Styles and Formatting pod has an option called (Reset Style). If you want to 
remove all formatting applied through a style in a style category from selected content, follow these 
steps:
1) Select the style category from the style list in the Styles and Formatting pod. For example, select 

Table Style.
2) Double-click Reset styles. (Alternatively, you can right-click Reset styles and click Apply.)
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Example (Reset a table style)

The following example illustrates how a table style is reset.
Sample table with a style applied

Inline formatting added to the headings. No inline formatting has been applied to the whole table, selected rows, or 
cells (RoboHelp considers these selections as table elements and removes any inline formatting applied to these 
elements when you reset a table style (just as the Clean Table Inline Formatting in the Select Table Style dialog box 
works)

After applying Reset Style, the table style is removed. Inline formatting of headings (non-table element) remains.
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Clear formatting

To remove all styling and formatting from a selection in the Design Editor:
• In the Character section of the Edit tab, choose Clear Formatting.
TIP: To clear the formatting of a paragraph, place the cursor inside the paragraph and then click Clear 
Formatting.
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TOCs, indexes, glossaries

TOCs

TOC basics

About TOCs

The table of contents is a hierarchy of the folders, topics, and any subfolders in Project Manager. Robo-
Help creates books from custom folders and pages from the topics in these folders. Any topics not saved 
in custom folders appear as pages at the first level in the table of contents.

You can reorder books and pages after you create the table of contents.

Create TOCs

Automatically create a table of contents based on the chapter layout defined in the Project Manager pod.
1) In Project Manager, right-click the Table of Contents folder, and select New Table Of Contents. TIP: 

If the project has many topics, collapse the Project Files folder first to view the Table Of Contents 
folder.

2) Specify a name for the TOC.
3) (Optional) Select Copy Existing Table of Contents and browse for an existing TOC file (.hhc) to create 

the TOC from an available TOC.
4) Click OK. RoboHelp opens the Table Of Contents pod.
5) In the Table Of Contents pod, click the Auto-Create TOC button .
6) Select an option in the Auto-Create TOC dialog box:

Delete Current TOC Before Creating New
Removes books and pages before automatically creating the table of contents. If this option is dese-
lected, existing books and pages are included in the table of contents.

Create TOC Pages For Mid-Topic Links
Creates pages in the table of contents based on bookmarks. RoboHelp makes the topic that 
contains the bookmark into a book and all bookmarks into pages.

7) Click OK.

NOTE: In Microsoft HTML Help projects, you synchronize the table of contents in window properties. 
Folder names and filenames, including those for topics, must use underscores rather than spaces.

RELATED LINKS:
Reorder TOC books and pages

Define chapter layout
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Print TOCs

1) Click the Table Of Contents pod.
2) In the toolbar, click Print.
3) From the pop-up menu, select the information to print.

Overview
Print all book and page titles.

Detailed
Print all book and page titles, the topic titles linked to each, and the folders in which the topics are 
located.

4) Click Properties or Page Setup to specify print options.

Create TOC books and pages

Version-control projects may have more options.

Create TOC books

1) Open the Table Of Contents pod by double-clicking the required TOC in Project Manager.
2) In the toolbar, click the New TOC Book button .
3) In the Book Title box, type the name to appear in the table of contents.
4) Click OK.

NOTE: A book must include at least one page for it to appear in the output.

Create TOC books and pages with targeted links

You can link books and pages in a table of contents to content that you specify. When a user clicks a book 
or page icon, the linked content appears in the Topic pane. You can link to topics, websites, and so on.
1) In the Table Of Contents pod, do one of the following:

– Click the New TOC Book button . Select Book With Link.
– Click the New TOC Page button .

2) Under Book (or Page) Destination, specify a destination:
– Select an item in the list. If needed, select from the pop-up menu and navigate to the item. 

You can link to items in other projects.
– To create a topic, click New Topic. Type a title, change the filename if needed, and select a 

master page. Link a book or page to it.

3) Click OK.
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Create TOC books from pages

1) In the Table Of Contents pod, right-click a page.
2) Select Create Book From Page.

A book is created with the same title as the page. The page is placed inside the new book.

Create TOC pages by dragging

1) Open the Table Of Contents pod and the Topic List pod.
2) In the Topic List pod, select one or more topics.
3) Drag the topics into the Table Of Contents pod.

NOTE: Titles of topics dragged into the Table Of Contents pod are based on the topic titles. To rename a 
topic title, right-click it and select Rename.

Create TOC books and pages with user-defined variables

1) In the Table Of Contents pod, right-click and select New > Book or Page.
2) From the Available Variables menu, select a variable. Click Add. The variable is listed in the Page 

Title box.
3) (Optional) In the Page Title box, add a prefix or suffix to the variable. For example, add the prefix 

“Adobe” to the variable “RoboHelp.”
4) From the Existing Topics list, select a topic for the new page.
5) Click OK. The book or page appears in the table of contents. Its title displays the user-defined vari-

able with the text you added.

TIP: To view or change the variable applied to a TOC item, right-click the item and select Properties.

Edit TOC books and pages

Rename TOC books and pages

NOTE: If you rename a TOC page, the topic title linked to the page isn’t affected. Similarly, if you change 
a topic title, the name of the TOC page isn’t affected. Rename the TOC page separately, if desired.
1) In the Table Of Contents pod, right-click a book or page. Select Rename.
2) Type the new name. Press Enter.

TIP: You can also rename a book or page by changing its properties.

Reorder TOC books and pages

1) In the Table Of Contents pod, select a book or page.
2) Do one of the following:

– Drag the item to a different location.
– Click arrows in the toolbar to move the item.
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Version-control projects may have more options.

Remove TOC books or pages

If you remove a page from the table of contents, the topic it links to is not deleted.
1) In the Table Of Contents pod, select a book or page icon.
2) In the toolbar, click the Delete button.

Version-control projects may have more options.

Change properties for TOC books or pages

Rename a book or page, or edit a destination, window frame, or custom icon.
1) In the Table Of Contents pod, right-click a book or page. Select Properties.
2) Make changes on the General and Advanced tabs.

NOTE: The primary layout controls the properties of books and pages. For example, you can add 
custom icons for books and pages only if the primary layout is Microsoft HTML Help.

3) Click OK.

Version-control projects may have more options.

Manage TOCs

Manage TOCs with reports

RoboHelp provides several reports to help you manage tables of contents and resolve errors.
1) Select Tools > Reports > [report name].

You can save, print, copy, and mail reports.

Table Of Contents report

This report displays the hierarchy of books and pages in a table of contents. You can view parts of a table 
of contents by selecting a specific folder from the Folder list. If you change topic titles or filenames, you 
can compare them with the titles used in the books and pages.

Choose from these report formats:

Detailed
Includes titles of books and pages, names of topics that are linked to them, and names of folders in 
which files are located.

Overview
Includes titles of books and pages and names of topics linked to them.

TIP: Use this report as a project outline.
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Topic Properties report

Customize this report to display any of these items:
• Topic titles
• Filenames
• Folder names
• Books and pages that reference topics

Topic Reference report

This report tracks references to the topics in a project, including books and pages in the table of contents 
that are targeted to topics.

Unreferenced Topics report

This report tracks topics in a project that aren’t used in the table of contents, the index, or navigation 
components.

Broken Links report

This report displays the broken links in a project, grouped by file.

Identify and fix broken TOC links

If books or pages have broken links, they appear in the Table Of Contents pod with a red X.
1) Select Project > Navigation > Broken Links.

References To Selected Topic
Shows all references to the missing topic. The Open Book icon  indicates broken TOC references.

All Missing Topics
Displays topics missing from the project.

2) To remove a TOC item, select it under References To Selected Topic, and click Delete.

RELATED LINKS:
Fix broken links

Multiple TOCs

About multiple TOCs

You can create multiple tables of contents for a single project. You can use this feature for single-source 
publishing. For example, you can create separate tables of contents for a project that contains multiple 
languages or outputs for different audiences. NOTE: To set a TOC as default, right-click a TOC in the Project 
Manager pod and select Set As Default.
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If you merge subprojects into a master project, the tables of contents of the subprojects are available in 
the master project.

Move books and pages to TOCs

1) In the Project Manager pod, double-click tables of contents in the Table Of Contents folder.
2) Drag books and pages from one Table Of Contents pod to another.

Create multiple TOCs for a project

1) Do one of the following:
– In the Project Manager pod, right-click the Table Of Contents folder. Select New Table Of 

Contents.
– Click the Create/View Table Of Contents button . In the Select TOC dialog box, click New.

2) Type a name.
3) (Optional) Select Copy Existing Table Of Contents to base the new table of contents on an existing 

one. Click the browse button  to locate the HHC file in the project folder, and select it.
4) Click OK.

By default, an empty table of contents with the same name as of the project appears in the Table Of 
Contents folder.
NOTE: Click the Auto-Create TOC button , to automatically create a table of contents.

Merge TOCs

Follow this procedure to merge the tables of contents within a project.
1) In the Table Of Contents pod, select the book or page where you want to merge the table of 

contents.
2) Click the Insert TOC Placeholder button . The Insert TOC Placeholder dialog box appears.
3) From the Select Table Of Contents menu, select the table of contents to merge.
4) Click OK.

When you generate a layout, select the merged table of contents from the list in the Layout screen of the 
wizard. The selected table of contents appears in the output view of the Help.

RELATED LINKS:
Merging Help projects

Create browse sequences from a table of contents

You can use multiple tables of contents to generate browse sequences.
1) Select Project > Navigation > Browse Sequence Editor.
2) Click Auto-Create Using TOC.

In the Auto-create Browse Sequences using ToC dialog, you can choose one of the following options:
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Create a sequence using TOC as is:
Default. Create a browse sequence based on the TOC. Use this option if there is a limited number 
of entries in the TOC.

Create a separate sequence for each book down to level:
Choose this option and specify the deepest level to be sequenced from the TOC.

3) In the Select TOC drop-down list, choose the type of TOC:
– All-Test
– CSH
– Developers
– EPUB
– Feature Topics
– HTML5-CSH
– Salesbuilder (Default)

4) Click OK, to apply the changes.

Indexes

Index basics

About indexes and keywords

You create an index by adding keywords and associating them with topics. You can spell check an index, 
and you can use topic To Do lists to track your work while indexing. Change the capitalization of keywords 
in the Index pod.

An index can include multiple levels of keywords and cross-references to other keywords. Subkeywords 
can be listed under a main keyword or in a Topics Found window. If a main keyword is linked to more 
than two topics, it needs subkeywords.

Topic keywords

Topic keywords appear the same as index file (HHK) keywords, but they are stored within individual 
HTML topics. The Index Designer identifies topic keywords with a key/page icon .

When working with topic keywords, consider the following details:
• When you import topics into a project, their keywords are added to the index.
• You can copy topic keywords to other topics and create index file keywords from them.
• You can use topic keywords with Keyword Link controls.
• If you remove a topic from a project, its keywords remain in the index in bold (indicating they are 

not linked to a topic). The keywords don’t appear in the index until you link them to other topics.
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• Topic keywords can link only to local HTML topics. The topic can appear only in the default Help 
window.

• Topic keywords cannot cross-reference (link to) other keywords in the index. Create the 
cross-reference using an index file keyword.

• Topic keywords are sorted in the index in alphabetical order. You cannot reorder the keywords.

Additional details for HTML Help projects

• You can merge topic keywords from multiple CHM files into a master project.
• If you add index controls to topics, the index file (HHK) for the control displays only index file 

keywords.

Additional details for WinHelp projects

• When you convert a WinHelp project (HPJ) file to a RoboHelp project, the keywords in the WinHelp 
topics are saved as keywords in the index file.

Index file keywords

Index file keywords are saved in the project index file (HHK) rather than in the code of individual HTML 
topics. The Index Designer identifies index file keywords with a key icon . You can create and maintain 
multiple indexes for a project.

When working with index file keywords, consider the following details:
• You can use index file keywords with all supported output types and with Keyword Link controls.
• Index file keywords can cross-reference (link to) other index file keywords.
• Index file keywords can link to local HTML topics, multimedia files, baggage files, bookmarks, and 

URLs. Depending on the Help format, a topic can appear in the default Help window, a custom 
window, or a frame.

• If you aren’t creating a binary index, and the project contains no topic keywords, you can sort the 
keywords in any order.

• When you remove a topic from the project, index file keywords remain in the index if other topics 
use them. You can remove or retain the keywords, regardless of whether other topics use them.

• You can merge index files with other projects. For HTML Help, binary indexes are required to merge 
projects. Keywords in binary indexes are sorted alphabetically and cannot be reordered.

• If you import topics into a project, assign index file keywords separately. Index file keywords aren’t 
included with topics, as are topic keywords.

• When you remove an index file keyword from an index, the keyword is also removed from topics 
that were assigned to it.

• If you remove a topic from a project, and you don’t remove references to the index file keywords 
it uses, the keywords are marked unused. (The exception is if other topics use them.) If these 
keywords aren’t used by other keywords, the project includes broken links.
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Specify keyword types for a project

A project can include index file keywords, topic keywords, or both. To specify the type to work with, 
change the project settings.
1) Select Project > Project Settings.
2) Click the General tab.
3) In Add New Keywords To, specify the keyword type.

– To add index file keywords, select Index File (HHK).
– To add topic keywords, select Topics.

4) Click OK.

New keywords use the type specified until you change the setting.

Notes:

• When you add a keyword to an index, it is automatically added to the index (HHK) or topic (HTM) 
files.

• Index file keywords use the key icon . Topic keywords use the page icon .

Print indexes

1) Click the Index pod.
2) From the pop-up menu, select the items to print.
3) In the toolbar, click Print.
4) Click Properties and Page Setup to specify print options.

TIP: Use the Index report or the See Also report to print customizable keyword lists.

Add and link index keywords

• If you add the same keyword to an index using different capitalization, the Index Designer adds the 
keywords as one entry, based on the first entry.

• If the index includes index file keywords and topic keywords that are identical, the keywords are 
merged when you generate the project. In the Index tab, they appear as one keyword. (In the Index 
Designer, they appear as separate keywords.)

• When you convert a WinHelp project (HPJ file) into a RoboHelp project (XPJ file), the keywords in 
the WinHelp topics are saved as keywords in the index file.

RELATED LINKS:
Create an index automatically

Add index keywords using the toolbar

1) In the Index pod, do one of the following:
– To add a keyword, click the New Index Keyword button .



217

INDEXES
CHAPTER 7 TOCS, INDEXES, GLOSSARIES

– To add a subkeyword, select a parent keyword from the list. Click the New Index Subkeyword 
button .

2) Type the keyword in the text box. Press Enter.
The keyword is added to the index. It appears in bold, indicating that it is not yet linked to topics.
TIP: To quickly add a keyword and subkeywords, skip step 1 and type the keyword and the subkey-
words separated by \ and click Add Keyword.

3) Select Project > Open > Pods > Topic List. The Topic List pod appears.
4) To link the keyword to topics, drag topics from the Topic List pod to the lower panel in the Index 

pod.
The linked keyword changes from bold to plain text.

Add index keywords based on a topic title

1) Open the Index pod.
2) Select Project > Open > Pods > Topic List.
3) In the Topic List pod, select a topic.

A question mark icon  indicates that a topic is not added to the index.
4) Drag the topic into the upper pane of the Index Designer.

The keyword name is based on the topic title. You can rename it.

Add index keywords using topic properties

1) In the Topic List or Project Manager pod, select a topic.
2) Click the Properties button .
3) In the Topic Properties dialog box, select the Index tab.
4) In the text box, type a keyword. To add a subkeyword, type the main keyword, a backslash, and the 

subkeyword.
5) Click Add.

Add index keywords by selecting topic text

1) Double-click a topic to open it in the Design view.
2) Select text to use as a keyword.
3) Right-click the text, and select Add To > Index Keyword > [index].

Copy index keywords

You can copy index keywords between topics. After copying, you can customize them to work with indi-
vidual topics.
1) In the Topic List pod, right-click a topic and select the Properties button .
2) Click the Index tab.
3) Click Add Existing.
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On the left, a list of all keywords in the project appears. On the right, a list of all keywords for the 
current topic appears. If the topic is not yet indexed, no keywords appear.

4) Copy the index keywords to the topic:
– To copy a single keyword, select it on the left and click the single arrow button.
– To copy all keywords, click the double arrow button.

5) Click OK. The keywords are linked to the topic.

TIP: To modify index keywords you copy, select a keyword. Enter text under Index Keywords. Click 
Replace.

Select an index keyword destination

You can link keywords to various destinations. When a user clicks the keyword, the destination opens in 
the topic pane.
1) In the Index pod, select a keyword.
2) Under Topics For, right-click a keyword topic.
3) Select Properties.
4) Under Existing Topics, specify a destination and click OK.

– Select an item in the list. If needed, select from the pop-up menu and navigate to the item. 
You can link to items in other projects.

– To create a topic as an index keyword topic, click New Topic. Type a title, change the filename 
if needed, and select a master page.

– To link to another type of destination, click the Link To pop-up menu and select a destination 
type. Type the identifying URL, e-mail address, FTP address, or baggage filename for the desti-
nation type.

Notes:

• The Name and Link To fields are disabled when you specify topic keywords. With topic keywords, a 
keyword can link only to the topic in which it is stored. It uses the topic title as the name.

• Find Topic locates a topic within the project to add an index keyword topic or modify its properties.

Create index keywords with user-defined variables

User-defined variables let you create multiple versions of an index keyword.
1) In the Index pod, right-click a keyword. Select Properties.
2) From the Available Variables menu, select a variable. Click Add.

The variable is listed in the Index Keyword box.
3) (Optional) In the Index Keyword box, add a prefix or suffix to the variable. For example, add the 

prefix “Adobe” to the variable “RoboHelp.”
4) From the Topics list, select a topic to link this new keyword to.
5) Click OK.
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Cross-reference index keywords

You can cross-reference index keywords so that when users select the cross-referenced keyword in the 
index, an alternate keyword appears. The user can select it to display the topic.

You can cross-reference only index file keywords.
1) In the Index pod, add a keyword to cross-reference. (This keyword links to the alternate keyword).
2) Right-click a keyword. Select Properties.
3) Select Cross-References. From the pop-up menu, select an alternate keyword.

The cross-reference appears in the lower panel of the Index Designer.

Version-control projects may have more options.

Edit index keywords

Move and sort index keywords

When you move an index keyword, its subkeywords are moved.

Topic keywords are automatically sorted first numerically and then alphabetically.
1) In the Index pod, do any of the following:

– Select a keyword. Click an arrow button in the toolbar. A button is unavailable if the action 
isn’t allowed.

– Drag the keyword.
– Right-click a keyword. Select Sort > [sort option].

NOTE: The Sort command is unavailable with a binary index. The sort function is enabled only 
when the primary layout is HTML Help and the Index is set to Index File with no Binary Index. 
In all other layouts, the index remains sorted but for HTML output, the sorting of the index 
can be changed. Sorting enables the up and down keys on Index Pod.

Version-control projects may have more options.

Rename keywords for a project

This procedure renames keywords in the index and topic keywords.
1) In the Index pod, right-click a keyword. Select Rename.
2) Type the new keyword in the text box.

Rename keywords for a topic

To rename a topic keyword referenced by a specific topic, change the topic properties. If other topics use 
the same keyword, the original keyword remains in the index. Only the topic you change is updated.
1) In the Topic List pod, select a topic.
2) Click the Properties button .
3) Click the Index tab. Select a keyword.
4) Type the new keyword in the text box.
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5) Click Replace.

Change the capitalization of a keyword

1) In the Index Designer, select a keyword.
2) On the Index Designer toolbar, click the Lowercase  or Uppercase  button.

Remove index keywords from the Index pod

If you remove a keyword from the Index pod, it’s removed from all topics that were linked to it.
1) In the Index pod, select a keyword.
2) In the toolbar, click Delete.

TIP: Unused keywords in the index are not referenced by other topics. They appear in bold in the Index 
pod. You can automatically remove them.

Remove index keywords from topics

If you remove a keyword from a topic, only the topic you change is affected. Other topics that reference 
the keyword are still linked to it.
1) In the Topic List pod, select a topic.
2) Click the Properties button .
3) Click the Index tab.
4) Select a keyword from the list.
5) Click Delete.

Manage indexes

Manage indexes with reports

RoboHelp provides reports to use in managing indexes, such as the Index and Unused Index Keywords 
reports. The Index report lets you choose options to define how the report displays information. You can 
display all the keywords, a list of keywords with their related topics, or a list of topics and their related 
keywords.

The Unused Index Keywords report lists keywords that topics do not reference. These keywords reside 
in the index file. Use this report to identify keywords to remove or to associate with topics.

You can save, copy, print, and mail reports.
1) Select Tools > Reports.
2) Select a report, such as Index, and view the results.
3) Click Close.

Identify and fix broken references for keyword topics

1) In the Project Manager pod, open the Broken Links folder.
Missing topics are listed. They appear with a red X.
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2) Right-click a missing topic. Select Properties.
Keywords that reference the missing topic appear with a key icon . You can remove or relink the 
topic reference in the Index pod.

Remove topic references from keywords

NOTE: If you remove all topics from the keyword, the Index pod displays the keyword in bold text to indi-
cate that it is unreferenced.

If you select a keyword in the Index pod, the lower panel displays all the topics that reference it. You can 
remove any topic from this panel to remove the keyword from the topic. The name of the topic that is 
no longer in the project that references the selected keyword is displayed. If you remove the topic from 
this panel, the broken link is removed and the index file is updated.
1) In the Index pod, select a keyword.

The lower panel of the Index pod lists the topics that reference the keyword.
2) Select a topic. In the toolbar, click the Delete button .

Remove unused index keywords

Unused keywords aren’t associated with topics. The Index pod displays unused index keywords in bold. 
Unused keywords don’t appear in the index.

The index keeps unused keywords after you remove topics that reference them. This way, you can assign 
the keywords to other topics without having to read them.
NOTE: This procedure doesn’t remove keywords that have one or more subkeywords.
1) In the Index pod, select a keyword. In the toolbar, click the Delete button .
TIP: Select Tools > Reports > Unused Index Keywords to identify unused keywords.

Apply conditional build tags to an index

1) In the Index pod, select a keyword.
2) Click Edit > Tags > Apply > New/Multiple.
3) Select tags or click Check All.
4) Click OK.

Automatic indexing with the Smart Index wizard

Create an index automatically

Use the Smart Index wizard to search the content of topics. Select from suggested keywords.
NOTE: Close third-party files before running the Smart Index wizard.
1) Select Tools > Smart Index Wizard.
2) Select the search criteria.

Find New And Existing Index Keywords
Add keywords based on topic content and existing index entries.
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Add Existing Index Keywords To Topic(s)
Search topics for keywords already used and link the keywords to the topics.

Use Custom Search Settings
Select Settings, and set custom search options. In the Smart Index Settings dialog box, you can 
define an effective language to find index keywords. For example, if you define the project 
language as French and the paragraph language is English, the Smart Index uses English dictionary 
to identify keywords for the paragraph.

NOTE: This option is applicable for English language only.
In the Settings area of the Smart Index Settings dialog box, you can select options to include as 
keywords in the index. For example, capitalize or mixed words, phrases, words in a phrase or words 
not in the dictionary.

In the Other Settings area, you can select options to exclude as keywords from the index. For 
example, select verbs or adverbs to exclude and include adjectives or nouns as keywords.

3) Select items to search for index keywords.
4) To specify words or phrases to be ignored by the Smart Index wizard, select Always Ignore or select 

Phrases. Edit, add, or delete entries.
5) To capitalize the first letter of the keyword, select Capitalize All New Index Keywords. (You can 

change the case later in the Index pod.)
6) Click Next.
7) Select Confirm Adding Index Keywords For Each Topic.

To add keywords without confirmation, select Automatically Add Index Keywords For All Topics, and 
click Finish.

8) (Optional) Select filter options for the search.

Folder
Search topics in a specified folder.

Status
Search topics by status.

Check Only New Topics (That Have Not Been Smart Indexed)
Search only non-indexed topics.

9) Click Next. Suggested keywords appear for the first topic.
10) Select, deselect, rename, or remove keywords.

To skip to the next topic, click Skip. Click Options to add verbs, synonyms, and existing index key-
words.
NOTE: The Sentences Containing box shows the suggested keyword in the context where it is found. 
The Info field indicates whether the selected keyword is new or existing.

11) Click Next, and click Close in the Results dialog box.
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The new keywords appear in the Index pod.

Notes:

• You can change the case of keywords and subkeywords.
• You can link keywords to destinations other than topics.
• Index keywords are different from See Also keywords.

Specify keywords to ignore

You can create a list of words or phrases that the Smart Index wizard ignores. This list is the Always Ignore 
list.

When the Smart Index wizard searches topics, it checks the Always Ignore list. If it finds an exact match, 
it ignores that match as a potential keyword.
1) Select Tools > Smart Index Wizard.
2) Click Always Ignore.
3) Do one of the following:

– To add a word, click New and enter text.
– To edit a word, select it. Click Edit and enter text.
– To delete a word, select it. Click Delete.

The list is stored as a WLF file in the project folder.
NOTE: The words and phrases that you enter are not case sensitive unless they are uppercase words or 
mixed-case words. In these instances, the Smart Index wizard must find an exact match before 
suggesting a new keyword.

RELATED LINKS:
Change project settings

Specify common words to ignore

You can create a list of common words (such as a) that are ignored in the search results of the published 
output. This list is the Stop list.

The Stop list can be only 512 characters long. Every word in the Stop list contains one added unseen char-
acter. If the character limit is reached mid-word, the entire word is not compiled.
1) Select Tools > Smart Index Wizard.
2) Click Always Ignore.
3) Click the Stop List tab.
4) Do one of the following:

– To add a word, click New and enter text.
– To edit a word, select it. Click Edit and enter text.
– To delete a word, select it. Click Delete.

The list is stored as an STP file in the project folder.
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Version-control projects may have more options.

RELATED LINKS:
Change project settings

Specify custom phrases

For greater control over the index keywords (words and phrases) suggested by the Smart Index wizard, 
create a custom phrase list. This list of keywords is unique to the project. For example, you can include 
product names.

When the Smart Index wizard searches topics, it checks the phrase list. If it finds a match in a topic that 
is not a keyword in the topic, it suggests the item as a keyword.
1) Select Tools > Smart Index Wizard.
2) Click Phrases.
3) Click New.

– To add a phrase, click New and enter text.
– To edit a phrase, select it. Click Edit and enter text.
– To delete a phrase, select it. Click Delete.

The list is stored as a PHR file in the project folder. You can edit this file in a text editor, such as Windows 
Notepad.
NOTE: The words and phrases that you enter are not case sensitive unless they are uppercase words or 
mixed-case words. In these instances, the Smart Index wizard must find an exact match before 
suggesting a new keyword.

Look up synonyms for indexing

NOTE: This option is available only in English.
1) Select Tools > Smart Index Wizard.
2) Click Next twice.
3) Select a keyword.
4) Click Options. Select Synonyms.

The keyword appears in the Word box.
5) (Optional) Click Antonyms to see antonyms for the keyword.
6) Under Categories, select the best match for the word.
7) Under Synonyms, select a word to add as a keyword. Click Add To Topic.
8) Click Close.

TIP: To view synonyms and antonyms for additional words, type in the Word box and click Look Up.

Version-control projects may have more options.
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Multiple indexes

Create multiple indexes

You can create multiple indexes in the same project. New indexes are added to the Index folder. With 
multiple indexes, you can right-click any index and select Set As Default to set the index as default index. 
You can right-click an index and select Rename to rename the index as well.

You can copy and drag keywords across multiple indexes.
1) Do one of the following:

– In the Project Manager pod, right-click the Index folder. Select New Index.
– Click the Create/View Index File button. Click New.

2) Type a name in the text box.
3) (Optional) To copy an existing index, select Copy Existing Index. Click the browse button  to navi-

gate to the index.
4) Click OK.

Merge indexes

Follow this procedure to merge the indexes within a project.
1) In the Project Manager pod, open the Index folder.
2) Double-click an index.
3) In the Index pod, select a keyword where you want to insert the merged index.
4) Click the Insert Index Placeholder button .
5) From the Select Index menu, select the index to insert.
6) Click OK.

The merged index appears with the New Index icon .
7) Double-click the icon, and click View.

The merged index appears in the Index pod.

RELATED LINKS:
Automatic indexing with the Smart Index wizard

Create binary indexes (HTML Help)

TOCs and indexes in Microsoft HTML Help

Merging Help projects

TOCs and indexes in Microsoft HTML Help

Assign custom TOC icons (HTML Help)

1) In the Table Of Contents pod, right-click a book or page. Select Properties.
2) Click the Advanced tab.
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Under Image, Auto indicates that the book or page uses the standard icon.
3) From the pop-up menu, select an icon.

You can assign other icons to books and pages after you add the bitmap file (BMP) to your project.
4) (Optional) Select Mark As New to display the standard icon with a red star. The star indicates to 

users that the TOC item contains new information.
NOTE: The Mark As New option is available if the primary layout is Microsoft HTML Help.

5) Click OK.

Version-control projects may have more options.
NOTE: The Table Of Contents pod displays all books and pages with the standard icons regardless of the 
selection you make at the Advanced tab. After you generate the project, you can view icons in the 
Contents pane.

Create binary contents files (HTML Help)

Use binary contents files for large projects to reduce opening time.
IMPORTANT: Do not merge projects that use binary contents files.
1) In the Project Manager pod, double-click a table of contents in the Table Of Contents folder. The 

Table Of Contents pod appears.
2) Select Output > Open > Outputs Setup.
3) Expand the Single Source Layouts folder.
4) Right-click a layout. Select Properties.
5) Click Edit.
6) Click the TOC Styles tab.
7) Select Binary TOC.
8) Click OK.
9) Generate the project.

Version-control projects may have more options.

Create binary indexes (HTML Help)

Microsoft HTML Help projects require binary indexes in certain cases:
• When projects have topic keywords. Topic keywords are saved in the HTML files that reference 

them.
• When HTML projects are merged. When you merge projects, each CHM file remains in its own 

project, but keywords from each index file are combined into the master project. Distribute each 
CHM file along with the master CHM file.

1) Make sure that Microsoft HTML Help is the primary layout.
2) Select Project > File > Project Settings.
3) In the General tab, select Binary Index.
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4) Click OK.
5) Add topic keywords (marked with a key icon ).
6) Merge subprojects if needed.
7) Generate and view the project.

Version-control projects may have more options.

RELATED LINKS:
Merging Help projects

Generate, view, and publish output

Customize a TOC (HTML Help)

Select a custom font for displaying book and page titles, and synchronize books and pages with topic 
content. Use raised or sunken edges to give a three-dimensional look.
1) In the Single Source Layouts pod, right-click a layout for HTML Help output.
2) Select Properties.
3) Click Edit next to Advanced Settings.
4) Click the TOC Styles tab.
5) Set style options:

Border
Add a border around the table of contents.

Dialog Frame
Add a frame around the table of contents.

Plus/Minus Squares
Display plus and minus icons that open and close books.

Always Show Selection
Display the topic selected from the Contents tab (even if this tab is not the left-pane focus).

Folders Instead Of Books
Display folder icons instead of book icons.

Single-Click To Open Book
Enable books to open with one click.

Raised Edge or Sunken Edge
Create a three-dimensional appearance.
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Lines Between Items
Add lines between books and pages.

Lines From Root
Displays lines connecting books and pages starting at root.

6) Specify a font.
7) Set window, frame, and other options:

– To display the topic in a custom window, select the window name from Default Window.
– To display the topic in a custom frame, select the frameset name from Default Frame.
– To use custom book and page icons, select a BMP file from Custom Image File. Make sure that 

you include the image path, such as C:\Program Files\Adobe 
RoboHelp[version]\My.bmp. NOTE: For custom book and page icons, create an icon strip. 
See the MSDN Library on the Microsoft website.

8) Click OK.

Version-control projects may have more options. NOTE: The binary TOC option is recommended only for 
large Help systems. It requires compiled HTML Help and doesn’t support customization or external TOC 
files.

Customize an index (HTML Help)

The index type for the HTML Help project determines the index properties:

Index file keywords
For index file keywords in non-binary indexes, you can customize the keyword fonts. Click the Index 
tab in the HTML Help viewer.

Merged indexes
If merging indexes from CHM files, select the Binary Index option.

Topic keywords
If your index includes topic keywords, create a binary index.

1) In the Single Source Layouts pod, right-click a layout for HTML Help output.
2) Select Properties.
3) Click Edit.
4) Click the Index tab. Set properties:

Default Window
Select the custom window to display topics. Custom windows can link only to index file keywords.
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Default Frame
Select a custom frame to display topics. Custom frames can link only to index file keywords.

Select Font
Select a font name and size.

Version-control projects may have more options.

Add TOC controls (HTML Help)

When a user opens a topic, the table of contents appears.

If a topic is in a subfolder, copy the contents of the file into the subfolder before adding the control.
1) Open a topic in the Design view.
2) Click where you want to add the table of contents.
3) Select Insert > HTML > Javascript > Table Of Contents. The Contents control appears in the Design 

Editor.
4) To test the control, generate the project. The Table Of Contents control displays the same table of 

contents as in the final output.

Version-control projects may have more options.
TIP: You can link other contents files in your project. Copy the HHC file into the project if you want to 
select the HHC file with the TOC control.

Add index controls (HTML Help)

If your project does not support a tri-pane design, you can add an index control to a topic to make the 
index file available. The index appears when the topic is opened with the index control.
1) If the topic is in a subfolder, copy the index file (HHK) to the subfolder.
2) In the Design Editor, open the topic with the control.
3) Click where you want to add the index.
4) Select Insert > HTML > Javascript > Index.

The index control appears.

To test the index control, compile the project. The index control displays the same index as in the final 
output.

Version-control projects may have more options.
TIP: You can use other index files in your project. Copy the HHK file and associated files (topics, images, 
multimedia) to select the HHK file with the index control.
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Link keywords and TOC items to custom windows and frames (HTML Help)

Custom windows can display context-sensitive Help and links from index keywords, TOC books, and TOC 
pages.
1) Create a custom window or frame.
2) Do one of the following:

– In the Table Of Contents pod, right-click a book or page. Select Properties.
– In the Index pod, right-click an index file keyword. Select Properties.

3) Click the Advanced tab.
4) From the Window pop-up menu, select a custom window.
5) From the Frame pop-up menu, select a custom frame.
6) Click OK.

Version-control projects may have more options.
NOTE: Microsoft HTML Help doesn’t support links to custom windows from the topic, only links to 
pop-ups.

RELATED LINKS:
Link to a pop-up

Automatic indexing with the Smart Index wizard

Glossaries

Create glossary terms

1) In the Project Manager pod, double-click a glossary in the Glossary folder.
2) In the Glossary pod, type a term in the Term box.
3) Click the Add Term button (plus sign) or press Enter.

The term appears in bold, indicating that it doesn’t have a definition.
4) In the Definition For panel, type a definition.

You cannot use formatted text, tabs, or returns.
TIP: For terms and definitions to appear within topics, add expanding glossary hotspots.

5) If needed, enable the Glossary tab in the single-source layout wizard so that it appears in the 
output. Add at least one term and its definition to enable the glossary checkbox in the single-source 
layout wizard.

NOTE: (Microsoft HTML Help) When you distribute the final output, include an HHActiveX.DLL file with the 
CHM file. This DLL file is the ActiveX® control that supports online glossaries. This file must be copied to 
and registered on end-user Windows systems.
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Import glossary terms and definitions

TIP: Before importing a glossary file (GLO), print a detailed report of both glossaries. The reports can help 
you determine which terms exist in both glossaries and compare definitions.
1) In the Project Manager pod, select a glossary in the Glossary folder.
2) Select Project > Import > Glossary.
3) Click the browse button  to navigate to a GLO file.
4) Do one or more of the following:

– For definitions in the external glossary to overwrite matching terms, select Replace Existing 
Glossary Definitions.

– Select one or more terms in the Terms In Imported Glossary list. Click Add.
– To import all terms, click Add All .

5) Click OK.

Test and print glossaries

Test the glossary in the output

1) Make sure that the Glossary pod is enabled.
2) Generate a layout.
3) Click View Result.
4) Click Glossary.
5) Select terms and view their definitions.

Print a glossary

1) Click the Glossary pod.
2) In the toolbar, click Print.
3) From the pop-up menu, select the information to print.

Overview
Print all terms.

Detailed
Print all terms and definitions.

4) Click Properties and Page Setup to specify print options.
5) Click OK.
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Remove terms from the glossary

Removing terms doesn’t remove expanding glossary hotspots. Remove hotspots separately.
1) In the Project Manager pod, double-click a glossary in the Glossary folder.
2) In the Glossary pod, select a term from the list.
3) In the toolbar, click Delete.

RELATED LINKS:
Glossary hotspots

Change glossary definitions

NOTE: If you change a definition that is used as an expanding glossary hotspot, update the project by 
running the Glossary Hotspot wizard.
1) In the Glossary pod, select the term to change.
2) Edit the definition text.

Create multiple glossaries

You can create multiple glossaries in the same project. New glossaries are added to the Glossary folder.

You can copy and drag terms across multiple glossaries.
NOTE: You cannot delete the default glossary.
1) Do one of the following:

– In the Project Manager pod, right-click the Glossary folder. Select New Glossary.
– Click the Create/View Glossary File button . Click New.

2) Type a name in the text box.
3) (Optional) To copy an existing glossary, select Copy Existing Glossary. Click the browse button  to 

navigate to the glossary.

TIP: Click the Start Glossary Hotspot Wizard button  in the toolbar to mark existing glossary terms in 
topics.

Merge glossaries

1) In the Project Manager pod, open the Glossary folder.
2) Double-click a glossary.
3) Click the Import Glossary button .
4) Click the folder button . Select the glossary to merge. Click Open.
5) If needed, deselect Replace Existing Glossary Definitions.

Select this option to replace existing definitions in the glossary with definitions from the merged 
glossary.
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6) Select terms from the imported glossary list. Click the single right arrow to merge them. Click the 
double right arrow to merge all terms.
NOTE: Select terms in the current project list and click the Left Arrows to deselect terms selected for 
merging.

7) Click OK.

The merged glossary terms appear in the Glossary pod.

RELATED LINKS:
Glossary hotspots

Glossary hotspots

About expanding glossary hotspots

The Glossary Hotspot wizard finds glossary terms within topics and marks them in the topics. You can 
mark all terms to convert to expanding hotspot when you generate or preview output.

Notes:

• Expanding glossary hotspots require Internet Explorer 4.0 or later. If they are used in a style, they 
require Internet Explorer 5.0 or later. Netscape Navigator doesn’t support expanding glossary 
hotspots.

• The Glossary panel is not supported in Oracle Help. Definitions appear inline instead of in a hotspot.
• The glossary appears in the printed documentation and appears at the end of the page.
• Control the hotspot appearance by modifying the glossary term and character style in the Styles 

editor (accessible from the Stylesheets button in the Product Manager pod).
• The Output Generator With Glossary Restyling script restyles the glossary as popups or tooltips and 

generates output for a selected layout. See About ExtendScript Toolkit support.

Add expanding glossary hotspots

1) Do one of the following:
– Drag a term from the Glossary pod into a topic.

Use this method if the term doesn’t occur in the topic, or if the term isn’t in an ideal place to 
expand.

– In the Glossary pod, click the Glossary Hotspot Wizard button .
The Glossary Hotspot wizard finds glossary terms within topics and marks them in the topics. 
You can mark all terms to convert to expanding hotspot when you generate or preview output.

Preview a hotspot by double-clicking it in the Design Editor.
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Update expanding glossary hotspots

The Glossary Hotspot wizard inserts markers for the terms defined in the selected glossary. It doesn’t 
insert definitions for terms in the topic. When you generate a preview or output, RoboHelp adds defini-
tions for the terms. As a result, topics always have the updated definitions for marked terms.
1) Choose Project > Open > Pods> Glossary and click Glossary Hotspot Wizard.
2) Select options. In the Select Term menu, select an individual term or all terms.

Confirm Marking Terms For Each Topic
Select to choose which terms in topics are marked to expand as glossary hotspots.

Automatically Mark Terms For All Topics
Tell the Glossary Hotspot wizard to mark all glossary terms it finds in topics to expand to glossary 
hotspots.

Case-Sensitive
Makes search case sensitive.

Mark Only The First Instance Of Term In Topic And Unmark Subsequent Instances
Select this option to turn the first marked instance of a term into an expanding glossary hotspot 
when you preview or generate output.

3) Click Next.
Select a term to mark in a chapter.

4) To assign the new definition to the term, select the box next to the term that does not match.
5) Click Next. Repeat steps for each topic that the Glossary Hotspot wizard displays.
6) Click Finish.

Test expanding glossary hotspots

1) In the Topic List pod, right-click the topic containing the hotspot.
2) Click View.
3) Click the glossary term in the topic.
4) Click the term again to close the hotspot.

Unmarking expanding glossary hotspots

Unmark hotspots using the Glossary Hotspot wizard

1) Choose Project > Open > Pods> Glossary and click Glossary Hotspot Wizard.
2) Select Confirm Adding Definitions For Each Topic.
3) Select a folder and status to search.
4) From the Select Term menu, select the term to remove.
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5) Click Next.
6) As each topic appears, deselect the check boxes to remove expanding glossary hotspots.
7) Click Finish.

Unmark hotspots in Design view

1) Open the topic in the Design view. Select the term.
2) Right-click and select Remove Expanding Text.

You can click the definitions of marked glossary terms in the Glossary Definition Viewer but you cannot 
edit the term definition. NOTE: When you upgrade a glossary from an older version, all the local changes 
are lost.
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Linking, navigation, and search

Navigation basics

Navigation options

The following navigation options are available for use in Help projects.

Hypertext links
Open the link destination.

Pop-ups
Display an HTML topic in a pop-up window rather than in the default viewer. Pop-ups can be linked 
only to another HTML topic or to bookmarks.

Link controls
Clickable objects that open a list of related topics. Types of link controls are See Also, Related 
Topics, or Keyword Links.

Breadcrumbs
These links appear on a Help page and outline the position of the page in the table of contents, or 
the directory structure of the project.

Browse sequences
The sequence of a series of topics. You define the order of topics in the sequence.

Searches
Find topics that contain search keywords. The search results appear as links in the Search tab of the 
navigation pane. The search keywords are highlighted in the topic pane.

In-topic navigation bars
Navigation bars added to a layout using WebHelp as the output type.

Expanding hotspots, drop-down hotspots, and twisties
Text links that expand to display additional information, but not other topics. These hotspots are 
available in browsers that support Dynamic HTML (DHTML).

Text-only pop-up
A window that displays only text, not topics or web pages. Text-only pop-ups are useful for defini-
tions or details. Unlike regular pop-ups, a text-only pop-up resides in the topic that contains it. It’s 
not a separate topic.
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Image maps
An image in an HTML topic that contains graphical links to other topics. Clickable areas in the image 
are hotspots.

Image links
A link in an image that takes users to a destination or opens a pop-up. Creating image links is like 
creating text links.

Bookmarks
A link that takes users to a specific place in a topic.

WinHelp topic control
(Microsoft HTML Help only) A clickable object that opens a WinHelp system.

You specify many of these features through settings in the Properties > Navigation dialog box for the 
specific layout:

Show Navigation Pane Link In Topics
Select to include a link to the navigation pane in topics that are opened through the context-sensi-
tive Help calls.

Add Breadcrumbs Links
Select to add breadcrumbs in the topic pages.

Show Merged TOC In Child Project
Select to view the merged TOC in the child project.

Format
Click to change the format of breadcrumbs.

Show Context In Search Result
(WebHelp, FlashHelp) Select to display the context of topics in search results.

Enable Highlight Search Result
Select to highlight the search results in Topics. Select the color to highlight the search results.

Add About Box
Set up information that appears in a dynamic window when users click the image in the main 
toolbar.

Example of About box

Browse Sequences
Create browse sequences before enabling them.
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Detail
Change the text displayed for the in-topic navigation bar elements.

Search Input Field In Toolbar
Include a search field in the main toolbar.

Synchronize Table Of Contents
Synchronize the TOC with the topic in the right pane so that users see where they are in the struc-
ture.

• To synchronize the TOC automatically, click the pop-up menu and select Automatically.
• To add a button that users can click to synchronize the TOC, click the pop-up menu and select 

Manually. NOTE: If you use custom skins, provide a button icon in the WebHelp Skin Editor.

About breadcrumbs

Breadcrumbs are navigational links displayed in web pages of the Help system. These links outline the 
position of the page in the table of contents or the directory structure of the project. You can define 
breadcrumbs in a master page or a topic. They can also be configured at run time to appear on the top 
or bottom of a page.

The user can click a portion of the breadcrumb trail to go directly to a page. For example, if the trail is 
Home > Installation > Hardware Requirements, the user can click Installation to go directly to the Instal-
lation page.

Breadcrumbs are displayed in merged projects. The breadcrumb trail for a page in a merged project 
shows the position of the page with respect to the merged project and the master project.

For example, suppose the master project MultiCuisine contains the project AsianCuisine. AsianCuisine in 
turn contains the project JapaneseRecipes. The breadcrumb trail for the topic “Common Japanese Ingre-
dients” is as follows:

Home > MultiCuisine > AsianCuisine > JapaneseRecipes

Breadcrumbs are generated only in WebHelp, WebHelp Pro, FlashHelp, FlashHelp Pro, HTML Help, and 
AIR Help. For all other layouts, breadcrumbs are not generated, even if placeholders are present.

Add breadcrumbs to topics

1) Select Output > Open > Outputs (SSL).
2) Double-click the WebHelp/WebHelp Pro/FlashHelp/FlashHelp Pro layout, and do the following:

– (WebHelp) In the Navigation pane, select Add Breadcrumbs Links, and click Format.
– (WebHelp Pro/FlashHelp/FlashHelp Pro) Click Next. Select Add Breadcrumbs Links and click 

Format.

3) In the Layout area, select the placement and alignment for the breadcrumbs.
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4) In the Text area, select or specify a name for the link to the main Help page, which appears on every 
topic page.

5) Select a separator for the Breadcrumbs.
6) Type a label that precedes the breadcrumbs trail. For example, you can add the static text "You are 

here" before the breadcrumb trail.
7) Preview the layout and formatting of breadcrumbs in the Preview pod.
8) Select a background color.
9) (Optional) Select Use Topic Level Format to use the default format settings.
10) (Optional) Click Format to change the default font settings.
11) Click OK, and then click Finish.

In the generated WebHelp, all the topic pages show a breadcrumb trail reflecting the TOC hierarchy.

RELATED LINKS:
Insert a placeholder

Create text links

You can create links with most items you see in the Project Manager and TOC Composer. These items 
include topics, bookmarks, URLs, baggage files, newsgroups, FTP sites, files (such as PDF) associated with 
other programs, and remote topics.

Use Design Editor to create text links

1) In the Design Editor, select the insertion point for the link.
2) Click the Insert Hyperlink button .
3) Select an option from the Link To menu. Specify the source location in the box.
4) If Display In Frame is selected, select an option from the pop-up menu.

Display In Frame
If the destination is a frame, this option defines the frameset for displaying the destination content. 
You can select the frame type or enter custom frame information. This option is unavailable for 
linking to topics.

Display In Auto-sizing Popup
Displays the destination topic in a pop-up window rather than in the viewer or browser. The 
window size adjusts to the content. If you have a long topic, use a custom-sized pop-up.

Display In Custom-sized Popup
Displays the destination topic in a pop-up window. To manually size the window, type a number in 
the Width and Height fields. If the text goes beyond the pop-up's height or width, the pop-up 
includes scroll bars. This option is available only for linking to topics.
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5) Add tool tip text to appear when you hover over the link.
6) Select a local topic, bookmark, frame, or URL that exists in your project as the link destination. To 

filter the list, click the triangle.

Drag to create links

1) In Design Editor, select the item in the topic for the hotspot. Select text, an image, or a multimedia 
object.

2) In the Project Manager pod, open the folder containing the destination item (such as a URL in the 
URLs folder, or a topic in a custom folder).

3) Locate and select the destination item.
4) (Optional) Click the TOC tab to display the TOC Composer or the Project tab to display the Project 

Manager.
5) Drag the destination item from the Project Manager pod or Topics List pod onto the selected item 

in the Design Editor.

NOTE: Topics with information types are not supported as links.

RELATED LINKS:
Image maps

Link to a pop-up

You can create a link that displays an HTML topic in a pop-up rather than in the default browser or viewer. 
A pop-up supports HTML formatting, images, Dynamic HTML, link controls, and other HTML features of 
the destination topic. When a user clicks the link, the pop-up opens and sizes to fit either the content of 
the topic or dimensions that you specify.

A pop-up can be used only to link to a topic or bookmark within the project.
1) In the Design Editor, place the cursor where you want a link, or select text or an image to define a 

hotspot.
2) In the toolbar, click the Insert Popup button .
3) Select Hyperlink Options.
4) Select a size option. If you choose Custom-Sized Pop-up, enter values in points in the Height and 

Width boxes. NOTE: Scrolling inside auto/custom pop-ups may not work in Multiscreen HTML5 
output on some devices.

5) Under Select Destination (File Or URL), select a topic , bookmark , or frameset.
6) Click OK.

NOTE: A link within a pop-up to another pop-up doesn't work in the HTML Help viewer or in Internet 
Explorer.
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Exclude pop-ups from full-text searches

1) Create a small HTML Help project to contain the pop-up topics.
2) Generate the project to create a CHM file.
3) Link to the pop-up topics in the second CHM file. (Do not merge the two Help systems.)
4) Distribute both CHM files to users.

RELATED LINKS:
Text-only pop-ups

Bookmarks

Use bookmarks to create incremental links within a topic. You can link to a bookmark from within the 
topic itself; from any other topic in your project; or from an index entry, TOC entry, or image map. The 
Bookmark icon  appears next to bookmarked objects. To view bookmarks from the Project Manager, 
click the plus sign  next to a topic.

Create bookmarks

1) Click left of the location for the bookmark.
2) Do one of the following:

– Click the Insert Bookmark icon .
– Select Insert > Links > Bookmark.

3) Enter a name, without spaces, using any combination of letters and numbers.

After you save the topic, bookmark icons appear indented under topics listed in the Project Manager pod 
and next to topics in the Topics List pod.

Create links to bookmarks

1) Open the destination for the link. To create a link within a topic, create a bookmark in the topic.
2) In the Design Editor, select the link location and then click the Insert Hyperlink button .
3) Under Select Destination (File Or URL), select the bookmark to link to.
4) Click the View icon  to test the link.

NOTE: Bookmarks are grouped with their topics.

Rename bookmarks

1) Open the topic with a bookmark. Select the bookmark, right-click it, and select Bookmark [book-
mark name] Properties.

2) Edit the name and click OK.
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3) Unassign and reassign the map ID for the renamed bookmark.
4) If the bookmark is used in context-sensitive Help, edit the map ID.

Locate bookmarks

1) Open a topic in the Design Editor.
2) Select Insert > Links > Go To Bookmark.
3) Select a bookmark to locate.
4) Click Go To.

Remove bookmarks

1) Remove all links to the bookmark.
2) Select the bookmark icon in the topic. In the toolbar, click the Delete button.

RELATED LINKS:
Edit a map ID

Link images and multimedia

Add links to multimedia clips

You can include links to image, video, sound, and other multimedia files.
1) In the Design Editor, place the cursor where you want the link, or select text or an image to create 

a hotspot for the link.
2) Click the Insert Hyperlink button .
3) In Link To, click the triangle button  and select Multimedia.
4) Select the file to link. Click Open.

Add links from images and multimedia

Topics can include multimedia as links, sound or video clips, local or external HTML topics, bookmarks, 
web or FTP sites, e-mail, or newsgroups.
1) In the Design Editor, click the multimedia object or the image to link.
2) Click the Insert Hyperlink button .

– To link from multimedia, in Link To, click the triangle button  and select Multimedia.
– To link from images, select the destination. Images can contain only one link.

TIP: Link from a sound or video object in the topic by right-clicking the object and selecting Insert 
Hyperlink.
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External links

Link to external topics (Microsoft HTML Help projects)

1) In the Design Editor, select a link location.
2) Click the Insert Hyperlink button .
3) In Link To, click the triangle button  to select Remote Topic.

Link to external files

1) Choose a link location in the Design Editor.
2) Enter text.
3) Highlight the text and click the Insert Hyperlink button .
4) Click the triangle button  next to Link To and then select File.
5) Browse to a file, open it, and copy it into the project folder.
6) Generate the file to test links to external topics.

WebHelp projects
The external file must be distributed in the WebHelp folder.

Microsoft HTML Help projects
The external file must be distributed with the CHM file.

NOTE: The external CHM file must be in the same folder as the project CHM file.

Link to WinHelp topics (Microsoft HTML Help projects)

Add WinHelp topic controls to link to a topic in a WinHelp file from an HTML topic.
1) In the Design Editor, click a location for the control.
2) Select Insert > HTML > Javascript > WinHelp Topic.
3) Set the button options.
4) Click Next. Select the WinHelp file and topic.
5) Click Next. Set font options for the button label.
6) Click Finish.
7) To test the project, generate it.

Link to e-mail addresses, FTP sites, newsgroups, and web addresses

1) In the Design Editor, choose a location for the link or select text or an image to define a hotspot.
2) Click the Insert Hyperlink button .
3) In Link To, click the triangle button  and then do any of the following:
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– To link to e-mail, select Email.
– To link to FTP sites or newsgroups, select FTP or Usenet News.
– To link to intranets or websites, select Web Address.

Link View

Use Link view to view and navigate project links.

Navigate in the Link View pod

The icon in the center of the Link View pod represents the current topic. Lines on either side of the icon 
represent inbound and outbound links. Each line is color coded to denote the type of link.
1) Select Project > Open > Pods > Link View. Link View appears as a document in the Doc Pad.
2) Select the pod (workflow pane) from which to drag topics. Do any of the following:

– To display topics from the Project Manager, select Project > Open > Pods > Project Manager.
– To display topics from the TOC Composer, select Project > Open > Pods > TOC.
– To display topics from the Index Designer, select Project > Open > Pods > Index.

3) Select a topic from Topics For, and then drag it into the center of Link View. Click the previous and 
next buttons to view the connected links.

4) To view another topic's links, in Link View, drag a topic on top of the one in the center of the group 
to display all links to and from it.

Change the appearance of links in the Link View pod

Change icon sizes

1) Select Project > Open > Pods > Link View.
2) Click the Use Small Icon button .

NOTE: The tool tip text indicates the action you can perform on the icons.

Set Link View scroll features

1) Select Project > Open > Pods > Link View.
2) Do any of the following:

– To scroll the topic with the linked topics, click the Keep Topic Elastic button .
– To scroll hyperlinks only, click the Keep Topic Centered button .
– For large projects, click the Display Limited Links button .

Set options in the Link View pod

Click the icons to see different types of links.
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• The current topic is in the center and has a blue border.
• Inbound links appear on the left.
• Outbound links appear on the right.

Define use of the Link View window.

Icon Size
Sets the size of the icons used to display topics. You can use small or large icons.

Center Topic Placement
Positions the center with inbound and outbound links.

Move Center Topic With View
Positions the topic to scroll with the links in the window.

Keep Center Topic Centered
Keeps the center topic stationary while links move with the scroll bar.

Link maintenance and repair

Update and remove links

Open the topic containing the link. Do any of the following:
• To update the link, right-click the link, select Hyperlink Properties, and make changes.
• To remove a link, right-click the link and select Remove Hyperlink.
• To remove the link and the text, select the text and press Delete.

Manage broken links

To identify broken links, use the Broken Links folder in the Project Manager. It displays the names of 
deleted or missing topics that are referenced in a project.
1) Select these options from the Tools menu to identify and fix broken links:

Show Topic Links
Displays a topic in Link View.

Show Topic References
Identifies references for one topic. Use this option to determine whether the topic is referenced in 
a TOC or index and whether other topics link to it.
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Enable BugHunter
For context-sensitive topics in Microsoft HTML Help systems. Use this option to diagnose problems 
that can occur when linking HTML Help systems to Windows applications.

Resolve Broken Links
Identifies missing or deleted topics that caused broken links. Use this option to determine where 
the broken links originate and to restore topic links.

Edit Topic References
Lets you look up references for topics in a project. Use this option to determine where references 
originate and to modify them.

Edit External Topic References
Identifies external topics (such as remote links or URLs) that are referenced in a project. Use this 
option to modify or remove them from the project.

Fix broken links

1) Select Project > Navigation > Topic References > References To Selected Topic.
– To fix a link, first select a link. Then click Edit, and edit or remove the hyperlink.
– To fix a TOC item, index keyword, or image map, first select the item. Then click Edit, and 

select a valid destination to repair the broken link.
– To remove TOC entries, select the TOC item and click Delete. The book or page is removed 

from the table of contents.

NOTE: If you use version control in a multi-author environment, some files might link to topics that have 
been moved, renamed, or removed by another author. If you don't have the latest version of the files, 
they appear as broken links.

Identify and update topic references

Identify topic references

1) From the Topics List pod or the Project Manager pod, select a topic.
– To show references for a single topic, right-click the topic and select Show > Topic References.
– To show references for all topics in the project, select Tools > Edit Topic References. On the 

right, select a topic. The left view shows all topic references.

Update topic references

1) Select Project > Navigation > Topic References.
– To fix broken links, in References To Selected Topic, select the link to repair. Click Edit or 

remove the link.

RELATED LINKS:
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Change an image map

Identify and update external topic references

1) Select Project > Navigation > External Topic References.
2) Do any of the following:

– To identify external references, select the topic.
– To fix broken links, in References To Selected Topic, select the link. Click Edit and make 

changes.
– To fix or remove TOC items and entries, in References To Selected Topic, select the item. Click 

Edit and select a destination, or click Delete.

NOTE: You cannot change index keywords from this dialog box.

RELATED LINKS:
Fix broken links

View and test hyperlinks

View hyperlinks and identify browse sequences

In the Design Editor, right-click and select Show Topic Links. Or, use the procedure that follows.
1) Select Project > Open > Pods > Link View. The Link View pod appears.
2) Drag topics from the Project Manager pod into the Link View pod.
3) Click the Project Manager pod.
4) Open the HTML Files (Topics) folder or a custom folder, and select a topic to view.
5) Drag the topic into the Link View pod over the center Link View icon .
6) Release the mouse button to display links.

Test links in a topic

1) Select Project > Open > Pods > Topic List. The Topic List pod appears.
2) Right-click the topic and select View.
3) Click links to test them.

RELATED LINKS:
Browse sequences

Link controls

About link controls

Link controls are navigational alternatives to the TOC and index. A link control works like a link and can 
appear as text, a button, or an image.
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NOTE: When you update a topic, make sure that its link controls are up-to-date. Deleting a topic or 
changing a topic title, topic content, or filename can affect link controls.

Link controls function in the following ways:
• Direct users to related topics and information. Link controls can save users time spent searching.
• Organize information for different kinds of users.
• Manage topic content by keeping information needed by multiple topics in a single topic and 

providing access to it from several places with link controls.
• Manage topic layout by inserting link controls as objects rather than as long lines of links.

Types of link controls

Related Topics
Displays a list of topics that you specify. You change the related topics list by topic, according to user 
need. Related Topics controls require more maintenance than other link controls. If you add or 
remove topics, make sure that you add or remove the topics in each Related Topics control.

See Also
Displays a list of topics that you group into a logical category. All topics assigned to identical See 
Also keywords appear in a list when users click See Also. See Also controls require less maintenance 
than other controls because you define the group of topics in one location (not in each topic). Make 
sure that you update the See Also control when you add or remove topics. Automatic updates occur 
in each topic containing the control.

Keyword Links
Controls that let you use index keywords for navigation within topics. Indexes group related topics 
based on keywords. When a user clicks an index keyword, an associated topic list appears. If you 
add or remove an index keyword in the index or in topic properties, the control updates within each 
topic that contains it. Keyword Link controls are usable with main-level, or parent-index keywords.

Keyword link properties

Assign index file keywords and topic keywords from the index file to Keyword Link controls.

Keywords In Project
Display all keywords available for the control.

Keywords In Control
Display keywords assigned to the control.

Add
Select the keyword from Keywords In Index. Select Add.

Delete
Select the keyword from Keywords In Control. Select Delete.
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For HTML Help projects:

Set Remote Keywords Use keywords from other CHM files. NOTE: While similar to the Related Topics 
control, the See Also control has the added feature of being able to leave out of its list, the topic where it 
is placed. In addition, it can be automatically updated in each topic containing the control. This means 
that the control can be copy/pasted among associated topics.

Add Related Topics controls

TIP: Changes you make to titles or filenames are not applied to the Related Topics control.
1) In the Design Editor, click a location for the control.
2) Click the Insert > Related Topics.
3) Choose an option to show related topics as a button, which can be a label or an image, or to show 

related topics as text.
4) From Topics In Project, select a topic and click Add. Continue to add all topics you want to appear 

as related topics. NOTE: The URL box displays the location of the topic file linked, and Title shows the 
title of the topic page.

5) (Optional) Click Change to update the topic name in Related Topics.
6) Choose options to display in a Topics found dialog or in a pop-up menu.
7) Select an option to display the selected topic in a frame or new window.
8) Select display and font options.
9) Click Finish and then click the View button  to test.

NOTE: (Microsoft HTML Help) If the topic contains a Related Topics control, the links might not work prop-
erly because of a known Microsoft HTML Help bug. Consider using See Also controls, Keyword Link 
controls, or standard HTML links.

Related Topics wizard

Use the Related Topics wizard to change how a link for a Keyword Link or Related Topics control appears: 
as a button with text or an image, as plain text, or as a hidden control that works with scripts.

Button
Defines how a control appears in a topic.

Label
Displays a control as a square gray button with black text. The text in the box displays on the button. 
You can edit the label.

Image
Displays a control as an image. The image filename appears in the box below this option. (You can't 
add a text label to an image or edit the label in RoboHelp.) To select an image, click the Browse 
button , and then select an image from the dialog box. Save the image as a Windows bitmap 
(BMP) and icon (ICO) file.
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Text
Displays a control as a text link (Example: More information).

Hidden (For Scripts)
Hides the control. Used for a topic to which you add a script. The control isn't visible in the topic. 
Work with a developer to configure a script.

(HTML Help Projects Only) If No Topics Are Associated With Any Of The Keywords, Disable The Button
If you create a Keyword Link control and then remove all the keywords assigned to the control, the 
control is disabled when a user opens the topic.

Choose Topic From
Defines how the list of topics is displayed when a user clicks a link control.

Topics Found dialog
Displays the list of topics in a Topics Found dialog box. The topic appears when a user selects a topic 
and then clicks Display.

Popup Menu
Displays the list of topics in a pop-up menu. Users select a topic to open it.

Frame
Specifies a frame in which to display a topic when the keyword is clicked. Custom framesets appear 
in the list.

For HTML Help projects using See Also or Keyword Link controls:

If no topics are associated with any of the specified keywords, disable the button
Disables the control if there are no topics associated with the control keywords. For example, if you 
create a Keyword Link control and then remove all the keywords assigned to the control, the 
control is disabled when users open the topic.

Create, assign, and add See Also keywords and controls

Create and assign See Also keywords

1) Do one of the following:
– Double-click the See Also folder in the Project Manager pod. The See Also pod appears.
– Type the See Also keyword in the text box. Click the plus sign.
– Click the Add New See Also Keyword button  icon. Type the new keyword and press Enter.

The keyword appears in bold, indicating that no topics are associated with it.
2) To assign topics to the See Also keyword, click the Topic List pod and do one of the following:
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– To add the keyword to multiple topics, select a topic, drag it into the lower pod, and repeat 
for all topics you want to assign.

– To add the keyword to individual topics, click the Topic List pod, select a topic, click the Prop-
erties button , and select See Also. Type the keyword to assign to the topic and click Add.

3) Add a See Also control to the new keyword.

See Also pod

New See Also Keyword
Create a See Also keyword.

Add Keyword
Add the See Also keyword entered in the box.

New Keyword Topic
Assign a keyword topic.

Find Topic
Find topics based on search criteria.

Set See Also Keywords in the See Also wizard

The See Also wizard appears when you try to insert a See Also control in a topic (Insert > See Also).

See Also Keywords In Project
Display a list of all available See Also keywords.

Add
Select the name from See Also Keywords In Project to add.

Delete
Select the name from See Also Keywords In Control to delete.

See Also Keywords In Control
Display See Also keywords assigned to the control.

For HTML Help projects:

Set Remote See Also Keywords
Use See Also keywords from other CHM files.

Set keywords in a remote CHM file

NOTE: HTML projects only.

The CHM file is copied to the project folder. Keywords are referenced only from the CHM file.



252

LINK CONTROLS
CHAPTER 8 LINKING, NAVIGATION, AND SEARCH

CHM File Name
Enter the remote CHM file to reference.

1) Click the Browse button  to browse for remote CHM files.

Keyword
Enter the keyword to reference. Type the name exactly as it is used in the CHM file.

Add
Add a keyword to Remote Keywords In Control.

Delete
Remove keyword from Remote Keywords In Control.

Remote Keywords In Control
Display the keywords insert.

Set See Also keywords in a remote CHM file

NOTE: HTML projects only.

Use See Also keywords in the Help project that are used in other CHM files. The CHM file is copied to the 
project folder. See Also keywords are not copied.

CHM File Name
The remote CHM file

Browse button
Click to browse to the remote CHM file.

See Also Keyword
Type the name of the See Also keyword exactly as it is used in the CHM file.

Add
Add the See Also keyword to the Remote See Also keywords in the control field.

Delete
Remove the See Also keyword from the Remote See Also keywords in the control field.

Remote See Also Keywords In Control
Display the See Also keywords to insert into the control.

Add See Also controls

1) Create See Also keywords.
2) In the Design Editor, click a location for the control.
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3) Click Insert Help Control .
4) Select See Also.
5) Select the link options.
6) Under See Also Keywords In Project, select a See Also keyword.
7) Click Add. Repeat for all keywords you want to add. Click Next.
8) Select display and font options.
9) Click Finish. To test the control, generate the project.

Change, reuse, or remove link controls

1) In the Design Editor, open a topic containing the link control.
– To change a control, double-click the control and change its properties.
– To reuse a control, right-click the control and select Copy. Right-click in the destination topic 

and select Paste.
– To remove a control, select the control and click Delete .

Text-only pop-ups

Work with text-only pop-ups

Text-only pop-ups are short text passages, such as definitions, that appear when a user clicks a linked 
term. You can insert a text-only pop-up anywhere except in topic headers and footers. For longer text 
passages, or if you need graphics, use a regular pop-up.

RELATED LINKS:
Link to a pop-up

Create text-only pop-ups

1) In the Design Editor, select the text.
2) From the Insert menu, select Text-Only Popup.
3) Type the pop-up text directly into the window.

Edit text-only pop-ups

1) Right-click the text-only pop-up and select Text Popup Properties.
– To edit the text, type in the Popup Text box.
– To edit background color, fonts, and margins, click in the appropriate box and make the 

changes. Your selections apply to text-only pop-ups you create in the future.

2) To test, click the View button  and select the text-only pop-up.
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Remove text-only pop-ups

1) Right-click the pop-up and click Remove Text Popup.

Test text-only pop-ups

Test before generating

1) From the Design Editor, open the topic containing the text-only pop-up.
2) Click the View button .
3) Click the text-only pop-up.

Test after generating

1) Click the View Primary Layout icon . If you are prompted to generate, click Yes.
2) Navigate to the topic containing the text-only pop-up.
3) Click the text-only pop-up.

Browse sequences

Create or edit browse sequences

Use browse sequences to provide a path for your readers to move through a series of topics. When 
working with browse sequences, keep in mind the following:
• You cannot include HTML files or external topics from other Help systems in browse sequences.
• A single topic can belong to multiple browse sequences.
• Each type of Help displays browse sequences differently. In WebHelp layouts, you can enable or 

disable browse sequences at a project level. In both WebHelp and Adobe AIR layouts, you can select 
the browse sequences that you want to display. If the layout defines content categories, you can 
select browse sequences for each content category. For information about how to enable or 
disable browse sequences and select them for content categories, see Configure the Adobe AIR 
layout and Generate WebHelp output.

Create browse sequences automatically

An automatically created browse sequence replaces existing browse sequences.
1) Create the table of contents.
2) Select Project > Browse Sequences.
3) Click Auto-Create Using TOC.
4) Enter the number of levels from the TOC hierarchy that you want to include in the browse 

sequence, and click OK.
5) Click OK. If the Enable Browse Sequence dialog box appears, click Yes.
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Create browse sequences manually

1) Select Project > Browse Sequences.
2) Click New and then name the browse sequence.
3) From Available Topics, select the folder containing the topics you’re adding.
4) Add topics to the browse sequence.

– To move a single topic, select the topic and click Add, or click the Add Browse Sequence 
button  to move it.

– To move a group of topics, select the folder containing the topics and click the Add All Browse 
Sequence button .

5) Click OK. If the Enable Browse Sequence dialog box appears, click Yes.

Remove a topic from a browse sequence

• From the Browse Sequence list, select the topic and click Remove.

Rename or remove a browse sequence

From the Browse Sequence list, select the browse sequence.
• To remove it, click Remove.
• To rename it, click Rename and enter the new name.

View and test browse sequences

Identify topics associated with browse sequences

1) Select Project > Browse Sequence Editor.
2) Under Browse Sequences, click the plus sign  next to each browse sequence to display the topics.

Test browse sequences

Topics that belong to multiple sequences appear within the browse sequence that is listed first in Link 
View.
1) Select Project > Open > Pods > Link View. The Link View pod appears.
2) Click the Project Manager tab.
3) In the Project Manager, open the HTML Files folder and select a topic.
4) Drag the topic into the Link View pod.

When a yellow line appears around the Link View icon , release the mouse button to display links 
to and from the topic.
If the topic is part of a browse sequence, the Previous  and Next  buttons appear above and be-
low it.

5) Click the Previous and Next buttons to test the browse sequence.
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View sequences for a single topic

1) Select a topic.
2) Click the Properties button .
3) Click the Advanced tab.

Test browse sequences in a browser or view

1) Verify that browse sequences are enabled.
2) Click the Generate button  to generate.
3) Click View Result and click through the browse sequence.

Identify the browse sequences a topic is assigned to

1) Open a topic in the Design Editor.
2) Click the Properties  button.
3) Click the Advanced tab.

RoboHelp output search

RoboHelp offers a variety of options through which you can add search metadata, optimize the contents 
of a project for search, and configure the search experience of end users.

RoboHelp search basics

RoboHelp supports these features for search in the output:

Multiple language search
RoboHelp search supports multiple languages at the project, topic, and paragraph level. For 
example, suppose users search for a German word in an English topic with an embedded German 
paragraph. If RoboHelp finds the German word, it displays the English topic with the German word 
highlighted.

Chinese/Japanese/Korean (CJK) search
WebHelp and FlashHelp output in RoboHelp supports keyword search, which means a user query 
is broken into individual words and then each word is looked up in the project content. Breaking a 
search query into individual words is not easy for Chinese/Japanese/Korean languages because 
those languages do not clearly mark word boundaries.

The search functionality with WebHelp, FlashHelp, AIRHelp, and browser-based AIRHelp output 
recognizes CJK content in search queries, so that the results you get are more useful. NOTE: Robo-
Help looks up every contiguous sequence of CJK characters as a whole and shows only those topics 
that match the entire search query in the same sequence.

To search for multiple CJK words, separate the words in the following ways:



257

ROBOHELP OUTPUT SEARCH
CHAPTER 8 LINKING, NAVIGATION, AND SEARCH

• Use logical operators AND or OR
RoboHelp looks up each CJK word and then shows results depending on the operator used.

• Use space
RoboHelp does a phrase search if you use space to separate words.

NOTE: Support for CJK search does not impact indexing of content in RoboHelp Server.

Substring search
(WebHelp/Pro, FlashHelp/Pro) If you enable this feature, a search for "log" returns topics 
containing the words "catalog" and "logarithm." Substring search takes longer than whole-string 
search.

NOTE: In merged projects, substring search works when enabled in both the master project and child proj-
ects.

Phrase search
To search for a phrase, users need to enter it in quotation marks in the search box. If the search 
term is "color swatch," RoboHelp returns all topics with the phrase "color swatch".

AND search
(WebHelp, WebHelp Pro, and AIR Help) By default, RoboHelp performs OR search when a user 
types multiple words without enclosing them in quotation marks. This means that RoboHelp finds 
all topics that have any of the words specified in the Search box. If you select the Allow AND Search 
In Output option in SSL settings, RoboHelp performs AND search when a user types multiple words 
without enclosing them in quotation marks. RoboHelp finds only the topics that have all the words 
specified in the Search box. AND search can be used in combination with phrase search.

In SSL settings, you can also specify whether or not AND search should be enabled by default. In 
addition, when AND search is supported in the output, end users have the option to enable or 
disable it.

NOTE: In merged projects, child projects inherit the setting of the parent project. In projects with DUCC 
(content categories), the setting applies to all content categories.

Boolean operators in search
(WebHelp) Users can narrow down the scope of search by combining search terms using the 
Boolean operators AND, OR, and NOT.

Ranking of search results
RoboHelp ranks search results based on their relevance. For example, if a word appears in the title 
of a topic, its rank is higher than the word in the topic keyword list. A topic with the word appearing 
in heading 1 ranks higher than the word appearing in heading 2 and is displayed first in the search 
results.
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Add search metadata

Search metadata comprises synonyms, topic keywords, and Stop Words.

To add or edit search metadata, do the following:
1) Select Edit > Search Metadata.
2) Do the following:

Synonyms
Select this option to define synonyms to allow for variations in search terms. For example, you can 
define "cursor," "pointer," and "mouse" as synonymous terms. If the search term is "mouse," Robo-
Help returns all topics containing the word "cursor," with that term highlighted. For more informa-
tion, see Change project settings.

Topic Keywords
Select this option to associate words or phrases to the current topic. Typically, you choose words 
or phrases that are relevant to the topic but are not found in the topic contents. For example, you 
can choose to associate the keyword "formatting" to a topic about fonts, styles, and point sizes. If 
the end user enters "formatting" as a search term, RoboHelp displays that topic even though it 
doesn't contain the word "formatting." When ranking search results, RoboHelp gives more weight 
to keywords than to search terms found in the body of a topic. For more information, see Change 
project settings.

NOTE: Keyword search is not available in Microsoft HTML Help (CHM).

Stop Words
Select this option to add common (minor) words, such as “a” or “the” in the Stop List file Project-
Name.stp. RoboHelp ignores these words to display optimal and relevant search results. For more 
information, see Change project settings.

Optimize content for search

RoboHelp supports many ways to optimize the content for search:

Make Office and PDF files searchable
(WebHelp/Pro, FlashHelp/Pro) Users can search for baggage files (such as PDF, Word, and Excel 
files) in published output. To appear in search results, these baggage files must be referenced in a 
topic through a hyperlink.

NOTE: You must have iFilter for Microsoft and PDF installed on to enable baggage file search.

Exclude unreferenced topics from search
The Exclude Unreferenced Topics From Output option in layout properties ensures that search 
results are displayed only from topics that are referenced in the following project components:

• TOC
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• Index
• Browse sequences
• Default topic
• CSH map IDs
• See Also keywords
• Related Topics keywords
• Hyperlinks

Exclude specified baggage file types from search
(Multiscreen HTML5, WebHelp, FlashHelp, and AIR Help) The Exclude Baggage File Types From 
Search option lets you exclude baggage files of specified types from search. For example, you can 
exclude all Excel files in your projects from search.

NOTE: In merged projects, configure this search setting for each project.

Exclude unreferenced baggage files from search
The Exclude Unreferenced Baggage Files From Search option ensures that search results display 
baggage files only if they are referenced from topics through hyperlinks and the index and TOC 
selected in layout properties. If the Exclude Unreferenced Topics From Output option is selected, 
RoboHelp considers only referenced topics; otherwise, it considers all topics in the project.

See the following table to find the layouts that support the Exclude Unreferenced Topics From Output 
and Exclude Unreferenced Baggage Files From Search options:

SSL
Exclude Unreferenced Topics From 

Output option
Exclude Unreferenced Baggage 

Files From Search option

Multiscreen HTML5 Yes Yes

eBook

Adobe AIR
Output type: Adobe AIR 
Application

Yes Yes

Adobe AIR
Output type: Browser 
based Help

Yes Yes

WebHelp Yes Yes

WebHelp Pro Yes Yes

FlashHelp Yes Yes

FlashHelp Pro Yes Yes

Microsoft HTML Help Yes No
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Configure search experience

You can configure the search experience of end users in the following ways:

Show Total Number Of Search Results
(WebHelp and AIRHelp) Using this option, you can specify whether the total number of results for 
a search string entered by users should be displayed in the output. By default, this search option is 
enabled in both upgraded and new RoboHelp projects.

NOTE: In merged projects, child projects inherit the setting of the parent project.

Show topic context in search results
By default, the search results list shows the first 60 characters of each topic to give context. You can 
disable the display of context by using the SSL dialog box.

NOTE: Only WebHelp/Pro and FlashHelp/Pro support context in Help results. In Flash Help/Pro, the 
context appears as a tool tip.

Customizable search results list
(WebHelp/Pro) By default, ten search results appear at a time. In these two outputs, the Search 
pane contains an option for the maximum number of search results to show in a list.

Hide Rank column in search results
For WebHelp and WebHelp Pro output, you can hide the Rank column in search results to allocate 
more space for displaying search results. The Hide Rank Column In Search Results option is available 
in the Search tab of WebHelp layout properties. See Generate WebHelp output and Generate 
WebHelp Pro or FlashHelp Pro output.

Search auto-complete

The search feature in the Responsive HTML5 output displays predictive search results based on a few 
characters that you type. The search results are intelligently ranked based on your search history and 
frequency of occurrence of the word in the document to ensure that your search results are as relevant 
as possible. The top five search results are displayed in the Search field.

Printed Documentation No No

XML Output Yes No

Oracle Help Yes No

JavaHelp Yes No

SSL
Exclude Unreferenced Topics From 

Output option
Exclude Unreferenced Baggage 

Files From Search option
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When you type the first few letters of any topic, subject or keywords into the search box, the powerful 
algorithm works at the background to detect spelling errors, the most occurring and probable keywords 
and match it against the past searches in order to suggest the best alternative for the partial text entered 
in the Search field.

The search does an intelligent prediction and attempts to improve your search in several ways:
• Support for synonyms and stop words: The search engine does not limit itself to the stop word, 

rather the next most occurring word is appended to the suggestion. It also includes synonyms of 
your search terms to find related results.

• Position of the cursor: The suggestions can change if the cursor is moved before or after the word.
• Spell check: The search engine recommends words that are most similar to each mis-spelt word. It 

allows up to two spelling errors.
• Checks the search history: The past searches are stored in the cookies and the searches that 

matches the text in the search box is displayed.
• Clear search history: You can use the X button next to the search phrase to clear the search history.

Navigating the search results using keyboard shortcuts
• Use the Up and Down arrow keys to select the next or previous suggestions.
• Use the Right arrow key to display the next suggestion.
• Press the Enter key to select the desired search term and display the results. This will save the 

searched term in history.
• Press the Escape key to hide suggestions.

External content search

External content search enables authors to display content from specified URLs based on terms that 
users are likely to search. You can create a list of URLs related to a project and, for each URL, provide a 
set of search terms, a title, and, a description. When a user's search query contains any of these search 
terms, RoboHelp returns the title and description of the corresponding URL in the search results. When 
the user clicks it, the contents are displayed in the Topic Pane. The URL returned in search results has the 
same rank as the keyword specified in topics.
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Set up and manage external content search

1) Select Project > Open > Pods > External Content Search.
2) Use the following options to set up and manage external content search:

Add
Click Add and specify search terms (separated by a comma, space, or semicolon) and the URL for 
the external content. Adding a title and a description is a good idea. Select any CBTs you want to 
apply. Click OK to save the entry in the SearchOptions.xml file in the project folder.

Edit
Select the entry you want to edit and click Edit. Modify the details and click OK.

Import
Click Import and select the SearchOptions.xml file from a project to import the external content 
search settings of that project into the current project.

Export
Click Export and select a folder to export the SearchOptions.xml file. Exporting the SearchOp-
tions.xml file from one project to another is useful when two projects need to allow searching 
similar external content.

Search
Specify a string to search for a particular entry. This option is useful when a project has many entries 
defined for external content search.

Enable external content search

You can enable external content search in the following layouts SSLs:
• Multiscreen HTML5
• WebHelp
• FlashHelp
• Adobe AIR
• WebHelp Pro
• FlashHelp Pro

1) In the Single Source Layouts pod, right-click the layout in which you want to generate output and 
select Properties.

2) Depending on the layout, do the following:
– (Multiscreen HTML5) Click a screen profile. In the Search tab, select Enable External Content 

Search.
– (Adobe AIR) Click Search and select Enable External Content Search.
– (WebHelp) Click Search and select Enable External Content Search.



263

EXTERNAL CONTENT SEARCH
CHAPTER 8 LINKING, NAVIGATION, AND SEARCH

– (WebHelp Pro) Select Enable External Content Search.
– (FlashHelp and FlashHelp Pro) Click Next and select Enable External Content Search.
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Multimedia and special effects

Images

Image basics

Image file formats

GIF (Graphic Interchange Format)
An 8-bit color format that can display 256 colors and is useful for images with a limited range of 
color. GIF images support the transparent attribute. They are best for grayscale photographs, 
cartoons, small icons, buttons, bars, lines, and bullets. They can be interlaced and animated.

JPEG (Joint Photographic Expert Group)
JPEG format is commonly used to display photographs and other continuous-tone images in HTML 
documents. If you use images with 256 colors or more, use JPEG format. JPEG files have either a 
.jpeg or .jpg filename extension.

BMP (Windows Bitmap)
The standard bitmap image format intended for Windows, used in WinHelp applications. Bitmap 
images support up to 24-bit color. When you import WinHelp projects into HTML, the bitmaps are 
converted into GIF or JPG format. You can use bitmaps and icon formats (ICO files) when you add 
link controls or HTML Help controls (custom buttons.)

MRB (Multi-Resolution Bitmap)
A Windows Help image format that contains an image saved in different screen resolutions in a 
single file. The program imports these files from WinHelp projects and converts them into GIF 
images.

WMF (Windows Metafile)
A vector graphics format intended for Windows systems. WMF files are commonly used as clip art 
for word-processing applications. The program imports these files from WinHelp projects and 
converts them into GIF images.

PNG (Portable Network Graphics)
A bitmap image format like GIF. The most recent versions of Netscape Navigator and Microsoft 
Internet Explorer support PNG.

Tips:

• Create a stationery watermark effect by displaying background colors and images from the Borders 
And Shading dialog box.
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• When you select an image, the Cable Drum button appears . Use it to link topic items (such as 
images, text, and tables) with another topic item, and assign a Dynamic HTML effect to the connec-
tion.

• When you import a Microsoft Word file or an HTML file, all images are imported with the file 
(images must be in anchored frames.)

NOTE: If you generate WebHelp Pro or WebHelp output, use GIF or JPEG files.

Locate images

Use the Graphics Locator to scan hard drives and folders for image files, view thumbnails, and copy files.
1) In the Toolbox pod, double-click the Graphics Locator .
2) Select the graphic file format to search for.
3) Enter the path for the search or browse to a new location.
4) Click Search.

Copy an image

1) In the Toolbox pod, double-click the Graphics Locator button .
2) Select an image from the Image Files list.
3) Browse to a destination.
4) Click Copy File.

View an image

To view an image, you associate the filename extension with an application:
1) In the Project view, select the Images folder.
2) Right-click an image.
3) Click View.
4) Select File > Options.
5) Click the Associations tab.
6) Click Add next to File Associations. Enter a filename extension.
7) Click Select. Browse to the application to use for editing and viewing the file type.

Add an image to a topic

You can insert files with the following filename extensions: .gif, .jpeg, .jpg, or .bmp. NOTE: For Web-based 
Help, use GIF or JPEG files.
1) In the Design Editor, select a location for the image.
2) In the toolbar, click the Insert Image button .
3) Do either of the following:

– Click the Browse button  to browse to a file.
– If the image file is in the project, select a folder from the Images In Project Folders pop-up 

menu. Select All Folders to see all images in the project.
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4) Click OK.

Tips:

• For an image used in the project, drag it from the Project Manager\Images folder into the topic.
• To add predefined images, click the Gallery tab in the Image dialog box, select a category, and select 

the image. To add it to the project, click OK.
• You can paste screen captures into the Design Editor without using a third-party image-editing tool. 

The images are saved as either GIF or JPEG files. Press Alt + PrtScr to capture the active screen.

Add a RoboScreenCapture image to a topic

Simultaneously create and add images.
1) Move the cursor to a desired location in the Design Editor of a topic.
2) Click the Insert ScreenCapture button  on the Object toolbar. The Insert ScreenCapture dialog box 

appears.
3) Enter a filename for the new image.
4) Select a file format.
5) Click OK. RoboScreenCapture opens and RoboHelp is minimized.
6) Select Capture > Active Window or any desired capture. The new image appears in the blank area.
7) Click Save .
8) Close RoboScreenCapture. The Image dialog box of RoboHelp for HTML appears.
9) (Optional) Resize the image or place borders around it.
10) Click OK.

Remove an image from a topic

• To remove an image from a topic, in the Design Editor, select the image. Click the Delete button. 
The image remains in the Images folder.

• To remove an image from a project, delete the file from all topics. The image is removed from the 
Images folder.

Edit an image in RoboHelp

1) In the Design Editor, select the image to edit.
2) Right-click the image and choose Image Properties.
3) Set options:

Text Wrapping
Select the alignment of the image with the surrounding text.

NOTE: If text wrapping occurs around an image, then the image cannot be aligned. If text wrapping is set 
to None, then the image, or the line it is on, can be aligned.
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Screen Tip
Enter text to display when the user hovers the cursor over the image. Typically, the screen tip text 
is the image title.

ALT Text
Enter the text to display when the image cannot be displayed (perhaps because users have disabled 
images in their browsers). Typically, ALT Text (alternative text) should contain a crisp description of 
the image.

Size
Click to set the dimensions of the image in pixels. In the Size dialog box, select Maintain Aspect 
Ratio to maintain the height to width proportion.

Margins
Click to specify the space between the image and the text. You can specify the same width for the 
margin on all sides or a different width for left, right, top, and bottom margins.

Borders
Click to add a border to the image and specify a style.

Edit an image with RoboScreenCapture

1) In the Design Editor, select the image to edit.
2) Do one of the following:

– Select Edit > View > Image.
– Right-click and select Edit with RoboScreenCapture.

3) Edit the image.
4) Click Save. NOTE: See RoboScreenCapture Help for more information.

Image thumbnails

Thumbnail support for images

You can now add images as thumbnails in the document that can be zoomed when clicked. Users would 
have greater flexibility in setting a standard thumbnail size, which will provide consistent look-and-feel 
of thumbnails across the published output. This also allows you to better organize the written content 
within the document with respect to the images.
NOTE: This feature is only for Responsive HTML5 Output.
1) Select the image in the document.
2) Select Project > (Open) Pods > Style and Formatting.
3) In the Styles and Formatting pod drop-down list, select Image Styles.

The existing image styles are listed.
4) Double click on the image style to apply the settings on the selected image in Step 1.
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NOTE: You can also create a new image style or edit an existing style by using the menu option 
preceding the Image Styles drop-down list. The height and width properties in an image style 
control the maximum size of an image when it is opened in full view. If no value is specified in the 
height and width properties, then the image is shown in its original size in full view. You can create 
a new image style and specify the height and width properties to give a consistent look-and-feel for 
the images in full view.

5) In the Output tab under the Generate section click on Responsive HTML5.
The Responsive HTML5 Settings dialog opens.

6) In the General tab, under the Manage Thumbnails section, specify the style names and the thumb-
nail dimensions. If there are more than one style that you want to use for thumbnails, use commas 
to separate them.
NOTE: If an image’s original size is 75x75 pixels and you specify the thumbnail size as 100x100 pixels, 
then the image thumbnail is created in 75x75 pixels. However, if the image size is 150x150 pixels, 
then the thumbnail is created in 100x100 pixels. When a user clicks on the thumbnail, the image is 
displayed in its original size of 150x150 pixels.

7) Specify the output location in the Output Folder and Start Page field.
8) Click Save and Generate to generate the output.



269

ADOBE CAPTIVATE DEMOS
CHAPTER 9 MULTIMEDIA AND SPECIAL EFFECTS

Image maps

Create an image map

1) In the Design Editor, open a topic containing an image.
2) Right-click the image. Select Insert Image Map.
3) Select Rectangle, Circle, or Polygon.

The cursor becomes a cross hair .
4) Draw a clickable area within the image border.
5) In Link To, click the triangle pop-up menu . Select a file under Select Destination (File Or URL) or 

another destination.
6) In Screen Tip Text, enter text to display when users hover the mouse over the image map.
7) Click OK.

TIP: The Project Manager saves the image map with the image in the Images folder. A plus sign at 
the left side of the Image button indicates an image map: . Click the plus sign to see a list of all 
hotspots in the image map. Hotspot links appear with the Hotspot icon .

8) To test, click the View button in the toolbar. Click the hotspot.

Change an image map

1) In the Design Editor, open the topic containing the image map.
2) Double-click the hotspot.
3) In Link To, click the triangle pop-up menu . Select a file under Select Destination (File Or URL) or 

another destination.
4) Select OK. If prompted, select OK to copy the file into the project.
5) To test, click the View button  in the toolbar. Click the hotspot.

RELATED LINKS:
Link to a pop-up

W3C compliance

Adobe Captivate demos

Follow these procedures to integrate content created using Adobe Captivate and update the source from 
within RoboHelp. You can launch Adobe Captivate from within RoboHelp and create demo topics. You 
can also insert SWF and HTML5 output of Adobe Captivate demos in existing topics. Demo or demonstra-
tion is a recording mode in Adobe Captivate. For more information, see Using Adobe Captivate.

When an Adobe Captivate demo is added in the project, you can open the source from within RoboHelp 
and edit it.
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Create an Adobe Captivate demo

Create an Adobe Captivate demo from within RoboHelp.
1) Select Project > New > Topic > Adobe Captivate Topic.
2) Specify a name for the Adobe Captivate project that will be created.
3) In the Title box for the Demo topic, type the topic name.
4) In the File Name box, specify a filename with the extension .htm.
5) Click OK.
6) Create the demo.

NOTE: You cannot access RoboHelp while Adobe Captivate is open.
7) Save the demo and close Captivate.
8) To test the demo, select or open the host topic, and click View .
9) Open the topic and add additional information, such as a header, footer, background color, or title 

text.
NOTE: You can select the Adobe Captivate demo inserted in the topic and cut and paste it into 
another topic if required.

Insert an Adobe Captivate demo

You can link to the demo topic from other topics in the project, from books and pages in the TOC, and 
from index keywords. When users click the link, the demo starts.
1) In RoboHelp, open the topic where you want to insert the demo.
2) Place the cursor where you want to insert the demo.
3) From the Insert menu, select Adobe Captivate Demo. The Adobe Captivate Demo dialog box 

appears:
– If the demo SWF file is already in the project, select it from the Multimedia In Project Folders 

list.
– If the file is outside the project folder, click the Browse button , navigate to the SWF file, and 

click Open. At the prompt, click Yes to copy the file to the project folder.
– If Adobe Captivate HTML5 output of the demo is available, browse and select the .htm file.

NOTE: RoboHelp adds the .htm file as a baggage file and uses the extension .cpz. If you have 
not specified the SWF file along with the HTML5 output file, RoboHelp adds a placeholder 
SWF for use in Design Editor. This means that you can’t edit the demo from within RoboHelp. 
The HTML5 output of the demo is used only in project output generated using the Multiscreen 
HTML5 layout.

4) Click OK. An object in the topic indicates where the file was placed.
5) To test the demo, click View .
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Import an Adobe Captivate Demo

You can import an Adobe Captivate demo as a new topic in your RoboHelp project.
1) Select Project > Import > Document > Adobe Captivate Demo.
2) Specify a title for the new topic that you want to create for the demo.
3) Specify the path of the HTML5 output for the demo.
4) Specify the path of the SWF output for the demo.

Notes:
• If you have specified an HTML5 output path and skipped specifying the corresponding SWF output 

path, RoboHelp adds a placeholder SWF for use in Design Editor. This SWF is non-editable.
• If the SWF being imported has any FLV file embedded in it, RoboHelp does not import the FLV file. 

Add the FLV as a baggage file. See Add files and folders to the Baggage folder

Edit an Adobe Captivate demo

1) Open the topic containing the Adobe Captivate demo, or in the Project Manager, expand the Multi-
media folder.

2) Right-click the demo. Select Edit.
NOTE: If you have inserted an HTML5 output file and skipped inserting the corresponding SWF file, 
RoboHelp adds a placeholder SWF for use in Design Editor. This SWF is non-editable.

3) Make the changes.
4) Close Adobe Captivate.

NOTE: When you preview an Adobe Captivate demo in RoboHelp, a prompt may ask you to update the file 
in the project. This prompt appears if you saved the Adobe Captivate demo outside RoboHelp to the 
default Adobe Captivate location. (The default location is C:\Documents and Settings\[user name]\My 
Documents\My Adobe Captivate Projects\.) Update the file to apply the changes made outside Robo-
Help.

Multimedia

Add multimedia

1) Select a location in the topic for inserting the multimedia.
2) Select Insert > Media > Multimedia.
3) Choose either Offline (local folder) option to insert multimedia file from a local folder or Online 

(URL) option to embed an online video using its URL.
4) If you choose multimedia option as Offline (local folder), do one of the following:

– To add a new file, click the Browse button  and navigate to the file. Double-click it. Select 
Yes.

– To add an existing file, select it from the Multimedia In Project Folders list.
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5) If you choose multimedia option as Online (URL), input the source URL (in embed code) of the 
online video as explained in the note below. For embedding Youtube, Vimeo, and Dailymotion 
videos, you can alternatively provide the http URL instead of the source URL.
NOTE: The source URL of the video can be copied from the embed code of the online video. Consider 
this embed code as an example: <iframe width="560" height="315" 
src="https://www.youtube.com/embed/PAxxJKa3PDo" frameborder="0" allow-
fullscreen></iframe>. Here, the source URL required to embed the video is: 
https://www.youtube.com/embed/PAxxJKa3PDo. This source URL is different from the http URL of 
the video.

6) Set options:

Text Wrapping
Sets the alignment of the multimedia object with the surrounding text.

Screen Tip
Replaces the multimedia file with a text label if users disable multimedia in their browsers.

7) You can set the appearance settings. The settings you specify affect how the embedded video 
appears in the published web output.

Size
Specifies the size of the embedded video.

If you are adding a QuickTime video, you need to add 16 pixels to the size of the video. This means, 
that if your video is 320 x 240, you will need to define the Size (in the Appearance drop-down 
described above), as 336 x 256.

Margin
Specifies left, right, top, and bottom margins in inches.

Border
Sets a border around the video object.

Player Settings
Specifies the video settings related to player controls, playback, and sound in the published output. 
The following options are available:

Auto:
Show player controls on hover. This option is available only when embedding an online video.

Always:
Show player controls always.

Never:
Never show player controls.
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Show annotations when available:
Show annotations if they are available in the embedded multimedia. This option is available only 
when embedding an online video.

Full Screen:
Show multimedia in full screen.

Autoplay:
Auto play multimedia when you open the topic that contains it.

Loop:
Loop multimedia ‘n’ times till the user stops it manually. Choose Infinitely or specify a value for ‘n’ 
for finite looping. It should be noted that finite looping option is available only for window media 
video (wmv) multimedia type, while infinite looping option is available for all multimedia types 
except window media video (wmv).

Mute:
Start the video in mute mode, which can later be changed manually.

Initial Volume:
Specify the initial volume of the video, which can later be changed manually. This option is available 
only for HTML5 video files.

8) Click OK.
9) Create a link to the multimedia file near the object with a note prompting users to select the link if 

they cannot access the multimedia file.
10) To test or preview, click View Item button in Project > View.

IMPORTANT: The player settings that you specify, depend on the output video type (such as .mov or .qt) 
for offline videos. For online videos, the settings will depend the on settings made available by the 
provide (such as youtube.com or vimeo.com.
NOTE: Some file formats do not work properly in compiled Microsoft HTML Help files.

The following are the allowed multimedia file types:
• Video files: *.avi, *.asf, *.asx, *.mpg, *.mpeg, *.mpg4, *.mpe, *.mov, *.qt, *.ra, *.rm, *.rpm, *.wmv, 

*.wvx
• HTML5 video files: *.mp4, *.ogg, *.ogv, *.webm.

.ogg, .ogv, and .webm formats are supported only for Multiscreen HTML5 SSL. These formats are 
not supported in Internet Explorer. Refer to the following table for more information about browser 
requirements for playing videos in generated Multiscreen HTML5 output:

Internet Explorer FireFox Chrome Safari

Ogg Not supported 3.5+ 5.0+ Not supported

MPEG 4 9.0+ Not supported 5.0+ 3.0+

WebM Not supported 4.0+ 6.0+ Not supported
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Where:
Ogg represents Ogg files with the Theora video codec and the Vorbis audio codec
MPEG4 represents MPEG 4 files with the H.264 video codec and the AAC audio codec
WebM represents WebM files with the VP8 video codec and the Vorbis audio codec
 TIP: For wider compatibility with multiple browsers on multiple devices, use MP4 video files. MP4 
videos are also supported in EPUB 3 eBook output.
Notes:
– (Only for Firefox) MP4 videos in Multiscreen HTML5 output are displayed in the size 400 x 300 

pixels by default. You can specify a different video size if necessary.
– (Windows 7 and Internet Explorer 9)To view MP4 videos in Multiscreen HTML5 output, make 

sure that Windows Media Player is installed.

• MPEG video files: *.mpg, *.mpeg, *.mpg4, *.mpe NOTE: MPEG 4 files with H.264 video codec and 
AAC audio codec are natively supported by most browsers.

• Windows media files: *.avi, *.asf, *.asx, *.wma, *.wmv, *.wax, *.wvx
• QuickTime files: *.qt, *.mov
• Real files: *.ra, *.rm, *.rpm
• Audio files: *.asf, *.asx, *.mp3, *.mp4, *.wav, *.au, *.mid, *.rmi, *.ra, *.rm, *.wma, *.wax
• Flash files: *.swf
• Flash video files: *.flv, *.f4v
• Adobe Captivate files: *.swf

If you use the multimedia file in other topics, add it by dragging the file from the Multimedia folder. NOTE: 
Multimedia content might have dependencies such as Flash or video/audio players that you need to 
install before you can view or hear them.

Change multimedia

1) Double-click the multimedia object. The Multimedia dialog box appears.
2) Make the changes.
3) Click OK.
4) To test, click the View button  in the toolbar.

Remove multimedia from topics

1) Click to select the multimedia object.
2) Click the Delete button. .

TIP: Click Undo  to restore a multimedia object you removed.
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Dynamic HTML and special effects

Dynamic HTML (DHTML) combines the capabilities of multimedia and scripting to create visual and 3D 
effects. The effects you insert perform an action or move in response to user input (such as a mouse 
click). Keep in mind the following details when working with DHTML:
• Mouse rollover effects include Drop Shadow, Font Change, Glow, and Rock 'n Roll.
• Page-load, page-click, or trigger activation effects include Blur, Elastic, Fade In/Fade Out, Flip Hori-

zontally/Vertically, Fly In/Out, Gray, Show/Hide, Spiral, and Rock 'n Roll.
• Some effects can be combined.
• For best results, use DHTML with Internet Explorer 5.0 and later.
• Dynamic effects in styles are not supported in W3C-compliant output. If you validate the code for 

W3C compliance, the report can indicate errors.
NOTE: HTML files support DHTML effects in IE and non-IE browsers, but XHTML does not support all 
instances of DHTML effects.

RELATED LINKS:
Apply conditional build tags to content

DHTML basics

Add DHTML effects to a topic

1) Open a topic in the Design Editor and select an element. Do one of the following:
– Select text.
– For paragraph-based effects, click inside the paragraph.
– For positioned boxes, select the text box so you see gray boxes on its edges.

2) Select Insert > DHTML > Effects > Effects.
3) From the When list, select the event for initiating the effect.
4) From the What list, select the effect you want to apply.
5) From the Settings list, adjust the properties.

The DHTML effect appears with light gray hash marks .
TIP: To ensure that you apply the effect to the correct topic, use the Design tag list.

Apply DHTML effects to multiple paragraphs

1) In the topic, click where you want the text box.
2) Select Insert > HTML > Text Box.
3) Right-click the box, and select Text Box Properties. Set properties.
4) Type text in the box.
5) Click to select the box.
6) Select Insert > DHTML > Effects > Effects.
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7) From the When list, select the event for initiating the effect.
8) From the What list, select the effect you want to apply.
9) From the Settings list, adjust the properties.

Update DHTML effects in a topic

Update Dynamic HTML (DHTML) effects by resaving topics in either of these two situations:
• You add or modify a style to include a Dynamic HTML effect. In this case, resave all topics attached 

to the style sheet so that they include code for creating the effect.
• You’re able to open a project in a version of RoboHelp earlier than version 8.0.

You can resave the topics at the prompt or update them later by clicking the Design tab and selecting 
Tools > Scripts > Update DHTML.

Change or remove DHTML effects

1) Open the topic in the Design Editor.
2) Do one of the following:

– Select the topic with the effect that you want to change. Select Insert > DHTML > Effects > 
Effects.

– Select the element to remove, and then select Insert > DHTML > Effects > Remove Effects.

TIP: The EPUB output does not support DHTML effects. To exclude DHTML effects from the EPUB output, 
you can use CBTs.

RELATED LINKS:
Generate EPUB and Kindle Book output

Generate EPUB and Kindle Book output

Dynamic hotspots

About DHTML hotspots

DHTML hotspots display information when clicked.

Expanding hotspot
When clicked, displays additional text next to the hotspot.

Drop-down hotspot
When clicked, displays additional information below the hotspot.

Add DHTML hotspots

1) Open the topic in the Design view. Select the text to use as the hotspot.
2) Do one of the following:
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– For expanding hotspots, select Insert > DHTML > Expanding Text. In the Expanding Text Editor, 
type the text to appear in the hotspot. Click outside the window to close the editor.

– For drop-down hotspots, select Insert > DHTML > DropDown Text. Enter text or images in the 
drop-down box. Click outside the Drop-down Text Editor.

3) Click the View button  to test.

TIP: Format DHTML hotspots differently from surrounding text to make them noticeable to readers.

Remove hotspots

NOTE: Content inside a hotspot is removed when you remove the hotspot.
1) Right-click a hotspot. Select Remove Expanding/Drop-Down Text.

Change formatting of DHTML hotspots

Change the formatting in a single topic or change for all topics using a style sheet. For multiple style 
sheets, modify each style sheet attached to the topics that use hotspots.
1) Select Project > Open > Pods > Style and Formatting
2) Do one of the following:

– To change formatting in a single topic, choose Available In and select the name of the topic to 
change.

– To change formatting in all topics using a style sheet, choose Available In and select the 
external style sheet.

3) Under Styles, select the hotspot style to change.
4) Click Modify.
5) Click Format and select the attributes to change.
6) Click OK. Click Close.

Triggers and targets

About triggers and targets

Triggers are text or images that have a special DHTML effect applied. When users click text or an image 
that's assigned a trigger, a target appears. To open DHTML effects using triggers, first assign a trigger to 
text or an image. Then connect the trigger to a target and assign a DHTML effect. When working with 
triggers and targets, keep in mind the following details:
• Triggers and targets must reside in the same topic.
• To indicate that an item is clickable, change the font color and underline, or add text to an image.

Trigger and target images
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Assign a trigger to text or images

1) Select the text or image to assign as the trigger.
2) Select Insert > DHTML > Trigger > Trigger. A cable drum icon  appears. Hash marks shade the text.
3) Connect the trigger to an image or text.

Connect triggers to text

1) Select the text to use as the target.
2) Select Insert > DHTML > Effects > Effects.
3) Under When, select 1st Trigger Activation.
4) Select What (the effect that occurs the first time the user clicks the trigger), and then select prop-

erty settings.
5) Select 2nd Trigger Activation and set the properties.
6) Click OK. A plug icon  appears next to the text, indicating that it is a target.
7) Click the trigger and drag to connect the trigger to the target text. To connect the trigger to multiple 

text targets, hold down the Shift key and click the trigger. Continue to hold the Shift key and drag 
the mouse to the next target text.

Connect triggers to images

1) Click the trigger image once to display the green cable drum icon .
2) Click the cable drum icon and drag to connect the image to the target image. A green line shows 

the connection between the trigger and target.
3) From the menu, select a DHTML effect.
4) To connect to another target, hold the Shift key and click the trigger again. Continue to hold the 

Shift key and drag to the next image.
5) From the menu, select a DHTML effect for the target image.

Removing triggers

1) Right-click the topic item assigned to a trigger and select Remove DHTML Trigger.

Marquees

Add marquees

A marquee is a moving text message.
• To place a marquee around existing topic content, select the topic content and set marquee prop-

erties.
• To set marquee properties first, click the marquee destination in the topic. Set marquee properties, 

and enter the marquee content.

NOTE: XHTML does not support Marquees.
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Set or change marquee properties

1) Select Insert > HTML > Text Box > Marquee.
2) Right-click the marquee, select Marquee Properties, and specify or change marquee properties.

– In Amount, select the rate at which the marquee moves. Higher number indicates faster 
speed.

– In Delay, select the duration in milliseconds for display.
– In Behavior, specify how the marquee moves.

Scroll
The marquee moves continuously across the window.

Slide
The marquee slides across the screen.

Alternate
The marquee bounces from the starting direction to the opposite window border.

– In Repeat, specify repetitions of the marquee. Select Continuously to repeat the marquee as 
long as the topic is open.

3) Click the View button  to test.

Delete marquees

1) Place the cursor on the marquee boundary.
2) Click the left mouse button.
3) Click Delete .

HTML comments in topics

Insert an HTML comment

1) Open a topic in Design Editor.
2) In Design view, insert the cursor and select Insert > HTML > Text Box > Comments.
3) In the Comment Editor, type your comment using the following format:

<!--a comment -->

4) Click OK.
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View an HTML comment

1) Open a topic in Design view or HTML view.
2) Select Edit > Show/Hide > Comments.

Comments appear as green callouts in Design view and as green text in HTML view.
3) (Design view) Move the cursor over the callout. The comment appears in a text pop-up note.

Iframes

Use iframes (inline frames) to insert PDF files or HTML files within an HTML topic. If you want to show a 
PDF file or an accessible URL link in an HTML page, you can insert an iframe and display the required files 
within the selected HTML page.

Insert an iframe

1) Select Insert > HTML > Text Box > Iframe.
2) Double-click the iframe.
3) Specify a name. Click the browse button to select a URL, HTML file, or PDF file to link.
4) (Optional) Click the Border tab to set border options.
5) Click OK.

NOTE: You can view the inserted file in the preview as well as in the generated Help.

Edit an iframe

• Double-click the iframe to change the name, the linked item, or the border.
• Drag the frame handles to resize the frame.
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Conditional text

Conditional text basics

Conditional text lets you generate subsets of the content within a project for various purposes or audi-
ences. You can create conditional build tags to exclude content from output, and then assign those tags 
to topics or elements within topics.

Customize printed output

Online documentation often contains elements that are not useful in a printed manual, such as text 
describing online features. You can tag these elements as conditional text and exclude them from the 
output. If the manual is a subset of the online documentation, you can apply a conditional build tag to 
the topics and topic content to include. Then apply another tag to the other elements. When you 
generate the project, you can exclude the online-only tag.

Target custom content to specific audiences

Sometimes topics pertain to products, experience levels, or types of users. Using conditional text, you 
can reduce the amount of information you deliver to each group. You can also eliminate notes explaining 
small differences between products.

Deliver versions of an application

To deliver demo, trial, and shareware versions of the application, you can omit topics in each version.

Design and test conditional text

1) Determine the types of output needed, such as printed manuals or online tutorials; consider 
current and future requirements. Determine whether versions for different skill levels are required.

2) Determine which conditional build tags to apply to each output type. All untagged components are 
included in the output. Determine whether to apply multiple tags to topics, for varied output types. 
For example, to deliver a manual for testers of beta software, tag the beta-specific topics with a tag 
such as Beta. Tag the other topics with a tag such as Printed. Then you can include beta-related 
topics first, and exclude them later.

3) Use the Topic Properties report or the Conditional Build Tag report to review the tags applied to 
each topic.

4) Determine whether to apply a conditional build tag to the entire topic or to one or more areas 
within a topic. For example, if you are creating a printed manual, exclude text that mentions an 
online glossary.
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5) Decide on tag names and colors, especially if the project is large and requires multiple output types. 
Define tag names that describe the output, such as Print or Online. Tag colors help you differentiate 
conditional text areas within a topic.

6) When updating a project, determine whether to delete content that is made obsolete by 
single-sourcing and conditional output. For example, a project contains text (such as “for advanced 
users”) or images that explain which content applies to which users. You can delete these elements 
or use conditional text to hide them in the output.

7) Determine which TOCs or pages of a TOC to include in the output, as you apply each tag.
8) Determine which indexes to include in the output. You can create multiple indexes in a project and 

include each one in the appropriate output.
9) Test the conditional tags by generating the output and viewing the results. Exclude combinations 

of tags you applied to topics, TOCs, or indexes. You can also preview topics, without generating, to 
experiment with conditional areas.

RELATED LINKS:
Preview conditional text areas

Workflow to implement conditional text

1) Create a conditional build tag.
2) Apply the tag to a combination of topics, topic content, TOCs, and indexes.
3) Define the tags to exclude from and include with the output.
4) Define the conditional build expression to include or exclude tagged topics.

The expression uses Boolean logic operators (OR, AND, NOT) to form phrases that exclude content 
marked with a tag.

5) Generate the output.

Managing links to excluded topics

If you exclude content from output, broken links can occur in topics that reference the excluded content. 
RoboHelp manages most of these links as described in the following table.

Type of link Result

Browse sequence An excluded topic doesn’t appear in the browse sequence

Image maps If an image with an image map is excluded from output, the image map 
is removed.

Index An index keyword that is linked to a topic that is excluded doesn’t 
appear in the Index pane.

Link control A link control (such as a Related Topic or Keyword Link) that references 
an excluded topic doesn’t display the topic.
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Conditional build tags

Create a conditional build tag

1) In the Project ribbon, click Tag .
2) In the New Conditional Build Tag dialog, type a name for the tag.
3) Assign a color to the tag by clicking the Build Tag Color button . In the color box, click a color to 

select it, or click Custom Color to define a new color. If you do not assign a color to the icon, Robo-
Help assigns a unique color to the icon by default.
RoboHelp uses this color when you apply this tag to content. For details, see Apply conditional build 
tags to content

NOTE: Two default tags are provided in all new projects: Online and Print. You can change their color, 
rename them, or apply them to topics or topic content.

Apply conditional build tags to content

Content that has a conditional build tag applied appears with diagonal hash marks in the color specified 
for the tag. If a project is generated using a conditional build tag expression, the topic doesn’t display the 
content to which the tag applies. The color of the diagonal hashing differentiates tagged areas. For a 
folder, no hash marks appear. You can display hash marks for topics inside a folder.

Notes:

• Remove text references to excluded topics, such as links. Hotspots are not active for excluded 
topics.

• You can apply a conditional build tag to topics in the TOC pod.
• To show or hide conditional text, go to the Edit ribbon and in the Show/Hide drop-down choose 

Conditional Areas.

Verifying tags applied to topics

The Used area of the Conditional Build Tag Properties dialog box lists the topics using a tag. The Level 
column shows how a tag is applied:

<Topic>
Applied to a topic.

Table of contents A TOC book or page that is linked to an excluded topic doesn’t appear in 
the Contents pane.

Type of link Result
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<Content>
Applied to topic content.

<Both>
Applied to both topic and content.

The File column lists the file containing the tagged information.
1) Right-click a conditional build tag in the Conditional Build Tag pod and click Properties.

Apply conditional build tags to a topic

1) In the Pod drop-down (Project, Edit, or Review ribbons) choose Topic List.
2) Select the topic.
3) In the Edit ribbon, click the Apply drop-down and select a tag.

Apply conditional build tags to multiple topics

1) In the Pod drop-down (Project, Edit, or Review ribbons) choose Topic List.
2) Select multiple topics.
3) Click the Properties icon  in the Project toolbar, and then click Advanced.
4) In the Conditional Build Tags (Topic Level Tags) pod, select a tag. Click OK.

Apply conditional build tags to topic content

1) Open a topic in the Design Editor.
2) Select topic content.
3) In the Edit ribbon, click the Apply drop-down and select a tag.

When you apply a conditional build tag to content in a topic, the content is overlined with the tag color 
defined when you Create a conditional build tag.

Apply multiple conditional tags to topic content

1) Open a topic in the Design Editor.
2) Select topic content.
3) In the Edit ribbon, click the Apply drop-down and select New/Multiple.
4) Select tags or click Check All. Click OK.

When you apply multiple conditional build tags to content in a topic, the content in overlined with the 
tag colors defined when you Create a conditional build tag.

If you apply multiple tags on the same content, then the color of the final over-line is a combination of 
each applied tag color.
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Apply conditional build tags to a folder, index, or TOC

1) Do one of the following:
– To apply tags to a folder, select a folder in the Project Manager pod.
– To apply tags to an index, click the Index folder in the Project Manager pod. Select a keyword 

or subkeyword.
– To apply tags to a TOC, click the Table of Contents folder in the Project Manager pod. Select 

a book or a page. If you apply tags to the entire TOC, the TOC is unavailable in the output. If 
you apply them only to pages in the TOC, the TOC is available. The tagged pages are not.

2) In the Edit ribbon, click the Apply drop-down and select New/Multiple.
3) Select tags or click Check All. Click OK.

Apply conditional build tags to placeholders

1) Do one of the following:
– Select a placeholder placed in a master page and select Edit > Tags > Apply.
– Right-click a placeholder in the master page and select Apply Conditional Build Tag > [new 

tag].

NOTE: You can apply conditional build tags on snippet instances as well but not on snippets.

Preview conditional text areas

To check the format of a topic with a conditional text area, preview it using a conditional build tag expres-
sion you have already defined. You can also define a conditional build tag expression while previewing 
the topic.
1) Open a topic in the Design Editor.
2) Select Edit > View > View Item.
3) Do one of the following:

– To preview an existing expression, choose it from the Conditional Build Tag Expression menu.
– To define and preview a new expression, click Define, and select tags to exclude from the 

output. Click OK.

TIP: To remove the conditional build tag expression from the preview, select None from the Conditional 
Build Tag Expression menu.

Hide and view conditional text

Items with conditional build tags applied appear in the Design Editor with an overline in the color speci-
fied for the tag.

Conditional text is always visible in the Design Editor, but you can hide the overline.
1) In the View section of the Edit tab, click the Show/Hide drop-down.

The Conditional Areas list item is a toggle option.
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2) To hide the conditional text, deselect the option.
NOTE: The icon to the left is deselected.
To show the conditional text, select the option.
NOTE: The icon to the left is selected.

Remove conditional build tags

1) Do one of the following:
– To remove conditional build tags from a topic, select one or more topics in the HTML files 

folder of the Project Manager pod.
– To remove conditional build tags from topic content, open a topic in the Design Editor. Select 

topic content.
– To remove conditional build tags from a TOC, click in the TOC pod. Select one or more books 

or pages.
– To remove conditional build tags from an index, click in the Index pod. Select a keyword or 

subkeyword.

2) Click Edit > Tags > Apply > New/Multiple.
3) Deselect tags or click Clear All. Then click OK.
4) To remove conditional build tags from a project, click Project. Expand the Conditional Build Tags 

folder, click a tag, and select Delete. Then click OK.
TIP: Before removing a conditional build tag from a project, run a project report to determine the 
topics affected.

Rename conditional build tags

1) Right-click a tag in the Conditional Build Tags pod.
2) Select Rename, and enter a new name in the box.
3) Press Enter. Topics using this tag are updated with the new name.

TIP: Make sure that the conditional build expression is updated with the new build tag name before you 
regenerate the project.

Conditional build tag expressions

Define conditional build tag expressions

An expression is a set of instructions. Expressions specify topics to include or exclude from the output. 
You can define a basic expression that excludes tags, or a complex expression with Boolean operators, 
such as AND, OR, NOT.



287

CONDITIONAL BUILD TAG EXPRESSIONS
CHAPTER 10 CONDITIONAL TEXT

Users cannot access topics or TOCs that are excluded from output. Index keywords and TOC entries do 
not appear. RoboHelp removes links to the topic and removes the topic from link controls. It removes 
links to bookmarks inside areas tagged as excluded. Tags applied to topic content do not affect TOC, 
index, or link controls.

Make sure that you have a single-source layout in which to store the expression. If needed, create a 
layout or modify a default layout.
TIP: You can bypass build tags and generate output including all topics in the project whether build tags 
have been applied or not. Select None in the Conditional Build Tag list, in the Options wizard, while gener-
ating the project.

Create a conditional build tag and apply it to topics or topic content.
1) In the Project ribbon, click the Tag drop-down and choose Named Expression.

The Define Conditional Build Tag Expression dialog is displayed:
Define the conditional build expressions

A
Select from the list of available expressions.

B
Rename the selected expression.
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C
Create a new expression.

D
Delete the selected expression.

E
From the list of current conditional build tags, choose the tags to include and exclude from the 
expression.

F
Use the AND, OR, and NOT boolean operators create an expressions. See Advanced conditional 
build tag expressions.

G
List of available conditional build tags

H
List of tags to exclude

I
Boolean operators used to create an expression using the Advanced option

J
Clear the expression built created using the Advanced option

2) When you first open the dialog, no build expression is currently selected.
3) To create a new expression, build the expression using the Basic or Advanced options and click 

Save.
4) To edit an available expression, choose the expression from the Expression drop-down and click 

Update.
5) Click Save.

If you are creating a new expression, you are prompted for a name.

Advanced conditional build tag expressions

If you define advanced conditional build tag expressions using Boolean operators, use these guidelines 
for customizing output. You can also let the program create them for you using the basic method.

Desired Result Action

All topics to which one tag has been applied Use the tag name. For example: Tag1
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NOTE: Topics and topic text to which you have applied no conditional build tag are included in the output.

All topics to which multiple tags have been 
applied

Use AND with the tag names. For example: Tag2 
AND Tag3

All topics to which any combination of tags has 
been applied

Use OR with the tag names. For example: Tag3 OR 
Tag4

All topics except those topics to which one tag 
has been applied

Use NOT with the tag name. For example: NOT 
Tag2

All topics except those topics to which multiple 
tags have been applied

Use NOT in combination with AND with the tag 
names. For example: NOT Tag1 AND NOT Tag2 
AND NOT Tag4

Desired Result Action
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Context-sensitive Help

About context-sensitive Help

A context-sensitive Help (CSH) topic provides information about the user interface of an application rela-
tive to the task a user performs. For example, CSH topics provide details about fields and controls in 
dialog boxes, descriptions of windows or screen objects, and explanations of messages. The user 
accesses a CSH topic by pressing F1, clicking a Help button, selecting from a menu, or clicking a ques-
tion-mark icon.

The process of creating and implementing context-sensitive Help typically involves the content author 
and the application developer. To specify context-sensitive topics, the author creates map IDs and map 
files. When a user accesses context-sensitive Help, a map number and Help file name are sent to the Help 
engine. The engine matches the map number to a topic ID and an HTM filename so that the correct topic 
appears.

The final step in the process is to test the context-sensitive Help. RoboHelp HTML provides several tools 
you can use in addition to testing context-sensitive Help in the application.

Window-level topic
Describes windows, dialog boxes, and messages in an application. Each window-level topic is in 
HTM format and stored in a file with the extension .htm. It can contain text formatting, links, 
images, and other features. These topics are more detailed than field-level topics because they 
describe the user interface components. Users access these topics by pressing F1, clicking Help 
buttons, and selecting from menus.

If a custom window is not included with the application Help, context-sensitive topics appear in the 
HTML Help viewer.

Field-level (What's This?) topic
(WinHelp and Microsoft HTML Help projects) Briefly describes a field. A user accesses the topic by 
clicking a question-mark icon, and then clicking a field in a dialog box. In RoboHelp, field-level topics 
are called What’s This? topics. NOTE: WebHelp, WebHelp Pro, FlashHelp, FlashHelp Pro, and AIR 
Help do not support What’s This Help. WebHelp window support is available only with the 
context-sensitive Help API (Application Programming Interface).

Airplane Help
Offline Help unsupported by an Internet connection. To use RH_ShowHelp, associate the offline 
Help system with the function RH_AssociateOfflineHelp. This step tells the function how to 
operate if no Internet connection is available. Individual calls to RH_ShowHelp must specify offline 
Help. Both RH_ShowHelp and RH_AssociateOfflineHelp are in the support files. Use 
airplane Help to provide back-up Help when an Internet connection fails. NOTE: RH_ShowHelp is a 
programming function that a developer uses to display a help topic using rules found in RoboHelp's 
CSH API.
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Author and developer roles in creating context-sensitive Help

On the  Authoring home page of Peter Grainge’s website, you can find information about four methods 
of calling WebHelp:
• Using URLs
• Using map IDs
• Using map IDs in merged WebHelp
• Using topic IDs

Map files and map IDs

RELATED LINKS:
Author and developer roles in creating context-sensitive Help

Information for developers

Author Developer

Writes the Help topics that describe how to use 
application components such as windows, dialog 
boxes, fields, and controls.

Builds the components (windows, dialogs, fields, 
controls) that make up the application.

Imports map files and assigns map IDs to each 
context-sensitive Help topic. Communicates to 
the developer any unclear assignments or 
changes in assignments.
or
Creates map files and assigns map IDs to each 
context-sensitive Help topic. Exports map files to 
the development environment when complete 
and notifies the developer of any changes.

Generates the map files that contain the map IDs 
and gives them to the author.
or
Obtains map files that contain the map IDs from 
the author.

Generates the project to include the 
context-sensitive Help topics with the output.

Writes code that calls the correct Help topics 
from within the application (based on map IDs 
included in the map files).

Tests the context-sensitive topics in the 
application. Repairs errors in the Help system.

Notifies the author when changes are made to 
the application (or map files) so that the Help 
project can be updated and regenerated. Repairs 
errors in the application code.

http://www.grainge.org/pages/authoring/authoring.htm
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About map numbers, map files, and map IDs

Map number
A numeric value associated with a topic ID. Map numbers and topic IDs are saved in map files. Map 
numbers are used with applications to specify a topic for calling context-sensitive Help. Whether 
application developers use map numbers, topics IDs, or both depends on the programming 
language they use.

Map file
A text file containing topic IDs and map numbers. You associate map IDs and map files with topics. 
As author, if you receive a map file from your developer, assign a map ID from the map file. If you 
manually create a map file, either auto-generate or manually create the map ID. A project can 
include multiple map files. Map files use the extensions .h, .hh, and .hm. The default map file is 
BSSCDefault.h.

Map ID
A string that pairs a topic ID with a map number. For example:

#define ID_SetupScreen 101

• ID_SetupScreen is the topic ID.
• 101 is the map number.
• ID_SetupScreen 101 is the Map ID.

An Icon indicates the status of a map ID:

• Blue icons  indicate that map IDs match topics.
• Yellow icons  indicate that map IDs do not match any topics.
• Locked icons  (blue or yellow) indicate that the map ID is in a map file that is locked. It cannot be 

assigned or unassigned.

Create map IDs, auto-generate map IDs, or import map files to use map IDs. A unique map ID must 
be assigned to each topic ID. Assign a map ID to a Help topic to display the Help topic in 
context-sensitive Help.

Mapping table
A mechanism that maps fields and controls in dialog boxes to map numbers. The mapping table is 
programmed into the application to provide context-sensitive Help functionality.

Managing map files

Create a map file

Map files are text files that include a map ID list. Map filenames use the .h extension. When creating file-
names, use underscores instead of spaces, and avoid using these illegal characters: \ / : * ? < > | # ", $, 
&, [ ]
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Authors or developers can create the map file. If the developer creates the map file, the author then 
imports it.
NOTE: RoboHelp also supports dynamic context-sensitive mapping of dialog boxes and topics. This 
approach eliminates the need for technical authors to manually keep track of map IDs. See Dynamic 
editing of context-sensitive topics.
TIP: You can lock a map file to make it read-only.
1) Open the Output Setup pod.
2) Expand the Context-Sensitive Help folder.
3) Right-click the Map Files folder.
4) Choose New Map File.
5) Enter a name.
6) Click OK. The file is added to the Map Files folder.

NOTE: Obsolete files potentially contain map numbers used for updated files.

Import a map file

1) Do one of the following:
– Click Project > Import > Map File.
– Expand the context-sensitive Help folder in the Output Setup pod.

2) Navigate to the map file. Make sure that it’s unlocked.
3) Double-click the map file to add it to the project Map Files folder.

Export a map file

1) In the Output Setup pod, expand the Context-Sensitive Help folder.
2) Right-click the Map Files folder.
3) Select Export Map Files.
4) Select the programming languages to save the map files to.
5) Specify a location for the map file. Click OK.

 TIP: When you export a map file, the original file remains in your project.

Lock or unlock a map file

Locked map files are read-only files. Do not add, remove, or change map IDs in locked map files. Do not 
modify the file if Remove Unused Map IDs is selected. If you do, you can possibly lose changes in the files. 
Imported map files are locked by default.
1) Select Project > Open > Pods > Output Setup.
2) Expand the Map Files folder (or a custom folder in the Map Files folder).
3) Right-click the map file.
4) Select Properties.
5) Select the Locked option. To unlock the file, deselect the Locked option.
6) Click Close.
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Remove an obsolete map file

Obsolete map files sometimes contain map numbers used for updated files. These map numbers can 
dynamically call a wrong topic. Delete unused map files to prevent this issue.
1) Open the Output Setup pod.
2) Expand the Context-Sensitive Help folder.
3) Expand the Map Files folder.
4) Select the map file.
5) Click Delete.

Remove an unused map ID

Your map files must be unlocked to use this option. To remove unused map IDs:
• Expand the Context-Sensitive Help folder in the Output Setup pod.
• Right-click the Map Files folder.
• Select Edit.
• Do the following:

Map Files
Select the map files from which to remove unused map IDs.

Select All
Click to remove unused map IDs from all map files.

Clear All
Click to deselect all map files and not remove unused map IDs.

Managing map IDs

Create a map ID

1) Open the Output Setup pod.
2) Expand the Context-Sensitive Help folder.
3) Expand the Map Files folder.
4) Double-click All Map IDs.
5) In Map File, click the Down Arrow and select a map file to store the map ID.
6) Click the Create/Edit Map ID button .
7) In Topic ID, type a word or phrase to identify the topic.
8) In Map Number, type a number. NOTE: You can create individual map IDs per topic or auto-generate 

using the Auto Map button. See Auto-generate a map ID
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Edit a map ID

You can assign or unassign topic map IDs, create new map IDs and files, and automatically map 
(auto-map) IDs. You can sort the topics by column.
1) Open the Output Setup pod.
2) Expand the Context-Sensitive Help folder.
3) Right-click the Map Files folder.
4) Select Edit Map IDs.
5) Choose from the following options:

Map File
List available map files (including imported map files).

<All Map Files>
Display all map IDs.

<Project Map File>
Display map IDs in the default map file BSSCDdefault.h. The map IDs for deselected map files reside 
in BSSCDefault.h.

Map file icon 
Click to open the New Map File dialog box and create a custom map file. Map numbers for custom 
map files are numbered automatically.

Map #
Display the map number of the topic ID. Map numbers reside in map files (.h, .hh, .hm).

Topic
Display the topic assigned to the map ID.

Hide Used IDs
Show unassigned map IDs.

New icon 
Create a map ID. The ID is appended to the map file selected in Map File.

Edit icon 
Edit the selected map ID.

Delete 
Remove the selected map ID. Before removing the ID, click Unassign to prevent a broken link to the 
topic.
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Options
Customize topic auto-mapping.

Assign
Assign the selected topic to the selected topic ID. This button is available when a topic is selected 
on the right and a map ID is selected on the left.

Unassign
Disassociate the map ID from the topic on the right.

Auto Map
Assign a map ID in the custom or default map file (BSSCDefault.h). Select a map file and a topic. Click 
Auto Map. This button is available only when you select <Project Map File> or a custom map file. If 
you auto-map a map ID and a map file is not selected, the map ID resides in the default map file 
(BSSCDefault.h).

• The program assigns the topic title or filename as the topic ID and assigns a map number. Click 
Options to customize auto-mapping.

• You cannot assign multiple topics to a map ID. You can assign multiple map IDs to a topic.

Topic
Lists the project topics. To filter the list, click the triangle . Select All Folders, Top Level Folder, or 
a custom folder.

Properties icon 
Show all topic IDs assigned to the topic.

Preview icon 
Display the topic.

NOTE: If you assign a map ID to a bookmark, you see a misleading error message indicating that the file 
does not exist. Disregard the warning. The topic does exist.

Reassign a map ID

Update the map ID if the Help topic doesn’t open, if the wrong topic opens, or if the developer changed 
the application that in way that affects the map IDs.
1) Select a map file under Map IDs in the Edit Map IDs dialog box.
2) Click Create/Edit Map ID.
3) Do one of the following:

– Reassign the map ID. Under Map ID, select the map ID. Click Unassign. Select another topic 
and click Assign.

– Change the topic ID or map number. Double-click the map ID and change the desired value.
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Auto-generate a map ID

You can generate map IDs using a custom map file or the default map file (BSSCDefault.h). Before you 
generate map files, check with the developer to determine naming conventions.
1) In the Output Setup pod, expand the Context-Sensitive Help folder.
2) Expand the Map Files folder.
3) Double-click All Map IDs.
4) In Map File, click the triangle button.
5) Select a map file.
6) Set options for naming and numbering map IDs. By default, the application assigns the topic title or 

filename as the topic ID and assigns a map number.
7) In the Topic field, select the topic.
8) Click Auto Map to create a map ID.
9) If necessary, double-click the map file to edit it.
10) Provide a copy of the map file to the developer.

Generate a map ID

The IDs reside in the map file you select from the Edit Map IDs dialog box.
1) Click Options in the Edit Map IDs dialog box.

Prefix Map IDs With
Select to enter a value at the beginning of each map ID.

Make Uppercase
Select for uppercase auto-generated map IDs.

Start Numbering With
Select to enter a starting number for map numbers.

Notes:

• Setting these options does not affect existing map IDs.
• By default, the application assigns the topic title or filename as the topic ID and assigns a map 

number.
• Auto-generating map IDs is available when you select <Project Map File> or a custom map file. If 

you auto-map a map ID and do not select a map file, the map ID resides in the default map file 
(BSSCDefault.h).

• You cannot assign multiple topics to a map ID. You can assign multiple map IDs to one topic.
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Assign a map ID to a topic

NOTE: RoboHelp also supports dynamic context-sensitive mapping of dialog boxes and topics. This 
approach eliminates the need for technical authors to manually keep track of map IDs. See Dynamic 
editing of context-sensitive topics.
1) Open the Output Setup pod.
2) Expand the Context-Sensitive Help folder.
3) Expand the Map Files folder.
4) Double-click All Map IDs.
5) In Map File, click the Down Arrow and select the map file that contains the map ID.
6) Select the map ID to assign.
7) Select the topic.
8) Click Assign.
9) Click Close.
10) Generate the project.
11) Test the window-level topics with the application.

Unassign a map ID

1) Open the topic.
2) Click the Properties button .
3) Click the Advanced tab.
4) Click Assigned Map IDs.
5) Select the map ID to unassign.
6) Click Edit Map IDs.
7) Click Unassign.
8) Click Close.
9) Generate the project.
10) Test the window-level topics with the application.

NOTE: If you assign map IDs to bookmarks and remove the bookmarks from the topics, manually unassign 
map IDs from the bookmarks.

Dynamic editing of context-sensitive topics

RoboHelp supports dynamic editing of the context-sensitive topic associated with an application dialog 
box. If no topic is associated with the dialog box, you can either dynamically map an existing topic with 
the dialog box or create a new topic and then map it with the dialog box.
NOTE: To use this feature, you must open the application from within RoboHelp. Also, the application 
must implement context-sensitive help using the RoboHelp 9 Context-Sensitive Help API. Currently, only 
C++ APIs on Windows are supported.
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Usage scenarios

Mapping dialog boxes with Help topics requires close collaboration between developers and technical 
authors. Normally, developers define map IDs for dialog boxes in the code and communicate them to 
technical authors. Technical authors then manually associate the map IDs with Help topics.

Dynamic context-sensitive mapping of dialog boxes and topics eliminates the need for technical authors 
to manually keep track of map IDs. Instead, technical authors can open the application and associate the 
relevant Help topic dynamically with a dialog box.

This feature also greatly facilitates Help integration testing and troubleshooting. Technical authors can 
readily test whether all dialog boxes are mapped to the correct Help topics. When a mismatch is found, 
they can quickly fix it and associate the dialog box with the correct Help topic.

Map an application dialog box with a topic

1) Open the Help project for the application in RoboHelp.
2) Click Tools > CSH > Open CSH Help.
3) Browse and select the executable file (.exe) for the application. Click Open.
4) Once the application has launched, browse to an application dialog box with context-sensitive Help 

mapping. Press F1 or click the Help button.
5) In the CSH Options dialog box in RoboHelp, select a map file from the Project Map File pop-up 

menu.
NOTE: The CSH Options dialog box appears only if you launched the application from within Robo-
Help using Tools > CSH > Open CSH Help.

6) Do one of the following:
– If you want to map an existing topic in the RoboHelp project with the dialog box, select Map 

To Selected Topic and select a topic for the mapping from the right pane.
– If you want to create a new topic and map it with the dialog box, select Map To New Topic.
– If you want to edit the contents of the topic currently mapped with the dialog box, select Edit 

Mapped Topic.
– If you want to remove the current mapping between the dialog box and a Help topic, select 

Remove Mapping.

7) Click OK.

Information for developers

The API shares parameters with HTML Help and WinHelp. You can create custom dialog boxes. NOTE: 
"Custom dialog boxes" refers to the feature that the projects using these APIs have to create their own 
dialog boxes based on their requirements.

Call your Help projects with the function RH_ShowHelp. The source code for this function is contained 
in the support files which you import into your development project. Languages supported are Visual 
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Basic, C/C++, JavaScript, and Java. The files are in C:\Program Files\Adobe\Adobe RoboHelp 
[version]\CSH API. The files are:
• CSH API\RoboHelp_CSH.vb (Visual Basic)
• CSH API\RoboHelp_CSH.cpp (C/C++, dependent on the .h)
• CSH API\RoboHelp_CSH.h (C/C++, dependent on the .cpp)
• CSH API\RoboHelp_CSH.js (Web pages - HTML/JavaScript)
• CSH API\RoboHelp_CSH.java (Java applications)

RH_ShowHelp has four parameters as shown in the following table:

Program Help for Visual Basic applications

This information is for developers connecting context-sensitive Help topics to Visual Basic applications.
1) Open the project in Visual Basic.
2) If the map files were created in RoboHelp, ask the Help system author to export the map files from 

RoboHelp to Visual Basic.
3) Include RoboHelp_CSH.vb with your project. The function RH_ShowHelp is defined in Robo-

Help_CSH.vb.
4) Add a reference to the Microsoft Internet Controls.
5) To launch the Help system, call RH_ShowHelp with uCommand set to HH_DISPLAY_INDEX, 

HH_DISPLAY_SEARCH, or HH_DISPLAY_TOC and dwData set to "0".
6) Set the value of the Help source parameter (according to the Output type) in a string variable called 

StrPathAndWindow as follows:

Parameter Description

hParent Handle to calling dialog HTML Help Only: This parameter closes the Help 
dialog when the calling window is closed.

a_pszHelpFile Help Source (depends on the Output type)
For Webhelp/FlashHelp: "Path to project start page"
For Webhelp Pro: "http://<ServerName>/roboapi.asp"
For HTML Help: "Path to .CHM file". To specify a dialog, use 
">WindowName" at the end of the parameter.

uCommand Constants:
HH_DISPLAY_INDEX Displays Index pane and default topic.
HH_DISPLAY_SEARCH Displays Search pane and default topic.
HH_DISPLAY_TOC Displays Contents pane and default topic.
HH_HELP_CONTEXT Opens topic associated with map ID in dwData 
parameter.

dwData To obtain the map ID, export the map file for the programming language. 
Use HH_HELP_CONTEXT in the uCommand parameter.
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NOTE: In the following examples, the API shares the same parameters regardless of output type. The 
only change made is the location of the Help file.

WebHelp/FlashHelp
Stores the full path to the start page and a dialog name in a string variable called StrPathAnd-
Window. An example of this string is "C:\Program Files\MyApplication\WebHelp\MyStart-
Page.htm>MyWindow.”

WebHelp Pro
Stores the full path to the server and a window name in a string variable called StrPathAndWindow. 
Check with the web administrator to determine whether the project name is required. (The project 
name is required if the Auto-Merge option in the RoboHelp Server Configuration Manager is set to 
Off.)

An example of this string is 
http://<servername>/robohelp/rest/search?project=<project-name>&quesn
=<search-query>

HTML Help
Stores the full path to the CHM file and a dialog name in a string variable called StrPathAndWindow. 
An example of this string is “C:\Program Files\MyApplication\MyHelp.chm>MyWindow.”

TIP: Do not hard-code the string variable StrPathAndWindow.
7) To call a Help topic, call the function RH_ShowHelp with a_pszHelpFile set to 

StrPathAndWindow, uCommand set to HH_HELP_CONTEXT, and dwData set to the map ID of 
the topic.

RH_ShowHelp syntax

RH_ShowHelp syntax

RH_ShowHelp(hParent As Long, a_pszHelpFile As String, uCommand As Long, 
dwData as Long) As Boolean

Example:

To open the topic mapped to number 1:  
Public cshObject as new RoboHelp_CSH .RH_ShowHelp Me.HWND, 
StrPathAndWindow, cshObject.HH_HELP_CONTEXT, 1;

Notes:

• In WebHelp Pro projects, the new context-sensitive Help API is supported only with RoboHelp 
Server.

• Create one global RoboHelp_CSH object to use for all context-sensitive Help calls.
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Airplane Help for Visual Basic applications

If using Airplane Help, associate offline Help before making function calls.

Syntax

Public Function RH_AssociateOfflineHelp(pszPrimaryHelpSource As String, 
pszBackupHelpSource As String) As Boolean

Example

strOnline = "http:// www.mycompany.com/roboapi.asp?project=myproject" 
strOffline = "C:\Program Files\My App\WebHelp\StartPage.htm"  
Public cshObject as new RoboHelp_CSH  ' Should be global object 
cshObject. RH_AssociateOfflineHelp strOnline, strOffline

Program Help for Visual C++ applications

This information is for developers connecting context-sensitive Help topics to C++ applications.
1) Open the project in the C++ IDE.
2) Add RoboHelp_CSH.cpp and RoboHelp_CSH.h to the project.
3) Link the wininet.lib and Htmlhelp.lib libraries to the application. Look for the Htmlhelp.lib library in 

the CSH API subfolder of the installation folder.
4) If you are using Microsoft Visual C++ with MFC, set the RoboHelp_CSH.cpp file so that it doesn’t use 

precompiled headers.

Prevent RoboHelp_CSH.cpp from using precompiled headers

Visual Studio 6

1) Select Project > Settings.
2) Select Robohelp_Csh.Cpp.
3) On the C/C tab, change Category to Precompiled Headers.
4) Select Not Using Precompiled Headers.
5) Click OK.

Visual Studio .NET

1) Right-click Robohelp_Csh.Cpp. Select Properties.
2) In the C/C folder, select Precompiled Headers.
3) Select Not Using Precompiled Headers.

Function calls from Visual C++ applications

NOTE: Connect context-sensitive Multiscreen HTML5, Responsive HTML5, WebHelp, WebHelp Pro, Flash-
Help, FlashHelp Pro, or HTML Help topics to Visual C++ applications.
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NOTE: You can call the context-sensitive help from other languages too. Visual C++ is given as an example 
here.

RH_ShowHelp syntax

int RH_ShowHelp(HWND hParent, const char * a_pszHelpFile, unsigned int 
uCommand, DWORD dwData)

RH_OpenHelpTopic Syntax

Call "RH_OpenHelpTopic” function to open a Help Topic in WebHelp or FlashHelp.
int RH_OpenHelpTopic(const TCHAR * a_pszHelpMainPage, 
                     const TCHAR * a_pszTopicRelPath);

Parameter Data type Description

hParent HWND Handle to calling the dialog box HTML Help Only: 
Close the Help dialog box with the calling window.

a_pszHelpFile const char * Help source For Webhelp/FlashHelp: "Path to 
project start page" For Webhelp Pro: 
"http://[ServerName]/roboapi.asp"
* For HTML Help: "Path to .CHM file"
To specify a dialog box, use ">WindowName" at the 
end of this parameter.

uCommand unsigned int Constants:
HH_DISPLAY_INDEX Displays Index pane and 
default topic.
HH_DISPLAY_SEARCH Displays Search pane and 
default topic.
HH_DISPLAY_TOC Displays Contents pane and 
default topic.
HH_HELP_CONTEXT Opens topic associated with 
map ID in dwData parameter.

dwData DWORD To obtain the map ID, export the map file for the 
programming language. Use HH_HELP_CONTEXT 
in the uCommand parameter.

Parameter Data type Description

a_pszHelpMainPage const char * Help source For Webhelp/FlashHelp: "Path to 
project start page" . To specify a window, append 
">WindowName" at the end Path to the project 
start page.

a_pszTopicRelPath const char * Relative path of the topic corresponding to the 
main page.
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TIP: To open to the default topic, make a Help call that sets uCommand to HH_DISPLAY_INDEX, 
HH_DISPLAY_SEARCH, or HH_DISPLAY_TOC, and dwData to "0". In WebHelp Pro systems, default 
window settings for default navigation buttons override the HH_DISPLAY constant.

Call a CSH function for AIR Help

NOTE: The AIR Help API is provided for many languages including JAVA, VC.NET, CS.NET, VB, VB.NET. The 
following example shows how to invoke the AIR Help API using Visual C++.

Call RH_AIR_ShowHelp function to show AIR Help Application.
int RH_AIR_ShowHelp(const TCHAR * a_pszViewerPath, 
const TCHAR * a_pszHelpId, 
const TCHAR * a_pszWindowName, 
unsigned long ulMapNum, 
const TCHAR * a_pszMapId, 
const TCHAR * a_pszTopicURL);

The return value is 0 for a successful result and non-zero if any error occurs.

RH_GetAIRAppPath

Call RH_GetAIRAppPath function to get AIR Help Application.
TCHAR * RH_GetAIRAppPath(const TCHAR * a_pszAppId, 
const TCHAR * a_pszPublisherId);

Parameter Data Type Description

a_pszViewerPath const char * Path to the installation directory of AIR Help 
Application.

a_ pszHelpId const char * (Optional) ID of help content to be viewed in 
Viewer. It is specified in .helpcfg file.

a_pszWindowName const char * (Optional) Customized output window name.

ulMapNum unsigned long Context-sensitive map number

a_pszMapId const char * (Optional) Context-sensitive map ID. If specified it 
takes priority and ulMapNum is ignored.

a_pszTopicURL const char * (Optional) URL of the topic to appear. If specified, 
this parameter takes priority over ulMapNum and 
a_pszMapId.

Parameter Data Type Description

a_pszAppId const char * Help app ID, specified in RoboHelp during AIR 
generation.

a_pszPublisherId const char * ID corresponding to the digital certificate used for 
signing the AIR application.
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The return value path of the AIR application. The user can call the function free() to free up the 
memory. NOTE: Data Type can also be const wchar * for Unicode enabled applications.

Call a CSH function for Responsive HTML5, WebHelp, FlashHelp, or FlashHelp Pro

The following example assumes the full path to the WebHelp/FlashHelp start page and a dialog box name 
are stored in a string variable called StrPathAndWindow. An example of this string is “C:\\Program 
Files\\MyApplication\WebHelp\MyStartPage.htm>MyWindow.” Do not hard-code this string.
NOTE: Export the map files to the location.

Example:

To open the topic mapped as number 1:
RH_ShowHelp(GetSafeHwnd(), strPathAndWindow, HH_HELP_CONTEXT, (DWORD)1);

NOTE: If using airplane Help, associate the offline Help before making calls.
NOTE: If using Multiscreen or Responsive HTML5 Help, you can also use the functions RH_ShowMul-
tiscreenHelpWithMapId andRH_ShowMultiscreenHelpWithMapNoto call HTML5 help topics using 
MapId and Map number, respectively. The source code and documentation for these functions is 
contained in the support file RoboHelp_CSH.cpp located at C:\Program Files\Adobe\Adobe RoboHelp 
[version]\CSH API\. You need to import this support file into your C/C++ development project to use 
these functions.

Call a CSH function for WebHelp Pro

1) Call the function.
The following example assumes the full path to the server and a window name are stored in a string 
variable called StrPathAndWindow. The project name is required if the Auto-Merge option is set to 
Off. The value of this string is 
http://<servername>/robohelp/rest/search?project=<project-name>&quesn
=<search-query> for getting the URL for a given keyword.
For getting the context-sensitive information, the URLs are 
http://servername>/robohelp/rest/robowindow?wtype=ctx 
&context=<id>[&area=<area_of_publishing>&type=project_type>]

or
http://servername>/robohelp/rest/robowindow?wtype=prj&window=<windown
ame>[&area=<area_of_publishing>&type=<project_type>]
NOTE: Export the map files to the location.
Example:
To open the topic mapped to number 1:
RH_ShowHelp(GetSafeHwnd(), strPathAndWindow, HH_HELP_CONTEXT, (DWORD)1);

2) Run and test the Help call.

NOTE: If using airplane Help, associate the offline Help before making calls.
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Call a CSH function for HTML Help

1) Call the function.
The following example assumes the CHM file and a window name are stored in a string variable 
called StrPathAndWindow. The value of this string indicates the path to the CHM file, such as C:\Pro-
gram Files\MyApplication\MyHelp.chm>MyWindow.
Example:
To open the topic mapped as number 1:
RH_ShowHelp(GetSafeHwnd(), strPathAndWindow, HH_HELP_CONTEXT, (DWORD)1);

2) Run and test the Help call.

Notes:

• If using airplane Help, associate the offline Help before making calls.
• In WebHelp Pro projects, the Help API is supported only with RoboHelp Server or RoboEngine 3.0 

or later.

Overriding the default MFC Help Handler

This topic is for Visual C++ developers who create MFC-based applications.
• As stated in the RoboHelp_CSH.h header file, the wininet.lib and Htmlhelp.lib libraries must be 

linked into the application. The Htmlhelp.lib library can be in the CSH API folder in the RoboHelp 
installation folder.

• Include the RoboHelp_CSH.cpp file in your project.
• To use the RoboHelp API instead of the default MFC Help handler, override the WinHelp function 

in your mainframe class. By default, Visual Studio calls this class CMainFrame, and you can use the 
class wizard inside Visual Studio to create the function override.

• After overriding the function and including RoboHelp_CSH.h, replace the contents of the function 
with this code. (Set the path to your Help file properly. The example shows RoboHelp Server-based 
Help.)
NOTE: Modify the path to server-based Help according to your project. In this example, the path 
applies to RoboHelp Server Help. See the rest of the API documentation to determine parameter 
values for each command and specify secondary windows for context-sensitive Help calls.

CWaitCursor wait; 
if (IsFrameWnd()) { 
// CFrameWnd windows should be allowed to exit help mode first 
CFrameWnd* pFrameWnd = (CFrameWnd*)this; 
pFrameWnd->ExitHelpMode(); 
}  
// cancel any tracking modes 
SendMessage(WM_CANCELMODE); 
SendMessageToDescendants(WM_CANCELMODE, 0, 0, TRUE, TRUE); 
// must use top level parent (for the case where m_hWnd is in DLL) 
CWnd* pWnd = GetTopLevelParent(); 
pWnd->SendMessage(WM_CANCELMODE); 
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pWnd->SendMessageToDescendants(WM_CANCELMODE, 0, 0, TRUE, TRUE); 
// attempt to cancel capture 
HWND hWndCapture = ::GetCapture(); 
if (hWndCapture != NULL) 
::SendMessage(hWndCapture, WM_CANCELMODE, 0, 0); 
// Set the path to server-based help 
CString csOnlineHelpPath = _T("http://myserver/RoboAPI.asp"); 
// Translate the nCmd from WinHelp commands to RoboHelp commands 
unsigned int nRHCmd; 
switch (nCmd) { 
case HELP_CONTEXT: nRHCmd = HH_HELP_CONTEXT; break; 
case HELP_CONTENTS: nRHCmd = HH_DISPLAY_TOC; break; 
case HELP_CONTEXTMENU: nRHCmd = HH_TP_HELP_CONTEXTMENU; break; 
case HELP_WM_HELP: nRHCmd = HH_TP_HELP_WM_HELP; break; 
case HELP_FINDER: nRHCmd = HH_HELP_FINDER; break; 
default: nRHCmd = nCmd; break; 
}  
// finally, run the RoboHelp Help engine 
if (!RH_ShowHelp(pWnd->m_hWnd, csOnlineHelpPath, nCmd, dwData)) 
AfxMessageBox(AFX_IDP_FAILED_TO_LAUNCH_HELP);

Visual C++ developers using Visual Studio .NET

• As stated in the RoboHelp_CSH.h header file, the wininet.lib and htmlhelp.lib libraries must be 
linked into the application.

• Include the RoboHelp_CSH.cpp file in your project.
• To use the RoboHelp API instead of using the default MFC Help handler, override the HtmlHelp 

function in your mainframe class. By default, Visual Studio calls this class CMainFrame, and you can 
use the class wizard inside Visual Studio to create the function override.

• After overriding the function and including RoboHelp_CSH.h, replace the contents of the function 
with the following code. (Set the path to your Help file accordingly. The example shows 
server-based Help.)
CWaitCursor wait; 
// Get the path to the Help system  
CWinApp* pApp = AfxGetApp(); 
ASSERT_VALID(pApp); 
// Set the path to server-based help  
CString csOnlineHelpPath = _T("http://RoboHelp 
Server:port/robohelp/server"); 
PrepareForHelp(); 
// must use top level parent (for the case where m_hWnd is in DLL)  
CWnd* pWnd = GetTopLevelParent(); 
// finally, run the RoboHelp Help engine 
if (!RH_ShowHelp(pWnd->m_hWnd, csOnlineHelpPath, nCmd, dwData)) 
AfxMessageBox(AFX_IDP_FAILED_TO_LAUNCH_HELP);

NOTE: In WebHelp Pro projects, the new context-sensitive Help API is supported only with RoboHelp 
Server or RoboEngine 3.0 or later.
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Airplane Help for C++ applications

Syntax

void RH_AssociateOfflineHelp(const char * a_pszPrimaryHelpSource, const 
char * a_pszBackupHelpSource)

Example

m_sOnline = "http://www.mycompany.com/roboapi.asp?project=myproject"; 
m_sOffline = "C:\Program Files\My App\WebHelp\StartPage.htm"; 
RH_AssociateOfflineHelp(m_sOnline, m_sOffline);

NOTE: To specify different window names for online and offline Help, you can map windows to RH_Asso-
ciateOfflineHelp. Follow this example for Visual Basic:

strOnline = 
"http://www.mycompany.com/roboapi.asp?project=myproject>RemoteWindow1" 
strOffline = "C:\Program Files\My App\MyHelp.chm>LocalWindow1" 
Public cshObject as new RoboHelp_CSH  ' Should be global object 
cshObject. RH_AssociateOfflineHelp strOnline, strOffline 
strOnline = 
"http://www.mycompany.com/roboapi.asp?project=myproject>RemoteWindow2" 
strOffline = "C:\Program Files\My App\MyHelp.chm>LocalWindow2" 
cshObject. RH_AssociateOfflineHelp strOnline, strOffline

NOTE: WebHelp Pro context-sensitive Help API is supported only with RoboHelp Server or RoboEngine 3.0 
or later.

Program Help for Java applications

This information is for developers connecting context-sensitive Help topics to Java applications.
1) Open the project in your Java IDE (integrated development environment).
2) Add RoboHelp_csh.java to the project.
3) Call the function defined in RoboHelp_csh.java using any needed parameters.

NOTE: Airplane Help is not supported in the Java API.

Function calls from Java applications

In the following examples, the API shares the same parameters regardless of output type. The only 
change made is the location of the Help file.

public static boolean RH_ShowHelp(int hParent, String a_pszHelpFile, int 
uCommand, int 
dwData)

Parameter Data Type Description

hParent int Reserved for future versions. Use 0.
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TIP: To launch the Help system (open to the default topic), make a Help call that sets uCommand to 
HH_DISPLAY_INDEX, HH_DISPLAY_SEARCH, or HH_DISPLAY_TOC, and dwData to "0". In 
WebHelp Pro systems, default window settings for default navigation button override the HH_DISPLAY 
constant (however, the Help system still opens to the default topic).

Call a CSH function for Responsive HTML5, WebHelp, FlashHelp, or FlashHelp Pro

1) Call the function.
RoboHelp_CSH.RH_ShowHelp(0, StrPathAndWindow, 
RoboHelp_csh.HH_HELP_CONTEXT, 1);

Where the full path to the WebHelp/FlashHelp start page and a window name (optional) are stored 
in StrPathAndWindow. (Never hard code this string.) NOTE: "Do not hard-code" here suggests that it 
should be left as a variable which should be taken as input from the user in order for the code to be 
reusable, for opening different help files.

2) Run the application and test the Help call.

NOTE: If using Multiscreen or Responsive HTML5 Help, you can also use the functions RH_ShowMul-
tiscreenHelpWithMapId andRH_ShowMultiscreenHelpWithMapNoto call HTML5 help topics using 
MapId and Map number, respectively. The source code and documentation for these functions is 
contained in the support file RoboHelp_CSH.java located at C:\Program Files\Adobe\Adobe RoboHelp 
[version]\CSH API\. You need to import this support file into your Java development project to use these 
functions.

a_pszHelpFile String Help source For Webhelp/FlashHelp: "<Path to 
project start page>" For WebHelp Pro: 
"http://[ServerName]/roboapi.asp"
*Optional: Specify dialogs using ">WindowName" 
at the end of this parameter

uCommand int Constants:
HH_DISPLAY_INDEX Displays Index pane and 
default topic.
HH_DISPLAY_SEARCH Displays Search pane and 
default topic.
HH_DISPLAY_TOC Displays Contents pane and 
default topic.
HH_HELP_CONTEXT Opens topic associated with 
map ID in dwData parameter.

dwData int Topic map ID (defined in Edit Map IDs in RoboHelp). 
To obtain the map ID, export the map file for your 
language (use HH_HELP_CONTEXT in the 
uCommand parameter).

Parameter Data Type Description
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Call a CSH function for WebHelp Pro

1) Call the function.
RoboHelp_CSH.RH_ShowHelp(0, StrPathAndWindow, 
RoboHelp_csh.HH_HELP_CONTEXT, 1);

Where the full path to the RoboHelp server and a dialog box name (optional) are stored in Str-
PathAndWindow. (The project name is required if the Auto-Merge option is set to Off in the Robo-
Engine Configuration Manager.) Examples of this value are “http://RoboHelp 
Server:port/robohelp/server” or “http://RoboHelp Server:port/robohelp/server?project=MyProj-
ect>MyWindow.”
To open the topic mapped as number 1:
RoboHelp_CSH.RH_ShowHelp(0, StrPathAndWindow, 
RoboHelp_csh.HH_HELP_CONTEXT, 1);

2) Run the application and test the Help call.

Program Help for web pages

This information is for developers connecting context-sensitive Help topics to web pages.
1) Talk to the Help author to determine the following:

– Who provides the map numbers.
– If the project has context-sensitive Help.
– Where the Help system resides (locally or on a server).

2) Open your web pages.
3) Link the pages to RoboHelp_csh.js.
4) Call the function contained in RoboHelp_csh.js wherever you call Help from the website.

Program Help for web pages (WebHelp/Pro)

TIP: Use the context-sensitive Help support files. These files allow developers to call built-in functionality.

The example below shows one way to declare a JavaScript function that displays a secondary dialog. The 
ShowHelp function shows the specified topic in a custom window with the attributes defined by the 
strHelpOptions variable.

var strHelpOptions = "location=no"; 
strHelpOptions += ",toolbar=no"; 
strHelpOptions += ",menubar=yes"; 
strHelpOptions += ",status=yes"; 
strHelpOptions += ",scrollbars=yes"; 
strHelpOptions += ",resizable=yes"; 
strHelpOptions += ",top=0"; 
strHelpOptions += ",left=0"; 
strHelpOptions += ",width=400"; 
strHelpOptions += ",height=400"; 
function ShowHelp(strUrl) 
{  
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window.open(strUrl, "Help", strHelpOptions); 
}  

To use ShowHelp, place the above script between the </HEAD> and <BODY> tags in the HTML file. 
Include an anchor tag like the following where users can get help:

Help!

This tag makes a hyperlink with the text Help! When an end user clicks the hyperlink, widget.htm opens 
in a secondary browser.

Function calls from web pages

NOTE: This information is for developers connecting context-sensitive Multiscreen/Responsive HTML5 
Help, WebHelp, WebHelp Pro, FlashHelp, or FlashHelp Pro topics to web pages.

In the following examples, the API shares the same parameters regardless of output type. The only 
change made is the location of the Help file.
NOTE: If using Multiscreen or Responsive HTML5 Help, you can also use the functions RH_ShowMul-
tiscreenHelpWithMapId and RH_ShowMultiscreenHelpWithMapNo to call HTML5 help topics using 
MapId and Map number, respectively. The source code and documentation for these functions is 
contained in the support file RoboHelp_CSH.js located at C:\Program Files\Adobe\Adobe RoboHelp 
[version]\CSH API\. You need to import this support file into your HTML/JavaScript development project 
to use these functions.

RH_ShowHelp syntax

function RH_ShowHelp(hParent, a_pszHelpFile, uCommand, dwData)

Parameter Data Type Description

hParent var Reserved for future versions of API. Use "0."

a_pszHelpFile var Help source For WebHelp: "<Path to project start 
page>" (Can be local or on a server) For WebHelp 
Pro: "http://[server name]/roboapi.asp"
*Optional: To specify a window, use 
">WindowName" at the end of this parameter

uCommand var Constants:
HH_DISPLAY_INDEX Displays Index pane and 
default topic.
HH_DISPLAY_SEARCH Displays Search pane and 
default topic.
HH_DISPLAY_TOCDisplays Contents pane and 
default topic.
HH_HELP_CONTEXT Opens topic associated with 
map ID in dwData parameter.
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RH_OpenHelpTopic Syntax

Call the "RH_OpenHelpTopic" function to open a WebHelp/FlashHelp topic.
function RH_OpenHelpTopic(a_pszHelpMainPage, a_pszRelTopicUrl)

TIP: To launch the entire Help system (open to the default topic), make a Help call that sets uCommand 
to HH_DISPLAY_INDEX, HH_DISPLAY_SEARCH, or HH_DISPLAY_TOC, and dwData to "0". In 
WebHelp Pro systems, default window settings for default navigation buttons override the 
HH_DISPLAY constant.

Call a context-sensitive function for WebHelp Pro

1) Call the following API for getting the context-sensitive information from the server.
The following example assumes that you have stored the full path to your RoboHelp server and a 
window name (optional) in a string variable called StrPathAndWindow. The project name is re-
quired if the Auto-Merge option is set to Off in the RoboEngine Configuration Manager. Examples 
of the value of this string are “http://RoboHelp Server:port/robohelp/server” or “http://RoboHelp 
Server:port/robohelp/server?project=MyProject>MyWindow.”
NOTE: Ask your technical writer which windows to call. Also, if the writer creates the map files, ask 
the writer to export the map files to the location.
For example:
To open the topic mapped as number 1:
<p>Click for Help (map number 1)</p>

2) Run the application and test the Help call.

NOTE: In WebHelp Pro projects, the new context-sensitive Help API is supported only in RoboEngine 3.0 
or later.

dwData var Map ID of the topic displayed. To obtain the map ID, 
the author can export the map file for a 
programming language using HH_HELP_CONTEXT 
in the uCommand parameter.

Parameter Data Type Description

a_pszHelpMainPage var Help source for WebHelp/FlashHelp: "Path to 
project start page". To specify a window, append 
">WindowName" at the end Path to the project 
start page.

a_pszRelTopicUrl var Relative path of the topic corresponding to the 
main page.

Parameter Data Type Description
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Call a context-sensitive function for WebHelp or FlashHelp

1) Call the following API for getting the context-sensitive information from the server.
http://servername>/robohelp/rest/robowindow?wtype=ctx&context=<MAP 
ID>

For example:
To open the topic mapped as number 1, change the <MAP ID> with 1.

2) Run the application and test the Help call.

Program Help for .NET

.NET basics

Supports all forms of RoboHelp Server with .NET development:
• Creates web services, WebForms, and WinForms.
• Provides comprehensive support for .NET Framework.
• Operates as a self-contained .NET web service.
• Provides APIs to support Help development in Visual C .NET, C# .NET, Visual Basic .NET, and ASP 

.NET.
• Ensures that existing context-sensitive Help supports .NET requirements.

RoboHelp Server with .NET is designed to create applications for desktops, intranets, or the Internet and 
to support the development of these applications.

Create server-based Help within the .NET environment and generate real-time analysis of end-user 
activity in a Help system. Use with Visual C .NET, ASP .NET, Visual Basic .NET, or C# .NET to integrate Help 
systems.

Context-sensitive Help support files for .NET

Support files for programming context-sensitive Help allow you to import code and enter variables 
instead of writing the code. The context-sensitive Help API for .NET supports Visual C++ .NET, ASP .NET, 
Visual Basic .NET, and C# .NET.

The API shares parameters with HTML Help and WinHelp. Custom windows are supported. 
Context-sensitive Help works without any modifications.

Import file for the corresponding language from the respective folders at:
C:\Program Files\Adobe\Adobe RoboHelp [version]\CSH API

C# .NET

C# .NET is an object-oriented language that enables C and C++ programmers to transition to the new .NET 
environment while providing integration with existing applications. Components can be converted into 
XML and run using any language on any operating system.
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ASP .NET

ASP .NET is part of the .NET Framework for building web applications and XML web services. ASP .NET 
pages use a compiled, event-driven programming model to generate markup such as HTML, WML, or 
XML. It allows the separation of application logic and user interface. You can use any .NET language, such 
as Visual Basic .NET or C# .NET, to create ASP .NET pages and AS P.NET XML web services files containing 
server-side logic.

Make a Help call

Make sure that context-sensitive Help function calls specify the online Help in the individual calls to 
RH_Showhelp. When a remote Help call is made, the online version of the Help system appears. If 
connecting to the Internet is not possible, offline Help appears.

Call context-sensitive Help for WebHelp or FlashHelp from C# .NET

1) Include the RoboHelp_CSH.cs file in the project.
2) Call the RH_ShowLocalHelp (hParent, strtHelpURL, strWndName, nCommand, 

nData)function.

Parameter Data Type Description

hParent Object Handle of the parent window.

strHelpURL String Help source for WebHelp; specifies the path to the project 
start page.

strWndName String Name of the window to be opened.

nCommand Int Class constants.

OptionConstants.CSH_DISPLAY_CONTEXT

Opens the topic associated with the map ID in the 
nData parameter

OptionConstants.CSH_DISPLAY_TOC

Displays the Contents pane and the default topic

OptionConstants.CSH_DISPLAY_INDEX

Displays the Index pane and the default topic

OptionConstants.CSH_DISPLAY_SEARCH

Displays the Search pane and the default topic

nData Int Displays the map ID of the topic. To obtain the map ID, you 
can export the map file for a programming language using 
OptionConstants.CSH_DISPLAY_CONTEXT in nCommand.
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Call context-sensitive Help for WebHelp Pro or FlashHelp Pro from C# .NET

1) Open VisualStudio.
2) Do one of the following:

– Select File > New > Project.
– Open a C# .NET project.

3) Add a button named Help.
4) Navigate to the context-sensitive Help supporting files in C:\Program Files\[RoboHelp Install 

Folder]\CSH API\CS.NET.
5) Copy the RoboHelp_CSH.cs file.
6) Paste the files to the C# .NET project.
7) Right-click the Reference folder. Select Add Reference.
8) Select .Net tab > System.Web.Services.Dll.
9) Click OK.
10) Right-click the Reference folder. Select Add Reference.
11) Select

c:\windows\system32\msxml2.dll

12) Select OK.
13) Double-click the Help button.
14) Copy C# .NET context-sensitive Help example code and paste into the code.
15) Add using RoboHelpAPI to the top of the document.
16) To test, compile, and run the project, select the Help button.

Call context-sensitive Help for WebHelp or FlashHelp from ASP .NET

1) Include the RoboHelp_CSH.cs file in the project.
2) Call the RH_ShowLocalHelp (hParent, strtHelpURL, strWndName, nCommand, 

nData)function.

Parameter Data Type Description

hParent Object Handle of the parent window.

strHelpURL String Help source for WebHelp; specifies the path to the project 
start page.

strWndName String Name of the window to be opened.
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Call context-sensitive Help for WebHelp Pro or FlashHelp Pro from ASP .NET

1) Open VisualStudio .NET.
2) Do one of the following:

– Select File > New > Project.
– Open an ASP.NET project.

3) Navigate to the context-sensitive Help supporting files in C:\Program Files\[RoboHelp Install 
Folder]\CSH API\ASP.NET.

4) Copy the RoboHelp_CSH.cs file.
5) Paste the supporting files to the ASP.NET project.
6) Right-click the Reference folder. Select Add Reference.
7) Select .Net tab > System.Web.Services.Dll.
8) Click OK.
9) Add a button in the application.
10) Double-click the button.
11) Copy the ASP.NET context-sensitive Help example code. Paste it into the code.
12) In the code, add using RoboHelpAPI.
13) To test, compile and run the project. Select the Help button.

nCommand Int Class constants.

OptionConstants.CSH_DISPLAY_CONTEXT
Opens the topic associated with the map ID in the 
nData parameter

OptionConstants.CSH_DISPLAY_TOC

Displays the Contents pane and the default topic

OptionConstants.CSH_DISPLAY_INDEX

Displays the Index pane and the default topic

OptionConstants.CSH_DISPLAY_SEARCH

Displays the Search pane and the default topic

nData Int Displays the map ID of the topic. To obtain the map ID, you 
can export the map file for a programming language using 
OptionConstants.CSH_DISPLAY_CONTEXT in nCommand.

Parameter Data Type Description
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Call context-sensitive Help for WebHelp or FlashHelp from Visual Basic .NET

1) Include the RoboHelp_CSH.vb file in the project.
2) Call the RH_ShowLocalHelp (hParent, strtHelpURL, strWndName, nCommand, 

nData)function.

Call context-sensitive Help for WebHelp Pro or FlashHelp Pro from Visual Basic .NET

1) Open VisualStudio.NET.
2) Do one of the following:

– Select File > New > Project.
– Open a Visual Basic .NET project.

3) Copy the RoboHelp_CSH.vb file.
4) Paste the supporting files to the ASP .NET project.
5) Right-click the Reference folder. Select Add Reference.
6) Select .Net tab > System.Web.Services.Dll.
7) Click OK.

Parameter Data Type Description

hParent Object Handle of the parent window.

strHelpURL String Help source for WebHelp; specifies the path to the project 
start page.

strWndName String Name of the window to be opened.

nCommand Int Class constants.

CSH_DISPLAY_CONTEXT

Opens the topic associated with the map ID in the 
nData parameter

CSH_DISPLAY_TOC

Displays the Contents pane and the default topic

CSH_DISPLAY_INDEX

Displays the Index pane and the default topic

CSH_DISPLAY_SEARCH

Displays the Search pane and the default topic

nData Int Displays the map ID of the topic. To obtain the map ID, you 
can export the map file for a programming language using 
CSH_DISPLAY_CONTEXT in nCommand.
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8) Right-click the Reference. Select Add Reference.
9) Select:

msxml2.dll

10) Select OK.
11) Add a button in the application.
12) Double-click the button.
13) Copy the Visual Basic .NET context-sensitive Help example code and paste it into the code.
14) To test, compile and run the project. Select the Help button.

Locate the RoboHelp Server with .NET samples

1) Select the sample for the application language.

Specify the URL (WebHelp Pro)

1) In code samples, find the string with the name:
m_strServer

2) Assign the server address to m_strServer:
http://server.com/robohelp/rest

3) Specify a project name.
m_strProject = P1

4) Specify the window name in the variable m_strParamValue.

NOTE: STRPRIMARY specifies the primary Help system and STRBACKUP specifies local Help. For Visual 
Basic .NET, Visual C++ .NET, and C# .NET the application is on the client, allowing both online and offline 
Help systems. For ASP .NET, all information is on a Web server. Specify a WebHelp Pro online Help system 
as a primary Help system and a WebHelp online Help system as a backup.

Web services provided in RoboHelp Server with .NET

RoboHelp Server provides the following two services using the REST web services.

Robowindow
Requests the server to get the window properties and context Help URL. See code details.

Search
Performs the sentence search and returns results. See code details.

Name Language

RoboHelp Server CSH.NET VC Sample Visual C++ .NET

RoboHelp CSH.NET VB Sample Visual Basic .NET

RoboHelp CSH.NET C# Sample C# .NET
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Steps without using support files

WebHelp Pro

WebHelp Pro is an uncompiled output type that is RoboHelp Server-based and supports standard Help 
features (such as TOC, index, and search). A browser is not required to view the output. In addition, 
WebHelp Pro provides end-user feedback reports on how people are using your system and other 
features available only with RoboHelp Server. WebHelp Pro projects require RoboHelp Server for 
context-sensitive Help.

Display content

An ASP file is included for viewing content. The default hyperlink is http://<RoboHelp 
Server>/Roboapi.Asp. You can pass a parameter to the ASP file:
• project=Project_Name
• context=MapNumber
• url=URL

For example:
• This URL displays default content from the server: http://<RoboHelp Server>/Roboapi.Asp
• This URL displays the project_name project (merged with any other projects): http://<RoboHelp 

Server>/robohelp/rest/search?project=<project-name>&quesn=<search-query>
• This URL displays content for map number 101: http://<RoboHelp Server>/ /robohelp/rest/robow-

indow?wtype=ctx&context=<id>&project=<project name>

Advanced window control

When opening context-sensitive WebHelp Pro from a browser, use the context-sensitive Help API and 
support files.

WebHelp

Context-sensitive Help for Visual Basic applications

Use this information to connect context-sensitive WebHelp or WebHelp Pro topics to Visual Basic appli-
cations.

The sample code here uses a function called Showhelp that opens a local or remote topic regardless of 
the browser type.

The ShowHelp function has two parameters: strTopic takes a URL or local filename as a value, and 
bIsLocal takes a Boolean value. It indicates whether the first parameter is a local filename (TRUE) or 
remote URL (FALSE). If the file is local, ShowHelp tells the browser to find the file in the Help subfolder 
of the application folder.

Public Function ShowHelp(strTopic As String, _ 
bIsLocal As Boolean) As Boolean 
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Dim strDir As String 
If bIsLocal Then 
' Get registry entry pointing to Help 
strDir = App.Path + "\Help\" 
End If 
' Launch topic 
Dim hinst As Long 
hinst = ShellExecute(Me.hwnd, vbNullString, _ 
  strTopic, vbNullString, _ 
  strDir, SW_SHOWNORMAL) 
' Handle less than 32 indicates failure 
ShowHelp = hinst > 32 
End Function

To call ShellExecute , declare the function. For example:
Private Declare Function ShellExecute Lib _ 
"shell32.dll" Alias "ShellExecuteA" _ 
(ByVal hwnd As Long, _ 
ByVal lpOperation As String, _ 
ByVal lpFile As String, _ 
ByVal lpParameters As String, _ 
ByVal lpDirectory As String, _ 
ByVal nShowCmd As Long) As Long

The ShowHelp function requires an explicit filename or URL. But for context-sensitive Help, it is better 
to code the application to use context IDs rather than explicit topic names. Use the following sample 
function, ShowHelpContext, which maps integer context IDs to topic name strings, then calls 
ShowHelp to launch the topic.

Public Function ShowHelpContext(nContextId As Integer) As Boolean  
Dim strTopic As String 
Dim bIsLocal As Boolean 
bIsLocal = True 
Select Case nContextId 
Case HH_GADGET_DIALOG  
strTopic = "gadget.htm"  
Case HH_WHATSIT_DIALOG  
strTopic = "whatsit.htm"  
Case HH_WIDGET_DIALOG  
strTopic = "widget.htm"  
Case HH_TECH_SUPPORT:  
strTopic = "http://www.mycompany.com" 
bIsLocal = False  
Case Else  
strTopic = "unknown-context.htm"  
End Select 
ShowHelpContext = ShowHelp(strTopic, bIsLocal)  
End Function 

..............................................................................................................................................
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Using ShowHelpContext makes maintaining context-sensitive Help much easier because, if a topic 
name changes, only one function must be modified. Declare context IDs (for 
example,HH_GADGET_DIALOG) as constants that can be shared among the program modules that use 
context-sensitive WebHelp or WebHelp Pro.

Const HH_GADGET_DIALOG As Integer = 1  
Const HH_WHATSIT_DIALOG As Integer = 2  
Const HH_WIDGET_DIALOG As Integer = 3  
Const HH_TECH_SUPPORT As Integer = 4 

Connect context-sensitive WebHelp and WebHelp Pro topics to Visual C++ applications

NOTE: This information is for developers who must connect context-sensitive WebHelp and WebHelp Pro 
topics to Visual C++ applications.

The sample code provided here uses a function called ShowHelp that opens a local or remote topic 
regardless of the browser type.

The ShowHelp function has two parameters: szTopic takes a URL or local filename as a value, and 
bIsLocal takes a Boolean value. It indicates whether the first parameter is a local filename (TRUE) or 
remote URL (FALSE). If the file is local, ShowHelp tells the browser to find the file in the Help subfolder 
of the application folder.

BOOL ShowHelp(LPCTSTR szTopic, BOOL bIsLocal) 
{  
TCHAR szDir[MAX_PATH] = ""; 
if (bIsLocal) 
{  
// Get directory of application 
DWORD dw = GetModuleFileName(AfxGetInstanceHandle(), szDir, MAX_PATH); 
TCHAR* pchEnd = _tcsrchr(szDir, '\\') + 1; 
ASSERT_POINTER(pchEnd, TCHAR); 
*pchEnd = '\0'; 
// Append subfolder name 
_tcscat(szDir, _T("Help")); 
}  
// Open topic 
HINSTANCE hinst = ShellExecute(NULL, //no parent hwnd 
NULL, // open 
szTopic, // topic file or URL 
NULL, // no parameters 
szDir, // folder containing file 
SW_SHOWNORMAL); // yes, show it 
// handle less than 32 indicates failure 
return hinst > (HINSTANCE)32; 
} 

.......................................................................................................................................

The ShowHelp function requires an explicit filename or URL. But for context-sensitive Help, it is better 
to code the application to use context IDs rather than explicit topic names. Use the following sample 
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function, ShowHelpContext, which maps integer context IDs to topic name strings, then calls 
ShowHelp to open the topic.

BOOL ShowHelpContext(int nContextId) 
{  
CString strTopic; 
BOOL bIsLocal = TRUE; 
switch (nContextId) 
{ 
case HH_GADGET_DIALOG: 
strTopic = _T("gadget.htm"); 
break; 
case HH_WHATSIT_DIALOG: 
strTopic = _T("whatsit.htm"); 
break; 
case HH_WIDGET_DIALOG: 
strTopic = _T("widget.htm"); 
break; 
case HH_TECH_SUPPORT: 
strTopic = _T("http://www.mycompany.com"); 
bIsLocal = FALSE; 
break; 
default: 
strTopic = _T("unknown-context.htm"); 
break; 
} 
return ShowHelp(strTopic, bIsLocal); 
} 

...........................................................................................................................................

Using ShowHelpContext makes maintaining context-sensitive Help much easier because if a topic 
name changes, only one function has to be modified. The context IDs (for example, HH_GADGET_DI-
ALOG) should be declared in a header file that can be shared among the program modules that use 
context-sensitive WebHelp or WebHelp Pro. This can be the same file where the prototypes for 
ShowHelp and ShowHelpContext are defined.

Programming HTML Help in applications

NOTE: Microsoft HTML Help projects only.

Window-level Help for Windows applications

• To call a topic using a map number, make a call to the HTML Help API using the following syntax:
HWND HtmlHelp(Window(), “c:\path\helpfile.chm”, HH_HELP_CONTEXT, 
Number); 

• To call a topic using a filename, make a call to the HTML Help API using the following syntax:
HWND HtmlHelp (Dialog(), “c:\path\helpfile.chm”, HH_DISPLAY_TOPIC, 
"topicfile.htm"); 
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What’s This? Help for Windows applications

The method for programming What’s This? Help depends on the way the context-sensitive Help was 
created.
• If the Help was created in RoboHelp as text-only topic files, see your software development kit for 

details.
• If the Help was created in What’s This? Help Composer, see Create What's This? Help.

NOTE: For more information, see the HTML Help API Reference at http://msdn.micro-
soft.com/en-us/library/ms670068(VS.85).aspx.

Window-level Help for non-Windows platforms

• Use WebHelp to display context-sensitive Help topics for C++ and Visual Basic applications, Java 
applications, and Web pages. For more information, see WebHelp.

• Use JavaHelp to display context-sensitive Help topics for Java applications. For more information, 
see Create context-sensitive JavaHelp.

• Use Oracle Help to display context-sensitive Help topics for Java applications, or applications 
written in other programming languages. For more information, see Create context-sensitive 
Oracle Help.

NOTE: If you must use your HTML Help output as a backup to a WebHelp, WebHelp Pro, FlashHelp, or 
FlashHelp Pro system that is on a server, use Adobe's airplane Help.

Context-sensitive HTML Help function call

Sample code:
HtmlHelp(hWnd,       /*Window handle of program or dialog*/  
"CSHHelp.chm",   /*Name of the CHM file*/  
HH_HELP_CONTEXT,  
dwMapNumber);    /*Map number from map file*/ 

HtmlHelp(hWnd
Program or dialog box window handle. A window handle identifies a window so the HTML Help 
engine discovers what application is performing the action.

CSHHelp.chm
Compiled HTML help file. It includes context-sensitive help. Give the developer this file for use with 
the application.

HH_HELP_CONTEXT
This is the command sent to the HTML Help engine for window-level Help. (A command such as 
HH_TP_HELP_WM_HELP is used for What's This? Help.)

Dwmapnumber
Map number from map file

http://msdn.microsoft.com/en-us/library/ms670068(VS.85).aspx
http://msdn.microsoft.com/en-us/library/ms670068(VS.85).aspx
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Troubleshoot window-level Help

NOTE: Microsoft HTML Help projects only.

Problem Wrong Help topic opens.

Error message Command: HH_HELP_CONTEXT
Processing C:\Project Folder\HelpProject.chm
Map Number: 2750
File: Folder_Name\Topic_Name.htm

Cause Incorrect map ID.

Resolution Update the map ID.
Generate the project and retest.

OR:

Cause Wrong or outdated map file.

Resolution Ensure everyone is using the correct map file.
If the correct map file is used, unassign the map ID for the topic.
Remove the old map file and import the new map file.
Assign new map IDs.
Generate and retest.

Problem Topic is not displayed.

Error message 1. No message
2. Command: HH_HELP_CONTEXT
Result: HH_HELP_CONTEXT called without a [Map] section
3. Command: HH_HELP_CONTEXT
Processing C:\Folder Name\Project_Name.chm
Result: Cannot find 180010 in C:\Folder Name\Project_Name.chm

Cause No assigned map ID.

Resolution If the map file does not exist, the message "HH_HELP_CONTEXT called 
without a [Map] section" appears.
For developer-supplied map files, import the map file. Assign the map 
IDs.
If the message "Cannot find 180010 in C:\Folder 
Name\Project_Name.chm" displays, update the map ID.
Generate and retest.

Problem Topic does not appear or wrong topic appears.
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Create context-sensitive JavaHelp

TIP: Use the context-sensitive Help API and support files to call built-in functionality, rather than creating 
functions to display topics.

Context-sensitive JavaHelp requires custom code from your developer.

A printed copy of the .JHM file may help your developer.

Example:

public class ContextHelp 
{ 
 private HelpSet hs; 
 private HelpBroker hb; 

Error message 1. Command: HH_HELP_CONTEXT
Processing C:\Project Folder\Project_Name.chm
Map Number: 1
File: Folder_Name\Topic_Name.htm
2. Command: HH_HELP_CONTEXT
Processing C:\Project Folder\Project_Name.chm
Result: Cannot find 180010 in C:\Project Folder\Project_Name.chm

Cause Wrong map number used in the call.

Resolution Print the Map IDs report and give it to the developer.
Use this file to correct map number assignments.

Problem Topic appears in wrong dialog box.

Error message "HTML Help Author" opens and displays, "The window name 'window' 
passed to HH_GET_WIN_TYPE has not been specified."

Cause Wrong dialog name used in the call or author did not inform the 
developer that a custom window was created for the topics.

Resolution Ensure the developer knows about the custom dialog.
Generate and retest after the application updates.

Problem Topic is not displayed.

Error message 1. Message is not displayed
2. Command: HH_HELP_CONTEXT
Result: HH_HELP_CONTEXT called without a [Map] section

Cause Map file or map number is missing.

Resolution For developer-supplied map file, restore or update the map file.
Generate the and retest.
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 public boolean ShowHelp(String strTopic, String strHelpSet){ 
    if (hb == null) { 
        ClassLoader loader = getClass().getClassLoader(); 
        URL url; 
        try { 
            url = HelpSet.findHelpSet(loader, strHelpSet); 
            hs = new HelpSet(loader, url); 
        } 
        catch (Exception e) { 
        return false; 
        } 
        hb = hs.createHelpBroker(); 
    } 
    hb.setCurrentID(strTopic); 
    hb.setDisplayed(true); 
   return true; 
 } 
}  

Test context-sensitive JavaHelp

Testing context-sensitive JavaHelp involves authors and developers.

Compress The Project
Compile the project and create a .JAR file. Give the .JAR to your developer.

Test Context-Sensitive Topics
Test topics in the application to ensure they appear in the correct dialogs and windows.

Resolve Errors
Work with your developer to solve any problems.

Create context-sensitive Oracle Help

NOTE: This information is for developers who need to connect context-sensitive Oracle Help topics to 
applications.
TIP: The context-sensitive Help API and support files let you call built-in functionality instead of having to 
create the functions to display topics.

Oracle Help supports context-sensitive Help, but your developer must write and customize the code to 
make it work.

A working example of a Java application with context-sensitive Help is shown below. To run the example:
1) Ensure that you have the Oracle Help for Java components and the Sun Java 2 SDK or later.
2) Copy and paste the code below into a file called CSHDemo.java.
3) Compile the file (for example, javac CSHDemo.java).
4) Run the Java applet (for example, java .cSHDemo <Oracle Help Helpset file>). The Oracle Help 

helpset file parameter is the fully-qualified path to the helpset file. As an example, if you create an 
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Oracle Help helpset file named "sample.hs" and saved it in "C:\myFiles," the command to run this 
application with your helpset file would be:

java CSHDemo C:\myFiles\Sample.hs

Sample context-sensitive Java application

/**********************************************************************
*********** 
 * Oracle Help Context-Sensitive Help Sample Application 
 * 
 * This application is intended to demonstrate a few methods for invoking 
 * context-sensitive Help with Oracle Help. 
 * 
 * USAGE:  CSHSample <full path to helpset file> 
 * 
 
************************************************************************
*********/ 
 
import oracle.help.Help; 
import oracle.help.CSHManager; 
import oracle.help.library.Book; 
import oracle.help.library.helpset.HelpSet; 
import oracle.help.navigator.Navigator; 
 
import java.awt.*; 
import java.awt.event.*; 
import java.net.URL; 
public class CSHSample extends Frame implements ActionListener 
{ 
  private Help helpObj; 
  private Book bookObj; 
  private CSHManager contextManager; 
  private MenuItem exitMenu; 
  private MenuItem contentsMenu; 
  private MenuItem searchMenu; 
  private MenuItem indexMenu; 
 
  // Constants set to TopicIDs from map file for Helpset passed in 
  // via command line. 
  public static final String LABEL = "what_is_a_label_htm"; 
  public static final String FIELD = "what_is_a_text_field_htm"; 
 
  public static void main(String[] args) 
  { 
    if (args.length != 1) { 
      System.err.println("Usage: CSHSample <full path to helpset file>"); 
      System.exit(1); 
    } 
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    Book bookObj = null; 
    String filename = args[0]; 
 
    // Expects filename format to be: 
"file:/[<drive>:/]dir/<helpset_file>" 
    // e.g., "file:/c:/myPath/myHelp.hs" 
    if (filename.charAt(0) == '/') 
      filename = "file:" + filename; 
    else 
      filename = "file:/" + filename; 
 
    try { 
      bookObj = (Book) new HelpSet(new URL(filename)); 
    } 
    catch (Exception e) { 
      System.err.println("CSHSample Error: " + e.getMessage()); 
      System.exit(1); 
    } 
 
    CSHSample sampApp = new CSHSample(bookObj); 
    sampApp.setVisible(true); 
  } 
 
  // Class Constructor 
  public CSHSample(Book bookObj) 
  { 
    super("CSH Sample Application"); 
 
    setResizable(false); 
    setSize(300, 200); 
 
    // Create Help Objects 
    try { 
      helpObj = new Help(false, false); 
      contextManager = new CSHManager(helpObj); 
      contextManager.addBook(bookObj, true); 
    } 
    catch (Exception e) { 
      System.err.println("CSHSample:: Failed While Creating Help object"); 
      e.printStackTrace(); 
      System.exit(1); 
    } 
 
    /******************************************************************** 
     * Add UI Components 
     *******************************************************************/ 
    MenuBar menubar = new MenuBar(); 
 
    Menu filemenu = new Menu("File"); 
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    exitMenu = new MenuItem("Exit"); 
    filemenu.add(exitMenu); 
    exitMenu.addActionListener(this); 
    menubar.add(filemenu); 
 
    Menu helpmenu = new Menu("Help"); 
    contentsMenu = new MenuItem("Help Contents"); 
    contentsMenu.addActionListener(this); 
    helpmenu.add(contentsMenu); 
    indexMenu = new MenuItem("Topic Index"); 
    indexMenu.addActionListener(this); 
    helpmenu.add(indexMenu); 
    searchMenu = new MenuItem("Full Text Search"); 
    searchMenu.addActionListener(this); 
    helpmenu.add(searchMenu); 
    menubar.add(helpmenu); 
 
    setMenuBar(menubar); 
 
    Panel mainPanel = new Panel(); 
    add(mainPanel, BorderLayout.CENTER); 
 
    // Add label 
    Label label = new Label("Country:", Label.LEFT); 
    mainPanel.add(label); 
    // Set context help for component. TopicID = LABEL 
    // Pass the component with the associated TopicID to the CSHManager 
Object 
    contextManager.addComponent(label, LABEL, true, true); 
 
    // Add TextField 
    TextField field = new TextField(15); 
    mainPanel.add(field); 
    // Set context help for component. TopicID = FIELD 
    // Pass the component with the associated TopicID to the CSHManager 
Object 
    contextManager.addComponent(field, FIELD, true, true); 
 
    /******************************************************************** 
     * End: Add UI Components 
     *******************************************************************/ 
 
    addWindowListener( 
      new WindowAdapter() 
      { 
        public void windowClosing(WindowEvent e) 
        { 
          setVisible(false); 
          System.exit(0); 
        } 
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      } 
    ); 
  } 
 
  public void actionPerformed(ActionEvent e) 
  { 
    Object source = e.getSource(); 
 
    if (source == exitMenu) { 
      setVisible(false); 
      System.exit(0); 
    } 
    else if (source == contentsMenu) { 
      // Show Help; Display Contents tab 
      Navigator[] navs = contextManager.getAllNavigators(); 
      if (navs != null) 
        contextManager.showNavigatorWindow(navs[0]); 
    } 
    else if (source == indexMenu) { 
      // Show Help; Display Index tab 
      Navigator[] navs = contextManager.getAllNavigators(); 
      if (navs != null) 
        contextManager.showNavigatorWindow(navs[1]); 
    } 
    else if (source == searchMenu) { 
      // Show Help; Display Search tab 
      Navigator[] navs = contextManager.getAllNavigators(); 
      if (navs != null) 
        contextManager.showNavigatorWindow(navs[2]); 
    } 
  } 
} 

NOTE: Oracle Help uses topic IDs (in a map file) to make context-sensitive Help calls. You can change the 
topic ID by editing the topic's META tag.

What’s This? Help

About the What's This? Help Composer tool

The What's This? Help Composer tool installs with RoboHelp. It supports both WinHelp authored in 
RoboHelp for Word and Microsoft HTML Help.

This tool scans applications and generates projects. It reads program files and creates context-sensitive 
Help topics for all controls and fields in dialog boxes. It can add suggested text to each Help topic to save 
authoring time.



331

WHAT’S THIS? HELP
CHAPTER 11 CONTEXT-SENSITIVE HELP

Supported files for Microsoft HTML Help:
• Program files (EXE)
• Dynamic Link Libraries (DLL)
• ActiveX controls (OCX)

You can add context-sensitive Help to any RoboHelp project. The result is a single text-only file 
(Context.txt) that contains text used for each context-sensitive Help topic that you create.

What's This? Help and Microsoft HTML Help

Creating a What's This? Help project for Microsoft HTML Help does the following:
• Creates a Context.txt file, which contains the context-sensitive topics.
• Attaches the Context.txt file to the project.
• Stores the Context.txt file in a database, updated when you edit the topics.
• Saves Dialog.cid and Context.h files (contain topic IDs) in the project folder. The developer uses 

these files.
• Stores the Context.txt file in the What's This? Help Files folder, in the Context-Sensitive Help folder. 

Double-click the Context.txt file to open the What's This? Help Composer for editing.

NOTE: Deleting any of these files from Project Manager removes the What's This? Help project from your 
HTML Help project.

Use What's This? Help Composer for context-sensitive Help

• Open the HTML Help project, then select this file to open it in What's This? Help Composer.
• Compiling the HTML Help project also complies the context-sensitive topics into your project, as 

part of the CHM file.
• See What's This? Help Composer's online Help system.

Create What's This? Help

1) Open the RoboHelp project.
2) Select File > New > What's This? Help Project.
3) Select an application. This is the name of the executable file (.exe), dynamic link library (.dll), or 

ActiveX control (.ocx).
4) Click Browse. In Files Of Type, select the file format.
5) Navigate to the folder that contains the application. Double-click the application file to select it.
6) Click Next. The name and location of the project file appear.

All What's This? Help Composer projects are titled "Context.txt" and are saved in the same folder as 
the HTML Help project.

7) Click Next. The names of all files containing dialog boxes for the application appear. These files are 
in the same folder as the application (or they are called by the application). The files listed are 
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included in the What's This? Help project. You can remove unwanted files. If you are unsure about 
what files to use, consult your application developer.

8) Click Next. What's This? Help Composer can generate Help topics for default buttons such as OK 
and Cancel.

9) To include these topics, select Yes, Create Default Help Text For This Project.
10) Click Finish.

The application's files are scanned and a database of information is generated. After a few mo-
ments, the new project opens in What's This Help Composer and a summary report appears. You 
can view this report, copy it to the Windows clipboard, and print it.

11) When you finish working with the summary report, click OK.
All the components of the dialog boxes and windows are identified in the Dialog Boxes pane. You 
can start authoring What's This? Help topics.

12) To return to RoboHelp and work on the HTML Help topics, save the What's This? Help project and 
close the program.

Version-control projects may have more options.

Tips:

• To work on the What's This? Help topics, open the Help project in RoboHelp, and then open What's 
This? Help.

• Before you start a What's This? Help project, consult your developer to determine details that 
might affect the application files and the way you author topics.

Import What's This? Help projects

You can import existing What's This? Help projects intended for C and C++ applications into your Micro-
soft HTML Help projects. You can use only one What's This? Help project with an HTML Help project.
1) Open the RoboHelp project.
2) Select File > Import > What's This? Help Project.
3) Navigate to the What's This? Help project file's (.chj) folder. Double-click to import it.

Version-control projects may have more options.

Notes:

• All What's This? Help project files are saved in the project folder.
• To update What's This? Help topics, edit the Context.txt file. This file is in the Project Manager, in 

the Text-Only Topic Files folder (in the Context-Sensitive Help folder). This file cannot be renamed.
• To open your project in What's This? Help Composer, double-click the Context.txt file.
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Open What's This? Help projects

1) Open the project in RoboHelp.
2) Select Project > Open > Pods > Output Setup.
3) Select Edit > What's This? Help Project. The project opens in What's This? Help Composer.

NOTE: Only HTML Help systems that are intended for C or C++ applications are supported by What's This? 
Help Composer.

Remove What's This? Help from a project

1) Open the HTML Help project.
2) Select Project > Open > Pods > Output Setup. The Output Setup pod appears.
3) Open the Context-Sensitive Help folder.
4) Open the Text-Only Topics folder.
5) Select Context.Txt (the What's This? Help file).
6) Click Delete .

Version-control projects may have more options.
NOTE: You can restore a What's This? Help file. The What's This? Help project file (.CHJ) remains in your 
project folder, and you can import it into your project to create a CONTEXT.TXT file. See Importing What's 
This? Help projects into HTML Help projects.

Test What's This? Help with BugHunter

NOTE: BugHunter is for use with Microsoft HTML Help projects only.
1) Before testing, verify that the following requirements are met:

– The application used with the Help topics is available on the authoring system.
– What's This? Help topics exist in the HTML Help project (CHM file).
– The application is programmed to use HTML Help.
– A copy of the map file is available for use in testing.

2) Generate the HTML Help project so all the What's This? Help topics are included in the CHM file. 
Copy the file into the same folder as the application.

3) Select Tools > Tools > Enable BugHunter.
4) Start the application and open a dialog box to test.
5) Click the question mark icon  and click a field or control.

Test HTML Help API

Test map numbers and window-level topics with map IDs in Microsoft HTML Help projects. To run the 
test, you must have access to the application. To recompile the CHM file after using this tool, close the 
program and reopen the project.
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Select A Compiled HTML Help File
Specifies the HTML Help (CHM) file to use.

Command
Test a map number or a topic. HH_DISPLAY_TOPIC requires the relative path and filename in the 
HTML File field.

Dialog (Optional)
Identifies the custom window for topic content. Use only if you have a custom window for 
displaying window-level Help topics.

HTML File
The HTML file to test for with HH_Display_Topic.

Map Number
The map number to test for HH_Help_Context.

Troubleshoot What's This? Help

NOTE: Microsoft HTML Help projects only.

Before you test What's This? Help with BugHunter, right-click in the BugHunter pane and select Options 
> Display Options. Deselect Only Window-Level Help Messages.

Problem Topic does not appear.

Error message No message

Cause Author did not create a text-only topic (for a field or control in a dialog).

Resolution Create a text-only topic for the field or control in the dialog box.
For developer-supplied map files, import the file first, then create 
text-only topics.
Compile the project. Retest using the updated CHM file.

Problem The wrong What's This? Help topic appears in a field or control.

Error message Command: HH_TP_HELP_WM_HELP?HH_TP_HELP_CONTEXT_MENU
Processing: Project_Name.chm
Control ID: 1174
Help ID: 1003
File: Folder_Name/FileName.TXT

Cause Developer incorrectly handled a message that requests What's This? 
Help.
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Maintaining text-only topics (Microsoft HTML Help projects)

When changes are made to the application, update your text-only topics to reflect these changes. (If you 
use What's This? Help Composer, most of these maintenance issues apply.)

Changes in the application affect the following:
• The map files used in your project.
• The content in your text-only topics that explain how to use the application's features.
• The text-only topic files (.TXT) you create for What's This? Help.

Resolution Provide the Map IDs report to the developer.
Text-only topics are indicated by Text-only Popup MapID.
Compile the project. Retest using the updated CHM file.

Problem The wrong topic or no topic appears.

Error message No message
or
Command: HH_TP_HELP_WM_HELP?HH_TP_HELP_CONTEXT_MENU
Processing: Project_Name.chm
Control ID: 1174
Help ID: 1003
File: Folder_Name/FileName.TXT

Cause A map number in the map file is missing its matching topic ID.
or
A topic ID is matched to the wrong topic.

Resolution If the problem is caused by a missing topic ID, correct the map file.
If the developer supplies the map file, update the map file.
For an auto-generated map file: Open the Context-Sensitive Text-Only 
Topics dialog box. Select the map number. Enter the topic ID. Click 
Add/Update.
If the problem is caused by a topic ID matched to the wrong topic, 
remove the text-only topic. Create one for the topic ID.
Compile the project. Retest using the updated CHM file.

Type of Change Action

Obsolete features (dialog boxes, message 
boxes, and windows are removed from the 
application).

Remove the text-only topics from the text-only 
files (.txt).
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Notes:

• If you are creating text-only topics and window-level topics, avoid using the same map file for both.
• Each time you update your context-sensitive Help, test all topics that have been changed or added.

Working with text-only topics

Create text-only topics

When creating text-only topic files for Microsoft HTML Help, you create topics and write content in the 
same dialog box. If using map files from your developer, import them before you begin.
1) Select Project > Open > Pods > Output Setup. The Output Setup pod appears.
2) Open the Context-Sensitive Help folder.
3) Right-click the What's This? Help Files folder. Select Create/Import Text-Only Topic File.
4) In File Name, enter a name for the topic file. If you imported a map file, use its name (Pizza.h and 

Pizza.txt).
5) Click Open.
6) Select a topic ID for the first topic to create:

– When auto-creating a map file In Topic ID, enter the topic ID.
– When importing a map file, select the topic ID from the list.

Sample of Topic ID entries
7) In Topic Text, enter topic content. This text appears in a popup when users request help for the field 

or control:
Sample of Topic Text

Updated and improved features (a dialog box 
is changed to include new controls, some 
fields are removed).

Edit the content of the text-only topics so they 
accurately explain how to use the features or if 
fields were removed from dialog boxes.

New features (for example, new dialog boxes 
are added).

Create new text-only topics.

New map files (for new features). Import the map files into the project before 
creating the text-only topics.

Updated map files (for new or existing 
features).

Update the existing map file by removing the 
obsolete map file and importing the updated 
one.

Type of Change Action



337

WORKING WITH TEXT-ONLY TOPICS
CHAPTER 11 CONTEXT-SENSITIVE HELP

1) Click Add/Update.
Version-control projects may have more options.

Tips:

• Topics or added code are not needed for OK, Cancel, Save, Open, and other buttons associated with 
Windows dialogs.

• HTML Help projects can include multiple .txt files.

Edit text-only topics

1) Select Project > Open > Pods > Output Setup. The Output Setup pod appears.
2) Open the Context-Sensitive Help and What's This? Help Files folders.
3) Double-click the topic file (.TXT).
4) Select the topic from the Topic ID list.
5) Edit the text in Topic Text.
6) Click Add/Update.

Version-control projects may have more options.
TIP: You can edit map numbers in this dialog.

Test text-only topics

Testing text-only topics requires access to the application.
• If you auto-generated map files, give these files to your developer.
• When done testing, compile the Help. Provide your developer with the CHM file.
• Install the latest version of the application, including the latest CHM file.
• If installing the latest application from a network or CD, replace the existing CHM file with the new 

copy when you compile. Copy the CHM file into the folder with the application EXE file.
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• Print a Map IDs report as a checklist for testing dialog boxes. Print the text-only topics file that 
matches topic IDs to topics.

Tips:

• Use BugHunter to test application calls.
• Use the Duplicate Map IDs to resolve problems with repeated map numbers.

Remove text-only topics

You can remove text-only topics in Microsoft HTML Help projects when changes to dialog box controls 
and fields affect context-sensitive Help.
1) Select Project > Open > Pods > Output Setup. The Output Setup pod appears.
2) Open the Context-Sensitive Help and What's This? Help Files folders.
3) Double-click the topic file (.txt).
4) Select the topic to remove.
5) Click Delete.

Version-control projects may have more options.

Tips:

• If your developer provides updated map files, replace them before removing the topic.
• Removing text-only topics leaves the topic ID and map number in the map file. You can remove 

unused Map IDs if you no longer need them.

Remove text-only topic files

Remove text-only topic files (.txt) from Microsoft HTML Help projects when you no longer need them.
1) Select Project > Open > Pods > Output Setup. The Output Setup pod appears.
2) Open the Context-Sensitive Help and What's This? Help Files folders.
3) Select the topic file (.txt).
4) Click Delete.
5) Open the Map Files folder.
6) Select the map file (.H) associated with the removed .txt file.
7) Click Delete. The topic file and its map file are deleted.

Version-control projects may have more options.
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Testing context-sensitive Help

Test with the Context-Sensitive Help tool

The Context-Sensitive Help tool simulates Help calls from an application.
1) In the Toolbox pod, double-click CSH Test.
2) Do one of the following:

– To test server-based Help, select Online.
– To test local Help, select Offline.

3) Do one of the following:
– For server-based Help, enter the server location and project name by using the following 

syntax for FlashHelp Pro:
http://RoboHelp 
Server/robohelp/server?project=MyProject&area=area-name&type=flashhe
lp 

For WebHelp Pro, use the following syntax:
http://RoboHelp 
Server/robohelp/server?project=MyProject&area=area-name&ver=1

– For local Help, click the Browse button, and select a Help file.

4) (Optional) Enter a window name.
5) Click the map file icon  and select a map file.
6) Click the triangle and select a map number.
7) Click Show Help.

If Help is working correctly, the topic associated with the map number appears.

Test with BugHunter for HTML Help

NOTE: Microsoft HTML Help projects only.

BugHunter is a troubleshooting tool to test context-sensitive Help topics and diagnose problems. During 
testing, BugHunter captures and displays calls that the application makes.
NOTE: Before you start using BugHunter, you must launch Html Help Workshop once. To launch Html Help 
Workshop, double-click the hhw.exe file in the Html Help Workshop install folder.

Use BugHunter for the following tasks:
• Test Help buttons, F1 Help, or What's This? Help.
• Track the causes of errors.
• Copy data to the clipboard or annotate it and save it in a text file.
• Discover why the wrong topic appears.
• Determine if a particular map number is used.
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• Determine if a window-level Help topic has a map ID assigned.

Start and close BugHunter

1) Select Project > Open > Pods > Tools.
2) Do one of the following:

– To start capturing data, choose Tools > Enable BugHunter.
The output dialog box displays capture data while the program is enabled. When you activate 
Help in an application's dialog box, messages from BugHunter appear in the output window. 
Right-click in the pane to copy, annotate, or save the data.

– To clear the pane, right-click inside it and select Clear All. Data remains in the pane until you 
clear it.

– To stop capturing data, choose Tools > Enable BugHunter.

Interpret BugHunter data

BugHunter data resembles this example:
C:\APPLICATION FOLDER\HELP_FILE.CHM, Custom Folder\Help_Topic_Name.htm, 
HH_HELP_CONTEXT, 10253, Topic launched 

Multiple lines of data resemble this example:
Project: C:\APP FOLDER\HELP_FILE.CHM 
File: Custom Folder\Help _Topic_Name.htm 
Command: HH_HELP_CONTEXT 
Map Number: 10253 
Result: Topic launched

Interpret the data as follows:

Project
Application location. Filename of the HTML Help that contains the called Help topic.

File
Folder and subfolders where the .htm topic exists.

Command
The command name sent to HTML Help.

10253
Map number.

Result
Activity summary. “Topic launched” indicates that the topic map ID matches the application code.
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Customize the BugHunter pane

1) Right-click inside the BugHunter pane and click Options.

View map numbers in hex format

1) Select File > Options. Click the BugHunter tab.
2) In Display options, select Map Numbers In Hex.

Test in the application

To test context-sensitive Help in the application, follow these guidelines:
• If you auto-generated map IDs in RoboHelp, export the map files and provide them to the devel-

oper. Update the application to use the map IDs, if it doesn’t already.
• Generate the project. Provide the output files to the developer.
• If you designed a custom window for displaying window-level topics, inform the developer. The 

application requires coding to display topics this way.
• Install the latest version of the application, or access the Web application. If you install the latest 

build of the application from a network drive or CD, you can replace the output file with the new 
copy each time you generate. Put the output files in the same folder as the application EXE file.

• Print the Map IDs report. Use it as a checklist for testing dialog boxes.
• In the application, click Help or press F1 to verify that the correct Help topic opens in each dialog 

box.
• Update any map IDs that did not work and check the following:
• Ensure that the correct map ID is assigned.
• Ensure that the topic has a window assigned to it.
• Generate the project to retest edited topics.

Context-sensitive Help terms

ALI file
A project file that is automatically created in the project folder when you add, update, or remove 
map IDs. It shows the topic ID/topic match (for example: ID_ABCForm=ABC.htm).

CHM file
The file created when an author compiles a Microsoft HTML Help project. All the files in the project, 
including context-sensitive Help topics and map files, are compressed and saved in this file.

Header file
A developer's term used to see map files. Developers create header files, which are text files 
containing a list of topic IDs and their corresponding map numbers. Header files use the .h, .hh, or 
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.hm extension. When a developer provides the author with header files, the author needs to import 
the files into the project.

HHCTRL.OCX
(Microsoft HTML Help projects) The Microsoft ActiveX control that contains the HtmlHelp() appli-
cation programming interfaces. Developers ensure that HHCTRL.OCX is invoked when users 
request Help.

HH_HELP_CONTEXT
(Microsoft HTML Help projects) Using this HTML Help API command, calls can be made to the appli-
cation using the map number.

HTML Help API
(Microsoft HTML Help projects) The application programming interface for Microsoft HTML Help 
that allows a Help window from an application to display. The HTML Help API contains commands 
for developers to specify the type, style, and position of Help windows.

HTML Help translator
(Microsoft HTML Help projects) A mechanism in Microsoft HTML Help that looks up context-sensi-
tive Help topics when users request help in applications.

HTML Help viewer
(Microsoft HTML Help projects) The default window used to display compiled Microsoft HTML Help 
(CHM files). Authors can also design a separate custom window to display context-sensitive Help 
topics.

Prefix
Characters affixed to the beginning of topic IDs (for example, in the topic ID, Idd_Mytopicid, "IDD_" 
is the prefix). Development tools that generate map files use a default prefix. When you generate 
map files in RoboHelp, you can specify a prefix. Prefixes are not mandatory, but they are useful for 
organizing topic IDs.

RH ShowHelp
RoboHelp API function used to call context-sensitive Help topics. You can call this function for 
WebHelp Pro, WebHelp, and HTML Help.

Support files
(WebHelp and WebHelp Pro projects) Adobe provides support files that allow developers to import 
code and enter variables. Each supported language has a corresponding support file with functions 
to use for calling WebHelp Pro or WebHelp projects and displaying individual topics for 
context-sensitive Help.
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Create Help for iOS and Android apps

RoboHelp provides an API that you can leverage to integrate Multiscreen or Responsive HTML5 output 
with iOS and Android apps. The API ships with the following:
• Objective C (iOS) and Java (Android) source code for the API functions that you can include in your 

app with or without customization
• Sample apps demonstrating the usage of the exposed API

iOS versions 5 and later are supported. Android 2.2 (Froyo) and higher versions are supported.

Capabilities delivered

You can leverage the following capabilities using the mobile Help API:
• Embed the Help into the app
• Open the Help in the in-app browser or the default browser for the mobile operating system
• Implement context-sensitive Help from mobile app screens
• Host the Help on a server and link to it from within the mobile app NOTE: While linking to Help 

hosted on an external server, ensure that your implementation conforms to Apple App Store guide-
lines.

Broad steps to implement mobile Help

1) Prepare your RoboHelp project for publication.
2) Prepare context-sensitive Help and create relevant mappings.
3) Generate Multiscreen or Responsive HTML5 output.
4) Bundle the Multiscreen or Responsive HTML5 output with the app.
5) Include the source files for the mobile Help API with the app.
6) Call the API functions to implement the required Help calls in the app.

Available API functions

iOS

• -(id) initForHelpPath: (NSString*)path;

• -(void) setHelpPath: (NSString*)path;

• -(void) setShowHelpInEmbeddedBrowser: (BOOL)bInEmbedded;

• -(void) showFullScreenHelp: 
(UIViewController*)presentingViewController;

• -(void) showFullScreenHelp: 
(UIViewController*)presentingViewController 
ForMapNo:(NSInteger)ctxId;
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• -(void) showFullScreenHelp: 
(UIViewController)presentingViewController ForMapId:(NSString)ctxId;

• -(void) cleanUpResources;

• -(void) setTitle: (NSString*)title;

• -(void) setBackButtonText: (NSString*)text;

• -(void) setSupportsIPhoneOrientation: 
(UIInterfaceOrientation)orientation supports:(BOOL)supports;

• -(void) setSupportsIPadOrientation: 
(UIInterfaceOrientation)orientation supports:(BOOL)supports;

TIP: To understand how to use these API functions, refer to the comments in the code.

Android

The following code sample illustrates the available Java methods:
• RoboHelpAPI(String url, View v)

• void setHelpPath(String url)

• void setShowHelpInEmbeddedBrowser(boolean bEmbedded)

• void showFullScreenHelp()

• void showFullScreenHelpForMapNo(int mapNo)

• void showFullScreenHelpForMapId(String mapId)

• void setTitle(String title)

• void setBackButtonText(String text)

• void setSupportsOrientation(boolean supports)

TIP: To understand how to use these API functions, refer to the comments in the code.

Sample app

RoboHelp ships with sample apps demonstrating the capabilities of the mobile Help API.
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iOS sample app demonstrating mobile Help API capabilities
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Android sample app demonstrating mobile Help API capabilities

Context-sensitive help for filtered dynamic content

When you use dynamic content filters to create help output, you can create context-sensitive help that 
will navigate the user directly to the filtered content. For example, if your content is region-based and 
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you can display contextual help filtered for a specific region. For details on how to create and use 
dynamic content filters, see Generate dynamic content output.
NOTE: Dynamic content filters are supported for Responsive HTML5 and Mobile App outputs.

To create a context-sensitive help link to a filter, create a link with the following syntax:
<help topic url>?filter=<tag1>:<value1>,<tag2>:<value2>...

For example, to create a direct link to the following filter:
Dynamic filter

Create the following link:
<help topic url>?filter=Region:US,Audience:Print

Reference

BugHunter tab of the Options dialog box (HTML Help)

Display options

Window-Level Help Messages captures messages only for window-level Help.
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TIP: Clear this option to test What's This? Help.

Map Numbers In Hex
Displays map numbers in hexadecimal notation rather than decimal format.

Each Message On A Single Line
Displays output on a single line. Multiple lines organize the data by the type of information.

Example (single line)

C:\APPLICATION FOLDER\HELP_FILE.CHM, Custom Folder\Help_Topic_Name.htm, 
HH_HELP_CONTEXT, 10253, Topic launched

Example (multiple lines)

Project: C:\APPLICATION FOLDER\HELP_FILE.CHM 
File: Custom Folder\Help_Topic_Name.htm 
Command: HH_HELP_CONTEXT 
Map Number: 10253 
Result: Topic launched 

Color options

Select the color for displaying Help, error messages, prompts, annotations, and the window background 
color.
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Generating output

Single sourcing basics and more

About single-source layouts

Single-source layouts act as templates for different versions of the project output. RoboHelp provides 
single-source layouts for each output type.

Typically, when generating a different version of the project (such as an online tutorial), you use different 
settings for the output. You can save these settings in single-source layouts. After creating the layout and 
defining output settings, generate, view, or publish output whenever needed, singly or in batches.

Layouts save settings and preferences for each version of the project, helping to ensure consistency. 
Conditional tags and conditional build expressions let you create different output for different versions 
of a project.

RELATED LINKS:
Work with layout types

Layout types in RoboHelp

RoboHelp supports the following layout types:
• Responsive HTML5 layout
• eBook layout
• WebHelp layout
• WebHelp Pro and FlashHelp Pro layouts
• Microsoft HTML Help layout
• JavaHelp layout
• Oracle Help layout
• XML layout
• Adobe AIR layout

Specify the primary layout

A primary layout is the default layout that you set for the work environment. It lets you generate output 
without specifying additional options. The primary layout contains settings for the output type with 
which it is associated. It controls project windows, the table of contents properties, and other project 
entities.
1) In the Single Source Layouts pod, right-click a layout.
2) Select Set As Primary Layout.

The primary layout is labeled in the Single Source Layouts pod.
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NOTE: If you create new windows, the window type is based on the default layout. For more information, 
see this article.

Create and edit single-source layouts

Create or duplicate single-source layouts

A duplicate layout retains the settings of the original.
1) In the Single Source Layouts pod, do one of the following:

– To create a layout, click the Create Layout button .
– To duplicate a layout, click the Duplicate Layout button .

2) In the Layout Name box, type a name.
3) For a new layout, select an output type from the pop-up menu.

NOTE: You cannot change the output type of a duplicated layout.
4) Click OK.
5) For a new layout, set options in the Properties dialog box that appears. Click Save.

Edit single-source layouts

1) In the Single Source Layouts pod, right-click the layout.
2) Select Properties.
3) Set options. Click Save.

NOTE: You cannot change the Output Type of a layout. Create a layout instead.

Rename a single-source layout

1) In the Single Source Layouts pod, right-click the layout.
2) Select Rename.
3) Enter the name.

RELATED LINKS:
Work with layout types

Generate, view, and publish output

Remove single-source layouts

Removing a layout does not affect other parts of a project.
1) In the Single Source Layouts pod, right-click the single-source layout. It cannot be the primary 

layout.
2) Select Delete.

http://notcolin.wordpress.com/2009/10/29/a-default-single-source-layout-whats-the-point/
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About excluding unreferenced topics from output

A project meant for single sourcing can include topics that are not relevant in all types of output gener-
ated from the project. For example, a project with multiple TOCs includes topics that are not relevant to 
the output that you generate based on a single TOC. In such a case, excluding unreferenced topics from 
the output ensures that users find only the relevant topics in navigation and search.

RoboHelp considers a topic unreferenced if the topic is not referenced by the following project compo-
nents:
• TOC
• Index
• Browse sequences
• Default topic
• CSH map IDs
• See Also keywords
• Related Topics keywords

The Exclude Unreferenced Topics From Output option is available in Adobe AIR, WebHelp, WebHelp Pro, 
FlashHelp, FlashHelp Pro, Microsoft HTML Help, XML Output, Oracle Help, and JavaHelp layouts.

RELATED LINKS:
Output generation basics

Generate dynamic content output

The dynamic content feature in RoboHelp allows you to create output that your users can easily filter 
based on parameters that you define using Conditional Build tags. For example, you can create a filter 
that allows your users to filter the output by region (US, UK, or Canada) and by audience (end-user, 
online, and print). Dynamic content also allows your writers to easily single-source content with the help 
of Conditional Build tags.

With this feature a writer creates Conditional Build tags depending on the filter criteria that you want to 
provide to your users. For example, you can create conditional build tags: US, UK, and Canada for region 
and End-user, Online, and Print for audience.

When you generate the output using the filter, the filter tab is displayed that allows users to filter the 
contents based on the criteria (tag/expression) selected in the filter in the output SSL.

Also, a user can then use the search functionality to find content within the filtered results.
NOTE: Dynamic content filters can be applied to Responsive HTML5 and Mobile outputs.

Tag content

To create a dynamic content filter in your output, you apply Conditional Build tags to the required parts 
of your project on which you want your users to filter.

In a RoboHelp project, you can apply conditional build tags to:
• Topics
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NOTE: If you apply a tag on a topic, all the contents of the topic and any TOC, Index entry pointing 
to it will inherit the tag in the output.

• Content within topics such a text and images
It is recommended that you do not apply conditional build tags on text at a level below a paragraph. 
While the filter functionality will still work at any level of granularly, setting tags below the para-
graph level of text can cause behavior such as incomplete sentences.

• Items in a TOC
• Items in an Index

NOTE: You cannot apply conditional build tags to the glossary.

You can apply multiple conditional build tags to the same section of your content. For example, you can 
apply the US and Canada tags to a topic that you want to target at your North American customers. You 
can then tag an alternate topic to target your UK customers. In the output, a user then has the option to 
filter content based on the region. You can also use an expression such as US AND Canada to create a 
filter criteria titled North America.

RoboHelp does not restrict the application of Conditional build tags. This implies that you can apply tags 
to content in any combination. For this reason, when you apply tags, you need to keep in mind how the 
output will display based on the output filtering mechanism.

Take the example of two tags US and Canada where you apply the US tag to a table and Canada tag to 
the content in the table. If you mark the US tag to show and the Canada tag to hide in the output, the 
content is displayed. This is because the content show property has overridden the table hide property. 
However, if you mark a topic as show and a paragraph in the topic as hide, the paragraph does not 
display.

For an example on how filtering works, see Use a dynamic content filter in the output.

Untagged content

When you use dynamic filters in a RoboHelp project, you are not required to tag all your content. Any 
content that is untagged is unconditional. This implies that untagged content will display to the user 
regardless of the filter.

Create a dynamic content filter

You can create one dynamic filter for each layout.
1) In the Output tab, click a layout.
2) In the layout settings dialog, check Use Dynamic Content Filter in the output and click Customize.

The Dynamic Content Filter dialog is displayed.
3) When you create a filter, you can define groups that include the filter criteria (tags and expres-

sions).
For example, you can create a Region group that includes the US, Canada, and UK conditional build 
tags.
You can also use expressions as criteria in a filter. For example, you can create a filter US AND Can-
ada and then provide your users with a North America criteria option in the output.
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NOTE: You can add tags and expressions to your filter without including them in any group. This 
implies that you can create a filter that does not include any groups. Or you can create a filter that 
contains one or more groups and tags or expressions that are not included in any of the groups.
IMPORTANT: You cannot create nested groups. This implies that a group cannot contain another 
group.

4) To add a tag or expression to a group, click the Add Criteria and select the tags and expressions from 
the Tags and Expressions dialog.
NOTE: You can add one instance of a tag or expression in a dynamic filter. For this reason, if you add 
a tag or expression to the filter, notice the tag or expression does not display in the Tags and Expres-
sions dialog.
When you add a tag or expression to a filter, the display name for the tag or expression displayed 
in the filter is the name that you give when you create it. However, you can change the display name 
in the filter for output display purposes. Also, the display name that you specify in the filter does not 
change the name of the tag or expression in the project.
NOTE: You can also include special characters in the display name of the tag or expression, except 
these characters: colon (:), semi-colon (;), comma (,), percent (%), ampersand (&), hash (#), and 
equals (=).

5) You can choose to filter content by default. This implies that when the output displays, the content 
is filtered to a predefined criteria. To set the default tag or expression in the filter, right-click the 
tag or expression and choose Select Default.

6) To change the display name of tag or expression in the filter, right-click the tag or expression and 
choose Rename.
NOTE: When you rename a tag, the status message that displays at the bottom of the Edit Filter 
dialog displays the name of the tag and not the display name.
NOTE: Group names within a filter must be unique. Tag or expression display names within a group 
must be unique. The check for unique display names is case-insensitive. For example, you cannot 
create two display names End-User and END-USER within the same group.

7) To allow your users to select multiple filter criteria in one group in the output, check Allow multiple 
selection in output.

8) Use the navigation arrows to move the groups, tags, and expressions within a filter.
For example, to move a tag out of a group, click the left arrow. This moves the tag to the same level 
as the containing group and just above the group. Use the right arrow to move a tag that is outside 
any group into the next group. You can also move the tags up and down in the group.
NOTE: You can also move the items by drag-and-drop.

9) Click Save.
10) In the layout settings dialog, click Save and Generate.

Use a dynamic content filter in the output

This section uses an example to describe how to use the dynamic content filter in the output and what 
to expect when you apply tags to the content and use the tags in the filter.

After you assign a dynamic content filter to a layout, you can generate the output for the layout.
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The output now contains a filter icon. Click the filter icon to display the dynamic content filter assigned 
to the current layout.
IMPORTANT: If a tag is not assigned to any content in the output, the tag is not displayed in the filter. So, 
if all the tags within a group are not displayed in the filter, the group is not displayed. Also, if a tag is not 
used in the filter (as tag or as part of an expression), then this tag is removed from the content it is applied 
on in the project.

By default, all the groups and criteria in the filter are unselected. This implies that all content is currently 
displayed (unconditionally) since no filter criteria is currently applied. However, if you set a default while 
creating the filter, the default group displays selected.

To filter the contents, you check and un-check the groups or criteria in the filter.

The following sections detail two scenarios to describe how the dynamic content filtering mechanism 
works:

Select one criteria (tag or expression) in a group

In Sales Builder filter, if you check US in the Region group:
• All content marked with the US tag displays.
• All content marked with a combination of the US tag and any other tag displays.

Content marked with the US and UK tag displays. But a topic marked with the UK tag is hidden. Also, 
content marked with the UK and Canada tags will be hidden.

• All content marked with tags in the Audience group are not displayed unless the content is 
combined with the US tag.
Content marked with the US and PDF tag will display. But content marked with the PDF tag is hid-
den. Also, content marked with the UK and Print tags is hidden.

• All untagged content displays.

Select one criteria in one group and another criteria in a second group

In Sales Builder filter, if you check US in the Region group and Print in the Audience group:

Test the dynamic content filter

After you create and apply a dynamic content filter to the output, you can use Show Tagged Output 
option to test your filters. This option generates the output with the tags displayed in the contents at the 
applied locations. You can then select the filter criteria and test how your filter works.
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Sample output with the enduser tag displayed

To generate the tagged output:
1) To open the Outputs (SSL) pod, in the Pods drop-down, choose Outputs (SSL).

The Pods drop-down is available in the Project, Edit, and Review ribbons.
2) In the Outputs (SSL) pod, right-click the Responsive / Mobile output and choose Show Tagged 

Output.

The tagged output is generated.

Generate dynamic user-centric content (DUCC)

Generate Adobe® AIR® and WebHelp output as integrated Help systems with different content catego-
ries. Users select the content category that's relevant for them and navigate and search within the 
content category. Each content category has its own TOC, index, and glossary. Creating dynamic 
user-centric content is useful if end users have to quickly toggle between the content for different roles, 
products, or variants. For example, queries that a call center agent handles sometimes pertain to 
different areas of system administration (for example, user administration, site administration, and 
content administration). The ability to view and search the system administration content as a set of 
modular content categories accessible from the same interface works as a time-saver where you handle 
queries in real time.

For information about how to create content categories, see Configure the Adobe AIR layout and 
Generate WebHelp output.
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A. Content category definition in SSL B.Content category selection in the output

Generate native (ASPX) or HTML output for Microsoft SharePoint

Microsoft SharePoint is a popular web platform for small to large organizations. It is designed as a 
centralized replacement for multiple web applications and supports various combinations of enterprise 
website requirements. It is typically associated with web content management and document manage-
ment systems.

RELATED LINKS:
PDF review

Manage comments and changes

Publish native (ASPX) Multiscreen output to Microsoft SharePoint

Using the Multiscreen HTML5 SSL, you can publish native (ASPX) output directly to a SharePoint 2010 or 
above document library or a SharePoint 2007 folder. When you view the published output in a browser, 
the topics appear in the SharePoint chrome as a single continuous HTML page.

For step-by-step instructions, see Generate Multiscreen HTML5 output.

Notes:
• (Only for Internet Explorer) If your content has an iFrame containing a PDF document, readers may 

not be able to scroll down to the bottom of the page. To prevent this issue, ensure that the Browse 
File Handling property in SharePoint is set to Permissive.

• If you're unable to republish content to SharePoint with Site Member permission, ensure that you 
have the Add and Customize Pages SharePoint permission.
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• Ensure that the topics/images you’re publishing to SharePoint don’t have double dots (..) in their 
names. Otherwise, the publish operation will fail with a Bad Request error.

Publish HTML output to Microsoft SharePoint

WebHelp, FlashHelp, and Browser based Help (Adobe AIR SSL)

Publish HTML output to a SharePoint site using a Universal Naming Convention (UNC) path. See Generate 
WebHelp output, and Configure a server to host browser-based Help.

Work with layout types

Responsive HTML5 layout

Most web browsers support native optimizations for displaying content on small-screen devices, such as 
smartphones and tablets. However, these generic optimizations are often insufficient for the wide 
variety of devices that proliferate today.

The Responsive HTML5 SSLs helps you provide a reading experience that is optimized for specific types 
of devices. You can add and configure different screen profiles for different sets of devices and generate 
HTML5 output for these screen profiles. When users visit the landing page for the HTML5 output on their 
devices, they are automatically redirected to content optimized for their device.

HTML5 output optimized for different devices

Screen layouts help you improve the reading experience even further by enabling you to choose and 
customize the way in which the contents and output elements, such as navigation links, are to be 
displayed on a device.
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When you create a project, RoboHelp adds Responsive HTML5 layouts to the project. The default 
Responsive HTML5 SSLs contains screen profiles for popular devices, such as iPad, iPhone, Kindle Fire, 
and Samsung Galaxy Tab. These screen profiles are mapped to predefined screen layouts.

RELATED LINKS:
Generate Multiscreen HTML5 output

Screen profiles

Screen layouts

Media rules and attributes in styles

Media queries

Customizable HTML5 Indigo layout

Present a visually rich content to your audience by using the chrome-less HTML5 Indigo layout. The 
Indigo layout is built in accordance with the latest web design trends and combine a striking look with 
unmatched functionality. It is a 508 compliant layout designed to create content for users with special 
needs and also offer superior search and intuitive navigation experience.

Access features such as show or hide widgets for glossary and TOC, mark topics as favorites for ease of 
access. The show or hide vertical menu on the right sidebar presents a user-friendly interface and 
advanced navigation for index, glossary and filter.

IMPORTANT: Starting from Update 2 of RoboHelp (2017 release), the responsive HTML5 Ocean layout is no 
longer available. You can still download and use the Ocean layout from the RoboHelp screen profiles and 
layouts page.

Default screen layouts are available in the Gallery folder of your RoboHelp installation. To access these 
layouts:
1) In the Output Setup pod, right-click Screen Layouts and select New Responsive Layout.
2) Select the desired layout from the available list in the gallery.
3) (Optional) You can specify a new name for the layout.

https://helpx.adobe.com/robohelp/robohelp-screen-profiles-layouts.html
https://helpx.adobe.com/robohelp/robohelp-screen-profiles-layouts.html
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Supported browsers

The primary target platforms for the output generated using the Responsive HTML5 SSL are Android OS 
and Apple iOS.

HTML5 output is supported in the following browsers:

NOTE: In addition to HTTP servers, you can publish HTML5 output to HTTPS servers.

Online/offline behavior

HTML5 output can be accessed both online and offline. End users can access the output by copying it to 
the device local memory and view it offline in a browser.

Configuring Responsive HTML5 prerequisites

Before you begin configuring the Responsive HTML5 SSL, consider the following:

Default screen profile
Set a default screen profile in the HTML5 SSL. The default screen profile is used if a device dimen-
sion and browser agent combination does not match any screen profile.

Device image and content window
Select a device image in screen profile properties. A device image helps in visualizing the 
look-and-feel of the output when you preview contents in a selected screen profile. For example, 
if you expect users to view the HTML5 output of a project on iPhones, adding the device image of 
an iPhone will make the preview experience closer to the real experience of viewing the output on 
an iPhone.

Screen resolution
Specify a range of screen resolution in screen profile properties to create a screen profile for 
devices with similar screen resolutions. Screen resolution is different from screen size; two devices 
can have similar screen size but a significant difference in screen resolution.

Browser agent (user agent)
You can create different screen profiles for devices with the same range of screen resolution but 
different browsers to achieve browser-specific appearances.

Platform Supported browser

Android OS Default installed Webkit-based browser (Chrome Lite)

iOS Apple Safari

Windows Desktop OS Firefox 4+, Chrome 9+, Internet Explorer 9

Mac OS Apple Safari
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When you specify a browser in screen profile properties, RoboHelp adds the browser agent ID to 
the output generated for that screen profile. When users visit the landing page for the HTML5 
output on their devices, the browser checks for the browser agent ID and other screen settings and 
loads the content optimized for that browser and device.

The predefined list of browsers takes into account the popular devices of today. If you want to add 
a browser to the list, specify a unique string from its user agent string. See a list of user agent 
strings.

HTML5 output generation workflows

Use the following workflows to generate HTML5 output:

New project with default screen profiles
Configure the general properties of the Responsive HTML5 SSL and set the search and optimization 
properties and generate output.

New project with custom screen profiles
In this case, your project must include the custom screen profiles before you start configuring the 
Responsive HTML5 SSLs. See for information on how to add a new screen profile to a project. Once 
the custom screen profiles are available in the project, add the screen profile to the Responsive 
HTML5 SSLs, configure other properties, and generate output.

Upgraded project
When you upgrade a project, RoboHelp adds screen profiles but does not add any new SSL or 
screen layout. After upgrading a project, add screen layouts from the Gallery. Add a new SSL of the 
Responsive HTML5 type, configure the Responsive HTML5 SSLs as required, and generate output.

Use this workflow for publishing existing WebHelp projects with a new look-and-feel. Responsive 
HTML5 outputs are HTML5-compatible; you can create frameless layouts and use high-quality 
(MP4) videos.

Recommendations for authoring HTML5 output

• Avoid using framesets.
• Use MP4 videos. See Add multimedia.

Multiscreen layout

Most web browsers support native optimizations for displaying content on small-screen devices, such as 
smartphones and tablets. However, these generic optimizations are often insufficient for the wide 
variety of devices that proliferate today.

The Multiscreen HTML5 SSLs helps you provide a reading experience that is optimized for specific types 
of devices. You can add and configure different screen profiles for different sets of devices and generate 
HTML5 output for these screen profiles. When users visit the landing page for the HTML5 output on their 
devices, they are automatically redirected to content optimized for their device.

http://www.useragentstring.com/pages/useragentstring.php
http://www.useragentstring.com/pages/useragentstring.php
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HTML5 output optimized for different devices

Screen layouts help you improve the reading experience even further by enabling you to choose and 
customize the way in which the contents and output elements, such as navigation links, are to be 
displayed on a device.

When you create a project, RoboHelp adds Multiscreen HTML5 layouts to the project. The default 
Multiscreen HTML5 SSLs contains screen profiles for popular devices, such as iPad, iPhone, Kindle Fire, 
and Samsung Galaxy Tab. These screen profiles are mapped to predefined screen layouts.

RELATED LINKS:
Generate Multiscreen HTML5 output

Screen profiles

Screen layouts

Media rules and attributes in styles

Media queries

Supported browsers

The primary target platforms for the output generated using the Multiscreen HTML5 SSL are Android OS 
and Apple iOS.

HTML5 output is supported in the following browsers:

Platform Supported browser

Android OS Default installed Webkit-based browser (Chrome Lite)

iOS Apple Safari

Windows Desktop OS Firefox 4+, Chrome 9+, Internet Explorer 9

Mac OS Apple Safari
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NOTE: In addition to HTTP servers, you can publish HTML5 output to HTTPS servers.

Online/offline behavior

HTML5 output can be accessed both online and offline. End users can access the output by copying it to 
the device local memory and view it offline in a browser.

Configuring Multiscreen HTML5 prerequisites

Before you begin configuring the Multiscreen HTML5 SSL, consider the following:

Default screen profile
Set a default screen profile in the HTML5 SSL. The default screen profile is used if a device dimen-
sion and browser agent combination does not match any screen profile.

Device image and content window
Select a device image in screen profile properties. A device image helps in visualizing the 
look-and-feel of the output when you preview contents in a selected screen profile. For example, 
if you expect users to view the HTML5 output of a project on iPhones, adding the device image of 
an iPhone will make the preview experience closer to the real experience of viewing the output on 
an iPhone.

Screen resolution
Specify a range of screen resolution in screen profile properties to create a screen profile for 
devices with similar screen resolutions. Screen resolution is different from screen size; two devices 
can have similar screen size but a significant difference in screen resolution.

Browser agent (user agent)
You can create different screen profiles for devices with the same range of screen resolution but 
different browsers to achieve browser-specific appearances.

When you specify a browser in screen profile properties, RoboHelp adds the browser agent ID to 
the output generated for that screen profile. When users visit the landing page for the HTML5 
output on their devices, the browser checks for the browser agent ID and other screen settings and 
loads the content optimized for that browser and device.

The predefined list of browsers takes into account the popular devices of today. If you want to add 
a browser to the list, specify a unique string from its user agent string. See a list of user agent 
strings.

HTML5 output generation workflows

Use the following workflows to generate HTML5 output:

New project with default screen profiles
Configure the general properties of the Multiscreen HTML5 SSL and set the search and optimization 
properties and generate output.

http://www.useragentstring.com/pages/useragentstring.php
http://www.useragentstring.com/pages/useragentstring.php
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New project with custom screen profiles
In this case, your project must include the custom screen profiles before you start configuring the 
Multiscreen HTML5 SSLs. See for information on how to add a new screen profile to a project. Once 
the custom screen profiles are available in the project, add the screen profile to the Multiscreen 
HTML5 SSLs, configure other properties, and generate output.

Upgraded project
When you upgrade a project, RoboHelp adds screen profiles but does not add any new SSL or 
screen layout. After upgrading a project, add screen layouts from the Gallery. Add a new SSL of the 
Multiscreen HTML5 type, configure the Multiscreen HTML5 SSLs as required, and generate output.

Use this workflow for publishing existing WebHelp projects with a new look-and-feel. Multiscreen 
HTML5 outputs are HTML5-compatible; you can create frameless layouts and use high-quality 
(MP4) videos.

Recommendations for authoring HTML5 output

• Avoid using framesets.
• Use MP4 videos. See Add multimedia.

eBook layout

The eBook layout helps you generate output in EPUB 3 and Kindle Book (MOBI) formats.

RoboHelp creates a single file containing the XHTML-based content. The exported file includes the 
thumbnail image that you specify for the cover page of the document. This thumbnail is used to depict 
the book in the library view of eBook readers.

RELATED LINKS:
Generate EPUB and Kindle Book output

WebHelp layout

About WebHelp

WebHelp is an uncompiled output type that ensures that users can view web-based or desktop applica-
tion Help in any browser and platform. It supports standard Help features and provides customizing 
capabilities.

You can author content in another HTML editor, such as Adobe Dreamweaver, and still take advantage 
of the WebHelp navigational and organizational Help features.

For older browsers that don’t support DHTML (used to display the navigation pane), WebHelp displays 
the navigation pane using another supported format.
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Differences between WebHelp and Microsoft HTML Help

Mac OS limitations for WebHelp

• Mac OS filenames have a 32-character limit.
• Output is displayed as HTML lists instead of DHTML.
• BMP image files don’t appear properly.

Add or remove search highlights in WebHelp

In a WebHelp system, search results are highlighted by default in the displayed topics. You can set the 
highlight color according to your preferences.
NOTE: WebHelp, WebHelp Pro, FlashHelp, and FlashHelp Pro projects use the same procedure to enable 
Search highlight.
1) Double-click the WebHelp layout.
2) Click Navigation.
3) Select or deselect Enable Highlight Search Result.
4) When search result highlighting is enabled, click the color picker box and select a highlight color of 

your choice from the pop-up menu.

Creating Section 508-compliant WebHelp

Section 508-compliant output facilitates Help access for users with visual, hearing, or mobility impair-
ments.

Text-to-speech utilities read the contents of the active window, available options, or text you type. These 
utilities and screen review aids translate onscreen text to speech or to a dynamic, refreshable, Braille 
display. This technology can provide keyboard assistance or shortcuts, captions for speech and sound, 
and visual warnings such as flashing toolbars.

Consider the following when you create Section 508-compliant WebHelp:
• WebHelp systems generated with the Section 508 option open in all supported browsers. However, 

view output with Internet Explorer to ensure compliance.
• For master projects generated using pure HTML or Section 508-compliant WebHelp, the subproj-

ects are available only from the TOC if you merge WebHelp systems. They are not available from 

WebHelp Microsoft HTML Help

Supported by a web browser Relies on Microsoft HTML Help engine for 
support

Uncompiled set of output files Compiled and compressed (CHM file)

Runs on any platform Requires 32-bit Windows platforms

Ideally suited for server-based distribution Workarounds required for server-based 
distribution



366

WORK WITH LAYOUT TYPES
CHAPTER 12 GENERATING OUTPUT

the index or full-text search. Subprojects appear as a book in the TOC. When users click the 
subproject TOC book, the subproject opens in a new browser window.

WebHelp features that support Section 508 compliance

• A Section 508 Compliant option that provides alternative text for images, dynamic elements, 
frames, forms, and so on. Visually impaired users using assistive software can hear where they are 
in the output and what they are selecting.

• Alternative text is provided for images of TOC books, pages, and the plus/minus icons, 
TOC/Search/Index tabs or panes, navigation buttons, and buttons from design-time controls.

• Other elements with alternative text include expanding and drop-down text, triggers and targets, 
and pop-up menus.

• Navigation frames that assistive software can read.
• Generation of HTML tables so that assistive software can identify row and column headers.
• Online forms that assistive software can read.
• Output that more than one mode of operation and information retrieval can use. For example, 

mobility-impaired users can use the keyboard or mouse. No features require auditory, visual, or 
mobility ability alone.

Guidelines to ensure Section 508 compliance in Help systems

• WebHelp is compliant for framesets and navigation. Make sure that other elements in topics are 
compliant.

• If the Help system contains form buttons or multimedia elements, such as images and audio, 
provide visual equivalents, such as screen tips so that assistive software can read from the screen.

• Construct information with multiple methods of access to accommodate disabilities. Offer informa-
tion in color in an alternative way that doesn’t use color.

• Use basic external style sheets so that documents are readable if the style sheet is unavailable.
• If a web page uses applets, include a link to the location where users can download the appropriate 

reader.
• Document keyboard shortcuts and other methods of accessibility.
• Do not use HTML Help controls.

Generating, Viewing and Publishing WebHelp Output

• To generate WebHelp output, first read about setting the various parameters for generating 
WebHelp output in Generate WebHelp output.

• Learn about generating the WebHelp output in Output generation basics.
• To know how to view WebHelp output, read View WebHelp, FlashHelp, WebHelp Pro, and Flash-

Help Pro output.
• To learn about the various delivery formats for WebHelp output, read Publish output

RELATED LINKS:
Generate, view, and publish output
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Microsoft HTML Help layout

Create custom skins for WebHelp and WebHelp Pro projects

Merging Help projects

WebHelp Pro and FlashHelp Pro layouts

About WebHelp Pro and FlashHelp Pro

WebHelp Pro and FlashHelp Pro layouts deliver server-based output for web and applications. To publish 
this output to a server, RoboHelp Server must be installed.

WebHelp Pro is an uncompiled output type that supports standard Help features.

You create WebHelp Pro or FlashHelp Pro projects in RoboHelp, authoring content, adding features, and 
customizing the appearance. When you're ready to view and test the output, generate the project. Robo-
Help creates output files in a single folder within the project folder.

Increased speed
The Contents, Index, and Search tabs appear more quickly.

Usage information logged in a database
Access the database to improve applications.

Runtime project merging
Merge multiple projects at runtime or when accessing the Help system from a server.

Window properties
Server access accommodates Toolbar, Menu, Location Bar, and Status Bar options. To set these tool 
properties, double-click a window in the Windows folder of the Output Setup pod.

Convert desktop Help to WebHelp Pro

1) Contact the server administrator or IT department to ensure that RoboHelp Server is installed and 
to learn its name.

2) Find the path or location of RoboHelp Server and specify it in the project.
3) Open the project in RoboHelp. Set WebHelp Pro as the output.
4) Connect to the server by publishing the project files.
5) To access the server, enter its domain name in the browser address bar. Ask the server adminis-

trator for the URL.

RELATED LINKS:
Specify the primary layout

View output

Publish output
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Microsoft HTML Help layout

About Microsoft HTML Help

HTML uses tags to mark elements, such as text and graphics, in a document with display instructions. 
HTML Help includes HTML documents (HTM files) for the topics, along with project source files. You use 
RoboHelp to add features such as links, a table of contents, an index, special effects, and related topics 
buttons.

You distribute a compressed file (CHM) to users that they view in the HTML Help viewer.

The main components of HTML Help include the following:

HTML Help ActiveX control
Supports navigation features such as the table of contents, index, and link controls (related topics 
and keyword links). It also supports HTML Help controls: WinHelp topic links, startup screens, and 
close window controls.

Layout engine
Microsoft Internet Explorer 6 and later supply the required components for HTML Help support.

HTML Help viewer
Displays compiled HTML Help (CHM file). It uses components of the Internet Explorer browser while 
displaying content in its proprietary window interface.

Compressed HTML
A collection of all files in the project in a single CHM file that occupies less disk space and is faster 
to load. You can ship this compiled file with an application or distribute it to users as a stand-alone 
online document.

Generating Microsoft HTML Help

The RoboHelp Help compiler processes all source files into a distributable format, which can then be 
tested or distributed.

You can generate the output at any stage in the project.

Compiler Messages

The compiler displays messages, statistics, and compiling errors during generation. If the compiler finds 
problems with the source files, error messages appear:

Notes
Conditions that probably do not cause a serious problem in the output. Note numbers range from 
1000 through 2999.
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Warnings
Conditions that result in defective output. For example, if the compiler cannot locate an image, it 
displays a warning and continues generating. Warning numbers range from 3000 through 4999.

Errors
Conditions that stop the compiler. You can't generate the output until you correct the error. Error 
numbers range from 5000 through 6999.

Internal Errors
Errors caused by the HTML Help Workshop program. Internal error numbers are 7000 and greater.

Link TOC books or pages to custom windows (Microsoft HTML Help)

1) Right-click a topic in the TOC pod, select New > Book or Page, and click the Advanced tab.
2) Specify the options for displaying the TOC book or page:

Window
Specify the custom window in which the topic is displayed.

Frame
Specify the frame in which the topic is displayed. Custom framesets appear in this list.

Comment
TOC comments are not visible to users.

Image
Select custom icons for displaying the book or page in the TOC. Click the pop-up menu  and press 
the Down Arrow key to move through the list of available icons. Select different icons for the closed 
book state and the open book state.

NOTE: Generate and view the Contents tab in the HTML Help viewer to display custom icons.

Mark As New
Displays a red star with the TOC book or page icon to indicate new items to end users. The standard 
icons look like the following:

–  New book
–  New page

Use Information Types
This option is only available when Book With Link is selected on the General tab. Select it to use a 
TOC book or page with information types.
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Information Types
Click Add to select topics for the information type. Click Edit to change an information type, and 
click Remove to delete an information type.

Types
Display book or page information types.

3) Click OK.

Extract CHM files

You can extract source files from a compiled Microsoft HTML Help file (CHM).
1) In the Toolbox pod, double-click HTML Help Studio.
2) Select File > Open, and then select a CHM file. Click Open.
3) Do either of the following:

– To extract an individual file or folder, select it and click the Extract button .
– To extract all files, click the Extract button. Select All Files.

4) Specify a destination for Extract To.

Rename CHM files

The CHM filename is based on the project filename (.xpj).
1) In the Single Source Layouts pod, right-click HTML Help. Select Properties.
2) In Output Folder And Filename, type a name for the file, including the .chm extension.
3) Click Save.

The CHM file is renamed the next time you generate Help.

Find HTML Help files and components

1) In the Toolbox pod, double-click Find HTML Help Files or Find HTML Help Components.
2) Click Search.

TIP: To rearrange or resize columns, drag their headings or separator bars.

Replace CHM files

1) In the Toolbox pod, double-click HTML Help Registration.
The Name column lists CHM files that are currently registered on the authoring system.

2) Select the CHM file to replace.
3) Click Edit.
4) Click the browse button  and navigate to the replacement CHM file.
5) Select the file, and click Open. Click OK.

NOTE: Replacing a CHM file does not affect how users view the Help project.
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Register or unregister CHM files

Sometimes compiled Microsoft HTML Help files (CHM) are registered if they are used with applications. 
You register CHM files on the authoring system. Registering the files doesn't affect how users view the 
Help project after it's distributed.
1) In the Toolbox pod, double-click HTML Help Registration.

– To register a CHM file, click Register. Navigate to the CHM file, and click Open. Click OK.
– To unregister a CHM file, select it and click Unregister. Click OK.

JavaHelp layout

About JavaHelp

JavaHelp is a compressed output type that works with applications written in the Java programming 
language. JavaHelp and Java applications run on various platforms.

RoboHelp provides support for the JavaHelp format and automatically creates all Java-based Help 
features and the HTML-based features such as HTML content and hypertext links. You can also leverage 
existing WinHelp and HTML projects to create JavaHelp systems. A file compression feature is available 
for distributing the JavaHelp system.

JavaHelp is a compressed file (JAR file) or a set of files used to run a Help system for a Java application. 
RoboHelp copies all the files to distribute into the JavaHelp folder, or into a JAR file if you choose to 
compile Help.

Authoring requirements

• Sun Java 2 SDK or later
• JavaHelp 1.1.3 or later

User requirements

• Java Runtime Environment (JRE) 1.2.1 or later
• JavaHelp 1.1.3 or later

Generate JavaHelp output

Generating JavaHelp saves the source files in the project subfolder JavaHelp (default).

When you generate JavaHelp files, RoboHelp can translate Related Topics controls into controls specifi-
cally for JavaHelp.
1) Place the Bsscjhrc.jar file in the application extensions folder, or in the class path passed to the Java 

Virtual Machine (Java.exe).
2) Incorporate related topics controls in the topics.
3) Generate the output.
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NOTE: If question marks appear instead of Related Topics controls, the Bsscjhrc.jar file is not in the correct 
location.

RELATED LINKS:
Output generation basics

Merge JavaHelp projects

Adding the reference merges all elements in the external HelpSet file with the existing project.
NOTE: You can add external navigation views (TOC, index, search) as remote views. However, adding the 
reference to an external HS file adds all views, with other project files, to the existing project.

JavaHelp limitations

Capitalization
Supports all caps and small caps.

Custom colors
Some custom colors don’t appear accurately in the JavaHelp viewer.

Expanding glossary hotspot definitions
Appear inline.

Fonts
Fonts are automatically set to JavaHelp default fonts. Font size is unsupported.

Forms
Only simple forms appear properly in the JavaHelp viewer.

Framesets
Unsupported.

HTML files generated by Word 2000 or later
Unsupported.

HTML Help controls
Supports WinHelp topic, Shortcut, Table of Contents, Index, Splash Screen, Close Window, and 
HHCTRL Version.

Images
Don’t appear consistently in compressed JavaHelp. Background images and image maps are unsup-
ported.

Links
Supports links to e-mail addresses, FTP sites, and external files.
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Lists
Only simple bulleted or numbered lists appear properly in the JavaHelp viewer.

Multimedia
Supports sound files, such as WAV or MIDI, and video files, such as AVI.

Paragraph alignment
Supports tags, such as P align=”center”.

Plain text
Supports non-HTML files.

Pop-up links
The pop-up note window does not have a bottom border if the entire pop-up note is contained 
within the content frame. This limitation does not apply to text-only pop-up notes.

Special effects
Supports ActiveX controls, DHTML, JavaScript, startup screens, and Visual Basic scripts.

Style sheets
Support for partial cascading style sheets is provided with JavaHelp 1.1. (External style sheets work 
correctly.) You can use level 1 cascading style sheets with the Sun Java 2 JDK or later, or Swing 1.1.1 
with Sun Java 2 JDK or later.

Table attributes
The following attributes are unsupported:

• Values set in the initial tag (TABLE) of a table override cell width specifications.
• The table width attribute (TABLE WIDTH) functions when specified in absolute pixels, but not in 

percentages.
• When used within the TABLE tag, the background color attribute (BGCOLOR) does not function.
• When used within the TABLE tag, the break tag (BR) causes the table cell to expand by the number 

of BR tags used.
NOTE: This feature is supported in JavaHelp 1.1.3 and later.

• Table alignment cannot be set precisely.

Text animations and effects
Unsupported.
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Oracle Help layout

About Oracle Help

Oracle Help is an output type that works with applications written in Java or any other programming 
language.

Oracle Help is a compressed file (.jar) or a set of files used to run a Help system for an application. When 
you generate Oracle Help, the files to distribute are created in a single output folder.

Authoring requirements

• Oracle Help components, version 3.2.2, or 4.1.2 or later
NOTE: Version 3.2.2 is built using the Oracle internal Java GUI tool kit called EWT. Version 4.1.2 is 
built using Java Foundation Classes. The functionality, APIs, and supported file formats are the 
same in both versions. To build applications using JFC, or to build custom navigators for the Help 
project, use version 4.1.2 or later. If developers are using Oracle products, use version 3.2.2.

• Sun Java 2 SDK or later
• Java Runtime Environment (JRE), version 1.2.1 or later

Oracle Help includes the Oracle Help components, the Oracle Help viewer, and API documentation for 
developers.

User requirements

• Oracle Help components (version 3.2.2, or 4.1.2 or later)
• The Oracle Help project (as either a compiled JAR file or a folder containing individual source files)
• Sun Java SDK (version 2 or later) or Java Runtime Environment (version 1.2.1 or later)

NOTE: When compiling Oracle Help, make sure to set the encoding type to utf-8 (-Dfile.encoding=UTF8) 
while calling the java compiler command. This ensures that the help is properly generated and can be 
displayed on all systems.

Update topic IDs for Oracle Help

Oracle Help uses topic IDs (in a map file) to make context-sensitive Help calls. You can change the topic 
ID by editing the topic meta tag.
1) Open the topic in the HTML Editor.

Notes:

• If two topics have the same topic title, the latter is assigned another ID when you generate. For 
example, TopicID becomes TopicID1.

• If two topics have the same topic ID meta tag, a warning is displayed in the Output View pod when 
you generate.

• If a topic has no title or meta tag specifying the topic ID, RoboHelp creates a topic ID based on the 
filename.
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Set the topic window for Oracle Help

Specify a window in which topics appear by editing the topic meta tag in the Design Editor. If you specify 
no window, the default window is used.
1) Open the topic in the HTML Editor.
2) Edit the meta tag.

meta name = "window-type" content = ["window name"]

Oracle Help remote views

Oracle Help uses views to define the contents of the Navigator left pane: TOC, keyword index, and 
full-text search.

You can also add remote views to Oracle Help projects. A remote view is an external table of contents, 
index, or full-text search database. Use remote views if you are merging smaller projects into one master 
project. You can specify that a remote view remain in its own tab, or merge with an existing view. By 
default, Oracle Help merges all views having the same engine, type, and label.

Oracle Help makes an important distinction between labels and titles:

Labels
Assigned to tabs.

Titles
Assigned to top-level books or nodes in the TOC.

Merge Oracle Help projects

1) Add a reference to an external HelpSet file (with the .hs extension) when you generate Oracle Help.

Adding a reference to an external HS file adds all views, with other project files, to the existing project.

Oracle Help indexes

One level of indenting is supported. Users can search for keywords in the list. As keywords are selected, 
topics are listed in the lower pane. Double-clicking a topic in the lower pane displays its content in the 
topic window on the right.

You can import external indexes and merge them using Oracle Help remote views. You can create sepa-
rate tabs for each index or you can merge them.
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Example of an Oracle Help index

Oracle Help full-text search

Oracle Help displays search results by relevance, not alphabetically. You can import full-text search data-
bases from other projects using Oracle Help remote views.
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Example of an Oracle Help full-text search

Oracle Help limitations

Not all limitations apply to every Oracle Help project.

Capitalization
Supports all caps and small caps.

Expanding glossary hotspot definitions
Appear inline.

Fonts
Limited font support.

Glossary pane
Unsupported if you use Glossary Designer.
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HTML Help controls
Supports WinHelp topic, Shortcut, Table of Contents, Index, Splash Screen, Close Window, and 
HHCTRL Version.

Links
Supports links to e-mail addresses, FTP sites, and external files.

Lists
Only simple bulleted or numbered lists appear properly in the Oracle Help viewer.

Multimedia
Supports sound files, such as WAV or MIDI, and video files, such as AVI.

Plain text
Supports non-HTML files.

Special effects
Supports ActiveX controls, DHTML, JavaScript, startup screens, and Visual Basic scripts. Unsup-
ported DHTML appears as plain text in generated Oracle Help projects.

Text animations and effects
Unsupported.

XML layout

RoboHelp uses handlers to convert XML to HTML and import XML files into topics. Handlers can also 
export topics or even entire projects as XML. You can create or customize XML handlers using the HDF 
Editor.

The following predefined handler files are available:

Import DocBook As Topics
Imports the selected DocBook files as HTML topics.

Import XHTML (*.XML)
Imports the selected XHTML files as HTML topics.

Import XML (CSS/XSL)
If the selected XML file has an associated style sheet (CSS or XSL file), this handler imports the XML 
file as an HTML topic, including formatting. If the selected XML file lacks an associated style sheet, 
this handler converts the XML file to an HTML file without formatting. This import option also 
provides advanced import options. You can import the XML file as text flow or tree flow or select a 
customized CSS or XSL file.
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NOTE: If all the HDF files (and therefore handlers) have been deleted, you cannot access the XML import 
or output functionality. Use the XML Handler Manager to import an HDF file containing a handler or rein-
stall RoboHelp to enable this functionality.

RELATED LINKS:
Generate XML output

Import XML files

Adobe AIR layout

You use the Adobe AIR layout to generate Help as an Adobe AIR application, browser-based Help (with 
the theme and skin of an Adobe AIR application), or a packaged data file that can be viewed in an AIR 
Help viewer.

Adobe AIR is a cross-platform runtime for building and deploying applications that connect the desktop 
to the web.
NOTE: On Linux, the AIR Runtime is not supported after Version 2.6. AIR Help will still run on Linux using 
Version 2.6.

For a list of benefits of generating output in the Adobe AIR layout, see About output types.

For more information about Help applications using Adobe AIR, see www.adobe.com/go/learn_rh_arti-
cle_airhelp_en.

Configure the Adobe AIR layout

You configure the Adobe AIR layout from the Adobe AIR option in the Single Source Layouts pod. In the 
Adobe AIR dialog box, you can select the output type, configure the installer settings, and define how the 
Help content is presented to the users.
1) Select Adobe AIR from the Single Source Layouts pod and do one of the following:

– Right-click and select Properties from the context menu.
– Select Edit > Properties.

RELATED LINKS:
Merging Help projects

Distribute Adobe AIR output

Hosting updates for AIR Help

Create custom skins for Adobe AIR projects

Review and collaboration in AIR Help

http://www.adobe.com/go/learn_rh_article_airhelp_en
http://www.adobe.com/go/learn_rh_article_airhelp_en
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Select Help output

You can select one of the four output options for Adobe AIR:
1) In the General tab of the Adobe AIR dialog box, select the output type:

Adobe AIR Application
Generates Adobe AIR output as embedded Help. The Help system is created as a single AIR appli-
cation installer. You can install the AIR application locally or distribute it to your users. Users can 
update their installed Help system based on Adobe AIR whenever an update is available on the 
web. For more information about autoupdates, see the AutoUpdating section in the Adobe AIR 
Helparticle by Peter Grainge. NOTE: You need JRE 1.6 or higher installed on your system to install the 
Adobe AIR application.

Browser Based Help
Generates browser-based Help as an Adobe Flex application that you can use as online or 
embedded Help. You can upload this output to the server with specific configurations. Users can 
view this Help using a browser with Adobe Flash plug-in 9.0 or later installed. NOTE: Browser-based 
Help does not support Adobe AIR application features such as commenting, favorites, resources, 
RSS, and auto-update.

AIR Application And Browser Based Help
Generates the Help system in two formats simultaneously: Adobe AIR application and 
browser-based Help. You can view the AIR application after installing it on your computer. You can 
view the browser-based Help by uploading it to a server. The two Help systems are independent of 
each other.

Help Content Only
Generates the Help system as a data file (RHA) that you can view in a Help viewer. Use the Help 
Viewer wizard in RoboHelp to create a Help viewer. To view multiple files in a single view, you can 
write the location of all those files in a HelpConfig file.

NOTE: For the syntax of the HelpConfig file, see Create and locate a Help content configuration file.
For a step-by-step description of how to merge the output of multiple projects into a single .air file, 
see www.adobe.com/go/learn_rh_merge_rha_en.

Configure Help settings

1) In the General tab of the Adobe AIR dialog box, set the following.

Output Location of AIR File
Click Browse to select a folder for the Help application installer (AIR file) and specify a name. By 
default, RoboHelp names the Help application installer by appending .air to your project name.

Output Location of Start Page (Browser-based Help Only)
Specify the first page to display in browser-based Help.

http://www.grainge.org/pages/authoring/air/air.htm
http://www.grainge.org/pages/authoring/air/air.htm
http://blogs.adobe.com/techcomm/2010/07/merging_multiple_helps_in_air_help_output.html
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Help Title
Specify a title for your Help application. This title appears in the title bar of the Help and in Program 
Files.

Version
Specify a version number for the generated Help application. Typically, you set 1.0 as the version 
number for the initial release of your Help application, and increment the version number for 
subsequent releases. The incremental version numbers help your users identify updated Help 
content in their local installations.

Help ID
Specify a unique identifier for the Help application. The Help ID can be alphanumeric and include 
periods and hyphens.

NOTE: When you deliver updated Help, change only the version number. The installed AIR Help uses the 
combination of Help ID and Version to identify whether a later version of Help is available.

Configure the Help application installer

NOTE: Optionally, you can uncheck the Installer Settings checkbox tocreate an unsigned Adobe AIR appli-
cation so that the application can be signed later. The extension .airi will be appended to AIR File name 
and the fields under Installer Settings group will be disabled, indicating that you have chosen to prepare 
an AIRI Help package that will be signed later. See Signing an intermediate AIR Help application with AIR 
Developer Tool.

To sign your Adobe AIR Help application with a digital certificate, check the Installer Settings checkbox 
and configure the settings for the Help application installer.
1) In the General tab of the Adobe AIR dialog box, set the following under the Installer Settings group:

Digital Certificate
A digital signature ensures that the Help system (or its updates) has not been altered or corrupted 
since it was created. All Adobe AIR applications require a digital signature and can't be installed 
without one. If your organization has purchased one from a certificate authority, click Browse to 
select it. Otherwise, click Create to create a self-signed (and reusable) certificate. See Create a 
self-signed digital certificate.

Password
Enter the password assigned to the digital certificate.

Include Timestamp
Select to include a timestamp on the digital certificate. The timestamp provides information on 
how long the certificate is valid.
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Program Menu Folder
Specify the program menu folder name. For example, on Windows, the string that you specify is 
appended to form the path Start > Programs > [program menu folder name] > [Help 
system title].

Create content categories

Create content categories to publish the output as a package of user-centric Help systems (for example, 
a package of Help systems for different user roles, geographies, products, or platforms).

End users view the output as an integrated package of Help systems and have the flexibility to select the 
Help system they want to access from a drop-down list. Each Help system has its own TOC, index, browse 
sequences, and search.
1) In the Content Categories tab of the Adobe AIR dialog box, do the following:

– To rename a content category, select the category. Click Rename and specify another name.
– To delete a content category, select the category and click Delete. Click Yes to confirm.
– To change the order of the content categories in the drop-down list from which users select, 

use Up or Down keys.
– To specify a content category as the default category, click Set As Default.

Configure content

You configure the presentation of content in the Help application. If you’ve created content categories, 
configure the presentation of content for each category.
1) In the Content tab of the Adobe AIR dialog box, set the following for each content category:

Content Title
Specify a title for the content category. The title appears in a drop-down list and helps users to navi-
gate to a content category.

NOTE: If you’ve not created content categories, skip this field. RoboHelp uses the title you specified in 
Help Settings in the General tab.

Table Of Contents
Select the TOC to be displayed in the generated Help. See TOCs.

Index
Select the index to be displayed in the generated Help. See Indexes.

Glossary
Select the glossary to be displayed in the generated Help. See Glossaries.

Variables Set
Select a variable set to override the default variable set in the generated Help. See User-defined 
variables.
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Default Topic
The topic that appears when Help opens. By default, the first topic in the table of contents is the 
default topic.

Language
Specify the output language for the layout if the language is different from the language of the 
project. RoboHelp uses this language setting for the UI strings and language-related UI elements in 
the preview and generated output.

Encoding
Specify the character encoding format if the web server to which you’re publishing has character 
encoding different from UTF-8.

Map Files
Specify the map files that contain topic IDs associated with map IDs to provide context-sensitive 
Help.

Browse Sequences
Select the browse sequences for this content category.

Conditional Build Expression
Specify a conditional build expression to apply to the output. See Conditional build tag expressions.

Apply To All Topics
Specify whether to apply a master page or a CSS to all the topics. If you do not select the Apply To 
All option, the master pages associated with individual topics become effective. If no master pages 
are applied to topics, they are generated as is. See Applying a master page or CSS at the time of 
generation

Exclude Unreferenced Topics From Output
Select this option to exclude any topic that exists in the project but is not the default topic in the 
layout or is not referenced from the selected TOC, index, or browse sequence, or any referenced 
topic.

NOTE: RoboHelp displays the unreferenced topics that are excluded from the output in the Output View 
pod.

Exclude Unreferenced Baggage Files From Search
Select this option to exclude any topic that exists in the project but is not referenced from the 
selected TOC or any referenced topic (if Exclude Unreferenced Topics From Output is selected). If 
Exclude Unreferenced Topics From Output is deselected, RoboHelp excludes baggage files that are 
unreferenced from any topic in the project.
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Set the Help viewer window and branding options

Appearance settings define the appearance for the Help viewer window.
1) In the Adobe AIR dialog box, select the Template group and set the following:

Template
Select a template from the pop-up menu.

Skin
Select a skin from the pop-up menu. Alternatively, click Gallery to select a skin from the skins avail-
able for the selected template. You can preview a skin before selecting it.

Copyright
Specify the entity that owns the copyright of the Help application. This entity is usually the name of 
the company publishing the Help content. The copyright notice appears in the About box (Help > 
About).

Description
Specify a description for the Help. The description appears in the About box (Help > About).

Favicon
(Browser-based Help) Specify an icon to associate with the Help system. The icon appears in the 
browser tab.

Width and Height
Set the width and height of the Help window.

Specify Branding options
Click to specify an icon for your Help system in different sizes and specify other branding options.

The following sizes are used by the operating system to display the Help system icon in predefined 
locations, such as the title bar, the taskbar, and the About box:

– 128x128
– 48x48
– 32x32
– 16x16

If you do not specify your own icon, the operating system defaults are used. For best results, 
provide an image for each of the specified sizes. In addition, make sure that the icons look present-
able in both 16- and 32-bit color modes. Icon files must be in the PNG format.

You can also display your company logo in the top-right corner of the Help application and copy-
right information or any brand-related information in the status bar. The image size for the logo is 
32x32.
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Template for the Help application

Choose the template that you want to use for your Help application. You can select one of the following 
three templates: NOTE: Templates are not applicable if you selected the Help Content Only output type.

Classic Help
The Classic Help template divides the page into a top pane, left pane, and a content pane.

Multi Tab Accordion
The Multi Tab Accordion template divides the page into a top pane, left pane, and a content pane.

Uni Pane
The Uni Pane template divides the page into a top pane and a content pane.

All the templates have different appearance and navigation options. They also have some common 
features. These features are support for TOC, index, glossary, search, print, and the Content pane. The 
following table shows the differences among three types of templates:

NOTE: Press F11 to show or hide the left and top panes.

You can choose any of the templates to use in the Help system and preview it before generating it. NOTE: 
You can customize a template. By default, all the available options for content display and navigation in 
a template are selected.

Configure content presentation

You configure how the Help application behaves when a user uses it.
1) In the Adobe AIR dialog box, select the View group, and set the following:

Enable Auto Update
Enables the AIR application to synchronize the AIR file installed on a desktop with the current 
content on the network drive or an HTTP server location. Do one of the following:

Features Classic Help Multi Tab Accordion Uni Pane

How do I
See Browse sequences.

Yes No No

Search Yes Yes Yes

Search results that 
show context

No Yes Yes

Showing/hiding the left 
pane

Yes Yes No

Viewing status bar Yes Yes Yes



386

WORK WITH LAYOUT TYPES
CHAPTER 12 GENERATING OUTPUT

Content updates within your network
Select File from the Type menu and click Browse to select the folder and file with the content 
updates.

Content updates outside your network
Select HTTP from the Type menu and enter the URL of the XML file that contains the updates to the 
Help contents.

The Auto-update feature helps your users update the Help application whenever an update is avail-
able. You can send the auto-update in the form of an XML file or host it on a web server. See Hosting 
updates for AIR Help.

Add
Click to specify Mac OS and Linux locations to update the installed Help if you are hosting the XML 
file on a local or network drive.

Add Resources
Select and click the Add button to add external links that appear in the Favorites group in the Help 
application.

You can add resources such as technical support pages, knowledgebase articles, RSS feeds, and 
related websites.

Show Online Content
Specify the full path from where the AIR Help viewer picks up the published browser-based Help. 
For example, http://www.example.com/[browserhelpfolder].

This option is applicable only if you select the output type as Adobe AIR Application or AIR Applica-
tion And Browser Based Help.

NOTE: If you select this option, make sure that you publish browser-based Help to the location pointed by 
the server URL. Otherwise, the AIR application shows offline content.

Configure search

In the Adobe AIR dialog box, select the Search group, and set the following:

Enable Highlight Search Results
Select to enable highlighting of search results. Topics that match the search criteria appear with the 
search term highlighted. Click the Text pop-up menu to set the highlight color.

Show Context In Search Results
Select to have the search results displayed along with the first few lines of the topic.
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Enable Substring Search
Select to have search results include not only the exact search string but also text in which the string 
is embedded. For example, a search for “log” returns topics containing the words “catalog” and 
“logarithm.” A substring search takes longer than a whole-string search.

Enable External Content Search
Select to display content from identified URLs outside the Help system. For information about how 
to specify URLs and associate them with search terms, see External content search.

Hide Rank Column In Search Results
Select to not display the Rank column in search results.

Show Total Number Of Search Results
Select to show the number of search results for a specific search string.

Allow AND Search In Output
Select to display only those topics that have all the words that are specified without using quotation 
marks in the Search box. By default, RoboHelp performs OR search when a user types multiple 
words without enclosing them in quotation marks. This means that RoboHelp finds all topics that 
have any of the words specified in the Search box.

NOTE: AND search can be used in combination with phrase search.
Select the Enable AND Search By Default option if required. If you allow AND search disable it by 
default, end users have the option to enable it in the output.

NOTE: In merged projects, child projects inherit the setting of the parent 
project. In projects with DUCC (content categories), the setting applies 
to all content categories.

Exclude Baggage Files Types From Search
Select the types of baggage files to exclude from search.

Configure collaboration

Collaboration settings are available for Adobe AIR Application only.
1) In the Adobe AIR dialog box, select the Collaboration group, and set the following:

Enable Topic Rating
Enables users to rate any topic on a scale of 0-5 stars.

Enable Commenting
Select to enable commenting.

Enable Comment Moderation
Select to allow acceptance or rejection of comments by authorized users (moderators).
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NOTE: When you distribute the output, make sure that you share the moderator password. See Distribute 
Adobe AIR output.

Set Location For Comments And Topic Ratings
Depending on whether you want a trust-based system or user authentication, select one of the 
following options:

– Select Network Folder. Click Browse to choose the shared network folder where the 
comments will be stored. Click Add to add locations on Mac and Linux systems if required. See 
URL formats for Windows, Mac, and Linux.
Specify the password that moderators need to provide to access the moderation dashboard.
Select Pending or Accepted to specify how you want to handle unmoderated comments. If you 
select Pending, unmoderated comments are not displayed to users.
Storing comments in a shared network folder is suitable in trust-based work environments, 
where shared reviews by internal stakeholders are part of the content development process.

– Select RoboHelp Server and specify the server URL.
Storing comments on RoboHelp Server enables you to authenticate users before allowing 
them to view or post comments.

Configuration File Path
Specify the path and name of the file that stores the configuration for comment syncing and 
auto-update. When the AIR application is distributed, users can copy the default configuration file 
from the !SSL folder of the project to the location specified in the configuration file path and modify 
the default settings according to their preferences. For example, they can disable commenting or 
change the location of storing comments.

You can enter the path in any of the following formats:

– A relative path (relative to the install folder)
– An absolute location, such as a shared network drive or a file location in the user drive
– A web URL pointing to the location where you’ve posted the XML file

Configure a server to host browser-based Help

You can directly upload the generated browser-based Help to a server. Consult your system adminis-
trator for information about which server to use.
NOTE: Server configuration is not applicable if your output type is Adobe AIR Application.
1) Select Server in the Adobe AIR dialog box.
2) Click New. Specify the following options in the New Destination dialog box:

Descriptive Name
Name for the server to publish the Help system to. For example, if you are publishing a Help system 
for internal review, enter “Internal Review Server.”
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Connection Protocols
Select the protocol for connecting to the server or the sharing platform. Select FTP, HTTP, File 
System, or SharePoint.

These are the FTP server connection details:

Hostname
Enter the host name of the FTP server.

Port
Enter the port number. Typically, FTP connections use the default port, 21.

User ID and Password
If your FTP server requires user authentication, enter the user ID and password that your system 
administrator provided for you.

Anonymous User
Select Anonymous User if your FTP server allows anonymous FTP. You do not require a user ID and 
password for connecting to the FTP server.

Specify these details for the HTTP server connection:

Host Name
Enter the host name of the server.

Server Directory
Enter the directory on the HTTP server to place the Help system contents. Some HTTP servers 
require a trailing slash (/) at the end of the path.

Select File System and enter the destination path if you have access to a network path where you 
can directly upload your Help system contents.

For the File System server connection, specify the destination path.
For the Microsoft SharePoint server connection, specify the SharePoint directory path. If the Share-
Point site path is mapped as a network drive on the system or added in network paths, you can use 
the browse button to select the network path.

3) Set the following options:

Check For Deleted Files
Check for files that have been deleted from the destination.

Prompt Before Overwriting Files
Receive a warning before overwriting files on the server.
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Republish All
Republish all files to the destination, overwriting existing files on the server. NOTE: If you are setting 
options for a master project, and a copy of the subproject is in the output folder, ensure that Repub-
lish All is not selected.

4) To publish Help, click Save And Generate.

Notes:
• For merged Help systems, publish individual projects to the same location. Do not use Republish All 

in the master project.
• Set layout options once and automatically generate the primary layout by selecting the Generate 

button.
• Generate or publish multiple layouts in a batch.
• If the output is corrupt, check if any topic file has the & character. Rename the topic and regenerate 

the output.
• For a list of video formats supported in Adobe AIR output, see 

http://kb2.adobe.com/cps/402/kb402866.html.

Create a self-signed digital certificate

You can create a digital certificate to test or privately distribute the Adobe AIR Help application. 
However, if you distribute Help through your website, be sure to procure a digital certificate from a 
certificate authority (CA), such as Thawte or VeriSign. Use the digital certificate to sign the Help system.

Digital certificates from certificate authorities can be verified through the web. They assure end-users 
that the Help application installer is genuine and free from malware. See 
www.adobe.com/go/learn_air_digital_certificate for more information.
1) Click Create near the Digital Certificate label.
2) In the Create Self-Signed Digital Certificate dialog box, enter the following details:

Publisher Name
Specify the name of the publisher. Usually, it is the name of your company. If you are creating a 
Help application based on Adobe AIR for another company, specify the name of your client. Option-
ally, you can specify the organizational unit and organization name.

Country
Select the country of the publisher.

Type
Select the encryption standard for the digital certificate. The 2048-RSA standard provides stronger 
encryption than the 1024-RSA standard.

Save As
Click Browse to select a folder and save the digital certificate that you created. Self-signed digital 
certificates are saved with a .p12 extension.

http://kb2.adobe.com/cps/402/kb402866.html 
http://www.adobe.com/go/learn_air_digital_certificate
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Signing an intermediate AIR Help application with AIR Developer Tool

All Adobe AIR Help applications must be signed to be installed on another system. However, there is 
provision to create unsigned Adobe AIR installer files so that the application can be signed later. These 
unsigned Adobe AIR installer files are called an AIRI (AIR Intermediate) package. This capability provides 
for cases in which the certificate is on a different machine or signing is handled separately from applica-
tion development.

If you choose to sign the application later by unchecking the Installer Settings in Adobe AIR Help settings 
dialog box, you will need to use the command-line AIR Developer Tool (ADT) included with AIR SDK in the 
RoboHelp installation directory (path: \RoboHTML\AIRSDK\bin).

For the steps, see Signing an AIR intermediate file with ADT.

Generate, view, and publish output

Generate output to view it and test links, browse sequences, and other elements. Generating output also 
updates files containing information about the project and the output files.

Publishing the output (WebHelp and FlashHelp only) places the output files or folders at a specified loca-
tion. The location can be a website, the local hard drive, or a network folder.

You can use a combination of WebHelp and WebHelp Pro output or Adobe AIR Application and Browser 
Based Help output to deliver Airplane Help, which is a popular name for integrated offline/online Help. 
Read thisarticleto find out how to implement Airplane Help with WebHelp and WebHelp Pro output.

Delivering Airplane Help with Adobe AIR Application and Browser Based Help output is easier. Make sure 
that you select the Show Online Content option and publish Browser Based Help output to the location 
pointed by the server URL that you’ve specified. See Configure the Adobe AIR layout.

Output generation basics

You generate output to your local hard drive. When you generate a layout output for the first time, a new 
subfolder is created for the generated output files. It is in the project folder under \!SSL!\[layout name].
NOTE: Each time you generate output, RoboHelp deletes the output folder files created in the last session. 
If you add or hand-code files in the output subfolder, copy them to another location before you generate 
output.
1) In the Single Source Layouts Pod, right-click the layout. Select Generate.
2) Set options according to the layout type.
3) Click Finish.

Tips for optimal project generation

• Work locally, not from a network.
RoboHelp must access all of the files in your project when generating the output. If a project consists 
of thousands of files, even a minor delay caused by network traffic compounds as RoboHelp at-
tempts to access each file. These delays can adversely affect the generation times.

http://www.adobe.com/go/learn_rh_airplane_help_en
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• Exclude the project folder from virus scan.
NOTE: Turning off virus-scanning software increases speed but is not recommended for security 
reasons.

• Ensure that your system has sufficient memory.

RELATED LINKS:
Navigation options

User-defined variables

Generate Responsive HTML5 output

The Responsive HTML5 SSL helps you generate output for all sizes of devices of your choice.

While you can create optimizations for displaying content on small-screen devices, such as smartphones 
and tablets using Multiscreen HTML5 help, it requires at least some work for each of the screens. Using 
Responsive HTML5, you can create a single output that is optimized for all your screens. Responsive 
HTML5 automatically adjusts to the screen a user is accessing it from and also adjusts to dynamic screen 
size changes, such as a flip of orientation or resizing of the browser.
NOTE: If you publish right-to-left language content, the sidebar is displayed on the right. However, if is 
viewed in the Google Chrome browser, the output is truncated towards the scrollbar.

The following table provides a comparison of Multiscreen and Responsive HTML5 on layout and screen 
info:

To generate a Responsive HTML5 output:
1) In the Single Source Layouts pod, double-click the Responsive HTML5 SSL.

NOTE: If the project you have opened was created in a previous version, you will need to create a 
Responsive HTML5 layout. In the Single Source Layouts section in the toolbar, click the New Output 
icon and select Responsive HTML5 as the output type.

2) In the General tab, set the following options:

Title Bar:
Specify the title you want to display in the title bar.

Responsive HTML5 Multiscreen HTML5

Number of 
Layouts

One Multiple

Need to 
configure 
screen profiles

No Yes

Specify 
different 
content for 
screen types

No Yes
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Favicon:
Specify an icon to associate with the output. The icon appears in the browser tab or the address bar 
depending on the browser being used.

Output Folder And Start Page:
Specify a location and start page for the output. To choose a location for the output folder, click the 
browse button. To select a start page other than the default for the output, enter it using the .htm 
extension. The start page is the home page of the output, which is not the default topic.

Manage Layout
Select a layout and customize it for look and feel. For more details, see Customize the Layout. You 
can click Preview to generate a preview of the changes you have made to the layout.

Manage Thumbnails
In this section, specify the image style(s) you want to use to generate image thumbnails. You can 
also specify the maximum size of the image thumbnail by entering the Width and Height values. For 
more information about creating and using image thumbnails, see Image thumbnails.

Dynamic Content Filter
Check the Use Dynamic Content Filter in the output to assign a dynamic content filter to the current 
output. For details on how to create a user dynamic content filters, see Generate dynamic content 
output

3) (Optional) In the Content tab, set the following options:

Table Of Contents
Select the TOC to be displayed in the generated output. See TOCs.

Index
Select the index to be displayed in the generated output. See Indexes.

Glossary
Select the glossary to be displayed in the generated output. See Glossaries.

Variable Set
Select a variable set to override the default variable set in the generated output. See User-defined 
variables.

Default Topic
The topic that appears when Help opens. By default, the first topic in the table of contents is the 
default topic.

Language
Specify the output language for the layout if the language is different from the language of the 
project. RoboHelp uses this language setting for the UI strings and language-related UI elements in 
the preview and generated output.
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Encoding
Specify the character encoding format.

Map Files
Specify the map files that contain topic IDs associated with map IDs to provide context-sensitive 
Help.

Browse Sequences
Select the browse sequences to display.

Conditional Build Expression
If you have conditional tags in the project, click Define to specify conditional build expressions. See 
Conditional build tag expressions.

Apply To All Topics
Select this option to apply master pages or CSS at the project level:

Master Page
The selected master page overrides the settings of all the individual topics with or without a master 
page applied to them in the project. The CSS and layout of the master page override the CSS and 
appearance of all the topics. If the selected master page does not have a header or footer, no topic 
displays a header or footer irrespective of if it had one header or footer defined.

CSS
The master pages associated with individual topics become effective. The selected CSS overrides all 
the topics and their CSS irrespective of whether they are associated with a master page or not.

See Applying a master page or CSS at the time of generation.

Exclude Unreferenced Topics From Output
Select this option to exclude any topic that exists in the project but is not the default topic in the 
layout or is not referenced from the selected TOC, index, or browse sequence, or any referenced 
topic.

NOTE: RoboHelp displays the unreferenced topics that are excluded from the output in the Output View 
pod.

Exclude Unreferenced Baggage Files From Search
Select this option to exclude any topic that exists in the project but is not referenced from the 
selected TOC or any referenced topic (if Exclude Unreferenced Topics From Output is selected). If 
Exclude Unreferenced Topics From Output is deselected, RoboHelp excludes baggage files that are 
unreferenced from any topic in the project.

4) (Optional) In the Search tab, set the following options:
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Enable Substring Search
If you enable this feature, a search for "log" returns topics containing the words "catalog" and 
"logarithm." Substring search takes longer than whole-string search.

Enable External Content Search
Select to display content from identified URLs outside the Help system. For information about how 
to specify URLs and associate them with search terms, see External content search.

Show Context In Search Results
Select to have the search results displayed along with the first few lines of the topic.

Use Topic Comment as Search Context
Select to use the topic comment to display in the search result.

NOTE: By default, each search result displays the RoboHelp topic title, followed by the first 100 characters 
of the first paragraph in the topic.

Number of Characters in Search Context
Set the maximum number of characters to display in the search result.

Exclude Baggage Files Types From Search
Select the types of baggage files to exclude from search.

Number of Results On A Page
Select the number of search results to display on a page.

Generate XML Sitemap
Select to generate a sitemap for your published output. In the published output, you will find the 
sitemap.xml file, which contains the sitemap of your published output. You can submit the 
sitemap.xml file to your search engine to improve the search results for your site. As different 
search engines use different process for sitemap.xml submission, ensure you follow the correct 
process as described in the search engine’s documentation.

Base URL of the Help System
Specify the base URL of your site where you plan to host the published output. If your base URL is 
different from your primary domain, then you must add the location of the sitemap.xml file in the 
robots.txt file. For example, if your site's primary domain is www.example.com and you plan to 
keep the sitemap.xml file at the www.example.com/ProductName/help/ location, then you must 
add an entry of the sitemap.xml file in the robots.txt file. Else, if the sitemap.xml file is saved at the 
same location as robots.txt, then you do not need to make any changes in the robots.txt file.

Content Change Frequency
Select the frequency at which you intend to update your help system or website. Search engines 
can use this information to revisit your site for indexing updated content.

5) (Optional) In the Optimization tab, set the following options:
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Convert Auto-sizing And Custom-sized Popups To Hyperlinks
Select this option to make sure that hyperlinks configured to display in auto-sizing or custom-sized 
pop-ups are converted to flat hyperlinks.

Convert Text-only Popups To Hyperlinks
Select this option to make sure that text-only pop-ups are converted to flat hyperlinks.

Convert Absolute Image Size To Relative Image Size
Select this option to convert the actual width and height of images into percentages. In this way, 
you can make images used in your project device-friendly and adapt to different device sizes.

Convert Absolute Table Size To Relative Table Size
Select this option to convert the actual width and height of tables into percentages. By allowing 
RoboHelp to optimize the tables in this way, you ensure that the tables adapt to different device 
sizes.

Enable Zoom On iOS Devices
Enable or disable pinch zoom on the iPad and the iPhone. When this option is enabled, users can 
zoom in on a RoboHelp output displayed on an iPad or iPhone by pinching the device screen.

Use Adobe Captivate HTML5 Output
Select this option to use Adobe Captivate HTML5 output instead of Adobe Captivate SWF output.

NOTE: Adobe Captivate HTML5 output must be available for demos that are imported or inserted in the 
project.

6) (Optional) In the Publish tab, set the following options:

Servers
Specify a server location for the output. To publish HTML5 output to a SharePoint site, click New 
and select SharePoint. Enter the UNC path of the folder on the SharePoint site (If the folder is 
mapped as a network drive, click Browse to select the drive).

Similarly, to publish HTML5 output to RoboHelp Server 10, click New and select RoboHelp Server. 
Enter the Server Name (http://<servername>:port number/<context-name>/server), User ID and 
Password. Select the Save Password option if you want to save the password. Click the refresh icon 
to view the available areas on the server where you can publish your project.

Options
Specify how to handle changes to files in the output:

Check For Deleted Files
If selected, RoboHelp HTML checks for files that have been deleted from the destination location 
and republishes them.

Prompt Before Overwriting Files
If selected, RoboHelp prompts you before overwriting files.
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Republish All
Select to republish all files to the destination target. For master projects with a copy of the 
subproject in the subfolder, do not select Republish All. You then avoid overwriting output files 
already published to the same location.

NOTE: If you change the destination to a new host, specify the user ID and password and save the pass-
word in the registry, if necessary.

7) (Optional) In the SharePoint tab, set the following options to publish output in the native (.aspx) file 
format:

SharePoint Version
Select either SharePoint 2007 or SharePoint 2010+.

Publish Location:
Depending on the version you select, do one of the following:

– If you selected SharePoint 2010+, click Browse, enter the SharePoint site path and credentials 
in the Connection Details dialog box; and then select the SharePoint document library and the 
folder where the output is to be published.

– If you selected SharePoint 2007, enter the SharePoint path to which the output is to be 
published.

Publish To SharePoint
Files are published to SharePoint only when this option is selected. Also specify the following:

– Check For Deleted Files:If selected, RoboHelp HTML checks for files that have been deleted 
from the destination location and republishes them.

– Prompt Before Overwriting Files: If selected, RoboHelp prompts you before overwriting files.
– Republish All: Select to republish all files to the destination. For master projects with a copy 

of the subproject in the subfolder, do not select Republish All. You then avoid overwriting 
output files already published to the same location.

Advanced Options
Specify the following options:

– Output Folder:Local folder for saving generated SharePoint output. This option is usually 
populated automatically. You should need to specify the output folder only if you’re working 
with merged projects.

– Generate SharePoint Native Output Before Publishing:Select this option to pregenerate 
ASPX files. If this option is not selected, RoboHelp generates the normal HTML files and then 
displays a dialog box allowing you to select whether to publish them. Clicking Publish causes 
RoboHelp to generate the ASPX files and upload them to SharePoint.

8) Click Save.
9) Click Save and Generate.

RoboHelp publishes the responsive HTML5 and displays the Result dialog.
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10) Click View Result to launch responsive HTML5 in your default browser. Now you can host this help 
on a server to be consumed online on various devices.

Generate Mobile App output

The Mobile App SSL helps you generate an Android or iOS mobile application as output. The procedure 
uses the RoboHelp - PhoneGap integration to generate an Android or iOS mobile application.
IMPORTANT: You require a PhoneGap account to create Mobile apps. To create more than one app you 
need to purchase Creative Cloud Subscription.

To generate a Mobile app:
1) Choose Output > Mobile App.

NOTE: If the project you have opened was created in a previous version, you will need to create a 
Mobile App layout. In the Single Source Layouts pod, click the Create Layout icon and select Mobile 
App as the output type.

2) Select a layout and customize it for look and feel. For more details, see Customize the Layout. You 
can click Preview to generate a preview of the changes you have made to the layout.

3) Check the Use Dynamic Content Filter in the output to assign a dynamic content filter to the current 
output. For details on how to create a user dynamic content filters, see Generate dynamic content 
output

4) In the Application Details tab, set the following options:

Package
A name that will uniquely identify the Mobile app. A common naming convention is to use your 
company domain name in reverse followed by the name of the App. For example 
com.adobe.myapp. This name is used by PhoneGap to uniquely identify the application.

NOTE: To avoid issues with third-party tools used in PhoneGap, you are recommended to use English 
alphabets, underscore character, and the dot as the separator.

Version
The PhoneGap version number for the app.

VersionCode (Android)
The Android version number for the app. If you upload your app to an Android store such as Google 
Play, a user will be notified of updates to your app every time you update the version number.

NOTE: This is not required if you are creating an iOS app.

Title
The title of the application that will display on a mobile device.

Description
The PhoneGap description for the application.
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Icon
The icon of the application that will display on a mobile device.

Splash Screen
The splash screen that will display when the app is opened on a mobile device.

You can specify multiple splash screens. Your users will see the splash screen based on their device 
screen size and screen resolution. For details on how to do this, see the information on configuring 
Splash Screens in PhoneGap documentation.

PhoneGap / Adobe credentials
PhoneGap or Adobe ID user name and password.

NOTE: To use the RoboHelp - PhoneGap integration, you require a PhoneGap or Adobe user account.

Platform
Choose the platform (iOS and/or Android) for which you want to create the app.

You can create an Android debug app without requiring the following Android signing files and 
credentials. However, for iOS, you will need the signing files.

Platform - Android
To create an Android app, you are required to provide the following credentials:

KeyStore File
A keystore is a binary file that contains a set of private keys.

Keystore Password
Password associated with the keystore file.

Certificate Alias
Represents the entity to be identified with the app, such as a person or a company.

Certificate Password
Password associated with the alias.

Platform - iOS
To create an iOS app, you are required to provide the following credentials:

Digital Certificate
To run the app on an Apple device, the app must be signed by a valid certificate. This file is provided 
by Apple through the Provisioning Portal.

Certificate Password
Password associated with the digital certificate.

http://docs.phonegap.com/
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Provisioning Profile
A file that allows applications to be installed on an iOS device. The file contains the digital certifi-
cate, App ID, and one or more device UDIDs on which you can install the app for testing. A user can 
directly install the app on these devices.

5) (Optional) In the Content tab, set the following options:

Table Of Contents
Select the TOC to be displayed in the generated output. See TOCs.

Index
Select the index to be displayed in the generated output. See Indexes.

Glossary
Select the glossary to be displayed in the generated output. See Glossaries.

Variable Set
Select a variable set to override the default variable set in the generated output. See User-defined 
variables.

Default Topic
The topic that appears when Help opens. By default, the first topic in the table of contents is the 
default topic.

Language
Specify the output language for the layout if the language is different from the language of the 
project. RoboHelp uses this language setting for the UI strings and language-related UI elements in 
the preview and generated output.

Encoding
Specify the character encoding format.

Map Files
Specify the map files that contain topic IDs associated with map IDs to provide context-sensitive 
Help.

Browse Sequences
Select the browse sequences to display.

Conditional Build Expression
If you have conditional tags in the project, click Define to specify conditional build expressions. See 
Conditional build tag expressions.
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Apply To All Topics
Select this option to apply master pages or CSS at the project level:

Master Page
The selected master page overrides the settings of all the individual topics with or without a master 
page applied to them in the project. The CSS and layout of the master page override the CSS and 
appearance of all the topics. If the selected master page does not have a header or footer, no topic 
displays a header or footer irrespective of if it had one header or footer defined.

CSS
The master pages associated with individual topics become effective. The selected CSS overrides all 
the topics and their CSS irrespective of whether they are associated with a master page or not.

See Applying a master page or CSS at the time of generation.

Exclude Unreferenced Topics From Output
Select this option to exclude any topic that exists in the project but is not the default topic in the 
layout or is not referenced from the selected TOC, index, or browse sequence, or any referenced 
topic.

NOTE: RoboHelp displays the unreferenced topics that are excluded from the output in the Output View 
pod.

Exclude Unreferenced Baggage Files From Search
Select this option to exclude any topic that exists in the project but is not referenced from the 
selected TOC or any referenced topic (if Exclude Unreferenced Topics From Output is selected). If 
Exclude Unreferenced Topics From Output is deselected, RoboHelp excludes baggage files that are 
unreferenced from any topic in the project.

Table Of Contents Settings
Select Index, Glossary, or both to add an index and a glossary at the end of the TOC. By default, the 
index is placed before the glossary. Use the Up and Down buttons to reverse the order in which the 
index and the glossary are to be placed.

6) (Optional)In the Search tab, set the following options:

Enable Substring Search
If you enable this feature, a search for "log" returns topics containing the words "catalog" and 
"logarithm." Substring search takes longer than whole-string search.

Enable External Content Search
Select to display content from identified URLs outside the Help system. For information about how 
to specify URLs and associate them with search terms, see External content search.
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Show Context In Search Results
Select to have the search results displayed along with the first few lines of the topic.

Use Topic Comment as Search Context
Select to use the topic comment to display in the search result.

NOTE: By default, each search result displays the RoboHelp topic title, followed by the first 100 characters 
of the first paragraph in the topic.

Number of Characters in Search Context
Set the maximum number of characters to display in the search result.

Exclude Baggage Files Types From Search
Select the types of baggage files to exclude from search.

7) (Optional)In the Optimization tab, set the following options:

Convert Auto-sizing And Custom-sized Popups To Hyperlinks
Select this option to make sure that hyperlinks configured to display in auto-sizing or custom-sized 
pop-ups are converted to flat hyperlinks.

Convert Text-only Popups To Hyperlinks
Select this option to make sure that text-only pop-ups are converted to flat hyperlinks.

Convert Absolute Image Size To Relative Image Size
Select this option to convert the actual width and height of images into percentages. In this way, 
you can make images used in your project device-friendly and adapt to different device sizes.

Convert Absolute Table Size To Relative Table Size
Select this option to convert the actual width and height of tables into percentages. By allowing 
RoboHelp to optimize the tables in this way, you ensure that the tables adapt to different device 
sizes.

Enable Zoom On iOS Devices
Enable or disable pinch zoom on the iPad and the iPhone. When this option is enabled, users can 
zoom in on a RoboHelp output displayed on an iPad or iPhone by pinching the device screen.

Use Adobe Captivate HTML5 Output
Select this option to use Adobe Captivate HTML5 output instead of Adobe Captivate SWF output.

NOTE: Adobe Captivate HTML5 output must be available for demos that are imported or inserted in the 
project.

Limit The Scope Of Project Styles Only To Topic Contents
Select this option to do the following:
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– Prevent the styles defined in project style sheets (CSS) from overriding the styles defined in 
the screen layout CSS

– Prevent topic and screen layout style sheets (CSS) from overriding the CSS used by SharePoint 
master pages

Example: Your project CSS may contain the style:

div{ 
color:red; 
}
If the layout CSS also contains a div style but with a different color and if this setting is not selected, 
the project definition could undesirably override the layout definition applying red.

8) Click Save.
9) Click Save and Generate.

RoboHelp publishes the Mobile App and displays the Result dialog.
10) Click View Result to launch the Mobile App Output dialog:

Mobile App Output dialog with download details

Click Save to Local Drive download button to download the app to your computer.
You can download and allow other users to download the app onto mobile devices by scanning the 
QR code or by navigating to the URL on the devices.
NOTE: iOS apps can only be installed via this URL if your device UDID is added in the mobile provision 
file.
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Upload your mobile app to the app store

After you have configured your mobile app settings, you can then generate the app. This app is the 
uploaded to the PhoneGap server. You can then either download the app to your computer or you can 
use the QR code to download the app to your mobile device.

To upload the app to the Apple or Android app stores, follow the instructions in the following articles:
• Android Developer Console
• Submitting Your App to the Apple App Store

Generate Multiscreen HTML5 output

The Multiscreen HTML5 SSL helps you generate output for screen profiles of your choice.
1) In the Single Source Layouts pod, double-click the Multiscreen HTML5 SSL.

NOTE: If the project you have opened was created in a previous version, you will need to create a 
Multiscreen HTML5 layout. In the Single Source Layouts pod, click the Create Layout icon and select 
Multiscreen HTML5 as the output type.

2) In the General tab, set the following options:

Title Bar
Specify the title you want to display in the title bar.

Favicon
Specify an icon to associate with the output. The icon appears in the browser tab or the address bar 
depending on the browser being used.

Output Folder And Start Page
Specify a location and start page for the output. To choose a location for the output folder, click the 
browse button. To select a start page other than the default for the output, enter it using the .htm 
extension. The start page is the home page of the output.

3) Click the Screen Profiles tab. Notice that a set of screen profiles are mapped to screen layouts. One 
of these screen profiles is set as the default screen profile (by default, Desktop is set as the default 
screen profile).
– Change the default screen profile if required. Select the screen profile you want to set as 

default and click Set As Default.
NOTE: The default screen profile is used if the resolution of the device from which the output 
is being launched does not match any screen profile.

– Change the order of screen profiles if required by clicking Move Up or Move Down.
NOTE: If the resolution of the device from which the output is being launched matches two 
screen profiles, the order of the screen profiles in the SSL settings determines the screen 
profile to be used.

– Add new screen profiles that are available in your project. Click Add Screen Profile and select 
screen profiles from the list.

https://developer.apple.com/library/prerelease/ios/documentation/IDEs/Conceptual/AppDistributionGuide/SubmittingYourApp/SubmittingYourApp.html
http://developer.android.com/distribute/googleplay/developer-console.html
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– Remove screen profiles for which you don’t need to generate output. Select the screen 
profiles from the Screen Profiles list and click Remove Screen Profile(s).

– Map screen profiles to screen layouts. NOTE: Click Preview to preview a mapped screen layout.

4) Expand the Screen Profiles tab and for each screen profile, specify the following settings:

Table Of Contents
Select the TOC to be displayed in the generated output. See TOCs.

Index
Select the index to be displayed in the generated output. See Indexes.

Glossary
Select the glossary to be displayed in the generated output. See Glossaries.

Variable Set
Select a variable set to override the default variable set in the generated output. See User-defined 
variables.

Default Topic
Select the topic that appears when the output opens. By default, the first topic in the table of 
contents is the default topic.

Language
Specify the output language for the layout if the language is different from the language of the 
project. RoboHelp uses this language setting for the UI strings and language-related UI elements in 
the preview and generated output. See Change project settings.

Encoding
Specify the character encoding format if the web server to which you’re publishing has character 
encoding different from UTF-8.

Map Files
Specify the map files that contain topic IDs associated with map IDs to provide context-sensitive 
Help. See Map files and map IDs.

Browse Sequences
Select the browse sequences to display. See Browse sequences.

Conditional Build Expression
If you have conditional tags in the project, click Define to specify conditional build expressions. See 
Conditional build tag expressions.

Apply To All Topics
Select this option to apply master pages or CSS at the project level:
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Master Page
The selected master page overrides the settings of all the individual topics with or without a master 
page applied to them in the project. The CSS and layout of the master page override the CSS and 
appearance of all the topics. If the selected master page does not have a header or footer, no topic 
displays a header or footer irrespective of if it had one header or footer defined.

CSS
The master pages associated with individual topics become effective. The selected CSS overrides all 
the topics and their CSS irrespective of whether they are associated with a master page or not.

See Applying a master page or CSS at the time of generation.

Exclude Unreferenced Topics From Output
Select this option to exclude any topic that exists in the project but is not the default topic in the 
layout or is not referenced from the selected TOC, index, or browse sequence, or any referenced 
topic.

NOTE: RoboHelp displays the unreferenced topics that are excluded from the output in the Output View 
pod.

Exclude Unreferenced Baggage Files From Search
Select this option to exclude any topic that exists in the project but is not referenced from the 
selected TOC or any referenced topic (if Exclude Unreferenced Topics From Output is selected). If 
Exclude Unreferenced Topics From Output is deselected, RoboHelp excludes baggage files that are 
unreferenced from any topic in the project.

5) For each screen profile, specify the following settings in the Search tab:

Enable Substring Search
If you enable this feature, a search for "log" returns topics containing the words "catalog" and 
"logarithm." Substring search takes longer than whole-string search.

Enable External Content Search
Select to display content from identified URLs outside the project output. For information about 
how to specify URLs and associate them with search terms, see External content search.

Show Context In Search Results
Select to have the search results displayed along with the first few lines of the topic. You can specify 
the maximum number of characters to show as the context.

Exclude Baggage Files Types From Search
Select the types of baggage files to exclude from search.

Number of Results On A Page
Select the number of search results to display on a page.



407

GENERATE, VIEW, AND PUBLISH OUTPUT
CHAPTER 12 GENERATING OUTPUT

6) For each screen profile, specify the following settings in the Optimization tab:

Convert Auto-sizing And Custom-sized Popups To Hyperlinks
Select this option to make sure that hyperlinks configured to display in auto-sizing or custom-sized 
pop-ups are converted to flat hyperlinks.

Convert Text-only Popups To Hyperlinks
Select this option to make sure that text-only pop-ups are converted to flat hyperlinks.

Convert Absolute Image Size To Relative Image Size
Select this option to convert the actual width and height of images into percentages. In this way, 
you can make images used in your project device-friendly and adapt to different device sizes.

Convert Absolute Table Size To Relative Table Size
Select this option to convert the actual width and height of tables into percentages. By allowing 
RoboHelp to optimize the tables in this way, you ensure that the tables adapt to different device 
sizes.

Enable Zoom On iOS Devices
Enable or disable pinch zoom on the iPad and the iPhone. When this option is enabled, users can 
zoom in on a RoboHelp output displayed on an iPad or iPhone by pinching the device screen.

Use Adobe Captivate HTML5 Output
Select this option to use Adobe Captivate HTML5 output instead of Adobe Captivate SWF output.

NOTE: Adobe Captivate HTML5 output must be available for demos that are imported or inserted in the 
project.

Limit The Scope Of Project Styles Only To Topic Contents
Select this option to do the following:

– Prevent the styles defined in project style sheets (CSS) from overriding the styles defined in 
the screen layout CSS

– Prevent topic and screen layout style sheets (CSS) from overriding the CSS used by SharePoint 
master pages

Example: Your project CSS may contain the style:

div{ 
color:red; 
}
If the layout CSS also contains a div style but with a different color and if this setting is not selected, 
the project definition could undesirably override the layout definition applying red.

7) (Optional) In the Publish tab, set the following options:
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Servers
Specify a server location for the output. To publish the HTML output to a SharePoint site, click New 
and select SharePoint. Enter the UNC path of the folder on the SharePoint site (If the folder is 
mapped as a network drive, click Browse to select the drive).

Options
Specify how to handle changes to files in the output:

Check For Deleted Files
If selected, RoboHelp HTML checks for files that have been deleted from the destination location 
and republishes them.

Prompt Before Overwriting Files
If selected, RoboHelp prompts you before overwriting files.

Republish All
Select to republish all files to the destination target. For master projects with a copy of the 
subproject in the subfolder, do not select Republish All. You then avoid overwriting output files 
already published to the same location.

NOTE: If you change the destination to a new host, specify the user ID and password and save the pass-
word in the registry, if necessary.

8) (Optional) In the SharePoint (Native) tab, set the following options to publish output in the native 
(.aspx) file format:

SharePoint Version
Select either SharePoint 2007 or SharePoint 2010+.

Publish Location:
Depending on the version you select, do one of the following:

– If you selected SharePoint 2010+, click Browse, enter the SharePoint site path and credentials 
in the Connection Details dialog box; and then select the SharePoint document library and the 
folder where the output is to be published.

– If you selected SharePoint 2007, enter the SharePoint path to which the output is to be 
published.

Publish To SharePoint
Files are published to SharePoint only when this option is selected. Also specify the following:

– Check For Deleted Files:If selected, RoboHelp HTML checks for files that have been deleted 
from the destination location and republishes them.

– Prompt Before Overwriting Files: If selected, RoboHelp prompts you before overwriting files.
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– Republish All: Select to republish all files to the destination. For master projects with a copy 
of the subproject in the subfolder, do not select Republish All. You then avoid overwriting 
output files already published to the same location.

Advanced Options
Specify the following options:

– Output Folder:Local folder for saving generated SharePoint output. This option is usually 
populated automatically. You should need to specify the output folder only if you’re working 
with merged projects.

– Generate SharePoint Native Output Before Publishing:Select this option to pregenerate 
ASPX files. If this option is not selected, RoboHelp generates the normal HTML files and then 
displays a dialog box allowing you to select whether to publish them. Clicking Publish causes 
RoboHelp to generate the ASPX files and upload them to SharePoint.

9) (Optional, in addition to step 8) RoboHelp lets you assign a SharePoint master page to each screen 
profile in the Multiscreen HTML5 SSL. You can also choose not to assign a SharePoint master page. 
Select one of the following options for each screen profile:

Site Master Page
Enter the master page path relative to the site.

Root Site: example.com

SharePoint site: example.com/robohelp

Master page is at:example.com/robohelp/doclib/minimal.master

Specify the path as doclib/minimal.master.

System Master Page
Use the master page defined as the default master page for system pages in SharePoint.

Custom Site Master Page
Use the master page defined as the default master page for sites in SharePoint.

Site Collection Master Page
Specify the master page path relative to the Site Collection (root of the site).

For example:

Root Site: example.com

SharePoint site: example.com/robohelp

Master page is at: example.com/robohelp/doclib/minimal.master

Specify the path as /robohelp/doclib/minimal.master.
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None
Do not apply a master page to SharePoint output. The output is displayed as ASPX pages without 
the SharePoint chrome.

Recommendation: To view Multiscreen HTML5 output optimally on SharePoint, ensure that your 
SharePoint master pages are HTML5-compliant. Otherwise, some HTML5 content or Multiscreen 
HTML5 options, such as the following, may not work for Multiscreen HTML5 output published on 
SharePoint:
– HTML5 videos (without a plug-in)
– The following options on the Optimization page in the Multiscreen HTML5 Settings dialog box:

• Convert Absolute Image Size To Relative Image Size
• Convert Absolute Table Size To Relative Table Size
• Use Adobe Captivate HTML5 Output

– (Only in Internet Explorer) Hint text is not removed from the search field in the published 
SharePoint content even when the user clicks the field to enter a search string. The user must 
manually delete the hint text.

– Minor layout issues

Generate EPUB and Kindle Book output

The EPUB format helps you to distribute content to mobile devices, eBook readers, and tablets. Adobe 
Digital Editions, Calibre, and the EPUB Reader plug-in with Mozilla Firefox are some EPUB readers.

Adobe Digital Editions reader software is free and can be downloaded from the Digital Editions product 
site.

RELATED LINKS:
Apply conditional build tags to content

EPUB resources

Read this article by Neil Perlin to get an overview of EPUB, RoboHelp’s support for EPUB, and some best 
practices.

For a list of top features of EPUB, see www.adobe.com/go/learn_rh_blog_epub_en.

For more information on the EPUB format, see www.idpf.org.

For guidelines for creating well-formed and well-formatted EPUB documents, refer to 
www.adobe.com/go/learn_rh_epub_best_practices_en (Best Practices Guide in EPUB format).

See the blog Digital Editions for information about Digital Editions.

Generate eBook output

1) In the Single Source Layouts pod, double-click the eBook SSL.
2) In the General tab, set the following options:

http://blogs.adobe.com/digitaleditions/
http://www.idpf.org/
http://www.adobe.com/go/learn_rh_blog_epub_enl
http://www.adobe.com/go/learn_rh_devnet_epub_en
http://www.adobe.com/go/learn_rh_epub_best_practices_en
http://www.adobe.com/products/digitaleditions/
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eBook Format(s)
Select EPUB 3 or Kindle Book or both as the eBook format. If you select EPUB 3, RoboHelp generates 
a .epub file. For Kindle Book output , RoboHelp uses the KindleGen converter to convert EPUB 3 
output to Kindle Format 8 and Mobi output.

NOTE: If the KindleGen converter is not available on your computer, download it from the link provided 
in the Kindle Book Generation dialog box.

Output Folder And File Name
Specifies a location and name for the output files. To choose a location for the output folder, click 
the browse button .

NOTE: You need not specify the extension with the file name. Based on the output selected, RoboHelp 
adds the extension.

Validate EPUB 3 Output
Set RoboHelp to validate the EPUB output using the standard EPUB validation tool EpubCheck. 
EpubCheck require Java Runtime 1.5 or above installed on the computer.

NOTE: If the EpubCheck.jar file is not available on your computer, download it from the link provided in 
the EPUB Validation dialog box. Validation messages are available only in English.

Show KindleGen Logs
Select to display the errors, warnings, and status messages generated by the KindleGen converter 
in the Output View pod.

3) In the Content tab, set the following options:

Table Of Contents
Select the TOC to be displayed in the generated output. See TOCs.

Index
Select the index to be displayed in the generated output. See Indexes.

Glossary
Select the glossary to be displayed in the generated output. See Glossaries.

Variable Set
Select a variable set to override the default variable set in the generated output. See User-defined 
variables.

Conditional Build Expression
If you have conditional tags in the project, click Define to specify conditional build expressions. See 
Conditional build tag expressions.
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Apply To All Topics
Select this option to apply master pages or CSS at the project level:

Master Page
The selected master page overrides the settings of all the individual topics with or without a master 
page applied to them in the project. The CSS and layout of the master page override the CSS and 
appearance of all the topics. If the selected master page does not have a header or footer, no topic 
displays a header or footer irrespective of if it had one header or footer defined.

CSS
The master pages associated with individual topics become effective. The selected CSS overrides all 
the topics and their CSS irrespective of whether they are associated with a master page or not.

See Applying a master page or CSS at the time of generation.

Embed Fonts
Select this option to embed the selected fonts into the eBook. Use this option , if you are creating 
content that includes uncommon fonts, or if you are using custom fonts that may not be available 
on the end-users’ environment.

Since the fonts will be included as part of the eBook output, the user experience will be uniform 
even if some users do not have the font installed.

When you check this option, the Embed Font dialog is displayed. In this dialog, you can choose to 
embed fonts that are currently included in your RoboHelp project. You can also choose embed 
system fonts that are not currently included.

Embed Fonts dialog
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Manage
Click manage to open the Embed Fonts dialog to make changes to the currently embedded fonts.

Exclude Unreferenced Topics From Output
Select this option to exclude any topic that exists in the project but is not the default topic in the 
layout or is not referenced from the selected TOC, index, or browse sequence, or any referenced 
topic.

NOTE: RoboHelp displays the unreferenced topics that are excluded from the output in the Output View 
pod.

Table Of Contents Settings
Select Index, Glossary, or both to add an index and a glossary at the end of the TOC. By default, the 
index is placed before the glossary. Use the Up and Down buttons to reverse the order in which the 
index and the glossary are to be placed.

4) In the Meta Information tab, specify metadata to conform to the Open Packaging Format (OPF) 
specification:

Title
A title for the output. By default, RoboHelp displays the project name.

Author(s)
(Optional) The name of the author. To specify multiple author names, use comma as the separator.

Publisher(s)
(Optional) The name of the entity responsible for making the output available, for example, the 
author or the organization.

Rights
(Optional) A statement about rights, for example, a copyright notice.

Description
(Optional) A description of the content.

Publication Identifier
An identifier conforming to specifications such as ISBN.

Language
The language in which the content is written. For information about the format, see Dublin Core 
Metadata Element Set.

Publish Date
(Optional) The date of publishing the output. Follow the format specified in Date and Time Formats.

http://dublincore.org/documents/2004/12/20/dces/
http://dublincore.org/documents/2004/12/20/dces/
http://www.w3.org/TR/NOTE-datetime
http://www.idpf.org/2007/opf/opf2.0/download/#Section2.2
http://www.idpf.org/2007/opf/opf2.0/download/#Section2.2
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Cover Image
(Optional) Specify the path for a JPG, JPEG, or PNG image that you want to use as the cover page of 
the eBook and the dimensions (use percentage values to allow browsers to optimize display for 
different-sized screens). You can also specify a GIF image. However, in the case of a GIF animation, 
only the first frame is used as the cover page.

NOTE: If you don’t specify a cover image, RoboHelp uses the first topic in the TOC as the cover page.

5) In the Meta Information tab, click Custom Metadata and specify additional EPUB 3-specific meta-
data in XML format. For more information on specifying Metadata for EPUB, refer to EPUB 3 spec-
ification for metadata.
For example, if you want to add the identifier type (ISBN, UUID, DOI, etc) for a Publication Identifier, 
you can use the XML format below:
<dc:identifier 
id="pub-id">urn:doi:10.1016/j.iheduc.2008.03.001</dc:identifier>

<meta refines="#pub-id" property="identifier-type" 
scheme="onix:codelist5">06</meta>

6) In the Optimization Settings tab, set the following options:

Convert Auto-sizing And Custom-sized Popups To Hyperlinks
Select this option to make sure that hyperlinks configured to display in auto-sizing or custom-sized 
pop-ups are converted to flat hyperlinks.

Convert Text-only Popups To Hyperlinks
Select this option to make sure that text-only pop-ups are converted to flat hyperlinks.

Convert Absolute Image Size To Relative Image Size
Select this option to convert the actual width and height of images into percentages.

Convert Absolute Table Size To Relative Table Size
Select this option to convert the actual width and height of tables into percentages.

7) Click Save And Generate.

Best practices

Keep the following best practices in mind as you prepare your content for EPUB output:
• Do not use space characters in bookmarks; space characters cause validation errors.
• Do not use Frameset elements in your content.

Limitations

The following HTML elements/attributes are not supported in EPUB 3 and are removed from EPUB 
output:
• Applets

http://idpf.org/epub/30/spec/epub30-publications.html#sec-metadata-elem
http://idpf.org/epub/30/spec/epub30-publications.html#sec-metadata-elem
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• Marquees (marquee tags are removed, but the content is displayed in the output)
• Table cellpadding

• Table cellspacing

• Table center alignment; the table appears left-aligned in the output

Generate EPUB 2.0.1 output

Prepare for generating the EPUB 2.0.1 output

1) Review your project content and apply CBTs to content not supported by the EPUB format (such as 
drop-down or expanded text).

2) Create the TOC for the EPUB output.
3) In the Single Source Layouts pod, right-click XML Output and select New Layout. Specify a name and 

click OK.
4) Select the TOC you created for the EPUB output.
5) Select or define the conditional build expression.
6) Click Save.

TIP: The sample projects available in your installation (accessible from the Starter pod) contain layouts 
that are configured for EPUB output. Check the settings of these layouts.

Run script to generate EPUB 2.0.1 output

1) Do one of the following:
– Select Output > Generate > EPUB 2.0.1 Output.
– Select Tools > Scripts > EPUB 2.0.1 Generator.

2) Specify a location to store the EPUB output.
3) Select the XML layout that contains the settings for the output.
4) In the Metadata tab, specify metadata to conform to the Open Packaging Format (OPF) specifica-

tion:

Title
A title for the output. By default, RoboHelp displays the project name.

Author(s)
(Optional) The name of the author. To specify multiple author names, use comma as the separator.

Publisher
(Optional) The name of the entity responsible for making the output available, for example, the 
author or the organization.

Tags
(Optional) The keywords to associate with the content.

http://www.idpf.org/2007/opf/opf2.0/download/#Section2.2
http://www.idpf.org/2007/opf/opf2.0/download/#Section2.2
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Rights
(Optional) A statement about rights, for example, a copyright notice.

Description
(Optional) A description of the content.

ISBN
(Optional) An identifier conforming to the ISBN specification.

Publish Date
The date of publishing the output. Follow the format specified in DateandTimeFormats.

Language
The language in which the content is written. For information about the format, see Dublin Core 
Metadata Element Set.

5) In the Cover Page tab, browse and select the image you want to display on the cover page of the 
EPUB output.

6) In the ePub Validation tab, select Validate ePUB File and specify the location of the standard EPUB 
validator, epubcheck.jar.

7) Click Generate.

Generate WebHelp output

1) In the Single Source Layouts pod, double-click the WebHelp layout.
NOTE: If you are not working on a new project, you might find that the default WebHelp layout has 
been renamed or deleted. Double-click any layout to check its type in the title bar of the layout 
settings dialog box. You can also add a new layout of a required type by using the Create Layout 
icon in the Single Source Layouts pod.

2) In the General tab of the WebHelp Settings dialog box, set the following options:

Title Bar
Specify the title you want to display in the title bar.

Favicon
Specify an icon to associate with the Help system. The icon appears in the browser tab.

Output Folder And Start Page
Specifies a location and start page for the Help files. To choose a location for the output folder, click 
the browse button . To select a start page other than the default for the Help project, enter it 
using the .htm extension. The start page is a frameset for Help content to which file developers link 
when calling the Help system from an application.

http://dublincore.org/documents/2004/12/20/dces/
http://dublincore.org/documents/2004/12/20/dces/
http://www.w3.org/TR/NOTE-datetime
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Use Lowercase File Names
Create filenames that use only lowercase letters. This option is recommended for UNIX users. NOTE: 
Don’t select this option for merged projects. Links to topics in other projects will convert to lower-
case, whereas the topic filenames will remain the same. The mixed cases create broken links on 
UNIX.

3) In the Content Categories tab, create content categories to publish the output as a package of 
user-centric Help systems (for example, a package of Help systems for different user roles, geogra-
phies, products, or platforms).
End users view the output as an integrated package of Help systems and have the flexibility to select 
the Help system they want to access from a drop-down list. Each Help system has its own TOC, 
browse sequences, index, and search.
– To create a content category, click New and specify a name.
– To rename a content category, select the category. Click Rename and specify another name.
– To delete a content category, select the category and click Delete. Click Yes to confirm.
– To change the order of the content categories in the drop-down list from which users select, 

use Up or Down keys.
– To specify a content category as the default category, click Set As Default.

4) In the Content tab, set the following options for each content category:

Content Title
Specify a title for the content category. The title appears in a drop-down list and helps users to navi-
gate to a content category.

NOTE: If you’ve not created content categories, skip this field. RoboHelp uses the title you specified in 
Help Settings in the General tab.

Table Of Contents
Select the TOC to be displayed in the generated Help. See TOCs.

Index
Select the index to be displayed in the generated Help. See Indexes.

Glossary
Select the glossary to be displayed in the generated Help. See Glossaries.

Variable Set
Select a variable set to override the default variable set in the generated Help. See User-defined 
variables.

Default Topic
The topic that appears when Help opens. By default, the first topic in the table of contents is the 
default topic.
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Language
Specify the output language for the layout if the language is different from the language of the 
project. RoboHelp uses this language setting for the UI strings and language-related UI elements in 
the preview and generated output.

Encoding
Specify the character encoding format.

Map Files
Specify the map files that contain topic IDs associated with map IDs to provide context-sensitive 
Help.

Browse Sequences
Select the browse sequences to display.

Conditional Build Expression
If you have conditional tags in the project, click Define to specify conditional build expressions. See 
Conditional build tag expressions.

Apply To All Topics
Select this option to apply master pages or CSS at the project level:

Master Page
The selected master page overrides the settings of all the individual topics with or without a master 
page applied to them in the project. The CSS and layout of the master page override the CSS and 
appearance of all the topics. If the selected master page does not have a header or footer, no topic 
displays a header or footer irrespective of if it had one header or footer defined.

CSS
The master pages associated with individual topics become effective. The selected CSS overrides all 
the topics and their CSS irrespective of whether they are associated with a master page or not.

See Applying a master page or CSS at the time of generation.

Exclude Unreferenced Topics From Output
Select this option to exclude any topic that exists in the project but is not the default topic in the 
layout or is not referenced from the selected TOC, index, or browse sequence, or any referenced 
topic.

NOTE: RoboHelp displays the unreferenced topics that are excluded from the output in the Output View 
pod.

Exclude Unreferenced Baggage Files From Search
Select this option to exclude any topic that exists in the project but is not referenced from the 
selected TOC or any referenced topic (if Exclude Unreferenced Topics From Output is selected). If 



419

GENERATE, VIEW, AND PUBLISH OUTPUT
CHAPTER 12 GENERATING OUTPUT

Exclude Unreferenced Topics From Output is deselected, RoboHelp excludes baggage files that are 
unreferenced from any topic in the project.

5) In the Navigation tab, set the following options:

Skin Selection
(Optional) Browse to a skin in the project, or click Gallery to select one from the Skins Gallery. Apply 
skins to customize the colors, buttons, text, fonts, and icons in the output.

NOTE: The Skin option is disabled if you select the Section 508 Compliant Output option. Use the Tradi-
tional Style - No Skin option.

In-Topic Navigation
This option is enabled if you have selected the Traditional Style - No Skin option. Click Edit to access 
options to include or exclude Show/Hide buttons for the Navigation pane and to include or exclude 
browse sequences in topics.

W3C Compliant Topics
For W3C-compliant topics, this option passes the topics through an HTML validator.

Add Mark Of The Web
Mark of the Web is a comment in the HTML markup for a web page. Internet Explorer 6 and later 
reference this comment to determine the security zone for the page on the user’s computer. Select 
this option to avoid having Internet Explorer block the output.

NOTE: Before merging projects, ensure that the Mark Of The Web option is either selected or deselected 
for all of the projects.

Section 508 Compliant Output
Select to deliver Section 508-compliant WebHelp. Output cannot include skins or other features 
such as DHTML.

Optimize Speed For
Select the option by which most users access Help. XML formats reduce load times by downloading 
only the data immediately needed. For example, the Contents pane fills quickly by initially down-
loading only enough data to fill the pane. The rest is downloaded in time for the user to move down 
the list.

– Web Site (Internet) Select if access is from a website. Assumes slower connections, uses 
data in smaller pieces, and requires more WebHelp files.

– Local PC or Intranet (Internal Network) Select if access is from an intranet or a local 
computer. Assumes faster connection, uses data in larger pieces, and requires fewer 
WebHelp files.
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Preferred Format
Specify how WebHelp handles Dynamic HTML (DHTML) and how end users access Help. The option 
you choose depends on user environment, such as the types of browsers and firewalls used.

DHTML > Pure HTML
Uses Dynamic HTML when supported, pure HTML otherwise. If users have firewalls that block Java 
applets, select DHTML > Pure HTML, which eliminates Java applets from Help.

Pure HTML
Displays Help using list-based, pure HTML in all browsers. However, Pure HTML reduces navigation 
functions.

Toolbar Buttons
Select navigation toolbar buttons to appear in the left pane.

Synchronize Table Of Contents
Synchronize the TOC with the topic in the right pane so that users see where they are in the struc-
ture.

– To synchronize the TOC automatically, click the pop-up menu and select Automatically.
– To add a button that users can click to synchronize the TOC, click the pop-up menu and select 

Manually. NOTE: If you use custom skins, provide a button icon in the WebHelp Skin Editor.

Add Breadcrumbs Links
Select to add breadcrumbs in the topic pages.

Format
Click to change the format of breadcrumbs.

Enable Browse Sequence
Specify whether the output should display browse sequences.

Show Navigation Pane Link In Topics
Select to include a link to the navigation pane in topics that are opened through the context-sensi-
tive Help calls.

Show Merged TOC In Child Project
Select to view the merged TOC in the child project.

Search Input Field In Toolbar
Include a search field in the main toolbar.



421

GENERATE, VIEW, AND PUBLISH OUTPUT
CHAPTER 12 GENERATING OUTPUT

Add About Box
Set up information that appears in a dynamic window when users click the image in the main 
toolbar.

Example of About box

6) In the Search tab, set the following options:

Enable Substring Search
If you enable this feature, a search for "log" returns topics containing the words "catalog" and 
"logarithm." Substring search takes longer than whole-string search.

Enable Highlighting In Search Results
Select to enable highlighting of search results. From the pop-up menu, select a color for the high-
light.

Enable External Content Search
Select to display content from identified URLs outside the Help system. For information about how 
to specify URLs and associate them with search terms, see External content search.

Show Context In Search Results
Select to have the search results displayed along with the first few lines of the topic.

Hide Rank Column In Search Results
Select to not display the Rank column in search results.

Show Total Number Of Search Results
Select to show the number of search results for a specific search string.

Allow AND Search In Output
Select to display only those topics that have all the words that are specified without using quotation 
marks in the Search box. By default, RoboHelp performs OR search when a user types multiple 
words without enclosing them in quotation marks. This means that RoboHelp finds all topics that 
have any of the words specified in the Search box.

NOTE: AND search can be used in combination with phrase search.
Select the Enable AND Search By Default option if required. If you allow AND search disable it by 
default, end users have the option to enable it in the output.

NOTE: In merged projects, child projects inherit the setting of the parent 
project. In projects with DUCC (content categories), the setting applies 
to all content categories.
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Exclude Baggage Files Types From Search
Select the types of baggage files to exclude from search.

7) In the Publish tab, set the following options, and then click Save And Generate.

Servers
Specify a server location for the output. To publish to a SharePoint site, click New and select Share-
Point. Enter the UNC path of the folder on the SharePoint site (If the folder is mapped as a network 
drive, click Browse to select the drive).

Options
Specify how to handle changes to files in the output:

Check For Deleted Files
If selected, RoboHelp HTML checks for files that have been deleted from the destination location 
and republishes them.

Prompt Before Overwriting Files
If selected, RoboHelp prompts you before overwriting files.

Republish All
Select to republish all files to the destination target. For master projects with a copy of the 
subproject in the subfolder, do not select Republish All. You then avoid overwriting output files 
already published to the same location.

NOTE: If you change the destination to a new host, specify the user ID and password and save the pass-
word in the registry, if necessary.

RELATED LINKS:
Dynamic HTML and special effects

Generate WebHelp Pro or FlashHelp Pro output

1) Set the following options, and then click Next. NOTE: The order of some options varies according to 
the type of output you generate.

Project Name
Differentiates multiple versions of a project on a server, if you merge projects.

Favicon
Specify an icon to associate with the Help system. The icon appears in the browser tab.

Output Folder And Start Page
Specifies a location and start page for the Help files. To choose a location for the output folder, click 
the folder button . To select a start page other than the default for the Help project, enter it using 
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the .htm extension. The start page is a frameset for Help content to which file developers link when 
calling the Help system from an application.

Conditional Build Expression
If you have conditional tags in the project, click Define to specify conditional build expressions.

Skin
Choose from the skins in the project, or click Gallery to select one from the Skins Gallery. Skins let 
you customize the output by changing the colors, buttons, text, fonts, and icons. A skin is required 
for FlashHelp output.

NOTE: The Skin option is disabled if you select the Section 508 Compliant Output option. Use the Tradi-
tional Style - No Skin option.

Table Of Contents
Select a table of contents to display in the generated Help.

Index
Select an index to display in the generated Help.

Glossary
Select a glossary to display in the generated Help.

Variables
Select a variable set to override the default variable set values in the generated Help.

Language
Specify the output language for the layout if the language is different from the language of the 
project. RoboHelp uses this language setting for the UI strings and language-related UI elements in 
the preview and generated output.

Encoding
Specify the character encoding format.

Default Topic
The topic that appears when Help opens. Click Select to specify a topic. By default, the first topic in 
the table of contents is the default topic.

Default Window
The container in which the Help displays. By default, the Help system opens in the user default 
browser window.
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Exclude Unreferenced Topics From Output
Select this option to exclude any topic that exists in the project but is not the default topic in the 
layout or is not referenced from the selected TOC, index, or browse sequence, or any referenced 
topic.

NOTE: RoboHelp displays the unreferenced topics that are excluded from the output in the Output View 
pod.

Exclude Unreferenced Baggage Files From Search
Select this option to exclude any topic that exists in the project but is not referenced from the 
selected TOC or any referenced topic (if Exclude Unreferenced Topics From Output is selected). If 
Exclude Unreferenced Topics From Output is deselected, RoboHelp excludes baggage files that are 
unreferenced from any topic in the project.

Apply To All Topics
Select this option to apply master pages or CSS at the project level:

Master Page
The selected master page overrides the settings of all the individual topics with or without a master 
page applied to them in the project. The CSS and layout of the master page override the CSS and 
appearance of all the topics. If the selected master page does not have a header or footer, no topic 
displays a header or footer irrespective of if it had one header or footer defined.

CSS
The master pages associated with individual topics become effective. The selected CSS overrides all 
the topics and their CSS irrespective of whether they are associated with a master page or not.

2) Set the following options, and then click Next.

Enable External Content Search
Select to display content from identified URLs outside the Help system. For information about how 
to specify URLs and associate them with search terms, see External content search.

Enable Highlight Search Result
Select to enable highlighting of search results. From the pop-up menu, select a color for the high-
light.

Show Context In Search Result
Select to have the search results displayed along with the first few lines of the topic.

Hide Rank Column In Search Results
(WebHelp Pro) Select to not display the Rank column in search results.

Show Total Number Of Search Results
(WebHelp Pro only) Select to show the number of search results for a specific search string.
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Allow AND Search In Output
(WebHelp Pro only) Select to display only those topics that have all the words that are specified 
without using quotation marks in the Search box. By default, RoboHelp performs OR search when 
a user types multiple words without enclosing them in quotation marks. This means that RoboHelp 
finds all topics that have any of the words specified in the Search box.

NOTE: AND search can be used in combination with phrase search.
Select the Enable AND Search By Default option if required. If you allow AND search disable it by 
default, end users have the option to enable it in the output.

NOTE: In merged projects, child projects inherit the setting of the parent 
project. In projects with DUCC (content categories), the setting applies 
to all content categories.

W3C Compliant Topics
For W3C-compliant topics, this option passes the topics through an HTML validator.

NOTE: Dynamic effects in styles aren’t supported in W3C-compliant output.

Add Mark Of The Web
Mark of the Web is a comment in the HTML markup for a web page. Internet Explorer 6 and later 
reference this comment to determine the security zone for the page on the user’s computer. Select 
this option to avoid having Internet Explorer block the output.

NOTE: Before merging projects, ensure that the Mark Of The Web option is either selected or deselected 
for the projects.

Add About Box
Click Add to specify information that appears in an About window that the user opens from the 
main toolbar.

Auto-Manage Flash Security
(FlashHelp Pro) If selected, the generated output path is copied to the local-trusted sandbox of 
Flash Player. Because of security changes in Flash 7 and later, place SWF files in the trusted security 
sandbox of Flash Player. RoboHelp maintains the RoboHelp[version].cfg file in the FlashPlayer-
Trust folder. NOTE: Dynamic effects in styles are not supported in W3C-compliant output.

Show Print Button In Skin
(FlashHelp Pro) Displays the Print button in the output.

Show Navigation Pane Link In Topics
Includes a link to the navigation pane in topics opened through context-sensitive Help.

Add Breadcrumbs Links
Select to add breadcrumbs in the topic pages.
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3) Set the following options, and then click Save And Generate.

Servers
Specify a server location for the output. Enter Servername:port/context-name/server or 
https://Servername:port/context-name/server depending on the protocol you want 
to use. RoboHelp uses the http protocol by default.

Options
Specify how to handle changes to files in the output:

Check For Deleted Files
If selected, RoboHelp HTML checks for files that have been deleted from the destination location 
and republishes them.

Prompt Before Overwriting Files
If selected, RoboHelp prompts you before overwriting files.

Republish All
Select to republish all files to the destination target. For master projects with a copy of the 
subproject in the subfolder, do not select Republish All. You then avoid overwriting output files 
already published to the same location.

NOTE: If you change the destination to a new host, specify the user ID and password and save the pass-
word in the registry, if necessary.

Generate Microsoft HTML Help output

1) Set the following options, and then click Save And Generate.

Select Output Folder And File Name
Specifies a location and start page for the Help files. To choose a location for the output folder, click 
the browse button . To select a start page other than the default for the Help project, enter it 
using the .chm extension.

Conditional Build Expression
If you have conditional tags in the project, click Define to specify conditional build expressions.

Table Of Contents
Select a table of contents to display in the generated Help.

Index
Select an index to display in the generated Help.

Glossary
Select a glossary to display in the generated Help.
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Variables
Select a variable set to override the default variable set values in the generated Help.

Language
Specify the output language for the layout if the language is different from the language of the 
project. RoboHelp uses this language setting for the UI strings and language-related UI elements in 
the preview and generated output.

Default Topic
The topic that appears when Help opens. Click Select to specify a topic. By default, the first topic in 
the table of contents is the default topic.

Default Window
The container in which the Help displays. By default, the Help system opens in the user default 
browser window.

Exclude Unreferenced Topics From Output
Select this option to exclude any topic that exists in the project but is not the default topic in the 
layout or is not referenced from the selected TOC, index, or browse sequence, or any referenced 
topic.

NOTE: RoboHelp displays the unreferenced topics that are excluded from the output in the Output View 
pod.

Add Breadcrumbs Links
Select to add breadcrumbs in the topic pages.

Optimize CHM File Size
Reduces the size of the CHM file.

Advanced Settings
Click to specify custom styles for the table of contents and index.

Apply To All Topics
Select this option to apply formatting at the project level:

Master Page
The selected master page overrides the settings of all the individual topics with or without a master 
page applied to them in the project. The CSS and layout of the master page override the CSS and 
appearance of all the topics. For example, if the selected master page doesn’t have a header or 
footer, topics won’t either.

CSS
The master pages associated with individual topics become effective. The selected CSS overrides all 
the topics and their CSS irrespective of whether they are associated with a master page or not.
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Generate Oracle Help output

1) Set the following options, and then click Next.

Select Output Folder And Filename
Name and location of output files.

Use Lowercase Filenames
Recommended for UNIX users or users accessing files on a UNIX server.

Conditional Build Expression
Click Define to specify conditional build expressions.

Default Topic
Click Select to select a topic to display when the Help opens.

Navigation Pane
Specify the tabs that appear in the Help navigation pane.

In-Topic Navigation Bar
Options for the navigation bar.

Output
Specify the type of Oracle Help output:

Uncompressed Oracle Help With Source Files
Generates HS files and individual source files.

Compressed Oracle Help
Generates JAR and HS files.

Compressed Oracle Help With Source Files
Generates JAR and HS files, and individual source files.

NOTE: Generating Oracle Help source files empties the Oracle Help output folder.

Table Of Contents
Select the table of contents to display in the output.

Index
Select the index to display in the output.

Variables
Select a variable set to override the default variable set values in the generated Help.
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Language
Specify the output language for the layout if the language is different from the language of the 
project. RoboHelp uses this language setting for the UI strings and language-related UI elements in 
the preview and generated output.

Encoding
Specify the character encoding format if the web server to which you’re publishing has character 
encoding different from UTF-8.

Exclude Unreferenced Topics From Output
Select this option to exclude any topic that exists in the project but is not the default topic in the 
layout or is not referenced from the selected TOC, index, or browse sequence, or any referenced 
topic.

NOTE: RoboHelp displays the unreferenced topics that are excluded from the output in the Output View 
pod.

Apply To All Topics
Select this option to apply formatting at the project level:

Master Page
The selected master page overrides the settings of all the individual topics with or without a master 
page applied to them in the project. The CSS and layout of the master page override the CSS and 
appearance of all the topics. For example, if the selected master page doesn’t have a header or 
footer, topics won’t either.

CSS
The master pages associated with individual topics become effective. The selected CSS overrides all 
the topics and their CSS irrespective of whether they are associated with a master page or not.

2) Set the following options, and then click Next:

Label
Text displayed when the mouse hovers over the view name. Leave empty to use default text.

Image
Click the browse button to select an image to use in the toolbar.

3) Set the following options, and then click Next:

Title
(Optional) Specify text that appears in the viewer. Leave the boxes empty to use default text 
(Contents, Index, Full-Text Search).



430

GENERATE, VIEW, AND PUBLISH OUTPUT
CHAPTER 12 GENERATING OUTPUT

Image
Click the browse button to select an image that appears next to the table of contents title.

4) Click Add to specify a remote view for the TOC, index and Search. Enter view properties, and then 
click Next:

General tab
Set the following options:

Name
(Optional) A unique name for the remote view.

Type
Remote view type: TOCNavigator, KeywordNavigator, or SearchNavigator. Oracle Help merges 
views with identical labels and view types.

Engine
Format of the data file for the view.

Data File
Path (filename or URL) to the remote view.

Optional tab
Set the following options:

Text
Specify the tab label and view title. Leave the boxes empty to use the default text (Contents, Index, 
Full-Text Search).

Image
Click the browse button to select an image to use in the toolbar.

Map Reference tab
Click the browse button to add a pointer to the map file for the remote view.

5) To merge an external HelpSet file (.hs) with the project, specify the path in SubHelp Sets, and click 
Add.

6) Click Save And Generate.
7) If the JavaHelp JDK Requirement dialog box appears, select one of the following options:

NOTE: This dialog box appears if Sun Java 2 JDK or later isn’t installed.

Generate without Full-text Search
Click to generate output without full-text search functionality.
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Locate Java SDK Install Folder
Click to browse to the Java JDK install folder. Click Network to locate and map the folder on a 
network drive.

Generate JavaHelp output

1) Set the following options, and then click Save And Generate.

Select Output Folder And Filename
Name and location of output files.

Use Lowercase Filenames
Recommended for UNIX users or users accessing files on a UNIX server.

Conditional Build Expression
Click Define to specify conditional build expressions.

Default Topic
Click Select to select a topic to display when Help opens.

In-Topic Navigation Bar
Specify options for the navigation bar.

Table Of Contents
Select a table of contents to display in the output.

Index
Select an index to display in the output.

Glossary
Select a glossary to display in the output.

Variables
Select a variable set to override the default variable set values in the generated Help.

Language
Specify the output language for the layout if the language is different from the language of the 
project. RoboHelp uses this language setting for the UI strings and language-related UI elements in 
the preview and generated output.

Encoding
Specify the character encoding format if the web server to which you’re publishing has character 
encoding different from UTF-8.
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Exclude Unreferenced Topics From Output
Select this option to exclude any topic that exists in the project but is not the default topic in the 
layout or is not referenced from the selected TOC, index, or browse sequence, or any referenced 
topic.

NOTE: RoboHelp displays the unreferenced topics that are excluded from the output in the Output View 
pod.

Version
Specify the JavaHelp version.

Compress
Select from the following options:

Uncompressed JavaHelp With Source Files
Generates HS files and individual source files.

Compressed JavaHelp JAR
Generates JAR and HS files.

Compressed JavaHelp With Source Files
Generates JAR and HS files, and individual source files.

NOTE: Generating JavaHelp source files empties the JavaHelp output folder.

Apply To All Topics
Select this option to apply formatting at the project level:

Master Page
The selected master page overrides the settings of all the individual topics with or without a master 
page applied to them in the project. The CSS and layout of the master page override the CSS and 
appearance of all the topics. If the selected master page does not have a header or footer, no topic 
displays a header or footer irrespective of if it had one header or footer defined.

CSS
The master pages associated with individual topics become effective. The selected CSS overrides all 
the topics and their CSS irrespective of whether they are associated with a master page or not.

Advanced
Navigation view properties and merging options.

2) If the JavaHelp JDK Requirement dialog box appears, select one of the following options:
NOTE: This dialog box appears if Sun Java 2 JDK or later isn’t installed.
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Generate without Full-text Search
Click to generate output without full-text search functionality. The JavaHelp SubHelpSets dialog box 
appears.

Merge an external JavaHelp HelpSet (HS file) into the project.

Subhelp sets
Enter the full path (filename or URL) to the HelpSet (.hs) file.

Add
Add the specified HS file.

Update
Change the location of a SubHelpSet file already added. Highlight the file, change the path in the 
SubHelpSet box, and click Update.

Remove
Delete the selected SubHelpSet file.

Locate Java SDK Install Folder
Click to browse to the Java JDK install folder. Click Network to locate and map the folder on a 
network drive.

You can define the viewer class for a given MIME type by specifying the following information.

Type
Enter the MIME type.

Class
Enter a Java class for viewing the MIME type.

Generate XML output

1) Set the following options, and then click Save And Generate.

Select Output Folder And File Name
Name and location of output files.

Conditional Build Expression
Click Define to specify conditional build expressions.

Select Export Handler
Advanced options include the following:
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Export Project To DocBook
Exports the entire XML project to DocBook format.

Export Topics To DocBook
Exports only the topics to DocBook format.

Export Project To XHTML
Exports the XML project to XHTML format. All topics are converted to XHTML files.

For DocBook options, click Advanced to set additional options:

Content Only
Exports only the meaningful content (text and data) contained in the project or topic. No DHTML 
effects are included.

Full-Featured Export
Exports the entire project or topic contents (text and data and their related display format). All 
DHTML effects are included.

Table Of Contents
Select a table of contents to display in the output.

Index
Select an index to display in the output.

Glossary
Select a glossary to display in the output.

Variables
Select a variable set to override the default variable set values in the generated Help.

Encoding
Specify the character encoding format.

Exclude Unreferenced Topics From Output
Select this option to exclude any topic that exists in the project but is not the default topic in the 
layout or is not referenced from the selected TOC, index, or browse sequence, or any referenced 
topic.

NOTE: RoboHelp displays the unreferenced topics that are excluded from the output in the Output View 
pod.

Apply To All Topics
Select this option to apply formatting at the project level:



435

GENERATE, VIEW, AND PUBLISH OUTPUT
CHAPTER 12 GENERATING OUTPUT

Master Page
The selected master page overrides the settings of all the individual topics with or without a master 
page applied to them in the project. The CSS and layout of the master page override the CSS and 
appearance of all the topics. For example, if the selected master page doesn’t have a header or 
footer, topics won’t either.

CSS
The master pages associated with individual topics become effective. The selected CSS overrides all 
the topics and their CSS irrespective of whether they are associated with a master page or not.

RELATED LINKS:
XML layout

Generate EclipseHelp

EclipseHelp contains a bunch of HTML files with an XML-based TOC and a plugin.xml file. Eclipse uses the 
plugin file to display the Help from Help > Help Contents.
1) Do one of the following:

– Select Output > Generate > EclipseHelp.
– Select Tools > Scripts > EclipseHelp Generator.

2) Select the folder where you want to store the EclipseHelp output.
3) Specify the following information:

Title
A title for the output. By default, RoboHelp displays the project name.

Provider Name
The name of the company.

Version
The version number of the output.

ID
A unique ID for the output.

4) Click Generate.

Batch-generate output

Batch-generating output eliminates the need to wait for each output to finish processing before starting 
the next one. You can publish output from different layouts to different locations. Batch-processing saves 
time if you use conditional build tags to test, view, or distribute different outputs.

Layouts are processed in the order they appear in the Batch Generate dialog box.
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IMPORTANT: During generation, RoboHelp deletes the output folder files created in the last session. If you 
add or hand-code files in the output subfolder, copy them to another location before generating the 
output.
1) In the Single Source Layouts pod, right-click a layout.
2) Select Batch Generate.
3) Select the layouts for the outputs to generate.
4) Click Generate or Publish.

Notes:

• Generating WebHelp or WebHelp Pro requires a browser.
• To generate printed Word documents for the first time, enable macros in Word.
• Publish is available only if destinations for the selected WebHelp layouts are defined.
• Check the status of a generation in the Batch Generate dialog box. For a status of Failed, check the 

compiler messages in the lower pane to resolve the problem. For WinHelp projects, generate the 
project in the Layout wizard and use Error wizard to locate the problem.

• View published WebHelp or WebHelp Pro output from the server to see changes and server-depen-
dent features.

Customize the Layout

The Layout Customization dialog (Responsive HTML5 and Mobile App) allows you to choose from a list 
of available layout components. You can select a layout component and then customize the properties 
of the layout.

To customize the layout:
1) In the Settings dialog, click Customize Selected Layout.

The Layout Customization dialog displays a preview of the look-and-feel of the layout.
Alternatively, to open the Layout Customization dialog, go to the Output Setup pod:
– Right-click on Responsive_with_Logo and choose Edit.
– Click the Pencil icon on the Project toolbar.
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Layout Customization dialog

2) Select a layout component from the Layout Components list.
Each component has a set of customizable properties associated with the component.

3) To edit a property, go to the property value in the Properties pane.
4) You can go to a property in the Property pane by clicking the property in the Property pane and 

editing the value of the property.
Alternatively, notice the Component preview pane displays the preview of the component. In addi-
tion, the preview pane displays buttons pointing to each property in the preview pane.
You can click a property button in the preview pane to go to the property in the Properties pane.
This will allow you to identify from the preview, the property that you are editing.

5) To save your changes:
– Click Save and Preview to save the updates and preview the changes.
– Click Save to save the updates without preview.

6) To reset all the component properties, click Reset component.
7) To reset a specific component property, select the component (either from the Property pane or 

from the preview pane) and click Reset property.
8) After you have completed the layout customization, click Close.
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View output

1) Do one of the following:
– If the output is already generated, in the Single-Source Layouts pod, right-click the layout and 

select View. If prompted, click Yes to regenerate the output before you view it.
– If you have generated the layout, click View Result. After viewing, you can click Done, or 

publish the output to the location specified in the layout by clicking Publish.
– First publish the master project and view the master project from the published location to 

see the merged system. To publish the project, click Publish. NOTE: If the Publish button is 
disabled, add a destination in the Publish dialog box when generating or editing.

View Multiscreen HTML5 output

1) To view Multiscreen HTML5 output with different browsers, Click the Multiscreen Preview button 
in the toolbar.

NOTE: Internet Explorer 9 or later is required for rendering media queries correctly in Multiscreen preview. 
Install the latest version of Internet Explorer.

View WebHelp, FlashHelp, WebHelp Pro, and FlashHelp Pro output

To preview a WebHelp Pro or FlashHelp Pro project locally without publishing to the Adobe RoboHelp 
Server, open it in a web browser. You can’t preview the index, table of contents, links, and browse 
sequences locally.

You also can test the published project, including all server-dependent features, by viewing it from the 
server.

View the project in the browser to test links, images, browse sequences, and other elements.
NOTE: Chrome security settings do not allow loading FlashHelp or FlashHelp Pro output from a local disk. 
For these output types, launch Chrome from the command line in access file allowed mode (Chrome.exe 
-allow-file-access-from-files).

View WebHelp, FlashHelp, WebHelp Pro, and FlashHelp Pro remotely

1) Open the project, and ensure that the appropriate layout is the primary layout.
2) Select Output > Generate > Primary Layout.

View WebHelp, FlashHelp, WebHelp Pro, and FlashHelp Pro locally

1) In the Single Source Layouts pod, right-click the layout. Do one of the following:
– To view the output in the default browser, select View. If prompted, click Yes if you want to 

update the output. Otherwise click No.
– To view the output in a selected browser, select View With and choose one of the browsers 

installed on your computer.
TIP: Different browsers render CSS-based content differently. Multibrowser support for 
previewing topics and project output helps you test whether the content appears correctly in 
commonly used browsers.
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2) If a Limitations dialog box appears, click OK. The dialog box lists features that you cannot view 
without being connected to a server, such as the Search button and Windows properties.
The project opens in the default browser.

IMPORTANT: If the topics contain links to PDFs, make sure that Adobe® Acrobat® 10 is installed on your 
computer. Previewing any PDF in Acrobat 9 or earlier versions might not work correctly.
TIP: To view a merged Help system from the master project local copy, copy the subproject WebHelp files 
to the master project mergedProject\[project name] folder. Right-click the layout in the Single Source 
Layouts pod. Select View. Do not use the Republish All option in the master project.

View compiled Microsoft HTML Help

1) In the Single Source Layout pod, right-click Microsoft HTML Help.
2) If prompted, click Yes if you want to update the output. Otherwise click No.

NOTE: To see inbound and outbound links by topic, select Project > Open > Pods > Link View.

RELATED LINKS:
View topics and design elements

Help Viewer Wizard

Generate an AIR Help viewer

1) Select Tools > Open > Toolbox.
2) Double-click to start Help Viewer Wizard.
3) Specify the required information.

NOTE: Just select the path for the file and enter any name as the file name.
4) Specify a version number and an ID.
5) Create a self-signed digital certificate. See Create a self-signed digital certificate.
6) Click Finish.

Copy the Help content file

1) Copy the Help content file (RHA) to your computer. It can be in any location, but the installer needs 
to remember the location.
See Select Help output for information about how an RHA file is generated.

Install the Help application

The AIR Help viewer is an AIR file that installs the Help application.
1) Go to the C:/Program Files/[folder name].
2) Double-click the AIR file.
3) Go to the same folder and double-click the EXE file.



440

GENERATE, VIEW, AND PUBLISH OUTPUT
CHAPTER 12 GENERATING OUTPUT

Create and locate a Help content configuration file

The AIR Help viewer must be associated with the Help content file to display content in the selected 
format. Create an XML file with a .helpcfg extension to associate the RHA file with the AIR Help viewer. 
Save the file at the same location as the installed AIR file. The AIR Help viewer uses the .helpcfg file to 
locate the path to the Help content file and then displays the Help content.

Repeat the XML code for every Help file that you want to display with the Help viewer.

For example, an XML file that contains the Help content configuration contains the following line of code:
<?xml version="1.0" encoding="utf-8" ?> 
<contents> 
<data id="" label="" onlineurl="" offlineurl=""/> 
</contents>

NOTE: The name of the .helpcfg file can be set to any name. The name does not need to match the name 
of the .air or .exe file in the installation folder.

Publish output

You can publish output for WebHelp and FlashHelp projects. After you specify an output location, publish 
the output whenever needed. Publish multiple versions of a project (including to multiple locations) 
using batch-processing.

You can select to publish only the files that changed since they were last published.
1) In the Single Source Layouts pod, right-click the layout and select Properties.
2) Do the following:

– (WebHelp) Click Publish.
– (FlashHelp) Click Next until the Publish dialog box appears.

3) Specify a publishing destination by doing one of the following:

Attribute name Attribute value

ID The unique string that distinguishes a Help data file from other Help 
data files in the viewer. You can use this ID to call the CSH API or to start 
the AIR Help viewer.

label The label for Help content when the Help viewer contains multiple Help 
data files. The Help viewer displays this string in the selected Help 
content.

onlineurl The online URL of the Help content that is hosted on a server.

offlineurl The offline location of the Help file if locally installed Help is available.

useoffline Optional setting. If you set this attribute to “true,” the AIR Help viewer 
picks offline Help content when you launch the Help application. If no 
offline Help is available, then you don’t need this attribute in the Help 
content configuration file.
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– Select or edit an existing destination from the Servers box, set options as necessary, and click 
Save.

Check For Deleted Files
If selected, RoboHelp HTML checks for files that have been deleted from the destination location 
and republishes them.

Prompt Before Overwriting Files
If selected, RoboHelp prompts you before overwriting files.

Republish All
Select to republish all files to the destination target. For master projects with a copy of the 
subproject in the subfolder, do not select Republish All. You then avoid overwriting output files 
already published to the same location.

NOTE: If you change the destination to a new host, specify the user ID and password and save the pass-
word in the registry, if necessary.

– To specify a new destination, click New. Type a descriptive name and set options as necessary. 
Click OK.

Merging Help Systems
To publish a subproject to the MergedProjects folder, specify the following information:

• In Host Name, enter the IP address or URL.
• In Server Directory, enter the path to the master project: /.../[master 

project]/MergedProjects/[subproject]. This path resides on the server after the 
master project is published.

Options
Options depend on the selected connection protocol.

Server Name
Server on which to publish files. You can use an IP address.

User ID
Specifies the user ID to connect to the host.

Password
Specifies the password for the user ID. The network system administrator can provide this informa-
tion.

Save Password
Saves the password so you do not need to enter it when you publish the files. (Saving the password 
enters the password into the registry. It is not encrypted.)
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Port
Port to use when connecting to the host.

Anonymous User
Publishes the files as an anonymous user that does not require a password. If you supply a pass-
word or other anonymous information such as an e-mail address, deselect this option. Type Anon-
ymous in the user ID box, and type a password in the Password box.

Server Directory
Specifies the destination directory on the server. The default is a forward slash.

Web Name
The name of a FrontPage Web on the server selected in Host Name. (No initial slash is required for 
subwebs.)

NOTE: Web Name is used only if FrontPage Server Extensions are installed on the server. Otherwise, the 
files are published to the server directory specified using FTP://.

Destination Path
(HTTP protocol) Path to the location to publish the files.

4) In the Single Source Layouts pod, right-click the layout, and select Publish. If prompted, choose 
whether to generate and include changes before publishing.

5) Click Close.

View the output from the server to see changes and server-dependent features.

Generate and publish output from the command prompt

Command-line generation publishes layouts without opening RoboHelp, or automatically in a scheduled 
batch. Command-line and batch generation and publishing can occur simultaneously.
NOTE: To access the command prompt from within RoboHelp, click Start > Programs > Adobe RoboHelp 
[version]> Tools > RoboHelp Command Prompt.

Open the application from the command prompt

1) At the command prompt, enter the command in the following format:
rhcl myproject\myproject.xpj

2) Access the output files in the default output folder.

Generate layouts from the command prompt

• To generate a single layout to the default output folder (!SSL!), enter the command in the following 
format:
rhcl [project path] [-l] [layout name]

• To generate a single layout to a custom output folder, enter the command in the following format:
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rhcl [project path] [-l] [layout name] [-o] [path of custom output folder]

• To generate all layouts to the default output folder (!SSL!), enter the command in the following 
format:
rhcl [project installation path] [-b]

• To generate all layouts to a custom output folder, enter the command in the following format:
rhcl [full or relative path of the RoboHelp project] [-b]

Publish layouts from the command prompt

1) Enter the command in the following format:
rhcl [project path] [-p] [server name][user name][password]

The server name, user name, and password are optional.

Command prompt options

Commands must start with rhcl and include the project path and name. Enter commands using the 
following format:

rhcl [-?] [-h] [project path] [-l] [layout name] [-p] [server name:user 
name:password] [-o] [output folder path] [-d] [-b] [-g]

Not all options are required when entering a command.

-l
Generates a layout. Specify the layout name (for example, -l FlashHelp). The application generates 
the primary layout if a layout is not specified.

-p
Publishes a layout. Configure all publishing destinations using the New Destination dialog box.

“
Indicates spaces.

-o
Sends the output to a folder.

-d
Displays layout and publishing destination names at the command prompt.

-b
Generates the layouts set for batch generation. Outputs to the output folder for a particular 
single-source layout.

-h
Displays Help.

• rhcl
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• rhcl -h

• rhcl -?

-g
Specifies a log filename.

If you specify this option with the rhcl command, rhcl writes the output into the specified log 
file. The output is not sent to the console. The specified log filename cannot contain Unicode char-
acters. If a file by this name exists, that file is overwritten.

Hosting updates for AIR Help

After you publish your initial Adobe AIR application, you can correct and revise the content as needed. 
By default, when a user launches the Help application, it displays the online content, so the displayed 
Help contains your updates.

When you generate a new version of an Adobe AIR application, a Help content configuration file is 
created along with the output. This XML file is unique for each version of the Help application. It contains 
information about the location of the published Help application, the Help ID, and the version number. 
Place this XML file with the Help application installer on the specified shared server location for users. 
When a user’s installed version checks for updates from this location, the Help application is updated.

Create and host an update

1) Right-click Adobe AIR in the Single Source Layouts pod, and select Properties.
2) Specify the updated information for your Help content.

Since you are updating existing Help content, retain the Help title and Help ID of the Help output you 
configured earlier, but update the version number.

3) In the Adobe AIR dialog box, select the View group and select Enable Auto Update, if it is not 
enabled already.

4) Specify the location of the updated Help content configuration file (XML file) that is hosted on a 
shared location or web server.
To distribute Help updates within your network, select the file path. To distribute outside the net-
work, select a web server location.

5) Update any other parameters you require, such as resource tabs.
6) Generate the Help output formats.
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Post an update

You can post an update for the Adobe AIR application at the specified web server address (HTTP location) 
or in the network folder.
1) Generate Help and then post the updated Help application installer and the associated XML file to 

the web server or folder.

Distribute the project output

After you create and test the project output, you distribute it to the developer or publisher. The output 
you deliver depends on the project. By default, the output for distribution is in the project subfolder. (For 
Microsoft HTML Help, the output is compiled into a single CHM file.)

Some RoboHelp tools provide Help functions through DLL and OCX files. Be sure to distribute these files. 
They must be included with the installer for the Help system.

DLLs required by a RoboHelp application are listed in application Help. Redistributables are listed in 
Redistrb.Txt in the Redist folder in RoboHelp [version] Program Files.
NOTE: Add the output to version control to provide accessibility to others.

Distribute Multiscreen HTML5 output

When a Multiscreen HTML5 Help system is published to a central server/location, only information rele-
vant to the current query is downloaded to the Web browser on user computers. If necessary, you can 
also choose to store the Help system locally on user computers.

By default, all Multiscreen HTML5 output files are placed in the !SSL!/Multiscreen_HTML5 project 
folder. It is recommended that you do not rename or move any subfolders under this folder.
• To distribute Multiscreen HTML5 Help with an application, copy the Multiscreen_HTML5 folder 

and its contents to a location designated by the developer. Let the developer know the name of the 
start page (HTM file).

• To publish Multiscreen HTML5 files to a server, website, or other network location, publish subproj-
ects to the correct folder in the MergedProjects subfolder. While manually copying the subproj-
ects to the MergedProjects subfolder, overwrite all the files—including 
screendata.js—except for the file parentdata.js, which should come from the parent 
project.

• While distributing standalone Multiscreen HTML5 Help, copy the Multiscreen_HTML5 folder 
and its contents to a CD, server, or a location on user computers. Let your users know which start 
page (HTM file) they should select to view the Help system.

• When publishing Help for a single screen profile, generate Multiscreen HTML5 output only for the 
particular screen profile. Do not copy and use the screen profile folder independently.

Output files in the Multiscreen_HTML5 folder

When you publish Multiscreen HTML5 output, the following output files are created in the project 
subfolders:
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NOTE: Do not import Multiscreen-HTML5-generated HTM files into the project. These HTM files are only 
for runtime use.

Output files in the Screen Profile folder

Files in this folder are specific to the screen profile. This folder also contains the generated topic files.

Output files in the whxdata folder

Files in this folder contain project data for various components.

Subfolders in the template folder

This folder contains resources including images, icons, and cascading stylesheets.

File Description

index.htm Default file name of the start page

parentdata.js Information about the parent project; blank if the project has no parent 
project

screendata.js Information about screen profiles

access_cookies.htm Used for reading/writing Internet Explorer cookies

File Description

index.htm Start page for the screen profile

projectdata.js Information about subprojects

ehlpdhtm.js JavaScript for advanced functionality, such as Dynamic HTML effects

File Description

csh.js Context-sensitive Help data

glo.js Glossary index data

gdata1.js Glossary definition data

idx.js Index of index data

idx1.js Index data

toc.js TOC data

whfts_xml.js Full-text search index data

window.js Window data
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Distribute eBook output

Distribute the following files generated in the eBook subfolder in the !SSL! folder of your project:

<project_name>.mobi
This output supports Kindle Format 8 and can be viewed on Amazon Kindle devices.

<project_name>.epub
This output can be viewed on a variety of devices and readers, including iBooks on iOS and Aldiko 
on Android.

Distribute WebHelp

For Help systems published to a central location, only the information relevant to the current inquiry is 
downloaded to user browsers. The system can also be stored locally.

By default, all WebHelp output files are placed in a project subfolder (!SSL!/WebHelp). The WebHelp 
folder includes subfolders. Do not rename or move any of these folders.
• To distribute WebHelp with an application, copy the WebHelp Folder and its contents to a location 

designated by the developer. Let the developer know the name of the start page (HTM file).
• To publish WebHelp files to a server, website, or other network location, publish subprojects to the 

correct folder in the MergedProjects subfolder.
• When distributing WebHelp as a stand-alone product, copy the WebHelp folder and its contents to 

a CD, a server, or any location on user systems. Let users know which start page (HTM file) to select 
to view the Help system.

Output files in the WebHelp folder

Generating WebHelp creates the following output files in subfolders of the project folder.
NOTE: Do not import WebHelp-generated HTM files into the project. They are for runtime uses only.

Folder Description

scripts JavaScript files for the various widgets used

resources Default resources

<Screen profile folder> Resources specific to the screen profile

File Description

cshdat_robohelp.htm Data for context-sensitive Help

cshdat_webhelp.htm Legacy support for context-sensitive API

default.css Style sheet
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default.skn Default skin

EHLPDHTM.JS JavaScript for advanced functionality such as Dynamic HTML effects

.GIF files Images for skins, navigation, and browse sequences

NewProject.htm Project start page

NewProject.log Lists all necessary files

NewProject_csh.htm Legacy support for context-sensitive API

NewProject_rhc.htm Supports context-sensitive API

webhelp.jar Supports applet-based WebHelp

whestart.ico Internet Explorer Favorites menu icon

whfbody.htm Full-text search lower pane

whfdhtml.htm Full-text search frameset

whfform.htm Full-text search upper pane

whfhost.js JavaScript for full-text search

whform.js Index and full-text search fields

whframes.js Framesets

whgbody.htm Glossary terms

whgdef.htm Glossary definitions

whgdhtml.htm Manages glossary terms and definitions

whghost.js Supports glossary

whhost.js Lists and loads files in index and glossary

whibody.htm Index lower pane

whidhtml.htm Index frameset

whiform.htm Index upper pane

whihost.js Supports index

whlang.js Language support

whmozemu.js Netscape Navigator functions

whmsg.js Message type definition and structure

whnjs.htm Displayed when JavaScript disabled

File Description
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Output files in the Whgdata subfolder

Files in !SSL!\Webhelp\Whgdata are used with Pure HTML WebHelp.

whphost.js Determines project contents

whproj.htm Project data

WHPROJ.JS JavaScript that supports WHPROJ.HTM

whproj.xml XML project data

whproxy.js Framework support

whres.xml Applet support (custom fonts and colors)

whskin_banner.htm For logo dialog box- About author (skins)

whskin_blank.htm Internal support file (same as _blank.htm) (skins)

whskin_frmset01.htm Frameset separating navigation pane, navigation bar, and topic (skins)

whskin_frmset010.htm Frameset separating navigation bar and navigation pane (skins)

whskin_info.htm System information page (skins)

whskin_mbars.htm Supports navigation bar (skins)

whskin_papplet.htm Navigation pane for applet (skins)

whskin_pdhtml.htm Navigation pane for Dynamic HTML (skins)

whskin_plist.htm Navigation pane for Pure HTML

whskin_tbars.htm Toolbar (skins)

whst_topics.xml Parses topics during generation

whstart.ico WebHelp icon

whstart.js Supports start page

whstub.js Framework support

whtbar.js Supports navigation bar

whtdhtml.htm TOC body

whthost.js Supports TOC

whtopic.js Supports in-topic navigation bar

whutils.js Supports common functions

whver.js Determines browser version

File Description
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Output files in the Whdata subfolder

Files in !SSL!\Webhelp\Whdata are for DHTML versions of WebHelp on older browsers.

File Description

whexpbar.gif Sets default navigation pane width

whlstf0.htm Full-text search body

whlstfl0.htm Level 2 full-text search letters

whlstg0.htm Glossary terms

whlsti0.htm Index terms

whlstt0.htm Contents (part 2)

whlstt1.htm Contents (part 2)

whnvf30.htm TOC frame

whnvf31.htm Index frame

whnvf32.htm Full-text search frame

whnvf33.htm Glossary frame

whnvl31.htm Level 1 index letters

whnvl32.htm Level 1 full-text search letters

whnvl33.htm Glossary letters

whnvp30.htm TOC navigation pane

whnvp31.htm Index navigation pane

whnvp32.htm Full-text search navigation pane

whnvp33.htm Glossary navigation pane

whnvt30.htm TOC tabs

whnvt31.htm Index tabs

whnvt32.htm Full-text search tabs

whnvt33.htm Glossary tabs

File Description

whftdata0.htm Full-text search data - HTML support

whftdata.js Full-text search data - JavaScript supporting WHFDATA0.HTM
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Output files in the Whxdata subfolder

Files in !SSL!\Webhelp\Whxdata are used in Java applet and DHTML versions of WebHelp on newer 
browsers.

whftdata0.xml Full-text search data - XML support

whFull-text search.htm Full-text search index data - HTML support

whFull-text search.js Full-text search index data - JavaScript supporting whFull-text 
search.htm

whFull-text search.xml Full-text search index data - XML support

whfwdata0.htm Full-text search keywords - HTML support

whfwdata.js Full-text search index data - JavaScript supporting whfwdata0.htm

whfwdata0.xml Full-text search keywords - XML support

whgdata.js Loads glossary term definitions

whGlossary.htm Glossary index data - HTML support

whGlossary.js Glossary index data - JavaScript supporting whGlossary.htm

whGlossary.xml Glossary index data - XML support

whidata0.htm Index data for non-XML browsers

whidata.js JavaScript supporting WHIDATA0.HTM

whidata0.xml Index data - XML version

whidx.htm Index of index data - HTML support

whidx.js Index of index data - JavaScript supporting whidx.htm

whidx.xml Index of index data - XML version

whtdata0.htm TOC data - HTML support

whtdata.js TOC data - JavaScript supporting whtdata0.htm

whtdata0.xml TOC data - XML support

whtoc.htm TOC index of TOC - HTML support

whtoc.js TOC index of TOC - JavaScript supporting whtoc.htm

whtoc.xml TOC index of TOC - XML support

File Description
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Distribute FlashHelp

By default, all FlashHelp output files are placed in a project subfolder (!SSL!/FlashHelp). When you 
generate FlashHelp, you can specify the name of the folder where the FlashHelp source files are located, 
and the name of the start page.

If the project includes subfolders, the FlashHelp folder includes these subfolders with the files in them. 
Do not rename or move any of these folders to keep the project structure intact.

Distribute FlashHelp with an application

1) Copy the FlashHelp Folder and its contents to a location designated by the developer. Let the devel-
oper know which .htm file is the start page.

Publish FlashHelp to a disc, server, or desktop

1) Let users know which start page (.htm file) to select to view the Help system.

Output files for FlashHelp

Output files are created when you use RoboHelp to generate FlashHelp. During project generation, 
output files are saved by default in a subfolder named FlashHelp.

Output files in the FlashHelp folder

File Description

whftdata0.xml Full-text search data

WHFTS.XML Full-text search index data

WHFWDATA0.XML Full-text search keywords

WHGDATA0.XML Glossary definition data

WHGLO.XML Glossary index data

WHIDATA0.XML Index data

WHIDX.XML Index of index data

WHTDATA0.XML TOC data

WHTOC.XML TOC index of TOC

File Description

cshdat_WEBHELP.htm Legacy support file for context-sensitive API

*.css Style sheet
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Output files in the whgdata subfolder

*.FHS FlashHelp skin file

WF_TOPICS.CSS Style sheet for customized topic scroll bars. Generated based on 
settings in FlashHelp skin

EHLPDHTM.JS Contains JavaScript functions that RoboHelp uses for advanced 
functionality such as Dynamic HTML effects

.GIF files Images for skins, navigation, and browse sequence images

<ProjectName>.htm Project start page

<ProjectName>_csh.htm Legacy support file for context-sensitive API

<ProjectName>_rhc.htm Context-sensitive Help API support file

wf_favicon.ico Icon for Favorites menu in Internet Explorer

WF_*.HTM FlashHelp run time FLA files

SKIN_*.SWF Skin files

WFRES.XML Localization file (generated from LNG file) that contains all strings 
loaded into FlashHelp at run time

WHPROJ.XML Project file used by the DHTML version of FlashHelp to load navigation 
data

whmozemu.js Functions supported in Netscape Navigator

WF_MASTER.JS JavaScript file required for FlashHelp run time

wf_dispatcher.js JavaScript file required for FlashHelp run time

whtopic.js Topic support file (In-topic navigation bar)

whutils.js Utility file for common functions

whver.js Determines browser version

File Description

whexpbar.gif Used to size default navigation pane width

whlstf0.htm Body of full-text search

whlstfl0.htm Letters for full-text search level 2

whlstg0.htm Glossary words list

File Description
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Output files in the whxdata subfolder

The output files in !Sl!\Flashhelp\whxdata are XML data files used in Java applet and DHTML versions of 
FlashHelp running on later browsers.

whlsti0.htm Index words list

whlstt0.htm Contents list part 1

whlstt1.htm Contents list part 2

whnvf30.htm TOC frame

whnvf31.htm Index frame

whnvf32.htm Full-text search frame

whnvf33.htm Glossary frame

whnvl31.htm Index letters level 1

whnvl32.htm Full-text search letters level 1

whnvl33.htm Glossary letters

whnvp30.htm TOC navigation pane

whnvp31.htm Index navigation pane

whnvp32.htm Full-text search navigation pane

whnvp33.htm Glossary navigation pane

whnvt30.htm TOC tabs

whnvt31.htm Index tabs

whnvt32.htm Full-text search tabs

whnvt33.htm Glossary tabs

File Description

whftdata0.xml Full-text search data file

WHFTS.XML Full-text search index data file

WHFWDATA0.XML Full-text search keyword data

WHGDATA0.XML Glossary definitions data file

WHGLO.XML Glossary index data file

WHIDATA0.XML Index data file

File Description
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NOTE: Do not import FlashHelp-generated HTM output files into the project. They are used for runtime 
purposes only.

Distribute Microsoft HTML Help

1) Distribute the following system Help files to the developer for installation with the program execut-
able (EXE) file. Or, distribute the files for stand-alone use.
NOTE: Users can run stand-alone Microsoft HTML Help by double-clicking the CHM file in Windows 
Explorer.

CHM
A single distributed Help system in a single Help file, in addition to any CHM files for subprojects to 
the master project. These child CHM files aren’t compiled into the master CHM.

HLP, CNT
If the project includes links to topics in a compiled WinHelp file, distribute the HLP and CNT files. 
They are not compiled into the master CHM file

2) The application developer distributes the following support files, depending on the features used 
in the project and the versions of Windows that users have.
– Microsoft HTML Help Support Files Built-in components.
– HHActiveX.DLL is an Adobe ActiveX control that provides support for online glossaries and 

browse sequences. Install and register the HHActiveX.DLL file on user systems. Copy this file 
from C:\Program Files\Adobe\Adobe RoboHelp [version]\RoboHTML into the same folder as 
the CHM.

– If the Help system includes third-party ActiveX controls, install and register the component 
support files for the user systems. Users copy the ActiveX control files into a custom folder, 
placing the path for the alternate folder before the .ocx or .dll extension, and then register 
the files.

NOTE: The Adobe licensing agreement lets you redistribute Microsoft HTML Help and Internet 
Explorer files with the HTML Help output.

WHIDX.XML Index of index data file

WHTDATA0.XML TOC data file

WHTOC.XML TOC index of TOC file

File Description
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Register ActiveX controls

If the project provides ActiveX controls, provide these instructions to users so they can register the 
controls that you distribute with the Help system.
1) Click Start and type cmd in the search box.
2) In the search results, right-click cmd.exe in the Programs list and click Run as administrator in the 

pop-up menu.
NOTE: If you get the User Account Control prompt, click Yes to continue.

3) To register the HHActiveX.DLL file, type the following command in the command prompt, specifying 
the HHActiveX.DLL path, and press Enter:
regsvr32 [path] hhactivex.dll

4) To register third-party ActiveX controls, type the following command and press Enter:
regsvr32 [activex_name.dll or activex_name.ocx]

5) Close the command prompt window.

RELATED LINKS:
Create a project

Manage files

ActiveX controls

Distribute JavaHelp

Distribute the following files and components:
• If the project is compressed, distribute the JAR file.
• If the project is not compressed, distribute all source files in the output folder.
• JavaHelp 1.1.3 or later components.
• Java Runtime Environment file (JRE), or have users download it from the Sun website.
• If the project contains related topics buttons, distribute the Bsscjhrs.jar file.

Output files for JavaHelp

Output File Description

.HS HelpSet file. Points to a set of map files and defines associated 
navigational views (TOC, index, and search).

.JAR Compressed JavaHelp file (optional) containing all project output.

default.css Default cascading style sheet file applied to all project topics.

projectname_ndx.xml Index file describing content and layout for the index view.

projectname_map.xml Map file associating Help topic IDs to HTML files with relevant content, 
and Window Types. Used in the API for context-sensitive calls, TOC, and 
index.
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Distribute Oracle Help

When you generate the output, you can compress all source files into a single JAR file. The JAR file is used 
for software application Help, and for distribution as a stand-alone product.
1) Include the following components when you distribute Oracle Help:

– If the project is compressed, the JAR file
– If the project is not compressed, all files and subfolders in the OracleHelp output folder
– JavaHelp 1.1.3 or later components
– Java Runtime Environment (JRE) or Java Development Kit (JDK)

Output files for Oracle Help

Distribute XML output

During generation, CSS, XSL, XML, HTM, and GIF output files are created in a subfolder in the project 
folder. Other files include the following:

projectname_toc.xml TOC file describing content and layout for the TOC view.

File Description

.HS HelpSet file. Points to a set of map files and defines associated 
navigational views (TOC, index, and search).

.JAR Compressed Oracle Help file (optional) containing all project output.

default.css Default cascading style sheet file applied to all project topics.

Projectnumber_fts.idx Full-text search file containing the full-text search database.

Projectnumber_nd.xml Index file describing content and layout for the index view.

Projectnumber_lnk.xml File containing associative links (See Also controls) to topics associated 
with See Also keywords.

Projectnumber_map.xml Map file associating Help topic IDs to HTML files with relevant content, 
and Window Types. Used in the API for context-sensitive calls, TOC, and 
index.

Projectnumber_toc.xml TOC file describing content and layout for the TOC view.

Output files In XML_Output folder Description

EHLPDHTM.JS Contains JavaScript functions for advanced 
functionality

Output File Description
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RELATED LINKS:
View output

Distribute Adobe AIR output

Distribution of Adobe AIR output depends on the output type you select.

Configure FlashPlayerTrust to run local browser-based Help

To run browser-based Help from a local drive, the installation folder must be added in the list of trusted 
folders defined in the RoboHelp.cfg file in the FlashPlayerTrust folder.
1) Select Start > Run.
2) Type %appdata%\Macromedia\Flash Player\#Security\FlashPlayerTrust\ and 

click OK.
3) Open the RoboHelp.cfg file in a text editor.
4) Add the path to the local folder in which the browser-based Help files are stored.

NewProject.htm Project start page

NewProject.log Output file that lists all necessary files

Output type File(s) to distribute
Required on user 

computers

Adobe AIR Application AIR (.air) file generated in the output 
location

AIR Runtime
See Adobe AIR Runtime 
Distribution

Browser Based Help All files generated in the output folder
When distributing browser-based Help 
as a standalone Help system, copy the 
output folder and its contents to a CD, a 
server, or any location on user systems. 
Let users know the start page (HTM file) 
to select to view the Help system.

Flash plug-in 9.0 or later
See Configure 
FlashPlayerTrust to run local 
browser-based Help.

AIR Application And 
Browser Based Help

Separately distribute:
AIR (.air) file generated in the output 
location
All files generated in the output folder

AIR Runtime
Flash plug-in 9.0 or later

Help Content Only RHA (.rha) file generated in the output 
location

AIR Runtime

Output files In XML_Output folder Description

http://www.adobe.com/products/air/runtime_distribution1.html
http://www.adobe.com/products/air/runtime_distribution1.html
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Moderator password and configuration file path

When you distribute Adobe AIR output, make sure that you share the moderator password and configu-
ration file path that you specified while generating the output.

Organizations deploying the output need the password to enable moderation and allow moderators 
access to the moderator dashboard.

They also need the configuration file path to save the configuration file after configuring comment 
syncing and auto-update according to their preferences. If the configuration file path is relative, the same 
AIR Help file can be installed in different locations with different configurations.

Configuration file attributes

Organizations deploying AIR Help can now configure commenting and auto-update according to their 
preferences. Copy the default configuration file from the !SSL folder of the project to the location speci-
fied in the configuration file path and modify the default settings.

The configuration file contains the following settings:

config topicrating
Enables or disables topic rating. Valid values are yes or no.

commentsync:
Enables or disables commenting. Valid values are yes or no.

updatecommentlocation:
Specifies the path that AIR Help uses to synchronize comments when an OS-specific update 
comment location is not specified.

windowsupdatecommentlocation:
Specifies the shared location on Windows computers where comments are to be stored and 
synced.

macupdatecommentlocation:
Specifies the shared location on MAC OS computers where comments are to be stored and synced.

linuxupdatecommentlocation:
Specifies the shared location on Linux computers where comments are to be stored and synced.

marknewcommentsaspending
Specifies if new comments should have the status ‘Pending’ or ‘Accepted’. Valid values are yes or 
no.

NOTE: Pending comments have to be moderated before users can see them.

autoupdate:
Enables or disables auto-updating. Valid values are yes or no.
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windowsupdatexmllocation:
Specifies the location of the auto-update XML file on Windows computers.

macupdatexmllocation:
Specifies the location of the auto-update xml file on MAC OS computers.

linuxupdatexmllocation:
Specifies the location of the auto-update xml file on Linux computers.

updatexmllocation:
Specifies the location of the auto-update xml.

NOTE: RoboHelp checks for this attribute before checking for the OS-specific updatexmllocation attribute. 
If this attribute is present, RoboHelp does not check for OS-specific updatexmllocation attributes.

logoimage:
Specifies the location of the image file that will be used to display a logo in AIR Help.

companytext:
Specifies the company name that is displayed in the status bar of AIR Help (for example, Powered 
By Adobe RoboHelp).

URL formats for Windows, Mac, and Linux

While configuring the Adobe AIR Application collaboration settings, specify the paths in the following 
formats:

About modifying the status of new comments

Authors set the status of new comments to Pending or Accepted at the time of generating Adobe AIR 
output.

Users can access the settings.xml file present in the network location for storing and syncing 
comments and change the default status of new comments. If the status is set to Pending, new 
comments have to be moderated. Otherwise, new comments are accepted without moderation and 
displayed to users.

Windows Mac Linux

File on 
hard disk

file:///C:/config.xml file:///Applications/config.xm
l

file:///etc/config.xml

File on 
network 
drive

file:////robohelpserver/
config.xml

file:///Volumes/robohelpserv
er/config.xml

file:///media/robohelpserve
r/config.xml
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Printed documents

About printed documents

Online output and printed documents share source files. Similarly, you can generate PDF files and print 
documents from the same source files.

Organize and customize content

Design a printed document based on only part of the project or the entire project. Determine where 
topics go in the document by arranging the pages and books during generation. Base printed document 
structure on the project TOC or select topics from custom folders in the Project Manager.

Map project styles to Word

Control how styles are used in printed documents with style mapping. Copy project styles directly to a 
Word document. Any applied project style retains the style in Word. You can alternatively skip style 
mapping and use topic styles.

Types of Word documents to create

Individual documents
Separate Word files for the title page, table of contents, glossary, and index. A separate document 
is also created for each root-level book (chapter) and page in the printed table of contents.

Master document
An optional document that links to the individual documents. Familiarity with master documents 
in Word is recommended. Do not edit this file; it contains only field codes referencing the docu-
ments. Do not use a master document for large manuals.

Single document
One Word file containing the title page, TOC, chapters, glossary, and index.

Printed document structure

• Books and pages at the root level of the printed document begin a new chapter.
• Subbooks and pages that are not at the root level of the printed document continue uninterrupted.
• Pages that link to a destination other than a topic are not available to use in the printed document.
• Organize sections of the printed documentation output in the Section Layout dialog box.

Conversion of online features

RoboHelp converts many common project features. It removes others, including ActiveX controls, 
borders, Dynamic HTML, headers and footers, JavaScript, link controls, and topic borders. The following 
table provides conversion details for specific features.
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Page setup

RoboHelp assigns default page settings to the printed documentation in Microsoft Word.

Body page settings

Starting Page
All documents start on an odd-numbered page. If the document ends on an odd-numbered page, 
a blank page is added at the end of the document. The blank page lacks a header, footer, or page 
number.

Feature Conversion notes

Bullets and numbering Converted (except image bullets).

Conditional build tags Topics and topic content that are excluded with 
conditional build tags and expressions are 
removed.

Drop-down hotspots and expanding hotspots If specified, expanding text and drop-down text 
appears inline. Map a style to hotspots so that 
they look different from the other text.

Expanding glossary hotspots Selecting expanding text and drop-down text in 
the printed output converts and displays inline. 
Map a style to hotspots so that they look 
different from the other text.

Font sets Word uses the first font. If the first font does not 
exist, Word creates a default font.

Forms Converted to HTML in Word. Third-party forms 
are removed from documents.

Images Specify whether you want to place or embed 
images. Placed images are included in an images 
folder in the output folder. Embed images if you 
want to place them within the document. Images 
can be included in headings, and then they also 
appear in the printed TOC.

Marquees Converted as text in Word.

Positioned text boxes Converted and placed at the end of the 
document or the bottom of the page.

Shading Fills but not patterns are converted.

Text boxes Converted and resized to fit text only.



463

PRINTED DOCUMENTS
CHAPTER 12 GENERATING OUTPUT

Headers
Headers repeat at the top of each page and are blank on the first page of sections. The name of the 
document appears on even-numbered pages, left-justified. The name of the root chapter appears 
on odd-numbered pages, right-justified.

Footers
Footers repeat at the bottom of each page and contain page numbers. Page numbers are left-justi-
fied on even-numbered pages and right-justified on odd-numbered pages.

Page Numbers
Page numbers are located in footers and are generally Arabic (1, 2, 3, and so on). The TOC docu-
ment uses lowercase Roman numerals (i, ii, iii, and so on).

Additional settings

To create Microsoft Word documents, note the following details for the source files and set them up 
accordingly.

Title page

• The title page uses settings from the document.
• Specify a default title page when you generate the printed documentation.
• The name of the document (which appears on the title page) is the printed document name you 

define in the Print Document General dialog box. This dialog box appears when you double-click the 
Printed Documentation layout.

• The header and footer are blank.
• The title page contains no page number.
• The title page document uses the style TitlePageTitle that is copied to the Word document.
• When you add the file, copy it to the project folder if you want RoboHelp to generate a copy in the 

output folder.

Table of contents

• The TOC is based on the heading levels of topic titles and the printed document structure hierarchy. 
You can define the printed document structure in the Print Document Content dialog box.
NOTE: You can also create a TOC from the Project Manager. Right-click a topic in the TOC pod, and 
choose Auto-Create TOC. Topics from the Project Manager are automatically promoted or 
demoted in heading style depending on their placement in the printed document structure.

• Most TOCs have multiple levels of headings, showing a hierarchy, or structure, of information to 
help users find information more quickly.

• TOC 1 – 9 are the styles used for TOC entries.
• Table Of Contents Page Title is the style used for the title of the TOC.
• Page numbers for the TOC document are lowercase Roman numerals (i, ii, iii, and so on).
• The filename is Chapter_00_Table_Of_Contents.doc.
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Chapters

• Chapter files contain the topics you specified in the Print Document Content dialog box. Root-level 
topics and books create new documents (except if you select the Single Document option when you 
generate).

• Page numbers for chapter documents are Arabic (1, 2, 3, and so on).
• The filename is Chapter_{##}_{Book or Page Name}.doc.

Glossary

• The glossary is based on the terms and definitions in the project. If no terms and definitions exist 
in the project, a glossary document is not generated.

• The glossary document uses three styles that are copied to the Word document:

Glossary Heading
The style used for the header letters (A, B, and so on). If the project has a specified language, the 
header letters are localized in that language.

Glossary Label
The style used for the glossary terms.

Glossary Definition
The style used for glossary definitions. Definitions appear on the same line as terms, with a hanging 
indent for subsequent lines.

• Page numbers for the glossary document are Arabic (1, 2, 3, and so on).
• By default, the filename is Chapter_{##}_Glossary.doc. ## is the number after the last chapter 

number.

Index

• The index is based on the keywords and subkeywords in the project. Topic keywords are included 
only if the associated topics are generated in the output.

• Index styles are based on the style Index Heading and Index 1-9 in the Word template you select for 
the printed documentation.

• By default, the index is indented with two columns. If the project has a specified language, the 
header letters are localized in that language.

• Page numbers for the index document are Arabic (1, 2, 3, and so on).
• The filename is Chapter_{##}_Index.doc. ## is the number after the glossary chapter number. If the 

document contains no glossary, it is the number after the last chapter number.

Accessory pages

• An accessory page, such as an acknowledgment, appendix, foreword, or copyright, retains its orig-
inal formatting.
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• When you add the file, you can copy it to the project folder. A copy is also generated in the output 
folder.

• Add new sections using the Section Layout dialog box.

Images

You can handle images in these ways:

Embed In Documents
Keep images within the document. Embedding images creates larger DOC files that are not depen-
dent on outside image files.

Link To Documents
Reference the images outside the document (creates smaller DOC files that reference outside 
image files). Image files are copied and stored in the Images folder in the printed document output 
folder.

TIP: Images in heading styles are removed. Change settings to include images in headings.

Organize and customize document content

1) In the Single Source Layouts pod, double-click Printed Documentation.
2) In Printed Document General, set general options for the printed document.

Name
Specify the name of the document. This name is used in the document headers and on the title 
page.

Location
Specify the path for Word documents. PDF documents also are saved to this location. Creates the 
printed documentation files under !SSL!\[layout name] in the project folder. Click the Browse 
button to browse to a different folder. Click OK.

NOTE: Printed Word documentation supports both DOC and DOCX formats.

PDF Settings
Set PDF properties.

Settings
Select options for document files creation.

Generate Individual Documents
Create a separate Word file for each chapter and section of the document. A chapter is any book 
or page at the root level of the TOC specified in the Print Document Content dialog box.
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Generate A Single Document
Create one Word file that contains the title page, TOC, chapters, glossary, and index.

NOTE: If Generate Individual Documents is selected, click Create Master Document to enable viewing of 
all documents.

Retain Hyperlinks
Select to retain hypertext links.

Start Each Topic On A New Page
Select to create page breaks.

Images
Set image options.

Embed In Documents
Keep images within the document.

Link To Documents
Reference the images outside the document. Image files are copied and stored in an Images folder 
in the printed document output folder.

TIP: By default, images that are included in heading styles are removed. To select to include them, click 
the Advanced button and select Images In TOC.

Define
Click to specify conditional build expressions.

Content
Select TOC, index, and glossary to display in the generated Help.

Variable Set
Select a variable set for the printed document.

Advanced
Specify detailed TOC, glossary, and text options.

NOTE: If you apply inline formatting to a heading, the inline style does not appear in the document unless 
you select the Styles in TOC field. Note that the inline style then also appears in the document TOC.

In your printed documents, you can also print the header and footer.
3) To apply the header and footer to the printed document, select a master page to apply the 

header/footer to the whole document.
4) To apply multiple header footer combinations, such as for left and right pages, click Multiple 

Header/Footer and in the Multiple Header Footer Options dialog:
– BULLET_ITEM
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– BULLET_ITEM
– BULLET_ITEM

5) To restart page numbering on the first page of your print output’s first chapter, select Restart Page 
Numbering on First Chapter.

6) Click Next.
7) In Print Document Content, under Topics, click the pop-up menu to display and select topics.

Show All Topics
Displays all topics regardless of conditional build tags.

TOC
Displays all topics in TOC

Folder buttons
To show topics in the Project Manager pod, select the folder button for a custom folder, a Top Level 
Folder, or All Folders. (View topics by title or filename.)

8) Under Topics, select the topics to add and design the TOC.
Select Maintain HTML Heading Levels to disable automatic mapping. Heading style levels are re-
tained. If the printed document structure does not match the structure in the Chapter Layout col-
umn, rework it in Word.
Drag and drop topics from the left to the right. The topic icon on the left turns blue to indicate that 
the topic is added.
Topics excluded in the General dialog box using conditional build tags have a gray icon in the Chap-
ter Layout column.
Missing topics are displayed with a broken page icon .

9) Under Chapter layout, edit or reorganize the content.
To add a new book, click the New Chapter button. To move a book or page, click the arrow buttons.

Moves an item to a higher level in the TOC.

Moves an item to a lower level in the TOC.

Moves up an item up in the TOC.

Moves an item down in the TOC.

10) Click Next to set the section layout for the document.
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The Section Layout column displays the default sections. You can remove a section, and add topics 
or existing Word documents as new sections. You can also reorder the sections.

Click to remove a section.

Select a topic in the left column and click this icon to add the topic as a section.

Click to add a Word document as a section. Locate the file, select it, and click Open.

Click to edit in Word if the selected section is a Word document. The changes are included in the 
printed document.

Use the arrow buttons to position a section in the printed document.
11) Do one of the following:

– Select Next to map styles.
– Save changes.
– Select Finish to generate. When the PrintDoc.dot macro message displays, click Disable 

Macros to continue. When the PrintDoc.dot macro message displays, click Disable Macros to 
continue.

Notes:

• All Microsoft Word documents must be closed.
• Document content changes do not affect TOCs.
• TOCs updated in the TOC Composer do not affect the chapter layout.
• To use the updated TOC, click Remove All. Then click Add All.

Prepare for printed documents

Printed document organization

• Before generating, print a Table of Contents Report. Choose Tools > Reports > TOC. Place a check 
mark next to the topics for the printed document so that you can easily identify them when the 
document is generated.

• For large documents (over 700-800 pages), create individual documents. Place more books at the 
root level in the printed document structure to create more DOC files. Otherwise, the printed docu-
ment includes only several large files.
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Styles and formatting

Ensure that both project styles and template styles are ready for generating.

Apply styles to all topic text

Inline formatting does not map to styles in Word and is converted as inline formatting.

Embedded styles do not map into Word. They are converted to inline styles. If any topics use embedded 
styles, link an external style sheet to the topic and apply styles to the text.

Apply styles to topic headings

To treat topics as separate sections instead of continuing text, ensure that all topic headings have a 
Heading Style. Also place them at the root level of the printed document structure.

If a custom heading does not use the RoboHelp heading style names in the format Heading[number], 
the topic doesn’t appear in the TOC. To solve this problem, modify one of the RoboHelp heading styles 
with settings from the custom heading style.

Use styles consistently

Printed documentation maps styles in the project to styles in Word.

Select a template

• Custom template
• RoboHelp Style Mapping.dot template
• A Word default template

Add new styles to the template

Analyze project styles to see how they map to Word. Create new styles as necessary. Consider the 
following:

Character styles
Styles can be mapped only to template styles of the same type. Create a matching character style 
before generating. Mapping is easier when template and project style names match. For example, 
create Word character styles.

Conditional text

Define conditional build expressions to exclude topics or topic content from printed documentation. 
Excluded topics are denoted with a gray question mark icon  in the Print Document Content dialog box.

RELATED LINKS:
Define conditional build tag expressions

Single-source layouts

Use with conditional build tags to customize output and save the settings.
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Share style mappings from a printed documentation layout with other authors to ensure consistency. 
Import style mappings (ZPL file) into the project, or export mappings to another location.

Mapping styles

Mapped styles

Non-mapped styles are formatted as they appear in the Design Editor. Style maps are saved in a ZPL file.

Heading styles

For heading mapping to occur, a standard HTML heading style must be applied to topic titles. If custom 
heading styles aren’t named in the format Heading <number>, they are not treated as headings.

Heading styles are automatically mapped to Word heading styles. To disable automatic mapping, select 
Maintain HTML Heading Levels in the Print Document Content dialog box. Heading style levels are 
retained, regardless of their position in the Print Document Content dialog box.

RoboHelp considers the RoboHelp project style applied to the heading and the placement of the topic in 
the printed TOC hierarchy.

Generating a printed document TOC exactly like the project TOC creates Word documents with identical 
heading styles and an identical TOC hierarchy. When the hierarchy of the TOC changes, the automatic 
process takes over and assigns heading levels.
• Books and pages at the root level are always Heading 1. If the project heading style is lower (such 

as a Heading 2), it is adjusted up.
• Books and pages with Headings 2 – 6 are adjusted according to their level in the printed document 

structure and their project heading style. Different project heading styles are adjusted as needed.
• Books and pages with Headings 7 – 9 are automatically mapped to Word Headings 7 – 9 styles.
• Books that link to pages are treated like topics.

RoboHelp makes these heading adjustments when it creates the printed document TOC.

Paragraph styles
Paragraph styles can be mapped only to paragraph styles in Word. They apply to font attributes, 
line spacing, numbering, and borders and shading.

Character styles
Character styles can be mapped only to character styles in Word. They apply to font attributes.

Multi-level list styles
Multi-level list styles in RoboHelp can be mapped only to multi-level list styles in Word. The indi-
vidual levels of the multi-level lists are mapped automatically. For example, the style for the level 
3 items in the RoboHelp list are mapped automatically to the style for the level 3 items in the list in 
Word.
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Table styles
Table styles in RoboHelp can be mapped only to table styles in Word.

Embedded styles
Embedded styles that are not defined in the external style sheet are applied inline in the Word 
document. They are not available for global use.

Inline styles
Inline styles are applied inline in the Word document and are not available for global use in the 
template.

Unmapped styles

The following styles aren’t available for mapping:
• Background + Text (BODY). These style settings are applied inline.
• Heading styles.

Unmapped styles denoted by Unassigned - Use Style In Project in the Print Document Appearance dialog 
box are added to the Word document. This style has the same attributes as the project style. To access 
the Print Document Appearance dialog box, double-click a printed documentation layout in the Single 
Source Layouts pod, and click Next three times.

Style naming

Mapped template styles retain the name of the Word template style.

Styles that RoboHelp adds

Duplicate styles

If the project has multiple style sheets with duplicate style names, the most frequently used style is 
mapped.

Map styles

1) Double-click Printed Documentation in the Single Source Layouts pod, and click Next until Print 
Document Appearance appears.
Project styles appear on the left. Matching template styles appear on the right. If a matching style 
is not found, you see [Unassigned - Use style in project]. Heading styles, which are mapped auto-
matically, are not listed.

2) Under Microsoft Word Template, select a template already in the project or another template 
option from the pop-up menu.

(None) Use The Project's CSS Styles
Formats from topics, not from a template.



472

PRINTED DOCUMENTS
CHAPTER 12 GENERATING OUTPUT

Use Microsoft Word Templates
In the Select Template File dialog box, open a template. Choose copy to the project folder or over-
write an existing template. Click Yes to enable quick access to the template. To share the template 
with other authors and maintain it in one location, click No.

Style Mapping. dot
Uses default template.

Browse 
NOTE: If the template you select has the same name as one of the default Word templates, _RHT is added 
to the custom template name.

3) Under Project’s CSS Styles, select a project style to map to a template style. A sample of the 
selected style is displayed underneath Preview.

Project’s CSS Styles (All)
Displays all styles in the project.

Project’s CSS Styles (Used Only)
Displays only the styles used in the project.

Character
Preview the font attributes of a style.

Paragraph
Preview the font attributes and spacing of a style.

Description
Preview a text description of a style.

4) Under Microsoft Word Template Styles, select the pop-up menu to display template styles.

Microsoft Word Styles (All)
Displays all styles in the template including Word defaults.

Microsoft Word Styles (User Defined)
Displays only user-defined styles.

NOTE: Styles must be mapped to other styles of the same type. For example, character to character, 
paragraph to paragraph, table to table, and multi-level list to multi-level list.

5) Select a style, and map all desired project styles, selecting them from the pop-up menu of the 
selected Microsoft Word style.

6) Map all desired project styles.
7) Click Finish to generate.
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8) When the macros message appears, click Always Trust Macros From This Publisher. Then click 
Enable Macros. Printed documentation files appear under !SSL!\[layout name] in the project 
folder.

9) Click View Result to view the output, or click Done.
Microsoft Word opens the document. Depending on the settings selected, the TOC, master docu-
ment, or a single document is displayed.

Export style maps

Ensure that the project styles are all mapped to the same Word template styles.
1) Open the project.
2) Create a printed documentation layout.
3) Map the styles. Save the settings.
4) In the Single Source Layouts pod, right-click the layout containing the style map to export. Select 

Export Preferences.
5) Browse to the destination for the style map. Click Save.

Import style maps

Share style maps to ensure that the project styles are all mapped to the same Word template styles.
1) In the Single Source Layouts pod, right-click the printed documentation layout. Select Import Pref-

erences.
2) Browse to the exported style map (.zpl file).
3) Select Open.

– If the template associated with the style map is not in the project, select Yes to copy it to the 
project folder.

When you generate output, the imported style map is used.
4) To edit the style map after it is imported, right-click the layout. Select Properties. Set options and 

click Next for each screen of the Properties dialog box.
5) Click Save.

Generate PDFs

PDFs retain links, bookmarks, formatting, graphics, fonts, special characters, and colors.

Generate a PDF

1) Open the project.
2) Click Output> Generate > PDF Output.

Generate a PDF with setup options

1) In the Single Source Layouts pod, double-click the printed documentation layout.
2) In the Output Format area, select Generate Adobe PDF.



474

PRINTED DOCUMENTS
CHAPTER 12 GENERATING OUTPUT

3) Click PDF Settings. Set options.
4) Select options on each screen to set up the chapter layout, the section layout, and the styles. Click 

Next to progress through the screens.
5) Click Finish.
6) (Optional) Click View Result.

Generate printed documents

You can create printed documentation and single-source layouts, and generate PDF files simultaneously 
with printed documents.

If no template is used, every document retains the formatting used inside the topics.
1) In the Single Source Layouts pod, double-click the printed documentation layout.
2) Select options in the Print Document General dialog box. For details on adding headers and footers, 

see Add headers and footers to printed documents.
3) Arrange the document structure in the Print Document Content dialog box.
4) Map Microsoft Word styles in the Print Document Appearance dialog box.
5) Copy hand-coded or added files to another location before generating the layout.
6) Click View Result.

By default, printed documentation files are created under !SSL!\[layout name] in the project folder. 
Templates are saved in the root project folder.

Notes:
• Some list items do not convert properly when generating printed documents with 1500 or more list 

items without Microsoft Office 2000 SP-2 or later installed.
• If you see the following error message, change the macro security settings in Microsoft Word: “The 

Word VBA macro version registered is incorrect. Please reinstall printed documeation.”
a) Open the Trust Center Settings:

• In Word 2007, click the Office button > Word options > Trust Center > Trust Center 
Settings.

• In Word 2010, click File > Options > Trust Center > Trust Center Settings.

b) Change Macro Settings to Enable all macros and then click OK.
c) Now generate the printed documentation output from RoboHelp HTML.

Add headers and footers to printed documents

You can choose to add headers and footers in the printed output of a document.
IMPORTANT: To add headers and footers to printed documentation, you need to first add the header and 
footer in the master pages of the document. For details see, Adding headers and footers for printed docu-
mentation.
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To add headers and footers:
1) To generate a printed output, see Generate printed documents.
2) In the Print Document General dialog box, to apply the header and footer setting to the entire docu-

ment, select a master page from the Header / Footer drop-down list.
3) To apply multiple header footer combinations, such as for left and right pages, click Multiple 

Header/Footer.
4) In the Multiple Header Footer Options dialog:

– To apply a combination of different header footer master pages to first, even and odd pages 
of one or more sections in the print output:
i) Select one or more sections.
ii) Select the master pages for first, even, and odd pages in the drop-down menus.
iii) Click OK.
iv) Repeat the steps to apply master pages to other sections.

– To apply a combination of different header footer master pages to first, even and odd pages 
of all the sections in the print output:
i) Ensure only one section is selected.
ii) Select the master pages for first, even, and odd pages in the drop-down menus.
iii) Click Apply to All Sections.
iv) Click OK.

– To apply the same header and footer to all the pages of one or more sections in the print 
output:
i) Select one or more sections.
ii) Select the master page for first page in pop-up menu.
iii) Click Apply to All Page Types.
iv) Click OK.

– To apply the same header and footer to all the pages of all the sections in the print output:
i) Ensure only one section is selected.
ii) Select the master page for first page in pop-up menu.
iii) Click Apply to All Page Types.
iv) Click Apply to All Sections.

5) To restart page numbering on the first page of first chapter of your print output, select Restart Page 
Numbering on First Chapter.

6) Click OK.
7) Click Save and Generate.
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Specify default printer options

You can configure the default printer settings from within RoboHelp. The options that are available vary 
according to the selected printer.
NOTE: The settings you specify affect how documents print in other Windows applications.

Settings include:

Paper Size
Specifies the size of the paper.

Paper Source
Specifies the location of paper in the printer. Options vary according to the printer. Examples of 
paper source are upper tray and envelope feed.

Orientation
Specifies if the orientation is Portrait or Landscape.

Margins
Specifies left, right, top, and bottom margins in inches.

Skins

About skins

Use skins to change the appearance of Adobe AIR, WebHelp, and FlashHelp systems. Skins apply to the 
left side of a window and the toolbar across the top of the output. Customize the Help system by 
changing colors, buttons, fonts, and icons, and by adding backgrounds and logos.

RoboHelp includes predefined skins in the RoboHelp Skins Gallery.

Edit skins

Follow this procedure to edit WebHelp and AIRHelp skins from within RoboHelp. Changes to skin prop-
erties take effect the next time you generate using the skin. If you localize a project, default skin text is 
translated using the project language setting. If you edit skin text, RoboHelp overrides customizations in 
the LNG file.
NOTE: FlashHelp skins are edited with FlashHelp Skin Development Kit. See Customize FlashHelp skins.
1) In the Output Setup pod, expand the Skins folder.
2) Right-click a skin. Select Edit.
3) Depending on the skin type, WebHelp Skin Editor or Adobe AIR Help Skin Editor launches. Set 

options, as needed.
NOTE: Some options aren’t available, depending on the output type.



477

SKINS
CHAPTER 12 GENERATING OUTPUT

4) Click OK.
5) Click Update View to view changes in the dialog box. Click Preview to view the changes in a separate 

window.

Tips:

• Use URL icons for website links, or use folder icons instead of book icons.
• To use TOC icons that are a different color, browse to the Image Gallery. The gallery is in C:\Program 

Files\Adobe\Adobe RoboHelp [version]\ RoboHTML\gallery\images\Books_and_Pages. You 
can also edit the image color in a graphics editor.

• When generating a project with custom toolbar items, select the custom button in the Navigation 
dialog box.

• To remove a button from a skin without deleting the image file, clear the option when you generate 
the project. Do not clear it in the WebHelp Skin Editor.

• Additional files, such as image files or JavaScript files for buttons, reside in the Project Folder\!Skin-
SubFolder!\<Skin Name>. The skins reside in separate subfolders in the !SkinSubFolder! folder.

• To specify a script that uses other files (such as HTML files or image files), copy these files to the 
skin subfolder under !Skinsubfolder!.

RELATED LINKS:
Create custom skins for WebHelp and WebHelp Pro projects

Create custom skins for Adobe AIR projects

Add skins to the gallery

Store or reuse skins across projects by adding them to Skins Gallery.
1) In the Output Setup pod, expand the Skins folder.
2) Right-click a skin. Select Add To Gallery.

Import skins

When you import Adobe AIR AHS files, WebHelp SKN files, or FlashHelp FHS files, all associated files are 
added to the skins subfolder. You can also import a compressed AHZ (for Adobe AIR), ZKN (for WebHelp), 
or FHZ (for FlashHelp) file.
1) In the Output Setup pod, right-click the Skins folder. Select Import.
2) Navigate to a skin file or a compressed skin file.
3) Select the file. Click Open.
4) (Optional) Type a name and filename for the skin.
5) Click OK.

You can select this skin the next time you generate output.
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Export skins

Exporting a skin saves it as a compressed file that contains the skin and its associated files.
1) In the Output Setup pod, expand the Skins folder.
2) Right-click a skin. Select Export.
3) Navigate to the location for the exported skin. Click Save.

Delete skins

1) Do one of the following:
– To delete a skin from the project, select it in the Skins folder in the Output Setup pod.
– To delete a skin from the gallery, select the skin in C:\Program Files\Adobe\Adobe RoboHelp 

[version]\RoboHTML\Sqskinsext\Gallery.

2) Press Delete.

Preview skins

You can preview skins for WebHelp, WebHelp Pro, FlashHelp, and FlashHelp Pro projects.
1) In the Output Setup pod, expand the Skins folder. Select a skin.
2) In the toolbar, click the View button .

Compile skins

Each template for the Adobe AIR layout has an associated style sheet called exStyle.css. You can locate 
this file in [Project folder]\!SkinSubFolder!\[skin name] and directly modify the styles in a text 
editor.
TIP: RoboHelp stores the default exStyle.css file in [Install folder]\AIRHelpExt\skins\[skin name]\SkinTem-
plate. Refer to the comments in this file while editing a style sheet.

After you modify the style sheet, compile the CSS file to generate a SWF file.
1) In the Output Setup pod, expand the Skins folder.
2) Right-click a skin. Select Compile.

Create custom skins for Adobe AIR projects

Adobe AIR Help Skin Editor helps you create and edit skins for Adobe AIR projects.
1) In the Output Setup pod, right-click the Skins folder. Select New Skin.
2) Do one of the following:

– Select Create Skin From Gallery. Click OK. Click the Adobe AIR tab. Select a skin. Click OK.
NOTE: Adobe AIR project skins are associate with templates. So selecting a skin also means 
selecting the template with which the skin is associated.
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– Select Create Custom Adobe AIR Skin. Select a template and specify a skin name. Click OK.

3) In Adobe AIR Help Skin Editor, fine-tune the palette, the font style, and the icon set.

Fine-tune the palette

Select a palette from the available palettes and fine-tune it by changing the colors of various parts of the 
template. Use the Hue, Saturation, and Contrast values to make finer adjustments.
1) In Available Palettes, click a palette. Use the Next and Previous buttons to browse through palettes 

available in RoboHelp Gallery.
2) Change the background colors to customize the palette. Do any of the following:

– Move the pointer over each background color. The preview shows where the color is used.
– Click a background color and select another color from the color picker.
– Adjust hue, saturation, and contrast with the sliders. Selecting the check box below a back-

ground color lets you adjust the hue, saturation, and contrast for only that color.

NOTE: You can save a customized palette in the gallery. Specify a name for the customized palette 
in the Selected Palette box and click Save. You can also remove customized palettes by deleting the 
XML file from %Application Data%\Adobe\RoboHTML\[version]\AIRSkinEditor\ColorThemes.

Modify font properties

Font properties include font type and font color.
1) Select a font from the drop-down list in Font Properties.

Style 1
Sets the font of text displayed on the header, footer, and main taskbar.

Style 2
Sets the font of disabled and mouseovertext.

Style 3
Sets the font of pod text.

Customize icons

Each template includes an icon set. You can change the icon set and edit the icon set by replacing existing 
icons with new icons. You cannot add or delete icons from an icon set.

While replacing icons, maintain the default icon dimensions for best results. For example, if the dimen-
sions of the default Add Comment button are 16x16, make sure that the new image has the same dimen-
sions.
NOTE: Supported file types for icons are .jpg, .gif, and .png.
• To change the icon set, click Select New Set. Select an icon set from the drop-down list and click 

Select.
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• To edit the current icon set, click Edit Current Set. Select the icon you want to customize. Click 
Browse and select the image file that contains the new icon. Click Apply after you have replaced the 
image for each icon state.

NOTE: If you cancel editing the skin after selecting a new icon set or applying changes to icons, these 
changes are not canceled.

Create custom skins for WebHelp and WebHelp Pro projects

The custom skin is saved as an SKN file to [Project folder]\!SkinSubFolder!\[skin name].

If you create a custom skin from a gallery skin, the gallery skin remains unchanged.
1) In the Output Setup pod, right-click the Skins folder. Select New Skin.
2) Do one of the following:

– Select Create Custom WebHelp Skin. Click OK.
– Select Create Skin From Gallery. Click OK. Select a skin. (Optional) Click Preview to view the 

selected skin.

3) Click the Toolbar tab. Set options, as needed:
NOTE: Some options aren’t available, depending on the output type.

Main
Lists items that appear on the main toolbar.

Add custom toolbar item 
On the Action tab, define a link or a script for the button:

Link
Link the button to a URL. Type the path or click the Browse button  to browse to it. Linked files 
are copied to the skins folder (ProjectName\!SkinSubFolder!\YourSkin).

For JavaScript, specify the function calls for these actions:

Onload
Specify a function to call when the page containing the button is loaded (MyFunction())

OnMouseOver
Specify the function to call when the pointer is over the button.

OnClick
Specify the function to call when the button is clicked.

Under Advanced, add or remove dependent files for the custom toolbar item when using the 
multi-author feature.
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Dependencies
Lists the dependent files already added. Click Add to specify the name of another dependent file.

Add
Browse to the location of a dependent file. Click OK. External files are copied to the project folder 
automatically.

Remove
Remove a dependent file from the Dependencies list. An image in the custom toolbar cannot be 
removed. Files are removed only from the RoboHelp software, not from the hard disk.

Inline JavaScript
Write function definitions for custom button functions in the project.

External JavaScript File
Browse for and select the file.

Remove custom toolbar item 
Click to delete a selected custom toolbar item.

Contents, Index, Search, Glossary
Select the button to change and click the Edit button  to edit the button text or to place an image 
on the button.

Search Input
Double-click to edit the field that appears in the toolbar and the Search pane. The button options 
apply to both the toolbar and the Search pane. The Caption and the Text Box Width apply to the 
toolbar only. The box can be from 10 to 40 characters wide.

About
Select and click Edit to change which image is displayed in the upper right of the main toolbar. 
Specify an About Button image, which is copied to the Skins folder. Then specify the following infor-
mation, as needed for the output format:

Image
Select an image to display at the left of the About box.

Company
Enter the company name, which is displayed below the logo. This text is a hypertext link to a URL 
specified under URL.

Copyright
Enter a copyright notice.
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URL
Enter a web address for the company website.

Title Image
Specify an image to display at the top of the About box. Keep the image smaller than 211 by 60 
pixels.

Author
Identify the system or give more information to users.

E-mail
Enter the e-mail address of the author.

Navigation Bar
Modify the items directly under the main toolbar , .

Previous Topic, Next Topic, Sync TOC, and Hide Navigation Component
Select the item to change and click Edit to change the image for the button.

The Previous and Next buttons let users move back and forward through a series of topics you 
define in browse sequences. You can change the image shown for the buttons when they are 
enabled and disabled. Enabled indicates that the user can click the button for more topics. Disabled 
indicates that no topics exist in that direction.

You can change the image for the Sync TOC button. When you generate, select Synchronize TOC 
(Manually) to ensure that the button appears on the navigation bar.

NOTE: The Hide Navigation Component button does not appear in all versions of Netscape Navigator 
when the output uses a skin.

4) Click the Navigation tab. Click the browse buttons  to select images, and specify other settings as 
needed:
NOTE: The toolbar is automatically resized to accommodate images. Images are tiled in backgrounds 
for the content and label region backgrounds.

Topic/Page
Select an image for TOC topics.

Remote URL
Select an image for links not in the project.

Background Image
Select an image to use in the background of the content region. The images are tiled.

Hover Color
Select the color that is displayed when the mouse is hovered over the topic.
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5) Click OK.
6) To rename the selected skin, right-click, select Rename, and type a name in the Name box.

NOTE: You cannot rename skins in the gallery.
7) Click Update View to view changes in the dialog box. Click Preview to view the changes in a separate 

window.
8) Click OK. Type a name and filename for the skin, including the .skn extension.

You can use the skin the next time you generate output.

TIP: To share a skin file (SKN) with others, define all customizable elements of the skin beforehand so that 
other authors can include or exclude certain elements when they generate output.

Customize FlashHelp skins

You can customize FlashHelp skins by replacing elements in an existing skin with elements from another 
skin. If you’re a skilled Flash developer, you also can create a skin with Adobe Flash or the RoboHelp Skin 
Development Kit.

The SDK includes instructions for using the kit and tips and tricks.

Customize or create a skin with Flash

Use an existing compressed skin file (FHZ) from the RoboHelp Skin Gallery or create one.
1) Download the Flash SDK from www.adobe.com/go/learn_rh_flash_sdk_en and make changes to 

the skin.
2) When finished with skin editing, share the compressed skin file (optional). Then, import the skin 

into the project.
3) Preview the skin.
4) When generating a FlashHelp layout, select the skin from the FlashHelp Options dialog box.

Modify the skin without Flash

FlashHelp skins are composed of Flash skin files (SWF files). Each SWF file is used for different skin 
elements, such as toolbar buttons and icons. Use Windows Explorer to replace individual SWF files in an 
existing skin with the SWF files of another.
1) Ensure that the project contains all the skins to use by importing them.
2) Navigate to !Skinsubfolder!\[skin name].
3) Open the skin subfolder that contains the SWF files to copy.
4) Right-click the SWF file and select Copy.
5) Open the skin subfolder containing the SWF files to replace.
6) Paste and replace the files.
7) In RoboHelp, when you generate the project, select the newly modified skin in the FlashHelp Prop-

erties dialog box. When project generation has finished, click View Result to test the skin.

http://www.adobe.com/go/learn_rh_flash_sdk_en
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Select and preview WebHelp or FlashHelp skins from the Skin gallery

1) In the Single Source Layouts pod, double-click a FlashHelp layout.
2) Click Gallery.
3) Select a skin. Click Preview to view it. Then click OK to select it.
4) Click Finish to generate the FlashHelp output.

The skin is added to the project and appears in the Skins project subfolder with a Flash icon .

FlashHelp vertical-style skins

In vertical-style skins, toolbar icons have tool tips. Tool tips appear when the mouse hovers over the 
button.

Prefix the names of these skins with “Vertical,” such as Vertical-Breeze.
NOTE: Vertical-style skins do not have a Search field in the toolbar.

Example of vertical-style skins
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Windows

RoboHelp supports WebHelp and FlashHelp windows for use with the context-sensitive Help API.

Create or edit windows

NOTE: This procedure applies to Multiscreen HTML5, Adobe AIR, WebHelp, WebHelp Pro, FlashHelp, 
FlashHelp Pro, and HTML Help.
1) Do one of the following:

– In the Output Setup pod (Output > Open > Output Setup), right-click the Windows folder. 
Select New Window and select the type of layout for which you want to create the window.
NOTE: The layout must be present in your project.

– Click the Create a new window icon on the Output Setup toolbar and select the window type 
from the drop-down menu.

– To create a window for the primary layout, click New Window under Windows in the Output 
Setup pod.

2) Type a name and caption in the text boxes.
3) Set options. Many of the options are common to all the output types. 

Placement
To change placement visually, point and click inside the sample window. To change size visually, 
point to a border in the sample window. To use exact measurements, in Placement, enter values in 
Top and Left for the position (percent of the browser window). To resize, enter values in Height and 
Width.

Windows To Display
Selected windows appear in the preview area of the upper-left corner.

4) Select the options specific to WebHelp Pro and FlashHelp Pro.
5) Click OK.

TIP: For JavaHelp and Oracle Help projects, set navigation pane options when you generate output.

RELATED LINKS:
Specify the primary layout

WebHelp, WebHelp Pro, FlashHelp, FlashHelp Pro Options

In addition to the standard Window Properties options, WebHelp Pro provides the following options. In 
WebHelp Pro and FlashHelp Pro, you can view settings after the project is published to the server.

Buttons
Click the up and Down Arrows to change button order as the buttons appear in the browser. Select 
the buttons to include. You can customize these buttons or add new buttons using skins.
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Set As Default
Click to set the selected button as the default. Contents is the default.

WebSearch
Displays the WebSearch button. This button is available only if enabled in the project.

Browse Sequences
Enables support of browse sequences if you created them. The window contains Previous and Next 
buttons. Use skins to customize them.

Search Input Field In Toolbar
Adds the Search button to the toolbar. Use skins to customize the Search Input Field.

Use Default Browser Settings
Select to use the user default browser size, toolbars, placement, and other properties. When dese-
lected, the standard browser toolbar, menu, location bar, and status bar are available.

Resizable
Selecting this option lets users resize the window. This setting is available when used with the 
context-sensitive Help API.

View
Select One Pane to display the topic pane. Select Two Pane to also display the navigation pane.

HTML options

In addition to the standard Window Properties options, HTML Help provides the following options:

Buttons
(HTML Help) Select buttons to display.

Button Description

Hide/Show Opens and closes the navigation pane.

Back Opens the previous topic.

Forward Opens the next topic in a pre-viewed sequence.

Stop Stops a web page form displaying.

Refresh Updates the topic content.

Home Shows the default web page.
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Tri-pane Tabs And Windows
Select tabs to include in the navigation pane. If you select TOC And Index and the project does not 
include a TOC, the HTML help viewer does not display the Contents tab.

TOC And Index
Displays the Contents and Index tabs in the navigation pane. A navigation pane requires these tabs. 
If you do not select this option, the navigation pane options are unavailable.

Favorites
Displays the Favorites tab in the navigation pane.

Glossary
Displays the Glossary tab in the navigation pane.

Search
Displays the Search tab in the navigation pane.

Adv Search
Enables users to search for topics using Wildcard and Boolean characters.

Browse Sequences
Enables support if you have created browse sequences.

Default Tab
Select the tab to display when the HTML Help project opens.

Options Opens menu access to Home, Show, Back, Stop, Refresh, Print, and 
Search Highlight On/Off.

Print From the Contents tab, prints pages, headings, and subtopics or the 
entire TOC. From the Index or Search tab, opens the Print dialog 
box.

Locate Click to synchronize books and pages in the Contents tab with the 
topics in the right pane. This option differs from Auto-synchronize 
TOC, which synchronizes books and pages with topics as users view 
topics.

Jump1 Opens a web page, intranet site (defined with a URL) or help topic 
(defined by its filename if included in the same file).

Jump 2 Opens a web page, intranet site (defined with a URL) or help topic 
(defined by its filename if included in the same CHM file).

Button Description
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Tab Position
Select a default location for the window tabs.

Tri-pane Options
Set properties for the onscreen appearance and behavior of the panes.

Hide Nav Pane On Startup
Hides the navigation pane. Click Show to open it.

Auto Synchronize TOC
Synchronizes books and pages in the Contents tab with the topic displayed in the right pane. (For 
this feature to work properly, the Always Show Selection option must be active. To check if it is 
active, open the single source layout and click Advanced Settings Edit. In TOC Styles, verify that 
Always Show Selection is selected.) Make sure that the filenames have underscores, not spaces.

Remember Window Size And Position
Notes the last size and position of the viewer.

Auto Show/Hide Nav Pane
Automatically hides the left pane when users switch focus from the HTML Help viewer to a 
program. The topic content remains visible but the left tabs are temporarily closed from view. 
These tabs appear as soon as the HTML Help viewer is clicked.

NOTE: If you select Auto Show/Hide Nav Pane, click Advanced Properties > Extended Styles, and select 
Top-Most window. This option prevents the right pane from being hidden behind the open application.

Nav Pane Width
Enter the width in pixels. The width to assign depends on the number of window tabs.

Advanced Properties
Specify advanced HTML windows properties on the Destinations, Styles, and Extended Styles tabs. 
Some options require coding in the application.

Advanced window Destinations properties

Default
Assign default topic.

Home
Define the URL to display when clicking Home.

Table Of Contents
Assign an alternate contents file (.HHC).
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Index
Assign an alternate index file (.HHK).

Button 1 Label
Assign a label to Button 1.

Custom Button 1
URL defines the destination for Button 1.

NOTE: Custom 1 button does not reference external CHM files if Internet Explorer 5.5 is installed.

Button 2 Label
Assign a label to Button 2.

Custom Button 2
URL defines the destination for Button 2.

Advanced window Styles properties

System Menu
Includes a system menu. Window style ID is WS_SYSMENU.

Minimize Box
Includes a minimize box. Window style ID is WS_MINIMIZEBOX.

Maximize Box
Includes a maximize box. Window style ID is WS_MAXIMIZEBOX.

Clip Siblings
Specifies whether the window covers other sibling windows. Window style ID is WS_CLIPSIBLINGS.

Clip Children
Specifies whether the window covers other children windows. Window style ID is WS_CLIPCHIL-
DREN.

Vertical Scroll
Includes a vertical scroll bar. Window style ID is WS_VSCROLL.

Horizontal Scroll
Includes a horizontal scroll bar. Window style ID is WS_HSCROLL.

Popup
Uses pop-up menu windows. Window style ID is WS_POPUPWINDOWSTYLE.
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Minimize
Minimizes application when window is open. Window style ID is WS_MINIMIZE.

Maximize
Maximizes application when window is open. Window style ID is WS_MAXIMIZE.

Border
Displays border around window. Window style ID is WS_BORDER.

Dlg Frame
Displays window in a dialog frame. Window style ID is WS_DLGFRAME.

Visible
Creates a visible window. Window style ID is WS_VISIBLE.

Thick Frame
Displays window using a thick frame style. Window style ID is WS_THICKNESS.

Disabled
Disables a window so that it does not accept user input. Window style ID is WS_DISABLED.

Advanced window Extended Styles properties

Tool Window
Sets the window for use as a floating toolbar. Window style ID is WS_EX_TOOLWINDOW.

Client Edge
Creates a 3D border with a sunken edge. Window style ID is WS_EX_CLIENTEDGE.

Static Edge
Creates a 3D border for windows that does not accept input. Window style ID is WS_EX_STATI-
CEDGE.

Transparent
Makes the window transparent. Window style ID is WS_EX_TRANSPARENT.

Accept Files
Lets the window accept drag-and-drop files. Window style ID is WS_EX_ACCEPTFILES.

Control Parent
Lets users navigate among child windows using the Tab key. Window style ID is WS_EX_CONTROL-
PARENT.
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Context Help
Adds a clickable question mark to the title bar that changes the cursor to a question mark pointer. 
Clicking in a child window then displays a WM_HELP message. Window style ID is WS_EX_CON-
TEXTHELP

Right-to-Left Order
Displays window text using the right-to-left reading order properties. Window style ID is WS_EX-
_RTLREADING.

No Parent Notify
Specifies that a child window does not send the WM_PARENTNOTIFY message to its parent window 
when created or destroyed. Window style ID is WS_EX_NOPARENTNOTIFY.

Right -aligned Text
Specifies generic right-aligned properties. Window style ID is WS_EX_RIGHT.

Left Scroll Bar
Places a vertical scroll bar left of the client area. Window style ID is WS_EX_LEFTSCROLLBAR.

Top-most Window
Places the window above all non-topmost windows, even when the window is deactivated. Appli-
cations can use the SetWindowsPos member function to change this position. Window style ID is 
WS_EX_TOPMOST.

To test this feature, generate and view the CHM file. When the HTML Help viewer opens, select a 
window. The viewer remains the topmost window.

Adding HTML buttons

You can add extra buttons that link to intranet, websites, and HTML pages. You can add a home button 
and two jump buttons to any URL. These buttons appear at the top of the HTML Help viewer.

Add a home button

1) In Windows Properties, click Buttons > Home.
2) Click Advanced Properties.
3) On the Destinations tab, in Home, enter the URL.
4) Click OK > OK.

Add a jump button

1) On the Windows Properties dialog box, select Button 1.
2) Click Advanced Properties.
3) On the Destinations tab, in the Button 1 label, enter label text for the icon displayed in the window 

(optional).
4) In Custom Button 1 URL, enter the link website address.
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5) Click OK > OK.

Notes:

• Custom windows without a navigation pane do not support custom buttons. If you select options 
such as Back, Forward, or Hide/Show, these buttons do not appear when you test Help topics.

• Website links to custom windows must include the tri-pane design (navigation pane).
• From the HTML Help viewer or window, Home buttons and URLs look like the following:

Home 
Button 1 
Button 2 

Edit windows for JavaHelp and Oracle viewers

The JavaHelp viewer includes a customizable navigation pane and a content pane. To omit the navigation 
pane, clear the TOC, Index, and Search settings. If you do not create a TOC or index, clear the corre-
sponding settings.
1) Click Project.
2) Double-click the single-source layout.
3) Set options for the navigation pane and in-topic navigation bar.

Options for JavaHelp viewers

Options for Oracle viewers

Desired Result Actions

Specify the location for browse sequences and 
WebSearch.

Select Top Right, Bottom Left, or Bottom Right.

Specify the appearance of browse sequences or 
WebSearch controls.

Select Button or Text.

Specify JavaHelp output type. Uncompressed JavaHelp With Source Files to 
create HS and individual output files.
Compressed JavaHelp to create .JAR and .HS files.
Compressed JavaHelp With Source Files to create 
.JAR, HS, and individual output files.

Desired result Action

Add (or remove) the Contents tab from the 
navigation pane.

Select or clear TOC.
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Assign a default window

1) In the Single Source Layouts pod, expand the Single Source Layouts folder.
2) Double-click a layout that uses WebHelp Pro or HTML Help.
3) In the Default Window menu, select the custom window.

Remove a window

1) In the Output Setup pod, expand the Windows folder.
2) Right-click a window. Select Delete.

Screen profiles

Screen profiles enable you to define unique screen specifications for different devices. When you add a 
screen profile to the Multiscreen HTML5 SSL, RoboHelp generates optimized output for that screen 
profile.

For example, if you create different screen profiles for a smartphone and a tab or an iPad and a Samsung 
Galaxy Tab, you will be able to generate different output that’s optimized for these devices.

A screen profile has the following attributes:

Screen resolution
Specify a range of resolutions in pixels for devices that should map to this screen profile. For details, 
see Use device pixel ratio for screen size and resolution.

Add (or remove) the Index tab from the 
navigation pane.

Select or clear Index.

Add (or remove) the Search tab from the 
navigation pane.

Select or clear Search.

Enable WebSearch. (Select to provide access to 
WebSearch from the Help viewer.)

Select WebSearc.h

Enable browse sequences (If you create browse 
sequences in the project, select this feature so 
functionality is available in the browser.)

Select Browse Sequences.

Specify the location for the in-topic navigation 
bar.

Select Top Right, Bottom Left, or Bottom Right as 
the location.

Specify the appearance of the in-topic navigation 
bar.

Select Button or Text as the style.

Desired result Action
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NOTE: If you have created any style using the screen profile, changing the width range requires manual 
updating of the style sheet. Save the screen properties and update the style sheet. For step-by-step 
instructions, see Manage media queries.

Browser(s)
(Optional) Enables you to generate and display browser-specific output for devices that match the 
resolution of this screen profile. For example, if an iPhone and Android phone match the width and 
height range specified in this screen profile, RoboHelp looks for browser agent information to 
generate and display the appropriate output. For more information about browser agents, see 
Configuring Responsive HTML5 prerequisites.

Add a screen profile to a Multiscreen HTML5 SSL

By default, a Multiscreen HTML5 SSL includes a set of predefined screen profiles. If you want to add any 
other screen profile that your project contains, do the following:
1) In the Single Source Layouts pod, right-click the Multiscreen HTML5 SSL and select Properties.
2) In the Multiscreen HTML5 Settings dialog box, click Screen Profiles in the left pane.
3) Click Add Screen Profile(s). A list of screen profiles available in the project is displayed. By default, 

all are selected.
NOTE: You can remove a screen profile from the SSL by deselecting the check box to the left of the 
screen profile. RoboHelp retains the screen profile in the project until you delete it from the Output 
Setup pod.

4) Click OK.
5) Click Save. If you now generate output using the Multiscreen HTML5 SSL, RoboHelp generates 

output for the new screen profile.

Modify a screen profile

RoboHelp provides a set of screen profiles by default. Let’s modify a screen profile—iPhone—to under-
stand the steps involved:
1) Expand Screen Profiles in the Output Setup pod.
2) Right-click iPhone and select Properties.
3) As necessary, modify one or more of the following settings:

Name
Specify a name. For example, you can change iPhone to iPhone_New.

NOTE: If you try to include a space or a period in the screen name, RoboHelp replaces the space or the 
character with an underscore.
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Type
Select a predefined screen profile to populate the screen resolution ranges with predefined values. 
The Check for new screen profiles link enables you to access latest screen profiles uploaded on 
adobe.com.

Screen Resolution
Set the range of screen resolutions for the screen profile by specifying the minimum and maximum 
width and height.

Browser(s)
Select browsers for the screen profile. RoboHelp provides a list of popular browsers. If you want to 
add to this list, make sure you specify a unique string from the browser agent or user agent of the 
browser.

Preview Settings
Click this to configure the settings for previewing the output with this screen profile. Define the 
dimensions of the window in which the content should be displayed. Select a device image for use 
in preview and specify the top-left position of the content window. If the settings look good, click 
Save.

4) Click Save to save the screen profile properties.

Add a screen profile to the project

1) In the Output Setup pod, right-click Screen Profiles and select New Screen Profile.
2) Select a predefined screen profile. RoboHelp displays the screen profile settings.

NOTE: You can click the Check for new screen profiles link to download a screen profile of your 
choice. Save the downloaded file—predefined_screens.xml—in 
AppData\Roaming\Adobe\RoboHTML\10.00 and <robohelp install folder>\RoboHTML\presets. 
RoboHelp updates the list of predefined screen profiles.

3) Modify the settings if required.
4) Click Save. RoboHelp creates the new screen profile and displays it in the project hierarchy under 

Screen Profiles.
TIP: You can reuse the settings for an existing screen profile to create one. Right-click a screen 
profile in the project hierarchy and select Duplicate Screen Profile.

Delete a screen profile

1) Right-click a screen profile in the Output Setup pod and select Delete.
2) When prompted, confirm that you want to delete the screen profile.
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Map styles for screen profiles

If you change the width of a screen profile, the media query for the screen profile defined in the style 
sheet becomes undefined. RoboHelp does not automatically update the media query. Follow these steps 
to map an undefined media query to a media:
1) Right-click the CSS file and select Edit.
2) In the Styles dialog box, select Manage Media Queries from the Media list.
3) Select the undefined media query that has the width you specified and click Map.
4) Select the screen profile name.
5) Click OK.

Use device pixel ratio for screen size and resolution

When you create a screen profile, you define the minimum and maximum width and height based on the 
screen resolution of the that you plan to target for output. For example, if you plan to target a desktop 
device, you specify the minimum width as 1080 and minimum height as 1920. However, high screen reso-
lution (HD and Full HD) devices often have screen resolutions that are 1080 x 1920. This causes the 
output to display incorrectly on these devices since the hardware, using the screen resolution, identifies 
the device as a large screen desktop.

To identify the screen resolution of your target device, you need to use the abstract screen resolution:

Physical screen resolution:
Available with the device specifications (manual)

Device pixel ratio
A list of devices and their corresponding pixel ratios are available at: Device pixel density tests.

For more information on device pixel ratio, see More about device Pixel Ratio.

Abstract screen resolution
To calculate the abstract screen resolution: (physical screen resolution) / device pixel ratio

When you create a screen profile, the following screen widths recommendations are provided:

Phone:
0 to 699

Tablet:
700 to 1295

Desktop:
1296 to 99999

http://bjango.com/articles/min-device-pixel-ratio/
http://www.quirksmode.org/blog/archives/2012/07/more_about_devi.html
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Screen layouts

Screen layouts help you define the look-and-feel of Multiscreen HTML5 or Responsive HTML5 SSL 
outputs. For example, using screen layouts, you can define what the topic page should look like, how the 
search page should behave, or what branding options to add. Screen layouts offer placeholders for 
different elements, such as Table of Contents, index, and glossary. This support gives you the flexibility 
to lay out the elements in the way you want.

Screen layouts contain XHTML screen layout pages (SLP) and their linked files, such as CSS, images, and 
multimedia assets.

An SLP has a set of placeholders and HTML content that define layouts for Multiscreen HTML5 or Respon-
sive HTML5 SSL outputs.
NOTE: Each screen layout can have only one Search Results layout page and one Topic layout page. 
Generic layout pages can be more than one.

Default screen layouts are available in the Gallery folder of your RoboHelp installation. For Multiscreen 
HTML5 or Responsive HTML5 output, you need to create a screen layout based on an available screen 
layout in the gallery. RoboHelp copies all required files in a <screen_layoutname> folder under !Screen-
Templates! in the project hierarchy.

Create a screen layout

1) In the Output Setup pod, right-click Screen Layouts and select New Screen Layout.
2) Select a screen layout from the available list in the gallery.
3) Specify a name and description.
4) Click OK.

Manage screen layouts

In the Output Setup pod, right-click a screen layout and do the following:
• To rename a screen layout, select Rename (or Properties) and specify another name.
• To view or change the description, select Properties.
• To import a screen layout, select Import and specify an SLZ file name.
• To export a screen layout, select Export and specify the location where the SLZ file should be saved.

Preview a screen layout

Preview a screen layout to see whether the different screen layout components and their appearance 
and placement meet your requirements.
NOTE: The contents of the project do not appear in a screen layout preview. If you want to see how the 
content appears in a certain screen layout, map the screen layout to a screen profile in Multiscreen 
HTML5 or Responsive HTML5 layout settings and click Preview in the toolbar.
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To preview a screen layout while editing the screen layout, do the following:
1) Press Ctrl + W.

Editing a screen layout

A screen layout has two key components, a set of screen layout pages and a CSS. The screen layout pages 
define the content and the structure. The CSS defines the layout and the skin.

You can edit or customize a screen layout page in various ways. For example, you can add new screen 
layout pages, edit the screen layout pages to customize the position and style of widgets on the pages, 
insert widgets, and so on.

Add a screen layout page (SLP)

A screen layout contains standard layout pages for displaying topic contents and search results. 
However, you can add and design any number of layout pages to display other types of content, for 
example a home page with the TOC.
NOTE: You can add a Search Results page if the screen layout does not already have a SearchResults.slp 
file.
1) In the Output Setup pod, right-click on the screen layout name or on an existing SLP name. Select 

New > Screen Layout Page.
2) In the General tab, specify a page title and description.
3) In the Appearance tab, attach a style sheet and modify styles if required.
4) (Optional) Add background sound.
5) Click OK.

Screen layout page components

The key component of a screen layout page is a widget. A widget contains placeholders that you can be 
styled and laid out using cascading style sheets. While generating output, RoboHelp converts the place-
holders into standard HTML tags with associated functionality.

NOTE: The look-and-feel of a widget in the output and in Screen Layout Editor might differ to some extent.

The following customizable widgets are available for achieving different functions:

LNG String
Insert this widget to add a string from the LNG file.

NOTE: The LNG file contains strings for various user interface elements. RoboHelp loads these strings at 
runtime.

Tab
Insert this widget to add a tab in a tabbed panel.
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Browse Sequence
Choose options from this widget menu to insert browse sequence buttons and links in default or 
custom styles.

Glossary
Insert this widget to create a placeholder for a glossary.

Index
Insert this widget to create a placeholder for an index.

Print Button
Insert this widget to add an icon for printing.

Print Link
Insert this widget to add a text link for printing.

Project Title
Insert this widget to create a placeholder for the project title.

Tabbed Panel
Insert a group of tabs in two layouts (tabs placed horizontally and tabs placed vertically (accor-
dion)). The default tab group consists of Table of Contents, Index, and Glossary. You can also choose 
Blank Horizontal Tabs or Blank Vertical Tabs(Accordion) to insert blank tab groups.

Search
Insert the Search Options and Search Results Area widgets. The Search Options widget lets you add 
and style a search box to display in the output. The option to show search results for all words spec-
ified in the search box is also added by default.

The Search Results Area widget lets you design and style the area in which search results should be 
displayed. You can add and configure components such as Search URL and Search Context.

Show/Hide
Insert the Show/Hide widget into a widget to enable end users to show or hide the widget. For 
example, if you insert the Show/Hide widget into a TOC widget, the end users get the capability to 
show or hide the TOC in the output.

Choose one of the following options:

Dual State Show/Hide
Displays different text (for example, Show or Hide) in each of the two states

Static Show/Hide
Displays the same text (for example, Show/Hide) in both states
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TOC
Choose between Tree and Expanding Node to insert a TOC element on a screen layout page and 
style the various placeholders. Tree displays TOC items in a hierarchical view. In Expanding Node, 
arrows next to the TOC items at each level display the items at the next level.

Topic
Insert this widget to create a placeholder for topic contents.

TOC widget

Insert a TOC Tree widget or a TOC Expanding Node widget into a screen layout page to create and style 
a placeholder for a TOC in the output.

Attributes

Class
Specifies that a Div class should be applied on the parent TOC placeholder

Child placeholders
A TOC Tree widget has the following child placeholders:

Open Book
Defines the look and feel of open book items in the TOC in the output. You can insert any relevant 
HTML content inside this placeholder.

Closed Book
Defines the look and feel of closed book items in the TOC in the output.

Page
Defines the look and feel of page items in the TOC in the output.

Link
Defines the look and feel of TOC items that are linked to web addresses, email messages, multi-
media files, Usenet newsgroups, and FTP sites in the output.

Placeholder properties and attributes

Each Multiscreen or Responsive HTML widget has a set of placeholders, and each placeholder has 
predefined attributes.

The following table lists various placeholders and their properties and attributes:

Placeholder Parent Children Attributes

Alphabet category Glossary Text class, showin

Browse sequence 
Back

[HTML] [None] class
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AND Search 
Control

Browse sequence 
Nect

[HTML] [None] class

Closed book TOC Text
Icon

class, classhover, 
classselected

Filter Box Glossary
Index

[None] placeholder

Glossary Tab Content Group
[HTML}

Glossary TermGlossary 
DefinitionAlphabet 
CategoryFilter Box

class, showin

Glossary Definition Glossary Text class, classhover

Icon Closed Book
Open Book
Page
Link
Note: These 
placeholders are 
children of TOC.

Image class, src, hoversrc, 
selectedsrc

Index Tab Content 
Group[HTML]

Index Keyword
Index Link
Alphabet Category
Filter Box

class, showin

Index Keyword Index Text class, classhover, 
classbookchilds

Index Link Index Text class, classhover

Lng String [All] [None] class

Navigation Link [All] [None] class, href

Open Book TOC Text
Icon

class, classhover, 
classselected, 
classbookchilds

Search Field [All] [None] placeholder

Search Combo Search Results [None] [None]

Search Context Search Result Item [None] class

Placeholder Parent Children Attributes
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Search URL [All] [None] class

Search Message Search Results [None] class

Search Page 
Numbers

Search Results [None] class, ckasspagelink, 
classpage

Search Result Back Search Results [None] class

Search Result Item Search Results Search Title
Search Context

class, classhover

Search Result Next Search Results [None] class

Search Results Tab Content 
Group[HTML]

Search Message
Search Combo
Search Result Item
Search Page Numbers
Search Result Back
Search Result Next

class

Search Title Search Result Item [None] class

Show/Hide [All] [None] class

Tab Tab Group [None] class, classhover, 
classselected

Tab Content Tab Content Group [None] class

Tab Content Group Tabbed Panel [None] class

Tab Group Tabbed Panel [None] defaulttab

Tabbed Panel [HTML] [None] class, showin

Text Closed Book
Open Book
Page
Link
Index Keyword
Index Link
Alphabet Category
Glossary Term
Glossary Definition

[None] class

TOC Tab Content 
Group[HTML]

Closed Book
Open Book
Page
Link

class, showin

Placeholder Parent Children Attributes
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Guidelines for screen layout design

• Design the screen layouts using the standard widgets available with RoboHelp.
• Avoid reusing any image from the standard widgets or default layouts in any new screen layout.
• Define styles for all widgets in a screen layout CSS regardless of whether or not the widget is used 

in the screen layout. This ensures that the look-and-feel of the screen layout is not affected if a 
widget is added later.

• Create only simple class styles in the CSS. Make sure that each style has a modular definition.
• Make sure that all the icons and images are present in the screen layout folder regardless of 

whether or not they are used in the screen layout. The image names and formats should be in the 
required format.

• Specify height and width of images in px for img styles.
• Make sure that required style names are used in the screen layout. If you need to define additional 

styles in the CSS, follow a similar naming convention but do not use 'w' as first the character. Style 
names starting with 'w' are reserved for predefined widgets.

• Do not use absolute positioning in styles. Fluid layouts work better for Multiscreen HTML5 or 
Responsive HTML5 output.

• Do not use positioning attributes (for example, float) in the styles of top-level parent element of 
widgets. Examples of these elements are Topic, Index, and Tabbed Panel.

• Include pseudo-class definition for hyperlink styles.
• Make sure that the font family used in styles is appropriate and taking care of supported devices
• Make sure that hyperlink styles take care of touch scenarios and include webkit proprietary attri-

butes (for example, -webkit-tap-highlight-color) if required.
NOTE: These attributes cannot be inserted through RoboHelp CSS Editor and need to be inserted 
manually.

• Use LNG strings for inserting generic text in screen layouts.
• Do not use any inline styling in screen layouts.
• Provide a representative image of each screen layout for use in its preview.
• Make sure that a Layout.css file includes the style definition used internally by Multiscreen or 

Responsive widgets. Refer to the Layout.css file of any factory screen layout available in the Gallery 
folder of your RoboHelp installation.

Page TOC Text
Icon

class, classhover, 
classselected

Link TOC Text
Icon

class, classhover, 
classselected

Topic Tab Content 
Group[HTML]

[None] class

Placeholder Parent Children Attributes
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Edit a screen layout page (SLP)

1) In the Output Setup pod, expand the screen layout you want to edit.
2) Double-click the screen layout page. Screen Layout Editor opens. You can add new components by 

inserting available widgets, change their placement, and modify their properties.
Screen layout page in Screen Layout Editor

3) Edit the screen layout page as required.
– To insert a widget, do one of the following:

• Select Insert > Multiscreen Widgets. Select a widget.
• Click a tool button on the Widget toolbar in Screen Layout Editor.

– To select a placeholder in the widget, click the placeholder name in the Tag list below the 
Screen Layout Editor title bar. For example, to navigate to the LNG String placeholder in a 
Tabbed Panel widget, click LNG String in the Tag list.

– To view or modify the attributes of a widget, do the following:
• Select Project > Open > Pods > Screen Layout Properties.

Customize the default Topic page

A new screen layout comes with two default pages, Search Results Page and Topic Page. You can 
customize these pages in various ways.

Here are some examples of how you can customize the Topic page:
• Place the project title placeholder at the bottom of the page.
• Change the background color of the Topic page. Click Document in the Tag list, right-click and select 

Topic Borders And Shading. Select a color and click OK.
• Customize the tabbed panel. To remove a tab, select the tab from the Tag list and press Delete. To 

add a tab, select the tab before which you want to add a tab and click the Insert Tab widget. Specify 
the tab name.

• Replace the images in the browse sequence. Select an image in the browse sequence. Right-click 
and select Image Properties. Browse and select the PNG file for the new image. Change the other 
image in the same way.
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Review and collaboration

At different stages of content development and even after delivery, you need input from various stake-
holders, such as other authors, SMEs, editors, and end users. RoboHelp enables effective collaboration 
among all these roles by providing multiple ways of gathering, tracking, and addressing feedback.

Review in Design Editor

Insert your review comments directly in a project. You can also enable the Track Changes mode and edit 
the content.

Display the Review toolbar

The Review toolbar includes buttons for the following tasks:
• Add a review comment
• Edit a review comment
• Enable the Track Changes mode
• Accept this change and move to the next
• Reject this change and move to the next
• Move to the previous change or review comment
• Move to the next change or review comment

To display the Review toolbar:
1) Select Review toolbar.

Enable the Track Changes mode

To review a project in Design Editor, open the project and edit the contents in the Track Changes mode.

 IMPORTANT: RoboHelp does not track formatting and structure changes. For example, if you underline a 
word or delete a row from a table, the changes are not tracked.
1) To enable the Track Changes mode, do any of the following:

– Select Review > Tracking > Track Changes.
– In the Review toolbar, click the Track Changes icon .

Configure review settings

• To change the color of inserted text, right-click an instance of inserted text, and select Inserted 
Content Properties. Select a color. Select Set Color As Default.
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• To change the color of deleted text, right-click an instance of deleted text, and select Deleted 
Content Properties. Select a color. Select Set Color As Default.

• To change the color of review comments, right-click a comment, and select Review Comment Prop-
erties. Select a color. Select Set Color As Default.

• To set the name you want to display as the reviewer name, select File > Options > General. In the 
Reviewer Name box, type the reviewer name.
NOTE: Relaunch RoboHelp to load the modified settings.

PDF review

Create a PDF for review

The Create PDF For Review option in the Review menu lets you create a PDF that reviewers can review 
with the free Adobe Reader. The PDF stores a tagged structure of the RoboHelp project, enabling you to 
import comments back in the RoboHelp project.
NOTE: To ensure that comments are imported correctly, avoid updating the project after creating the PDF.

You can save the PDF locally or send it to the reviewers by e-mail. If you have Acrobat X Pro or above 
installed on the same computer, you can host your PDF on a SharePoint workspace, or share it in a 
network location.
NOTE: An image map applied in a circle is converted as a hyperlink in the largest square inside the circle. 
Image maps applied in polygons are not converted. Iframes are not converted; only placeholders appear. 
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Tables, images, and other elements that do not fit in a page are cropped. You can include or exclude 
dynamic HTML content, such as expanding text and drop-down text, in the PDF created for review.
1) Select Review > Collaborate > Create PDF.

Various options to filter content for review

2) Use one of the following options to display the topics, master pages, and snippets that you want to 
include in the PDF:

Project Manager
Select this option to view the topic list in the order in which the topics appear in the Project 
Manager pod. The topics you select from the list for adding in the PDF appear in the same order in 
the PDF.

Table Of Contents
Select this option to view the topic list from a selected TOC. Selecting the Exclude TOC Items Not 
Linked To Topics option ensures that the PDF does not include any empty TOC entry.

3) (Optional) Use the check boxes to the left of topic names as well as the following options to filter 
the topic list further:

Status
Select this option to filter topics based on a topic status.
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Last Modified
Select this option to filter topics modified before or after a specified date or within a specified date 
range.

NOTE: RoboHelp alerts you if you select a topic that is linked to Microsoft Word or FrameMaker 
document and the content is outdated.

4) (Optional) Select Include Expanding And Drop-Down Text to include dynamic HTML content, such 
as expanding text and drop-down text.

5) (Optional) Select Set Topic Status To ‘Sent for Review’ to autoset the status of the topics you have 
selected for review.

6) Select one of the following PDF settings:

Save Locally:
Creates a PDF and saves it to a location you specify. You can use the PDF for self- review or copy it 
to a shared location so other reviewers can add their feedback.

Send As E-Mail Attachment
Creates a PDF and attaches it to a new e-mail message open in your e-mail client. You can complete 
the message and send it to the reviewers.

Send For Shared Review
Creates a PDF and uploads it to a network location, or SharePoint server for shared review.

NOTE: This option is enabled in RoboHelp if Acrobat X Pro or above is installed on the same computer. This 
option is disabled when Set Topic Status To ‘Sent for Review’ is selected (in Step 5).

7) Select Enabling Commenting In Adobe Reader.
NOTE: This option is enabled in RoboHelp if Acrobat X Pro or above is installed on the same 
computer.

8) (Optional) Define and apply a conditional build expression to filter contents.
9) Click OK.

Embed SWFs in review PDF

To ensure that the PDF for review includes the SWFs inserted in the project, do the following:
1) Select File > Options > General.
2) Select Embed SWF In Review PDF.

NOTE: When you create a PDF for review without selecting this option, the PDF contains place-
holders where SWFs are inserted in the project.
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Add comments to SWFs

If the PDF for review contains SWFs that you can play and pause, you can add comments to individual 
slides. However, when RoboHelp imports the comments, it removes the slide association and places all 
the comments added to a SWF file above the SWF file in Design Editor. It also displays each comment as 
a separate entry in Review Pane.
TIP: To indicate the context of a comment, add the slide title or text to describe the slide (for example, 
Command menu slide: Move the pointer away from the selected menu item).
1) Choose Comments > Show Comment & Markup Toolbar.
2) Click Pause where you want to add a comment.
3) Select the Sticky Note commenting tool and click the slide to add the comment.
4) Click Play to continue the review.

Import comments from PDF

• Select Review > Collaborate > Import comments.
• (Optional) Select Update Topic Status to ‘Reviewed’ to update the statuses of all topics that are 

being imported after review to Reviewed.

About PDF comments imported in Design Editor

The following table shows how each type of PDF comment is imported in Design Editor:

NOTE: If a comment or track change has been imported from a review PDF, any changes to that comment 
or track change is not imported on further import of comments from the same PDF.

Import of comments added to SWFs

RoboHelp imports the comments added to SWFs and places them near the inserted SWFs. You can track 
the comments from the Review Pane pod. The comments are not associated with slides.

PDF Editor

Sticky note Review comment

Callout Review comment

Comment inserted on highlighted text Review comment

Inserted text Inserted text in Track Changes mode

Deleted text Deleted text in Track Changes mode

Replaced text Combination of deleted and inserted text
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Import of comments added to placeholders, snippets, and headers and footers

For topic TOCs, breadcrumbs, snippets, and headers and footers in master pages, RoboHelp places 
comments above or below these elements. It does not insert the comments in the location where they 
were added in the PDF. Insertions and deletions are also imported as sticky notes.

Managing Shared resources

In a distributed authoring environment, you often have authors needing to share content resources. For 
example, you can have different writers working on different topics on a document simultaneously. You 
can even have two or more writers working on the same topic at different times, maybe in different time 
zones. RoboHelp provides functionality to use cloud-sharing (Dropbox, Google Drive, and SkyDrive) or a 
file system-based shared location to share the following resources in your project:
• HTML files
• Images
• Masterpages
• Snippets
• Style Sheets
• Topics

RoboHelp provides easy ways to add resources in the shared location and the project. Drag files and 
folders between Resource Manager and Windows Explorer. Drag images, style sheets, and topics from 
Project Manager to Resource Manager. Drag master pages between the Project Set-up pod and Resource 
Manager. Drag snippets from Resource Manager to topics (RoboHelp updates the Snippets pod).

When you drag a resource from within a project (for example, a snippet from the Snippets pod) to a 
shared location in Resource Manager, you export the resource and make it available to other authors. 
Conversely, when you drag and drop a resource from Resource Manager to a project, you import the 
resource (with its associated files) to the project.

Add a shared location

You can add any number of resource locations as root elements in the Resource Manager pod.
1) Select Review > Open > Pods > Resource Manager and click Add Shared Location .

The Add Shared Location dialog allows you to specify a type of shared location.
2) In the Location type drop-down list, choose the type depending on your shared application:

Dropbox:
Share your Dropbox folder with other users. For details on Dropbox and how to download and get 
started, go to dropbox.com. Then choose Dropbox from the Location type drop-down list and 
select the shared Dropbox folder.

https://www.dropbox.com
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Google Drive:
Share your Google Drive folder with other users. For details on Google Drive and how to download 
and get started, go to drive.google.com. Then choose Google Drive from the Location type 
drop-down list and select the shared Google Drive folder.

SkyDrive:
Share your SkyDrive folder with other users. For details on Sky Drive and how to download and get 
started, go to skydrive.live.com. Then choose SkyDrive from the Location type drop-down list and 
select the shared SkyDrive folder.

SharePoint:
Add a mapped (network) drive to point to your SharePoint server. For more details, see Microsoft 
SharePoint. Then choose Other from the Location type drop-down list and select the SharePoint 
server mapped drive.

Other:
Share your Windows folder with other users. Then choose Other from the Location type drop-down 
list and select the shared folder.

IMPORTANT: If you are using Dropbox, Google Drive, or SkyDrive, you will need to first install these 
applications.

3) Specify a name for the shared location.
4) If you select the location type as Dropbox, Google Drive, or SkyDrive, the value in the Path field 

defaults to the install directory of the application. Click the browse button to choose an alternative 
path.

5) To create the shared location, click OK.

To further organize the shared resources, you can then create folders in each shared location. Click 
Create Folder  and specify a name for the folder.

Add a category

Categories help you manage different types of resources. You can add and edit categories and associate 
various file types with each category. For example, you can add a category called Video and associate .flv, 
.swf, and .avi file types with it.
1) Select Review > Open > Pods > Resource Manager. Click the Add/Edit Categories button.
2) Click Add Category .
3) Enter a name for the new category and click OK.
4) Click Add File Type  to add a file type for the selected category.

Notes:

• You can add file types to an existing category.
• You can edit the file types in an existing category.

https://skydrive.live.com
http://office.microsoft.com/en-in/sharepoint/
http://office.microsoft.com/en-in/sharepoint/
https://drive.google.com
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• You can click Reset To Default to reset to the default view of the Resource Manager. All the 
user-defined categories and file types still exist in the root folder.

Sharing resources between users

1) To share a resource with other users, drag the resource from the Project Manager and drop it in the 
specific folder in the Resource Manager pod.
Alternatively, right-click on the resource. From the context menu, choose Resource Manager -> 
Share.
In the Select Content dialog, select the specific shared folder.
RoboHelp adds the file to Resource Manager along with dependencies:
– Referenced CSS files
– Referenced images
– Files hyperlinked in the topic files (The files are added with broken references, but you can 

use Manage Linked Resources to add files in the project with working links.)
– Referenced snippets

2) To use a resource shared by users, drag the resource from the specific folder in the Resource 
Manager pod and drop it in the Project Manager.
RoboHelp adds the file to Resource Manager along with dependencies as in the case sharing re-
sources with other users, described above.
IMPORTANT: If you use a shared resource from the Resource Manager that contains a dependent 
snippet, you need to manually also pull the snippet into the Project Manager for the first time. After 
this, any changes made to this snippet by other users will be synchronized to your copy in Project 
Manager.

Show/Hide contents in the Resource Manager pod

1) Select Review > Open > Pods > Resource Manager.
2) Click the Show/Hide Categories button .
3) Select or deselect the categories to show or hide in the Resource Manager pod.
4) Select one of the following options:

All
Displays all the resources in the shared locations.

Linked
Displays only the resources used in the open project.



513

MANAGING SHARED RESOURCES
CHAPTER 13 REVIEW AND COLLABORATION

Manage shared files and folder

After you have create a shared location and added folders and shared resources to the location, you can 
perform a number of operations on these in the Resource Manager pod.

To perform file or folder specific operations, right-click on the file or folder in the Resource Manager and 
use the options in the menu.

Edit:
Open the file in the associated editor.

Explore:
Open the folder in Windows Explorer. Open the parent folder of the file in Windows Explorer.

Copy:
Copy the file or folder to the Clipboard.

Paste:
Paste the copied file or folder to the shared location.

Delete:
Delete the file or folder.

Sync:
Synchronize the copy of the file in the project with the copy on the shared location.

Remove Link:
Remove the link of the copy of the file in the project with the copy on the shared location. Any 
updates to the shared copy will not be reflected in the project copy. Also, any updates to the project 
copy will not be reflected in the shared copy.

Use this option if a user is making a large number of changes on a file and you plan to synchronize 
these changes only after the user is done with the changes.

Compare with project copy:
Use a version control application to compare the project file with the shared copy.

NOTE: To compare files, you will need a version control application installed. You will also need to 
Configure version control application in RoboHelp

Rename:
Rename a file or a folder.

Add to Project:
Add shared resource to the project.

Use this option if another user of the shared resource has added the file to the shared folder and 
you want to add the file to your project.
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Import:
(Folder) Imports one or more files into the selected folder.

Export:
Export to the selected folder in the Export Resource Files dialog box.

New Folder:
Add a folder at the current folder location.

Refresh:
Refreshes the contents of the selected file or folder.

Properties:
Displays the properties of the selected file or folder.

Manage linked resources

Linked resources are shared resources used in a project. When you use a shared resource in a project, 
RoboHelp adds a copy of the shared resource in the project. However, it maintains a link with the shared 
location to track whether the master copy is updated.
NOTE: Deleting the master copy from the shared location does not delete the copy of the resource used 
in the project.
1) To perform tasks such as comparing and updating resources, click Shared Resources .
2) In the Manage Linked Resources dialog:

Compare:
Display Project Manager and share location copies of a selected file side-by-side in the topic 
preview.

Click Compare to launch the two files in a file comparison application. However, you need to first 
install and then Configure version control application.

Filter Resources:
Searches linked resources in the project based on specified criteria.

A linked resource can have one of the following status:

In sync:
The shared resource and the copy used in the project are identical.

Modified in the shared location:
The original shared resource is modified, and the copy used in the project is out-of sync.

Modified in the project:
The copy used in the project is modified.
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NOTE: In Project Manager and Resource Manager, resources used in the project appear with icons that 
indicate if the resources are in sync or out of sync.

Modified in both locations:
Both the original shared resource and the copy in the project have been modified.

Not found in the shared location:
The original resource is not found in the shared location.

Not found in the project:
A reference to the resource exists in the project but the resource is deleted from the project folder. 
This scenario occurs only in the case of manual deletion of the resource.

Update:
Allows you to update the resource either in Project or at Shared location.

Update on Sync:
Choose to be notified when the topic is updated in the shared location. This option is selected by 
default. You can choose to turn it off if you do not want regular notifications. For example, if 
another user is making a large number of changes to a topic, you can turn off this option. Turn the 
option back on after the user is done with the changes.

Remove Link:
Removes the links of the selected resources to the shared location. The resources remain in the 
project as copied resources; any updates to the master copies in the shared location must be 
tracked manually.

Replace Link:
Replaces the current link with a link to another shared resource that has the same file extension.

Manage linked resource notifications

You use the Sync All command on the toolbar, to synchronize all the linked resources in real time.

When you choose the Sync All command, the Link Resource Notification dialog displays the following 
options:

Files modified at Shared Location. Update files in Project
Some of the files (displayed in the listbox) in the shared location have been modified since the last 
synchronization are hence are out-of-sync with the files in your project. Check this option, to 
synchronize your project files with the files in the shared location.
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Files modified at Shared Location and in Project. Override files in Project
Some of the files (displayed in the listbox) both in the shared location and your project have been 
modified since the last synchronization and hence are out-of-sync . Check this option, to override 
the files in your project with the files in the shared location.

Files modified in Project. Update files at Shared Location
Some of the files (displayed in the listbox) in your project have been modified since the last synchro-
nization and hence the shared location files are out-of-sync with the files in your project. Check this 
option, to synchronize the files in the shared location with the files in your project.

Configure Resource Manager settings

1) Do one of the following:
– Select File > Options. Click Resource Manager.
– Select Review > Open > Pods > Resource Manager. Click the Resource Manager Settings 

button.

2) In the Options dialog box, specify application-level and project-level settings for Resource Manager.

Specify application-level Resource Manager settings

1) In the Options dialog box, specify how you want to use shared resources in projects. Select either 
of the following options:

As Copy
Inserts a copy of a shared resource in the project. Resource Manager does not notify you or update 
the project if the original resource in the shared location is updated.

As Linked
Inserts a copy of a shared resource in the project and maintains a link between the copy (in the 
project) and the original (in the shared location). Maintaining a link helps Resource Manager to 
keep track of updates to the resource and allow you to update the resource in the project or in the 
shared location.

NOTE: If a linked style sheet includes references to other resources, RoboHelp does not track updates to 
the referenced resources.

2) Specify the frequency of checking updates to linked resources.
NOTE: Besides checking for updates according to this defined frequency, RoboHelp checks the status 
of linked resources when opening a project and when generating output.

3) Do one of the following:
– Specify the frequency of refreshing the shared location.
– Select Disable Auto-Refresh. NOTE: In either of these cases, you can use the Refresh icon in the 

Resource Manager pod for manual refresh.
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Specify project-level Resource Manager settings

You can specify your preferences for the update of linked resources at a project level. For example, for 
project A, you can specify that Resource Manager should auto-update all linked resources if they are 
updated in the shared location. On the other hand, for project B, you can specify that Resource Manager 
should notify you if a linked resource is updated.

To specify project-level settings for the update of linked resources:
1) Select one of the following options:

Notify me:
Notifies if linked resources are different from their original versions in the shared location

Do Not Notify:
Does not notify if linked resources are different from their original versions in the shared location

Auto update local project resources:
Updates all linked resources in the project with the changes in the shared location

Configure version control application

When sharing resources with other users, you often need to compare the version of the resource in your 
project with a version in the shared location. To compare project and shared files, you need to install a 
version control application on your computer. You the need to configure RoboHelp to recognize and 
work with this application:
1) In the Resource Manager pod, click Resource Manager Settings.
2) Go to the Version Control tab.
3) In the SharePoint Settings group:

– Enter or browse to the path of the version control application
– Enter required command line arguments. For details, see the documentation of the version 

control application.

4) Click OK to save the changes.
You will need to restart RoboHelp to ensure the changes take effect.

Manage comments and changes

You can review the comments and accept or reject them directly in Design Editor. You can also view the 
comments and changes as a list in the Review Pane pod, filter them in different ways, and accept or reject 
them. You can set a status for each comment in Review Pane.
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Review Pane pod

Review Pane displays the comments and changes made directly in Design Editor as well as the comments 
imported from a reviewed PDF.

To display the Review Pane pod, select Review > Open > Pods > Review Pane.
NOTE: If you’re inserting comments or editing the content in the Track Changes mode, click in Review 
Pane to refresh the contents of Review Pane.

Review Pane displays the following information about each comment or change:

Icon
Displays an icon indicating a comment or the type of change, for example, inserted text and deleted 
text.

Reviewer
Displays the reviewer name as configured in Acrobat (for review comments) or in File > Options (for 
tracked changes). See Configure review settings.

Modified
Displays the last modified date and time for the comment or change.

Details
Displays the comment or change in plain text.

Status
Displays the status of the comment. NOTE: RoboHelp supports three types of statuses: Accepted, 
Rejected, and None. When you import a PDF in which statuses are set, RoboHelp converts the 
Canceled and Completed statuses to None.

Type
Displays Review Comment or the type of change, Inserted and Deleted.

Path
Displays the topic in which the comment or change is present.

• To show or hide columns, right-click the Review Pane pod and select Show Columns. Select the 
columns.

• To sort the comments and changes on the type of information displayed in a column, click the 
header of that column.

• To access the previous or next comment in Design Editor, click the Previous icon  and the Next 
icon  in the Review Pane toolbar.
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Filter comments and changes

1) Click the Filter Entries icon  in the Review Pane toolbar, and select one of the following options:

Hide All
Hides all comments and changes in Review Pane as well as in Design Editor.

Show All
Displays all comments and changes in Review Pane as well as in Design Editor.

Show By Type
Enables you to select one of the three views: All Types, Review Comments, and Track Changes. All 
Types displays both comments and changes in Review Pane. Review Comments displays only 
comments in Review Pane. Track Changes displays only insertions and deletions made in the Track 
Changes mode in Review Pane.

Show By Reviewer
Enables you to filter comments and changes by specific reviewers. RoboHelp creates the reviewer 
list from comments and changes available in the project.

Show By Status
Enables you to select a status and view only comments with that status.

Show For All Topics
Displays comments and changes in all the open topics or only the active topic.

Group comments and changes

1) Right-click the Review Pane pod, and select Group By. Select one of the following options:
– Color
– Reviewer
– Modified
– Status
– Type
– Topic
– Path

TIP: Select None to remove grouping.

Reply or set a status to a comment

• To reply to a comment, right-click the comment and select Reply To Review Comment.
NOTE: RoboHelp displays the replies as child comments in Review Pane.
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• To set a status, select the comment, and click the Set Status icon  in the Review Pane toolbar. 
Select Accepted, Rejected, or None.

Accept or reject changes

You can review the changes made by reviewers in Review Pane, and accept or reject a change. In both 
cases, RoboHelp updates the content as well as Review Pane. For example, if you accept a change of type 
Deleted Text, the text marked for deletion is deleted from the content and the entry in Review Pane is 
deleted.

To accept changes, do one of the following:
• (All changes) Select Review > Tracking > Accept > Accept All.

TIP: To accept all changes only in a selected topic, select Accept All From <topic_name>.
• Select a change of type Inserted Text or Deleted Text in the topic. Select Review > Tracking > Accept 

> Accept And Move To Next, or click the Accept And Move To Next icon  in the Review Pane 
toolbar.

• Select a change of type Inserted Text or Deleted Text from Review Pane, and click the Accept And 
Move To Next  in the Review Pane toolbar.

To reject changes:
• (All changes) Select Review > Tracking > Reject > Reject All.

NOTE: To reject all changes in a selected topic, select Reject All From <topic_name>.
• Select a change of type Inserted Text or Deleted Text in the topic. Select Review > Tracking > Reject 

> Reject And Move To Next, or click the Reject And Move To Next icon  in the Review Pane 
toolbar.

• Select a change of type Inserted Text or Deleted Text from Review Pane, and click the Reject And 
Move To Next icon  in the Review Pane toolbar.

Delete comments

Do one of the following:
• Select the comment in the topic. Select Review > Comments > Delete.
• Select the comment in Review Pane, and click the Delete Review Comment icon  in the Review 

Pane toolbar.
NOTE: If you delete a comment, RoboHelp deletes the comment from Review Pane as well as from 
the content. If the comment has replies, the replies (child comments) are also deleted from Review 
Pane.

Review and collaboration in AIR Help

Rating, commenting, and moderation capabilities in AIR Help (Adobe AIR Application output) let you 
implement review and collaboration in flexible ways. Depending on your requirement, you can choose 
between a trust-based internal setup and a server-driven, secure external setup. Similarly, you can 
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enable or disable moderation, allow or disallow anonymous comments, and choose to work online or 
offline (with the ability to publish comments saved in offline mode).

Topic rating

If you are delivering Help as an Adobe AIR application, you can enable topic rating to gather user feed-
back. Users can rate any topic on a scale of 0-5 stars. The AIR Help application saves the topic rating for 
each user in a shared network drive location (same as the location for syncing comments) or on a Robo-
Help server and loads the ratings at the time of viewing a topic.

When a user opens a topic, the user sees the average rating for that topic. Users need to hover the mouse 
over the rating widget to see their own rating. If a RoboHelp server is set to save topic ratings, users are 
authenticated before providing rating. In offline scenarios, topic rating is saved in the local user database 
and a status is shown in the AIR Help application status bar. When the user goes online the next time and 
is authenticated by the server, the unsynced items are automatically synced.

To enable topic rating, see Configure collaboration.

Commenting

Store comments in a shared network folder

If you want to provide a trust-based collaboration framework for internal users, specify a shared network 
location to store comments. Users can read and add comments if they have read/write access to that 
network location. Comments from each user are stored in a separate XML file at the location.

For information about how to specify a shared network location, see Configure collaboration.

Store comments on a RoboHelp server

If you want to allow commenting by users outside a corporate network, store comments on a RoboHelp 
server. The server authenticates users before allowing them to read or add comments.
NOTE: RoboHelp Server provides user authentication through both database and LDAP.

Key steps to implement and use collaboration using a RoboHelp server

1) (Author) In RoboHelp HTML, generate AIR Help with the following layout settings:
– Enable Topic Rating
– Enable Commenting
– Enable Comment Moderation
– In Set Location For Comments And Topic Ratings, select RoboHelp Server and specify the 

server URL.
For more detailed steps, see Configure collaboration.

2) (Administrator) In RoboHelp Server Web Administrator, sign in as an administrator and click 
Settings > Moderation. Specify the following settings:
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– Select Allow Post Anonymous if you want to let users comment anonymously on Help 
content.
NOTE: RoboHelp Server authenticates all users. When anonymous posting is enabled, users 
have the option to post a comment without their usernames being displayed.

– Select Mark New Comments As Pending if you want to display user comments only after a 
moderator approves them.
For more detailed steps, see Using RoboHelp Server 10.

3) (User) Launch the AIR Help application. Click Show/Hide Comments Pod and add comments. See 
Add comments and Moderate comments.

Configure preferences for comments

Users can configure the following preferences for comments in AIR Help (output):

Always Use Log-In Name For Reviewer Name
If comments are stored in a shared network folder, users can specify the name they want to display 
with their comments. By default, RoboHelp displays the user name as defined in the user area.

NOTE: If comments are stored on a RoboHelp server, RoboHelp uses the login name.

Use Default Location To Sync Comments
Users can select this option to specify a new location for storing comments. The default location is 
the location specified at the time of generating AIR Help.

Receive Comments From Shared Folder
Users can select this option to receive all comments automatically when the Comments pod is 
displayed after launching AIR Help.

Show Moderation Pod
Users can select this option to enable the moderation mode if they have moderator privileges. In 
trust-based commenting (shared network location), moderators only need access to the password 
specified by the author at the time of generating AIR Help. In server-based commenting, modera-
tors need admin privileges.

NOTE: Users can enable the moderation mode only if the author has enabled moderation at the time of 
generating AIR Help.

Delete All Comments
Select to delete all comments from your local database. When you click Send And Receive after 
selecting this option, all your comments are deleted from the shared location or the RoboHelp 
server.
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Add comments

Users can add comments if commenting is enabled when generating the Adobe AIR output. Comments 
are stored locally until you click Send To Server or Send and Receive option.
1) Click Show/Hide Comments Pod to display the Comments pod.
2) To add a comment, click Show/Hide Add Comment. Enter the comment and click Save.
3) Click Send And Receive to publish saved comments.

Comment moderation

Regardless of whether you store comments in a shared network location or on a RoboHelp server, Robo-
Help supports comment moderation. If moderation is enabled, the status of an unmoderated comment 
is Pending or Accepted as set in the SSL. A rejected comment can be seen only by the user who added 
the comment.

Moderate comments

In the AIR Help output, do the following:
1) Click Preferences.
2) Click Comment.
3) Specify the password.
4) Select Show Moderation Pod. Click OK.
5) Use the following options to filter comments:

Shared location RoboHelp server

Enabling 
moderation

Disabled by default Enabled by default
Admins can modify the settings using 
the Admin UI on RoboHelp Server

Authentication Not required to read or add comments
Required to moderate comments
Moderator password is provided by 
authors and can’t be changed

Required to read or add comments if 
anonymous commenting is not allowed
Admin privileges required to moderate 
comments

Status of new 
comments

Moderators can modify the 
settings.xml file in the location 
where comments are centrally located.
If the moderation state attribute is set to 
‘on’, new comments remain in the 
Pending state until they are moderated. 
If it is set to ‘off’, all new comments are 
marked Accepted by default and are not 
queued for moderation. A moderator 
can still reject or delete the comments 
later.

The Mark New Comments As Pending 
option set on the server determines the 
status of new comments.
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View All list
Select Pending, Rejected, or Accepted to filter comments by status.

Comments By list
Select an author name to filter comments by an author.

Comments For Current Topic
Click to view comments on the current topic only.

Comments For All Topics
Click to view comments on all topics.

6) Click Accept, Reject, or Delete to moderate a comment.
7) Click Send And Receive to synchronize the comments with the shared location or the server.
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Advanced program features

ActiveX controls

About ActiveX controls

ActiveX controls are Microsoft Windows-based applications that you can plug into projects. They are 
small, pre-compiled, modular, and reusable. Web developers use ActiveX controls to extend the func-
tionality of their HTML pages. You can use ActiveX controls to extend the functionality of topics.

ActiveX controls work exclusively in browsers that support ActiveX technology. Microsoft Internet 
Explorer and the HTML Help viewer support these controls. Netscape Navigator does not support ActiveX 
controls.

RoboHelp includes several ActiveX controls for HTML Help functionality, including link controls and HTML 
Help controls. You can add other ActiveX controls. ActiveX controls can perform credit card transactions, 
spreadsheet calculations and provide database communications.

Some ActiveX controls are included with projects. For example, the HHCTRL.OCX provided by Microsoft 
is a required ActiveX control. It enables the table of contents, index, and full-text search.
NOTE: Copy ActiveX controls to and register them on user systems. ActiveX controls are not included in 
compiled CHM files. For WebHelp and WebHelp Pro projects, Internet Explorer 4.0 or later supports 
ActiveX controls.

Add design-time controls

NOTE: This information applies to Microsoft HTML Help projects.
1) Insert the cursor in the topic where you want to place the control.
2) Select Insert > HTML > Javascript > Design-Time Control.
3) From the list of controls, select a control to insert into the project.
4) Click OK.

Types of HTML Help ActiveX controls

Calendar Control
When users open a topic with a calendar control, a calendar appears in the text. Users can select 
months and years to view and print.

Custom Buttons
Users can download the latest information from a database or the latest version of the application 
with custom buttons.
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Banner
When users open a topic that contains a banner, they are directed to the content. The banner lets 
you design and test text, images, and icons to display at designated intervals in a topic.

Chart
Lets users draw charts that they can view and print. They can change the chart properties by 
selecting options and check boxes. They can also enter data to display in the chart or graph.

Calculations
Lets users enter data, for example, in an online test. Users can obtain test results and view results 
(the correct answers to each question).

TIP: You can insert any ActiveX control registered on the system into topics in projects. To add other 
ActiveX controls, install and register the ActiveX control on the system before using it.

Add ActiveX controls

For the controls to work, distribute and register Custom ActiveX.ocx files on the user systems. (The Robo-
Help license allows you to distribute these controls.) By default, the controls are at C:\Program 
Files\Adobe\Adobe RoboHelp [version]\Redist.
1) Insert the cursor in the topic where you want to place the control.
2) Select Insert > HTML > Javascript > ActiveX Control.
3) Select the ActiveX control to add and click OK.
4) Double-click the ActiveX control to edit its appearance and properties. HTML Help doesn't support 

all ActiveX controls, and some controls don't have properties dialog boxes.

Customize ActiveX control properties

1) Double-click the ActiveX control in the topic to open the Properties dialog box, and view ActiveX 
control properties including the following:

Code Source
Provides an address (URL) for the latest copy of the ActiveX control (if it is not on the local system).

Data Source
Provides an address (URL) that specifies where the ActiveX control searches to find any of its data 
arguments.

ID
Displays the identification of the ActiveX control (if it includes an ID).

2) Click the ActiveX Control tab, and click Add to specify the following properties. Then click OK.
– In Name, select the property type to add from the list of customizable properties for the 

ActiveX control.
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– In Value, enter a value for the selected property.

3) Click the Margins tab, and specify the margins.
4) Click the Borders tab. Under Settings, select Box or Custom.

The Custom setting lets you add a border of a different size and color to each side of the ActiveX 
control. Specify line style and border color and thickness, and preview the selections.

5) In the Size tab, specify the following Size properties:
– Enter Preferred Width and Height in pixels (px) (default) or percentages (%).
– Click Maintain Aspect Ratio to keep the height and width proportional.

Remove ActiveX control properties

1) In the Design Editor, double-click the ActiveX control to open the Properties dialog box.
2) Select the name or value of the property to delete.
3) Click the Delete button.

Customize the calendar control

1) Select Insert > HTML > Javascript > ActiveX Control.
2) Select Calendar Control [version]. The control appears in the Design editor, as shown in the 

following example:

3) Double-click it and change the available settings in the ActiveX Control tab.
4) To change the font color for weekday headings, click Add in the ActiveX Control tab.
5) Select Dayfontcolor, enter a color value, and click OK.
6) To view the calendar, click the View button .

Applets

1) Select Insert > HTML > Javascript > Applet.
2) Add the following information:

Code
The class files to use.

Code Base
Path to the selected class files. If the applet is in the project folder, leave this field blank.
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Name
Name for the class files. Assign applet names for several applets to communicate with each other.

Alt Text
alternate text used if the browser cannot display the applet.

Parameters
Name and value of parameters defining variable elements of an applet, such as background color 
or font.

Add
Opens a dialog box to enter the name and value of applet parameters. Examples of name and value 
are FontType and FontType=Arial respectively.

Edit
Opens a dialog box to edit parameters.

Delete
Removes selected parameters.

Size
Sets object width and height.

Margins
Sets object margins.

Borders
Sets a border around the object.

Notes:

• To use an applet in a topic, move the applet to the project folder before adding it.
• Most applets are class files. Work with the developer to obtain class files for the applet.
• To add class files to version control, manually add them to the Baggage Files folder.
• Applets work only in WebHelp, WebHelp Pro, FlashHelp, and FlashHelp Pro projects.
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Forms

Workflow to create forms

NOTE: Forms created in the Design Editor must have a corresponding Common Gateway Interface (CGI) 
script on the server.
1) Add the form and set form properties.
2) Add specific form elements.
3) Link to a script that acts on the data that the user enters. This step requires a CGI script written in 

a scripting or programming language.
Top of Form
Bottom of Form

Add a form to a topic

1) Select a location where you want to insert a form.
2) Select Insert > HTML > HTML Form > Form. A rectangular box is inserted to hold the form elements.

Set form properties

1) Right-click inside a form and select Form Properties.
2) Set the following options in the Form tab, and then set Size in pixels and Margin, Border, and 

Shading options. Click OK.

Action
In the Form Action box, enter the address to use to carry out the action of the form.

Method
From the Method list, select the method to use for sending form data to the server.

Post
Sends the data through an HTTP post transaction

Get
Appends the arguments to the action URL, and opens it as if it is an anchor.

Name
In the Name box, enter the form name.

TIP: If you want to include a background image or pattern, click the Browse button  to locate the 
image to use.
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Form elements

Form elements are available from the Design Editor.

Text Field
Lets users type text in a form. You can enter default text in the field to guide users, or you can leave 
the field empty.

Multi-Line Text Field
Lets users enter over one line of text in a form field.

Hidden Field
Lets users add names and values for hidden fields.

Password Field
Lets users apply password protection. When users type in the box, the viewer displays the pass-
word as a series of asterisks (*) for confidentiality.

Radio Button
Lets users select only one alternative from a group. Options are presented in a list, one of which is 
selected by default. Clicking a new button clears the previously selected item.

Check Box
Enables users to select any combination of alternatives. Check boxes can represent a group of 
non-exclusive choices.

Button
Lets users insert a plain button on the form, designate the caption, and perform customized actions 
defined by the author.

Submit Button
Lets users submit a completed form to a server.

Image Button
Lets users insert a custom image on top of a button that performs an action when clicked.

Reset Button
Lets users reset the form to its initial state.

Drop-Down Menu
Lets users insert a drop-down menu in the form. Users can select one or more items, depending on 
how you configure the drop-down menu.
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Add and edit text fields

1) Select a location in the form to insert a text field or multi-line text field, and select Insert > HTML > 
HTML Form > Text Field. You can also select Insert > HTML > HTML Form > Multi-Line Text Field.

2) For a text field, double-click the element to open the Text Field dialog box, specify the following 
properties, and click OK.

Control Type
Indicates the type of field.

Control Identifier
Indicates the name to associate with the field. Not displayed on the form. The CGI program uses it 
to identify the form element. To include a label next to the text field, type the text in the Design 
Editor.

Initial Text
Displays text when the form opens. (If you select Password under Control Type, all characters in this 
field appear as asterisks.)

Preferred Width
Sets the width of the field.

Length Limit
Sets the maximum number of characters that users can enter.

3) For multi-line text fields, double-click the element to open the Multi-Line Text Field dialog box, 
specify the following properties, and click OK.

Control Identifier
Name for the field. Not displayed on the form, but used to identify the form element. To include a 
label next to the text field, enter text in the Design Editor.

Rows
Number of rows in the field.

Columns
Number of columns in the field.

Initial Text
Text that appears when the form opens.
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Add special fields

1) Place the cursor where you want to insert the field.
2) Select Insert > Variables > Field.
3) Select the type of field from the Value list:

Date
Day, month, year or combinations of the day, month, and year

Time
Time of day (including AM or PM, if desired)

Title
Topic title or other text

File
Filename format

Variable
Name and value

4) Select a format for the field from the Format list.
5) (Optional) Click New. A line with the default formatting is added at the end of the Format list. Type 

a name for the new format in the Current Format box. The Example column displays how the field 
appears in the topic.

6) Click OK. The field is added to the topic.

TIP: Select Auto-Update This Field to update the field upon opening the topic. To view topic fields, from 
the View menu, select Show, and choose Fields.

Add buttons to forms

1) Select a location to insert the button, select Insert > HTML > HTML Form > Button, and double-click 
the placeholder button that appears.

2) In Control Type, select the type of button:

Submit Button (Caption)
Appears as a standard button and sends the form to the CGI script for processing.

Submit Button (Image)
Appears as a custom image and sends the form to the CGI script for processing.

Reset
Clears the form of any entries made by the user.
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Plain Button
Lets you customize the action the button performs.

3) In the Control Identifier box, type the button name.
4) In the Button Caption box, type the button caption.
5) If you select Submit Button (Image), specify a screen tip in the Screen Tip box.
6) If you select Submit Button (Image), specify a button in Button Image Path.
7) Click OK.

Add image buttons

1) Place the cursor inside the form to contain the button.
2) Select Insert > HTML > HTML Form > Image Button, and click OK.
3) Enter an image name, select an image from the Images In Project Folder, or choose an image in the 

Gallery tab.
4) To specify screen tip, button caption, and size, double-click the image and select or enter the 

desired values.

Add check boxes

1) Select a location in the form to insert a check box.
2) Select Insert > HTML > HTML Form > Check Box.
3) Double-click the check box, and specify the check box options:

Control Type
Select Check Box.

Control Identifier
Type the name to associate with the check box.

Control Value
Enter the value for the control.

Select This Control Is Initially Selected
Makes the option a default selection when the topic is opened.

4) Click OK.

Add radio buttons

1) Select a location in the form to insert a radio button.
2) Select Insert > HTML > HTML Form > Radio Button.
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3) Double-click the radio button and specify the properties:

Control Type
Select Radio Button.

Control Identifier
Type the name to associate with the radio button.

Control Value
Enter the value for the option.

Select This Control Is Initially Selected
Makes the option a default selection when the topic is opened.

4) Click OK.

Add drop-down menus

1) Select a location in the form for the menu.
2) Select Insert > HTML > HTML Form > Drop-down Menu.
3) Double-click the drop-down menu.
4) Set options for the Drop-down Menu tab:

Control Identifier
Type a name for the menu. This name is not displayed. It is used to sort data from the form. Use 
the Design Editor to add a label next to the menu.

Rows
Set how options display. For example, set to 1 to show one item at a time.

Allow Multiple Selections
Lets users select multiple options.

5) Set options on the Options tab:

New
Lets you specify a new label. Enter a name in the Label field, and a value in the Value field.

Selected
Marks the option as a default.

6) Click OK.
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Frames

About frames and framesets

Design framesets to customize navigation:

Frames
Divide the viewer into separate regions for separate topics.

Framesets
Allow some topics to change while topics in another frame remain stationary.

The frameset tells the viewer how to display the frames and which topics to display inside each frame. 
Topics that are displayed in the frames are the frame source topics. You can use framesets as regular 
HTML topics.

You can have multiple frames in a frameset. Because screen space determines how many frames are 
practical, too many frames give the viewer a cluttered look. Sometimes only parts of words appear inside 
each frame. Numerous frames cause increased load times.

Notes:

• Printing is restricted to one frame at a time, although you can print the entire project from the 
viewer or browser.

• Target hypertext links to specific frames.
• Hypertext-linked external topics or URLs sometimes display incorrectly.
• Framesets are saved in the HTML Files (Topics) folder in the Project Manager. A square icon  indi-

cates frameset files.

RELATED LINKS:
Create text links

Create framesets

1) Select Project > Open > Pods > Project Manager.
2) Right-click Project Files and select New > Frameset, and click a template.
3) Enter a title. The title becomes the filename. Click Next.
4) Define the properties for each frame in the frameset:

– In Name, enter a name.
– From the All Folders pop-up menu, select the file or URL to attach to the frame. The selection 

appears in the Initial File field.
– Design the frame, specifying values for the height, width, frame margins, and border color. 

Specify the following options, and then click Finish:
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No Resize
Prevents users from resizing the frame.

Scrolling
Controls the display of scroll bars inside the frame.

Auto
Displays a scroll bar if the entire topic content can be viewed only by scrolling.

Yes
Always displays scroll bars.

No
Does not display scroll bars.

New Topic
Creates a topic and assigns it to a frame.

Change frames and framesets

1) Select Project > Open > Pods > Project Manager.
2) In the HTML Files (Topics) folder, double-click the frameset file.

NOTE: If the folder isn’t visible, click the Toggle Project Manager View button .
3) Make changes.

NOTE: You cannot select a template for a defined frameset. To use a different template, create a frameset.

Change the size of a frame

NOTE: This procedure does not change the default settings.
1) Drag the cursor to the gray line between the two frames (frame divider).
2) After the cursor has changed, drag the frame divider left or right to make one frame larger and the 

other frame smaller.

Remove framesets

If you accidentally delete a frameset, you can import it back into the project if it has not been removed 
from the hard disk.
1) Select Project > Open > Pods > Project Manager.
2) Expand the HTML Files (Topics) folder.
3) Select the frameset file to remove.
4) Click the Delete button .
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TIP: Deleting a frameset in the TOC, or one that is referenced by a hypertext link, moves the frameset to 
the Broken Links folder. To add it back into the project, right-click and select Restore.

Link framesets to books or pages

1) Select Project > Open > Pods > Project Manager.
2) Double-click the Table Of Contents folder.
3) Right-click a table of contents in the folder, and click the New TOC Book  or New TOC Page tool  

in the TOC toolbar.
4) Enter a title to appear in the TOC, and select Book With Link.
5) Select a frameset from Existing Topics, and click OK.

Link to topics in frames

1) Ensure that the frameset is open in the browser or viewer.
2) Open a topic and select the text to link.
3) Right-click and select the Insert Hyperlink button .
4) In Link To, click the triangle pop-up menu  to select a type of destination.

Or, select the topic or URL from Select Destination (File Or URL).
5) In the Display In Frame pop-up menu, select the destination. This option defines the frame for 

displaying content.

Page Default (None)
Opens the topic in the same frame as the Help file window.

New window
Opens the topic in a new browser window.

Same Frame
Opens the topic in the same frame as the current topic.

Parent Frame
Opens the topic in the link parent frame and hides the original topic.

Whole Page
Opens the topic in the Help file window, replacing the original topic or frameset.

6) Click OK.
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HTML Help controls

Reuse HTML Help controls

HTML Help controls are portable. You can copy the controls into topics and change them to suit their 
locations.
1) In the Design Editor, open the topic that contains the control to reuse.
2) Right-click the control and select Copy.
3) Open the topic that needs the control.
4) Right-click the place for the control and select Paste.
5) To change the control, double-click it.

Add WinHelp topic controls

NOTE: You cannot call topics with the @ character in the title from a Related Topics control in compiled 
HTML Help files.
1) In the Design Editor, click a location for the control.
2) Select Insert > HTML > Javascript > WinHelp Topic.
3) Set the button options.

Text
Inserts a standard gray button with black text. Edit the text for the button in the text field.

Image
Inserts a BMP or an ICO file. Click the folder button to browse to the file. Select the file and copy it 
into the project.

Hidden
Inserts a control that is not visible in the topic. This option does not insert the control as an object 
in the topic.

4) Click Next. Select the WinHelp file and topic.

Help
Specifies the Help file. Click Yes to copy the HLP file into the project folder. If the WinHelp system 
includes a table of contents file, click Yes to copy it into the project folder.

Display As Popup
Displays the WinHelp topic in a pop-up menu.

Window
Specifies the type of window.
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Specify Topic
Defines topic by topic title, topic ID, or map number.

5) Click Next to set the font options for the button label.
6) Click Finish. Compile the Help system to test.

TIP: Distribute the HTML Help system with the HLP and CNT files.

RELATED LINKS:
Add design-time controls

Add index controls

NOTE: Applies to Microsoft HTML Help projects only.

The tri-pane design includes an Index tab, where users can access keywords.

If the project does not support a tri-pane design, you can add an index control to a topic to make the 
index file available. The index appears when users open the topic with the index control.

If the topic is in a subfolder, copy the index file (.HHK) to the subfolder before you add the control.
1) In the Design Editor, click the place in the topic to add the index.
2) Select Insert > HTML > Javascript > Index.
3) To test the index control, compile the project. The index control displays the same index as in the 

final output.

TIP: You can use other index files (HHK) in the project. Copy the HHK file and associated files (topics, 
images, multimedia) to select the HHK file with the index control.

Add table of contents controls

NOTE: Applies to Microsoft HTML Help projects only.

When users open a topic, the TOC appears.

If a topic is in a subfolder, copy the contents of the file into the subfolder before adding the control.
1) In the Design Editor, click the place in the topic to add the TOC.
2) Select Insert > HTML > Javascript > Table Of Contents.
3) To test the control, first generate the project. The Table Of Contents control displays the same table 

of contents as in the final output.

TIP: You can link other contents files in the project. Copy the HHC file into the project to select the HHC 
file with the TOC control.

Add splash screens

NOTE: Applies to Microsoft HTML Help projects only.
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You also can include splash screens when topics open. You can use Windows bitmaps (BMP) and GIF 
images.
1) In the Design Editor, open the topic to display the splash screen when opened.
2) Select Insert > HTML > Javascript > Splash Screen.
3) From Image File For Splash, click Browse and navigate to the image to use in the project.
4) Highlight the image file and click Open.
5) In Duration Of Splash Display (Seconds), set the amount of time that the image remains on the 

screen.
6) Click Finish. To test the splash screen, preview the topic.

TIP: You see a Splash object that identifies its location in the file. This object is not displayed in the viewer. 
When the topic is opened, only the image is displayed.

Add shortcuts

NOTE: Applies to Microsoft HTML Help projects only.
1) In the Design Editor, click the place in the topic to add the shortcut control.
2) Select Insert > HTML > Javascript > Shortcut Wizard.
3) Set the button options.

Text
Inserts a gray button that performs the action.

Image
Inserts a custom image (BMP or ICO) that performs the action.

Hidden
Inserts a control that is not visible in the topic.

4) Click Next to set up shortcut functionality.

Program To Run
Specifies the program to run from the control. Navigate to the drive/folder where the EXE file is 
located and double-click it.

Program Parameters
Defines command-line arguments to apply when the program runs, if needed.

Window Class Of Program Window
Specifies the window class.

Topic To Display
Specifies a topic to display if the program cannot be located.
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5) Click Next to set the font options for the button label.
6) Click Finish.

Add HHCTRL version controls

An HHCTRL version control shows the version number of the Microsoft HTML Help on a user system.
1) In the Design Editor, click the place in the topic to add the control.
2) Select Insert > HTML > Javascript > HHCTRL Version.
3) Select button options.

Text
Inserts a gray button with black text that performs the action. Use the existing label or edit the text.

Image
Inserts a custom image (BMP or ICO) as the button.

Hidden
Inserts a control that is not visible in the topic. See the developer for a script that closes the 
window. You can also add scripts to topics.

4) Click Next to set the font options for the button label.
5) Click Finish.

TIP: Preview the topic to test the HHCTRL version control.

Add close window controls

1) In the Design Editor, click where you want to add the close window control in the topic.
2) Select Insert > HTML > Javascript > Close Window.
3) Set up the button options for the control.

Text
Inserts a gray button that performs the action when selected. Edit the text to appear on the button.

Image
Inserts an image that performs the action when selected.

Hidden
Inserts a control that is not visible in the topic. See the developer for a script that closes the 
window. You can add scripts to topics.

4) If you are adding a standard button, click Next and set up the font options for the button label. You 
can assign a different font, style, and size.
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5) Click Finish.

TIP: To test the close window control, compile the Microsoft HTML Help project.

Change HTML Help controls

NOTE: Applies to Microsoft HTML Help projects only.
1) In the Design Editor, open the topic with the control.
2) Double-click the control.

TIP: Right-click a control and select Design-Time Control Properties to change properties.

Remove HTML Help controls

1) In the Design Editor, open the topic that contains the control to remove.
2) Select the control.
3) Click Delete.

TIP: Click Undo to restore a control that you removed by mistake.

Information types (for HTML Help)

Information types are designed for HTML Help (CHM Help) only.

About information types (HTML Help)

Information types control which books and pages a user can access from the Contents tab in the HTML 
Help viewer. They are an optional feature that you can use in Microsoft HTML Help projects only.

You first define categories and add information types to them. Then assign topics (pages or books) to the 
information types. From the Contents tab in the HTML Help viewer, users can customize books and pages 
that appear in the table of contents. If you do not assign an information type to a topic, the topic appears 
in the HTML Help viewer regardless of user customization.

A category is a way to group information types, such as job description or skill level. You can create up to 
10 categories and 32 information types.

Information types fall into two categories:

Inclusive
All information types from a category are available to users.

Exclusive
Restricts users so they can select only one information type from a category. For example, you can 
assign Exclusive classifications by skill level, so that users can access only the Help topics that 
pertain to their skill level.
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With the current version of Microsoft HTML Help, it is not possible to filter Index and Search tabs to 
support information types. Users cannot access a topic from the HTML Help index that is not in the infor-
mation types that they select.

For a detailed explanation of information types, see Strategies for Using Information Types in HTMLHelp 
by Rob Houser.

Define categories and information types (HTML Help)

1) Select Edit > Information Types.
2) In the Category field, enter a name.
3) Classify the category:

Inclusive
Users can select any combination of information types in a category.

Exclusive
Users can only select one information type in a category.

Hidden
Users do not see these topics in the TOC. They cannot customize information types to filter them. 
If you are assigning topics to information types for context-sensitive Help, select this option.

4) Click Add Category. Repeat steps 2 through 4 to add more categories.
5) Select a category to add information types.
6) In Information Type, enter an information type.
7) Click Add Info Type. Repeat steps 6 and 7 to add more information types in the same category.
8) Click OK.

Assign information types (HTML Help)

After creating information types, assign them to books or pages in a TOC. NOTE: Make sure that Microsoft 
HTML Help is set as the primary layout.
1) In the Project Manager pod, double-click a table of contents in the Table Of Contents folder.
2) In the TOC pod, right-click the book or page, and select Properties.
3) Click the Advanced tab.
4) Select Use Information Types.
5) Select an entry in Information Types and click Types.
6) Select an information type.

http://www.userassistance.com/presentations/infotypes.htm
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Access information types from the HTML Help viewer

When users open Help systems, the system prompts them to select information types. All topics not 
assigned to information types are available from the index.
1) Click the Contents tab.
2) Select Custom.
3) Click Next. The list that appears depends on the Exclusive or Inclusive classification of the informa-

tion types.
4) Select any combination of information types, and click Next.
5) Click Finish. The Contents tab is updated to display only pages that correspond to the information 

types selected.

TIP: If the Help system displays in the Internet Explorer browser, you can use information types as long as 
the first topic includes the TOC ActiveX control.

Edit information types (HTML Help)

Change categories for information types (HTML Help)

1) Select Edit > Information Types.
2) From the list of categories, select one.
3) Click in the Category box and edit the text.
4) To change its classification from Inclusive to Exclusive or Hidden, click the option. Then click the 

Change button.

Remove categories from information types (HTML Help)

When you remove a category, you also remove its associated information types.
1) Select Edit > Information Types.
2) From the list of categories, select one to remove.
3) Click Delete Category. The category along with all its information types are deleted.

Remove information types (HTML Help)

Remove information types from books and pages (HTML Help)

1) In the Project Manager pod, double-click a table of contents in the Table Of Contents folder.
2) In the TOC pod, right-click the book or page, and select Properties.
3) Click the Advanced tab.
4) From Information Types, choose the topic folder.
5) Click Remove to remove assignments.
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Remove information types from categories (HTML Help)

1) Select Edit > Information Types.
2) From the list of categories, select the one that includes the information type to remove.
3) Select the information type.
4) Click Delete Info Type.

Scripts

About scripts

Scripts are coded instructions that tell the HTML Help viewer or browser how to react to events. Scripts 
add power and more functionality to HTML Help systems, intranets, and websites.

Two common supported scripting languages are VBScript and JavaScript. The scripting used is the same 
kind used by web pages. Scripts are uncompiled. You can view them in the RoboHelp HTML Editor. 
Because they are uncompiled, they do not require a dynamic-link library (DLL).

Because HTML Help does not support macros, use scripts to provide the same functionality that macros 
provide for WinHelp systems. Application developers can provide scripts for you to plug right into the 
topics.
NOTE: Add support files used in scripts (such as image files) to the Baggage Files folder to include in the 
project.

Add a script to an HTML topic

1) In the Design Editor, click the place in the topic to add the script.
2) Select Insert > HTML > Javascript.
3) In the Source tab, enter the scripting code.

– If you first copy the script to the Clipboard, you can click inside the Source tab and paste the 
data into the box. You can also type the script directly into the box.

– Enclose the script within comment tags <!-- and --> for compatibility with all browsers.

4) Select the Tag tab, select a Name or Value tag to edit, and select Edit Name or Edit Value.
5) Change the tag, as needed, and click OK. The value can be VBScript or JavaScript.

The icon  indicates where the script is inserted in the topic. To edit the script, double-click the icon.
6) Test the HTML file after you generate output.

Event support in scripting

Use events in scripts to invoke functions at specific trigger points defined in RoboHelp.
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Predefined events

The following events are predefined in RoboHelp:

NOTE: Event names are not case-sensitive.

Register a function for an event

You can register a function defined in a script for an event from the Script Explorer pod or by modifying 
the script. When multiple functions are registered for the same event, RoboHelp runs the functions in 
the order in which they have been registered. TIP: You can break the chain of execution of functions regis-
tered for the same event by changing the return value of a function to false.

Register using the Script Explorer pod

1) Select the script in the Script Explorer pod. Right-click and choose Register For Event.
2) In the Register Event dialog box, specify the function name that you want to register and select an 

event name from the Event Name list.
NOTE: Make sure that you specify the function name as it is defined in the script. Event names are 
predefined in RoboHelp. For example, the SaveAll event runs when you choose File > Save All.

3) Click OK.

Register through a script

Use the following syntax to register a function to an event:
registerEvent (EventName:string, FilePath:string, FunctionName:string)

Event Description Argument

SaveAll Sends notification when File > Save All is 
executed

None

OpenTopic Sends notification when a file is opened 
in the editor

Full path of the file

CloseTopic Sends notification when a file is closed 
in the editor

Full path of the topic

PreSSLGenerate Sends notification before an SSL is 
generated

Name of the layout

PostSSLGenerat
e

Sends notification after an SSL is 
generated

Name of the layout

PreImport Sends notification before a file is 
imported

Full path of the file being imported

PostImport Sends notification after a file is 
imported

Full path of the imported file
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NOTE: You can specify arguments with an event to retrieve information that you can use for processing. 
For example, you can retrieve the filename in an import operation.

Unregister a function

Unregister using the Script Explorer pod

1) Select the script in the Script Explorer pod. Right-click and choose Unregister.

Unregister through a script

Use the following syntax to register a function:
unregisterEvent (EventName:string, FilePath:string, FunctionName:string)

About ExtendScript Toolkit support

Create your own scripts to automate repetitive tasks and time-consuming workflows. For example, you 
can write a script that counts the images used in a RoboHelp project.

RoboHelp provides a set of sample scripts that you can use or customize. You can access these sample 
scripts from Tool > Scripts.

Native Mobile App Generator
Use this script to package Help content as a native mobile app for the Android mobile operating 
system.

EclipseHelp Generator
Use this script to generate EclipseHelp output.

EPUB 2.0.1 Generator
Use this script to generate EPUB 2.0.1output.

WebHelp To CHM Converter
Use this script to generate WebHelp output as a single CHM file. Before running the script, you can 
customize the WebHelp layout to add the color and branding you prefer in the CHM output.

Output Generator With Glossary Restyling
Use this script to generate output for a selected layout with the glossary as popups or tooltips. By 
default, RoboHelp generates output with the glossary as expanding hotspots.

NOTE: Run Glossary Hotspot Wizard once before running this script.

Image Extension Updater
Use this script to update the file extension of image paths referred across topics in a project. By 
default, the script converts file extension .bmp to .png in each topic. You can update the script to 
convert different extensions.
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NOTE: The script updates the name of the image file referred in the topic; it does not create any image. 
The images with the new extension should be present in the location where the original images reside.

Link Converter
Use this script to convert an anchor link href target across all the files in a RoboHelp project. For 
example, define a link to convert www.adobe.com to www.adobe.com/support/ across all the Help 
files in a project. See the script file for more information.

Master Page Import
Use this script to import master pages.

UDV Converter With UI
Use this script to convert a keyword into a user-defined variable and change its value across all files 
in a project. Enter a keyword, a user-defined variable name, and its value.

UDV Converter
Use this script to convert a keyword into a user-defined variable and change its value across all the 
files in a project. See the script for more details.

Word Count Generator
Use this script to get a word count for an opened RoboHelp project. It provides a word count by 
topic and by project. To run the Word Count script, right-click the script and select Run. The word 
count summary appears in the Output View pod.

Reference Page Image Updater
Use this script to insert images of reference pages in topics generated through FrameMaker docu-
ment import. For more details, see the DESCRIPTION section in the script file header.

Style-based Index Generator
Use this script to create style-based index entries for keywords present in the topics of a project. 
The styles need to be specified in the script. The script searches all the keywords with the 
mentioned styles in each topic and creates index entries for them. By default, the script creates 
entries for h1 (Heading 1) and "h2" (Heading 2) styles. The style array in the script should be 
updated with the desired style names.

Creating scripts

You can write scripts and debug them using the Script Explorer of the ExtendScript Toolkit.

John Daigle provides a step-by-step introduction in Automating tasks with built-in scripting on the Adobe 
RoboHelp video tutorials page.

For information about the methods covered in the Data Object Model, see Adobe RoboHelp Scripting 
Guide.

http://www.adobe.com/go/learn_rh_scripting_guide_en
http://www.adobe.com/go/learn_rh_scripting_guide_en
http://www.adobe.com/designcenter/robohelp/videos/
http://www.adobe.com/designcenter/robohelp/videos/
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Manage script folders

Create a script folder
Create a folder for storing specific scripts. For example, you can store scripts that record data in one 
folder and scripts that display output in another folder. NOTE: The sample scripts are stored in the 
scripts folder of your RoboHelp installation: C:\Programe Files\Adobe\Adobe RoboHelp 
[version]\RoboHelpHTML\presets\scripts

Drag folders
You can drag folders into and out of the Script Explorer.

Import and export
You can export and import folders in different projects and locations. To import or export a folder, 
it must contain at least one script file.

Manage script files

Create a script file
Create a script file and specify a name.

Edit
Right-click a script in the Script Explorer or Windows Explorer to edit it using ExtendScript Toolkit. 
Double-click a script file to edit it using a third-party editor. TIP: To add a third-party editor, go to 
File > Options, click the Associations tab, and add the .jsx filename extension for the third-party 
editor.

Import and export
Export a script file to or import it from a computer or a network.

Drag script files
Drag a script file into different folders on a computer or a network.

Run scripts

Using the command line
You can run scripts by entering a command in the following format:

Robohtml.exe -x [scriptfilenames]
You can specify multiple script filenames, separated by a space, to run one script after another. If 
the filename path contains a space, enclose the filename path in single or double quotation marks.

Using the Tools menu
You can use the RoboHelp scripting samples available at Tools > Scripts or create new scripts to run 
them; see the ExtendScript Toolkit documentation.
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Using Windows Explorer
Double-click a script to open it in the ExtendScript Toolkit and run it.

Using ExtendScript Toolkit
Start RoboHelp directly from the ExtendScript Toolkit and run your scripts. To start RoboHelp, 
select Adobe RoboHelp [version] from the ExtendScript Toolkit pop-up menu. Click the Click To 
Connect To Target Application  to run RoboHelp. The icon is green to indicate that RoboHelp 
HTML is running. NOTE: If you don’t select Adobe RoboHelp in the ExtendScript Toolkit, and you try 
running a script, an error occurs.

Twisties

Use twisties to enhance glossary terms, drop-down text, and expanding text with images for open and 
close. Users will see different images when they open or close glossary, drop-down, or expanding text.

Add or change images in a hotspot

1) Select Drop-down hotspot style in the Styles dialog box.
2) Expand Character styles to view the Drop-down hotspot style.
3) Click the Select Twisties Images button .
4) Select an image to display closing drop-down text and one image to open a drop-down hotspot.
5) Select an option to place the images either at the Start Of Text or End Of Text. Similarly, you can 

change images for expanding text.

Add or change images of glossary terms

1) Select a glossary term style in the Styles dialog box.
2) Click the Select Twisties Images button .
3) Select an image to display closing drop-down text and another image to open a drop-down hotspot. 

Select different images to differentiate between opening and closing a hotspot.
4) Select an option to place the images either at the Start Of Text or End Of Text. Similarly, you can 

change images for expanding text.

Removing Twisties images

1) To remove images from glossary terms or drop-down hotspots, click the Clear button in the Select 
Twisties Images dialog box.
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Default keyboard shortcuts

Adobe RoboHelp HTML provides shortcuts to help you quickly work in documents without using the 
mouse. Use these shortcuts in Design Editor. Additional keyboard shortcuts appear next to the command 
names in menus.
NOTE: To use certain shortcuts, you must select text first. Those cases are marked with an asterisk (*).

Task Keyboard shortcut

Basic operations

New project CTRL + Alt + N

Open project CTRL+O (letter O)

Close project CTRL + Alt + C

Rename Project Ctrl + Alt + R

Options Shift + Control + T

Save Component Ctrl + Alt + S

Save All CTRL+S

Undo CTRL+Z

Redo CTRL+Y

Cut CTRL+X

Copy CTRL+C

Paste CTRL+V

Delete Delete button

Close All CTRL+Alt+X

Exit Shift + Ctrl + X

Select all CTRL+A

Find CTRL+F

Replace CTRL+H

Find and Replace In Files CTRL+SHIFT+F

Go to bookmark F5

Print from active pane CTRL+P
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Page Setup Ctrl + Alt + U

Help F1

Spell check active pane F7

Thesaurus SHIFT+F7

Create a topic CTRL+T

Duplicate a topic CTRL+D

Edit item CTRL+E

Close a topic CTRL+F4

Open a linked topic in a new tab CTRL+click

Rename F2

Paragraph markers CTRL+SHIFT+8

Preview topic CTRL+W

Insert hypertext link* CTRL+K*

Insert image CTRL+G

Insert text-only pop-up* CTRL+ALT+P

Open Project Settings dialog CTRL+SHIFT+/

Open Topic Properties dialog ALT+ENTER

Display Conditional Build Tag dialog* CTRL+N

Next tab CTRL+PAGE DOWN

Previous tab CTRL+PAGE UP

Update

Update CTRL+F5

Update All CTRL+ALT+F5

Force Update CTRL+SHIFT F5

Force Update All CTRL+SHIFT+ALT+F5

Manage document Ctrl + Alt + D

Text formatting in Design Editor

Bold CTRL+B

Task Keyboard shortcut
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Italicize CTRL+I

Underline CTRL+U

Format – Paragraph menu CTRL+SHIFT+D

Format – Font menu CTRL+D

Apply Font CTRL+SHIFT+ALT+F

Increase font size to next size in menu* CTRL+SHIFT+>

Decrease font size to previous size in menu* CTRL+SHIFT+<

Increase font size by 1 point* CTRL+]

Decrease font size by 1 point* CTRL+[

Styles in Design Editor

Apply a style* CTRL+SHIFT+S

Apply the Normal style CTRL+SHIFT+N

Apply a Bullets or Numbering style CTRL+SHIFT+L

Apply Heading 1* ALT+CTRL+1

Apply Heading 2* ALT+CTRL+2

Apply Heading 3* ALT+CTRL+3

TOC pod

Move book or topic up in the table of contents CTRL+Up Arrow

Move book or topic down in the table of contents CTRL+Down Arrow

Move book or topic to the left in the table of 
contents

CTRL+Left Arrow

Move book or topic to the right in the table of 
contents

CTRL+Right Arrow

Index pod

Change index keyword to lowercase CTRL+L

Change first letter of index keyword to uppercase CTRL+J

Review Pane

Add a review comment CTRL+ALT+M

Screen Layout Editor

Task Keyboard shortcut
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*Select text first.

Preview the open screen layout CTRL+W

Version Control

Refresh version status on File Status tab F5

Task Keyboard shortcut
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