# Contents

**Chapter 1: Welcome to Adobe® Contribute® CS3**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Installation</td>
<td>1</td>
</tr>
<tr>
<td>Adobe Help</td>
<td>2</td>
</tr>
<tr>
<td>Resources</td>
<td>4</td>
</tr>
<tr>
<td>What's new?</td>
<td>8</td>
</tr>
<tr>
<td>Website development and maintenance overview</td>
<td>9</td>
</tr>
</tbody>
</table>

**Chapter 2: Getting Started**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Contribute workflow</td>
<td>11</td>
</tr>
<tr>
<td>Connecting to a website or blog</td>
<td>12</td>
</tr>
<tr>
<td>Starting Contribute without a network connection</td>
<td>13</td>
</tr>
<tr>
<td>Integrating Contribute with Adobe Creative Suite 3 applications</td>
<td>15</td>
</tr>
<tr>
<td>Integrating Adobe Bridge CS3 with Adobe Contribute CS3</td>
<td>16</td>
</tr>
</tbody>
</table>

**Chapter 3: Exploring the Contribute Workspace**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Contribute workspace</td>
<td>19</td>
</tr>
<tr>
<td>Switching between browsing and editing</td>
<td>23</td>
</tr>
<tr>
<td>Browsing to web pages and blog entries</td>
<td>23</td>
</tr>
<tr>
<td>Opening web pages and blog entries without browsing</td>
<td>24</td>
</tr>
<tr>
<td>Setting up access to commonly used pages</td>
<td>26</td>
</tr>
<tr>
<td>Setting Contribute preferences</td>
<td>28</td>
</tr>
<tr>
<td>Changing or disabling the Contribute startup password</td>
<td>29</td>
</tr>
<tr>
<td>Setting browser encoding</td>
<td>29</td>
</tr>
<tr>
<td>Using Contribute accessibility features</td>
<td>30</td>
</tr>
</tbody>
</table>

**Chapter 4: Working with Pages and Blog Entries**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About working with web pages and blog entries</td>
<td>33</td>
</tr>
<tr>
<td>Editing existing web pages and blog entries</td>
<td>37</td>
</tr>
<tr>
<td>Saving drafts</td>
<td>40</td>
</tr>
<tr>
<td>Getting web page drafts and files reviewed by others</td>
<td>41</td>
</tr>
<tr>
<td>Working with web pages based on Dreamweaver templates</td>
<td>47</td>
</tr>
<tr>
<td>Using Contribute to work offline</td>
<td>50</td>
</tr>
<tr>
<td>Editing web page content in an external application</td>
<td>52</td>
</tr>
<tr>
<td>Adding Google search functionality to your web page</td>
<td>52</td>
</tr>
<tr>
<td>Editing web page source in an external application</td>
<td>53</td>
</tr>
<tr>
<td>Discarding a draft, new page, or new blog entry</td>
<td>54</td>
</tr>
<tr>
<td>Deleting a web page or blog entry</td>
<td>54</td>
</tr>
<tr>
<td>Exporting a Web Page or Blog Entry (Windows only)</td>
<td>55</td>
</tr>
<tr>
<td>Printing a web page or blog entry</td>
<td>56</td>
</tr>
</tbody>
</table>

**Chapter 5: Adding Pages, Blog Entries, and Documents**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About converting documents to PDFs (Windows only)</td>
<td>58</td>
</tr>
<tr>
<td>Creating or copying a page on your website</td>
<td>58</td>
</tr>
</tbody>
</table>
Problems creating a connection .......................................................... 231
Problems editing a page ................................................................. 233
Problems canceling pages .............................................................. 235
Problems sending reviews by using e-mail ...................................... 235
Problems publishing a page ............................................................ 235
Problems creating documents from templates ................................. 236
Problems administering Contribute ............................................... 237
Using Contribute with dynamic pages ........................................... 240
Problems with configuring Contribute in RSS aggregators ............... 241

Chapter 15: Windows Keyboard Shortcuts
File menu ......................................................................................... 243
Edit menu ....................................................................................... 243
View menu ..................................................................................... 244
Insert menu ................................................................................... 244
Format menu .................................................................................. 244
Table menu .................................................................................... 245
Working with blog entries ............................................................... 245
Working in templates ..................................................................... 246
Editing text .................................................................................... 246
Working in tables .......................................................................... 246
Working with images ..................................................................... 247
Getting help .................................................................................. 247

Chapter 16: Macintosh Keyboard Shortcuts
File menu ......................................................................................... 249
Edit menu ....................................................................................... 249
View menu ..................................................................................... 250
Insert menu ................................................................................... 250
Format menu .................................................................................. 250
Table menu .................................................................................... 251
Help menu ..................................................................................... 251
Working in templates ..................................................................... 251
Editing text .................................................................................... 252
Working in tables .......................................................................... 252
Working with images ..................................................................... 253

Index ............................................................................................. 255
Chapter 1: Welcome to Adobe® Contribute® CS3

Adobe® Contribute® CS3 enables users to easily create and edit web pages on existing websites. Whether you’re using Contribute to update web pages or to manage the website, you’ll find Contribute a very useful tool for browsing, editing, and publishing content to a website.

Contribute is packaged along with other Adobe Create Suite 3 products and the Create Suite 3 products have been integrated with Contribute. While Contribute can interact with other Creative Suite 3 products, new menus, options, and toolbar buttons have been provided in all the Creative Suite 3 applications to help suite products to interact with Contribute.

This chapter contains the following sections:

• “Installation” on page 1
• “Adobe Help” on page 2
• “Resources” on page 4
• “What’s new?” on page 8
• “Website development and maintenance overview” on page 9

Installation

Requirements
To review complete system requirements and recommendations for your Adobe software, see the Read Me.html file on your installation DVD.

Install the software
1 Close any other Adobe applications open on your computer.
2 Insert the installation disc into your DVD drive, and follow the on-screen instructions.

Note: For more information, see the Read Me.html file on the installation DVD.

Activate the software
If you have a single-user retail license for your Adobe software, you will be asked to activate your software; this is a simple, anonymous process that you must complete within 30 days of starting the software.

For more information on product activation, see the Read Me file on your installation DVD, or visit the Adobe website at www.adobe.com/go/activation.

1 If the Activation dialog box isn't already open, choose Help > Activate.
2 Follow the on-screen instructions.
**Note:** If you want to install the software on a different computer, you must first deactivate it on your computer. Choose Help > Deactivate.

**Register**

Register your product to receive complimentary installation support, notifications of updates, and other services.

- To register, follow the on-screen instructions in the Registration dialog box, which appears after you install and activate the software.

  *If you postpone registration, you can register at any time by choosing Help > Registration.*

**Read me**

The Read Me.html file for your product can be found on the installation DVD (and is also copied to the application folder during product installation). This file provides valuable information about the following:

- System requirements
- Installing and uninstalling
- Activation and registration
- Font installation
- Troubleshooting
- Customer support
- Legal notices

**Adobe Help**

**Adobe Help resources**

Documentation for your Adobe software is available in a variety of formats.

**In-product and LiveDocs Help**

In-product Help provides access to all documentation and instructional content available at the time the product ships. It is available through the Help menu in your Adobe product.

LiveDocs Help includes all the content from in-product Help, plus updates and links to additional instructional content available on the web. For some products, LiveDocs also lets you add comments. Find LiveDocs Help for your product in the Adobe Help Resource Center, at www.adobe.com/go/ctcs3_documentation.

Most versions of in-product and LiveDocs Help let you search across the Help of multiple products. Topics also contain links to relevant content on the web or to topics in the Help of another product.

Think of Help, both in the product and on the web, as a hub for accessing additional content and communities of users. The most complete and up-to-date version of Help is always on the web.

**PDF documentation**

The in-product Help is also available as a PDF that is optimized for printing. Other documents, such as installation guides and white papers, may also be provided as PDFs.
All PDF documentation is available through the Adobe Help Resource Center, at www.adobe.com/go/ctcs3_documentation. PDF documentation included with your product can be found in the Documents folder on the installation or content DVD.

**Printed documentation**


A printed workflow guide is included with all Adobe Creative Suite 3 products, and individual Adobe products may include a printed getting started guide.

**Using Help in the product**

In-product Help is available through the Help menu. After you start the Adobe Help Viewer, click Browse to see Help for additional Adobe products installed on your computer.

To help you learn about multiple Adobe products, these features are available:

- You can search across Help for multiple products.
- Topics may contain links to topics in Help for other Adobe products or to additional content on the web.
- Some topics are shared across multiple products. If you see a Help topic with a Photoshop icon and a Contribute icon, you know that the topic either describes functionality that is similar in the two products or documents cross-product workflows.

*Note:* If you search for a phrase, such as “shape tool,” enclose it in quotation marks to see only those topics that include all the words in the phrase.

**Accessibility features**

Adobe Help content is accessible to people with disabilities—such as mobility impairments, blindness, and low vision. In-product Help supports standard accessibility features, including the following:

- Text size can be changed with standard context menu commands.
- Links are underlined for easy recognition.
- If link text doesn’t match the title of the destination, the title is referenced in the Title attribute of the Anchor tag. For example, the Previous and Next links include the titles of the previous and next topics.
- Content supports high-contrast mode.
- Graphics without captions include alternate text.
- Each frame has a title to indicate its purpose.
- Standard HTML tags define content structure, for screen reading or text-to-speech tools.
- Style sheets control formatting, so there are no embedded fonts.

**Keyboard shortcuts for toolbar controls (Windows)**

Each control in the toolbar for in-product Help has a keyboard equivalent:

- **Back button**  Alt+left arrow
- **Forward button**  Alt+right arrow
- **Print**  Ctrl+P
About button  Ctrl+I  

Browse menu  Alt+down arrow or Alt+up arrow to view Help for another application  

Search box  (Windows) Ctrl+S to place cursor in Search box  

Keyboard shortcuts for navigation (Windows)  
To navigate in-product Help and view topics, use the following keyboard shortcuts:  
• To move between panes, press Ctrl+Tab (forward) and Shift+Ctrl+Tab (backward).  
• To move through and outline links within a pane, press Tab (forward) or Shift+Tab (backward).  
• To activate an outlined link, press Enter.  
• To make text bigger, press Ctrl+equal.  
• To make text smaller, press Ctrl+hyphen.  

Choosing the right Help documents  
After installing, activating, and registering your software, familiarize yourself with the many learning aids and customer services available to you. These include in-product and online Help, instructional movies and tutorials, printed books, instructional seminars, free plug-ins and automated actions, customer support, user communities and blogs, RSS feeds, and much more. Browse the topics in the Resources section for an overview of aids and services, and as you progress in your work, don't forget about them. These resources can resolve questions, provide powerful tools, and save you time.  

Your role on the website team determines which Contribute resources you start with and use regularly.  
Contribute administrators  should start with the Quick Start guides to install Contribute and help users get connected. As you work with Contribute, refer to the How Do I panel to complete common administration tasks quickly, and use the online help to get detailed information about Contribute administration tasks and features.  
Contribute users  should start with the Quick Start guides to understand how to complete basic tasks. Then complete the tutorial to update some sample web pages and learn more about Contribute. As you work with Contribute, refer to the How Do I panel to complete common tasks quickly, and use the online help to get detailed and complete information about Contribute tasks and features.  

For more information about all the resources, see “Resources” on page 4.  

Resources  

Adobe Video Workshop  
Adobe Creative Suite 3 Video Workshop enables you to learn about your Adobe product. There are over 200 training videos for Adobe Creative Suite 3, covering a wide range of subjects for print, web, and video professionals.  
You can use the Video Workshop to learn about any Creative Suite 3 product you're interested in. Many videos show you how to use Adobe applications together.  
When you start the Video Workshop, you choose exactly the products and topics you want to learn. You can see details about each video to help focus your learning path.
Community of presenters
With this release, we invited the Adobe community to share their expertise and insights. Adobe and Lynda.com present tutorials, tips, and tricks from leading designers and developers such as Joe Lowery, Katrin Eismann, and Chris Georgenes. You can see and hear Adobe experts such as Lynn Grillo, Greg Rewis, and Russell Brown. In all, over 30 product experts share their knowledge.

Tutorials and source files
The Video Workshop includes training for novices and experienced users. You'll also find videos on new features and key techniques. Each video covers a single subject and typically runs about 3-5 minutes. Most videos come with an illustrated tutorial and source files, so you can print out detailed steps and try the tutorial on your own.

Using Adobe Video Workshop
You can access Adobe Video Workshop using the DVD included with your Creative Suite 3 product. It's also available online at www.adobe.com/go/learn_videotutorials. Adobe will regularly add new videos to the online Video Workshop, so check in to see what's new.

Contribute CS3 videos
Adobe Video Workshop covers many subjects for Adobe® Contribute® CS3, including:

- Publishing to a website
- Administering a website
- Editing and posting blog entries
- Using Dreamweaver templates with Contribute

To access Adobe Creative Suite 3 video tutorials, visit Adobe Video Workshop at www.adobe.com/go/learn_videotutorials.

Extras
You have access to a wide variety of resources that will help you make the most of your Adobe software. Some of these resources are installed on your computer during the setup process; additional helpful samples and documents are included on the installation or content DVD. Unique extras are also offered online by the Adobe Exchange community, at www.adobe.com/go/exchange.

Installed resources
During software installation, a number of resources are placed in your application folder. To view those files, navigate to the specific application folder on your computer.

- Windows: [startup drive]/Program files/Adobe/Adobe Contribute
- Mac OS: [startup drive]/Applications/Adobe Contribute

Depending on your Adobe product, the application folder may contain the following:

Plug-ins Plug-in modules are small software programs that extend or add features to your software. Once installed, plug-in modules appear as options in the Import or Export menu; as file formats in the Open, Save As, and Export Original dialog boxes; or as filters in the Filter submenus.
Presets Presets comprise a wide variety of useful tools, preferences, effects, and images. Product presets include brushes, swatches, color groups, symbols, custom shapes, graphic and layer styles, patterns, textures, actions, workspaces, and more. Preset content can be found throughout the interface. Some presets become available only when you select the corresponding tool. If you don’t want to create an effect or image from scratch, just peruse the preset libraries for inspiration.

Templates Template files can be opened and viewed from Adobe Bridge, opened from the Welcome Screen, or opened directly from the File menu. Depending on the product, template files range from letterhead, newsletters and websites, to DVD menus and video buttons. Each template file is professionally constructed and represents a best-use example of product features. Templates can be a valuable resource when you need to jump start a project.

Samples Sample files include more complicated designs and are a great way to see new features in action. These files demonstrate the range of creative possibilities offered by your application.

Fonts Several OpenType® fonts and font families are included with your Creative Suite product. Fonts are copied to your computer during installation:

- Windows: [startup drive]/Program Files/Common Files/Adobe/Fonts
- Mac OS X: [startup drive]/Library/Application Support/Adobe/Fonts

For information about installing fonts, see the Read Me.html file on the installation DVD.

DVD content The installation or content DVD included with your product contains additional resources for use with your software. The Goodies folder contains product-specific files such as templates, images, presets, actions, plug-ins, and effects, along with subfolders for Fonts and Stock Photography. The Documentation folder contains a PDF version of the Help, technical information, and other documents such as specimen sheets, reference guides, and specialized feature information.

Adobe Exchange For more free content, visit www.adobe.com/go/exchange, an online community where users download and share thousands of free actions, extensions, plug-ins, and other content for use with Adobe products.

Bridge Home Bridge Home, a new destination in Adobe Bridge CS3, provides up-to-date information on all your Adobe Creative Suite 3 software in one convenient location. Start Adobe Bridge, then click the Bridge Home icon at the top of the Favorites panel to access the latest tips, news, and resources for your Creative Suite tools.

Note: Bridge Home may not be available in all languages.

Adobe Design Center Adobe Design Center offers articles, inspiration, and instruction from industry experts, top designers and Adobe publishing partners. New content is added monthly.

You can find hundreds of tutorials for design products and learn tips and techniques through videos, HTML tutorials, and sample book chapters.

New ideas are the heart of Think Tank, Dialog Box, and Gallery:

- Think Tank articles explore how today's designers engage with technology and what their experiences mean for design, design tools, and society.
• In Dialog Box, experts share new ideas in motion graphics and digital design.
• The Gallery showcases how artists communicate design in motion.


Adobe Developer Center
Adobe Developer Center provides samples, tutorials, articles, and community resources for developers who build rich Internet applications, websites, mobile content, and other projects using Adobe products. The Developer Center also contains resources for developers who develop plug-ins for Adobe products.

In addition to sample code and tutorials, you’ll find RSS feeds, online seminars, SDKs, scripting guides, and other technical resources.


Customer support
Visit the Adobe Support website, at www.adobe.com/go/ctcs3_support, to find troubleshooting information for your product and to learn about free and paid technical support options. Follow the Training link for access to Adobe Press books, a variety of training resources, Adobe software certification programs, and more.

Downloads
Visit www.adobe.com/go/ctcs3_updates to find free updates, tryouts, and other useful software. In addition, the Adobe Store (at www.adobe.com/go/store) provides access to thousands of plug-ins from third-party developers, helping you to automate tasks, customize workflows, create specialized professional effects, and more.

Adobe Labs
Adobe Labs provides you with the opportunity to experience and evaluate new and emerging innovations, technologies, and products from Adobe.

At Adobe Labs, you have access to resources such as these:
• Prerelease software and technologies
• Code samples and best practices to help accelerate your learning curve
• Early versions of product and technical documentation
• Forums, wiki-based content, and other collaborative resources to help you interact with like-minded developers

Adobe Labs fosters a collaborative software development process. This environment allows customers to become productive with new products and technologies faster and the Adobe development teams to respond and react to early feedback in order to shape the software in a way that meets the needs and expectations of the community.


User communities
Features forums, blogs, and other avenues for users to share technologies, tools, and information; ask questions; and find out how others are getting the most out of their software. User-to-user forums are available in English, French, German, and Japanese; blogs are posted in a wide range of languages.

To participate in forums or blogs, visit www.adobe.com/communities.
What’s new?

Integrating Adobe Bridge CS3 with Adobe Contribute CS3  As part of the integration with Adobe Creative Suite 3, Adobe Contribute CS3 can now work with Adobe Bridge. This integration enables interaction between Adobe Contribute and Adobe Bridge applications, and also other suite applications. As a result, you can browse for assets in Adobe Bridge from Adobe Contribute and insert files into Contribute. Also, as a result of the integration of Adobe Contribute with all suite products, the startup script in the various installers will make Adobe Contribute CS3 available to all Creative Suite 3 applications. (See “Integrating Adobe Bridge CS3 with Adobe Contribute CS3” on page 16.)

Inserting MS Office docs as PDF in Adobe Contribute pages  You can insert MS Word and MS Excel documents as PDFs in Adobe Contribute pages (Windows only). Before you insert the documents, you must define conversion and security settings for converting the documents to PDF. The only pre-requisites for this feature are that Acrobat Elements and Acrobat Reader 8 must be installed. (See “Inserting MS Office documents as PDFs in Contribute pages (Windows only)” on page 72.)

Support for inserting PDFs in Adobe Contribute pages  You can insert PDF files in an Adobe Contribute page. (See “Inserting PDFs in Contribute pages” on page 82.)

Integrating Adobe Help Viewer 1.1 with Adobe Contribute CS3  Adobe Contribute CS3 has been integrated with Adobe Help Viewer 1.1 and, as a result, the look-and-feel of the online help adheres to the Adobe Help Viewer format. The Adobe Help Viewer is a common application used to open Help windows across all Creative Suite 3 products.

Enhanced blogger support  Adobe Contribute CS3 includes enhanced blogger support. You can access connections to your blogs using gmail authentication or existing blogger account details.

Enhanced blog entry management  The enhanced user interface in Adobe Contribute CS3 lets you browse to a specific blog home page and edit specific blog entries by using the Entries list box next to the Address text box. You can refresh the Entries list by clicking the Refresh icon next to it. (See “Refreshing the Entries list” on page 55.)

Selecting Templates for MS Office documents while publishing to website or opening in Contribute  You can use Adobe Contribute CS3 to place static content from MS Office documents (MS Word and MS Excel) into templates before publishing them in html format (Windows only). As a result, when you perform the Publish to Website or Open in Contribute operations, you can select a template for the page, which will show your document on the target site. (See “Setting templates while opening MS Office documents in Contribute (Windows only)” on page 80.)

Working with HTML Snippets in Adobe Contribute pages  Advanced Contribute users can use Adobe Contribute CS3 to add custom HTML code snippets while editing a web or blog site using Contribute. For example, you can use code snippets to display video or audio clips on your website or blog. (See “Inserting HTML code snippets into Contribute pages” on page 83.)

Support for inserting rich media from Internet  Adobe Contribute CS3 lets you insert image, Flash, or video files from the Internet, into a web page or a blog site.

Support for Internet Protocol (IP) version 6 in Contribute CS3  Adobe Contribute CS3 includes IPv6 support. URLs using IPv6 addressing are supported only with the Internet Explorer 7 browser and later on Windows. Although earlier versions of Contribute supported only IPv4, you can install or upgrade Contribute CS3 on computers with IPv6.

Connecting to blog servers using URLs  In Contribute CS3, you can create a connection to a blog server by providing the URL of your blog home page and your username and password details. (See “Creating a website connection” on page 183.)
Support for the Roller blog server in Contribute CS3 Adobe Contribute CS3 includes support for the Roller blog server. While creating a connection to a Roller blog server, you must define the user name, password and Access Point details.

Previewing a blog entry draft in the browser In Adobe Contribute CS3, you can preview a blog entry draft in a web browser before you publish it.

Selecting multiple categories and trackbacks You can now select multiple categories to group related blog entries and multiple trackbacks to insert in a blog entry draft.

Website development and maintenance overview

Contribute works with your existing website, whether it’s an intranet or a public website. It often takes a team of people to get a website up and running and to keep the content current.

The team may include the following people:

Web developers create the website. The web developer (or design team) uses a website-creation application, such as Adobe Dreamweaver, to build the website. This person is responsible for planning, designing, developing, testing, and publishing the website. For some websites, the developer might use templates to maintain a consistent look and feel across the website.

Dreamweaver web developers should see Dreamweaver Help for more information.

Contribute users maintain the website. Contribute users are the marketers, managers, educators, students, small business owners, administrative assistants, project managers, and so on, who use Contribute to keep their websites up-to-date. The user needs no experience in HTML or web design. Because Contribute works like a word processor, the user experience is intuitive and familiar. Users can add or update text, images, tables, links, and Microsoft Word and Excel documents.

This guide is designed for Contribute users.

Contribute administrators set up Contribute users and help them use Contribute to maintain the website. The Contribute administrator is also responsible for setting folder and user permissions, which determine who can edit website content and what contents they can edit. Only one Contribute administrator can be designated for each website in Contribute. However, more than one person can administer the website if the Contribute administrator shares the administration password for the website.
Chapter 2: Getting Started

If you do not have Adobe® Contribute® CS3 on your computer, install it now by following the instructions in “Installation” on page 1. Before installation, ensure that your computer meets the minimum setup requirements. For more information, see “Requirements” on page 1.

Before you can use Adobe® Contribute® CS3 to edit and update your website and blog content, you must create a connection to the web server that stores your website or blog. By creating a connection, you enable Contribute to access the web pages on your website and blog entries on your blog, and you can then edit pages and blog entries and publish any changes you make.

In most cases, your Contribute administrator sets up Contribute for you or provides the information you need to connect to your website or blog server.

This chapter contains the following sections:
- “The Contribute workflow” on page 11
- “Connecting to a website or blog” on page 12
- “Starting Contribute without a network connection” on page 13
- “Integrating Contribute with Adobe Creative Suite 3 applications” on page 15
- “Integrating Adobe Bridge CS3 with Adobe Contribute CS3” on page 16

The Contribute workflow

Contribute uses a browse-edit-publish workflow to help you easily find the web page or blog entry to edit, make changes to it, and then update the web page or blog entry on your website or blog server.

Note: You must connect to a website before you can edit and publish pages on that website, and you must connect to a blog server before you can edit and publish entries in that blog. For more information, see “Connecting to a website or blog” on page 12.

The following overview describes the Contribute workflow:

1. **Browse to a page or blog entry.** Use the Contribute browser to find the web page or blog entry you want to edit. The browser will be familiar to users of Microsoft Internet Explorer and other popular browsers. The browser toolbar has the normal navigation buttons plus a Choose button to help you navigate to files that aren't linked on your website. You can create bookmarks in Contribute and view your Internet Explorer bookmarks. You can also use shortcuts to view current drafts quickly.

2. **Edit your content.** After you browse to the desired page or blog entry, click the Edit Page or Edit Entry button in the toolbar to open the web page or blog entry in the Contribute editor. Contribute copies the file from your web or blog server and locks it on the server so that no one else can edit the page or blog entry while you're working on it.

The Contribute editor works much like a word processor. You can edit text, images, tables, and links on the page or blog entry, and you can even add Microsoft Word or Excel documents to your website or blog entry. The toolbar contains familiar editing buttons as well as buttons for saving, discarding, or publishing your edits.
3. Publish the changes. When you finish editing your page or blog entry, you can publish the page or blog entry to your website or blog server. Click the Publish button, and Contribute replaces the existing page or blog entry on your web server or blog with the edited version. Contribute also unlocks the file on the server so other users can edit the page or blog entry.

Note: In Contribute, the permissions for the role you belong to determine whether you can publish web pages. If you cannot publish web pages, use the Send for Review option to transfer the draft to another user. Depending on the protocols that your blog server supports, you may be limited in the type of content you can publish in your blog entries.

Connecting to a website or blog

Contribute lets you connect to your website or blog quickly and easily.

Connecting to a website

Your Contribute administrator does one of the following to help set up a connection to your website for you:

• Send you an e-mail message with a website connection key file (see “Using a website connection key” on page 12). The connection key contains all the network information that Contribute needs to connect to your website.

Note: Connection keys are used only with website connections; they are not used for blog connections.

• Give you the necessary connection information for the website so you can enter the information in the Connection Wizard (see “Creating a website connection” on page 183).

If you use a Macintosh computer and have a .Mac account, Contribute detects the .Mac account and asks if you want to create a connection to it.

If your website is managed by Contribute Publishing Server, your administrator sends you a connection key or gives you connection information to enter in the Contribute browser address bar.

Connecting to a blog

To connect to a blog, you need the necessary connection information for the blog so you can enter the information in the Connection Wizard. You can use the MetaWeblog API to connect to a blog account that is hosted on a blog publishing service, such as Blogger, WordPress, Roller, or TypePad or an internal server. If you use a Macintosh computer and have a .Mac account, Contribute detects the .Mac account and asks if you want to create a connection to it.

Note: Connection keys are not used for blog connections; they are available only for website connections.

For more information about connecting to a blog, see “Creating a blog server connection” on page 184.

Using a website connection key

Your Contribute administrator might provide a connection key, which you can use to establish a connection to your website. The connection key contains all the network information that Contribute needs for connecting to your website.

The Contribute administrator sends you an e-mail message with the key. The connection key is either a file or a URL.

Note: Your Contribute administrator might give you the network location from which to download the connection key instead of sending you an e-mail message.
To import a website connection key:

1. Open the e-mail message containing the connection key.

The connection key is attached as a file.

2. Double-click the connection key.

3. Do one of the following:
   - If the Import Connection Key dialog box appears, enter your name, your e-mail address, and the password for the connection key, and then click OK.
   - If the Log in to Publishing Server dialog box appears, enter your user name and password, and then click OK.

   **Note:** If you don’t know the password, contact the Contribute administrator who sent you the connection key.

4. If you are prompted for other connection information, such as FTP, type that information, and then click OK.

When the connection is complete, the home page of the website appears in the Contribute browser.

**Entering a Contribute startup password**

If the Require Contribute startup password option is selected in the Security category of Preferences, Contribute prompts you for your startup password when you start the program.

A startup password protects unauthorized users from editing or publishing pages and blog entries to your website or blog. If you do not enter the password when you start Contribute, all web pages and blogs are disabled and cannot be enabled. You can only browse to web pages or blog entries and create web pages or blog entries. After you enter the correct password, you can make updates and publish changes or new entries to the connected websites and blogs until you close Contribute.

In addition to providing secure access, when the Require Contribute Startup password option is selected, Contribute uses a stronger encryption method when saving your connection information on your computer.

**Note:** If you receive a connection key that requires a Contribute startup password, you must create a startup password before you can import that connection.

**To enter a Contribute startup password:**

1. In the Enter Password dialog box, type the Contribute startup password.

   You can enter the password incorrectly only three times before Contribute locks you out. If you are locked out, you can restart Contribute and reenter the startup password.

   If you forget your password, you have to delete all of your website connections and add them again.

2. Click OK.

   **Note:** If you click Skip, you bypass the password prompt and Contribute starts. When you skip the password, you can only edit or cancel existing drafts for the website. You won’t be able to edit pages other than drafts, or publish changes to drafts until you restart Contribute and enter the correct startup password.

**Starting Contribute without a network connection**

When you start Contribute, it checks your network connection so that it can connect to your website or blog. Contribute alerts you if it does not detect a connection.
If you start Contribute without a network connection and receive the Connection Failure alert, you have two choices:

- Select Work Offline if you know that you're not connected to the network and you want to work offline. For more information, see “Using Contribute to work offline” on page 50.
- Select Try to Connect Anyway if you aren't sure what the problem is and you want Contribute to try to connect again. If Contribute still can't connect, you can disable the website or blog and continue checking any other website and blog connections. For more information, see “Disabling your website or blog at startup” on page 14.

For more information about solving connection problems, see “Troubleshooting” on page 229.

Disabling your website or blog at startup

Contribute alerts you if it detects a problem with any of your website or blog connections when it starts. Contribute displays the alert after the first connection problem it encounters.

You can have Contribute try to connect again. If Contribute still can't connect, you can disable the website or blog server connection and try to connect to other websites and blogs. If you disable a website or blog server, you can enable it after you resolve your network connection problem.

**Note:** You can disable a website or blog at any time—not just at startup—when there's a problem. If you have multiple websites and blogs, you can disable the ones you aren't currently working on, so Contribute does not maintain the connection for an extended period of time. For more information, see “Disabling website and blog connections” on page 208.

**To disable a website or blog server when your network connection fails:**

1. Start Contribute.

   The Connection Failure dialog box appears.

2. Select Try to Connect Anyway to force Contribute to continue checking for a network connection.

3. If Contribute still fails to connect, Contribute displays an error message with two options:
   - Click Yes to continue trying to connect to other websites and blog servers.
   - Click No to disable the rest of your websites and blog servers.

4. Click OK.

**To enable a disabled website or blog:**

1. Browse to any page on the website or to any blog entry in the blog, and click Connect in the toolbar.

2. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).

   The My Connections dialog box appears.

3. Do one of the following:
   - To enable a website, select the website you want to enable from the list, and click Enable.
   - To enable a blog, select the blog server under which the blog is listed, and click Enable. All the blogs listed under this blog server are enabled. You cannot enable individual blogs.

4. Click Close.
Integrating Contribute with Adobe Creative Suite 3 applications

You can run custom startup scripts during the installation of other Adobe Creative Suite 3 applications to enable access from the relevant suite product to Adobe Contribute. When these scripts are run, Adobe Contribute-related menus, options, and toolbar icons are created in the Creative Suite 3 applications. Also, relevant Creative Suite 3 product-related menus, options, and toolbar icons are created in Adobe Contribute.

Performing Adobe Contribute-related operations in Creative Suite 3 applications

The Cross DOM is a small API that provides a set of functions that are common across Adobe Creative Suite 3 applications. These include functions to open files, execute scripts, and print files. You can use the Cross DOM API for startup scripts to perform any of the following operations across the Adobe Creative Suite 3 applications:

- Open a new web page or blog entry in Adobe Contribute from another Creative Suite 3 application using the Open function in the Cross-DOM API. Also, you can open files in Adobe Contribute from another Creative Suite 3 application using the Cross-DOM API in a startup script.
- Open files from the following Creative Suite 3 applications in Adobe Contribute by using the Open function in the Cross-DOM API: Adobe Bridge, Adobe Photoshop, Adobe Illustrator, Adobe InDesign, Adobe Acrobat, Adobe Flash, Adobe Dreamweaver, and Adobe Fireworks.
- Open video and audio files from the following Creative Suite 3 applications using the Open function in the Cross-DOM API: Adobe After Effects, Adobe Premiere Pro, Adobe Audition, and Adobe Encore. If the file can be viewed in the embedded browser, it is opened in the embedded browser.
- Print files from the following Creative Suite 3 applications in Adobe Contribute using the PDF printer and the Print function in the Cross-DOM API: Adobe Bridge, Adobe Photoshop, Adobe Illustrator, Adobe InDesign, Adobe Acrobat, Adobe Flash, Adobe Dreamweaver, and Adobe Fireworks.
- Print files from the following Creative Suite 3 applications using the Print function in the Cross-DOM API: Adobe After Effects, Adobe Premiere Pro, Adobe Audition, and Adobe Encore. (Although video files are rarely printed, printing these files lets you verify whether the corresponding applications respond to BridgeTalk messages.)
- Close Adobe Contribute from other Creative Suite 3 applications using the Close function in the Cross-DOM API.

Note: Adobe Bridge scripts using the BridgeTalk protocol enable communication between Adobe Contribute and the Adobe Creative Suite 3 applications. The BridgeTalk message object is used to send message packets between the applications.
Integrating Adobe Bridge CS3 with Adobe Contribute CS3

The Adobe Bridge CS3 software is the new navigational control center built for Adobe Creative Suite 3 applications and their components. Adobe Bridge CS3 provides centralized access to your Creative Suite 3 project files, applications, and settings.

Adobe Contribute CS3 has been integrated with the Adobe Bridge application in the Adobe Creative Suite 3 release. This integration lets you perform the following tasks:

- Organize assets
- Insert files
- Communicate across applications using the BridgeTalk protocol
- Access Adobe stock photos.

Inserting files from Adobe Bridge into Adobe Contribute

Using Adobe Bridge, you can insert files or folders into web pages or blog entry drafts in Adobe Contribute. If the Contribute draft supports the selected file type, then the selected file is placed in the draft, or a link to the selected file is displayed in the draft. File types which are not supported, are not inserted in the draft.

To insert files from Adobe Bridge into Adobe Contribute:

2. Open a draft of a web page or blog entry.
   
   **Note:** While placing a file in Contribute, if Adobe Contribute is not running, or if a web page or blog entry draft is not open, a message is displayed indicating that there is no open draft to place the file.
3. Select File > Browse or click the Bridge toolbar icon.
   
   **Note:** You can select multiple files or folders to place in a Contribute draft.

   Adobe Bridge is opened in a new window.
4. In Adobe Bridge, select the file you want to insert.
5. Select File > Place > In Contribute.

   The file, or a link to the file is inserted in the Contribute draft. If you select a file type which is not supported, such a file is not inserted in the draft.
   
   **Note:** You can also insert a file into a Contribute web page or blog entry draft by dragging the file from Windows Explorer or Macintosh Finder, and dropping it into the Contribute web page or blog entry draft.

Opening files from Adobe Bridge in Adobe Contribute (Windows Only)

You can select a file in Adobe Bridge, and open the file in Adobe Contribute.

To open file from Adobe Bridge in Adobe Contribute:

1. Start Adobe Bridge.
2. Select the file you want to open in Contribute.
Note: You can open only Microsoft Word documents with .doc or .docx extension, and Microsoft Excel documents with .xls, .xlsm, or .xlsx extension.

3 Select Tools > Contribute > Open in Contribute.

Note: The Tools > Contribute > Open in Contribute menu is available for the Windows platform only.

Contribute is started and the contents of the Word or Excel document are inserted in the web page draft based on the insertion option you selected.

Publishing files from Adobe Bridge to Adobe Contribute (Windows only)

You can select the following file types in Adobe Bridge, and publish them in Adobe Contribute: .doc, .xls, .docx, .xlsm, and .xlsx. When you publish an MS Office document that contains other files, the additional files are copied to your web page draft automatically.

To publish a file from Adobe Bridge in Adobe Contribute:

1 Start Adobe Bridge.
2 Select the file you want to publish to Adobe Contribute.
3 Select Tools > Contribute > Publish to Website.

Note: The Tools > Contribute > Publish to Website menu is available for the Windows platform only.

The Publish to Website dialog box appears.

4 To select the settings for publishing the document, do the following:
   a Select the website where you want to publish the file.
      Note: If you do not have a connection to your website before you publish a document, you can create one by selecting Create New Connection in the Select pop-up menu in the Publish To Website dialog box. For more information on creating a website connection, see “Creating a website connection” on page 183.
   b Select a location for storing the file.
      Note: You can select multiple files or folders from Adobe Bridge to publish in Contribute.
   c Enter a filename. The filename must not have any spaces, tabs, or alphanumeric characters.
   d Select a format.
   e (Optional) Clear the Publish current selection only check box to publish the whole document instead of the selection.

You can also set these preferences in the Microsoft Documents tab from the Edit menu in Contribute. To do this, select Edit > Preferences > Microsoft Documents and make a selection. For more information on setting these preferences, see “Setting Contribute preferences” on page 28.

5 Click Publish.

Contribute publishes the document to your web page, and a confirmation dialog box appears.

Note: If Contribute is not running when you publish a file from Adobe Bridge to Contribute, Adobe Contribute is started first, and then the Publish to Website dialog box is opened.

6 Click OK.
Chapter 3: Exploring the Contribute Workspace

You can use Adobe® Contribute® CS3 as a web browser and as a web page editor. You can easily switch between browsing web pages and editing web pages. The Contribute workspace makes it easy for you to access pages, whether you're browsing or editing.

You can navigate the Contribute dialog boxes and workspace without using your mouse. You can also set preferences to customize Contribute.

This chapter includes the following sections:

- “The Contribute workspace” on page 19
- “Switching between browsing and editing” on page 23
- “Browsing to web pages and blog entries” on page 23
- “Opening web pages and blog entries without browsing” on page 24
- “Setting up access to commonly used pages” on page 26
- “Setting Contribute preferences” on page 28
- “Changing or disabling the Contribute startup password” on page 29
- “Setting browser encoding” on page 29
- “Using Contribute accessibility features” on page 30

The Contribute workspace

The Contribute workspace has three main areas: the Contribute browser and editor, the toolbar, and the sidebar.
The Contribute browser and editor

The main window in Contribute is used for browsing and editing. If you are not sure whether you are browsing or editing in Contribute, look at the toolbar. The toolbars are different when you are browsing and when you are editing a draft (see “The Contribute toolbars” on page 20).

When you use the Contribute browser, you can browse to any web page—not just to pages on your website. The Contribute browser functions as a true web browser: Click links in web pages to browse to the page you want to edit. You can also create bookmarks to pages that you visit frequently.

When you use the Contribute editor, you can edit pages in websites you have connected to (see “Connecting to a website or blog” on page 12). You can edit text, images, tables, links, and pages with frames. You can publish your changes to make the updated web page live on your website.

It's easy to browse and edit in Contribute, and to switch between browsing and editing. For more information, see “Switching between browsing and editing” on page 23.

The Contribute toolbars

The Contribute toolbar changes according to whether you are browsing or editing a web page or a blog entry. When you are editing, the editor toolbar lets you edit text or images, depending on the content you’ve selected. And when you are editing a draft for your blog, the blog metadata and secondary metadata toolbars are also available.

Depending on the role the Contribute administrator assigned you, some buttons in the toolbars might not be enabled for you.

The browser toolbar contains buttons for navigating your website or creating a page or blog entry. The browser toolbar contains the same options for websites and blogs.
The editor toolbar contains buttons for common operations from the File, Insert, Format, and Table menus. The editor toolbar options vary depending on whether you are working on a draft for a website or a blog.

The blog metadata toolbar contains information about the draft, including the blog title, the blog post title, and the associated tags. This toolbar is available for blog drafts only.

The secondary metadata toolbar contains more options for associating metadata with a blog post. This toolbar is available for blog drafts only.

The text formatting toolbar contains buttons for formatting text. The text formatting toolbar options also vary depending on whether you are working on a draft for a website or a blog.

Note: If your Contribute administrator has restricted editing to text only, some formatting options are not available. Also, options might be disabled if a Cascading Style Sheet has been applied to a text selection.

The image editing toolbar contains buttons for editing images.

The Contribute sidebar makes it easy to switch between editing and browsing, and gives you quick access to your drafts. You can also use the sidebar to get quick instructions for performing tasks in Contribute.

The sidebar has two parts:

The Pages panel gives you access to the web browser and all drafts you’re currently editing. There is also a link to the Draft Console, which shows the status of your drafts.

Note: The Draft Console is not available if your website doesn’t have an administrator assigned.

The How Do I panel provides quick step-by-step instructions to help you complete some common Contribute tasks. The panel shows a list of browsing tasks while you are browsing, and a list of editing tasks while you are editing.

Click any link in the How Do I panel in the sidebar to get more information on that task. If the desired task is not in the list, see Contribute Help (Help > Adobe Contribute Help) to get detailed information.
You can expand, collapse, or resize the panels and the sidebar.

**To expand or collapse the sidebar, do one of the following:**
- Select View > Sidebar.
- In Windows, click the arrow on the splitter bar between the sidebar and the Contribute browser and editor.
- On the Macintosh, double-click the grabber on the splitter bar between the sidebar and the Contribute browser and editor.

**To resize the sidebar:**
- Drag the splitter bar between the sidebar and the Contribute browser and editor.

**To expand or collapse a panel in the sidebar:**
- Double-click the panel title bar.

**To resize panels vertically in the sidebar:**
- Drag the title bar in the How Do I panel.
Switching between browsing and editing

You can use Contribute to browse or edit web pages and blog entries. You can switch between browsing and editing at any time. When you leave a draft you're editing, Contribute saves your changes so that you can return to the draft later and continue editing where you left off.

When you switch to browsing, Contribute does not publish your draft. While you are browsing the page or blog entry, the message area advises you that you have an unpublished draft of the page or blog entry.

If you are not sure if you are browsing or editing in Contribute, look at the toolbar. When you are browsing, you'll see the browser toolbar, with the Edit Page (or Create Connection) button and when you are editing, the editor toolbar appears (see “The Contribute toolbars” on page 20).

To switch from browsing to editing, do one of the following:
• Click the Edit Page button in the toolbar to edit a web page or click the Edit Entry button to edit a blog entry.

Note: Edit Page and Edit Entry are enabled only for pages on a website or entries in a blog that you are connected to and that you have permission to edit.
• Click a draft title in the Pages panel in the sidebar.

To switch from editing to browsing, do one of the following:
• Click Browser in the Pages panel in the sidebar.
• Click the Save for Later button in the toolbar.
• Select View > Browser.

Browsing to web pages and blog entries

The easiest way to find a web page or blog entry you want to edit is to browse to the page or entry in Contribute like you would browse in any web browser.

To learn other ways to find your web pages or blog entries, see “Opening web pages and blog entries without browsing” on page 24.

Note: (Windows only) If you use Microsoft Internet Explorer as your primary web browser, the Contribute browser inherits preferences from Internet Explorer. To change basic settings, such as fonts, cookies, or plug-ins, change your preferences in Internet Explorer; then start Contribute again.
You can browse to any website or blog entry with Contribute, but you can edit only web pages and blog entries that are in your websites and blogs; that is, websites or blogs that you've created connections to (for more information, see “Connecting to a website or blog” on page 12). When you browse to a page that is in your website or a blog entry that is in your blog and that you have permission to edit, the Edit Page button is enabled in the toolbar.

**To browse to a web page or blog entry in Contribute, do one of the following:**

- Click links in web pages or blog entries to navigate to other pages.
- Type the web address (URL) of the page in the Address text box, and click Go. You can also press Enter or Return.
- Select View > Go to Web Address, enter the web address (URL), and click OK.

**Opening web pages and blog entries without browsing**

You can use Contribute to open web pages and blog entries without browsing to find them. For more information, see the following sections:

- “Viewing drafts and new pages or blog entries” on page 25
- “Viewing home pages for your websites and blogs” on page 25
- “Viewing recently published web pages and blog entries” on page 25
- “Viewing pages and files that you can't browse to” on page 26
- “Viewing pages in your bookmarks list” on page 27
Viewing drafts and new pages or blog entries
The Pages panel displays the titles of drafts you are currently editing. You can also access drafts from the File menu.

To view a draft, do one of the following:
• Click the title of the draft in the Pages panel in the sidebar.
• Select File > Drafts, and then select a draft from the pop-up menu.

Viewing home pages for your websites and blogs
You can use the toolbar to view the home pages for all your websites and blogs. The View menu also gives you access to these pages and blog entries.

To view the home page for a website or blog you’re connected to, do one of the following:
• Click the Home Pages button in the toolbar, and then select a home page.
• Select View > Home Pages, and then select a home page from the pop-up menu.

Viewing recently published web pages and blog entries
The File menu gives you quick access to web pages and blog entries you’ve recently published.
To view a recently published web page or blog entry:

- Select File > Recent Pages and Blog Entries, and then select a page from the pop-up menu.

**Viewing blog entries**
The Entries pop-up menu provides quick access to a blog entry from your blog home page.

**To view a blog entry:**
1. Browse to your blog home page.
2. From the Entries pop-menu, select the blog entry you want to manage. You can also select a blog entry by using View > Select Blog Entry > Blog entry title.

The selected blog entry appears in the embedded browser, and the title of the selected blog entry is displayed in the Entries pop-up menu.

*Note: If a blog entry does not have a title, the title of the blog entry appears as <Untitled Blog Entry> in the Entries pop-up menu.*

**Viewing pages and files that you can’t browse to**
Contribute gives you access to pages and files that are associated with your website or blog but that you can’t browse to. Use the Choose button in the toolbar to view pages and files that are saved on a website folder but aren’t linked from any page on your website or blog.

**To view a page or file that is not linked from another web page or blog entry:**
1. In the Contribute browser or editor, select View > Choose File or Blog Entry or click the Choose button in the browser toolbar.

The Choose File or Blog Entry dialog box appears.
2. Select a file or blog entry by doing one of the following:
   - If the file is in a folder on the website or blog you are currently browsing, select a file.
   - If the file is not in a folder on the current website or blog, use the Look In pop-up menu to navigate to the correct website or blog folder, and then select a file.

Depending on the type of the file you select, a preview may appear so that you can confirm that you’re selecting the correct file.
3. Click OK.

The web page or file appears in the Contribute web browser.

*Note: If you select a file type that the Contribute browser can’t display, you’ll see the File Placeholder page.*

**Setting up access to commonly used pages**

Contribute lets you keep a list of bookmarks for pages that you visit frequently. You can add a bookmark for any page—not just pages in websites or entries in blogs that you’re connected to.
Viewing pages in your bookmarks list
You can select pages in your list of bookmarks to quickly view those pages.

In Windows, Contribute also includes your Internet Explorer bookmarks (up to 2000 bookmarks) in the Other Bookmarks list under your Contribute bookmarks.

To view a page in your list of bookmarks, do one of the following:
• To view a Contribute bookmark, select the Bookmarks menu, and then select a bookmark from the list.
• (Windows only) To view an Internet Explorer bookmark, select Bookmarks > Other Bookmarks, and then select a bookmark from the list.

Adding a page to your bookmarks
You can add any web page—not just pages in websites or entries in blogs that you’re connected to—to your bookmarks list. You can have as many as 1000 bookmarks.

To add a page to your list of bookmarks:
1 Browse to the page you want to add to your bookmarks list.
2 Select Bookmarks > Add Bookmark.
The Add Bookmark dialog box appears.
3 To change the title of the bookmark, enter a new title in the Name text box.
This is the name that appears in your bookmarks list.
4 To add the page to a folder, click an existing folder name or click New Folder to add a folder.
5 Click OK.
Contribute adds the page to your bookmarks list in the Bookmarks menu.

Deleting a page from your bookmarks
You can delete any page from your bookmarks list, or you can delete a bookmarks folder.

To delete a bookmark:
1 Select Bookmarks > Delete Bookmark.
The Delete Bookmark dialog box appears.
2 Select the name of the bookmark or the folder you want to delete.
3 Click Delete.
Contribute removes the page from your bookmarks list in the Bookmarks menu.
4 To delete another bookmark or folder, select it, and then click Delete again.
5 Click Close when you finish deleting bookmarks.
Setting Contribute preferences

You use the Preferences dialog box to set your user preferences for Contribute. You can set preferences for blog defaults, general editing, file editors, proxy settings, invisible elements, inserting Microsoft Office documents, PDF documents, the servers to ping when a blog entry is posted, password security, and blog entry tags.

To edit user preferences:
1. Select Edit > Preferences (Windows) or Contribute > Preferences (Macintosh).

   The Preferences dialog box appears.

2. Select an option from the list on the left:
   - Select Blog Defaults to set options for the default blog in which a blog entry is created, to connect to, whether to create a blog entry when you click the New button, and whether comments and trackbacks are allowed by default for blog entries.
   - Select Editing to set general editing options, such as how Contribute handles table editing, or to select a spelling dictionary.
   - Select File Editors to select primary application editors by file type.
   - Select FTP Proxy to add or change settings for your FTP proxy server.
   - Select Invisible Elements to hide or show invisible elements.
   - Select Microsoft Office Documents to determine how Contribute handles Office documents.
   - Select PDF Documents to configure the way Contribute handles insertion of PDF documents in draft web pages or blog entries.
   - Select Ping Servers to add or remove the ping server URLs you want Contribute to notify when you post a new blog entry using Contribute. You can also view a list of the most recent failed ping server log entries, up to a specified number of entries.
• Select Security to set up a Contribute startup password.

• Select Tagging to add and remove tagging servers, determine where Contribute adds tags to blog entries, and to specify details about the tag repository.

Changing or disabling the Contribute startup password

You can change your Contribute startup password as often as you like. Before you can change the startup password, you must first successfully enter the current Contribute startup password and start Contribute.

If the Require Contribute startup password option is selected in the Contribute Preference dialog box, you must enter the correct password to start Contribute and edit website pages. If you forget or don’t know the Contribute startup password, you can’t use Contribute to edit pages unless you disable the Contribute startup password requirement. Before you can change the startup password requirement, you must remove all your existing website connections.

To change the Contribute startup password:

1. Select Edit > Preferences (Windows) or Contribute > Preferences (Macintosh).
   
The Preferences dialog box appears.
2. Select Security from the option list on the left.
3. Type the new password, and then type the new password again.
4. Click OK.

To disable a Contribute startup password:

1. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).
2. Under Website Name, select a website connection, and then click Remove.

   Note: You might have to discard any unpublished drafts before removing the website connections.
3. Repeat step 2 until you remove all website connections.
4. Click Close.
5. Select Edit > Preferences (Windows) or Contribute > Preferences (Macintosh).
6. In the Preferences dialog box, select Security.
7. Deselect the Require Contribute startup password option.
8. Click OK.

Setting browser encoding

To specify how a page should appear in the Contribute browser, you can set the browser encoding for that page. You might need to set encoding if characters aren’t displayed properly in the Contribute browser.
To change browser encoding:
1. In the Contribute browser, right-click (Windows) or Control-click (Macintosh) on the page.
2. Select Encoding, and then select an option from the pop-up menu.

Using Contribute accessibility features

Accessibility refers to making websites and web products usable by people with visual, auditory, motor, and other disabilities. Contribute provides features that make it accessible to users with disabilities.

Using screen readers with Contribute

A screen reader recites text that appears on the computer screen. It also reads nontextual information, such as button labels or image descriptions.

You can use a screen reader when you edit your web pages. The screen reader starts reading at the upper left corner of the application.

Contribute supports the following screen readers:

- JAWS for Windows, from Freedom Scientific (www.freedomscientific.com)
- Window Eyes screen readers, from GW Micro (www.gwmicro.com)

Using operating system accessibility features

Contribute supports the Windows operating system high-contrast setting. You activate this setting through the Windows Control Panel.

When high contrast is on, Contribute responds as follows:

- Dialog boxes and panels use system color settings.
  
  For example, if you set the color to White on Black, all Contribute dialog boxes and panels appear with a white foreground color and black background.

- The Contribute editor uses the background and text colors you set in Format > Page Properties so that your pages render colors as a website visitor's browser renders them.

Using the keyboard to navigate Contribute

While you are editing, you can use the keyboard to navigate the Contribute workspace, dialog boxes, and tables without a mouse.

You can also use keyboard shortcuts to open some dialog boxes and perform some commands. For a list of shortcuts, see “Windows Keyboard Shortcuts” on page 243.

Navigating the workspace

You can use keyboard shortcuts to navigate the Contribute workspace—that is, to select commands from the menus and to switch between the Contribute browser and editor. For a complete list of Contribute keyboard shortcuts, see “Windows Keyboard Shortcuts” on page 243.

All the items in the Pages panel and toolbar are accessible through the menus. To view task information in the How Do I panel, use Contribute Help (Help > Adobe Contribute Help).
To use the keyboard to switch from the Contribute browser to the editor, do one of the following:

• Press Control+Shift+E (Windows) or Command+Shift+E (Macintosh), to edit the current page.

*Note: This has the same effect as clicking the Edit Page button in the toolbar.*

• (Windows Only) Press Alt+F, press Alt+F again, and then use the arrow keys to select a current draft or new page from the pop-up menu.

The drafts and new pages listed in the Pages panel appear in this list.

To use the keyboard to switch from the Contribute editor to the browser:

• Press Control+Shift+B (Windows) or Command+Shift+B (Macintosh).

*Note: This has the same effect as clicking Browser in the Pages panel.*

Navigating dialog boxes

You can use the keyboard to navigate dialog boxes.

To navigate a dialog box:

• To move through dialog box options, press Tab.

On the Macintosh, pressing Tab moves the insertion point from one text field to the next.

• To accept a choice and exit the dialog box, press Enter or Return.

• To close the dialog box without making any changes, press Escape or Alt+F4 (Windows).

• (Windows Only) To move through choices for an option, use the arrow keys.

For example, if an option has a pop-up menu, move focus to that option, use the Down Arrow key to move through the choices.

• (Windows Only) To move through an option list, press Control+Tab to shift focus to the option list, and then use the arrow keys to move up or down the list.

To see an example of an option list, select Edit > Preferences.

• (Windows Only) To shift to the options for an option in an option list, press Control+Tab.

Navigating tables

After you select a table, you can use the keyboard to navigate through it.

To navigate a table:

1. In the Contribute editor, do one of the following to select the table:

   • If the insertion point is to the left of the cell, press Shift+Right Arrow.
   
   • If the insertion point is to the right of the cell, press Shift+Left Arrow.

2. Press the Down Arrow key to position the insertion point in the first cell.

3. Use the arrow keys or press Tab to move to other cells as necessary.

   *Pressing Tab in the rightmost cell of a row adds another row to the table.*

4. To select a cell, press Control+A (Windows) or Command+A (Macintosh) while the insertion point is in the cell.
To exit the table, use the Select Table Cell command (Control+A) or Command+A (Macintosh); then press the Up, Left, or Right Arrow key.

**Authoring for accessibility**

It's important to make your web pages accessible to all your website visitors.

The U.S. government and other organizations have established accessibility legislation and guidelines. For more information about two significant initiatives, see the World Wide Web Consortium Web Accessibility Initiative (www.w3.org/wai) and Section 508 of the Federal Rehabilitation Act (www.section508.gov).

Also, as you edit your pages, remember that some visitors use screen readers. Contribute helps you make your images and tables more accessible in the following ways:

- You can add text that screen readers recite to describe images on your pages. Your Contribute administrator can have Contribute prompt you for descriptive text whenever you insert an image. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 220.
- You can include table headings to be recited by screen readers. To insert tables with headings, see “Inserting a table on a page” on page 120.

**Note:** Screen readers do not read boldface headings centered in a row or column.
Chapter 4: Working with Pages and Blog Entries

Adobe® Contribute® CS3 lets you edit existing web pages and content on your website and to edit existing blog entries and content on your blogs. You can cancel your edits or cancel a new web page or blog entry. You can delete blog entries and, with permission, you can delete web pages and other files on your website. You can also export a page to an HTML file.

Note: For information about creating pages, see “Creating or copying a page on your website” on page 58.

Before you publish your edits to a web page, you can send a draft of your updated web page to another user for review. When you publish the web page draft, Contribute updates the existing web page with your edits. You publish drafts of blog entries in the same way, with the exception of sending a draft of a blog entry to other users (see “Working with Pages and Blog Entries” on page 33).

You can now experience the benefits of Contribute in browsers such as Microsoft Internet Explorer and Mozilla Firefox. Using the Contribute toolbar in these browsers, you can add and edit web pages, publish web pages to your website, or publish to a blog directly from the browsers.

This chapter contains the following sections:
- “About working with web pages and blog entries” on page 33
- “Editing existing web pages and blog entries” on page 37
- “Saving drafts” on page 40
- “Getting web page drafts and files reviewed by others” on page 41
- “Working with web pages based on Dreamweaver templates” on page 47
- “Using Contribute to work offline” on page 50
- “Editing web page content in an external application” on page 52
- “Adding Google search functionality to your web page” on page 52
- “Editing web page source in an external application” on page 53
- “Discarding a draft, new page, or new blog entry” on page 54
- “Deleting a web page” on page 54
- “Exporting a Web Page or Blog Entry (Windows only)” on page 55
- “Printing a web page or blog entry” on page 56

About working with web pages and blog entries

Contribute lets you edit existing blog entries on your blog and existing pages on your website, including web pages based on templates. For web pages, you can use the draft review process or the e-mail review process to have your edits reviewed by another user before you publish.
Editing web pages and blog entries

You can edit web pages on websites and blog entries on blogs that you’re connected to and have permission to edit (see “Connecting to a website or blog” on page 12). You cannot edit a web page or blog entry if it is locked—that is, if someone else is currently editing it. When you browse to a web page or blog entry, the message area under the toolbar indicates whether you can edit it.

While you edit a web page or blog entry, Contribute saves it as a draft, and the draft title appears in the Pages panel in the sidebar.

For more information, see “Opening a page on your website for editing” on page 37. For information about working with drafts, see “Saving drafts” on page 40.

Note: To edit a Microsoft document that you’ve linked to on your website, see “Editing web page content in an external application” on page 52.
There might be restrictions on which parts of a web page draft you can edit. Your template designer can create a template with locked regions or your Contribute administrator can set up editing constraints that restrict editing to text only.

Note: If you do not have permission to edit a page or part of a page that you need to edit, talk to your Contribute administrator or see "Managing Users and Roles" on page 211.

Understanding the draft review process

The Contribute draft review process lets you send a draft to other Contribute users to get feedback or to collaborate before you publish the draft. Or, if your role doesn’t allow you to publish directly to the website, you might need to send the draft to someone who can review the draft and publish it.

You can send a draft for review to anyone who has connected to the website; Contribute stores user names when users connect to the website. You can send the draft to multiple reviewers at one time, but only one person can edit the draft at a time. When you send a draft for review, you transfer “ownership” of that draft to the reviewer. That means the reviewer has to take action on the draft. After you send a draft for review, you can track the draft to see what action the review takes on the draft.

When you receive a draft for review, it appears in your Pages panel in Contribute. You might also receive an e-mail message from the sender to alert you that you have a draft to review. As a reviewer, you can decide to edit the draft, send it to another user for review, or discard all changes by canceling the draft. Depending on your role, you might also be able to publish the draft.

Understand the e-mail review process

The Contribute e-mail review process uses your default e-mail application to create a message containing a web address where reviewers can see a temporary copy of your draft. Contribute automatically creates the temporary copy on the same server where you publish your website. The recipient clicks the web address (URL) link in the e-mail message to view your draft.

Note: If you are assigned a role that cannot publish, you cannot use the e-mail review process. In that case, use the draft review process (see "Understanding the draft review process" on page 35).
When you send an e-mail review request, Contribute displays a message under the toolbar to alert you that you sent the draft for review; the message includes the date you sent the review request. You can then save the draft for later, until you get feedback from your reviewer, or you can continue editing the draft.

After reviewing your draft, the reviewer can send you feedback by e-mail. The reviewer cannot edit the review draft. You can make changes to your draft based on the reviewer’s feedback, and then publish the draft or request another review. When the draft is canceled or published, Contribute removes the temporary copy of the draft that it placed on the server for the reviewer.

E-mail review process

About templates

A Dreamweaver template contains a preset page layout and includes elements such as text and images. A template gives you a starting point for new web pages and blogs. Using a template can ensure that the pages on your website or blog have a consistent look.

For example, on a company’s internal website, the company employee template might contain basic elements and provide sections for employee information. Suppose the template has the company logo and address, and blank sections for the employee’s name, department, phone number, and picture. Any new employee page based on the company employee template inherits the same page layout.

In a template, the designer creates regions to control which elements of a template-based page you can edit. There are editable regions in a template, which you can edit, and locked regions, which you can’t edit. In the employee template example, the company logo and address might be in a locked region. The employee information sections would be editable regions.
Editing existing web pages and blog entries

You can edit any web pages on your website or blog entries on your blog, as long as you have permission and someone else is not currently editing the web page or blog entry.

For more information about editing existing web pages and blog entries, see “Editing web pages and blog entries” on page 34.

You can also use Contribute plug-ins to edit web pages and blog entries from your browser such as Internet Explorer and Mozilla Firefox.

For more information about editing web pages and blog entries with Contribute plug-ins, see “Opening a web page or blog entry for editing from your browser” on page 39.

Opening a page on your website for editing

After you've connected to a website, you can easily open and edit pages on that website. To open a page for editing, you browse to the page.

To edit a page on your website:
1. Browse to the page to edit (see “Browsing to web pages and blog entries” on page 23).
2. Do one of the following:
   - Click the Edit Page button in the toolbar.
   - Select File > Actions > Edit Page.
The page appears in the Contribute editor as a draft, and the draft title appears in the Pages panel.

**Opening a blog entry for editing in Contribute**

You can make changes to a blog entry in two ways. You can edit an entry directly in Contribute. Alternatively, if you have an entry in a browser window, you can click the Edit in Contribute button to start Contribute, where you can edit the entry. For more information, see “Opening a web page or blog entry for editing from your browser” on page 39.

*Note:* If the Edit Page or Edit Entry button is not visible in the toolbar in the Contribute application, you aren’t connected to the blog server hosting the blog. Click the Create Connection button in the toolbar to create a connection to the blog server.

**To edit a blog entry in Contribute:**

1. Browse to your blog home page.
2. From the Entries pop-menu, select the blog entry you want to manage, or select View > Select Blog Entry > blog entry title and choose the relevant blog entry to edit. Alternatively, select View > Choose File or Blog Entry, and in the Choose File or Blog Entry dialog box, click the Edit button.

The selected blog entry appears in the embedded browser, and the title of the selected blog entry is displayed in the Entries pop-up menu.

3. Click the Edit Entry button or select File > Actions > Edit Entry.

The blog entry opens as a draft in Contribute. You can make your changes to the content as needed, and publish the entry.

*Note:* You can link this blog entry to a blank blog entry and publish the entries. For more information, see “Linking to a new blank blog entry” on page 136.

**Opening a page for editing that is on your computer**

You can use Contribute to edit pages that aren’t on a website you’ve connected to; you can open an HTML page saved on your computer and make your edits. The experience is similar to using Notepad or TextEdit, but it has the ease of use and functionality of Contribute.

For example, suppose you receive an HTML page in e-mail that you need to edit for a coworker. Even if the page isn’t associated with a website you’ve connected to, you can save the page to your computer, open and edit the page in Contribute, and return it to your coworker.

*Note:* Do not create a connection to your local drive. If you do, Contribute treats files saved on your computer as files on a website, and the Direct Edit feature does not work properly.

**To edit a web page that is on your computer:**

1. In the Contribute browser or editor, select File > Open.

The Open dialog box appears.

*Note:* You cannot use this feature to open and edit TXT files saved on your computer.

2. Navigate to and select the file you want to edit, and then click Open.

The page opens as a draft in the Contribute editor; the toolbar contains Save and Close buttons instead of Publish and Discard Draft buttons.
Note: Administrator preferences are not applied because this page is not part of a website. To enforce preferences for pages that are edited this way, see the Contribute Support Center at http://www.adobe.com/support/contribute/.

Opening a web page or blog entry for editing from your browser

Now you can use Contribute plug-ins to easily edit web pages and blog entries directly from a browser such as Microsoft Internet Explorer and Mozilla Firefox. You can make changes to your content from the web page or blog entry itself, instead of opening the Contribute application.

Supported browsers and operating systems

This feature is available on the following browser versions and operating systems:

- Internet Explorer versions 5.5 and 6.0 on Windows 2000 (SP 4) and Windows XP (SP 2)
- Mozilla Firefox versions 1.5 and 2.0 on Windows 2000 (SP 4) and Windows XP (SP 2)
- Mozilla Firefox versions 1.5 and 2.0 on Mac OS X* (10.3.9) and Mac OS X (10.4.x).

Installing the browser plug-ins in Windows

The Internet Explorer browser plug-in is automatically installed when you install Contribute CS3 on your computer. When you launch Contribute CS3 for the first time on a Windows computer, you will be prompted to install the Firefox Extension plug-in. If you click Cancel, you can install this component from the following path:

<contribute install path>/SupportFiles/FirefoxExtension/FirefoxExtensionSetup

After Contribute CS3 is successfully installed on your computer, the Edit in Contribute and Post to Blog plug-ins appear as buttons in a separate toolbar in the browser window.

Note: If you have Contribute and still cannot see the toolbars, select View > Toolbars > Contribute Toolbar in your web browser.

Installing the browser plug-ins on the Macintosh

When you launch Contribute CS3 for the first time on a Macintosh computer, you will be prompted to install the Firefox Extension plug-in.

When you launch Contribute CS3 for the first time on a Windows computer, you will be prompted to install the Firefox Extension plug-in. If you click Cancel, you can install this component from the following path:

<contribute install path>/FFExtnForContributeCS3.app

After Contribute CS3 is successfully installed on your computer, the Edit in Contribute and Post to Blog plug-ins appear as buttons in a separate toolbar in the browser window.

Key information on using Contribute in Windows and on the Macintosh

This section lists some important information to remember when you use Contribute in Internet Explorer and Mozilla Firefox browsers in Windows and on the Macintosh.
Using Contribute on the Macintosh
This sections lists the key information for using Contribute on the Macintosh:

• You can remove the Contribute browser plug-ins for Mozilla Firefox on the Macintosh only by using the Firefox Extension Manager.
• You cannot repair the Contribute application on the Macintosh; reinstall the application.

Editing a web page or blog entry in Contribute from your browser

To edit a web page or blog entry in Contribute from your browser:
1. Open or navigate to the web page, blog, or individual blog entry in your browser.
   Note: You must have a connection to your website or blog before you edit a web page or blog entry in your browser. See “Creating a website connection” on page 183 and “Creating a blog server connection” on page 184.
2. Click Edit in Contribute.
3. If you browsed to a blog home page, then select a blog entry to edit in the Entries pop-up menu.
   The web page or blog entry opens as a draft in the Contribute editor. You can now edit this page or entry.
   Note: If you see the Create Connection button when Contribute opens the page or entry, then you do not have a connection to the website or blog you were browsing and you cannot edit.

Undoing mistakes
In Contribute, as in most applications, you can undo individual mistakes as you make them. You can also redo an edit if you decide that you don’t want to undo it.

Note: In Contribute, you can also discard changes, after you publish your draft, by reverting to a previously published version of a page. For more information, see “Rolling back to a previous version of a page” on page 166.

To undo an edit:
• Select Edit > Undo.

To redo an edit:
• Select Edit > Redo.

Saving drafts
You can save a draft while you work (see “Saving a draft while you work” on page 40), or you can save a draft and switch to another draft or to the browser (see “Saving a draft” on page 41).

Saving a draft while you work
Contribute automatically saves a copy of your draft when you switch to the browser, switch to another draft, publish the draft, or exit Contribute; but you can also periodically save your work if you want.

When you edit a page or blog entry (see “Editing existing web pages and blog entries” on page 37), Contribute automatically saves the page or blog entry as a draft, and the draft title appears in the Pages panel in the sidebar.
To save a draft and continue working:
1 Select File > Save.

Note: When you save a new page draft for the first time, you do not give it a filename until you publish it. For more information, see “Publishing a new page to your website” on page 159.

To save a draft that is on your computer and continue working, do one of the following:
1 Click Save in the toolbar.

Note: This option is only available for drafts saved on your computer, not drafts that are associated with a website or blog.

2 Select File > Save.

Saving a draft
You can save a draft you’re editing and work on another draft, switch to browsing, or close Contribute.

Contribute saves your draft whenever you leave it and keeps the draft in the Pages panel until you publish (see “Published Your Web Pages and Blog Entries” on page 157), cancel (see “Discarding a draft, new page, or new blog entry” on page 54), or send for review (see “Using the draft review process” on page 41).

To save a draft until later:
1 Do one of the following to leave your draft:
   • Click Browser in the Pages panel to switch to the browser.
   • Select View > Browser to switch to the browser.
   • Click the Save for Later button in the toolbar to close the draft and switch to the browser.
   • Click another draft title in the Pages panel to edit that page.
   • Close Contribute.

2 If you closed Contribute, restart the application.

3 Click the draft title in the Pages panel to return to the draft you were previously editing.
The draft appears in the Contribute editor for you to continue editing.

Getting web page drafts and files reviewed by others
You can use the draft review process to get web page drafts and files reviewed before they are published. You can use the e-mail review process to post web page drafts for review.

Note: The draft review process only applies to web page drafts. It is not applicable to blog entry drafts.

Using the draft review process
The Contribute draft review process lets you easily send web page drafts to other Contribute users for review. You can also send files for review directly from your computer.

Note: The draft review process only applies to web page drafts. It is not applicable to blog entry drafts.
This review process lets you get feedback and collaborate with others on a web page draft or file. Reviewers can see your draft, then edit it, publish it, and send it to another reviewer, or delete it. For more information, see “Understanding the draft review process” on page 35.

Note: This feature is not available unless your website has an administrator. The administrator can set publishing and deleting permissions for each user role in the draft review process. For more information, see “Setting general role settings” on page 217.

Sending a web page draft for review

The Contribute draft review process lets you send a web page draft to other Contribute users so that you can get feedback before you publish it. Or, if your role doesn’t allow you to publish directly to the website, you might need to send the draft to someone who can review the draft and publish it.

For more information about the draft review process, see “Understanding the draft review process” on page 35.

Note: The draft review process only applies to web page drafts. It is not applicable to blog entry drafts.

To send a draft for review:

1. Click Send for Review in the toolbar, or select File > Actions > Send for Review.

   The Send for Review dialog box appears.

2. Select the Send the draft to another Contribute user option, and then complete the dialog box.

   You can send the draft to any user who has connected to this website.

   For information about options in the dialog box, click the Help button.

3. Click Send.

4. If the Send New Page dialog box appears, you can change the draft’s filename or click Choose Folder to select the folder from where you want to publish the file. Then click Send.

   Note: The current folder location appears in the web address under the filename.

5. If the Send Linked New Files dialog box appears, you can click the names of the unpublished linked pages, and then change the filenames and folder location. Then click Send All.
Contribute sends the draft to the reviewer.

**To undo the sending of a draft:**
1. Click the Draft Console link in the Pages panel.
   The draft console appears.  
   *If you have just sent the draft and are still viewing it in the Contribute window, you can click the Undo Send button and skip the rest of this procedure.*

2. Select a draft in the Sent Drafts section.
Contribute displays the draft.

3. Click the Undo Send button in the toolbar.
   You can use this option if you were the last person to send the draft for review. If, however, you send the draft to someone to review, and that person sends the draft to another reviewer, you cannot retrieve the draft because you were not the last person to send it for review.

   The draft disappears from the reviewer’s Pages panel and appears in your Pages panel.

**Sending a file for review from your computer**
You can send a file that is on your computer to another person to review or publish for you.

   *You can also publish a file directly from your computer, depending on the role the Contribute administrator assigned you. For more information, see “Publishing a file from your computer to your website” on page 162.*

**To send a file for review directly from your computer:**
1. Select File > Send File from My Computer.
   The Select File dialog box appears.

2. Select the file you want to add to the website, and then click Select.
   *Note: You cannot select HTML files or dynamic file types, such as JSP. If you select an invalid file type, Contribute warns that you cannot select this file and provides a complete list of invalid file types.*

   If you have connections to more than one website, the Select Website dialog box appears.

3. If the Select Website dialog box appears, select the website where you want to add the draft for the file for review, and then click OK.
   The website list includes any website you are connected to. The reviewer you want to send the file to must also be connected to the website you select.

   The Send for Review dialog box appears.

4. Select the name of the person you want to review the file you are sending from your computer, enter comments for the reviewer, and then click Send.
   The Send New Page dialog box appears.

5. You can change the filename, or click the Choose Folder button to save this draft in another location, and then click Send.
   *Note: The current folder location appears in the web address under the filename.*

Contribute sends the file to the reviewer.
Tracking your web page drafts
After you send a web page draft for review, you can track it to see what the reviewer does with the draft.

*Note:* The draft review process only applies to web page drafts. It is not applicable to blog entry drafts.

**To track your drafts:**
1. Click the Draft Console link in the Pages panel.
   
   *Note:* The Draft Console is not available if you don’t have a website connection that has an administrator assigned.

   The Draft Console displays links to all the drafts you have sent and all the drafts you’re editing or reviewing. Each sent draft also has status information.

   ![Contribute removes published and deleted drafts from the Draft Console every 30 days. If you would like to manually remove outdated drafts, press Control+Shift while selecting View > Refresh Drafts.]

   2. If you would like to view a draft, select the draft title.

   The draft appears in Contribute; you can click the Draft Console link to return to the Draft Console.

   3. To update your view at any time, do one of the following:
      - Click the Refresh drafts icon at the bottom of the Pages panel.
      - Click the Refresh button in the Draft Console.
      - Select View > Refresh Drafts.

   4. When you finish viewing the Draft Console or the draft you selected, select the browser or another draft in the Pages panel.

Reviewing a web page draft
When someone sends you a web page draft to review, the draft appears in your Pages panel in Contribute. You can manually refresh the Pages panel to check for drafts to review.

When you review a web page draft, depending on your user role, you can edit the draft, publish it, send it for review, or delete it. You can also view all the comments that previous senders have attached to the draft.

*Note:* The draft review process only applies to web page drafts. It is not applicable to blog entry drafts.

**To manually retrieve drafts that are sent to you for review, do one of the following:**
- Click the Refresh Drafts icon at the bottom of the Pages panel.
- Select View > Refresh Drafts.

If any drafts have been sent to you for review, they appear in the Pages panel.

**To review a draft:**
1. Select a draft in the Pages panel to review.

   The draft appears in the Contribute window for you to review; the draft status pane at the bottom of the window contains information about the draft.

   *Note:* If the draft status pane is not expanded, click the expander arrow at the bottom right of the Contribute window to display the pane.

   2. Do one of the following:
      - Click the Publish button in the toolbar to make the draft live on your website.
Note: Depending on the role the Contribute administrator assigned you, you might not be able to publish drafts.

- Click the Send for Review button in the toolbar to send the draft to another reviewer.

Note: Use this button to send to any reviewer, including the original sender.

Complete the Send for Review dialog box, and then click Send.

- Click the Edit Draft button in the toolbar to make changes to the draft.

The draft appears in the Contribute editor. After you finish editing, click the Send for Review, Publish, or Delete Draft button.

Note: Depending on the role the Contribute administrator assigned you, you might not be able to publish drafts.

- Click the Delete Draft button in the toolbar to discard this draft.

Note: Depending on the role the Contribute administrator assigned you, you might not be able to delete drafts.

To view comments for a web page draft you are reviewing:

1. While you are reviewing a web page draft, click the expander arrow at the bottom right of the Contribute window to display the draft status pane, if it is not already showing.

2. Do one of the following:
   - Click the Draft History button in the draft status pane.
   - Select View > Draft History.

The Draft History dialog box appears.

3. Select a sender's name to see comments by that person.

4. To close the comments, click Close.

Making your web page draft available for review by e-mail

You can make the web page draft available for others to review—even if they don't have Contribute.

Note: If the page to be reviewed is in a frameset, the web address is for the single page that you edited, not the entire frameset.

For more information about the e-mail review process, see “Understanding the e-mail review process” on page 35. If you are assigned a role that cannot publish, you cannot use the e-mail review process. In that case, use the draft review process (see “Understanding the draft review process” on page 35).

Note: The draft review process only applies to web page drafts. It is not applicable to blog entry drafts.

To use the e-mail review process:

1. In your draft, click the Send for Review button in the toolbar, or select File > Actions > Send for Review.
The Send for Review dialog box appears.

2 Select the Send e-mail with a link to a preview of the draft option, and then click Send.

3 If the Send New Page dialog box appears, you can change the draft's filename or click Choose Folder to save this draft in another location. Then click Send or Next.

Note: The current folder location appears in the web address (URL) under the filename.

4 If the Send Linked New Files dialog box appears, select each unpublished linked page to change the filename and folder location as necessary. Then click Send All.

Contribute creates a new e-mail message in your default e-mail application.

On the Macintosh, Contribute works with the following default e-mail applications: Mail, Eudora, and Entourage.

Note: If Contribute does not find a default e-mail application or cannot start your e-mail application, you can create the e-mail message by clicking the Click here link in the message area under the toolbar. Copy the web address (URL) for the draft that appears in the browser window and paste the address in an e-mail message to send to reviewers.

5 Enter the reviewer’s name and a message, and then send the e-mail message.

In Contribute, you can work on another draft or switch to the Contribute browser until you receive feedback from the reviewer. When you receive feedback from the reviewer, click the draft title in the Pages panel to return to the draft and update it.

Note: When you delete or publish the draft, Contribute removes the temporary copy of the draft that it placed on the server for the reviewer.

**Accessing new Review Drafts**

Adobe Contribute CS3 is configured to check for new review drafts and to synchronize them with the available drafts for connected websites and blogs in the background. The next time you edit an existing review draft, Contribute automatically checks for new review drafts, downloads them, and displays them in the Pages panel along with a notification in the Status bar indicating that there are new review drafts for review. Alternatively, you can manually check for new drafts by clicking the Refresh icon. The new draft sent for review is listed in the Drafts to Review area in the Draft Console page. As a result, the process of starting Contribute is not delayed.
To download new review drafts:

1. Click the Draft Console link in the Pages panel.

Note: The Draft Console will not be available if you do not have a website connection that has an administrator assigned to it.

The Draft Console displays links to all the drafts you have sent, and all the drafts you are editing or reviewing. Every dispatched draft has status information.

Note: Contribute removes published and deleted drafts from the Draft Console every 30 days. If you want to manually remove outdated drafts, press Control+Shift while selecting View > Refresh Drafts.

2. If you want to view a draft, select the draft title.

The draft appears in Contribute; you can click the Draft Console link to return to the Draft Console.

3. To update your view at any time, do one of the following:
   - Click the Refresh drafts icon in the Draft console panel.
   - Select View > Refresh Drafts.

If there are new review drafts, Contribute downloads them, and displays them in the Pages panel, along with a notification in the Status bar indicating that there are new review drafts for review.

While you are editing a draft, if Contribute delivers an updated version of an earlier review, you can delete the earlier draft. This delete operation does not force Contribute to check for new review drafts, and therefore, improves the performance of Contribute.

Working with web pages based on Dreamweaver templates

A Dreamweaver template is a special type of web page that contains a preset page layout and includes elements such as text and images. In Contribute, you can create a web page or a blog entry based on a template. You can also edit a template-based page for a website or a blog, edit the template properties of the page for a website, and customize templates for blogs.

Note: If you have a lot of templates on your website, Contribute can take longer to start. For faster startup, consider not connecting to specific websites and blog connections or disabling your websites and blog connections when you start Contribute. For more information, see “Enabling a website or blog server connection” on page 208.

Editing a template-based web page

A page based on a Dreamweaver template (a template-based page) has editable regions, where you can add or edit content, and locked regions, where you cannot add or edit content.

Note: If you try to edit a locked region in a document based on a template, the pointer changes to indicate that you can’t click in that region.

When you view a template-based page, you see outlines around the editable regions. The editable regions each have a tab at the upper left giving the name of that content area. The tabs show you where you can add or update content on the page.

For example, a product template-based page might have a Title region, for the product title, and a Description region, for a product description. You add content to the appropriate sections.
You can edit the editable regions of a template-based page as you would edit any other web page.

To edit a template-based web page:
1 Browse to the template-based page you want to edit.
2 Do one of the following:
   • Click the Edit Page button in the toolbar.
   • Select File > Actions > Edit Page.

The web page opens as a draft in the Contribute editor. You can make edits in the editable regions.

Working with templates for web pages and blogs
You can change template properties and customize templates when you work in web pages or blogs in Contribute. You can change template properties such as background color on a web page. You can customize blog templates by adding extra fields in the Dreamweaver template file, which is created automatically after you start working in a blog in Contribute.

Setting template properties for a web page
The Dreamweaver template designer might make it possible for you to show or hide parts of the page. You control this content in the Template Properties dialog box. Pages based on a template might have editable attributes, such as background color, that you can edit in template properties.

To modify template properties:
1 Browse to a template-based page; then click the Edit Page button in the toolbar.
2 Select Format > Template Properties.

The Template Properties dialog box opens.

3 In the Name list, select a property.
Contribute updates the bottom of the dialog box to show the label of the selected property and its assigned value.

4 In the field to the right of the property label, edit the value to modify the property.

5 Click Apply to apply changes without closing the dialog box, or click OK to apply changes and close the dialog box.
Customizing Dreamweaver template files for blogs

Whenever you create a connection to a blog in Contribute, a Dreamweaver template (DWT) file is automatically generated. You can customize DWT files to include additional fields in your blog if your blog publishing service supports extra fields. You can use these additional fields to add extra information to your blogs.

**Note:** Not all blog publishing services support extra fields.

You can enter any additional fields in the form of XML tags in the Dreamweaver template file. After you add these tags, the additional fields appear the next time you create a blog entry. For more information on creating blog entries, see “Creating a blog entry for your blog” on page 63.

**Note:** This process is helpful to customize your Dreamweaver template file. Familiarity with XML tags is helpful to publish your blog entries to a blog publishing service such as Movable Type.

You can also publish this customized blog entry to another blog if the other blog server supports extra fields; otherwise the additional fields are invisible in the blog. After you change the blog entry back to the original blog, all the additional fields become visible. For more information on specifying target blogs, see “Selecting the blog to post a blog entry to” on page 68.

**To customize a blog template file:**

1. Open the DefaultTemplate.dwt file in any text editor. To do this, do the following:
   - In Windows, the DefaultTemplate.dwt file is located at: C:\Documents and Settings\yourname\Local Settings\Application Data\Adobe\Contribute CS3\Sites\Site x\Templates.
   - On the Macintosh, the DefaultTemplate.dwt is located at: /Macintosh HD/Application Support/Adobe/Contribute CS3/Sites/Site x/Templates

   **Note:** If you cannot see the Local Settings folder, open Windows Explorer and select Tools > Folder Options > View. In Hidden files and folders, select Show hidden files and folders.

2. Enter the XML tags for the fields you want. Following is an example for adding the Extended Content, Excerpt, and Keyword tags:

   ```xml
   <<begintranslate>> <!-- TemplateBeginEditable name="mt_text_more" --> <<endtranslate>> <!-- TemplateEndEditable -->
   <<begintranslate>> <!-- TemplateBeginEditable name="mt_excerpt" --> <<endtranslate>> <!-- TemplateEndEditable -->
   <<begintranslate>> <!-- TemplateBeginEditable name="mt_keywords" --> <<endtranslate>> <!-- TemplateEndEditable -->
   
   Always add the tags after the following lines:
   
   `<div class="entry-content">

   ```xml
   <<begintranslate>> <!-- TemplateBeginEditable name="adobe_main_content" --> <<endtranslate>> <!-- TemplateEndEditable -->
   
   3. Save and close the file.

   The additional fields appear the next time you create a blog. For more information, see “Creating a blog entry for your blog” on page 63.
Refreshing Templates
If you have several templates on your website, Contribute can take longer to start. For faster startup, you can configure Adobe Contribute CS3 to start up without downloading templates from the server to your client computer. You can download updated templates whenever it is required, or when Contribute displays a message indicating that a selected template is not synchronized with the template available on the server.

To refresh templates while creating new web pages or blog entries:
1 In the Contribute browser, click the New button in the toolbar, or select File > New.

The New Web Page or Blog Entry dialog box opens.

2 In the Create new web page or blog entry for pane, select and expand the website or blog connection in which you want to create the new page or blog entry, if it is not already expanded.

3 Below the Preview pane, view information about the template associated with the selected website. If Contribute indicates that the template is out of date, click the Refresh Templates button, and select one of the following options from the pop-up menu:
   • For all websites updates templates for all websites and blogs globally.
   • For selected website/blog updates templates for the selected website or blog only.
   • For selected template updates the selected template only.

The template is refreshed.

4 Click OK.

While creating a new page, if you select a template that does not match the template on the server, Contribute prompts you to confirm whether you want to create the page based on the old template. If you click Yes, the new page is created based on the old template. However, if you click No, the selected template is updated, and then the page is created.

Note: If a template is not available, the For selected template option will be disabled.

Using Contribute to work offline
Contribute gives you the freedom to edit web pages and blog entries without a network connection. Using the Work Offline feature of Contribute, you can work on an airplane, at home, or anywhere.

While you are working offline, you can edit drafts, but you cannot use the Contribute browser. Contribute remains offline—even if you establish a network connection—until you switch to working online.

To use Contribute to work offline:
• If Contribute is running and has a network connection, select File > Work Offline (Windows) or Contribute > Work Offline (Macintosh).
• If Contribute is not running, start Contribute without a network connection; select Work Offline in the Connection Failure dialog box, and then click OK.

The Contribute browser displays the Working Offline page. Click a draft title in the Pages panel to start editing.
Switching between working online and working offline
If you start Contribute offline without a server connection, or switch to working offline during an online Contribute session, you can switch to working online whenever you establish a server connection.

Note: Contribute does not reestablish the connection to your web server. You must connect to the server before you switch to working online in Contribute.

To switch from working online to working offline:
1 Select File > Work Offline (Windows) or Contribute > Work Offline (Macintosh).
Switching to working offline does not disconnect your network connection.

To switch from working offline to working online:
1 Restore your network connection, if necessary.
2 Do one of the following:
   • Select File > Work Offline (Windows) or Contribute > Work Offline (Macintosh).
The check mark next to this menu option disappears.
   • Click the Work Online button in the toolbar.

Working offline in the Contribute editor
When you're working offline, the Contribute editor displays information about what you can do offline. You cannot browse to other web pages, websites, blog entries, or blogs when you are offline.

You can edit current drafts in the Pages panel or create web pages and blog entries while you're offline. Some Contribute editor functions are not available when you're offline. For example, you can't publish web pages or blog entries until you are online again.

Before you work offline, be sure to click Edit Page to create drafts for any web pages or blog entries you want to edit offline. You cannot access home pages or recently published web pages or blog entries while you are offline.

To edit a draft while working offline:
• Click a draft title in the Pages panel of the sidebar.
The draft opens in the Contribute editor.

To create a web page or blog entry while working offline:
• Select File > New. The New Web Page or Blog Entry dialog box opens. You can create a blank web page or blog entry.
The new web page or blog entry opens as a draft in the Contribute editor, and its title appears in the Pages panel.

To delete a new web page or blog entry while working offline:
1 Open any new web page or blog entry that you created while working offline.
   Note: You can delete only those web pages and blog entries that you created while working offline. You cannot cancel changes to a draft while working offline.
2 Click the Discard Draft button in the toolbar or select File > Actions > Discard Draft.
Contribute discards the new web page or blog entry from the Pages panel and opens the Contribute Working Offline page.
Editing web page content in an external application

To edit images, Microsoft Word documents, Adobe Fireworks content, or files of other types on your website, edit the content in the application in which it was created. You can open the appropriate application from Contribute to edit the file.

**Note:** Use Contribute to edit the file in an external application; changes you make to the local, original source file do not appear on your website.

Before you can use Contribute to start an external application editor, you may need to associate an editor with the type of the file you intend to edit. Contribute has preassigned editors for common file types.

**To edit content in an external application:**

1. To find the content you want to edit, do one of the following:
   • Browse to the page or file that contains the content you want to edit, and then click Edit Page.
   • Click the Choose button in the toolbar, navigate to the file you want to edit, and then click OK.
   **Note:** If the Contribute browser cannot display the page or file you've selected, you'll see the File Placeholder page.

2. Do one of the following:
   • If you browsed to a page and opened it as a draft, right-click (Windows) or Control-click (Macintosh) the element you want to edit, and then select Edit in External Application.
   Contribute displays the External Application Editing page and starts an external editing application.
   • If you are editing an image in Fireworks, click No in the Find Source dialog box to indicate that you do not want to edit the source file for this image; you want to edit the image for your website only.

3. In the external application, make changes as necessary; then save your changes and close the application.
   **Note:** If you are editing in Fireworks, click the Done button in the editing window.

4. In Contribute, click one of the action buttons in the toolbar.
   ![Click the Launch link on the External Application Editing page to open the content in the external editor again, to make additional changes.]

Adding Google search functionality to your web page

You can add a Google™ search field to your web page, so that your website visitors can search the entire web or just your website.

**To insert a Google search field:**

1. In your draft, place the insertion point where you'd like the search field to appear.

2. Select Insert > Google Search Field.
   The Insert Google Search Field dialog box appears.

3. Set the options on each screen, and then click Next.
   For information about any of the options in a screen, click the Help button.

4. Review the summary, and then click Done.
The Google search field appears on your draft.

**To change Google search field properties:**
1. In your draft, select the Google search field.
2. Select Format > Google Search Field Properties.
   The Google Search Field Properties dialog box appears.
3. Click any tab at the top of the dialog box, and then change options as necessary.
   For information about any of the options in the tab, click the Help button.
4. When you finish, click OK.

**Editing web page source in an external application**

You can edit web page source in an external application to make quick modifications or to do testing, such as link checking or accessibility testing. Contribute opens the source in an external editing application.

*Note:* If your Contribute administrator has not enabled source editing, you cannot edit the source in an external application. For information, talk to your Contribute administrator.

*Important:* Editing web page source in an external application is very different than the editing experience in Contribute. If you are unsure about editing the source directly, talk to your Contribute administrator.

**To edit a web page's source in an external application:**
1. In the Contribute browser or editor, view the page you want to edit the source for.
   Contribute displays the External Application Editing page and starts an external editing application.
3. In the external application, make changes as necessary, and then save your changes and close the file or application.
   *Important:* Be careful when you edit web page source—you can easily alter style and formatting and get unexpected results. If you are unsure about editing the source directly, talk to your Contribute administrator.
4. In Contribute, do one of the following:
   - Click the Edit in Contribute link on the External Application Editing page to reload the draft in Contribute.
     This option lets you see your changes and resume editing.
   *Note:* If Contribute warns you that you must save and close the file in the external application, click OK.
   - Click the Launch link on the External Application Editing page to reopen the content in the external editor.
     This option lets you make additional changes, and provides a convenient way to switch back and forth between Contribute and the external editing application.
   - Click the Publish button in the toolbar to publish your changes to the website.
   - Click the Send for Review button to send the draft to another user to review your changes.
   - Click the Discard Draft button if you want to discard the changes after editing in an external application.
This options discards all changes you’ve made in Contribute or in the external application since you started editing this draft.

**Discarding a draft, new page, or new blog entry**

When you are editing a draft of an existing web page or blog entry, you can decide to discard all changes and retain the currently published version of the web page or blog entry. When you are editing a new web page or blog entry that you created, you can discard it.

Also, depending on your role, you might be able to delete pages that are published on your website. For more information, see “Deleting a web page” on page 54.

**To discard changes to a draft of a published web page or blog entry:**
- In your draft, click the Discard Draft button in the toolbar.

The published version of the web page or blog entry appears in the Contribute browser, without any edits.

**To cancel a new web page or blog entry:**
- In the new page draft, click the Discard Draft button in the toolbar.

Contribute discards the new web page or blog entry.

**Deleting a web page or blog entry**

You can permanently delete pages and entries from your website or blog.

If you want to delete a draft, and not remove the existing page or entry from your website or blog, see “Discarding a draft, new page, or new blog entry” on page 54.

This section covers the following topics:
- “Deleting a web page” on page 54
- “Deleting a blog entry” on page 55

**Deleting a web page**

Depending on your role, you might be able to delete pages from your website. If you can delete pages, you can delete files of any type on your website, including image files.

*Note:* If you do not have permission to delete a page that you need to delete, talk to your Contribute administrator or see “Setting folder and file access settings” on page 218.

You do not need special permission to delete a new page that you created and haven’t published yet. For more information, see “Discarding a draft, new page, or new blog entry” on page 54.

**To delete a page or file:**
1. Do one of the following to find the page or file:
   - Browse to the page or file you want to delete.
   - Click the Choose button in the toolbar; then select a file and click OK.
Note: If Contribute cannot display the page or file you browse to, you’ll see the File Placeholder page. You can still delete the page or file, even though you can’t view it.

2 Select File > Actions > Delete Page.

Note: This menu item is disabled if you do not have permission to delete pages on your website.

An alert appears.

3 Click Yes to confirm that you want to delete the file.

Contribute deletes the page and displays the last page you viewed in the browser.

Deleting a blog entry
You can delete existing entries from your blog.

If you want to delete a draft, see “Discarding a draft, new page, or new blog entry” on page 54.

To delete a blog entry:
1 In the Contribute browser, browse to the blog home page that contains the entry you want to delete.

2 From the Entries pop-up menu, select the blog entry you want to delete, or select View > Select Blog Entry and choose the relevant blog entry.

3 When the blog entry is displayed in the embedded browser, click the Delete Entry button, or select File > Actions > Delete Entry.

Note: You can also delete a blog entry by selecting the Choose File or Blog Entry option from the View menu. In the dialog box that appears, select the required blog entry, and click the Delete button.

4 In the confirmation dialog box, click Yes to confirm that you want to delete the entry.

Contribute deletes the entry from your blog, and displays your blog home page.

Note: The list of blog entries in the Entries pop-up menu is updated after a blog entry is deleted.

Refreshing the Entries list
You can update the list of blog entries in your home page by refreshing the list, manually.

To refresh the Entries list:
• Click the Refresh Blog Entry List button to refresh the list of blog entries displayed in the Entries pop-up menu, or select View > Refresh Blog Entry List.

The blog entries listed in the Entries pop-up menu are updated.

Exporting a Web Page or Blog Entry (Windows only)
Contribute lets you export a web page or blog entry from Contribute to an external HTML file. You can save the file anywhere on your computer or network.

If you export a new web page with images—that is, a page you haven't published yet—you’ll see the images in your exported web page. If you edit an existing web page—a previously published page—you might not see all the images on your exported page. This is because the new web page references local versions of the images, and the existing page references images that are saved on your website.
To export a web page or blog entry:
1. Browse to the web page or blog entry to export.
2. Do one of the following:
   • If you are exporting a web page, click the Edit Page button in the toolbar.
   • If you are exporting a blog entry, click the Edit Entry button in the toolbar.
   The Export dialog box appears.
4. Select a location to save the exported file.
5. Enter a filename.
6. Click Save.
   The exported file appears in the folder you selected.

Printing a web page or blog entry

You can browse to a web page or blog entry and print it, or you can print a web page or blog entry you are editing to check your changes.

To preview a web page or blog entry before you print:
1. Do one of the following:
   • Select File > Print Preview (Windows).
   • Select File > Print, and then click the Preview button (Macintosh).
   The web page or blog entry appears in a browser window.
2. To print the page or blog entry, click Print or OK.
3. Click Close to close the preview when you finish viewing it.

To print a page:
1. Select File > Print.

   Note: (Windows only) In the Contribute browser you can also right-click, then select Print.

   The Print dialog box appears.
2. Click Print or OK.
   Your default printer prints the page.
Chapter 5: Adding Pages, Blog Entries, and Documents

With Adobe® Contribute® CS3, you can add pages to your website. You can create a blank web page, a copy of a web page, a copy of a sample web page, or a web page based on a template. In addition to creating web pages, you can add existing content from Microsoft Office documents, such as Word or Excel files, to your website, and add Adobe Flash video files to a web page.

You can also use Contribute to create a stand-alone page that is not associated with one of your websites by saving the new page to your computer. And, finally, you can add a printable document to your website by converting it to an Adobe® Flash® Player 9 document.

With Contribute, you can create and post blog entries to your blog. You can also create a blank blog entry, create a blog entry by quoting a selection from a web page you are viewing, or create a blog entry from existing information you select in your browser or in Microsoft Office documents, such as Word or Excel files.

In addition to creating blog entries, you can:

- Add MP3 files and other content to a blog entry by creating an enclosure.
- Add categories, which you can use to group related blog entries.
- Select the blog you want to publish the entry to.
- Set preferences to do the following for blog entries:
  - Allow users to add comments.
  - Allow users to link to a blog entry by using its trackback URL.
  - Specify the ping server URLs you want Contribute to notify when you post a blog entry.
  - View a list of failed pings to the ping servers.
  - Determine where Contribute adds tags to blog entries and specify details about the tag repository.

After you create a web page, you can change its properties or even add keywords or a description for the web page so that website visitors can use a search engine to find the page.

You can also use the Contribute toolbar in Microsoft applications such as Word, Excel, and Outlook to insert the documents into Contribute, make changes, and publish to the websites you are connected to.

This chapter contains the following sections:

- “About converting documents to PDFs (Windows only)” on page 58
- “Creating or copying a page on your website” on page 58
- “Creating a stand-alone web page” on page 63
- “Creating a blog entry for your blog” on page 63
- “Setting page properties for a web page” on page 65
- “Adding keywords and a description for a web page” on page 66
- “Setting preferences for blog entries” on page 67
- “Entering metadata for a blog entry” on page 67
About converting documents to PDFs (Windows only)

You can use Contribute to convert MS Office documents such as Word documents, PowerPoint presentations, and Excel spreadsheets to PDF documents, and insert these documents in Adobe Contribute web pages or blog entry drafts. The process of inserting an MS Office document as a PDF involves conversion of the document to a PDF before it is inserted.

The PDF files are uploaded to a folder based on relevant Administrator settings.

Creating or copying a page on your website

You can create or copy any of the following types of pages on your website:

- Copy of Current Page
- Blank Web Page
- Starter Web Page
- Template

*Note:* If your Contribute administrator has restricted the types of new pages you can create, you won’t see all of these options when you create or copy a page. For more information, talk to your Contribute administrator or see “Settings for new web pages” on page 223.

Copying a page on your website

You can create a copy of the page you are currently viewing on your website. You must be viewing the page in the Contribute browser. You cannot create a copy of a page that is a draft in the Contribute workspace. Also, you cannot copy a page from one website to another website.

Remember to add a link to the page before you publish; otherwise, website visitors cannot navigate to the page.

To create a copy of a web page:

1. Navigate to the page you want to copy, and click the New button in the toolbar or select File > New.

*Note:* You cannot create a copy of a page that contains frames.
The New Web Page or Blog Entry dialog box appears.

2 In the Create new web page or blog entry for pane, select Copy of Current Page.

**Note:** If you cannot select this option, you are viewing a page in your browser that you cannot copy. If you do not see this option, your Contribute administrator has restricted the types of new pages that you can create. For more information, talk to your Contribute administrator or see “Settings for new web pages” on page 223.

A preview of the page appears in the Preview pane on the right side of the dialog box.

3 Enter a page title in the Page title text box.

This title appears in the browser title bar when a website visitor views the page; it does not appear on the page itself.

4 Click OK.

The new page opens as a draft in Contribute. Be sure to add a link to your new page before you publish it (see “Creating text and image links” on page 133).

**Note:** Contribute creates the new page in the same folder as the page you copied. You can change the folder location when you publish the new page.

**Creating a blank web page**

You can create a blank web page to add to your website. Remember to add a link to the page before you publish; otherwise, website visitors cannot navigate to the page.
Note: It's a good idea to create the new page and a link to that page at the same time. To do that, see "Linking to a new page" on page 134.

To create a blank web page:
1 In the Contribute browser, click the New button in the toolbar, or select File > New.
   The New Web Page or Blog Entry dialog box opens.
2 In the Create new web page or blog entry for pane, expand the website in which you want to create the new page, if it is not already expanded and select Blank Web Page.
   Note: If you don't see this option, your Contribute administrator has restricted the types of new pages that you can create. For more information, talk to your Contribute administrator or see "Settings for new web pages" on page 223.
3 Enter a page title in the Page title text box.
   This title appears in the browser title bar when a website visitor views the page; it does not appear on the page itself.
4 Click OK.
   The new page opens as a draft in Contribute. Be sure to add a link to your new page before you publish it (see "Creating text and image links" on page 133).
   Note: Contribute creates the new page in the same folder as the page you were viewing when you created the page (unless you selected another website in step 2). You can change the folder location when you publish the new page.

Copying a starter web page
Contribute comes with built-in starter web pages that you can copy and use on your website. Use any of these pages as a starting point for your web page.

Remember to add a link to the page before you publish it; otherwise, website visitors cannot navigate to the page.

Note: It's a good idea to create the new page and a link to that page at the same time. To do that, see "Linking to a new page" on page 134.

To copy a starter web page:
1 In the Contribute browser, click the New button in the toolbar, or select File > New.
   The New Web Page or Blog Entry dialog box opens.
2 In the Create new web page or blog entry for pane, do the following:
a Expand the website in which you want to create the new page, if it is not already expanded.
b Expand the Starter Web Pages folder, and then select a starter web page.
   Note: If you don't see the Starter Web Pages folder, your Contribute administrator has restricted the types of new pages that you can create. For more information, talk to your Contribute administrator or see "Settings for new web pages" on page 223.
   A preview of the page you select appears in the Preview pane on the right side of the dialog box.
3 Enter a page title in the Page title text box.
   This title appears in the browser title bar when a website visitor views the page; it does not appear on the page itself.
4 Click OK.
The new page opens as a draft in Contribute. For information about editing the starter web page, see “Editing a starter web page” on page 61. Also, be sure to add a link to your new page before you publish it (see “Creating text and image links” on page 133).

Note: Contribute creates the new page in the same folder as the page you were viewing when you created the page (unless you selected another website in step 2). You can change the folder location when you publish the new page.

Editing a starter web page

The Contribute starter web pages were created by a professional design firm. You can copy any of the sample pages and use them in your website. You can use any of the pages as a starting point to create your own page, or replace the existing content with your information.

After you create a page based on a starter web page, you can modify the page. This page is not a template, in which some parts can be modified but other parts are restricted. The page is a starting point for your web page; you can change it as needed.

Note: The hypertext links on the page do not work automatically; you must edit each link on the page so that it refers to a page in your website.

The following are guidelines for working with text, images, and links on the starter pages. These are tips to help you get started; there are many ways to modify the starter web pages to make them your own.

To modify text in a draft based on a starter page:

• To replace existing text, select any text on the draft and type over it.

When you replace existing text, Contribute retains the formatting established by the design of the starter web page. You can apply formatting to any text to override the design.

• To add text to draft, copy text from the draft or from another source (such as Microsoft Word), place the insertion point on the page or select text you want to replace, and then select Edit > Paste Text Only.

Note: To delete the date object from your page, you must deselect Protect Scripts and Forms in the administration settings. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 220.

For more information about working with text, see "Working with Text" on page 85.

To replace an image or graphic element in a draft based on a starter page:

• Select the image, press Delete, and then drag a new image to the draft.

Most images and graphics on the starter web pages have dimensions on them. When you replace an image, try to use an image that's close in size to the one you're replacing, so that you retain the page design.

Note: If you see a yellow shield icon, it's probably a placeholder for the current date. When you publish the page, the current date appears.

For more information about working with images, see "Working with Images and Graphic Elements" on page 99.

To enable links in a draft based on a starter page:

• To replace existing link text, select a link, and then type your link text.

Note: Not all links on the starter web pages look like typical links, with blue, underlined text. Links might not be underlined and might have a different design treatment applied to them. When you click an intended link on a draft based on a starter page, the status bar at the bottom of the Contribute editor indicates that it is a link.
• To make a link work, select a link, click the Link button in the toolbar, and then select Browse to Web Page. Click the Browse or Choose button in the Insert Link dialog box to find and select a page, and then click OK to close the Insert Link dialog box.

You must make the links work, or delete the ones you don't want.

You can also link to a new web page, such as another starter web page, and modify the new starter web page later. For more information, see “Linking to a new page” on page 134.

• To add a link to a vertical navigation bar, select the row that contains the last link in the series, and then select Edit > Copy. With the row still selected, click the Insert Row Below button in the toolbar. Select the new row, and then select Edit > Paste.

For more information about working with links, see “Working with Links” on page 133.

Creating a web page based on a template
You can create a page based on a template, which can help you maintain a consistent look across your website. In Contribute there are two types of templates:

• A template created in Dreamweaver® (see Dreamweaver Help > Using Dreamweaver). A Dreamweaver template is a template that a designer creates for you with editable and locked regions.

• A page that your Contribute administrator designated as a template. Your Contribute administrator can designate any page on your website as a template.

You can create a copy of either type of template to use as a starting point for your new page. The only difference is that a Dreamweaver template has editable and locked regions (see “Working with web pages based on Dreamweaver templates” on page 47), and a page designated as a template by your Contribute administrator might not.

You can create a blog entry based on a template if your blog publishing service generates Dreamweaver templates for your blog. To know more about creating blog entries, see “Creating a blog entry for your blog” on page 63.

Remember to add a link to the new page before you publish it; otherwise, website visitors cannot navigate to the page.

Note: It’s a good idea to create the new page and a link to that page at the same time for websites and blog entries. For more information, see “Linking to a new page” on page 134 and “Linking to a new blank blog entry” on page 136.

To create a page based on a template:
1 In the Contribute browser, click the New button in the toolbar, or select File > New.

The New Web Page or Blog Entry dialog box opens.

2 In the Create new web page or blog entry for pane, do the following:
   a Expand the website in which you want to create the new page, if it is not already expanded.
   b Expand the Templates folder, and then select a template.

Note: If you don’t see the Templates folder, your Contribute administrator has restricted the types of new pages that you can create. For more information, talk to your Contribute administrator or see “Settings for new web pages” on page 223.

A preview of the page you select appears in the Preview pane on the right side of the dialog box.

3 Enter a page title in the Page title text box.

This title appears in the browser title bar when a website visitor views the page; it does not appear on the page itself.

4 Click OK.
The new page opens as a draft in Contribute. Be sure to add a link to your new page before you publish it (see “Creating text and image links” on page 133).

Note: Contribute creates the new page in the same folder as the page you were viewing when you created the page (unless you selected another website in step 2). You can change the folder location when you publish the new page.

Creating a stand-alone web page

You can use Contribute to create pages that aren’t on a website you’ve connected to. You can save the page on your computer or network.

To create a draft that is not associated with a Contribute website:

1. In the Contribute browser, click the New button in the toolbar, or select File > New. The New Web Page or Blog Entry dialog box appears.

2. In the Create new web page or blog entry for pane, expand My Computer (Windows) or This Mac (Macintosh), and then select Blank Web Page.

   Note: Please select the option under My Computer (Windows) or This Mac (Macintosh) and not under a website that you are connected to.

3. Enter a title for the new page.

4. Click OK, and then click OK again at the prompt. The Save As dialog box appears.

5. Browse to the location where you want to save the file, and click OK. The new page opens as a draft in the Contribute editor.

Creating a blog entry for your blog

You can create the following types of blog entries:

• Blank Blog Entry
• Blog Entry Based on a Quoted Selection from a Web Page

Creating a blank blog entry

You can create a blank blog entry to add to your blog. A blank blog entry is a blank page that might have the template (page layout and elements such as text and images) of your blog template, depending on whether your blog publishing service generates Dreamweaver templates for your blog. For example, if you create a blank blog entry for your blog hosted by TypePad, the blank blog entry has the page layout and elements of the blog template.

You can add new information in a blank blog entry.
To create a blank blog entry:

1. In the Contribute browser, click the New button in the toolbar, or select File > New.

The New Web Page or Blog Entry dialog box opens.

2. Select the desired blog, and choose the Blank Blog Entry option.

3. Enter a title for the blog entry in the Blog entry title text box.

4. Click OK.

The new blog entry opens as a draft in Contribute.

5. (Optional) Add a tag using the Tags field.

6. In the Date area, click the Set Date icon and set the date and time when you want your blog entry draft to be published.

7. (Optional) Select one or more categories from the Categories list.

8. Click the Allow Tracbacks icon to maintain a list of other blogs that are linked to your blog entry.

9. Click the Allow Comments icon to allow users to enter comments about your blog entry.

Note: Before publishing the blog entry, from the File menu select Preview in Browser to view the blog entry in a web browser and test all the links in the entry.

10. Enter content for the blog entry and publish it.

Note: You can link a blank blog entry to another blank blog entry and publish the entries. For more information, see “Linking to a new blank blog entry” on page 136.

Creating a blog entry based on a quoted selection

You can create a new blog entry from information you select in a web page in the Contribute browser. Such a selection is called a quote.

You can also create a blog entry from a quoted selection in an external browser, such as Microsoft Internet Explorer (see “Posting content to a blog from a browser” on page 169) or from Microsoft Office applications such as Word, Excel, and Outlook (see “Posting content to a blog from Microsoft Office applications (Windows only)” on page 170). You can then publish the entry to your blog.

To create a new blog entry from a quoted selection in a web page in Contribute:

1. In the Contribute browser, browse to the web page you want to quote a selection from.

2. Make a selection in the web page.

3. Do one of the following:
   - If you have a connection to the website you are viewing, click the New button in the toolbar.
   - If you don't have a connection to the website you are viewing, select File > New.

The New Web Page or Blog Entry dialog box appears.

4. Expand the folder for the blog where you want to publish the new entry.

5. Select Quote from Current Page.

Note: This option is not available if you are using a browser other than the Contribute browser.

6. Enter the title for the blog entry in the Blog entry title field.
7  Click OK.

**Editing a blog entry**
Adobe Contribute CS3 has simplified the task of managing blog entries. You can quickly access a blog entry from your blog's home page by selecting the entry title from the Entries pop-up menu. This list displays all blog entries in the blog to which you are connected in reverse chronological order. When you select a blog entry from the Entries pop-up menu, the selected blog entry is loaded in the embedded browser.

You can make changes to a blog entry in the following ways:

- You can edit a blog entry directly in Contribute. For more information, see “Opening a blog entry for editing in Contribute” on page 38.
- If you have a blog home page or an individual entry in a browser window, you can click the Edit in Contribute button to start Contribute and edit. For more information, see “Opening a web page or blog entry for editing from your browser” on page 39.

*Note:* You must have a connection to the website or blog before you can edit a web page or blog entry in your browser.

**Setting date and time for a blog entry**
You can set the date and time when you want to schedule the publishing of your blog entry draft.

If you select an earlier date, and publish the blog entry, it is published immediately with the date you specified. If you select a future date and publish the blog entry, the blog entry will be published on the specified date at the specified time only if your blog server supports the date control API. Alternatively, the blog entry is published immediately with the future date you specified.

*Note:* The publishing date and time settings are honored by compatible blog servers only.

**Setting page properties for a web page**
For each web page, you can specify layout and formatting properties, including the default font family and font size, background color, margins, link styles, and many other aspects of page design.

*Note:* You can set page properties for web pages only. You can't set them for blog entries.

The page properties you select apply only to the current web page. If a page uses an external CSS style sheet, Contribute does not make changes to the external style sheet, because those changes affect all other pages that use that style sheet.

*Note:* If you are editing a draft based on a template, or if you are restricted to text-only editing by your Contribute administrator, you might be able to change the page title only. For more information, contact your Contribute administrator or see “Setting page-editing and paragraph settings” on page 220.

**To set page properties:**
1  In your draft, click the Page Properties button in the toolbar, or select Format > Page Properties.
The Page Properties dialog box appears.

2 Select categories from the list on the left and make changes as necessary.

By default, Contribute uses CSS to assign page properties. If your Contribute administrator set the preference to use HTML tags instead of CSS, you see only the Title/Encoding and Appearance categories on the left side of the dialog box. For more information about this setting, contact your Contribute administrator or see “Setting style and font settings” on page 221.

Note: If you cannot select the Links or Headings categories, your Contribute administrator has set options to prevent you from changing those page properties. Likewise, if you can only change page margins in the Appearance category, the administrator has restricted access to the other properties in that category. For more information, talk to your Contribute administrator or see “Setting style and font settings” on page 221.

For information about options in any of the categories, click the Help button.

3 Click Apply to see changes without closing the dialog box or click OK to apply changes and close the dialog box.

Adding keywords and a description for a web page

You can associate keywords and a description with your web page. Visitors who type one of your keywords in a search engine can find your page.

Note: You can add keywords and descriptions for web pages only. You can't add them for blog entries.

To add or change keywords and a description for a web page:

1 Browse to the page you want to add keywords and a description for, and then click the Edit Page button in the toolbar.

A draft opens in the Contribute editor.

2 Select Format > Keywords and Description.
The Page Keywords and Description dialog box appears.

3 Enter or change keywords in the Keywords pane. Separate each keyword with a single space (for example, meeting minutes planning committee holiday party).

4 Enter or change the page description in the Description pane.

5 Click OK.

Setting preferences for blog entries

You can set other preferences for blog entries. In the Preferences dialog box, you can perform the following tasks:

- Set options for the default blog to connect to, whether to create a blog entry when you click the New Page button, whether comments are allowed for blog entries, and whether to allow other users to link to a blog entry using its trackback URLs (see “Setting Contribute preferences” on page 28).

Note: Some blog hosts do not support comments, or require you to set a preference to allow comments. Review your blog host’s documentation for more information.

For more information about adding trackback URLs to blog entries, see “Adding trackback URLs to a blog entry” on page 70. For more information about adding tags to blog entries, see “Adding tags to a blog entry” on page 69.

- Specify the ping server URLs you want Contribute to notify when you post a blog entry.
- View a list of failed pings to the ping servers.

Entering metadata for a blog entry

When you’re creating or editing a blog entry, you can enter additional information about the entry using the blog metadata features. You can do the following tasks for blog entries:

- Select the blog to post the blog entry to
- Enter or change the title
- Add tags
- Assign categories
- Add trackback URLs
- Specify whether to allow comments
The primary blog metadata features—the blog to post the entry to, the blog entry title, and the tags to add to the blog entry—are available from the main blog entry toolbar in the Contribute browser. Secondary blog metadata features—categories, whether to allow trackback URLs, and whether to allow comments—are available when you click the Show/Hide Secondary Metadata button on the blog entry toolbar, next to the Tags field or select More Options from the View menu.

In addition to the blog entry toolbars, you can also enter metadata features for a blog entry from the Format > Blog Metadata menu.

**Selecting the blog to post a blog entry to**

You can select the blog where you want to post a blog entry you're creating or editing. You can post a blog entry to any blog to which you've created a Contribute connection.

**To select the blog to which you want to post a blog entry:**

1. Create or edit the blog entry you want to post.

   **Note:** For information about creating a blog entry, see “Creating a blog entry for your blog” on page 63. For information about editing a blog entry, see “Editing a blog entry” on page 65.

2. Do one of the following:

   • Select the blog where you want to post from the Blog pop-up menu in the toolbar.
   • Select Format > Blog Metadata > Blogs, and then select the blog you want to post to from the pop-up menu.

   **Note:** A warning appears if you're posting an existing blog entry that you're editing to a target blog other than the original blog. If you post the edited blog entry to a different blog, some blog metadata associated with the blog entry may be removed, and links to other blog entry drafts in the original blog are removed.

3. (Optional) Click OK to close the warning dialog box.

The blog entry is posted to the target blog.

When you post an existing edited blog entry to a new blog, any links from the blog entry to blog entry drafts in the original blog are broken. You must resolve the broken links in the blog entry you moved and in the drafts to which it linked.

**Note:** For more information on linking to a blog entry, see “Linking to a new page” on page 134. For more information on publishing a blog entry, see “Posting content to a blog” on page 169.

**Entering or changing a blog entry’s title**

You can enter or change the title for a blog entry. You can enter a title for a blog entry when you create it or change it after you save the blog entry as a draft or post it to your blog.

**To enter the title for a new blog entry:**

• Enter the title in the Blog entry title field in the New Web Page or Blog Entry dialog box when you create the entry.

**To enter or change the title for an existing blog entry or blog entry draft:**

Do one of the following:

• Enter the title in the Title field in the toolbar.

• Select Format > Blog Metadata > Title, and enter the title in the Title field in the toolbar.
Adding tags to a blog entry

You can use tags to enter one or more brief descriptions for your blog entries. Other users can search for blog entries that use those tags. For example, for a blog entry about the most strikeouts in a major league baseball game, you could enter tags such as “baseball,” “strikeouts,” “strikeout records,” and so on. The following tag repositories are provided for you:

- www.technorati.com/tag

When the user enters a tag in the tag field for a blog entry, Contribute creates a tag link. After the user publishes the entry and clicks the tag link, a list appears in the embedded browser showing all the blog entries indexed by the tag repository using the same tag.

When you create or edit a blog entry in the Pages panel, you can enter as many tags as you want for the entry, separated by commas.

Note: You can set preferences to determine where tags appear with your blog entries, the tag prefix to appear before tags in a blog entry, and more. For more information on entering tags, see “Setting Contribute preferences” on page 28.

To add tags to a blog entry:

1. In the Pages panel, select the desired blog entry.
2. Do one of the following:
   - Click the Tags field in the toolbar to place the pointer in it.
   - Select Format > Blog Metadata > Tags to place the pointer in the Tags field in the toolbar.
3. In the Tags field, enter one or more tags for the blog entry. You can enter as many tags as you want for an entry. Use commas to separate tags.
4. After you add the tags for the blog entry, you can edit it, publish it, or save it as a draft.

Note: You can clear tags from a blog entry by deleting them from the Tags field, or, if you are editing the blog entry, by deleting the tag in the entry. After you publish the updated blog entry, the tag no longer appears with the blog entry on the blog.

Assigning categories to a blog entry

You can assign categories to blog entries to group similar blog entries together. For example, you can categorize blog entries related to current affairs or sports.

You can assign more than one category to a blog entry. You can change or remove a selected category at any time.

Support for categories varies among blog hosts. Some blog hosts provide predefined categories, others let you create your own categories, and some don’t support categories. For more information, review your blog host’s documentation.

To assign a category to a blog entry:

1. In the Pages panel, select the desired blog entry.
2. Do one of the following:
   - Select the desired category from the Categories pop-up menu in the toolbar.
A check mark appears next to the selected category.

- Select Format > Blog Metadata > Categories, and then select the desired category from the pop-up menu.

A check mark appears next to the selected category.

**Note:** You can assign multiple categories to a blog entry.

**To assign a different category to a blog entry:**
1. If necessary, select the desired blog entry in the Pages panel.
2. Do one of the following:
   - Select the new category from the Categories pop-up menu in the toolbar.
   - Select Format > Blog Metadata > Categories, and then select the new category from the pop-up menu.

A check mark appears next to the specified category.

**To remove a category from a blog entry:**
1. If necessary, in the Pages panel, select the desired blog entry in the Pages panel.
2. Do one of the following:
   - Deselect the categories from the Categories pop-up menu in the toolbar.
   - Select Format > Blog Metadata > Categories, and then deselect all selected Categories from the pop-up menu.

**Refreshing the list of available categories**
Some blog hosts let you add, edit, or delete the categories you can assign to blog entries. After you make changes to the available categories at your blog host, you can refresh the list of available categories in Contribute to reflect the changes.

**Note:** You can make changes only to the available categories at your blog host. You can’t make changes to the categories in Contribute.

**To refresh the list of available categories:**
1. Select the desired blog in the Pages panel.
2. Click the Refresh button on the blog metadata toolbar.

The revised categories appear in the Categories pop-up menu in the toolbar. They also appear when you select Format > Blog Metadata > Categories. Blog entries using a newly created, edited, or deleted category are updated.

**Adding trackback URLs to a blog entry**
When you create a blog entry, you can add one or more trackback URLs to it. You use trackback URLs to maintain a list of other blogs that are linked to your blog entry. To link to one of your blog entries, other blog authors add that blog entry’s trackback URLs to their blog entry. Your blog maintains a record of these linked blog entries for each of your blog entries. You can click these links to view the linked entries. You can also prevent other users from adding your blog’s trackback URL to their blog entries by disabling the Allow Trackback option.

**Note:** You set a preference to determine whether trackback is enabled for blog entries. Some blogs don’t support the trackback feature or require you to set a preference to allow it. For more information, see your blog documentation. For more information on enabling trackback URLs for blog entries, see “Setting Contribute preferences” on page 28.
To add a trackback URL to a blog entry:

1. Select the desired blog entry in the Pages panel.

   Note: Contribute does not validate the URLs you enter in the Trackbacks dialog box or the Trackback URL(s) field. If you enter an invalid URL, or want to change the trackback URL later, you can edit the blog entry and add a new trackback URL. However, you cannot edit or delete the trackback URLs you originally entered.

2. Do one of the following:
   - Click the Trackbacks button in the toolbar.
   - Select Insert > Trackbacks.

3. Enter the trackback URL for the blog entry in the Trackback URL(s) field, and then click OK.

   Contribute adds the URLs to the blog entry, and the Trackbacks field appears at the bottom of the Contribute workspace. You can add, edit, or delete trackback URLs in this field. These modifications are also reflected in the Trackbacks dialog box.

   Note: Some blogs do not support the trackback feature or require you to set a preference to allow it. For more information, see your blog documentation.

   After you add a trackback URL to the blog entry, you can edit, publish, or save it as a draft.

   Note: You can add only one trackback URL per line in the Trackbacks dialog box and the Trackback URL(s) field in the Contribute workspace.

Allowing comments for blog entries

You can use the Blog Defaults option of the Preferences dialog box to specify whether Contribute allows the blog server to accept comments for your blog entries. If you enable comments, users can enter comments about your blog entries. You can also allow or disallow comments for individual blog entries.

   Note: You set a preference to determine whether comments are enabled for blog entries. For more information about allowing comments for blog entries, see "Setting Contribute preferences" on page 28. Some blogs don’t support comments or require you to set a preference to allow it. For more information, see your blog documentation.

To allow or disallow comments for a blog entry:

1. Browse to a blog entry.

2. Click the Edit Entry button in the toolbar, or select File > Actions > Edit Entry.

3. Do one of the following:
   - Select or deselect Format > Blog Metadata > Allow Comments to allow or disallow comments for the blog entry.
   - Click the Allow Comments button in the toolbar to allow or disallow comments.

4. After you allow or disallow comments for the blog entry, you can edit, post, or save it as a draft.

   When you post the blog entry to your blog, a Comments link lets anyone reading the entry post a comment.
Inserting MS Office documents as PDFs in Contribute pages (Windows only)

You can use Contribute to convert MS Office documents such as Word documents, PowerPoint presentations, and Excel spreadsheets to PDF documents, and insert these documents in Adobe Contribute web pages or blog entry drafts. The process of inserting an MS Office document as a PDF involves conversion of the document to a PDF before it is inserted.

*Note: If you are inserting a Microsoft Word document or Microsoft Powerpoint presentation, and want to specify the area of the document to convert, convert the document while working in Word or Powerpoint, and then insert it in your page in Contribute.*

**To insert an Office document as a PDF in Contribute:**
1. In the draft, place the insertion point where you want the PDF document to appear.
2. Select Insert > Document as PDF.
   The Open dialog box appears with a list of PDF Convertible Documents.
3. Select an MS Office document, and then click Open.
   The Insert Office Document as PDF dialog box appears.

4. Select one of the following options:
   • Create a link to the PDF document converts the document to a PDF, and inserts a link to the selected document.
   • Insert the PDF as Embedded object converts the document to a PDF, and embeds the PDF document as an object.
   *Note: The Insert the PDF as Embedded Object option is disabled if your website administrator has prevented embedding of PDFs.*
5. Select the Remember this setting and don’t ask again check box, if desired.
6. Click OK.
   Contribute converts the document to a PDF document and inserts it as a link or an embedded object into your draft.

**To delete a PDF document from a draft:**
1. In the draft, click the PDF document to select it.
2. Press the Delete key.
To create and insert a PDF document by dragging:

1. In the draft, place the insertion point where you want the PDF document to appear.

   ![Reduce the size of the Contribute window so that you can also see the application that contains the file you plan to drag.]

2. Open Windows Explorer.

3. Drag the document to convert, to the insertion point.

   The Insert Microsoft Office Document dialog box appears.

4. Select Convert to PDF and create a link to the PDF or Convert to PDF and embed the PDF as Object, and then click OK.

Contribute converts the document to a PDF document and inserts it into your draft.

Adding Microsoft Word and Excel documents to a website

With Contribute you can easily add Word and Excel documents or content from those documents to your website or blog entry.

For example, suppose you have a Word table that contains contact information for all of your sales representatives in North America. You don’t have to recreate the table on your web page—you can use Contribute to add it to your website.

There are four ways to add Word or Excel content to a web page or blog entry:

- Add the contents of a Word or Excel document to a new or existing web page or blog entry (Windows only).
- Insert a link to a Word or Excel document on an existing web page or blog entry.
- Convert the document to a PDF, and insert a link to the document in an existing web page or blog entry.
- Convert the document to a PDF, and insert the document as an embedded object in an existing web page or blog entry.

   ![In Windows, you can set a user preference so that when you add a Word or Excel document Contribute always adds the contents of the document as an embedded object or inserts a link to the document.]

You can add the contents of a Word and Excel document to the Contribute editor directly from Microsoft Office applications. For more information, see “Opening documents in Contribute from Microsoft Office applications (Windows only)” on page 75.

Adding Microsoft Word or Excel content to a page (Windows only)

You can add the contents of a Word or Excel document to a new or existing web page or blog entry.

When you add content to a page, Contribute converts it to HTML and copies it to your web page or blog entry. You can then edit the content in Contribute; changes you make to the original file on your computer do not appear on your website or blog entry.
If the document you are converting to HTML is larger than 300K, Contribute notifies you that the file is too large to convert and gives you other options for inserting the document, such as converting the document to a PDF document or inserting a link to the document. For information about these options, see “Inserting MS Office documents as PDFs in Contribute pages (Windows only)” on page 72 and “Inserting a link to a Microsoft Word or Excel document” on page 74.

**Note:** If you use Microsoft Office 97, you cannot add the contents of a Word or Excel document; you must insert a link to the document or convert the document to a PDF document.

**To add the contents of a Word or Excel document to a draft:**
1. In your draft, place the insertion point where you want the content to appear.
2. Do one of the following to select the file with the content you want to insert:
   a. In Contribute:
      i. Select Insert > Microsoft Office Document.
         The Open dialog box appears.
      ii. Select the required Microsoft Office document, and click Open.
   b. (Windows only) From Windows Explorer, drag the file from its current location to the Contribute draft where you want the content to appear.
3. In the Insert Microsoft Office Document dialog box, click Insert the contents of the document into this page, and then click OK.
4. (Optional) Select the Remember this setting and don’t ask again check box if you do not want to be asked about the insert option in the future.
   
   You can also set these preferences from the Edit menu in Contribute. To do this, select Edit > Preferences > Microsoft Documents and set the desired preferences. For more information on setting these preferences, see “Setting Contribute preferences” on page 28.
5. Click OK.

The contents of the Word or Excel document appear in your draft.

**Inserting a link to a Microsoft Word or Excel document**

You can insert a link to a Microsoft Word or Excel document in an existing page or blog entry.

When you publish the page or blog entry with the link, Contribute copies the document to your website and then links to that copy (not to the original file on your computer).

**Note:** To edit content in the linked page or blog entry after you publish, see “Editing web page source in an external application” on page 53. Changes you make to the original file do not appear on your website or blog entry.

**To create a link to a Word or Excel document:**
1. In your draft, place the insertion point where you want the content to appear.
2. Do one of the following to select the file with the content you want to insert:
   a. Place the insertion point in your draft where you want the link to appear, or select text or an image on the draft, then click the Link button in the toolbar and select File on My Computer.
   b. (Windows only) Drag the file from its current location to the Contribute draft where you want the link to appear.

In the Insert Link dialog box, enter link text, browse to the file you want to link to, and then click OK.
In the Insert Microsoft Office Document dialog box, click Create a link to the document, and then click OK.

*Note:* The link text is the name of the file you link to. To change link text after you create the link, see “Changing link text and destination” on page 147.

A link to the document appears in your draft.

**Converting documents to PDF and inserting them in drafts (Windows only)**

You can convert a Microsoft Word or Excel document to a PDF document, and insert a link to the PDF in an existing web page or blog entry, or insert the PDF as an embedded object in the draft.

**To convert an MS Office document to a PDF and insert it as a link or embedded object:**

1. In the draft, place the insertion point where you want the PDF document to appear.
2. Select Insert > MS Office Document. In the dialog box that appears, browse to the file, and then click Open.
3. Select from the following options to insert the PDF document in your Contribute draft:

   *Select these options are available for Microsoft Word and Excel documents only.*
   
   - Select Convert to PDF and create a link to the PDF to convert the selected document into a PDF, and insert a link to the PDF document.
   - Select Convert to PDF and embed the PDF as Object to convert the selected document into a PDF, and embed the PDF document as an object.

4. (Optional) Select the Remember this setting and don’t ask again check box if you do not want to be asked about the insert option in the future.
5. Click OK.

The document is converted to a PDF document and inserted as a link, or embedded as an object in your draft.

**Opening documents in Contribute from Microsoft Office applications (Windows only)**

You can open documents such as spreadsheets, Word documents, and e-mail messages in Contribute using the Contribute toolbar in Microsoft Word, Excel, and the Outlook e-mail reader. You can open the documents inside these applications, use the Office toolbar for Contribute to insert the contents into the Contribute editor, and publish the content to your website without having to open Contribute.

The Microsoft Office toolbar is automatically installed when you install Contribute CS3 on your computer.

*Note: The Contribute toolbar is installed only on computers with Microsoft Office 2003, Microsoft Office XP, and Microsoft Office 2007 versions.*

You can see the following changes in the MS Office toolbar:

- A new menu item Contribute appears in the application menu.
Opening documents in Contribute from Microsoft Word, Excel, and the Outlook e-mail reader
Whenever you open a document in Contribute from a Microsoft Office application, you can either insert a section or the entire contents of the document in the Contribute editor, create a link to the document from the active page in the Contribute editor, or insert the contents as a PDF.

Note: When you open Outlook e-mail messages in Contribute, you can insert only the contents of the message in the editor.

There are three ways to add content from Microsoft Office applications to your new web page:
• Add Word, Excel, or Outlook contents to the page
• Insert a link from a Word or an Excel document
• Inserting a Word or Excel document as a PDF

Adding Microsoft Word, Excel, or Outlook contents into a page from Microsoft Office (Windows only)
You can add the contents of a document (Word document, Excel spreadsheet, or an Outlook message) to a new web page. You can also associate templates with these documents before opening them.

When you add content to a page, Contribute copies the contents of your document into the Contribute editor. You can then edit the content in Contribute, and publish it to your website.

To add Word, Excel, or Outlook content to a page from Microsoft Office:
1 Open a document in Microsoft Word or Excel.
2 To open the document in Contribute, do one of the following from the Contribute toolbar in the application:

Note: If you made changes to the document, save the document before you open it in Contribute.
• Select Contribute > Open in Contribute.
• Click the Open in Contribute button in the toolbar.

Note: Contribute provides an alert if you do not have a website connection. For more information on creating a website connection, see “Creating a website connection” on page 183.

The Open As New Page dialog box appears in Contribute.
3 Select the website where you want to place your document.

4 Click the Choose Template button to set an updated template for an MS Office document opened in Contribute. For more information about setting a template, see “Setting templates while opening MS Office documents in Contribute (Windows only)” on page 80.

If you do not click the Choose Template button in the Open as New Page dialog box, the template that was last used to open a Microsoft Office document or the _blank template is associated with the document you are currently opening. In addition, if this template does not match the template on the server, Contribute displays the Download Template dialog box. You can choose to do one of the following:

- Click the Open using the old template button to open the document using the old template.
- Click the Download and Open button to download the updated template from the server, and then open the document.

Note: If the target website does not have templates, when you click the Choose Template button a message indicating that there are no templates is displayed.

5 (Optional) If you selected content in the document, and want to open the entire document instead of the selection, clear the Open current selection only check box.

Note: This option is available only if you selected content in the document.

For information about options in the dialog box, click the Help button.

6 Click Open.

The Insert Microsoft Office Document dialog box appears in Contribute.

Note: The Insert Microsoft Office Document dialog box does not appear if you are inserting contents from an Outlook e-mail message. The contents of the e-mail message are automatically inserted into the Contribute editor after you click Open.

7 Select Insert the contents of the document into this page.

8 (Optional) Select the Remember this setting and don't ask again check box if you do not want to be asked about the insert option in the future.

For more information about options in the dialog box, click Help.

9 Click OK.

The selected template is applied to the web page, and Contribute opens the document in a draft. Before you publish this document, you must create a link to this new page from an existing page. For more information, see “Creating text and image links” on page 133.
Note: You cannot use the Open in Contribute option for .rtf files.

Inserting a link to a Microsoft Word or Excel document from Microsoft Office (Windows only)
You can insert a link to a Microsoft Word or Excel document in a new page. When you publish the page with the link, Contribute copies the document to your website and then links to the copy (not to the original file on the computer).

To insert a link to a Word or Excel document from Microsoft Office:

1. Open a document in Microsoft Word or Excel.
2. (Optional) To open only a specific section of the document in Contribute, select the section.
3. To open the document in Contribute, do one of the following from the Contribute toolbar in the application:
   - Select Contribute > Open in Contribute.
   - Click the Open in Contribute button in the toolbar.

   Note: If you have made current changes to the document, save the document before you open it in Contribute.
   - Select Contribute > Open in Contribute.
   - Click the Open in Contribute button in the toolbar.

   Note: Contribute provides an alert if you do not have a website connection. For more information on creating a website connection, see “Creating a website connection” on page 183.

   The Open As New Page dialog box appears in Contribute.

4. Select the website where you want to place your document.

5. Click the Choose Template button to set a template for an MS Office document opened in Contribute. For more information about setting a template, see “Setting templates while opening MS Office documents in Contribute (Windows only)” on page 80.

   If you do not click the Choose Template button in the Open as New Page dialog box, the template that was last used to open a Microsoft Office document is associated with the document you are currently opening. In addition, if the template does not match the template on the server, Contribute displays the Download Template dialog box. You can do one of the following:
   - Click the Open using the old template button to open the document using the old template.
   - Click the Download and Open button to update the template with changes from the server, and then open the document.

   Note: If the target website does not have templates, when you click the Choose Template button a message indicating that there are no templates is displayed.

6. (Optional) Clear the Open current selection only check box to open the entire document instead of the selection.
Note: This checkbox is enabled only if you have selected any content in your document.

For information about options in the dialog box, click the Help button.

7 Click Open.

The Insert Microsoft Office Document dialog box appears.

8 Select Create a link to this document.

9 (Optional) Select the Remember this setting and don't ask again check box if you do not want to be asked about the insert option in the future.

For more information about options in the dialog box, click Help.

10 Click OK.

The selected template is applied to the web page, and Contribute inserts a link to the document in a draft. Before you publish this document, you must create a link to this new page from an existing page. For more information, see “Creating text and image links” on page 133.

Inserting a Microsoft Word or Excel document as a PDF from Microsoft Office (Windows only)

With Contribute, you can insert a Microsoft Word or an Excel document as a PDF document from Microsoft Word or Excel into a web page. For more information about converting MS Office documents to PDFs and inserting PDFs in Contribute pages, see “About converting documents to PDFs (Windows only)” on page 58.

To insert a document as a PDF document from Microsoft Office:

1 Open a document in Microsoft Word or Excel.

2 (Optional) To open only a specific section of the document in Contribute, select the section.

3 To open the document in Contribute, do one of the following from the Contribute toolbar in the application:

Note: If you made changes to the document, save the document before you open it in Contribute.

• Select Contribute > Open in Contribute.

• Click the Open in Contribute button in the toolbar.

Note: Contribute provides an alert if you do not have a website connection. For more information on creating a website connection, see “Creating a website connection” on page 183.

The Open As New Page dialog box appears.

4 Select the website where you want to place your document.

5 Click the Choose Template button to set a template for an MS Office document opened in Contribute. For more information about setting a template, see “Setting templates while opening MS Office documents in Contribute (Windows only)” on page 80.

If you do not click the Choose Template button in the Open as New Page dialog box, the template that was last used to open a Microsoft Office document is associated with the document you are currently opening. In addition, if this template does not match the template on the server, Contribute displays the Download Template dialog box. You can do one of the following:

• Click the Open using the old template button to open the document using the old template.

• Click the Download and Open button to update the template with changes from the server, and then open the document.
Note: If the target website does not have templates, when you click the Choose Template button a message indicating that there are no templates is displayed.

6  (Optional) Clear the Open current selection only check box to open the entire document instead of the selection. For information about options in the dialog box, click the Help button.

7  Click Open.

The Insert Microsoft Office Document dialog box appears.

8  Select Convert to PDF and create a link to the PDF or Convert to PDF and embed the PDF as Object.

9  (Optional) Select the Remember this setting and don't ask again check box if you do not want to be asked about the insert option in the future. For information about options in the dialog box, click the Help button.

10  Click OK.

Contribute converts the document to a PDF file and inserts it as a link or as an embedded object into your draft. Also, Contribute applies the selected template to the web page.

Setting templates while opening MS Office documents in Contribute (Windows only)
Adobe Contribute CS3 lets you place content from MS Office documents (MS Word and MS Excel) or entire documents in document templates, while opening the documents in Contribute.

To select document templates while opening an MS Office document in Contribute:
1  Open a Microsoft Office application file.
2  Edit the content and save the document.
3  Click the Open in Contribute button in the toolbar.

The Open as New Page dialog box appears.

Note: You cannot use the Open in Contribute option for .rtf files.

4  Select the required website.

The Root URL of the selected website appears automatically.

5  Click the Choose Template button. The Choose Template dialog box appears.

If you do not click the Choose Template button in the Open as New Page dialog box, the template that was last used to open a Microsoft Office document is associated with the document you are currently opening. In addition, if this template does not match the template on the server, Contribute displays the Download Template dialog box. You can do one of the following:

•  Click the Open using the old template button to open the document using the old template.
•  Click the Download and Open button to update the template with changes from the server, and then open the document.

Note: If the target website does not have templates, when you click the Choose Template button a message indicating that there are no templates is displayed. If the document you are opening is in the native format, the Choose Template button is disabled.

6  Select a template from the list of available templates.

The preview of the selected template appears in the Preview pane.
**Note:** While creating a new page, if you select a template that does not match the template on the server, Contribute prompts you to confirm whether you want to create the page based on the old template. If you click Yes, the new page is created based on the old template. If you click No, the selected template is updated, and then the page is created.

7 Select a template region from the list of editable regions available in the selected template.

**Note:** If the selected template does not have editable regions, the Select the template region list is empty.

This list is disabled if you select the _blank template.

**Note:** After selecting a template to use, you must select a template region. If you select a template to use and click OK, then the first editable region in the Select the template region list is selected.

8 Click the Refresh Templates button, and select one of the following options to update templates and editable regions in a selected template:

- For this website To view an updated list of templates for the selected website.
- For selected template To view an updated list of editable regions in the selected template.

9 By default, the Make this as the default template check box is selected. Clear this check box, if desired.

10 Click OK.

The selected template is applied to the web page containing the MS Office document, and the document is opened in the HTML format.

11 (Optional) If you selected content in the document, and want to open the entire document instead of the selection, clear the Open current selection only check box.

12 Click Open.

The Insert Microsoft Office Document dialog box appears.

13 Select one of the following options:

- Insert the contents of the document into this page to copy the content of the selected document into the draft.
- Create a link to the office document to insert a link to the selected document.
- Convert to PDF and create a link to the PDF to convert the selected document into a PDF, and insert a link to the PDF document.
- Convert to PDF and embed the PDF as Object to convert the selected document into a PDF, and embed the PDF document as an object.

14 (Optional) Select the Remember this setting and don’t ask again check box if you do not want to be asked about the insert option in the future.

15 Click OK.

The selected template is applied to the new web page in which the document is inserted. The selected content appears in the Contribute draft, or a link to the selected content is inserted in the draft. If you converted the document to a PDF file, Contribute inserts a link to the PDF file, or embeds the PDF file as an object.

**Note:** If you open or publish a document in Contribute without clicking the Choose Template button in the Publish to Website or Open as New Page dialog box, the last template stored in the registry is applied to the web page containing the MS Office document. If you are performing the Publish to Website or Open in Contribute operation for the first time, then a blank template is selected.
Inserting PDFs in Contribute pages

Adobe Contribute CS3 lets you embed PDFs as objects, or insert links to PDFs in Contribute web pages and blog entry drafts. You can add rich PDF content ranging from high resolution images to three-dimensional models on your website or blog page. The PDFs may be available on your computer, or on a website.

When you publish a web page or blog entry containing an embedded PDF object, Contribute makes the content EOLAS-compliant.

Note: It is recommended that you install Adobe Acrobat 8 on your computer before working with PDFs in Contribute CS3.

To insert a PDF from your computer:

1. In the draft, place the insertion point where you want the PDF document to appear.
2. Select Insert > PDF Document > From My Computer.
   
   The Open dialog box appears.
3. Navigate to the required PDF document, and then click Open.
   
   The Insert PDF Document dialog box appears.
4. Select one of the following options:
   
   • Create a link to the PDF document
   • Insert the PDF as embedded object.

   Note: The Insert the PDF as embedded Object option is disabled if the Administrator has selected the Do not allow PDF Embedding option for the relevant website or blog connection.

5. (Optional) Select the Remember this option and don’t ask again check box, if it is required.
6. Click OK.

   Note: If you inserted the PDF as an embedded object, a message box appears indicating that some content of the PDF is not accessible, and that some browsers may not render the PDF content. Select the Don’t warn me again check box, if desired, and then click OK.

   The link to the PDF or the content of the embedded PDF appears at the insertion point in the draft. If you inserted the PDF as a link, the name of the PDF file appears as the linked text.

To insert a PDF from your website:

1. In the draft, place the insertion point where you want the PDF document to appear.
2. Select Insert > PDF Document > From Website.

   Note: You can use the Insert > PDF Document > From Website option only if you have an active website.

   The Choose File or Blog Entry dialog box appears.
3. Double-click the web address and navigate to the folder containing the PDF you want to insert. Select the required PDF and click OK.

   Alternatively, the Insert PDF Document dialog box appears, and you can select one of the following options:

   • Create a link to the PDF document
• Insert the PDF as embedded object.

5 (Optional) Select the Remember this option and don’t ask again check box, if desired.

**Note:** The Insert the PDF as embedded Object option is disabled if the Administrator has selected the Do not allow PDF Embedding option for the relevant website.

6 Click OK.

**Note:** If you inserted the PDF as an embedded object, a message box appears indicating that some content of the PDF is not accessible, and that some browsers may not render the PDF content. Select the Don’t warn me again check box, if desired, and then click OK.

The link to the PDF or the content of the embedded PDF appears at the insertion point in the draft. If you inserted the PDF as a link, the name of the PDF file appears as the linked text.

**Note:** You can also drag and drop a PDF file from Windows Explorer to your website or blog entry draft.

### Resizing embedded PDF files inserted in web pages or blog entries

You can change the size of the embedded PDF object in a web page or blog entry draft by selecting the object and dragging its boundaries. Alternatively, you can resize the object by entering specific values in the PDF Properties dialog box.

**To resize an embedded PDF file manually:**

1 In your draft, select the content of the embedded PDF you want to resize.
2 Drag one of the selection handles to the desired size.

*Hold the Shift key as you drag if you do not want to change the height and width of the PDF object by the same percentage.*

**To resize an embedded PDF file with specific values:**

1 In your draft, select the embedded PDF you want to resize.
2 Double-click the embedded PDF object, right-click the object and select the PDF Properties option, or select the PDF object and choose Format > PDF Properties.

The PDF Properties dialog box appears.
3 Enter Width and Height values, and choose whether or not to constrain proportions.
4 Click OK.

Contribute changes the height and width of the embedded PDF object.

**Note:** You can also format an embedded PDF object by right-clicking the object and selecting an option from the pop-up menu.

### Inserting HTML code snippets into Contribute pages

Advanced Adobe Contribute users can use Adobe Contribute CS3 to add custom HTML code snippets to Contribute pages. For example, you can insert code snippets that run video or audio files in your web or blog pages. However, you can add code snippets only if the website Administrator has granted the relevant permission to your user role.
You can create and insert your own HTML code snippets. Although Contribute validates the syntax of the code snippet, it does not validate the code for logical correctness.

**Important:** The HTML code you add to a Contribute page may override some Administrator settings, thus altering product behavior. Therefore, it is recommended that you use this feature with discretion.

**To insert HTML code snippets in Contribute pages:**
1. Browse to a web page or your blog home page.
2. If you browsed to a blog home page, select a blog entry to edit from the Entries pop-up menu.
3. Click Edit page or Edit Entry.
4. Place the insertion point in your draft where you want to insert the HTML code snippet.
5. Select Insert > HTML Snippet.

The Insert HTML Snippet dialog box appears.

**Note:** If your website Administrator has not enabled the Allow HTML Snippet Insertion option for your user role, the HTML Snippet option in the Insert menu will be disabled. However, this option is enabled by default for blog entries.

6. Type the code snippet, or insert the HTML code snippet you have copied from another source.
7. Click OK.

The HTML code snippet is executed in the relevant draft.

**Selecting the blog entry to edit**

You use the Select a Blog Entry to Edit dialog box to select which of the blog's entries you want to edit.

**To select a blog entry to edit:**
1. In the Select the entry you want to edit pane, select the blog entry.

A preview of the page you select appears in the Preview pane.

2. Click Edit.

Contribute opens the selected blog entry for editing.
Chapter 6: Working with Text

You can use Adobe® Contribute® CS3 to add and format text, much as you do with a basic word processor. You’ll find a few differences in working with text in Contribute and a word-processing program, such as Microsoft Word, because Contribute formats your text using HTML behind the scenes.

This chapter contains the following sections:

• “About HTML and CSS styles in the Contribute Style menu” on page 85
• “Adding text to a web page” on page 86
• “Changing text appearance on the page” on page 87
• “Positioning text on the page” on page 92
• “Creating lists” on page 93
• “Checking spelling” on page 97
• “Finding and replacing text” on page 97

For information about working with text in tables, see “Working with Tables” on page 119. For information about aligning text around images, see “Aligning an image” on page 105. For information about editing link text, see “Working with Links” on page 133.

About HTML and CSS styles in the Contribute Style menu

The Style pop-up menu in Contribute lists HTML heading and paragraph styles, plus user-defined Cascading Style Sheet (CSS) styles that you can apply to format your content. All styles in the list appear as they appear when you apply them to text.

Note: If the Style menu is not enabled, your Contribute administrator has restricted the website so you cannot apply styles.

You might also be able to create CSS styles as you format text; Contribute automatically adds these styles to your style list. This makes applying the same formatting to a block of text much simpler as well as letting you create a more consistent look for your pages.

Note: You do not see HTML heading or CSS styles if your Contribute administrator has disabled one or both of them. To enable or disable CSS styles in Contribute, talk to your Contribute administrator or see “Setting style and font settings” on page 221.

You cannot attach a Cascading Style Sheet to a page in Contribute to add more styles; use Dreamweaver to attach a style sheet.
Adding text to a web page

You can add text to a web page by typing text, copying and pasting text, or dragging text from another application or web page to your Contribute draft.

If you are using the Windows version of Contribute, you can add the entire contents of a Microsoft Word or Excel document to a web page. For more information, see “Adding Microsoft Word and Excel documents to a website” on page 73.

Your Contribute administrator can specify the amount of space that Contribute adds between paragraphs when you press Enter or Return. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 220.

To add text to a draft, do one of the following:

• Place the insertion point in the draft; then type text directly into your draft.

• Select text in another application; then select Edit > Copy. Place the insertion point in your Contribute draft; then select Edit > Paste.

Leave Microsoft Excel running when you copy and paste Excel content to Contribute so that the pasted content retains its formatting.

• Drag selected text from another application to your Contribute draft.

Note: Contribute might preserve text formatting applied in the other application.

Adding the current date to a page

You can add the current date to a page. The date can also include the day of the week and the time.

To add the date to a draft:

1 Place the insertion point in your draft where you want the date to appear.

2 Select Insert > Date.

The Insert Date dialog box appears.

3 Select the format for the day, date, and time.

For information about options in the dialog box, click the Help button.

4 Click OK.
Contribute adds the current date to your draft.

**Adding special characters to a page**

You can add special characters, such as a copyright symbol (©) or a pound sign (#), to your page.

*Note:* You can add special characters only to pages that use Western (Latin 1) encoding. For more information about setting page encoding, see "Setting page properties for a web page" on page 65.

**To add a special character to a draft:**

1. Place the insertion point in your draft where you want the character to appear.
2. Do one of the following:
   - Select Insert > Special Characters, and then select a character from the pop-up menu.
   - Select Insert > Special Characters, and then select Other. In the Insert Other Character dialog box, click the character you want to insert, and then click OK.

   ![Insert Other Character dialog box](image)

   The character appears in your draft.

**Changing text appearance on the page**

Contribute lets you format text—characters and entire paragraphs—quickly and easily. You can use menu options or use the text formatting toolbar to change text with one click.

For a detailed illustration of the text formatting toolbar, see "The Contribute toolbars" on page 20.

*Note:* For information about moving text, see "Positioning text on the page" on page 92.

**Changing text font and size**

You can change the appearance of text by changing its font or size. Select a font or size from the available options; you cannot enter a custom size.
Most browsers can render the fonts in the Contribute font list. It’s good web-design practice to use fonts that are generally available to your website visitors.

Each font in the list actually represents a font combination list. To edit your list of available fonts, see “Editing the font list” on page 88.

**To change text size:**

1. In your draft, select the text you want to change.
2. Do one of the following:
   - Select a size from the Font Size pop-up menu in the text formatting toolbar.
   - Right-click (Windows) or Control-click (Macintosh), select Size, and then select a size from the pop-up menu.

*Note: This option is not available if you are working in a table.*

   - Select Format > Size, then select a size from the pop-up menu.

**To change text font:**

1. In your draft, select the text you want to change.
2. Do one of the following:
   - Select a font from the Font pop-up menu in the text formatting toolbar.
   - Right-click (Windows) or Control-click (Macintosh), select Font, and then select a font from the pop-up menu.

*Note: This option is not available if you are working in a table.*

   - Select Format > Font, then select a font from the pop-up menu.

**Editing the font list**

Font combinations in the Contribute font list determine how a browser displays text in your web page. Each font you see in the Font menu represents the first font in that font combination. You can edit the font combinations in Contribute.

A browser uses the first font in a font combination that is installed on the website visitor’s computer. If none of the fonts in the combination are installed, the browser displays the text as the visitor’s browser preferences specify.

**To edit the font list:**

1. In your draft, select Format > Font > Edit Font List.

The Edit Font List dialog box appears.
2 Select a font combination in the Font list section.
The fonts in the selected combination appear in the Chosen fonts section. The Available fonts section lists fonts that are installed on your computer.

3 Make changes as necessary.
You can add or remove a font combination, move a font combination up or down in the list, add or remove fonts from a font combination, or add a font that is not installed on your system.

For information about options in the dialog box, click the Help button.

4 Click OK when you finish editing the font list.

Applying styles to text
You can easily apply styles, such as a heading style, to format your text. The Style pop-up menu in Contribute lists HTML heading and paragraph styles, plus user-defined CSS styles.

Note: If the Style menu is not enabled, your Contribute administrator has restricted the website so that you cannot apply styles.

For more information about the HTML and CSS styles in the Style menu, see “About HTML and CSS styles in the Contribute Style menu” on page 85.

To apply a style to text:
1 In your draft, select the text you want to change or place the insertion point in the paragraph you want to change.

2 Do one of the following:
• Select a style from the Style pop-up menu in the text formatting toolbar.
• Select Format > Style, and then select a style from the pop-up menu.

The text you selected, or the entire paragraph where the insertion point is, changes to the new style.

Note: If you select a built-in heading style, the entire paragraph changes to that style, even if you selected specific text in the paragraph.

When you press Enter or Return after text that has a style applied, Contribute applies the same style to the next line, unless the previous text was a heading. When you press Enter or Return after a heading, the next line of text is in paragraph style.

To clear the current text style:
1 In your draft, select the text you want to change, or place the insertion point in the text.

2 Select Normal from the Styles pop-up menu in the text formatting toolbar.

Note: You can also select Format > Style > Remove Paragraph Breaks. This option clears the style and removes any paragraph tags around the selection.

Creating and managing styles
As you format text in a page, Contribute keeps track of the styles and builds a library of styles that you can reuse in that page.
Note: If your Contribute administrator has restricted style creation for your website, you can apply formatting properties to text, but Contribute does not save the style for you to reuse. For more information, talk to your Contribute administrator or see “Setting style and font settings” on page 221.

You can manage your list of user-defined CSS styles by renaming them or deleting them as necessary. You cannot rename or delete HTML styles in the list.

For more information about HTML and CSS styles, see “About HTML and CSS styles in the Contribute Style menu” on page 85.

To create a text style:
1. In your draft, place the insertion point in the paragraph, or select some of the text in the paragraph.
2. Apply the font, size, or color as desired.

Contribute keeps track of the formatting properties you assign and assigns a label to the new style, using the naming convention: Style1, Style2, Style3, Stylen. The label appears in the Style pop-up menu in the text formatting toolbar.

If you assign the same formatting attributes to two or more text elements, Contribute labels those elements with the same title, eliminating redundant style names.

To rename a style:
1. In your draft, select Format > Style > Rename Style or select Rename Style from the Style pop-up menu in the text formatting toolbar.
2. The Rename Style dialog box appears.
3. Select the style you want to rename from the Style pop-up menu.
4. Enter a new name in the New style name text field.
5. Click OK.

Contribute renames the style and the new name appears in the Style pop-up menu in the text formatting toolbar.

To delete a style:
1. In your draft, select Format > Style > Delete Style or select Delete Style from the Style pop-up menu in the text formatting toolbar.
2. The Delete Style dialog box appears.
3. Select the style you want to delete.
4. Click Delete.

Contribute deletes the style from the Style pop-up menu in the text formatting toolbar.

Changing text style on the page
You can change text style to bold, italic, underlined, strikethrough, emphasis, strong, and fixed width.

Note: If these options are not enabled, your Contribute administrator has restricted the website so that you cannot use these text formatting options.

To make text bold, italic, or underlined:
1. In your draft, select the text you want to change.
2. Do one of the following:
• Click the Bold or Italic button in the text formatting toolbar.
• Right-click (Windows) or Control-click (Macintosh), then select Bold, Italic, or Underline.

*Note: This option is not available if you are working in a table.*
• Select Format > Bold, Format > Italic, or Format > Underline.

*It is not good practice to use the underline style in web pages because website visitors might mistake underlined text for link text. Use a style other than underline to emphasize text.*

**To make text strikethrough, emphasized, strong, or fixed width:**
1. In your draft, select the text you want to change.
2. Do one of the following:
   • Right-click (Windows) or Control-click (Macintosh), select Other, and then select one of the options from the pop-up menu.

*Note: This option is not available if you are working in a table.*
• Select Format > Other, and then select one of the options from the pop-up menu.

*Note: Emphasis and Strong apply the same styles as Italic and Bold, respectively, but use different HTML tags. Your Contribute administrator determines which tag Contribute actually inserts.*

**Applying text color**
You can change the color of text or you can highlight text.

**To change text color:**
1. In your draft, select the text you want to change.
2. Do one of the following:
   • Click the Text Color button in the text formatting toolbar.
   • Right-click (Windows) or Control-click (Macintosh), and then select Color.

*Note: This option is not available if you are working in a table.*
• Select Format > Text Color.
The color selector appears.
3. Select a color from the color selector.
The color selector closes and the text color changes in your draft.

**To highlight text:**
1. In your draft, select the text you want to highlight.
2. Click the Highlight Color button in the text formatting toolbar, or select Format > Highlight Color.
The color selector appears.
3. Select a color from the color selector.
The color selector closes and the text is highlighted in your draft.
Positioning text on the page

To position text on your page, you can add paragraph spacing, align text, or change indentation.

Note: For information about formatting text to change its appearance, see “Changing text appearance on the page” on page 87.

Adding paragraph spacing
Contribute works similarly to many word processing applications: you press Enter (Windows) or Return (Macintosh) to create a paragraph. Web browsers automatically insert a blank line of space between paragraphs. You can add a single line of space between paragraphs by inserting a line break.

To add a paragraph return:
1 In your draft, place the insertion point at the end of a paragraph.
2 Press Enter (Windows) or Return (Macintosh).

To add a line break, do one of the following:
1 In your draft, place the insertion point where you want the line break to appear.
2 Do one of the following:
   • Select Insert > Line Break.
   • Press Shift+Enter (Windows) or Shift+Return (Macintosh).

Aligning text
You can select one of four text alignment options: Left, Center, Right, and Justify.

To change text alignment:
1 In your draft, select text, or place the insertion point in the text.

Note: Contribute applies alignment to the entire paragraph, even if you select specific text in the paragraph.
2 Do one of the following:
   • Click one of the alignment buttons in the text formatting toolbar.
   • Select Format > Align, and then select an alignment from the pop-up menu.

The text alignment changes in your draft.

Indenting text
In Contribute you can indent or outdent a paragraph. You can indent or outdent the same paragraph multiple times, further increasing or decreasing the space at the beginning of the text. Indenting and outdenting affects the right margin as well as the left.

To indent or outdent text:
1 In your draft, select the text you want to change or place the insertion point in the text.
2 Do one of the following:
   • Click the Indent or Outdent button in the text formatting toolbar.
• Select Format > Indent or Format > Outdent.
The text indentation changes in your draft.

Creating lists

You can create numbered lists, bulleted lists, and definition lists in Contribute. You can also create sublists in your lists.

Creating numbered lists

You can use numbered lists for information organized as a sequence or progression. You can apply numbering as you create the list, or you can add numbering to an existing list.

To create a numbered list:
1 Place the insertion point in your draft where you want to add the list.
2 Do one of the following:
   • Click the Numbered List button in the text formatting toolbar.
   • Select Format > List > Numbered List.
3 Type the first list item.
4 Press Enter (Windows) or Return (Macintosh) to type another item, and repeat for each item.
5 When you finish typing the list, do one of the following to turn off numbering:
   • Press Enter or Return twice.
   • Press Enter or Return, and then click the Numbered List button in the text formatting toolbar.

To create a numbered list from existing text:
1 In your draft, select multiple lines of existing text.
2 Do one of the following:
   • Click the Numbered List button in the text formatting toolbar.
   • Select Format > List > Numbered List.
Contribute adds numbers to your list.

Creating bulleted lists

Use bulleted lists to organize information that is related but in no particular sequence. You can apply bullets as you create the list, or you can add bullets to an existing list.

To create a bulleted list:
1 Place the insertion point in your draft where you want to add the list.
2 Do one of the following:
   • Click the Bulleted List button in the text formatting toolbar.
   • Select Format > List > Bulleted List.
3 Type the first list item.
4 Press Enter (Windows) or Return (Macintosh) to type another item, and then repeat for each item.
5 When you finish typing the list, do one of the following to turn off the bullets:
   • Press Enter or Return twice.
   • Press Enter or Return, and then click the Bulleted List button in the text formatting toolbar.

To create a bulleted list from existing text:
1 In your draft, select multiple lines of existing text.
2 Do one of the following:
   • Click the Bulleted List button in the text formatting toolbar.
   • Select Format > List > Bulleted List.
Contribute adds bullets to your list.

Creating definition lists
A definition list is a series of items, each with an indented sub-item.

To create a definition list:
1 Place the insertion point in your draft where you want to create the list.
2 Select Format > List > Definition List.
3 Type the first list item, and then press Enter (Windows) or Return (Macintosh).
4 Type the indented definition, and then press Enter or Return, and then repeat the previous step as necessary.
5 When you finish typing the list, do one of the following to turn off the indenting:
   • Press Enter or Return twice.
   • Press Enter or Return, and then select Format > List > Definition List.

To create a definition list from existing text:
1 In your draft, select multiple lines of existing text.
2 Select Format > List > Definition List.

Creating sublists
You can change the level of a numbered or bulleted list item to create a nested list. For example, you might have a bulleted list where one of the bullets has a sublist of bullets.
The nested list does not have to be of the same type as the parent list. For instance, you can nest a bulleted list in a numbered list. You can have multiple nested lists in your list.

To create a sublist:
1. In your draft, place the insertion point at the end of the line in an existing list where you want to create the sublist.
2. Press Enter (Windows) or Return (Macintosh).
3. Do one of the following:
   • Click the Indent button in the text formatting toolbar.
   • Press Tab.

   **Note:** This option is not available for template-based pages or in tables.
   • Select Format > Indent.

Contribute indents the number or bullet of the new line.

4. To have the sublist and parent list be different types, click the Numbered List or Bulleted List button in the text formatting toolbar, as appropriate.
5. Type the list item, and then press Enter or Return to add more items to the sublist.
6. When you finish typing the list, do one of the following to leave the sublist:
   • Press Enter or Return twice.
   • Press Enter or Return, then click the Outdent button in the text formatting toolbar.

   **Note:** If you changed the sublist to be a different type than the parent list, click the Numbered List or Bulleted List button to switch back to the type of the parent list.
Setting list properties
You can change the appearance of an entire list, or change the look of an individual list item in a bulleted or numbered list.

To set list properties for an entire list:
1. In your draft, select an entire bulleted or numbered list.
2. Do one of the following:
   • Select Format > List > Properties.
   • Right-click (Windows) or Control-click (Macintosh), and then select List > Properties.

   Note: This option is not available for template-based pages or in tables.

The List Properties dialog box appears.

3. Make changes as necessary.
   For information about options in the dialog box, click the Help button.

4. Click OK.
   Contribute applies your changes to the list. It also applies the new style automatically to any items you add to the list.

To set list properties for a list item:
1. In your draft, place the insertion point in the bulleted or numbered list item you want to change.

   Note: If you select multiple items, list properties are applied to the entire list.

2. Do one of the following:
   • Select Format > List > Properties.
   • Right-click (Windows) or Control-click (Macintosh), and then select List > Properties.

   Note: This option is not available for template-based pages or in tables.

The List Properties dialog box appears.

3. In the Selected item section, change options for the list as necessary.
   For information about options in the dialog box, click the Help button.

4. Click OK.
   Contribute applies your changes to the list item.
Checking spelling

It's a good idea to use the Check Spelling command to check the spelling in your draft after you add or edit text.

To check and correct spelling:
1 In your draft, select Format > Check Spelling.
If Contribute encounters an unrecognized word, the Check Spelling dialog box appears.
2 Select the appropriate option based on how you want Contribute to handle the discrepancy.
For information about options in the dialog box, click the Help button.
3 After you finish checking spelling, click the Close button in the Check Spelling dialog box or click OK in the Spelling Check Completed message box.

Finding and replacing text

You can search the draft you’re editing for specific text. You can also search for and replace text in drafts.

To search for text:
1 In your draft, select Edit > Find.
The Find and Replace dialog box appears.
2 Type the text you want to find, and then click Find next until you finish searching the draft.
For information about options in the dialog box, click the Help button.
3 When you finish, click Close.

To search and replace text:
1 In your draft, select Edit > Find.
The Find and Replace dialog box appears.
2 Type the text you want to find, and then type the replacement text.
3 Click Find Next.
4 For each instance, decide whether to replace the text, replace all instances of the text, or find the next instance without replacing the text.
For information about options in the dialog box, click the Help button.
5 When you finish, click Close.
Chapter 7: Working with Images and Graphic Elements

Adobe® Contribute® CS3 makes it easy for you to edit, add, or delete images on your web pages. You can add Adobe® Flash® Player 9 movies (FLV files) as easily as you add an image to a page. Now you can also add enclosures (audio and video files) to your blog. You can use Contribute to add PayPal buttons for completing e-commerce transactions through your web page. You can insert rich media images, Flash files, and videos directly from the Internet into Contribute pages.

Contribute supports the following file formats:
- **Image files** .gif, .jif, .jpe, .jpeg, .jpg, and .png
- **Flash files** .swf
- **Video files** .avi, .flv, .mp4, .mpeg, .mpg, .mov, .qt, and .wmv

For information about making an image a hypertext link (also known as a link), see “Creating text and image links” on page 133.

This chapter contains the following sections:
- “About inserting images and buttons” on page 99
- “Adding an image to a page” on page 101
- “Inserting shared assets into a web page” on page 103
- “Changing image properties” on page 104
- “Changing an image’s position or orientation” on page 105
- “Editing an image in Contribute” on page 106
- “Editing an image in an external application” on page 109
- “Inserting Flash content into your web page” on page 110
- “Inserting a video on to your web page” on page 111
- “Changing a video’s position or orientation” on page 112
- “Adding enclosures to your blog” on page 113
- “Adding and deleting a horizontal rule” on page 116
- “Inserting PayPal e-commerce buttons” on page 117

**About inserting images and buttons**

There are special considerations when you insert images and PayPal buttons on a web page.
About inserting images

You can add images from several sources, including your computer, local network, website, e-mail, Microsoft Internet Explorer web browser, or another application, such as Microsoft Word or Excel.

Note: Images that you add to your page should be in one of the following web-ready formats: .gif, .jfif, .jpe, .jpeg, .jpg, and .png (16). If the image you want to add is in another format, you can use an image-editing tool, such as Adobe Fireworks, to convert the image to a web-ready format.

When you add an image to a page, it’s a good idea to add descriptive text about the image so that the image is accessible to users with disabilities. Your Contribute administrator can enforce the image-accessibility option so that a dialog box prompts you for a description whenever you add an image.

Note: For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 220.

About PayPal buttons

PayPal buttons, created by WebAssist.com, make it easy for you to add e-commerce functionality to a Contribute page. After you create a payment button, you can instantly accept credit card payments from your customers. PayPal provides a secure, hosted check-out service to process and record all your transactions. If you don’t have a PayPal account, you can open one for free in a few minutes. There are no setup or monthly fees, and PayPal charges you only when a customer payment occurs.

Note: Your Contribute administrator must enable the PayPal feature for your role before you can use it. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 220.

You can add five kinds of PayPal buttons to a web page:

Buy Now button defines an item offered for immediate purchase, and includes a product name, price, item number, and other shipping and handling costs.

Add to Cart button defines an item that a customer can use to add the item to a shopping cart for purchase.

View Cart button is used with the Add to Cart button, and lets customers view the items in their shopping cart and check out whenever they want to complete their purchases.

Subscription button defines a service that the customer can pay for on a recurring basis, and also provides an option to setup a free trial period. You can define the amount, the subscription period, and how many times to repeat billing.

Donation button lets you collect donations from a button on your website, or even using a link in an e-mail.

All payment button wizards let you price items in multiple currencies, such as Canadian dollars, British pounds sterling, euros, or Japanese yen. They also provide options that let you display your business name and logo on the checkout page. Finally, you can specify a web address (URL) for a web page you want shown when a customers completes a purchase, such as a “Thank you for your order” page.

You insert the PayPal button and its associated functionality in a page by completing the screens of the PayPal wizard. Through the wizard, you select button images to insert in the page and define multiple options (such as an item number, price, and so on) for each item you are selling. If you need help completing the screens in the PayPal wizard, click the Help button to view additional online help.

You can insert multiple PayPal buttons in the same page. Just be sure not to insert more than one button in the same paragraph or table cell.
If your page contains other HTML forms, make sure you do not insert a PayPal button in an existing HTML form. If you use JavaScript code to reference a form in your page, verify that the JavaScript functionality is still working after you add the PayPal button(s) to your page.

Adding an image to a page

You can use three ways to add an image to your web page:

- Use the Insert menu or the Image button to add an image from your computer or website.
- Drag an image from another source to your Contribute draft.
- Copy and paste an image from another source on your Contribute draft.

*Note:* If your Contribute administrator has restricted the types of images your user role can insert, you might be able to insert images only from shared assets.

Using the Insert menu or Image button to add images to a page

You can use the Insert menu or Image button in the toolbar to add an image from your computer or website to a page.

You can add images from other sources by dragging them to the page (see “Dragging images to a page” on page 102) or by copying and pasting them on the page (see “Copying and pasting images” on page 102).

To add an image using the Insert menu or Image button:

1. Place the insertion point in your draft where you want the image to appear.
2. Do one of the following:
   - Click the Image button in the toolbar.
   - Select Insert > Image.
3. Select one of the following options from the pop-up menu:
   - From My Computer
   - From Website
   - From Internet
   - From Shared Assets

*Note:* If your Contribute administrator has restricted the types of images your user role can insert, you might be able to insert images only from shared assets.

The Select Image, Choose Image on Website, Browse for Image, or Insert Shared Asset dialog box appears.

💡 If you have already inserted an image in a page in a Contribute website, and you want to reuse the image, select From Website.

4. Browse to and select the image, and then click the Select button.

*Note:* You must select a specific file. You cannot select a folder to insert in a Contribute page.

5. If the Image Description dialog box appears, enter text to describe the image for users with disabilities or for users whose browsers are set to display text only, and then click OK.
The image appears in your draft. To make the image web-ready, Contribute reduces large images to the size pre-set by the Contribute administrator, if the administrator has enabled image processing for your role.

**Note:** If the image you are inserting is from your computer, you can edit the image inline (if your user role has permission to edit inline), but you can't edit the image in an external application until you publish the draft. For more information about editing, see “Editing an image in Contribute” on page 106.

After you insert the image, double click the image to change image properties. For more information, see “Changing image properties” on page 104.

### Dragging images to a page

You can drag an image from another source to your Contribute page.

**Note:** If your Contribute administrator has restricted the types of images your user role can insert, you might be able to insert images only from shared assets.

You can also add images by using the Insert menu or Image button (see “Using the Insert menu or Image button to add images to a page” on page 101) or by copying and pasting them on the page (see “Copying and pasting images” on page 102).

**To add an image by dragging:**

1. Reduce the size of the Contribute application window so you can also see the application that contains the image you plan to drag.
2. In the other application, select the image.
3. Drag the image to your Contribute draft where you want the image to appear.

   You can't drag an image from a web browser if the image has a link attached to it. Save the image to your computer first, and then drag the image to your Contribute draft, or copy and paste the image.

4. If the Image Description dialog box appears, enter text to describe the image for users with disabilities or for users whose browsers set to display text only, and then click OK.

The image appears in your draft. To make the image web-ready, Contribute reduces large images to the size pre-set by the Contribute administrator, if the administrator has enabled image processing for your role.

**Note:** If the image you are inserting is from your computer, you can edit the image inline, but you can't edit the image in an external application until you publish the draft. For more information about editing, see "Editing an image in Contribute" on page 106.

After you insert the image, double click the image to change image properties. For more information, see “Changing image properties” on page 104.

### Copying and pasting images

You can copy an image from another source, and paste it on your Contribute page.

**Note:** If your Contribute administrator has restricted the types of images your user role can insert, you might be able to insert images only from shared assets.

You can also add images by using the Insert menu or Image button (see “Using the Insert menu or Image button to add images to a page” on page 101) or by dragging them to the page (see “Dragging images to a page” on page 102).
To add an image by copying and pasting:

1. In the application that contains the image you want to copy, select the image.
2. Select Edit > Copy.
3. Place the insertion point in your Contribute draft where you want the image to appear.
4. Select Edit > Paste.
5. If the Image Description dialog box appears, enter text to describe the image for users with disabilities or for users whose browsers are set to display text only, and then click OK.

The image appears in your draft. To make the image web-ready, Contribute reduces large images to the size pre-set by the Contribute administrator, if the administrator has enabled image processing for your role.

Note: If the image you are inserting is from your computer, you can edit the image inline, but you can't edit the image in an external application until you publish the draft. For more information about editing, see “Editing an image in Contribute” on page 106.

💡 After you insert the image, double click the image to change image properties. For more information, see “Changing image properties” on page 104.

Inserting shared assets into a web page

Contribute lets you insert images, Flash content, or Dreamweaver library items from a list of shared assets for your website.

Your Contribute administrator adds assets to the list so that they are available to most or all users. Then you can insert assets from the list as you need them.

For example, suppose you need to add the official company logo to your draft. As long as your Contribute administrator has added the logo to the list of shared assets for your role, you can easily find the approved logo and add it to your page. For more information, see “Setting options for shared assets” on page 226.

To insert a shared asset into a web page:

1. Place the insertion point in your draft where you want the shared asset to appear.
2. Do one of the following, depending on the type of shared asset you are inserting:
   - For all shared assets, including Dreamweaver library items, select Insert > Shared Asset.
   - For images only, select Insert > Image > From Shared Assets or click the Image button in the toolbar, and then select From Shared Assets.
   - For Flash content only, select Insert > Flash > From Shared Assets.

Note: If library items and Flash content are not available, your Contribute administrator might have indicated that users in your role can insert images only from shared assets.
The Insert Shared Asset dialog box appears.

3 Select a shared asset in the left pane.
A preview appears in the right pane.

4 Click OK.

5 If the Image Description dialog box appears, enter text to describe the image for users with disabilities or for users whose browsers are set to display text only, and then click OK.

The shared asset appears on your draft.

Changing image properties

After you add an image to a page (see “Adding an image to a page” on page 101), you can change its viewable properties. Image properties include location of image source, display area size, padding, alignment, border, and alternate text.

Modifying image properties only affects the way the image appears on the page. To edit the image, see “Editing an image in Contribute” on page 106.

To change image properties:
1 In your draft, do one of the following:
   • Double-click the image.
   • Select the image, and then click the Image Properties button in the image editing toolbar.
   • Select the image, and then select Format > Image Properties.
   • Right-click (Windows) or Control-click (Macintosh) the image, and then select Image Properties.
The Image Properties dialog box appears.

![Image Properties dialog box](image.png)

2 Make changes as desired.
For information about options in the dialog box, click the Help button.

3 Click OK.
Contribute applies your changes to the image.

**Changing an image’s position or orientation**

You can move an image on a page, you can change its alignment in relation to surrounding elements, and you can rotate an image to change its orientation on the page.

**Moving an image**
You can easily move an image to a new location on a web page.

To move an image on a draft, do one of the following:
- Drag the image to a new location.
- Select the image, and then copy (or cut) and paste the image in a new location.

**Aligning an image**
You can change image alignment two ways: you can change the alignment of an image on the page (for example, where an image is in a table cell) or you can change how the image aligns with surrounding elements.

To change alignment of an image:
1 In your draft, select the image you want to realign.
2 Click an alignment option in the image editing toolbar.
Contribute aligns the image in the draft.
To change alignment of an image in relation to surrounding elements:

1. In your draft, select the image you want to realign.

2. Do one of the following:
   - Double-click the image, and then select an option from the Alignment pop-up menu in the Image Properties dialog box.
   - Right-click (Windows) or Control-click (Macintosh) the image, and then select an option from the Align pop-up menu.

Contribute aligns the image in relation to surrounding elements, such as text.

Editing an image in Contribute

In Contribute, you can edit an image's brightness and contrast, sharpening, cropping, and dimensions.

To make more advanced edits, you can edit images in an external image-editing application. For more information, see “Editing an image in an external application” on page 109.

Note: When you edit an image in Contribute, Contribute creates a copy of the image you are editing, so edits affect only this instance of the image. When you use Contribute to edit an image in an external application, you edit the original image source file, so these edits affect all instances of that image on your website.

This section covers the following topics:

- “Adjusting the brightness and contrast of an image” on page 106
- “Sharpening an image” on page 107
- “Cropping an image” on page 107
- “Resizing an image” on page 108
- “Rotating an image” on page 109

Adjusting the brightness and contrast of an image

You can adjust the contrast or brightness of an image. This affects the highlights, shadows, and midtones of an image. You typically adjust brightness and contrast to correct images that are too dark or too light.

Note: Changing an image this way affects only this instance of the image; it does not affect the original image source file.

To adjust the brightness and contrast of an image:

1. In your draft, select the image you want to adjust.

2. Do one of the following:
   - Click the Brightness/Contrast button in the image editing toolbar.
   - Select Format > Edit Image > Adjust Brightness and Contrast.
   - Right-click (Windows) or Control-click (Macintosh) the image, and then select Edit Image > Adjust Brightness and Contrast.

Note: These options are not available if you belong to a user role that the Contribute administrator has restricted from inline image editing. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 220.
The Brightness/Contrast dialog box appears.

3 Drag the Brightness and Contrast sliders to adjust the settings. Values range from -100 to 100.

4 Click OK.

**Sharpening an image**
Sharpening increases the contrast around the edges of objects to increase the image's definition.

*Note: Changing an image this way affects only this instance of the image; it does not affect the original image source file.*

**To sharpen an image:**
1 In your draft, select the image you want to adjust.

2 Do one of the following:
   • Click the Sharpen button in the image editing toolbar.
   • Select Format > Edit Image > Sharpen.
   • Right-click (Windows) or Control-click (Macintosh) the image, and then select Edit Image > Sharpen.

*Note: These options are not available if you belong to a user role that the Contribute administrator has restricted from inline image editing. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 220.*

The Sharpen dialog box appears.

3 Specify the degree of sharpening by dragging the slider control, or entering a value between 0 and 10 in the text box.

As you adjust the sharpness of the image, you can preview the change to the image.

4 Click OK.

**To undo sharpening and revert to the original image:**
• Select Edit > Undo Sharpen.

You can only undo the effect of the Sharpen command (and revert to the original image file) before publishing the page containing the image.

**Cropping an image**
You can crop (or trim) images.

*Note: Changing an image this way affects only this instance of the image; it does not affect the original image source file.*

**To crop an image:**
1 In your draft, select the image you want to crop.

2 Do one of the following:
   • Click the Crop Tool icon in the image editing toolbar.
   • Select Format > Edit Image > Crop.
   • Right-click (Windows) or Control-click (Macintosh) the image, and then select Edit Image > Crop.
Note: These options are not available if you belong to a user role that the Contribute administrator has restricted from inline image editing. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 220.

Crop handles appear.

3 Adjust the crop handles to surround the part of the image you want to keep.

4 Do one of the following to finish the crop:
   • Double-click inside the bounding box.
   • Press Enter or Return.
   • Right-click (Windows) or Control-click (Macintosh) the image, and then select Edit Image > Finish Crop.

The shaded part of the image disappears from the image.

To undo the effects of the Crop command and revert to the original image:
   • Select Edit > Undo Crop.

You can undo the effect of the Crop command (and revert to the original image file) until you quit Contribute.

Resizing an image

You can change the size of an image visually or by entering specific values.

Note: Changing an image this way affects only this instance of the image; it does not affect the original image source file.

To resize an image visually:
1 In your draft, select the image you want to resize.
2 Click the Resize button in the image editing toolbar.
3 Drag one of the selection handles to the desired image size.

Contribute changes the height and width of the image by the same percentage so that the image is not distorted.

💡 Hold the Shift key as you drag if you do not want to change the height and width of the image by the same percentage.

Note: Resizing this way affects the image size and its display area on the page. To change only the display area, see “Changing image properties” on page 104.

To resize an image with specific values:
1 In your draft, select the image you want to resize.
2 Enter Width and Height values in the image editing toolbar.

Contribute changes the height and width of the image.

Note: Resizing this way affects the image size and its display area on the page. To change only the display area, see “Changing image properties” on page 104.
To revert an image to its original size:
• In your draft, select Format > Edit Image > Revert to Original Size.

Rotating an image
You can rotate an image to change its orientation on the page.

To rotate an image:
1 In your draft, select the image you want to rotate.
2 Do one of the following:
• Click one of the rotate buttons in the image editing toolbar.
  You can click the rotate button multiple times to further rotate the image.
• Select Format > Edit Image > Rotate Clockwise or Edit Image > Rotate Counter-Clockwise.
  Right-click (Windows) or Control-click (Macintosh) the image, and then select Edit Image > Rotate Clockwise or
  Edit Image > Rotate Counter-Clockwise.

Editing an image in an external application
You can use Contribute to start an external image-editing application. You can make simple edits directly in
Contribute, using the image editing toolbar (see “Editing an image in Contribute” on page 106).

Note: When you edit an image in Contribute, Contribute creates a copy of the image you are editing, so edits affect only
this instance of the image. When you use Contribute to edit an image in an external application, you edit the original
image source file, so these edits affect all instances of that image on your website.

To edit an image in an external image-editing application:
1 Do one of the following:
• In the Contribute browser, click Choose in the toolbar, select the image you want to edit, and then click OK. When
  the image opens, click Edit in the toolbar.
• In the Contribute editor, select an image, and then select Format > Edit Image in External Application or right-
  click (Windows) or Control-click (Macintosh) the image, and then select Edit Image in External Application.

Note: The image you select should be on a published page on your website or in one of your website folders. If you add
a new image to a draft, you cannot edit that image in an external editor until it has been published to the website.

Contribute starts an application for you to edit the image.
2 If you are editing an image in Fireworks, click No in the Find Source dialog box to indicate that you do not want
to edit the source file for this image.
By clicking No, you edit the image for the website only.
3 In the external application, make changes as necessary, and then save your changes and close the application.
Important: Editing an image in an external application permanently changes the original image saved on the server and
affects other occurrences of this image throughout your website.
4 If you are editing in Fireworks, click Done in the editing window, and then close the application.
To make additional changes to the image before you publish, click Launch in Contribute to open the content in the external editor again.

In Contribute, click Publish to publish your changes to the website.

Note: Depending on the role the Contribute administrator assigned you, you might not be able to publish.

The updated image appears in Contribute.

## Inserting Flash content into your web page

Many websites contain Flash assets such as navigation buttons or a banner. You can insert Flash content from your computer, from your website, from the Internet, or from your Shared Assets list.

When you publish a page that contains Flash content, Contribute automatically copies the file (.swf) to your website.

Note: For information about inserting movie types other than Flash, see “Inserting a video on to your web page” on page 111.

**To insert Flash content:**

1. Place the insertion point in your draft where you want the Flash content to appear.
2. Select one of the following options:
   - Insert > Flash > From My Computer
   - Insert > Flash > From Website
   - Insert > Flash > From Internet
   - Insert > Flash > From Shared Assets

The Open, Choose Image From Website, Browse for Flash, or Insert Shared Asset dialog box appears.

3. Navigate to and select the Flash SWF file you want to insert, and then click Open or OK.

Note: You cannot select a folder to insert in a Contribute page.

The Flash movie object appears in your draft.

**To reuse a Flash movie (SWF file):**

- Select Insert > Flash > From Website.

**Setting Flash movie properties**

You can set properties for Flash movies (SWF files) that you insert into your web pages.

**To set Flash movie properties:**

1. In your draft, select the Flash movie object.
2. Select Format > Flash Movie Properties.
The Flash Movie Properties dialog box appears.

3 Make changes as necessary.

For information about options in the dialog box, click the Help button.

4 Click OK.

Inserting a video on to your web page

You can insert videos onto a web page and control them in Contribute.

Note: If you are inserting a SWF file, the process is slightly different; for more information, see "Inserting Flash content into your web page" on page 110.

You can insert videos that are saved on your computer, or videos available on the Internet, or videos on your website. You can also insert a video of certain file types from a still camera, video camera, or a video editor such as Movie Maker or iMovie into your web page. Some file types that you can use include QuickTime (MOV and QT), Flash video files (FLV), video files (MP4, MPG, or MPEG), AVI, and Windows Media (WMV).

When you edit and save videos for your website, save the videos for the web, so that they are compressed.

To insert a video:
1 Place the insertion point where you want the video to appear in your draft.
2 Select one of the following options:
   • Insert > Video > From My Computer
   • Insert > Video > From Website
   • Insert > Video > From Internet

The Select Video, Browse for Video, or Choose Video On Website dialog box appears.

Note: You can also drag the video from another application. To do this, reduce the size of the Contribute application window so that you can also see the application that contains the video you plan to drag. In the other application, select the video and drag the video to your Contribute draft where you want the video to appear.

3 Navigate to and select the video file to insert, and then click Open.

Note: If you insert MOV file types in Contribute, your website visitors must have the QuickTime player installed to view the video on a Windows computer. If you insert WMV file types, your website visitors must have the Windows Media player installed to view the video on a Macintosh.
A video placeholder appears in your draft.

*Note:* You may not be able to insert a video that exceeds the size restrictions that your Contribute administrator specifies for your user role. For more information, talk to your Contribute administrator or see “Setting options for file placement” on page 225.

The video does not play in the draft; you must publish your draft to play the video.

The default video display in Contribute for all video files (except for an FLV file) is 320 x 240. For an FLV file, Contribute detects the display size of the FLV file and displays it in the same size as the FLV file. If Contribute cannot detect the size of your FLV file, the video display is 320 x 240.

### Setting video properties

You can set properties for videos you insert into your web pages.

*Note:* To edit properties for a SWF file, see “Setting Flash movie properties” on page 110.

#### To set video properties:

1. Select the video placeholder in your draft.
2. Double-click the video placeholder, or select Format > Video Properties.
   
   Right-click (Windows) or Control-click (Macintosh) the video placeholder and select Video Properties.

Depending on the file you insert, a Video Properties dialog box appears.

The following Video Properties dialog box appears if you are inserting any video file except a Flash Video (FLV) file. The dialog box for FLV files has more options.

3. Make changes as necessary.
   For information about options in the dialog box, click the Help button.
4. Click OK.

   Check your video file properties for the size of your movie. Then, double-click the video placeholder in Contribute to set the display size to the size of your video, so that your web page displays the video properly.

### Changing a video’s position or orientation

You can move a video on a page, and you can change its alignment in relation to surrounding elements.
Moving a video
You can easily move a video to a new location on a web page.

To move a video on a draft, do one of the following:
• Drag the video to a new location.
• Select the video, and then copy (or cut) and paste the video in a new location.

Aligning a video
You can change video alignment in relation to surrounding elements.

To change alignment of a video in relation to surrounding elements:
1 In your draft, select the video to realign.
2 Do one of the following:
• Select Format > Align and then select an alignment option.
• Right-click (Windows) or Control-click (Macintosh) the video, and then select an option from the Align pop-up menu.

Contribute aligns the video in relation to surrounding elements, such as text.

Adding enclosures to your blog
Enclosures are audio and video files that you add to your blog entry. For example, you can add a podcast to a blog entry, and then publish it to your blog. After you publish a blog that has an enclosure, the enclosure appears as a link in the page.

Note: You can add only one enclosure to a new or existing blog entry draft. You can still add one enclosure when you edit an existing blog entry that has multiple enclosures.

When you add an enclosure to a draft, the bottom of the Contribute status bar changes to show the enclosure details. You can click the arrow in the status bar to minimize or expand this status bar, or delete the enclosure.

You can add audio and video files from the following locations to your blog entry draft:
• Your computer
• Your websites (to which you are connected)
• The Internet

Adding enclosures from your computer
You can add audio and video files located on your hard disk on your computer.

To add an enclosure from your computer:
1 Do one of the following:
• Select Insert > Enclosure > From My Computer.
• Click on the Enclosures button in the toolbar and select From My Computer from the pop-up menu.

The Select Enclosure dialog box appears.
2 Navigate to and select the audio or video file to insert, and then click Open.

The audio or video file now appears in the Enclosure workspace in the draft. The file does not play in the draft; you must publish your draft to play the file.

**Adding enclosures from your website**

You can add audio and video files from websites (to which you are connected) in Contribute.

**To add an enclosure from your website:**

1. Do one of the following:
   - Select Insert > Enclosure > From Website.
   - Click on the Enclosures button in the toolbar and select From Website from the pop-up menu.

The Choose Enclosure on Website dialog box appears.

2. Navigate to and select the audio or video file to insert.

For information about options in the dialog box, click the Help button.

3. Click Open.

The audio or video file now appears in the Enclosure workspace in the draft. The file does not play in the draft; you must publish your draft to play the file.

**Adding enclosures from the Internet**

You can add audio and video files as enclosures from the Internet.

Before adding enclosures, you can set the default media player to Windows Media Player (Windows only) or QuickTime (Windows or Macintosh).

**Adding enclosures from the Internet (Windows Media Player in Windows)**

When your default media player is Windows Media Player, you must play the audio and video files in Windows Media Player, and then add the files as enclosures in your blog entry draft.

*Note:* You cannot insert audio or video files as enclosures without playing them first in Windows Media Player.

**To add an enclosure from the Internet (Windows Media Player in Windows):**

1. In your draft, do one of the following:
   - Select Insert > Enclosure > From the Internet.
   - Click on the Enclosures button in the toolbar and select From the Internet from the pop-up menu.

The Browse for Enclosure dialog box appears.

2. Navigate to the web page that contains the link to the desired audio or video file.

3. Right-click on the hyperlink of the audio or video file and select Copy Shortcut.

This copies the path of the audio or video file to the clipboard.

4. Paste this path in the address bar in the Browse for Enclosure dialog box and click Go.

The audio or video file opens in Windows Media Player in a separate window and begins to play.

5. Close the Windows Media Player application window.

*Note:* You do not have to play the file completely to close the player window.
6 Go back to the Browse for Enclosure dialog box, which is currently open in Contribute, and click OK. The audio or video file is inserted as an enclosure and now appears in the Enclosure workspace in the draft. The file does not play in the draft; you must publish your draft to play the file.

**Adding enclosures from the Internet (QuickTime)**
You can add enclosures from the Internet if your default media player is set to QuickTime in Windows and on the Macintosh. The default media player for the Macintosh is QuickTime. In Windows, you might have to set QuickTime as the default media player to use it to add enclosures.

**To add an enclosure from the Internet (QuickTime):**
1 In your draft, do one of the following:
   • Select Insert > Enclosure > From the Internet.
   • Click on the Enclosures button in the toolbar and select From the Internet from the pop-up menu.
   
   The Browse for Enclosure dialog box appears.
2 Browse to the web page and then to the hyperlink of the audio or video file to insert.
3 Click the hyperlink of the audio or video file.
   The audio or video file opens and plays in QuickTime player in the Browse for Enclosure dialog box.
4 Click OK.
   The audio or video file is inserted as an enclosure and now appears in the Enclosure workspace in the draft. The file does not play in the draft; you must publish your draft to play the file.

**Deleting enclosures**
You can delete an enclosure that is present in the draft you are currently editing.

**To delete enclosures:**
• Click the Delete icon in the Enclosure workspace.

*Note: Deleting an enclosure from a blog entry does not delete the enclosure file; it only removes the link to the enclosure file from the blog entry. To delete files permanently from the blog, verify how you can delete files with your blog publishing service.*
Adding and deleting a horizontal rule

You can add horizontal rules to your pages to help organize content. For example, you can use rules to group text and other elements into topic areas.

To insert a horizontal rule:
1. Place the insertion point in your draft where you want the horizontal rule to appear.
2. Select Insert > Horizontal Rule.

Contribute inserts the horizontal rule. Content before the insertion point appears above the line, and content after the insertion point appears below the line.

To delete a horizontal rule:
1. In your draft, click the horizontal rule to select it.
2. Press Delete.

Changing the properties of a horizontal rule

You can customize the height, width, and shading applied to a horizontal rule on a page. By default, a horizontal rule in Contribute is 3 pixels high, expands to the width of the page or table cell in which it is inserted, and has a small drop shadow (or shading) applied.

For information about adding and deleting horizontal rules to a page, see "Adding and deleting a horizontal rule" on page 116.

To set horizontal rule properties:
1. In your draft, click the horizontal rule to select it, and do one of the following:
   - Select Format > Horizontal Rule Properties.
   - Right-click (Windows) or Control-click (Macintosh) the horizontal rule, and then select Properties.
The Horizontal Rule Properties dialog box appears.

2 Change options as necessary.
For information about options in the dialog box, click the Help button.
3 Click OK.
Contribute changes the horizontal rule properties.

Inserting PayPal e-commerce buttons

PayPal is a payment processing service that lets you sell your products and services online and accept credit card payments from your customers. You can add instant e-commerce functionality by creating payment buttons on your web pages.

Note: Your Contribute administrator must enable the PayPal feature for your role before you can use it. For more information, talk to your Contribute administrator or see "Setting page-editing and paragraph settings" on page 220.

This section covers the following topics:
• “Inserting a single PayPal button” on page 117
• “Inserting multiple PayPal buttons” on page 118
• “Editing a PayPal button” on page 118

Inserting a single PayPal button
You can easily insert a PayPal button into your page.

To insert a PayPal button:
1 Place the insertion point in your draft where you want the button to appear.
   Note: Make sure the insertion point does not overlap another PayPal button.
2 Select Insert > PayPal, and then select the type of button you want to insert.
   Note: If you cannot select a button, your Contribute administrator hasn't enabled the PayPal feature for your role. For more information, talk to your Contribute administrator or see "Setting page-editing and paragraph settings" on page 220.

The PayPal object wizard opens.
3 In the wizard, complete the screens to set the options you want to apply.
Click Next to move through the screens in the wizard.
On the Summary page, click Finish.
The PayPal button appears in your draft.

**Inserting multiple PayPal buttons**
You can insert multiple PayPal buttons in the same page. For example, you might insert an Add to Cart button and a View Cart button in the same page. However, you cannot insert more than one PayPal button in a paragraph or table cell. If you attempt to do so, an error message appears.

*Note: Your Contribute administrator must enable the PayPal feature for your role before you can use it. For more information, talk to your Contribute administrator or see “Setting page-editing and paragraph settings” on page 220.*

**To add a button in a paragraph that already contains a button:**
1. In your draft, place the insertion point in the paragraph, and then press Enter (Windows) or Return (Macintosh).
2. Insert a PayPal button.

**To add a button to a table cell that already contains a button:**
1. In your draft, place the insertion point in the cell, and then select Table > Split Cell.
2. Insert a PayPal button.

**Editing a PayPal button**
You can edit the setting you originally set for a PayPal button. For example, you might want to raise or reduce the price of an item, update the item name or description, select a different button image and so on.

**To edit a PayPal button:**
1. In the draft, click to select the PayPal button you want to edit.
   
   The highlighted button type for the selected button is the only item enabled in the pop-up menu.
3. Click a tab in the Advanced options screen to select the type of information you want to update, and then make your changes.
4. Click OK to save your changes.
Chapter 8: Working with Tables

A table is a powerful tool for presenting tabular data. For example, you might add a table to a web page that lists all your sales reps in one column, with their contact information in another column.

In Adobe® Contribute® CS3, you can add text and images to table cells the same way that you add text and images to a page (see “Working with Text” on page 85 and “Working with Images and Graphic Elements” on page 99). After you create a table you can easily modify both its appearance and structure.

This chapter contains the following sections:

- “About conflicts in table formatting” on page 119
- “Inserting a table on a page” on page 120
- “Selecting table elements” on page 121
- “Resizing tables, rows, and columns” on page 122
- “Aligning tables” on page 123
- “Cutting and copying table cells” on page 124
- “Adding, deleting, and merging table rows and columns” on page 125
- “Modifying table appearance” on page 127
- “Sorting tabular data” on page 131

About conflicts in table formatting

When formatting tables, you can set properties for the entire table or for selected cells, rows, or columns in the table. When a table property, such as background color or alignment, is set to one value for the entire table and another value for individual cells, cell formatting takes precedence over row formatting, which in turn takes precedence over table formatting.

The order of precedence for table formatting is as follows:

1. Cells
2. Rows
3. Table

For example, if you set the background color for a single cell to blue, and then set the background color of the entire table to yellow, the blue cell does not change to yellow because cell formatting takes precedence over table formatting.

Note: When you set properties for a column, Contribute changes the attributes of the `td` tag corresponding to each cell in the column.
Inserting a table on a page

You can insert a table anywhere on a page, including in another table. You can quickly add a standard table with three rows and three columns, or you can modify options to add a custom table.

💡 When you start adding content to your table, use Preview in Browser to see exactly how the table will appear in the browsers of your website visitors (see “Previewing a page in your default browser” on page 158).

To insert a table:
1. Place the insertion point in your draft where you want the table to appear.
2. Do one of the following to open the Insert Table dialog box:
   • Click the Table button in the toolbar.
   • Select Insert > Table.
   • Select Table > Insert > Table.

The Insert Table dialog box appears.

3. Complete the dialog box.

For information about options in the dialog box, click the Help button.

4. Click OK.

The table appears in your draft.

💡 After you insert the table, select it, and then click the Table button again to change table properties. For information about changing header properties, see “Modifying row or column properties” on page 128.

To insert a table in a table:
1. In your draft, place the insertion point in the table cell where you want the table to appear.
2. Do one of the following to open the Insert Table dialog box:
   • Click the Table button in the toolbar.
• Select Insert > Table.
• Select Table > Insert > Table.
The Insert Table dialog box appears.
3 Change options as necessary.
4 Click OK.
The table appears in the table cell where you placed the insertion point.

Selecting table elements

You can select an entire table, row, or column, or you can select a single cell or a contiguous block of cells in a table.

Selecting an entire table, row, or column

You might select an entire table, row, or column because you want to paste it onto another page (see “Cutting and copying table cells” on page 124) or because you want to change the background of all the cells in the selection at once (see “Modifying table appearance” on page 127).

To select an entire table, do one of the following:
• Click the upper left corner of the table or click anywhere on the right or bottom edge.
• Click in a table cell, and then select Table > Select Table.
Selection handles appear on the selected table's lower and right edges.

To select rows or columns:
1 Position the pointer to point at the left edge of a row or the top edge of a column.
2 When the pointer changes to a selection arrow, click to select the row or column, or drag to select multiple rows or columns.

Selecting a cell, a block of cells, or nonadjacent cells

You might want to select a cell or group of cells because you want to paste it onto another page (see “Cutting and copying table cells” on page 124) or because you want to change the background of all the cells in the selection at once (see “Modifying table appearance” on page 127).

When you select a block of cells, the block must form a rectangle. When you select multiple nonadjacent cells in a table, you can only modify the properties of those cells. You cannot copy or paste sets of nonadjacent cells.
To select a single cell, do one of the following:
• Click in the cell, and then drag to select the cell.
• Click in the cell, and then select Edit > Select All.

To select a line or a rectangular block of cells, do one of the following:
• Drag from one cell to another cell.
• Click in one cell, and then Shift-click another cell.

All the cells within the linear or rectangular region defined by the two cells are selected.

To select nonadjacent cells:
• Control-click (Windows) or Command-click (Macintosh) the cells, rows, or columns you want to select.

Note: If a cell, row, or column you Control-click or Command-click isn't already selected, it's added to the selection. If it is already selected, it's removed from the selection.

Resizing tables, rows, and columns

You can resize an entire table or individual rows and columns. When you resize an entire table, all the cells in the table are resized proportionately.

To resize a table:
1 In your draft, select the table you want to resize (see “Selecting table elements” on page 121).
2 Do one of the following:
   • To resize the table horizontally, drag the selection handle on the right.
   • To resize the table vertically, drag the selection handle on the bottom.
   • To resize in both dimensions, drag the selection handle at the lower right corner.

To resize a column's width, do one of the following in your draft:
• Select the column, and then drag the right border of the column.
• Select the column, and then click the Table button in the toolbar.

In the Table Column Properties dialog box, change the number in the Column width text box, and then select Pixels or Percent for the width. Alternatively, select Fit to contents to clear the set width and resize the columns to accommodate the content you add.

Note: If you select any column but the rightmost one, the width of the adjacent column also changes, and Contribute retains the original table width. If you select the rightmost column, the width of the entire table changes, and all the columns grow wider or narrower proportionately.
To resize a row’s height, do one of the following in your draft:

- Select the row, and then drag the lower border of the row.
- Select the row, and then click the Table button in the toolbar.

In the Table Row Properties dialog box, change the number in the Row height text box. Alternatively, select Fit to contents to clear the set height and resize the rows to accommodate the content you add.

Aligning tables

You can indicate how a table aligns on the web page in relation to elements, such as text or images, around it on the page.

You cannot select an alignment option when you create a table. You must insert the table (see “Inserting a table on a page” on page 120), and then change the alignment option in table properties.

To change alignment for a table:

1. In your draft, select the table you want to realign (see “Selecting table elements” on page 121).
2. Do one of the following to open the Table Properties dialog box:
   - Click the Table button in the toolbar.
   - Right-click (Windows) or Control-click (Macintosh), and then select Table Properties from the pop-up menu.
   - Select Table > Table Properties.

The Table Properties dialog box appears.

3. Select an alignment option from the Table alignment pop-up menu:
   - Default aligns the table to the left of the page. Text or images do not flow around the table.
   - Left aligns the table to the left side of the page. Text or images flow to the right of the table.
   - Center aligns the table in the center of the page.
   - Right aligns the table to the right side of the page. Text or images flow to the left of the table.

4. Click Apply to see changes without closing the dialog box, or click OK to apply changes and close the dialog box.
The table alignment changes in your draft.

**Cutting, copying, and pasting cells**

You can cut, copy, or paste a single table cell or multiple cells at once, preserving the cell formatting. You can paste cells at the insertion point or paste over a selection in an existing table.

The selected cells must be contiguous and in the shape of a rectangle. For example, the selection in this illustration is a rectangle of cells, so the cells can be cut or copied.

<table>
<thead>
<tr>
<th>Name</th>
<th>Phone</th>
<th>Role</th>
</tr>
</thead>
<tbody>
<tr>
<td>Derek Bander</td>
<td>x4921</td>
<td>Project Manager</td>
</tr>
<tr>
<td>George Woods</td>
<td>x1102</td>
<td>Director, Operations</td>
</tr>
<tr>
<td>Diane Smith</td>
<td>x7094</td>
<td>Customer Service</td>
</tr>
</tbody>
</table>

The selection in this illustration is not a rectangle, so the cells can’t be cut or copied.

<table>
<thead>
<tr>
<th>Name</th>
<th>Phone</th>
<th>Role</th>
</tr>
</thead>
<tbody>
<tr>
<td>Derek Bander</td>
<td>x4921</td>
<td>Project Manager</td>
</tr>
<tr>
<td>George Woods</td>
<td>x1102</td>
<td>Director, Operations</td>
</tr>
<tr>
<td>Diane Smith</td>
<td>x7094</td>
<td>Customer Service</td>
</tr>
</tbody>
</table>

**Cutting and copying table cells**

You can copy a single cell or multiple cells, and cut the cells, or the cells’ content, from the table. You can copy a single cell or multiple cells, and paste the cells in the same or another table (see “Pasting table cells” on page 125).

**To copy table cells, rows, or columns:**

1. In your draft, select one or more cells, rows, or columns in the table (see “Selecting table elements” on page 121).
2. Do one of the following:
   - Select Edit > Copy.
   - Right-click (Windows) or Control-click (Macintosh), and then select Copy.

Contribute copies the selection to the Clipboard.

**To cut table cells, rows, or columns:**

1. In your draft, select one or more cells, rows, or columns in the table (see “Selecting table elements” on page 121).
2. Do one of the following:
   - Select Edit > Cut.
   - Right-click (Windows) or Control-click (Macintosh), and then select Cut.

Contribute cuts the selection from the table and copies it to the Clipboard.

**To remove cell content but leave the cells intact:**

1. In your draft, select one or more cells.

*Note:* Do not select an entire row or column. If you do, when you select Edit > Clear or press Delete, Contribute removes the entire row or column—not just its contents—from the table.
2 Select Edit > Clear or press Delete.
Contribute removes the contents of the cells you selected, but leaves the empty cells in the table.

**Pasting table cells**

You can copy cells (see “Cutting and copying table cells” on page 124) and then paste them at the insertion point in a table or paste over a selection in an existing table.

When you paste multiple table cells, the contents of the Clipboard must be compatible with the structure of the table or the selected block where they will go. For example, if you copy a block that is two cells by two cells, you must paste it in a two-by-two block.

**To paste table cells:**

1 Copy some table cells (see “Cutting and copying table cells” on page 124).
2 In your draft, do one of the following to indicate where you want to paste the cells:
   • To replace existing cells with the cells you are pasting, select a set of existing cells with the same layout as the cells you copied.
     For example, if you’ve cut or copied a three-by-two block of cells, select another three-by-two block in which to paste the cut or copied content.
   • To paste a full row of cells above a particular cell, click in that cell.
   • To paste a full column of cells to the left of a particular cell, click in that cell.
   • To create a table with the pasted cells, place the insertion point outside the table.

**Note:** If you have less than a full row or column of cells in the Clipboard, and you click in a cell and then paste the cells from the Clipboard, the cell you clicked in and its neighbors (depending on its location in the table) might be replaced with the cells you are pasting.

3 Do one of the following:
   • Select Edit > Paste.
   • Right-click (Windows) or Control-click (Macintosh), and then select Paste.
Contribute pastes the cells from the Clipboard.

**Adding, deleting, and merging table rows and columns**

You can modify an existing table by adding or deleting rows or columns. You can also merge cells to accommodate data.

**Adding rows and columns**

You can add a single row or column, or you can add multiple rows or columns at the same time.

**To add a single row to a table:**

1 In your draft, place the insertion point in a table cell, or select an entire row.
2 Do one of the following:
   • Click the Insert Row Below button in the toolbar.
A new row appears below the insertion point or selection.
- Select Table > Insert > Row Above or Table > Insert > Row Below.
- Right-click (Windows) or Control-click (Macintosh), and then select Insert Row Above or Insert Row Below.

**To add a single column to a table:**
1. In your draft, place the insertion point in a table cell, or select an entire column.
2. Do one of the following:
   - Click the Insert Column to the Right button in the toolbar.
   A new column appears to the right of the insertion point or selection.
- Select Table > Insert > Column to the Left or Table > Insert > Column to the Right.
- Right-click (Windows) or Control-click (Macintosh), and then select Insert Column to the Left or Insert Column to the Right.

**To add multiple rows or columns to a table:**
1. In your draft, place the insertion point in a table cell.
2. Do one of the following:
   - Select Table > Insert > Multiple Rows or Columns.
   - Right-click (Windows) or Control-click (Macintosh), and then select Insert Multiple Rows or Columns.

The Insert Rows or Columns dialog box appears.

3. Complete the dialog box.
   For information about options in the dialog box, click the Help button.
4. Click OK.
Contribute adds the rows or columns to your table.

**Deleting rows and columns**
You can delete a single row or column, or you can delete multiple rows or columns at the same time.

**To delete rows or columns from a table in your draft, do one of the following:**
- Select entire rows or columns, and then press Delete or Backspace.
- Select entire rows or columns or place the insertion point in a single row or column, right-click (Windows) or Control-click (Macintosh), and then select Delete Row or Delete Column.
• Select entire rows or columns, and then select Table > Delete > Row or Table > Delete > Column.

Merging and splitting cells
You can merge any number of adjacent cells—as long as the entire selection is a line or a rectangle of cells—to produce a single cell that spans several columns or rows. You can split a cell into any number of rows or columns, regardless of whether it was previously merged.

To merge table cells:
1. In your draft, select the cells you want to merge.
   
   **Note:** You must select at least two cells.

2. Do one of the following:
   • Select Table > Merge Cells.
   • Right-click (Windows) or Control-click (Macintosh), and then select Merge Cells.

Contribute merges the content into a single cell.

To split table cells:
1. In your draft, place the insertion point in the cell you want to split.
   
   **Note:** Contribute only splits one cell at a time, even if you select multiple cells.

2. Do one of the following:
   • Select Table > Split Cell.
   • Right-click (Windows) or Control-click (Macintosh), and then select Split Cell.

The Split Cell dialog box appears.

3. Select a radio button to indicate whether to split the cell into rows or columns, and then enter the number of new rows or columns in which to divide the cell.

4. Click OK.

Contribute splits the cell into multiple rows or columns.

Modifying table appearance
You can modify a table’s appearance by doing any of the following:

• Changing properties for an entire table (see “Modifying table properties” on page 128)
• Changing properties for individual cells, rows, or columns in a table (see "Modifying row or column properties" on page 128 and "Modifying cell properties" on page 129)

• Applying a preset design scheme to a table (see “Using a preset table format” on page 130)

Note: Before you change properties, it’s a good idea to understand how Contribute resolves formatting conflicts for cells, rows, and tables (see “About conflicts in table formatting” on page 119).

Modifying table properties
You can modify the alignment, width, border width and color, and background color of a selected table.

To modify table properties:
1 In your draft, select the table you want to modify (see “Selecting table elements” on page 121).
2 Do one of the following to open the Table Properties dialog box:
   • Click the Table button in the toolbar.
   • Right-click (Windows) or Control-click (Macintosh), and then select Table Properties from the pop-up menu.
   • Select Table > Table Properties.

The Table Properties dialog box appears.

3 Change table properties as necessary.
   For information about options in the dialog box, click the Help button.
4 Click Apply to apply changes without closing the dialog box, or click OK to apply changes and close the dialog box.
   Your table property changes appear in your draft.

Modifying row or column properties
You can modify horizontal and vertical alignment, background color, height or width, and text wrap for a selected row or column.

Note: To understand how Contribute resolves formatting conflicts for cells, rows, and tables, see “About conflicts in table formatting” on page 119.
To modify table row or column properties:
1 In your draft, select the row or column you want to modify (see "Selecting an entire table, row, or column" on page 121).
2 Do one of the following to open the Table Properties dialog box:
   • Click the Table button in the toolbar.
   • Right-click (Windows) or Control-click (Macintosh), and then select Table Cell Properties from the pop-up menu.
   • Select Table > Table Cell Properties.
   The Table Properties dialog box appears with the appropriate tab selected.
3 Change the row or column properties as desired.
   For information about options in the dialog box, click the Help button.
4 Click Apply to preview your changes, or click OK to apply changes and close the dialog box.

Modifying cell properties
You can modify horizontal and vertical alignment, background color, and text wrap for a selected cell.
Note: To understand how Contribute resolves formatting conflicts for cells, rows, and tables, see "About conflicts in table formatting" on page 119.

To modify table cell properties:
1 In your draft, select the cell or cells you want to modify (see “Selecting an entire table, row, or column” on page 121).
2 Do one of the following to open the Table Properties dialog box:
   • Right-click (Windows) or Control-click (Macintosh), and then select Table Cell Properties from the pop-up menu.
   • Select Table > Table Cell Properties.
   • Click the Table button in the toolbar.
Note: If you placed the insertion point in the cell instead of selecting the cell, this option opens the Insert Table dialog box instead of the Table Properties dialog box for cells.

The Table Properties dialog box appears with the appropriate tab selected.

3 Change the cell properties as desired.
For information about options in the dialog box, click the Help button.

4 Click Apply to preview your changes, or click OK to apply changes and close the Table Properties dialog box.

Using a preset table format
You can apply a preset design to a table and select options to further customize the design.

Note: You can apply preset table designs to a simple rectangular grid of cells only. You can't use these designs to format tables that contain merged cells or other unusual formatting.

To use a preset table design:
1 In your draft, select a table to modify or place the insertion point in any cell in the table.
2 Select Table > Format Table.
The Format Table dialog box appears with the Basic tab selected.

3 Complete the dialog box.

For information about options in the dialog box, click the Help button.

4 Click OK.

Contribute formats your table with the design you selected.

**Sorting tabular data**

You can sort the rows of a table based on the contents of a single column. For example, if you have a Names column in a table, you can sort items in that column alphabetically.

You can also perform a more complicated table sort based on the contents of two columns.

*Note: You cannot sort on a column that contains merged cells.*

**To sort a table:**

1 In your draft, select the table to sort or place the insertion point in any cell in the table.

2 Select Table > Sort Table.
The Sort Table dialog box appears.

3 Complete the dialog box.

For information about options in the dialog box, click the Help button.

4 Click OK.

Contribute reorders the table.
Chapter 9: Working with Links

A hypertext link, often called a link, creates a connection from one page to another page. On a web page, links are typically underlined and differentiated by color from the surrounding text. When a visitor to your website clicks a link in one page, another page opens.

Visitors use links to navigate your website. When you add a new page to a website, you have to add a link to the new page on an existing page. Then, users can click the link in the existing page to view the new page.

When you add a link to a web page or blog entry draft, the link is not live until you publish the page (see “Publishing Your Web Pages and Blog Entries” on page 157). Before you publish a web page or blog entry with a link, use the Preview in Browser feature to test the link and make sure it works.

This chapter contains the following sections:

• “Creating text and image links” on page 133
• “Setting the advanced linking options” on page 142
• “Editing links” on page 147
• “Testing links” on page 148

Creating text and image links

With Adobe® Contribute® CS3, you can make text or images in your web page or blog act as links. When a visitor to your website clicks a link on a specified text or an image, the browser takes the visitor to another web page or file, or starts their e-mail application; if the link is in a blog, Contribute takes the visitor to another blog entry.

Your text or image can link to any of the following:

• A current draft or a recently published page on your website
• A new web page, which Contribute creates at the same time as the link
• A new blog entry, which Contribute creates at the same time as the link
• An existing web page on your website or on another website
• An e-mail address
• An existing file on your computer, such as a Microsoft Word or PDF file

Note: To link to items in your Adobe® Acrobat® Connect 5.5 and 6 account, see “Linking to Adobe® Acrobat® Connect™ content, training, and meetings” on page 140.

Linking to a draft or a recently published page on your website

You can create a link on your page to a draft that you are currently editing or to a recently published page on your website. Contribute has a complete list of current drafts for you to link to, and stores a list of the last ten pages you published on your website.

For information about linking to a page that is not a current draft or was not recently published, see “Linking to a page on your website or on another website” on page 137.
To create a link to a draft or recently published page on your website:

1. In your draft, do one of the following to indicate where the link will appear:
   - Place the insertion point in the draft.
   - Select text in the draft.
   - Select an image in the draft.

2. Do one of the following to open the Insert Link dialog box:
   - Click the Link button in the toolbar, and then select Drafts and Recent Pages.
   - Select Insert > Link > Drafts and Recent Pages.
   - Right-click (Windows) or Control-click (Macintosh), and then select Insert Link.

The Insert Link dialog box appears.

3. Click Drafts and Recent Pages (Windows) or Drafts (Macintosh) at the top of the dialog box, if it’s not already selected.

4. Complete the dialog box.
   For information about options in the dialog box, click the Help button.

5. Click OK.

The link appears in your draft.

Linking to a new page

You can create a link to a new web page on your website—that is, you can create a link to a new page that Contribute creates at the same time that it creates the link.

Note: The new page appears on your website when you publish the draft with the link.

For example, suppose you are working on a page listing your products and need to create a link to a product page that doesn’t exist yet. Contribute lets you create the new page and link to it before you add content to the page.
The preferred way to add a new page to your website is to create a link and the new page at the same time, and then add content later. (The other way to add a new page to your website is to create the page first, and then link it later. For more information, see “Creating or copying a page on your website” on page 58.)

It's a good idea to create a link to a new page at the same time you create the new page. This way, you don't have to remember to link to the page later, and you ensure that users can navigate to the page on your website.

To create a link to a new page:
1 In your draft, do one of the following to indicate where the link will appear:
   • Place the insertion point in the draft.
   • Select text in the draft.
   • Select an image in the draft.
2 Do one of the following to open the Insert Link dialog box:
   • Click the Link button in the toolbar, and then select Create New Page.
   • Select Insert > Link > Create New Page.
   • Right-click (Windows) or Control-click (Macintosh), and then select Insert Link.

The Insert Link dialog box appears.

3 Click the Create New Page button (Windows) or New Page button (Macintosh) at the top of the dialog box, if it is not already selected.

The bottom half of the dialog box changes.

4 Complete the dialog box.

For information about options in the dialog box, click the Help button.

5 Click OK.
Contribute adds the link to the draft, and then opens the new page in the Contribute editor. To return to the draft where you added the link, click the draft title in the Pages panel.

**Note:** Contribute automatically saves the new page in the same folder as the draft that links to it (unless you selected another website). When you publish your draft, Contribute also publishes the new page. You can change the folder location for the new page then, if you need to.

### Linking to a new blank blog entry

You can create a link to a new blank blog entry on your blog—that is, you can create a link to a new blog entry that Contribute creates at the same time that it creates the link.

**Note:** The new blank blog entry appears on your blog when you publish the blog entry draft (the blog entry where you want to insert the link) with the link.

#### To create a link to a new blank blog entry:

1. In your blog entry draft, do one of the following to indicate the link location:
   - Place the insertion point in the draft.
   - Select text in the draft.
   - Select an image in the draft.

   **Note:** Some blogs do not allow images, enclosures, media files, and links to local files in the content. Verify if your blog makes this exception.

2. Do one of the following to open the Insert Link dialog box:
   - Click the Link button in the toolbar, and select Create New Entry.
   - Select Insert > Link > Create New Entry.
   - Right-click (Windows) or Control-click (Macintosh), and select Insert Link.

The Insert Link dialog box appears.
3 Click the Create New Entry button (Windows) or New Entry button (Macintosh) at the top of the dialog box, if it is not already selected.
The bottom half of the dialog box changes.
4 Complete the dialog box.

For information about options in the dialog box, click the Help button.
5 Click OK.

Note: Contribute automatically saves the new blog entry in the same folder as the draft that links to it. When you publish your draft (the blog entry where you inserted the link), Contribute also publishes the new blog entry. For more information on publishing blog entries, see “Publishing a blog entry to your blog” on page 175.

Linking to a page on your website or on another website
You can create a link to another page on your website or on another website. If the page you’re linking to is not linked to any other pages—so you can’t browse to it—Contribute lets you use the file system to find the page.

Note: If the page you want to link to was recently published or is a draft, see “Linking to a draft or a recently published page on your website” on page 133.

To create a link to a page on your website or on another website:
1 In your draft, do one of the following to indicate where the link will appear:
   • Place the insertion point in the draft.
   • Select text in the draft.
   • Select an image in the draft.
2 Do one of the following to open the Insert Link dialog box:
   • Click the Link button in the toolbar, and then select Browse to Web Page.
   • Select Insert > Link > Browse to Web Page.
   • Right-click (Windows) or Control-click (Macintosh), and then select Insert Link.
The Insert Link dialog box appears.

3 Click the Browse to Web Page button (Windows) or Browse button (Macintosh) at the top of the dialog box, if it is not already selected.

4 Complete the dialog box.

For information about options in the dialog box, click the Help button.

5 Click OK.

Contribute adds the link to your draft.

**Linking to an e-mail address**

You can create a link to an e-mail address. When a website visitor clicks the link, Contribute creates a new message, with the e-mail address you specified, in the visitor's default e-mail application.

For example, you might create the text link “Contact us about our new products!” When a visitor clicks the link, Contribute starts the visitor's e-mail application and creates an e-mail message to the Sales department.

**To create a link to an e-mail address:**

1 In your draft, do one of the following to indicate where the link will appear:
   - Place the insertion point in the draft.
   - Select text in the draft.
   - Select an image in the draft.

2 Do one of the following to open the Link dialog box:
   - Click the Link button in the toolbar, and then select E-mail Address.
   - Select Insert > Link > E-mail Address.
• Right-click (Windows) or Control-click (Macintosh), and then select Insert Link.

The Insert Link dialog box appears.

3 Click the E-mail Address button (Windows) or E-mail button (Macintosh) at the top of the dialog box, if it is not already selected.

4 Complete the dialog box.

For information about options in the dialog box, click the Help button.

5 Click OK.

Contribute adds the link to the page.

**Linking to a file on your computer**

To add content to your website that you saved on your computer, create a link on a page on your website to a file saved on your computer or network.

For example, you might link to a Word document saved on your hard drive or an HTML page saved on your desktop. This essentially adds a new page to your website, with the content contained in the file.

When you publish the page with the link, Contribute copies the file into your website and then links to that copy—not to the actual file on your computer—to create the new page on your website.

💡 If you want to replace an existing page on your website, with the contents of a file saved on you computer, see "Replacing a file on your website" on page 164.

You can use the Insert Link dialog box to insert a link to a file on your computer, or you can drag the file to your page (see “Inserting a link to a Microsoft Word or Excel document from Microsoft Office (Windows only)” on page 78).

**Note:** If the file you want to link to is already saved on your web server—and not your computer—see "Linking to a page on your website or on another website" on page 137.
To create a link to a file on your computer using the Insert Link dialog box:

1. In your draft, do one of the following to indicate where you want the link to appear:
   - Place the insertion point in the draft.
   - Select text in the draft.
   - Select an image in the draft.

2. Do one of the following to open the Insert Link dialog box:
   - Click the Link button in the toolbar, and then select File on My Computer.
   - Select Insert > Link > File on My Computer.
   - Right-click (Windows) or Control-click (Macintosh), and then select Insert Link.
   The Insert Link dialog box appears.

3. Click the File on My Computer button (Windows) or File button (Macintosh) at the top of the dialog box, if it is not already selected.

4. Complete the dialog box.
   For information about options in the dialog box, click the Help button.

5. Click OK.
   Contribute copies the file to create a page on your website. A link to the new page appears in your draft.

   Note: To edit content to the linked page after you publish, see “Editing web page content in an external application” on page 52. Changes you make to the original file do not appear on your website.

Linking to Adobe® Acrobat® Connect™ content, training, and meetings

If you are a Acrobat Connect customer, you can link to Acrobat Connect content, training, and meetings on a web page.
Acrobat Connect is a communication program with the following components: Acrobat Connect Live, Acrobat Connect Presentation, Acrobat Connect Training, and Acrobat Connect Manager—a web application that is your access and control point for the other three components.

In Acrobat Connect Manager, content (which includes any files used in training, meetings, and so on), training, and meetings are organized in folders called libraries. Contribute provides an easy way for you to access and link to items in your Acrobat Connect Manager libraries.

**Note:** The content, training, and meetings that you can access depend on your Acrobat Connect configuration and your permissions.

**To link to Acrobat Connect content, training, and meetings:**

1. In your draft, place the insertion point where you want the link to appear.

   The link text Contribute inserts is the title of the content you link to. For example, if you link to a meeting named My Meeting, the link text in your draft is My Meeting. You can change the link text after you insert the link.

   **Note:** If you select text in your draft instead of placing the insertion point, Contribute changes that text to match the name of the content you link to. If you select an image in your draft, Contribute places the link text next to the image.

2. Select Insert > Acrobat Connect Link.

   The Adobe Acrobat Connect Login dialog box appears if this is the first time you're inserting an Acrobat Connect link after you start Contribute.

3. If the Acrobat Connect Login dialog box appears, enter your Acrobat Connect server URL and user information, and then click OK.

   The Select Acrobat Connect Account dialog box appears if you have multiple Acrobat Connect accounts.

4. If the Select Acrobat Connect Account dialog box appears, select an Acrobat Connect account, and then click OK.
The Insert Acrobat Connect Link dialog box appears. This dialog box displays folders that contain the Acrobat Connect library items for the Acrobat Connect account you're connected to.

5 (Optional) To access another Acrobat Connect account, click the Settings button; enter information in the Acrobat Connect Login dialog box, and then click OK.

6 Find and select the item you want to link to, and then click OK.
Contribute inserts a link to the item you selected.

To change link text to Acrobat Connect content:
❖ In your draft, select the link text, and then type over it.

Setting the advanced linking options

The Insert Link dialog box has three advanced linking options: editing the link's URL, setting a target, and linking to a specific place on a page.

Editing the URL for a link
If you are familiar with creating links in HTML, you can use Contribute to edit a link's URL.

When you link to a web page on a website, the link's URL appears in the Web Address (URL) text box and in the HREF text box in the Advanced section of the Insert Link dialog box. Use this HREF text box to alter the URL that Contribute places in the page's HTML.

Note: If the page is new, you'll see (new) appended to the end of the URL. Contribute removes (new) when you publish the new page.

The Web Address (URL) text box always shows the full URL, and the HREF text box shows the URL that's written in the page's HTML. The HREF might be a different, usually shorter, version of the URL.
To edit a link’s URL:
1 In your draft, select an existing link.

Note: To insert a link, see “Creating text and image links” on page 133.

2 Do one of the following to open the Insert Link dialog box:
   • Select Format > Link Properties.
   • Right-click (Windows) or Control-click (Macintosh), and then select Link Properties.
   The Insert Link dialog box appears.

3 Click the Advanced button (Windows) or the expander arrow (Macintosh) to expand the dialog box, if it is not already expanded.

4 Change the web address (URL) in the HREF text box.
   Note: You might notice that text in the Link text box changes as you enter text in this text box. It is the text in the HREF text box that Contribute places in the page’s HTML for the URL.

5 Click OK.

Setting a target for your page
You can specify where a linked page opens by creating a target for the link. For example, you can have your linked document open in a new window instead of the current window.

If you create a link in a document with frames, you can indicate which frame, or target, displays the new content. For more information about creating targets for frames, see “Targeting frame content” on page 154.

Note: You cannot control where an e-mail link opens. When an e-mail link is clicked, the default e-mail application automatically starts.

You can specify the target when you create the link (see “Setting a target for a new link” on page 143), or you can edit an existing link to change or add the target (see “Setting a target for an existing link” on page 144).

Setting a target for a new link
You can specify the target for a link when you create the link.

To create a link with a target:
1 In your draft, create a link (see “Creating text and image links” on page 133).

2 In the Insert Link dialog box, click the Advanced button (Windows) or the expander arrow (Macintosh) to expand the dialog box, if it is not already expanded.

3 Select a target from the pop-up menu:
   Default opens the linked document in the current window. If the page contains frames, the linked page opens in the frame that contains the link.
Entire window opens the linked document in the current window. If the page contains frames, the linked page fills the entire window, not just the frame that contains the link.

New window opens the linked document in a new browser window, instead of the current window.

4 Click OK.

Contribute adds the link to your draft.

Setting a target for an existing link
You can edit an existing link to change or add the target.

To specify a target for an existing link:
1 In your draft, select an existing link.
2 Do one of the following to open the Insert Link dialog box:
   • Select Format > Link Properties.
   • Right-click (Windows) or Control-click (Macintosh), and then select Link Properties.

The Insert Link dialog box appears.
3 Click the Advanced button (Windows) or the expander arrow (Macintosh) to expand the dialog box, if it is not already expanded.
4 Select a target from the pop-up menu:
   Default opens the linked document in the current window. If the page contains frames, the linked page opens in the frame that contains the link.
   Entire window opens the linked document in the current window. If the page contains frames, the linked page fills the entire window, not just the frame that contains the link.
   New window opens the linked document in a new browser window, instead of the current window.

Note: If the page you’re linking from was in a frame, a list of frame names appears here. If you choose a frame or type a frame name, the linked page appears in that frame when the website visitor clicks the link.

5 Click OK.

Contribute modifies the existing link with the target information.

Linking to a specific place in a page
You can place an invisible marker, called a section anchor, on your page to mark a specific topic or place. You can then create links to the anchor, which take website visitors to the specified position on the page with the anchor.

For example, you might add an anchor to the company address and phone number on the Company Information page. Then you might add a link with the text “Contact Us!” to your home page. When a website visitor clicks this link, the Company Information page opens to the address and phone number section. This way, the user does not need to search the Company Information page to find the contact information.
Adding a section anchor
You can add a section anchor to a page, and then link to that anchor from the same page or from another page. For more information about section anchors, see “Linking to a specific place in a page” on page 144.

To add an anchor to a page:
1 In your draft, place the insertion point at the beginning of the section where you want the page to open when a website visitor clicks the link.
2 Select Insert > Section Anchor.
The Section Anchor dialog box appears.

3 Enter a name for your anchor.
The name cannot begin with a number and cannot contain any spaces. You cannot have two anchors with the same name on a web page.
4 Click OK.
Contribute inserts an anchor marker in your draft. [image]

Note: If you have invisible elements turned off, Contribute turns invisible elements on so that you can see the anchor marker. To turn invisible elements off again, select Edit > Preferences and then select Invisible Elements.

Linking to a section anchor
You can link to a section anchor when you create the link, or you can edit an existing link to indicate or change a section anchor. For more information on section anchors, see “Linking to a specific place in a page” on page 144.

To link to a section anchor:
1 In your draft, create a link (see “Creating text and image links” on page 133).
2 In the Insert Link dialog box, click the Advanced button (Windows) or the expander arrow (Macintosh) to expand the dialog box, if it is not already expanded.
3 Select a named anchor from the Section anchor pop-up menu.

Note: All anchors in the page you are linking to appear in the list.
4 Click OK.
Contribute adds the link to your draft.

To indicate an anchor for an existing link:
1 In your draft, select an existing link.
2 Do one of the following to open the Insert Link dialog box:
   • Select Format > Link Properties.
   • Right-click (Windows) or Control-click (Macintosh), and then select Link Properties.
The Insert Link dialog box appears.

3 Click the Advanced button (Windows) or the expander arrow (Macintosh) to expand the dialog box, if it is not already expanded.

4 Select a named anchor from the Section anchor pop-up menu, or type an anchor name.

All anchors in the page you are linking to appear in the list.

5 Click OK.

Contribute modifies the existing link.

**Editing section anchors**

After you create a section anchor, you can change its name or delete it.

*Note:* If you edit a section anchor, links to that anchor will be broken until you fix the link on the page that links to the section anchor.

**To edit a section anchor name:**

1 In your draft, select the anchor, and then do one of the following:
   - Double-click the section anchor.
   - Right-click (Windows) or Control-click (Macintosh), and then select Anchor Properties from the pop-up menu.
   - Select Format > Anchor Properties.
The Edit Section Anchor dialog box appears.

2 Change the anchor name.
   The name cannot begin with a number and cannot contain any spaces. You cannot have two anchors with the same name on a web page.
3 Click OK.

To delete a section anchor:
• In your draft, select the section anchor, and then press Delete.

Editing links

You can change the text or destination of a link, remove it, or change its properties.

Changing link text and destination
After you insert a link, you can later change link text or change the page that the link opens.

To change link text:
1 In your draft, select the link text you want to change.
2 Type new text.

To change link destination:
1 In your draft, select an existing link.
2 Do one of the following to open the Insert Link dialog box:
   • Select Format > Link Properties.
   • Right-click (Windows) or Control-click (Macintosh), and then select Link Properties.
3 If you want to change the type of page you link to, click a button at the top of the dialog box; otherwise, skip this step.
4 Select or browse to a new page.
5 Click OK.

Removing a link
After you insert a link, you can easily remove the link from your text or image.
To remove a link:
1 In your draft, select the link you want to remove.
2 Do one of the following:
   • Select Format > Remove Link.
   • Right-click (Windows) or Control-click (Macintosh), and then select Remove Link from the pop-up menu.

The link text or image in the draft is no longer a link.

Changing link properties
You can change link properties, including link text and destination and advanced link settings.

To change link properties:
1 In your draft, select an existing link.
2 Do one of the following to open the Insert Link dialog box:
   • Select Format > Link Properties.
   • Right-click (Windows) or Control-click (Macintosh), and then select Link Properties.

The Insert Link dialog box appears.
3 Change any of the following link properties:
   • Link text
     You can also change link text by selecting the text in your draft and typing over it.
   • Linked file, web page, or e-mail
   • Web address
     For more information about the web address, see “Editing the URL for a link” on page 142.
   • Anchor
     For more information about anchors, see “Linking to a specific place in a page” on page 144.
   • Target
     For more information about setting a target, see “Setting a target for your page” on page 143.
4 Click OK.

Testing links

Contribute lets you preview a temporary copy of a web page on a web browser, or a blog entry draft on a blog server so that you can test links.

Note: If you belong to a user role that cannot publish, you cannot use the Preview in Browser feature to test links.

To test a link:
1 In your draft, select File > Preview in Browser.
Your page appears in your default web browser.

2 Click the links to make sure they open the correct pages (or start your e-mail application).

3 Close the browser preview to return to the draft you’re editing.
Chapter 10: Working with Pages with Frames

Framesets divide a browser window into multiple frames or regions, each of which can display different content. You design pages with frames in an HTML design application, such as Adobe Dreamweaver. You can edit pages with frames in Adobe® Contribute® CS3.

Note: For more information about creating pages with frames in Dreamweaver, see Dreamweaver Help (Help > Using Dreamweaver).

This chapter contains the following sections:

• “About frames” on page 151
• “Editing frame content” on page 153
• “Saving and publishing a page with frames” on page 154
• “Targeting frame content” on page 154

About frames

A web page designed with frames displays different content in different regions of a web browser. This design is typically used to display content that doesn’t change, such as a navigation bar, in one area and content that changes in the main content area.

For example, a web page might have one narrow frame on the left side that contains navigation links, one frame along the top that contains the logo and title of the website, and one large frame that takes up the rest of the page and displays the main content.
Understanding frames and framesets

A page that contains frames is called a frameset. A frameset is an individual file that defines the layout and properties of all the frames on a page, including the number of frames, the size and placement of the frames, and the web address (URL) of the page that initially appears in each frame.

A frame is an organizational element of a frameset page. It’s easy to think of the page that’s currently displayed in a frame as an integral part of the frame, but each frame is just a container for a page. Pages that initially load in the frames are referenced by the frameset, but any page can be loaded in a frame.

The content that appears in each frame is saved in separate files. A page with three frames—navigation, logo, and main content—actually has four files: the frameset and three web pages, one for each frame. When a website visitor clicks a link in one frame, a new page can be loaded in another frame. There can be a different page for each link in a frame.

A frame can load pages from the same or different websites. So you might be able to edit content in some, but not all, frames.

About targeting a frame

To use a link in one frame to open a new page in another frame, you must set a target for the link. Selecting a frame in which to open a page is called targeting a frame.

Each link in a frameset should have a target—a frame in which to open the page when the user clicks the link. For example, the main frame might be the target for multiple links, so that the content of the main frame changes each time the user clicks a link in the navigation frame.

Note: If you don’t specify a target for a link, Contribute uses the Default option and opens the new page in the frame that contains the link.
When you add a link to a page in a frameset, you can indicate a target frame for the page you're linking to. The frameset designer should have given each frame a name so that you can select specific frames as targets. You can also change the target after you've inserted the link by editing the link properties (see “Editing links” on page 147).

Editing frame content

When you browse to a page with frames, you can use Contribute to change content in any of the frames, as long as you have permission.

For more information about frames and framesets, see “About frames” on page 151.

To edit content in a frame:

1. Browse to the page with frames to edit, and then click the Edit Page button.

The Select a Frame to Edit dialog box appears, with a list of page titles and web addresses (URLs) for the frame pages.

2. Select the frame you want to edit.

When you select a frame, a border appears around that frame in the Contribute editor.

A. Selected frame in the dialog box  B. Selection indicator in the editor

Note: A lock icon appears beside the page name if you can't edit it. The lock means that you do not have permission to edit that frame's content or that another user is currently editing the page.

3. Click Edit.

A draft for the frame you selected appears in the Contribute editor without the other frames.

4. Edit the content as you normally would.

5. When you are ready to publish, see “Saving and publishing a page with frames” on page 154.
Saving and publishing a page with frames

A frameset is made up of individual web pages. When you edit a page that appears in a frame, you alter only the page you edit—not the frameset. Publishing a page that appears in a frameset is the same as publishing a page that isn't in a frameset. Because you do not actually alter the frameset page, you do not need to publish it.

After you finish editing a frame page (see “Editing frame content” on page 153), you have the following options before you publish the page:

- Click Cancel in the toolbar (see “Discarding a draft, new page, or new blog entry” on page 54).
- Select File > Preview in Browser (see “Previewing a page in your default browser” on page 158).
- Click Send for Review in the toolbar (see “Getting web page drafts and files reviewed by others” on page 41).

To publish a page that appears in a frame:

- In your draft, click Publish (see “Publishing a page to your website” on page 158).

Note: Depending on the role the Contribute administrator assigned you, you might not be able to publish.

Contribute displays the frameset with the updated page loaded in the correct frame.

Note: If you publish changes to a frameset that is nested (a frameset in a frameset), the child nested frameset that you changed appears in Contribute. If there are multiple nested framesets, only the first frameset containing the edited page appears.

Targeting frame content

You can change the content that appears in a frame by creating links in one frame that open pages in another frame.

For more information, see “About targeting a frame” on page 152.

To insert a link and select a target frame for the linked page:

1. Browse to the page with frames to edit, and then click the Edit Page button.
   
   The Select a Frame to Edit dialog box appears.

2. Select the frame in which you want to add a link that opens a new page in another frame, and then click Edit.
   
   A draft for the frame you selected appears in the Contribute editor.

3. Place the insertion point in your draft where you want the link to appear or select text or an image.

4. Do one of the following:
   
   - Select Insert > Link, and then select a type of page from the pop-up menu.
   
   - Click Link in the toolbar, and then select a type of page from the pop-up menu.

   The Insert Link dialog box appears.
5. Complete the dialog box. The options in the dialog box vary according to the type of page you are linking to. For information about options in the dialog box, click the Help button.

6. In the Insert Link dialog box, click the Advanced button to expand the dialog box, if it is not already expanded.

7. In the Target frame pop-up menu, select the frame where you want the linked page to open. You can either enter a custom-named frame in the Target frame text box (which opens the page in that frame) or select one of the following frame targets:
   - **Default**: opens the page in the same frame as the current page.
   - **Entire Window**: replaces the frameset with the page.
   - **New Window**: opens the page in a new browser window.

8. Click OK.

The link appears in your draft.

**Note**: If you created a link to a new page, the new page draft appears and you need to return to the draft where you added the link.

9. Click Publish.

The frame page appears, with updated content in the frame you edited.
Chapter 11: Publishing Your Web Pages and Blog Entries

Publishing a draft makes it live on your website or blog, so your visitors can view the page.

Before you publish your draft, you can preview it in your browser. You can also make the draft available to others for review, to get approval or feedback, before you publish the draft (see “Getting web page drafts and files reviewed by others” on page 41). If you decide not to publish your draft, you can cancel it, leaving the published version of the page as is.

If the draft you’re publishing was already on your website, Adobe Contribute CS3 replaces the existing page with your updated version. You can also make updates to an existing page, and then publish it as a new page without altering the original page.

If the draft you’re publishing is a new page that was not on your website or blog, Contribute adds it to your website or blog. For new pages, Contribute asks you to name the file for the page before you publish.

After you publish a draft, if you realize that you need to unpublish it, don’t worry—you can undo publishing by reverting to a previous version of the page if your Contribute administrator has enabled the Page Rollback feature.

You can publish your Microsoft Office documents to your websites that you are connected to, without opening Contribute. The Contribute plug-ins in Word, Excel, and Outlook email reader let you easily publish your Word documents, Excel spreadsheets, and e-mail messages to your website. You can publish a document to a web page in the document’s default format (as a .doc/.docx file in Word or a .xls/.xlsx/.xlsm file in Excel), in the .htm format, or as a PDF. Microsoft Outlook documents can be published only as .htm files.

With Contribute, you can easily post content to your blogs directly from Microsoft Office applications and browsers such as Internet Explorer and Mozilla Firefox. You can also post content such as news items to your blog from RSS aggregators. You can post any web page or a document to your blog and modify the contents before you publish it.

You can also Contribute to publish blank blog entries to your blog. Additionally, you can publish blog entries that have links to new blank blog entries and publish all of the blog entries at once.

This chapter contains the following sections:

- “About the Rollback feature for web pages” on page 158
- “Previewing a page in your default browser” on page 158
- “Publishing a page to your website” on page 158
- “Publishing a file from your computer to your website” on page 162
- “Replacing a file on your website” on page 164
- “Rolling back to a previous version of a page” on page 166
- “Publishing a document from Microsoft Office to your website (Windows only)” on page 167
- “Posting content to a blog” on page 169
- “Posting content to a blog from RSS aggregators” on page 172
- “Publishing a blog entry to your blog” on page 175
About the Rollback feature for web pages

You can use the Rollback feature to revert to a previous version of any published page. You do not have to roll back to the last published version; you can select any version that Contribute has saved as a rollback file.

When you roll back to a previous version of a page, Contribute reverts to the previous text contained in the version of the page you select. However, any assets imported into the page may or may not be recovered. For example, suppose you update an image file outside of Contribute and then replace the original image with another image using the same filename. In this case, Contribute cannot roll back to the previous version of the image because Contribute does not manage assets outside the web pages it creates.

Contribute does, however, maintain the older version of an image if you use Contribute to edit the image in an external application. Contribute considers images, Microsoft Word documents, and other content that you edit in an external application as assets. You can roll back assets that you’ve edited through Contribute the same way that you roll back pages.

For example, suppose you roll back from version C of a page to version A, and you used Contribute to edit an image in version B. When you roll back to version A, you do not see the current version of the image. You need to also roll back the image, independently of the page rollback.

Previewing a page in your default browser

When you edit a draft in Contribute you can easily view your changes in a browser at any time, to ensure that your changes appear as you intend in the browser. Previewing your page also gives you an opportunity to test your links before you publish the page.

💡 You can view the source code for a page when you preview it in the browser.

Note: If the Contribute administrator assigned you to a role that cannot publish, you cannot use the Preview in Browser feature.

To preview a page in your browser, do one of the following:

• Select File > Preview in Browser.
• Press the F12 key.

Publishing a page to your website

After you finish editing and reviewing a draft, you are ready to publish it to your website. When you publish a draft, Contribute makes it live on your website—and, if the page was previously published, Contribute replaces the existing page with the updated page.

Note: Depending on the role the Contribute administrator assigned you, you might not be able to publish.

You can publish any of the following types of pages to your website:

• Updates to an existing page
• New page, not previously published
• Existing page as a new page

**Publishing updates to an existing page**

When you publish updates to an existing page, Contribute replaces the currently published version of the page on your website with the new version.

When Contribute publishes your draft, it also publishes any new pages that your draft links to (but not pages that link to your draft). Contribute prompts you to name any linked pages that haven’t been published before. Publishing all new pages that are linked from the draft helps ensure that you do not have broken links in your website.

**Note:** To replace an existing page on your website with a page that has the same filename, delete the existing page on your website (see “Deleting a web page or blog entry” on page 54) and then publish the replacement page. If you do not have permission to delete pages, contact your Contribute administrator.

**To publish updates to an existing page:**

1. In your draft, click the Publish button in the toolbar.

**Note:** Depending on the role the Contribute administrator assigned you, you might not be able to publish.

If the draft contains links to any new pages, the Publish New Linked Pages dialog box appears.

2. If the Publish New Linked Pages dialog box appears, for each unpublished linked page, you can click the page name to select it, change the filename and folder location, and then click Publish All.

For information about options in the dialog box, click the Help button.

Contribute publishes the draft (and any new pages it links to) to your website, and then displays it in the Contribute browser.

**Publishing a new page to your website**

When you publish a new page to your website, Contribute asks you to name the file for the page and any other new pages the page links to. Then Contribute publishes the new page, and any pages that the new page links to, on your website. Publishing all pages that are linked from the new page helps ensure that you do not have broken links on your website.
If you haven’t added a link on an existing page to your new page, website visitors won’t be able to view the page. Remember to go to an existing web page before (or just after) you publish a new page, and add a link to the new page (see “Linking to a draft or a recently published page on your website” on page 133).

💡 You can create a link to the page at the same time that you create the page. For more information, see “Linking to a new page” on page 134.

**To publish a new page:**

1. In the new page draft you’re editing, click the Publish button in the toolbar.

![Publish](publish.png)

**Note:** Depending on the role the Contribute administrator assigned you, you might not be able to publish.

The Publish New Page dialog box appears.

![Publish New Page](publish_new_page.png)

2. You can change the filename, and then click the Choose Folder button to save this draft in another location on your website.

For information about options in the dialog box, click the Help button.

**Note:** Contribute automatically saves the file with the same name as the page title.

3. Click Publish or Next.

**Note:** Contribute warns you if you have not linked the new page draft from an existing page. After you publish the new page, be sure to create a link to it (see “Linking to a draft or a recently published page on your website” on page 133).
If your new page draft links to any other new pages, the Publish New Linked Pages dialog box appears.

4. If the Publish New Linked Pages dialog box appears, for each unpublished linked page, you can click the page name to select it, change the filename and folder location, and then click Publish All.

For information about options in the dialog box, click the Help button.

Contribute publishes the new page to your website and displays it in the Contribute browser.

**Publishing an existing page as a new page**

Contribute lets you update an existing page and then publish it as a new page without overwriting the original page. This feature is similar to the Save as feature in other applications.

For example, suppose you open the product page for men’s cargo pants and start updating the page with information about women’s cargo pants for your company website. Then you realize that you forgot to make a copy of the existing page before you made edits. As long as you don’t click Publish, the original page is unchanged. Use the Publish as New Page feature to publish the modified page as a new page on your website.

This is possible because when you click Edit Page for an existing page, Contribute creates a copy of the page (known as a draft) for you to edit. Saving changes to the draft does not alter the page on your website.

**To publish an existing page as a new page:**

1. Browse to an existing page, and then click the Edit Page button.
2. Make changes to the draft.

*Note: Depending on the role the Contribute administrator assigned you, you might not be able to publish.*

Contribute warns you if have not linked the new page from an existing page. After you publish the new page, be sure to create a link to it (see “Linking to a draft or a recently published page on your website” on page 133).
The Publish as New Page dialog box appears.

4 You can change the page title and filename for the draft, and then click the Choose Folder button beside the filename to save this draft in another location on your website.

Note: Contribute automatically saves the file with the same name as the page title.

For information about options in the dialog box, click the Help button.

5 Click Publish or Next.

If your new page draft links to any other new pages, the Publish New Linked Pages dialog box appears.

6 If the Publish New Linked Pages box appears, for each unpublished linked page, you can click the page name to select it, change the filename and folder location, and then click Publish All.

For information about options in the dialog box, click the Help button.

Contribute publishes the draft to your website and then displays it in the Contribute browser.

**Publishing a file from your computer to your website**

You can add a document or file (except HTML pages) directly to your website from your computer.
You can also add documents or files, including HTML pages, to your website by linking to them from a draft. For more information, see “Linking to a file on your computer” on page 139.

**Note:** Depending on the role the Contribute administrator assigned you, you might not be able to add files to your website.

To replace an existing page on your website with the contents of a file that’s saved on your computer, see “Replacing a file on your website” on page 164.

To publish a file from your computer to your website:

1. Select File > Publish File from My Computer.

   To have the file reviewed before you publish it, or if you can't publish to the website, select File > Send File from My Computer to send the file for review. For more information, see “Sending a file for review from your computer” on page 43.

   The Select File dialog box appears.

2. Select the file you want to add to the website, and then click Select.

   **Note:** You cannot select HTML, executable, or template files. If you select an invalid file type, Contribute warns that you cannot select this file and provides a complete list of invalid file types.

   If you have connections to more than one website, the Select Website dialog box appears.

3. If the Select Website dialog box appears, select the website where you want to add the file from your computer.

   The website list includes any website you are connected to and have permission to publish to.

   The Publish New Page dialog box appears.

4. You can change the filename, and then click the Choose Folder button to save this draft in another location on your website.

   To replace an existing file on your website with the file you are publishing, change the name of the file to match the name of the existing file and make sure you choose the folder that contains the file you want to replace.

5. Click Publish.
If the draft has the same name as an existing file on your website, the Replace File dialog box appears.

6 If the Replace File dialog box appears, select to either replace the existing file with the one you are trying to publish or leave the existing file on the website and publish the new file with a similar filename, and then click OK.

The file is added to your website. Remember the web address (URL) for the page or go ahead and link the new page from another page, so that you can easily get back to it.

💡 Use Contribute to edit this file after you publish. Changes you make to the original file on your computer after publishing do not appear on your website.

### Replacing a file on your website

You can replace a file on your website with a file on your computer.

For example, suppose you post the quarterly earnings spreadsheet on your website each quarter. You can easily replace the current live version with the new spreadsheet saved on your computer.

There are two ways to replace a file:

- Publish the file directly from your computer.
- Link to the file from a draft.

**To replace an existing file on your website by publishing another file directly from your computer:**

1 Select File > Publish File from My Computer.

The Select File dialog box appears.

2 Select the file you want to add to the website, and then click Select File.

**Note:** You cannot select HTML, executable, or template files. If you select an invalid file type, Contribute warns that you cannot select this file and provides a complete list of invalid file types.

If you have connections to more than one website, the Select Website dialog box appears.

3 If the Select Website dialog box appears, select the website that contains the current version of the file you are replacing, and then click OK.
The Publish New Page dialog box appears.

4 Change the filename, if necessary, to make sure it matches the name of the file you’re replacing; also, make sure you choose the folder that contains the file you want to replace.

5 Click Publish.

The Replace File dialog box appears.

6 Select the Replace file name with your version option, and then click OK.

Contribute replaces the existing file on your website with the file from your computer.

💡 Use Contribute to edit this file after you publish. Changes you make to the original file on your computer after publishing do not appear on your website.

To replace a file on your website by linking to a file on your computer:

1 Browse to the page that contains the link to the file you want to replace, and then click the Edit Page button.

2 In the draft, select the link to the file you’re replacing, and then click the Link button in the toolbar and select File on My Computer.

The Insert Link dialog box appears. The File on My Computer button should be selected at the top of the dialog box.

3 Click the Browse button, and then navigate to and select the file on your computer you want to link to.

Note: You cannot select HTML, executable, or template files. If you select an invalid file type, Contribute warns that you cannot select this file and provides a complete list of invalid file types.

The filename for the new file must exactly match the filename for the file you are replacing. If the names do not match, Contribute does not replace the file.

4 Click OK to close the Insert Link dialog box.

5 In your draft, click the Publish button.
The Replace File dialog box appears.

6 Select the Replace the file option, and then click OK.

Contribute publishes the file from your computer and updates the link in the draft to replace the old file with the new file from your computer.

💡 Use Contribute to edit this file after you publish. Changes you make to the original file on your computer after publishing do not appear on your website.

### Rolling back to a previous version of a page

To provide an extra degree of safety in publishing, Contribute lets you undo any web page you publish and roll back to a previously published version of that web page.

For more information about rollbacks, see “About the Rollback feature for web pages” on page 158.

**Note:** The Rollback feature is only available if your Contribute administrator enabled it. For more information, see your Contribute administrator or see “Enabling and disabling rollbacks” on page 194.

#### To roll back to a previous version of a page or asset:

1. Browse to the page to roll back.
2. Select File > Actions > Roll Back to Previous Version.

The Roll Back Page dialog box appears.

3. Select a previous version of the published page from the list of available pages.

**Note:** The list of previously published pages shows a number of previous versions of the page, depending on your Contribute administrator’s setting.

Contribute displays the page in the Preview section.

4. If the page you selected is the one you want to publish, click the Roll Back button. If the page is not the one you want to publish, select another page from the list, and then click Roll Back.
Contribute replaces the currently published version of the page with the previously published version that you selected. The version you selected becomes the current version on the website.

*Note:* The page you replace with the selected rollback page appears in the Roll Back Page dialog box the next time you open the dialog box so you can roll back to that version if you need to.

**Publishing a document from Microsoft Office to your website (Windows only)**

You can publish documents from Microsoft Word, Excel, and Outlook e-mail reader to your website without opening the Contribute application. You can also associate templates with these documents before publishing them. For example, you can create standard templates using Adobe Dreamweaver, and attach the templates to an MS Office document while opening the document in Contribute, or publishing it to your corporate website using Contribute. Next time you want to change the look and feel of your MS Office documents on the corporate website, you only need to update the document’s associated template. The Contribute plug-ins in these applications make the publishing process fast and efficient.

Templates and editable regions of templates listed in your desktop client are periodically updated with the latest templates and template content available on the server, automatically. In Adobe Contribute CS3 you can also manually synchronize these components using the Refresh option.

**To publish a document from Microsoft Office to your website:**

1. Open a Microsoft Office application file.
2. (Optional) To publish only a specific section of the document, select the section.

   *Note:* You cannot publish a selection in an e-mail message in Microsoft Outlook if the message format is Plain Text.

3. To publish the file, do one of the following:

   * Note: Before you publish, you must save the document if you made any changes.
   - Select Contribute > Publish To Website.
   - Click the Publish To Website button in the toolbar.

   *Note:* You cannot use the Publish to Website option for .rtf files.
The Publish To Website dialog box appears.

4 To select the settings for publishing the document, do the following:

a Select a website where you want to publish the file.

Note: If you do not have a connection to your website before you publish a document, you can always create one by selecting Create New Connection in the Select pop-up menu in the Publish To Website dialog box. For more information on creating a website connection, see "Creating a website connection" on page 183.

b Select a location for storing the file.

c Enter a filename.

Note: The filename must not have any spaces, tabs, or alphanumeric characters.

d Select a format.

e Click the Choose Template button. The Choose Template dialog box appears.

If you do not click the Choose Template button in the Publish to Website dialog box, the template that was last used to publish a Microsoft Office document is associated with the document you are currently publishing. In addition, if the template does not match the template on the server, Contribute displays the Download Template dialog box. You can choose to do one of the following:

• Click the Publish using the old template button to publish the document using the old template.

• Click the Download and Publish button to download the updated template from the server, and then publish the document.

Note: The Choose Template button is disabled when the native format is selected.

f Select a template from the list of available templates.

The Preview of the selected template appears in the Preview box.

g If the template you select for publishing an MS Office document to a website has been updated on the server, the Open as New Page dialog box appears. You can choose to publish using the old template, or download the updated template available on the server, and then publish the document.

h Select a template region from the list of editable regions available in the selected template.

This list is disabled if you select _blank template.
Click the Refresh Templates button, and select one of the following options to update your list of templates and editable regions in a selected template:

- **For this website** to view an updated list of templates for the selected website
- **For selected template** to view an updated list of editable regions in the selected templates

By default, the Make this as the default template check box is selected. Clear this check box, if desired.

Click OK.

(Optional) Clear the Publish current selection only check box to publish the whole document instead of the selection.

Click Publish.

Contribute publishes the document to your website, and a confirmation dialog box appears.

Click OK.

The selected template is applied to the web page containing the MS Office document, and the document is published in the HTML format.

**Note:** If you open or publish a document in Contribute without clicking the Choose Template button in the Publish to Website or Open as New Page dialog box, the last template stored in the registry is applied to the web page containing the MS Office document. If you are performing the Publish to Website or Open in Contribute operation for the first time, then a blank template is selected.

### Posting content to a blog

With Contribute, you can now post content directly to your blog without opening the blog site. You can use the Post To Blog plug-ins to post content to your blog from a browser or from Microsoft Office applications such as Word, Excel, and Outlook e-mail reader. With the Post To Blog plug-in from a web page in your browser or a document in a Microsoft Office application, you can transfer the page contents to the Contribute editor, make changes to the content, and then post the content to your blog.

For more information, see the following topics:

- “Posting content to a blog from a browser” on page 169
- “Posting content to a blog from Microsoft Office applications (Windows only)” on page 170

Additionally, you can also post content such as news items to your blogs from RSS aggregators. For more information, see “Posting content to a blog from RSS aggregators” on page 172.

### Posting content to a blog from a browser

You can use the Contribute plug-ins in your browser to post web pages from a browser such as Internet Explorer and Mozilla Firefox to your blog. You can use the Post To Blog plug-in from a web page in your browser, transfer the page contents to the Contribute editor, make changes to the content, and then post the content to your blog.

**Note:** You must install the browser plug-ins to use this feature. This feature is available only on selected browser versions and operating systems. For a complete list of supported browsers and operating systems, see “Opening a web page or blog entry for editing from your browser” on page 39.
To post content to a blog from a browser:
1. Open or navigate to the page in the browser that has the content you want to publish to your blog.
   - You must have a connection to your blog before you post a page. For more information, see “Creating a blog server connection” on page 184.
2. Select the content in the web page to post.
3. Click Post To Blog in the toolbar.

The selected content in the web page appears in the Contribute editor.
4. Make any necessary changes.
   - Note: Some blogs do not allow images, enclosures, media files, or links to local files in the content. Verify if your blog makes this exception.
5. To post this content to a different blog, select a blog from the Blog pop-up menu in the Contribute editor.
   - You can also set these preferences in the Blog Defaults tab from the Edit menu in Contribute. Select Edit > Preferences > Blog Defaults (if it is not already selected), and select a blog from the Default Blog pop-up menu. For more information on setting these preferences, see “Setting Contribute preferences” on page 28.
6. Click Publish.

Posting content to a blog from Microsoft Office applications (Windows only)
You can post documents from Microsoft Office applications such as Word, Excel, and Outlook e-mail reader to your blog. You can use the Post To Blog plug-in in a document in Word, Excel, or Outlook e-mail reader, transfer the page contents to the Contribute editor, make changes to the content, and then post the content to your blog.

- Note: You can post an e-mail message in Microsoft Outlook to your blog only if the message format is HTML.

You can publish a document to a web page in the document's default format (as a .doc/.docx file in Word or a .xls/.xlsx/.xlsm file in Excel) in the .htm format, or as a PDF. Microsoft Outlook documents can be published only as .htm files.

To post content to a blog from Microsoft Office:
1. Open a file in a Microsoft Word or Excel.
   - You must have a connection to your blog before you post a page. For more information, see “Creating a blog server connection” on page 184.
2. Select the content you want to post to a blog entry in Contribute.
3. To post the selection, do one of the following:
   - Before you post to your blog, save the document if you made any changes.
   - Select Contribute > Post To Blog.
   - Click Post To Blog in the toolbar.
The Insert Microsoft Office Document dialog box appears.

4 Select from the following options:

Note: These options are available for Microsoft Word and Excel only.

- **Insert the contents of the document into this page** to copy the content of the selected document into the draft.
- **Create a link to the office document** to insert a link to the selected document.
- **Convert to PDF and create a link to the PDF** to convert the selected document into a PDF, and insert a link to the PDF document.
- **Convert to PDF and embed the PDF as Object** to convert the selected document into a PDF, and embed the PDF document as an object.

5 (Optional) Select the Remember this setting and don’t ask again check box if you do not want to be asked about the insert option in the future.

You can also set these preferences in the Microsoft Documents tab from the Edit menu in Contribute. To do this, select Edit > Preferences > Microsoft Documents and make a selection. For more information on setting these preferences, see “Setting Contribute preferences” on page 28.

For information about options in the dialog box, click the Help button.

6 Click OK.

The selected content appears in the Contribute draft of your blog entry, or a link to the selected content is inserted in the blog entry draft. If you converted the document to a PDF, Contribute inserts a link to the PDF or embeds the PDF as an object.

7 In the Date area, set the date and time when you want to schedule the publishing of your document. The blog entry will be published only on the specified date and at the specified time and not when you click the Publish button.

Note: The publishing date and time settings are honored by compatible blog servers only.
8 Make any desired changes.

Note: Some blogs do not allow images, enclosures, media files, and links to local files in the content. Verify if your blog makes this exception.

9 Click Publish.

Posting content to a blog from RSS aggregators

With Contribute, you can easily post content such as news items to your blog from RSS aggregators. You can set Contribute as your blog publishing tool in RSS aggregators such as FeedDemon (Windows) and NetNewsWire (Macintosh). You can now post your favorite news clips to your blog and also add your own comments before you post it.

Using Contribute with RSS Aggregators

You can use Contribute in RSS aggregators such as FeedDemon (in Windows) and NetNewsWire (in Macintosh). You can configure Contribute in these RSS aggregators and post your favorite news items with your comments to your blog.
Configuring Contribute in FeedDemon (Windows)

FeedDemon is a desktop RSS aggregator for Windows. You can configure Contribute in FeedDemon and post news entries to your blog. You can transfer the contents of the news entry to Contribute, add your own comments, and post to your blog. For more information on installing FeedDemon, go to http://www.newsgator.com/NGOLProduct.aspx?ProdID=FeedDemon.

Configuring Contribute in FeedDemon may vary with different versions of FeedDemon. The following configuration process applies to FeedDemon version 2.0.

To configure Contribute in FeedDemon:

1. Open the FeedDemon application.
2. Select any news item in the list.
3. Do one of the following:
   - Right-click the news item and select Send Item > Blog this News Item > Configure Blog Publishing Tools.
   - Press Shift+Ctrl+B.

The Blog Publishing Tool dialog box appears.

4. Click Add.

The Program dialog box appears.

5. Enter the following details:
   - Enter Contribute in the Name text box.
• Enter the command in the Command-line or URL text box. To enter the command, browse to the location where the contribute.exe file is located on your hard disk. After you select the file and the path appears in the Command Line text box, click the cursor at the end of the path, enter one space and type -mmPostToBlog.

6 (Optional) Select Set as default to have Contribute be your default blog publishing tool.
7 Click OK.
Contribute now appears in the Blog Publishing Tool dialog box.
8 Click OK.
To verify if Configure is successfully configured in FeedDemon, do the following:
• Select any news item in FeedDemon.
• Right-click the news item.
• Select Send Item > Blog this News Item and check whether Contribute appears in the list.

Posting to a blog from FeedDemon
After you successfully configure Contribute in FeedDemon, you can post news entries to your blog.

To post to a blog from FeedDemon:
1 Open the news item in FeedDemon.
2 Right-click the news item and select Send Item > Blog this News Item > Contribute.
The contents of the news item appears in the Contribute editor.
3 Make any changes as necessary.
4 Click Publish.

Contribute publishes the news entry to your blog and then displays it in the Contribute browser.

**Configuring Contribute in NetNewsWire (Macintosh)**

NetNewsWire is a desktop RSS aggregator for the Macintosh computer. You can configure Contribute in NetNewsWire and post news entries to your blog. You can transfer the contents of the news entry to Contribute, add your own comments, and post to your blog. For more information on installing NetNewsWire, go to http://www.newsgator.com/NGOLProduct.aspx?ProdID=NetNewsWire.

**To configure Contribute in NetNewsWire:**
1 Open the NetNewsWire application.
2 Select Preferences.
3 Click Weblog Editor.
4 In the Weblog editor application pop-up menu, browse to the location of the `contribute.app` file.

**Posting to a blog from NetNewsWire**

After you successfully configure Contribute in NetNewsWire, you can post news entries to your blog.

**To post to a blog from NetNewsWire:**
1 Select the news item in the News Items list in NetNewsWire.
2 Click Post to Weblog.

The contents of the news item appears in the Contribute editor.
3 Make changes as necessary.
4 Click Publish.

Contribute publishes the news entry to your blog and then displays it in the Contribute browser.

**To preview the blog entry in your browser, do one of the following:**
- Select File > Preview in Browser.
- Press the F12 key.

**Publishing a blog entry to your blog**

After you finish editing and reviewing your blog entry, you are ready to publish it to your blog. When you publish a blog entry, you can publish all the blog entries or web pages that are linked to the blog entry. When you publish a blog entry, Contribute makes it live on your blog.

You can publish any of the following types of blog entries to your blog:
- Updates to an existing blog entry
- Existing blog entry as a new entry
- New blank blog entry
**Publishing updates to an existing blog entry**

When you publish updates to an existing blog entry, Contribute replaces the currently published version of the blog entry with the new version.

💡 You can create a link to the blog entry at the same time that you create a blog entry. For more information, see “Linking to a new blank blog entry” on page 136.

**To publish updates to an existing blog entry:**

1. In the blog entry draft, click the Publish button in the toolbar.

*Note: Some blogs do not allow images, enclosures, media files, and links to local files in the content. You might not be able to publish such content if the blog you are publishing to does not accept these files. Verify if your blog makes this exception.*

If the blog entry draft links to any new blog entries, the Publish New Linked Blog Entries dialog box appears.

If the blog entry draft links to any web pages, the Publish New Linked Pages dialog box appears.

2. If the Publish New Linked Blog Entries dialog box or Publish New Linked Pages dialog box appears, do the following:
   a. Click the blog entry or the web page to select it.
   b. If you selected a web page, change the file and folder location if necessary.
   c. Click Publish All.

For more information about options in the dialog box, click the Help button.

Contribute publishes the blog entry and any new blog entries or web pages that are linked to it, and then displays it in the Contribute browser.

**To preview the blog entry in your browser, do one of the following:**

- Select File > Preview in Browser.
- Press the F12 key.

**Publishing an existing blog entry as a new entry**

You can publish an existing blog entry in your blog, make changes, and republish it as a new entry.

You can use the Publish as New Entry feature to publish an existing blog entry as a new entry. For example, suppose you have an existing blog entry on the list of your favorite radio stations, and now you want to add a list of your friend's favorite radio stations. You can open the blog entry that has your favorites list, make your changes, and then publish the entry as a different blog entry to your same blog.

**To publish an existing blog entry as a new blog entry:**

1. Browse to the blog entry in your blog, and then click the Edit Entry button.

2. Make changes to the blog entry.

3. Select File > Actions > Publish as New Entry.

If your blog entry links to any other new blog entries, the Publish New Linked Blog Entries dialog box appears:

4. If the Publish New Linked Blog Entries dialog box appears, do the following:
   a. Click the blog entry to select it.
Click Publish All.

For more information about options in the dialog box, click the Help button.

Contribute publishes the blog entry to your blog and then displays it in the Contribute browser.

To preview the blog entry in your browser, do one of the following:

• Select File > Preview in Browser.
• Press the F12 key.

Publishing a new blank blog entry

You can publish a new blank blog entry to your blog. You can also publish a blank blog entry with links to other new blank blog entries or web pages. When you publish a new blog entry that has a link to another new blog entry or web page, Contribute publishes the new blog entry, and all blog entries that are linked to the blog entry.

You can create a link to the blog entry at the same time that you create a blog entry. For more information, see “Linking to a new blank blog entry” on page 136.

To publish a new blog entry:

1 In your draft, click the Publish button in the toolbar.

Note: Some blogs do not allow images, enclosures, media files, and links to local files in the content. You might not be able to publish such content if the blog you are publishing to does not accept these files. Verify if your blog makes this exception.

If the blog entry draft links to any new blog entries, the Publish New Linked Blog Entries dialog box appears.

If the blog entry draft links to any web pages, the Publish New Linked Pages dialog box appears.

2 For each unpublished linked blog entry or web page, do the following:

• Click the blog entry or the web page to select it.
• If you selected a web page to link to your blog entry, change the file and folder location if necessary.
• Click Publish All.

For more information about options in the dialog box, click the Help button.

Contribute publishes the blog entry draft and any new blog entries or web pages that are linked to it, and then displays it in the Contribute browser.

To preview the blog entry in your browser, do one of the following:

• Select File > Preview in Browser.
• Press the F12 key.
Chapter 12: Creating and Managing Website and Blog Server Connections

After you install Adobe® Contribute® CS3, you must create a connection to a website or blog before you can begin to edit its pages or create pages or blog entries.

This chapter explains how to use the Contribute Connection Wizard (Windows) or Connection Assistant (Macintosh) to create a connection. It also explains how to set administrative settings for a website and how to rename and remove website and blog server connections. It also explains how to specify the types of audio, video, and image files you can publishing to your blogs.

After you create a website connection, you can create roles (see “Managing Users and Roles” on page 211) and then export site connection information to your users.

This chapter contains the following sections:

• “About creating and sending website connections” on page 179
• “Preparing to connect to a website or blog” on page 182
• “Creating a website connection” on page 183
• “Creating a blog server connection” on page 184
• “Enabling and Disabling CPS for a website” on page 188
• “Becoming an administrator of an existing Contribute website” on page 190
• “Configuring Contribute administration settings” on page 192
• “Sending connection keys for websites” on page 200
• “Sending connections for CPS managed sites” on page 201
• “Adding users to websites that CPS manages” on page 202
• “Removing users from sites that CPS manages” on page 203
• “Managing website and blog server connections” on page 204

About creating and sending website connections

When you connect to a website, depending on your web server configuration and the complexity of your website, Contribute might not automatically detect all possible web server configurations. The Web Server settings of the Administer Website dialog box let you specify alternative configurations for your website's index files and alternative web addresses.

After you set up a connection to a website, you can send that connection information in a connection key file to users. Or, if the website is that Contribute Publishing Server (CPS) manages, you can use the URL.

Note: Connection keys are not available for blogs.

This section covers the following conceptual topics:

• “Web server index pages” on page 180
• “Alternative website addresses” on page 180
• “Connection keys” on page 181

**Web server index pages**

The index page for a website is the default web page that appears when a visitor enters a website (such as www.mysite.com) but doesn’t specify a page on the website. A web server can be configured to look for a page with a particular filename if no page is specified; the most common default index page filenames are index.htm, index.html, default.htm, and default.html. If you are unsure of the index page filenames that your web server uses, see your web server's documentation.

In addition to the primary index page filename, most web servers are configured with alternative index page filenames, specifying pages to be displayed if there is no page with the filename requested as the primary index page.

**Note:** Index pages are available only for websites. Blogs do not use index pages.

For example, a web server might look for the following index page names (in this order):

1. index.htm
2. index2.htm
3. 404error.htm

If a page is named index.htm, the server sends that page to the browser to be displayed; if such a page isn't present, the server sends index2.htm to the browser. If neither of those index pages is available, the server sends the 404error.htm page to the browser. Secondary pages such as these often provide an alternative entrance to the website or inform the visitor that the website is unavailable.

Contribute includes a list of popular index page filenames, using most of the popular document type extensions (.htm, .html, .cfm, .asp, .jsp, .php, and so on). If the index page filename that you use for your website is listed in the Index files section of the Index and URL Mapping dialog box (index.cfm, for example), you can most likely ignore this configuration option. If, however, your index page filenames are not included among those listed in the dialog box, you must add your index page filenames to the list, and arrange the names in the order in which your web server is configured to look for them.

For example, if your website uses an Adobe ColdFusion application server that uses the document type extension .cfm, and the index page for your website uses the filename main.cfm, add the filename main.cfm to the list of index pages in the Index and URL Mapping dialog box, and list that filename as the first page that Contribute should find on the website. “Adding index page filenames” on page 195 explains how to add an index page filename to your Contribute settings.

**Alternative website addresses**

Web servers can be configured in a variety of ways to respond to varying user needs. One common part of web server configuration is the mapping of web addresses to either different IP addresses (often for either load balancing or localization issues), or multiple web addresses pointing to a single IP address. The following common web server configurations involve URL mapping:

**Multiple DNS aliasing** occurs when two or more domain name server (DNS) aliases point to a single server (for our purposes, a single server consists of a single IP address). When connecting to a server configured with multiple DNS aliases, Contribute views the defined website and the aliases as separate websites, even though they are the same from the users’ perspective.
For example, if your server hosts the website www.carsonline.com, and you set up two additional web addresses that refer to that same website (for example, www.cars.com and www.mycars.com), you must configure Contribute to recognize these separate web addresses as the same website.

**Virtual server** configurations have two or more DNS aliases pointing to the same server, but users view them as different websites. When a server configured in this way receives a request to retrieve a web page, it serves different pages depending on the address used in the request. There are two types of virtual server configurations:

- DNS-based virtual servers use a single IP address that has two or more DNS aliases pointing to that address. In this configuration, the web server differentiates the page request based on the web address, serving different pages to the different addresses.
- IP-based virtual servers use multiple IP addresses to differentiate web servers.

A common use of virtual server configurations is to provide localized content to different geographic locations. For example, a news website might provide different local information to users viewing the website based on their location.

**Port numbers** are often used to further divide a domain name into multiple websites. Often this is to allow the website to provide different software functionality based on a port that may be listening for incoming requests.

A web address that uses a different port number is considered to be a different website. However, this is not always the case. As with web server configurations using multiple DNS aliases, it's important that you map host names using different port numbers to the correct website.

For example, if your organization's website can be accessed through two different web addresses differentiated by port numbers, you must add these web addresses to the Alternate addresses field. In this example, assume that your organization maintains the following web addresses:

www.cars.com
www.cars.com:8080

Both these web addresses point to the same website, with the exception that those sites using port number 8080 read the browser's cookie file to check whether the visitor is a new or returning user. If the user is already registered, the website appears without prompting for registration. If a user is new, a dialog box appears requesting the user to register to gain access to the website.

**Connection keys**

Using the Connection Wizard (Windows) or Connection Assistant (Macintosh), you can easily set up connections to websites for other users. The wizard enables Contribute users to collaborate by sharing website connections.

Contribute lets you share website connection information by embedding website information in a **connection key file**. Because the connection key is encrypted with a password, any network or File Transfer Protocol (FTP) login information you send in the file remains secure and can be accessed only through Contribute. The connection key file uses the filename extension.stc. You can either e-mail the file to users, or save it to your computer for users to download and import. If you double-click the file, either on the desktop or as an e-mail attachment, Contribute starts and imports the connection.

FTP and Secure FTP (SFTP) connection keys can be used across platforms; LAN connection keys are platform specific.

The procedure for sending a connection key varies depending on the type of user model you've chosen to manage your website. If you're letting users connect to a site by manually entering connection information or by using a connection key file, see “Sending connection keys for websites” on page 200. If you're managing users with a connection server, see “Sending connections for CPS managed sites” on page 201.
Preparing to connect to a website or blog

Collect the following information before you begin:

- Your user name and e-mail address

The user name and e-mail address identify users and the web pages or blog entries they are working on. Contribute prevents multiple users from simultaneously editing the same web page. (Contribute uses a system much like the Dreamweaver check in and check out system to avoid editing conflicts.)

If you have multiple copies of Contribute, use a different user name for each copy. For example, Chris(laptop), and Chris(Mac). Using the same user name can cause problems because you can override checkouts you make on the other computer.

- Web address of the website or blog server

A website’s Uniform Resource Locator (URL) is its address either on the Internet or on an organization’s intranet. Website URLs usually have the following form:

http://www.mysite.com/

A blog server’s access point Uniform Resource Locator (URL) is its address either on the Internet or your organization’s intranet. Blog server URLs usually have the following form:

http://blogname.blogsite.com

- Network path to the website (for connecting to local networks)

The network path is the location of the website in your organization’s local network. The network path includes the name of the server on which the website is stored and the directory path of the website’s files on that server. For example, your network path might be \mycomputer\wwwroot\ (Windows) or afp://server:volume: (Macintosh).

Note: If you are a Mac OS X user, to create a LAN connection, make sure to mount the network volume of the server you are creating a connection to on your computer desktop before you create your connection. In the Finder, select Go > Connect to Server to mount the network to which you want to connect.

- FTP or SFTP connection information

FTP provides a secure way to transfer files to your local or remote web server. If you will connect to your website from a remote location (for example, telecommuting from home or another office) you may need to connect to the website using FTP, to transfer files from a remote location across the Internet to your website (for example, if you don’t have a local network connection to the website).

If you or your users will connect to your website by using FTP or SFTP, you must know the address of the FTP server as well as the user name and password to connect to the FTP server. For example, your FTP server’s address might be ftp.mysite.com.

Note: For websites that are that CPS manages, require users to use their own FTP or SFTP account information to connect to the website.

- Verification that Contribute directly supports your blog

Blogs hosted on Blogger, TypePad, Roller, or WordPress are directly supported in Contribute.
If your blog is hosted by another service, the host must support the MetaWeblog API. The MetaWeblog API allows Contribute and other external programs to make changes to the text and attributes of blog entries. If your blog host supports the MetaWeblog API, you must enter the blog’s access point URL, such as http://blogname.blogsie.com, as well as your user name and password for the blog hosted by that service.

**Note:** You must have a blog account already set up with the blog host before you can connect to it using Contribute.

## Creating a website connection

The Connection Wizard (Windows) or Connection Assistant (Macintosh) guides you through the steps of creating a connection to a website, prompting you for the information needed to establish a website connection.

The process is different to create a connection to a blog; for more information, see “Creating a blog server connection” on page 184.

**Note:** If you use a Macintosh computer and have a .Mac account, you can easily create a connection to your .Mac account. In the Connection Assistant, select the .Mac check box. For information about selecting a folder to connect to in your .Mac website, see “Creating a connection to a .Mac account” on page 187.

### To create a website connection:

1. Start Contribute.
2. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).

The My Connections dialog box appears. The options in this dialog box let you create and manage your Contribute connections.

You can also use the My Connections dialog box to create a connection to blogs. For more information on creating connections to blogs, see “Creating a blog server connection” on page 184.
3 Click Create.

The Connection Wizard (Windows) or Connection Assistant (Macintosh) appears. This wizard or assistant guides you through setting up a new website connection.

Click Back or Go Back to return to a previous screen, if necessary. If you need more information about how to complete a screen, click the Help button.

4 Click Next.

5 From the What do you want to connect to pop-up menu, select Website.

6 In the What is the web address (URL) of your website field, enter the website you want to connect to. If necessary, click the Browse button and browse to the website.

7 Click Next.

8 From the How do you connect to your web server pop-up menu, select your connection service and do one of the following:
   a If you selected FTP, enter the FTP server name, user name, and password.
   b If you selected Secure FTP (SFTP), enter the SFTP server name, user name, and password.
   c If you selected Local/Network, enter the network path to your website.
   d If you selected WebDAV, enter the WebDAV URL, user name, and password.

9 (Optional) Click Advanced, and select the appropriate advanced connection options for the connection service you specified in step 7.

10 Click Next.

11 On the Summary screen, review the connection settings to verify that they’re correct and click Done (Windows) or Finish (Macintosh) to complete the connection.

Contribute creates a connection to the website.

After Contribute has successfully created a connection to the website, the Connection Wizard or Connection Assistant closes, and the main page of the website appears in the Contribute browser.

Creating a blog server connection

The Connection Wizard (Windows) or Connection Assistant (Macintosh) guides you through the steps of creating a connection to a blog, prompting you for the information needed to establish a blog server connection.

You can create a connection to a blog server in two ways:

• Specifying the blog server user name and blog server password details.
• Specifying the blog URL, and blog server user name and blog server password details.

To create a connection to a website, see “Creating a website connection” on page 183.

You can connect to a blog that is hosted on one of the following servers:

• The Blogger, TypePad, Roller, or WordPress blog publishing services. Users with blogs on one of these hosts can connect to their blogs directly by selecting the host in the Connection Wizard or Connection Assistant.
• Other internal servers, such as Movable Type, that support the MetaWeblog API.

Note: The MetaWeblog API lets Contribute users make changes to the text and attributes of blog entries.
To create a blog server connection:

1. Start Contribute.
2. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).

The My Connections dialog box appears. The options in this dialog box let you create and manage your Contribute connections.

For more information on creating connections to websites, see “Creating a website connection” on page 183.

3. Click Create.

The Connection Wizard (Windows) or Connection Assistant (Macintosh) appears. This wizard or assistant guides you through setting up a new website connection.

4. Click Next.
5. Select Blogs from the What do you want to connect to pop-up menu.
6. Select your blog's host from the Who hosts your blog pop-up menu.
7. Click Next.
8. If you selected Blogger, TypePad, or WordPress, enter the blog's user name and password.
9. Click Done (Windows) or Finish (Macintosh) to complete the connection.

Contribute creates a connection to the blog server.

Note: If you want to connect to the Roller blog server, select Other Blog Servers from the Who hosts your blog pop-up menu, and provide the required information.

After Contribute successfully creates a connection to the blog, the Connection Wizard or Connection Assistant closes. The My Connections dialog box appears, listing your connected blog(s). The blogs are also listed on the Contribute Start page.
**Note:** After you are connected to a blog server and you create another blog on the same blog server, you can add the new blog and its details by reconnecting to the blog server. For more information, see “Reconnecting to a blog server” on page 186.

**To create a blog server connection using the blog URL:**

1. Start Contribute.
2. In the Create New area, click the Blog Connection link.

   The Choosing a Connection screen of the Create Connection wizard appears.

3. By default, the Blogs option is selected in the What do you want to connect to pop-up menu.
4. Select Other Blog Servers from the Who hosts your blog pop-up menu if your blog is hosted on an internal server that supports the MetaWeblog protocol.

   The What is the URL of your blog text box and Browse button appear.
5. (Optional) In the What is the URL of your blog text box, type or browse to the URL of the home page of your blog.
6. Click Next.

   The Blog Site Connection Information screen of the Create Connection wizard appears.

   If you selected Blogger, or if Contribute is able to find the access point of the blog server whose URL you specified, only the Enter your blog server user name and Enter your blog server password text boxes appear. However, if you selected Other Blog Servers, or if Contribute is unable to find the access point of the blog server you specified, the Blog Protocol pop-up menu (which is disabled,) and the Access Point text box also appear.

7. Enter your user name in the Enter your blog server user name text box.
8. Enter the password to connect to your blog in the Enter your blog server password text box.
9. If the Access Point text box appears, specify the Access Point.

   **Note:** The Access Point is a URL used to connect to your Blog server. You can view a list of common access points in the Help documentation. Press F1 to view online help.

   **Note:** Click the Back or Go Back button to return to a previous screen if necessary.
10. Click Done.

   Contribute creates a connection to the blog server, and the blog's home page appears in the Contribute browser.

**Reconnecting to a blog server**

If you have created a blog with the blog publishing service (that you are already connected to in Contribute) and want to connect to the new blog, you might have to reconnect to the blog server. Reconnecting to the blog server creates a connection and adds templates for the new blog in Contribute.

**To reconnect a blog server connection:**

- If Contribute is not running, open the application. Contribute reconnects to the blog server and automatically updates the connection with the details of the new blogs.
- If Contribute is running, do any of the following:
  a. Exit Contribute and reopen the application.
  b. Edit the blog server connection without making any changes to the user information. For more information on editing blog server connections, see “Editing website and blog server connections” on page 205.
Disable and enable the blog server connection. For more information, see “Disabling website and blog connections” on page 208 and “Enabling a website or blog server connection” on page 208.

**Creating a connection to a .Mac account**

You can use Contribute with your .Mac account and seamlessly set up a connection to your website. This integration of Contribute and .Mac is available on Mac OS X 10.2 and later.

*Note:* On 10.1.X, you need to mount your iDisk so that Contribute can detect your .Mac account. To mount your iDisk, in the Finder, select Go > iDisk.

If Contribute detects that you have an active .Mac account, you will be prompted to create a connection to your account when you start Contribute. If you dismiss the prompt, and later want to create a connection, use the Connection Assistant to create the connection to your account.

**To create a connection to a .Mac account:**

1. Select Contribute > My Connections (Macintosh).

   The My Connections dialog box appears.

2. Click Create.

   The Connection Assistant appears.

3. Select .Mac website from the What do you want to connect to pop-up menu.

   Using the .Mac information stored in your computer's system preferences, Contribute mounts your iDisk and creates the connection to the root folder of your website. For information about selecting a different folder to connect to see “Selecting a .Mac website folder to connect to” on page 187.

   *Note:* If Contribute does not detect your .Mac account, you will be asked if you want to set up a .Mac account.

4. Click Continue to go to the next screen; on the Summary screen, click Finish to complete the website connection.

**Selecting a .Mac website folder to connect to**

When you select Get connection information from my .Mac account, Contribute automatically detects the path to your .Mac website's root folder. To create a connection to a subfolder of your .Mac website, let Contribute complete the path information, and then edit the path to the desired folder.

1. Select Contribute > My Connections (Macintosh).

   The My Connections dialog box appears.

2. Click Create.

   The Connection Assistant appears.

3. Select .Mac website from the What do you want to connect to pop-up menu.

4. In the Connection Assistant, click Continue to add the .Mac connection information.

5. In the Connection Assistant, click Go Back and deselect the Get connection information from my .Mac account check box so you can select the path you want to connect to.

   The .Mac website connection information will not be deleted; you can make the changes you want in the Connection Assistant screens.

6. Click Continue to update the settings as desired. On the Summary screen, click Finish to close the Connection Assistant.
Enabling and Disabling CPS for a website

After you install and configure CPS, you can enable CPS for your website. At any point, you can disable CPS or the User Directory service.

Note: To disable other services, you must use the CPS Console. For more information, see the CPS Console Help.

This section covers the following topics:

• “Enabling CPS to work with your website” on page 188
• “Disabling CPS for a website” on page 189
• “Disabling the User Directory service for a website” on page 190

Enabling CPS to work with your website

Before you can start using CPS with your website, you must install and configure CPS (see CPS Console Help for information about configuring). You must also create a Contribute connection to your website (see “Creating a website connection” on page 183).

After you’ve completed those tasks, you can enable CPS for your website.

💡 Before you enable CPS to use the User Directory with your website, make sure that any users who previously connected to the site using a connection key publish all outstanding drafts. After you enable CPS for your website, those users cannot connect to the website until you add them to the website from your LDAP, Active Directory, or file-based user database.

To start using CPS with your website:

1. Start Contribute.
2. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and then select the website you want to administer from the submenu.

The Administer Website dialog box appears.

3. Select Publishing Server from the list of administrative categories on the left.
4. Click the Enable Publishing Server button.

The Enable Publishing Server dialog box appears.

5. Enter the Publishing Server web address in the address field, and then click OK.
For more information about options in this dialog box, click the Help button in the dialog box. Contribute establishes a connection to CPS, and you can launch the CPS Console.

**Note:** When you enable the User Directory, any users who previously connected to the site are removed, and any connection keys you may have previously sent no longer work. You must add users from your LDAP, Active Directory, or file-based user database. To learn how to add users to sites that CPS manages, see “Adding users to websites that CPS manages” on page 202.

6  (Optional) In the Administer Website dialog box, click the Publishing Server Console link to launch the CPS Console.

---

**Disabling CPS for a website**

You can disable CPS for a website that CPS manages. This can be useful when you need to temporarily prevent users from connecting to the server; for example, when you move the server or perform server maintenance.

When you disable CPS, users who were connected to the website cannot connect until you re-enable CPS. Contribute does not remove the administrative settings file for the website when you disable CPS, so roles and permissions are unaffected.

**To disable a CPS website connection:**

1  Publish any open drafts for the website.

You might not be able to access outstanding drafts after you disable the service.

**Note:** Make sure that users connected to the website also publish any outstanding drafts.

2  Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and then select the website you want to administer from the submenu.

The Administer Website dialog box appears.

3  Select Publishing Server from the category list on the left.

4  Click the Disable Publishing Server button.
A confirmation dialog box appears.

5 Click Yes to continue.

Contribute disables CPS for this website. Contribute does not remove the administrative settings file for the website, so roles and permissions are unaffected. You still have a connection to the website as a non-managed site.

Note: Users who were connected to this website cannot connect until you re-enable CPS or send them connection keys with new connection information.

6 Click Close to close the Administer Website dialog box.

Disabling the User Directory service for a website

You can disable the User Directory service for any website that CPS manages.

Note: To disable other services, you must use the CPS Console. For more information, see the CPS Console Help.

When you disable the User Directory service, users who were connected to the website cannot connect until you send them connection keys with new connection information.

To disable the User Directory service for a website:

1 Publish any open drafts for the website.

You might not be able to access outstanding drafts after you disable the service.

Note: Make sure that users connected to the website also publish any outstanding drafts.

2 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and then select the website you want to administer from the submenu.

The Administer Website dialog box appears.

3 Select Publishing Server from the category list on the left.

4 Click the Disable User Directory button.

Contribute disables the User Directory service for this website.

Note: Users who were connected to this website cannot connect until you send them connection keys with new connection information.

5 Click Close to close the Administer Website dialog box.

Becoming an administrator of an existing Contribute website

When you create a Contribute website connection, you have the option of becoming the administrator of that website. If you do not become the website administrator when you create the connection, you or another user can become the administrator later.

You can become the website administrator of any website that does not have an administrator associated with it. The website administrator is responsible for setting website permissions and for being a point of contact for users who need assistance.
Note: If someone inadvertently becomes the administrator for a website, or you forget the administrator password, you can reset the password and create a administrative login. For more information, see “Contribute freezes when sending a connection key” on page 238.

To become the website administrator of a Contribute website:

1 Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh) to display the My Connections dialog box, which lists all the websites that you have a connection to, as well as the administrator (if any) assigned to each website.

If a website does not have an administrator associated with it, the text No administrator appears in the Administrator column of the dialog box.

If a website does not have an administrator, you can become the administrator by completing this procedure.

2 Select the website you want to administer, and click Administer.

3 A dialog box asks whether you want to become the administrator of the website. Click Yes to become the website administrator.

After this selection, Contribute sets you as the administrator for the site, and the Administer Website dialog box appears. You can optionally set an administrative password for the site.

4 (Optional) Select the Administration category in the Administer Website dialog box.

5 Click Set Administrator Password.

The Administrator Password dialog box appears.
Enter and confirm an administrative password for the website, and click OK.

After you assign an administrative password to the website, the Administer Website dialog box appears, allowing you to configure the website's settings and permission groups.

Configuring Contribute administration settings

The Administer Website dialog box lets you configure a variety of settings that specify how Contribute interacts with your website as well as letting you manage users.

You can set settings that affect the whole website, such as the administrator's contact or password information, the number of rollback versions of pages to save, and filename conventions for website default home pages.

To open the Administer Website dialog box:
1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to set options for.
2. If prompted, enter the Administrator password, and then click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more information, see “Becoming an administrator of an existing Contribute website” on page 190.

The Administer Websites dialog box appears.
3 Select the administrative settings category you want to modify from the list on the left side of the dialog box.

See the following topics for information about using the options in this dialog box:

- “Changing the website administrator” on page 193
- “Changing the administrator’s password” on page 193
- “Enabling and disabling rollbacks” on page 194
- “Specifying new page preferences” on page 195
- “Adding index page filenames” on page 195
- “Removing index page filenames” on page 197
- “Specifying alternative website addresses” on page 197
- “Specifying a guard page” on page 198
- “Enabling compatibility with older versions of Contribute” on page 199
- “Enabling or Disabling PDF Embedding” on page 199

**Changing the website administrator**

You can change the administrator of a Contribute website by changing the e-mail address associated with the website. Users send e-mail to this address when they need to contact the website administrator for assistance.

*Note: Changing the e-mail address of the website administrator does not change the administrator password. To change the administrator password, see “Changing the administrator’s password” on page 193.*

**To change the administrator e-mail address:**

1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.
2. Do one of the following:
   - If the Administrator Password dialog box appears, enter the administrator password and click OK.
   - If the website has no administrator, click Yes when a dialog box asks whether you want to become the website administrator. Then enter and confirm an administrator password for the website, and click OK.

The Administer Website dialog box appears.

3. Select the Administration category on the left side of the dialog box.

4. Enter a new e-mail address in the Administrator contact e-mail text box.

5. Select another category to modify, or click Close to exit the Administer Website dialog box.

**Changing the administrator’s password**

You can change the password used by the administrator.

**To change the administrator password:**

1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.
2. If prompted, enter the Administrator password, and then click OK.
Assigning an administrator to a site and assigning a password for the administrative account are optional. For more information, see “Becoming an administrator of an existing Contribute website” on page 190.

The Administer Website dialog box appears.

3 Select the Administration category on the left side of the dialog box.

4 Click Change Password in the Administrator Information section of the dialog box.

The Change Administrator Password dialog box appears.

5 Enter your current password and the new password you want to use in the text boxes. You must enter the new password twice to confirm that you are entering it correctly.

6 Click OK.

7 Select another category to modify, or click Close to exit the Administer Website dialog box.

Enabling and disabling rollbacks

Rollback pages are backup versions of each web page published with Contribute. Enable Rollback is on by default. You can disable rollback or change the number of rollback versions. Each rollback page is a copy of the last published version of that page before the currently published version.

For example, if you browse to a page for editing in Contribute, modify the content, and publish your changes without having previously updated and published that page, there is only one rollback version of the page (in this case, the rollback version is the original page).

Contribute can maintain as many as 99 rollback versions of each published page. When you specify the number of rollback pages, carefully consider the amount of disk space that will be consumed by storing the rollback pages. The pages are stored on the web server. The default number of rollback pages is three.

To enable and disable rollback pages:

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh) and select the website you want to administer from the submenu.

2 If prompted, enter the Administrator password, and then click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more information, see “Becoming an administrator of an existing Contribute website” on page 190.

The Administer Website dialog box appears.

3 Select the Rollbacks category on the left side of the dialog box.

4 Select Enable rollbacks to activate rollbacks, or deselect it to turn rollbacks off.

5 Enter the number of rollback versions to maintain in the Keep previous versions of each page text box, or use the arrow buttons to change the number. Contribute can maintain as many as 99 rollback versions of each web page.
Select another category to modify, or click Close to exit the Administer Website dialog box.

**Specifying new page preferences**
The New Pages category lets you determine the document encoding that should be used for your web pages as well as the file extension to use when creating pages from a blank page or templates in a site.

Document encoding specifies the encoding used for characters on a web page. For English and Western European languages, select Western. Additional options include Central European, Cyrillic, Greek, Icelandic, Japanese, Traditional Chinese, Simplified Chinese, and Korean. If an option for the encoding you want is not available, select UTF-8 to create a page using the encoding that your operating system is using.

**To specify document encoding for new pages:**
1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.
2. If prompted, enter the Administrator password and click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more information, see “Becoming an administrator of an existing Contribute website” on page 190.

The Administer Website dialog box appears.

3. Select the New Pages category on the left side of the dialog box.

The New Pages panel appears.

4. Select the document encoding format you want to use from the Default encoding pop-up menu.

5. Select another category to modify, or click Close to exit the Administer Website dialog box.

**To specify the default file extension for new pages:**
1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.
2. Do one of the following:
   - If the Administrator Password dialog box appears, enter the administrator password, and click OK.
   - If the website has no administrator, click Yes when a dialog box asks whether you want to become the website administrator. Then enter and confirm an administrator password for the website, and click OK.

The Administer Website dialog box appears.

3. Select the New Pages category on the left side of the dialog box.

The New Pages panel appears.

4. Enter the default file extension you want to use for both new blank pages, and new pages created from templates.

The default file extension is .htm, but you can specify any file extension appropriate to your website. For example, if your website exclusively uses Adobe ColdFusion pages, you will want to create pages with the file extension .cfm.

5. Select another category to modify, or click Close to exit the Administer Website dialog box and save your changes.

**Adding index page filenames**
You can add new index filenames to your website settings that correspond to your website’s index files.

*Note: For more information about index page filenames, see “Web server index pages” on page 180.*
To add an index page filename:

1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.

2. If prompted, enter the Administrator password, and click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more information, see “Becoming an administrator of an existing Contribute website” on page 190.

The Administer Website dialog box appears.

3. Select the Web Server category on the left side of the dialog box and click the Index Files tab.

The Index Files panel appears.

4. Click the Add button.

The Add or Edit Index Filename dialog box appears.

5. Enter an index filename and, click OK.

The new index filename appears at the bottom of the list of possible index filenames.

6. Using the arrow buttons, arrange the index pages in the order that your web server’s configuration specifies. For example, if your web server is configured to use three index pages—index.htm, index2.htm, and 404error.htm—and the primary page is index.htm, the designated order is:

- index.htm
- index2.htm
- 404error.htm

This is the order in which the web server retrieves and displays the index pages if one or more of the pages are unavailable.

7. When you have added and ordered the filenames in the Index file list, click Close to exit the Administer Website dialog box and save your changes, or select another category to modify.
Removing index page filenames
You can remove index page names from the default list in Contribute. When deleting index page filenames, ensure that your Contribute sites don’t rely on the page names you are removing from the Index files list.

To remove an index page filename:
1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.
2 If prompted, enter the Administrator password, and click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more information, see “Becoming an administrator of an existing Contribute website” on page 190.

The Administer Website dialog box appears.
3 Select the Web Server category on the left side of the dialog box, and click the Index Files tab.

The Index Files panel appears.
4 Select the filename you want to remove from the Index files list.

Note: You cannot select multiple index files from the list; you must select each file individually and click Remove.
5 Click Remove.
6 When you have removed the filename from the Index file list, click Close to exit the Administer Website dialog box and save your changes, or select another category to modify.

Specifying alternative website addresses
If Contribute users visit a website using a different host name, directory path, or port number, you must configure Contribute to recognize these alternative web addresses and associate them with the appropriate website connection.

Note: For more information about alternative web addresses, see “Alternative website addresses” on page 180.

If you don’t configure Contribute to recognize alternative web addresses, users might have problems editing or publishing web pages if they connect to a website that isn’t defined in Contribute.

You need to configure Contribute to recognize the alternative web addresses that users need to access, not all possible alternative web addresses.

To specify an alternative web address for a website:
1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.
2 If prompted, enter the Administrator password, and click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more information, see “Becoming an administrator of an existing Contribute website” on page 190.

The Administer Website dialog box appears.
3 Select the Web Server category on the left side of the dialog box, and click the Web Address tab.
The Web Addresses panel appears.

4 Click the Add button.
The Add or Edit Alternate Address dialog box appears.

5 Enter an alternative URL, and click OK.
The new URL appears in the Alternate addresses list.

6 When you have entered all the alternative web addresses, click Close to exit the Administer Website dialog box and save your changes, or select another category to modify.

**Specifying a guard page**

Guard pages are web pages that Contribute places in folders containing administrative files and temporary copies of pages that have been sent for review. The guard page prevents users from browsing to a Contribute folder containing files that you don't want them to access.

**To specify a guard page for a website:**

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.

2 If prompted, enter the Administrator password, and click OK.

Assigning an administrator to a site and assigning a password for the administrative account are optional. For more information, see "Becoming an administrator of an existing Contribute website" on page 190.

The Administer Website dialog box appears.

3 Select the Web Server category on the left side of the dialog box, and click the Guard Page tab.
The Guard Page dialog box appears.

4 Click Find Guard Page.
The web page you specified as an index page for the site is set as the guard page. By placing a copy of the website's index page in a folder, Contribute can redirect users to the home page of the website.

5 When you have specified a guard page, click Close to exit the Administer Website dialog box and save your changes, or select another category to modify.

**Enabling compatibility with older versions of Contribute**

Contribute offers administrators two compatibility options—one that allows users with earlier versions to work on the website, and one that does not:

- **Transition Mode**
  In this mode, users of earlier versions of Contribute can continue working on the website, along with Contribute 4.0 and later users. This lets you evaluate the new version and set up new roles and permissions without disrupting users with earlier versions of Contribute.

- **Compatibility Mode**
  In this mode, all users must use Contribute 4.0 or later. Users with earlier versions cannot work on the website.

Contribute 4.0 or later starts in Transition mode by default when you migrate from an earlier version of Contribute. Use this mode temporarily; when you're ready, transition all users to Contribute 4.0 or later and enable Compatibility Mode.

**To enable Compatibility Mode:**

1. In Contribute 4.0 or later, select Edit > Administer Websites, and then select a website.

   The Administer Website dialog box appears.

2. Select Compatibility from the category list on the left.

   The Compatibility options appear in the Administer Website dialog box.

3. Select Compatibility, and then click Close.

   After you enable Compatibility Mode, all users connected to the website must use Contribute 4.0 or later.

**Enabling or Disabling PDF Embedding**

Contribute enables an Administrator to restrict users from embedding PDF documents as objects in a web page. If users are allowed to insert embedded PDF objects, they can choose to insert the document either as a link or as an embedded PDF. However, if users are not allowed to embed PDF objects, they only have the option to insert the PDF document as a link.

**To enable or disable PDF embedding:**

1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.

2. If prompted, enter the Administrator password and click OK.

   The Administer Website dialog box appears.

3. Select the Enable PDF Embedding category on the left side of the dialog box.

4. Select the Allow PDF Embedding or Do not allow PDF Embedding option.

5. Click Close.
Sending connection keys for websites

Using the Export Connection Wizard (Windows) or Export Connection Assistant (Macintosh), you can easily set up connections to websites for other users by sending them a connection key. For more information about connection keys, see “Connection keys” on page 181.

**Note:** To send a website connection key to other users, you must create one or more Contribute website connections to share. For information about creating a Contribute website connection, see “Creating a website connection” on page 183.

For information about sending connection keys for websites that CPS manages, see “Sending connections for CPS managed sites” on page 201.

**To create a website connection key to share with users:**

1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.

2. Do one of the following:
   - If the website has no administrator, click Yes when a dialog box asks whether you want to become the website administrator. Then enter and confirm an administrator password for the website, and click OK.

3. The Administer Website dialog box appears.

   ![Administer Website dialog box](image)

   **3** Select the Users and Roles category on the left side of the dialog box.

   The Users and Roles dialog box appears.

4. You can send a connection key file to a new user, or you can send a connection key to a user who has already connected to the site, and assign them a new role.

   - To send a connection key to a new user, click Send Connection Key.
   - To send a connection key to an existing user, assigning them a new role, select the user’s name from the list of connected users, and click Send Connection Key.
The Send Connection Key Wizard (Windows) or Export Connection Key Assistant (Macintosh) appears.

5 Follow the instructions in the wizard or assistant, and click Next (Windows) or Continue (Macintosh) to proceed to the next screen.

6 After completing the wizard or assistant, a new connection key file is created for the user, assigning them to a new role.

You can e-mail the connection key file to the user or save the file to your computer.

7 Select another category to modify, or click Close to exit the Administer Website dialog box and save your changes.

**Sending connections for CPS managed sites**

If you use CPS to manage your website, you send users a connection key that connects them to the server. For more information about connection keys, see “Connection keys” on page 181.

*Note:* Before users can use a connection key to connect to a CPS managed website, you must add users to the website. If you haven't already done so, see “Adding users to websites that CPS manages” on page 202.

If you’re not using CPS to manage your website, see “Sending connection keys for websites” on page 200 for information about sending connection keys.

**To send a CPS connection key:**

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.

If the website has no administrator, click Yes when a dialog box asks whether you want to become the website administrator. Then enter and confirm an administrator password for the website, and click OK.

The Administer Website dialog box appears.

2 Click Send Connection Key.

The Send Connection Key dialog box appears.
You can select to e-mail the connection link to the user, or save the file to your local computer.

Select another category to modify, or click Close to exit the Administer Website dialog box and save your changes.

## Adding users to websites that CPS manages

The User Directory service of CPS lets you add users from your organization’s LDAP or Active Directory service. 

**Note:** To add users to sites that CPS manages, you must have enabled CPS to work with your website. For more information on, see “Enabling and Disabling CPS for a website” on page 188.

For websites that CPS manages, you must manually add users to a website’s user list before those users can connect—unlike non-managed websites where anyone with a connection key or connection information can connect to the site.

After you add a user to a website, you can send them a connection key or connection information to connect to the website.

### To add users to CPS managed sites:

1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and then select the website you want to administer from the submenu.

   If the website has no administrator, click Yes when a dialog box asks whether you want to become the website administrator. Then enter and confirm an administrator password for the website, and click OK.

   The Administer Website dialog box appears.

2. Select the Users and Roles category from the list on the left.

   The Users and Roles panel of the Administer Website dialog box appears.

3. Click Add Users.

   The Add Users dialog box appears.
4. Select a role for the users you want to add from the Role for the new users pop-up menu. The role you assign determines the editing permissions the new users have for modifying the site's pages.

5. Use Search to find users, and then add them to the role you selected.

6. (Optional) Select Send connection key e-mail to users to send an e-mail to the users you’ve added to the role.

   You can also have users type connect:server domain name (where server domain name is the name of the server where CPS is installed) in the Contribute browser address bar to connect to the website.

   For more information about options in this dialog box, click the Help button in the dialog box.

7. Click OK.

Contribute adds the specified users to the website and sends them e-mail that contains the connection key.

Removing users from sites that CPS manages

CPS lets you add users to a website from your organization's LDAP or Active Directory service (see “Adding users to websites that CPS manages” on page 202). You can remove any users that you’ve added so that they cannot connect to the website.

To remove users from roles of managed sites:
1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and then select the website you want to administer from the submenu.

   If the website has no administrator, click Yes when a dialog box asks whether you want to become the website administrator. Then enter and confirm an administrator password for the website, and click OK.

   The Administer Website dialog box appears.

2. Select the Users and Roles category.

   The Users and Roles panel of the Administer Website dialog box appears.

3. Select the name of the user who you want to remove and click Remove.

4. When you are finished removing users, click Close.

Configuring dependent files for blogs

When you create a Contribute blog server connection, you can specify the types of audio, video, and image files that you can publish in blog entries to blogs hosted by the blog service.

To configure the dependent files available for a blog:
1. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh) to display the My Connections dialog box, which lists all your connected blogs.

2. Select the desired blog host, and click Configure.

   The Blog Server Publish Options dialog box opens.

   Note: The Configure button is available only for blog hosts; it is not available for a hosted blog.
3 Select the publishing options for the blog host:
- Allow images (GIF, JPG, PNG, and so on)
- Allow audio (MP3, WMA, WAV, and so on)
- Allow video (MPG, MPEG, WMV, and so on)
4 Click OK.
You can publish blog entries with the specified file types.

Managing website and blog server connections

You can use the My Connections dialog box to manage your website and blog server connections. The connection management options differ for non-CPS-managed websites, CPS-managed websites, and blog connections.

You can also use the My Connections dialog box to specify the types of audio, video, and image files that you can publish in blog entries.

For websites managed with CPS, you can either disable connections of individual sites, or you can remove the CPS connection. You cannot rename or remove an individual connection if it is managed using CPS.

For blogs, you can disable only the blog server. Disabling a blog server disables all blogs hosted on that server. You cannot disable individual blogs hosted by a server. Similarly, you can rename only the blog server listed in the My Connections dialog box, not individual blogs hosted by a blog server.

To manage website and blog server connections:
1 Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).
The My Connections dialog box appears.

2 Select a website or blog server from the list of connections.
3 Manage connections by doing any of the following:
   • “Editing website and blog server connections” on page 205
If you use the Connection Wizard or Connection Assistant to create a connection, you can update the connection information when server or network configurations are altered (for example, changing network paths or a website's URL).

**Note:** If you import a connection key, the only pieces of connection information you can edit are your name and your e-mail address.

- “Renaming a website or blog server connection” on page 206
You can rename a website or blog server connection in Contribute.

You can rename only the blog server listed in the My Connections dialog box, not individual blogs hosted by a blog server.

- “Removing website and blog server connections” on page 207
You can delete an obsolete website or blog server connection from Contribute. When you delete the blog server listed in the My Connections dialog box, all individual blogs hosted by the blog server are deleted. You cannot delete individual blogs.

- “Disabling website and blog connections” on page 208
You can disable website and blog server connections to improve the performance of Contribute by reducing the number of active connections.

- “Enabling a website or blog server connection” on page 208
You can enable a website or blog server connection that you previously disabled.

- “Connecting to websites and blog servers at startup” on page 209
You can configure Contribute not to connect to website or blog connections at startup, to improve the Contribute startup time.

4 Click Close when you are finished.

**Editing website and blog server connections**
You can edit the connection information for any Contribute website or blog. You can modify a connection if any of its parameters change (for example, if you move a website to a different network location or change a blog's URL).

**Note:** If you import a connection key for a website, the only connection information you can edit is your name and your e-mail address.

- If you have open drafts, you can't change your name or e-mail address for the website belonging to those drafts, nor can you change your user name or password for the blog belonging to those drafts. You must close the drafts before you can change that information.

**To edit a website or blog server connection:**
1 Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).
The My Connections dialog box appears.

2 Select a website or blog server from the list of connections.

3 Click the Edit button.
The Connection Wizard or Connection Assistant appears.
4 Navigate through the Connection Wizard or Connection Assistant using the Next or Continue button, and modify the necessary website or blog server connections settings.

For more information on the Connection Wizard or Connection Assistant website and blog server settings, see “Creating a website connection” on page 183 and “Creating a blog server connection” on page 184.

5 When you have modified the necessary connection settings for a website and verified that they are correct, you must send a connection file to users containing the new connection setting information.

**To edit a website connection for a website that CPS manages:**
1 Close any open drafts for the website you are removing.

Contribute does not remove a connection to a website in which you're editing pages.

2 Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).

The My Connections dialog box appears.

3 Select a website from the list of connections.

4 Click the Edit button.

The Edit Connection wizard appears.

5 Make changes as necessary, and then click Done when you are finished.

6 Click Close to close the My Connections dialog box.

**Renaming a website or blog server connection**

You can rename a website or blog server connection as it appears in Contribute. The new name appears in the Home Pages menu, the My Connections dialog box, and, if you rename a website, the Administer Websites submenu. Renaming the website or blog server connection doesn't change the actual name of the website or blog server; it changes how the website or blog server is referred to in Contribute.

*Note:* You cannot rename a website connection for a site managed with CPS. Website names come from the title of the site's home page. To ensure that sites are easily identifiable, give the home page a meaningful name. Additionally, you can rename only blog server connections, not individual blogs hosted on that blog server.

**To rename a website or blog server as it appears in Contribute:**
1 Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).

The My Connections dialog box appears.

2 Select the desired website or blog server connection from the list of connections.

3 Click the Rename button.

The website or blog server connection name is highlighted by an editing box.

4 Click inside the editing box, and enter a new name for the website or blog server connection.

5 Press Enter or Return to apply your changes.

6 Click Close to save your changes and close the My Connections dialog box.
Removing website and blog server connections

You can remove Contribute website and blog server connections when they are not needed. Removing a Contribute connection does not remove the website or blog server; it removes only the website or blog server connection information.

The process for removing a website can differ slightly, depending on whether the website uses CPS.

💡 For information about removing unpublished drafts from a disabled website or blog, see “Removing unpublished drafts in a disabled website or blog” on page 208.

**To remove a website or blog server connection:**

1. Close any open drafts for the website or blog entries hosted by the blog server you are removing.
   
   Contribute does not remove a connection to a website or blog in which you’re editing pages.

2. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).
   
   The My Connections dialog box appears.

3. Select a website or blog server from the list of connections.

4. Click Remove.
   
   Contribute removes the website or blog server connection from the My Connections dialog box. All blogs hosted by the deleted blog server are also deleted.

**To remove a CPS-managed website connection:**

1. Close any open drafts for the website you are removing.
   
   Contribute does not remove a connection to a website in which you’re editing pages.

2. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).
   
   The My Connections dialog box appears.

3. Select a website from the list of connections.

4. Click Administer.
   
   The Administer Website dialog box appears.

5. Select Administration from the category list on the left.

6. Click Remove Administration button.
   
   A confirmation dialog box appears.

   **Note:** Contribute removes the website connection from the Websites list in the CPS Console. The next time you log in to the console, the website will not be on your list. If the website still appears in the list, click the Delete button in the console to remove the website.

7. Click Yes to continue.
   
   Contribute removes the connection information and administrative settings file (including user roles and website permissions) associated with this website. Users who were connected to this website cannot connect to it.

💡 If users need to connect to this website, you need to create a connection and recreate roles and reset permissions. Then, send connection keys with new connection information to users.

8. Click through Close twice.
You can remove this unadministered website from Contribute. For more information see “To remove a website or blog server connection:” on page 207.

Disabling website and blog connections

When Contribute starts, it verifies all the connections defined in the My Connections dialog box and opens a connection to each defined website and blog. Sometimes, a website or blog may not be available. For example, the network connection may be weak or inconsistent, the network may time out, or the server may have exceeded the maximum number of connections. If one or more of the websites or blogs are unavailable for any reason, Contribute cannot open those connections.

Note: If Contribute can’t connect to a website or blog, it may automatically disable that connection. An alert that Contribute is not connected to the website or blog appears in the Contribute browser.

To improve Contribute performance, you can disable connections to websites and blog servers that you don’t need to update frequently. Defining many websites and blog servers requires multiple network connections over an extended period, which impacts performance. When you need to edit the website or blog, you can enable the connections.

Disabling a connection for CPS-managed websites works the same as it does for non-CPS-managed websites. In addition, disabling a blog server connection works like disabling websites managed by CPS.

If you do not want your website to be managed by the publishing server (CPS), you may disable the publishing server from the Administer Website dialog box. For more information, see “Disabling CPS for a website” on page 189.

To disable individual Contribute website or blog server connections:

1. Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh). The My Connections dialog box appears.

2. Select the desired website or blog server connection from the list of connections. (Disabled connections are marked with a red slash.)

3. Click the Disable button.

4. A dialog box appears, informing you that the connection has been disabled. Click OK to verify that this is the connection you want to disable. If you have inadvertently disabled the wrong connection, you can re-enable the connection; for more information, see ”Enabling a website or blog server connection” on page 208.

5. Click Close to save your changes and close the My Connections dialog box.

Removing unpublished drafts in a disabled website or blog

When you use the My Connections dialog box to remove a connection to a website or blog that contains unpublished drafts, Contribute warns you that you must either cancel or publish the unpublished drafts before you can remove the connection.

Enabling a website or blog server connection

If you disable a website or blog server connection, or if Contribute automatically disables it because it can’t connect to the website or blog server, you can enable it later.

To enable the current website or blog server connection:

❖ Click Connect in the toolbar.
To enable any website or blog server connection:
1 Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).
   The My Connections dialog box appears.
2 Select the desired website or blog server connection from the list of connections. (Disabled connections are marked with a red slash.)
3 Click the Enable button.
4 Click Close to save your changes and close the My Connections dialog box.

Connecting to websites and blog servers at startup
During startup, Contribute will not connect to any website or blog server. However, you can select the desired website or blog server and configure Contribute to connect to it during startup. You can also configure Contribute to connect to all websites and blog servers at startup.

To define connection settings for individual sites and blogs:
1 Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).
   The My Connections dialog box appears.
2 Select a website or blog server.
   Note: By default, Contribute is configured not to connect to any website or blog server. To modify this behavior, see “To define connection settings for all sites and blogs:” on page 209.
3 Clear the selection of the Don’t connect to web site or blog server name at startup check box to configure Contribute to connect to the selected website or blog server at startup.
   Note: You cannot set this option for a specific blog entry.
   Next time you start Contribute, a connection is established to the selected website or blog server only. In the case of blog connections, all blog entries in the selected blog server will be enabled.
   For more information on accessing websites that CPS manages, see “Understanding server access for connecting to CPS-managed websites” in Deploying Contribute and Contribute Publishing Server.
   You can configure Contribute to connect to all websites and blog servers at startup.

To define connection settings for all sites and blogs:
1 Select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).
   The My Connections dialog box appears.
2 Select each website and blog connection, and do the following:
   • Enable the connection.
   • Clear the selection of the Don’t connect to web site or blog server name at startup check box.
3 Clear the selection of the Don’t connect to any site at startup (improves Contribute startup time) check box.
4 Click Close.
   When you restart Contribute, all connections enabled before closing Contribute, remain enabled.
   This option appears the first time you connect to this server or when server information changes (for example, when the security certificate expires). To verify that you can trust this server before you select the check box, do the following:
• Click the Certificate link and note the Public key fingerprint.
• Ask your CPS administrator to verify that the public key fingerprint is valid.

If you do not select the Trust this server check box, you cannot connect to the website.
Chapter 13: Managing Users and Roles

Adobe® Contribute® CS3 lets you control the extent to which users can alter a website. To do so, you create roles for each website and define permissions for each role. After a website's permissions are defined, Contribute creates a folder labeled _mm at the root of the website and places a shared settings file in this folder. The shared settings file contains all the website settings and permissions for Contribute website connections that you create. All Contribute users who connect to the website automatically inherit the settings defined for their assigned role.

- “Understanding roles” on page 211
- “Creating Contribute roles” on page 212
- “Editing a role's settings” on page 214
- “Managing drafts sent for review” on page 228

Understanding roles

Contribute lets you define a set of user permissions, ranging from file access to the level of typographic control, as a role. You assign the roles you create to Contribute users, which determines the degree to which a specific user can modify a site's content.

Contribute has three default roles that you can assign to users “as-is,” or modify further to meet the content editing needs of your website. The default Contribute roles are:

**Administrator** Users with this role are administrators of this website.

**Publisher** Users with this role can create and edit pages as well as publish pages to the website.

**Writer** Users with this role can create and edit pages but cannot publish pages to the website. To publish new pages or page modifications to a site, users in this role must send their updates to a user in the publisher role for review. The publisher can then choose to publish the page to the site or send it back to the writer for additional editing.

In most cases you can use the default settings specified for these roles. However, if your website has certain design features that need to be preserved, you can configure Contribute to work with those design considerations.

If you are not familiar with such web page design elements as font and paragraph usage, Cascading Style Sheets (CSS) styles, and image file formats and size limitations, consult a web page designer or other web professional who is knowledgeable about your organization's website.

About role settings

Contribute lets you define the following categories of permissions and website settings in the Role dialog box:

**General** lets you select a starting (home) page that users in the selected role see when they enter the website. For more information, see “Setting general role settings” on page 217.

**Folder/File Access** limits a role's access to the selected folder (or folders) and any subfolders they contain. For more information, see “Setting folder and file access settings” on page 218.
**Editing** lets you specify what content users can modify and determine how Contribute processes paragraphs, line spacing, and accessibility options. For more information, see “Setting page-editing and paragraph settings” on page 220. You can also allow users to insert HTML code snippets in Contribute pages. For more information, see “Setting the option for inserting HTML Code Snippets” on page 221.

**Styles and Fonts** specifies which font sets users have access to, and which users can apply style and formatting to text. For more information, see “Setting style and font settings” on page 221.

**New Pages** specifies whether Contribute users can create blank pages, and which (if any) Adobe's Dreamweaver MX templates they can use to create pages. You can also specify which pages, if any, the user can copy. The options in this category determine what options users see in the New Page dialog box. For more information, see “Settings for new web pages” on page 223.

**New Images** lets you specify a maximum file size, width, and height for images. You can also restrict users so that they can use images only from a shared asset library that you create, or you can allow them to add any image to a web page. For more information, see “Setting options for new images” on page 224.

**File Placement** lets you specify folder locations for files based on the file extension used to identify the file type. You can also specify that Contribute not allow files of a certain size to be uploaded to the web server. For more information, see “Setting options for file placement” on page 225.

**Shared Assets** lets you create a library of assets (such as images, Flash content, or Dreamweaver library items) that users can add to web pages. You can restrict access to shared assets to specific users or let any Contribute user accessing the website add the assets to their pages. For more information, see “Setting options for shared assets” on page 226.

### Creating Contribute roles

When Contribute users connect to a website, they are prompted to indicate which role they belong to. For example, a Contribute user might choose or be assigned to the Writer role. Thereafter, while connected to that website, that user has whatever permissions you have configured for the Writer role.

**To create a role:**

1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and then select the website you want to administer from the submenu.

   If the website has no administrator, click Yes when a dialog box asks whether you want to become the website administrator. Then enter and confirm an administrator password for the website, and click OK.

   The Administer Website dialog box appears.

2. Select Users and Roles.
By default, Contribute creates three roles: Administrator, Publisher, and Writer.

3 Click Create New Role.

The Create New Role dialog box appears.

4 Select an existing role from the Create new role from copy of list box.

Selecting an existing role as a base for a new role lets you reuse the selected role's settings. You can modify the new role's settings as needed.

5 Enter a name for the role you want to create, and then click OK.

The new role appears in the list of role names in the User and Roles panel of the Administer Website dialog box.

6 Select the role name, and then click Edit Role Settings.

The Edit Role dialog box appears. The Edit Role dialog box lets you modify the user settings associated with each role.

7 Modify the settings for the role.
When you are finished defining the role, click OK to save your changes. The Role dialog box closes, returning you to the Administer Website dialog box.

8 To create additional roles, repeat steps 4 through 7 for each role you want to add.

9 Select another administrative category to modify, or click Close to apply your changes and exit the Administer Website dialog box.

Note: You can modify a role’s settings at any time, even after you have distributed a connection key. Connection information and website permissions are maintained separately.

• To modify the roles you have created, select the role whose settings you want to modify and click Edit Role Settings. The Role dialog box appears. To learn more about the settings you can modify, see “Editing a role’s settings” on page 214.

• To send the connection to the users that make up the role, click Send Connection Key. The Export Connection Wizard appears. To learn how to export a connection key, see “Sending connection keys for websites” on page 200.

To edit the role now, skip to step 4 of the following procedure. Otherwise, click Close to close the Define Roles dialog box, and then click Close to close the Administer Website dialog box.

Editing a role’s settings

The Role Settings dialog box lets you define different home pages for users based on the role they belong to, limit roles to working in specific folders, and determine the modifications a role can make to a website.

Note: For information about creating roles, see “Creating Contribute roles” on page 212.

To edit settings for a Contribute role:

1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and then select the website you want to administer from the submenu.

If the Administrator Password dialog box appears, enter the administrator password and click OK.

The Administer Website dialog box appears.

2 Select Users and Roles.
The User and Roles category of the Administer Website dialog box lets you see what roles already exist, add users to roles, edit and remove roles, and send connection key files to users assigning them a role.

3 Select the role whose settings you want to modify, and then click Edit Role Settings.

The Edit Role Settings dialog box appears. The Edit Role Settings dialog box lets you modify the settings associated with each role.
4 Select a settings category to modify.
For more information about the role settings you can modify in a specific category, see the following sections:
- “Setting general role settings” on page 217
- “Setting folder and file access settings” on page 218
- “Setting page-editing and paragraph settings” on page 220
- “Setting the option for inserting HTML Code Snippets” on page 221
- “Setting style and font settings” on page 221
- “Settings for new web pages” on page 223
- “Setting options for file placement” on page 225
- “Setting options for shared assets” on page 226
- “Setting options for new images” on page 224

5 Modify the settings for the role.
When you finish defining the role, click OK to save your changes. The Role dialog box closes, returning you to the Administer Website dialog box.

6 Select another administrative category to modify, or click Close to apply your changes and exit the Administer Website dialog box.
Setting general role settings

The General category lets you specify a starting (home) page that users in the selected role see when they enter the website. For example, if users in a given role are assigned to a section of the site that excludes the site's home (or main) page, you might consider specifying a page elsewhere in the site as the starting page for that role.

To set general website settings for a role:
1. Open the Edit Role Name Setting dialog box, if it’s not already open. (See “Editing a role’s settings” on page 214.)
2. Click the General category on the left side of the dialog box.
3. (Optional) Select Allow users to publish files.
   
   If you select this option, users assigned to this role can publish pages they create. They can also publish or delete drafts sent to them for review.

   Providing publish and delete restrictions for draft reviews lets users delete and publish drafts sent to them by other Contribute users. Before allowing a user to publish and delete drafts, carefully consider if their assigned role should be given this level of control in the publishing of documents. You might need to create a specific role with this permission enabled.

   Users without draft publishing and deleting permissions can only send drafts for review or edit drafts in the review process. For more information about the draft review process, see “Getting web page drafts and files reviewed by others” on page 41.
4. In the Role description text box, enter a brief description of the role and its responsibilities.

   This description appears when a user selects a role to join.
5 When you initially defined the website, you specified the website's home page. To let users in the selected role have a more specific home page on the website, enter the URL in the Home page for users in this role text box, or click the Choose button to locate the home page.

You can choose to specify any page on the website as the home page for the specified role.

6 Select another role settings category to modify, or click OK to apply your changes.

**Setting folder and file access settings**

The Folder/File Access settings category lets you limit a role's access to selected folders (or directories) and to any subfolders they contain as well as determine whether users can delete web pages and related files.

### Setting folder access settings

You can choose to limit user access to specific folders on the website or to allow users to access all the folders in the defined website.

**To define folder access settings:**

1. Open the Edit Role Name Settings dialog box, if it's not already open. (See “Editing a role's settings” on page 214.)
2. Click the Folder/File Access category on the left side of the dialog box.
3. Select Allow users to edit files in any folder to let users access all folders and files on the website's root, or select Only allow editing within these folders to limit access to a specific subfolder or group of subfolders.
4. If you've selected Only allow editing within these folders, specify folders by clicking Add Folder.
The Choose Folder dialog box appears.

5 The Choose Folder dialog box displays all folders and files under the website's root.
You can preview pages on the website by selecting them. This lets you see which pages you are restricting access to.

6 Navigate to the folder you want to provide access to, and click Select Folder.
For example, if the website's root is http://www.mysite.com and you want to specify that users can edit only those
pages that are in the folder labeled marketing, click the marketing folder. The access path appears as:
http://www.mysite.com/marketing.
The Choose Folder dialog box closes, and the selected folder appears in the Folder access list. You can add folders to
the Folder access list to give users access to multiple directories on the website.

7 Click OK.
When the next Contribute user connects to this website, they can edit only those pages and files that are inside the
listed folders.

To change access to a folder in the list, do one of the following:
• To remove a folder from access, select the folder in the folder list, and then click Remove.
• To change a folder the user can access, select the folder in the folder list, and then click Edit.

Setting file-deletion settings
You can allow users to delete pages from the web server. When determining whether users should be able to remove
a page from the website, carefully consider whether you want to maintain a backup copy of deleted pages.
If you do want to maintain backup copies, you must make sure that the Contribute rollback feature is enabled. To
learn more about web page rollbacks, see “Enabling and disabling rollbacks” on page 194.

To let users delete files from the web server:
1 Open the Edit Role Name Settings dialog box, if it's not already open. (See “Editing a role's settings” on page 214.)
2 Click the Folder/File Access category on the left side of the dialog box.

3 Select Allow users to delete files they have permission to edit.

4 You can also choose to remove any rollback files associated with a page by selecting Remove rollback versions on delete. Carefully consider whether you want to maintain backup copies of web pages before allowing users to delete both an active web page and any rollbacks versions of that page.

5 Select another settings category to modify, or click OK to apply your changes.

If a user deletes a file, but not the rollback copies of the file, the file can be recovered from the rollback copy. For more information, see “Rolling back to a previous version of a page” on page 166.

Setting page-editing and paragraph settings

The Editing category lets you specify what kinds of changes users can make to the website's web pages and how Contribute treats paragraphs and typographic elements.

To set page-editing settings:

1 Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Editing a role’s settings” on page 214.)

2 Click the Editing category on the left side of the dialog box.

The Editing category provides options that let you specify which page-editing attributes Contribute applies. When you set these options, carefully consider who the content contributors are and what page-editing capabilities they require.

3 Change options in the following sections as necessary:

• The General editing restrictions: This section lets you specify what kinds of changes users can make to pages.
• The Paragraph spacing: This section lets you specify how Contribute applies HTML paragraph tags, which determines whether blank lines appear between paragraphs as a user types.

• The Other editing options: This section gives you more editing options.

Note: In Contribute CS3, Users can insert HTML code snippets in web pages if you select the Allow HTML Snippet Insertion option. For more information, see "Setting the option for inserting HTML Code Snippets" on page 221.

4 Select another role settings category to modify, or click OK to apply your changes.

Setting the option for inserting HTML Code Snippets

Based on permissions granted by the Administrator to user roles, users can perform relevant operations in Adobe Contribute CS3.

To allow users to insert HTML snippets in Contribute pages:

1 Open Contribute.

2 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and choose a site to administer.

If the Administrator Password dialog box appears, enter the administrator password and click OK.

The Administer Website dialog box appears.

3 Select Users and Roles. Select Administrator, and then click Edit Role Settings.

The Edit "Administrator" Settings dialog box appears.

4 Select Editing from the list on the left.

The settings appear on the right.

5 Select Allow HTML Snippet Insertion.

By default, the Allow HTML Snippet Insertion option is enabled only for a blog site. You must manually edit the bloghub.csi file to disable this feature for blog sites.

Note: If your website Administrator has not enabled the Allow HTML Snippet Insertion option for your user role, the HTML Snippet option in the Insert menu will be disabled. By default, this option is not enabled for websites.

6 Click OK to apply your changes.

Note: This feature is applicable also on the Macintosh platform.

Setting style and font settings

The Styles and Fonts category in the Role dialog box lets you control whether typographic styles and fonts appear in the Contribute toolbar and which kinds of typographical styles users can apply to text.

To set the style and font settings for a website:

1 Open the Edit Role Name Settings dialog box, if it's not already open.
2 Click the Styles and Fonts category on the left side of the dialog box.

3 Select a style setting from the Style support pop-up menu. The style and font options vary based on what option you select from the pop-up menu.

The Style Support options are:

**Don't allow users to create styles** prevents users from creating styles. Users cannot modify any text and style formatting options.

**Document-level CSS** lets you determine whether users can create CSS styles in the document and to what degree they can apply CSS styles from existing CSS style sheets.

**HTML tags** lets you determine whether users can create HTML styles, and to what degree they can modify and apply styles on the website.

4 Modify the style settings for your chosen style support option as necessary.

For more information about options in this dialog box, click the Help button in the dialog box.

5 Select another role settings category to modify, or click OK to apply your changes.

**Limiting available CSS styles**

Although CSS style sheets often include many style definitions, you may want to limit the number of styles available to a given Contribute user role. Limiting available styles to those necessary for updating information in the body of a web page can help to eliminate potential stylistic editing mistakes by content editors with limited knowledge of web pages and CSS styles.
Contribute lets you limit the number of CSS styles available in the Style menu by selecting a CSS style sheet from which to filter styles for a given role. The filter file you select can include only those styles you want the members of that role to have access to, or you can create individual CSS style sheets for each role, and select them as the CSS styles to use for that role.

To limit the number of available CSS styles:
1. Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Editing a role’s settings” on page 214.)
2. Click the Styles and Fonts category on the left side of the dialog box.
3. From the Style support pop-up menu, select Document-level CSS.
4. Select the following options:
   • Allow users to apply styles
   • Include CSS styles in the Style menu
   • Show only CSS styles included in the CSS file
5. Click Choose.
   The Choose File or Blog Entry dialog box shows all folders and files under the website’s root.
6. Navigate to the CSS style sheet whose styles you want to let users access from the Styles menu.
7. Select the CSS style sheet, and then click OK.
8. Select another role settings category to modify, or click OK to apply your changes.

Settings for new web pages
The New Pages category in the Edit Role Name Settings dialog box lets you specify whether users can create blank pages or create duplicate pages by copying the current page. You can also define which Dreamweaver templates users are able to see and use.

To set the new pages options for a website:
1. Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Editing a role’s settings” on page 214.)
2 Click the New Pages category on the left side of the dialog box.

3 Change options as necessary.

Contribute lets you control the types of new pages that users can create, and it lets you specify templates for creating pages.

When specifying the new page types that users are able to create, carefully consider the look and feel of the website. In many cases, it may be best to constrain users either to use copies of existing pages or to use only Dreamweaver templates, if they are available.

For more information about options in this dialog box, click the Help button in the dialog box.

4 Select another role settings category to modify, or click OK to apply your changes.

**Setting options for new images**

You can use the New Images category of the Role dialog box to specify whether users can import images, specify whether users can edit images, limit the maximum file size of an image a user can add to a page, and reduce images larger than a size you specify.

**To set the new images options for a website:**

1 Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Editing a role’s settings” on page 214.)
2 Click the New Images category on the left side of the dialog box.

3 Specify the options Contribute uses to restrict the adding of images to a page.
   For more information about options in this dialog box, click the Help button in the dialog box.

4 Select another role settings category to modify, or click OK to apply your changes.

**Setting options for file placement**

Contribute lets you specify what folders into which you can copy different file types. The file types include images, linked documents (such as Microsoft Office documents and Acrobat PDF files), and Adobe® Flash® content. By default, Contribute places these files relative to the web page that they are linked to.

**To set the file placement options for a website:**

1 Open the Edit Role Name Settings dialog box, if it's not already open. (See “Editing a role's settings” on page 214.)
2. Click the File Placement category on the left side of the dialog box.

3. Specify the rules Contribute uses to place files as necessary.

   For more information about options in this dialog box, click the Help button in the dialog box.

4. Select another role settings category to modify, or click OK to apply your changes.

**Setting options for shared assets**

Contribute lets users add images, Adobe® Flash® content, or Adobe's Dreamweaver library items to your website from a list of shared assets. The website administrator can make shared assets available to users by adding assets to the list so that they are available to most or all users. Then users can insert assets from the list as they need them.
For more information, see “Inserting shared assets into a web page” on page 103.

You can modify your Shared Assets list as follows:

- Add image files, Flash content, and Dreamweaver library items to your list of shared assets.
  
  The assets you add to your Shared Assets list must already be on the server; Contribute does not upload the files for you. You can use Contribute to browse to files and then add them to a central list for users.

- Remove shared assets from your list.
  
  You can remove shared assets from individual lists for specific roles or from one list that applies to the entire website.

- Change shared asset properties.
  
  Properties include the name used to refer to the asset, alternate text for images, and the editing attribute for Dreamweaver Library items.

You create one Shared Assets list for all roles in your website, or you customize these lists for each role.

⚠️ If different roles are restricted to different shared assets, it’s a good idea to add all shared assets for the website at once and then modify the list for each role. It’s more efficient to add the shared assets once and delete as necessary than to add the same assets several times.

**To add shared assets, delete shared assets, or modify shared asset properties for an entire website or for a specific role:**

1. Open the Edit Role Name Settings dialog box, if it’s not already open. (See “Editing a role’s settings” on page 214.)

   **Note:** If you’re making changes that apply to all roles associated with the website, it doesn't matter which role you select.

2. Select Shared Assets from the list on the left.
The Shared Assets settings appear.

💡 If you already have shared assets in your list, they are sorted by type alphabetically. To view the list alphabetically, click the Name heading at the top of that column.

3 Do one of the following:
   • To add a shared asset, click the Add button, and then select Image, Library Item, or Flash. You can Shift-click to select multiple assets.
   • To delete a shared asset, select an asset in the pane, and then click the Remove button.
   • To view or change shared asset properties, select an asset in the pane; then click the Edit button.

4 Do one of the following:
   • To let your changes apply to all roles associated with the website, make sure Use this list for all roles is selected.
   • To let your changes apply to the role you selected in the Define Roles dialog box only, deselect Use this list for all roles.

Note: This option applies to the entire list of shared assets showing in the pane. It is not specific to any shared assets that might be selected in the pane.

For more information about options in this dialog box, click the Help button in the dialog box.

5 Click OK.

Managing drafts sent for review

As an administrator, you can view and change the status of drafts that are currently in the draft review process for your website. You can change owners for a draft that has been sent for review, and you can also remove any draft from the draft review process.

Note: For more information about the draft review process, see “Understanding the draft review process” on page 35.

To view drafts in the drafts review process:
1 Select Edit > Administer Websites > Manage Sent Drafts.
The Manage Sent Drafts dialog box appears.

2 Do any of the following:
   • To view a draft, select the draft, and then click View Draft.
   • To transfer ownership of a draft to another person, select the draft, and then click Change Owner.
   • To remove a draft from the draft review process, select the draft, and then click Undo Checkout.

For more information about options in this dialog box, click the Help button in the dialog box.

3 Click Close when you are finished.
Chapter 14: Troubleshooting

This chapter documents common problems that you may encounter as an Adobe® Contribute® CS3 user and provides potential solutions.

This chapter contains the following sections:

• “Problems installing Contribute” on page 229
• “Problems starting Contribute” on page 229
• “Problems creating a connection” on page 231
• “Problems editing a page” on page 233
• “Problems canceling pages” on page 235
• “Problems sending reviews by using e-mail” on page 235
• “Problems publishing a page” on page 235
• “Problems creating documents from templates” on page 236
• “Problems administering Contribute” on page 237
• “Using Contribute with dynamic pages” on page 240
• “Problems with configuring Contribute in RSS aggregators” on page 241

Problems installing Contribute

Contribute is designed to function properly when it is installed on the Windows platform. The following common errors can cause problems when installing the Contribute software:

• Entering an invalid serial number
• Entering the serial number incorrectly
• Installing Contribute on a system that has restricted user permissions

If you encounter problems installing Contribute, verify that you are entering a valid and correct product activation serial number and that the system on which you are installing the software has proper network and disk access for your user account.

Problems starting Contribute

The following sections describe problems you might encounter when starting Contribute:

• “Startup is slow or the application appears to freeze” on page 230
• “The Connection Failure dialog box appears when Contribute is connected to the network” on page 230
• “Contribute doesn’t detect that it is disconnected from the network” on page 230
• “The Dial-up dialog box appears when Contribute is connected to the network” on page 230
Startup is slow or the application appears to freeze

When you start Contribute, it opens a connection to each website defined in the My Connections dialog box. If you have many Contribute websites defined, the application may be slow and unresponsive at first. To alleviate this problem, consider disabling websites that you don’t update on a frequent basis. You can easily enable websites when you need to update them.

For more information, see the following sections:

• “Disabling website and blog connections” on page 208
• “Enabling a website or blog server connection” on page 208
• “Improving application performance by disabling websites” on page 239

The Connection Failure dialog box appears when Contribute is connected to the network

Occasionally, the Connection Failure dialog box appears even though you have an active network connection. This sometimes occurs when Contribute is installed on a computer with other applications that regularly access the network.

Click OK to close the Connection Failure dialog box. If the Connection Failure dialog box continues to appear, verify that your computer is indeed connected to the network, or, if you are using a dial-up connection, that you have successfully established a dial-up connection.

Contribute doesn’t detect that it is disconnected from the network

In some instances, Contribute may be unaware that the network connection is either disconnected or otherwise unavailable. If this occurs, Contribute attempts to connect to the first of your website connections. If it fails and there are more websites to connect to, Contribute displays a dialog box that asks whether you want to continue trying to connect to your remaining websites. If you click Yes, Contribute displays the same dialog for each website (provided you click Yes each time). If you click No, Contribute disables the remaining websites.

Even if you click Yes, Contribute disables the website if it is unable to connect to it. When this occurs, Contribute does not display the Working Offline page, but instead lists each website as disabled. To work offline, select File > Work Offline (Windows) or Contribute > Work Offline (Macintosh). To connect to your websites, verify that your computer is connected to the network and that the network is operational.

The Dial-up dialog box appears when Contribute is connected to the network

By default, the Microsoft Internet Explorer web browser is configured to automatically dial a network connection if a connection is not present. In some instances, when Contribute is started, this can cause Contribute to attempt to dial the network connection.

To prevent this from occurring, you can update the Internet Explorer connection settings to never dial up a network connection.

To disable dial-up networking in Internet Explorer:
1  Start Internet Explorer if it is not already running.
2  Select Tools > Internet Options.
The Internet Options dialog box appears.

3 Click the Connections tab.

4 Select either Never dial a connection or Dial whenever a network connection is not present under Dial-up settings.

5 Click Apply.

6 Click OK.

**Contribute reports that the user is not in a valid role**

If the user’s role is deleted or changed by the administrator, or if the user created the connection, he or she can start the Connection Wizard (Windows) or Connection Assistant (Macintosh) to create a connection, and then select a valid role. If the user imported a changed connection key, the administrator can send the user a new connection key containing a valid role to import.

For more information, see “Sending connection keys for websites” on page 200.

**Problems creating a connection**

The following sections describe problems you may encounter when creating a connection with Contribute:

- “Can’t view the My Connections dialog box” on page 231
- “Can’t move to the next screen in the Connection Wizard” on page 231
- “Connection Wizard can’t locate the remote folder” on page 231
- “LAN connection can’t locate the remote folder” on page 232
- “FTP dialog box fails to accept your user name and password” on page 232

**Can’t view the My Connections dialog box**

If you cannot view the My Connections dialog box, or edit your connections, Contribute may be in offline mode. Click the Work Online button to connect to your server.

**Can’t move to the next screen in the Connection Wizard**

If you cannot navigate to the next screen of the Connection Wizard (Windows) or Connection Assistant (Macintosh), you may have entered the connection information incorrectly. Verify that you have entered the correct website address, server name, user name, password, and network path. If these items are correct, verify that the website is online using your computer’s web browser.

**Connection Wizard can’t locate the remote folder**

When you enter FTP or SFTP connection information into Contribute, the Connection Wizard verifies that the FTP folder is the same folder that contains your website’s files. If these folder paths don’t match, Contribute cannot write to the page displayed by your browser. For this reason, your FTP folder must have proper read/write access.

On UNIX® servers, such as Apache, public-read bit is set for files and public-execute bit is set for web directories.
To ensure that the website and FTP folder are the same, Contribute uploads a temporary file using the FTP host information you provide. The Connection Wizard uses the website's address to “guess” the FTP path. Contribute then attempts to read the temporary file through HTTP using the web address you provided. If Contribute succeeds in locating the temporary file, the paths match, and the Connection Wizard creates the connection.

If the paths don't match, the Connection Wizard prompts you for the correct FTP path, because Contribute was unable to guess the path.

To ensure that you are entering the correct FTP path, use the Connection Wizard's Browse button to locate and select the FTP folder. If the path to the folder is correct, ensure that the folder has the proper read/write permissions for the user. If you are creating an anonymous FTP account, the server must be configured to support delete, rename, and overwrite privileges for the anonymous user.

To learn how to check your server's FTP and folder permissions, refer to the documentation supplied with your server operating system.

To give specific permission groups access to subfolders of a read-only FTP root, do one of the following:

- Write-enable the root folder.
- Create a unique connection for each subfolder in the root folder, and write-enable these subfolders.

**LAN connection can’t locate the remote folder**

If the local area network (LAN) can't locate the remote folder containing your web pages, consider the following solutions:

- The remote folder must be set to shared to be visible to the network and any clients attempting to connect to it.
- The folder must have proper read, write, delete, overwrite, and change permissions.

**To check whether a folder is visible to your local area network:**

1. Select Start > Run from the Windows Start menu.

   The Run dialog box appears.

2. Enter the network path to the folder in the Open text box, and click OK.

   For example, enter `\MyServer\MyFolder`.

3. Verify that the folder is visible to the network and that you have proper file access permissions.

**FTP dialog box fails to accept your user name and password**

Ensure that you are entering the correct user name and password for the specified FTP or SFTP server. The FTP user name and password may be different from your computer's login information.
Note: If you enter a user name and password many times without successfully logging in to the server, the FTP server may be configured to reject all future attempts. If this appears to be the case, you may need to exit the application and attempt to log in again or contact your administrator to unlock the account if it has been locked.

Problems editing a page

The following sections describe problems you may encounter when editing a page:

• “Edit Page button is not visible” on page 233
• “Edit button is disabled” on page 233
• “Clicking the Edit button displays an error message” on page 234
• “Clicking Edit Page displays a different page” on page 234

Edit Page button is not visible

If the Edit Page button is not visible for a page you browse to, ensure that you have a connection to that website, and that you have permission to edit the displayed page. For more information, see the following sections:

• “Creating a website connection” on page 183
• “Setting folder and file access settings” on page 218

If the website has alternate web addresses (for example, you are browsing to the page using an IP address instead of the website's DNS name), you may need to configure Contribute to recognize these addresses. For more information, see “Specifying alternative website addresses” on page 197.

You might be experiencing a network or server abnormality. Try refreshing the page or using the Back and Forward buttons to navigate to the page a second time.

Edit button is disabled

There are several reasons why the Edit button may be disabled for a certain page:

• When you browse to a page, Contribute checks whether you have permission to edit that page on the website. Depending on network traffic and server response, this can take a few moments (during this time, the Edit Page button is dimmed).
• The page may be locked for editing by another user. Contribute should display a message that the file is locked and provide the contact information for the user who is editing the file.

In some instances, you may need to remove a lock file to allow access to the page. For more information, see “You need to override a file checkout” on page 239.

• The user may not have write permission to either the server, the folder containing the web page, or the page. To learn how to check the server's folder permissions, see the documentation supplied with the server operating system.
• The specified URL may point to a directory listing, and not to a specific page. Click a page to display it, and navigate to the page you want to edit.
• When you go to a website, Contribute lists the directory's contents if no index file is there. Click a page to display it, and navigate to the page you want to edit.
• The file type may not be editable by Contribute.
• The page may not exist because it has been deleted or because the user entered the wrong page filename.
• The path to the file may exceed the system's maximum character length.
• The correct Contribute Startup password was not entered.
• On the Macintosh, the server volume is not mounted on the computer desktop.

**Clicking the Edit button displays an error message**
The user may not have proper read/write permissions on the server to edit the page, or the shared settings file may be corrupt or changed.
To learn how to check the server's folder permissions, refer to the documentation supplied with the server operating system.
If the server's read/write permissions are properly set, you may have a corrupt shared settings file. If this is the case, you must delete the shared settings file from the web server and create a shared settings file.

**To delete the shared settings file:**
1. Connect to the server, either by mounting it on your desktop (Macintosh) or by logging in to it (using an FTP client, telnet, SSH, or similar software).
   *Note:* You can't perform this procedure from a web browser.
2. On the server, open the root folder of your Contribute website, and then open the _mm folder that's inside the root folder.
   A typical Windows directory path for the _mm folder might be:
   \myServer\wwwroot\mySite\_mm
   A typical UNIX directory path for the _mm folder might be:
   /myServer/webServer/mySite/_mm
3. Delete the shared settings file.
4. Using Contribute, select Edit > Administer Websites, and then select the website whose shared settings file you deleted.
   A dialog box appears informing you that the website has no administrator and asking whether you want to become the administrator for the website. Click Yes to become the website administrator.
5. You are asked to enter an administrator password.
   Enter and confirm the new password, and click OK.
   The Administer Websites dialog box appears.
6. Click Done, or proceed to administer the website.

**Clicking Edit Page displays a different page**
If you click the Edit Page button and Contribute displays a page other than the one you want, the index page file mapping may be incorrectly configured in the Administration settings in Contribute. To learn more, see “Web server index pages” on page 180.
To check the index page mapping:
1 Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and select the website you want to administer from the submenu.
2 If prompted, enter the Administrator password, and then click OK.
   The Administer Website dialog box appears.
3 Select the Web Server category on the left side of the dialog box and click the Index Files tab.
   The Index Files panel appears, showing a list of index pages.

Problems canceling pages

The following sections describe problems you may encounter when canceling pages in Contribute:

The Cancel button isn’t visible when you are reviewing a draft, which means you may inadvertently be working offline. Select File > Work Offline (Windows) or Contribute > Work Offline (Macintosh) to reconnect to the server.

Clicking the Cancel button reports an error if the web server is unavailable or if the user’s permissions on the server are not correctly set. Ensure that the web server is online, and that the server’s read/write permissions are properly set.

Problems sending reviews by using e-mail

In some situations, Contribute might not be able to find or start your default e-mail application to create the e-mail review message.

Note: On the Macintosh, Contribute works with the following default e-mail applications: Mail, Eudora, and Entourage.

If Contribute cannot find or start your default e-mail application, you can create the e-mail message by clicking the Click here link in the message area under the toolbar. Copy the web address (URL) for the draft that appears in the browser window, and paste the address in an e-mail message to send to reviewers.

Problems publishing a page

The following sections describe problems you may encounter when publishing a page with Contribute:

Publish button isn’t visible when you are reviewing a draft:
   • You may be working offline. Select File > Work Offline (Windows) or Contribute > Work Offline (Macintosh) to reconnect to the server.
   • Your assigned role may not have publish permission. Confirm with the Contribute administrator if the role to which you are assigned has publishing permission.

Clicking the Publish button reports errors for a certain page and might have one of the following reasons:
   • The server may be offline or otherwise unavailable.
Ensure that the web server is running by browsing to the website using your computer’s web browser.
• The user’s permissions to either the server itself, the folder containing the web page, or the specific page may have changed.

Ensure that the user has the correct file and folder access permissions. To learn how to check the server’s file and folder permissions, refer to the documentation supplied with the server operating system.

• The folder containing the page that the user wants to publish to may have been deleted, or does not exist.

Save the page to another folder on the website, or create an appropriate folder for the page.

• Another user may have locked the page. This can occur if a user with Dreamweaver MX accesses the file and resets the lock file.

Check whether another user has the file checked out, or whether the lock file is invalid and needs to be forcibly removed. To remove the lock file, see “You need to override a file checkout” on page 239.

### Problems creating documents from templates

The following sections describe problems you might encounter when you create web pages or blog entries from templates with Contribute:

• “Page templates for websites and blogs don’t appear in Contribute” on page 236

• “A new page has broken images or other missing elements” on page 236

#### Page templates for websites and blogs don’t appear in Contribute

If your templates for web pages and blogs don’t show up in Contribute, first click the Refresh Templates button in the New Web Page or Blog Entry dialog box, and then select For all websites or For selected website/blog to download templates. If either of the options For all websites or For selected website/blog appear disabled, verify if you selected the web site or blog for which you want to refresh templates.

If you still cannot see templates for your web pages or blogs, do the following:

• Ensure that the templates are have been properly downloaded from the server. Sometimes the user downloading the templates clicks Cancel partway through the downloading process, canceling the entire file download.

• The permission group the user belongs to might have restricted template access for web pages. For more information, see “Settings for new web pages” on page 223.

• Make sure the template file name contains the .dwt file extension.

• Make sure that all the templates for the website reside in the Templates directory in the site root folder.

#### A new page has broken images or other missing elements

If a user creates a new page from a template that has images or other dependent files, and the links to those files appear broken, it may be that the user doesn’t have access to the directory storing those files. To correct this:

• Ensure that the user has read access to any folders containing images or other referenced page elements (such as Flash movies).

• Check that the template doesn’t contain broken links or invalid syntax.

• Check that the any file upload quotas set on the server are not exceeded.

• Verify that the server’s disk is not full.
Problems administering Contribute

The following sections describe problems you may encounter when administering Contribute:

- “The Administer Websites menu is deactivated” on page 237
- “You forgot the administrator role password” on page 237
- “Contribute freezes when sending a connection key” on page 238
- “A web page is inadvertently deleted” on page 238
- “Users don’t see enough rollback copies of pages” on page 238
- “Improving application performance by disabling websites” on page 239
- “You need to remove a single user from a role” on page 239
- “You need to override a file checkout” on page 239

The Administer Websites menu is deactivated

If the Administer Websites menu is deactivated, ensure that Contribute is working online by selecting File > Work Offline (Windows) or Contribute > Work Offline (Macintosh).

If websites within the Administer Websites pop-up menu are deactivated, they might be disabled. For more information, see “Enabling a website or blog server connection” on page 208.

You forgot the administrator role password

If you forget the password assigned to the Contribute administrator role, you can reset the password by deleting the shared settings file from the website and creating a shared settings file.

Note: If you delete the shared settings file, all the roles you have previously created are lost; you must set up those permissions again.

To delete the shared settings file:

1. Connect to the server, either by mounting it on your desktop or by logging in to it (using an FTP client, telnet, SSH, or similar software).

Note: You can’t perform this procedure from a web browser.

2. On the server, open the root folder of your Contribute website, and then open the _mm folder that’s inside the root folder.

A typical Windows directory path for the _mm folder might be:

\myServer\wwwroot\mySite\_mm

A typical UNIX directory path for the _mm folder might be:

/path_to_the_web_server_doc_root/mySite/_mm/

The shared settings file is an XML file (labeled contribute.xml) in the _mm folder.

3. Delete the shared settings file.

4. Using Contribute, select Edit > My Connection (Windows) or Contribute > My Connection (Macintosh), select the website whose shared settings file you deleted, and click Edit.

5. Re-establish a connection to the site.
6 When you re-define the website connection, select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh) and administer the website to which you are connected. Contribute prompts you to become the administrator of the website.

7 Select Set Administrator Password to become the administrator for the site, and reset the administrator password.

**Contribute freezes when sending a connection key**

If you use a web-based e-mail account (such as Hotmail or Yahoo!) or an e-mail application that Contribute is unable to recognize, the Export Connection Wizard (Windows) or Export Connection Assistant (Macintosh) freezes when you try to automatically attach and send the connection key by e-mail.

To prevent this, save the connection key to your local computer and manually attach it to an e-mail message that you create using your e-mail application.

**A web page is inadvertently deleted**

If a user inadvertently deletes a web page from the web server, you can recreate the page from the rollback copies maintained on the web server. To do this, rollbacks must be enabled, and the option to delete all rollback copies of a page must not be selected. To learn more about page rollbacks, see “Enabling and disabling rollbacks” on page 194.

**To replace a deleted web page:**

1 Browse to the deleted page using Contribute.

To do this, you can either enter the URL of the page or click a link on an existing page that links to the deleted page. When you do this, the web server responds with an HTTP 404 error (page not found).

**Note:** Some web servers are configured so that they redirect you to the website’s home page or a customized error page if a “file not found” error is encountered. If this happens, you can manually copy the page from the _baks directory located at the root of the Contribute website.

2 Select File > Actions > Roll Back to Previous Version.

The Roll Back Page dialog box appears.

3 Select a previous version of the published page from the list of available pages.

**Note:** The list of previously published pages displays as many as 99 of the previous versions of the page.

Contribute displays the page in the Preview section.

4 Click the Roll Back button if the page you selected is the one you want to publish. If it is not the one you want to publish, select another page from the list, and then click Roll Back.

Contribute replaces the currently published version of the page with the previously published version that you selected. The version you selected becomes the current version on the website.

**Note:** The page you replace with the selected rollback page appears in the Roll Back Page dialog box the next time you open the dialog box. You can roll back to that version if you need to.

**Users don’t see enough rollback copies of pages**

If users complain that they don’t see enough rollback copies of pages to revert to, consider increasing the number of rollback files that Contribute maintains.

For more information, see “Enabling and disabling rollbacks” on page 194.
Improving application performance by disabling websites

Under certain conditions, you might want to disable a Contribute website. This prevents Contribute from accessing that website, and potentially hindering the application's performance. You might want to disable a website for any of the following reasons:

- The Contribute application has several websites defined, but only one or two websites are updated regularly.

When you start Contribute, it establishes a connection to each website connection you have defined and maintains an open and active connection during the time the application is running. If you have many websites defined (for example, six or more) but are actively working with only one or two, you may improve application performance by disabling the other websites.

- You’re using a dial-up network that authenticates open connections and disables them after a specified time period.

Many corporate networks terminate connections that remain inactive for extended periods of time. If you have Contribute websites defined that you are not actively working with, you may need to disable these websites to avoid website unavailable errors.

- The website is offline.

If a Contribute website is offline or otherwise unavailable, you may improve performance by disabling the website. When Contribute encounters a website that is unavailable, it displays the error message: “The server serverName is not responding. Contact your system administrator.”

You can retry the connection by clicking the Retry Connection button in the browser toolbar.

- The user’s permission group has been removed.

If a user was a member of a permission group that has been removed, Contribute reports an error when it attempts to load the website.

- You are attempting to connect to websites outside of their firewalls, so some websites connect and others do not.

For more information, see “Disabling website and blog connections” on page 208.

You need to remove a single user from a role

If you are using Contribute Publishing Server (CPS) to manage users, you can remove an individual user from a role or you can reassign that user to a different role.

To learn more, see “Removing users from sites that CPS manages” on page 203.

If you are not using CPS to manage users, Contribute does not support the removal of a single user from a role. To remove a single user from a role, do the following:

- Delete that user’s connection from their personal copy of Contribute. As an added measure, your organization’s network authentication can be configured to prevent the user from having read/write access to the website.

- Rename the role and redistribute it to the users you want to include, and then delete the old role.

To learn more, see “Creating Contribute roles” on page 212.

You need to override a file checkout

If a user has a page open for editing, Contribute creates a lock file (identified by a .lck extension) that prevents other users from editing that page. In the following instances, you may need to delete a lock file to allow another user to edit such a page:
• A user who no longer works for your organization has left a file in a locked state on the server.
• A web administrator or other web professional has locked (checked out) the page using Dreamweaver MX and has left the page in a locked state.
• A system error or other anomaly is preventing a user from checking in a page that they no longer want to edit.

Before overriding a checked out page in Contribute, ensure that the person who last worked with the page really is finished working with it and cannot unlock the page using Contribute or Dreamweaver.

To delete a lock file:
1 Using Contribute, browse to the page you want to unlock.
2 At the end of the page's URL, append the .lck extension to the filename in the Contribute browser such as www.mysite.com/index.htm.lck.
3 Contribute displays the File Placeholder Page.

The File Placeholder Page appears when Contribute encounters a file type that it can't open. Because the Contribute lock file is of a special type, Contribute cannot display it.
4 Select File > Delete Page.

Note: This menu item is disabled if you do not have permission to delete pages from your website. If this is the case, you must enable file deletion for the user's permission group. For more information, see “Setting folder and file access settings” on page 218.

An alert asks whether you are certain that you want to delete the file.
5 Click Yes to confirm that you want to delete the file.

Another alert appears, warning that you are deleting a special file and asking if you want to proceed.
6 Click Yes to confirm that you want to delete the file.

Contribute deletes the lock file and displays the last page you viewed.

Using Contribute with dynamic pages

Contribute is designed to edit HTML content on your website. It is not, however, designed to edit dynamic content stored in a database or to add or edit dynamic tags. Contribute works around your dynamic document code, and provides tools to protect those parts of your web pages and your website that should not be edited by Contribute users.

The Contribute browser is a full-featured web browser that lets users view dynamic pages, enter data into forms, and submit those forms.

Contribute also supports new pages and templates that include dynamic elements. For example, you can create a template that includes ColdFusion tags for initialization, includes, counters, and dynamic data elements. Users can also copy existing dynamic pages. In either case, as the Contribute website administrator, you must ensure that your website's code is protected.

Preventing users from editing dynamic pages
To prevent Contribute users from editing dynamic elements on pages, consider the following precautions:
• Restrict editing to specific folders.
Using the Contribute permission groups, you can limit folder access. For example, if your website includes a dynamic job-listings page, put the page in its own folder and exclude the folder from the list of editable folders on the website. When a Contribute user browses to the folder, the Edit Page button is disabled.

- Lock pages you want to protect by using the server's file-access tools.

Set the file permissions for dynamic pages to read-only. When Contribute users view a dynamic page and click Edit Page, they see a message stating that the page is read-only and is not editable.

- Select Protect scripts and forms in the Contribute administration settings.

**Editing static content in dynamic pages**

You can allow users to edit static content within dynamic pages and protect only the dynamic portions of the page. Contribute users cannot edit source code, nor can they edit anything outside the `<body>` and `<title>` tags of a page. This protects initialization scripts and include files from being edited. To protect dynamic elements in the body of your page, consider the following precautions:

- Use templates to block off dynamic parts of your page. For example, if you have a page that incorporates dynamically generated content (such as `CFLOOP` in ColdFusion or repeating ASP), you can make that page into a template, ensure that those regions of the template are locked, and create an instance of the template. Contribute users can edit only within the specified regions.

You may not want users to create pages from these templates, or copy those pages. To learn how to restrict users from creating pages from your templates or copying those pages, see “Settings for new web pages” on page 223.

- By default, Contribute is set to allow unrestricted editing of non-template pages and to protect scripts and forms from being edited. If you deselect the option that protects forms and scripts, users can modify code embedded in your pages, such as `SCRIPT` tags, server-side includes, ASP, JSP, ColdFusion, and PHP. This option also protects any tag with a nontext character in the tag name, such as `ASP:MyTag`. However, Contribute may not be able to recognize and protect custom tags, such as `myCustomTag`, and the data elements between ColdFusion `CFOUTPUT` tags such as `#...#`.

Users are able to edit plain HTML enclosed in conditional tags (such as the content between `CFIF` and `CFELSE`, and other HTML container tags such as `CFOUTPUT`).

For more information, see “Setting page-editing and paragraph settings” on page 220.

- Limit editing to text-only. Select this option in the Editing category of the Edit Role Name settings dialog box to limit users to only editing and formatting text. For any page not protected by a template, users can edit only text and common text formatting tags (such as `<b>`, `font`, `<span>`, and so on.). No other tags can be selected or deleted. However, HTML content between tags may be editable.

For more information, see “Setting page-editing and paragraph settings” on page 220.

**Problems with configuring Contribute in RSS aggregators**

The following section describes the problems you might encounter when you configure Contribute in RSS aggregators.
Contribute doesn’t appear in the blog publishing tools list in FeedDemon

If you cannot see Contribute in the blog publishing list even after you configure it, check for the following configuration details in FeedDemon:

• Verify if the Command Line or URL text box displays the correct path to the Contribute.exe file.
• Verify if you typed a space and typed -mmPostToBlog after Contribute.exe in the Command Line or URL text box.
Chapter 15: Windows Keyboard Shortcuts

The following sections contain tables listing the Windows operating system keyboard shortcuts for Adobe® Contribute® CS3.

File menu

The following table lists the keyboard shortcuts for performing File menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a page</td>
<td>Control+N</td>
</tr>
<tr>
<td>Open a file on your computer</td>
<td>Control+O</td>
</tr>
<tr>
<td>Close draft</td>
<td>Control+W</td>
</tr>
<tr>
<td>Edit page</td>
<td>Control+E</td>
</tr>
<tr>
<td>Send for review</td>
<td>Control+Shift+S</td>
</tr>
<tr>
<td>Publish</td>
<td>Control+Shift+P</td>
</tr>
<tr>
<td>Edit page source in external application</td>
<td>Control+Shift+E</td>
</tr>
<tr>
<td>Save without publishing</td>
<td>Control+S</td>
</tr>
<tr>
<td>Save for later</td>
<td>Control+Shift+L</td>
</tr>
<tr>
<td>Preview in browser</td>
<td>F12</td>
</tr>
<tr>
<td>Print</td>
<td>Control+P</td>
</tr>
<tr>
<td>Exit/Quit</td>
<td>Control+Q</td>
</tr>
</tbody>
</table>

Edit menu

The following table lists the keyboard shortcuts for performing Edit menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Control+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Control+Y</td>
</tr>
<tr>
<td>Cut</td>
<td>Control+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Control+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Control+V</td>
</tr>
</tbody>
</table>
The following table lists the keyboard shortcuts for performing View menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paste as text</td>
<td>Control+Shift+V</td>
</tr>
<tr>
<td>Clear</td>
<td>Delete</td>
</tr>
<tr>
<td>Select all</td>
<td>Control+A</td>
</tr>
<tr>
<td>Find</td>
<td>Control+F</td>
</tr>
</tbody>
</table>

View menu

The following table lists the keyboard shortcuts for performing View menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open or close sidebar</td>
<td>F4</td>
</tr>
<tr>
<td>Open Draft Console</td>
<td>Control+Shift+D</td>
</tr>
<tr>
<td>Open the browser</td>
<td>Control+Shift+B</td>
</tr>
<tr>
<td>Back</td>
<td>Alt+Left</td>
</tr>
<tr>
<td>Forward</td>
<td>Alt+Right</td>
</tr>
<tr>
<td>Refresh browser</td>
<td>F5</td>
</tr>
<tr>
<td>Select file on website</td>
<td>Control+Shift+O</td>
</tr>
</tbody>
</table>

Insert menu

The following table lists the keyboard shortcuts for performing Insert menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert an image from your computer</td>
<td>Control+Alt+I</td>
</tr>
<tr>
<td>Insert a table</td>
<td>Control+Alt+T</td>
</tr>
<tr>
<td>Insert a link to a web page</td>
<td>Control+Alt+L</td>
</tr>
<tr>
<td>Insert a section anchor</td>
<td>Control+Alt+A</td>
</tr>
<tr>
<td>Add a line break</td>
<td>Shift+Enter</td>
</tr>
<tr>
<td>Add a non-breaking space</td>
<td>Control+Shift+Space</td>
</tr>
</tbody>
</table>

Format menu

The following table lists the keyboard shortcuts for performing Format menu actions in Contribute.
### Table menu

The following table lists the keyboard shortcuts for performing Table menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select a table</td>
<td>Control+T</td>
</tr>
<tr>
<td>Insert a table</td>
<td>Control+Alt+T</td>
</tr>
<tr>
<td>Merge selected cells</td>
<td>Control+Alt+M</td>
</tr>
<tr>
<td>Split selected cell</td>
<td>Control+Alt+S</td>
</tr>
<tr>
<td>Insert a row</td>
<td>Control+M</td>
</tr>
<tr>
<td>Insert a column</td>
<td>Control+Shift+A</td>
</tr>
<tr>
<td>Show table properties</td>
<td>Control+Shift+T</td>
</tr>
</tbody>
</table>

### Working with blog entries

The following table lists the keyboard shortcut for working with blog entries.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Refresh blog entries in the Entries list</td>
<td>Control+Shift+R</td>
</tr>
</tbody>
</table>
Working in templates

The following table lists the keyboard shortcuts for navigating template regions.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to the next editable region</td>
<td>Control+Alt+E</td>
</tr>
<tr>
<td>Move to the previous editable region</td>
<td>Control+Shift+Alt+E</td>
</tr>
</tbody>
</table>

Editing text

The following table lists the keyboard shortcuts for editing text in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a paragraph</td>
<td>Enter</td>
</tr>
<tr>
<td>Insert a line break &lt;BR&gt;</td>
<td>Shift+Enter</td>
</tr>
<tr>
<td>Insert a space</td>
<td>Spacebar</td>
</tr>
<tr>
<td>Insert a non-breaking space</td>
<td>Control+Shift+Space</td>
</tr>
<tr>
<td>Move text or object to another place in the page</td>
<td>Drag selected item to new location</td>
</tr>
<tr>
<td>Select a word</td>
<td>Double-click the word</td>
</tr>
<tr>
<td>Select a paragraph</td>
<td>Triple-click a word in the paragraph</td>
</tr>
<tr>
<td>Indent paragraph</td>
<td>Control+Alt+]</td>
</tr>
<tr>
<td>Outdent paragraph</td>
<td>Control+Alt+[</td>
</tr>
<tr>
<td>Align left</td>
<td>Control+Shift+Alt+L</td>
</tr>
<tr>
<td>Align center</td>
<td>Control+Shift+Alt+C</td>
</tr>
<tr>
<td>Align right</td>
<td>Control+Shift+Alt+R</td>
</tr>
</tbody>
</table>

Working in tables

The following table lists the keyboard shortcuts for performing table actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select cell (with insertion point inside the cell)</td>
<td>Control+A</td>
</tr>
<tr>
<td>Move to the next cell</td>
<td>Tab</td>
</tr>
<tr>
<td>Move to the previous cell</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>Insert a row (above current)</td>
<td>Control+M</td>
</tr>
<tr>
<td>Add a row at end of table</td>
<td>Tab in the last cell</td>
</tr>
</tbody>
</table>
## Working with images

The following table lists the keyboard shortcuts for performing image actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert an image</td>
<td>Control+Alt+I</td>
</tr>
<tr>
<td>Change image properties</td>
<td>Double-click image</td>
</tr>
</tbody>
</table>

## Getting help

The following table lists the keyboard shortcuts for accessing the online help system in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open online help</td>
<td>F1</td>
</tr>
<tr>
<td>Open the Start Page</td>
<td>Alt+Home</td>
</tr>
</tbody>
</table>
Chapter 16: Macintosh Keyboard Shortcuts

The following sections contain tables listing the Macintosh operating system keyboard shortcuts for Adobe® Contribute® CS3.

File menu

The following table lists the keyboard shortcuts for performing File menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a page</td>
<td>Command+N</td>
</tr>
<tr>
<td>Open a file on your computer</td>
<td>Command+O</td>
</tr>
<tr>
<td>Close draft</td>
<td>Command+W</td>
</tr>
<tr>
<td>Edit page</td>
<td>Command+Shift+E</td>
</tr>
<tr>
<td>Send for review</td>
<td>Command+Shift+S</td>
</tr>
<tr>
<td>Publish</td>
<td>Command+Shift+P</td>
</tr>
<tr>
<td>Edit page source in external application</td>
<td>Command+Shift+E</td>
</tr>
<tr>
<td>Save without publishing</td>
<td>Command+S</td>
</tr>
<tr>
<td>Save for later</td>
<td>Command+Shift+L</td>
</tr>
<tr>
<td>Print</td>
<td>Command+P</td>
</tr>
<tr>
<td>Exit/Quit</td>
<td>Command+Q</td>
</tr>
</tbody>
</table>

Edit menu

The following table lists the keyboard shortcuts for performing Edit menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Command+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Command+Y</td>
</tr>
<tr>
<td>Cut</td>
<td>Command+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Command+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Command+V</td>
</tr>
<tr>
<td>Paste as text</td>
<td>Command+Shift+V</td>
</tr>
</tbody>
</table>
The following table lists the keyboard shortcuts for performing View menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clear</td>
<td>Delete</td>
</tr>
<tr>
<td>Select all</td>
<td>Command+A</td>
</tr>
<tr>
<td>Find</td>
<td>Command+F</td>
</tr>
<tr>
<td>Open the browser</td>
<td>Command+Shift+B</td>
</tr>
<tr>
<td>Open Draft Console</td>
<td>Command+Shift+D</td>
</tr>
<tr>
<td>Back</td>
<td>Option+Left</td>
</tr>
<tr>
<td>Forward</td>
<td>Option+Right</td>
</tr>
<tr>
<td>Refresh browser</td>
<td>Command+R</td>
</tr>
<tr>
<td>Choose file or blog entry</td>
<td>Command+Shift+O</td>
</tr>
</tbody>
</table>

The following table lists the keyboard shortcuts for performing Insert menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert an image from your computer</td>
<td>Command+Option+I</td>
</tr>
<tr>
<td>Insert a table</td>
<td>Command+Option+T</td>
</tr>
<tr>
<td>Insert a link</td>
<td>Command+Option+L</td>
</tr>
<tr>
<td>Insert a section anchor</td>
<td>Command+Option+A</td>
</tr>
<tr>
<td>Add a line break</td>
<td>Shift+Return</td>
</tr>
<tr>
<td>Add a non-breaking space</td>
<td>Command+Shift+Space</td>
</tr>
</tbody>
</table>

The following table lists the keyboard shortcuts for performing Format menu actions in Contribute.
Table menu

The following table lists the keyboard shortcuts for performing Table menu actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make selected text bold</td>
<td>Command+B</td>
</tr>
<tr>
<td>Make selected text italic</td>
<td>Command+I</td>
</tr>
<tr>
<td>Underline selected text</td>
<td>Command+U</td>
</tr>
<tr>
<td>Set left alignment</td>
<td>Command+Option+Shift+L</td>
</tr>
<tr>
<td>Set center alignment</td>
<td>Command+Option+Shift+C</td>
</tr>
<tr>
<td>Set right alignment</td>
<td>Command+Option+Shift+R</td>
</tr>
<tr>
<td>Set justified alignment</td>
<td>Command+Option+Shift+J</td>
</tr>
<tr>
<td>Indent a paragraph</td>
<td>Command+Option+J</td>
</tr>
<tr>
<td>Outdent a paragraph</td>
<td>Command+Option+I</td>
</tr>
<tr>
<td>Add a keyword or description</td>
<td>Command+Option+K</td>
</tr>
<tr>
<td>Set page properties</td>
<td>Command+J</td>
</tr>
</tbody>
</table>

Help menu

The following table lists the keyboard shortcut for accessing the Contribute Start page.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open the Start Page</td>
<td>Option+Home</td>
</tr>
</tbody>
</table>

Working in templates

The following table lists the keyboard shortcuts for navigating template regions.
### Editing text

The following table lists the keyboard shortcuts for editing text in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to the next editable region</td>
<td>Command+Option+E</td>
</tr>
<tr>
<td>Move to the previous editable region</td>
<td>Command+Shift+Option+E</td>
</tr>
<tr>
<td>Create a paragraph</td>
<td>Enter</td>
</tr>
<tr>
<td>Insert a line break <code>&lt;br&gt;</code></td>
<td>Shift+Enter</td>
</tr>
<tr>
<td>Insert a space</td>
<td>Spacebar</td>
</tr>
<tr>
<td>Insert a non-breaking space</td>
<td>Command+Shift+Space</td>
</tr>
<tr>
<td>Move text or object to another place in the page</td>
<td>Drag selected item to new location</td>
</tr>
<tr>
<td>Select a word</td>
<td>Double-click the word</td>
</tr>
<tr>
<td>Select a paragraph</td>
<td>Triple-click a word in the paragraph</td>
</tr>
<tr>
<td>Indent paragraph</td>
<td>Command+Option+]</td>
</tr>
<tr>
<td>Outdent paragraph</td>
<td>Command+Option+[</td>
</tr>
<tr>
<td>Align left</td>
<td>Command+Shift+Option+L</td>
</tr>
<tr>
<td>Align center</td>
<td>Command+Shift+Option+C</td>
</tr>
<tr>
<td>Align right</td>
<td>Command+Shift+Option+R</td>
</tr>
</tbody>
</table>

### Working in tables

The following table lists the keyboard shortcuts for performing table actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select cell (with insertion point inside the cell)</td>
<td>Command+A</td>
</tr>
<tr>
<td>Move to the next cell</td>
<td>Tab</td>
</tr>
<tr>
<td>Move to the previous cell</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>Insert a row (before current)</td>
<td>Command+M</td>
</tr>
<tr>
<td>Add a row at end of table</td>
<td>Tab in the last cell</td>
</tr>
<tr>
<td>Insert a column</td>
<td>Command+Shift+A</td>
</tr>
<tr>
<td>Merge selected table cells</td>
<td>Command+Option+M</td>
</tr>
<tr>
<td>Split table cell</td>
<td>Command+Option+S</td>
</tr>
</tbody>
</table>
Working with images

The following table lists the keyboard shortcuts for performing image actions in Contribute.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert an image</td>
<td>Command+Option+I</td>
</tr>
<tr>
<td>Change image properties</td>
<td>Double-click image</td>
</tr>
</tbody>
</table>
Index

Symbols
.Mac accounts
  creating connection 187
Adobe Acrobat Connect content,
  linking to 140
Adobe Bridge CS3
  inserting files in Adobe Contribute
    CS3 16
  integrating with Adobe Contribute
    CS3 16
  opening files in Adobe Contribute
    CS3 16
  publishing files to Adobe
    Contribute CS3 17
Adobe Bridge Home 6
Adobe Contribute CS3
  inserting files from Adobe Bridge
    CS3 16
  integrating with Adobe Bridge
    CS3 16
  opening files from Adobe Bridge
    CS3 16
  publishing files from Adobe Bridge
    CS3 17
Adobe Contribute Publishing Server.
  See CPS.
Adobe CS3 applications
  running startup scripts to integrate
    Adobe Contribute 15
Adobe Design Center 6
Adobe Help 2
Adobe Video Workshop 4
alignment
  images 105
  keyboard shortcuts 252
  keyboard shortcuts for
    Macintosh 250
  keyboard shortcuts,
    Macintosh 252
  keyboard shortcuts, Windows 244,
    246
tables 123
text 92
videos 113
Allow Comments 71
alternative text
  accessibility requirements 32
  images, adding to 100
alternative web addresses
types of 180
applications
  images, editing 109
  web page content, editing in 53
ASP pages 241
audio, blog files 113, 203
AVI files 111
background color
  high setting 30
  web page properties 65
blog entries 38
  browsing 23
  categories, assigning 69
  comments, allowing 71
  creating based on selection 64
  creating based on templates 62
  creating blank 63
  customizing templates 49
  deleting 55
  discarding changes 54
  editing from a browser 39
  editing offline 51
  editing, methods for 65
  enclosures 113
  existing, publishing as new 176
  exporting 55
  features 33, 57
  linking to new blank 136
  metadata, entering 67
  opening for editing 38
  preferences 67
  printing 56
  publishing new 177
  recently published, viewing 25
  saving drafts for later 41
  saving drafts while working 40
  selecting blogs for posting 68
  setting date and time 65
  tagging 69
  templates 36, 47, 62, 236
titles 68
trackback URLs 70

A
about 58
  converting documents to PDF 58
accessibility
  about 32
  high contrast 30
  images 100
  keyboard shortcuts,
    Macintosh 249
  keyboard shortcuts, Windows 243
  keyboard-only navigation 30
  of Help 3
  screen readers 30
accessing 46
  new review draft 46
activation of software 1
Add Bookmark dialog box 27
add to cart
  adding PayPal button 100
adding
  add to cart PayPal button 100
  buy now PayPal button 100
  donation PayPal button 100
  keywords and descriptions to web
    pages 66
  subscription PayPal button 100
  view cart PayPal button 100
Administer Website dialog box
deadivated, troubleshooting 237
administrators
  assigning role 191
  changing 193
  defined 9
documentation for 4
draft review process,
  managing 228
  overriding file checkouts 239
  password, changing 193
  passwords, resetting 237
  roles 211

settings 192
website connections, setting up 12
Adobe Contribute
  adding PayPal button 100
  buy now PayPal button 100
  donation PayPal button 100
  keywords and descriptions to web
    pages 66
  subscription PayPal button 100
  view cart PayPal button 100
  Allow Comments 71
  alternative text
  accessibility requirements 32
  images, adding to 100
  alternative web addresses
types of 180
applications
  images, editing 109
  web page content, editing in 53
ASP pages 241
audio, blog files 113, 203
AVI files 111
background color
  high setting 30
  web page properties 65
blog entries 38
  browsing 23
  categories, assigning 69
  comments, allowing 71
  creating based on selection 64
  creating based on templates 62
  creating blank 63
  customizing templates 49
  deleting 55
  discarding changes 54
  editing from a browser 39
  editing offline 51
  editing, methods for 65
  enclosures 113
  existing, publishing as new 176
  exporting 55
  features 33, 57
  linking to new blank 136
  metadata, entering 67
  opening for editing 38
  preferences 67
  printing 56
  publishing new 177
  recently published, viewing 25
  saving drafts for later 41
  saving drafts while working 40
  selecting blogs for posting 68
  setting date and time 65
  tagging 69
  templates 36, 47, 62, 236
  titles 68
  trackback URLs 70
changing, 179
connections, blog server
about 179
administrators 12
editing information 205
enabling 14, 208
managing 204
refreshing 186
removing 207
renaming 206
selecting for startup 209
setting up 184
supported 182
troubleshooting 230, 231
working offline 13, 50
blog URL
defining to connect to a blog server 186
using to create connection to blog server 186
blogs
dependent files, configuring 203
home pages, viewing 25
posting content from a browser 169
posting content from Microsoft Office 170
posting content from RSS aggregators 172, 241
publishing existing entries as new 176
publishing new entries 177
selecting for posting 68
unlinked files, viewing 26
updating entries 176
workflow overview 11
bold text
formatting 90
keyboard shortcuts, Macintosh 250
keyboard shortcuts, Windows 244
bookmarks
adding 27
deleting 27
viewing 27
Bridge CS3 16
brightness and contrast
high, accessibility settings 30
images, adjusting 106
broken links 159
Browse to Web Page dialog box 137
browser toolbar 20
browsers
blog content, posting 169
editing web pages or blog entries in 39
encoding 29
links, previewing 148
supported 39
targeting links 143
browsing
blog entries 23
Pages panel 21
previewing pages 158
switching to editing 23
toolbars 20
unlinked web page 26
web pages 23
workflow overview 11
workspace 20
bulleted lists, creating 93
buttons, PayPal
about 100
editing 118
inserting multiple 118
inserting single 117
buy now
adding PayPal button 100
C
canceling
troubleshooting 235
Cascading Style Sheets. See CSS.
categorizing blog entries 69
cells, table
copying or cutting 124
formatting conflicts 119
keyboard shortcuts, Macintosh 251, 252
keyboard shortcuts, Windows 245, 246
merging 127
pasting 125
properties 129
selecting 121
splitting 127
centering text 92
Change Administrator Password dialog box 194
color
high-contrast setting 30
text 91
web page properties 65
columns, table
adding 125
deleting 126
formatting conflicts 119
keyboard shortcuts, Windows 245, 246
properties 128
resizing 122
selecting 121
sorting data 131
comments
allowing for blog entries 71
viewing 45
conflicts, user 182
connecting to a blog server
using blog URL 186
Connection Assistant
blog server setup 184
troubleshooting 231
website setup 183
Connection Failure dialog box 230
collection keys
importing 12
security 181
sending for CPS sites 201
sending for websites 200
troubleshooting 231, 238
website connections
  See also connection keys

Connection Wizard
  blog server setup 184
  troubleshooting 231
  website setup 183

connections
  administrators 12
  disabling CPS 189
  editing information 205
  enabling 14, 208
  enabling CPS 188
  information, collecting 182
  managing 204
  removing 207
  renaming 206
  setting up blog server 184
  setting up website 183
  troubleshooting 231
  User Directory service, disabling 190
  working offline 50

connections at startup
  selecting websites and blog servers 209

contrast
  high 30
  images, adjusting 106

Contribute CS3
  integrating with Bridge CS3 16

Contribute editor
  working offline 51
  converting 58
  MS Office documents to PDFs 58

copying
  images 102
  keyboard shortcuts, Macintosh 249
  keyboard shortcuts, Windows 243
  starter pages 60
  table cells 124
  web pages 58

CPS
  adding users 202
  connection keys, sending 201
  disabling for websites 189
  editing connection information 205
  enabling 188
  managing connections 204
  removing connections 207
  removing users 203
  User Directory service, disabling 190
  Create New Entry dialog box 136
  Create New Page dialog box 134
  Create New Role dialog box 213
  creating connections
    .Mac accounts 187
    creating web pages
      refreshing templates 50
    cropping images 107
  CSS
    available styles 85
    creating styles 89
    limiting available styles 222
    page properties 65
    text, applying to 89
    user permissions 221
  customizing templates 49

D
  date
    adding to web page 86
    for publishing blog entry 63
    date and time
      setting for blog entries 65
    default settings. See preferences; properties
    definition lists 94
  Delete Bookmark dialog box 27
  deleted web pages, restoring 238
  deleting
    blog entries 55
    bookmarks 27
    enclosures 115
    links 147
    locked files 239
    permissions for deletion 219
  shared settings file 237
  table cells 124
  table rows and columns 126
  users from roles 239
  web page 54
  web page or blog entry 54
  website connections 207
  dependent files
    blogs 203
    placement options 225
  troubleshooting 236
  descriptions
    images 100
    keyboard shortcuts, Macintosh 250
    keyboard shortcuts, Windows 244
  Design Center 6
  developers, defined 9
  dialog boxes, keyboard-only navigation 31
  Dial-up dialog box, troubleshooting 230
  dictionary, spell check 97
  disabling
    CPS 189
    dial-up networking 230
    individual blog server connection 208
    individual website connection 208
    reenabling website connections 14
    rollbacks 194
  User Directory service 190
  website or blog connections at startup 14
  websites 239
  discarding
    changes to a web page, blog entry, or draft 54
  DNS, multiple aliases 180
  domain name server, multiple aliasing 180
  donation
    adding PayPal button 100
  downloading
    template 77, 78, 79, 80, 168
    downloads
      updates, plug-ins, and tryouts 7
  Draft Console 21, 44
  Draft History 45
  draft review process
    about 35
    e-mailing web pages 45
    keyboard shortcuts, Macintosh 249
    keyboard shortcuts, Windows 243
    managing 228
    reviewing drafts 44
    sending web pages directly to user 43
    sending web pages to website 41, 42
tracking drafts 44
troubleshooting 235
undo sending web pages 43
viewing comments 45
drafts
about 33
comments, viewing 45
discarding changes 54
editing offline 51
linking to 133
removing unpublished 208
reviewing 44
saving for later 41
saving while working 40
spelling, checking 97
tracking 44
viewing 25
Drafts and Recent Pages dialog box 133
Dreamweaver library items
inserting from shared assets 103
permissions 226
Dreamweaver templates
about 36
blog entries 62
creating web pages 62
customizing 49
editing pages based on 47
keyboard shortcuts, Macintosh 251
keyboard shortcuts, Windows 246
permissions 223
properties 48
troubleshooting 236
dynamic pages
code, protecting 240
scripts and forms, protecting 240
static content, editing in 241

E
Edit menu, keyboard shortcuts
Macintosh 249
Windows 243
Edit Section Anchor dialog box 147
editing 38
blog entries 38
browser-based 39
conflicts 182
connection information 205
discarding changes 54
external application files 53
features 33
finding and replacing text 97
frames 153
images 106, 109
keyboard-only navigation 30
link URLs 142
offline 51
overriding locked files 239
Pages panel 21
PayPal buttons 118
permissions 211, 220
redoing 40
section anchors 146
source code 240
spelling, checking 97
starter web pages 61
switching from browsing 23
template regions 36
template-based page 47
text with keyboard shortcuts, Macintosh 252
text with keyboard shortcuts, Windows 246
toolbars for 20
troubleshooting 233
undoing 40
web page content in external application 52
web pages and blog entries 34
web pages from a website 37
workflow overview 11
workspace 20
editing methods
for blog entries 65
editor toolbar 21
E-mail Address dialog box 138
e-mail links 138
e-mail review
keyboard shortcuts, Macintosh 249
keyboard shortcuts, Windows 243
managing 228
process 35
reviewing web pages 44
sending web pages 44
sending web page links 45
sending web pages directly to user 43
sending web pages to website 41, 42
tracking 44
troubleshooting 235
undo sending web pages 43
viewing comments 45
e-mailing connection keys
for CPS sites 201
for websites 200
security 181
troubleshooting 238
embedded PDFs
resizing 83
emphasis text style. See also italic text
Enable Publishing Server dialog box 188
enabling
blog server connections 208
CPS 188
rollbacks 194
website connections 14, 208
enclosures
adding 113
deleting 115
encoding, character 29
Entries list 26
refreshing 55
Excel
folder placement options 225
linking documents to web pages 74, 78
opening documents in Adobe Contribute 75
posting blog content 169, 170
publishing documents 167
Explorer
bookmarks 27
dial-up networking, disabling 230
editing web pages and blog entries 39
posting blog content 169
settings 23
exporting connection keys
for CPS sites 201
for websites 200
security 181
troubleshooting 238
exporting web pages or blog entries 55
external applications
images, editing 109
web page content, editing in 53
Extras 5

F
FeedDemon, posting blog content from 172, 173, 241
file extension, default 195
File menu, keyboard shortcuts
Macintosh 249
Windows 243
File on My Computer dialog box 139
files
deletion permissions 219
folder access permissions 218
linking to 139
missing, troubleshooting 236
overriding checkout 239
placement options 225
publishing 162
replacing on website 163, 164
viewing unlinked 26
Find and Replace command 97
finding. See searching
Firefox
installing plug-ins 39
posting blog content 169
fixed-width text style 90
Flash (SWF) files
folder placement options 225
inserting 103, 110
properties 110
shared asset permissions 226
Folder/File Access options 218
folders
Mac accounts 187
dynamic pages, restricting 240
file placement options 225
FTP, troubleshooting 231
permissions 218
shared settings file 211
troubleshooting remote 232
font installation 2
fonts
adding 88
bold 90
color 91
creating styles 89
encoding 29
italic 90
keyboard shortcuts,
Macintosh 250
keyboard shortcuts, Windows 244
limiting available CSS styles 222
size, changing 87
special characters 87
style permissions 221
styles, applying 89
underlined 90
web page properties 65
Format menu, keyboard shortcuts
Macintosh 250
Windows 244
Format Table dialog box 130
forms, protecting 240
frames
about 151, 152
editing content 153
saving and publishing 154
targeting 152, 154
framesets
about 151, 152
publishing pages 154
FTP
connection information 182
connection keys, sending 181
troubleshooting 231
user name and password, troubleshooting 232
G
Google search functionality
adding 52
graphics. See images
H
headings, applying styles 89
Help 2
help system
How Do I panel 21
keyboard shortcuts,
Macintosh 251
keyboard shortcuts, Windows 247
high-contrast setting 30
highlighting text 91
history, draft 45
home pages
user settings 217, 218
viewing 25
Horizontal Rule Properties dialog box 116
horizontal rules 116
HTML code snippets
editing permissions 221
inserting in Adobe Contribute pages 83
user permissions 221
HTML tags
static content in dynamic pages 241
user permissions 222
hypertext links. See links
I
Image button 101
image editing toolbar 21
Image Properties dialog box 104
images
See also shared assets
adding to web pages 100, 101
alignment 105
alternative text, adding 100
blog files 203
brightness, adjusting 106
contrast, adjusting 106
copying and pasting 102
cropping 107
descriptions, adding 100
dragging onto a page 102
editing in Adobe Contribute 106
editing in external applications 109
folder placement options 225
horizontal rules 116
Insert menu 101
keyboard shortcuts,
Macintosh 253
keyboard shortcuts, Windows 247
moving on a page 105
permissions 224
properties 104
resizing 108
rotating 109
sharpening 107
start pages, editing 61
troubleshooting missing 236
iMovie 111
Import Connection Key dialog box 13
indenting
lists 94
paragraphs 92
index pages
about 180
deleting filenames 197
individual blog server connection
disabling 208
individual website connection
disabling at startup 208
Insert Link dialog box
Browse to Web Page 137
Create New Entry 136
Create New Page 134
Drafts and Recent Pages 133
E-mail Address 138
File on My Computer 139
Insert menu, keyboard shortcuts
Macintosh 250
Windows 244
Insert Microsoft Office Document
dialog box 171
Insert Table dialog box 120
inserting
HTML code snippets in Adobe
Contribute pages 83
MS Office documents as PDFs in
Adobe Contribute 72, 75
PayPal buttons 117
PDFs in Adobe Contribute
pages 82
inserting files
from Adobe Bridge CS3 to Adobe
Contribute CS3 16
installation
troubleshooting 229
integrating
Adobe Bridge CS3 with Adobe
Contribute CS3 16
integrating with Contribute CS3 16
Internet Explorer
bookmarks 27
dial-up networking, disabling 230
editing web pages and blog
entries 39
posting blog content 169
settings 23
italic text
formatting 90
keyboard shortcuts, Macintosh 250
keyborad shortcuts, Windows 244
J
JAWS for Windows screen reader
images 100
settings 32
supported 30
JSP pages 241
justifying text 92
K
keyboard shortcuts for tables
Macintosh 252
keyboard shortcuts in Help 3
keyboard shortcuts, Macintosh
Edit menu 249
File menu 249
Format menu 250
Help menu 251
images 253
Insert menu 250
templates 251
View menu 250
keyboard shortcuts, Windows
blog entries list 245
Edit menu 243
editing text 246
File menu 243
Format menu 244
help system 247
images 247
Insert menu 244
Table menu 245
tables 246
templates 246
View menu 244
keyboard-only navigation 30
keys, connection. See connection keys
keywords and descriptions
adding for web pages 66
L
LAN, troubleshooting 232
languages, encoding 29
library items
Adobe Acrobat Connect, linking
to 140
inserting from shared assets 103
permissions 226
line breaks
adding 92
keyboard shortcuts,
Macintosh 250
keyboard shortcuts, Windows 244
lines, horizontal 116
linking to
Adobe Acrobat Connect
content 140
drafts or recently published
pages 133
e-mail addresses 138
files on your computer 139
new blank blog entries 136
new pages 134
section anchors 145
website pages 137
links
broken 159
deleting 147
destinations, changing 147
enclosures, blogs 113
file placement options 225
Microsoft Word or Excel
documents to web pages 74, 78
previewing in a browser 148
properties, changing 148
publishing web pages 133, 159
section anchors, adding 145
section anchors, editing 146
starter pages, editing 61
targeting frames 152, 154
targeting where a page opens 143
testing 148, 158
text, changing 147
trackback URLs 70
troubleshooting 236
URLs, editing 142
web page properties 65
lists
bulleted 93
definition 94
numbered 93
properties 96
sublists 94
LiveDocs 2
locked files, unlocking 239
locked template regions 36
Macintosh keyboard shortcuts 250
keyboard shortcuts for table rows 251
keyboard shortcuts for tables 252
Macintosh keyboard shortcuts
Edit menu 249
File menu 249
Format menu 250
Help menu 251
images 253
Insert menu 250
templates 251
View menu 250
managing connections 204
draft review process 228
margins, setting web page 65
meetings, linking to Adobe Acrobat
Connect meetings 140
merging table cells 127
metadata, blog entries 67
MetaWeblog API 182
Microsoft Excel
adding content to web pages 73, 76
folder placement options 225
inserting documents as PDF 79
linking documents to web pages 74, 78
opening documents in Adobe Contribute 75
posting blog content 169, 170
publishing documents 167
Movie Maker 111
movies
alignment 113
blog files 113, 203
Flash, inserting 103, 110
Flash, properties 110
inserting 111
moving 113
properties 112
moving images 105
videos 113
Mozilla Firefox
installing plug-ins 39
posting blog content 169
MS Office documents
converting to PDFs 72
inserting in Adobe Contribute 75
My Connections troubleshooting 231
offline, working 50
online help system
How Do I panel 21
keyboard shortcuts, Macintosh 251
keyboard shortcuts, Windows 247
opening
blog entries for editing 38
Microsoft Office documents in Adobe Contribute 75
page in a new window 143
web pages and blog entries without browsing 24
web pages for editing 37
opening Adobe Contribute
changing startup password 29
entering startup password 13
troubleshooting 229
working offline 13, 50, 51
opening files
from Adobe Bridge CS3 in Adobe Contribute CS3 16
opening MS Office documents in Adobe Contribute
setting templates 80
opening without browsing 24
other blog servers
selecting for creating blog servers 186
selecting to connect to a blog server 186
Outlook
opening documents in Adobe Contribute 75
posting blog content 169, 170
publishing documents 167
overriding file checkouts 239
P
Page Properties 65
page separators 116
Pages panel 21
pages. See web pages paragraphs
alignment 92
bulleted lists 93
definition lists 94
indenting 92
keyboard shortcuts 252
keyboard shortcuts for Macintosh 250
keyboard shortcuts, Macintosh 252
keyboard shortcuts, Windows 244, 246
line breaks 92
list properties 96
numbered lists 93
passwords
FTP 232
passwords, administrator changing 193
resetting 237
passwords, startup changing 29
entering 13
pasting
images 102
keyboard shortcuts, Macintosh 249
keyboard shortcuts, Windows 243
table cells 125
PayPal buttons
about 100
add to cart 100
adding 117
buy now 100
donation 100
editing 118
inserting multiple 118
inserting single 117
subscription 100
view cart 100
PDF 58
converting MS Office documents 58
Microsoft Word or Excel documents, inserting 79
PDF documents
inserting MS Office documents in Adobe Contribute 75
PDF files
folder placement options 225
PDFs
inserting as embedded objects 75
inserting as links 75
inserting in Adobe Contribute pages 82
permissions
editing HTML code 221
editing web pages 220
file deletion 219
file placement 225
folder access 218
home page settings 217, 218
images 224
publishing 217
removing 239
role settings 211, 214, 217
See also roles
shared assets 226
shared settings file 211, 237
software code 240
style settings 221, 222
template regions 36
troubleshooting 231
web page creation 223
PHP pages 241
placing files
from Adobe Bridge CS3 to Adobe Contribute CS3 16
plug-ins 5
in Adobe Store 7
podcasts 113
port numbers 181
posting blog content from browsers 169
Microsoft Office 170
RSS aggregators 172, 241
preferences
blog entries 67
role settings 211, 214, 217
setting for Contribute 28
previewing
links 148
web pages 158
printing
keyboard shortcuts, Macintosh 249
keyboard shortcuts, Windows 243
web pages or blog entries 56
properties
Flash content (SWF files) 110
horizontal rules 116
images 104
lists 96
movies 112
table cells 129
table rows and columns 128
tables 128
templates 48
web page 65
Publish File dialog box 164
Publish New Linked Blog Entries dialog box 176
Publish New Linked Pages dialog box 161, 162
Publish New Page dialog box 160
Publish to Website dialog box 167
publisher role 211
publishing
about 157
blog content from a browser 169
blog content from Microsoft Office 170
blog content from RSS aggregators 172, 241
blog entries, new 177
existing blog entries as new 176
existing page as new page 161
files 162
frame pages 154
keyboard shortcuts, Macintosh 249
keyboard shortcuts, Windows 243
linked documents 159
linking to recent pages 133
Microsoft Office documents 167
new web pages 159
permissions 211, 217
previewing links 148
previewing pages 158
replacing files 163, 164
Rollback feature 158, 166
troubleshooting 235
updates to an existing page 159
updating blog entries 176
updating web pages 159
viewing recent web pages and blogs 25
workflow overview 11
publishing blog entry
specifying date and time 63
publishing files
from Adobe Bridge CS3 to Adobe Contribute CS3 17
Q
Quick Time files 111, 115

R
read me file 2
reconnecting to blog servers 186
redoing an edit 40
Refresh Drafts 44
refreshing
blog server connections 186
drafts 44
Entries list 55
refreshing templates
creating web pages 50
registration of software 1
remote folders, troubleshooting
FTP 231
LAN 232
removing. See deleting
renaming
website connections 206
website or blog server
connnections 206
replacing
files on website 163, 164
text 97
Require Adobe Contribute startup
password 13
requirements, system 1
resizing
embedded PDFs 83
images 108
tables 122
reverting to previous version
about 158
enabling and disabling Rollback
feature 194
troubleshooting 238
using Rollback feature 166
review drafts
accessing new drafts 46
reviewing drafts
about 35
e-mailing web pages 45
keyboard shortcuts,
Macintosh 249
keyboard shortcuts, Windows 243
managing 228
reviewing web pages 44
sending web pages directly to
user 43
sending web pages to website 41,
42
tracking 44
troubleshooting 235
undo sending web pages 43
viewing comments 45
roles
about 211
administrator, assigning 191
administrator, changing 193
creating new 212
draft review management 228
home page settings 217, 218
removing from users 239
settings 214
settings, general 211, 217
shared settings files 211
troubleshooting 231
types of 211
See also permissions
Roll Back Page dialog box 166
Rollback feature
about 158
troubleshooting 238
using 166
rotating images 109
rows, table
adding 125
deleting 126
formatting conflicts 119
keyboard shortcuts, Windows 245,
246
properties 128
resizing 122
selecting 121
RSS aggregators, posting blog content
from 172, 241
running startup scripts in Adobe CS3
applications
integrating Adobe Contribute 15
settings
Contribute preferences 28
date and time for blog entries 65
setting templates
while opening MS Office
documents in Adobe
Contribute 80
setup
troubleshooting 229
SFTP
collection information 182
troubleshooting 231, 232
S
Save As 161
Save for Later command 41
saving drafts
exporting web pages or blog
entries 55
for later 41
keyboard shortcuts,
Macintosh 249
keyboard shortcuts, Windows 243
Publish as New Page 161
while working 40
screen readers
accessibility settings 32
images 100
supported 30
scripts, protecting 240
searching
Google functionality, adding to
websites 52
text 97
Section Anchor dialog box 145
section anchors
about 211
adding 145
editing 146
keyboard shortcuts,
Macintosh 250
keyboard shortcuts, Windows 244
linking to 145
security
administrator password,
changing 193
connection keys, sending 181
startup password 13, 29
Select a Frame to Edit dialog box 153
Select Website dialog box 163
selecting
template 77, 78, 79, 80, 168
Send for Review 42
sending connection keys
for CPS sites 201
for websites 200
security 181
troubleshooting 238
setting
Contribute preferences 28
date and time for blog entries 65
setting templates
while opening MS Office
documents in Adobe
Contribute 80
setup
troubleshooting 229
SFTP
collection information 182
troubleshooting 231, 232
shared assets
  inserting into a page 103
permissions 226
shared settings file
  deleting 237
  storing permissions 211
sharpening images 107
shortcuts, Macintosh
  Edit menu 249
  File menu 249
  Format menu 250
  Help menu 251
  Insert menu 250
  templates 251
  View menu 250
shortcuts, Windows
  Edit menu 243
  editing text 246
  File menu 243
  Format menu 244
  help system 247
  images 247
  Insert menu 244
  Table menu 245
  tables 246
  templates 245, 246
  View menu 244
sidebar
  parts of 21
  resizing 22
slow startup
  troubleshooting 230
slow startup, troubleshooting 239
software
  activation 1
  registration 1
software downloads 7
Sort Table dialog box 131
source code
  protecting 240
  viewing 158
spacing
  keyboard shortcuts 252
  keyboard shortcuts, Macintosh 250, 252
  keyboard shortcuts, Windows 244, 246
special characters 87
speed, troubleshooting 239
spelling, checking
  commands 97
  keyboard shortcuts, Macintosh 250
  keyboard shortcuts, Windows 244
Split Cell dialog box 127
stand-alone web pages, creating 63
starter web pages
  copying 60
  editing 61
starting Adobe Contribute
  changing password 29
  entering password 13
  troubleshooting 229
  working offline 13, 50, 51
startup
  disabling website or blog server connections 14
startup password
  changing 29
  entering 13
startup scripts in Adobe CS3 products
integrating Adobe Contribute with Adobe CS3 applications 15
startup speed
  troubleshooting 230
strike-through text 90
strong text style
style sheets
  available 85
  creating styles 89
  limiting available 222
  page properties 65
  text, applying to 89
  user permissions 221
sublists 94
subscription
  adding PayPal buttons 100
SWF files
  folder placement options 225
  inserting 103, 110
  properties 110
  shared asset permissions 226
symbols
  encoding 29
  special characters 87
system requirements 1
T
table cells
  copying or cutting 124
  formatting conflicts 119
  keyboard shortcuts, Macintosh 251, 252
  keyboard shortcuts, Windows 245, 246
  merging 127
  pasting 125
  properties 129
  selecting 121
  splitting 127
table columns
  adding 125
  deleting 126
  formatting conflicts 119
  keyboard shortcuts, Macintosh 251, 252
  keyboard shortcuts, Windows 245, 246
  properties 128
  resizing 122
  selecting 121
  sorting data 131
Table menu, keyboard shortcuts
  Windows 245
Table Properties dialog box 128
table rows
  adding 125
  deleting 126
  formatting conflicts 119
  keyboard shortcuts for Macintosh 251
  keyboard shortcuts, Windows 245, 246
  properties 128
  resizing 122
  selecting 121
tables
  alignment 123
  formatting conflicts 119
  keyboard shortcuts for Macintosh 252
  keyboard shortcuts, Windows 246
  keyboard-only navigation 31
  preset formats 130
  properties 128
  resizing 122
INDEX

265

INDEX

selecting a table, row, or column 121
selecting cells 121
sort by options 131
sorting data 131
tagging blog entries 69
targeting frames 152, 154
links 143
section anchors 145
template
choosing 77, 78, 79, 80, 168
downloading 77, 78, 79, 80, 168
templates
blog entries 62
creating web pages 62
customizing 49
editable regions 36
editing pages 47
keyboard shortcuts, Macintosh 251
keyboard shortcuts, Windows 246
permissions 223
properties 48
refreshing while creating web pages 50
setting for MS Office documents 80
starter web pages, copying 60
starter web pages, editing 61
tables, preset formats 130
troubleshooting 236
Web developers, defined 9
text
adding to a web page 86
alignment 92
bold 90
color, setting 91
creating styles 89
encoding 29
finding and replacing 97
font, changing 87
fonts, adding 88
formatting 90
highlighting 91
indenting 92
italic 90
keyboard shortcuts, Macintosh 252
keyboard shortcuts, Windows 246
limiting available CSS styles 222
line breaks 92
link, changing 147
paragraph spacing 92
screen readers 30, 32
special characters 87
spelling, checking 97
starter pages, editing 61
styles, applying 89
underlined 90
user permissions 221
time
for publishing blog entry 63
toolbars
blog metadata 21
browser 20
editor 21
image editing 21
sidebar 21
workspace 19
trackback URLs, blog entries 70
tracking drafts 44
troubleshooting
Administer Websites dialog box 237
canceling pages 235
connection keys 238
Connection Wizard or Assistant 231
connections 231
disabling websites 239
editing web pages 233
e-mail reviews 235
FTP 231, 232
installation 229
LAN 232
network connections 230
publishing 235
restoring deleted web pages 238
roles 231
slow startup 230
starting Adobe Contribute 229
templates 236
tryouts 7

u
underlined text 90
undo
editing 40

keyboard shortcuts, Macintosh 249
keyboard shortcuts, Windows 243
sending drafts for review 43
unlinked pages
viewing 26
unlocking files 239
unpublished drafts, removing 208
unpublishing pages
about 158
using Rollback feature 166
updates 7
updating
blog entries 176
templates 77, 79, 80, 168
web pages 159
updating templates 78, 168
URLs
about 182
alternative 180
links, editing 142
User Directory service
adding users to a website 202
disabling 190
removing users from a website 203
user names
FTP, troubleshooting 232
users
administrator role, assigning 191
conflicts 182
CPS 202
creating roles 212
defined 9
documentation for 4
draft review management 228
FTP, troubleshooting 232
home page settings 217, 218
removing from a CPS site 203
removing from roles 239
role settings 211, 214, 217
See also permissions
shared settings file 211
troubleshooting 231
workflow overview 11

v
versions, reverting to previous
about 158
enabling and disabling Rollback feature 194
troubleshooting 238
using Rollback feature 166
video
  alignment 113
  blog files 113, 203
closures, blog entries 113
Flash, inserting 103, 110
Flash, properties 110
inserting 111
moving 113
properties 112
Video Properties dialog box 112
Video Workshop 4
view cart
  adding PayPal button 100
View menu, keyboard shortcuts
  Macintosh 250
  Windows 244
viewing
  blog entries 26
  bookmarks list 27
  comments for drafts 45
drafts 25
home pages 25
recently publishing web pages and blogs 25
unlinked pages and files 26
virtual servers 181
W
Web developers, defined 9
web page
  deleting 54
web page content
  editing in external application 52
web page or blog entry
  deleting 54
web pages
  accessibility 32
  adding keywords and descriptions 66
  browsing 23
  copying 58
  creating blank 59
date, adding 86
discard changes 54
dynamic 240
deleting offline 51
exporting 55
external applications, editing content in 53
features 33, 57
file extension, default 195
images, inserting 100, 101
opening for editing 37
Pages panel 21
permissions for creating 223
permissions for editing 220
previewing in a browser 158
printing 56
properties 65
publishing existing as new 161
publishing new 159
recently published, viewing 25
restoring deleted 238
saving drafts 40, 41
scripts and forms, protecting 240
stand-alone, creating 63
starter 60, 61
static content, editing 241
templates 36, 47, 62, 236
text, adding 86
troubleshooting editing 233
unlinked, viewing 26
updating 159
workflow overview 11
web pages and blog entries 24
drafts 34
web pages
  bookmarking 27
website connections
  about 179
  administrators 12
  alternative addresses 180
disabling CPS for 189
disabling information 205
enabling 14, 208
enabling CPS for 188
information, collecting 182
managing 204
removing 207
renaming 206
selecting for startup 209
setting up 183
troubleshooting 231
working offline 13, 50
website or blog connections
  disabling at startup 14
websites
  administrator role, assigning 190, 193
  bookmarking 27
  bookmarking pages 27
disabling 239
disabling CPS 189
enabling CPS 188
file placement options 225
files, publishing 162
Google search functionality, adding 52
home pages, viewing 25
linking pages 137
linking to new pages 134
opening pages for editing 37
publishing existing pages as new 161
publishing new pages 159
unlinked pages 26
updating pages 159
Windows Eyes screen reader
  images 100
settings 32
supported 30
Windows keyboard shortcuts
  blog entries list 245
  Edit menu 243
  editing 246
  File menu 243
  Format menu 244
  help system 247
  images 247
  Insert menu 244
  Table menu 245
tables 246
templates 246
View menu 244
Windows Media files 111
windows, opening links in new 143
Word
  adding content to web pages 73, 76
  folder placement options 225
  inserting documents as PDF 79
  linking documents to web pages 74, 78
  opening documents in Adobe Contribute 75
posting blog content 169, 170
publishing documents 167
Work Offline 50
workflow overview 11
working
  offline in the Contribute editor 51
workspace
  browser and editor 19
  keyboard-only navigation 30
  sidebar 21
  toolbars 20
writer role 211