
Instantly add style to
your Web site

The process people are going through to create graphically rich Web sites is far too painful. Most Internet and

intranet Web sites are designed by creative business users—people with backgrounds in information services

(IS), marketing, engineering, human resources, and other disciplines. These business users are expected to:

• Produce and regularly update visually compelling Web sites while juggling their other job responsibilities.

• Master a complex combination of tasks, including writing HTML, producing table-based HTML layouts,

creating and optimizing Web graphics, coding with JavaScript, and more.

• Adapt to Web graphics tools that neither forgive design changes,  nor encourage experimentation.

• Overcome tight schedules, restricted budgets, and minimal design experience to publish their Web sites.

Creative business users end up compromising more than they’d like just to get their Web sites done. What

they really need is software that helps them overcome these obstacles to produce great-looking sites that

communicate effectively with their audiences.

That’s why we’re introducing Adobe ImageStyler 1.0 software with its powerful new approach to Web graph-

ics creation and production. Adobe ImageStyler handles all of the tasks involved in Web graphics creation

from designing visual effects to optimizing Web graphics, producing JavaScript rollover effects, and even

batch-updating Web pages. This innovative program offers complete design flexibility through its unique

object-based editing model and graphical styles.

Basically, you can start with any kind of object (shapes, text, or imported graphics); apply graphical attributes

quickly with styles; add rollover effects, image maps, and other Web-oriented attributes; edit the object or

style in other ways; and then change any edit at any time. With this object-based editing model, changes are

nondestructive, so any edit you make is associated with an object and can be changed independently of it.

This flexibility lets you experiment freely and work faster. You can tweak anything you want, and even set

graphics up as templates for ongoing work.

Adobe ImageStyler 1.0 is fundamentally more versatile and powerful than any other Web graphics tool you’ve

tried. The best way to experience this unique graphics program is to see its features in action. We’ve prepared

this hands-on tour of Adobe ImageStyler 1.0 to show you how things work and give you a chance to try

features yourself. You can follow the examples in order or skip around looking at the features that interest

you. (Sometimes a sequence of features builds from one to the next to illustrate an important concept, but

for the most part, you can follow your own inclinations in working through the examples.)

This reviewer’s guide is divided into these sections:

• Instant Creativity with Web Graphics (page 2)

• One-step Web Graphics Production (page 19)

• Batch-creation Tools for Timesaving Web-site Production (page 25)

• Award-winning Adobe User Interface (page 29)

Each section guides you through the relevant features and shows you how they help creative business users

efficiently produce spectacular Web graphics. All of the features described apply to both Macintosh and

Windows versions of Adobe ImageStyler 1.0 software, so feel free to work on your platform of choice or even

to move back and forth between platforms.
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The combination of object-based editing and graphical styles offers creative business users a powerful solu-

tion to their Web graphics problem. The following sections walk you through the core steps in creating Web

graphics with Adobe ImageStyler and illustrate the many ways that you can put these concepts to work.

Instant Creativity with Web Graphics
Adobe ImageStyler 1.0 software delivers the most flexible Web graphics creation tools available today. These

tools allow you to create or import objects; instantly apply visual effects to these objects with graphical

styles; transform, group, align, or combine objects; apply graphical mattes; and even link objects together

for easier updating. With these tools, you can create buttons, navigation bars, promotional graphics, infor-

mation graphics, banners, and a host of other Web graphics with complete ease.

Core Concepts: A Unique New Approach to Graphics Creation
The central problem with many Web graphics creation tools today is that they treat edits destructively,

forcing you to start over again to tweak a visual effect, apply it across a series of objects, and do other basic

Web tasks. Adobe ImageStyler transforms Web graphics production by offering you complete design flex-

ibility. This flexibility is rooted in two innovative concepts: object-based editing and graphical styles. Here’s

a quick look at how these unique concepts work for you.

Object-based editing. In Adobe ImageStyler, all objects are treated equally. You can work with text, shapes,

and imported images with the same flexibility. Furthermore, any edits you make—whether you’re applying

a visual effect, a graphical matte, or a JavaScript rollover effect—exist independently of the object, so you

can change anything about your edits at any time without having to redo steps along the way. For example,

you can create a shape, apply a complex graphical style, and then change the shape. The new shape simply

adopts the old shape’s style. You can create complex effects with text and then edit that text to say something

different or to use a different font or font size. You can also perform any edit on an image with complete

freedom. This flexible object model has far-reaching benefits. Unlike other programs, you can, for example,

apply a JavaScript rollover effect to an object and then move or edit the object without reapplying the effect.

Apply an interesting visual effect to a graphic in
Adobe Imagestyler, then switch that graphic for
another without reapplying the effect.

Graphical styles. Adobe ImageStyler offers a unique, flexible approach to creating sophisticated visual

effects for graphics: graphical styles. In Adobe ImageStyler, objects can have up to five layers, and each layer

can have a unique combination of effects assigned to it. Furthermore, you can save and name multilayered

combinations of graphical attributes as styles and then apply these styles to different objects any time you

want. The layers in the style simply conform to the shape of different objects. Adobe ImageStyler includes

dozens of different elements—textures, colors, gradients, opacities, distortion effects, 3D effects, and so

on—that can be mixed together in new styles to create outstanding visual effects. It also includes more than

100 professionally designed styles for you to use right away or for you to modify for your own variations.

Apply styles to shapes, text, and images to
instantly create eye-catching visual effects.

Top 5 Features in ImageStyler
Adobe ImageStyler is packed
with features that help you
create spectacular Web graphics
with extraordinary efficiency.
However, five of these features
form the core innovation in this
unique new product. Here’s a
brief look:
• Style Editing. Create cool

visual effects by applying
multilayered combinations of
graphical attributes, such as
color, transparency, and
embossing, to text, shapes,
and images. For a closer look,
see pages 3–9.

• Live Objects. Work with the
most flexible Web graphics
tool available today. Apply
extraordinary effects or make
other edits to your objects,
and then change the underly-
ing text, shape, or image at
any time. For a closer look, see
pages 10–18.

• JavaScript Rollover Effects.
Add interactivity to your site
with sophisticated graphics
that change when a mouse
moves over, clicks on, or
moves away from them. For a
closer look, see pages 21–23.

• AutoLayout. Export laid-out
pages as table-based HTML
pages with pixel-level accu-
racy. Then publish these
pages on your Web site
directly. For a closer look, see
page 25.

• Batch Graphics Creation.
Automatically deploy graph-
ics across dozens of Web
pages on your site. For a
closer look, see pages 25–28.
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Before You Begin: Working with Palettes

Adobe ImageStyler presents most of its features in tabbed palettes (similar to those found in other Adobe

graphics programs). These palettes place key functionality at your fingertips for a more efficient workflow.

Throughout this Reviewer’s Guide, we direct you to various palettes to perform different steps. Our instruc-

tions are brief: We simply tell you to make the palette active. If the palette isn’t visible, do one of the follow-

ing steps:

• Locate and choose the palette name on the Window menu to open it. Then follow the directions to

specify the necessary parameters.

• Click the palette tab to bring it to the front of its container and make it active.

Applying a Predesigned Style
To get a quick idea of the rich visual effects you can create with styles, you’ll first apply a predesigned style

to an object.

Try it:

1. In a new ImageStyler document, create a basic shape. For example, select the rounded-rectangle tool to

draw a rounded rectangle.

2. If necessary, make the Styles palette visible.

3. With the shape selected, click any style you want, and then click Apply at the bottom of the Styles

palette. Try applying several different styles to see how easy it is to change your mind.

Now check out some of the translucent styles, such as Glass Glow, Glass Bead, and Invis Jitter, to see how

sophisticated these effects can be.

Try it:

1. Make sure nothing is selected. Then choose File > Place As Texture to place a background image. Locate

and select ASP_041.jpg in the \REV_GD folder on your reviewer’s CD.

2. Choose Preview View from the Styles palette to change how the Styles are listed.

Preview View lets you see both the style name and its effect before you apply it. The Swatches View

shows the visual effect of the style, while the Name View emphasizes the style name and provides a small

icon depicting the style.

3. With the object selected, click Glass Bead in the palette list, then click Apply.

Review and undo multiple steps
You can undo or redo any number
of steps at any time. Just press
Ctrl+Z/Command+Z to undo a
step, or Ctrl+Shift+Z/Command+R
to redo a step. Or choose Undo
from the Edit menu to review a
sequence of steps and undo
several at once.

Apply complex visual effects
to shapes or other objects in
one efficient step.

Gold Plate style Four-way Blend style Ripple Texture style
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4. Move the object around on the background texture to see how it lets the underlying image show

through while distorting it.

5. Apply the Glass Glow style to see a different translucent effect.

Creating a Style: Working with Layers and Attributes
Now that you’ve applied a predesigned style, let’s try a new combination of attributes on different layers to

create a style from scratch. We’ll create a two-layer style. The first layer will have a color and 3D emboss

applied, as well as a gradient and a distortion effect. The second layer will have a new width, a background

fill, and a new softness setting applied. The final result will look like this:

When applied, this new style makes an object look
punched out of a background.

Remember that the order of these steps is somewhat arbitrary because ImageStyler lets you change anything

you want at any time.

Try it:

1. In a new ImageStyler document, create an object using any of the drawing tools. For example, select the

rectangle tool and draw a basic rectangle.

Note: All objects start with one layer. The first attributes you create will apply to that layer.

2. If necessary, make the Color palette visible.

A Choose a Color Selection view. For example, choose RGB View or
HSB View.

B Click this Color Proxy to specify a foreground color that applies to
any selected objects.

C Click this Color Proxy to specify a background color.
D Check the Web Safe Colors cube to restrict your color choices to

Web-safe colors.

A

B
C

D

3. Choose HSB View from the Color palette popup menu.

4. With the object selected, enter these values and press Enter or Return, or adjust the HSB sliders to match

them: 180 for Hue, 100 for Saturation, and 80 for Brightness.

As you adjust the sliders or enter values, note that the object updates instantly to reflect each change.

This is just one example of the live, interactive editing environment that ImageStyler offers.

5.  Click the 3D tab to make the palette visible.

6. Choose Emboss from the drop-down menu at the top of the 3D palette, and then change the Depth to 7

by adjusting the slider or entering the value and pressing Enter or Return.

Note that the object updates instantly as you make the change.

These examples show a
translucent object posi-
tioned over a flood of
background color.
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7. Create a second layer: Choose Window > Object Layers to display the palette (or click the Object Layers

tab to make the palette active).

8. Click the Duplicate Layer button at the bottom of the palette to create a second layer with the same

attributes applied to it. Then double-click Layer 2 to rename it. Type Background Layer for its name,

and click OK.

Note: The object looks the same because the duplicate layer appears behind the original layer.

9. Change the relative width of the new layer: Click the Layer tab to display the palette. Then enter 3 for

Width or adjust the slider bar to 3.

Now, when you apply this new style, the background edge of the object will be 3 pixels wider than the

foreground edge. This width adjustment is always calculated in relation to the object. If you apply the

style you’re creating to a different-sized object, the background width is simply 3 pixels wider than the

new object’s size.

10. Click the 3D tab to make that palette visible again.

Note: The settings you specified in Step 6 still appear. You’ll use these same settings but change the light

source to create the punched out look.

11. Press the Shift key to constrain the light-source control, so it changes in 15-degree increments. Then

drag it to 315 degrees.

Object Layers palette

Press the Shift key and drag this control
to change the lighting effect applied to
the Background Layer.

12. Add a background to your document: Deselect the object, and then choose File > Place as Texture.

Locate Scrambled.psd in the Textures folder in the ImageStyler folder on your hard disk.

A Hides or displays a layer.
B Creates a new layer.
C Duplicates a selected layer and any attributes

applied to that layer.
D Deletes a selected layer.
E Offers you a choice in how you view the layers

listed in the palette.

A

B C D

E

Overview of the Object Layers Palette: Five-Layer Style Selected

Use the Object Layers palette to create up to five layers

for each style you specify. Organizing attributes on layers

helps you build complex combinations of effects.
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13. Select your object, select the Background Layer in the Object Layers palette, and choose Background for

Fill With from the Layer palette.

Note: This setting fills the current layer with whatever color, texture, or image is in the background

behind the object. You can use this unique capability to achieve some unusual and compelling effects

quickly. In this case, filling the second layer with the background helps create the punched-out look.

14. Soften the edge of the second layer by adjusting the softness value to 3 in the Layer palette.

15. Switch back to the first layer to make some more adjustments: Click Layer 1 in the Object Layers palette.

16. Click the Gradient tab to make that palette visible. Then make the Color palette visible as well. Position

the two palettes near each other but away from your selected object to view your changes interactively.

17. Click the right node in the Gradient palette to set the gradient to linear as the automatic default.

A Choose a gradient type: Linear, Burst, Double Burst, or
Radial.

B Select Relative to maintain the gradient’s relationship to an
object as you rotate or otherwise transform it.

C Click the left node to specify a color for it, or drag it to
adjust where the color begins.

D Click the right node to specify a color for it, or drag it to
adjust where the color begins.

E Enter a value or drag the angle control to specify an angle
for the gradient.

E

DC

B

A

18. Choose Saturation view from the Color palette popup menu. Then specify a color for the right node by

pressing down the mouse button and dragging around the color spectrum until you see a color you want.

Note that the object updates instantly as you drag across different colors. This is another example of the

fluid, interactive editing environment that ImageStyler offers.

Combining attributes into styles
Adobe ImageStyler offers more than one hundred layer attributes that can be combined on up to five layers

to create a style. The chart below summarizes the key layer attributes and points out the controls available to

vary how the attribute is applied to a layer. (Some attributes are mutually exclusive on a single layer but can

be used in a single style by placing them on separate layers.)

Attributes available What creative business users can do

Source Specify a color, image, texture, or background.

Offsets Specify an x or y Offset for a layer in the Layer palette.

Width Specify a Width for the layer in the Layer palette.

Softness Specify a Softness value for a layer in the Layer palette.

Color Specify a color setting in the Color palette.

Color gradient Specify the type of gradient—Linear, Radial, Burst, or Double Burst—and the
starting and ending points and colors.

Opacity Specify the opacity setting for a layer or gradient in the Opacity palette.

Opacity gradient Specify an opacity gradient for a layer in the Opacity palette.

Distortion effects Specify a variety of effect-specific parameters in the Distort palette, such as
Displace, Lens, Twirl, Spherize, Quantize, and Radial Quantize.

3D effects Specify parameters such as Depth, Softness, and Lighting for Cutout, Emboss,
Bevel, or Ripple in the 3D palette.

Textures Select among the dozens of textures available in the Textures palette, or
import additional textures into this palette.

Filters Apply filters to images, such as Brightness, Contrast, Saturation, Tint,
Posterize, and Invert, using the Filters palette.
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19. Click the left node and set a color for it in the Color palette. Then, in the Gradient palette, drag the right

and left nodes along the slider to adjust where the gradient starts, and drag the angle control to specify

the angle for this linear gradient.

20. Make the Distort palette visible. Then choose Twirl from the popup menu, and enter 80 for Turns or

adjust the slider.

21. Make the Styles palette visible. With the object selected, click the New Style button at the bottom of the

palette, enter a name for the new style you’ve created, check Ignore Color of First Layer, and click OK.

Specify the number of turns in your Twist distortion.

By saving this combination of attributes as a style, you can apply it to any object at any time—without

repeating these steps again!

Copying and Pasting Style Attributes
In some instances, you may not want to save a combination of attributes as a style, but you may still want to

use it several times in a particular document. Adobe ImageStyler gives you a number of ways to do this: You

can copy and paste attributes from one object to another, or you can press the Shift key and click a styled

object with the eyedropper to instantly apply it to several other selected objects. You can even use the eye-

dropper tool to sample a set of attributes in one ImageStyler document, and then use the paint bucket tool

to apply them to objects in another ImageStyler document.

Try it:

1. In a new ImageStyler document, choose the ellipse tool, and draw a circle.

2. Apply a color from the Color palette. For example, make the circle a medium shade of blue.

3. Make the 3D palette visible.

4. Choose Ripple from the popup menu at the top of the palette. Then set the Depth to 10, the Softness

to 4, and Edge to Plateau. If you set these attributes with the sliders, note how the object adopts the

attributes interactively as the slider moves.

Create a new shape and apply your style to it
in one quick step.

5. Using any of the other drawing tools, draw a series

of shapes.

6. Select the shape that you styled with attributes in

Step 4, and press  Ctrl+C/Command+C to copy

those attributes. Then select one of the new

shapes, and choose Edit > Paste Style

(Ctrl+Shift+I/Command+B) to apply it instantly.

7. Press Shift and click on all of the other shapes you

made to select them.

8. Select the eyedropper tool from the toolbox, press

Shift, and click either of the two styled shapes to

apply the attributes to the selected shapes.

Use the eyedropper tool to sample
the attributes applied to one object,
and apply them to one or more
selected objects.
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Modifying a Style
Once you create a style, you can modify any aspect of it at any time. You can save the modified version as a

new style, or you can simply make subtle changes to a style’s attributes on the fly for one-time use. With this

inherent flexibility, you can create families of styles in a few quick steps. For example, let’s say that you

created the style in the previous section and then needed several variations that used different color combi-

nations in the gradients. You could make these style variations in moments by applying the style to an ob-

ject, changing the gradient colors, saving the change to a new style name, and then repeating the process.

This ability to iterate visual effects quickly is one of the most extraordinary aspects of using ImageStyler.

To help you get started quickly, ImageStyler offers more than 100 predesigned styles. You can put these

styles to work right away, or you can modify them to create new styles. In this example, we’ll modify a

predesigned style and save it for future use.

Try it:

1. In a new ImageStyler document, select the rounded-rectangle tool and draw a shape on the page.

2. Make the Styles palette visible.

3. Choose Preview View from the Styles palette popup menu.

4. With your new object selected, click 3 Bevel 1, and then click Apply.

Applying styles or attributes in Adobe ImageStyler
Adobe ImageStyler offers many ways to apply styles to objects in a composition. Here’s a look at the tech-

niques available and when you might choose them.

Method When to use it

Double-click style name or To apply a style to one or more objects quickly and easily
swatch on the Styles palette

Create alias to link multiple graphics To update multiple related graphics instantly
and then apply a style

Copy and paste To copy a combination of attributes from one object to another without
first making it a style

Press Shift and click with eyedropper To copy and apply a style from a graphic in one ImageStyler composition
tool, then press Shift and click with to a graphic in another ImageStyler composition
paint bucket tool

Shift-click with eyedropper tool on To copy and apply a style from one object to another within an
one graphic with another selected ImageStyler composition

Batch-update styled graphics To automatically create and update related graphics across a Web site

Replace an object or graphic To update the underlying object without changing the style applied

5. Make the 3D palette visible, and change the Depth to 22.

Adjust the Depth option to change the bevel
dramatically.
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6. Make the Textures palette visible. Then try selecting and applying textures until you find one you like

(just double-click a Texture swatch, or click a texture and click Apply).

Check the Layer palette to see that the Fill With option changes to reflect what you’ve applied to the

object. It now says Texture.

Complete the style modification by applying
a new texture to the object.

7. Click the Styles tab again to return to this palette. Then click the New Style button at the bottom of the

palette, enter a name for your new style, check Ignore Color of First Layer, and click OK.

If you want, try applying your modified style to a new object: Select the type tool and click in the

ImageStyler window. In the Type Tool dialog box, enter your name. Then select Arial or Helvetica for the

font, specify 96 points for the font size, and click OK. With the text still selected, click the name of your

newly modified style in the Styles palette and click Apply.

Deleting a Style
You can delete a style at any time: Just click the style in the Styles palette and click the Delete Style button at

the bottom of the palette. Or, you can narrow the choice of styles that appears in the Styles palette without

permanently deleting those styles. Just move them temporarily from the Styles folder in the ImageStyler

program folder to a new location. For example, create a folder called Extra Styles in which to store styles you

use only occasionally.

A Applies a selected style to a selected shape, text, or
image object.

B Creates a new style based on the layers and attributes
applied to a selected object.

C Deletes a selected style in the Styles palette list. Also
deletes the corresponding file from the Styles folder
in the ImageStyler program folder.

D Offers you a choice in how you view the styles listed
in the palette.

Swatches View

A

B C

D

Preview View

A

B C

D

Name View

A

B C

D

Three Views of the Styles Palette

The Styles palette offers three views of its style list, so you can choose the one that best suits your workflow.

Use this palette to apply styles, save new styles, and delete styles.

Share Styles with Colleagues
It’s easy to share the styles you
create or modify with colleagues
who use Adobe ImageStyler. Any
time you save a new style,
ImageStyler adds it to the Styles
folder in the ImageStyler pro-
gram folder on your hard disk.
(For example, if you create a new
style named Sharp Bevel, a file
called SharpBevel.ist appears in
the Styles folder.) Just send your
colleagues these new files with
instructions to store them in the
Styles folders on their hard disks.
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Working with Live Objects

In Adobe ImageStyler, you build your Web graphics and layouts by using three different types of objects:

Geometric shape objects

Image objects
Text objects

You can create shapes and text in ImageStyler using the drawing and type tools. For images, you can

choose among the ones in the Shapes palette, add more graphics to the Shapes palette for ongoing use, or

import images in a variety of formats. The key thing to remember with any of these objects is that they are

live—which means that you can edit them and then change your edits with complete freedom.

The next few sections walk through the different ways you can work with objects. As you try out the differ-

ent techniques described, remember that all objects are equal—in general, what you can do to one, you can

do to any object. That, combined with the cool visual effects you can create with styles, is the essential

power of Adobe ImageStyler.

Creating and Changing Shapes
If you’ve worked with any graphics software, you’ll instantly be familiar with the drawing tools in Adobe

ImageStyler. This program offers ellipse, rectangle, rounded rectangle, and polygon tools. The power of

these tools lies in what you can do with the shapes once you create them.

Try it:

1. In a new ImageStyler document, select the rectangle tool, and draw a rectangle.

2. Make the Styles palette visible.

3. With the rectangle selected, choose the style you want to apply, and click Apply.

4. If necessary, choose Window > Properties to make the Properties palette visible (or click its tab).

5. Choose Polygon from the popup menu at the top of the Properties palette.

Note that the new shape retains the style you applied.

6. Click Outline in the Properties palette to turn your styled polygon into an outline shape, and then adjust

the Width to 34 to give the outline more weight.

7. Make the Shapes palette visible, and, if necessary, choose Preview View from the popup menu. Then

scroll to find the shape called Arrow, Spiral Left, select it, and click the Replace button.

Note: The new shape retains the applied style. However, the options in the Properties palette have

changed because the shapes in the Shapes palette are actually image objects, not geometric shapes.

Original, styled shape
The replaced shape with the same
style applied
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Editing Text

In many Web graphics programs, working with text is challenging. You can create a text block and apply text

attributes and visual effects to it, but then editing the text is usually impossible. To change the text, you have

to start over again. With Adobe ImageStyler, on the other hand, text is just another object. The changes you

make to it are nondestructive, so you can change any aspect of the text at any time.

Try it:

1. In a new ImageStyler document, select the type tool from the toolbox.

2. Click in the document window to open the Type Tool dialog box.

3. Enter a few words of text. For example, type your name, or type Adobe ImageStyler.

4. Choose a sans serif font for Font, choose 72 points for Size, and click OK. Adjust the location of your

text on-screen if necessary.

5. Make the Styles palette visible, and make sure it’s displaying styles in Preview View. (Choose this option

from the Styles palette popup menu).

6. Try applying several different styles to the text. For example, click Silver Button, and click Apply. Then

click Ripple Colors, and click Apply.

It’s as easy to style text as it is to style a shape or image in Adobe ImageStyler.

Try applying one style to your text, then try another.

Overview of the Properties Palette (geometric shape selected)

The options available in the Properties palette change depending on the type of object selected. This over-

view shows the options for a selected shape. You can also specify attributes for text and images. (See page 16

for an example of using the Properties palette with an image.)

A Choose a new shape from the popup menu.
B Click Fill to create a solid object, or click Outline to have an

outline shape.
C Specify the options that appear here, depending on the

type of shape you’ve selected and whether it’s a filled shape
or an outline.
For any shape: Specify a Width for your outline version.
For a rounded rectangle: Specify a Radius for your filled or
outlined shape.
For a polygon: Specify the number of Sides for your filled or
outlined shape.

A

B

C
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7. Resize the text interactively by dragging a selection handle. Press Shift as you drag to maintain the pro-

portions of the text.

This is just one more example of the flexible, interactive editing environment in Adobe ImageStyler.

Drag a handle on the text block
to resize the text interactively.

8. Double-click the text to open the Type Tool dialog box again. Then edit the text to say something else.

9. Change other attributes of the text as well. For example, make the text vertical by choosing a vertical

option from the Alignment popup menu.

Associating Objects through Graphical Aliases
When you’re developing a Web site, you often need to repeat graphical objects throughout the site. For

example, you may set up navigational buttons that must all look the same at all times. Yet you also want to

update your graphics often to keep your site fresh and inviting.

Adobe ImageStyler makes this process efficient by letting you create graphical aliases, which are linked

objects. Any change you make to one graphical alias automatically updates the others. Let’s take a quick look

at how graphical aliases work. We’ll then work with this concept a bit more in the next section.

Try it:

1. In a new ImageStyler document, select the polygon tool, and draw a button-size polygon.

2. Press Ctrl+M/Command+M three times to create three linked aliases of the polygon.

3. Stack the four polygons in a column.

4. Make the Textures palette visible.

5. With one of the polygons selected, click any texture, and then click Apply.

Note: All of the linked polygons immediately have the texture applied. Try experimenting with different

textures if you like.

6. Click the Styles tab to make it visible, and choose Preview View from the Styles palette popup menu.

7. Click 2 Drop Shadow 3 to add a drop shadow to all of the linked polygons.

For this example, create a set of linked
buttons for a navigation  bar. Then
apply a funky texture, and a drop-
shadow style to one of the graphics.
The others update instantly to reflect
your changes.

Styling Text Efficiently
One of the benefits of the live
objects model in ImageStyler is
that you can select multiple text
blocks and change their
attributes all at once with the
Properties palette. This is
particularly useful for Web users
who often have to deal with lots
of tiny text blocks.

Tip
For a really efficient workflow, you
can align a set of graphical aliases
as you make them. Create your
first object. Then, with that object
selected, press Alt+Shift/
Option+Shift and drag the object
up, down, or to the right or left.
Release the mouse button. Then
repeat the process to create
several more graphical aliases.
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Transforming Objects

Adobe ImageStyler offers a full complement of tools for doing standard drawing tasks, such as rotating,

skewing, and cropping objects. You can also align objects precisely, and group them to maintain their rela-

tionships with each other. In this example, you’re going to create graphical aliases for buttons in a naviga-

tion bar. You’ll then style, align, skew, and group them to preserve their final arrangement.

Try it:

1. In a new ImageStyler document, select the rectangle tool, and draw a rectangle.

2. Choose Window > Transform, or click the Transform tab to make the palette visible.

3. With the rectangle selected, enter 180 for W and 325 for H in the Transform palette, and press Enter

or Return. (If the rectangle goes off the canvas, click and drag it into the window.)

4. Click the Styles tab to make the palette visible (if necessary, choose Preview View from the Styles palette

popup menu).

5. With the rectangle selected, click Bronze Metal in the Styles palette, and click Apply.

6. Draw a narrow rectangle across your navigation bar. Refine its size by entering 190 for W and 40 for H

in the Transform palette and pressing Enter or Return.

This rectangle is your first button.

7. Press Ctrl+M/Command+M three times to create three aliases of the button.

8. Roughly arrange them on the navigation bar. Then select all of the buttons and the navigation bar, and

choose Object > Align > Horizontal Centers to align them along their center point.

9. Deselect the navigation bar. With only the buttons selected, choose Object > Distribute > Vertical to

space them apart from each other evenly.

10. Select only one of the buttons, click Glass Bead in the Styles palette list, and click Apply.

All of the linked buttons update instantly.

11. Change your mind: Apply the Glass Glow style instead.

12. Select all of the buttons, and choose Object > Group to maintain their relationship to each other.

You could also group them with the navigation bar if you wanted.

13. Select the subgroup-selection tool in the toolbox, and click on one of the buttons to select it.

14. Select the skew tool in the toolbox. Position the cursor over a top-center handle of the subselected but-

ton, and drag gently to the right.

You want to give these buttons a slight skew—nothing dramatic. When you skew one, they all skew

identically.

A Enter a value in pixels to specify the location of the selected object
in relation to the x and y axes (the 0, 0 point for the document is in
the upper-left corner and for the object is on the upper-left handle
of the bounding box).

B Enter a value or drag the rotation control to specify the angle of
rotation for the selected object.

C Enter a value in pixels to specify the degree of shearing (or skew)
horizontally and vertically for the selected object.

D Enter a value in pixels to specify the width and height of the
selected object.

A

B C

D

Overview of the Transform Palette
Use the Transform palette to precisely position, rotate, skew, and resize objects.

Create this handsome navigation
bar with complete efficiency.

Tip
Use the drag-selection tool to
quickly select discrete groups
of objects.
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Combining Objects

You can quickly construct complex shapes in Adobe ImageStyler using the Combine commands (Unite,

Unite with Color, Intersect, Exclude, and Minus Front). To create these unique graphics, you can combine

overlapping shapes, text, images, and imported EPS files. You can then save your shape in the Shapes palette

for ongoing use.

Note: When you create a combined object, it becomes an image object. If you’re using the Unite, Minus

Front, Intersect, and Exclude commands, the resulting object adopts the attributes of the bottom-most

object. Remember though that you’re working in a highly flexible editing environment: You can change

those attributes later. You can uncombine these objects at any time—the objects resume their former

attributes. You can even edit the topmost text object in a combination object that includes text.

Try it:

1. In a new ImageStyler document, choose File > Place As Texture, locate ASP_021.jpg in \REV_GD on

your reviewer’s CD, and place it as a background image.

2. Select the rectangle tool and draw a rectangle that’s about 400 pixels by 100 pixels. (Keep an eye on the

Transform palette to help you.)

3. Click the Color palette tab to display it, and adjust the color if you’d prefer a different color.

4. With nothing selected, set the default color in the Color palette to black.

5. Select the type tool, and click in the document window.

6. Type Adobe ImageStyler, choose a bold version of Arial or Helvetica, and specify 36 points for size. Then

click OK.

7. With the new text block and the rectangle selected, choose Object > Align > Centers.

Tip
Using the eyedropper tool, you
can select any visible color on
your monitor to use in your
composition. To venture
outside of ImageStyler and
sample colors, just select the
eyedropper tool, press Ctrl/
Command, hold down the
mouse button, and drag
outside the application win-
dow. The Color palette updates
interactively as you drag.

The key thing to remember is that the objects you make with the Combine
commands are also live ImageStyler objects. You can edit, style, and
otherwise manipulate them just as you would any other object.

Original objects Unite Change style

Original objects Minus Front Add texture
Change text

Original objects Intersect
Fill with: Image

Apply style
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8. Choose Object > Combine > Minus Front to knock out the rectangle with the text you created.

9. With this object still selected, choose Object > Maintain Alignment.

Note: With the Maintain Alignment command, you can edit your text to include more words or to be

larger or smaller in size, and the rectangle scales with it.

10. Double-click the text in the shape you’ve created, add 1.0 after Adobe ImageStyler, and increase the

point size to 48 points. Then click OK.

The rectangle and text scale together.

11. Double-click the text again, and decrease the point size to 24 points. Then click OK.

12. Now save the shape in the Shapes palette for future use: Make the Shapes palette visible and position it

outside of the document window. Then drag your new shape on top of it and release the mouse button.

In the dialog box that appears, enter a name for the shape, and click OK.

Extra: You can make some interesting effects using imported EPS files. For example, you could take a com-

pany logo, position it on a color- or texture-filled shape, and combine the two, so the logo knocks out the

shape. Try this by placing the Globe1.eps file (located in the \REV_GD folder on your Reviewer’s CD) in an

ImageStyler document, and using the Minus Front command to combine it with a shape.

Applying Active Mattes to Images

You can create dramatic effects by applying shapes to imported images to mask

them. Anything outside of the applied shape disappears, leaving only the part

of the image enclosed by the shape to show through. In Adobe ImageStyler, this

mask effect is called an active matte because this complex effect remains live. At

any time, you can:

• Change one matte for another.

• Scale, crop, rotate, and otherwise manipulate the active matte along with

the image.

• Replace the image within the matte (see “Setting up Graphical Templates”

later in this section for details).

• Undo the matte, returning the image to its previous state.

Example of an image with an active matte applied

Tip
To drag and drop a shape into
the Shapes palette for future use,
you must either:

—Position the Shapes palette
outside the composition window,
or
—Drag the shape you want to
save outside the composition
window and then back over the
Shapes palette.

Either of the actions above alerts
the program that you want to
save the shape. Otherwise,
ImageStyler assumes that you’re
simply repositioning the shape
under or near the Shapes palette
in the composition window.
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Try it:

1. In a new ImageStyler document, choose File > Place, and locate a file called ASP_020.jpg in the

\REV_GD folder on your reviewer’s CD.

2. Make the Shapes palette visible. Also, make the Properties palette visible, so you can see how the active

matte is used as the alpha channel.

3. Choose Name View from the Shapes palette popup menu.

4. With the imported image selected, scroll through the palette list to find a shape that appeals to you, and

then click the Matte button at the bottom of the palette.

5. Resize the matted image smaller to see how the active matte resizes with it.

6. Choose No Alpha from the Alpha Channel popup menu on the Properties palette to remove the

active matte.

7. Scroll through the Shapes palette, and apply a different shape as a matte. Experiment with applying two

or three more shapes to see the different results you can get.

Graphical mattes can be more than just an edge effect in ImageStyler. You can create complex effects by

combining them with other attributes. For example, you could create a shape comprised of three overlap-

ping circles, each with a different opacity applied. You could then save the shape in the Shapes palette and

apply it as an active matte to another object with fabulous results.

• As your last change to this image, choose the shape called Circle Overlap in the Shapes palette, and click

the Matte button to apply this matte to the image of the swimmer.

Extra: You can use text as an active matte to create some eye-catching effects. Either create a text block, save

it in the Shapes palette, and apply it to your image, or create a text block, copy it, and choose Edit > Paste

Special > Paste Active Matte to apply it to your image.

Choosing No Alpha from the
Properties palette automatically
removes the matte and restores the
original image.

Create an active matte from text.

Create complex effects with active mattes.

A Technical Look at Active
Mattes
Images can be divided into RGB
color and alpha components. The
alpha information defines what
part of the color appears and how
transparent that color is—in
essence, the alpha channel
defines the shape of the image.
In Adobe ImageStyler, active
mattes are applied to images by
intersecting the alpha informa-
tion in those images with shapes.
If you apply an active matte to an
image without an alpha channel,
ImageStyler creates a rectangular
alpha channel and then intersects
it with the shape you’re applying.
You can monitor and change the
alpha channel for an image in
ImageStyler by selecting an
image and adjusting settings in
the Properties palette.
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Overview of the Shapes Palette

Use the Shapes palette to insert predesigned shapes in your Web graphics or to apply active mattes to se-

lected images. Even save your own graphics as shapes in the Shapes palette, so you can use them over and

over again.

A Lists all of the shapes available. The shapes in this palette are
actually image objects. Adobe ImageStyler includes predesigned
shapes. You can add your own at any time.

B Replaces a selected shape in your document with a selected shape
from the palette list.

C Places a selected shape in the document window.
D Applies an active matte to a selected image.
E Imports a separate image file as a shape in the Shapes palette.
F Deletes a selected shape from the palette list and from the Shapes

folder in the ImageStyler program folder.
G Offers you a choice in how you view the shapes listed in the

palette.

A

B C D E F

G

Working with Images
Throughout this section, we’ve emphasized the power, versatility, and flexibility of the Adobe ImageStyler

editing environment. Now let’s put these assertions to the test by walking through an entire sequence of

steps that you might perform on an image.

In many respects, images present the most vivid examples of the flexible editing environment in

ImageStyler. In most programs, changes made to images are destructive—you may be able to undo some of

them, but you typically have to start over again if you change your mind about something.

With ImageStyler, an image is just another object. You can resize it, apply styles to it, manipulate it, change

its brightness or saturation, and more—all without losing any image information. You could open the same

file two weeks later, and resize the image larger, change the style applied, and add a different active matte

and still produce pixel-perfect results.

Adobe ImageStyler is the perfect tool for creative business users because it’s adaptive to their needs and skill

sets. It’s also an incredible tool for professional designers who want to go from prototype to finished Web

graphic in a flash.

Apply any combination of changes to
images, undo those changes at any
time, or even apply them to other
images by simply replacing the first
image with another one.
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Try it:

1. In a new ImageStyler document, choose File > Place, and locate a file called ASP_041.jpg in the

\REV_GD folder on your reviewer’s CD.

2. Select the cropping tool in the toolbox, and drag the middle handle on the left and right edges of the

image to crop the image.

You want to crop the image so that it perfectly frames the bicycle wheels.

3. Switch back to the selection tool to scale the image. Then press the Shift key and drag the corner handle

to make the image a little smaller.

4. Apply a color filter to the image:

—Choose Window > Filters, or click the Filters tab to make the palette visible.

—Adjust Tint to its maximum value of 255. This setting replaces all of the color information in the

image with the current color in the Color palette. If you drag the Tint slider, note that the image updates

as you drag—another example of the interactive editing environment.

—Click the Color palette tab to make it visible, and then choose a medium blue to tint the image blue.

5. Click the Shapes palette tab to make it visible, and choose Name View from the palette’s popup menu.

6. Select Puddle 2 from the Shapes palette list, and click Matte.

7. Click the Styles palette tab to make it visible, and choose Name View from the palette’s popup

menu.

8. Click Glass Glow to apply this style to the matted image.

You can change any of the attributes you just set at any time. Want to tint the image a different color?

Select the image, open the Color palette, and click another hue. Want to style it differently? Choose an-

other style in the Styles palette, or adjust any attributes in the current style. The possibilities are endless.

Setting up Graphical Templates
There’s one more huge advantage to the flexible object-based editing model in Adobe ImageStyler: graphi-

cal templates. Because you can change everything so easily, you can use an ImageStyler document as a kind

of template. Take the image you just modified in the previous section. (If necessary, go back and run

through those steps—it’ll only take a few minutes, and it’s key to understanding the power of graphical

templates.) While you could complete the steps involved efficiently, they take some time. However, once

you’ve set up your first image, you can copy the graphic and replace the image any number of times. You

have, in effect, a graphical template.

How might you use this capability? Well, let’s say that you’re running a corporate intranet for a large, dis-

persed company. One of your tasks is to help people in your company find the right people for different

information and to know a little more about each other—so you’ve set up a personnel area that includes

people’s names, locations, contact information, biographical details, and job descriptions. You’re also in-

cluding pictures to give people a closer connection as they communicate by phone or e-mail over long

distances. With Adobe ImageStyler, you could set up a template for how those personnel pictures appear,

and then simply copy and replace the image for each employee.

Try it:

• Select the image you refined

in the last section, and copy it.

Move it away from the first

image. Then choose File >

Replace, and locate

ASP_020.jpg in the \REV_GD

folder on your reviewer’s CD.

The new image adopts all the

edits you made to the original

image.

Replace this image... ...with another.

Tip
When you crop an image, you
can adjust what appears in
the cropped frame. With the
cropping tool selected, drag
within the frame to change
the portion of the image that
appears.
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One-step Web Graphics Production
While Adobe ImageStyler excels at the creative end of Web graphics production, it’s also extraordinary at

the mechanics of producing those graphics. As we noted in the introduction to this document, creative

business users are under increasing pressure to master a wide range of disciplines from HTML coding to

graphics optimization to JavaScript coding. ImageStyler bridges these disciplines, offering you a single

efficient environment in which to go from Web graphics design to final produced HTML page.

In particular, Adobe ImageStyler delivers a set of features that automate the creation of JavaScript rollover

effects and image maps, two popular ways to liven up Web sites and increase viewer click-throughs. It pro-

vides a tool for making key tradeoffs between on-screen quality and final file sizes. It produces adaptive

color palettes by default to ensure color fidelity in your final graphics (while producing good results for

people viewing your Web site with 8-bit screen displays). And it delivers an extraordinary feature, called

AutoLayout, which allows you to design a complete page in Adobe ImageStyler and then generate a Web-

ready version instantly.

Unlike the other sections of this guide where you can hop around more freely, this section goes through

these features in sequence. That way, you can experience how efficient it is to build and output an interac-

tive Web page in Adobe ImageStyler.

Setting up Your Layout
The first thing you’ll do is set up the basic design that you want to export as a final laid-out HTML page.

Then, in the following sections, you can add JavaScript rollover effects and image maps, check the final file

size, and use AutoLayout to export your final page. If you tried any of the steps in the “Instant Creativity

with Web Graphics” section, the steps here should feel comfortable to you.

You’ll create a Web page that looks like this one. You’ll then add interactivity through JavaScript rollover
effects and image maps; check the exported file size; preview the layout in your Web browser; change the
position of the clouds to see how flexible the rollover effects are; and produce a final Web page.

Set up your design:

1. Open a new ImageStyler document, and choose Edit > Canvas Size.

2. Enter 700 pixels for Width and 600 pixels for Height.

3. Choose File > Place As Texture to place a background image. Then locate and select Cloud Blue.jpg in

\REV_GD on your reviewer’s CD.
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7. Make the Filters palette active. Then drag the Tint slider to 220.

8. In the Color palette, click the Foreground color proxy, and then select a sepia brown to tint the image.

9. Make the Styles palette active. If necessary, choose Preview View from the palette’s popup menu.

10. Select 6 Outline White in the palette list, and click Apply to apply this style to your selected image.

11. In the Transform palette, enter 65 for X and 115 for Y to position the image on your page.

12. Copy the image, and then enter 263 for X and 115 for Y in the Transform palette to position the image

next to the first image. Repeat this process one more time, entering 461 for X and 115 for Y in the Trans-

form palette to position the final image.

13. With the third image selected, choose File > Replace, and locate ASP_021.jpg in \REV_GD on your

reviewer’s CD.

A picture of a foot kicking a soccer ball replaces the bicyclist. This image is sized, tinted, and styled just

like the first image.

14. Select the second image, choose File > Replace, and locate OAD_082.jpg in \REV_GD on your

reviewer’s CD.

A picture of a kayaker replaces the bicyclist, and also adopts all the edits you made to the first image.

15. Set the default color to white: Make the Color palette visible. Then, with nothing selected, click white to

set it as the color value ImageStyler uses for the next few steps.

16. Add text to your design: Select the type tool, click in the document window to open the Type Tool dialog

box, and then create and position the first text block. Repeat to create two more text blocks:

—Type Adobe Employee Fitness Programs. Apply Arial or Helvetica Bold and 30 point, and click OK.

Then enter 107 for X and 29 for Y in the Transform palette to position it.

—For the second text block, type Summer Edition. Apply Arial or Helvetica Bold and 18 point, and click

OK. Then enter 290 for X and 73 for Y in the Transform palette to position it.

—For the third text block, type For a balanced, healthy lifestyle. Apply Arial or Helvetica Bold and 18

point, and click OK. Then enter 227 for X and 277 for Y in the Transform palette to position it.

4. Choose File > Save As, and then name and save your ImageStyler document.

5. Choose File > Place, and locate ASP_041.jpg in \REV_GD on your reviewer’s CD.

A picture of a woman on a bicycle appears in your layout.

6. Make the Transform palette active, and enter 190 for Width and 142 for Height to resize the selected

image smaller.

Tip
You could also position the text
blocks precisely by positioning
the first text block, creating and
roughly positioning the other
two text blocks, selecting them
all, and choosing Object > Align >
Horizontal Centers.
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22. Position the clouds in two neat rows of three using the Transform palette. Here are the coordinates to

use in the Transform palette:

Top row, left to right: Enter 88 for X and 333 for Y for the first, 290 for X and 333 for Y for the second,

and 496 for X and 333 for Y for the third.

Second row, left to right: Enter 88 for X and 435 for Y for the first, 290 for X and 435 for Y for the sec-

ond, and 496 for X and 435 for Y for the third.

23. With nothing selected, set the default color to black. Then use the type tool to add 12-point, Arial or

Helvetica Regular text to each cloud button. Here is the text for each button:

Top row, left to right: Club Memberships, Team Sports, Sports Training

Second row, left to right: Nature Sports, Water Sports, Kid Sports

17. Click the Styles palette tab to make it active, then choose Name View from the palette’s popup menu.

Select all three text blocks, click the Silver Metal style, and click Apply.

18. Click the Shapes palette tab to make it active, then choose Name View from the palette’s popup menu.

Choose Cloud2, and click the Place button to insert it in your layout.

19. Use the Transform palette to resize the cloud shape smaller: 142 for Width and 39 for Height.

20. Press Ctrl+M/Command+M five times to add 5 more aliased clouds to your design.

21. Click the Styles palette tab to make it active. Select one of the clouds, click the Blue Metal style, and

click Apply.

24. Choose File > Save to preserve your work.

As you can see, ImageStyler makes it efficient to put together a full page layout quickly. Now you’re ready to

add interactivity to your Web page.

Creating JavaScript Rollover Effects

Whether you’re working on a big commercial site or a corporate intranet, you want the visitors to your site

clicking through to different areas. Click-throughs are one of the quantifiable ways you know that your site

design is working. That’s why more and more sites are turning their links into JavaScript rollover effects—to

create interactivity and entice viewer involvement in those sites. (These rollover effects can be particularly

effective in getting people to respond to promotions or to follow through hyperlinked information.)

Apply a style to all of your l inked clouds in one step.
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The problem with creating JavaScript rollover effects is twofold:

• If you don’t have a graphics tool to help, you have to master JavaScript coding to use it.

• If you do have one of the graphics tool that can generate JavaScript code automatically, those tools tend

to be somewhat rigid. If you create a button or banner with a rollover effect, you can’t move, copy, or

otherwise manipulate it without redoing the JavaScript code.

Adobe ImageStyler 1.0 solves both of these problems, delivering a flexible, automated solution for JavaScript

rollover effects that lets you produce these effects without writing a line of code. Once you create a

JavaScript rollover effect, it becomes another attribute of that object and behaves like other ImageStyler

attributes—so you can edit the object freely without reapplying the rollover effect. You can change the

underlying object, apply a different style, move the object, copy it, and more with complete freedom.

Creating a JavaScript rollover effect is an efficient 3-part process: You apply a JavaScript action to an object

using the JavaScript palette. You then alter the object to indicate how it responds to the action applied.

When you’re ready, you can export  a page with rollover effects using AutoLayout, or you can batch-update

a set of Web pages with JavaScript rollover effects. (For details on batch-updating JavaScript rollover effects,

see the procedure for “Automatically Replacing Plain Text with Graphical Text,” which starts on page 25.)

Try it:

1. Choose Window > JavaScript to open the JavaScript palette.

2. Select the text block that says Club Memberships on the top, left cloud.

3. Click the New JavaScript Action button at the bottom of the JavaScript palette to set the effect to occur

onMouseOver.

You can choose to apply a JavaScript rollover effect that occurs onMouseOver, onMouse Down, or

onMouseOut (i.e., when the mouse moves over the object, when the mouse clicks down on the object,

or when the mouse moves away from the object.)

4. With the new JavaScript rollover effect selected on the palette, change the state of the text to set what

happens when the effect occurs. Turn the text Red, and enter 3 for X Offset and -3 for Y Offset at the top

of the JavaScript palette.

Check how the text block changes by clicking back and forth between No Action and onMouseOver in

the JavaScript palette.

Efficient Ways to Work with
JavaScript Rollover Effects
• Create rollover effects for a

navigation bar in one compo-
sition, then copy those effects
into a new composition.

• Deploy rollover effects across
many Web pages using the
batch updating capabilities in
Adobe ImageStyler.

• Generate rollover effects once
in a design, then tweak that
design endlessly without
redoing your effects.

Tip
If you’d like to experiment more
extensively with JavaScript
rollover effects, try applying one
to the cloud shape. You could
set the cloud to change to a
different cloud shape when the
mouse passes over it or clicks
down on it. Use the Cloud1
shape in the Shapes palette, or
choose a different shape to
create this effect.

Select a text block with a JavaScript
rollover effect applied and then click the
different states in the JavaScript palette
to review their effect.
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5. Select the five remaining text blocks, and repeat Step 4 to apply the rollover effect to them all at once.

6. Preview your effects by choosing File > Preview In > [Default Browser/Your choice of browsers listed].

Then close the Web browser window when you’re finished viewing your page.

When your page is loaded into your Web browser, pass your mouse over each cloud to see the effect.

Note, however, that the cloud buttons are a little too spread out.

7. In ImageStyler, select the top row of clouds and their text blocks with the drag-selection tool, then

press Ctrl+G/Command+G to group them. Repeat this step for the bottom row of clouds and their

text blocks.

8. Change the position of the clouds using the Transform palette:

Top row: Enter 59 for X and 314 for Y.

Second row: Enter 136 for X and 372 for Y.

9. Select and ungroup each row of clouds. Then choose File > Preview in Browser > [Default Browser/Your

choice of browsers listed] to look at your new layout. Be sure to save your ImageStyler document again

before moving on to the next step.

Important
What you see when you choose
Preview In Browser depends, in
part, on what options are
selected in the Export palette. If
necessary, choose Window >
Export, and make sure
AutoLayout is selected.

A Moves the selected object by the number of pixels you
specify when a viewer moves the mouse over, clicks
down on, or moves the mouse away from the object
with the effect applied.

B Indicates the initial state for the selected object (before
the JavaScript rollover effect is applied).

C When active, indicates that one or more of these
JavaScript actions have been applied to a selected
object: onMouseOver, onMouseDown, onMouseOut.

D Adds a new JavaScript Action to a selected object.
Clicking it repeatedly cycles through the JavaScript
actions available in the palette.

E Duplicates the JavaScript action and the new behavior
you specified for that state.

F Deletes a JavaScript action from a selected object.

Overview of the JavaScript Palette
Add interactivity to your Web site by applying JavaScript rollover effects to shapes, text, and images.

B

C

D E F

A
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Generating Image Maps

Image maps—graphics with URL links embedded in them—appear everywhere on the Web. Yet they can be

as challenging to make and to maintain as JavaScript rollover effects using the Web graphics tools currently

available. Adobe ImageStyler simplifies the creation of client-side image maps, letting you associate URLs

with any object in an ImageStyler composition and then export those objects as an image map.

Once again, the real beauty of this feature is its incredible flexibility, which is based on the object-centric

editing model in Adobe ImageStyler. For one thing, you don’t have to wait until just before you export a

composition to embed your URLs. You can associate them with objects at any time, and then continue

editing those objects. If you move an object, the embedded URL goes with it. If you replace an object, the

URL is associated with the new object.

Try it:

1. Choose Window > Web to open the Web palette.

2. Select each cloud in turn (starting with the top left cloud), enter the corresponding URL, and press

Enter or Return:

Top Left Cloud: http://www.adobe.com/clubmem

Top Middle Cloud: http://www.adobe.com/teamsports

Top Right Cloud: http://www.adobe.com/sportstrg

Bottom Left Cloud: http://www.adobe.com/naturesports

Bottom Middle Cloud: http://www.adobe.com/watersports

Bottom Right Cloud: http://www.adobe.com/kidsports

3. Save your file. Then choose File > Preview In > [Default Browser/Your choice of browsers listed] to see

your results. Move your cursor over each cloud and look at the URL information that appears at the

bottom of the browser.

Previewing Image Quality and File Size

When you’re creating Web graphics, you must constantly trade off between on-screen graphic quality and

your final file size (file size has a tremendous impact on a graphic or Web page’s download time at different

modem speeds). Adobe ImageStyler makes this process efficient with the Active Preview option on the

Export palette. With this option selected, you can try out different export options, including GIF, JPEG, and

PNG, and see the visual and file size impact immediately. The screen updates to show the on-screen impact,

and the Export palette reports the final file size using a particular

combination of export settings. If you leave Active Preview on (or

turn it on and off for spot checks), you can keep an eye on the visual

quality and file size as you edit your compositions.

Try it:

1. Choose Window > Export.

2. Select Active Preview.

Export palette

Check your links in your
Web browser.
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3. Select different export options from the popup menu at the top of the palette. Then see how rapidly

ImageStyler updates the file size information. No other software provides this information as quickly.

4. As your final selection, choose JPEG, and set the Quality to 40. Or, hold down the Shift key as you drag

the quality slider. The slider then jumps to the most relevant values. Finish by saving your file.

JPEG settings tend to work best for photographic images.

Using AutoLayout to Produce HTML Pages

Now that you’ve completed your design, you can export it as a Web-ready layout using the AutoLayout

feature in Adobe ImageStyler. With AutoLayout, Adobe ImageStyler exports two things: sliced image files

and a table-based HTML page that references those image files and reassembles them with pixel-level accu-

racy. You get a final HTML page that’s ready for posting (or easy to open in an HTML editor for further

tweaking).

Auto Layout offers several key benefits. For example:

• Adobe ImageStyler intelligently determines where the optimal slicing points are for a particular graphic,

saving you the time and energy of deciding by eye.

• ImageStyler can handle a repeating background texture in a layout, treating it as a separate background

pattern file in the HTML it produces.

• You can add, move, resize, and work with objects without manually repositioning slicing guides.

• You can export JavaScript rollover effects without a hitch.

Try it:

1. Choose AutoLayout in the Export palette.

2. Press Ctrl+E/Command+E to export your composition.

3. Launch your Web browser, and open your new Web page to view your final results.

4. If you read HTML code, choose View > Source (or the appropriate command for your Web browser) to

look at the underlying code for this page.

Batch-creation Tools for Timesaving Web Site Production
Adobe ImageStyler offers powerful batch-creation features that help you quickly deploy new graphics. You

can find all instances of plain HTML headings and convert them to graphics with text, such as banners or

buttons, or to graphically styled text in moments. You can also export ImageStyler graphics in a variety of

Web-standard formats. Adobe ImageStyler helps you keep your Web site fresh-looking and inviting, provid-

ing the perfect creative complement to the Web-site management tools you use every day.

Automatically Replacing Plain Text with Graphical Text
If you’ve worked with HTML for any length of time, you’re intimately aware of the 16 core text styles that

HTML offers. In particular, it provides a handful of heading levels: H1, H2, H3, H4, H5, H6, and class

tagged text. These headings add little visual interest or appeal to a site. That’s why Adobe ImageStyler makes

it so easy for you to update a batch of Web pages, replacing any instances of an H1–H6 or class tagged text

with either styled text or graphics with text.

This batch-replacement process is straightforward and far more efficient than deploying graphics by hand:

You simply create a style for each H1-H6 tag you want to replace on your site. For example, you could apply

a mercury style to text and use it to replace all H1 tags; or you could design a button, including the font and

font size for the text on the button, and replace all H4 tags. You could even specify a JavaScript rollover

effect and batch-deploy it across many Web page at once. After you set up your styled text, you use the Web

palette to associate each styled element with the HTML tag it’s replacing. You then choose the Batch Replace

HTML command, select all the HTML files you want to update, and click OK.

About Adaptive Color
Palettes
We designed Adobe
ImageStyler 1.0 to save you
time and effort. That’s why it
automatically generates
adaptive palettes when you
export your Web graphics.
Preferred by Web designers,
these 8-bit custom palettes are
biased towards the colors in
the standard 216-color, Web-
safe palette, but they are
optimized for each image. (A
Web-safe-only palette can be
limiting because its colors tend
to be highly saturated and
weighted towards midtones.)
Basically, adaptive palettes
improve on the Web-safe
palette by honoring other key
colors in an image as well,
letting the Web browser dither
images as necessary. The
results are richer colors on-
screen without too much
dithering.
We’ve also built a Web-safe
color option into the Color
palette. Checking this option
ensures that the colors you
select fall within the 216 colors
that are guaranteed to work
across browsers, platforms, and
8-bit displays.
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Adobe ImageStyler searches out every instance of the HTML tags, replaces them with graphics, and updates

the HTML in the file appropriately. So, for example, you might have all of the navigational links on a site set

up as H4 tags. In a single batch process, you could replace all of these links with handsomely styled buttons

that maintain the original wording and your URL links. A link that said “Order Information” would simply

become an ImageStyler button that says the same thing.

Try it:

1. In a new ImageStyler document, set up the following text styles:

For H1 tagged text: Select the type tool, click an insertion point, and type Head1 Text in the Type Tool

dialog box. Apply 30 point Arial or Helvetica, and click OK. From the Styles palette, select Gold Metal

Embed, and click Apply.

For H3 tagged text: Select the type tool, click an insertion point, and type Head3 Text in the Type Tool

dialog box. Apply 18 point Arial or Helvetica, and click OK. Select the eyedropper tool and sample a

brown shade from the Head1 Text to apply that solid color to Head3 Text. Then select the rounded-

rectangle tool and draw a rounded rectangle that’s a little taller than the 18-point text and runs the

width of your document window. From the Properties palette, click Outline to make it a hollow rounded

rectangle. Then click Gold Metal Embed in the Styles palette, and click Apply.

2. Apply a JavaScript rollover effect to Head3 Text: Select the text, and click the New JavaScript Action

button at the bottom of the JavaScript palette. With the onMouseOver action selected in the palette,

create a new state for the text. Enter 7 for X Offset at the top of the JavaScript palette. Then select the

eyedropper tool and sample a gold applied to Head1 Text to apply that color. Click back and forth be-

tween the two states in the JavaScript palette to see the effect.

3. Save your file.

4. Make the Web palette visible. Then select Head1 Text, and select H1 from the Replace popup menu in

the Web palette.

5. Select Head3 Text, and select H3 from the Replace popup menu.

6. Locate these files in \REV_GD on your reviewer’s CD: boating.html, climbing.html, and

sightseeing.html. Copy them into a folder on your hard disk.

Select the HTML tag that this
styled text should replace.

Select the HTML tag that this
styled text should replace.

Tip
In some instances, you’ll want
your graphical objects to adjust
their size in relation to the text
object when you batch-update a
series of pages. For example, you
may want a button to be an
appropriate size when the word
”Sales” appears on it, and then to
adjust to a different size for the
words ”Customer Service and
Support.” With ImageStyler, this
is easy to do. Just select each
graphic and its text object in
your ImageStyler template, and
choose Object > Maintain
Alignment. Then, the size adjust-
ments happen automatically
during the batch-updating
process.
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7. Launch your Web browser and open the files you copied to see what they look like.

7. In ImageStyler, choose File > Batch HTML Replacement, locate the files you copied, select them all, and

click OK.

ImageStyler automatically finds all instances of an H1 or H3 head and replaces it with your styled text.

8. In your Web browser, click Reload to view an updated version of the last file you loaded. Then open

the other two files to view the changes. Move your mouse over the H3 text to see the JavaScript

rollover effect.
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Using Batch HTML Replacement with Graphical Templates

You can use the Batch HTML Replacement command as a quick way to apply graphical templates. For

example, you set up an ImageStyler composition with the look you want for your buttons and banners.

Then, whenever you need a new set of buttons or banners, you could open an HTML editor, enter the text

for the graphics, and then launch ImageStyler and run batch-update on the HTML document you created.

You instantly get buttons or banners that you can incorporate into your Web site.

Try it:

1. Create a new ImageStyler document and design some button styles (refer to earlier sections of this docu-

ment for ideas). Be sure to associate the styled text for each button with the appropriate tag using the

Web palette.

2. Open an HTML editor, such as Adobe PageMill, and enter text for a dozen buttons. Tag each text entry

with an appropriate H1–H6 tag. Then save the file.

3. In ImageStyler, choose File > Batch Replace HTML, select the files you just created, and click Open to

replace the tagged text.

4. Open the new HTML file in your Web browser to see your new set of buttons.

5. Repeat this process any time you need a new set of buttons with a consistent look.

Automatically Updating Web Graphics
Once you create graphics in ImageStyler and publish them on your Web site, you can update them in a

single efficient step. For example, you could replace all H1 tags with a banner graphic, then tweak that ban-

ner the following week and replace it across all of the relevant pages. When ImageStyler performs the first

batch replacement, it maintains the code that identifies the HTML tag as an H1 tag for easy updating. With

this flexibility, you can create a look for your site, and then make subtle adjustments to it every month or

even every week.

Try it:

• Open the ImageStyler document you saved in the section titled “Automatically Replacing Plain Text with

Graphical Text” and edit your styled text any way you like. Then choose File > Batch Replace HTML,

select the HTML pages you created in the previous section, and click Open to update them automati-

cally. Open the resulting files in your Web browser to see the changes you’ve made.

Exporting Individual Web Graphics
You can export your ImageStyler compositions as JPEG, GIF, and PNG files. You can also export their files

in Adobe Photoshop® (PSD) format and then drop those files into Photoshop or into another program that

accepts PSD files. When you export Web graphics, you control a number of settings that affect the final

quality of your graphics. For example, you can adjust a quality slider to determine the level of quality for a

JPEG file. The higher the setting, the better the quality but the larger the final file. (You can interactively

tradeoff between file size and visual quality using the Active Preview option in the Export palette. For de-

tails, see page 24.) Once you specify your export settings, those settings are saved as part of the ImageStyler

composition. You can then use them the next time you export graphics from that file, or you can change

those settings at any time.

Try it:

1. Choose File > Open, and locate HiLightNavBar.ist in \REV_GD on your reviewer’s CD.

2. Choose Window > Export to open the Export palette, and make sure the Active Preview option is se-

lected in the palette.

3. Select GIF from the popup menu at the top of the Export palette.

4. Adjust the Color slider to the left to reduce the number of colors exported to 128.

Note: The file size updates interactively as you move the slider. This graphic uses a narrow range of

colors, so you can reduce the file size by constraining the number of colors in your composition.

5. Select the Make Page option, and then choose Trimmed Composition from the popup menu next to it.

6. Choose File > Export (or press Ctrl+E/Command+E) to export your file.
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Award-winning Adobe User Interface
Adobe ImageStyler 1.0 sports the Adobe-standard user interface, which has proven popular with many

Adobe customers. This award-winning user interface helps you tailor your work environment and stream-

line your work processes. The program also integrates well with other Adobe products, such as Adobe

Photoshop and Adobe Illustrator®, so you can incorporate design assets from these other Adobe products.

Adobe ImageStyler also offers a complete cross-platform solution for Web graphics creation. This cross-

platform compatibility allows you to share files seamlessly and collaborate effectively in a mixed-platform

workgroup.

Here is a quick overview of some of the key integration features in Adobe ImageStyler 1.0:

Work with Adobe’s award-winning
palettes
Adobe ImageStyler offers a selection
of palettes that put key functionality
right at your fingertips. You can
perform many tasks from applying
graphical styles to exporting your
final graphics and Web-page layouts
using these handy tools. Customize
your work environment by opening
or closing them, rearranging them
on-screen, or moving individual
palettes into different containers to
suit your workflow.

Take advantage of standard
keyboard shortcuts
Wherever appropriate, Adobe
ImageStyler incorporates standard
Adobe keyboard shortcuts. That way,
anyone who has experience with
another Adobe product, such as
Photoshop, can get to work more
easily with Adobe ImageStyler.

Select and work with familiar
tools
Adobe ImageStyler shares tools in
common with other popular
Adobe programs, such as Adobe
Photoshop, Adobe Illustrator,
Adobe ImageReady™, and Adobe
PageMaker® software. Once you
know the tools in one product,
you’ll recognize them in the
others quickly. The result? You can
get to work efficiently with such
standard tools as the basic
drawing tools, the eyedropper
tool, the paint bucket tool, the
hand tool, and more. You can even
use some of the same single-key
shortcuts to access common tools
across these programs.

Drag and drop graphics from
other Adobe products to
ImageStyler, and vice versa
Adobe ImageStyler supports drag-
and-drop functionality between
programs for a more efficient
workflow. You can drag and drop
graphics back and forth from
ImageStyler to any program that
supports this feature, including
Photoshop, Illustrator, Microsoft®

Office and certain HTML editors,
such as Adobe PageMill® and
Microsoft FrontPage®. You can also
drag and drop any GIF, JPEG, PICT
(Macintosh only), and BMP (Win-
dows only) files into ImageStyler.

Import a range of image file formats
Adobe ImageStyler uses Photoshop import
and acquisition plug-ins to import a range of
image file formats. You simply choose the
Adobe-standard Place command to embed
files saved in EPS, Compuserve® GIF, JPEG,
PSD, DIB (Windows), BMP (Windows), and
PICT (Mac OS) formats. You can also bring in
images from a range of ImageStyler-compat-
ible or TWAIN-based scanners and digital
cameras. And you can replace imported files
with the Replace command—the replaced
image then takes on any style, attributes,
transformations, or embedded URLs that you
applied to the first image.
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installation
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color display (recommended)
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(required), Mac OS Software
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mended)

• 32 MB of RAM (required), 64 MB of
RAM (recommended)

• 40 MB of free hard-disk space for
installation

• 256-color display (required), 24-bit
color display (recommended)

• CD-ROM drive

* System requirements may change
prior to shipping.

About Adobe Systems
Adobe Systems Incorporated, the award-winning provider of graphics and publishing solutions, gives you

the power to make your ideas stand out exactly as you intend. Whether you work in a design studio, an

office, or at home, Adobe’s software, images, type, and printing technologies offer you a seamless workflow

for creating and distributing graphically rich communications in print and electronic media.
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