Accessibility

Support Knowledgebase

Optimize performance in Illustrator (CS-CS2 on Mac OS X)

What's covered

Optimizing the Mac OS configuration

Optimizing the hardware configuration

Using Illustrator features effectively

The performance of Adobe Illustrator depends on several factors, including the options you select, your workflow, and the operating system and hardware configuration. The performance improvements listed below are most noticeable when you work with larger files. Optimizing the Mac OS and hardware configurations improves performance in other applications as well.

Before you perform the steps below, make sure to install the latest version of Illustrator or any Illustrator updates to the version you are using. Illustrator updates often include performance-related fixes or enhancements. Current version information and updates are available on the Adobe website at www.adobe.com .

Optimizing the Mac OS configuration

If you configure your system to run efficiently, then you increase the amount of memory available to applications and ensure that they run smoothly. Quit applications that you aren't using or disable nonessential fonts to improve the performance of Illustrator.

Fonts

If you install only the fonts you need, then you will improve system performance and the performance of applications that access fonts. Each installed font increases the amount of RAM used by the system, which decreases the amount of RAM available to open applications and increases the amount of time applications take to display font menus. Use a font management utility, such as Extensis Suitcase, to help you manage a large number of fonts.

Printer drivers

Because non-PostScript printer drivers can conflict with Illustrator, Adobe recommends that you set a PostScript printer driver as the default printer in Mac OS.

Note: To complete this procedure, a PostScript printer must be connected to the computer either directly or via a network.

To set a PostScript printer as the default printer:

1. At the Finder, choose Go > Applications, open the Utilities folder, and then double-click Printer Setup Utility (Mac OS X 10.3 or later) or Print Center (Mac OS X 10.2.8 or earlier).

2. If a PostScript printer isn't listed, click Add Printer, navigate to a PostScript printer, and then click Add.

3. Select a PostScript printer, and then choose Printers > Make Default.

To configure Illustrator to print to a nondefault printer:

1. In Illustrator, choose File > Print.

2. Choose the printer from the Printer menu.

3. Click Done to close the Print dialog box, or Print to print the file.

Optimizing the hardware configuration

The hardware you use affects the performance of Illustrator: The faster the processor or hard drive, the faster Illustrator can process information. Other hardware enhancements, such as installing additional RAM, using a multiprocessor system, or optimizing and defragmenting drives, can also improve performance.

Processor speed

Because Illustrator manipulates large quantities of data and performs many calculations, its speed is limited by the speed of the computer processor: The faster the processor, the faster Illustrator performs.

Installed RAM

If Illustrator has insufficient RAM, it uses hard disk space (that is, a scratch disk) to process information. Illustrator is fastest when it can process file information in memory, without having to use the hard disk.

Hard disks

As you add, delete, and move files on a hard disk, available space is no longer a single, contiguous block. If the system does not have enough contiguous space, it saves fragments of a file to different locations on the hard disk. An application requires more time to read a fragmented file than one saved to a contiguous location. You can defragment files and optimize available hard disk space by using a third-party disk utility (for example, Norton Utilities).

Since Illustrator reads and writes information while working on a file, the faster the access speed of the disk containing the file or the Illustrator scratch disk, the faster Illustrator can process file information. To improve the performance of Illustrator, work on files saved on drives with fast access speeds, such as an internal hard drive, rather than those with slow access speeds, such as a network server (a network drive) or removable media (for example, a Zip drive, or a diskette). Removable media often have slower access times and are more easily damaged than internal hard drives.

When you want to save an Illustrator file to a network or removable drive, Adobe recommends you first save the file to an internal hard disk, and then close the file and use the Finder to copy the closed file to the external or network drive, or save the file to the network using Adobe Version Cue.

Printer language

For best results when printing from Illustrator, use a PostScript printer. Because most non-PostScript printers rely on display information, host computer resources, and proprietary printer drivers to relay print information to the printer, they may take much longer to print than a PostScript printer.

Using Illustrator features effectively

The way you work in Illustrator, and especially the way you view artwork, can effect the performance of Illustrator. Modifying view options, linking images rather than embedding them, and optimizing scratch disk and startup options can all affect the speed of Illustrator and its memory usage.

Outline view

Outline view hides paint attributes, displaying the artwork as unfilled paths. Working in Outline view can speed the display of complex artwork, such as objects containing gradients or patterns. Outline view can also make it easier to edit objects hidden behind other filled objects. Choose View > Outline to display a document in outline mode.

For more information about viewing artwork in Illustrator, see Illustrator Help.

Custom views

You can create custom views of your document, allowing you to quickly change the view mode, magnification, scroll position, and layer options by choosing a custom view from the View menu. To create a custom view, set the view attributes you want to save, choose View > New View, and enter a name in the New View dialog box. The custom view appears in the View menu.

Display performance

You can specify the quality and speed of the display when you move the artboard using the Hand tool. To specify the display quality, choose Illustrator > Preferences > Units & Display Performance. Drag the Hand Tool slider to the left to improve the display quality when you use the Hand tool, or move it to the right to improve speed.

Raster effect resolution

You can change the resolution of raster effects to optimize the performance of Illustrator. To change the resolution of raster effects, choose Effect > Document Raster Effects Settings, do one of the following, and then click OK:

-- If you are editing files, click Screen. Illustrator uses a resolution of 72 ppi for raster effects, increasing display speed.

-- If you are printing files, click High. Illustrator uses a resolution of 300 ppi for raster effects, decreasing printing speed but increasing print quality.

Layers palette

The Layers palette lets you easily organize and modify artwork. When you hide layers that contain complex artwork or high resolution bitmap images, Illustrator redraws the screen faster. To hide a layer, click the eye icon to the left of the layer's name. To hide all but the selected layer, Option-click the eye icon.

The Layers palette can display thumbnails for top-level layers, nested layers, groups, and objects. You can reduce the number of thumbnails so Illustrator redraws the screen faster:

1. Choose Palette Options from the Layers palette menu.

2. Reduce the number of thumbnails:

-- To remove all thumbnails from the Layers palette, select Small in the Row Size section, and then click OK.

-- To remove thumbnails for specific elements in the Layers palette, deselect Layers, Groups, or Objects in the Thumbnails section, and then click OK.

Scratch disk

When you work with an embedded bitmap image, and the system doesn't have enough RAM to perform an operation, Illustrator uses hard disk space as a scratch disk. Because it takes longer to access information on a hard disk than it does to access information in memory, using a portion of the hard disk as virtual memory can decrease performance. If you need more memory to work in Illustrator, Adobe Systems recommends installing more RAM.

By default, Illustrator uses the system drive as its primary scratch disk. You should change the Illustrator primary scratch disk setting to your fastest hard drive.

To change the scratch disk preference:

1. Choose Illustrator > Preferences > Plug-ins & Scratch Disk.

2. Choose a hard disk from the Primary pop-up menu. If you intend to work with large images and have more than one hard disk, choose another disk from the Secondary pop-up menu.

3. Click OK and restart Illustrator.

Note: Adobe recommends that you use a disk utility, such as Norton Utilities or TechTool Pro, to optimize and defragment the hard disk regularly.

Illustrator startup files

Adobe Illustrator startup files contain the default patterns, gradients, graph designs, colors, and color libraries that appear in new Illustrator documents. These files also determine zoom level, window size, viewing preferences, and scroll position for new documents. You can minimize the file size of new documents by removing unnecessary swatches, gradients, graphic styles, and brushes from Adobe Illustrator startup files.

For instructions on creating custom startup files, see Illustrator Help.

Templates

Templates let you create new documents that share common settings and design elements. For example, to design a series of business cards with a similar look and feel, create a template with the desired artboard size, view settings (such as guides), and print options. You can minimize the file size of new documents by removing unnecessary swatches, symbols, graphic styles, and brushes from templates.

Templates offer a powerful alternative to creating custom startup files. While you can create only two custom startup files (one for CMYK mode and one for RGB mode), you can create an unlimited number of templates. In addition, you can store and access templates anywhere, as opposed to startup files, which must have a specific name and location.

For instructions on creating template files, see Illustrator Help.

Linked files

Embedded bitmap images (such as TIFF, BMP, or Photoshop EPS) can dramatically increase the size of an Illustrator document, causing slower performance. To improve performance, select Link in the Place dialog box when you place a bitmap image. The Link option references the placed image on the hard disk. (If a service bureau requires embedded images, save a copy of the file and select Include Linked Files in the Illustrator Native Format Options or EPS Format Options dialog box.)

Note: Illustrator CS embeds linked images if you apply a filter to them. Illustrator CS2 does not allow you to apply a filter to a linked image.

EPS previews

If a document contains linked EPS images with high-resolution previews, Illustrator may redraw the screen slowly as you edit artwork. To allow Illustrator to redraw the screen more quickly, use low-resolution EPS previews: Choose Illustrator > Preferences > File Handling & Clipboard, select Use Low Resolution Proxy for Linked EPS, and then click OK.

Show DCS Transparency Interactions option

The Links Palette Options dialog box includes a Show DCS Transparency Interactions option for Illustrator CS2 and a Show Transparency Interactions option for Illustrator CS. If this option is selected, the Links palette displays a yellow icon to identify linked DCS EPS graphics that are transparent or overlap transparent objects. Because this option forces Illustrator to regularly determine if linked EPS files interact with transparency, it can reduce performance.

To disable the Show Transparency Interactions option:

1. Choose Palette Options from the Links palette menu.

2. Deselect Show DCS Transparency Interactions for (Illustrator CS2) or Show Transparency Interactions (Illustrator CS), and then click OK.

Navigator palette

The Navigator palette displays a thumbnail view of the current artwork for easy navigation. Depending on the complexity of the artwork, a substantial amount of processing time may be required to update the thumbnail each time you make a change. To improve screen redraw speed and performance in a complex Illustrator document, hide the Navigator palette by choosing Window > Hide Navigator.

You can set up custom views to more efficiently zoom to particular areas of your document. See the Custom Views section of this document for more information.

Anti-Alias Artwork option

The Anti-Alias Artwork option smoothes text and graphics by blending the color of an object's edge pixels with that of adjacent pixels. However, this process can cause slow screen redraw. To disable this option, choose Illustrator > Preferences > General, deselect Anti-aliased Artwork, and then click OK.

Simplify command

The Simplify command reduces the amount of anchor points in paths and path shapes, reducing file size and increasing performance. To apply the Simplify command, select the desired path or object, and then choose Object > Path > Simplify.

For more information on the Simplify command, see Illustrator Help.

Smart Guides

Smart Guides allow you to create, align, edit, and transform Illustrator objects relative to other objects. If artwork contains a large number of objects, Illustrator requires more time to display Smart Guides. To disable Smart Guides, choose View > Smart Guides. A check mark appears next to the command when Smart Guides are enabled.

For more information on Smart Guides, see Illustrator Help.


Related Documents

Document 326405
Last edited - 04/22/2005

 

Got Some Time to Take a Survey?

Tell us what you think about this support site.