Accessibilité

Notes d'accompagnement de Flash

Notes d'accompagnement de Macromedia Flash MX 2004 et de Flash MX Professionnel 2004

Ce document aborde des questions qui ne sont pas abordées dans la documentation de Macromedia Flash MX 2004 et de Flash MX Professionnel 2004. Il peut être mis à jour si de nouvelles informations sont disponibles.

Flash MX 2004 et Flash MX Professionnel 2004

Les solutions Flash MX 2004 et Flash MX Professionnel 2004 permettent d'enrichir des contenus Internet et de développer des applications Web complexes. Que vous souhaitiez créer des graphismes animés ou des applications de données dynamiques, les produits Flash MX 2004 comportent tous les outils nécessaires pour produire des résultats à la hauteur de vos espérances et offrir les meilleurs résultats sur les principales plates-formes, ainsi que sur la plupart des périphériques communiquants (assistants personnels et téléphones portables).

Ces notes d’accompagnement ont été actualisées avec la description des mises à jour de Flash MX 2004 et Flash MX Professionnel 2004.

Configuration requise

A compter de cette version, les applications Flash MX 2004 et Flash MX Professionnel 2004 ne prennent plus en charge Windows Me, Windows NT, Macintosh OS 9 ni OS& 10.2.5 et versions antérieures. Pour plus d'informations, reportez-vous à la section configuration système requise pour Flash MX 2004 et Flash MX Professionnel 2004.

Problèmes communs aux plates-formes Windows et Macintosh

Mise à jour de l'aide (versions 7.1 et 7.1.1 uniquement)

Lors de la première exécution de Flash, vous êtes invité à télécharger et mettre à jour l'aide de votre application. Nous vous invitons à effectuer cette opération, afin de disposer de la documentation la plus récente sur le produit.

Le système d'aide est régulièrement mis à jour avec les rectificatifs et les nouvelles informations disponibles. Pour vérifier la disponibilité de mises à jour de l’aide après l'installation de Flash, affichez le panneau Aide (Aide > Aide), puis cliquez sur le bouton Mettre à jour. Si de nouveaux fichiers d'aide sont disponibles, une boîte de dialogue vous invitant à les télécharger s'affiche à l'écran. Cliquez sur Oui pour effectuer la mise à jour. Macromedia recommande de vérifier la disponibilité de ces mises à jour au minimum une fois par mois.

Compatibilité ascendante de Flash MX 2004 et de Flash MX Professionnel 2004

En raison des nouvelles fonctionnalités des versions 2004, il est impossible d'ouvrir dans Flash MX un fichier source (FLA) créé dans Macromedia Flash MX 2004 ou Flash MX Professionnel 2004. Toutefois, la commande « Enregistrer au format Flash MX » (décrite dans le guide Utilisation de Flash) permet d'enregistrer un document au format .FLA de Flash MX. Si vous enregistrez un fichier dans ce format, les fonctionnalités spécifiques à la version 2004 seront perdues.

Pour toucher un plus large public, vous pouvez également exporter un fichier source Macromedia Flash MX 2004 ou Flash MX Professionnel 2004 dans le format Flash Player version 2, 3, 4, 5 ou 6 (.SWF). Les fonctionnalités non prises en charge dans ces versions risquent de ne pas fonctionner.

La meilleure méthode pour copier des éléments de fichiers créés dans Flash MX vers des fichiers créés dans Flash MX 2004 ou Flash MX Professionnel 2004 consiste à ouvrir ces fichiers dans ces applications, puis à copier et coller les éléments directement dans l'application Flash.

Il est impossible de copier du texte d'un fichier ouvert dans Flash MX 2004 ou Flash MX Professionnel 2004 vers un fichier ouvert dans Flash MX. Pour effectuer ce type d'opération, enregistrez le fichier au format Flash MX avant de l'ouvrir dans Flash MX.

Composants

Flash MX 2004 et Flash MX Professionnel 2004 sont livrés avec un jeu complet de nouveaux composants d’interface utilisateur. Rédigés en langage ActionScript 2.0, ces composants reposent sur une nouvelle architecture qui offre à la fois une meilleure stabilité et plus de fonctionnalités que les composants Flash MX.

Transfert d'applications existantes comportant des composants
En raison des nombreuses modifications apportées à l'architecture des composants, le transfert des applications conçues avec des composants Flash MX vers le nouveau jeu de composants 2004 nécessite un travail de développement conséquent. Il est possible de poursuivre le développement d’applications avec les composants Flash MX présents dans les produits Flash MX 2004 sans mettre à niveau le jeu de composants.

Flash Player 6.0.79.0 nécessaire pour les composants
Les composants Flash MX 2004 et Flash MX Professionnel 2004 prennent en charge le format SWF des versions 6 et 7 de Flash Player. En revanche, les composants des versions 2004 ne sont pas compatibles avec les versions de Flash Player antérieures à la version 6.0.79.0. La fonctionnalité de détection de la nouvelle version de Flash Player permet de détecter si le visiteur dispose de Flash Player 6.0.79.0 ou d'une version ultérieure ; pour plus d'informations, consultez la section « Configuration des paramètres de publication pour la détection de Flash Player » dans le guide Utilisation de Flash.

Taille des composants de Flash MX 2004
Les composants de Flash MX 2004 et Flash MX Professionnel offrent de nombreuses nouvelles fonctionnalités. C'est pourquoi la taille des fichiers SWF contenant les composants des versions 2004 peut être plus importante que celle des fichiers SWF équivalents dans Flash MX. Cette différence s'explique par les nombreux nouveaux services offerts par ces composants et par la sophistication de leur infrastructure.

Les composants de Flash MX et Flash Player 7
Il est possible d’utiliser les composants de Flash MX dans Flash MX 2004 et Flash MX Professionnel 2004. Toutefois, ils risquent de ne pas fonctionner en cas de publication dans le format Flash Player 7. Si votre application fait appel à des composants Flash MX, continuez à la publier dans le format SWF pour Flash Player 6.

Vous pouvez aussi télécharger un jeu actualisé de composants pour Flash MX qui ont été modifiés pour prendre en charge Flash Player.

Compatibilité ascendante de Flash Player 7 – voir les notes d'accompagnement de Flash Player 7.

Les nombreuses modifications apportées à Flash Player 7 risquent d'entraîner certains dysfonctionnements lors de la publication de scripts dans le format SWF de Flash Player 7. Ces modifications, ainsi que les procédures permettant d'adapter les contenus existants au nouveau format, sont décrites dans la section « Portage de scripts existants sur Flash Player 7 » du Guide de référence ActionScript.

Les fonctions ci-dessous sont notamment susceptibles de provoquer des problèmes lors de la publication de contenu existant vers le format SWF de Flash Player 7 :

- Conformité à la norme ECMA-262
- Filtrage de domaine (modèle de sécurité Flash Player 7)

Le transfert d'animations Flash du format SWF de Flash Player 6 à Flash Player 7 nécessite un travail de développement conséquent. Si vous n'avez pas besoin des nouvelles fonctionnalités de Flash Player 7, il est recommandé de continuer à publier vos contenus au format SWF de Flash Player 6.

Extension Manager

Macromedia Extension Manager est disponible sur le CD-ROM de Flash. Vous pouvez également télécharger la dernière version d’Extension Manager depuis le site Macromedia Exchange pour Flash.

Problèmes liés au texte

Si le chemin d'enregistrement du fichier FLA contient des caractères sur deux octets sur un ordinateur ne gérant pas ce jeu de caractères, les composants et le texte ne s'affichent pas lors de l'exécution du fichier.

La méthode de transformation du texte a été modifiée. Dans Flash MX, le texte était assimilé à une forme et se transformait par rapport à l'angle opposé. Dans Flash MX 2004 et Flash MX Professionnel 2004, le texte est plutôt assimilé à un symbole et se transforme par rapport au point de transformation.

Importation de fichiers EPS

En raison d’une limite imposée par la technologie utilisée, l'importation de fichiers EPS d'Illustrator vers Flash ne permet pas de préserver les calques. Vous pouvez résoudre ce problème en important les fichiers au format Adobe Illustrator ou PDF.

Vidéo et son

Certaines fonctionnalités vidéo nécessitent l'installation de QuickTime. Pour plus d'informations, voir la section Configuration système requise.

Codecs Vidéo - Flash prend en charge toutes les fonctionnalités de QuickTime et AVI, mais certains codecs peuvent entraîner différents problèmes.

La liste ci-dessous répertorie les codecs vidéo pour le format QuickTime susceptibles de bloquer l'application Flash :

  • Intel Indeo Video
  • SoftDV

Il est également impossible d'importer des flux vidéos au format MPEG dans Flash via QuickTime.

Pour une utilisation avec QuickTime, il est recommandé d’utiliser les codecs vidéo suivants :

  • Vidéo non-compressée
  • Sorenson Video 1, 2 et 3
  • JPEG animé A et B

Il est impossible de modifier ou d'obtenir un aperçu des fichiers vidéo au format WMV.

L'importation de fichiers AVI à l'aide du codec vidéo Intel Indeo ne fonctionne pas correctement.

Codecs audio - Il est également possible que des problèmes surviennent lors de l'utilisation de certains codecs audio. En principe, la fenêtre d'importation vidéo affiche un message d'avertissement pour les plages audio utilisant des codecs non pris en charge. Les codecs audio non pris en charge sont les suivants :

  • IMA 4:1
  • Certains codecs vidéo et audio pour Windows provenant d’éditeurs tiers sont susceptibles de provoquer des problèmes, notamment de distorsion des séquences audio et vidéo et de blocage de l'application. Le cas risque de se produire, par exemple, avec les codecs vidéo MPEG2 généralement livrés avec les logiciels de lecture de DVD.

Pour une utilisation avec QuickTime, les codecs audio suivants sont recommandés :

  • Audio non-compressé
  • ALaw 2:1
  • ADPCM

Mémoire - De manière générale, les séquences vidéo utilisent beaucoup de mémoire. Lors de l'importation de longues séquences vidéo, vous risquez de ne pas disposer d'une quantité de mémoire suffisante. Pour économiser de la mémoire, il est recommandé de désactiver l'importation audio. En effet, les séquences audio importées ne sont pas compressées en mémoire vive.

Comme avec la plupart des applications de développement multimédia, l'allocation d'une quantité de mémoire plus importante peut faciliter la gestion des longues séquences vidéo ou d'autres fichiers multimédia dans Flash.

ActionScript 2.0 - mot-clé « dynamic »

Le comportement du mot-clé «dynamic» d’ActionScript 2.0 a fait l'objet d'une modification après la finalisation de la documentation d’origine. Auparavant, chaque sous-classe d'une classe dynamique était automatiquement dynamique. Dès lors, la vérification des types de données sur ces classes était moins rigoureuse, puisqu'elle autorisait l'ajout dynamique (lors de l'exécution) de propriétés et de méthodes. Nous avons décidé de faire une exception pour la classe MovieClip, car il est fréquent de créer des sous-classes MovieClip afin d'associer la classe à un symbole MovieClip. Les sous-classes de MovieClip ne sont plus automatiquement dynamiques. Pour ce faire, elles doivent dériver d’une classe dynamique autre que la classe MovieClip, ou vous devez les modifier explicitement en leur donnant l'attribut « dynamic ». Les utilisateurs ont ainsi la possibilité de contrôler la rigueur de la vérification des type de données de leurs sous-classes MovieClip. Cette modification a été signalée dans une mise à jour des fichiers d'aide.

Problèmes spécifiques à Windows

Installation

Pour installer Flash MX 2004 ou Flash MX Professionnel 2004 sous Windows 2000 ou Windows XP, vous devez avoir ouvert une session en tant qu'administrateur. Il est également recommandé qu’un administrateur procède à l'activation du produit, afin que tous les utilisateurs de l'ordinateur puissent y avoir accès.

Extensions des fichiers non enregistrés

Si vous envoyez un document Flash par courriel avant de l'enregistrer, son extension risque de ne pas être valide. Veillez à enregistrer vos documents Flash avant de les envoyer en pièce jointe.

Problèmes spécifiques au Macintosh

Installation

Pour installer Flash MX 2004 ou Flash MX Professionnel 2004 sur OS X, vous devez disposer des droits d'administrateur. Il est également recommandé qu’un administrateur procède à l'activation du produit, afin que tous les utilisateurs de l'ordinateur puissent y avoir accès.

Prise en charge du formatage UFS

Flash MX 2004 et Flash MX Professionnel 2004 ne sont pas compatibles avec les disques durs Mac formatés en UFS. Un certain nombre de problèmes, répertoriés par Apple, se produisent avec les applications Carbon. Le formatage UFS n’est recommandé et pris en charge par Apple que pour les applications natives (par exemple Cocoa).

Caractères ASCII supérieurs dans les noms de fichiers .swf
Sur Mac OS X, si le nom d’un fichier .swf comporte des caractères figurant dans la moitié supérieure de la table ASCII (caractères accentués en particulier), par exemple « Français.swf », un message d’erreur s’affiche. De plus, l’animation Flash ne s’affiche pas dans le navigateur. Ce dysfonctionnement est présent au moins depuis Flash Player 6.

Il semble qu’il ne soit pas possible de créer un fichier HTML comportant un nom de fichier .swf avec des caractères de la partie supérieure de la table ASCII et de l’afficher localement dans un navigateur Web. Il est donc recommandé de ne pas saisir ces caractères dans le nom du fichier .swf.

Caractères ASCII supérieurs dans les noms de fichiers .fla
Avec Mac OS X, si vous créez un fichier avec un contenu multilingue à l’aide du panneau Chaînes et l’enregistrez en .fla en lui donnant un nom comportant des caractères figurant dans la moitié supérieure de la table ASCII, le panneau Sortie affiche le message d’erreur suivant en mode Tester l'animation : « Erreur à l’ouverture de l’URL »

Cette erreur ne se produit que si l’option « Insérer l’ActionScript de détection automatique de langue » a été activée dans la boîte de dialogue Paramètres du panneau Chaînes. Lors du test de l’animation, le panneau de sortie apparaît parce que Flash ne trouve pas le fichier XML dont le nom contient des caractères figurant dans la moitié supérieure de la table ASCII.

Il est conseillé de renommer le fichier .fla avec des caractères non accentués.

Fireworks / Lancer et modifier
Cette note concerne uniquement les utilisateurs dont le nom de volume Mac comporte des caractères figurant dans la moitié supérieure de la table ASCII.

Si vous travaillez dans Flash et lancez Fireworks pour modifier un graphisme bitmap, les modifications n’apparaissent pas dans Flash lorsque vous cliquez sur le bouton Terminé dans Fireworks. Le problème ne se produit que lorsque le fichier PNG a été enregistré dans un dossier personnel de l’utilisateur, par exemple Documents.

Toutefois, si le fichier PNG est enregistré sur le disque dur (c’est-à-dire si d’autres utilisateurs peuvent également l’ouvrir), le fichier ne s’ouvrira pas du tout au lancement de Fireworks, et un message d’erreur affichera « Fichier introuvable ».

Si vous utilisez cette fonctionnalité fréquemment, il est fortement recommandé d’ouvrir une instance séparée de Fireworks pour modifier vos fichiers PNG et de les réimporter ensuite dans Flash, ou de donner à votre volume Mac un nom ne comportant pas de caractères figurant dans la moitié supérieure de la table ASCII.

Mise à jour de Flash MX 2004 et Flash MX Professionnel 2004, version 7.1.1.

Installation de la mise à jour
Si Flash MX 2004 ou Flash MX Professionnel 2004 est déjà installé sur votre ordinateur, il n’est pas nécessaire de le désinstaller avant d’exécuter l’installation de la mise à jour. Cette mise à jour remplace le programme Flash MX 2004 ou Flash MX Professionnel 2004 actuel. Avant de débuter l'installation de la mise à jour, veillez à fermer Flash et vérifiez que vous avez ouvert une session avec les droits Administrateur.

Après l’installation de la mise à jour
Cette section ne concerne que les utilisateurs qui avaient installé Flash MX 2004 ou Flash MX Professionnel 2004, puis ont effectué la mise à jour vers la nouvelle version. Les utilisateurs qui n’ont installé que la dernière version ne sont pas concernés. Pour connaître la version du produit dont vous disposez, choisissez Aide > A propos de Flash.

Erreurs de compilation avec les projets existants

Après l’exécution du programme de mise à jour, des erreurs peuvent se produire lors de la compilation de projets existants. Pour les résoudre, supprimez le dossier suivant :

Windows 2000 ou Windows XP : C:\Documents and Settings\Nom_Utilisateur\Local Settings\Application Data\Macromedia\Flash MX 2004\langue>\Configuration\Classes\aso

Windows 98 : C:\Windows\Profiles\Nom_Utilisateur\Application Data\Macromedia\Flash MX 2004\<langue>\Configuration\Classes\aso

Mac OS X : Disque dur:Users:Nom_Utilisateur:Library:Application Support:Macromedia:Flash MX 2004:<langue>:Configuration:Classes:aso

Mise à jour de projets comportant des liaisons de données

Si l’un de vos projets existants contient des liaisons de données, vous devez le mettre à jour avec la nouvelle version. Pour ce faire, procédez comme suit :

Remarque : faites une copie de sécurité de votre projet avant de le mettre à jour.

1. Ouvrez votre projet dans Flash MX Professionnel 2004.
2. Ouvrez le panneau Bibliothèques communes (Fenêtre > Autres panneaux > Bibliothèques communes > Classes.
3. Mettez à jour votre projet avec la dernière version du clip compilé DataBindingClasses, en utilisant l’une des méthodes suivantes :

a. faites glisser le clip compilé DataBindingClasses depuis la bibliothèque Classes dans votre bibliothèque.
b. faites glisser le clip compilé DataBindingClasses depuis la bibliothèque Classes sur la scène, puis supprimez-le.

Si la boîte de dialogue « Résoudre les conflits de bibliothèque » apparaît, choisissez l’option « Remplacer les éléments existants ».

Problèmes résolus
Cette section s’applique à la version 7.1.1 de Flash MX 2004 et Flash MX Professionnel 2004.

Licence en volume ou utilisateurs multiples
Dans le cas où un utilisateur non Administrateur exécutait Flash après qu’un Administrateur ait effectué l’installation sans enregistrer le logiciel, le problème suivant se présentait : l’utilisateur non Administrateur se vayait demander sans nécessité le numéro de série au second lancement de Flash. Ce problème a été résolu. Il est donc conseillé aux utilisateurs de Flash dans des environnements de licence en volume ou d’utilisateurs multiples d’installer cette mise à jour.

Flash MX Professionnel 2004 en mode d’évaluation
Dans certains cas, des utilisateurs non Administrateurs ne pouvaient pas exécuter Flash MX Professionnel 2004 en mode d’évaluation. Ce problème a été résolu.

Comportement Rembobiner
Une mise à jour du comportement Rembobiner peut être téléchargée ici. Avec ce nouveau comportement, un clic maintenu sur le bouton de rembobinage effectuera un rembobinage en continu de l’animation, et non plus de deux images uniquement.

 

Mise à jour de Flash MX 2004 et Flash MX Professionnel 2004, version 7.2

Installation de la mise à jour

Si Flash MX 2004 ou Flash MX Professionnel 2004 est déjà installé sur votre ordinateur, il n’est pas nécessaire de le désinstaller avant d’exécuter l’installation de la mise à jour. Cette mise à jour remplace le programme Flash MX 2004 ou Flash MX Professionnel 2004 actuel. Avant de débuter l'installation de la mise à jour, veillez à fermer Flash et vérifiez que vous avez ouvert une session avec les droits Administrateur.

Des mises à jour seront disponibles dans toutes les langues dans lesquelles Flash MX 2004 et Flash MX Professionnel 2004 ont été traduits. Vous ne pouvez effectuer une mise à jour de Flash que dans la langue pour laquelle le programme d’installation a été prévu.

Désactivation et réactivation des extensions

En raison des modifications que cette mise à jour effectue dans les dossiers Configuration (voir ci-dessous la section « Problèmes résolus »), il est conseillé aux utilisateurs de Flash MX 2004 ou Flash MX Professionnel 2004 qui ont installé les extensions Flash de désactiver celles-ci avant la mise à jour à la version 7.2. Consultez cette Technote* pour plus d’informations.

Problèmes identifiés

À la suite de la mise à jour vers la version 7.2, les utilisateurs de la version anglaise de Flash sur l’une des versions européennes de Windows (italienne, française, allemande ou espagnole) peuvent noter un problème de duplication de leurs dossiers Local Settings et Application Data. Les dossiers Local Settings et Application Data existent toujours, mais ils sont dupliqués avec des noms localisés. En conséquence, certains éléments peuvent également apparaître en double dans l’interface de Flash. Le palliatif consiste à désinstaller totalement la version existante de Flash, à supprimer manuellement les deux jeux de dossiers, puis à exécuter la nouvelle version du programme d’installation de la version 7.2.

La position du panneau Bibliothèque n’est pas toujours mémorisée. En raison de sa portée et de sa complexité, ce problème n’est pas résolu par la présente mise à jour, mais sa correction est prévue pour la prochaine version complète de Flash.

À la suite d’événement Mouse down sur le rail et le curseur de défilement du composant UIScrollBar, si l’utilisateur relâche le curseur puis clique à nouveau dessus, l’événement onPress n’est pas toujours détecté. Le palliatif consiste à cliquer à deux reprises ou à déplacer légèrement la souris avant de provoquer à nouveau le défilement.

Lors de l’ouverture dans la version 7.2 d’un fichier .fla enregistré dans Flash v7.1.1 sur un Macintosh, les caractères qui ont fait l’objet d’une substitution dans la version Macintosh v7.1.1 ne sont pas convertis à nouveau dans les caractères d’origine.

Les utilisateurs de Flash MX 2004 ou Flash MX Professionnel 2004 qui n’effectuent pas la mise à jour à la version 7.2 ne pourront pas obtenir de nouvelles mises à jour de leurs fichiers d’aide. Pour obtenir les mises à jour des fichiers d’aide, il est nécessaire d’effectuer la mise à jour vers la version 7.2.

Sur le Macintosh, les utilisateurs disposant de plusieurs ports Ethernet peuvent se voir demander de réactiver le logiciel lors d’une mise à jour de Flash MX 2004 vers la version 7.2.

L’installation de la version 7.2 modifie le fichier du comportement Déclencher une source de données. Si des extensions provenant d’autres éditeurs ont enregistré des modifications dans ce fichier, ces modifications sont alors supprimées. Il est donc nécessaire de modifier manuellement ce fichier pour y réintégrer ces modifications. Ce fichier se trouve dans le chemin C:\Program Files\Macromedia\Flash MX 2004\fr\First Run\Behaviors\Trigger.xml (sous Windows) ou <HD>/Applications/Macromedia Flash MX 2004/First Run/Behaviors/Trigger.xml (sur Macintosh).

Macintosh uniquement : Il est fortement conseillé de désinstaller les composants Flash Remoting AS 2.0 déjà installés avant d’exécuter le programme d’installation de la mise à jour, puis de les réinstaller après cette mise à jour.

Windows 2000 uniquement : L’exécution à deux reprises successives de la commande Remplacer tout pour un symbole bloque l'application Flash.

Windows uniquement : Une opération de copier/coller depuis Flash MX 2004 ou Flash MX Professionel 2004 et vers Flash MX bloque l'application Flash.

Problèmes résolus

Mises à jour de l’aide et de la documentation

L’un des principaux objectifs de la mise à jour 7.2 était d’améliorer l’aide et la documentation fournies avec le produit. Voici un résumé des modifications :

  • Plus de 400 nouveaux exemples de code ont été ajoutés
  • Le pourcentage des entrées accompagnées d’exemples est passé de 43 % à 98 %
  • La documentation d’ActionScript a été augmentée de 85 %
  • Vingt-et-un nouveaux fichiers FLA d’exemple ont été ajoutés à la documentation, afin d’illustrer des fonctionnalités courantes de l’application
  • Plus de 2000 problèmes ont été corrigés dans la documentation
  • Deux nouveaux chapitres sur l’utilisation des composants ont été ajoutés
  • Deux chapitres existants sur l’utilisation des composants ont été réécrits, avec des informations supplémentaires sur les styles et le réhabillage
  • Les informations sur le style ont été actualisées pour tous les composants

Ces mises à jour de l’aide et de la documentation ne sont disponibles qu’en anglais et en japonais. Les autres versions localisées de Flash MX 2004 et Flash MX Professionnel 2004 version 7.2 contiennent les dernières versions antérieures localisées des fichiers d’aide. Toutefois, la version anglaise des nouveaux fichiers de la documentation au format .PDF figure sur le CD-ROM ou dans le fichier d’installation téléchargé. La nouvelle mise à jour de la documentation est également disponible, au format .PDF, ici.

Les fichiers d’exemples de Flash MX 2004 ont été déplacés dans le dossier « Flash MX 2004\Samples ».
Pour consulter ces fichiers d’exemple, vous devrez ouvrir manuellement ce dossier, car les fichiers ne sont plus accessibles à partir du panneau Aide.

Nouvel exemple : Utilisation des fonctionnalités vidéo avancées (Flash Professionnel uniquement)
Ce nouvel exemple fourni avec Flash démontre quelques-unes des fonctionnalités vidéo les plus perfectionnées de Flash MX Professionnel 2004. L'application vous fera visiter un monde généré par ordinateur en vidéo FLV. Elle permet de définir des signets vidéo et fait la démonstration de techniques vidéo perfectionnées, notamment l’affichage non linéaire, l'exécution de fonctions à partir de points de repère vidéo et l'emploi de code ActionScript pour mettre une vidéo en pause, la rembobiner, la faire avancer et la repositionner. Cet exemple montre également l’utilisation et le contrôle de plusieurs composants MediaDisplay, la synchronisation vidéo et les composants de réhabillage. Ce fichier se trouve dans le dossier \Flash MX 2004\Samples\AdvancedVideo\

Nouvel exemple : Création d’une visionneuse de population (Flash Professionnel uniquement)
Ce nouvel exemple fourni avec Flash démontre une méthode unique et intuitive de visualisation de données. Une carte de 15 pays européens permet de modifier la « population » de chaque pays à l’aide d’une balance. Des silhouettes humaines représentant la population du pays sélectionné sont placées sur la balance. Leur taille augmente automatiquement afin de représenter la population relative de ce pays. Chaque fois que la population d'un pays donné est placée sur la balance, la population totale de chaque plateau est recalculée, et la balance penche du côté qui possède le total le plus élevé. Les services Web sont utilisés pour obtenir les populations initiales des pays. Dans l'exemple, le langage ActionScript est utilisé pour afficher les données, assurer leur suivi et les comparer, ainsi que pour faire fonctionner la balance. Ce fichier se trouve dans le dossier \Flash MX 2004\Samples\PopulationViewer\

Modifications apportées aux dossiers Configuration
Des modifications importantes ont été effectuées par la mise à jour, à la fois sur l’emplacement des dossiers Configuration et sur leur contenu. Des informations détaillées sur le contenu de ces dossiers figurent dans les fichiers Flash MX 2004\fr\Configuration\Configuration_ReadMe.htm (Windows) et Macromedia Flash MX 2004/Configuration/Configuration_ReadMe.htm (Macintosh). Ces modifications sont destinées à réduire considérablement la quantité de données copiées dans les dossiers de l’utilisateur lors de la première exécution du programme, afin de réduire le temps et l’espace disque nécessaires à cette opération.

Problèmes de blocage résolus (les numéros internes des bogues sont indiqués à titre de référence)
96714 : L’utilisation répétitive du bouton Tester le projet (dans le panneau Projet) provoque un blocage sous OS X 10.3
96110 : L’utilisation d’une valeur incorrecte pour définir la propriété Inspectable provoque un blocage.
95197 : La publication d’un champ de texte statique susceptible d'être sélectionné avec un répertoire autre que le répertoire par défaut provoque un blocage
77881 : Le fait de couper une sélection incorrecte d’un écran puis d’annuler cette opération provoque un blocage.
93918 : Sur OS X, en cas d’utilisation de plusieurs moniteurs, la déconnexion d’un de ces moniteurs provoque un blocage.
95086 : La tentative de personnaliser la barre d’outils lorsque l’outil Polygone y figure provoque un blocage de Flash.
93405 : Blocage lors du test d’un fichier erroné, en raison de l’utilisation de l’instruction continue dans un bloc switch/case.
92981 : La publication au format Flash 4/5 de certains caractères en texte dynamique provoque un blocage de Flash.
92051 : L’instruction JSFL moveToFolder provoque un blocage.
91225 : La conversion de fichiers SWC en MovieClips provoque une disparition de leurs instances de la scène, puis un blocage de Flash.
89881 : Blocage de OS X juste avant la création de l'espace de travail lorsqu’il est impossible de charger les fichiers de configuration.
88586 : Dans l’Inspecteur de propriétés, un appui sur la touche Tabulation juste après avoir défini l’URL d’un fichier WSDL provoque un blocage de Flash.
89060 : Après plusieurs opérations de recherche/remplacement, la sélection de l’option Police dans le champ Par : de la page de démarrage provoque un blocage de Flash.
89189 : Dans le panneau d’aide, le fait de cliquer sur un lien pointant sur un fichier qui n’existe pas dans un dossier qui existe provoque un blocage.   
88002 : Sur Macintosh, le fait de copier dans un fichier Flash MX du texte en police Hiragino Kakugo Std W8 et de le coller dans Flash MX2004 provoque un blocage de Flash.
84937 : Un clic sur le bouton Vérifier la syntaxe peut provoquer un blocage de Flash MX2004 dans certaines circonstances.
86169 : Blocage de Flash au démarrage, à l’ouverture du panneau Actions si celui-ci comporte des fichiers xml non valides dans les actions personnalisées.
86430 : L’importation de fichiers .JPGs depuis un CD provoque un blocage de Flash.

Problèmes d’utilisabilité résolus
95826 : Les outils de dessin ne mémorisent pas les paramètres de trait.
95101 : Une boîte de dialogue d’alerte s’affiche au démarrage si le compte de l’utilisateur dispose d’autorisations limitées.
93727 : Un scénario long comportant des dossiers n’est pas correctement actualisé si des dossiers sont développés et réduits.
93025 : Impossible d’utiliser les touches fléchées pour se déplacer dans le panneau Aide après avoir basculé d’une application à l’autre.
92877 : Erreur JSFL à l’ouverture d’un fichier .FLA de Flash MX Professionnel 2004 dans la page de démarrage de Flash MX 2004.
92376 : Lors d’une opération saveAndCompact via JSAPI, les symboles de composants sont remplacés par l’icône générique.
91752 : Problème de retraçage avec du contenu swf après la mise à jour de l’aide si le panneau Aide est ancré.
91590 : Le scénario n’est pas toujours actualisé immédiatement lorsque l’utilisateur supprime un calque à l’aide de l'icône Corbeille.
68801 : Le rechargement d’un composant provoque le développement de tous les dossiers du panneau Composants / l’état du panneau des composants n’est pas mémorisé.
90052 : À la première exécution après l’installation, la mise à jour de l’aide est proposée même si l’aide est à jour.
91274 : Si l’utilisateur clique dans un champ texte dynamique sans avoir effectué de sélection et utilise le curseur de taille du texte, il n’est plus possible de sélectionner le champ texte.
91469 : Le type de fichier PDF ne figure pas dans la liste des options d’importation.
77639 : Le curseur de texte reste visible dans le panneau ActionScript même si celui-ci a perdu le focus.
89730 : Configuration : le panneau d’aide est vide si un utilisateur ouvre une session au moment de l’installation mais pas au moment de l’exécution, et vice-versa (sous Windows 98).
88853 : Les paramètres d’accrochage d’un objet ne sont pas mémorisés entre deux sessions.
78987 : La plupart des raccourcis clavier comportant la touche Option ne fonctionnent pas sur Macintosh.
84661 : Les icônes des projets n’apparaissent pas systématiquement dans le panneau Projet, ce qui rend la fonction d'archivage et d'extraction de fichiers inutilisable.
85775 : Les options Sync et Boucle/Répéter sont désactivées par l’activation d’un lien dans Son du périphérique.
85940 : Échec des options Sync et Boucle/Répéter lors de l’activation d’un lien dans Son du périphérique.

Problèmes de performances et d’utilisation des ressources résolus
79265 : Sur Macintosh, la page de démarrage utilise des ressources processeur même lorsqu’elle est inactive à l’arrière-plan.
88067 : Les fichiers temporaires ne sont pas effacés dans le dossier Configuration.
88130 : Ralentissement/blocage apparent lors du chargement d’une animation contenant beaucoup de code ActionScript.
87225 : Le dossier Configuration au niveau de l'utilisateur est trop important (75 Mo).
87305 : Le temps nécessaire à l’exécution des fonctions Tester l'animation ou Publier se dégrade au fil du temps.
87300 : L’exécution des objets USER consomme trop de ressources / Impossible d’ouvrir Dreamweaver si Flash est en cours d’exécution / Les menus ne se retracent pas correctement lorsque Flash est en cours d’exécution depuis un certain temps.
87051 / 87052 : Le temps de compilation des animations comportant beaucoup d’ActionScript est trop long.

Problèmes de polices et de texte résolus
88847 : La définition de caractères japonais (Shift JIS) en hexadécimal dans ActionScript ne fonctionne pas.
89233 : L’espace interligne du texte dynamique est différent entre la scène et l’exécutable.
68923 : Certaines polices provenant d’éditeurs tiers (CID) ne produisent que des caractères illisibles dans les champs texte.
88268 : Certains caractères japonais sont remplacés (par exemple par des symboles chinois) à la saisie.
71971 : L’espace interligne est trop important pour les polices OTF sur deux octets.
87748 : Certains caractères sur deux octets deviennent illisibles lorsqu’ils sont importés de fichiers EPS sans les informations de police.
87761 : Tous les caractères sur deux octets deviennent illisibles lorsqu’ils sont importés de fichiers EPS sur Mac OS X.

Problèmes d’affichage résolus
81401 : Il est possible de provoquer une situation dans laquelle l’écran perd son association de classes.
89229 : Chemins relatifs incorrects lors de l’utilisation de comportements d’écran.

Problèmes de composants lors de la création résolus
93835 : Les paramètres des composants comportant des listes de types ne sont pas actualisés lors de l’actualisation de ces composants sur la scène.
93876 : La modification manuelle de la propriété horizontale d’un composant SWC provoque une déformation du graphique.
72048 : La création d’un SWC à partir d’un autre SWC ne comporte pas tous les fichiers ASI.
76948 : Le remplissage automatique de la variable _targetInstanceName ne fonctionne pas après la compilation du composant.

Problèmes de composants résolus
87773 : Le composant Scrollbar autonome ne figure pas dans Flash MX 2004.
81829 : DataGrid n’affiche pas correctement l’élément DataProvider d’un composant Dataset.
95544 : L’événement de modification du Menu renvoie la valeur « undefined » pour groupName.
95492 : Composant Menu – Il ne devrait pas être possible de saisir du texte dans les sous-menus d’un élément de menu désactivé.
88021 : Les composants ne fonctionnent pas correctement lors d’un loadMovie si l’animation en cours de chargement a la valeur True pour _lockroot.
86804 : Le composant DataGrid modifiable ne fonctionne pas correctement lorsque la saisie passe par un IME.
86661 : Il est possible de déplacer le composant Alert à l’extérieur de l’écran, sans pouvoir ensuite le ramener dans la partie visible.
86659 : Il est possible de déplacer le composant Window à l’extérieur de l’écran, sans pouvoir ensuite le ramener dans la partie visible.
86651 : L’objet Événement de modification du composant Accordion ne contient pas les paramètres prevValue et nextValue.
86649 : Lorsque le paramètre openDuration du composant Accordion contient la valeur 0, les panneaux enfants de ce composant ne sont pas toujours modifiés.
86598 : Impossible d’ouvrir le composant Menu au clavier si la barre de menu ne comporte qu’un élément.
86595 : ComboBox ne devrait pas déclencher systématiquement un événement de modification lorsque les touches fléchées Haut et Bas sont utilisées.
86589 : Le paramétrage de la propriété monthNames d’un composant DateChooser provoque un changement des noms de mois pour les autres instances de DateChooser.
86578 : Dans un composant DataGrid modifiable, le déplacement avec la touche de tabulation devrait sélectionner tout le texte de la cellule qui reçoit le focus.
86570 : Le paramétrage de la propriété Visible du composant NumericStepper sur False via l’Inspecteur de composants ne fonctionne pas.
86544 : Le composant ComboBox devrait avoir le même attribut restrict que les composants TextInput et TextArea.
86540 : Les événements open() et close() de ComboBox ne sont pas déclenchés au bon moment.
86536 : Les icônes de bouton ne s’affichent pas pour les boutons désactivés.
86532 : En cas d’ajout et de suppression de texte, TextArea devient inutilisable (plus de défilement, et le texte reste entièrement sélectionné).
85999 : Le code du composant Tree teste isNodeVisible au lieu de isNodeVisible(noeud).
85009 : La modification de la couleur d’arrière-plan dans le composant Tree avec la méthode setPropertiesAt ne fonctionne pas correctement si le paramètre openDuration est supérieur à 0. 
84189 : Un composant ComboBox chargé dans un autre swf ferme la liste (propriété dropdown) en cas de défilement de celle-ci.
80473 : La dernière ligne d’un texte sur plusieurs lignes n’apparaît pas dans le composant Alert.
80471 : La propriété addEventListener du composant RadioButtonGroup n’est pas correctement déclarée.
79454 : Impossible de se déplacer par tabulations dans des listes déroulantes modifiables si leurs propriétés tabIndexes snt définies explicitement.
79360 : Le composant Loader ne possède pas de représentation visuelle sur la scène, il est pratiquement impossible de travailler en mode visuel.
79207 : En cas de désactivation de TextAreas, l’utilisation des ressources processeur monte à 100 %.
76154 : Le paramétrage de la propriété Selected du composant Button sur True via l’Inspecteur de composants ou l’Inspecteur de propriétés ne fonctionne pas.
75321 : Défilement dans le composant DataGrid : la suppression d’éléments à partir de la base de la grille désactive le défilement.
71941 : Le composant Menu déclenche un événement de modification en cas de passage sur des éléments à l’aide des touches fléchées.
71844 : Avec le composant ScrollPane, si les propriétés horizontale et verticale de scrollPolicy sont désactivées et si la propriété de scrollDrag est à True, il est possible de déplacer tout le contenu à l’extérieur de l’écran, ce qui le rend impossible à récupérer.
71790 : Les éléments de DataGrid n’apparaissent qu’après un clic dans les en-têtes.
71760 : La barre de défilement horizontal du composant TextArea ne fonctionne pas correctement si la propriété Wordwrap est paramétrée sur False.
71754 : Lors de l’exécution, les composants passent brièvement en Times New Roman (ou dans une autre police à empattement).
70730 : Avec le composant ScrollPane, si la valeur de la propriété vLineScrollSize est supérieure à la valeur résiduelle
à la fin du défilement (maxscroll-currentscroll), mouseWheel ne fonctionne plus.
70161 : Le contenu du composant ScrollPane peut défiler à l’aide de la molette de la souris, même si ce contenu est déjà entièrement visible dans le composant.
69059 : Le composant MenuBar devrait distribuer les événements transmis par ses menus.
69014 : La définition des propriétés hPosition et vPosition d’un composant TextArea provoque le défilement à la fin du texte.
66040 : Le composant Radio Button peut recevoir le focus même sil est désactivé, et son état peut être changé de True à False et vice-versa.
59164 : La propriété Label du composant Button est uniquement lisible lorsque l’utilisateur lui attribue une valeur.
58373 : Les styles de classe ne fonctionnent pas avec le composant List.

Problèmes de fichiers de classes intrinsèques résolus
93379 : TextField.autoSize accepte une valeur incorrecte lors de la compilation.
93790 : Supprimer la méthode AttachVideo() du fichier MovieClip.as.
92827 : Les définitions intrinsèques de MovieClipLoader et Stage ne devraient pas contenir de méthodes d’écouteur d'événement.
87488 : Certaines informations manquent dans les fichiers intrinsèques de classes intégrées .as.

Problèmes JSFL résolus
93805 : L’interligne n’est pas défini correctement à l’aide de JSFL.
87153 : Flash devrait avoir des API JavaScript pour la manipulation de fichiers (E/S).

Problèmes de compilation résolus
89270 : La fonction math.acos appliquée à un chiffre négatif inférieur à 1 renvoie une valeur fausse en cas de publication au format Flash 4.
89271 : La fonction math.asin appliquée à un chiffre négatif ou positif supérieur à 1 renvoie une valeur fausse en cas de publication au format Flash 4.
89274 : La fonction math.pow (var1, var2) renvoie une valeur fausse avec des chiffres négatifs, et 0 en cas de publication au format Flash 4.
79653 : Les puces ne fonctionnent pas avec la propriété htmlText d’un champ texte.
87105 : Compilation incorrecte des arguments de switch en cas de publication au format Flash Player 4 et 5.
79631 : Switch ne fonctionne pas en cas de publication au format Flash 5.
79815 : trace(false !== 1) renvoie false dans Flash MX 2004 mais true dans Flash MX.

Autres problèmes résolus
94994 : Exportation d’images : impossible d’enregistrer un fichier en dehors du dossier « Utilisateurs ».
93512 : Disparition de chaînes du panneau Chaînes.
92155 : Impossible d’afficher et exporter des caractères de polices intégrées dans des champs de texte dynamique et de saisie de texte en cas de publication au format Flash 4 ou 5.
80785 : Le crénage automatique provoque un chevauchement de caractères sous OS X 10.3.
66513 / 76185 : Échec de la mise à jour de l’aide en présence d’un proxy.
89287 : Retour du texte d’origine des chaînes du panneau Chaînes lors d’un changement de focus.
86423 : L'interaction de formation Drag and Drop ne fonctionne pas correctement.
84474 : Le numéro de version 7.1.1 n’est pas renvoyé par les appels au produit.
78012 : Perte de données lors de l’enregistrement de fichiers .fla de diapositives lorsque l’Inspecteur de propriétés a le focus.
79819 : Lors de l’enregistrement du ficher, perte des modifications en actionscript si le navigateur de scripts a été utilisé.
83246 : Un fichier Wave disparaît du scénario lorsque le paramétrage de Sync est changé de Répéter à Boucle.
84989 : Certaines pages d’aide ne sont pas trouvées lors d’une recherche.
88342 : Flash MX 2004 devrait comporter une classe Event Proxy pour faciliter la gestion des problèmes de portée des événements.

Pour soumettre un rapport de bogue à l'équipe Macromedia Flash

Vous avez découvert une bogue ? La première chose à faire est de contacter le support technique de Macromedia. Celui-ci pourra vous aider à résoudre le problème et enregistrera celui-ci. Si vous n'avez plus le droit de bénéficier du service d'assistance, utilisez le formulaire de demande de nouvelles fonctionnalités et de rapport de bogues de Macromedia.

Remarque : en raison du nombre important de messages que nous recevons, nous ne sommes pas en mesure de répondre à toutes les demandes.

Merci d'utiliser Macromedia Flash MX 2004 et de prendre le temps de nous envoyer vos commentaires !

Avertissements, termes et conditions d’utilisation et attribution

Copyright (c) 1993-2004 Macromedia, Inc. et ses concédants de licence. Tous droits réservés. Macromedia, le logo Macromedia, Flash et Macromedia Flash sont des marques commerciales ou des marques déposées de Macromedia, Inc. aux États-Unis et/ou dans d'autres pays. Les autres noms ou marques appartiennent à leurs propriétaires respectifs.

Ce logiciel est protégé par les lois et traités internationaux sur les copyrights. Toute utilisation, reproduction ou distribution partielle ou totale de ce logiciel, par quelque moyen que ce soit, est strictement interdite. Toute personne ne respectant pas ces dispositions se rendra coupable du délit de contrefaçon et sera passible des sanctions pénales prévues par la loi.

Les avertissements, termes et conditions relatifs aux composants logiciels tiers peuvent être consultés à l’adresse /go/thirdparty* et s’appliquent par référence au contenu de ce document.

Ressources de Flash

 

Documentation sur la famille des produits Studio

 

Types de documentation

Apprenez-en plus sur les différents types de documentation disponible pour l'apprentissage. La documentation est disponible aux formats LiveDocs, Aide et PDF.