Accessibility

Security bulletin

Security update available for Shockwave Player

Release date: October 28, 2010

Vulnerability identifier: APSB10-25

CVE number: CVE-2010-2581, CVE-2010-2582, CVE-2010-3653, CVE-2010-3655, CVE-2010-4084, CVE-2010-4085, CVE-2010-4086, CVE-2010-4087, CVE-2010-4088, CVE-2010-4089, CVE-2010-4090

Platform: Windows and Macintosh

Summary

Critical vulnerabilities have been identified in Adobe Shockwave Player 11.5.8.612 and earlier versions on the Windows and Macintosh operating systems. These vulnerabilities, including CVE-2010-3653, referenced in Security Advisory APSA10-04, could allow an attacker, who successfully exploits these vulnerabilities, to run malicious code on the affected system. Adobe recommends users of Adobe Shockwave Player 11.5.8.612 and earlier versions update to Adobe Shockwave Player 11.5.9.615 using the instructions provided below.

Affected software versions

Shockwave Player 11.5.8.612 and earlier versions for Windows and Macintosh

Solution

Adobe recommends users of Adobe Shockwave Player 11.5.8.612 and earlier versions upgrade to the newest version 11.5.9.615, available here: http://get.adobe.com/shockwave/.

Severity rating

Adobe categorizes this as a critical update and recommends that users apply the latest update for their product installation by following the instructions in the "Solution" section above.

Details

Critical vulnerabilities have been identified in Adobe Shockwave Player 11.5.8.612 and earlier versions on the Windows and Macintosh operating systems. These vulnerabilities, including CVE-2010-3653, referenced in Security Advisory APSA10-04, could allow an attacker, who successfully exploits these vulnerabilities, to run malicious code on the affected system. Adobe recommends users of Adobe Shockwave Player 11.5.8.612 and earlier versions update to Adobe Shockwave Player 11.5.9.615 using the instructions provided above.

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2010-3653).
NOTE: There are reports that this issue is being exploited in the wild.

This update resolves a memory corruption vulnerability in the dirapi.dll module that could lead to code execution (CVE-2010-2581).

This update resolves a heap-based buffer overflow vulnerability that could lead to code execution (CVE-2010-2582).

This update resolves a stack overflow vulnerability in the dirapi.dll module that could lead to code execution (CVE-2010-3655).

This update resolves a memory corruption vulnerability in the dirapi.dll module that could lead to code execution (CVE-2010-4084).

This update resolves a memory corruption vulnerability in the dirapi.dll module that could lead to code execution (CVE-2010-4085).

This update resolves a memory corruption vulnerability in the dirapi.dll module that could lead to code execution (CVE-2010-4086).

This update resolves a memory corruption vulnerability in the IML32.dll module that could lead to code execution (CVE-2010-4087).

This update resolves a memory corruption vulnerability in the dirapi.dll module that could lead to code execution (CVE-2010-4088).

This update resolves a memory corruption vulnerability in the IML32.dll module that could lead to code execution (CVE-2010-4089).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2010-4090).

Acknowledgments

Adobe would like to thank the following individuals and organizations for reporting the relevant issues and for working with Adobe to help protect our customers: