Accessibility

Security bulletin

Security update available for Adobe Flash Player

Release date: April 15, 2011

Last updated: April 28, 2011

Vulnerability identifier: APSB11-07

CVE number: CVE-2011-0611

Platform: All Platforms

Summary

A critical vulnerability has been identified in Adobe Flash Player 10.2.153.1 and earlier versions (Adobe Flash Player 10.2.154.25 and earlier for Chrome users) for Windows, Macintosh, Linux, and Solaris, and Adobe Flash Player 10.2.156.12 and earlier versions for Android. This vulnerability (CVE-2011-0611), as referenced in Security Advisory APSA11-02, could cause a crash and potentially allow an attacker to take control of the affected system. There are reports that this vulnerability is being exploited in the wild in targeted attacks via a malicious Web page, or a Flash (.swf) file embedded in a Microsoft Word (.doc) or Microsoft Excel (.xls) file delivered as an email attachment, targeting the Windows platform.

Adobe recommends users of Adobe Flash Player 10.2.153.1 and earlier versions (Adobe Flash Player 10.2.154.25 and earlier versions for Chrome users) for Windows, Macintosh, Linux, and Solaris update to Adobe Flash Player 10.2.159.1 (Adobe Flash Player 10.2.154.27 for Chrome users). Adobe recommends users of Adobe Flash Player 10.2.156.12 and earlier versions for Android update to Adobe Flash Player 10.2.157.51. Adobe recommends users of Adobe AIR 2.6.19120 and earlier versions for Windows, Macintosh and Linux update to Adobe AIR 2.6.19140.

Affected software versions

  • Adobe Flash Player 10.2.153.1 and earlier versions for Windows, Macintosh, Linux, and Solaris operating systems
  • Adobe Flash Player 10.2.154.25 and earlier versions for Chrome users
  • Adobe Flash Player 10.2.156.12 and earlier for Android
  • Adobe AIR 2.6.19120 and earlier versions for Windows, Macintosh and Linux

To verify the version of Adobe Flash Player installed on your system, access the About Flash Player page, or right-click on content running in Flash Player and select "About Adobe (or Macromedia) Flash Player" from the menu. If you use multiple browsers, perform the check for each browser you have installed on your system.

To verify the version of Adobe Flash Player for Android, go to Settings > Applications > Manage Applications > Adobe Flash Player 10.2 (or Adobe Flash Player 10.1).

To verify the version of Adobe AIR installed on your system, follow the instructions in the Adobe AIR TechNote.

Solution

Adobe recommends all users of Adobe Flash Player 10.2.153.1 and earlier versions for Windows, Macintosh, Linux, and Solaris upgrade to the newest version 10.2.159.1 by downloading it from the Adobe Flash Player Download Center. Windows users can install the update via the auto-update mechanism within the product when prompted.

Google Chrome users can update to Chrome version 10.0.648.205 or later.

Users of Flash Player for Android version 10.2.156.12 and earlier can update to Flash Player version 10.2.157.51 by browsing to the Android Marketplace on an Android phone.

Adobe recommends users of Adobe AIR 2.6.19120 and earlier versions for Windows, Macintosh and Linux update to Adobe AIR 2.6.19140.

Severity rating

Adobe categorizes these as critical updates and recommends affected users update their installations to the newest versions.

Details

A critical vulnerability has been identified in Adobe Flash Player 10.2.153.1 and earlier versions (Adobe Flash Player 10.2.154.25 and earlier for Chrome users) for Windows, Macintosh, Linux, and Solaris, and Adobe Flash Player 10.2.156.12 and earlier versions for Android. This vulnerability (CVE-2011-0611), as referenced in Security Advisory APSA11-02, could cause a crash and potentially allow an attacker to take control of the affected system. There are reports that this vulnerability is being exploited in the wild in targeted attacks via a malicious Web page, or a Flash (.swf) file embedded in a Microsoft Word (.doc) or Microsoft Excel (.xls) file delivered as an email attachment, targeting the Windows platform.

These updates resolves a memory corruption vulnerability that could lead to code execution (CVE-2011-0611).

Adobe recommends users of Adobe Flash Player 10.2.153.1 and earlier versions (Adobe Flash Player 10.2.154.25 and earlier versions for Chrome users) for Windows, Macintosh, Linux, and Solaris update to Adobe Flash Player 10.2.159.1 (Adobe Flash Player 10.2.154.27 for Chrome users). Adobe recommends users of Adobe Flash Player 10.2.156.12 and earlier versions for Android update to Adobe Flash Player 10.2.157.51. Adobe recommends users of Adobe AIR 2.6.19120 and earlier versions for Windows, Macintosh and Linux update to Adobe AIR 2.6.19140.

Affected software

Recommended player update

Availability

Flash Player 10.2.153.1 and earlier

10.2.159.1

Flash Player Download Center

Flash Player 10.2.153.1 and earlier -
network distribution

10.2.159.1

Flash Player Licensing

Flash Player 10.2.156.12 and earlier
for Android

10.2.157.51

Android Marketplace
(browse to on an Android phone)

Google Chrome

10.2.154.27

AIR 2.6.19120

2.6.19140

Flash Professional CS5,
Flash CS4 Professional and Flex 4

10.2.159.1

 

Acknowledgments

Adobe would like to thank the following individuals and organizations for reporting the relevant issues and for working with Adobe to help protect our customers:

Revisions

April 28, 2011 - Updated with information on Adobe Flash Player for Android update.
April 15, 2011 - Bulletin released.