Accessibility
Adobe
Sign in Privacy My Adobe

Security bulletin

Security update available for Adobe Shockwave Player

Release date: June 14, 2011

Last updated: November 9, 2011

Vulnerability identifier: APSB11-17

CVE number: CVE-2011-0317, CVE-2011-0318, CVE-2011-0319, CVE-2011-0320, CVE-2011-0335, CVE-2011-2108, CVE-2011-2109, CVE-2011-2111, CVE-2011-2112, CVE-2011-2113, CVE-2011-2114, CVE-2011-2115, CVE-2011-2116, CVE-2011-2117, CVE-2011-2118, CVE-2011-2119, CVE-2011-2120, CVE-2011-2121, CVE-2011-2122, CVE-2011-2123, CVE-2011-2124, CVE-2011-2125, CVE-2011-2126, CVE-2011-2127, CVE-2011-2128

Platform: Windows and Macintosh

Summary

Critical vulnerabilities have been identified in Adobe Shockwave Player 11.5.9.620 and earlier versions on the Windows and Macintosh operating systems. These vulnerabilities could allow an attacker, who successfully exploits these vulnerabilities, to run malicious code on the affected system. Adobe recommends users of Adobe Shockwave Player 11.5.9.620 and earlier versions update to Adobe Shockwave Player 11.6.0.626 using the instructions provided below.

Affected software versions

Shockwave Player 11.5.9.620 and earlier versions for Windows and Macintosh.

Solution

Adobe recommends users of Adobe Shockwave Player 11.5.9.620 and earlier versions upgrade to the newest version 11.6.0.626, available here: http://get.adobe.com/shockwave/

Severity rating

Adobe categorizes this as a critical update and recommends that users apply the latest update for their product installation by following the instructions in the "Solution" section above.

Details

Critical vulnerabilities have been identified in Adobe Shockwave Player 11.5.9.620 and earlier versions on the Windows and Macintosh operating systems. These vulnerabilities could allow an attacker, who successfully exploits these vulnerabilities, to run malicious code on the affected system. Adobe recommends users of Adobe Shockwave Player 11.5.9.620 and earlier versions update to Adobe Shockwave Player 11.6.0.626 using the instructions provided in the "Solution" section above.

This update resolves a memory corruption vulnerability in the Dirapi.dll component that could lead to code execution (CVE-2011-0317).

This update resolves a memory corruption vulnerability in the Dirapi.dll component that could lead to code execution (CVE-2011-0318).

This update resolves a memory corruption vulnerability in the Dirapi.dll component that could lead to code execution (CVE-2011-0319).

This update resolves a memory corruption vulnerability in the Dirapi.dll component that could lead to code execution (CVE-2011-0320).

This update resolves multiple memory corruption vulnerabilities in the Dirapi.dll component that could lead to code execution (CVE-2011-0335).

This update resolves a design flaw that could lead to code execution (CVE-2011-2108).

This update resolves multiple integer overflow vulnerabilities in the Dirapi.dll component that could lead to code execution (CVE-2011-2109).

This update resolves multiple memory corruption vulnerabilities in the IML32.dll component that could lead to code execution (CVE-2011-2111).

This update resolves multiple buffer overflow vulnerabilities in the IML32.dll component that could lead to code execution (CVE-2011-2112).

This update resolves multiple buffer overflow vulnerabilities in the Shockwave3DAsset component that could lead to code execution (CVE-2011-2113).

This update resolves multiple memory corruption vulnerabilities that could lead to code execution (CVE-2011-2114).

This update resolves multiple memory corruption vulnerabilities in the IML32.dll component that could lead to code execution (CVE-2011-2115).

This update resolves a memory corruption vulnerability in the IML32.dll component that could lead to code execution (CVE-2011-2116).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2011-2117).

This update resolves an input validation vulnerability in the FLV ASSET Xtra component that could lead to code execution (CVE-2011-2118).

This update resolves a memory corruption vulnerability in the Dirapi.dll component that could lead to code execution (CVE-2011-2119).

This update resolves an integer overflow vulnerability in the CursorAsset x32 component that could lead to code execution (CVE-2011-2120).

This update resolves an integer overflow vulnerability that could lead to code execution (CVE-2011-2121).

This update resolves a memory corruption vulnerability in the Dirapi.dll component that could lead to code execution (CVE-2011-2122).

This update resolves an integer overflow vulnerability in the Shockwave 3D Asset x32 component that could lead to code execution (CVE-2011-2123).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2011-2124).

This update resolves a buffer overflow vulnerability in the Dirapix.dll component that could lead to code execution (CVE-2011-2125).

This update resolves a buffer overflow vulnerability that could lead to code execution (CVE-2011-2126).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2011-2127).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2011-2128).

Acknowledgments

Adobe would like to thank the following individuals and organizations for reporting the relevant issues and for working with Adobe to help protect our customers:

Revisions

November 9, 2011 - Updated acknowledgments to include Xin Ouyang of Palo Alto Networks, additional CVEs for Luigi Auriemma through iDefense Labs and Luigi Auriemma through TippingPoint's Zero Day Initiative
June 15, 2011 - Updated acknowledgements to amend CVE credits.
June 14, 2011 - Bulletin released.