Accessibility

Security bulletin

Security update available for Adobe Shockwave Player

Release date: August 9, 2011

Vulnerability identifier: APSB11-19

CVE number: CVE-2010-4308, CVE-2010-4309, CVE-2011-2419, CVE-2011-2420, CVE-2011-2421, CVE-2011-2422, CVE-2011-2423.

Platform: Windows and Macintosh

Summary

Critical vulnerabilities have been identified in Adobe Shockwave Player 11.6.0.626 and earlier versions on the Windows and Macintosh operating systems. These vulnerabilities could allow an attacker, who successfully exploits these vulnerabilities, to run malicious code on the affected system. Adobe recommends users of Adobe Shockwave Player 11.6.0.626 and earlier versions update to Adobe Shockwave Player 11.6.1.629 using the instructions provided below.

Affected software versions

Shockwave Player11.6.0.626 and earlier versions for Windows and Macintosh

Solution

Adobe recommends users of Adobe Shockwave Player 11.6.0.626 and earlier versions upgrade to the newest version 11.6.1.629 available here: http://get.adobe.com/shockwave/.

Severity rating

Adobe categorizes these as critical updates and recommends affected users update their installations to the newest versions.

Details

Critical vulnerabilities have been identified in Adobe Shockwave Player 11.6.0.626 and earlier versions on the Windows and Macintosh operating systems. These vulnerabilities could allow an attacker, who successfully exploits these vulnerabilities, to run malicious code on the affected system. Adobe recommends users of Adobe Shockwave Player 11.6.0.626 and earlier versions update to Adobe Shockwave Player 11.6.1.629 using the instructions provided in the "Solution" section above.

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2010-4308).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2010-4309).

This update resolves a memory corruption vulnerability in the IML32.dll component that could lead to remote code execution (CVE-2011-2419).

This update resolves a memory corruption vulnerability that could lead to remote code execution (CVE-2011-2420).

This update resolves a memory corruption when Shockwave Player parses a .dir media file in the Dirapi.dll component that could lead to code execution. (CVE-2011-2421).

This update resolves a memory corruption vulnerability in the Textra.x32 component that could lead to remote code execution (CVE-2011-2422).

This update resolves a memory corruption in the msvcr90.dll component that could lead to remote code execution (CVE-2011-2423).

Acknowledgments

Adobe would like to thank the following individuals and organizations for reporting the relevant issues and for working with Adobe to help protect our customers: