Accessibility

Security bulletin

Security update available for Adobe Shockwave Player

Release date: February 14, 2012

Last updated: March 15, 2012

Vulnerability identifier: APSB12-02

CVE number: CVE-2012-0757, CVE-2012-0758, CVE-2012-0759, CVE-2012-0760, CVE-2012-0761, CVE-2012-0762, CVE-2012-0763, CVE-2012-0764, CVE-2012-0766, CVE-2012-0771

Platform: Windows and Macintosh

Summary

This update addresses critical vulnerabilities in Adobe Shockwave Player 11.6.3.633 and earlier versions on the Windows and Macintosh operating systems. These vulnerabilities could allow an attacker, who successfully exploits these vulnerabilities, to run malicious code on the affected system. Adobe recommends users of Adobe Shockwave Player 11.6.3.633 and earlier versions update to Adobe Shockwave Player 11.6.4.634 using the instructions provided below.

Affected software versions

Shockwave Player 11.6.3.633 and earlier versions for Windows and Macintosh

Solution

Adobe recommends users of Adobe Shockwave Player 11.6.3.633 and earlier versions update to the newest version 11.6.4.634, available here: http://get.adobe.com/shockwave/.

Severity rating

Adobe categorizes this as a critical update and recommends that users apply the latest update for their product installation by following the instructions in the "Solution" section above.

Details

This update addresses critical vulnerabilities in Adobe Shockwave Player 11.6.3.633 and earlier versions on the Windows and Macintosh operating systems. These vulnerabilities could allow an attacker, who successfully exploits these vulnerabilities, to run malicious code on the affected system. Adobe recommends users of Adobe Shockwave Player 11.6.3.633 and earlier versions update to Adobe Shockwave Player 11.6.4.634 using the instructions provided above.

This update resolves a memory corruption vulnerability in the Shockwave 3D Asset that could lead to code execution (CVE-2012-0757).

This update resolves a heap overflow vulnerability that could lead to code execution (CVE-2012-0758).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2012-0759).

This update resolves a memory corruption vulnerability in the Shockwave 3D Asset that could lead to code execution (CVE-2012-0760).

This update resolves a memory corruption vulnerability in the Shockwave 3D Asset that could lead to code execution (CVE-2012-0761).

This update resolves a memory corruption vulnerability in the Shockwave 3D Asset that could lead to code execution (CVE-2012-0762).

This update resolves a memory corruption vulnerability in the Shockwave 3D Asset that could lead to code execution (CVE-2012-0763).

This update resolves a memory corruption vulnerability in the Shockwave 3D Asset that could lead to code execution (CVE-2012-0764).

This update resolves a memory corruption vulnerability in the Shockwave 3D Asset that could lead to code execution (CVE-2012-0766).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2012-0771).

Acknowledgments

Adobe would like to thank the following individuals and organizations for reporting the relevant issues and for working with Adobe to help protect our customers:

Revisions

March 15, 2012 - Added information and acknowledgement regarding CVE-2012-0771.
February 14, 2012 - Bulletin released.