Accessibility

Security bulletin

Security update available for Adobe Shockwave Player

Release date: May 8, 2012

Vulnerability identifier: APSB12-13

Priority: 2

CVE number: CVE-2012-2029, CVE-2012-2030, CVE-2012-2031, CVE-2012-2032, CVE-2012-2033

Platform: Windows and Macintosh

Summary

Adobe released a security update for Adobe Shockwave Player 11.6.4.634 and earlier versions for Windows and Macintosh. This update addresses vulnerabilities that could allow an attacker who successfully exploits these vulnerabilities to run malicious code on the affected system.

Adobe recommends users of Adobe Shockwave Player 11.6.4.634 and earlier for Windows and Macintosh update to Adobe Shockwave Player 11.6.5.635 using the instructions provided in the "Solution" section below.

Affected software versions

Shockwave Player 11.6.4.634 and earlier versions for Windows and Macintosh

Solution

Adobe recommends users of Adobe Shockwave Player 11.6.4.634 and earlier versions update to the newest version 11.6.5.635, available here: http://get.adobe.com/shockwave/.

Priority and Severity ratings

Adobe categorizes this update with the following priority rating and recommends users update their installation to the newest version:

Product
Updated Version
Platform
Priority Rating
Adobe Shockwave Player 11.6.5.635 Windows and Macintosh
2


This update addresses critical vulnerabilities in the software.

Details

Adobe released a security update for Adobe Shockwave Player 11.6.4.634 and earlier versions for Windows and Macintosh. This update addresses vulnerabilities that could allow an attacker who successfully exploits these vulnerabilities to run malicious code on the affected system.

Adobe recommends users of Adobe Shockwave Player 11.6.4.634 and earlier for Windows and Macintosh update to Adobe Shockwave Player 11.6.5.635 using the instructions provided in the "Solution" section below.

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2012-2029).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2012-2030).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2012-2031).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2012-2032).

This update resolves a memory corruption vulnerability that could lead to code execution (CVE-2012-2033).

Acknowledgments

Adobe would like to thank the following individuals and organizations for reporting the relevant issues and for working with Adobe to help protect our customers: