Accessibility

Support Knowledgebase

Optimize performance in Photoshop (Mac OS)

What's covered

Photoshop options and plug-ins

Image files

Operating system software

Hardware

Resources

Available random-access memory (RAM) and computer processor speed have the greatest effect on the performance of Adobe Photoshop. However, other factors, such as the options you select, your workflow, and your operating system and hardware configuration, can also affect performance. Optimizing your operating system and hardware configuration also improves performance of other applications. Photoshop CS supports a maximum image dimension of 300,000 x 300,000 pixels, which allows for images with a maximum size of 4 GB for TIFF files, and almost unlimited file sizes for images saved in the new native Large Document Format (.psb). Photoshop CS can access only 2 GB RAM, so large files will need to use considerable scratch disk space. Large Document Format files cannot be read by Photoshop 7.0.x or earlier. To optimize performance in Photoshop, apply the following recommendations.

This document summarizes the Adobe recommendations for optimizing overall performance in Photoshop. For performance problems that are related to system errors, see document 327279 , "Troubleshooting system errors or freezes in Photoshop (CS and 7.x on Mac OS X)."

Photoshop options and plug-ins

The options you select and plug-ins you use in Photoshop can affect its performance. The options and plug-ins that most directly affect performance include those covered in this section.

Setting scratch disks

that has plenty of unused space and fast read/write speeds (rather than a network drive or removable media such as a Zip drive). Photoshop requires at least 320 MB of free hard-disk space, but more is recommended. If you have more than one hard drive, it is suggested that you specify additional scratch disks. Photoshop CS supports up to 64 exabytes (EB) of scratch disk space on a total of four volumes. Photoshop 7.x supports up to 4 EB. (An EB is equal to 1 billion gigabytes.) A scratch disk in Photoshop is similar to virtual memory in Mac OS. For the best performance, you should set the primary scratch disk to a defragmented hard drive that is not running the OS, and The OS volume should contain at least 20 GB of free space to ensure the virtual memory system has plenty of available hard disk space.Note that RAID 0 partitions provide the best performance as Photoshop scratch disks.

To set the scratch disk preference:

1. Choose Photoshop > Preferences > Plug-Ins & Scratch Disks.

2. Choose the drive that has the most free space from the First pop-up menu.

3. Choose a second drive, if available, from the Second pop-up menu.

4. Choose other drives, if available, from the Third and Fourth pop-up menus.

5. Click OK.

Working with the File Browser

The File Browser allows you to view, sort, and process images. Photoshop CS also allows you to tag and sort images, search and edit metadata and keywords, and run batch processes. If you open a folder containing numerous images in the File Browser, performance may slow while the File Browser creates a cache of thumbnails for the images in the folder. Other changes you can make to File Browser preferences settings to increase performance include: turning off High Quality Previews; reducing the size of images processed by the File Browser; reducing the custom thumbnail size if you've set a larger size than the default; deselect Render Vector File to prevent Photoshop from creating thumbnails of vector files; or turning off background processing.

For more information about the File Browser, see the Photoshop User Guide or Online Help.

16-bit functionality

Photoshop CS significantly increases the number of features that can be performed on 16-bit images. However, if your resources are low, reducing your images to 8-bit can improve performance. Note that this reduction will permanently delete the extra bit data from your image.

Adjusting the Image Cache

Photoshop uses image caching to redraw high-resolution images on-screen faster. With image caching, Photoshop quickly updates a low-resolution version of an image as you edit it. To enable the Image Cache option, specify the number (1 to 8) of low-resolution versions you want Photoshop to store (cache). The more versions you specify, however, the slower Photoshop will open image files. The Photoshop default Image Cache setting is 4. Setting the Image Cache option to 1 disables image caching; only the active screen image is cached. Setting the Image Cache higher than 4 improves the performance when working on larger images, by redrawing them faster.

Note: Image Caching may cause a less accurate preview. When needed, view files at 100% to ensure an accurate preview.

To adjust the Image Cache setting:

1. Choose Photoshop > Preferences > Image Cache.

2. Enter a value from 1 to 8 in the Cache Levels text box. Click OK.

3. Restart Photoshop.

Deselecting Export Clipboard

The Export Clipboard setting allows Photoshop to export anything copied to the clipboard as a PICT file. Exporting is time consuming, however, and occurs whenever you quit Photoshop or go from Photoshop to another application. Deselecting this setting increases the performance of Photoshop.

To deselect Export Clipboard:

1. Choose Photoshop > Preferences > General.

2. Deselect Export Clipboard.

3. Click OK.

Minimizing palette preview thumbnails

Photoshop requires additional memory to display preview thumbnails in the Layers, Channels, and Paths palettes. Photoshop updates the preview thumbnails as you make changes to an image. The more preview thumbnails Photoshop displays, and the larger their size, the more memory Photoshop requires to draw and update them.

To minimize or disable thumbnail previews in palettes, choose Palette Options from the palette's pop-up menu, then select the smallest size or None for Thumbnail Size, then click OK.

Using the Extract command

When you use the Extract command (Image > Extract) on a computer with low RAM or hard-disk space, Photoshop responds slowly or not at all. The Extract command can require more than the recommended minimum amount of RAM and disk space for Photoshop. If Photoshop responds slowly when you use the Extract command, increase memory used by Photoshop, or free additional space on the hard disk.

For instructions on how to increase memory used by Photoshop, see "Allocating more memory to Photoshop" in this document.

Using the Enable Async I/O plug-in

The Enable Async I/O plug-in installed with Photoshop enables faster disk operations (read and write speed).

The Enable Async I/O plug-in is enabled by default. If the plug-in is enabled, an asterisk appears after the Efficiency percentage (for example 100%*) in the lower left of the Photoshop image window. To view the Efficiency percentage, choose Efficiency from the pop-up menu in the lower left of the image window. If the plug-in is disabled, a tilde (~) or a "not" sign () appears as the first character in the Enable Async I/O folder name, or the folder or plug-in may be missing.

To enable the Enable Async I/O plug-in:

1. Quit Photoshop.

2. In the Finder, locate the Enable Async I/O folder or the Enable Async I/O folder in the Adobe Photoshop [version]: Plug-ins: Adobe Photoshop Only: Extensions folder.

To install the Async I/O plug-in (Photoshop 7):

Note: If the folder is missing, custom install the Enable Async I/O plug-in:

1. Quit Photoshop.

2. Insert the Photoshop CD, and start the Photoshop installer.

3. Follow the on-screen instructions until you reach the Install Adobe Photoshop dialog box.

4. Choose Custom Install from the pop-up menu.

5. Expand Photoshop Only Plug-ins.

6. Select Extensions (deselect the other options), and click Install.

Note: To install the Async I/O plug-in in Photoshop CS, you must install Photoshop CS again in the same location you put it the first time, there is no custom install.

3. Delete the tilde or the "not" sign from the beginning of the ~Enable Async I/O or Enable Async I/O folder name.

4. Restart Photoshop. (Replace the tilde or the "not" sign to disable the plug-in.)

Using the Detect Watermark plug-in

Photoshop includes the Digimarc Corporation digital watermarking plug-ins such as Detect Watermark, Embed Watermark, and Read Watermark. The Detect Watermark plug-in checks each image you open for a digital watermark, which increases the time it takes for Photoshop to open the file. If the plug-in detects a watermark, a copyright symbol appears in the image window's title bar. You can find the source of the image by choosing Filter > Digimarc > Read Watermark.

To disable the Detect Watermark plug-in:

1. Quit Photoshop.

2. In the Finder, locate the Digimarc folder in the Adobe Photoshop [version]: Plug-Ins: Adobe Photoshop Only folder.

3. Type a tilde (~) at the beginning of the Detect Watermark plug-in's filename or move the Detect Watermark plug-in from the Plug-ins folder (for example, move it to the desktop).

4. Restart Photoshop.

For updated Digimarc plug-ins, check the Digimarc website at www.digimarc.com. Make sure to install the updated plug-ins you download into the Plug-ins: Adobe Photoshop Only: Digimarc folder.

Image files

You can optimize your workflow to improve the performance of Photoshop by minimizing file size, editing individual channels, and using image compression selectively. Additionally, because layers and channels significantly add to the size of a file, you can minimize file size by merging layers and deleting channels when they are no longer needed. Finally, if you are preparing images for color separation, you can work in RGB mode until you are ready to print, and then change the images to CMYK mode.

Minimizing resolutions

You can minimize the size of your files by reducing their resolution, which is measured in pixels per inch (PPI). Photoshop requires more memory and disk space to process high-resolution images, which increases the time it takes to display, process, and print them. Increasing the resolution of an image does not always improve the quality of the image, but may instead only increase its file size. You want the resolution of images to be the highest value your printer can use. Resolutions higher than that only add information that your printer can't use, but must process, thereby increasing print times.

For continuous-tone images, such as photographs, that you plan to print, begin by using a resolution that is 1.5 to 2 times the screen frequency, measured in lines per inch (lpi), that you'll use to print the image. For line-art images, such as drawings, use the same value as your printer's resolution, measured in dots per inch (dpi). For example, if the resolution of your printer is 600 dpi, and you plan to print the image using the printer's default screen frequency of 85 lpi, save continuous-tone images at a resolution between 127 ppi (85 lpi x 1.5) and 170 ppi (85 lpi x 2), and save line-art images at a resolution of 600 ppi.

Recommended resolutions for continuous-tone images:

Output
Recommended resolution
Macintosh monitor
72 ppi
Windows-compatible monitor
96 ppi
300 dpi laser printer
100 ppi
600 dpi laser printer
150 ppi
725 dpi inkjet printer
150 ppi
1200 dpi or higher imagesetter
1.5 x the screen frequency (lpi) value you specified

To reduce the resolution of an image in Photoshop:

1. Open the image, then choose Image > Image Size.

2. In the Image Size dialog box, decrease the Resolution value, and then click OK.

Turning off maximize compatibility

The Maximize PSD File Compatibility option in Edit > Preferences > File Handling allows you to save a composite version of your file with the layered version. Although saving the composite allows the most compatibility with your PSD images and previous versions of Photoshop or other applications that can open a PSD file, it also significantly increases the file size of the image. You can set this preference to Never save the composite, Always save it, or ask to save it each time you save in the PSD format.

Minimizing the number of layers

Layers make many operations in Photoshop dramatically easier, but they also increase file sizes and redraw time because Photoshop recomposes each later after each change in the image. After you have completed changes to layers, you can flatten (merge) them to reduce a file's size. You should also make sure to remove blank layers from the file since they too increase its size. It is important to remember that Photoshop does not let you separate layers after merging them. Instead, you can either use the Undo command or you can use the Photoshop History palette to reverse a merge.

-- To flatten all layers in a file, choose Layer > Flatten Image.

-- To merge a layer with the layer below it:

1. In the Layers palette, select the layer above the layer with which you want to merge it.

2. Choose Layer > Merge Down.

Flattening TIFF files

Photoshop allows layers to be saved in TIFF files. Layered TIFF files are larger than flattened TIFF files and require more resources for processing and printing. If you work with a layered TIFF file, save the original layered file as an Adobe Photoshop (*.psd) file; then, when you are ready to save the file in TIFF format, save a copy without layers.

Using image compression

Although compressed files generally have smaller file sizes, Photoshop may take longer to open or save them. With the exception of images saved in Photoshop format, Photoshop must decompress a file to open it and then recompress the file to save it. The BMP, CompuServe GIF, JPEG, Photoshop, Photoshop EPS, Photoshop PDF, and TIFF formats can be saved with compression. In addition, Photoshop enables you to specify a compression method for TIFF layers in the TIFF Options window. You can improve performance by saving your file in compressed Photoshop format (a compression format in which there is no data loss) as you work, and then save your file in the format you want when you are finished editing the image.

To save an image without compression from Photoshop, choose File > Save As, select the format you want, and then select the "no compression" option in the format's option dialog box. For example, select the TIFF format, and in the TIFF Options dialog box, select None for Image Compression.

Editing individual channels

Photoshop requires less memory to apply a filter to a single channel than it does to apply a filter to multiple channels or to an entire image (composite channel). In a flattened image, each RGB channel is about one-third the size of the file; each CMYK channel is about one-fourth the size. To edit a single channel, select the channel you want to edit in the Channels palette.

Using the Filter Gallery and applying filters to individual channels

The new Photoshop CS Filter Gallery allows you to test one or more filters on an image before applying the effect(s), which can save considerable time.

Dragging and dropping between files

Dragging and dropping layers or files is more efficient than copying and pasting them. Dragging bypasses the clipboard and transfers data directly. Copying and pasting can potentially involve more data transfer and may take more time.

Operating system software

By customizing your system so it runs efficiently, you can increase the amount of memory available to applications, and ensure that applications will run efficiently. By increasing the amount of memory available to Photoshop, allocating more memory to it, quitting applications you are not using, or disabling nonessential extensions, you improve the performance of Photoshop. Adobe recommends using Mac OS 10.3.3 or later. This update provides better support and performance when external storage devices are used as Photoshop scratch disks.

Restarting to defragment memory (Mac OS 9.x only)

Starting and quitting applications repeatedly can fragment the memory in Mac OS. Applications may be unable to access all the available memory if memory is fragmented or is unavailable in a single, contiguous block. This can decrease their performance or may prevent them from starting. Restarting the Macintosh defragments its memory.

Allocating more memory to Photoshop

Photoshop uses random-access memory (RAM) to process image information. The more RAM available to Photoshop, the faster Photoshop can process image information. Other open applications and startup programs decrease the amount of memory potentially available to Photoshop. Quitting applications or startup items you are not using makes more memory available to Photoshop.

In Mac OS X, memory for Photoshop is allocated from RAM that is available after the OS has used the amount of RAM it needs. If you do not need to use memory for other applications, you can assign almost all the available RAM to Photoshop (leave at least 20 MB open for overhead processing). You can use a system monitor that graphs memory such as System Manager to determine the best amount of RAM to assign to Photoshop for your computer.

To allocate more memory to Photoshop in Mac OS X:

1. Choose Photoshop > Preferences > Memory & Image Cache.

2. In the Memory Usage section, increase the Maximum Used by Photoshop percentage, and click OK.

Note: Do not set the percentage to more than 70%.

3. Restart Photoshop.

To allocate more RAM to Photoshop CS in Mac OS 9.x:

1. Quit Photoshop.

2. Start any applications you want to run simultaneously with Photoshop.

3. In the Finder, choose About This Computer from the Apple menu.

4. Note the Largest Unused Block value, which is the total amount of available memory.

5. In the Finder, select the Adobe Photoshop application icon, then choose File > Get Info.

6. In the Adobe Photoshop Info window, choose Memory from the Show pop-up menu and enter a value for Preferred Size that is less than 90% of the Largest Unused Block value you noted in step 4.

7. Close the Adobe Photoshop Info window.

System extensions (Mac OS 9.x)

System extensions and control panels use memory that could be made available to other applications, including Photoshop. If your Macintosh has a limited amount of memory, use the Apple Extensions Manager to disable nonessential extensions and control panels. Disabling nonessential extensions can also prevent extension conflicts. For more information about disabling extensions, see document 311687 , "Disabling Extensions and Isolating Extension Conflicts in Mac OS 9.x or 8.x"

Hardware

The hardware you use affects the performance of Photoshop; the faster the processor or hard drive, the faster Photoshop can process image information. Other hardware enhancements, such as installing additional RAM, using a multiprocessor system, or optimizing and defragmenting drives, can also improve Photoshop's performance.

Processor speed

The CPU (Central Processing Unit) of the Macintosh limits the speed of Photoshop. Since Photoshop manipulates large quantities of data and performs many calculations, its speed is greatly dependent on processor speed.

Photoshop requires a G3 or faster processor. Photoshop can also take advantage of multiprocessor systems (that is, systems that have two or more PowerPC processors), which are much faster than a single-processor system. All Photoshop features are faster on a multiprocessor system, and some features are much faster.

Installed RAM

Photoshop requires memory (RAM) that is three to five times the file size of the image you are editing. If memory is insufficient, Photoshop uses hard-drive space (that is, a scratch disk) to process information. Photoshop is fastest when it can process all or most image information in memory, without having to use the scratch disk. Allocate enough memory to Photoshop to accommodate your largest image file.

To check memory use in Photoshop, open the Efficiency Indicator:

1. Click the triangle in the bottom border of the image window.

2. Choose Efficiency to display the percentage of time actually doing an operation instead of reading or writing the scratch disk. If the value is below 100%, Photoshop is using the scratch disk and, therefore, is operating more slowly.

Hard drives

As you add, delete, and move files on a hard drive, its available space is no longer a single, contiguous block. If the system does not have enough contiguous space, it saves fragments of a file to different locations on the hard drive. It takes an application longer to read a fragmented file than one saved to a contiguous location. You can defragment files and optimize available hard drive space by using a disk utility (for example, the Apple Disk Utility, Symantec Norton Utilities, or Micromat Drive 10).

Since Photoshop reads and writes image information while editing an image, the faster the access speed of the drive containing the image or the Photoshop scratch disk, the faster Photoshop can process image information. To improve Photoshop performance, work on files saved on drives with fast access speeds, such as an internal hard drive, rather than those with slow access speeds (a network drive) or removable media (for example, a Zip disk). Removable media often have slower access times and are more easily damaged than internal hard drives.

Resources

These websites provide troubleshooting tips and further information about the Mac OS:

-- Apple Support: www.apple.com/support

-- Mac Resource Page: www.macresource.com

-- MacFixIt Troubleshooting Solutions for the Macintosh: www.macfixit.com

-- MacDirectory: www.macdirectory.com


Related Documents

311687: Disabling Extensions and Isolating Extension Conflicts in Mac OS 9.x or 8.x

311216: Scanning Basics

322391: Photoshop, networks, and removable media (7.x and CS)

Document 317280
Last edited - 04/21/2006

 

Got Some Time to Take a Survey?

Tell us what you think about this support site.