Accessibility

Support Knowledgebase

Optimize performance in Photoshop (CS2 on Mac OS)

What's covered

Adobe Photoshop options and plug-ins

Image files

Operating system software

Hardware

Resources

The performance of Adobe Photoshop CS2 is affected most by available random-access memory (RAM) and computer processor speed. Other factors can also affect performance, such as the options you select, your workflow, and your operating system and hardware configuration. Optimizing your operating system and hardware configuration also improves performance of other applications. Photoshop CS2 supports new maximum image dimensions, and file sizes requiring increased system requirements. The maximum file size Photoshop CS2 supports is 300,000 x 300,000 pixels, except for PDF files, which are still constrained by the 30,000 x 30,000 pixel limitation.

Photoshop CS2 has an increased file size capability for the following file types:

-- PSD files: 2 GB

-- TIFF files: 4 GB

Note: Most applications cannot work with TIFF files over 2 GB.

-- PSB files: 4 Exabytes (4096 Petabytes, or 4 million Terabytes)

-- PDF files: 10 GB (pages are limited to a maximum size of 200 inches).

Note: Large Document Format files (.PSB) cannot be read by Photoshop 7.0.x or earlier.

Adobe Photoshop options and plug-ins

The options you select and plug-ins you use in Photoshop can affect its performance. The options and plug-ins that most directly affect performance include those covered in this section.

Setting scratch disks

A scratch disk in Photoshop is similar to virtual memory in Mac OS. For the best performance, you should set the primary scratch disk to a defragmented hard drive that is not running the OS, and that has plenty of unused space and fast read/write speeds (rather than a network drive or removable media such as a Zip drive). Photoshop requires at least 750 MB of free hard-disk space, but more is recommended. The OS volume should contain at least 20 GB of free space to ensure the virtual memory system has plenty of available hard disk space. If you have more than one hard drive, it is suggested that you specify additional scratch disks. Note that RAID 0 partitions provide the best performance as Photoshop scratch disks. Photoshop CS2 supports up to 64 exabytes (EB) of scratch disk space on a total of four volumes. (An EB is equal to 1 billion gigabytes.)

To set the scratch disk preference:

1. Choose Photoshop > Preferences > Plug-Ins & Scratch Disks.

2. Choose the drive that has the most free space from the First pop-up menu.

3. Choose a second drive, if available, from the Second pop-up menu.

4. Choose other drives, if available, from the Third and Fourth pop-up menus.

5. Click OK.

6. Restart Photoshop.

Adjusting the Image Cache

Photoshop uses image caching to redraw high-resolution images on-screen faster. With image caching, Photoshop quickly updates a low-resolution version of an image as you edit it. To enable the Image Cache option, specify the number (1 to 8) of low-resolution versions you want Photoshop to store (cache). The more versions you specify, however, the slower Photoshop will open image files. The Photoshop default Image Cache setting is 6. Setting the Image Cache option to 1 disables image caching; only the active screen image is cached. Setting the Image Cache higher than 4 improves the performance when working on larger images, by redrawing them faster. If you have performance issues in Photoshop CS2, set the Image Cache to 2, then test your performance.

Note: Image Caching may cause a less accurate preview. When needed, view files at 100% to ensure an accurate preview.

To adjust the Image Cache setting:

1. Choose Photoshop > Preferences > Memory & Image Cache.

2. Enter a value from 1 to 8 in the Cache Levels text box. Click OK.

3. Restart Photoshop.

Set Maximize PSD And PSB File Compatibility to Ask

Maximize PSD and PSB File Compatibility increases the size of your file by attaching a flattened copy of your image when you save your image. In past versions of Photoshop, you didn't need to keep this option on. In Photoshop CS2, however, a small amount of extra data is included in the file when you choose this option that ensures that PSD and PBS files saved in Photoshop CS2 will open in previous versions. Additionally, when this option is on, and you open a Photoshop CS2 image in a previous version with a feature in it that cannot be supported by the older version, Photoshop will display a warning.

If you are saving files in Photoshop CS2 for use in older versions, then save them with this option on (that is, set to Ask or Always).

To change the Maximize File Compatibility option:

1. Choose Photoshop > Preferences > File Handling.

2. Change Maximize PSD And PSB File Compatibility to one of the following:

-- Ask: Prompts you to maximize file compatibility when you save.

-- Always: Saves with maximized file compatibility without asking.

-- Never: Does not save or prompt you to save with maximized file compatiblity.

Use font management software and turn off the WYSIWYG font list

Your computer can slow down if there are too many active fonts on the system. Font management software allows you to deactivate the fonts you aren't using to speed up the computer. Turning off the WYSIWYG font preview list will also speed the processing of fonts in Photoshop.

To turn off the font preview:

1. Choose Photoshop > Preferences > Type.

2. Deselect Font Preview Size.

Minimizing palette preview thumbnails

Photoshop requires additional memory to display preview thumbnails in the Layers, Channels, and Paths palettes. Photoshop updates the preview thumbnails as you make changes to an image. The more preview thumbnails Photoshop displays, and the larger their size, the more memory Photoshop requires to draw and update them.

To minimize or disable thumbnail previews in palettes, choose Palette Options from the palette's pop-up menu, then select the smallest size or None for Thumbnail Size, then click OK.

Using the Extract command

When you use the Extract command (Filter > Extract) on a computer with low RAM or hard-disk space, Photoshop responds slowly or not at all. The Extract command can require more than the recommended minimum amount of RAM and disk space for Photoshop. If Photoshop responds slowly when you use the Extract command, increase memory used by Photoshop, or free additional space on the hard disk.

For instructions on how to increase memory used by Photoshop, see "Allocating more memory to Photoshop" in this document.

16-bit functionality

Photoshop CS2 significantly increases the number of features that can be performed on 16-bit images. However, if your resources are low, reducing your images to 8-bit can improve performance. Note that this reduction will permanently delete the extra bit data from your image.

Deselecting Export Clipboard

The Export Clipboard setting allows Photoshop to export anything copied to the clipboard as a PICT file. Exporting is time consuming, however, and occurs whenever you quit Photoshop or go from Photoshop to another application. Deselecting this setting increases the performance of Photoshop.

To deselect Export Clipboard:

1. Choose Photoshop > Preferences > General.

2. Deselect Export Clipboard.

3. Click OK.

Adjusted Refresh plug-in

This plug-in is not necessary for Photoshop CS2, because the new maximum tile size in Photoshop CS2 is 132 KB. The amount of space set aside for and displayed in the Scratch Sizes indicator in Photoshop CS was much larger than in earlier versions because the tile sizes were larger. The Adjusted Refresh plug-in reduced the initial scratch disk usage when you started Photoshop, and reduced the size of the Photoshop image tiles from the default size of 1 MB per tile to 64 KB per tile. The smaller tiles allow the display to redraw in smaller pieces, reducing the time needed to preview some filter updates.

Bigger Tiles plug-in

The Bigger Tiles plug-in, which is located in the Applications/Adobe Photoshop CS2/Plug-Ins/Adobe Photoshop Only/Extensions/Bigger Tiles folder, is disabled by default. When you enable it by removing the ~ from the filename, then you increase the image tile size in Photoshop. You should only enable the plug-in if you have more than 1 GB of RAM installed.

If you enable the plug-in, then Photoshop redraws more data at a time because each tile is larger, and each tile is drawn, complete, at one time. Photoshop takes less time to redraw fewer tiles that are larger, than more tiles that are smaller. Because Photoshop redraws more data at one time, each tile it takes longer to be redrawn; so bigger tiles can look like they are redrawing slower, but they are actually redrawing faster than if the image had more smaller tiles.

Image files

You can optimize your workflow to improve the performance of Photoshop by minimizing file size, editing individual channels, and using image compression selectively. Additionally, because layers and channels significantly add to the size of a file, you can minimize file size by merging layers and deleting channels when they are no longer needed. Finally, if you are preparing images for color separation, you can work in RGB mode until you are ready to print, and then change the images to CMYK mode.

Minimizing resolutions

You can minimize the size of your files by reducing their resolution, which is measured in pixels per inch (PPI). Photoshop requires more memory and disk space to process high-resolution images, which increases the time it takes to display, process, and print them. Increasing the resolution of an image does not always improve the quality of the image, but may instead only increase its file size. You want the resolution of images to be the highest value your printer can use. Resolutions higher than that only add information that your printer can't use, but must process, thereby increasing print times.

For continuous-tone images, such as photographs, that you plan to print, begin by using a resolution that is 1.5 to 2 times the screen frequency, measured in lines per inch (lpi), that you'll use to print the image. For line-art images, such as drawings, use the same value as your printer's resolution, measured in dots per inch (dpi). For example, if the resolution of your printer is 600 dpi, and you plan to print the image using the printer's default screen frequency of 85 lpi, save continuous-tone images at a resolution between 127 ppi (85 lpi x 1.5) and 170 ppi (85 lpi x 2), and save line-art images at a resolution of 600 ppi.

Recommended resolutions for continuous-tone images:

Output
Recommended resolution
Macintosh monitor
72 ppi
300 dpi laser printer
100 ppi
600 dpi laser printer
150 ppi
725 dpi inkjet printer
150 ppi
1200 dpi or higher imagesetter
1.5 x the screen frequency (lpi) value you specified

To reduce the resolution of an image in Photoshop:

1. Open the image, then choose Image > Image Size.

2. In the Image Size dialog box, decrease the Resolution value, and then click OK.

Purge Undo, Clipboard, or Histories

Undo, Clipboard, and Histories all hold image data. To release RAM, choose Edit > Purge to purge the Undo and Clipboard. Purging Histories can release RAM or scratch disk depending on how recent your history data is. To reduce disk space usage, reduce the number of History States available in the General preference.

Reduce the number of History states

In Photoshop CS2, each history state that includes an operation that affects the entire image (for example, when you apply Gaussian blur or unsharp mask to the entire image) creates a full copy of your image at its original size. If your initial image is 500 KB, and you apply Gaussian blur to it, your image will need 1 MB of scratch space. If your history states consist of operations that affect only part of the image, such as paint strokes, only the size of the tiles touched by the strokes are added to the image size. If you count up the number of histories you have where operations have affected the entire image, and multiply your original image size by that number, you'll have an approximate amount of scratch disk space the image will need. If you have applied levels, a reduce noise filter, and an unsharp mask filter to your entire image that's 5 MB in size, the image will need 20 MB of scratch space. When you reduce the number of history states available, you potentially reduce the number of copies of your image using scratch space.

Reduce patterns and brush tips

If you need to reduce your scratch disk overhead to a minimum, you can minimize the number of patterns and brush tips you use in each of your presets, and you can reduce the number of patterns you use in your image's Layer Styles (as applied with the Bevel and Emboss Texture or in the Pattern Overlay). Each small pattern and sampled brush in the presets uses at least one tile for storage. Patterns used in Layer Styles take extra RAM, as well.

Minimizing the number of layers

Layers are fundamental toworking in Photoshop, but they also increase file sizes and redraw time because Photoshop recomposes each layer after each change in the image. After you have completed changes to layers, you can flatten (merge) them to reduce a file's size. You should also make sure to remove blank layers from the file since they too increase its size. It is important to remember that Photoshop does not let you separate layers after merging them. Instead, you can either use the Undo command or you can use the Photoshop History palette to reverse a merge.

-- To flatten all layers in a file, choose Layer > Flatten Image.

-- To merge a layer with the layer below it:

1. In the Layers palette, select the layer above the layer with which you want to merge it.

2. Choose Layer > Merge Down.

Flattening TIFF files

Photoshop allows layers to be saved in TIFF files. Layered TIFF files are larger than flattened TIFF files and require more resources for processing and printing. If you work with a layered TIFF file, save the original layered file as an Adobe Photoshop (*.psd) file; then, when you are ready to save the file in TIFF format, save a copy without layers.

Using image compression

Although compressed files generally have smaller file sizes, Photoshop may take longer to open or save them. With the exception of images saved in Photoshop format, Photoshop must decompress a file to open it and then recompress the file to save it. The BMP, CompuServe GIF, JPEG, Photoshop, Photoshop EPS, Photoshop PDF, and TIFF formats can be saved with compression. In addition, Photoshop enables you to specify a compression method for TIFF layers in the TIFF Options window. You can improve performance by saving your file in compressed Photoshop format (a compression format in which there is no data loss) as you work, and then save your file in the format you want when you are finished editing the image.

To save an image without compression from Photoshop, choose File > Save As, select the format you want, and then select the "no compression" option in the format's option dialog box. For example, select the TIFF format, and in the TIFF Options dialog box, select None for Image Compression.

Editing individual channels

Photoshop requires less memory to apply a filter to a single channel than it does to apply a filter to multiple channels or to an entire image (composite channel). In a flattened image, each RGB channel is about one-third the size of the file; each CMYK channel is about one-fourth the size. To edit a single channel, select the channel you want to edit in the Channels palette.

Using the Filter Gallery and applying filters to individual channels

The Filter Gallery in Photoshop CS2 allows you to test one or more filters on an image before applying the effect(s), which can save considerable time.

Dragging and dropping between files

Dragging and dropping layers or files is more efficient than copying and pasting them. Dragging bypasses the clipboard and transfers data directly. Copying and pasting can potentially involve more data transfer and may take more time.

Operating system software

By customizing your system so it runs efficiently, you can increase the amount of memory available to applications, and ensure that applications will run efficiently. By increasing the amount of memory available to Photoshop, allocating more memory to it, quitting applications you are not using, or disabling nonessential extensions, you improve the performance of Photoshop. Adobe recommends using Mac OS v10.3.3 or later. This update provides better support and performance when external storage devices are used as Photoshop scratch disks.

Run Apple periodic maintenance scripts to clean logs and temporary files

Mac OS X performs background maintance tasks overnight. If your computer is turned off or in sleep mode at night, then the maintenance tasks are not perfomred. Run a utility, such as CronMaster, to manually perform these tasks, or enter the commands using the Terminal. For further information, read document #107388, Mac OS X: How to force background maintenance taks (logs and temporary items), on the Apple support web page at www.apple.com/support/ .

Check your system for damaged fonts

If there is a damaged font on your system and you have WYSIWYG font preview turned on, your computer can slow significantly.If you turn off font preview and your computer performance improves significantly, test for a damaged font. See Related Records for more information on how to troubleshoot fonts.

Allocating more memory to Photoshop with 32-bit operating systems and computers

Photoshop uses random-access memory (RAM) to process image information. The more RAM available to Photoshop, the faster Photoshop can process image information. Other open applications and startup programs decrease the amount of memory potentially available to Photoshop. Quitting applications or startup items you are not using makes more memory available to Photoshop.

To allocate more memory to Photoshop:

1. Choose Photoshop > Preferences > Memory & Image Cache.

2. In the Memory Usage section, increase the Maximum Used by Photoshop percentage, and click OK.

3. Restart Photoshop.

Allocating Memory above 2 GB with 64-bit Processors

Photoshop CS2 is a 32-bit application, and when you run it on a 32-bit operating system, such as Mac OS 10.2.8, it still can only access 2 GB of RAM. The operating system uses some of this RAM, so the Photoshop Memory Usage preference displays only a maximum of 1.6 or 1.7 GB or total available RAM.

When you run Photoshop CS2 on a 64-bit operating system, such as Mac OS 10.3 and higher, it can access up to 8 GB of RAM. You can see the actual amount of RAM Photoshop can use in the Maxiumum Used By Photoshop number when you set the Maximum Used by Photoshop slider in the Memory & Image Cache preference to 100%. The RAM above the 100% used by Photoshop, which is from approximately 3 GB to 3.7 GB, can be used directly by Photoshop plug-ins (some plug-ins need large chunks of contiguous RAM), filters, actions, etc. If you have more than 4 GB (to 8 GB), the RAM above 4 GB is used by the operating system as a cache for the Photoshop scratch disk data. Data that previously was written directly to the hard disk by Photoshop, is now cached in this high RAM before being written to the hard disk by the operating system. If you are working with files large enough to take advantage of these extra 2 GB of RAM, the RAM cache can speed performance of Photoshop.

The default RAM allocation setting in Photoshop CS2 is 70%. These settings should be optimal for most users. To get the ideal RAM allocation setting for your system, change the RAM allocation in 5% increments and watch the performance of Photoshop in the Activity Monitor. You must quit and restart Photoshop after each change to see the change take effect.

The available RAM shown in the Memory & Image Cache preferences already deducted an amount that is reserved for the OS at any given time from the total RAM in your machine. You shouldn't set the percentage of RAM to be used by Photoshop to 100% (unless you are using more than 2G of RAM) because other applications which run at the same time as Photoshop (for example, Adobe Bridge) need a share of the available RAM. Some applications take use more RAM than you might expect. For example, web browsers can use 20-30 MB of RAM, and music players can use 20-50 MB RAM. Watch the Activity Monitor to view the RAM allocations on your computer.

Watch your efficiency indicator while you work in Photoshop to determine the amount of RAM you'll need to keep your images in RAM. The efficiency indicator is available from the pop-up menu on the status bar of your image or from the Palette Options on the Info Palette pop-up menu. When the efficiency indicator goes below 95-100%, you are using the scratch disk. If the efficiency is around 60%, you'll see a large performance increase by changing your RAM allocation or adding RAM.

Note: If you don't see the pop-up menu on the status bar of the image, widen the image window.

See the Related Documents section of this document for more information about memory allocation.

Hardware

Photoshop performance is limited by the hardware you use; the faster the processor or hard disk you use, the faster Photoshop can process image information. Other hardware enhancements, such as installing additional RAM, using a multiprocessor system, or optimizing and defragmenting drives, can also improve performance.

Processor speed

The CPU (Central Processing Unit) of the Macintosh limits the speed of Photoshop. Since Photoshop manipulates large quantities of data and performs many calculations, its speed is greatly dependent on processor speed.

Photoshop requires a G3 or faster processor. Photoshop can also take advantage of multiprocessor systems (that is, systems that have two or more PowerPC processors), which are much faster than a single-processor system. All Photoshop features are faster on a multiprocessor system, and some features are much faster.

Installed RAM

The amont of memory Photoshop requires depends on how you use the program. If memory is insufficient, Photoshop uses hard-drive space (that is, a scratch disk) to process information. Photoshop is fastest when it can process all or most image information in memory, without having to use the scratch disk. Watch the Efficiency Indicator to determine if you are operating as efficiently as possible.

To check memory use in Photoshop, open the Efficiency Indicator: Choose Efficiency from the pop-up menu on the status bar of your image to display the percentage of time actually doing an operation instead of reading or writing the scratch disk. If the value is below 95-100%, Photoshop is using the scratch disk and, therefore, is operating more slowly. If the efficiency is around 60%, you'll see a large performance increase by changing your RAM allocation or adding RAM.

Hard disks

As you add, delete, and move files on a hard drive, its available space is no longer a single, contiguous block. If the system does not have enough contiguous space, it saves fragments of a file to different locations on the hard drive. It takes an application longer to read a fragmented file than one saved to a contiguous location. You can defragment files and optimize available hard drive space by using a disk utility (for example, the Apple Disk Utility).

Since Photoshop reads and writes image information while editing an image, the faster the access speed of the drive containing the image or the Photoshop scratch disk, the faster Photoshop can process image information. To improve Photoshop performance, work on files saved on drives with fast access speeds, such as an internal hard drive, rather than those with slow access speeds (a network drive) or removable media (for example, a Zip disk). Removable media often have slower access times and are more easily damaged than internal hard drives.

Resources

These websites provide troubleshooting tips and further information about the Mac OS:

-- Apple Support: www.apple.com/support

-- Mac Resource Page: www.macresource.com

-- MacFixIt Troubleshooting Solutions for the Macintosh: www.macfixit.com

-- MacDirectory: www.macdirectory.com

-- The X Lab: www.thexlab.com


Related Documents

320005: Memory allocation and usage (Photoshop CS2)

331307: Troubleshoot system errors or freezes in Photoshop (CS2 on Mac OS X)

327791: Troubleshoot font problems (Mac OS X)

Document 332270
Last edited - 01/02/2007

 

Got Some Time to Take a Survey?

Tell us what you think about this support site.