Accessibility

Support Knowledgebase

Optimize performance of Photoshop (CS2 on Windows)

What's covered

Adobe Photoshop options and plug-ins

Image files

Operating system software

Hardware

Resources

The performance of Adobe Photoshop CS2 is affected most by available random-access memory (RAM) and computer processor speed. Other factors can also affect performance, such as the options you select, system configuration, and the built-in limitations of Photoshop. Photoshop CS2 supports new maximum image dimensions, and file sizes requiring increased system requirements. The maximum file size Photoshop CS2 supports is 300,000 x 300,000 pixels, except for PDF files, which are still constrained by the 30,000 x 30,000 pixel limitation.

Photoshop CS2 has an increased file size capability for the following file types:

-- PSD files: 2 GB

-- TIFF files: 4 GB

Note: Most applications cannot work with TIFF files over 2 GB.

-- PSB files: 4 Exabytes (4096 Petabytes, or 4 million Terabytes)

-- PDF files: 10 GB (pages are limited to a maximum size of 200 inches).

Note: Large Document Format files (.PSB) cannot be read by Photoshop 7.0.x or earlier.

Adobe Photoshop options and plug-ins

The options you select and plug-ins you use in Photoshop can affect its performance. The options and plug-ins that most directly affect performance include those covered in this section.

Setting scratch disks

The Photoshop scratch disk is similar to virtual memory. For the best performance, you should set the scratch disk to a defragmented hard disk that has plenty of unused space and fast read/write speeds (rather than a network drive or removable media such as a Zip drive). Photoshop requires at least 650 MB of free hard-disk space, but more is recommended. If you have more than one hard disk volume, you should specify additional scratch disks. Photoshop CS2 supports up to 64 exabytes (EB) of scratch disk space on a total of four volumes. (An EB is equal to 1 billion gigabytes.) RAID 0 partitions provide the best possible performance as Photoshop scratch disks.

Note: Adobe recommends that you set the primary scratch disk to a different hard disk than the one Windows uses for its virtual memory or paging file.

To set the scratch disk:

1. Choose Edit > Preferences > Plug-Ins & Scratch Disks.

2. Choose the drive that has the most free space from the First pop-up menu.

3. Choose a second drive, if available, from the Second pop-up menu.

4. Choose other drives, if available, from the Third and Fourth pop-up menus.

5. Click OK.

6. Restart Photoshop.

Adjusting the Image Cache

Photoshop uses image caching to redraw high-resolution images faster. With image caching, Photoshop uses low-resolution versions of an image to quickly update the image on-screen as you work. To enable the Image Cache option, specify the number (1 to 8) of low-resolution versions you want Photoshop to store (cache). The more versions of an image you have Photoshop cache, however, the slower it opens image files. In Photoshop, the default Image Cache setting is 6. Setting the Image Cache option to 1 disables image caching; only the current screen image is cached. Setting the Image Cache higher than 4 improves the performance when working on larger images by redrawing them faster. If you have performance issues in Photoshop CS2, set the Image Cache to 2, then test your performance.

Note: Image caching may cause a less accurate preview. When necessary, view files at 100% to ensure an accurate preview.

To adjust the Image Cache setting:

1. Choose Edit > Preferences > Memory & Image Cache.

2. Enter a value from 1 to 8 in the Cache Levels text box.

3. Restart Photoshop.

Set Maximize PSD And PSB File Compatibility to Ask

Maximize PSD and PSB File Compatibility increases the size of your file by attaching a flattened copy of your image when you save your image. In past versions of Photoshop, you didn't need to keep this option on. In Photoshop CS2, however, a small amount of extra data is included in the file when you choose this option that ensures that PSD and PBS files saved in Photoshop CS2 will open in previous versions. Additionally, when this option is on, and you open a Photoshop CS2 image in a previous version with a feature in it that cannot be supported by the older version, Photoshop will display a warning message.

If you are saving files in Photoshop CS2 for use in older versions, then save them with this option on (that is, set to Ask or Always).

To change the Maximize File Compatibility option:

1. Choose Photoshop > Preferences > File Handling.

2. Change Maximize PSD And PSB File Compatibility to one of the following:

-- Ask: Prompts you to maximize file compatibility when you save.

-- Always: Saves with maximized file compatibility without asking.

-- Never: Does not save or prompt you to save with maximized file compatibility.

Minimizing palette preview thumbnails

Photoshop requires additional memory to display preview thumbnails in the Layers, Channels, and Paths palette. Photoshop updates the preview thumbnails as you make changes to the image itself. The more preview thumbnails Photoshop displays, and the larger the thumbnail you select, the more memory Photoshop requires to draw and update preview thumbnails.

To minimize or turn off palette previews in the Layers, Channels, or Paths palette, select Palette Options from the palette menu. For Thumbnail Size, select the smallest thumbnail size or select None, then click OK.

Using the Extract command

When you run the Extract command (Filter > Extract) on a computer that has low RAM or disk space, Photoshop responds slowly or not at all. The Extract command can require more than the recommended minimum amount of RAM and disk space for Photoshop--if Photoshop responds slowly when you use the Extract command, increase the percentage of memory used by Photoshop, or free additional hard-disk space.

To increase the percentage of memory used by Photoshop:

1. Choose Edit > Preferences > Memory & Image Cache.

2. In the Memory Usage section, increase the Maximum Used By Photoshop percentage, and click OK.

Note: Don't set the percentage to more than 75%.

3. Restart Photoshop.

16-bit functionality

Photoshop CS2 significantly increases the number of features that can be performed on 16-bit images. However, if your resources are low, reducing your images to 8-bit can improve performance. Note that this reduction will permanently delete the extra bit data from your image.

Adjusted Refresh plug-in

This plug-in is not necessary for Photoshop CS2, because the new maximum tile size in Photoshop CS2 is 132 KB. The amount of space set aside for and displayed in the Scratch Sizes indicator in Photoshop CS was much larger than in earlier versions because the tile sizes were larger. The Adjusted Refresh plug-in reduced the initial scratch disk usage when you started Photoshop, and reduced the size of the Photoshop image tiles from the default size of 1 MB per tile to 64 KB per tile. The smaller tiles allow the display to redraw in smaller pieces, reducing the time needed to preview some filter updates.

Bigger Tiles plug-in

The Bigger Tiles plug-in, which is located in the Program Files\Adobe\Adobe Photoshop CS2\Plug-Ins\Adobe Photoshop Only\Extensions\Bigger Tiles folder, is disabled by default. When you enable it by removing the ~ from the filename, then you increase the image tile size in Photoshop. You should only enable the plug-in if you have more than 1 GB of RAM installed.

If you enable the plug-in, then Photoshop redraws more data at a time because each tile is larger, and each tile is drawn, complete, at one time. Photoshop takes less time to redraw fewer tiles that are larger, than more tiles that are smaller. Because Photoshop redraws more data at one time, each tile it takes longer to be redrawn; so bigger tiles can look like they are redrawing slower, but they are actually redrawing faster than if the image had more smaller tiles.

Image files

You can optimize your workflow to improve performance by minimizing file size, editing individual channels, and using image compression selectively. Additionally, because layers and channels add significantly to the size of a file, you can minimize file size by merging layers and deleting channels when you no longer need them. And finally, if you are preparing images for color separation, you can work in RGB mode until you are ready to print and then change the images to CMYK mode. When converted from CMYK to RGB, a file's size should decrease by about 25%.

Minimizing file size

You can minimize the size of your files by reducing their resolution, measured in pixels per inch (ppi). Photoshop requires more memory and disk space to process high-resolution images, therefore increasing the time it takes Photoshop to display, process, and print them. Increasing the resolution of an image doesn't always improve the quality of the image, and instead only increases its file size. You want the resolution of your images to be the highest value your printer can use. Resolutions higher than that only add information to your image that your printer can't use, but must process, and thus increase print times.

If you plan to print continuous-tone images (for example, photographs), begin by using a resolution that is 1.5 to 2 times the screen frequency, measured in lines per inch (lpi), that you'll use to print the image. For line-art images, such as drawings, use the same value as your printer's resolution, measured in dots per inch (dpi). For example, if the resolution of your printer is 600 dpi, and you plan to print the image using the printer's default screen frequency of 85 lpi, save continuous-tone images at a resolution between 127 ppi (85 lpi x 1.5) and 170 ppi (85 lpi x 2), and save line-art images at a resolution of 600 ppi.

Recommended resolutions for continuous-tone images:

Output
Recommended resolution
Windows-compatible monitor
96 ppi
300 dpi laser printer
100 ppi
600 dpi laser printer
150 ppi
725 dpi inkjet printer
150 ppi
1200 dpi or higher imagesetter
2x the screen frequency (lpi) value you specified

To reduce the resolution of an image in Photoshop:

1. Open the image, then choose Image > Image Size.

2. In the Image Size dialog box, decrease the Resolution value, then click OK.

Purge Undo, Clipboard, or Histories

Undo, Clipboard, and Histories all hold image data. To release RAM, choose Edit > Purge to purge the Undo and Clipboard. Purging Histories can release RAM or scratch disk depending on how recent your history data is. To reduce disk space usage, reduce the number of History States available in the General preference.

Reduce the number of History states

In Photoshop CS2, each history state that includes an operation that affects the entire image (for example, when you apply Gaussian blur or unsharp mask to the entire image) creates a full copy of your image at its original size. If your initial image is 500 KB, and you apply Gaussian blur to it, your image will need 1 MB of scratch space. If your history states consist of operations that affect only part of the image, such as paint strokes, only the size of the tiles touched by the strokes are added to the image size. If you count up the number of histories you have where operations have affected the entire image, and multiply your original image size by that number, you'll have an approximate amount of scratch disk space the image will need. If you have applied levels, a reduce noise filter, and an unsharp mask filter to your entire image that's 5 MB in size, the image will need 20 MB of scratch space. When you reduce the number of history states available, you potentially reduce the number of copies of your image using scratch space.

Reduce patterns and brush tips

If you need to reduce your scratch disk overhead to a minimum, you can minimize the number of patterns and brush tips you use in each of your presets, and you can reduce the number of patterns you use in your image's Layer Styles (as applied with the Bevel and Emboss Texture or in the Pattern Overlay). Each small pattern and sampled brush in the presets uses at least one tile for storage. Patterns used in Layer Styles take extra RAM, as well.

Minimizing the number of layers

Layers are fundamental to working in Photoshop, but they also increase file sizes and redraw time because Photoshop recomposes each layer after each change in the image. After you have completed changes to layers, you can flatten (merge) them to reduce a file's size. You should also make sure to remove blank layers from the file since they too increase its size. It is important to remember that Photoshop does not let you separate layers after merging them. Instead, you can either use the Undo command or you can use the History palette to reverse a merge.

-- To flatten all layers in a file, choose Layer > Flatten Image.

-- To merge a layer with the layer below it:

1. In the Layers palette, select the layer above the layer with which you want to merge it.

2. Choose Layer > Merge Down.

Flattening TIFF files

Photoshop allows layers to be saved in TIFF files. Layered TIFF files are larger than flattened TIFF files and require more resources for processing and printing. If you work with a layered TIFF file, save the original layered file as an Adobe Photoshop (*.psd) file; then, when you are ready to save the file in TIFF format, save a copy without layers.

Using image compression

Although compressed files generally have small file sizes, Photoshop may take longer to open or save them. With the exception of images saved in Photoshop format, Photoshop must decompress a file to open it and then recompress the file to save it. The BMP, CompuServe GIF, JPEG, Photoshop, Photoshop EPS, Photoshop PDF, and TIFF formats all can be saved with compression. In addition, Photoshop enables you to specify a compression method for TIFF layers in the TIFF Options window. You can improve performance by saving your file in compressed Photoshop format (a compression format in which there is no data loss) as you work, and then save your file in the format you want when you are finished editing the image.

To save an image without compression from Photoshop, choose File > Save As, select the format you want, and then select the "no compression" option in the format's Options dialog box. For example, select the TIFF format, and in the TIFF Options dialog box, select None for Image Compression.

Editing individual channels

Photoshop requires less memory to apply a filter to a single channel than it does to apply a filter to multiple channels or to an entire image (composite channel). In a flattened image, each RGB channel is about one-third the size of the file; each CMYK channel is about one-fourth the size. To edit a single channel, select the channel you want to edit in the Channels palette.

Using the Filter Gallery and applying filters to individual channels

The Filter Gallery in Photoshop CS2 allows you to test one or more filters on an image before applying the effect(s), which can save considerable time.

Dragging and dropping between files Dragging and dropping layers or files is more efficient than copying and pasting them. Dragging bypasses the clipboard and transfers data directly. Copying and pasting can potentially involve more data transfer and is much less efficient.

Operating system software

By customizing your operating system so it runs efficiently, you not only increase the amount of system resources available to applications, but also ensure that your applications run efficiently. Optimizing your hard drive and virtual memory, organizing or removing temporary files, and disabling unnecessary applications running in the background improves performance.

Note: Photoshop CS2 can only operate on computers running Windows 2000 or Windows XP.

Allocating more memory to Photoshop with 32-bit operating systems and computers

Photoshop uses random-access memory (RAM) to process image information. The more RAM available to Photoshop, the faster Photoshop can process image information. Other open applications and startup programs decrease the amount of memory potentially available to Photoshop. Quitting applications or startup items you are not using makes more memory available to Photoshop.

To allocate more memory to Photoshop:

1. Choose Edit > Preferences > Memory & Image Cache.

2. In the Memory Usage section, increase the Maximum Used by Photoshop percentage, and click OK.

3. Restart Photoshop.

Allocating memory above 2 GB with 64-bit processors

Photoshop CS2 is a 32-bit application. When it runs on a 32-bit operating system, such as Windows 2000 and Windows XP Professional, it can access the first 2 GB of RAM on the computer.The operating system uses some of this RAM, so the Photoshop Memory Usage preference displays only a maximum of 1.6 or 1.7 GB of total available RAM. If you are running Windows XP Professional with Service Pack 2, you can set the 3 GB switch in the boot.ini file, which allows Photoshop to use up to 3 GB of RAM.

Important: The 3 GB switch is a Microsoft switch and may not work with all computers. Contact Microsoft for instructions before you set the 3 GB switch, and for troubleshooting the switch. You can search on the Microsoft support page for 3gb for information on this switch.

When you run Photoshop CS2 on a computer with a 64-bit processor (such as a, Intel Xeon processor with EM64T, AMD Athlon 64, or Opteron processor), and running a 64-bit version of the operating system (Windows XP Professional x64 Edition), that has 4 GB or more of RAM, Photoshop will use 3 GB for it's image data. You can see the actual amount of RAM Photoshop can use in the Maximum Used By Photoshop number when you set the Maximum Used by Photoshop slider in the Memory & Image Cache preference to 100%. The RAM above the 100% used by Photoshop, which is from approximately 3 GB to 3.7 GB, can be used directly by Photoshop plug-ins (some plug-ins need large chunks of contiguous RAM), filters, actions, etc. If you have more than 4 GB (to 6 GB), the RAM above 4 GB is used by the operating system as a cache for the Photoshop scratch disk data. Data that previously was written directly to the hard disk by Photoshop, is now cached in this high RAM before being written to the hard disk by the operating system. If you are working with files large enough to take advantage of these extra 2 GB of RAM, the RAM cache can speed performance of Photoshop.

The default RAM allocation setting is 55%. This setting should be optimal for most users. To get the ideal RAM allocation setting for your system, change the RAM allocation in 5% increments and watch the performance of Photoshop in the Performance Monitor. You must quit and restart Photoshop after each change to see the change take effect.

The available RAM shown in the Memory & Image Cache preferences already deducted an amount that is reserved for the OS at any given time from the total RAM in your machine. You shouldn't set the percentage of RAM to be used by Photoshop to 100%, because other applications which run at the same time as Photoshop (for example, Adobe Bridge) need a share of the available RAM. Some applications take use more RAM than you might expect. For example, web browsers can use 20-30 MB of RAM, and music players can use 20-50 MB RAM. Watch the Performance Monitor to view the RAM allocations on your computer.

Watch your efficiency indicator while you work in Photoshop to determine the amount of RAM you'll need to keep your images in RAM. The efficiency indicator is available from the pop-up menu (choose Show > Efficiency) on the status bar of your image and from the Palette Options on the Info Palette pop-up menu. When the efficiency indicator goes below 95-100%, you are using the scratch disk. If the efficiency is around 60%, you'll see a large performance increase by changing your RAM allocation or adding RAM.

See the Related Documents section of this document for more information about memory allocation.

Check your system for damaged fonts

If there is a damaged font on your system and you have WYSIWYG font preview turned on, your computer can slow significantly.If you turn off font preview and your computer performance improves significantly, test for a damaged font. See Related Records for more information on how to troubleshoot fonts.

Temporary files

When you work in an application, a copy of your data file is stored temporarily on the hard drive. Many applications create .tmp files and then delete them when you quit the application. Crashes or system errors, however, may prevent an application from deleting these files. These files can build up over time, taking up disk space and causing problems. From time to time, you should quit all programs and remove all temporary files.

To delete temporary files:

1. Choose one of the following:

-- (Windows XP) Start > Search > All Files and Folders

-- (Windows 2000) Start > Search > For Files and Folders

2. In the Named text box, *.tmp.

3. Choose Local Hard Drives from the Look In pop-up menu.

4. Click Find Now or Search Now.

5. When the search results appear, choose Edit > Select All.

6. Choose File > Delete. Click Yes to send the files to the Recycle Bin.

7. Empty the Recycle Bin.

To make sure that at least 280 MB of free space is available on the hard disk to which temporary files are written:

1. Quit all applications.

2. Choose Start > Control Panel, and then double-click System.

3. Click the Advanced tab, and then click Environment Variables.

4. In the User Variables For [user profile] section, locate TEMP in the Variable column, and note the folder listed in the Value column. If the complete path for the folder isn't visible, double-click TEMP in the Variable column, and note the folder name in the Variable Value text box.

Note: If a TEMP variable doesn't exist, contact your system administrator for assistance.

5. In Windows Explorer, verify that the folder you noted in step 4 exists on a non-compressed disk partition that has at least 280 MB of free space:

-- If the folder doesn't exist, then create it: Right-click the drive, choose New Folder from the menu, and type the folder name you noted in step 4 (for example, Temp).

-- If the disk doesn't have enough free space, then create additional space by removing unnecessary files. To determine the amount of free space, right-click the drive and choose Properties from the menu.

Optimizing and defragmenting hard disks

Over time, the computer's hard disk can become damaged or fragmented (unavailable in a large contiguous block). If there is not enough contiguous space for the system to save a file, it saves pieces of the file to different locations on the disk. It takes an application longer to read a fragmented file whose pieces are saved in several locations.

To optimize and defragment the hard disk: Use the Disk Defragmenter: Choose Start > Programs > Accessories > System Tools > Disk Defragmenter (Windows 2000) or Start > All Programs > Accessories > System Tools > Disk Defragmenter (Windows XP).

Windows virtual memory and Photoshop scratch disk files

Virtual memory allows your system to use hard-disk space to store information normally stored in memory (RAM). Because it takes longer to access information on a hard disk than it does to access information in memory, using a portion of the hard disk as virtual memory can decrease performance. In addition, Photoshop cannot use the hard-disk space the system uses for virtual memory for its scratch disk files, which it uses to store image information as you work. If you need more memory to work in Photoshop, Adobe Systems recommends installing more RAM.

Specifying a fixed virtual memory setting helps prevent Photoshop scratch disk files from competing for the same space with virtual memory, especially if you set the virtual memory setting on a different drive than the primary scratch disk. For both kinds of virtual memory, be sure to use a drive with enough free, uncompressed space. RAID 0 partitions provide the best possible performance as Photoshop scratch disks.

1. Quit all applications.

2. Choose Start > Settings > Control Panel, double-click System, and click the Advanced tab, and then select Settings in the Performance section.

3. In the Virtual Memory section, do one of the following:

(Windows XP) Click the Advanced tab, and in the Virtual memory section, click Change.

(Windows 2000) Click Change.

4. From the Drive list, select a hard drive that has at least twice the amount of your computer's installed RAM, or for Windows XP, 1.5 times the amount of your computer's installed RAM. For example, if your computer has 512 MB of RAM, select a hard drive that has at least 1 GB of free hard drive space, or 768 MB for Windows XP. For best performance, choose a hard drive not used for the Photoshop scratch disk(s).

5. In the Paging File Size for Selected Drive section, select Custom size (Windows XP only), and in the Initial Size box, enter a value equal to the twice the amount of your computer's installed RAM.

6. In the Maximum Size box, enter a value equal to four times the amount of your computer's installed RAM.

7. Click Set and then click OK.

Note: For the best performance, the Paging File should be on a separate, empty, de-fragmented hard disk.

8. Click to close the System Control Panel Applet (Windows XP) or the System dialog boxes (Windows 2000).

9. To restart Windows, click Yes in the System Settings Change dialog box.

Applications running in the background

Some applications may complete for memory with Photoshop causing slowdowns or system errors when running concurrently with Photoshop. Before starting Photoshop, disable other applications, including startup items (items that start automatically with Windows).

In Windows XP:

To disable startup items:

1. Quit all applications.

2. Choose Start > Run, and type msconfig in the Open box. Click OK.

3. Click the Startup tab, and click Disable All.

4. Select any startup items that are essential for testing the problem. If you are unsure whether an item is essential, leave it deselected (disabled).

5. Click OK, and restart Windows.

Note: Depending on settings in the System Configuration utility, a System Configuration utility dialog box may appear after the restart, asking you if you want to continue in Selective Startup mode. If this occurs, click OK once to close the message dialog box. Click OK again to quit the System Configuration utility. Click Exit Without Restart.

6. Right-click icons in the Notification Area (called the System Tray in earlier versions of Windows) to close or disable any startup items that are still active.

Then, try to re-create the problem:

-- If the problem doesn't occur, one of the disabled startup items conflicts with Photoshop. Reenable startup items one at a time, testing each time until you determine which item conflicts with Photoshop. Then contact that item's developer for an update, if available.

-- If the problem does occur, startup items aren't the cause and you can reenable them:

a. Choose Start > Run, and type msconfig in the Open box. Click OK.

b. Click the Startup tab, and click Enable All.

c. Click OK, and restart Windows.

In Windows 2000:

To identify a problematic application in the Startup folder:

1. Quit all applications.

2. In Windows Explorer, move all icons and shortcuts from the following folders to another folder:

-- Documents and Settings/All Users/Start Menu/Programs/Startup

-- Documents and Settings/ [username] /Start Menu/Programs/Startup

3. Restart Windows, and try to re-create the problem. Then continue as follows:

-- If the problem recurs, move the icons and shortcuts back to the Startup folder.

-- If the problem doesn't recur, move the icons and shortcuts back to the Startup folder one at a time to determine which application causes the problem.

To identify a problematic application specified in the registry to start automatically:

1. Right-click the taskbar, and choose Task Manager from the menu.

2. Click the Applications tab.

3. Select an application, and then click End Task.

4. Restart Photoshop, and try to re-create the problem. Then continue as follows:

-- If the problem recurs, repeat steps 1-4 and select another application in step 3.

-- If the problem doesn't recur, the application you selected in step 3 conflicts with Photoshop.

Hardware

Photoshop performance is limited by the hardware you use; the faster the processor or hard disk you use, the faster Photoshop can process image information. Other hardware options, such as installing additional RAM, using a multiprocessor system, or using optimized and defragmented disks, can also improve performance.

Performance or redraw issues

Performance and redraw problems include:

-- Photoshop runs extremely slowly, or slows down suddenly.

-- Windows, palettes, images, and selections don't redraw correctly when partially covered by dialog boxes.

-- Images redraw very slowly when edited.

-- Menus don't appear or you can't access menu items.

-- The pointer disappears when you move it around the screen or between two screens.

-- The pointer displays an hourglass each time it hovers over a palette (such as the Layers palette).

-- Dialog boxes are blank.

-- Errors occur, such as "This application needs to close."

-- Redraw of layer edges is delayed after you enable Show Layer Edges.

These solutions have solved these problems:

-- Reduce the image cache level to 2 in the Memory & Image Cache preference.

-- Move all fonts from the Windows\Fonts folder to the desktop, then add them back.

-- Disable hyperthreading in the BIOS. If performance improves, then upgrade to the latest BIOS.

For more information and instructions on the above solutions, see the Related Documents section in this document.

Processor speed

Speed is limited by the speed of the computer's processor, or CPU (Central Processing Unit). Since Photoshop manipulates large quantities of data and performs many calculations, its speed is greatly dependent on the processor's speed. Photoshop requires a Pentium III or 4 processor.

All Photoshop features are faster on a multiprocessor system, although some can take greater advantage of the multiprocessor system's capabilities.

Installed RAM

Photoshop requires the available RAM to equal several times the size of each image, depending on how you use the application. If Photoshop has insufficient memory, it uses hard-disk space (scratch disk) to process information. Because accessing information in memory is faster than accessing information on a hard disk, Photoshop is fastest when it can process all or most image information in memory (RAM), without using the scratch disk. Allocate enough memory to Photoshop to accommodate your largest image file.

To check use of memory for Photoshop, open the Efficiency Indicator: Choose Show > Efficiency from the pop-up menu on the status bar of your image to display the percentage of time actually doing an operation instead of reading or writing the scratch disk. If the value is less than 95-100%, Photoshop is using the scratch disk and, therefore, is operating more slowly. If the efficiency is around 60%, you'll see a large performance increase by changing your RAM allocation or adding RAM.

Hard disks

Since Photoshop reads and writes image information while working on an image, the faster the access speed of the disk containing your image or the scratch disk, the faster Photoshop can process image information. To improve Photoshop performance, work on files saved on disks with fast access speeds, such as an internal hard disk, rather than those with slow access speeds, such as a network server (hard disk accessed over a network) or removable media, for example, Zip disks. Removable media often have slower access times and are more easily damaged than nonremovable disks.

Resources

The following books and Web sites provide troubleshooting tips and general information about Windows.

Books

Microsoft Windows Resource Kits

Windows for Dummies books

Web sites

Microsoft Support: http://support.microsoft.com

CNET: www.cnet.com

ArsTechnica: http://arstechnica.com/index.ars


Related Documents

320005: Memory allocation and usage (Photoshop CS2)

331412: Slow performance and screen redraw problems in Photoshop (CS2 on Windows)

327946: Troubleshoot system errors or freezes in Photoshop (CS2 on Windows XP)

331308: Troubleshoot system errors or freezes in Photoshop (CS2 on Windows 2000)

328607: Troubleshoot font problems (Windows)

Document 332271
Last edited - 01/02/2007

 

Got Some Time to Take a Survey?

Tell us what you think about this support site.