Accessibility

Support Knowledgebase

Troubleshoot system errors or freezes (Illustrator CS, CS2 on Windows XP)

What's covered

Beginning troubleshooting

Intermediate troubleshooting

Advanced troubleshooting

This document can help you resolve system errors that occur while using Adobe Illustrator CS-CS2 in Windows XP. System errors can manifest themselves in many different ways, including (but not limited to) the following:

-- A blank or flickering dialog box

-- A frozen cursor or screen

-- An error such as one of the following:

"This program has performed an illegal operation and will be shut down. If the problem persists, contact the program vendor."

"Illustrator caused a General Protection Fault in module [filename]."

"Illustrator caused an Invalid Page Fault in module [filename]."

"Application Error."

"Unhandled exception detected. Application will be terminated."

"Illegal Instruction."

"Segment load failure in [filename]."

Many different factors can cause system errors, including conflicts among device drivers, applications, operating system settings, hardware, and corrupt elements in specific files. Although a system error may occur only when you work with Illustrator, Illustrator may not necessarily be the cause--it may be the only application that is memory- or processor-intensive enough to expose the problem.

To benefit most from this document, perform the tasks in order. Keep track of the tasks you perform and the results of each, including errors and other problems. Adobe Technical Support can use this information to better assist you, if you need to call.

Beginning troubleshooting

The tasks in this section can help you resolve the most common system errors. Before performing any of these tasks, back up all personal files (for example, Illustrator files you created). Always restart the computer after a system error occurs to refresh its memory. Continuing to work without restarting the computer may compound the problem.

Note: Some of these tasks require you to locate hidden files and hidden folders. Some procedures require you to locate files by their full file names, which include extensions (for example, example_file.ini). By default, Windows Explorer doesn't show hidden files, hidden folders, and file name extensions that it recognizes.

To show hidden files, hidden folders, and all file extensions in Windows Explorer:

1. In Windows Explorer, choose Tools > Folder Options.

2. Click the View tab in the Folder Options dialog box.

3. In Advanced Settings, select Show Hidden Files And Folders.

4. Deselect Hide Extensions For Known File Types.

5. Click OK.

1. Make sure that the system meets the minimum requirements for Illustrator.

Adobe Illustrator may not run correctly on a system that doesn't meet the following requirements:

Illustrator CS2

-- Intel Pentium III or Pentium 4 processor

-- Microsoft Windows XP with Service Pack 1 or 2 or Windows 2000 with Service Pack 3 or 4

-- 256 MB of RAM* or 384MB with Bridge (512 MB recommended)

-- 820 MB of available hard-disk space

-- 1024x768 monitor resolution with 16-bit or greater video card (24-bit screen display recommended)

-- CD-ROM drive

-- For PostScript printing: Adobe PostScript Level 2 or PostScript 3 printers

Illustrator CS

-- Intel Pentium III or Pentium 4 processor

-- Microsoft Windows XP or Windows 2000 with Service Pack 3

-- 192 MB of RAM* (256 MB recommended)

-- 470 MB of available hard-disk space

-- CD-ROM drive

-- For PostScript printing: Adobe PostScript Level 2 or PostScript 3 printers

*To check how much RAM is installed, choose Start > Control Panel, click Performance and Maintenance, and then click System. The amount of RAM appears on the lower half of the General panel in the System Properties window.

2. Install the latest version of Illustrator.

The latest version of Illustrator may be more compatible with your operating system and drivers. Before you install an update or upgrade, make sure that the system meets the requirements.

Updates are available from the Adobe website at www.adobe.com/support/downloads . An upgrade, however, may solve a wider range of problems. You can purchase upgrades from Adobe Authorized Resellers and from Adobe directly:

-- To locate an Authorized Reseller, visit the Adobe website at www.adobe.com/store/customerregistration/other_places.jhtml and choose your country or region from the pop-up menu at the top of the page, or call Customer Services at 800-833-6687 (U.S./Canada only).

-- To purchase an upgrade from Adobe, visit the Adobe Store at www.adobe.com/store/products/master.jhtml?id=catIllustrator and choose your country or region from the pop-up menu at the top of the page, or call Customer Services at 800-833-6687 (U.S./Canada only).

3. Install current Windows service packs and other updates.

Updates to the Windows operating system improve its performance and compatibility with applications. You can obtain Windows service packs and other updates from the Microsoft website at www.windowsupdate.com . For assistance installing service packs and other updates, contact Microsoft technical support.

If you've reinstalled an application or the Windows operating system after installing the latest Windows update, reinstall the update. Some applications install commonly used system files, overwriting the updated versions installed by the Windows update.

4. Re-create the Illustrator preferences file.

Re-create the Illustrator preferences file to eliminate problems that a damaged preferences file might cause.

Note: When you re-create the preferences file, unsaved actions are lost. To save actions that you created, choose Save Actions from the Actions palette menu.

To re-create the Illustrator preferences file:

1. Quit Illustrator.

2. Rename the AIPrefs file (for example, to AIPrefs.old) located in Documents and Settings\ [user profile] \Application Data\Adobe\Adobe Illustrator [version] Settings.

3. Start Illustrator. Illustrator creates a new preferences file.

If the problem continues, the preferences file isn't the cause. To restore custom settings, delete the new preferences file and restore the original name of the previous preferences file.

5. Run Illustrator while no other applications are running.

Some applications may cause system errors or freezes when running concurrently with Illustrator. Before starting Illustrator, disable other applications, including startup items (items that start automatically with Windows).

To disable startup items:

1. Quit all applications.

2. Choose Start > Run, and type msconfig in the Open box. Click OK.

3. Click the Startup tab, and click Disable All.

4. Select any startup items that are essential for testing the problem. If you are unsure whether an item is essential, leave it deselected (disabled).

5. Click OK, and restart Windows.

6. Right-click icons in the Notification Area (called the System Tray in earlier versions of Windows) to close or disable any startup items that are still active.

Then, try to re-create the problem:

-- If the problem doesn't occur, one of the disabled startup items conflicts with Illustrator. Reenable startup items one at a time, testing each time until you determine which item conflicts with Illustrator. Then contact that item's developer for an update, if available.

-- If the problem does occur, startup items aren't the cause and you can reenable them:

a. Choose Start > Run, and type msconfig in the Open box. Click OK

b. Click the Startup tab, and click Enable All.

c. Click OK, and restart Windows.

6. Set a PostScript printer as the default.

To determine if the printer driver for the current default printer conflicts with Illustrator, install a printer that uses a PostScript printer driver, and then set that printer as the default. (In Windows, you can install a printer that isn't a physical piece of hardware.) If the problem doesn't recur, the printer driver that you were using previously conflicts with Illustrator; contact the printer manufacturer for an updated driver.

To install a printer that uses a PostScript printer driver:

1. Download the installer for the Adobe PostScript printer driver (AdobePS) from the Adobe website at www.adobe.com/support/downloads/#printer .

2. Double-click the installer file, and then follow the on-screen instructions.

To set a printer as the default:

1. Choose Start > Printers And Faxes.

2. Right-click the printer, and then choose Set As Default from the pop-up menu.

7. Troubleshoot third-party plug-ins.

Remove third-party plug-ins from the Illustrator plug-ins folder, and then restart Illustrator. If the problem recurs, move the plug-ins back to the Illustrator plug-ins folder, and proceed to the next section of this document, "Intermediate troubleshooting." If the problem doesn't recur, identify and address conflicting plug-ins.

To identify and address conflicting plug-ins:

1. Move one third-party plug-in back to the Illustrator plug-ins folder.

2. Restart Illustrator, and try to re-create the problem.

3. If the problem doesn't recur, begin again at step 1. If the problem does recur, contact the developer of the plug-in you last moved, and inquire about an update.

Intermediate troubleshooting

If the tasks in the previous section don't solve the problem, try the following intermediate troubleshooting tasks.

8. Reinstall Illustrator in Safe mode or a simplified mode.

Device drivers and software that loads automatically with Windows (for example, screen savers, virus protection utilities) can conflict with the Illustrator installer. To prevent conflict, reinstall Illustrator while Windows is in Safe mode or a simplified mode, which disables nonstandard device drivers and startup software.

Note: You must install Illustrator CS2 in a simplified mode. The installer isn't compatible with Safe mode.

To reinstall Illustrator CS2 in a simplified mode:

1. Move any personal files out of the Illustrator folder and its subfolders.

2. Uninstall Illustrator:

-- If you installed Illustrator from the Illustrator CD, choose Start > Control Panel > Add Or Remove Programs. Select Illustrator CS2 and click Remove. Follow the on-screen instructions.

-- If you installed Illustrator from the Adobe Creative Suite CDs, choose Start > Control Panel > Add Or Remove Programs. Select Adobe Creative Suite 2 and click Remove. Follow the on-screen instructions to uninstall the Illustrator component.

3. Choose Start > Run, and type msconfig in the Open box. Click OK.

4. Click the Startup tab, and click Disable All.

5. Click OK, and restart Windows.

6. Install Illustrator from the installation media.

7. Choose Start > Run, type msconfig in the Open box, and then click OK.

8. Click the Startup tab, and click Enable All.

9. Click OK, and restart Windows.

To reinstall Illustrator CS in Safe mode:

1. Move any personal files out of the Illustrator folder and its subfolders.

2. Uninstall Illustrator:

-- If you installed Illustrator from the Illustrator CD, choose Start > Control Panel > Add Or Remove Programs. Select Illustrator CS, and click Remove. Follow the on-screen instructions.

-- If you installed Illustrator from the Adobe Creative Suite CD, insert disk 1 of the Adobe Creative Suite and run the uninstaller to remove Illustrator.

3. Restart Windows.

4. Press the F8 key before Windows starts, when you see a message such as "For Advanced Startup Options. . . ."

5. Select Safe Mode from the list of startup options.

6. "Safe Mode" should appear in each corner of the desktop.

-- If "Safe Mode" doesn't appear in each corner of the desktop, then repeat steps 6-8.

-- If "Safe Mode" does appear in each corner of the desktop, then log in as administrator of the local machine.

7. If a dialog box indicates that Windows is running in Safe Mode, then click OK.

8. Install Illustrator from the installation media.

9. Restart Windows.

9. Run Illustrator in a new user account.

Create a new user account that has the same permissions as the account that you use when the problem occurs. If the problem doesn't recur, the original user account may be damaged. For instructions on creating a new user account, see "To add a new user to the computer" in Windows Help or contact your system adminstrator.

10. Update the video card driver.

Many video card manufacturers frequently update their software drivers. If you haven't recently updated the video card driver, contact the video card manufacturer for an updated driver, or download one from the manufacturer's Web site. (To determine the manufacturer of a video card, view the card's properties in Device Manager.) You can often determine if the video card driver is outdated by changing the color-depth and resolution used for Illustrator. If the problem doesn't recur, the driver is probably outdated.

To change the color-depth and resolution used for Illustrator:

1. Choose Start > All Programs, right-click Adobe Illustrator CS2 or Adobe Illustrator CS, and choose Properties from the pop-up menu.

2. Click the Compatibility tab.

3. Select Run in 256 Colors.

4. Select Run in 640 x 480 Screen Resolution.

5. Click OK, and then restart Illustrator.

To disable graphics hardware acceleration:

1. Choose Start > Control Panel > Display.

2. Click the Settings tab.

3. Click Advanced.

4. Click the Troubleshoot tab.

5. Move the Hardware Acceleration slider to None.

6. Click Apply and then click OK to accept the new setting and close the dialog box

8. Click OK to close the Display Properties dialog box.

9. Restart Windows and Illustrator. If the problem no longer occurs, contact the video card manufacturer for an updated driver.

11. Verify that other device drivers are compatible with Windows XP.

If updating the video card driver doesn't resolve the problem, verify that all other device drivers are compatible with Windows XP. Device drivers are software files that allow Windows to communicate with devices such as scanners, mouse devices, and keyboards. Contact the device manufacturer to make sure that you are using the latest driver for it.

To check for device driver problems:

1. Choose Start > Control Panel > System.

2. Click the Hardware tab, and then click Device Manager.

3. Click the plus sign (+) to the left of each device type.

4. If a device appears with a black exclamation mark (!) in a yellow circle, right-click that device, and choose Properties from the pop-up menu.

5. Note the properties for the device:

-- Check the Device Status field: If the device isn't working properly, information in this field can help you troubleshoot the problem.

-- If the Properties dialog box has a Driver tab, click it. If the Driver tab doesn't indicate the driver provider, click Driver Details. If Microsoft is the provider, a generic driver is probably installed; contact the device manufacturer to obtain the most recent driver they provide.

12. Check for fonts problems.

To determine whether a font causes the problem, reduce the number of active TrueType fonts by moving the font files to another location:

Note: Don't move the TrueType fonts installed by Windows. For a list of these fonts, see document 326402 , "TrueType Fonts Installed by Windows XP."

1. Create a new folder (for example, C:\TrueType).

2. Open the Windows\Fonts folder.

3. Move TrueType font files--excluding those installed by Windows--from the Windows\Fonts folder to the folder you created in step 1.

4. Restart Windows.

5. Move a few of the fonts from step 3 back to the Windows\Fonts folder.

6. Restart Windows.

7. Start Illustrator, and try to re-create the problem.

8. If the problem doesn't recur, repeat steps 5-7, testing different fonts. If the problem recurs, one of the fonts you moved in step 5 may be the cause. Remove those fonts from the Windows\Fonts folder, and repeat steps 4-6, this time adding only one font at a time. When the problem recurs, do one or more of the following:

-- If you use a font utility other than the Windows Fonts folder (for example, Extensis Suitcase), remove the fonts using that utility. For instructions, refer to the documentation for the utility.

-- Remove the font and reinstall it from the original media.

-- Contact the font manufacturer to obtain an updated version of the font.

13. Set the virtual memory paging file to the default size.

Virtual memory allows the system to use hard disk space to store information normally stored in memory (RAM). Windows XP manages virtual memory using a paging file; you define the minimum and maximum size of this file. If the size is different from the default in Windows XP, applications may return errors. Some applications, however, may require a nondefault size for the paging file, so change the size only if other applications aren't adversely affected.

To set the paging file to the default size:

Note: You must be logged on as an Administrator to change the size of the paging file.

1. Quit all applications.

2. Choose Start > Control Panel > System.

3. Click the Advanced tab, and then click Settings in the Performance section.

4. Click the Advanced tab, and then click Change in the Virtual Memory section.

5. From the Drive list, select a hard disk partition that has free space equal to at least three times the amount of the computer's installed RAM. To determine the amount of space available on a hard disk partition, click the drive letter; the amount of space available appears in the Paging File Size for Selected Drive section.

6. In the Initial Size box, enter a value equal to one and a half times the amount of the computer's installed RAM.

7. In the Maximum Size box, enter a value equal to twice the amount of the Initial Size value.

8. Click Set, and then click OK to close the Virtual Memory dialog box.

9. Click OK to the alert "The changes you have made require you to restart your computer . . ."

10. Click OK to close the Performance Options dialog box, and then click OK to close the System Properties dialog box.

11. Click Yes in the System Settings Change dialog box. Windows restarts.

14. Optimize handling of temporary files by Windows XP.

Windows and applications store working data in temporary (.tmp) files that they create on the hard disk. Excessive or outdated temporary files can interfere with performance of Windows or applications. Delete temporary files, and make sure that at least 50 MB of free space is available on the hard disk to which temporary files are written.

To delete temporary files:

1. Quit all applications.

2. Choose Start > Search, and then click All Files Or Folders.

3. Type *.tmp in the All Or Part Of The File Name box.

4. Choose Local Hard Drives from the Look In pop-up menu, and then click Search.

5. After the search results appear, choose Edit > Select All.

6. Choose File > Delete. Click Yes to confirm that you want to send the files to the Recycle Bin.

7. Remove any files you don't want to delete from the Recycle Bin, and then empty the Recycle Bin. Windows deletes all temporary files not in use.

Note: Repeat this procedure periodically. Windows deletes temporary files when Windows and applications close normally. When Windows or an application crashes, however, temporary files can accumulate on the hard drive.

To make sure that at least 50 MB of free space is available on the hard disk to which temporary files are written:

1. Quit all applications.

2. Choose Start > Control Panel, and then double-click System.

3. Click the Advanced tab, and then click Environment Variables.

4. In the User variables for [user name] section, locate TEMP in the Variable column, and note the folder listed in the Value column. If the complete pathname for the folder isn't visible, double-click TEMP in the Variable column, and note the folder name in the Variable Value box.

Note: If a TEMP variable doesn't exist, contact your system administrator for assistance.

5. In Windows Explorer, verify that the folder you noted in step 4 exists on a noncompressed drive that has at least 50 MB of free space:

-- If the folder doesn't exist, create it: Right-click the drive, choose New Folder from the pop-up menu, and type the folder name you noted in step 4 (for example, Temp).

-- If the drive doesn't have enough free space, create additional space by removing unnecessary files. To determine the amount of free space, right-click the drive and choose Properties from the pop-up menu.

15. Optimize scratch disks.

When insufficient RAM is available for bitmap image editing, Illustrator uses a scratch disk file-- temporary disk space for storing data and performing computations. Illustrator can create two scratch disk files of up to 2 GB each. Each scratch disk file must be on a separate hard drive partition.

The hard drive partition you specify as the primary scratch disk should have free space equal to three to five times the size of the average bitmap image file; specify a secondary scratch disk if you have an additional hard drive partition. If disk space is insufficient, delete temporary files (see task 14 above), or remove other files from your hard disk(s).

To specify a scratch disk in Illustrator, choose Edit > Preferences > Plug-ins & Scratch Disk.

16. Repair and defragment hard disks.

System errors can occur if hard disks contain damaged sectors or fragmented files. Repair and defragment hard disks using either the Error-checking tool and Disk Defragmenter utility included with Windows or a third-party disk utility (for example, Symantec Norton Utilities). You should run such utilities on each hard disk or partition. More information about the Error-checking tool and Disk Defragmenter appears below; for more information about a third-party disk utility, refer to the documentation for the utility.

The Error-checking tool repairs bad sectors, lost allocation units and file fragments, cross-linked files, and invalid file names. To access the Error-checking tool, choose Start > My Computer, right-click the desired hard disk, and choose Properties from the pop-up menu; in the Local Disk Properties dialog box, click the Tools tab, and then click Check Now in the Error-checking section.

Note: To prevent Disk Defragmenter from moving files to bad sectors of a disk, run the Error-checking tool before running Disk Defragmenter.

Disk Defragmenter rearranges the files and free space on your computer so files are stored in contiguous units and free space is consolidated in one contiguous block. To access the Disk Defragmenter utility, choose Start > All Programs > Accessories > System Tools > Disk Defragmenter.

17. Scan the system for viruses.

Use current anti-virus software (for example, Symantec Norton AntiVirus or McAfee VirusScan) to check the system for viruses. Virus infections can damage software and cause system errors. For more information, see the documentation for the anti-virus software.

18. Identify the file that causes the problem.

If an error indicates which file causes the problem, reinstall the application to which that file belongs. If that file is damaged and causes problems in Illustrator, reinstalling the associated application can correct the problem.

If an error indicates a Windows file, contact Microsoft for help replacing that file.

Advanced troubleshooting

If the tasks in the previous section didn't resolve the problem, you may be able to resolve the problem by reinstalling Windows XP and Illustrator, reformatting your hard disk and reinstalling Windows XP and Illustrator, or by determining if hardware is conflicting with Illustrator.

Disclaimer: Adobe doesn't support hardware and provides these procedures as a courtesy only. For further assistance, contact the hardware manufacturer or an authorized reseller. If you troubleshoot hardware problems yourself, you may void the warranty for your computer.

Note: Before you remove or rearrange hardware, turn off and disconnect power to the computer and any peripheral devices.

19. Perform a clean installation of Windows XP, and reinstall Illustrator.

Perform a clean installation of Windows XP, and install Illustrator from the original installation media. Perform this procedure particularly if you've upgraded to Windows XP and overwrote the previous version of the operating system.

After you reinstall Windows and Illustrator, try to re-create the problem:

-- If the problem no longer occurs, install other applications one at a time and try to re-create the problem after each installation. If the problem occurs after an installation, the recently installed application may be the cause.

-- If the problem occurs when only Windows and Illustrator are installed, proceed to task 20.

For instructions on performing a clean installation of Windows XP, see document 315341, "How to perform an in-place upgrade (reinstallation) of Windows XP" on the Microsoft website at http://support.microsoft.com .

20. Reformat the hard disk, and reinstall only Windows XP and Illustrator.

Reformat the hard disk, and then install only Windows XP and Illustrator from the original installation media. Reformatting a disk erases all files it contains, so be sure to back up all personal files first. Also make sure that you have all application and system disks.

Note: Don't install additional software or hardware until you are sure that the problem is resolved. Don't back up the hard disk and restore Windows and Illustrator instead of reinstalling them; if the problem is caused by an application or Windows, and either one is restored instead of reinstalled, the problem may recur.

After you reformat the hard disk and reinstall Windows and Illustrator, try to re-create the problem:

-- If the problem no longer occurs, install other applications one at a time and try to re-create the problem after each installation. If the problem occurs after an installation, the recently installed application may be the cause.

-- If the problem occurs when only Windows and Illustrator are installed, the cause is hardware-related, and you should contact the hardware manufacturer or an authorized reseller for assistance. Before contacting the manufacturer or reseller, however, you may want to try one or more tasks in the following section.

21. Check for SCSI problems.

If you have a SCSI controller for your scanner or hard drives, check your SCSI card for incorrect settings, drivers, hardware damage, or cable damage. Also, check that your SCSI chain is terminated properly. For instructions, contact your SCSI card manufacturer.

To identify SCSI hardware problems by using the System Properties dialog box:

1. Choose Start > Control Panel, click Performance and Maintenance, and then click System.

2. Click the Hardware tab, and then click Device Manager.

3. Click the plus sign to the left of the SCSI and RAID Controllers line.

4. For each adapter listed, right-click the name, and then choose Properties from the pop-up menu. If the Device Status section indicates that the SCSI adapter isn't working correctly, reinstall SCSI device drivers; contact the manufacturer of the SCSI card for further help.

22. Check for problems with RAM DIMMs.

Ensure that the RAM DIMMs (dual inline memory modules) are installed properly and are not the cause. Do one or more of the following:

-- Change the order of the installed DIMMs.

-- Remove all but the minimum number of DIMMs needed to run Windows and Illustrator, and test to see if the problem persists. If it does, replace the DIMMs you removed and remove the others, testing again to see if the problem persists. If the problem doesn't recur, one or more of the removed DIMMs are the cause. For assistance, contact the RAM DIMM manufacturer.


Related Documents

Document 324053
Last edited - 01/11/2006

 

Got Some Time to Take a Survey?

Tell us what you think about this support site.